Introduction
Introduction

This Reference Guide briefly introduces the basics for COM objects, and their associated methods and properties in AutoCAD Mechanical ActiveX Automation, which provides a mechanism to manipulate AutoCAD Mechanical programmatically from within or outside of AutoCAD Mechanical. It does this by exposing various objects to the "outside world." Once these objects are exposed, they can be accessed by many different programming languages and environments, or from within other applications such as Microsoft Word VBA™ or Excel VBA™.

AutoCAD Mechanical ActiveX Automation contains three parts of type libraries, including SymBBAuto (Symbols, Balloons, and Bills Of Materials), AcadmAuto (AutoCAD Mechanical), and GEAuto (Geometry), as well as Mcad2DSPreview Active Control Module.

An object is the main building block of any ActiveX Automation application. The objects are structured in a hierarchical fashion, with the AcadmApplication object at the root. The object hierarchy fits into the AutoCAD Mechanical object hierarchy and both work together to represent various aspects of a concrete mechanical design model.

What do you think about this topic? Send Feedback!


Type Libraries and Object Models
Type Libraries and Object Models

A type library file contains standard descriptions of exposed objects, methods, and properties that are available for Automation. AutoCAD Mechanical ActiveX Automation contains the following type libraries:

Type Library | Description
AcadmAuto | Autodesk AutoCAD Mechanical (AcadmAuto) 2020 Type Library is used for mechanical structure objects and provides access to the root of the object hierarchy in AutoCAD Mechanical ActiveX Automation.
SymBBAuto | Autodesk SymBBAuto 2020 Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided. Note: the file name of the library on disk is symbbauto[xxx].tlb where xxx denotes the language version, for example 'enu' for English.
GEAuto | Autodesk GEAuto 2020 Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.

To start the Microsoft Visual Basic Editor, open the AutoCAD Mechanical. On the toolbar, click Assist > Macro > Visual Basic Editor. The Microsoft Visual Basic window is displayed. To use the AutoCAD Mechanical type libraries, you must set a reference to specified type libraries:

  1. In the Microsoft Visual Basic Editor, click Tools > References.
  2. In the References dialog box, select the check boxes for the type libraries as shown in the following image:

In addition to the preceding three type libraries, AutoCAD Mechanical provides an Mcad2DSPreview Active Control Module that is installed under the root path of Mechanical Desktop. In the Visual Basic Editor, when editing a user form, you can add this control:

  1. Click Tools > Additional Controls.
  2. In the Additional Controls dialog box, select the Mcad2DSPreview Control check box as show below:

Note: Mechanical Desktop VBA can interact with the above type libraries through the AutoCAD Mechanical API to get the related support and achieve a high degree of integration between AutoCAD-based applications.

Object Models

The following diagrams show the object model for each type library:

AcadmAuto

SymBBAuto

GEAuto


API Reference
Libraries
Name | Description
AcadmAuto | The Autodesk AutoCAD Mechanical Type Library is used for AutoCAD Mechanical ActiveX Automation. It contains the classes, functions, and properties pertaining to 2D structure.
SymBBAuto | The Autodesk SymBBAuto Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided.
GEAuto | The Autodesk GEAuto Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.
Topics
Name | Description
Mcad2DSPreview | Mechanical Structure Preview ActiveX Control (Mcad2DSPreview). Allows users to display a thumbnail bitmap of a block, a list of entities, a folder, a component view, or an entire component (tiled views).


AcadmAuto Library
Summary

The Autodesk AutoCAD Mechanical Type Library is used for AutoCAD Mechanical ActiveX Automation. It contains the classes, functions, and properties pertaining to 2D structure.

CoClasses
Name | Description
AcadmApplication | The AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
Mcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group. The types of complex standard parts are screw connections and part features.
Mcad2dComponentDescriptor | Provides a description of a 2D component.
Mcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
Mcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
Mcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
Mcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
McadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing. Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.
McadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
McadArc | An arc curve.
McadAttribute | Represents an instance of an attribute.
McadAttributeField | Represents the description of a single attribute field.
McadAttributeFields | A collection of McadAttributeField objects.
McadAttributes | A collection of McadAttribute objects.
McadAugmentedLine | A multisegmented curve with normal information at the nodes.
McadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
McadComplexHideSituations | A collection of McadComplexHideSituation objects
McadComponent | References an instance of a component definition in the assembly.
McadComponentDefinition | References the definition of an assembly component.
McadComponentDefinitions | A collection of McadcomponentDefinition objects.
McadComponents | A collection of McadComponent objects.
McadComponentView | A collection of McadComponentView objects.
McadComponentViewDefinition | References the definition of a component view.
McadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
McadComponentViewDescriptor | Encapsulates the description of a 2D component view.
McadComponentViews | A collection of McadComponentView objects.
McadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
McadDocuments | The collection of McadDocument objects present in the application.
McadEllipse | An ellipse or elliptical arc object.
McadFolder | References an instance of a folder definition.
McadFolderDefinition | A collection of McadFolderDefinition objects.
McadFolderDefinitions | A collection of McadFolderDefinition objects.
McadFolderDescriptor | Encapsulates the description of a folder.
McadFolders | A collection of McadFolder objects.
McadFormulaEvaluator | This object provides general methods for Standard Data provider
McadHideSituation | This object provides general methods for 2D structure hide situations.
McadHideSituations | This object provides general methods for 2D structure hide situations.
McadLayerCfg | This is class AcadmAuto::McadLayerCfg.
McadLayerCfgs | This is class AcadmAuto::McadLayerCfgs.
McadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
McadLayerObjectCfg | This is class AcadmAuto::McadLayerObjectCfg.
McadLayerObjectCfgs | This is class AcadmAuto::McadLayerObjectCfgs.
McadLayerObjectMgr | This is class AcadmAuto::McadLayerObjectMgr.
McadLine | An unbounded line object.
McadObjects | A collection of IMcadObject subtype objects.
McadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
McadPolyline | A polyline object.
McadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
McadSpline | A spline object.
McadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
McadTransaction | The McadTransaction object. These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.
McadUtility | This API provides some general utility methods.
Enumerations
Name | Description
Mcad2DSViewType | Enumerates the 2D structure view types.
McadCollectionType | Enumerates all collection types for which to create the new collection. Some of collection types can only be used in Mechanical Desktop. mcAttributeFields : Specifies the collection of attribute fields. mcAttributes : Specifies the collection of attributes. mcComponentDefinitions : Specifies the collection of component definitions. mcComponents : Specifies the collection of components. mcObjects : Specifies the collection of Mcad objects. mcComponentViews : Specifies the collection of component views. mcComponentViewDefinitions : Specifies the collection of component view definitions. mcFolders : Specifies the collection of folders. mcFolderDefinitions : Specifies the collection of folder definitions. mcAnnotationViewDefinitions : Specifies the collection of the annotation... more
McadDocDrawingType | type McadDocDrawingType
McadFieldType | Enumerates the field value types. mcShort : Indicates the field value is Short. mcLong : Indicates the field value is Long. mcDouble : Indicates the field value is a Double. mcCharacter : Indicates the field value is Character. mcShortArray : Indicates the field value is Array of Short. mcLongArray : Indicates the field value is Array of Long. mcDoubleArray : Indicates the field value is Array of Double. mcString : Indicates the field value is String. mcObjectID : Indicates the field value is Object ID. mcObjectIDArray : Indicates the field value is Array of Object IDs. mcMcadObject : Indicates the... more
McadHideSituationRefType | Enumerates all referenced types for this hide situation. mc2DSDirectRef : Indicates that the leaf or view instance is directly referred by hide situation. mc2DSSubEntRef : Indicates that the leaf or view instance of a subentity of the view is referenced by hide situation. mc2DSPartialRef : Indicates that the view instance is partially or fully referred by hide situation. mc2DSAllRef : It is equivalent to mc2DSDirectRef | mc2DSSubEntRef.
McadHideSituationSubentType | Enumerates all referenced hide subentity types for this hide situation. mc2DSNoEnt : Indicates that there are no subentities. mc2DSFGEnt : Indicates the foreground hide situation. mc2DSBGEnt : Indicates the background hide situation. mc2DSFGExclEnt : Indicates the foreground excluded hide situation. mc2DSBGExclEnt : Indicates the background excluded hide situation. mc2DSUpperBGExclEnt : Indicates the upper background excluded hide situation.
McadLayerObjectHideType | This is record McadLayerObjectHideType.
McadObjectType | Enumerates all generic objects within the Mechanical Desktop or AutoCAD. mcObject : Specifies the McadObject type of the object. mcGeometry : Specifies the McadObject type of the geometry. mcCurve : Specifies the McadObject type of the curve. mcLine : Specifies the McadObject type of the line. mcArc : Specifies the McadObject type of the arc. mcEllipse : Specifies the McadObject type of the ellipse. mcSpline : Specifies the McadObject type of the spline. mcPolyline : Specifies the McadObject type of the polyline. mcAaugmentedLine : Specifies the McadObject type of the augmented line. mcComponent : Specifies the McadObject type of the... more
McadPhantomState | Enumerates all phantom states. mcNormalDef : Specifies the normal state, with a value of 0. mcPhantomDef : Specifies the phantom state, with a value of 1. mcPhantomDefInCurrent : Specifies the phantom state in the current drawing, with a value of 2.
McadPowerObjectType | Enumerates the power object types. mcNoObj : Specifies no power object. mcShaftCalcObj : Specifies the shaft calculation power object. mcCamCalcObj : Specifies the cam calculation power object. mcFEAObj : Specifies the FEA power object. mcMomOfInertiaObj : Specifies the momentum of inertia power object. mcDeflLineObj : Specifies the line power object. mcScrewConObj : Specifies the screw connection of the power object. mcPartFeatObj : Specifies the part feature power object. mcShaftObj : Specifies the shaft power object. mcAllFolderPowerObj : Specifies the all folders power object.
McadSelectionOrderOption | Enumerates all available 2D Structure selection order options.
Interfaces
Name | Description
IAcadmApplication | AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
IAcadmApplicationVersion | Version of AutoCAD Mechanical application that is running
IMcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group.
IMcad2dComponentDescriptor | Provides a description of a 2D component.
IMcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
IMcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
IMcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
IMcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr2 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr3 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr4 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr5 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinition2 | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
IMcadArc | An arc curve.
IMcadAttribute | Represents an instance of an attribute.
IMcadAttributeField | Represents the description of a single attribute field.
IMcadAttributeFields | A collection of McadAttributeField objects.
IMcadAttributes | A collection of McadAttribute objects.
IMcadAugmentedLine | A multisegmented curve with normal information at the nodes.
IMcadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
IMcadComplexHideSituations | A collection of McadComplexHideSituation objects
IMcadComponent | References an instance of a component definition in the assembly.
IMcadComponentDefinition | References the definition of an assembly component.
IMcadComponentDefinitions | A collection of McadcomponentDefinition objects.
IMcadComponents | A collection of McadComponent objects.
IMcadComponentView | A collection of McadComponentView objects.
IMcadComponentViewDefinition | References the definition of a component view.
IMcadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
IMcadComponentViewDescriptor | Encapsulates the description of a 2D component view.
IMcadComponentViews | A collection of McadComponentView objects.
IMcadCurve | A generic curve entity.
IMcadDescriptor | A generic descriptor object that contains the overall description of an object.
IMcadDocuments | The collection of McadDocument objects present in the application.
IMcadDocumentVersion | Version of AutoCAD Mechanical that saved the file.
IMcadEllipse | An ellipse or elliptical arc object.
IMcadFolder | References an instance of a folder definition.
IMcadFolder2 | References an instance of a folder definition.
IMcadFolderDefinition | A collection of McadFolderDefinition objects.
IMcadFolderDefinitions | A collection of McadFolderDefinition objects.
IMcadFolderDescriptor | Encapsulates the description of a folder.
IMcadFolders | A collection of McadFolder objects.
IMcadFormulaEvaluator | This object provides general methods for Standard Data provider
IMcadGeometry | This is class IMcadGeometry.
IMcadHideSituation | This object provides general methods for 2D structure hide situations.
IMcadHideSituations | A collection of AMSHide objects.
IMcadLayerCfg | This class contains the configuration settings for a mechanical layer.
IMcadLayerCfgs | This is class IMcadLayerCfgs.
IMcadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
IMcadLayerObjectCfg | This class contains the configuration settings for a mechanical object.
IMcadLayerObjectCfgs | This is class IMcadLayerObjectCfgs.
IMcadLayerObjectMgr | This class is for accessing the layer object settings.
IMcadLine | An unbounded line object.
IMcadObject | A reference to a generic object or sub-object within the Mechanical Desktop, AutoCAD or AutoCAD Mechanical.
IMcadObjects | A collection of IMcadObject subtype objects.
IMcadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
IMcadPolyline | A polyline object.
IMcadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
IMcadSpline | A spline object.
IMcadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
IMcadUtility | This API provides some general utility methods.
IMcadUtility2 | This is class IMcadUtility2.
IMcadUtility3 | This is class IMcadUtility3.


AcadmApplication CoClass
Summary

The AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

AcadmAuto::AcadmApplication
Visual Basic
Public Class AcadmApplication
Links
AcadmAuto Library


IAcadmApplication Interface
Summary

AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IAcadmApplication
Visual Basic
Public Interface IAcadmApplication
Inherits IDispatch
Links
IAcadmApplication Members, AcadmAuto Library


IAcadmApplication Members
Summary

The following tables list the members exposed by IAcadmApplication.

Methods
Name | Description
AddAttributeClass | Creates a new attribute class definition using the specified fields.
DocumentFromHost | Gets the corresponding McadDocument from the specified host application's document.
GetAttributeClassFields | Gets the field information from the specified attribute class definition.
GetFormulaEvaluator | Gets the formula evaluator from the specified Acad object.
ReadAttributeClass | Reads one or more class definitions in a file.
RemoveAttributeClass | Removes the specified attribute class definition.
WriteAttributeClass | Writes the specified attribute class definition to the specified file.
Properties
Name | Description
ActiveDocument | Gets the currently active document (drawing).
Application | Gets the AcadmApplication object.
AttributeClasses | Gets the names of the currently defined attribute classes.
Documents | Gets the collection of all documents for the application.
StructureModeEditEntity | Gets the status of the structure entity edit mode in the editor state.


IAcadmApplication::ActiveDocument Property
Summary

Gets the currently active document (drawing).

Visual Basic
Property ActiveDocument() As IMcadDocument**
Remarks

This property is an McadDocument object.


IAcadmApplication::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This is an AcadmApplication object.


IAcadmApplication::AttributeClasses Property
Summary

Gets the names of the currently defined attribute classes.

Visual Basic
Property AttributeClasses() As VARIANT*
Remarks

This property is a Variant.


IAcadmApplication::Documents Property
Summary

Gets the collection of all documents for the application.

Visual Basic
Property Documents() As IMcadDocuments**
Remarks

This property is a n McadDocuments collection.


IAcadmApplication::StructureModeEditEntity Property
Summary

Gets the status of the structure entity edit mode in the editor state.

Visual Basic
Property StructureModeEditEntity() As VARIANT_BOOL
Remarks

This property is a Boolean.


IAcadmApplication::AddAttributeClass Method
Summary

Creates a new attribute class definition using the specified fields.

Visual Basic
Sub AddAttributeClass(Name As String, Fields As IMcadAttributeFields)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the attribute.
Fields | McadAttributeFields collection; input-only. Specifies the fields that are used to add the new attribute.
Returns

None


IAcadmApplication::DocumentFromHost Method
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Sub DocumentFromHost(HostDocument As IDispatch, Document As [out, retval] IMcadDocument*)
Parameters
Parameters | Description
HostDocument | AcadObject object; input-only. Specifies the host application's document from which to get the corresponding document.
Returns

McadDocument object


IAcadmApplication::GetAttributeClassFields Method
Summary

Gets the field information from the specified attribute class definition.

Visual Basic
Sub GetAttributeClassFields(Name As String, Fields As [out, retval] IMcadAttributeFields*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute class definition from which to get the corresponding fields.
Returns

McadAttributeFields collection


IAcadmApplication::GetFormulaEvaluator Method
Summary

Gets the formula evaluator from the specified Acad object.

Visual Basic
Sub GetFormulaEvaluator(object As IAcadObject, evaluator As [out, retval] IMcadFormulaEvaluator *)
Parameters
Parameters | Description
object | AcadObject object; input-only. Specifies the object for which to get the formula evaluator.
Returns

McadFormulaEvaluator object

Remarks

The McadFormulaEvaluator uses data providers from acad objects to evaluate formulas.

Example

Refer to SDK Samples: FormulaEvaluator.dvb

Links
Example


IAcadmApplication::ReadAttributeClass Method
Summary

Reads one or more class definitions in a file.

Visual Basic
Sub ReadAttributeClass(FileName As String)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file from which to read the attribute class definitions.
Returns

None


IAcadmApplication::RemoveAttributeClass Method
Summary

Removes the specified attribute class definition.

Visual Basic
Sub RemoveAttributeClass(Name As String)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute class definition to remove.
Returns

None


IAcadmApplication::WriteAttributeClass Method
Summary

Writes the specified attribute class definition to the specified file.

Visual Basic
Sub WriteAttributeClass(FileName As String, Append As [in, defaultvalue(TRUE)] VARIANT_BOOL, Class As [in, optional] VARIANT)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file to which to write the new attribute class definition.
Append | Boolean, default value is TRUE; input-only. Specifies whether the new attribute class definition is appended to the specified class.
Class | Variant (String); input-only. Specifies the class to which to append the new attribute class definition.
Returns

None


IAcadmApplicationVersion Interface
Summary

Version of AutoCAD Mechanical application that is running

Class Hierarchy

Declaration syntax

IAcadmApplicationVersion
Visual Basic
Public Interface IAcadmApplicationVersion
Inherits IUnknown
Links
IAcadmApplicationVersion Members, AcadmAuto Library


IAcadmApplicationVersion Members
Summary

The following tables list the members exposed by IAcadmApplicationVersion.

Methods
Name | Description
GetVersionNumber | Gets the version of AutoCAD Mechanical application that is running.


IAcadmApplicationVersion::GetVersionNumber Method
Summary

Gets the version of AutoCAD Mechanical application that is running.

Visual Basic
Sub GetVersionNumber(ByRef Major As long, ByRef Minor As long, ByRef Patch As long)
Parameters
Parameters | Description
Major | Long. Major release number.
Minor | Long. Minor release number
Patch | Long. Patch number.


IMcad2dComplexStdPartCompGroupDescriptor Interface
Summary

Provides a description of a 2D complex standard part component group.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor
Visual Basic
Public Interface IMcad2dComplexStdPartCompGroupDescriptor
Inherits IMcad2DStructureDescriptor
Remarks

The types of complex standard parts are screw connections and part features.

Links
IMcad2dComplexStdPartCompGroupDescriptor Members, AcadmAuto Library


IMcad2dComplexStdPartCompGroupDescriptor Members
Summary

The following tables list the members exposed by IMcad2dComplexStdPartCompGroupDescriptor.

Methods
Name | Description
AddView | Adds a view group descriptor to a 2D complex standard part component group descriptor.
HasEqualTypeWithViewGroup | Checks if a 2D complex standard part component group descriptor has equal type with a given power object view group descriptor, TRUE, or not, FALSE.
MigrateTo2DStructure | Migrates a 2D complex standard part component group to 2D structure. New 2D standard part components with standard part views are created.
RemoveView | Removes the view group descriptor from a 2D complex standard part component group descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D complex standard part component group descriptor.


IMcad2dComplexStdPartCompGroupDescriptor::Views Property
Summary

Gets view group descriptors from the 2D complex standard part component group descriptor.

Visual Basic
Property Views() As VARIANT *
Remarks

This property is a Variant (an array of McadComponentView or McadFolder objects).


IMcad2dComplexStdPartCompGroupDescriptor::AddView Method
Summary

Adds a view group descriptor to a 2D complex standard part component group descriptor.

Visual Basic
Sub AddView(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor object; input-only. Specifies a power object view group descriptor to add to the complex standard part descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.


IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method
Summary

Checks if a 2D complex standard part component group descriptor has equal type with a given power object view group descriptor, TRUE, or not, FALSE.

Visual Basic
Sub HasEqualTypeWithViewGroup(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor, EqualType As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor object; input-only. Specifies a power object view group descriptor to check for equal type with this 2D complex standard part descriptor.
Remarks

This property is a Boolean.


IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method
Summary

Migrates a 2D complex standard part component group to 2D structure. New 2D standard part components with standard part views are created.

Visual Basic
Sub MigrateTo2DStructure()
Returns

None


IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method
Summary

Removes the view group descriptor from a 2D complex standard part component group descriptor.

Visual Basic
Sub RemoveView(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor to be removed; input-only. Specifies a power object view group descriptor to remove from the complex standard part descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.


IMcad2dComponentDescriptor Interface
Summary

Provides a description of a 2D component.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor
Visual Basic
Public Interface IMcad2dComponentDescriptor
Inherits IMcad2DStructureDescriptor
Links
IMcad2dComponentDescriptor Members, AcadmAuto Library


IMcad2dComponentDescriptor Members
Summary

The following tables list the members exposed by IMcad2dComponentDescriptor.

Methods
Name | Description
AddComponentView | Adds a component view descriptor to a 2D component descriptor.
CreateComponent | Creates a new 2D component from a 2D component descriptor.
HasEqualTypeWithView | Checks if a 2D component descriptor has equal type with a given component view descriptor, TRUE, or not, FALSE.
RemoveComponentView | Removes the specified component view descriptor from a 2D component descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets the component from the component descriptor.
ComponentDefinition | Gets and sets the component definition for the component descriptor.
ComponentViews | Gets component view descriptors from the component descriptor.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
OwningComponentDefinition | Gets and sets the owning component definitions on the component descriptor.


IMcad2dComponentDescriptor::Component Property
Summary

Gets the component from the component descriptor.

Visual Basic
Property Component() As VARIANT*
Remarks

This property is a Variant ( McadComponent object).


IMcad2dComponentDescriptor::ComponentDefinition Property
Summary

Gets and sets the component definition for the component descriptor.

Visual Basic
Property ComponentDefinition() As VARIANT
Remarks

This property is a Variant ( McadComponentDefinition object).


IMcad2dComponentDescriptor::ComponentViews Property
Summary

Gets component view descriptors from the component descriptor.

Visual Basic
Property ComponentViews() As VARIANT*
Remarks

This property is a Variant (array of McadComponentViewDescriptor objects).


IMcad2dComponentDescriptor::OwningComponentDefinition Property
Summary

Gets and sets the owning component definitions on the component descriptor.

Visual Basic
Property OwningComponentDefinition() As VARIANT
Remarks

This property is a Variant ( McadComponentDefinition object).


IMcad2dComponentDescriptor::AddComponentView Method
Summary

Adds a component view descriptor to a 2D component descriptor.

Visual Basic
Sub AddComponentView(pDescriptor As IMcadComponentViewDescriptor)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies the component view descriptor to added to this component descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.


IMcad2dComponentDescriptor::CreateComponent Method
Summary

Creates a new 2D component from a 2D component descriptor.

Visual Basic
Sub CreateComponent()
Returns

None


IMcad2dComponentDescriptor::HasEqualTypeWithView Method
Summary

Checks if a 2D component descriptor has equal type with a given component view descriptor, TRUE, or not, FALSE.

Visual Basic
Sub HasEqualTypeWithView(pDescriptor As IMcadComponentViewDescriptor, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies a component view descriptor to check for equal type with this 2D component descriptor.
Remarks

This property is a Boolean.


IMcad2dComponentDescriptor::RemoveComponentView Method
Summary

Removes the specified component view descriptor from a 2D component descriptor.

Visual Basic
Sub RemoveComponentView(pDescriptor As IMcadComponentViewDescriptor)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies the component view descriptor to remove from this component descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.


IMcad2dShaftCompGroupDescriptor Interface
Summary

Provides a description of the group of shaft and standard part objects that comprise a shaft power object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dShaftCompGroupDescriptor
Visual Basic
Public Interface IMcad2dShaftCompGroupDescriptor
Inherits IMcad2DStructureDescriptor
Links
IMcad2dShaftCompGroupDescriptor Members, AcadmAuto Library


IMcad2dShaftCompGroupDescriptor Members
Summary

The following tables list the members exposed by IMcad2dShaftCompGroupDescriptor.

Methods
Name | Description
MigrateTo2DStructure | Migrates a 2D shaft component group to 2D structure. A new 2D shaft component with standard parts is created.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D shaft component group descriptor.


IMcad2dShaftCompGroupDescriptor::Views Property
Summary

Gets view group descriptors from the 2D shaft component group descriptor.

Visual Basic
Property Views() As VARIANT*
Remarks

This property is a Variant (array of McadComponentView or McadFolder objects).


IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method
Summary

Migrates a 2D shaft component group to 2D structure. A new 2D shaft component with standard parts is created.

Visual Basic
Sub MigrateTo2DStructure()
Returns

None


IMcad2dStdPartComponentDescriptor Interface
Summary

Provides a description of the 2D standard part component.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor
Visual Basic
Public Interface IMcad2dStdPartComponentDescriptor
Inherits IMcad2dComponentDescriptor
Links
AcadmAuto Library


IMcad2DStructureDescriptor Interface
Summary

This object is the base class for 2D structure descriptors.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor
        IMcad2dComponentDescriptor
        IMcad2dShaftCompGroupDescriptor
        IMcadFolderDescriptor
        IMcadPowObjViewGroupDescriptor
Visual Basic
Public Interface IMcad2DStructureDescriptor
Inherits IMcadDescriptor
Links
IMcad2DStructureDescriptor Members, AcadmAuto Library


IMcad2DStructureDescriptor Members
Summary

The following tables list the members exposed by IMcad2DStructureDescriptor.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.


IMcad2DStructureDescriptor::Name Property
Summary

Gets and sets the name of a 2D structure descriptor.

Visual Basic
Property Name() As String
Remarks

This property is a String.


IMcad2DStructureMgr Interface
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
Visual Basic
Public Interface IMcad2DStructureMgr
Inherits IDispatch
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Links
IMcad2DStructureMgr Members, AcadmAuto Library


IMcad2DStructureMgr Members
Summary

The following tables list the members exposed by IMcad2DStructureMgr.

Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.


IMcad2DStructureMgr::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcad2DStructureMgr::EditTarget Property
Summary

Sets or gets either a folder or component view in 2D structure as the edit target.

Visual Basic
Property EditTarget() As IMcadFolder*
Remarks

  • This property is a Variant (McadFolder object).
  • To set the edit target to the MVD, specifies an empty or null string.


IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
Summary

Create an annotation view and definition based on the specified component definition and component view definitions.

Visual Basic
Sub AddNewAnnotationViewDefinition(ByRef pNewAnnotationViewDef As IMcadAnnotationViewDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, matrices As VARIANT, pCompDef As IMcadComponentDefinition, pCompViewDefs As IMcadComponentViewDefinitions, Name As [in, optional ] VARIANT)
Parameters
Parameters | Description
pNewAnnotationViewDef | McadAnnotationViewDefinition object; output-only. Specifies the new annotation view definition to create.
pNewFolderInst | McadFolder object; output-only. Specifies the parent folder for the new annotation view definition.
pMat | GeMatrix object; input-only. Specifies the base position for the new annotation view.
matrices | Variant (array of GeMatrix objects); input-only. Specifies the array of matrices for the new position of each of the new views.
pCompDef | McadComponentDefinition object; input-only. Specifies a valid component based on which to create the new annotation view.
pCompViewDefs | McadComponentViewDefinitions collection; input-only. Specifies an array of component view definitions of pCompDefKey whose corresponding annotation view position are specified in arMatrices.
Name | Variant (String); input-only. Specifies the name of the new annotation view definition. If not specified, system will generate an appropriate name.
Returns

None

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::AddNewComponentDefinition Method
Summary

Creates a new component definition in mechanical structure.

Visual Basic
Sub AddNewComponentDefinition(Name As [in, optional] VARIANT, pVal As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Name | Variant (String); input-only. Specifies the name of the component definition. If not specified, the default automatic name is used.
Returns

McadComponentDefinition object

Remarks

Component definition is a nongraphical description of a mechanical structure component that AutoCAD Mechanical saves in data area of a drawing, similar to how it saves a block definition.


IMcad2DStructureMgr::AddNewComponentView Method
Summary

Creates a new component view in mechanical structure.

Visual Basic
Sub AddNewComponentView(pDefToInst As IMcadComponentViewDefinition, pCompInst As IMcadComponent, pMat As IGeMatrix, ByRef pNewViewInst As IMcadComponentView*, pTargetView As [in, optional] VARIANT)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition for the component view.
pCompInst | McadComponent object; input-only. Specifies the new or existing component instance to add a component view for.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pNewViewInst | McadComponentView object; output-only, Specifies the new component view.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created component view is placed. If not specified, this component view is created in the active view.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcad2DStructureMgr::AddNewComponentViewDefinition Method
Summary

Creates a new component view definition in mechanical structure.

Visual Basic
Sub AddNewComponentViewDefinition(ByRef pNewViewDef As IMcadComponentViewDefinition*, ByRef pNewViewInst As IMcadComponentView*, pCompInst As IMcadComponent, pMat As IGeMatrix, pAddViews As [in, optional] VARIANT, entityIds As [in, optional] VARIANT, pTargetView As [in, optional] VARIANT, Name As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewViewDef | McadComponentViewDefinition object; output-only. Specifies the new component view definition.
pNewViewInst | McadComponentView object; output-only. Specifies the new component view.
pCompInst | McadComponent object; input-only. Specifies the new or existing component instance to add a component view for.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pAddViews | Variant ( McadFolders collection); input-only; optional. Specifies the new component views or folders to add to the new component view definition.
entityIds | Variant (Array of Longs); input-only; optional. Specifies the Object IDs of drawing objects to be added to this component view.
pTargetView | Variant ( McadFolder object); input-only; optional. Specifies the parent view where the created component view is placed. If not specified, this component view is created in the active view.
Name | Variant (String); input-only; optional. Specifies the name of the component view. If not specified, the default automatic name is used.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcad2DStructureMgr::AddNewFolder Method
Summary

Creates a new folder in mechanical structure.

Visual Basic
Sub AddNewFolder(pDefToInst As IMcadFolderDefinition, pMat As IGeMatrix, ByRef pNewViewInst As IMcadFolder*, pTargetView As [in, optional] VARIANT)
Parameters
Parameters | Description
pDefToInst | McadFolderDefinition object; input-only. Specifies the folder definition for the folder.
pMat | GeMatrix object; input-only. Specifies the position to place the new folder.
pNewViewInst | McadFolder object; out-put only. Specifies the new folder.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created folder is placed. If not specified, this folder is created in the active view.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcad2DStructureMgr::AddNewFolderDefinition Method
Summary

Creates a new folder definition in mechanical structure.

Visual Basic
Sub AddNewFolderDefinition(ByRef pNewFolderDef As IMcadFolderDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, pAddViews As [in, optional] VARIANT, entityIds As [in, optional] VARIANT, pTargetView As [in, optional] VARIANT, Name As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewFolderDef | McadFolderDefinition object; output only. Specifies the new folder definition.
pNewFolderInst | McadFolder object; output only. Specifies the new folder.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pAddViews | Variant ( McadFolders collection); input only; optional. Specifies the new component views or folders to add to the new folder definition.
entityIds | Variant (Array of Longs);input; optional. Specifies the Object IDs of drawing objects to be added to this folder.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created folder is placed. If not specified, this folder is created in the active view.
Name | Variant (String); input; optional. Specifies the name of the component view; if not specified, the default automatic name is used.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcad2DStructureMgr::CopyComponentFromDatabase Method
Summary

Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.

Visual Basic
Sub CopyComponentFromDatabase(sourcedef As IMcadComponentDefinition, database As IAcadDatabase, ByRef newdef As IMcadComponentDefinition*)
Parameters
Parameters | Description
sourcedef | Variant ( McadComponentViewDefinition object); input-only. Specifies the source component view definition to copy from the AcadDatabase database.
Database | AcadDatabase database; input-only. Specifies the AcadDatabase to implement the copy.
newDef | Variant ( McadComponentViewDefinition object); output-only. Specifies the new copied component view definition.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::CopyFolderFromDatabase Method
Summary

Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.

Visual Basic
Sub CopyFolderFromDatabase(sourcedef As IMcadFolderDefinition, database As IAcadDatabase, ByRef newdef As IMcadFolderDefinition*)
Parameters
Parameters | Description
sourcedef | Variant ( McadFolderDefinition object); input-only. Specifies the source folder definition in 2D structure to copy from the AcadDatabase database.
Database | AcadDatabase database; input-only. Specifies the AcadDatabase to implement the copy.
newDef | Variant ( McadFolderDefinition object); input-only. Specifies the new copied folder definition in 2D structure.
Returns

None


IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method
Summary

Creates a new empty 2D complex standard part descriptor.

Visual Basic
Sub Create2dComplexStdPartCompGroupDescriptor(Descriptor As [out, retval] IMcad2dComplexStdPartCompGroupDescriptor*)
Returns

Mcad2dComplexStdPartCompGroupDescriptor object


IMcad2DStructureMgr::Create2dComponentDescriptor Method
Summary

Creates a new empty 2D component descriptor.

Visual Basic
Sub Create2dComponentDescriptor(Descriptor As [out, retval] IMcad2dComponentDescriptor*)
Returns

Mcad2dComponentDescriptor object


IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method
Summary

Creates a new empty 2D standard part component descriptor.

Visual Basic
Sub Create2dStdPartComponentDescriptor(Descriptor As [out, retval] IMcad2dStdPartComponentDescriptor*)
Returns

Mcad2dStdPartComponentDescriptor object


IMcad2DStructureMgr::CreateBlocksFromStructure Method
Summary

Migrates the 2D structure component views and folders to blocks.

Visual Basic
Sub CreateBlocksFromStructure(removeStructure As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
removeStructure | Boolean, default value = TRUE; input-only. Specifies whether all local 2D Structure folders, component views and components are removed after converting to blocks.
Returns

None

Remarks

  • AutoCAD Mechanical objects of drawings are created with versions of AutoCAD Mechanical that did not support mechanical structure or drawings created with the structure option disabled.
  • Hide situations and occurrence property overrides will not be maintained after converting to block.
  • Xref components will not be converted to blocks.
  • The name of the block that is converted from a component view will use the format, _. For example, the component view, COMP1:1(Top) will be converted to a block with name COMP1_Top. The name of the block that is converted from folder will be the same as the name of the folder definition. For example, the folder, FOLDER1:1 will be converted to a block with name FOLDER1.


IMcad2DStructureMgr::CreateComponentViewDescriptor Method
Summary

Creates a new empty component view descriptor.

Visual Basic
Sub CreateComponentViewDescriptor(Descriptor As [out, retval] IMcadComponentViewDescriptor*)
Returns

McadComponentViewDescriptor object


IMcad2DStructureMgr::CreateFolderDescriptor Method
Summary

Creates a new empty folder descriptor.

Visual Basic
Sub CreateFolderDescriptor(Descriptor As [out, retval] IMcadFolderDescriptor*)
Returns

McadFolderDescriptor object


IMcad2DStructureMgr::CreateStructureFromBlocks Method
Summary

Creates an array of 2D structure component or folder descriptors based on existing block definitions.

Visual Basic
Sub CreateStructureFromBlocks(componentDescriptors As VARIANT, folderDescriptors As VARIANT)
Parameters
Parameters | Description
componentDescriptors | Variant (array of Mcad2DComponentDescriptor objects); input-only. Specifies the new component descriptors to create in the 2D structure.
FolderDescriptors | Variant (array of McadFolderDescriptor objects); input-only. Specifies the new folder descriptors to create in the 2D structure.
Returns

None


IMcad2DStructureMgr::ExternalStructureDatabases Method
Summary

Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.

Visual Basic
Sub ExternalStructureDatabases(database As IAcadDatabase, Databases As [out, retval] VARIANT)
Parameters
Parameters | Description
Database | AcadDatabase database; input-only. Specifies the xref database to get the corresponding AcadDatabase objects for.
Remarks

  • This property is a Variant (array of AcadDatabase objects).
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::GetComplexStdPartsForMigr Method
Summary

Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.

Visual Basic
Sub GetComplexStdPartsForMigr(entityGroups As VARIANT, PowerObjectType As [in, defaultvalue(mcScrewConObj | mcPartFeatObj)] long, ViewGroupDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
entityGroups | Variant (array of arrays of object IDs (array of arrays of Longs)); input-only; defining view groups. The function ami2DSGetComplexStdPartsForMigr returns the descriptors of complex standard parts (CSPs) to be migrated. Entity groups help to assign CSP view group descriptors to CSP component group descriptors. An entity group is similar to a parent assembly view of the CPS, so each created CSP descriptor contains only one view group from each entity group. If the array of entity groups is empty, then each created CSP descriptor has only one view group.
PowerObjectType | Long, default value = mcScrewConObj | mcPartFeatObj; input-only.
Returns

Variant (array of Mcad2dComplexStdPartCompGroupDescriptor objects)

Remarks

mcScrewConObj and mcPartFeatObj are two types in McadPowerObjectType enumeration.


IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method
Summary

Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.

Visual Basic
Sub GetComplexStdPartViewsForMigr(PowerObjType As [in, defaultvalue(mcScrewConObj | mcPartFeatObj)] long, ViewGroupDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
PowerObjType | Long; input-only; default value = mcScrewConObj | mcPartFeatObj.
Returns

Variant (array of McadPowObjViewGroupDescriptor objects)

Remarks

mcScrewConObj and mcPartFeatObj are two types in McadPowerObjectType enumeration.


IMcad2DStructureMgr::GetComponentDefinitions Method
Summary

Returns a list of component definitions in the current document or in the specified database.

Visual Basic
Sub GetComponentDefinitions(ByRef componentdefs As IMcadComponentDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
componentdefs | McadComponentDefinitions collection; output-only. Returns the list of component definitions.
includeExternals | Boolean; input-only. Specifies whether the external component definitions that are referenced from the hose database are included, TRUE, or not, FALSE.
Database | Variant (AcadDatabase database), default value = NULL; input-only; optional. Specifies the AcadDatabase for the external component definitions to perform the method.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::GetComponentViewDefinitions Method
Summary

Returns a list of component view definitions in the current document or in the specified database.

Visual Basic
Sub GetComponentViewDefinitions(ByRef compViewDefs As IMcadComponentViewDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
compViewDefs | McadComponentViewDefinitions collection; output-only. Returns the list of component definitions.
includeExternals | Boolean; input-only. Specifies whether the external component view definitions that are referenced from the hose database are included, TRUE, or not, FALSE.
Database | Variant (AcadDatabase database), default value = NULL; input-only; optional. Specifies the AcadDatabase for the external component definitions to perform the method.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::GetFolderDefinitions Method
Summary

Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.

Visual Basic
Sub GetFolderDefinitions(ByRef folderdefs As IMcadFolderDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
folderdefs | McadFolderDefinitions collection; output-only. Specifies the collection of folder definitions to get.
includeExternals | Boolean; input-only. Specifies whether the external folder definitions are get, TRUE, or not, FALSE.
Database | AcadDatabase database; input-only; optional. Specifies the AcadDatabase for external folder definitions to get.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method
Summary

Gets the array of power object folder descriptors to be migrated to 2D structure.

Visual Basic
Sub GetFolderPowerObjectsForMigr(PowerObjectType As [in, defaultvalue(mcAllFolderPowerObj)] long, FolderDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
PowerObjectType | Long, default value = mcAllFolderPowerObj; input-only.
Returns

Variant (array of McadFolderDescriptor objects)

Remarks

mcAllFolderPowerObj is one type in McadPowerObjectType enumeration.


IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
Summary

Gets the next unique annotation view definition name based on a specified component definition.

Visual Basic
Sub GetNextAnnotationViewDefinitionName(pCompDef As IMcadComponentDefinition, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pCompDef | McadComponentDefinition object; input-only. Specifies the component definition for the next unique annotation view definition.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database for the next unique annotation view definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::GetNextComponentDefinitionName Method
Summary

Gets the name of the next unique component definition based on the specified name.

Visual Basic
Sub GetNextComponentDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the name of the current component definition. By default, the component name specified in the user options is used.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database of the next unique component definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::GetNextFolderDefinitionName Method
Summary

Gets the name of the next unique folder definition based on a specified name.

Visual Basic
Sub GetNextFolderDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the name of the current folder definition. By default, the component name specified in the user options is used.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database of the next unique folder definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.


IMcad2DStructureMgr::GetSelection Method
Summary

Get the currently selected folders and/or component views in 2D structure.

Visual Basic
Sub GetSelection(ByRef Views As IMcadFolders*)
Parameters
Parameters | Description
views | Variant ( McadFolders collection); output-only. Specifies the folders to get. Both folders and component views are specified in the selected folders.
Returns

None


IMcad2DStructureMgr::GetShaftsForMigr Method
Summary

Gets the array of shaft component group descriptors to be migrated to 2D structure.

Visual Basic
Sub GetShaftsForMigr(GroupDescriptors As [out, retval] VARIANT)
Returns

Variant (array of Mcad2dShaftCompGroupDescriptor objects); output-only.


IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method
Summary

Gets the array of single standard component descriptors to be migrated to 2D structure.

Visual Basic
Sub GetSingleStdPartComponentsForMigr(entityGroups As VARIANT, StdPartDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
entityGroups | Variant (array of arrays of object IDs (array of arrays of Longs)); input-only. The function ami2DSGetSglStdPartCompsForMigr returns the descriptors of single standard components to be migrated. Entity groups help to assign view group descriptors to component group descriptors. An entity group is similar to a parent assembly view of the component group, so each created descriptor contains only one view group from each entity group. If the array of entity groups is empty, then each created descriptor has only one view group.
Returns

Variant (array of Mcad2dComponentDescriptor objects); output-only


IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method
Summary

Gets the array of single standard part view descriptors to be migrated to 2D structure.

Visual Basic
Sub GetSingleStdPartViewsForMigr(ComponentViewDescriptors As [out, retval] VARIANT)
Returns

Variant (array of McadStdPartComponentViewDescriptor objects); output-only


IMcad2DStructureMgr::GetStructureFromEntity Method
Summary

Get the a McadFolder or McadComponentView for an entity in model space.

Visual Basic
Sub GetStructureFromEntity(ent As IAcadEntity, pView As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
ent | AcadEntity; input-only. Specifies the entity in model space to get the corresponding 2D structure from.
Returns

Variant ( McadFolder object)

Remarks

If the mspace entity is not in 2D structure, this method returns an empty string.


IMcad2DStructureMgr::HasComponentDefinition Method
Summary

Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.

Visual Basic
Sub HasComponentDefinition(pName As String, ByRef pCompDef As IMcadComponentDefinition*, pHasCompDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the component definition to perform the check.
pCompDef | McadComponentDefinition object; output-only. Returns the component definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::HasFolderDefinition Method
Summary

Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.

Visual Basic
Sub HasFolderDefinition(pName As String, ByRef pFolderDef As IMcadFolderDefinition*, pHasFolderDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the folder definition to perform the check.
pFolderDef | McadfolderDefinition object; output-only. Returns the folder definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean


IMcad2DStructureMgr::Highlight Method
Summary

Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.

Visual Basic
Sub Highlight(pViews As IMcadFolders, highlight As VARIANT_BOOL)
Parameters
Parameters | Description
pViews | McadFolders collection; input-only. Specifies the collection of one or more folders and/or component views to be highlighted.
Highlight | Boolean; input-only. Specifies whether to highlight the specified collection of component views or folders, TRUE, or not, FALSE.
Returns

None


IMcad2DStructureMgr::Is2DStructureEnabled Method
Summary

Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.

Visual Basic
Sub Is2DStructureEnabled(pIsStructureEnabled As [out, retval] VARIANT_BOOL)
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::IsEntityAllowed Method
Summary

Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.

Visual Basic
Sub IsEntityAllowed(pEntity As IAcadEntity, pIsAllowed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity object for which to perform the determination.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::IsFreeEntity Method
Summary

Check whether an entity is a free entity, TRUE, or not, FALSE.

Visual Basic
Sub IsFreeEntity(pEntity As IAcadEntity, pIsFree As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity object for which to perform the check.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr::IsInActiveTarget Method
Summary

Checks whether an entity is in the active target, TRUE, or not, FALSE.

Visual Basic
Sub IsInActiveTarget(pEntity As IAcadEntity, pIsInActiveTarget As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity to perform the check.
Returns

Boolean


IMcad2DStructureMgr::IsStructureBlock Method
Summary

Checks whether a block is block structure rather than mechanical structure.

Visual Basic
Sub IsStructureBlock(Block As IAcadBlock, IsStructureBlock As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Block | AcadBlock object; input-only. Specifies the block to perform the check.
Returns

Boolean


IMcad2DStructureMgr::PurgeAll2DS Method
Summary

Purges all 2D structure definitions whose name matches the pattern.

Visual Basic
Sub PurgeAll2DS(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all 2D structure definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the ObjectARX documentation of acutWcMatch() for details of the wildcard characters.
Returns

None


IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method
Summary

Purges all annotation view definitions whose name matches the pattern.

Visual Basic
Sub PurgeAnnotationViewDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all annotation view definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the ObjectARX documentation of acutWcMatch() for details of the wildcard characters.
Returns

None


IMcad2DStructureMgr::PurgeComponentDefinitions Method
Summary

Purges all component definitions whose name matches the pattern.

Visual Basic
Sub PurgeComponentDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all component definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the ObjectARX documentation of acutWcMatch() for details of the wildcard characters.
Returns

None


IMcad2DStructureMgr::PurgeComponentViewDefinitions Method
Summary

Purges all component view definitions whose name matches the pattern.

Visual Basic
Sub PurgeComponentViewDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all component view definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the ObjectARX documentation of acutWcMatch() for details of the wildcard characters.
Returns

None


IMcad2DStructureMgr::PurgeFolderDefinitions Method
Summary

Purges all folder definitions whose name matches the pattern.

Visual Basic
Sub PurgeFolderDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all folder definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the ObjectARX documentation of acutWcMatch() for details of the wildcard characters.
Returns

None


IMcad2DStructureMgr::RestructureViews Method
Summary

Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.

Visual Basic
Sub RestructureViews(pViews As IMcadFolders, pTarget As IMcadFolder)
Parameters
Parameters | Description
pViews | Variant ( McadFolders collection); input-only. Specifies the collection of component views or folders in 2D structure to restructure.
pTarget | Variant ( McadFolder object); optional; input-only. Specifies the parent folder or component view where the specified collection of component views or folders are placed.
Returns

None

Remarks

  • An error will be returned if this operation violates parent child rules.
  • To restructure the master (root) view definition, set pTarget = Nothing.


IMcad2DStructureMgr::RootComponentDefinition Method
Summary

Gets the root, or top level component definition in which 2D structure components are inserted into in this document.

Visual Basic
Sub RootComponentDefinition(Database As [in, optional] VARIANT, pVal As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database to get the root for; if not specified, the root for the host database of the document is used.
Remarks

  • This property is a McadComponentDefinition object.
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.


IMcad2DStructureMgr::RootViewDefinition Method
Summary

Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.

Visual Basic
Sub RootViewDefinition(Database As [in, optional] VARIANT, pVal As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database to get the root for; if not specified, the root for the host database of the document is used.
Remarks
  • This property is a McadComponentViewDefinition object.
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.


IMcad2DStructureMgr::Update Method
Summary

Forces an immediate update of 2D structure.

Visual Basic
Sub Update(ForceAll As VARIANT_BOOL)
Parameters
Parameters | Description
ForceAll | Boolean, default value = TRUE; input-only. Specifies whether to update all 2D structure in the document, TRUE, or not, FALSE. It is not recommended to set ForceAll to TRUE.
Returns

None


IMcad2DStructureMgr::UpdateEntities Method
Summary

Updates 2D structure with entity changes in model space.

Visual Basic
Sub UpdateEntities()
Returns

None

Remarks

When a new entity is added to an active target in 2D structure or a structure entity is modified / deleted, using AutoCAD API, execute this method to update the 2D structure with the entity changes.


IMcad2DStructureMgr2 Interface
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
Visual Basic
Public Interface IMcad2DStructureMgr2
Inherits IMcad2DStructureMgr
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Links
IMcad2DStructureMgr2 Members, AcadmAuto Library


IMcad2DStructureMgr2 Members
Summary

The following tables list the members exposed by IMcad2DStructureMgr2.

Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


IMcad2DStructureMgr2::StartTransaction Property
Summary

Starts a new transaction and returns an McadTransaction object.

Visual Basic
Property StartTransaction() As IMcadTransaction**
Remarks

To end a transaction, set the transaction object to Null.

To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete. To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.


IMcad2DStructureMgr3 Interface
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
Visual Basic
Public Interface IMcad2DStructureMgr3
Inherits IMcad2DStructureMgr2
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Links
IMcad2DStructureMgr3 Members, AcadmAuto Library


IMcad2DStructureMgr3 Members
Summary

The following tables list the members exposed by IMcad2DStructureMgr3.

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


IMcad2DStructureMgr3::AddNewAnnotationView Method
Summary

Creates new annotation view

Visual Basic
Sub AddNewAnnotationView(pDefToInst As IMcadAnnotationViewDefinition, pMat As IGeMatrix, ByRef pNewViewInst As IMcadFolder*, OwningSpace As [in, optional] VARIANT)


IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
Summary

Create an annotation view and definition based on the specified component definition and component view definitions.

Visual Basic
Sub AddNewAnnotationViewDefinition(ByRef pNewAnnotationViewDef As IMcadAnnotationViewDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, matrices As VARIANT, pCompDef As IMcadComponentDefinition, pCompViewDefs As IMcadComponentViewDefinitions, Name As [in, optional] VARIANT, CreateLabels As [in, optional] VARIANT, LabelPattern As [in, optional] VARIANT, OwningSpace As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewAnnotationViewDef | McadAnnotationViewDefinition object; output-only. Specifies the new annotation view definition to create.
pNewFolderInst | McadFolder object; output-only. Specifies the parent folder for the new annotation view definition.
pMat | GeMatrix object; input-only. Specifies the base position for the new annotation view.
matrices | Variant (array of GeMatrix objects); input-only. Specifies the array of matrices for the new position of each of the new views.
pCompDef | McadComponentDefinition object; input-only. Specifies a valid component based on which to create the new annotation view.
pCompViewDefs | McadComponentViewDefinitions collection; input-only. Specifies an array of component view definitions of pCompDefKey whose corresponding annotation view position are specified in arMatrices.
Name | Variant (String); input-only. Specifies the name of the new annotation view definition. If not specified, system will generate an appropriate name.
CreateLabels | _nt_
LabelPattern | _nt_
OwningSpace | _nt_
Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcad2DStructureMgr3::UpdateEntities Method
Summary

Updates 2D structure with entity changes in model space.

Visual Basic
Sub UpdateEntities(Database As [in, optional] VARIANT)
Remarks

When a new entity is added to an active target in 2D structure or a structure entity is modified / deleted, using AutoCAD API, execute this method to update the 2D structure with the entity changes.


IMcad2DStructureMgr4 Interface
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5
Visual Basic
Public Interface IMcad2DStructureMgr4
Inherits IMcad2DStructureMgr3
Links
IMcad2DStructureMgr4 Members, AcadmAuto Library


IMcad2DStructureMgr4 Members
Summary

The following tables list the members exposed by IMcad2DStructureMgr4.

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


IMcad2DStructureMgr4::SelectionLockMode Property
Summary

Property that specifies the state of the 2D Structure selection lock mode.

Visual Basic
Property SelectionLockMode() As VARIANT_BOOL


IMcad2DStructureMgr4::SelectionOrderMode Property
Summary

Property that specifies the state of the 2D Structure selection order mode.

Visual Basic
Property SelectionOrderMode() As McadSelectionOrderOption


IMcad2DStructureMgr4::GetReferenceLockMode Method
Summary

Gets the state of the 2D Structure reference lock mode for a database.

Visual Basic
Sub GetReferenceLockMode(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pMode As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | Optional. Default is NULL. The database to retrieve the state of the 2D Structure reference lock mode. By default, the current database is used.


IMcad2DStructureMgr4::GetStructureMode Method
Summary

Gets the state of the 2D Structure mode for a database.

Visual Basic
Sub GetStructureMode(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pMode As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | Optional. Default is NULL. The database to retrieve the state of the 2D Structure mode. By default, the current database is used.


IMcad2DStructureMgr4::SetReferenceLockMode Method
Summary

Sets the state of the 2D Structure reference lock mode for a database.

Visual Basic
Sub SetReferenceLockMode(bMode As VARIANT_BOOL, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase)
Parameters
Parameters | Description
bMode | The state of the 2D Structure reference lock mode to set.
pDatabase | Optional. Default is NULL. The database to set the state of the 2D Structure reference lock mode. By default, the current database is used.


IMcad2DStructureMgr4::SetStructureMode Method
Summary

Sets the state of the 2D structure mode for a database.

Visual Basic
Sub SetStructureMode(bMode As VARIANT_BOOL, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase)
Parameters
Parameters | Description
bMode | The state of the 2d Structure mode to set.
pDatabase | Optional. Default is NULL. The database to set the state of the 2D Structure mode. By default, the current database is used.
Remarks

Raises an error when setting the state of the 2D Structure mode to false for a database that has 2D Structure.


IMcad2DStructureMgr5 Interface
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5
Visual Basic
Public Interface IMcad2DStructureMgr5
Inherits IMcad2DStructureMgr4
Links
IMcad2DStructureMgr5 Members, AcadmAuto Library


IMcad2DStructureMgr5 Members
Summary

The following tables list the members exposed by IMcad2DStructureMgr5.

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateRootViewDefinition | Creates a master view definition in the specified database. If the database already contains a master view definition, it returns the existing one.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExistsStructure | Checks for the existence of mechanical structure in the specified database.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


IMcad2DStructureMgr5::CreateRootViewDefinition Method
Summary

Creates a master view definition in the specified database. If the database already contains a master view definition, it returns the existing one.

Visual Basic
Sub CreateRootViewDefinition(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pVal As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
pDatabase | AcadDatabase object; default value = NULL; input-only; optional. Specifies the database to check. If NULL, the host database of the current document is assumed.
pVal | MCadFolderDefinition object; output only. Specifies the created or existing master view definition.
Remarks

Read-only.


IMcad2DStructureMgr5::ExistsStructure Method
Summary

Checks for the existence of mechanical structure in the specified database.

Visual Basic
Sub ExistsStructure(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | AcadDatabase object; default value = NULL; input-only; optional. Specifies the database to check. If NULL, the host database of the current document is assumed.
pVal | Variant (Boolean); output only. True, if the database contains view or folder definitions.
Remarks

Read-only.


IMcadAnnotationViewDefinition Interface
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2
Visual Basic
Public Interface IMcadAnnotationViewDefinition
Inherits IMcadFolderDefinition
Remarks

Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Example

Refer to SDK Samples: CreateStructure.dvb

Links
IMcadAnnotationViewDefinition Members, AcadmAuto Library, Example


IMcadAnnotationViewDefinition Members
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinition.

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadAnnotationViewDefinition::ComponentDefinition Property
Summary

Extracts the component definition that the annotation view is based on.

Visual Basic
Property ComponentDefinition() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.


IMcadAnnotationViewDefinition::AddComponentView Method
Summary

Add an annotation view for the specified component view definition.

Visual Basic
Sub AddComponentView(pDefToInst As IMcadComponentViewDefinition, pMat As IGeMatrix, pVal As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition whose annotation is to be created.
pMat | GeMatrix object; input-only. Specifies the position to place the annotation view.
Returns

McadComponentView object

Remarks

GeMatrix object defines a 4 x 4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Example

Refer to SDK Samples: CreateStructure.dvb

Links
Example


IMcadAnnotationViewDefinition::RemoveComponentView Method
Summary

Removes the specified child component view of this annotation view definition.

Visual Basic
Sub RemoveComponentView(pCompView As IMcadComponentView)
Parameters
Parameters | Description
pCompView | McadComponentView object; input-only. Specifies the child component view to be removed.
Returns

None


IMcadAnnotationViewDefinition2 Interface
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2
Visual Basic
Public Interface IMcadAnnotationViewDefinition2
Inherits IMcadAnnotationViewDefinition
Remarks

Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Example

Refer to SDK Samples: CreateStructure.dvb

Links
IMcadAnnotationViewDefinition2 Members, AcadmAuto Library, Example


IMcadAnnotationViewDefinition2 Members
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinition2.

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
AnnotationViewLabel | Returns annotation view label for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
Children | Gets the children of the folder definition.
CreateAnnotationViewLabel | Creates annotation view label for subview of annotation view
CreateAnnotationViewLabels | Creates annotation view label for subview of annotation view
Delete | Deletes the object being referenced.
EraseAnnotationViewLabel | Erase annotation view label for subview of annotation view
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
HasAnnotationViewLabel | Erase annotation view label for subview of annotation view
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadAnnotationViewDefinition2::AnnotationViewLabel Method
Summary

Returns annotation view label for subview of annotation view

Visual Basic
Sub AnnotationViewLabel(pSubView As IMcadComponentView, pLabelPath As [out, retval] IMcadFolder*)


IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)
Summary

Returns annotation view label pattern for subview of annotation view

Visual Basic
Sub AnnotationViewLabelPattern(pSubView As IMcadComponentView, LabelPattern As String)


IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)
Summary

Returns annotation view label pattern for subview of annotation view

Visual Basic
Sub AnnotationViewLabelPattern(pSubView As IMcadComponentView, pLabelPattern As [out, retval] BSTR)


IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method
Summary

Creates annotation view label for subview of annotation view

Visual Basic
Sub CreateAnnotationViewLabel(pSubView As IMcadComponentView, LabelPattern As [in, optional] VARIANT)


IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method
Summary

Creates annotation view label for subview of annotation view

Visual Basic
Sub CreateAnnotationViewLabels(LabelPattern As [in, optional] VARIANT)
Parameters
Parameters | Description
LabelPattern | _nt_


IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method
Summary

Erase annotation view label for subview of annotation view

Visual Basic
Sub EraseAnnotationViewLabel(pSubView As IMcadComponentView)


IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method
Summary

Erase annotation view label for subview of annotation view

Visual Basic
Sub HasAnnotationViewLabel(pSubView As IMcadComponentView, pHasLabel As [out, retval] VARIANT_BOOL)


IMcadAnnotationViewDefinitions Interface
Summary

A collection of McadAnnotationViewDefinition objects.

Class Hierarchy

Declaration syntax

IMcadAnnotationViewDefinitions
Visual Basic
Public Interface IMcadAnnotationViewDefinitions
Inherits IDispatch
Links
IMcadAnnotationViewDefinitions Members, AcadmAuto Library


IMcadAnnotationViewDefinitions Members
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinitions.

Methods
Name | Description
Add | Appends a new annotation view definition to the collection.
Item | Gets the annotation view definition at the specified index.
Remove | Removes the specified annotation view definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of annotation view definitions in the collection.


IMcadAnnotationViewDefinitions::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadAnnotationViewDefinitions::Count Property
Summary

Gets the total number of annotation view definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadAnnotationViewDefinitions::Add Method
Summary

Appends a new annotation view definition to the collection.

Visual Basic
Sub Add(Definition As IMcadAnnotationViewDefinition)
Parameters
Parameters | Description
Definition | McadAnnotationViewDefinition object; input-only. Specifies the new annotation view definition to add to the collection.
Returns

None


IMcadAnnotationViewDefinitions::Item Method
Summary

Gets the annotation view definition at the specified index.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadAnnotationViewDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the annotation view definition to get from the collection.
Returns

McadAnnotationViewDefinition object


IMcadAnnotationViewDefinitions::Remove Method
Summary

Removes the specified annotation view definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the annotation view definition to get from the collection.
Returns

None


IMcadArc Interface
Summary

An arc curve.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc
Visual Basic
Public Interface IMcadArc
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadAttribute Interface
Summary

Represents an instance of an attribute.

Class Hierarchy

Declaration syntax

IMcadAttribute
Visual Basic
Public Interface IMcadAttribute
Inherits IDispatch
Links
IMcadAttribute Members, AcadmAuto Library


IMcadAttribute Members
Summary

The following tables list the members exposed by IMcadAttribute.

Methods
Name | Description
FieldDescription | Gets the description for the specified attribute field.
FieldName | Gets the name of the specified attribute field.
FieldType | Gets the data type held by the specified field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
GetFieldIndex | Gets the index associated with the specified attribute field name.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ClassName | Gets the name of the attribute's class definition.
Document | Gets the document containing this object.
FieldCount | Gets the number of fields in the attribute.
Holders | Gets references to the object that this attribute is attached to.
ObjectID | Gets the object ID of the attribute object.
ObjectID32 | Gets the object ID of the attribute object.


IMcadAttribute::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadAttribute::ClassName Property
Summary

Gets the name of the attribute's class definition.

Visual Basic
Property ClassName() As BSTR*
Remarks

This property is a String.


IMcadAttribute::Document Property
Summary

Gets the document containing this object.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.


IMcadAttribute::FieldCount Property
Summary

Gets the number of fields in the attribute.

Visual Basic
Property FieldCount() As long*
Remarks

This property is a Long.


IMcadAttribute::Holders Property
Summary

Gets references to the object that this attribute is attached to.

Visual Basic
Property Holders() As IMcadObjects**
Remarks

This property is a McadObjects collection.


IMcadAttribute::ObjectID Property
Summary

Gets the object ID of the attribute object.

Visual Basic
Property ObjectID() As LONG_PTR*
Remarks

This property is a Long.


IMcadAttribute::ObjectID32 Property
Summary

Gets the object ID of the attribute object.

Visual Basic
Property ObjectID32() As LONG*
Remarks

This property is a Long.


IMcadAttribute::FieldDescription Method
Summary

Gets the description for the specified attribute field.

Visual Basic
Sub FieldDescription(Index As [in, optional] VARIANT, Description As [out, retval] BSTR)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the description for. If not specified, the description of the first field is returned.
Remarks
  • This property is a String.
  • The Index element can be obtained from the GetFieldIndex method.


IMcadAttribute::FieldName Method
Summary

Gets the name of the specified attribute field.

Visual Basic
Sub FieldName(Index As [in, defaultvalue(0)] long, Name As [out, retval] BSTR)
Parameters
Parameters | Description
Index | Long, default value = 0; input-only; optional. Specifies the index for the attribute field to get the name for.
Remarks

This property is a String.


IMcadAttribute::FieldType Method
Summary

Gets the data type held by the specified field.

Visual Basic
Sub FieldType(Index As [in, optional] VARIANT, Type As [out, retval] McadFieldType)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the field type for. If not specified, the type of the first field is returned.
Remarks

This property is a McadFieldType enumeration.


IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue(Index As [in, optional] VARIANT, Value As VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Remarks

This property is a Variant determined by FieldType .


IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue(Index As [in, optional] VARIANT, Value As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Remarks

This property is a Variant determined by FieldType .


IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue32(Index As [in, optional] VARIANT, Value As VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Value | _nt_
Remarks

This property is a Variant determined by FieldType.


IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue32(Index As [in, optional] VARIANT, Value As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Value | _nt_
Remarks

This property is a Variant determined by FieldType.


IMcadAttribute::GetFieldIndex Method
Summary

Gets the index associated with the specified attribute field name.

Visual Basic
Sub GetFieldIndex(Name As String, Index As [out, retval] long)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute field name.
Returns

Long


IMcadAttributeField Interface
Summary

Represents the description of a single attribute field.

Class Hierarchy

Declaration syntax

IMcadAttributeField
Visual Basic
Public Interface IMcadAttributeField
Inherits IDispatch
Links
IMcadAttributeField Members, AcadmAuto Library


IMcadAttributeField Members
Summary

The following tables list the members exposed by IMcadAttributeField.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Description | Specifies the text description or comment describing the contents of the attribute field.
FieldType | Specifies the data type held by the specified attribute field.
Name | Specifies the name of the attribute field.
Static | Specifies whether the fields data is static, TRUE, or shared across all instances of the attribute, FALSE.


IMcadAttributeField::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadAttributeField::Description Property
Summary

Specifies the text description or comment describing the contents of the attribute field.

Visual Basic
Property Description() As String
Remarks
  • This property is a String.
  • Setting or changing the field description only has an effect when the McadAttributeField is used to define an attribute class.


IMcadAttributeField::FieldType Property
Summary

Specifies the data type held by the specified attribute field.

Visual Basic
Property FieldType() As McadFieldType
Remarks
  • This property is a McadFieldType enumeration.
  • Setting or changing the field type only has an effect when the McadAttributeField is used to define an attribute class.


IMcadAttributeField::Name Property
Summary

Specifies the name of the attribute field.

Visual Basic
Property Name() As String
Remarks
  • This property is a String.
  • Setting or changing this property only has an effect when the McadAttributeField is used to define an attribute class.


IMcadAttributeField::Static Property
Summary

Specifies whether the fields data is static, TRUE, or shared across all instances of the attribute, FALSE.

Visual Basic
Property Static() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Setting or changing this property only has an effect when the McadAttributeField is used to define an attribute class.


IMcadAttributeFields Interface
Summary

A collection of McadAttributeField objects.

Class Hierarchy

Declaration syntax

IMcadAttributeFields
Visual Basic
Public Interface IMcadAttributeFields
Inherits IDispatch
Links
IMcadAttributeFields Members, AcadmAuto Library


IMcadAttributeFields Members
Summary

The following tables list the members exposed by IMcadAttributeFields.

Methods
Name | Description
Add | Appends an attribute field to the collection.
Item | Gets the attribute field at the specified index.
Remove | Removes the specified attribute field from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of attribute fields in the collection.


IMcadAttributeFields::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadAttributeFields::Count Property
Summary

Gets the total number of attribute fields in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadAttributeFields::Add Method
Summary

Appends an attribute field to the collection.

Visual Basic
Sub Add(Field As IMcadAttributeField)
Parameters
Parameters | Description
Field | McadAttributeField object; input-only. Specifies the new attribute field to add to the collection.
Returns

None


IMcadAttributeFields::Item Method
Summary

Gets the attribute field at the specified index.

Visual Basic
Sub Item(Index As long, Field As [out, retval] IMcadAttributeField*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute field to get from the collection.
Returns

McadAttributeField object


IMcadAttributeFields::Remove Method
Summary

Removes the specified attribute field from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute field to remove from the collection.
Returns

None


IMcadAttributes Interface
Summary

A collection of McadAttribute objects.

Class Hierarchy

Declaration syntax

IMcadAttributes
Visual Basic
Public Interface IMcadAttributes
Inherits IDispatch
Links
IMcadAttributes Members, AcadmAuto Library


IMcadAttributes Members
Summary

The following tables list the members exposed by IMcadAttributes.

Methods
Name | Description
Add | Appends an attribute to a the collection.
Item | Gets the attribute at the specified index.
Remove | Removes the specified attribute from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of items in the collection.


IMcadAttributes::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadAttributes::Count Property
Summary

Gets the total number of items in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadAttributes::Add Method
Summary

Appends an attribute to a the collection.

Visual Basic
Sub Add(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the collection.
Returns

None


IMcadAttributes::Item Method
Summary

Gets the attribute at the specified index.

Visual Basic
Sub Item(Index As long, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute to get from the collection.
Returns

McadAttribute object


IMcadAttributes::Remove Method
Summary

Removes the specified attribute from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute to get from the collection.
Returns

None


IMcadAugmentedLine Interface
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadAugmentedLine
Visual Basic
Public Interface IMcadAugmentedLine
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadComplexHideSituation Interface
Summary

This object provides general methods for 2D structure complex hide situations.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComplexHideSituation
Visual Basic
Public Interface IMcadComplexHideSituation
Inherits IMcadObject
Links
IMcadComplexHideSituation Members, AcadmAuto Library


IMcadComplexHideSituation Members
Summary

The following tables list the members exposed by IMcadComplexHideSituation.

Methods
Name | Description
AddLevel | Adds new level to complex hide, new hide situation pNewHide is created for the new level, or existing hide situation is used as level if it was specified in pNewHide.
Delete | Deletes the object being referenced.
Explode | Converts complex hide situation to normal hide situations. Each levels of complex hide create simple independent hide situation. The foreground and background will be set from the position of the level in the complex hide situation.
Highlight | Highlights the topological entity on the model.
InitFromHide | Initializes the complex hide situation from the specified normal hide situation. The complex hide will has two levels. First level is foreground of the specified hide and the second level is background of the specified hide.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
LookupLevelName | Looks up the level with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
MoveLevel | Changes the position of the level (hide) within the complex hide levels.
RemoveLevel | Removes the specified level (hide) from the complex hide situation.
RemoveLevelByIdx | Removes the level (hide) with the given index from the complex hide situation.
Reverse | Reverses the order of all levels in the complex hide situation.
UpdateBgSelection | Recalculates the background selections based on the current foreground selections.
Properties
Name
Description
Application
Gets the AcadmApplication object.
Concealed
Gets or sets whether the complex hide situation is concealed, TRUE, or not, FALSE.
Definition
Gets or sets the parent folder definition for this complex hide situation.
Document
Gets the corresponding McadDocument from the specified host application's document.
Editable
Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
HiddenLinesInvisible
Gets whether the hidden lines are invisible, TRUE, or dashed, FALSE.
HideAppropriateObjectsOnly
Specifies how background objects are processed:

  • TRUE: A filter is applied and objects that have their 'Usage in Hide' property set to 'Ignore in Hide' or 'Foreground only' (via the Layer/Object property).
  • FALSE: All objects selected for the background are hidden.
HideSituations
Returns all hide situations from this complex hide situation.
IsModifiedStandardPartHide
Gets whether the complex hide situation has been modified by users, TRUE, or not, FALSE.
IsStandardPartHide
Gets whether hide situations was automatically created by standard parts, TRUE, or not, FALSE.
LevelCount
Returns the number of levels in complex hide situation.
Name
Gets or sets the complex hide situation.
NextLevelName
Returns the default name for the next new level in the complex hide situation.
Suppressed
Gets whether the complex hide situation is suppressed, TRUE, or not, FALSE.
SysName
Gets the complex hide situation system name.
WasErased
Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadComplexHideSituation::Concealed Property
Summary

Gets or sets whether the complex hide situation is concealed, TRUE, or not, FALSE.

Visual Basic
Property Concealed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::Definition Property
Summary

Gets or sets the parent folder definition for this complex hide situation.

Visual Basic
Property Definition() As IMcadFolderDefinition*
Remarks

This property is a McadFolderDefinition object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::HiddenLinesInvisible Property
Summary

Gets whether the hidden lines are invisible, TRUE, or dashed, FALSE.

Visual Basic
Property HiddenLinesInvisible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
Summary

Specifies how background objects are processed:

  • TRUE: A filter is applied and objects that have their 'Usage in Hide' property set to 'Ignore in Hide' or 'Foreground only' (via the Layer/Object property).
  • FALSE: All objects selected for the background are hidden.
Visual Basic
Property HideAppropriateObjectsOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::HideSituations Property
Summary

Returns all hide situations from this complex hide situation.

Visual Basic
Property HideSituations() As IMcadHideSituations* *
Remarks

This property is a McadHideSituations enumeration.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::IsModifiedStandardPartHide Property
Summary

Gets whether the complex hide situation has been modified by users, TRUE, or not, FALSE.

Visual Basic
Property IsModifiedStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::IsStandardPartHide Property
Summary

Gets whether hide situations was automatically created by standard parts, TRUE, or not, FALSE.

Visual Basic
Property IsStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::LevelCount Property
Summary

Returns the number of levels in complex hide situation.

Visual Basic
Property LevelCount() As long*
Remarks

This property is a Long.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::Name Property
Summary

Gets or sets the complex hide situation.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::NextLevelName Property
Summary

Returns the default name for the next new level in the complex hide situation.

Visual Basic
Property NextLevelName() As BSTR*
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::Suppressed Property
Summary

Gets whether the complex hide situation is suppressed, TRUE, or not, FALSE.

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The hide situation is not computed when it is suppressed.
Example

Refer to SDK Samples: amshide2d.dvb

Links
Example


IMcadComplexHideSituation::SysName Property
Summary

Gets the complex hide situation system name.

Visual Basic
Property SysName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::AddLevel Method
Summary

Adds new level to complex hide, new hide situation pNewHide is created for the new level, or existing hide situation is used as level if it was specified in pNewHide.

Visual Basic
Sub AddLevel(levelIdx As long, pNewHide As [in, out] IMcadHideSituation*)
Parameters
Parameters | Description
levelIdx | Long; input-only. Specifies the index for the level of the hide situation.
pNewHide | McadHideSituation enumeration; input-only. New empty hide situation will be created in the new level with given index. If pNewHide exists, then this hide situation will be used for given index.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::Explode Method
Summary

Converts complex hide situation to normal hide situations. Each levels of complex hide create simple independent hide situation. The foreground and background will be set from the position of the level in the complex hide situation.

Visual Basic
Sub Explode()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::InitFromHide Method
Summary

Initializes the complex hide situation from the specified normal hide situation. The complex hide will has two levels. First level is foreground of the specified hide and the second level is background of the specified hide.

Visual Basic
Sub InitFromHide(pHide As IMcadHideSituation)
Parameters
Parameters | Description
pHide | McadHideSituation object; input-only. Specifies the normal hide situation with which to initialize the complex hide situation.
Returns

None


IMcadComplexHideSituation::LookupLevelName Method
Summary

Looks up the level with the specified name.

Visual Basic
Sub LookupLevelName(levelName As String, pFound As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
levelName | String; input-only. Specifies the name of the level to look up.
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::MoveLevel Method
Summary

Changes the position of the level (hide) within the complex hide levels.

Visual Basic
Sub MoveLevel(srcIdx As long, destIdx As long)
Parameters
Parameters | Description
srcIdx | Long; input-only. Specifies the index of the source level to reposition.
destIdx | Long; input-only. Specifies the index of the destination level to reposition.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::RemoveLevel Method
Summary

Removes the specified level (hide) from the complex hide situation.

Visual Basic
Sub RemoveLevel(pHide As IMcadHideSituation)
Parameters
Parameters | Description
pHide | McadHideSituation enumeration; input-only. Specifies the level (hide) to remove.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::RemoveLevelByIdx Method
Summary

Removes the level (hide) with the given index from the complex hide situation.

Visual Basic
Sub RemoveLevelByIdx(levelIdx As long)
Parameters
Parameters | Description
levelIdx | Long; input-only. Specifies the index for the level (hide) to remove.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::Reverse Method
Summary

Reverses the order of all levels in the complex hide situation.

Visual Basic
Sub Reverse()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituation::UpdateBgSelection Method
Summary

Recalculates the background selections based on the current foreground selections.

Visual Basic
Sub UpdateBgSelection()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadComplexHideSituations Interface
Summary

A collection of McadComplexHideSituation objects

Class Hierarchy

Declaration syntax

IMcadComplexHideSituations
Visual Basic
Public Interface IMcadComplexHideSituations
Inherits IDispatch
Links
IMcadComplexHideSituations Members, AcadmAuto Library


IMcadComplexHideSituations Members
Summary

The following tables list the members exposed by IMcadComplexHideSituations.

Methods
Name | Description
Add | Appends an complex hide situation to the collection.
Item | Gets the complex hide object at the specified index from the collection.
Remove | Removes the specified Complex hide from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of complex hide situations in the collection.


IMcadComplexHideSituations::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a GeApplication object.


IMcadComplexHideSituations::Count Property
Summary

Gets the total number of complex hide situations in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadComplexHideSituations::Add Method
Summary

Appends an complex hide situation to the collection.

Visual Basic
Sub Add(Component As IMcadComplexHideSituation)
Parameters
Parameters | Description
Component | McadComplexHideSituation object; input-only. Specifies the complex hide situation to add to the collection.
Returns

None


IMcadComplexHideSituations::Item Method
Summary

Gets the complex hide object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComplexHideSituation*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the complex hide situation to get.
Returns

McadComplexHideSituation object


IMcadComplexHideSituations::Remove Method
Summary

Removes the specified Complex hide from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the complex hide situation to remove.
Returns

None


IMcadComponent Interface
Summary

References an instance of a component definition in the assembly.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComponent
Visual Basic
Public Interface IMcadComponent
Inherits IMcadObject
Links
IMcadComponent Members, AcadmAuto Library


IMcadComponent Members
Summary

The following tables list the members exposed by IMcadComponent.

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ClearOverrideProperties | Clears all override properties of this component if any exists.
ColorOverride | Sets the color override for all the component's views.
ContainingComponent | Returns the lowest level component that this object is inserted into.
CopyDefinition | Creates a copy of the definition for the specified folder or component view as in AMSCOPYDEF.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
GetComponentInDefinition | Gets the component equivalent to this component in the scope of the component's owning component definition.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for all the component's views.
RemoveAttribute | Removes the specified attribute from this component.
ReplaceDefinition | Replaces a specified component with a new definition as in AMSREPLACEDEF.
SortChildren | Sorts the children of this component.
VisibilityOverride | Sets the visibility override for all the component's views.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the occurrences of the children of the component.
ComponentViews | Gets all component views contained in this component.
Definition | Gets the definition for the component.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
hasExternalDef | Gets whether this component has external definitions, TRUE, or not, FALSE.
HasGhostViews | Specifies whether a component has a ghost component view, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether this component has override properties, TRUE, or not, FALSE.
is2D | Gets whether this component is in 2D structure.
Name | Specifies the name associated with the referenced object.
Owner | Gets the definition of the owner for the component.
Position |
Reference | Specifies whether a component is referenced by an external file.
Visible | Gets or sets the visibility of the component.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadComponent::Children Property
Summary

Gets the occurrences of the children of the component.

Visual Basic
Property Children() As IMcadComponents**
Remarks

This property is a McadComponents collection.


IMcadComponent::ComponentViews Property
Summary

Gets all component views contained in this component.

Visual Basic
Property ComponentViews() As IMcadComponentViews**
Remarks

This property is a McadComponentViews collection.


IMcadComponent::Definition Property
Summary

Gets the definition for the component.

Visual Basic
Property Definition() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.


IMcadComponent::hasExternalDef Property
Summary

Gets whether this component has external definitions, TRUE, or not, FALSE.

Visual Basic
Property hasExternalDef() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponent::HasGhostViews Property
Summary

Specifies whether a component has a ghost component view, TRUE, or not, FALSE.

Visual Basic
Property HasGhostViews() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponent::HasOverrideProperties Property
Summary

Checks whether this component has override properties, TRUE, or not, FALSE.

Visual Basic
Property HasOverrideProperties() As VARIANT_BOOL *
Remarks

This property is a Boolean.


IMcadComponent::is2D Property
Summary

Gets whether this component is in 2D structure.

Visual Basic
Property is2D() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponent::Name Property
Summary

Specifies the name associated with the referenced object.

Visual Basic
Property Name() As String
Remarks

This property is a String.


IMcadComponent::Owner Property
Summary

Gets the definition of the owner for the component.

Visual Basic
Property Owner() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.


IMcadComponent::Position Property
Visual Basic
Property Position() As IGeMatrix*
Remarks

This property has no implementation and is currently unsupported.


IMcadComponent::Reference Property
Summary

Specifies whether a component is referenced by an external file.

Visual Basic
Property Reference() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadComponent::Visible Property
Summary

Gets or sets the visibility of the component.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadComponent::AddAttribute Method
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the component.
Associativity | McadAttributeAssociativity enumeration, default value = 0; input-only; optional. Specifies the behavior of the attribute when the object that the attribute is attached to is copied. If not specified, the default associativity behavior is used.
Returns

None


IMcadComponent::ClearOverrideProperties Method
Summary

Clears all override properties of this component if any exists.

Visual Basic
Sub ClearOverrideProperties()
Returns

None


IMcadComponent::ColorOverride Method
Summary

Sets the color override for all the component's views.

Visual Basic
Sub ColorOverride(bColor As VARIANT_BOOL, bContoursColorOnly As VARIANT_BOOL, trueColor As [in,defaultvalue(NULL)] IAcadAcCmColor)
Parameters
Parameters | Description
bColor | Boolean; input-only. Specifies whether the color is set, TRUE, or not, FALSE.
bContoursColorOnly | Boolean; input-only. Specifies whether this method only sets the color for contours, TRUE, or not, FALSE.
trueColor | AcadAcCmColor object, default value =NULL; input-only; optional. Points to the color to set to. By default, it is NULL which results in the color value to be unchanged.
Returns

None

Remarks

Since color overrides applies only when predefined reference is FALSE, this method will fail if the predefined reference has already been set.


IMcadComponent::ContainingComponent Method
Summary

Returns the lowest level component that this object is inserted into.

Visual Basic
Sub ContainingComponent(Component As [out, retval] IMcadComponent*)


IMcadComponent::CopyDefinition Method
Summary

Creates a copy of the definition for the specified folder or component view as in AMSCOPYDEF.

Visual Basic
Sub CopyDefinition(newDefName As String)
Parameters
Parameters | Description
newDefName | String; input-only. Specifies the unique name for the copied component definition.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Links
Example


IMcadComponent::GetAttributes Method
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = FALSE; input-only; optional. Specifies whether the exact match is used.
Returns

McadAttributes collection


IMcadComponent::GetComponentInDefinition Method
Summary

Gets the component equivalent to this component in the scope of the component's owning component definition.

Visual Basic
Sub GetComponentInDefinition(Component As [out, retval] IMcadComponent*)


IMcadComponent::PredefinedReferenceOverride Method
Summary

Sets the predefined reference override for all the component's views.

Visual Basic
Sub PredefinedReferenceOverride(bPredefinedRef As VARIANT_BOOL)
Parameters
Parameters | Description
bPredefinedRef | Boolean; input-only. Specifies whether to set predefined reference override property, TRUE, or not, FALSE. Visibility of everything except contours is turned off. Contour lines are changed to the configured linetype and color of the phantom line layer (AM_11 by default).
Returns

None


IMcadComponent::RemoveAttribute Method
Summary

Removes the specified attribute from this component.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the attribute to be removed.
Returns

None


IMcadComponent::ReplaceDefinition Method
Summary

Replaces a specified component with a new definition as in AMSREPLACEDEF.

Visual Basic
Sub ReplaceDefinition(newDef As IMcadComponentDefinition)
Parameters
Parameters | Description
newDef | McadComponentDefinition object; input-only. Specifies the new definition that already exists to perform the replacement.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Links
Example


IMcadComponent::SortChildren Method
Summary

Sorts the children of this component.

Visual Basic
Sub SortChildren()
Returns

None


IMcadComponent::VisibilityOverride Method
Summary

Sets the visibility override for all the component's views.

Visual Basic
Sub VisibilityOverride(bContoursOnly As VARIANT_BOOL, bHiddenLines As VARIANT_BOOL, bCenterLines As VARIANT_BOOL)
Parameters
Parameters | Description
bContoursOnly | Boolean; input-only. Specifies whether to isolates the contour (continuous) lines in a folder or view, TRUE, or not, FALSE. It can be used in conjunction with Centerline visibility and Color, but is not available in conjunction with Hidden Line visibility. If predefined override is set, then bContoursOnly and bHiddenLines will be ignored.
bHiddenLines | Boolean; input-only. Specifies whether to turns off visibility of hidden lines in a folder or view, TRUE, or not, FALSE. This option is not applicable when the Contours Only visibility is set.
bCenterLines | Boolean; input-only. Specifies whether to turn on the centerline visibility, TRUE, or not, FALSE.
Returns

None


IMcadComponentDefinition Interface
Summary

References the definition of an assembly component.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComponentDefinition
Visual Basic
Public Interface IMcadComponentDefinition
Inherits IMcadObject
Remarks

From this definition, an instance of it can be created in an assembly. A component instance is represented by an McadComponent object. This component is visible as a node in the assembly browser.

In order to have a representation of this visible in model space, one of its associated component view definitions must be instanced. This instantiation is a component view.

A component view instance is represented by an McadComponentView object.

Links
IMcadComponentDefinition Members, AcadmAuto Library


IMcadComponentDefinition Members
Summary

The following tables list the members exposed by IMcadComponentDefinition.

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
AddComponent | Adds an instance of the specified component definition to this component definition.
CopyDefinition | Creates a copy of the component definition.
Delete | Deletes the object being referenced.
Externalize | Externalizes the component definition to the specified file name.
GetAttributes | Gets the attributes attached to the object being referenced.
GetInstances | Get all instances of this definition in a given scope.
GetNextComponentViewDefinitionName | Gets the name of the next unique component view definition based on the specified name.
HasComponentViewDefinition | Checks whether a component view definition with the specified name exists in a component definition, TRUE, or not, FALSE.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
Localize2DS | Localizes the component definition into the document.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.
RemoveComponent | Removes the specified component instance from the subassembly component definition.
SortChildren | Sorts the children in this component definition.
Update | Causes an update or a regeneration of any pending changes on the object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the component instances inserted into a subassembly component definition.
ComponentViewDefinitions | Gets the collection of component view definitions contained in this component definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
ExternalPath | Specifies the file name including path for the drawing used by an external component definition.
is2D | Gets whether this component definition is in 2D structure.
is2DAssembly | Gets whether this component definition is associated with 2D assembly.
IsExternal | Gets whether the component definition is to an externally referenced drawing.
isFeature | Gets whether this component definition is associated with a feature.
IsLeafNode | Gets whether the component definition is a leaf node component definition.
IsRoot | Gets whether the component definition is the root component definition.
isShaft | This is isShaft, a member of class IMcadComponentDefinition.
isStandardPart | This is isStandardPart, a member of class IMcadComponentDefinition.
Name | Gets and sets the name of the component definition.
PhantomState | Gets the phantom state of this component definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadComponentDefinition::Children Property
Summary

Gets the component instances inserted into a subassembly component definition.

Visual Basic
Property Children() As IMcadComponents**


IMcadComponentDefinition::ComponentViewDefinitions Property
Summary

Gets the collection of component view definitions contained in this component definition.

Visual Basic
Property ComponentViewDefinitions() As IMcadComponentViewDefinitions**
Remarks

This property is a McadComponentViewDefinitions collection.


IMcadComponentDefinition::ExternalPath Property
Summary

Specifies the file name including path for the drawing used by an external component definition.

Visual Basic
Property ExternalPath() As BSTR*
Remarks

This property is a String.


IMcadComponentDefinition::is2D Property
Summary

Gets whether this component definition is in 2D structure.

Visual Basic
Property is2D() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponentDefinition::is2DAssembly Property
Summary

Gets whether this component definition is associated with 2D assembly.

Visual Basic
Property is2DAssembly() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponentDefinition::IsExternal Property
Summary

Gets whether the component definition is to an externally referenced drawing.

Visual Basic
Property IsExternal() As VARIANT_BOOL*


IMcadComponentDefinition::isFeature Property
Summary

Gets whether this component definition is associated with a feature.

Visual Basic
Property isFeature() As VARIANT_BOOL*


IMcadComponentDefinition::IsLeafNode Property
Summary

Gets whether the component definition is a leaf node component definition.

Visual Basic
Property IsLeafNode() As VARIANT_BOOL*


IMcadComponentDefinition::IsRoot Property
Summary

Gets whether the component definition is the root component definition.

Visual Basic
Property IsRoot() As VARIANT_BOOL*


IMcadComponentDefinition::isShaft Property
Summary

This is isShaft, a member of class IMcadComponentDefinition.

Visual Basic
Property isShaft() As VARIANT_BOOL*


IMcadComponentDefinition::isStandardPart Property
Summary

This is isStandardPart, a member of class IMcadComponentDefinition.

Visual Basic
Property isStandardPart() As VARIANT_BOOL*


IMcadComponentDefinition::Name Property
Summary

Gets and sets the name of the component definition.

Visual Basic
Property Name() As String
Remarks

This property is a String.


IMcadComponentDefinition::PhantomState Property
Summary

Gets the phantom state of this component definition.

Visual Basic
Property PhantomState() As McadPhantomState
Remarks

This property is a McadPhantomState enumeration.


IMcadComponentDefinition::AddAttribute Method
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the component definition.
Associativity | McadAttributeAssociativity enumeration, default value = 0; input-only; optional. Specifies the behavior of the attribute when the object that the attribute is attached to is copied. If not specified, the default associativity behavior is used.
Returns

None


IMcadComponentDefinition::AddComponent Method
Summary

Adds an instance of the specified component definition to this component definition.

Visual Basic
Sub AddComponent(Definition As IMcadComponentDefinition, Position As IGeMatrix, Component As [out, retval] IMcadComponent*)
Parameters
Parameters | Description
Definition | McadComponentDefinition Object; input-only. Specifies the definition to add an instance of.
Position | GeMatrix object; input-only. Input required but not applicable to this product.
Returns

McadComponent object


IMcadComponentDefinition::CopyDefinition Method
Summary

Creates a copy of the component definition.

Visual Basic
Sub CopyDefinition(Name As [in, optional] VARIANT, Definition As [out, retval] IMcadComponentDefinition*)


IMcadComponentDefinition::Externalize Method
Summary

Externalizes the component definition to the specified file name.

Visual Basic
Sub Externalize(FileName As String)


IMcadComponentDefinition::GetAttributes Method
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = False; input-only; optional. Specifies whether the exact match is used.
Returns

McadAttributes collection


IMcadComponentDefinition::GetInstances Method
Summary

Get all instances of this definition in a given scope.

Visual Basic
Sub GetInstances(ComponentDefinition As [in, optional] VARIANT, Instances As [out, retval] IMcadComponents*)


IMcadComponentDefinition::GetNextComponentViewDefinitionName Method
Summary

Gets the name of the next unique component view definition based on the specified name.

Visual Basic
Sub GetNextComponentViewDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the base name to get the next component view definition name. If the value is NULL, one of the unused component view names specified in the user options is used as the base name.
Returns

String


IMcadComponentDefinition::HasComponentViewDefinition Method
Summary

Checks whether a component view definition with the specified name exists in a component definition, TRUE, or not, FALSE.

Visual Basic
Sub HasComponentViewDefinition(pName As String, ByRef pCompViewDef As IMcadComponentViewDefinition*, pHasViewDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the the component view definition to perform the check.
pCompViewDef | McadComponentViewDefinition object; output-only. Returns the component view definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean


IMcadComponentDefinition::Localize2DS Method
Summary

Localizes the component definition into the document.

Visual Basic
Sub Localize2DS(LocalizeAll As VARIANT_BOOL)
Parameters
Parameters | Description
LocalizeAll | Boolean; input-only. Specifies whether all children are localized, TRUE, or only this component definition is localized, FALSE.
Returns

None


IMcadComponentDefinition::RemoveAttribute Method
Summary

Removes the specified attribute from the object being referenced.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the attribute to remove from the object.
Returns

None


IMcadComponentDefinition::RemoveComponent Method
Summary

Removes the specified component instance from the subassembly component definition.

Visual Basic
Sub RemoveComponent(Component As IMcadComponent)
Parameters
Parameters | Description
Component | McadComponent object; input-only
Returns

None


IMcadComponentDefinition::SortChildren Method
Summary

Sorts the children in this component definition.

Visual Basic
Sub SortChildren()
Returns

None


IMcadComponentDefinition::Update Method
Summary

Causes an update or a regeneration of any pending changes on the object.

Visual Basic
Sub Update(Force As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
Force | Boolean, default value = FALSE; input-only; optional. Specifies whether the object is forced to update regardless of whether there are any pending changes.
Returns

None


IMcadComponentDefinitions Interface
Summary

A collection of McadcomponentDefinition objects.

Class Hierarchy

Declaration syntax

IMcadComponentDefinitions
Visual Basic
Public Interface IMcadComponentDefinitions
Inherits IDispatch
Links
IMcadComponentDefinitions Members, AcadmAuto Library


IMcadComponentDefinitions Members
Summary

The following tables list the members exposed by IMcadComponentDefinitions.

Methods
Name | Description
Add | Appends a new component definition to the collection.
Item | Gets the component definition at the specified index from the collection.
Remove | Removes the specified component definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component definitions in the collection.


IMcadComponentDefinitions::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadComponentDefinitions::Count Property
Summary

Gets the total number of component definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadComponentDefinitions::Add Method
Summary

Appends a new component definition to the collection.

Visual Basic
Sub Add(Definition As IMcadComponentDefinition)
Parameters
Parameters | Description
Definition | McadComponentDefinition object; input-only. Specifies the new component definitions to add to the collection.
Returns

None


IMcadComponentDefinitions::Item Method
Summary

Gets the component definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component definition to return.
Returns

McadComponentDefinition object


IMcadComponentDefinitions::Remove Method
Summary

Removes the specified component definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component definition to remove.
Returns

None


IMcadComponents Interface
Summary

A collection of McadComponent objects.

Class Hierarchy

Declaration syntax

IMcadComponents
Visual Basic
Public Interface IMcadComponents
Inherits IDispatch
Links
IMcadComponents Members, AcadmAuto Library


IMcadComponents Members
Summary

The following tables list the members exposed by IMcadComponents.

Methods
Name | Description
Add | Appends a new component to the collection.
Item | Gets the component at the specified index from the collection.
Remove | Removes the specified component from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of components in the collection.


IMcadComponents::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadComponents::Count Property
Summary

Gets the total number of components in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadComponents::Add Method
Summary

Appends a new component to the collection.

Visual Basic
Sub Add(Component As IMcadComponent)
Parameters
Parameters | Description
Component | McadComponent object; input-only. Specifies the new components to add to the collection.
Returns

None


IMcadComponents::Item Method
Summary

Gets the component at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComponent*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component to return.
Returns

McadComponent object


IMcadComponents::Remove Method
Summary

Removes the specified component from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component to remove.
Returns

None


IMcadComponentView Interface
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView
Visual Basic
Public Interface IMcadComponentView
Inherits IMcadFolder2
Links
IMcadComponentView Members, AcadmAuto Library


IMcadComponentView Members
Summary

The following tables list the members exposed by IMcadComponentView.

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsGhostView | Specifies whether a component view is a ghost component view, TRUE, or not, FALSE.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
Component | Gets the component of the component view.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
isFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadComponentView::Component Property
Summary

Gets the component of the component view.

Visual Basic
Property Component() As IMcadComponent**
Remarks

This property is a McadComponent object.


IMcadComponentView::isFeature Property
Summary

Gets whether the component view is the view of a feature, TRUE, or not, FALSE.

Visual Basic
Property isFeature() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponentView::IsGhostView Method
Summary

Specifies whether a component view is a ghost component view, TRUE, or not, FALSE.

Visual Basic
Sub IsGhostView(bTreatFeatAsNonGhost As [in, defaultvalue(TRUE)] VARIANT_BOOL, pIsGhost As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
bTreatFeatAsNonGhost | Boolean, default value = TRUE; input-only; optional. Specifies whether a feature view should be treated as a non-ghost view.
Returns

Boolean

Remarks

When one or more component views are restructured, remained component views are held temporarily on a ghost until they are too restructured.


IMcadComponentViewDefinition Interface
Summary

References the definition of a component view.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadComponentViewDefinition
Visual Basic
Public Interface IMcadComponentViewDefinition
Inherits IMcadFolderDefinition
Remarks

Each component view definition has an associated component definition. The component view definition defines a particular view of a component definition. From this component view definition, an instance of it can be created in an assembly. The definition itself is not visible in the model; only instances of it are visible.

It is important to note that a component view definition can exist without any component view instances referencing it in the assembly. The relationship between McadComponentViewDefinition and McadComponentView objects is similar to that of the AutoCAD Block and BlockRef objects.

Links
IMcadComponentViewDefinition Members, AcadmAuto Library


IMcadComponentViewDefinition Members
Summary

The following tables list the members exposed by IMcadComponentViewDefinition.

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Adds a component view to a specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified component view from this component view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
Owner | Gets the owner of this component definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadComponentViewDefinition::IsFeature Property
Summary

Gets whether the component view is the view of a feature, TRUE, or not, FALSE.

Visual Basic
Property IsFeature() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadComponentViewDefinition::Owner Property
Summary

Gets the owner of this component definition.

Visual Basic
Property Owner() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.


IMcadComponentViewDefinition::AddComponentView Method
Summary

Adds a component view to a specified component view definition.

Visual Basic
Sub AddComponentView(pDefToInst As IMcadComponentViewDefinition, pCompInst As IMcadComponent, pMat As IGeMatrix, pVal As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition to add the component view to.
pCompInst | McadComponent object; input-only. Specifies the new component view to add.
pMat | GeMatrix object; input-only. Specifies the position for the new component view.
Returns

McadComponentView object

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcadComponentViewDefinition::RemoveComponentView Method
Summary

Removes the specified component view from this component view definition.

Visual Basic
Sub RemoveComponentView(pCompView As IMcadComponentView)
Parameters
Parameters | Description
pCompView | McadComponentView object; input-only. Specifies the component view to remove from this definition.
Returns

None


IMcadComponentViewDefinitions Interface
Summary

A collection of McadComponentViewDefinition objects.

Class Hierarchy

Declaration syntax

IMcadComponentViewDefinitions
Visual Basic
Public Interface IMcadComponentViewDefinitions
Inherits IDispatch
Links
IMcadComponentViewDefinitions Members, AcadmAuto Library


IMcadComponentViewDefinitions Members
Summary

The following tables list the members exposed by IMcadComponentViewDefinitions.

Methods
Name | Description
Add | Appends a new component view definition to the collection.
Item | Gets the component view definition at the specified index from the collection.
Remove | Removes the specified component view definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component view definitions in the collection.


IMcadComponentViewDefinitions::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadComponentViewDefinitions::Count Property
Summary

Gets the total number of component view definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadComponentViewDefinitions::Add Method
Summary

Appends a new component view definition to the collection.

Visual Basic
Sub Add(Definition As IMcadComponentViewDefinition)
Parameters
Parameters | Description
Definition | McadComponentViewDefinition object; input-only. Specifies the new component view definitions to add to the collection.
Returns

None


IMcadComponentViewDefinitions::Item Method
Summary

Gets the component view definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadComponentViewDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view definition to return.
Returns

McadComponentViewDefinition object


IMcadComponentViewDefinitions::Remove Method
Summary

Removes the specified component view definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view definition to remove.
Returns

None


IMcadComponentViewDescriptor Interface
Summary

Encapsulates the description of a 2D component view.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor
Visual Basic
Public Interface IMcadComponentViewDescriptor
Inherits IMcadFolderDescriptor
Links
IMcadComponentViewDescriptor Members, AcadmAuto Library


IMcadComponentViewDescriptor Members
Summary

The following tables list the members exposed by IMcadComponentViewDescriptor.

Methods
Name | Description
CreateComponentView | Creates a new component view from this descriptor.
CreateFolder | Creates a new folder from the folder descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets and sets the component for the component view descriptor.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
FullViewName | Gets the full component name for this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.


IMcadComponentViewDescriptor::Component Property
Summary

Gets and sets the component for the component view descriptor.

Visual Basic
Property Component() As VARIANT
Remarks

This property is a Variant ( McadComponent object).


IMcadComponentViewDescriptor::FullViewName Property
Summary

Gets the full component name for this descriptor.

Visual Basic
Property FullViewName() As BSTR*
Remarks

This property is a String.


IMcadComponentViewDescriptor::CreateComponentView Method
Summary

Creates a new component view from this descriptor.

Visual Basic
Sub CreateComponentView()
Returns

None


IMcadComponentViews Interface
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

IMcadComponentViews
Visual Basic
Public Interface IMcadComponentViews
Inherits IDispatch
Links
IMcadComponentViews Members, AcadmAuto Library


IMcadComponentViews Members
Summary

The following tables list the members exposed by IMcadComponentViews.

Methods
Name | Description
Add | Appends a new component view to the collection.
Item | Gets the component view at the specified index from the collection.
Remove | Removes the specified component view from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component views in the collection.


IMcadComponentViews::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadComponentViews::Count Property
Summary

Gets the total number of component views in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadComponentViews::Add Method
Summary

Appends a new component view to the collection.

Visual Basic
Sub Add(Component As IMcadComponentView)
Parameters
Parameters | Description
Component | McadComponentView object; input-only. Specifies the new components to add to the collection.
Returns

None


IMcadComponentViews::Item Method
Summary

Gets the component view at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view to return.
Returns

McadComponentView object


IMcadComponentViews::Remove Method
Summary

Removes the specified component view from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view to remove.
Returns

None


IMcadCurve Interface
Summary

A generic curve entity.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc
            IMcadAugmentedLine
            IMcadEllipse
            IMcadLine
            IMcadPolyline
            IMcadSpline
Visual Basic
Public Interface IMcadCurve
Inherits IMcadGeometry
Links
AcadmAuto Library


IMcadDescriptor Interface
Summary

A generic descriptor object that contains the overall description of an object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
Visual Basic
Public Interface IMcadDescriptor
Inherits IDispatch
Remarks

A descriptor is used as a convenience to handle a variable, and potentially large and interdependent set of specific properties and information that make up the description of an object. A descriptor can be obtained from an object to query information, or used in the creation of new objects conforming to the description.

Links
IMcadDescriptor Members, AcadmAuto Library


IMcadDescriptor Members
Summary

The following tables list the members exposed by IMcadDescriptor.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.


IMcadDescriptor::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks
  • This property is a cadmApplication object.
  • AcadmApplication object is an instance of the AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadDescriptor::Document Property
Summary

Gets the document containing this object.

Visual Basic
Property Document() As IMcadDocument**


IMcadDocuments Interface
Summary

The collection of McadDocument objects present in the application.

Class Hierarchy

Declaration syntax

IMcadDocuments
Visual Basic
Public Interface IMcadDocuments
Inherits IDispatch
Links
IMcadDocuments Members, AcadmAuto Library


IMcadDocuments Members
Summary

The following tables list the members exposed by IMcadDocuments.

Methods
Name | Description
Item | Gets the document at the specified index from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of documents in the collection.


IMcadDocuments::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadDocuments::Count Property
Summary

Gets the total number of documents in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadDocuments::Item Method
Summary

Gets the document at the specified index from the collection.

Visual Basic
Sub Item(Index As VARIANT, Document As [out, retval] IMcadDocument*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the document to return.
Returns

McadDocument object


IMcadDocumentVersion Interface
Summary

Version of AutoCAD Mechanical that saved the file.

Class Hierarchy

Declaration syntax

IMcadDocumentVersion
Visual Basic
Public Interface IMcadDocumentVersion
Inherits IUnknown
Links
IMcadDocumentVersion Members, AcadmAuto Library


IMcadDocumentVersion Members
Summary

The following tables list the members exposed by IMcadDocumentVersion.

Methods
Name | Description
GetVersionNumber | Version of AutoCAD Mechanical that saved the file.


IMcadDocumentVersion::GetVersionNumber Method
Summary

Version of AutoCAD Mechanical that saved the file.

Visual Basic
Sub GetVersionNumber(ByRef Major As long, ByRef Minor As long, ByRef Patch As long)
Parameters
Parameters | Description
Major | Long. Major revision number.
Minor | Long. Minor revision number.
Patch | Long. Patch number.


IMcadEllipse Interface
Summary

An ellipse or elliptical arc object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadEllipse
Visual Basic
Public Interface IMcadEllipse
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadFolder Interface
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
Visual Basic
Public Interface IMcadFolder
Inherits IMcadObject
Links
IMcadFolder Members, AcadmAuto Library


IMcadFolder Members
Summary

The following tables list the members exposed by IMcadFolder.

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadFolder::BasePoint Property
Summary

This is BasePoint, a member of class IMcadFolder.

Visual Basic
Property BasePoint() As IGePoint*


IMcadFolder::Children Property
Summary

Gets the occurrence of the children views of the folder.

Visual Basic
Property Children() As IMcadFolders**
Remarks

This property is a McadFolders collection.


IMcadFolder::ContextDefinition Property
Summary

Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.

Visual Basic
Property ContextDefinition() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.


IMcadFolder::Definition Property
Summary

Gets the definition of the folder.

Visual Basic
Property Definition() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.


IMcadFolder::Entities Property
Summary

Gets the entities of the folder in model space.

Visual Basic
Property Entities() As VARIANT*
Remarks

This property is a Variant (array of Longs).


IMcadFolder::Entities32 Property
Summary

Gets the entities of the folder in model space.

Visual Basic
Property Entities32() As VARIANT*
Remarks

This property is a Variant (array of Longs).


IMcadFolder::ExtentsMaximum Property
Summary

Gets the upper right point of the extents for the folder or component view

Visual Basic
Property ExtentsMaximum() As IGePoint**


IMcadFolder::ExtentsMinimum Property
Summary

Gets the lower left point of the extents for the folder or component view.

Visual Basic
Property ExtentsMinimum() As IGePoint**


IMcadFolder::GeomPathName Property
Summary

Gets the occurrence path of the folder.

Visual Basic
Property GeomPathName() As BSTR*
Remarks

This property is a String.


IMcadFolder::HasExternalDef Property
Summary

Checks whether this folder has an external folder definition, TRUE, or not, FALSE.

Visual Basic
Property HasExternalDef() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolder::HasOverrideProperties Property
Summary

Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.

Visual Basic
Property HasOverrideProperties() As VARIANT_BOOL *
Remarks

This property is a Boolean.


IMcadFolder::IsInstance Property
Summary

Checks whether it is the path to the folder instance, TRUE, or not, FALSE.

Visual Basic
Property IsInstance() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolder::IsLeaf Property
Summary

Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.

Visual Basic
Property IsLeaf() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolder::IsLocked Property
Summary

Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.

Visual Basic
Property IsLocked() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolder::Owner Property
Summary

Gets the definition of the owner for the folder.

Visual Basic
Property Owner() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.


IMcadFolder::Position Property
Summary

Gets or sets the position of the folder or component view in model space.

Visual Basic
Property Position() As IGeMatrix*


IMcadFolder::ViewName Property
Summary

Gets the name of the folder.

Visual Basic
Property ViewName() As String
Remarks
  • This property is a String.
  • Setting the folder name has not been implemented.


IMcadFolder::ViewScale Property
Summary

Sets the view scale of the view.

Visual Basic
Property ViewScale() As double
Remarks

This property is a Double.

Example

Refer to SDK Samples: RestructureView.dvb

Links
Example


IMcadFolder::Visible Property
Summary

Gets or sets the visibility of the folder.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFolder::AddEntities Method
Summary

Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.

Visual Basic
Sub AddEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the object IDs of the entities to add.
Returns

None

Remarks

The added entities can be removed using the RemoveEntities method.


IMcadFolder::ClearLeaf Method
Summary

Modifies this path from Leaf path to Instance path.

Visual Basic
Sub ClearLeaf()
Returns

None


IMcadFolder::ClearOverrideProperties Method
Summary

Clears all property overrides for the folder or component view if any exists.

Visual Basic
Sub ClearOverrideProperties()
Returns

None


IMcadFolder::ColorOverride Method
Summary

Sets the color override for the folder or component view.

Visual Basic
Sub ColorOverride(bColor As VARIANT_BOOL, bContoursColorOnly As VARIANT_BOOL, trueColor As [in,defaultvalue(NULL)] IAcadAcCmColor)
Parameters
Parameters | Description
bColor | Boolean; input-only. Specifies whether the color is set, TRUE, or not, FALSE.
bContoursColorOnly | Boolean; input-only. Specifies whether this method only sets the color for contours, TRUE, or not, FALSE.
trueColor | AcadAcCmColor object, default value =NULL; input-only; optional. Points to the color to set to. By default, it is NULL which results in the color value to be unchanged.
Returns

None

Remarks

Since color overrides applies only when predefined reference is FALSE, this method will fail if the predefined reference has already been set.


IMcadFolder::CopyEntities Method
Summary

Copies the entities to this folder or component view as in Content - Copy.

Visual Basic
Sub CopyEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (Array of Longs); input-only. Specifies the array of AcDbObjectIds of entities to copy.
Returns

None

Example

Refer to SDK Samples: RestructureView.dvb

Links
Example


IMcadFolder::CopyView Method
Summary

Copies the specified view to this view as in Content - Copy

Visual Basic
Sub CopyView(pFolderToCopy As IMcadFolder)
Parameters
Parameters | Description
pFolderToCopy | McadFolder object; input-only. Specifies the folder to copy.
Returns

None

Example

Refer to SDK Samples: RestructureView.dvb

Links
Example


IMcadFolder::CopyViewDefinition Method
Summary

Creates a copy of the definition for the specified folder or component view as in Break Link.

Visual Basic
Sub CopyViewDefinition(newDefName As String)
Parameters
Parameters | Description
newDefName | String; input-only. Specifies the new unique definition name.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Links
Example


IMcadFolder::Explode Method
Summary

Explode the specified folder or component view to the model space.

Visual Basic
Sub Explode()
Returns

None


IMcadFolder::IsSubentityOf Method
Summary

Checks whether this is subentity of the specified pOther view.

Visual Basic
Sub IsSubentityOf(pOther As IMcadFolder, IsEqual As [in, defaultvalue(FALSE)] VARIANT_BOOL, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pOther | McadFolder object; input-only. Specifies the view to check the subentity relationship.
IsEqual | Boolean, default value = False; input-only; optional. Specifies if this and pOther paths are equal. If TRUE, this method returns True.
Returns

Boolean


IMcadFolder::PredefinedReferenceOverride Method
Summary

Sets the predefined reference override for the folder or component view.

Visual Basic
Sub PredefinedReferenceOverride(bPredefinedRef As VARIANT_BOOL)
Parameters
Parameters | Description
bPredefinedRef | Boolean; input-only. Specifies whether to set predefined reference override property, TRUE, or not, FALSE. Visibility of everything except contours is turned off. Contour lines are changed to the configured linetype and color of the phantom line layer (AM_11 by default).
Returns

None


IMcadFolder::RemoveEntities Method
Summary

Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.

Visual Basic
Sub RemoveEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the object IDs of the entities to be removed.
Returns

None


IMcadFolder::ReplaceDefinition Method
Summary

Replace the definitions of a folder with another definition as in AMSREPLACEDEF.

Visual Basic
Sub ReplaceDefinition(newDef As IMcadFolderDefinition)
Parameters
Parameters | Description
newDef | McadFolderDefinition object; input only. Specifies the new definition to perform the replacement.
Returns

None


IMcadFolder::VisibilityOverride Method
Summary

Sets the visibility override for the folder or component view.

Visual Basic
Sub VisibilityOverride(bContoursOnly As VARIANT_BOOL, bHiddenLines As VARIANT_BOOL, bCenterLines As VARIANT_BOOL)
Parameters
Parameters | Description
bContoursOnly | Boolean; input-only. Specifies whether to isolates the contour (continuous) lines in a folder or view, TRUE, or not, FALSE. It can be used in conjunction with Centerline visibility and Color, but is not available in conjunction with Hidden Line visibility. If predefined override is set, then bContoursOnly and bHiddenLines will be ignored.
bHiddenLines | Boolean; input-only. Specifies whether to turns off visibility of hidden lines in a folder or view, TRUE, or not, FALSE. This option is not applicable when the Contours Only visibility is set.
bCenterLines | Boolean; input-only. Specifies whether to turn on the centerline visibility, TRUE, or not, FALSE.
Returns

None


IMcadFolder2 Interface
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView
Visual Basic
Public Interface IMcadFolder2
Inherits IMcadFolder
Links
IMcadFolder2 Members, AcadmAuto Library


IMcadFolder2 Members
Summary

The following tables list the members exposed by IMcadFolder2.

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadFolder2::OwningSpace Property
Summary

Returns owning space of view, model space or layout block table record

Visual Basic
Property OwningSpace() As IAcadBlock**


IMcadFolderDefinition Interface
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
        IMcadComponentViewDefinition
Visual Basic
Public Interface IMcadFolderDefinition
Inherits IMcadObject
Links
IMcadFolderDefinition Members, AcadmAuto Library


IMcadFolderDefinition Members
Summary

The following tables list the members exposed by IMcadFolderDefinition.

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadFolderDefinition::ChildrenCount Property
Summary

Gets the total number of the children for the folder.

Visual Basic
Property ChildrenCount() As int *
Remarks

This property is a Integer.


IMcadFolderDefinition::ComplexHideSituations Property
Summary

Returns all complex hide situations from this folder definition.

Visual Basic
Property ComplexHideSituations() As IMcadComplexHideSituations* *
Remarks

This property is a McadComplexHideSituations collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::FullName Property
Summary

Gets the full name of this folder definition.

Visual Basic
Property FullName() As BSTR*
Remarks

  • This property is a String.
  • This method returns the same string as Name method in case of folder definition.


IMcadFolderDefinition::HideSituations Property
Summary

Returns all hide situations from this folder definition.

Visual Basic
Property HideSituations() As IMcadHideSituations* *
Remarks

This property is a McadHideSituations collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::InstanceCount Property
Summary

Gets the total number of the folder instances.

Visual Basic
Property InstanceCount() As int *
Remarks

This property is a Integer.


IMcadFolderDefinition::IsAnnotation Property
Summary

Gets whether this is an annotation view definition, TRUE, or not, FALSE.

Visual Basic
Property IsAnnotation() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolderDefinition::IsDetail Property
Summary

Gets whether this is a detail view definition, TRUE, or not, FALSE.

Visual Basic
Property IsDetail() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolderDefinition::IsLocked Property
Summary

Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.

Visual Basic
Property IsLocked() As VARIANT_BOOL
Remarks

No modifications to the folder definition are allowed when it is in the locked state.


IMcadFolderDefinition::IsRoot Property
Summary

Checks whether this folder definition is root view definition, TRUE, or not, FALSE.

Visual Basic
Property IsRoot() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadFolderDefinition::LockType Property
Summary

Gets the lock type of this folder definition.

Visual Basic
Property LockType() As long*
Remarks

This method returns the bits combination of values from the McadViewDefLockName enumeration.


IMcadFolderDefinition::Name Property
Summary

Gets or sets the name of this folder definition.

Visual Basic
Property Name() As String
Remarks
  • This property is a String.
  • This property returns the same string as FullName method in case of the folder definition.


IMcadFolderDefinition::ViewType Property
Summary

Gets or sets the view type of this folder definition.

Visual Basic
Property ViewType() As Mcad2DSViewType
Remarks

This property is a Mcad2DSViewType enumeration.


IMcadFolderDefinition::AddComplexHideSituation Method
Summary

Creates a new complex hide situation with the specified name in this folder definition.

Visual Basic
Sub AddComplexHideSituation(Name As String, pHides As IMcadHideSituations, ByRef HideSituation As IMcadComplexHideSituation*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the new complex hide situation.
pHides | McadHideSituations collection; input-only. Specifies the pointer to collection of Simple hide object keys in a size of 2.
HideSituation | McadComplexHideSituation object; output-only. Returns pointer to the new complex hide situation object.
Returns

None

Remarks

You must set the collection of simple hide object keys with a size of 2. The complex hide can be created only if it merges 3 and up simple hide situation. Otherwise complex hide will be erased.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::AddFolder Method
Summary

Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.

Visual Basic
Sub AddFolder(pDefToInst As IMcadFolderDefinition, pMat As IGeMatrix, pVal As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
pDefToInst | McadFolderDefinition object; input-only. Specifies the folder definition to add.
pMat | GeMatrix object; input-only. Specifies the position for the folder or folder.
Returns

McadFolder object


IMcadFolderDefinition::AddFromExistingEntities Method
Summary

Add entities in an existing database to this folder definition.

Visual Basic
Sub AddFromExistingEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the IDs of the entities to add to this folder definition.
Returns

None


IMcadFolderDefinition::AddHideSituation Method
Summary

Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.

Visual Basic
Sub AddHideSituation(Name As String, ByRef HideSituation As IMcadHideSituation*, foregroundEntityIds As VARIANT, backgroundEntityIds As VARIANT, pFgEnts As [in , defaultvalue(NULL)] IMcadFolders, pBgEnts As [in , defaultvalue(NULL)] IMcadFolders)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the new hide situation.
HideSituation | McadHideSituation object; output-only. Returns pointer to the new hide situation object.
foregroundEntityIds | VARIANT (array of 4 byte signed integers); input-only. Specifies the array of Object IDs for foreground free Model Space entities for hide situation. This parameter must be set. Otherwise hide will be erased.
backgroundEntityIds | VARIANT (array of 4 byte signed integers); input-only. Specifies the array of Object IDs for background free Model Space entities for hide situation.
pFgEnts | McadFolders collection, default value = NULL; input-only. Specifies the pointer to collection of foreground folder object keys.
pBgEnts | McadFolders collection, default value = NULL; input-only. Specifies the pointer to collection of background folder object keys.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::Children Method
Summary

Gets the children of the folder definition.

Visual Basic
Sub Children(ByRef ParentView As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
ParentView | Variant; input-only. To get views expressed in context of the master view definition, specify the instance of this folder definition in ParentView parameter.
Remarks

This property is a McadFolders collection. Returned views are expressed by default as local to this folder definition.


IMcadFolderDefinition::Extents Method
Summary

Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.

Visual Basic
Sub Extents(ByRef lowerLeft As IGePoint*, ByRef upperRight As IGePoint*)
Parameters
Parameters | Description
lowerLeft | GePoint object; output-only. Specifies the lower left point of the extents for the folder.
upperRight | GePoint object; output-only. Specifies the upper right point of the extents for the folder.
Remarks

GePoint object defines a three dimensional object in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.


IMcadFolderDefinition::Externalize Method
Summary

Externalizes the folder definition.

Visual Basic
Sub Externalize(FileName As String, ByRef TemplateName As VARIANT)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the name of the new file in which the folder definition is to be stored.
TemplateName | Variant; input-only; optional. Specifies the template used to create new file.
Returns

None


IMcadFolderDefinition::FindHideSituations Method
Summary

Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.

Visual Basic
Sub FindHideSituations(pSubent As IMcadFolder, ByRef referringHides As IMcadHideSituations*, ByRef referredToAs As VARIANT, refType As [in , defaultvalue(mc2DSAllRef)] McadHideSituationRefType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity/view which references the searched hide situations.
referringHides | McadHideSituations collection; output-only. Returns pointer to collection of hide objects found with given reference type.
referredToAs | Variant (array of 4 byte signed integers); output-only. Returns pointer to the array of reference type (flag) for each hide from previous hide collection. This flag indicates whether the HideSituation refers to entity/view as a background (BG), foreground (FG), BG exclude or FG exclude.
refType | McadHideSituationRefType enumeration, default=value = mc2DSAllRef; input-only; optional. Specifies the combination of reference types towards the given Entity/view.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::GetHidesSuppressState Method
Summary

Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.

Visual Basic
Sub GetHidesSuppressState(bSuppressed As VARIANT_BOOL, ByRef bState As VARIANT_BOOL, ByRef bHasHides As VARIANT_BOOL)
Parameters
Parameters
Description
bSuppressed
Boolean; input-only. Specifies whether to check either suppressed or unsuppressed hide situations.

  • TRUE: Checks the suppressed hide situations. The bState output parameter is TRUE if the view definition or its child views have at least one suppressed hide situation.
  • FALSE: Checks the unsuppressed hide situations. The bState output parameter is FALSE if the view definition or its child views have at least one unsuppressed hide situation.

bState
Boolean; output-only. Returns whether the view definition or its child views have at least one suppressed or unsuppressed hide situation.
bHasHides
Boolean; output-only. Returns whether if the view definition or its child views have hide situations, TRUE, or not, FALSE.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::Instances Method
Summary

Gets the instances of the folder definition.

Visual Basic
Sub Instances(ByRef database As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database in which to get the instances of the folder definition; if not specified, the host database of the document is used.
Remarks

This property is a McadFolders collection.


IMcadFolderDefinition::InstancesDefinition Method
Summary

Checks whether this folder or component view definition has an instance of the specified folder or component view definition.

Visual Basic
Sub InstancesDefinition(pFolderDef As IMcadFolderDefinition, bInstances As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pFolderDef | McadFolderDefinition object; input-only. Specifies the parent folder definition to check the descendent relationship.
Remarks

If this method returns TRUE, then this folder definition is a descendent of pFolderDef and cannot be instanced into pFolderDef.


IMcadFolderDefinition::IsExternal Method
Summary

Checks whether folder definition is external to the given database, TRUE, or not, FALSE.

Visual Basic
Sub IsExternal(ByRef relativeDatabase As VARIANT, External As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
relativeDatabase | AcadDatabase database; input-only; optional. Specifies the AcadDatabase to check. The host database is used by default.
Remarks

This property is a Boolean.


IMcadFolderDefinition::Localize Method
Summary

Localizes the specified folder definition or all children.

Visual Basic
Sub Localize(LocalizeAll As VARIANT_BOOL)
Parameters
Parameters | Description
LocalizeAll | Boolean; input-only. Specifies whether all children are localized, TRUE, or only this folder definition is localized, FALSE.
Returns

None

Remarks

This method is applicable only to McadFolderDefinition and not to McadComponentViewDefinition . It is necessary to localize the component definition and this operation will localize all its view definitions.


IMcadFolderDefinition::LookupViewName Method
Summary

Look up for the view with the specified name.

Visual Basic
Sub LookupViewName(viewName As String, ByRef pFound As VARIANT_BOOL, ByRef database As VARIANT)
Parameters
Parameters | Description
pFound | Boolean; output-only. Specifies whether the specified view is found, TRUE, or not, FALSE.
ViewName | String; input-only. Specifies the view name for the view to look up.
Database | Variant (AcadDatabase object); input-only; optional. Specify the database in which to look up for the view; if not specified, the host database of the document is used.
Returns

None


IMcadFolderDefinition::NextViewName Method
Summary

Gets the name of the next view instance for this folder definition.

Visual Basic
Sub NextViewName(ByRef database As VARIANT, pVal As [out, retval] BSTR)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the database in which to look up for duplicate view names; if not specified, the host database of the document is used.
Remarks
  • This property is a String.
  • For example, for the folder definition Folder1 with one instance Folder1:1, this property returns the name Folder1:2. It is the valid name for the next view instance of this definition.


IMcadFolderDefinition::Occurrences Method
Summary

Gets the occurrences of the folder definition from the specified database.

Visual Basic
Sub Occurrences(ByRef database As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database in which to get the occurrences; if not specified, occurrences from all databases are returned.
Remarks

This property is a McadFolders collection.


IMcadFolderDefinition::RemoveFolder Method
Summary

Removes a folder from a folder definition.

Visual Basic
Sub RemoveFolder(pFolder As IMcadFolder)
Parameters
Parameters | Description
pFolder | McadFolder object; input-only. Specifies the folder to remove from this definition.
Returns

None


IMcadFolderDefinition::SetHidesSuppressState Method
Summary

Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.

Visual Basic
Sub SetHidesSuppressState(bSuppressed As VARIANT_BOOL)
Parameters
Parameters | Description
bSuppressed | Boolean; input-only. Specifies whether to suppress all hide situations, TRUE, or unsuppress all hide situations, FALSE.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadFolderDefinition::SortChildren Method
Summary

Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.

Visual Basic
Sub SortChildren()
Returns

None


IMcadFolderDefinitions Interface
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

IMcadFolderDefinitions
Visual Basic
Public Interface IMcadFolderDefinitions
Inherits IDispatch
Links
IMcadFolderDefinitions Members, AcadmAuto Library


IMcadFolderDefinitions Members
Summary

The following tables list the members exposed by IMcadFolderDefinitions.

Methods
Name | Description
Add | Appends a new folder definition to the collection.
Item | Gets the folder definition at the specified index from the collection.
Remove | Removes the specified folder definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folder definition definitions in the collection.


IMcadFolderDefinitions::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadFolderDefinitions::Count Property
Summary

Gets the total number of folder definition definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadFolderDefinitions::Add Method
Summary

Appends a new folder definition to the collection.

Visual Basic
Sub Add(Definition As IMcadFolderDefinition)
Parameters
Parameters | Description
Definition | McadFolderDefinition object; input-only. Specifies the new folder definition definitions to add to the collection.
Returns

None


IMcadFolderDefinitions::Item Method
Summary

Gets the folder definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder definition to return.
Returns

McadFolderDefinition object


IMcadFolderDefinitions::Remove Method
Summary

Removes the specified folder definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder definition to remove.
Returns

None


IMcadFolderDescriptor Interface
Summary

Encapsulates the description of a folder.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
Visual Basic
Public Interface IMcadFolderDescriptor
Inherits IMcad2DStructureDescriptor
Links
IMcadFolderDescriptor Members, AcadmAuto Library


IMcadFolderDescriptor Members
Summary

The following tables list the members exposed by IMcadFolderDescriptor.

Methods
Name | Description
CreateFolder | Creates a new folder from the folder descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.


IMcadFolderDescriptor::Definition Property
Summary

Gets and sets folder definition using this descriptor.

Visual Basic
Property Definition() As VARIANT
Remarks

This property is a Variant ( McadFolderDefinition object).


IMcadFolderDescriptor::Entities Property
Summary

Gets and sets entities on this descriptor.

Visual Basic
Property Entities() As VARIANT
Remarks

This property is a Variant (array of object IDs (Long)).


IMcadFolderDescriptor::Entities32 Property
Summary

Gets and sets entities on this descriptor.

Visual Basic
Property Entities32() As VARIANT
Remarks

This property is a Variant (array of object IDs (Long)).


IMcadFolderDescriptor::Position Property
Summary

Gets or sets the position of the folder.

Visual Basic
Property Position() As IGeMatrix*


IMcadFolderDescriptor::PowerObjectType Property
Summary

Gets the power object type for this descriptor.

Visual Basic
Property PowerObjectType() As McadPowerObjectType*
Remarks

This property is a McadPowerObjectType object.


IMcadFolderDescriptor::TargetView Property
Summary

Gets and sets the target (parent) view for this descriptor.

Visual Basic
Property TargetView() As VARIANT
Remarks

This property is a Variant (McadObject object).


IMcadFolderDescriptor::ViewKey Property
Summary

Gets the view key for this descriptor.

Visual Basic
Property ViewKey() As VARIANT*
Remarks

This property is a Variant ( McadFolder object).


IMcadFolderDescriptor::ViewName Property
Summary

Gets and sets the view name for this descriptor.

Visual Basic
Property ViewName() As String
Remarks

This property is a String.


IMcadFolderDescriptor::Views Property
Summary

Gets and sets child views from this descriptor.

Visual Basic
Property Views() As VARIANT
Remarks

This property is a Variant (array of McadFolder objects).


IMcadFolderDescriptor::CreateFolder Method
Summary

Creates a new folder from the folder descriptor.

Visual Basic
Sub CreateFolder()
Returns

None


IMcadFolders Interface
Summary

A collection of McadFolder objects.

Class Hierarchy

Declaration syntax

IMcadFolders
Visual Basic
Public Interface IMcadFolders
Inherits IDispatch
Links
IMcadFolders Members, AcadmAuto Library


IMcadFolders Members
Summary

The following tables list the members exposed by IMcadFolders.

Methods
Name | Description
Add | Appends a new folder to the collection.
Item | Gets the folder at the specified index from the collection.
Remove | Removes the specified folder from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folders in the collection.


IMcadFolders::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadFolders::Count Property
Summary

Gets the total number of folders in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadFolders::Add Method
Summary

Appends a new folder to the collection.

Visual Basic
Sub Add(Component As IMcadFolder)
Parameters
Parameters | Description
Component | McadFolder object; input-only. Specifies the new folder to add to the collection.


IMcadFolders::Item Method
Summary

Gets the folder at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder to return.
Returns

McadFolder object


IMcadFolders::Remove Method
Summary

Removes the specified folder from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder to remove.
Returns

None


IMcadFormulaEvaluator Interface
Summary

This object provides general methods for Standard Data provider

Class Hierarchy

Declaration syntax

IMcadFormulaEvaluator
Visual Basic
Public Interface IMcadFormulaEvaluator
Inherits IDispatch
Links
IMcadFormulaEvaluator Members, AcadmAuto Library


IMcadFormulaEvaluator Members
Summary

The following tables list the members exposed by IMcadFormulaEvaluator.

Methods
Name | Description
Evaluate | Evaluates the expression using the all data providers, which were set in McadFormulaEvaluator. If the attribute in expression cannot by evaluated, the attribute name is returned.
Exist | Checks whether the data providers of formula evaluator have the specified attribute, TRUE, or not, FALSE.
GetAllAttribs | Gets all attributes in the given data providers.
GetAllAttribsData | Gets all information about the specified attribute from first data provider of formula evaluator and returns TRUE if this method can be implemented correctly.
GetAllAttribValues | Gets all values for the specified attribute from all providers that supply this attribute.
GetData | Gets the data for the specified attribute name from the first data provider of formula evaluator.
IsEditable | Checks whether the specified attribute data can be modified in the data provider, TRUE, or not, FALSE.
SetData | Sets a new value for the specified attribute in all data providers that contain this attribute.
SetDataProvider | Sets the additional data provider to Mcad Formula evaluator, TRUE, or not, FALSE.
Properties
Name | Description
Application | Gets the AcadmApplication object.


IMcadFormulaEvaluator::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadFormulaEvaluator::Evaluate Method
Summary

Evaluates the expression using the all data providers, which were set in McadFormulaEvaluator. If the attribute in expression cannot by evaluated, the attribute name is returned.

Visual Basic
Sub Evaluate(formula As String, value As [out, retval] BSTR)
Parameters
Parameters | Description
formula | String; input-only. Specifies the formula expression to perform the check. The expression must be start with "=". The attribute name must by between "<>". Example "=Type: "
Returns

String


IMcadFormulaEvaluator::Exist Method
Summary

Checks whether the data providers of formula evaluator have the specified attribute, TRUE, or not, FALSE.

Visual Basic
Sub Exist(attName As String, exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name to perform the check.
Returns

Boolean.


IMcadFormulaEvaluator::GetAllAttribs Method
Summary

Gets all attributes in the given data providers.

Visual Basic
Sub GetAllAttribs(attribs As [out, retval] VARIANT)
Returns

Variant


IMcadFormulaEvaluator::GetAllAttribsData Method
Summary

Gets all information about the specified attribute from first data provider of formula evaluator and returns TRUE if this method can be implemented correctly.

Visual Basic
Sub GetAllAttribsData(attrib As String, ByRef value As String, ByRef data As String, ByRef editFlag As VARIANT_BOOL, result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attrib | String; input-only. Specifies the attribute name.
data | String; output-only. Returns the raw attribute data in the formula that is not evaluated.
editFlag | Boolean; output-only. Returns whether the attribute is editable, TRUE, or not, FALSE.
Value | String; output-only. Returns the evaluated attribute data.
Returns

Boolean


IMcadFormulaEvaluator::GetAllAttribValues Method
Summary

Gets all values for the specified attribute from all providers that supply this attribute.

Visual Basic
Sub GetAllAttribValues(value As String, values As [out, retval] VARIANT)
Parameters
Parameters | Description
Value | String; input-only. Specifies the attribute value to perform the check.
Returns

Variant (array of Strings)


IMcadFormulaEvaluator::GetData Method
Summary

Gets the data for the specified attribute name from the first data provider of formula evaluator.

Visual Basic
Sub GetData(attName As String, value As [out, retval] BSTR)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name for which to get the evaluated data.
Returns

String


IMcadFormulaEvaluator::IsEditable Method
Summary

Checks whether the specified attribute data can be modified in the data provider, TRUE, or not, FALSE.

Visual Basic
Sub IsEditable(attName As String, isEditable As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name to perform the check.
Returns

Boolean

Remarks

Typically global attributes created by user are editable but standard part attributes are not editable.


IMcadFormulaEvaluator::SetData Method
Summary

Sets a new value for the specified attribute in all data providers that contain this attribute.

Visual Basic
Sub SetData(attName As String, data As String)
Parameters
Parameters | Description
attName | String; input-only. Specifies the name of the attribute for which to set a new value.
data | String; input-only. Specifies the new value to set for the specified attribute.
Returns

None

Remarks

You need to check whether this attribute is editable using the IsEditable method beforehand.


IMcadFormulaEvaluator::SetDataProvider Method
Summary

Sets the additional data provider to Mcad Formula evaluator, TRUE, or not, FALSE.

Visual Basic
Sub SetDataProvider(object As IAcadObject, result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | AcadObject object; input-only. Specifies the entity ID which determines the data provider.
Returns

Boolean


IMcadGeometry Interface
Summary

This is class IMcadGeometry.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
Visual Basic
Public Interface IMcadGeometry
Inherits IMcadObject
Links
IMcadGeometry Members, AcadmAuto Library


IMcadGeometry Members
Summary

The following tables list the members exposed by IMcadGeometry.

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ContainingComponent | Returns the lowest level component that this object is inserted into.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
HasChanged | Provides passive notification of whether the referenced geometry has changed since the geometry reference object was created or was last checked (and the state reset).
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Geometry | Specifies the geometric representation of the geometry being referenced.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadGeometry::Geometry Property
Summary

Specifies the geometric representation of the geometry being referenced.

Visual Basic
Property Geometry() As IGeEntity*


IMcadGeometry::AddAttribute Method
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Remarks

The optional associativity type specifies the behavior of the attribute when the object that the attribute is attached to is copied.


IMcadGeometry::ContainingComponent Method
Summary

Returns the lowest level component that this object is inserted into.

Visual Basic
Sub ContainingComponent(Component As [out, retval] IMcadComponent*)


IMcadGeometry::GetAttributes Method
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = False; input-only; optional. Specifies whether the exact match is used.
Attributes | _nt_


IMcadGeometry::HasChanged Method
Summary

Provides passive notification of whether the referenced geometry has changed since the geometry reference object was created or was last checked (and the state reset).

Visual Basic
Sub HasChanged(Reset As [in, defaultvalue(TRUE)] VARIANT_BOOL, Changed As [out, retval] VARIANT_BOOL)


IMcadGeometry::RemoveAttribute Method
Summary

Removes the specified attribute from the object being referenced.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)


IMcadHideSituation Interface
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadHideSituation
Visual Basic
Public Interface IMcadHideSituation
Inherits IMcadObject
Links
IMcadHideSituation Members, AcadmAuto Library


IMcadHideSituation Members
Summary

The following tables list the members exposed by IMcadHideSituation.

Methods
Name | Description
AddMSSubent | Adds the model space entity to this hide situation.
AddMSSubents | Adds model space entities to hide situation.
AddSubent | Adds the entity/view to this hide situation.
AddSubents | Adds the entities/views to this hide situation.
AutoSelectBackground | Automatically selects background objects and adds them to a new or existing level.
ClearSubents | Clears the hide situation sub-entities with the given sub-entity type.
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveSubent | Removes the entity/view from this hide situation with the given sub-entity type.
RemoveSubentByIdx | Removes the entity/view from this hide situation with the given sub-entity type and index number.
Subents | Gets the hide subentities of this hide situation.
SwapFgAndBg | Swaps foreground and background hide sub-entities.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BgSelectionName | Gets or sets the name for the background selection set.
Concealed | Gets or sets whether the hide situation is concealed, TRUE, or not, FALSE.
ContoursOnlyInForeground | Gets or sets the flag how the foreground entities set is used in this hide calculation.
Definition | Gets or sets the parent folder definition of the hide situation.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FgSelectionName | Gets or sets the name for the foreground selection set.
HiddenLinesInvisible | Gets or sets the hide style for lines is dashed, TRUE, or invisible, FALSE.
HideAppropriateObjectsOnly | Specifies how background objects are hidden, TRUE, or not, FALSE.
IgnoreBgExclude | Gets or sets the BgExclude flag.
IgnoreFgExclude | Gets or sets the FgExclude flag.
IgnoreUpperBgExclude |
InverseForeground | Gets or sets the flag how we use foreground entities set in this hide calculation.
IsComplexHideLevel | Checks whether this is complex hide situation, TRUE, or not, FALSE.
IsLastLevel | Checks if this hide situation is the last level of one complex hide situation, TRUE, or not, FALSE.
IsMigrated | Checks whether this is migrated hide situation, TRUE, or not, FALSE.
IsModifiedStandardPartHide | Checks whether this is the modified standard part hide situation, TRUE, or not, FALSE.
IsStandardPartHide | Checks whether this is standard part hide situation, TRUE, or not, FALSE.
LevelIndex |
Name | Gets or sets the name of the hide situation.
OuterContourOnly | Gets or sets the flag to define the outer contour property.
ParentHide | Gets the complex hide situation that owns this hide situation if this hide situation is part of one complex hide situation.
SaveSimplifiedOuterContour | Optimizes the outer contour selection and stores the contour for future calculations.
Suppressed | Gets or sets the suppression state of the hide situation, TRUE, or the unsuppression state, FALSE.
SysName | Gets or sets the system name.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadHideSituation::BgSelectionName Property
Summary

Gets or sets the name for the background selection set.

Visual Basic
Property BgSelectionName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::Concealed Property
Summary

Gets or sets whether the hide situation is concealed, TRUE, or not, FALSE.

Visual Basic
Property Concealed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::ContoursOnlyInForeground Property
Summary

Gets or sets the flag how the foreground entities set is used in this hide calculation.

Visual Basic
Property ContoursOnlyInForeground() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::Definition Property
Summary

Gets or sets the parent folder definition of the hide situation.

Visual Basic
Property Definition() As IMcadFolderDefinition*
Remarks

This property is a McadFolderDefinition object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::FgSelectionName Property
Summary

Gets or sets the name for the foreground selection set.

Visual Basic
Property FgSelectionName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::HiddenLinesInvisible Property
Summary

Gets or sets the hide style for lines is dashed, TRUE, or invisible, FALSE.

Visual Basic
Property HiddenLinesInvisible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::HideAppropriateObjectsOnly Property
Summary

Specifies how background objects are hidden, TRUE, or not, FALSE.

Visual Basic
Property HideAppropriateObjectsOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::IgnoreBgExclude Property
Summary

Gets or sets the BgExclude flag.

Visual Basic
Property IgnoreBgExclude() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Background exclusion set should not be calculated as a part of the foreground and it will be skipped from hide calculating.
Example

Refer to SDK Samples: amshide2d.dvb

Links
Example


IMcadHideSituation::IgnoreFgExclude Property
Summary

Gets or sets the FgExclude flag.

Visual Basic
Property IgnoreFgExclude() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Foreground exclusion set should not be calculated as a part of the foreground and it will be skipped from hide calculating.
Example

Refer to SDK Samples: amshide2d.dvb

Links
Example


IMcadHideSituation::IgnoreUpperBgExclude Property
Property IgnoreUpperBgExclude() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::InverseForeground Property
Summary

Gets or sets the flag how we use foreground entities set in this hide calculation.

Visual Basic
Property InverseForeground() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::IsComplexHideLevel Property
Summary

Checks whether this is complex hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsComplexHideLevel() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::IsLastLevel Property
Summary

Checks if this hide situation is the last level of one complex hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsLastLevel() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::IsMigrated Property
Summary

Checks whether this is migrated hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsMigrated() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadHideSituation::IsModifiedStandardPartHide Property
Summary

Checks whether this is the modified standard part hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsModifiedStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::IsStandardPartHide Property
Summary

Checks whether this is standard part hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::LevelIndex Property
Property LevelIndex() As long*
Remarks

This property is a Long.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::Name Property
Summary

Gets or sets the name of the hide situation.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::OuterContourOnly Property
Summary

Gets or sets the flag to define the outer contour property.

Visual Basic
Property OuterContourOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::ParentHide Property
Summary

Gets the complex hide situation that owns this hide situation if this hide situation is part of one complex hide situation.

Visual Basic
Property ParentHide() As IMcadComplexHideSituation**
Remarks

This property is a McadComplexHideSituation object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::SaveSimplifiedOuterContour Property
Summary

Optimizes the outer contour selection and stores the contour for future calculations.

Visual Basic
Property SaveSimplifiedOuterContour() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • This option should be enabled only if you observe a significant delay in the processing of the hide situation. While this option is selected, changes made to the foreground are not reflected in the hide situation.
Example

Refer to SDK Samples: amshide2d.dvb

Links
Example


IMcadHideSituation::Suppressed Property
Summary

Gets or sets the suppression state of the hide situation, TRUE, or the unsuppression state, FALSE.

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::SysName Property
Summary

Gets or sets the system name.

Visual Basic
Property SysName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::AddMSSubent Method
Summary

Adds the model space entity to this hide situation.

Visual Basic
Sub AddMSSubent(ent As IAcadEntity, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
ent | AcadEntity object; input-only. Specifies the model space entity to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::AddMSSubents Method
Summary

Adds model space entities to hide situation.

Visual Basic
Sub AddMSSubents(entityIds As VARIANT, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
entityIds | Variant (array of Long); input-only. Specifies the ID for model space entities to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::AddSubent Method
Summary

Adds the entity/view to this hide situation.

Visual Basic
Sub AddSubent(pSubent As IMcadFolder, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity/view to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::AddSubents Method
Summary

Adds the entities/views to this hide situation.

Visual Basic
Sub AddSubents(pSubents As IMcadFolders, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubents | McadFolders collection; input-only. Specifies the collection of entities/views to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::AutoSelectBackground Method
Summary

Automatically selects background objects and adds them to a new or existing level.

Visual Basic
Sub AutoSelectBackground(OccurrencesOnly As [in, defaultvalue(FALSE)] VARIANT_BOOL, CreateNewLevel As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
OccurrencesOnly | Boolean, default value = FALSE; input-only; optional. Specifies whether to perform this function to occurrences only.
CreateNewLevel | Boolean, default value = FALSE; input-only; optional. Specifies whether to create a new level or perform this function for the existing level.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::ClearSubents Method
Summary

Clears the hide situation sub-entities with the given sub-entity type.

Visual Basic
Sub ClearSubents(subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::RemoveSubent Method
Summary

Removes the entity/view from this hide situation with the given sub-entity type.

Visual Basic
Sub RemoveSubent(pSubent As IMcadFolder, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity or view to remove.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None


IMcadHideSituation::RemoveSubentByIdx Method
Summary

Removes the entity/view from this hide situation with the given sub-entity type and index number.

Visual Basic
Sub RemoveSubentByIdx(subentIdx As long, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
subentIdx | Long; input-only. Specifies the index for the entity or view to remove.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::Subents Method
Summary

Gets the hide subentities of this hide situation.

Visual Basic
Sub Subents(subentType As McadHideSituationSubentType, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the type of hide subentities to return.
Remarks

This property is a McadFolders collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituation::SwapFgAndBg Method
Summary

Swaps foreground and background hide sub-entities.

Visual Basic
Sub SwapFgAndBg()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Links
Example


IMcadHideSituations Interface
Summary

A collection of AMSHide objects.

Class Hierarchy

Declaration syntax

IMcadHideSituations
Visual Basic
Public Interface IMcadHideSituations
Inherits IDispatch
Links
IMcadHideSituations Members, AcadmAuto Library


IMcadHideSituations Members
Summary

The following tables list the members exposed by IMcadHideSituations.

Methods
Name | Description
Add | Appends a hide situation to the collection.
Item | Gets the hide object at the specified index from the collection.
Remove | Removes the specified Hide from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of hide situations in the collection.


IMcadHideSituations::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadHideSituations::Count Property
Summary

Gets the total number of hide situations in the collection.

Visual Basic
Property Count() As long*


IMcadHideSituations::Add Method
Summary

Appends a hide situation to the collection.

Visual Basic
Sub Add(Component As IMcadHideSituation)


IMcadHideSituations::Item Method
Summary

Gets the hide object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadHideSituation*)


IMcadHideSituations::Remove Method
Summary

Removes the specified Hide from the collection.

Visual Basic
Sub Remove(Index As long)


IMcadLayerCfg Interface
Summary

This class contains the configuration settings for a mechanical layer.

Class Hierarchy

Declaration syntax

IMcadLayerCfg
Visual Basic
Public Interface IMcadLayerCfg
Inherits IDispatch
Links
IMcadLayerCfg Members, AcadmAuto Library


IMcadLayerCfg Members
Summary

The following tables list the members exposed by IMcadLayerCfg.

Properties
Name | Description
AssocObjects | Specifies objects associated with the layer.
Desc | Specifies the layer description.
Invisible | Specifies the visibility of the layer.
Key | Specifies the layer key.
LineType | Specifies the layer linetype.
LineTypeId | Specifies the layer linetype ID.
LineTypeId32 | Specifies the layer line type ID. Only available for x64 platform.
LineWeight | Specifies the layer lineweight.
Name | Specifies the layer name.
NoPlot | Specifies whether the layer is plotted.
NoReplicateInLayerGroup | Specifies whether the layer is replicated when a new layergroup is created.
OverrideColorByLayerGroup | Specifies whether the color associated with the layer is overridden by the layergroup color.
TrueColor | Specifies the layer color.


IMcadLayerCfg::AssocObjects Property
Summary

Specifies objects associated with the layer.

Visual Basic
Property AssocObjects() As VARIANT*


IMcadLayerCfg::Desc Property
Summary

Specifies the layer description.

Visual Basic
Property Desc() As String


IMcadLayerCfg::Invisible Property
Summary

Specifies the visibility of the layer.

Visual Basic
Property Invisible() As VARIANT_BOOL


IMcadLayerCfg::Key Property
Summary

Specifies the layer key.

Visual Basic
Property Key() As BSTR*
Remarks

Read-only.


IMcadLayerCfg::LineType Property
Summary

Specifies the layer linetype.

Visual Basic
Property LineType() As String
Remarks

Read-only.


IMcadLayerCfg::LineTypeId Property
Summary

Specifies the layer linetype ID.

Visual Basic
Property LineTypeId() As LONG_PTR


IMcadLayerCfg::LineTypeId32 Property
Summary

Specifies the layer line type ID. Only available for x64 platform.

Visual Basic
Property LineTypeId32() As LONG


IMcadLayerCfg::LineWeight Property
Summary

Specifies the layer lineweight.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT


IMcadLayerCfg::Name Property
Summary

Specifies the layer name.

Visual Basic
Property Name() As String


IMcadLayerCfg::NoPlot Property
Summary

Specifies whether the layer is plotted.

Visual Basic
Property NoPlot() As VARIANT_BOOL


IMcadLayerCfg::NoReplicateInLayerGroup Property
Summary

Specifies whether the layer is replicated when a new layergroup is created.

Visual Basic
Property NoReplicateInLayerGroup() As VARIANT_BOOL


IMcadLayerCfg::OverrideColorByLayerGroup Property
Summary

Specifies whether the color associated with the layer is overridden by the layergroup color.

Visual Basic
Property OverrideColorByLayerGroup() As VARIANT_BOOL


IMcadLayerCfg::TrueColor Property
Summary

Specifies the layer color.

Visual Basic
Property TrueColor() As IAcadAcCmColor*


IMcadLayerCfgs Interface
Summary

This is class IMcadLayerCfgs.

Class Hierarchy

Declaration syntax

IMcadLayerCfgs
Visual Basic
Public Interface IMcadLayerCfgs
Inherits IDispatch
Links
IMcadLayerCfgs Members, AcadmAuto Library


IMcadLayerCfgs Members
Summary

The following tables list the members exposed by IMcadLayerCfgs.

Methods
Name | Description
Add | This is Add, a member of class IMcadLayerCfgs.
Item | This is Item, a member of class IMcadLayerCfgs.
Remove | This is Remove, a member of class IMcadLayerCfgs.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.


IMcadLayerCfgs::_NewEnum Property
Summary

This is _NewEnum, a member of class IMcadLayerCfgs.

Visual Basic
Property _NewEnum() As LPUNKNOWN*


IMcadLayerCfgs::Application Property
Summary

Returns the application object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is read-only.


IMcadLayerCfgs::Count Property
Summary

Returns the total number of layer objects in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is read only.


IMcadLayerCfgs::Add Method
Summary

This is Add, a member of class IMcadLayerCfgs.

Visual Basic
Sub Add(LayerCfg As IMcadLayerCfg)


IMcadLayerCfgs::Item Method
Summary

This is Item, a member of class IMcadLayerCfgs.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadLayerCfg*)


IMcadLayerCfgs::Remove Method
Summary

This is Remove, a member of class IMcadLayerCfgs.

Visual Basic
Sub Remove(Index As long)


IMcadLayerGroupMgr Interface
Summary

Provides access to methods and properties used to manage layers in documents.

Class Hierarchy

Declaration syntax

IMcadLayerGroupMgr
Visual Basic
Public Interface IMcadLayerGroupMgr
Inherits IDispatch
Links
IMcadLayerGroupMgr Members, AcadmAuto Library


IMcadLayerGroupMgr Members
Summary

The following tables list the members exposed by IMcadLayerGroupMgr.

Methods
Name | Description
GetLayerGroupEntities | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupEntities32 | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupNames | Gets all of the layer group names for the document.
GetLayersFromGroup | Gets the names of all layers in a specified layer group.
MoveLayerGroupEntities | Moves all of the entities in one layer group to another layer group.
Properties
Name | Description
Document | Gets the corresponding McadDocument from the specified host application's document.


IMcadLayerGroupMgr::Document Property
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.


IMcadLayerGroupMgr::GetLayerGroupEntities Method
Summary

Gets the object IDs for the entities associated with that specified layer group.

Visual Basic
Sub GetLayerGroupEntities(layerGroupName As String, bIgnoreBlocks As [in, defaultvalue(FALSE)] VARIANT_BOOL, bOnlyBlockRefs As [in, defaultvalue(FALSE)] VARIANT_BOOL, bIgnore_FLO_Objects As [in, defaultvalue(FALSE)] VARIANT_BOOL, pEntityIds As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name for which to get entity IDs.
bIgnoreBlocks | Boolean, default value = FALSE; input-only. Denotes that AutoCAD block references are not returned.
bOnlyBlockRefs | Boolean, default value = FALSE; input-only. Denotes that only AutoCAD block references are returned .
bIgnore_FLO_Objects | Boolean, default value = FALSE; input-only. Denotes that entities on Frozen, Locked, or Off layers are not returned.
Returns

Variant (Array of entity IDs (Longs)).


IMcadLayerGroupMgr::GetLayerGroupEntities32 Method
Summary

Gets the object IDs for the entities associated with that specified layer group.

Visual Basic
Sub GetLayerGroupEntities32(layerGroupName As String, bIgnoreBlocks As [in, defaultvalue(FALSE)] VARIANT_BOOL, bOnlyBlockRefs As [in, defaultvalue(FALSE)] VARIANT_BOOL, bIgnore_FLO_Objects As [in, defaultvalue(FALSE)] VARIANT_BOOL, pEntityIds As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name for which to get entity IDs.
bIgnoreBlocks | Boolean, default value = False; input-only. Denotes that AutoCAD block references are not returned.
bOnlyBlockRefs | Boolean, default value = False; input-only. Denotes that only AutoCAD block references are returned .
bIgnore_FLO_Objects | Boolean, default value = False; input-only. Denotes that entities on Frozen, Locked, or Off layers are not returned.
pEntityIds | _nt_
Returns

Variant (Array of entity IDs (Longs)).


IMcadLayerGroupMgr::GetLayerGroupNames Method
Summary

Gets all of the layer group names for the document.

Visual Basic
Sub GetLayerGroupNames(pLayerGroupNames As [out, retval] VARIANT)
Returns

Array of Strings


IMcadLayerGroupMgr::GetLayersFromGroup Method
Summary

Gets the names of all layers in a specified layer group.

Visual Basic
Sub GetLayersFromGroup(layerGroupName As String, pLayerNames As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name from which to get the names of all layers.
Returns

Variant (Array of Strings)


IMcadLayerGroupMgr::MoveLayerGroupEntities Method
Summary

Moves all of the entities in one layer group to another layer group.

Visual Basic
Sub MoveLayerGroupEntities(sourceGroup As String, targetGroup As String)
Parameters
Parameters | Description
sourceGroup | String; input-only. Specifies the source layer group from which to move all entities.
targetGroup | String; input-only. Specifies the target layer group to which to move all entities.
Remarks

The entities are potentially on different layers in the source group; these layers will be respected upon their transfer to the target layer group.


IMcadLayerObjectCfg Interface
Summary

This class contains the configuration settings for a mechanical object.

Class Hierarchy

Declaration syntax

IMcadLayerObjectCfg
Visual Basic
Public Interface IMcadLayerObjectCfg
Inherits IDispatch
Links
IMcadLayerObjectCfg Members, AcadmAuto Library


IMcadLayerObjectCfg Members
Summary

The following tables list the members exposed by IMcadLayerObjectCfg.

Properties
Name | Description
Hide | Specifies the layer object hide type.
LayerName | Specifies the layer key.
LayerObjKey | Specifies the layer object key. This table lists the layer object keys and their description.
LineType | Specifies the layer object line type.
LineTypeId | Specifies the layer object line type ID.
LineTypeId32 | Specifies the layer object line type ID. Only available for x64 platform.
LineWeight | Specifies the layer object line weight.
TrueColor | Specifies the layer object color.


IMcadLayerObjectCfg::Hide Property
Summary

Specifies the layer object hide type.

Visual Basic
Property Hide() As McadLayerObjectHideType


IMcadLayerObjectCfg::LayerName Property
Summary

Specifies the layer key.

Visual Basic
Property LayerName() As String


IMcadLayerObjectCfg::LayerObjKey Property
Summary

Specifies the layer object key.

This table lists the layer object keys and their description.

Key | Description
BHNV | Behind
BHNVS | Behind (extra)
BOR2 | Drawing Border Thin Objects
BOR3 | Drawing Border Objects
BOR5 | Drawing Border Thick Objects
CAL2 | Calculation Thin Objects
CAL3 | Calculation Objects
CAL5 | Calculation Thick Objects
CAL7 | Calculation Very Thick Objects
CENN | Centerline, narrow
CENW | Centerline
CLIN | Construction Line
CON1 | Contour 1
CON2 | Contour 2
CON3 | Contour 3
CON4 | Contour 4
DETA | Detail Border
DIAG | Diagonal Cross for Planes
DILI | Dimension/Extension Lines
DIMP | Dimension, parametric
DIMR | Dimension, reference
FEMN | FEA: Mesh
FEMPN | FEA: Number of Points
FEMSP | FEA: Stress
FEMST | FEA: Text for Stress
FEMVN | FEA: Deformation Mesh
FEMVT | FEA: Text for Deformation
HATC | Hatch
HIDN | Hidden Line, narrow
HIDW | Hidden Line
HLIN | Auxiliary Line
HOCN | Hole Circle, narrow
HOCW | Hole Circle
INFO | Part Reference Geometry
LEAD | Leader
N_BHNV | Standard Parts: Behind
N_CON1 | Standard Parts: Contour 1
N_CON2 | Standard Parts: Contour 2
N_CON3 | Standard Parts: Contour 3
N_CON4 | Standard Parts: Contour 4
N_CENN | Standard Parts: Centerline, narrow
N_CENW | Standard Parts: Centerline
N_DILI | Standard Parts: Dimension Line
N_HATC | Standard Parts: Hatch
N_HIDN | Standard Parts: Hidden Line, narrow
N_HIDW | Standard Parts: Hidden Line
N_LEAD | Standard Parts: Leader
N_NGIP | Standard Parts: Non Plottable Objects
N_PHAN | Standard Parts: Phantom
N_TCON | Standard Parts: Thread Contour
N_THLI | Standard Parts: Thread Line
NTLEN | Standard Parts: Thread End at Usable Length
N_VPLI | Standard Parts: Section/Viewing Plane Line
NGIP | Non Plottable Objects
PAL2 | Cell Lines
PAL3 | Grip Frame
PAL5 | Outer Frame
PHAN | Phantom
POSN | Balloon Geometry
RCGN | Reference Circle for Gear Cogwheels, narrow
RCGW | Reference Circle for Gear Cogwheels
SBRK | Break Line Short
SECT | Break Out Line
SYB3 | Calculation Symbols
MSYM | Symbol Geometry
TCON | Thread Contour
THLI | Thread Line
TIT2 | Title Block Thin Objects
TIT3 | Title Block Objects
TIT5 | Title Block Thick Objects
TLEN | Thread End at Usable Length
TRAIL | Trailing Line
TRLI | Transition Line
TXT1 | Text Very Small
TXT2 | Text Small
TXT3 | Text Medium
TXT5 | Text Large
TXT7 | Text Very Large
VIEW | Viewport
VEDH | View Edge, hidden
VEDV | View Edge, visible
VPLI | Section/Viewing Plane Line
ZIZA | Break Line Long (Zig Zag)
Visual Basic
Property LayerObjKey() As BSTR*
Remarks

This property is read-only.


IMcadLayerObjectCfg::LineType Property
Summary

Specifies the layer object line type.

Visual Basic
Property LineType() As String


IMcadLayerObjectCfg::LineTypeId Property
Summary

Specifies the layer object line type ID.

Visual Basic
Property LineTypeId() As LONG_PTR


IMcadLayerObjectCfg::LineTypeId32 Property
Summary

Specifies the layer object line type ID. Only available for x64 platform.

Visual Basic
Property LineTypeId32() As LONG


IMcadLayerObjectCfg::LineWeight Property
Summary

Specifies the layer object line weight.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT


IMcadLayerObjectCfg::TrueColor Property
Summary

Specifies the layer object color.

Visual Basic
Property TrueColor() As IAcadAcCmColor*


IMcadLayerObjectCfgs Interface
Summary

This is class IMcadLayerObjectCfgs.

Class Hierarchy

Declaration syntax

IMcadLayerObjectCfgs
Visual Basic
Public Interface IMcadLayerObjectCfgs
Inherits IDispatch
Links
IMcadLayerObjectCfgs Members, AcadmAuto Library


IMcadLayerObjectCfgs Members
Summary

The following tables list the members exposed by IMcadLayerObjectCfgs.

Methods
Name | Description
Add | This is Add, a member of class IMcadLayerObjectCfgs.
Item | Obtains a specified layer from the collection.
Remove | This is Remove, a member of class IMcadLayerObjectCfgs.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerObjectCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.


IMcadLayerObjectCfgs::_NewEnum Property
Summary

This is _NewEnum, a member of class IMcadLayerObjectCfgs.

Visual Basic
Property _NewEnum() As LPUNKNOWN*


IMcadLayerObjectCfgs::Application Property
Summary

Returns the application object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

Read-only.


IMcadLayerObjectCfgs::Count Property
Summary

Returns the total number of layer objects in the collection.

Visual Basic
Property Count() As long*
Remarks

Read-only.


IMcadLayerObjectCfgs::Add Method
Summary

This is Add, a member of class IMcadLayerObjectCfgs.

Visual Basic
Sub Add(LayObjCfg As IMcadLayerObjectCfg)


IMcadLayerObjectCfgs::Item Method
Summary

Obtains a specified layer from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadLayerObjectCfg*)
Parameters
Parameters | Description
Index | Long value; input-only. Specifies an index of the selected layer object in the collection. Values range from 0 to one less than the total number of objects.
Component | McadLayerObjectCfg object. Returns the selected layer object in the collection.


IMcadLayerObjectCfgs::Remove Method
Summary

This is Remove, a member of class IMcadLayerObjectCfgs.

Visual Basic
Sub Remove(Index As long)


IMcadLayerObjectMgr Interface
Summary

This class is for accessing the layer object settings.

Class Hierarchy

Declaration syntax

IMcadLayerObjectMgr
Visual Basic
Public Interface IMcadLayerObjectMgr
Inherits IDispatch
Links
IMcadLayerObjectMgr Members, AcadmAuto Library


IMcadLayerObjectMgr Members
Summary

The following tables list the members exposed by IMcadLayerObjectMgr.

Methods
Name | Description
CreateLayer | Creates a mechanical layer for the current drafting standard.
GetAllLayerObjs | Gets all the mechanical objects specified by the standard.
GetAllLayers | Gets all the mechanical layers for the specified standard in the current drawing.
GetLayerObjProperty | Gets the property of the layer object settings according to the layer object key and standard ID.
GetLayerProperty | Gets the property of the layer settings according to the layer name and standard ID.
ImportLayerObj | Imports the layer object settings from the specified drawing.
SetLayerObjDefault | Resets the mechanical layer and object properties to their default values.
Properties
Name | Description
Document | This is Document, a member of class IMcadLayerObjectMgr.


IMcadLayerObjectMgr::Document Property
Summary

This is Document, a member of class IMcadLayerObjectMgr.

Visual Basic
Property Document() As IMcadDocument**


IMcadLayerObjectMgr::CreateLayer Method
Summary

Creates a mechanical layer for the current drafting standard.

Visual Basic
Sub CreateLayer(layerName As String, groupName As [in,optional] VARIANT)
Parameters
Parameters | Description
layerName | BSTR object; input only. Specifies the layer name.
groupName | Variant object; input only. Specifies the group name of the layer.


IMcadLayerObjectMgr::GetAllLayerObjs Method
Summary

Gets all the mechanical objects specified by the standard.

Visual Basic
Sub GetAllLayerObjs(stdId As [in,optional] VARIANT, arLayObjCfg As [out,retval] IMcadLayerObjectCfgs*)
Parameters
Parameters | Description
stdId | Variant object; input only. Specifies current standard ID.
arLayObjCfg | Returns a list of all the mechanical objects.


IMcadLayerObjectMgr::GetAllLayers Method
Summary

Gets all the mechanical layers for the specified standard in the current drawing.

Visual Basic
Sub GetAllLayers(stdId As [in,optional] VARIANT, arLayCfg As [out,retval] IMcadLayerCfgs*)
Parameters
Parameters | Description
stdId | Variant object; input only. Specifies the current standard.
arLayCfg | McadLayerCfgs object. Returns a list of all the layers in the standard.


IMcadLayerObjectMgr::GetLayerObjProperty Method
Summary

Gets the property of the layer object settings according to the layer object key and standard ID.

Visual Basic
Sub GetLayerObjProperty(objKey As String, stdId As [in,optional] VARIANT, objProp As [out, retval] IMcadLayerObjectCfg*)
Parameters
Parameters | Description
objKey | BSTR object; input-only. Specifies the layer object key.
stdId | Variant object; input-only; optional. Specifies the standard ID.
objProp | MCadLayerObjectCfg object. Returns the configuration settings for a mechanical object.


IMcadLayerObjectMgr::GetLayerProperty Method
Summary

Gets the property of the layer settings according to the layer name and standard ID.

Visual Basic
Sub GetLayerProperty(layerName As String, stdId As [in,optional] VARIANT, layerProp As [out, retval] IMcadLayerCfg*)
Parameters
Parameters | Description
layerName | BSTR object; input only. Specifies the layer name.
stdId | Variant object; input-only; optional. Specifies the standard ID.
layerProp | McadLayerCfg object. Returns the configuration settings for a mechanical layer.


IMcadLayerObjectMgr::ImportLayerObj Method
Summary

Imports the layer object settings from the specified drawing.

Visual Basic
Sub ImportLayerObj(dwgName As String, bReplace As VARIANT_BOOL)
Parameters
Parameters | Description
dwgName | BSTR object; input only. Specifies the drawing name.
bReplace | Variant (Boolean). If true, the attributes of the entities will be changed in the current drawing according to the layer configuration of a foreign database of the source drawing.


IMcadLayerObjectMgr::SetLayerObjDefault Method
Summary

Resets the mechanical layer and object properties to their default values.

Visual Basic
Sub SetLayerObjDefault()


IMcadLine Interface
Summary

An unbounded line object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadLine
Visual Basic
Public Interface IMcadLine
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadObject Interface
Summary

A reference to a generic object or sub-object within the Mechanical Desktop, AutoCAD or AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComplexHideSituation
    IMcadComponent
    IMcadComponentDefinition
    IMcadFolder
    IMcadFolderDefinition
    IMcadGeometry
    IMcadHideSituation
Visual Basic
Public Interface IMcadObject
Inherits IDispatch
Remarks

This object is a temporary reference to the object unless it is made persistent using the MakePersistent method, where an identifier is generated for the reference and the reference is stored with the document. In a later session, the identifier can be used to revive the reference object.

Links
IMcadObject Members, AcadmAuto Library


IMcadObject Members
Summary

The following tables list the members exposed by IMcadObject.

Methods
Name | Description
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


IMcadObject::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadObject::Document Property
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.


IMcadObject::Editable Property
Summary

Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.

Visual Basic
Property Editable() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • For many object types, this property indicates that the object is not external and can, for example, be deleted or its parameter modifications preserved when the drawing is saved.


IMcadObject::WasErased Property
Summary

Gets whether component view definition was erased, TRUE, or not, FALSE.

Visual Basic
Property WasErased() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadObject::Delete Method
Summary

Deletes the object being referenced.

Visual Basic
Sub Delete()
Returns

None

Remarks

This will only be successful for object whose Editable property is a TRUE.


IMcadObject::Highlight Method
Summary

Highlights the topological entity on the model.

Visual Basic
Sub Highlight(Highlight As VARIANT_BOOL, Scale As [in, defaultvalue(1.0)] double)
Parameters
Parameters | Description
Highlight | Boolean; input-only. Specifies whether to highlight the object, TRUE, or not, FALSE.
Scale | Double, default value = 1; input-only; optional. Specifies the scale factor for unbounded objects.
Returns

Boolean

Remarks

Highlighting the entity will only be visible if the outermost block reference, or the solid body itself resides in the model space block record if it is not nested in a block.


IMcadObject::IsEqualTo Method
Summary

Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.

Visual Basic
Sub IsEqualTo(Object As IMcadObject, ConsiderComp As [in, defaultvalue(TRUE)] VARIANT_BOOL, DifferInComp As [out, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | McadObject object; input-only. Specifies the reference to the object to be compared to.
ConsiderComp | Boolean, default value = TRUE; input-only; optional. Specifies whether differences in component instance focus should be considered for equivalence, TRUE, or not, FALSE.
DifferInComp | Variant (Boolean); optional. Specifies whether the objects differ in component insert scope, TRUE, or not, FALSE.
Returns

Boolean


IMcadObject::MakePersistent Method
Summary

Assigns a unique identifier for the reference object and stores the reference object with the specified database.

Visual Basic
Sub MakePersistent(Database As [in, optional] VARIANT, Identifier As [out, retval] BSTR)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify which database in the document the object is to be stored in. If not specified, the object is stored in the current working database that is either the host database for the document, or the database that is currently being xref edited.
Returns

String

Remarks
  • Database resident objects that are referenced by an object reference include the object being referenced, for example a feature, as well as any objects in the references scope or focus, for example the chain of components that make up the focus of a feature key.
  • If an xref database is specified, this method will fail when the object references database objects that are 'above' the specified database in the xref database graph.


IMcadObjects Interface
Summary

A collection of IMcadObject subtype objects.

Class Hierarchy

Declaration syntax

IMcadObjects
Visual Basic
Public Interface IMcadObjects
Inherits IDispatch
Links
IMcadObjects Members, AcadmAuto Library


IMcadObjects Members
Summary

The following tables list the members exposed by IMcadObjects.

Methods
Name | Description
Add | Appends a new object to the collection.
Item | Gets the object at the specified index from the collection.
Remove | Long; input-only. Specifies the index of the object to remove.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.


IMcadObjects::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadObjects::Count Property
Summary

Gets the total number of objects in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadObjects::Add Method
Summary

Appends a new object to the collection.

Visual Basic
Sub Add(Object As IMcadObject)
Parameters
Parameters | Description
Object | McadObject object; input-only. Specifies the new objects to add to the collection.
Returns

None


IMcadObjects::Item Method
Summary

Gets the object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the object to return.
Returns

McadObject object


IMcadObjects::Remove Method
Summary

Long; input-only. Specifies the index of the object to remove.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the object to remove.
Returns

None


IMcadPick Interface
Summary

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.

Class Hierarchy

Declaration syntax

IMcadPick
Visual Basic
Public Interface IMcadPick
Inherits IDispatch
Remarks

A McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties. Using a pick object it is possible to get the subentity paths, pick point (point used for selection of entity) pick vector type of object, and so on.

Links
IMcadPick Members, AcadmAuto Library


IMcadPick Members
Summary

The following tables list the members exposed by IMcadPick.

Properties
Name | Description
Application | Gets the AcadmApplication object.
ObjectType | Specifies the object reference type that the pick is used to select.
PickPoint | Specifies the pick point of the pick object.


IMcadPick::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadPick::ObjectType Property
Summary

Specifies the object reference type that the pick is used to select.

Visual Basic
Property ObjectType() As McadObjectType


IMcadPick::PickPoint Property
Summary

Specifies the pick point of the pick object.

Visual Basic
Property PickPoint() As IGePoint*


IMcadPolyline Interface
Summary

A polyline object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadPolyline
Visual Basic
Public Interface IMcadPolyline
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadPowObjViewGroupDescriptor Interface
Summary

Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadPowObjViewGroupDescriptor
Visual Basic
Public Interface IMcadPowObjViewGroupDescriptor
Inherits IMcad2DStructureDescriptor
Links
IMcadPowObjViewGroupDescriptor Members, AcadmAuto Library


IMcadPowObjViewGroupDescriptor Members
Summary

The following tables list the members exposed by IMcadPowObjViewGroupDescriptor.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Entities | Gets the entities from the view group descriptor in model space.
Entities32 | Gets the entities from the view group descriptor in model space.
Name | Gets and sets the name of a 2D structure descriptor.
PowerObjectType | Gets the power object type from the power object view group descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.


IMcadPowObjViewGroupDescriptor::Entities Property
Summary

Gets the entities from the view group descriptor in model space.

Visual Basic
Property Entities() As VARIANT*
Remarks

This property is a Variant (array of entity IDs (Longs)).


IMcadPowObjViewGroupDescriptor::Entities32 Property
Summary

Gets the entities from the view group descriptor in model space.

Visual Basic
Property Entities32() As VARIANT*
Remarks

This property is a Variant (array of entity IDs (Longs)).


IMcadPowObjViewGroupDescriptor::PowerObjectType Property
Summary

Gets the power object type from the power object view group descriptor.

Visual Basic
Property PowerObjectType() As McadPowerObjectType*
Remarks

McadPowerObjectType enumeration


IMcadPowObjViewGroupDescriptor::TargetView Property
Summary

Gets and sets the target (parent) view for this descriptor.

Visual Basic
Property TargetView() As VARIANT
Remarks

This property is a Variant ( McadObject object).


IMcadSpline Interface
Summary

A spline object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadSpline
Visual Basic
Public Interface IMcadSpline
Inherits IMcadCurve
Links
AcadmAuto Library


IMcadStdPartComponentViewDescriptor Interface
Summary

Encapsulates the description of a component view of a standard part.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor
Visual Basic
Public Interface IMcadStdPartComponentViewDescriptor
Inherits IMcadComponentViewDescriptor
Links
AcadmAuto Library


IMcadUtility Interface
Summary

This API provides some general utility methods.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
Visual Basic
Public Interface IMcadUtility
Inherits IDispatch
Links
IMcadUtility Members, AcadmAuto Library


IMcadUtility Members
Summary

The following tables list the members exposed by IMcadUtility.

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


IMcadUtility::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadUtility::Document Property
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**


IMcadUtility::CreateAttribute Method
Summary

Creates a new attribute instance using a specified ClassName as input.

Visual Basic
Sub CreateAttribute(ClassName As String, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ClassName | String; input-only. Specifies the class name with which to create the new attribute.
Returns

McadAttribute object


IMcadUtility::CreateAttributeField Method
Summary

Creates a new attribute field object.

Visual Basic
Sub CreateAttributeField(Field As [out, retval] IMcadAttributeField*)
Remarks

McadAttributeField object


IMcadUtility::CreateCollection Method
Summary

Creates a collection object for the specified type.

Visual Basic
Sub CreateCollection(Type As McadCollectionType, Collection As [out, retval] LPDISPATCH)
Parameters
Parameters | Description
Type | McadCollectionType enumeration; input-only. Specifies the collection type for which to create the new collection.
Returns

Mcad collection object


IMcadUtility::CreatePickObject Method
Summary

Creates a new pick object.

Visual Basic
Sub CreatePickObject(Pick As [out, retval] IMcadPick*)
Remarks

Pick objects are usually created with the Pick method, but this method is intended for creating an empty pick object to manually set the data in.


IMcadUtility::CreateSystemAttribute Method
Summary

Creates a new system attribute instance.

Visual Basic
Sub CreateSystemAttribute(Name As String, DataType As McadFieldType, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
Name | Name String
DataType | DataType McadFieldType


IMcadUtility::GetAllAttributes Method
Summary

Gets all of the attributes in the drawing.

Visual Basic
Sub GetAllAttributes(Name As [in, optional] VARIANT, Scope As [in, optional] VARIANT, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
Name | Variant (String); input-only; optional. Limits the attributes to only those in a specified type; if not specified, attributes in all types are returned.
Scope | Variant ( McadObject object); input-only; optional. If specified, limits the search to a specific object, for example a part object would limit the search to all attributes on the part. Note that currently only part objects are allowed for the Scope element.
Returns

McadAttributes collection


IMcadUtility::GetAttributeFromID Method
Summary

Gets the attribute from a specified object ID.

Visual Basic
Sub GetAttributeFromID(ObjectID As LONG_PTR, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ObjectID | Long; input-only. Specified the object ID from which to get the attribute.
Returns

McadAttribute object


IMcadUtility::GetAttributeFromID32 Method
Summary

Gets the attribute object from an object ID.

Visual Basic
Sub GetAttributeFromID32(ObjectID As LONG, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ObjectID | Long; input-only. Specifies the geometry object ID to perform this method.
Attribute | The IMcadAttribute object.


IMcadUtility::GetGeometryFromPick Method
Summary

Obtains a geometry reference object of the specified type from the specified pick object.

Visual Basic
Sub GetGeometryFromPick(Type As McadObjectType, Infer As VARIANT_BOOL, Pick1 As IMcadPick, Pick2 As [in, optional] VARIANT, Geometry As [out, retval] IMcadGeometry*)
Parameters
Parameters | Description
Type | McadObjectType enumeration; input-only. Specifies the type to infer from the actual geometry picked.
Infer | Boolean; input-only. Specifies whether the specified type should be inferred from the actual geometry picked. For example, a pick to an arc can be used to request a geometry reference to a line and the axis of the circle would be returned.
Pick1 | McadPick object; input-only. Specifies the pick object when the inferred type would require more than one pick,
Pick2 | Variant ( McadPick object); input-only; optional. Specifies the additional pick object when the inferred type would require more than one pick,
Returns

McadGeometry object


IMcadUtility::GetIdsFromObject Method
Summary

Gets the object ID or multiple object IDs that constitute the object being referenced.

Visual Basic
Sub GetIdsFromObject(Object As IMcadObject, ObjectIDs As [out, retval] VARIANT)
Parameters
Parameters | Description
Object | IMcadObject object; input-only. Specifies the object for which to get object ID(s). It can be McadFolder, McadComponentView, McadHideSituation, and McadComplexHideSituation.
Returns

Variant (array of Longs)


IMcadUtility::GetIdsFromObject32 Method
Summary

Gets the object ID or multiple object IDs that constitute the object being referenced.

Visual Basic
Sub GetIdsFromObject32(Object As IMcadObject, ObjectIDs As [out, retval] VARIANT)
Parameters
Parameters | Description
Object | IMcadObject object; input-only. Specifies the object for which to get object ID(s). It can be McadFolder, McadComponentView, McadHideSituation, and McadComplexHideSituation.
ObjectIDs | _nt_


IMcadUtility::GetObjectFromID Method
Summary

Obtains a geometry reference object of the specified type from the specified object ID.

Visual Basic
Sub GetObjectFromID(Id As LONG_PTR, Type As McadObjectType, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Id | Long; input-only. Specifies the geometry object ID to perform this method.
Type | McadObjectType enumeration; input-only. Specifies the object type to perform this method.
Returns

IMcadObject object


IMcadUtility::GetObjectFromID32 Method
Summary

Obtains a geometry reference object of the specified type from the specified object ID.

Visual Basic
Sub GetObjectFromID32(Id As LONG, Type As McadObjectType, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Id | Long; input-only. Specifies the geometry object ID to perform this method.
Type | McadObjectType enumeration; input-only. Specifies the object type to perform this method.
Object | The IMcadObject object.


IMcadUtility::GetObjectFromPick Method
Summary

Creates an object reference of the specified type from the specified pick object.

Visual Basic
Sub GetObjectFromPick(Pick As IMcadPick, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Pick | McadPick object; input-only. Specifies the McadPick object to create an object reference from.
Returns

McadObject object

Remarks

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen. A McadPick object can be obtained by prompting users for a selection using the McadUtility > Pick method or constructed from its properties.


IMcadUtility::Pick Method
Summary

Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.

Visual Basic
Sub Pick(Prompt As String, Type As McadObjectType, AllowGhost As [in, defaultvalue(FALSE)] VARIANT_BOOL, ActiveInstance As [in, defaultvalue(FALSE)] VARIANT_BOOL, KeyWords As [in, optional] VARIANT, KeyWordUsed As [in, out, optional] VARIANT, FilterType As [in, optional] VARIANT, FilterData As [in, optional] VARIANT, Pick As [out, retval] IMcadPick*)
Parameters
Parameters | Description
Prompt | String; input-only. Specifies the string to prompt users for the selection of the object.
Type | McadObjectType enumeration; input-only. Specifies the type of the object to pick.
AllowGhost | Boolean, default value = False; input-only; optional. Specifies whether the ghost selection is enabled, TRUE, or not, FALSE.
ActiveInstance | Boolean, default value = False; input-only; optional. Specifies whether the selection is restricted to the active component instance, TRUE, or not, FALSE.
KeyWords | Variant; input-only; optional. Specifies a list of keywords to be included within the prompt, separated by spaces.
KeyWordUsed | Variant; output-only; optional. If the KeyWords element is supplied and the user chooses a keyword instead of making a selection, the selected keyword is returned in the KeyWordUsed element.
FilterType | Variant; input-only; optional. Specifies the filter type to filter the selection.
FilterData | Variant; input-only; optional. Specifies the filter data to filter the selection.
Returns

McadPick object

Remarks

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen. A McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties.


IMcadUtility2 Interface
Summary

This is class IMcadUtility2.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
        IMcadUtility3
Visual Basic
Public Interface IMcadUtility2
Inherits IMcadUtility
Links
IMcadUtility2 Members, AcadmAuto Library


IMcadUtility2 Members
Summary

The following tables list the members exposed by IMcadUtility2.

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


IMcadUtility2::RefocusObject Method
Summary

Repath the folder, component view or hide situation to the target view

Visual Basic
Sub RefocusObject(Object As IMcadObject, Target As IMcadObject, InPlace As [in, defaultvalue(TRUE)] VARIANT_BOOL, Result As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Object | _nt_
Target | _nt_
InPlace | _nt_
Result | _nt_
Remarks

This API is applicable for McadFolder, McadComponentView and McadHideSituation/McadComplexHideSituation.


IMcadUtility3 Interface
Summary

This is class IMcadUtility3.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
        IMcadUtility3
Visual Basic
Public Interface IMcadUtility3
Inherits IMcadUtility2
Links
IMcadUtility3 Members, AcadmAuto Library


IMcadUtility3 Members
Summary

The following tables list the members exposed by IMcadUtility3.

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetDrawingType | Obtains the DWG drawing type from the side database.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


IMcadUtility3::GetDrawingType Method
Summary

Obtains the DWG drawing type from the side database.

Visual Basic
Sub GetDrawingType(database As IAcadDatabase, Type As [out, retval] McadDocDrawingType)


Mcad2dComplexStdPartCompGroupDescriptor CoClass
Summary

Provides a description of a 2D complex standard part component group. The types of complex standard parts are screw connections and part features.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dComplexStdPartCompGroupDescriptor
Visual Basic
Public Class Mcad2dComplexStdPartCompGroupDescriptor
Links
AcadmAuto Library


Mcad2dComponentDescriptor CoClass
Summary

Provides a description of a 2D component.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dComponentDescriptor
Visual Basic
Public Class Mcad2dComponentDescriptor
Links
AcadmAuto Library


Mcad2dShaftCompGroupDescriptor CoClass
Summary

Provides a description of the group of shaft and standard part objects that comprise a shaft power object.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dShaftCompGroupDescriptor
Visual Basic
Public Class Mcad2dShaftCompGroupDescriptor
Links
AcadmAuto Library


Mcad2dStdPartComponentDescriptor CoClass
Summary

Provides a description of the 2D standard part component.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dStdPartComponentDescriptor
Visual Basic
Public Class Mcad2dStdPartComponentDescriptor
Links
AcadmAuto Library


Mcad2DStructureDescriptor CoClass
Summary

This object is the base class for 2D structure descriptors.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2DStructureDescriptor
Visual Basic
Public Class Mcad2DStructureDescriptor
Links
AcadmAuto Library


Mcad2DStructureMgr CoClass
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2DStructureMgr
Visual Basic
Public Class Mcad2DStructureMgr
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Links
AcadmAuto Library


Mcad2DSViewType Enumeration
Summary

Enumerates the 2D structure view types.

Visual Basic
Public Enum Mcad2DSViewType
  mc2DSUndefinedView = 0
  mc2DSFrontView = 1
  mc2DSTopView = 2
  mc2DSBackView = 3
  mc2DSSideView = 4
  mc2DSSideLeftView = 5
  mc2DSSideRightView = 6
  mc2DSBottomView = 7
  mc2DSPartialView = 8
  mc2DSSectionView = 9
  mc2DSDetailView = 10
  mc2DSHalfSectionView = 11
  mc2DSHalfSectionVisibleView = 12
  mc2DSAuxiliaryView = 13
End Enum
Members
Members | Description
mc2DSUndefinedView | Indicates the 2D structure view type is undefined.
mc2DSFrontView | Indicates the 2D structure view type is Front View.
mc2DSTopView | Indicates the 2D structure view type is Top View.
mc2DSBackView | Indicates the 2D structure view type is Back View.
mc2DSSideView | Indicates the 2D structure view type is Side View.
mc2DSSideLeftView | Indicates the 2D structure view type is Side-Left View.
mc2DSSideRightView | Indicates the 2D structure view type is Side-Right View.
mc2DSBottomView | Indicates the 2D structure view type is Bottom View.
mc2DSPartialView | Indicates the 2D structure view type is Partial View.
mc2DSSectionView | Indicates the 2D structure view type is Section View.
mc2DSDetailView | Indicates the 2D structure view type is Detail View.
mc2DSHalfSectionView | Indicates the 2D structure view type is Half-Section View.
mc2DSHalfSectionVisibleView | Indicates the 2D structure view type is Section-Visible View.
mc2DSAuxiliaryView | Indicates the 2D structure view type is Auxiliary View.
Links
AcadmAuto Library


McadAnnotationViewDefinition CoClass
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing. Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAnnotationViewDefinition
Visual Basic
Public Class McadAnnotationViewDefinition
Example

Refer to SDK Samples: CreateStructure.dvb

Links
AcadmAuto Library, Example


McadAnnotationViewDefinitions CoClass
Summary

A collection of McadAnnotationViewDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAnnotationViewDefinitions
Visual Basic
Public Class McadAnnotationViewDefinitions
Links
AcadmAuto Library


McadArc CoClass
Summary

An arc curve.

Class Hierarchy

Declaration syntax

AcadmAuto::McadArc
Visual Basic
Public Class McadArc
Links
AcadmAuto Library


McadAttribute CoClass
Summary

Represents an instance of an attribute.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttribute
Visual Basic
Public Class McadAttribute
Links
AcadmAuto Library


McadAttributeField CoClass
Summary

Represents the description of a single attribute field.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributeField
Visual Basic
Public Class McadAttributeField
Links
AcadmAuto Library


McadAttributeFields CoClass
Summary

A collection of McadAttributeField objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributeFields
Visual Basic
Public Class McadAttributeFields
Links
AcadmAuto Library


McadAttributes CoClass
Summary

A collection of McadAttribute objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributes
Visual Basic
Public Class McadAttributes
Links
AcadmAuto Library


McadAugmentedLine CoClass
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAugmentedLine
Visual Basic
Public Class McadAugmentedLine
Links
AcadmAuto Library


McadCollectionType Enumeration
Summary

Enumerates all collection types for which to create the new collection. Some of collection types can only be used in Mechanical Desktop.

mcAttributeFields : Specifies the collection of attribute fields.

mcAttributes : Specifies the collection of attributes.

mcComponentDefinitions : Specifies the collection of component definitions.

mcComponents : Specifies the collection of components.

mcObjects : Specifies the collection of Mcad objects.

mcComponentViews : Specifies the collection of component views.

mcComponentViewDefinitions : Specifies the collection of component view definitions.

mcFolders : Specifies the collection of folders.

mcFolderDefinitions : Specifies the collection of folder definitions.

mcAnnotationViewDefinitions : Specifies the collection of the annotation view definitions.

mcHideSituations : Specifies the collection of normal hide situation objects.

mcComplexHideSituations : Specifies the collection of complex hide situation objects.

Visual Basic
Public Enum McadCollectionType
  mcAttributeFields = 0
  mcAttributes = 1
  mcComponentDefinitions = 2
  mcComponents = 3
  mcObjects = 4
  mcComponentViews = 5
  mcComponentViewDefinitions = 6
  mcFolders = 7
  mcFolderDefinitions = 8
  mcAnnotationViewDefinitions = 9
  mcHideSituations = 10
  mcComplexHideSituations = 11
End Enum
Links
AcadmAuto Library


McadComplexHideSituation CoClass
Summary

This object provides general methods for 2D structure complex hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComplexHideSituation
Visual Basic
Public Class McadComplexHideSituation
Links
AcadmAuto Library


McadComplexHideSituations CoClass
Summary

A collection of McadComplexHideSituation objects

Class Hierarchy

Declaration syntax

AcadmAuto::McadComplexHideSituations
Visual Basic
Public Class McadComplexHideSituations
Links
AcadmAuto Library


McadComponent CoClass
Summary

References an instance of a component definition in the assembly.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponent
Visual Basic
Public Class McadComponent
Links
AcadmAuto Library


McadComponentDefinition CoClass
Summary

References the definition of an assembly component.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentDefinition
Visual Basic
Public Class McadComponentDefinition
Remarks

From this definition, an instance of it can be created in an assembly. A component instance is represented by an McadComponent object. This component is visible as a node in the assembly browser. In order to have a representation of this visible in model space, one of its associated component view definitions must be instanced. This instantiation is known as a component view. A component view instance is represented by an McadComponentView object.

Links
AcadmAuto Library


McadComponentDefinitions CoClass
Summary

A collection of McadcomponentDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentDefinitions
Visual Basic
Public Class McadComponentDefinitions
Links
AcadmAuto Library


McadComponents CoClass
Summary

A collection of McadComponent objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponents
Visual Basic
Public Class McadComponents
Links
AcadmAuto Library


McadComponentView CoClass
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentView
Visual Basic
Public Class McadComponentView
Links
AcadmAuto Library


McadComponentViewDefinition CoClass
Summary

References the definition of a component view.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDefinition
Visual Basic
Public Class McadComponentViewDefinition
Remarks

Each component view definition has an associated component definition. The component view definition defines a particular view of a component definition. From this component view definition, an instance of it can be created in an assembly. The definition itself is not visible in the model; only instances of it are visible. It is important to note that a component view definition can exist without any component view instances referencing it in the assembly. The relationship between McadComponentViewDefinition and McadComponentView objects is similar to that of the AutoCAD Block and BlockRef objects.

Links
AcadmAuto Library


McadComponentViewDefinitions CoClass
Summary

A collection of McadComponentViewDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDefinitions
Visual Basic
Public Class McadComponentViewDefinitions
Links
AcadmAuto Library


McadComponentViewDescriptor CoClass
Summary

Encapsulates the description of a 2D component view.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDescriptor
Visual Basic
Public Class McadComponentViewDescriptor
Links
AcadmAuto Library


McadComponentViews CoClass
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViews
Visual Basic
Public Class McadComponentViews
Links
AcadmAuto Library


McadDocDrawingType Enumeration
Summary

type McadDocDrawingType

Visual Basic
Public Enum McadDocDrawingType
  mcAcad = 0
  mcAcadM = 2
  mcAcadMStruct = 3
  mcMDT = 4
  mcMDTPart = 5
  mcInventorLink = 6
  mcUndefined = 7
End Enum
Links
AcadmAuto Library


McadDocument CoClass
Summary

The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.

Class Hierarchy

Declaration syntax

AcadmAuto::McadDocument
Visual Basic
Public Class McadDocument
Links
AcadmAuto Library


McadDocuments CoClass
Summary

The collection of McadDocument objects present in the application.

Class Hierarchy

Declaration syntax

AcadmAuto::McadDocuments
Visual Basic
Public Class McadDocuments
Links
AcadmAuto Library


McadEllipse CoClass
Summary

An ellipse or elliptical arc object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadEllipse
Visual Basic
Public Class McadEllipse
Links
AcadmAuto Library


McadFieldType Enumeration
Summary

Enumerates the field value types.

mcShort : Indicates the field value is Short.

mcLong : Indicates the field value is Long.

mcDouble : Indicates the field value is a Double.

mcCharacter : Indicates the field value is Character.

mcShortArray : Indicates the field value is Array of Short.

mcLongArray : Indicates the field value is Array of Long.

mcDoubleArray : Indicates the field value is Array of Double.

mcString : Indicates the field value is String.

mcObjectID : Indicates the field value is Object ID.

mcObjectIDArray : Indicates the field value is Array of Object IDs.

mcMcadObject : Indicates the field value is Object.

mcMcadObjectArray : Indicates the field value is Array of Objects.

Visual Basic
Public Enum McadFieldType
  mcShort = 0
  mcLong = 1
  mcDouble = 2
  mcCharacter = 3
  mcShortArray = 4
  mcLongArray = 5
  mcDoubleArray = 6
  mcString = 7
  mcObjectID = 8
  mcObjectIDArray = 9
  mcMcadObject = 10
  mcMcadObjectArray = 11
End Enum
Links
AcadmAuto Library


McadFolder CoClass
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolder
Visual Basic
Public Class McadFolder
Links
AcadmAuto Library


McadFolderDefinition CoClass
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDefinition
Visual Basic
Public Class McadFolderDefinition
Links
AcadmAuto Library


McadFolderDefinitions CoClass
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDefinitions
Visual Basic
Public Class McadFolderDefinitions
Links
AcadmAuto Library


McadFolderDescriptor CoClass
Summary

Encapsulates the description of a folder.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDescriptor
Visual Basic
Public Class McadFolderDescriptor
Links
AcadmAuto Library


McadFolders CoClass
Summary

A collection of McadFolder objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolders
Visual Basic
Public Class McadFolders
Links
AcadmAuto Library


McadFormulaEvaluator CoClass
Summary

This object provides general methods for Standard Data provider

Class Hierarchy

Declaration syntax

AcadmAuto::McadFormulaEvaluator
Visual Basic
Public Class McadFormulaEvaluator
Links
AcadmAuto Library


McadHideSituation CoClass
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadHideSituation
Visual Basic
Public Class McadHideSituation
Links
AcadmAuto Library


McadHideSituationRefType Enumeration
Summary

Enumerates all referenced types for this hide situation.

mc2DSDirectRef : Indicates that the leaf or view instance is directly referred by hide situation.

mc2DSSubEntRef : Indicates that the leaf or view instance of a subentity of the view is referenced by hide situation.

mc2DSPartialRef : Indicates that the view instance is partially or fully referred by hide situation.

mc2DSAllRef : It is equivalent to mc2DSDirectRef | mc2DSSubEntRef.

Visual Basic
Public Enum McadHideSituationRefType
  mc2DSDirectRef = &H0001
  mc2DSSubEntRef = &H0002
  mc2DSPartialRef = &H0004
  mc2DSAllRef = mc2DSDirectRef|mc2DSSubEntRef
End Enum
Links
AcadmAuto Library


McadHideSituations CoClass
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadHideSituations
Visual Basic
Public Class McadHideSituations
Links
AcadmAuto Library


McadHideSituationSubentType Enumeration
Summary

Enumerates all referenced hide subentity types for this hide situation.

mc2DSNoEnt : Indicates that there are no subentities.

mc2DSFGEnt : Indicates the foreground hide situation.

mc2DSBGEnt : Indicates the background hide situation.

mc2DSFGExclEnt : Indicates the foreground excluded hide situation.

mc2DSBGExclEnt : Indicates the background excluded hide situation.

mc2DSUpperBGExclEnt : Indicates the upper background excluded hide situation.

Visual Basic
Public Enum McadHideSituationSubentType
  mc2DSNoEnt = 0
  mc2DSFGEnt = 1
  mc2DSBGEnt = 2
  mc2DSFGExclEnt = 4
  mc2DSBGExclEnt = 8
  mc2DSUpperBGExclEnt = 16
End Enum
Links
AcadmAuto Library


McadLayerCfg CoClass
Summary

This is class AcadmAuto::McadLayerCfg.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerCfg
Visual Basic
Public Class McadLayerCfg
Links
AcadmAuto Library


McadLayerCfgs CoClass
Summary

This is class AcadmAuto::McadLayerCfgs.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerCfgs
Visual Basic
Public Class McadLayerCfgs
Links
AcadmAuto Library


McadLayerGroupMgr CoClass
Summary

Provides access to methods and properties used to manage layers in documents.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerGroupMgr
Visual Basic
Public Class McadLayerGroupMgr
Links
AcadmAuto Library


McadLayerObjectCfg CoClass
Summary

This is class AcadmAuto::McadLayerObjectCfg.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectCfg
Visual Basic
Public Class McadLayerObjectCfg
Links
AcadmAuto Library


McadLayerObjectCfgs CoClass
Summary

This is class AcadmAuto::McadLayerObjectCfgs.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectCfgs
Visual Basic
Public Class McadLayerObjectCfgs
Links
AcadmAuto Library


McadLayerObjectHideType Enumeration
Summary

This is record McadLayerObjectHideType.

Visual Basic
Public Enum McadLayerObjectHideType
  mcDontHide = &H00
  mcHideBg = &H01
  mcHideFg = &H02
  mcHideFgBg = &H03
End Enum
Links
AcadmAuto Library


McadLayerObjectMgr CoClass
Summary

This is class AcadmAuto::McadLayerObjectMgr.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectMgr
Visual Basic
Public Class McadLayerObjectMgr
Links
AcadmAuto Library


McadLine CoClass
Summary

An unbounded line object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLine
Visual Basic
Public Class McadLine
Links
AcadmAuto Library


McadObjects CoClass
Summary

A collection of IMcadObject subtype objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadObjects
Visual Basic
Public Class McadObjects
Links
AcadmAuto Library


McadObjectType Enumeration
Summary

Enumerates all generic objects within the Mechanical Desktop or AutoCAD.

mcObject : Specifies the McadObject type of the object.

mcGeometry : Specifies the McadObject type of the geometry.

mcCurve : Specifies the McadObject type of the curve.

mcLine : Specifies the McadObject type of the line.

mcArc : Specifies the McadObject type of the arc.

mcEllipse : Specifies the McadObject type of the ellipse.

mcSpline : Specifies the McadObject type of the spline.

mcPolyline : Specifies the McadObject type of the polyline.

mcAaugmentedLine : Specifies the McadObject type of the augmented line.

mcComponent : Specifies the McadObject type of the component.

mcComponentDefinition : Specifies the McadObject type of the component definition.

mcComponentView : Specifies the McadObject type of the component view.

mcComponentViewDefinition : Specifies the McadObject type of the component view definition.

mcFolder : Specifies the McadObject type of the folder.

mcFolderDefinition : Specifies the McadObject type of the folder definition.

mcAnnotationViewDefinition : Specifies the McadObject type of the annotation view definition.

Visual Basic
Public Enum McadObjectType
  mcObject = 0
  mcGeometry = 1
  mcCurve = 2
  mcLine = 3
  mcArc = 4
  mcEllipse = 5
  mcSpline = 6
  mcPolyline = 7
  mcAaugmentedLine = 8
  mcComponent = 9
  mcComponentDefinition = 10
  mcComponentView = 11
  mcComponentViewDefinition = 12
  mcFolder = 13
  mcFolderDefinition = 14
  mcAnnotationViewDefinition = 15
End Enum
Links
AcadmAuto Library


McadPhantomState Enumeration
Summary

Enumerates all phantom states.

mcNormalDef : Specifies the normal state, with a value of 0.

mcPhantomDef : Specifies the phantom state, with a value of 1.

mcPhantomDefInCurrent : Specifies the phantom state in the current drawing, with a value of 2.

Visual Basic
Public Enum McadPhantomState
  mcNormalDef = 0
  mcPhantomDef = 1
  mcPhantomDefInCurrent = 2
End Enum
Links
AcadmAuto Library


McadPick CoClass
Summary

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPick
Visual Basic
Public Class McadPick
Remarks

The McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties. Using a pick object it is possible to get the subentity paths, pick point (point used for selection of entity) pick vector type of object, and so on.

Links
AcadmAuto Library


McadPolyline CoClass
Summary

A polyline object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPolyline
Visual Basic
Public Class McadPolyline
Links
AcadmAuto Library


McadPowerObjectType Enumeration
Summary

Enumerates the power object types.

mcNoObj : Specifies no power object.

mcShaftCalcObj : Specifies the shaft calculation power object.

mcCamCalcObj : Specifies the cam calculation power object.

mcFEAObj : Specifies the FEA power object.

mcMomOfInertiaObj : Specifies the momentum of inertia power object.

mcDeflLineObj : Specifies the line power object.

mcScrewConObj : Specifies the screw connection of the power object.

mcPartFeatObj : Specifies the part feature power object.

mcShaftObj : Specifies the shaft power object.

mcAllFolderPowerObj : Specifies the all folders power object.

Visual Basic
Public Enum McadPowerObjectType
  mcNoObj = &H00000000
  mcShaftCalcObj = &H00000001
  mcCamCalcObj = &H00000002
  mcFEAObj = &H00000004
  mcMomOfInertiaObj = &H00000008
  mcDeflLineObj = &H00000010
  mcScrewConObj = &H00000020
  mcPartFeatObj = &H00000040
  mcShaftObj = &H00000080
  mcAllFolderPowerObj = mcShaftCalcObj|mcCamCalcObj|mcFEAObj|mcMomOfInertiaObj|mcDeflLineObj
End Enum
Links
AcadmAuto Library


McadPowObjViewGroupDescriptor CoClass
Summary

Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPowObjViewGroupDescriptor
Visual Basic
Public Class McadPowObjViewGroupDescriptor
Links
AcadmAuto Library


McadSelectionOrderOption Enumeration
Summary

Enumerates all available 2D Structure selection order options.

Visual Basic
Public Enum McadSelectionOrderOption
  mcTopDown = 0
  mcBottomUp = 1
End Enum
Members
Members | Description
mcTopDown | Value 0. Specifies that the 2D Structure selection order is from top to bottom.
mcBottomUp | Value 1. Specifies that the 2D Structure selection order is from bottom to top.
Links
AcadmAuto Library


McadSpline CoClass
Summary

A spline object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadSpline
Visual Basic
Public Class McadSpline
Links
AcadmAuto Library


McadStdPartComponentViewDescriptor CoClass
Summary

Encapsulates the description of a component view of a standard part.

Class Hierarchy

Declaration syntax

AcadmAuto::McadStdPartComponentViewDescriptor
Visual Basic
Public Class McadStdPartComponentViewDescriptor
Links
AcadmAuto Library


McadTransaction CoClass
Summary

The McadTransaction object. These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.

Class Hierarchy

Declaration syntax

AcadmAuto::McadTransaction
Visual Basic
Public Class McadTransaction
Remarks

To end a transaction, set the transaction object to Null. Nested transactions are not supported. To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete. To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.

Links
AcadmAuto Library


McadUtility CoClass
Summary

This API provides some general utility methods.

Class Hierarchy

Declaration syntax

AcadmAuto::McadUtility
Visual Basic
Public Class McadUtility
Links
AcadmAuto Library


SymBBAuto Library
Summary

The Autodesk SymBBAuto Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided.

CoClasses
Name | Description
McadAnnotationViewLabel | Annotation view label entity.
McadAnnotationViewStandard | Annotation view label standard.
McadBalloon | A balloon symbol object
McadBalloons | A collection of McadBalloon objects
McadBalloonStandard | The balloon standards for a bill of materials symbol standard.
McadBOM | A bill of materials database object.
McadBOMItem | A bill of materials item or row object
McadBOMItems | A collection of McadBOMItem objects
McadBOMMgr | A bill of materials manager object
McadBOMs | A collection of McadBOM objects
McadBOMStandard | A bill of materials symbol standard object
McadBorder | This object represents the drawing border of the title/border created in the drawing.
McadColumnDefinition | Stores the BOM column definition information.
McadColumnDefinitions | A collection of McadColumnDefinition objects
McadDatumIdentifier | Implements datum identifier symbols.
McadDatumStandard | A datum target symbol standard
McadDatumTarget | A datum target symbol
McadDetailSymbol | This object represents the detail symbol created in the drawing.
McadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
McadDetailSymbolStandard | This object represents the Detail symbol standard.
McadEdge | This object represents the edge symbol created in the drawing.
McadEdgeLibrary | This is class SymBBAuto::McadEdgeLibrary.
McadEdgeLibraryObject | This is class SymBBAuto::McadEdgeLibraryObject.
McadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
McadFCFLibrary | This is class SymBBAuto::McadFCFLibrary.
McadFCFLibraryObject | This is class SymBBAuto::McadFCFLibraryObject.
McadFCFStandard | A feature control frame symbol standard
McadFeatureControlFrame | Implements feature control frame symbols.
McadFeatureIdentifier | A feature identifier symbol
McadIdentifier | Implements functionalty common to Datum Identifier symbols and Feature Identifier symbols.
McadIdentifierStandard | Defines the drafting standard settings for Datym and Feature Identifier symbols.
McadJoint | This is class SymBBAuto::McadJoint.
McadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
McadMarkStamp | A marking or stamping symbol
McadMarkStampStandard | A marking/stamping symbol standard
McadNote | This object represents the Note symbol created in the drawing.
McadNoteStandard | This object represents the Note symbol standard.
McadPartList | A part list symbol
McadPartListBalloonedFilter | A filter object that filters the contents of a parts List by ballooned parts.
McadPartListCustomFilter | A filter object that filters the contents of a parts list by a BOM property.
McadPartListFilter | An object that filters the contents of a parts list
McadPartListFilters | A collection of McadPartListFilter objects
McadPartListGOST | A part list object
McadPartLists | A collection of McadPartList objects
McadPartListStandard | The part list-specific information of a bill of materials symbol standard
McadPartListStdPartsFilter | A filter object that filters the contents of a parts list by Standard parts.
McadPartReference | A part reference symbol
McadPartReferences | This is class SymBBAuto::McadPartReferences.
McadRevisionList | This object represents the revision list created in the drawing. The interface is IMcadRevisionList.
McadRevisionListDescriptor | This object contains all data associated with a revision list.
McadRevisionLists | This object is a collection of revision list objects.
McadRevisionMgr | This object is used for general functionality of revision lists.
McadScaleArea | This object represents the scale area created in the model space.
McadScaleAreaMgr | This object is used to create and find a scale area in the model space.
McadSectionLine | The object represents the section line creating in the drawing.
McadSectionLineStandard | This object represents the standard.
McadStandard | This existing object represents the standard.
McadStandardMgr | The symbol standards manager object
McadStandards | A collection of McadStandard objects
McadSurfaceTexture | A surface texture symbol
McadSurfaceTextureLibrary | This is the object representing the surface texture library.
McadSurfaceTextureLibraryObject | Implements the IMcadSurfaceTextureLibraryObject interface.
McadSurfaceTextureStandard | A surface texture symbol standard
McadSymbol | A symbol object.
McadSymbolBBMgr | This existing object is the main manager object in SymBBAuto.
McadSymbolLibrary | Implements the IMcadSymbolLibrary interface.
McadSymbolLibraryObject | Implements the IMcadSymbolLibraryObject interface.
McadSymbolLibraryObjects | Implements the IMcadSymbolLibraryObjects interface.
McadSymbolStandard | A symbol standard.
McadSymbolStandards | A collection of McadSymbolStandard objects
McadTaper | This object represents the taper symbol created in the drawing.
McadTaperStandard | This object represents the Taper and Slope symbol standard.
McadTitle | This object represents the title block of the title/border created in the drawing.
McadTitleBorder | This object represents the title/border created in the drawing.
McadTitleBorderContext | This new object contains all option settings associated with a title/border.
McadTitleBorderDescriptor | This object contains all data associated with a title/border.
McadTitleBorderMgr | This object is used for general functionality for title/border.
McadTitleBorders | This object is a collection of title/border objects.
McadTitleBorderStandard | This object represents the Drawing Sheet standard element.
McadWelding | Implements weld symbols.
McadWeldingLibrary | Implements the IMcadWeldingLibraryObject interface.
McadWeldingLibraryObject | Implemented the IMcadWeldingLibraryObject.
McadWeldingStandard | A weld symbol standard.
Enumerations
Name | Description
McadAlignmentType | Enumerates all available alignment types for a drawing document element, such as captions and data in a column of a BOM database.
McadAnnotViewLabelPositionType | McadAnnotViewLabelPositionType defines position of annotation view label.
McadArrowType | Enumerates all available arrow types for a symbol leader. sbNoArrow : Indicates that no arrow is attached to the symbol leader. sbArrowOpen : Indicates that the open arrow is attached to the symbol leader. sbArrowOpen15 : Indicates that the open 15-degree arrow is attached to the symbol leader. sbArrowOpen30 : Indicates that the open 30-dergee arrow is attached to the symbol leader. sbArrowOpen60 : Indicates that the open 60-degree arrow is attached to the symbol leader. sbArrowOpen90 : Indicates that the open 90-degree arrow is attached to the symbol leader. sbArrowEmpty : Indicates that the empty arrow is attached to... more
McadAttachmentPoint | Enumerates all available points for attaching a leader to symbols. sbTopLeft : Places the leader to the top-left of symbols. sbBottomLeft : Places the leader to the bottom-left of symbols. sbBottomRight : Places the leader to the bottom-right of symbols. sbTopRight : Places the leader to the top-right of symbols.
McadAttachmentType | Enumerates all available leader attachment point types for symbols. sbToCenter : Attaches the leader to the center of symbols. sbToExtents : Attaches the leader to the extents of symbols. sbToOrigin : Attaches the leader to the origin of symbols in the coordinate system.
McadAttachPosition | This is record McadAttachPosition.
McadAttributeAssociativity | Enumerates all available behaviors of the attribute when the object that the attribute is attached to is copied. mcDefault : If the McadAttributeAssociativity element is not specified in pertinent methods, the default associativity behavior is used. mcCopyAlways : Indicates this attribute is always copied. mcShareAlways : Indicates this attribute is always shared. mcIgnoreAlways : Indicates this attribute is always ignored.
McadBalloonCollectionType | Enumerates all available alignment types of collected balloons for selected part references. The orientation of collected balloons depends on the position of the last leader segment. sbHorizontal : Aligns collected balloons horizontally. sbVertical : Aligns collected balloons vertically.
McadBalloonType | Enumerates all available balloon patterns that can be used to override when creating new balloon symbols by a specific standard. sbByStandardBalloon : Sets the standard option as the balloon pattern in a drawing document. The standard balloon is defined by the drawing manager. sbNoBalloon : Sets the open option as the balloon pattern in a drawing document. sbCircularBalloon : Sets the predefined Circular option as the balloon pattern in a drawing document. sbCircular2Balloon : Sets the predefined Circular2 option as the balloon pattern in a drawing document. sbLinearBalloon : Sets the predefined Linear option as the balloon pattern in a... more
McadBOMExportFormatType | Enumerates all available BOM table export formats. exTXT : Indicates the export format of text separated with tabulator. exCSV : Indicates the export format of text separated with semicolon. exHTML : Indicates the export format of HTML. exMDB : Indicates the export format of the current Microsoft Access. exMDB97 : Indicates the export format of Microsoft Access 97. exEXCEL97 : Indicates the export format of Microsoft Excel 97. exEXCEL95 : Indicates the export format of Microsoft Excel 95. exDB5 : Indicates the export format of dBase 5. exDBIV : Indicates the export format of dBase IV. exDBIII : Indicates the... more
McadBOMImportFormatType | Enumerates all available BOM table import formats. imMDB : Indicates the import format of the current Microsoft Access. imEXCEL97 : Indicates the import format of Microsoft Excel 97. imEXCEL95 : Indicates the import format of Microsoft Excel 95. imDB5 : Indicates the export format of dBase 5. imDBIV : Indicates the export format of dBase IV. imDBIII : Indicates the export format of dBase III. imimFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0. imFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6. imFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5. imTXT :... more
McadBOMItemDefinitionType | Enumerates all available BOM item definition types. Unknown : Indicates that the BOM item definition type is unknown. NonModal : Indicates that the BOM item definition type is User-Defined. PartRef : Indicates that the BOM item definition type is AutoCAD Mechanical Part Reference. BlockDef : Indicates that the BOM item definition type is Block Definition. CompDef : Indicates that the BOM item definition type is AutoCAD Mechanical/Mechanical Desktop Component Definition.
McadBomOverrideType |
McadBOMUOMType | Enumerates all available BOM UOM (Unit of Measurement) types. Each : Indicates that the BOM UOM type is per item. sqm : Indicates that the BOM UOM type is per each square meter. sqcm : Indicates that the BOM UOM type is per each square centimeter. sqft : Indicates that the BOM UOM type is per each square foot. sqin : Indicates that the BOM UOM type is per each square inch. gal : Indicates that the BOM UOM type is per gallon qt : Indicates that the BOM UOM type is per qt. lqd_oz : Indicates that the BOM... more
McadColumnSplitStyle | Enumerates all available column split styles for a Parts List. sbSplitRows : Specifies that a Parts List is split by rows in a column split. sbSplitSections : Specifies that a Parts List is split by sections in a column split.
McadColumnSplitWrap | Enumerates all available column split wrap directions for a Parts List. sbSplitLeft : Specifies that a Parts List wraps to the left in a column split. sbSplitRight : Specifies that a Parts List wraps to the right in a column split.
McadColumnType | Enumerates all column types available in this BOM database for drawing documents. This ColumnType element is the internal name of the column attribute. sbPartID : Specifies the object ID of this BOM item. sbItem : Specifies the item number for this BOM item. sbQuantity : Specifies the quantity of part references for this BOM item. sbPartListName : Specifies the parts list name that is created from this BOM database. sbPartListPath : Specifies the path to store the parts list that is created from this BOM database. sbDescription : Specifies the supplementary data for this BOM database. sbDescription2 : Specifies the... more
McadDataType | Enumerates all data types that can be used for columns in this BOM database. sbGeneralText : Sets the general text as the data type for columns in this BOM database. sbInteger : Sets Integer as the data type for columns in this BOM database. sbReal : Sets Real as the data type for columns in this BOM database.
McadDetailSymbolStandardPropType | Enumerates the property types for detail view standard that can be set to ByStandard.
McadDirectionLayType | Enumerates all available directions of machining lay specifications for a surface texture symbol in a drawing document. sbNotSpecified : No directions of machining lay specifications are available. sbParallelToPlane : Sets Parallel to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbPerpendicularToPlane : Sets Perpendicular to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbCrossedIn2SlantDirections : Sets Angular in Both Directions for the direction of machining lay specification of a surface texture symbol. sbMultiDirection : Sets Multidirectional for the direction of machining lay specification of a surface... more
McadEdgeRequirement | Enumerates all available requirements for Edge library object.
McadFCFRequirement | Enumerates all available requirements for FCF library object.
McadFilterOperator | Enumerates all available filter operator for a Parts List custom filter. sbContains : Specifies a "contains" operator. sbDoesNotCont : Specifies a "does not contain" operator. sbEqual : Specifies a "equal" operator. sbNotEqual : Specifies a "not equal" operator. sbLess : Specifies a "less than" operator sbGreater : Specifies a "greater than" operator. sbLessEqual : Specifies a "less than or equal" operator. sbGreaterEqual : Specifies a "greater than or equal" operator.
McadFilterType | Enumerates all available filter types for a Parts List. sbFilterBasic : Specifies a basic filter type for a Parts List. sbFilterBallooned : Specifies a filter that filters the contents of a Parts List by ballooned parts. sbFilterCustom : Specifies a filter that filters the contents of a Parts List by a BOM property. sbFilterParts : Specifies a filter that filters the contents of a Parts List by selected parts. sbFilterStdParts : Specifies a filter that filters the contents of a Parts List by Standard parts. sbFilterSheet : Specifies a filter that filters the contents of a Parts List by a... more
McadGDTSymbolType | Enumerates all symbol types available for a feature control frame symbol. All the enumeration symbol types can be rolled into two groups: Geometric Characteristic and Material Removal Modifier. sbStraightness : Sets Straightness as the GDT symbol type for a feature control frame symbol. sbFlatness : Sets Flatness as the GDT symbol type for a feature control frame symbol. sbCircularity : Sets Circularity as the GDT symbol type for a feature control frame symbol. sbCylindricity : Sets Cylindricity as the GDT symbol type for a feature control frame symbol. sbProfileLine : Sets Profile of a Line as the GDT symbol type... more
McadIdentificationType | Enumerates all available types of identification line used for a weld symbol. Identification lines are not available for ANSI standard. sbNoIdentificationLine : Places no identification line on either the arrow side or the other side for a weld symbol. sbIdentificationOtherSide : Places the identification line on the other side of the arrow. sbIdentificationArrowSide : Places the identification line on the arrow side.
McadIdentifierPositionType | Enumerates the identifier position type for section line.
McadJointType |
McadLineVisibility | Enumerates the available line visibility types.
McadNoteAttachPointType | Enumerates all available note attach point types.
McadNoteTemplateGroupType | Enumerator for note template group type.
McadOrientation | Enumerates all available orientations of welding symbol elements. sbLeftSide : Places a weld tail to the left of the arrow. sbRightSide : Places a weld tail to the right of the arrow. sbBelow : Place symbols on the arrow side upward the weld tail. sbAbove : Place symbols on the other side of the arrow upward the weld tail.
McadScaleType | Enumerator for scale type.
McadSectionLineSegmentType | Enumerates the available line segment types.
McadSectionLineStandardPropType | Enumerates the property types for section view standard, which can be set to ByStandard.
McadStdPartsFilterOption | Enumerates all available filter options for a Parts List Standard parts filter. sbStdPartsOnly : Specifies a Standard parts filter that filters the contents of a Parts List by Standard parts. sbExcludeStdParts : Specifies a Standard parts filter that filters the contents of a Parts List by non-Standard parts.
McadSurfaceTextureRequirement | Surface Texture Requirement information. sbSurfTextRaMax : Roughness value Ra sbSurfTextRaMin : Roughness value Ra - minimum sbSurfTextProduction : Production method sbSurfTextProduction2 : Production method sbSurfTextAllowance : Finish allowance sbSurfTextDirLay : Direction of lay sbSurfTextSampLength : Sampling length or waviness height sbSurfTextCutoff : Cutoff value and evaluation length sbSurfTextOtherValue : Other roughness value sbSurfTextOtherMin : Other roughness minimum value sbSurfTextMaxRspac : Maximum spacing sbSurfTextReference : Reference length and evaluation length sbSurfTextWavines : Surface waviness sbSurfTextComment : Comment sbSurfTextFirstRequirement : First requirement sbSurfTextSecondRequirement : Second requirement sbSurfTextThirdRequirement : Third requirement
McadSurfaceTextureType | Enumerates all available surface types for a surface texture symbol. sbBasic : Set the Basic surface type for a surface texture symbol. sbRemovalOfMaterialRequired : Set the Removal of Material Required surface type for a surface texture symbol. sbRemovalOfMaterialProhibited : Set the Removal of Material Prohibited surface type for a surface texture symbol. sbRemovalAllowanceSpecified : Set the Removal of Allowance Specified surface type for a surface texture symbol.
McadSymBBSymbolLibraryType | Enumerates the available Symbol Library Type.
McadTaperDimensionType | Enumerates the available taper dimension type.
McadTaperRatioFormatType | Enumerates the available ratio format type.
McadTaperSlopeSymType | Enumerator for taper slope symbol type.
McadTargetType | Enumerates all available termination types for a datum target symbol. sbNoTarget : Set the None termination type for a datum target symbol. sbBalloon : Not implemented yet. Set the None termination type for a datum target symbol. sbPoint : Set the None termination type for a datum target symbol. sbLine : Set the None termination type for a datum target symbol. sbCircular : Set the None termination type for a datum target symbol. sbRectangular : Set the None termination type for a datum target symbol. sbAttach : Set the None termination type for a datum target symbol.
McadTextControl | Enumerates all available text controls for a Parts List. sbNone : Specifies that a Parts List text is not controlled. The text overruns the column width when the length of the text exceeds the column width. sbFit : Specifies that a Parts List text fits within the column when the length of the text exceeds the column width. sbWrap : Specifies that a Parts List text wraps to the next line when the length of the text exceeds the column width.
McadUndefinedSize | Enumerates the undefined size's cases for edge symbol
McadUndefinedSizeDirection | Enumerates the undefined size's direction for edge symbol
McadViewDefLockType | Enumerates the lock type of the folder definition or component view definition in mechanical structure. mc2DSNoLock : Specifies no lock in mechanical structure. mc2DSXrefLock : Specifies the lock of the Xref objects in mechanical structure. mc2DSStdPartLock : Specifies the lock of standard parts in mechanical structure. mc2DSUserLock : Specifies the user-defined lock in mechanical structure.
McadWeldAssociation | Enumerates all available association types between two fillet weld symbols for the staggered weldment. sbNoAssociation : Sets no association. sbAssociationSpacer : Space the fillet symbols. sbAssociationMoveStagger : Staggers the fillet symbols. sbAssociationMirrorStagger : Mirrors the fillet symbols. sbAssociationSpecialStagger : Staggers the fillet symbols in a special way. sbAssociationBacking : Back the fillet symbols.
McadWeldingRequirement | Enumerates the available Weld requirements variable.
McadWeldSymbolType | Enumerates all available weld symbol types for a weld symbol standard. All the enumeration weld symbol types can be rolled into three groups: Weld Symbols, Contour Symbols, and Backing Symbols. A weld symbol type may use different signs in different standard, such as ANSI, BSI, and ISO. sbNoSymbol : Sets no weld symbol type for a weld symbol standard. sbFilletWeld : Sets the Fillet Weld symbol type for a weld symbol standard. Available for ANSI sbSecondaryFillet : Sets the Secondary Fillet Weld symbol type for a weld symbol standard. sbPlugWeld : Sets the Plug Weld symbol type for a weld... more
Interfaces
Name | Description
IMcadAnnotationViewLabel | Annotation view label entity.
IMcadAnnotationViewStandard | Annotation view label standard.
IMcadBalloon | A balloon symbol object.
IMcadBalloons | A collection of McadBalloon objects.
IMcadBalloonStandard | The balloon standards for a bill of materials symbol standard.
IMcadBalloonStandard2 | The balloon standards for a bill of materials symbol standard.
IMcadBOM | A bill of materials database object.
IMcadBOM2 | A bill of materials database object.
IMcadBOM3 | A bill of materials database object.
IMcadBOM4 | A bill of materials database object.
IMcadBOMItem | A bill of materials item or row object.
IMcadBOMItem2 | A bill of materials item or row object.
IMcadBOMItem3 | A bill of materials item or row object.
IMcadBOMItem4 | A bill of materials item, or row object.
IMcadBOMItems | A collection of McadBOMItem objects
IMcadBOMMgr | A bill of materials manager object
IMcadBOMMgr2 | A bill of materials manager object
IMcadBOMMgr3 | A bill of materials manager object.
IMcadBOMMgr4 | A bill of materials manager object.
IMcadBOMs | A collection of McadBOM objects
IMcadBOMStandard | A bill of materials symbol standard object
IMcadBOMStandard2 | A bill of materials symbol standard object
IMcadBorder | This object represents the drawing border of the title/border created in the drawing.
IMcadBorder2 | This is class IMcadBorder2.
IMcadColumnDefinition | Stores the BOM column definition information.
IMcadColumnDefinition2 | Stores the BOM column definition information.
IMcadColumnDefinition3 | Stores the BOM column definition information.
IMcadColumnDefinitions | A collection of McadColumnDefinition objects
IMcadDatumIdentifier | Implements datum identifier symbols.
IMcadDatumIdentifier2 | This is class IMcadDatumIdentifier2.
IMcadDatumIdentifier3 | This is class IMcadDatumIdentifier3.
IMcadDatumIdentifier4 | This is class IMcadDatumIdentifier4.
IMcadDatumStandard | A datum target symbol standard
IMcadDatumStandard2 | A datum target symbol standard
IMcadDatumTarget | A datum target symbol
IMcadDatumTarget2 | A datum target symbol.
IMcadDetailSymbol | This object represents the detail symbol created in the drawing.
IMcadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
IMcadDetailSymbolStandard | This object represents the Detail symbol standard.
IMcadDetailSymbolStandard2 | This interface is derived from IMcadDetailSymbolStandard. It is used for the detail view standard.
IMcadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
IMcadEdge | This object represents the edge symbol created in the drawing.
IMcadEdgeLibrary | The object representing Edge library.
IMcadEdgeLibraryObject | The Edge library object.
IMcadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
IMcadFCFLibrary | Object representing the Feature Control Frame library.
IMcadFCFLibraryObject | The Feature Control Frame library object.
IMcadFCFStandard | A feature control frame symbol standard
IMcadFCFStandard2 | This is class IMcadFCFStandard2.
IMcadFeatureControlFrame | Implemets feature control frame symbols.
IMcadFeatureControlFrame2 | IMcadFeatureControlFrame extended interface.
IMcadFeatureControlFrame3 | This is class IMcadFeatureControlFrame3.
IMcadFeatureControlFrame4 | This is class IMcadFeatureControlFrame4.
IMcadFeatureIdentifier | A feature identifier symbol.
IMcadFeatureIdentifier2 | This is class IMcadFeatureIdentifier2.
IMcadIdentifier | An identifier symbol
IMcadIdentifierStandard | An identifier symbol standard
IMcadIdentifierStandard2 | This is class IMcadIdentifierStandard2.
IMcadJoint | The IMcadJoint interface.
IMcadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
IMcadMarkStamp | Interface for working with the Marking/Stamping symbol created in the drawing.
IMcadMarkStampStandard | Interface for working with the Marking/Stamping symbol standard.
IMcadNote | This object represents the Note symbol created in the drawing.
IMcadNoteStandard | This object represents the Note symbol standard.
IMcadPartList | A part list symbol.
IMcadPartList2 | A part list symbol.
IMcadPartList3 | Stores the Parts List symbol settings information.
IMcadPartListBalloonedFilter | A filter object that filters the contents of a Parts List by ballooned parts.
IMcadPartListCustomFilter | A filter object that filters the contents of a Parts List by a BOM property.
IMcadPartListFilter | An object that filters the contents of a parts list.
IMcadPartListFilter2 | An object that filters the contents of a parts list.
IMcadPartListFilters | A collection of McadPartListFilter objects
IMcadPartListGOST | Interface for interacting with the GOST part list created in the drawing.
IMcadPartLists | A collection of McadPartList objects
IMcadPartListStandard | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard2 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard3 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard4 | Stores the Parts List standard setting information.
IMcadPartListStdPartsFilter | A filter object that filters the contents of a Parts List by Standard parts.
IMcadPartReference | A part reference symbol.
IMcadPartReference2 | A part reference symbol.
IMcadPartReference3 | A part reference symbol.
IMcadPartReferences | This is class IMcadPartReferences.
IMcadRevisionList | Interface that represents the revision list created in the drawing.
IMcadRevisionListDescriptor | Interface for interacting with all data associated with a revision list.
IMcadRevisionLists | Interface for working with a collection of revision list objects.
IMcadRevisionMgr | Interface for working with the general functionality of a revision list.
IMcadScaleArea | This object represents the scale area created in the model space.
IMcadScaleAreaMgr | This object is used to create and find a scale area in the modelspace.
IMcadSectionLine | The object represents the section line creating in the drawing.
IMcadSectionLineStandard | Interface for working with the standard.
IMcadSectionLineStandard2 | This interface is derived from IMcadSectionLineStandard. It is for the section view standard.
IMcadStandard | This existing object represents the standard.
IMcadStandard2 | This existing object represents the standard.
IMcadStandard3 | This existing object represents the standard.
IMcadStandard4 | This existing object represents the standard.
IMcadStandardMgr | The symbol standards manager object
IMcadStandards | A collection of McadStandard objects
IMcadSurfaceTexture | A surface texture symbol
IMcadSurfaceTexture2 | A surface texture symbol.
IMcadSurfaceTexture3 | This is class IMcadSurfaceTexture3.
IMcadSurfaceTexture4 | A surface texture symbol.
IMcadSurfaceTexture5 | This is class IMcadSurfaceTexture5.
IMcadSurfaceTextureLibrary | This object represents the surface texture library.
IMcadSurfaceTextureLibraryObject | The IMcadSurfaceTextureLibraryObject interface.
IMcadSurfaceTextureStandard | A surface texture symbol standard
IMcadSurfaceTextureStandard2 | A surface texture symbol standard.
IMcadSurfaceTextureStandard3 | A surface texture symbol standard.
IMcadSymbol | A symbol object.
IMcadSymbol2 | A symbol object.
IMcadSymbolBBMgr | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr2 | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr3 | This object is the main manager object in SymBBAuto.
IMcadSymbolLibrary | The IMcadSymbolLibrary interface. The grouping of library object is based on the combination of standard and standard revision type. In each group, there is only one default.
IMcadSymbolLibraryObject | Represents the library of symbol objects.
IMcadSymbolLibraryObjects | The IMcadSymbolLibrary Objects interface.
IMcadSymbolStandard | A symbol standard.
IMcadSymbolStandard2 | A symbol standard.
IMcadSymbolStandard3 | A symbol standard.
IMcadSymbolStandards | A collection of McadSymbolStandard objects
IMcadTaper | This object represents the taper symbol created in the drawing.
IMcadTaperStandard | This object represents the Taper and Slope symbol standard.
IMcadTaperStandard2 | This object represents the Taper and Slope symbol standard.
IMcadTitle | This object represents the title block of the title/border created in the drawing.
IMcadTitle2 | This is class IMcadTitle2.
IMcadTitleBorder | This object represents the title/border created in the drawing.
IMcadTitleBorderContext | This new object contains all option settings associated with a title/border.
IMcadTitleBorderDescriptor | This object contains all data associated with a title/border.
IMcadTitleBorderMgr | This object is used for general functionality for title/border.
IMcadTitleBorders | This object is a collection of title/border objects.
IMcadTitleBorderStandard | This object represents the Drawing Sheet standard element.
IMcadTitleBorderStandard2 | This is class IMcadTitleBorderStandard2.
IMcadTransaction | The McadTransaction object.
IMcadWelding | A weld symbol object
IMcadWelding2 | This is class IMcadWelding2.
IMcadWeldingLibrary | The IMcadWeldingLibrary interface.
IMcadWeldingLibraryObject | The IMcadWeldingLibraryObject interface.
IMcadWeldingStandard | A weld symbol standard.
IMcadWeldingStandard2 | A weld symbol standard.
IMcadWeldingStandard3 | This is class IMcadWeldingStandard3.


IMcadAnnotationViewLabel Interface
Summary

Annotation view label entity.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel
Visual Basic
Public Interface IMcadAnnotationViewLabel
Inherits IMcadSymbol2
Links
IMcadAnnotationViewLabel Members, SymBBAuto Library


IMcadAnnotationViewLabel Members
Summary

The following tables list the members exposed by IMcadAnnotationViewLabel.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelPattern | Property that returns/sets label pattern of annotation view label entity.
LabelText | Property that returns evaluated text defined by label pattern, this text is displayed by annotation view label entity.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadAnnotationViewLabel::LabelPattern Property
Summary

Property that returns/sets label pattern of annotation view label entity.

Visual Basic
Property LabelPattern() As String
Remarks

Label pattern supports variables. List of variables supported by annotation view label standard is accessible by McadAnnotationViewStandard::LabelPatternVariables property.


IMcadAnnotationViewLabel::LabelText Property
Summary

Property that returns evaluated text defined by label pattern, this text is displayed by annotation view label entity.

Visual Basic
Property LabelText() As BSTR*


IMcadAnnotationViewStandard Interface
Summary

Annotation view label standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard
Visual Basic
Public Interface IMcadAnnotationViewStandard
Inherits IMcadSymbolStandard3
Links
IMcadAnnotationViewStandard Members, SymBBAuto Library


IMcadAnnotationViewStandard Members
Summary

The following tables list the members exposed by IMcadAnnotationViewStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LabelPattern | Property that returns/sets default label pattern of annotation view label entity.
LabelPatternVariables | Property that returns array of variables supported in label pattern.
LabelPosition | Property that specifies position of annotation view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadAnnotationViewStandard::LabelPattern Property
Summary

Property that returns/sets default label pattern of annotation view label entity.

Visual Basic
Property LabelPattern() As String
Remarks

Label pattern supports variables. List of variables supported by standard is accessible by McadAnnotationViewStandard::LabelPatternVariables property.


IMcadAnnotationViewStandard::LabelPatternVariables Property
Summary

Property that returns array of variables supported in label pattern.

Visual Basic
Property LabelPatternVariables() As VARIANT*
Remarks

Here is the default list of supported variables:

  • evaluates to component name of annotation view
  • evaluates to the name of annotation view sub view with attached label
  • evaluates to scale of annotation view sub view with attached label
  • evaluates to scale of annotation view


IMcadAnnotationViewStandard::LabelPosition Property
Summary

Property that specifies position of annotation view label.

Visual Basic
Property LabelPosition() As McadAnnotViewLabelPositionType
Remarks

Annotation view label can be placed below or above of annotation view sub view.


IMcadBalloon Interface
Summary

A balloon symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadBalloon
Visual Basic
Public Interface IMcadBalloon
Inherits IMcadSymbol2
Links
IMcadBalloon Members, SymBBAuto Library


IMcadBalloon Members
Summary

The following tables list the members exposed by IMcadBalloon.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AppendBOMItem | Appends the specified BOM item to the collection of items referenced by this balloon.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveBOMItem | Removes the specified bill of materials item from the collection of items referenced by this balloon.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentType | Specifies the leader attachment point type for balloons created by a specific balloon standard.
BalloonType | Specifies the default pattern of balloons created by a specific standard.
BOM | Specifies the bill of materials table referenced by a specific balloon.
BOMItems | Specifies the collection of bill of material items referenced by a specific balloon.
CollectionType | Specifies the alignment type of the balloon's collection.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlock | Specifies the custom block used by a specific balloon.
CustomBlockName | Specifies the name of the custom block used by a specific balloon.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether a specific balloon is displayed using a custom block, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadBalloon::AttachmentType Property
Summary

Specifies the leader attachment point type for balloons created by a specific balloon standard.

Visual Basic
Property AttachmentType() As McadAttachmentType
Remarks

This property is a McadAttachmentType enumeration.


IMcadBalloon::BalloonType Property
Summary

Specifies the default pattern of balloons created by a specific standard.

Visual Basic
Property BalloonType() As McadBalloonType
Remarks

This property is a McadBalloonType enumeration.


IMcadBalloon::BOM Property
Summary

Specifies the bill of materials table referenced by a specific balloon.

Visual Basic
Property BOM() As IMcadBOM**
Remarks

This property is a McadBOM collection.


IMcadBalloon::BOMItems Property
Summary

Specifies the collection of bill of material items referenced by a specific balloon.

Visual Basic
Property BOMItems() As IMcadBOMItems*
Remarks

This property is a McadBOMItems object.


IMcadBalloon::CollectionType Property
Summary

Specifies the alignment type of the balloon's collection.

Visual Basic
Property CollectionType() As McadBalloonCollectionType
Remarks

This property affects the display orientation of the balloons when this balloon references multiple items. Valid alignment types include:

  • sbHorizontal: Sets the alignment of the specific collected balloons to be horizontal.
  • sbVertical: Sets the alignment of the specific collected balloons to be vertical.

This property is a McadBalloonCollectionType enumeration.


IMcadBalloon::CustomBlock Property
Summary

Specifies the custom block used by a specific balloon.

Visual Basic
Property CustomBlock() As IAcadBlock*
Remarks

This property is a cadBlock object.


IMcadBalloon::CustomBlockName Property
Summary

Specifies the name of the custom block used by a specific balloon.

Visual Basic
Property CustomBlockName() As String
Returns

String

Remarks

An empty string, "", is used to indicate to use the standard display.


IMcadBalloon::IsCustomBlockUsed Property
Summary

Gets whether a specific balloon is displayed using a custom block, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

Boolean


IMcadBalloon::AppendBOMItem Method
Summary

Appends the specified BOM item to the collection of items referenced by this balloon.

Visual Basic
Sub AppendBOMItem(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the bill of materials item to append to the collected balloon.
Returns

None

Remarks

You should not call this method more than once when creating a new AcmBalloon object. You should also not call it when editing an existing AcmBalloon object.


IMcadBalloon::RemoveBOMItem Method
Summary

Removes the specified bill of materials item from the collection of items referenced by this balloon.

Visual Basic
Sub RemoveBOMItem(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBalloon Object ; input-only. Specifies the bill of materials item to be removed from the collected balloon.
Returns

None


IMcadBalloons Interface
Summary

A collection of McadBalloon objects.

Class Hierarchy

Declaration syntax

IMcadBalloons
Visual Basic
Public Interface IMcadBalloons
Inherits IDispatch
Links
IMcadBalloons Members, SymBBAuto Library


IMcadBalloons Members
Summary

The following tables list the members exposed by IMcadBalloons.

Methods
Name | Description
Add | Appends a new balloon to the collection.
Item | Gets the specific balloon from the collection.
Remove | Removes the specified balloon from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of balloons in the collection.


IMcadBalloons::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadBalloons::Count Property
Summary

Gets the total number of balloons in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadBalloons::Add Method
Summary

Appends a new balloon to the collection.

Visual Basic
Sub Add(Item As IMcadBalloon)
Parameters
Parameters | Description
Item | McadBalloon object; input-only. Specifies the balloon to add to the collection.
Returns

None


IMcadBalloons::Item Method
Summary

Gets the specific balloon from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBalloon*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the balloon index to return.
Returns

McadBalloon object


IMcadBalloons::Remove Method
Summary

Removes the specified balloon from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the balloon to be removed.
Returns

None


IMcadBalloonStandard Interface
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadBalloonStandard
    IMcadBalloonStandard2
Visual Basic
Public Interface IMcadBalloonStandard
Inherits IDispatch
Links
IMcadBalloonStandard Members, SymBBAuto Library


IMcadBalloonStandard Members
Summary

The following tables list the members exposed by IMcadBalloonStandard.

Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.


IMcadBalloonStandard::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

  • This property is an AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadBalloonStandard::ArrowType Property
Summary

Specifies the leader arrow type for balloon symbols based on this standard.

Visual Basic
Property ArrowType() As McadArrowType
Remarks

This property is a McadArrowType object.


IMcadBalloonStandard::AttachmentType Property
Summary

Specifies the leader attachment point type for the balloons created from this standard.

Visual Basic
Property AttachmentType() As McadAttachmentType
Remarks

This property is a McadAttachmentType enumeration.


IMcadBalloonStandard::AuxiliaryArrowType Property
Summary

Specifies the auxiliary arrow type for balloon symbols created by this standard.

Visual Basic
Property AuxiliaryArrowType() As McadArrowType
Remarks

This property is a McadArrowType enumeration.


IMcadBalloonStandard::BalloonType Property
Summary

Specifies the type of the balloons referencing this standard.

Visual Basic
Property BalloonType() As McadBalloonType
Remarks

This property is a McadBalloonType enumeration.


IMcadBalloonStandard::BOMStandard Property
Summary

Gets the bill of materials standard object referenced by balloons on this balloon standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks

This property is a McadBOMStandard object.


IMcadBalloonStandard::Color Property
Summary

Specifies the color of balloons referencing this standard.

Visual Basic
Property Color() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation documentation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
  • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property. sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadBalloonStandard::ColumnList Property
Summary

Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.

Visual Basic
Property ColumnList() As VARIANT
Remarks

This property is a Variant (array of Longs).


IMcadBalloonStandard::CustomBlockName Property
Summary

Specifies the custom block used for the balloons referencing this standard.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.


IMcadBalloonStandard::IsAuxiliaryArrowUsed Property
Summary

Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.

Visual Basic
Property IsAuxiliaryArrowUsed() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadBalloonStandard::IsCustomBlockUsed Property
Summary

Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadBalloonStandard::MaximumColumns Property
Summary

Specifies the maximum number of columns that can be specified for this BalloonType .

Visual Basic
Property MaximumColumns() As long*
Remarks

This property is a Long.


IMcadBalloonStandard::Revision Property
Summary

Specifies the revision version of this balloon standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.


IMcadBalloonStandard::RevisionYear Property
Summary

Specifies the revision version year of this balloon standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.


IMcadBalloonStandard::TextHeight Property
Summary

Specifies the height of text in balloon symbols created by on this standard.

Visual Basic
Property TextHeight() As double
Remarks

This property defaults to be 0.24 inches.

This property is a Double.


IMcadBalloonStandard::RemoveColumn Method
Summary

Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the column to be removed.
Returns

None


IMcadBalloonStandard::SetToDefaults Method
Summary

Sets the properties of the standard balloon symbol to the factory default values.

Visual Basic
Sub SetToDefaults()


IMcadBalloonStandard2 Interface
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadBalloonStandard
    IMcadBalloonStandard2
Visual Basic
Public Interface IMcadBalloonStandard2
Inherits IMcadBalloonStandard
Links
IMcadBalloonStandard2 Members, SymBBAuto Library


IMcadBalloonStandard2 Members
Summary

The following tables list the members exposed by IMcadBalloonStandard2.

Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.
TrueColor | Specifies the true color of balloons referencing this standard.


IMcadBalloonStandard2::TrueColor Property
Summary

Specifies the true color of balloons referencing this standard.

Visual Basic
Property TrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.


IMcadBOM Interface
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
Visual Basic
Public Interface IMcadBOM
Inherits IAcadDictionary
Links
IMcadBOM Members, SymBBAuto Library


IMcadBOM Members
Summary

The following tables list the members exposed by IMcadBOM.

Methods
Name | Description
AddItem | Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem | Creates an unassociated item entry and adds it to the BOM table.
Items | Specifies the collection of bill of materials items contained in the BOM table.
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


IMcadBOM::Data Property
Summary

Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.

Visual Basic
Property Data() As VARIANT
Remarks

This property is a Variant (two dimension array of Strings).


IMcadBOM::PartLists Property
Summary

Gets the list of parts lists associated to the BOM table.

Visual Basic
Property PartLists() As IMcadPartLists**
Remarks

This property is a McadPartLists collection.


IMcadBOM::Target Property
Summary

Gets the target definition of a BOM table.

Visual Basic
Property Target() As IAcadObject**
Remarks

This property is a cadObject. This can be any of the drawing objects.


IMcadBOM::AddItem Method
Summary

Creates a BOM item for the part reference and adds it to the BOM table.

Visual Basic
Sub AddItem(ReferenceIDs As VARIANT, ItemNo As String, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
ReferenceIDs | Variant (long or array of longs); input-only. Specifies the object ID or array of object IDs for the part reference, usually obtained from the McadBOMMgr > SelectBOMEntity method.
ItemNo | String; input-only. Specifies the item number for the BOM item to be added to the BOM table.
Returns

McadBOMItem object


IMcadBOM::AddUnassociatedItem Method
Summary

Creates an unassociated item entry and adds it to the BOM table.

Visual Basic
Sub AddUnassociatedItem(ItemNo As String, Quantity As long, Data As [in, optional] VARIANT, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
ItemNo | String; input-only. Specifies the number of this item.
Quantity | String; input-only. Specifies the number of this item.
Data | Variant (two dimensional array of strings). Specify the data for the entry in the format specified by the McadBOMItem > Data property.
Returns

McadBOMItem object.


IMcadBOM::Items Method
Summary

Specifies the collection of bill of materials items contained in the BOM table.

Visual Basic
Sub Items(Expanded As [in, defaultvalue(FALSE)] VARIANT_BOOL, Items As [out, retval] IMcadBOMItems*)
Parameters
Parameters | Description
Expanded | Boolean; input-only; optional. The default value is FALSE. If TRUE, expanded items are included in the collection.
Remarks

This property is a McadBOMItems collection.


IMcadBOM2 Interface
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
Visual Basic
Public Interface IMcadBOM2
Inherits IMcadBOM
Links
IMcadBOM2 Members, SymBBAuto Library


IMcadBOM2 Members
Summary

The following tables list the members exposed by IMcadBOM2.

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Items
Specifies the collection of bill of materials items contained in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects

Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


IMcadBOM2::applySort Method
Summary

Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.

Visual Basic
Sub applySort()
Remarks

This method has no implementation and is currently unsupported.


IMcadBOM2::GetProperties Method
Summary

Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Visual Basic
Sub GetProperties(ByRef isStructuralyExpanded As VARIANT_BOOL, ByRef isUsingAssmPath As VARIANT_BOOL, ByRef structSeparator As String, ByRef assocLayoutIds As VARIANT, ByRef targetId As LONG_PTR)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM representation are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, True, or not, False. This parameter is available when isStructuralyExpanded is False.
structSeparator | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, True, or not, False. This parameter is available when isStructuralyExpanded is False.
assocLayoutIds | Variant; input-only. Specifies the drawing layout associated with the BOM representation.
targetId | Long; input-only. Specifies the BOM representation to get the properties for.


IMcadBOM2::GetProperties32 Method
Summary

Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Visual Basic
Sub GetProperties32(ByRef isStructuralyExpanded As VARIANT_BOOL, ByRef isUsingAssmPath As VARIANT_BOOL, ByRef structSeparator As String, ByRef assocLayoutIds As VARIANT, ByRef targetId As LONG)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM representation are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, TRUE, or not, FALSE. This parameter is available when isStructuralyExpanded is False.
structSeparator | String; input-only. Specifies the separator for used in the assembly path. This parameter is available when isStructuralyExpanded is False and isUsingAssmPath is True.
assocLayoutIds | Variant; input-only. Specifies the drawing layout associated with the BOM representation.
targetId | Long; input-only. Specifies the BOM representation to get the properties for.


IMcadBOM2::SetProperties Method
Summary

Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects
Visual Basic
Sub SetProperties(isStructuralyExpanded As VARIANT_BOOL, isUsingAssmPath As VARIANT_BOOL, structSeparator As String, assocLayoutIds As VARIANT, ByRef regen As VARIANT_BOOL)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM table are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the subassemblies in the BOM table are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
structSeparator | String; input-only. Specifies the separator for used in the assembly path. This parameter is available when isStructuralyExpanded is False and isUsingAssmPath is True.
assocLayoutIds | Variant (TBD); input-only. Specifies the drawing layout associated with the BOM table.
regen | Boolean; input-only. Specifies whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects, True, or not, False. If True, this method also reindexes the drawing database for optimum display and better object selection performance.


IMcadBOM3 Interface
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4
Visual Basic
Public Interface IMcadBOM3
Inherits IMcadBOM2
Links
IMcadBOM3 Members, SymBBAuto Library


IMcadBOM3 Members
Summary

The following tables list the members exposed by IMcadBOM3.

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects

Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


IMcadBOM3::IsBorder Property
Summary

Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.

Visual Basic
Property IsBorder() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadBOM3::IsVisible Property
Summary

Checks whether the BOM table is visible, TRUE, or not, FALSE.

Visual Basic
Property IsVisible() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • For border BOM, isVisible will be true although it will not be listed in the browser. The BOM table not listed in the BOM Editor dialog will have isVisible set to false.


IMcadBOM3::GetStructuredChildItems Method
Summary

Gets the immediate child items of a BOM item in a Structured BOM table.

Visual Basic
Sub GetStructuredChildItems(Item As IMcadBOMItem, SkipPhantom As VARIANT_BOOL, Items As [out, retval] IMcadBOMItems*)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item for which to gets the child items.
SkipPhantom | Boolean; input-only. Specifies whether to return the child BOM items if they are phantom parts, TRUE, or not, FALSE. If TRUE, phantom child items will be ignored and its next level child BOM items will be returned.
Items | _nt_
Remarks

This API only applies to Structured BOM table. The parent item must have been expanded so that its child items are present. Any violation of these will return Acad::InvalidInput. Only immediate child items are returned.


IMcadBOM3::GetStructuredParentItem Method
Summary

Gets the parent item of the specified child item in the structured BOM representation.

Visual Basic
Sub GetStructuredParentItem(Item As IMcadBOMItem, SkipPhantom As VARIANT_BOOL, ParenItem As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the child BOM item for which to gets the parent item.
SkipPhantom | Boolean; input-only. Specifies whether to return the parent BOM item if it is a phantom part, TRUE, or not, FALSE. If TRUE, phantom parent will be ignored and its next level parent BOM item will be returned.
ParenItem | _nt_
Remarks

This API only applies to Structured BOM table. Only immediate parent item is returned.


IMcadBOM3::MergeItems Method
Summary

Merges the specified BOM items into one row in the BOM table.

Visual Basic
Sub MergeItems(Items As IMcadBOMItems)
Parameters
Parameters | Description
Items | McadBOMItems collection; input-only. Specifies the BOM items to be merged.


IMcadBOM4 Interface
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4
Visual Basic
Public Interface IMcadBOM4
Inherits IMcadBOM3
Links
IMcadBOM4 Members, SymBBAuto Library


IMcadBOM4 Members
Summary

The following tables list the members exposed by IMcadBOM4.

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects
SplitItem
Splits a row of the bill of materials (BOM) into two items.
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


IMcadBOM4::SplitItem Method
Summary

Splits a row of the bill of materials (BOM) into two items.

Visual Basic
Sub SplitItem(Item As IMcadBOMItem, PartRefIds As [in, optional] VARIANT)
Parameters
Parameters | Description
Item | MCadBOMItem; input only. Specifies the BOM row to be split.
PartRefIds | Input object ID array; optional. Array containing the part references that belong to the BOM row specified by Item. Only the first argument is needed for a non-part reference item.


IMcadBOMItem Interface
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
Visual Basic
Public Interface IMcadBOMItem
Inherits IAcadObject
Links
IMcadBOMItem Members, SymBBAuto Library


IMcadBOMItem Members
Summary

The following tables list the members exposed by IMcadBOMItem.

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Quantity | Specifies the quantity of a BOM item.


IMcadBOMItem::AutoCalculateEnabled Property
Summary

Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.

Visual Basic
Property AutoCalculateEnabled() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • If this property is a TRUE, setting a new value for the McadBOMItem > Quantity property fails.


IMcadBOMItem::Balloons Property
Summary

Specifies the balloon symbols associated with this BOM item.

Visual Basic
Property Balloons() As IMcadBalloons**
Remarks

This property is a McadBalloons collection.


IMcadBOMItem::BOM Property
Summary

Specifies the BOM table that this BOM item is a member of.

Visual Basic
Property BOM() As IMcadBOM**
Remarks

This property is a McadBOM collection.


IMcadBOMItem::Data Property
Summary

Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.

Visual Basic
Property Data() As VARIANT
Remarks

This property is a Variant (two dimension array of Strings).


IMcadBOMItem::Expanded Property
Summary

Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.

Visual Basic
Property Expanded() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The McadBOMItem > IsExpandable property indicates whether or not this BOM item is expandable.
  • To set the Expanded or Structured property (isStructuralyExpanded) for a BOM database collection this BOM item belongs to, use the McadBOM > SetProperties method.


IMcadBOMItem::IsExpandable Property
Summary

Specifies whether this BOM item is expandable, TRUE, or not, FALSE.

Visual Basic
Property IsExpandable() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • The McadBOMItem > Expanded property indicates whether or not this expandable BOM item is expanded.
  • To set the Expanded or Structured property (isStructuralyExpanded) for a BOM database collection this BOM item belongs to, use the McadBOM > SetProperties method.


IMcadBOMItem::ItemNumber Property
Summary

Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.

Visual Basic
Property ItemNumber() As String
Remarks

This property is a String.


IMcadBOMItem::Quantity Property
Summary

Specifies the quantity of a BOM item.

Visual Basic
Property Quantity() As long
Remarks
  • This property is a Long.
  • Setting a new value for the Quantity property only succeeds until then McadBOMItem > AutoCalculateEnabled property is a FALSE for this item.


IMcadBOMItem::AddReference Method
Summary

Adds the specified part references to this BOM item.

Visual Basic
Sub AddReference(Reference As VARIANT)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies the object IDs for part references to add to this BOM item.
Returns

None


IMcadBOMItem::GetReferences Method
Summary

Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.

Visual Basic
Sub GetReferences(ByRef Items As VARIANT, References As [out, retval] VARIANT)
Parameters
Parameters | Description
Items | Variant (array of Longs). Specifies the BOM item to get part references for.
Returns

Variant (array of arrays of Longs)


IMcadBOMItem::GetReferences32 Method
Summary

Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.

Visual Basic
Sub GetReferences32(ByRef Items As VARIANT, References As [out, retval] VARIANT)
Parameters
Parameters | Description
Items | Variant (array of Longs). Specifies the BOM item to get part references for.
References | _nt_


IMcadBOMItem::ReferenceExists Method
Summary

Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.

Visual Basic
Sub ReferenceExists(Reference As VARIANT, Exists As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies an array of object IDs for the part reference to query for this BOM item.
Returns

Boolean


IMcadBOMItem::RemoveReference Method
Summary

Removes the specified part reference from this BOM item.

Visual Basic
Sub RemoveReference(Reference As VARIANT)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies the array of object IDs for the part reference to be removed from this BOM item. If the reference has any balloons associated to it, they will be erased as well.
Returns

None


IMcadBOMItem2 Interface
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
Visual Basic
Public Interface IMcadBOMItem2
Inherits IMcadBOMItem
Links
IMcadBOMItem2 Members, SymBBAuto Library


IMcadBOMItem2 Members
Summary

The following tables list the members exposed by IMcadBOMItem2.

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.


IMcadBOMItem2::ExcludeFromPartList Property
Summary

Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.

Visual Basic
Property ExcludeFromPartList() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadBOMItem2::Phantomed Property
Summary

Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.

Visual Basic
Property Phantomed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadBOMItem2::GetAttribute Method
Summary

Gets the BOM attribute of a specified key.

Visual Basic
Sub GetAttribute(Key As String, Evaluate As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] BSTR)
Parameters
Parameters | Description
Key | String; input-only. Specifies the attribute key to perform this method.
Evaluate | Boolean, default value = TRUE; input-only; optional. Specifies whether the BOM attribute is returned in evaluated form, TRUE, or in raw form, FALSE.
pVal | _nt_


IMcadBOMItem2::GetCalculatedQuantity Method
Summary

Gets the calculated quantity regardless of the AutoCalc flag.

Visual Basic
Sub GetCalculatedQuantity(ByRef Qty As long, ByRef QtyIgnoreRefQty As long)
Parameters
Parameters | Description
Qty | Long; output-only. Returns the total number of parts associated with this BOM item.
QtyIgnoreRefQty | Long; output-only. Returns the total number of parts associated with this BOM item not taking into account the part's reference quantity.


IMcadBOMItem2::GetItemDefinition Method
Summary

Gets the definitions of the specified BOM items.

Visual Basic
Sub GetItemDefinition(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

This function is deprecated in favor of the new GetItemPartDefinition.

It will return nothing for eNonModal BOM item, one component definition ID for eCompDef BOM item, and array of part definition IDs for ePartRef and eBlockDef.


IMcadBOMItem2::GetItemDefinition32 Method
Summary

Gets the definitions of the specified BOM items.

Visual Basic
Sub GetItemDefinition32(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

This function is deprecated in favor of the new GetItemPartDefinition.

It will return nothing for eNonModal BOM item, one component definition ID for eCompDef BOM item, and array of part definition IDs for ePartRef and eBlockDef.


IMcadBOMItem2::GetPartBalloons Method
Summary

Gets the attached balloons on the parts.

Visual Basic
Sub GetPartBalloons(Reference As VARIANT, Balloons As [out, retval] IMcadBalloons*)
Parameters
Parameters | Description
Reference | Variant; input-only. Specifies the part(s) associated with the balloons to get. It can be a single part or array of parts object IDs . If no part is given or NULL, all balloons associated with this BOM items will be returned.
Balloons | _nt_


IMcadBOMItem2::SetAttribute Method
Summary

Sets an BOM attribute value at the specified attribute key.

Visual Basic
Sub SetAttribute(Key As String, Val As String)
Parameters
Parameters | Description
Key | String; input-only. Specifies the attribute key for which to give a attribute value.
Val | String; input-only. Specifies the attribute value on the given attribute key.


IMcadBOMItem3 Interface
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4
Visual Basic
Public Interface IMcadBOMItem3
Inherits IMcadBOMItem2
Links
IMcadBOMItem3 Members, SymBBAuto Library


IMcadBOMItem3 Members
Summary

The following tables list the members exposed by IMcadBOMItem3.

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.


IMcadBOMItem3::SortPriority Property
Summary

Property that indicates the priority of the item for purpose of sorting.

Visual Basic
Property SortPriority() As long
Remarks

A smaller value item will be listed first, before a bigger value item. Sort priority will be used for McadBom.applySort() method.


IMcadBOMItem3::GetItemPartDefinition Method
Summary

The method replaces the previous GetItemDefinition method.

Visual Basic
Sub GetItemPartDefinition(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

Returns the definition of the BOM item. It returns one unique definition ID for NonModal and PartRef BOM item; one component definition ID for CompDef BOM item and array of part definition IDs for BlockDef BOM item.


IMcadBOMItem3::GetItemPartDefinition32 Method
Summary

The method replaces the previous GetItemDefinition32 method.

Visual Basic
Sub GetItemPartDefinition32(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

Returns the definition of the BOM item. It returns one unique definition ID for NonModal and PartRef BOM item; one component definition ID for CompDef BOM item and array of part definition IDs for BlockDef BOM item.


IMcadBOMItem3::SetAttributePreDefinedListValue Method
Summary

Sets a specific value within the predefined list for the specified attribute.

Visual Basic
Sub SetAttributePreDefinedListValue(attributeName As String, preDefineListValue As String)
Parameters
Parameters | Description
attributeName | Name of attribute which is a predefined list.
preDefineListValue | The specific value within the predefined list to set to. This value must be a valid key in the predefined list.


IMcadBOMItem4 Interface
Summary

A bill of materials item, or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4
Visual Basic
Public Interface IMcadBOMItem4
Inherits IMcadBOMItem3
Links
IMcadBOMItem4 Members, SymBBAuto Library


IMcadBOMItem4 Members
Summary

The following tables list the members exposed by IMcadBOMItem4.

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetBomOverride | Method that checks if there is a bom override for the specified attrib/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveAttribute | Method to remove the local attribute value if any from this bom item. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.


IMcadBOMItem4::GetBomOverride Method
Summary

Method that checks if there is a bom override for the specified attrib/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.

Visual Basic
Sub GetBomOverride(attributeName As String, ByRef originalValue As String, ByRef originalData As String, ByRef currentValue As String, ByRef currentData As String, ByRef editable As VARIANT_BOOL, overrideType As [out, retval] McadBomOverrideType)
Parameters
Parameters | Description
attributeName | Name of attribute/column to check.
originalValue | The original evaluated value (what would be there if there is no override). Would be empty if there is no bom override.
originalData | The original unevaluated data (what would be there if there is no override). Would be empty if there is no bom override.
currentValue | The current evaluated value.
currentData | The current unevaluated data.
editable | Indicates if the attribute can be edited.


IMcadBOMItem4::RemoveAttribute Method
Summary

Method to remove the local attribute value if any from this bom item. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.

Visual Basic
Sub RemoveAttribute(attributeName As String)
Parameters
Parameters | Description
attributeName | Name of attribute/column to remove.
Remarks

Because quantity override is handled differently, this method of McadBomItem will not work for quantity override.


IMcadBOMItems Interface
Summary

A collection of McadBOMItem objects

Class Hierarchy

Declaration syntax

IMcadBOMItems
Visual Basic
Public Interface IMcadBOMItems
Inherits IDispatch
Links
IMcadBOMItems Members, SymBBAuto Library


IMcadBOMItems Members
Summary

The following tables list the members exposed by IMcadBOMItems.

Methods
Name | Description
Add | Appends a specified BOM item to this BOM database table collection.
Item | Specifies the BOM item at a specified index from this BOM database table collection.
Remove | Removes the specified BOM item from this McadBOMItems collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the number of items in a McadBOMItems collection.


IMcadBOMItems::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadBOMItems::Count Property
Summary

Specifies the number of items in a McadBOMItems collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadBOMItems::Add Method
Summary

Appends a specified BOM item to this BOM database table collection.

Visual Basic
Sub Add(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item to be appended to this BOM database table collection.
Returns

None


IMcadBOMItems::Item Method
Summary

Specifies the BOM item at a specified index from this BOM database table collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the BOM item to get from the collection.
Returns

McadBOMItem object


IMcadBOMItems::Remove Method
Summary

Removes the specified BOM item from this McadBOMItems collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specified the index of the BOM item to be removed from this McadBOMItems collection.
Returns

None


IMcadBOMMgr Interface
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
Visual Basic
Public Interface IMcadBOMMgr
Inherits IDispatch
Links
IMcadBOMMgr Members, SymBBAuto Library


IMcadBOMMgr Members
Summary

The following tables list the members exposed by IMcadBOMMgr.

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddPartData | Creates a part data entry for the specified part reference.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
RemoveBOMTable | Removes the specified BOM table.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


IMcadBOMMgr::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadBOMMgr::SymbolBBMgr Property
Summary

Gets the Symbol BOM and Balloon manager object for this document.

Visual Basic
Property SymbolBBMgr() As IMcadSymbolBBMgr**
Remarks

This property is a McadSymbolBBMgr object.


IMcadBOMMgr::AddBOMTable Method
Summary

Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.

Visual Basic
Sub AddBOMTable(Name As String, Target As [in, optional] VARIANT, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the BOM table to be added for a specified Target block.
Target | Variant (model/paper space block or a Long type component definition id); input-only; optional. Specifies the target to add a BOM table for. If the Target element is not specified, the main BOM table is created.
Returns

McadBOM collection


IMcadBOMMgr::AddPartData Method
Summary

Creates a part data entry for the specified part reference.

Visual Basic
Sub AddPartData(Part As IAcadObject, Data As VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to create the data entry for.
Data | Variant (two dimensional array of strings); input-only. Specifies the data entry for the specified part reference's symbol, block, or block reference.
Returns

None

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. This method fails if Data is already associated with the specified part.


IMcadBOMMgr::BOMTableExists Method
Summary

Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.

Visual Basic
Sub BOMTableExists(TargetName As [in, optional] VARIANT, Exists As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
TargetName | Variant (AcadBlock object or String); input-only; optional. Specifies the target block object or block name to check. If not specified, the main BOM table is checked.
Returns

Boolean


IMcadBOMMgr::ExportBOM Method
Summary

Exports the BOM table data to a specified file in a specified format.

Visual Basic
Sub ExportBOM(BOM As IMcadBOM, FileType As String, FileName As String)
Parameters
Parameters | Description
BOM | McadBOM collection; input-only. Specifies the BOM table to be exported.
FileType | String; input-only. Specifies the file type for the exported BOM table. Valid file types include .mdb, .xls, .dbf, .txt, .csv, .html.
FileName | String; input-only. Specifies the file name for the exported BOM table.
Returns

None


IMcadBOMMgr::GetAllBOMTables Method
Summary

Gets all of the BOM tables in the document.

Visual Basic
Sub GetAllBOMTables(IncludeXREFs As [in, defaultvalue(FALSE)] VARIANT_BOOL, BOMs As [out, retval] IMcadBOMs*)
Parameters
Parameters | Description
IncludeXREFs | Boolean; input-only; optional; default value is FALSE. Specifies whether BOM tables from all the externally referenced drawings for this BOM table are included. If the IncludeXREFs element is TRUE, the BOM tables from all the externally referenced drawings are included.
Returns

McadBOMs collection


IMcadBOMMgr::GetBOMTable Method
Summary

Gets the specified BOM table associated with the specified block target.

Visual Basic
Sub GetBOMTable(Target As IAcadObject, ByRef Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Target | AcadObject object; input-only. Specifies the block target to get the BOM table for.
Name | String; input-only. Specifies the name of the BOM table to get.
Returns

McadBOM collection


IMcadBOMMgr::GetPartData Method
Summary

Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.

Visual Basic
Sub GetPartData(Part As IAcadObject, Data As [out, retval] VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to get the associated data for.
Returns

Variant (two dimensional array of strings)


IMcadBOMMgr::ImportBOM Method
Summary

Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.

Visual Basic
Sub ImportBOM(FileName As String, TableName As String, Target As [in, optional] VARIANT, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file name for the BOM table data to be imported.
TableName | String; input-only. Specifies the name of the BOM table to be imported.
Target | Variant (AcadBlock object); input-only; optional. Specifies the block target to import the BOM table data for. If not specified, the new data are added to the main BOM table.
Returns

McadBOM collection


IMcadBOMMgr::RemoveBOMTable Method
Summary

Removes the specified BOM table.

Visual Basic
Sub RemoveBOMTable(BOM As IMcadBOM)
Parameters
Parameters | Description
BOM | McadBOM collection; input-only. Specifies the BOM table to be removed.
Returns

None


IMcadBOMMgr::SelectBOMEntity Method
Summary

Prompts for the selection of part references.

Visual Basic
Sub SelectBOMEntity(IntoNested As [in, defaultvalue(FALSE)] VARIANT_BOOL, Path As [out, retval] VARIANT)
Parameters
Parameters | Description
IntoNested | Boolean; input-only; optional; default value is FALSE. Specifies whether or not the nested part references in the BOM table are selected.
Returns

Variant (array of longs)

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. An array of object IDs of the selected parts is returned.


IMcadBOMMgr::SelectBOMEntity32 Method
Summary

Prompts for the selection of part references.

Visual Basic
Sub SelectBOMEntity32(IntoNested As [in, defaultvalue(FALSE)] VARIANT_BOOL, Path As [out, retval] VARIANT)
Parameters
Parameters | Description
IntoNested | Boolean; input-only; optional; default value is False. Specifies whether or not the nested part references in the BOM table are selected.
Path | _nt_
Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. An array of object IDs of the selected parts is returned.


IMcadBOMMgr::SetPartData Method
Summary

Sets the data entry associated with the specified part reference.

Visual Basic
Sub SetPartData(Part As IAcadObject, Data As VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to set the data entry for.
Data | Variant (two dimensional array of strings); input-only. Specifies the key value pairs for the data entry to set for the specified part reference.
Returns

None

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. The data is represented as a two dimensional array of strings of key value pairs.


IMcadBOMMgr2 Interface
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
Visual Basic
Public Interface IMcadBOMMgr2
Inherits IMcadBOMMgr
Links
IMcadBOMMgr2 Members, SymBBAuto Library


IMcadBOMMgr2 Members
Summary

The following tables list the members exposed by IMcadBOMMgr2.

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


IMcadBOMMgr2::CurrentBOM Property
Summary

Gets or sets the current BOM table.

Visual Basic
Property CurrentBOM() As IMcadBOM*


IMcadBOMMgr2::AddBorderBOMTable Method
Summary

Creates a new border BOM database with a given border.

Visual Basic
Sub AddBorderBOMTable(BlockRef As IAcadObject, Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
BlockRef | AcadObject object; input-only. Specifies the block reference object, IAcadBlockReference of the title border.
Name | String; input-only. Specifies the BOM table name.
BOM | _nt_


IMcadBOMMgr2::AddPartGrfDef Method
Summary

Add graphical definition such as Part Reference or Block Reference, to represent the same part.

Visual Basic
Sub AddPartGrfDef(Part As IAcadObject, NewGrfDef As IAcadObject)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the target part for which to add graphical definitions.
NewGrfDef | AcadObject object; input-only. Specifies the graphical definition to be added to the specified part.
Remarks

You can have as many as different definitions linked to a single part data, but all of them must be of same type.


IMcadBOMMgr2::ExportBOM2 Method
Summary

Exports the BOM table to a file of a specific format.

Visual Basic
Sub ExportBOM2(Format As McadBOMExportFormatType, BOM As IMcadBOM, Path As String, TableName As String, Overwrite As VARIANT_BOOL)


IMcadBOMMgr2::ExportPartList Method
Summary

Exports the parts list to a file of a specific format.

Visual Basic
Sub ExportPartList(Format As McadBOMExportFormatType, PartList As IMcadPartList, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the Part List dialog box. The column formatting is based on the current BOM Standard. In order to BOM Standard first.

See Also

McadBOMMgr Object

Links
See Also


IMcadBOMMgr2::GetBOMTableByCompDefId Method
Summary

Gets the BOM table from a given component definition ID.

Visual Basic
Sub GetBOMTableByCompDefId(ObjId As LONG_PTR, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
ObjId | Long; input-only. Specifies the object ID of the component definition to perform this method.
BOM | _nt_


IMcadBOMMgr2::GetBOMTableByCompDefId32 Method
Summary

Gets the BOM table from a given component definition ID.

Visual Basic
Sub GetBOMTableByCompDefId32(ObjId As LONG, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
ObjId | Long; input-only. Specifies the object ID of the component definition to perform this method.
BOM | _nt_


IMcadBOMMgr2::GetBOMTableByName Method
Summary

Gets the BOM table from the specified name.

Visual Basic
Sub GetBOMTableByName(Name As String, BOM As [out, retval] IMcadBOM*)


IMcadBOMMgr2::GetBorderBOMTable Method
Summary

Gets a border BOM database from a given border.

Visual Basic
Sub GetBorderBOMTable(BlockRef As IAcadObject, ByRef Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
BlockRef | AcadObject object; input-only. Specifies the block reference object, IAcadBlockReference of the title border.
Name | String; input-only. Specifies the BOM table name.
BOM | _nt_


IMcadBOMMgr2::GetEvaluatedPartData Method
Summary

Gets the BOM attributes for the specified part

Visual Basic
Sub GetEvaluatedPartData(Part As IAcadObject, Data As [out, retval] VARIANT)
Parameters
Parameters | Description
Part | _nt_
Data | _nt_
Returns

Variant (2-dimensional array data). For each record, the first element is the string Key of the BOM attribute and the second element is the string data of that Key.

Remarks

This is an enhanced version of the current getPartData(partId, valueMap) API, which returns the valueMap with evaluated data and also returns an extra parameter for the numOfItems. Evaluation of the data is based on the bomStdId passed in. If the partId is a data entry id, numOfItems is not applicable.


IMcadBOMMgr2::GetPartAttribute Method
Summary

Gets the BOM attribute associated with a given key of a specified part.

Visual Basic
Sub GetPartAttribute(Part As IAcadObject, Key As String, evaluated As [in, defaultvalue(TRUE)] VARIANT_BOOL, Data As [out, retval] BSTR)
Parameters
Parameters | Description
Part | _nt_
Key | _nt_
evaluated | _nt_
Data | _nt_
Remarks

This is an equivalence of the current getPartData(partId, valueMap) API which return the attribute of a given key. If evaluate is true, evaluated value will be returned else raw data i.e. formula will be returned.


IMcadBOMMgr2::GetSheetBOMTable Method
Summary

Gets the BOM table associated to a specific paper space.

Visual Basic
Sub GetSheetBOMTable(Layout As IAcadObject, BOM As [out, retval] IMcadBOM*)


IMcadBOMMgr2::ImportBOM2 Method
Summary

Imports the data in a file of the specified format into the BOM table.

Visual Basic
Sub ImportBOM2(Format As McadBOMImportFormatType, BOM As IMcadBOM, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the Part List dialog box. The column formatting is based on the current BOM Standard. In order to BOM Standard first.


IMcadBOMMgr2::ImportPartList Method
Summary

Imports the data in a file of the specified format into the parts list.

Visual Basic
Sub ImportPartList(Format As McadBOMImportFormatType, PartList As IMcadPartList, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the BOM table dialog box. BOM row items for each part imported will be created in the BOM table that owns the part list.


IMcadBOMMgr2::RemovePartGrfDef Method
Summary

Removes the graphical definition such as Part Reference or Block Reference, from the part reference.

Visual Basic
Sub RemovePartGrfDef(Ref As IAcadObject)
Remarks

After the removal, the Part reference or Block Reference is no longer linked to the original data.


IMcadBOMMgr2::SetPartAttribute Method
Summary

Sets the BOM attribute associated with a given key of a specified part.

Visual Basic
Sub SetPartAttribute(Part As IAcadObject, Key As String, Data As String)
Parameters
Parameters | Description
Part | String; input-only. Specifies the part for which to set the BOM attribute.
Key | String; input-only. Specifies the attribute key on which to set the BOM attribute.
Data | String; input-only. Specifies the BOM attribute value to be set.
Remarks

This is an equivalence of the current setPartData(partId, valueMap) API which set the attribute value for a given key.


IMcadBOMMgr3 Interface
Summary

A bill of materials manager object.

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4
Visual Basic
Public Interface IMcadBOMMgr3
Inherits IMcadBOMMgr2
Links
IMcadBOMMgr3 Members, SymBBAuto Library


IMcadBOMMgr3 Members
Summary

The following tables list the members exposed by IMcadBOMMgr3.

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


IMcadBOMMgr3::GetBOMTableByCompDefHandle Method
Summary

Gets the specified BOM table associated with the handle of a component definition

Visual Basic
Sub GetBOMTableByCompDefHandle(Handle As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Handle | _nt_
BOM | _nt_


IMcadBOMMgr4 Interface
Summary

A bill of materials manager object.

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4
Visual Basic
Public Interface IMcadBOMMgr4
Inherits IMcadBOMMgr3
Links
IMcadBOMMgr4 Members, SymBBAuto Library


IMcadBOMMgr4 Members
Summary

The following tables list the members exposed by IMcadBOMMgr4.

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetAllPartReferences | Gets all the part references from the specified database.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


IMcadBOMMgr4::GetAllPartReferences Method
Summary

Gets all the part references from the specified database.

Visual Basic
Sub GetAllPartReferences(items As [out, retval] IMcadPartReferences *)
Parameters
Parameters | Description
items | Collection of part references.


IMcadBOMs Interface
Summary

A collection of McadBOM objects

Class Hierarchy

Declaration syntax

IMcadBOMs
Visual Basic
Public Interface IMcadBOMs
Inherits IDispatch
Links
IMcadBOMs Members, SymBBAuto Library


IMcadBOMs Members
Summary

The following tables list the members exposed by IMcadBOMs.

Methods
Name | Description
Add | Adds a BOM table to the BOM database collection.
Item | Gets the BOM table at a specified index from the BOM database collection.
Remove | Removes the BOM table at a specified index from the BOM database collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the BOM tables in a BOM database collection.


IMcadBOMs::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadBOMs::Count Property
Summary

Gets the total number of the BOM tables in a BOM database collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadBOMs::Add Method
Summary

Adds a BOM table to the BOM database collection.

Visual Basic
Sub Add(Item As IMcadBOM)
Parameters
Parameters | Description
Item | McadBOM collection. Specifies the BOM table to add to the BOM database collection.


IMcadBOMs::Item Method
Summary

Gets the BOM table at a specified index from the BOM database collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the BOM table to get from this BOM database collection.
Returns

McadBOM collection


IMcadBOMs::Remove Method
Summary

Removes the BOM table at a specified index from the BOM database collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Removes the BOM table at a specified index from the BOM database collection.
Returns

None


IMcadBOMStandard Interface
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2
Visual Basic
Public Interface IMcadBOMStandard
Inherits IMcadSymbolStandard3
Links
IMcadBOMStandard Members, SymBBAuto Library


IMcadBOMStandard Members
Summary

The following tables list the members exposed by IMcadBOMStandard.

Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadBOMStandard::BalloonStandard Property
Summary

Gets the specific balloon standard that is associated with a BOM standard.

Visual Basic
Property BalloonStandard() As IMcadBalloonStandard**
Remarks

This property is a McadBalloonStandard object.


IMcadBOMStandard::ColumnCount Property
Summary

Gets the number of columns specified for this BOM standard.

Visual Basic
Property ColumnCount() As long*
Remarks

This property is a Long.


IMcadBOMStandard::Columns Property
Summary

Gets the columns definitions for a BOM standard.

Visual Basic
Property Columns() As IMcadColumnDefinitions**
Remarks

This property is a McadColumnDefinitions collection.


IMcadBOMStandard::PartListStandard Property
Summary

Gets the specific part list standard that is associated with a BOM standard.

Visual Basic
Property PartListStandard() As IMcadPartListStandard**
Remarks

This property is a McadPartListStandard object.


IMcadBOMStandard::AddColumn Method
Summary

Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.

Visual Basic
Sub AddColumn(ColumnType As McadColumnType, DataType As McadDataType, ColumnName As String, Caption As [in, optional] VARIANT, Index As [in, optional] VARIANT, Column As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
ColumnType | McadColumnType enumeration; input-only. Specifies the column type for the column to add to the BOM standard. This ColumnType element is the internal name of the column attribute.
DataType | McadDataType enumeration; input-only. Specifies the data type of the column.
ColumnName | String; input-only. Specifies the column name to display in the BOM table.
Caption | Variant (String); input-only; optional. If not specified, the ColumnType value is retrieved for the Caption element.
Index | Variant (Long); input-only; optional. Specifies the index of the collection of McadColumnDefinition objects in the BOM standard.
Returns

McadColumnDefinition object

Remarks

To add a user-defined BOM column, you must set McadColumnType to sbUnknown. The name of the property must match its type. For example, "item" must be of type sbItem. If a property with this name already exists the property will be set to visible. To add a partref to a nested block reference, you must pass an array of object IDs for the parent block references and its block reference.


IMcadBOMStandard::GetColumn Method
Summary

Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.

Visual Basic
Sub GetColumn(Item As [in, optional] VARIANT, Name As [in, optional] VARIANT, Caption As [in, optional] VARIANT, Index As [in, optional] VARIANT, Type As [in, optional] VARIANT, Column As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
Item | Variant (Long); input-only; optional. Specifies the item number for the column to get from this BOM standard.
Name | Variant (Long); input-only; optional. Specifies the name for the column to get from this BOM database standard.
Caption | Variant (String); input-only; optional. Specifies the caption for the column to get from this BOM database standard.
Index | Variant (String); input-only; optional. Specifies the caption for the column to get from this BOM database standard.
Type | Variant ( McadColumnType enumeration); input-only; optional. Specifies the column type for the column to get from this BOM standard.
Returns

McadColumnDefinition object


IMcadBOMStandard::MoveColumn Method
Summary

Moves the specified column at a specified index to a new index.

Visual Basic
Sub MoveColumn(Index As long, ToIndex As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the original index for the collection of McadColumnDefinition objects in the BOM standard.
ToIndex | Long; input-only. Specifies the new index for the collection of McadColumnDefinition objects in the BOM standard.
Returns

None


IMcadBOMStandard::RemoveColumn Method
Summary

Removes the specified column from this BOM standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Variant (Long); input-only. Specifies the index of the collection of McadColumnDefinition objects in the BOM standard.
Returns

None


IMcadBOMStandard2 Interface
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2
Visual Basic
Public Interface IMcadBOMStandard2
Inherits IMcadBOMStandard
Links
IMcadBOMStandard2 Members, SymBBAuto Library


IMcadBOMStandard2 Members
Summary

The following tables list the members exposed by IMcadBOMStandard2.

Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
GetUOMName | Get the available UOM (units of measure).
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadBOMStandard2::GetUOMName Method
Summary

Get the available UOM (units of measure).

Visual Basic
Sub GetUOMName(UOMType As McadBOMUOMType, pVal As [out, retval] BSTR)


IMcadBorder Interface
Summary

This object represents the drawing border of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadBorder
    IMcadBorder2
Visual Basic
Public Interface IMcadBorder
Inherits IDispatch
Links
IMcadBorder Members, SymBBAuto Library


IMcadBorder Members
Summary

The following tables list the members exposed by IMcadBorder.

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.


IMcadBorder::Attributes Property
Summary

Property that specifies all the attributes for the border.

Visual Basic
Property Attributes() As VARIANT


IMcadBorder::Extends Property
Summary

Property that returns the extents of the border.

Visual Basic
Property Extends() As VARIANT*


IMcadBorder::Name Property
Summary

Property that specifies the name identifier of the border.

Visual Basic
Property Name() As String


IMcadBorder::Position Property
Summary

Property that returns the position of the border.

Visual Basic
Property Position() As VARIANT*


IMcadBorder::SetToDefaultAttributes Method
Summary

Initialize default attributes of the border.

Visual Basic
Sub SetToDefaultAttributes(ret As [out, retval]VARIANT_BOOL)


IMcadBorder2 Interface
Summary

This is class IMcadBorder2.

Class Hierarchy

Declaration syntax

IMcadBorder
    IMcadBorder2
Visual Basic
Public Interface IMcadBorder2
Inherits IMcadBorder
Links
IMcadBorder2 Members, SymBBAuto Library


IMcadBorder2 Members
Summary

The following tables list the members exposed by IMcadBorder2.

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
BlockId | This is BlockId, a member of class IMcadBorder2.
BlockId32 | This is BlockId32, a member of class IMcadBorder2.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.


IMcadBorder2::BlockId Property
Summary

This is BlockId, a member of class IMcadBorder2.

Visual Basic
Property BlockId() As LONG_PTR*


IMcadBorder2::BlockId32 Property
Summary

This is BlockId32, a member of class IMcadBorder2.

Visual Basic
Property BlockId32() As LONG*


IMcadColumnDefinition Interface
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
Visual Basic
Public Interface IMcadColumnDefinition
Inherits IDispatch
Links
IMcadColumnDefinition Members, SymBBAuto Library


IMcadColumnDefinition Members
Summary

The following tables list the members exposed by IMcadColumnDefinition.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


IMcadColumnDefinition::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadColumnDefinition::Caption Property
Summary

Specifies the caption for the column.

Visual Basic
Property Caption() As String
Remarks

This property is a String.


IMcadColumnDefinition::CaptionAlignment Property
Summary

Property that specifies the BOM and Parts List column caption alignment types.

Visual Basic
Property CaptionAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column caption alignment type. This is the same as reading from the BOMCaptionAlignment property. Writing to this property sets the BOM and Parts List column caption alignment types. This is the same as writing to both the BOMCaptionAlignment and PartListCaptionAlignment properties. This property is a replaced by the BOMCaptionAlignment and PartListCaptionAlignment properties.


IMcadColumnDefinition::ColumnType Property
Summary

Specifies the type of the column.

Visual Basic
Property ColumnType() As McadColumnType
Remarks

This property is a McadColumnType enumeration.


IMcadColumnDefinition::DataAlignment Property
Summary

Property that specifies the BOM and Parts List column data alignment types.

Visual Basic
Property DataAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column data alignment type. This is the same as reading from the BOMDataAlignment property. Writing to this property sets the BOM and Parts List column data alignment types. This is the same as writing to both the BOMDataAlignment and PartListDataAlignment properties. This property is a replaced by the BOMDataAlignment and PartListDataAlignment properties.


IMcadColumnDefinition::DataType Property
Summary

Specifies the type of the data that the column specifies.

Visual Basic
Property DataType() As McadDataType
Remarks

This property is a McadDataType enumeration.


IMcadColumnDefinition::Equivalents Property
Summary

Specifies the list of equivalence strings for this column.

Visual Basic
Property Equivalents() As VARIANT
Remarks

If a column data value is defined as “=<equivalentString>” e.g. “=<NAME>”, then this column’s equivalents property will be a string array with the first (and only) element being “NAME”. This means that this column will show the value of the Name column. If we create a single string array with the first (and only) element set to “DESCR” and use this string array to set the equivalents property, then this column will now show the value of the description column.

Note that the equivalents property cannot have multiple string values.


IMcadColumnDefinition::Index Property
Summary

Specifies the index of the column.

Visual Basic
Property Index() As long*
Remarks

This property is a Long.


IMcadColumnDefinition::Name Property
Summary

Specifies the name of the column in a BOM database standard object.

Visual Basic
Property Name() As String
Remarks

This property is a String.


IMcadColumnDefinition::Precision Property
Summary

Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.

Visual Basic
Property Precision() As long
Remarks

This property is a Long.


IMcadColumnDefinition::Size Property
Summary

Specifies the data size for the column.

Visual Basic
Property Size() As long
Remarks

This property is a Long.


IMcadColumnDefinition::Width Property
Summary

Specifies the width of the column.

Visual Basic
Property Width() As double
Remarks

This property is a Double.


IMcadColumnDefinition2 Interface
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3
Visual Basic
Public Interface IMcadColumnDefinition2
Inherits IMcadColumnDefinition
Links
IMcadColumnDefinition2 Members, SymBBAuto Library


IMcadColumnDefinition2 Members
Summary

The following tables list the members exposed by IMcadColumnDefinition2.

Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


IMcadColumnDefinition2::IsVisible Property
Summary

Checks whether the BOM table is visible, TRUE, or not, FALSE.

Visual Basic
Property IsVisible() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • For border BOM, isVisible will be true although it will not be listed in the browser. The BOM table not listed in the BOM Editor dialog will have isVisible set to false.


IMcadColumnDefinition3 Interface
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3
Visual Basic
Public Interface IMcadColumnDefinition3
Inherits IMcadColumnDefinition2
Links
IMcadColumnDefinition3 Members, SymBBAuto Library


IMcadColumnDefinition3 Members
Summary

The following tables list the members exposed by IMcadColumnDefinition3.

Methods
Name | Description
GetPreDefinedList | Retrieves the predefined list associated with this definition if any.
RemovePreDefinedList | Removes the predefined list associated with this definition.
SetPreDefinedList | Sets a predefined list to be associated with this definition.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BOMCaptionAlignment | Property that specifies the BOM column caption alignment type.
BOMDataAlignment | Property that specifies the BOM column data alignment type.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsPreDefinedList | Indicates whether this definition is associated with a pre defined list.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
PartListCaptionAlignment | Property that specifies the Parts List column caption alignment type.
PartListDataAlignment | Property that specifies the Parts List column data alignment type.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


IMcadColumnDefinition3::BOMCaptionAlignment Property
Summary

Property that specifies the BOM column caption alignment type.

Visual Basic
Property BOMCaptionAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column caption alignment type. This is the same as reading from the CaptionAlignment property.

Writing to this property sets the BOM column caption alignment type. This is the same writing to the CaptionAlignment property. In addition, writing to the CaptionAlignment property also sets the Parts List column caption alignment type.


IMcadColumnDefinition3::BOMDataAlignment Property
Summary

Property that specifies the BOM column data alignment type.

Visual Basic
Property BOMDataAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column data alignment type. This is the same as reading from the DataAlignment property.

Writing to this property sets the BOM column data alignment type. This is the same writing to the DataAlignment property. In addition, writing to the DataAlignment property also sets the Parts List column data alignment type.


IMcadColumnDefinition3::IsPreDefinedList Property
Summary

Indicates whether this definition is associated with a pre defined list.

Visual Basic
Property IsPreDefinedList() As VARIANT_BOOL*


IMcadColumnDefinition3::PartListCaptionAlignment Property
Summary

Property that specifies the Parts List column caption alignment type.

Visual Basic
Property PartListCaptionAlignment() As McadAlignmentType
Parameters
Parameters | Description
penAlign | _nt_
Remarks

Writing to this property sets the Parts List column caption alignment type. This is the same writing to the CaptionAlignment property. In addition, writing to the CaptionAlignment property also sets the BOM column caption alignment type.


IMcadColumnDefinition3::PartListDataAlignment Property
Summary

Property that specifies the Parts List column data alignment type.

Visual Basic
Property PartListDataAlignment() As McadAlignmentType
Remarks

Writing to this property sets the Parts List column data alignment type. This is the same writing to the DataAlignment property. In addition, writing to the DataAlignment property also sets the BOM column data alignment type.


IMcadColumnDefinition3::GetPreDefinedList Method
Summary

Retrieves the predefined list associated with this definition if any.

Visual Basic
Sub GetPreDefinedList(ByRef preList As VARIANT, ByRef def As String)
Parameters
Parameters | Description
preList | Array of string pair containing key, description.
def | The default key string, if any.


IMcadColumnDefinition3::RemovePreDefinedList Method
Summary

Removes the predefined list associated with this definition.

Visual Basic
Sub RemovePreDefinedList()


IMcadColumnDefinition3::SetPreDefinedList Method
Summary

Sets a predefined list to be associated with this definition.

Visual Basic
Sub SetPreDefinedList(preList As VARIANT, def As [in, optional] BSTR)
Parameters
Parameters | Description
preList | Array of string pair containing key, description.
def | The default key string, if any.
Remarks

It is not possible to set predefined list for columns like 'QTY', 'ITEM' and 'BOM_UNITS'.


IMcadColumnDefinitions Interface
Summary

A collection of McadColumnDefinition objects

Class Hierarchy

Declaration syntax

IMcadColumnDefinitions
Visual Basic
Public Interface IMcadColumnDefinitions
Inherits IDispatch
Links
IMcadColumnDefinitions Members, SymBBAuto Library


IMcadColumnDefinitions Members
Summary

The following tables list the members exposed by IMcadColumnDefinitions.

Methods
Name | Description
Add | Appends a specified column to this BOM database table.
Item | Gets the column at a specified index from this BOM database table.
Remove | Removes the column at a specified index from this BOM database table.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of column definitions in the collection.


IMcadColumnDefinitions::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadColumnDefinitions::Count Property
Summary

Specifies the total number of column definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadColumnDefinitions::Add Method
Summary

Appends a specified column to this BOM database table.

Visual Basic
Sub Add(Item As IMcadColumnDefinition)
Parameters
Parameters | Description
Item | McadColumnDefinition object; input-only. Specifies the column to add to this BOM database table.
Returns

None


IMcadColumnDefinitions::Item Method
Summary

Gets the column at a specified index from this BOM database table.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the column to get from this BOM database table.


IMcadColumnDefinitions::Remove Method
Summary

Removes the column at a specified index from this BOM database table.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the column to remove from this BOM database table.
Returns

None


IMcadDatumIdentifier Interface
Summary

Implements datum identifier symbols.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
Visual Basic
Public Interface IMcadDatumIdentifier
Inherits IMcadIdentifier
Links
SymBBAuto Library


IMcadDatumIdentifier2 Interface
Summary

This is class IMcadDatumIdentifier2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3
Visual Basic
Public Interface IMcadDatumIdentifier2
Inherits IMcadDatumIdentifier
Links
IMcadDatumIdentifier2 Members, SymBBAuto Library


IMcadDatumIdentifier2 Members
Summary

The following tables list the members exposed by IMcadDatumIdentifier2.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


IMcadDatumIdentifier2::SurfExtLinesOffset Property
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.


IMcadDatumIdentifier2::SurfExtLinesOvershot Property
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double


IMcadDatumIdentifier2::AddStdCompliantLeader Method
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().


IMcadDatumIdentifier3 Interface
Summary

This is class IMcadDatumIdentifier3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3
                        IMcadDatumIdentifier4
Visual Basic
Public Interface IMcadDatumIdentifier3
Inherits IMcadDatumIdentifier2
Links
IMcadDatumIdentifier3 Members, SymBBAuto Library


IMcadDatumIdentifier3 Members
Summary

The following tables list the members exposed by IMcadDatumIdentifier3.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumNote | This is DatumNote, a member of class IMcadDatumIdentifier3.
FarSideStatus | This is FarSideStatus, a member of class IMcadDatumIdentifier3.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.
SymbolStandard | Specifies the symbol standard for a symbol.
ThreadNote | This is ThreadNote, a member of class IMcadDatumIdentifier3.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


IMcadDatumIdentifier3::DatumNote Property
Summary

This is DatumNote, a member of class IMcadDatumIdentifier3.

Visual Basic
Property DatumNote() As String


IMcadDatumIdentifier3::FarSideStatus Property
Summary

This is FarSideStatus, a member of class IMcadDatumIdentifier3.

Visual Basic
Property FarSideStatus() As VARIANT_BOOL


IMcadDatumIdentifier3::SurfIndLeaderArrowType Property
Summary

This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType


IMcadDatumIdentifier3::ThreadNote Property
Summary

This is ThreadNote, a member of class IMcadDatumIdentifier3.

Visual Basic
Property ThreadNote() As String


IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method
Summary

This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.

Visual Basic
Sub AddLeaderWithSurfIndLeader(Points As VARIANT)


IMcadDatumIdentifier3::GetSurfIndLeader Method
Summary

This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.

Visual Basic
Sub GetSurfIndLeader(pVal As [out, retval]VARIANT)


IMcadDatumIdentifier4 Interface
Summary

This is class IMcadDatumIdentifier4.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3
                        IMcadDatumIdentifier4
Visual Basic
Public Interface IMcadDatumIdentifier4
Inherits IMcadDatumIdentifier3
Links
IMcadDatumIdentifier4 Members, SymBBAuto Library


IMcadDatumIdentifier4 Members
Summary

The following tables list the members exposed by IMcadDatumIdentifier4.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
IsAttachToFCF
This is IsAttachToFCF, a member of class IMcadDatumIdentifier4.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumNote | This is DatumNote, a member of class IMcadDatumIdentifier3.
FarSideStatus | This is FarSideStatus, a member of class IMcadDatumIdentifier3.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.
SymbolStandard | Specifies the symbol standard for a symbol.
ThreadNote | This is ThreadNote, a member of class IMcadDatumIdentifier3.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


IMcadDatumIdentifier4::IsAttachToFCF Method
Summary

This is IsAttachToFCF, a member of class IMcadDatumIdentifier4.

Visual Basic
Sub IsAttachToFCF(Attach As [out, retval] VARIANT_BOOL)


IMcadDatumStandard Interface
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2
Visual Basic
Public Interface IMcadDatumStandard
Inherits IMcadSymbolStandard3
Links
IMcadDatumStandard Members, SymBBAuto Library


IMcadDatumStandard Members
Summary

The following tables list the members exposed by IMcadDatumStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadDatumStandard::BorderLineType Property
Summary

Specifies the linetype of a datum standard's border line.

Visual Basic
Property BorderLineType() As IAcadLineType*
Remarks
  • This property is a cadLineType.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.


IMcadDatumStandard::BorderLineTypeName Property
Summary

Specifies the name of the linetype of a datum identifier's border line.

Visual Basic
Property BorderLineTypeName() As String
Remarks

This property is a String.


IMcadDatumStandard::DrawLeaderArrow Property
Summary

Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.

Visual Basic
Property DrawLeaderArrow() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadDatumStandard::HatchAngle Property
Summary

Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.

Visual Basic
Property HatchAngle() As double
Remarks

This property defaults to the value specified by the HPANG system variable.

This property is a Double.


IMcadDatumStandard::HatchDistance Property
Summary

Specifies the distance between lines in the hatch pattern.

Visual Basic
Property HatchDistance() As double
Remarks

It defaults to the distance specified by the HPSPACE system variable.

This property is a Double.


IMcadDatumStandard::HiddenLeaderLineType Property
Summary

Specifies the linetype of a datum identifier's hidden leader line.

Visual Basic
Property HiddenLeaderLineType() As IAcadLineType*
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.


IMcadDatumStandard::HiddenLeaderLineTypeName Property
Summary

Specifies the name of the linetype of a datum identifier's hidden leader line.

Visual Basic
Property HiddenLeaderLineTypeName() As String
Remarks

This property is a String.


IMcadDatumStandard::PointColor Property
Summary

Specifies the point color of datum identifiers referencing this standard.

Visual Basic
Property PointColor() As ACAD_COLOR
Remarks

The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:

  • sbByBlock: If sbByBlock is specified, new balloon objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
  • sbByLayer: If sbByLayer is specified, new balloon objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadDatumStandard::PointSize Property
Summary

Specifies the point size of datum identifiers referencing this standard.

Visual Basic
Property PointSize() As double
Remarks

This property is a Double.


IMcadDatumStandard2 Interface
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2
Visual Basic
Public Interface IMcadDatumStandard2
Inherits IMcadDatumStandard
Links
IMcadDatumStandard2 Members, SymBBAuto Library


IMcadDatumStandard2 Members
Summary

The following tables list the members exposed by IMcadDatumStandard2.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
PointTrueColor | Specifies the true color of a point.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadDatumStandard2::PointTrueColor Property
Summary

Specifies the true color of a point.

Visual Basic
Property PointTrueColor() As IAcadAcCmColor *
Parameters
Parameters | Description
pVal | _nt_


IMcadDatumTarget Interface
Summary

A datum target symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2
Visual Basic
Public Interface IMcadDatumTarget
Inherits IMcadSymbol2
Links
IMcadDatumTarget Members, SymBBAuto Library


IMcadDatumTarget Members
Summary

The following tables list the members exposed by IMcadDatumTarget.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.


IMcadDatumTarget::CircleRadius Property
Summary

Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.

Visual Basic
Property CircleRadius() As double
Remarks

Double


IMcadDatumTarget::DatumValue Property
Summary

Specifies the value of the Datum field of the datum target.

Visual Basic
Property DatumValue() As String
Remarks

This property is a String.


IMcadDatumTarget::DimensionValue Property
Summary

Specifies the dimension value for a datum target symbol.

Visual Basic
Property DimensionValue() As String
Remarks

This property is a String.


IMcadDatumTarget::DrawLine Property
Summary

Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.

Visual Basic
Property DrawLine() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadDatumTarget::DrawPoint Property
Summary

Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.

Visual Basic
Property DrawPoint() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadDatumTarget::LeaderLinetypeHidden Property
Summary

Specifies whether the datum target leader's linetype is hidden.

Visual Basic
Property LeaderLinetypeHidden() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadDatumTarget::LineEndPoint Property
Summary

Specifies the end point of the line target.

Visual Basic
Property LineEndPoint() As VARIANT
Remarks

This property is a only valid if the TargetType is sbLine.

This property is a Variant (3-element array of doubles).


IMcadDatumTarget::LineFactor Property
Summary

Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.

Visual Basic
Property LineFactor() As double
Remarks

The property is a only valid if the TargetType is sbLine.

This property is a Double.


IMcadDatumTarget::LineMidPoint Property
Summary

Gets the midpoint of the line target, or the leader start point.

Visual Basic
Property LineMidPoint() As VARIANT*
Remarks

This property is a only valid if the TargetType is sbLine.

This property is a Variant (3-element array of doubles).


IMcadDatumTarget::RectangleAngle Property
Summary

Specifies the angle of the rectangular area target.

Visual Basic
Property RectangleAngle() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.


IMcadDatumTarget::RectangleXSize Property
Summary

Specifies the X axis length of the rectangular area target.

Visual Basic
Property RectangleXSize() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.


IMcadDatumTarget::RectangleYSize Property
Summary

Specifies the Y axis length of the rectangular area target.

Visual Basic
Property RectangleYSize() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.


IMcadDatumTarget::TargetOrigin Property
Summary

Specifies the origin point of the datum target subsymbol.

Visual Basic
Property TargetOrigin() As VARIANT
Remarks

This property is a Variant (3-element array of doubles).


IMcadDatumTarget::TargetType Property
Summary

Specifies the termination type for a datum target.

Visual Basic
Property TargetType() As McadTargetType
Remarks

This property is a McadTargetType enumeration. It should only be called during the creation of a datum target, as the target type cannot be changed for existing datum target objects.


IMcadDatumTarget2 Interface
Summary

A datum target symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2
Visual Basic
Public Interface IMcadDatumTarget2
Inherits IMcadDatumTarget
Links
IMcadDatumTarget2 Members, SymBBAuto Library


IMcadDatumTarget2 Members
Summary

The following tables list the members exposed by IMcadDatumTarget2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetTargetAttach | Specifies the datum target to attach.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleCornerPoint | Specifies the rectangle corner point.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.


IMcadDatumTarget2::RectangleCornerPoint Property
Summary

Specifies the rectangle corner point.

Visual Basic
Property RectangleCornerPoint() As VARIANT
Remarks

This property is only used for datum targets with McadTargetType = sbRectangular.


IMcadDatumTarget2::SetTargetAttach Method
Summary

Specifies the datum target to attach.

Visual Basic
Sub SetTargetAttach(pDatumTarget As IMcadDatumTarget, Position As McadAttachPosition)
Parameters
Parameters | Description
pDatumTarget | Datum target to attach.
Position | Position of the datum target to attach.
Remarks

This method is only used for datum target with McadTargetType = sbAttach.


IMcadDetailSymbol Interface
Summary

This object represents the detail symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbol
Visual Basic
Public Interface IMcadDetailSymbol
Inherits IMcadSymbol2
Links
IMcadDetailSymbol Members, SymBBAuto Library


IMcadDetailSymbol Members
Summary

The following tables list the members exposed by IMcadDetailSymbol.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateLabelEntity | Create detail symbol label.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetSourceGeometry | Set source geometry for the symbol.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
BaseViewScale | Specifies scale of the base view.
CoordinateSystem | Specifies the coordinate system for the symbol.
CorrectionScaleFactor | Specifies scale factor when specify by factor.
DetailScale | Specifies scale of the detail View.
IsAssociativeDetail | Specifies whether to create associative details.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelEntity | Specifies the detail symbol label object.
LabelEntityOffset | Specifies the offset of the label.
LabelName | Specifies name of the label for the detail view.
LabelPattern | Specifies the label pattern for the detail view.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Radius | Specifies radius of the base view.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
SpecByAbsoluteScale | Specifies detail View to specify by absolute scale.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadDetailSymbol::AnnotationOffset Property
Summary

Specifies offset of the annotation.

Visual Basic
Property AnnotationOffset() As VARIANT


IMcadDetailSymbol::BaseViewScale Property
Summary

Specifies scale of the base view.

Visual Basic
Property BaseViewScale() As double


IMcadDetailSymbol::CorrectionScaleFactor Property
Summary

Specifies scale factor when specify by factor.

Visual Basic
Property CorrectionScaleFactor() As double


IMcadDetailSymbol::DetailScale Property
Summary

Specifies scale of the detail View.

Visual Basic
Property DetailScale() As double


IMcadDetailSymbol::IsAssociativeDetail Property
Summary

Specifies whether to create associative details.

Visual Basic
Property IsAssociativeDetail() As VARIANT_BOOL
Remarks

Note that this property is a not available for some standards.


IMcadDetailSymbol::LabelEntity Property
Summary

Specifies the detail symbol label object.

Visual Basic
Property LabelEntity() As IMcadDetailSymbolLabel*


IMcadDetailSymbol::LabelEntityOffset Property
Summary

Specifies the offset of the label.

Visual Basic
Property LabelEntityOffset() As VARIANT


IMcadDetailSymbol::LabelName Property
Summary

Specifies name of the label for the detail view.

Visual Basic
Property LabelName() As String


IMcadDetailSymbol::LabelPattern Property
Summary

Specifies the label pattern for the detail view.

Visual Basic
Property LabelPattern() As String


IMcadDetailSymbol::LabelText Property
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*


IMcadDetailSymbol::Radius Property
Summary

Specifies radius of the base view.

Visual Basic
Property Radius() As double


IMcadDetailSymbol::ShowAnnotationLeader Property
Summary

Specifies to show the annotation leader.

Visual Basic
Property ShowAnnotationLeader() As VARIANT_BOOL


IMcadDetailSymbol::ShowBorder Property
Summary

Specifies to show the view border.

Visual Basic
Property ShowBorder() As VARIANT_BOOL


IMcadDetailSymbol::ShowLeader Property
Summary

Specifies to show the leader.

Visual Basic
Property ShowLeader() As VARIANT_BOOL


IMcadDetailSymbol::SpecByAbsoluteScale Property
Summary

Specifies detail View to specify by absolute scale.

Visual Basic
Property SpecByAbsoluteScale() As VARIANT_BOOL
Remarks

VARIANT_TRUE indicates specify by absolute scale. VARIANT_FALSE indicates specify by factor.


IMcadDetailSymbol::CreateLabelEntity Method
Summary

Create detail symbol label.

Visual Basic
Sub CreateLabelEntity(Origin As VARIANT)
Parameters
Parameters | Description
Origin | Input origin of the detail symbol label. The VARIANT is a 3-element array of doubles for x, y, and z points.


IMcadDetailSymbol::SetSourceGeometry Method
Summary

Set source geometry for the symbol.

Visual Basic
Sub SetSourceGeometry(pVal As IAcadEntity)
Parameters
Parameters | Description
pVal | Geometry to be used as source geometry
Remarks

The entity should be a curve object except for 3D polyline.


IMcadDetailSymbolLabel Interface
Summary

This object represents the detail symbol label created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbolLabel
Visual Basic
Public Interface IMcadDetailSymbolLabel
Inherits IMcadSymbol2
Links
IMcadDetailSymbolLabel Members, SymBBAuto Library


IMcadDetailSymbolLabel Members
Summary

The following tables list the members exposed by IMcadDetailSymbolLabel.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelAbove | Specifies position of the label.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolEntity | Specifies the detail symbol object.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadDetailSymbolLabel::AnnotationOffset Property
Summary

Specifies offset of the annotation.

Visual Basic
Property AnnotationOffset() As VARIANT


IMcadDetailSymbolLabel::LabelAbove Property
Summary

Specifies position of the label.

Visual Basic
Property LabelAbove() As VARIANT_BOOL
Parameters
Parameters | Description
pVal | VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.


IMcadDetailSymbolLabel::LabelText Property
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*


IMcadDetailSymbolLabel::SymbolEntity Property
Summary

Specifies the detail symbol object.

Visual Basic
Property SymbolEntity() As IMcadDetailSymbol*


IMcadDetailSymbolStandard Interface
Summary

This object represents the Detail symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2
Visual Basic
Public Interface IMcadDetailSymbolStandard
Inherits IMcadSymbolStandard3
Links
IMcadDetailSymbolStandard Members, SymBBAuto Library


IMcadDetailSymbolStandard Members
Summary

The following tables list the members exposed by IMcadDetailSymbolStandard.

Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of the detail border.
LabelAbove | Specifies position of the label.
LabelPattern | Specifies the label pattern for the detail view.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadDetailSymbolStandard::AllowedScales Property
Summary

Specifies the list of allowable scales.

Visual Basic
Property AllowedScales() As VARIANT
Remarks

The Variant is an array of double.


IMcadDetailSymbolStandard::BorderLineType Property
Summary

Specifies the linetype of the detail border.

Visual Basic
Property BorderLineType() As String


IMcadDetailSymbolStandard::LabelAbove Property
Summary

Specifies position of the label.

Visual Basic
Property LabelAbove() As VARIANT_BOOL


IMcadDetailSymbolStandard::LabelPattern Property
Summary

Specifies the label pattern for the detail view.

Visual Basic
Property LabelPattern() As String


IMcadDetailSymbolStandard::ShowAnnotationLeader Property
Summary

Specifies to show the annotation leader.

Visual Basic
Property ShowAnnotationLeader() As VARIANT_BOOL


IMcadDetailSymbolStandard::ShowBorder Property
Summary

Specifies to show the view border.

Visual Basic
Property ShowBorder() As VARIANT_BOOL


IMcadDetailSymbolStandard::ShowLeader Property
Summary

Specifies to show the leader.

Visual Basic
Property ShowLeader() As VARIANT_BOOL


IMcadDetailSymbolStandard::AddAllowedScale Method
Summary

Add scale to the list of allowable scales.

Visual Basic
Sub AddAllowedScale(scale As double)


IMcadDetailSymbolStandard::EraseAllowedScales Method
Summary

Remove all allowable scales.

Visual Basic
Sub EraseAllowedScales()


IMcadDetailSymbolStandard2 Interface

IMcadDetailSymbolStandard2 Interface MG2013New
Summary

This interface is derived from IMcadDetailSymbolStandard. It is used for the detail view standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2
Visual Basic
Public Interface IMcadDetailSymbolStandard2
Inherits IMcadDetailSymbolStandard
Links
IMcadDetailSymbolStandard2 Members, SymBBAuto Library


IMcadDetailSymbolStandard2 Members
Summary

The following tables list the members exposed by IMcadDetailSymbolStandard2.

Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
GetByStandard | Gets if the specified detail view property follow the standard.
SetByStandard | Sets if the specified detail view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineColor | Specifies the color of the border line.
BorderLineLineType | Specifies the linetype of the border line.
BorderLineType | Specifies the linetype of the detail border.
BorderLineWeight | Specifies the lineweight of the border line.
BoundaryLineColor | Specifies the color of the boundary line.
BoundaryLineType | Specifies the linetype of the boundary line.
BoundaryLineWeight | Specifies the lineweight of the boundary line.
ConnectionLineColor | Specifies the color of the connection line.
ConnectionLineType | Specifies the linetype of the connection line.
ConnectionLineWeight | Specifies the lineweight of the connection line.
IdentifierOutsideBoundary | Specifies if the identifier is placed outside the boundary.
LabelAbove | Specifies position of the label.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern for the detail view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLabel | Specifies if show label.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property

IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property MG2013New
Summary

Specifies if the identifier is placed outside the boundary.

Visual Basic
Property IdentifierOutsideBoundary() As VARIANT_BOOL


IMcadDetailSymbolStandard2::BoundaryLineColor Property

IMcadDetailSymbolStandard2::BoundaryLineColor Property MG2013New
Summary

Specifies the color of the boundary line.

Visual Basic
Property BoundaryLineColor() As IAcadAcCmColor*


IMcadDetailSymbolStandard2::BoundaryLineType Property

IMcadDetailSymbolStandard2::BoundaryLineType Property MG2013New
Summary

Specifies the linetype of the boundary line.

Visual Basic
Property BoundaryLineType() As IAcadLineType*


IMcadDetailSymbolStandard2::BoundaryLineWeight Property

IMcadDetailSymbolStandard2::BoundaryLineWeight Property MG2013New
Summary

Specifies the lineweight of the boundary line.

Visual Basic
Property BoundaryLineWeight() As ACAD_LWEIGHT


IMcadDetailSymbolStandard2::BorderLineColor Property

IMcadDetailSymbolStandard2::BorderLineColor Property MG2013New
Summary

Specifies the color of the border line.

Visual Basic
Property BorderLineColor() As IAcadAcCmColor*


IMcadDetailSymbolStandard2::BorderLineLineType Property

IMcadDetailSymbolStandard2::BorderLineLineType Property MG2013New
Summary

Specifies the linetype of the border line.

Visual Basic
Property BorderLineLineType() As IAcadLineType*


IMcadDetailSymbolStandard2::BorderLineWeight Property

IMcadDetailSymbolStandard2::BorderLineWeight Property MG2013New
Summary

Specifies the lineweight of the border line.

Visual Basic
Property BorderLineWeight() As ACAD_LWEIGHT


IMcadDetailSymbolStandard2::ConnectionLineType Property

IMcadDetailSymbolStandard2::ConnectionLineType Property MG2013New
Summary

Specifies the linetype of the connection line.

Visual Basic
Property ConnectionLineType() As IAcadLineType*


IMcadDetailSymbolStandard2::ConnectionLineColor Property

IMcadDetailSymbolStandard2::ConnectionLineColor Property MG2013New
Summary

Specifies the color of the connection line.

Visual Basic
Property ConnectionLineColor() As IAcadAcCmColor*


IMcadDetailSymbolStandard2::ConnectionLineWeight Property

IMcadDetailSymbolStandard2::ConnectionLineWeight Property MG2013New
Summary

Specifies the lineweight of the connection line.

Visual Basic
Property ConnectionLineWeight() As ACAD_LWEIGHT


IMcadDetailSymbolStandard2::ShowLabel Property

IMcadDetailSymbolStandard2::ShowLabel Property MG2013New
Summary

Specifies if show label.

Visual Basic
Property ShowLabel() As VARIANT_BOOL


IMcadDetailSymbolStandard2::LabelTextStyle Property

IMcadDetailSymbolStandard2::LabelTextStyle Property MG2013New
Summary

Specifies the text style of view label.

Visual Basic
Property LabelTextStyle() As IAcadTextStyle*


IMcadDetailSymbolStandard2::LabelTextColor Property

IMcadDetailSymbolStandard2::LabelTextColor Property MG2013New
Summary

Specifies the text color of view label.

Visual Basic
Property LabelTextColor() As IAcadAcCmColor*


IMcadDetailSymbolStandard2::LabelTextHeight Property

IMcadDetailSymbolStandard2::LabelTextHeight Property MG2013New
Summary

Specifies the text height of view label.

Visual Basic
Property LabelTextHeight() As double


IMcadDetailSymbolStandard2::LabelOffset Property

IMcadDetailSymbolStandard2::LabelOffset Property MG2013New
Summary

Specifies the label offset from section view.

Visual Basic
Property LabelOffset() As double


IMcadDetailSymbolStandard2::GetByStandard Method

IMcadDetailSymbolStandard2::GetByStandard Method MG2013New
Summary

Gets if the specified detail view property follow the standard.

Visual Basic
Sub GetByStandard(propType As McadDetailSymbolStandardPropType, pVal As [out, retval] VARIANT_BOOL)


IMcadDetailSymbolStandard2::SetByStandard Method

IMcadDetailSymbolStandard2::SetByStandard Method MG2013New
Summary

Sets if the specified detail view property follow the standard.

Visual Basic
Sub SetByStandard(propType As McadDetailSymbolStandardPropType, newVal As VARIANT_BOOL)


IMcadDocument Interface
Summary

The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.

Class Hierarchy

Declaration syntax

IMcadDocument
Visual Basic
Public Interface IMcadDocument
Inherits IDispatch
Links
IMcadDocument Members, SymBBAuto Library


IMcadDocument Members
Summary

The following tables list the members exposed by IMcadDocument.

Properties
Name | Description
Application | Gets the AcadmApplication object.
LayerGroupMgr | Returns the layer group manager for the document.
LayerObjectMgr | This is LayerObjectMgr, a member of class IMcadDocument.
StructureMgr2D | Gets the 2D structure manager object for the document.
Utility | Gets the utility object.


IMcadDocument::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.


IMcadDocument::LayerGroupMgr Property
Summary

Returns the layer group manager for the document.

Visual Basic
Property LayerGroupMgr() As IMcadLayerGroupMgr**
Remarks

This property is a McadLayerGroupMgr object.


IMcadDocument::LayerObjectMgr Property
Summary

This is LayerObjectMgr, a member of class IMcadDocument.

Visual Basic
Property LayerObjectMgr() As IMcadLayerObjectMgr**


IMcadDocument::StructureMgr2D Property
Summary

Gets the 2D structure manager object for the document.

Visual Basic
Property StructureMgr2D() As IMcad2DStructureMgr2**
Remarks

This property is a Mcad2DStructureMgr object.


IMcadDocument::Utility Property
Summary

Gets the utility object.

Visual Basic
Property Utility() As IMcadUtility**
Remarks

This property is a McadUtility object.


IMcadEdge Interface
Summary

This object represents the edge symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadEdge
Visual Basic
Public Interface IMcadEdge
Inherits IMcadSymbol2
Links
IMcadEdge Members, SymBBAuto Library


IMcadEdge Members
Summary

The following tables list the members exposed by IMcadEdge.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllAround | Specifies the all-around designation for the edge symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
Direction | Property that specifies if the direction of the edge symbol's size is defined.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Majority | Specifies the appearance of the majority symbol.
MaxValue | Specifies the value of the upper boundary for the edge symbol.
MinValue | Specifies the value of the lower boundary for the edge symbol.
NewSymbolRev | Specifies if the edge symbol follows new standard revision.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SignValue | Specifies the sign ("+" or "-") for the edge symbol.
Standard | Gets the standard this symbol is used in.
StandardNumber | Specifies if the edge symbol displays the standard number.
SymbolStandard | Specifies the symbol standard for a symbol.
UndefsizeDirection | Property that specifies the direction for the edge symbol's undefined size.


IMcadEdge::AllAround Property
Summary

Specifies the all-around designation for the edge symbol.

Visual Basic
Property AllAround() As VARIANT_BOOL


IMcadEdge::Direction Property
Summary

Property that specifies if the direction of the edge symbol's size is defined.

Visual Basic
Property Direction() As VARIANT_BOOL
Remarks

TRUE indicates the direction is defined. FALSE indicates undefined.


IMcadEdge::Majority Property
Summary

Specifies the appearance of the majority symbol.

Visual Basic
Property Majority() As VARIANT_BOOL


IMcadEdge::MaxValue Property
Summary

Specifies the value of the upper boundary for the edge symbol.

Visual Basic
Property MaxValue() As String


IMcadEdge::MinValue Property
Summary

Specifies the value of the lower boundary for the edge symbol.

Visual Basic
Property MinValue() As String


IMcadEdge::NewSymbolRev Property
Summary

Specifies if the edge symbol follows new standard revision.

Visual Basic
Property NewSymbolRev() As VARIANT_BOOL


IMcadEdge::SignValue Property
Summary

Specifies the sign ("+" or "-") for the edge symbol.

Visual Basic
Property SignValue() As McadUndefinedSize


IMcadEdge::StandardNumber Property
Summary

Specifies if the edge symbol displays the standard number.

Visual Basic
Property StandardNumber() As VARIANT_BOOL
Remarks

This is supported only for DIN standard.


IMcadEdge::UndefsizeDirection Property
Summary

Property that specifies the direction for the edge symbol's undefined size.

Visual Basic
Property UndefsizeDirection() As McadUndefinedSizeDirection


IMcadEdgeLibrary Interface
Summary

The object representing Edge library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadEdgeLibrary
Visual Basic
Public Interface IMcadEdgeLibrary
Inherits IMcadSymbolLibrary
Links
SymBBAuto Library


IMcadEdgeLibraryObject Interface
Summary

The Edge library object.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject
Visual Basic
Public Interface IMcadEdgeLibraryObject
Inherits IMcadSymbolLibraryObject
Links
IMcadEdgeLibraryObject Members, SymBBAuto Library


IMcadEdgeLibraryObject Members
Summary

The following tables list the members exposed by IMcadEdgeLibraryObject.

Methods
Name | Description
RequirementValue | Property to get the main requirement value for the Edge symbol type.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" indication.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsDefinedDirection | Get if the direction of the symbol library object's size is defined.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
StandardNumber | Get the usage of the Standard label note for the symbol library object.
symbolStandardClassName | Get the symbol standard class name.
UndefsizeDirection | Get the direction for the symbol library object's undefined size.


IMcadEdgeLibraryObject::IsAllAround Property
Summary

Get the usage of the "all around" indication.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*


IMcadEdgeLibraryObject::IsDefinedDirection Property
Summary

Get if the direction of the symbol library object's size is defined.

Visual Basic
Property IsDefinedDirection() As VARIANT_BOOL*


IMcadEdgeLibraryObject::IsMajority Property
Summary

Get the usage of the majority symbol.

Visual Basic
Property IsMajority() As VARIANT_BOOL*


IMcadEdgeLibraryObject::StandardNumber Property
Summary

Get the usage of the Standard label note for the symbol library object.

Visual Basic
Property StandardNumber() As VARIANT_BOOL*


IMcadEdgeLibraryObject::UndefsizeDirection Property
Summary

Get the direction for the symbol library object's undefined size.

Visual Basic
Property UndefsizeDirection() As McadUndefinedSizeDirection*


IMcadEdgeLibraryObject::RequirementValue Method
Summary

Property to get the main requirement value for the Edge symbol type.

Visual Basic
Sub RequirementValue(variable As McadEdgeRequirement, pVal As [out,retval] BSTR)


IMcadEdgeStandard Interface
Summary

This object represents the edge symbol standard, Edges of Workpieces standard element.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadEdgeStandard
Visual Basic
Public Interface IMcadEdgeStandard
Inherits IMcadSymbolStandard3
Links
IMcadEdgeStandard Members, SymBBAuto Library


IMcadEdgeStandard Members
Summary

The following tables list the members exposed by IMcadEdgeStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all-around designation is allowed in the edge symbol.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
FullList | Specifies whether the majority symbol is full list or simplified.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether the majority symbol is allowed in the edge symbol.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
StandardNumAllowed | Specifies whether the standard number is allowed to be displayed in the edge symbol.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadEdgeStandard::AllAroundAllowed Property
Summary

Specifies whether the all-around designation is allowed in the edge symbol.

Visual Basic
Property AllAroundAllowed() As VARIANT_BOOL


IMcadEdgeStandard::FullList Property
Summary

Specifies whether the majority symbol is full list or simplified.

Visual Basic
Property FullList() As VARIANT_BOOL


IMcadEdgeStandard::MajorityAllowed Property
Summary

Specifies whether the majority symbol is allowed in the edge symbol.

Visual Basic
Property MajorityAllowed() As VARIANT_BOOL


IMcadEdgeStandard::StandardNumAllowed Property
Summary

Specifies whether the standard number is allowed to be displayed in the edge symbol.

Visual Basic
Property StandardNumAllowed() As VARIANT_BOOL*
Remarks

The default setting is set to TRUE for DIN standard only.


IMcadFCFLibrary Interface
Summary

Object representing the Feature Control Frame library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadFCFLibrary
Visual Basic
Public Interface IMcadFCFLibrary
Inherits IMcadSymbolLibrary
Links
SymBBAuto Library


IMcadFCFLibraryObject Interface
Summary

The Feature Control Frame library object.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadFCFLibraryObject
Visual Basic
Public Interface IMcadFCFLibraryObject
Inherits IMcadSymbolLibraryObject
Links
IMcadFCFLibraryObject Members, SymBBAuto Library


IMcadFCFLibraryObject Members
Summary

The following tables list the members exposed by IMcadFCFLibraryObject.

Methods
Name | Description
RequirementValue | Property to get the main requirement value for the FCF symbol type.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
Symbol | Get the geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol2 | Get the secondary geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol3 | Get the third geometric dimensioning and tolerancing symbol of a feature control frame library object.
symbolStandardClassName | Get the symbol standard class name.


IMcadFCFLibraryObject::IsAllAround Property
Summary

Get the usage of the "all around" symbol.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*


IMcadFCFLibraryObject::Symbol Property
Summary

Get the geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol() As McadGDTSymbolType*


IMcadFCFLibraryObject::Symbol2 Property
Summary

Get the secondary geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol2() As McadGDTSymbolType*


IMcadFCFLibraryObject::Symbol3 Property
Summary

Get the third geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol3() As McadGDTSymbolType*


IMcadFCFLibraryObject::RequirementValue Method
Summary

Property to get the main requirement value for the FCF symbol type.

Visual Basic
Sub RequirementValue(variable As McadFCFRequirement, pVal As [out,retval] BSTR)


IMcadFCFStandard Interface
Summary

A feature control frame symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2
Visual Basic
Public Interface IMcadFCFStandard
Inherits IMcadSymbolStandard3
Links
IMcadFCFStandard Members, SymBBAuto Library


IMcadFCFStandard Members
Summary

The following tables list the members exposed by IMcadFCFStandard.

Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadFCFStandard::AvailableAuxiliarySymbols Property
Summary

Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.

Visual Basic
Property AvailableAuxiliarySymbols() As VARIANT*
Remarks

The OfferedAuxiliarySymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant(array of McadGDTSymbolType enumeration).


IMcadFCFStandard::AvailableGDTSymbols Property
Summary

Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.

Visual Basic
Property AvailableGDTSymbols() As VARIANT *
Remarks

The OfferedGDTSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant(array of McadGDTSymbolType enumeration).


IMcadFCFStandard::EndPadding Property
Summary

Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property EndPadding() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFCFStandard::FrameGap Property
Summary

Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.

Visual Basic
Property FrameGap() As double
Remarks

This property is a Double.


IMcadFCFStandard::GDTTextFont Property
Summary

Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.

Visual Basic
Property GDTTextFont() As BSTR*
Remarks

This property is a String.


IMcadFCFStandard::GDTTextStyle Property
Summary

Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.

Visual Basic
Property GDTTextStyle() As IAcadTextStyle*
Remarks
  • This property is a cadTextStyle object.
  • AcadTextStyle (TextStyle) object is an object the AutoCAD ActiveX and VBA Reference documentation. It is a named and saved collection of settings that determines the appearance of text characters.


IMcadFCFStandard::GDTTextStyleName Property
Summary

Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.

Visual Basic
Property GDTTextStyleName() As String
Remarks

This property is a String.


IMcadFCFStandard::MergeDatum Property
Summary

Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeDatum() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFCFStandard::MergeSymbol Property
Summary

Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeSymbol() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFCFStandard::MergeTolerance Property
Summary

Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeTolerance() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFCFStandard::OfferedAuxiliarySymbols Property
Summary

Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.

Visual Basic
Property OfferedAuxiliarySymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableAuxiliarySymbols, they are ignored.


IMcadFCFStandard::OfferedGDTSymbols Property
Summary

Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.

Visual Basic
Property OfferedGDTSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableGDTSymbols, they are ignored.


IMcadFCFStandard::SeparateDatumID Property
Summary

Specifies whether the datum identifier symbol is displayed separate.

Visual Basic
Property SeparateDatumID() As VARIANT_BOOL


IMcadFCFStandard::SeparateProjected Property
Summary

Specifies whether the projected symbol is displayed separate.

Visual Basic
Property SeparateProjected() As VARIANT_BOOL


IMcadFCFStandard::GetSymbolImplementation Method
Summary

Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.

Visual Basic
Sub GetSymbolImplementation(Type As McadGDTSymbolType, Representation As [out, retval] BSTR)
Parameters
Parameters | Description
Type | McadGDTSymbolType enumeration; input-only. Specifies the symbol type to get the character string implementation representation for.
Returns

String


IMcadFCFStandard2 Interface
Summary

This is class IMcadFCFStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2
Visual Basic
Public Interface IMcadFCFStandard2
Inherits IMcadFCFStandard
Links
IMcadFCFStandard2 Members, SymBBAuto Library


IMcadFCFStandard2 Members
Summary

The following tables list the members exposed by IMcadFCFStandard2.

Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadFCFStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFCFStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadFCFStandard2::SurfIndLeaderArrowScale Property
Summary

This is SurfIndLeaderArrowScale, a member of class IMcadFCFStandard2.

Visual Basic
Property SurfIndLeaderArrowScale() As double


IMcadFCFStandard2::SurfIndLeaderArrowType Property
Summary

This is SurfIndLeaderArrowType, a member of class IMcadFCFStandard2.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType


IMcadFeatureControlFrame Interface
Summary

Implemets feature control frame symbols.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
Visual Basic
Public Interface IMcadFeatureControlFrame
Inherits IMcadSymbol2
Links
IMcadFeatureControlFrame Members, SymBBAuto Library


IMcadFeatureControlFrame Members
Summary

The following tables list the members exposed by IMcadFeatureControlFrame.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.


IMcadFeatureControlFrame::DatumIDValue Property
Summary

Specifies the value of the Datum ID field of a feature control frame.

Visual Basic
Property DatumIDValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumPrimary2Value Property
Summary

Specifies the value of the secondary Datum1 field of the feature control frame.

Visual Basic
Property DatumPrimary2Value() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumPrimary3Value Property
Summary

Specifies the value of the third Datum1 field of the feature control frame

Visual Basic
Property DatumPrimary3Value() As String


IMcadFeatureControlFrame::DatumPrimaryValue Property
Summary

Specifies the value of the Datum1 field of a feature control frame.

Visual Basic
Property DatumPrimaryValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumSecondary2Value Property
Summary

Specifies the value of the secondary Datum2 field of the feature control frame.

Visual Basic
Property DatumSecondary2Value() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumSecondary3Value Property
Summary

Specifies the value of the third Datum2 field of the feature control frame

Visual Basic
Property DatumSecondary3Value() As String


IMcadFeatureControlFrame::DatumSecondaryValue Property
Summary

Specifies the value of the Datum2 field of the feature control frame.

Visual Basic
Property DatumSecondaryValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumTertiary2Value Property
Summary

Specifies the value of the secondary Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiary2Value() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::DatumTertiary3Value Property
Summary

Specifies the value of the third Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiary3Value() As String


IMcadFeatureControlFrame::DatumTertiaryValue Property
Summary

Specifies the value of the Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiaryValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::IsAllAround Property
Summary

Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.

Visual Basic
Property IsAllAround() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadFeatureControlFrame::ProjectedValue Property
Summary

Specifies the value of the Projected Zone field of the feature control frame.

Visual Basic
Property ProjectedValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::Symbol Property
Summary

Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol() As McadGDTSymbolType
Remarks

This property is a McadGDTSymbolType enumeration.


IMcadFeatureControlFrame::Symbol2 Property
Summary

Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol2() As McadGDTSymbolType
Remarks

This property is a McadGDTSymbolType enumeration.


IMcadFeatureControlFrame::Symbol3 Property
Summary

Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol3() As McadGDTSymbolType


IMcadFeatureControlFrame::Tolerance2Value Property
Summary

Specifies the value of the secondary Tolerance 1 field of a feature control frame.

Visual Basic
Property Tolerance2Value() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::Tolerance3Value Property
Summary

Specifies the value of the third Tolerance 1 field of the feature control frame.

Visual Basic
Property Tolerance3Value() As String


IMcadFeatureControlFrame::ToleranceB2Value Property
Summary

Specifies the value of the secondary Tolerance 2 field of the feature control frame.

Visual Basic
Property ToleranceB2Value() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::ToleranceBValue Property
Summary

Specifies the value of the Tolerance 2 field of the feature control frame.

Visual Basic
Property ToleranceBValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame::ToleranceValue Property
Summary

Specifies the value of the Tolerance 1 field of the feature control frame.

Visual Basic
Property ToleranceValue() As String
Remarks

This property is a String.


IMcadFeatureControlFrame2 Interface
Summary

IMcadFeatureControlFrame extended interface.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
Visual Basic
Public Interface IMcadFeatureControlFrame2
Inherits IMcadFeatureControlFrame
Links
IMcadFeatureControlFrame2 Members, SymBBAuto Library


IMcadFeatureControlFrame2 Members
Summary

The following tables list the members exposed by IMcadFeatureControlFrame2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


IMcadFeatureControlFrame2::BottomNoteValue Property
Summary

Specifies and places all notes related to the tolerance below the feature control frame symbol.

Visual Basic
Property BottomNoteValue() As String


IMcadFeatureControlFrame2::TopNoteValue Property
Summary

Specifies and places all notes related to the tolerance above the feature control frame symbol.

Visual Basic
Property TopNoteValue() As String


IMcadFeatureControlFrame3 Interface
Summary

This is class IMcadFeatureControlFrame3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4
Visual Basic
Public Interface IMcadFeatureControlFrame3
Inherits IMcadFeatureControlFrame2
Links
IMcadFeatureControlFrame3 Members, SymBBAuto Library


IMcadFeatureControlFrame3 Members
Summary

The following tables list the members exposed by IMcadFeatureControlFrame3.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


IMcadFeatureControlFrame3::SurfExtLinesOffset Property
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.


IMcadFeatureControlFrame3::SurfExtLinesOvershot Property
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double


IMcadFeatureControlFrame3::AddStdCompliantLeader Method
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().


IMcadFeatureControlFrame4 Interface
Summary

This is class IMcadFeatureControlFrame4.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4
Visual Basic
Public Interface IMcadFeatureControlFrame4
Inherits IMcadFeatureControlFrame3
Links
IMcadFeatureControlFrame4 Members, SymBBAuto Library


IMcadFeatureControlFrame4 Members
Summary

The following tables list the members exposed by IMcadFeatureControlFrame4.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AddSurfIndLeader
This is AddSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadFeatureControlFrame4.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
RemoveSurfIndLeader
This is RemoveSurfIndLeader, a member of class IMcadFeatureControlFrame4.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFeatureControlFrame4.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property
Summary

This is SurfIndLeaderArrowType, a member of class IMcadFeatureControlFrame4.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType


IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method
Summary

This is AddLeaderWithSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub AddLeaderWithSurfIndLeader(Points As VARIANT)


IMcadFeatureControlFrame4::AddSurfIndLeader Method
Summary

This is AddSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub AddSurfIndLeader(Points As VARIANT)


IMcadFeatureControlFrame4::GetSurfIndLeader Method
Summary

This is GetSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub GetSurfIndLeader(pVal As [out, retval] VARIANT)


IMcadFeatureControlFrame4::RemoveSurfIndLeader Method
Summary

This is RemoveSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub RemoveSurfIndLeader()


IMcadFeatureIdentifier Interface
Summary

A feature identifier symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2
Visual Basic
Public Interface IMcadFeatureIdentifier
Inherits IMcadIdentifier
Links
SymBBAuto Library


IMcadFeatureIdentifier2 Interface
Summary

This is class IMcadFeatureIdentifier2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2
Visual Basic
Public Interface IMcadFeatureIdentifier2
Inherits IMcadFeatureIdentifier
Links
IMcadFeatureIdentifier2 Members, SymBBAuto Library


IMcadFeatureIdentifier2 Members
Summary

The following tables list the members exposed by IMcadFeatureIdentifier2.

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


IMcadFeatureIdentifier2::SurfExtLinesOffset Property
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.


IMcadFeatureIdentifier2::SurfExtLinesOvershot Property
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double


IMcadFeatureIdentifier2::AddStdCompliantLeader Method
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().


IMcadIdentifier Interface
Summary

An identifier symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
            IMcadFeatureIdentifier
Visual Basic
Public Interface IMcadIdentifier
Inherits IMcadSymbol2
Links
IMcadIdentifier Members, SymBBAuto Library


IMcadIdentifier Members
Summary

The following tables list the members exposed by IMcadIdentifier.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


IMcadIdentifier::Value Property
Summary

Specifies the value of the feature or datum identifier. The maximum length of the value is 2.

Visual Basic
Property Value() As String
Remarks

This property is a String.


IMcadIdentifierStandard Interface
Summary

An identifier symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2
Visual Basic
Public Interface IMcadIdentifierStandard
Inherits IMcadSymbolStandard3
Links
IMcadIdentifierStandard Members, SymBBAuto Library


IMcadIdentifierStandard Members
Summary

The following tables list the members exposed by IMcadIdentifierStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadIdentifierStandard::DefaultArrowType Property
Summary

Gets the default arrow type for identifier symbols created referencing this standard.

Visual Basic
Property DefaultArrowType() As McadArrowType*
Remarks

This property is a McadArrowType enumeration.


IMcadIdentifierStandard::IsDatumIDSupported Property
Summary

Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.

Visual Basic
Property IsDatumIDSupported() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadIdentifierStandard::IsFeatureIDSupported Property
Summary

Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.

Visual Basic
Property IsFeatureIDSupported() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadIdentifierStandard2 Interface
Summary

This is class IMcadIdentifierStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2
Visual Basic
Public Interface IMcadIdentifierStandard2
Inherits IMcadIdentifierStandard
Links
IMcadIdentifierStandard2 Members, SymBBAuto Library


IMcadIdentifierStandard2 Members
Summary

The following tables list the members exposed by IMcadIdentifierStandard2.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
FarSideLeaderLineType | This is FarSideLeaderLineType, a member of class IMcadIdentifierStandard2.
FarSideLeaderLineTypeName | This is FarSideLeaderLineTypeName, a member of class IMcadIdentifierStandard2.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadIdentifierStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadIdentifierStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadIdentifierStandard2::FarSideLeaderLineType Property
Summary

This is FarSideLeaderLineType, a member of class IMcadIdentifierStandard2.

Visual Basic
Property FarSideLeaderLineType() As IAcadLineType*


IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property
Summary

This is FarSideLeaderLineTypeName, a member of class IMcadIdentifierStandard2.

Visual Basic
Property FarSideLeaderLineTypeName() As String


IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property
Summary

This is SurfIndLeaderArrowScale, a member of class IMcadIdentifierStandard2.

Visual Basic
Property SurfIndLeaderArrowScale() As double


IMcadIdentifierStandard2::SurfIndLeaderArrowType Property
Summary

This is SurfIndLeaderArrowType, a member of class IMcadIdentifierStandard2.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType


IMcadJoint Interface
Summary

The IMcadJoint interface.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadJoint
Visual Basic
Public Interface IMcadJoint
Inherits IMcadSymbol2
Links
IMcadJoint Members, SymBBAuto Library


IMcadJoint Members
Summary

The following tables list the members exposed by IMcadJoint.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllAround | Specifes whether the Dead Joint symbol is all around.
Annotation | Specifes the annotation text of Dead Joint symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifes the additional annotation text of Dead Joint symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecAnnotation | Specifes the additional annotation text of Dead Joint symbol.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies the type of Dead Joint symbol.


IMcadJoint::AllAround Property
Summary

Specifes whether the Dead Joint symbol is all around.

Visual Basic
Property AllAround() As VARIANT_BOOL


IMcadJoint::Annotation Property
Summary

Specifes the annotation text of Dead Joint symbol.

Visual Basic
Property Annotation() As String


IMcadJoint::Orientation Property
Summary

Specifes the additional annotation text of Dead Joint symbol.

Visual Basic
Property Orientation() As McadOrientation


IMcadJoint::SecAnnotation Property
Summary

Specifes the additional annotation text of Dead Joint symbol.

Visual Basic
Property SecAnnotation() As String


IMcadJoint::SymbolType Property
Summary

Specifies the type of Dead Joint symbol.

Visual Basic
Property SymbolType() As McadJointType


IMcadJointStandard Interface
Summary

This object represents a Dead Joint symbol standard created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadJointStandard
Visual Basic
Public Interface IMcadJointStandard
Inherits IMcadSymbolStandard3
Links
SymBBAuto Library


IMcadMarkStamp Interface
Summary

Interface for working with the Marking/Stamping symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadMarkStamp
Visual Basic
Public Interface IMcadMarkStamp
Inherits IMcadSymbol2
Remarks

Interface for McadMarkStamp.

Links
IMcadMarkStamp Members, SymBBAuto Library


IMcadMarkStamp Members
Summary

The following tables list the members exposed by IMcadMarkStamp.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
ContentValue | Specifies the marking or stamping contents.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MethodValue | Specifies the marking or stamping method.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies whether the symbol is a marking or stamping symbol.
TechnicalReqValue | Specifies a reference to a technical requirement.


IMcadMarkStamp::ContentValue Property
Summary

Specifies the marking or stamping contents.

Visual Basic
Property ContentValue() As String


IMcadMarkStamp::MethodValue Property
Summary

Specifies the marking or stamping method.

Visual Basic
Property MethodValue() As String


IMcadMarkStamp::SymbolType Property
Summary

Specifies whether the symbol is a marking or stamping symbol.

Visual Basic
Property SymbolType() As BSTR*


IMcadMarkStamp::TechnicalReqValue Property
Summary

Specifies a reference to a technical requirement.

Visual Basic
Property TechnicalReqValue() As String


IMcadMarkStampStandard Interface
Summary

Interface for working with the Marking/Stamping symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadMarkStampStandard
Visual Basic
Public Interface IMcadMarkStampStandard
Inherits IMcadSymbolStandard3
Remarks

The McadMarkStampStandard COM object is the wrapper for the AcmMarkStampStd class.

Links
IMcadMarkStampStandard Members, SymBBAuto Library


IMcadMarkStampStandard Members
Summary

The following tables list the members exposed by IMcadMarkStampStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableMarkingContents | Gets the list of symbols that are available for marking contents referencing this standard.
AvailableMarkingMethods | Gets the list of symbols that are available for marking methods referencing this standard.
AvailableStampingContents | Gets the list of symbols that are available for stamping contents referencing this standard.
AvailableStampingMethods | Gets the list of symbols that are available for stamping methods referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedMarkingContents | Specifies the list of symbols that are offered for marking contents referencing this standard.
OfferedMarkingMethods | Specifies the list of symbols that are offered for marking methods referencing this standard.
OfferedStampingContents | Specifies the list of symbols that are offered for stamping contents referencing this standard.
OfferedStampingMethods | Specifies the list of symbols that are offered for stamping methods referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadMarkStampStandard::AvailableMarkingContents Property
Summary

Gets the list of symbols that are available for marking contents referencing this standard.

Visual Basic
Property AvailableMarkingContents() As VARIANT*


IMcadMarkStampStandard::AvailableMarkingMethods Property
Summary

Gets the list of symbols that are available for marking methods referencing this standard.

Visual Basic
Property AvailableMarkingMethods() As VARIANT*


IMcadMarkStampStandard::AvailableStampingContents Property
Summary

Gets the list of symbols that are available for stamping contents referencing this standard.

Visual Basic
Property AvailableStampingContents() As VARIANT*


IMcadMarkStampStandard::AvailableStampingMethods Property
Summary

Gets the list of symbols that are available for stamping methods referencing this standard.

Visual Basic
Property AvailableStampingMethods() As VARIANT*


IMcadMarkStampStandard::OfferedMarkingContents Property
Summary

Specifies the list of symbols that are offered for marking contents referencing this standard.

Visual Basic
Property OfferedMarkingContents() As VARIANT


IMcadMarkStampStandard::OfferedMarkingMethods Property
Summary

Specifies the list of symbols that are offered for marking methods referencing this standard.

Visual Basic
Property OfferedMarkingMethods() As VARIANT


IMcadMarkStampStandard::OfferedStampingContents Property
Summary

Specifies the list of symbols that are offered for stamping contents referencing this standard.

Visual Basic
Property OfferedStampingContents() As VARIANT


IMcadMarkStampStandard::OfferedStampingMethods Property
Summary

Specifies the list of symbols that are offered for stamping methods referencing this standard.

Visual Basic
Property OfferedStampingMethods() As VARIANT


IMcadNote Interface
Summary

This object represents the Note symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadNote
Visual Basic
Public Interface IMcadNote
Inherits IMcadSymbol2
Links
IMcadNote Members, SymBBAuto Library


IMcadNote Members
Summary

The following tables list the members exposed by IMcadNote.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustLanding | Specifies new landing for the note symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateNoteText | Creates text in note symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
EvaluatedNoteText | Property to specify the rendered text of variables or expressions.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsLeftOriented | Specify if text in note symbol is left-aligned.
Landing | Specifies if note symbol has landing (the extension of the leader line that underlines the text).
LeaderAttachPoint | Specifies the justification of the leader in the note symbol.
LeaderCount | Gets the number of leaders attached to a specific symbol.
NoteText | Specifies the text in the note symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TextAlignment | Specifies the alignment of the text in the note symbol.


IMcadNote::EvaluatedNoteText Property
Summary

Property to specify the rendered text of variables or expressions.

Visual Basic
Property EvaluatedNoteText() As BSTR*


IMcadNote::IsLeftOriented Property
Summary

Specify if text in note symbol is left-aligned.

Visual Basic
Property IsLeftOriented() As VARIANT_BOOL
Remarks

The variant is TRUE if left-aligned and FALSE if right-aligned.


IMcadNote::Landing Property
Summary

Specifies if note symbol has landing (the extension of the leader line that underlines the text).

Visual Basic
Property Landing() As VARIANT_BOOL
Remarks

To add a landing the Landing method must be called after CreatNoteText.


IMcadNote::LeaderAttachPoint Property
Summary

Specifies the justification of the leader in the note symbol.

Visual Basic
Property LeaderAttachPoint() As McadNoteAttachPointType
Remarks

This method should be called after creating note text.


IMcadNote::NoteText Property
Summary

Specifies the text in the note symbol.

Visual Basic
Property NoteText() As String
Remarks

To initially add note text, use the CreateNoteText method. The CreateNoteText method will set the text at an offset from the tip of the leader point (so it should be called after adding the leaders). To add a landing (the extension of the leader line that underlines the text), the Landing method must be called after CreatNoteText.


IMcadNote::TextAlignment Property
Summary

Specifies the alignment of the text in the note symbol.

Visual Basic
Property TextAlignment() As McadAlignmentType


IMcadNote::AdjustLanding Method
Summary

Specifies new landing for the note symbol.

Visual Basic
Sub AdjustLanding(newPoint As VARIANT)
Parameters
Parameters | Description
newPoint | _nt_
Remarks

The VARIANT should contain a SAFEARRAY of three doubles. Hint: Use AcAxPoint3d to convert VARIANT to AcGePoint3d.


IMcadNote::CreateNoteText Method
Summary

Creates text in note symbol.

Visual Basic
Sub CreateNoteText(newVal As String)
Remarks

This method will set the text at an offset from the tip of leader point. So it should be called after adding leaders. To add a landing (the extension of the leader line that underlines the text), the Landing method must be called after CreatNoteText.


IMcadNoteStandard Interface
Summary

This object represents the Note symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadNoteStandard
Visual Basic
Public Interface IMcadNoteStandard
Inherits IMcadSymbolStandard3
Links
IMcadNoteStandard Members, SymBBAuto Library


IMcadNoteStandard Members
Summary

The following tables list the members exposed by IMcadNoteStandard.

Methods
Name | Description
AddTemplate | Adds new template and its value to the specified template group.
ChangeTemplateValue | Changes the value of template in the specified template group.
DeleteAllTemplates | Deletes all templates in all template groups.
DeleteTemplate | Deletes template from the specified template group.
GetAllTemplates | Get all templates for the group with given type.
GetFeatureTypes | Get type of features that the note symbol is attached to.
GetTemplateGroup | Gets the type and name of the template group for the specified index.
GetTemplateValue | Gets the non-evaluated value of the template for specified template type and name.
NumberOfTemplateGroups | Gets number of template groups that the note standard holds.
RenameTemplate | Renames template in the specified template group.
SetCompatibilityCondition | Sets up the feature type(s) you are interested in.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTemplate | Sets the default template in the specified template group.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
Landing | Specifies if note symbol has landing.
LeaderAttachPoint | Specifies default leader justification of the text in note symbol.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadNoteStandard::Landing Property
Summary

Specifies if note symbol has landing.

Visual Basic
Property Landing() As VARIANT_BOOL


IMcadNoteStandard::LeaderAttachPoint Property
Summary

Specifies default leader justification of the text in note symbol.

Visual Basic
Property LeaderAttachPoint() As McadNoteAttachPointType


IMcadNoteStandard::AddTemplate Method
Summary

Adds new template and its value to the specified template group.

Visual Basic
Sub AddTemplate(groupType As VARIANT, tempName As String, value As String, allowNewGroup As [in,defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
value | Input value of the template
allowNewGroup | TRUE if allow to create new template group if the specified template group does not exist. Default is TRUE.
tempname | Input name of the template


IMcadNoteStandard::ChangeTemplateValue Method
Summary

Changes the value of template in the specified template group.

Visual Basic
Sub ChangeTemplateValue(groupType As VARIANT, tempName As String, value As String, updateDimStyles As [in,defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
value | Input new value of the template
updateDimStyles | TRUE if update dimension styles. Default is TRUE.
tempname | Input name of the template


IMcadNoteStandard::DeleteAllTemplates Method
Summary

Deletes all templates in all template groups.

Visual Basic
Sub DeleteAllTemplates(deleteGroups As [in,defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
deleteGroups | TRUE if delete template groups. Default is FALSE.


IMcadNoteStandard::DeleteTemplate Method
Summary

Deletes template from the specified template group.

Visual Basic
Sub DeleteTemplate(groupType As VARIANT, tempName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
tempname | Input name of the template


IMcadNoteStandard::GetAllTemplates Method
Summary

Get all templates for the group with given type.

Visual Basic
Sub GetAllTemplates(groupType As VARIANT, tempNames As [out,retval] VARIANT)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.


IMcadNoteStandard::GetFeatureTypes Method
Summary

Get type of features that the note symbol is attached to.

Visual Basic
Sub GetFeatureTypes(noteSym As IMcadNote, featureType As [out,retval] VARIANT)
Parameters
Parameters | Description
noteSym | Input note symbol object


IMcadNoteStandard::GetTemplateGroup Method
Summary

Gets the type and name of the template group for the specified index.

Visual Basic
Sub GetTemplateGroup(index As LONG, onlyCompatible As [in,defaultvalue(FALSE)] VARIANT_BOOL, groupType As [out,retval] VARIANT)
Parameters
Parameters | Description
onlyCompatible | Input flag to indicate if only allow compatible template group
Index | Input index of the list of template group.


IMcadNoteStandard::GetTemplateValue Method
Summary

Gets the non-evaluated value of the template for specified template type and name.

Visual Basic
Sub GetTemplateValue(groupType As VARIANT, tempname As String, pValue As [out,retval] BSTR)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
tempname | Input name of the template


IMcadNoteStandard::NumberOfTemplateGroups Method
Summary

Gets number of template groups that the note standard holds.

Visual Basic
Sub NumberOfTemplateGroups(onlyCompatible As [in,defaultvalue(FALSE)] VARIANT_BOOL, number As [out,retval] int)
Parameters
Parameters | Description
onlyCompatible | Input flag to indicate if only allow compatible template group


IMcadNoteStandard::RenameTemplate Method
Summary

Renames template in the specified template group.

Visual Basic
Sub RenameTemplate(groupType As VARIANT, oldTempName As String, newTempName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
oldTempName | Input original name of the template.
newTempName | Input new name of the template.


IMcadNoteStandard::SetCompatibilityCondition Method
Summary

Sets up the feature type(s) you are interested in.

Visual Basic
Sub SetCompatibilityCondition(groupType As VARIANT)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
Remarks

To reset the condition to allow all groups, use an array with zero logical length as an argument.


IMcadNoteStandard::SetToDefaultTemplate Method
Summary

Sets the default template in the specified template group.

Visual Basic
Sub SetToDefaultTemplate(groupType As VARIANT, temName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
temName | Input name of the default template.


IMcadPartList Interface
Summary

A part list symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
            IMcadPartListGOST
Visual Basic
Public Interface IMcadPartList
Inherits IMcadSymbol2
Links
IMcadPartList Members, SymBBAuto Library


IMcadPartList Members
Summary

The following tables list the members exposed by IMcadPartList.

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


IMcadPartList::AttachmentPoint Property
Summary

Specifies the placement of the base point for the part list.

Visual Basic
Property AttachmentPoint() As McadAttachmentPoint
Remarks

This property is a McadAttachmentPoint enumeration.


IMcadPartList::BOM Property
Summary

Specifies the bill of materials table that this parts list is referencing.

Visual Basic
Property BOM() As IMcadBOM*
Remarks

This property is a McadBOM collection.


IMcadPartList::CustomBlockName Property
Summary

Specifies the custom block scheme name used to display this parts list.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.


IMcadPartList::CustomBlocks Property
Summary

Gets the custom blocks used to display this parts list.

Visual Basic
Property CustomBlocks() As VARIANT*
Remarks

This property is a Variant (2-element array of AcadBlock objects).


IMcadPartList::FilterEmptyBlocks Property
Summary

Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.

Visual Basic
Property FilterEmptyBlocks() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartList::Filters Property
Summary

Gets the list of filters for a parts list.

Visual Basic
Property Filters() As IMcadPartListFilters**
Remarks

This property is a n McadPartListFilters collection.


IMcadPartList::Height Property
Summary

Specifies the height of a parts list.

Visual Basic
Property Height() As double
Remarks

This property is a Double.


IMcadPartList::IsCustomBlockUsed Property
Summary

Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadPartList::IsHeadingEnabled Property
Summary

Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsHeadingEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartList::IsTitleEnabled Property
Summary

Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsTitleEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartList::ItemList Property
Summary

Specifies all the BOM items included in a part list.

Visual Basic
Property ItemList() As IMcadBOMItems*
Remarks

This property is McadBOMItems collections.


IMcadPartList::MappingName Property
Summary

Specifies the name of the custom mapping.

Visual Basic
Property MappingName() As String
Remarks

This property is a String.


IMcadPartList::MultipleRow Property
Summary

Specifies the single, double, or triple lines of text in the rows for the parts list.

Visual Basic
Property MultipleRow() As long
Remarks

Valid values include 1, 2, or 3.

This property is a Long.


IMcadPartList::Title Property
Summary

Specifies the parts list's title text.

Visual Basic
Property Title() As String
Remarks

This is String.


IMcadPartList::ViewID Property
Summary

Specifies the object ID of the drawing view that this parts list is associated with.

Visual Basic
Property ViewID() As LONG_PTR
Remarks

This property is a Long.


IMcadPartList::ViewID32 Property
Summary

Specifies the object ID of the drawing view that this parts list is associated with.

Visual Basic
Property ViewID32() As LONG
Remarks

This property is a Long.


IMcadPartList::Width Property
Summary

Specifies the width of a parts list.

Visual Basic
Property Width() As double
Remarks

This property is a Double.


IMcadPartList::WrapText Property
Summary

Property that specifies whether the Parts List heading and row text wraps.

Visual Basic
Property WrapText() As VARIANT_BOOL
Remarks

Reading from this property retrieves the row text wrap state. When this property is a VARIANT_TRUE, reading from the RowTextControl property returns sbWrap to indicate the same row text wrap state. Writing to this property sets the heading and row text wrap states. This is the same as writing to both the HeadingTextControl and RowTextControl properties, setting them to sbWrap. This property is a replaced by the HeadingTextControl and RowTextControl properties.


IMcadPartList::AddFilter Method
Summary

Creates a filter of the specified type and adds it to the part list filter list.

Visual Basic
Sub AddFilter(Name As String, Filter As [out, retval] IMcadPartListFilter*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the filter name to be created.
Returns

McadPartListFilter object

Remarks
  • A newly added parts list filter only take effect until the McadPartListFilter > IsOn property is TRUE.
  • The filter name can be obtained using the McadPartListFilter > Name property.


IMcadPartList::RemoveFilter Method
Summary

Removes the specified part list filter from this part list.

Visual Basic
Sub RemoveFilter(Filter As IMcadPartListFilter, Erase As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Filter | McadPartListFilter object; input-only. Specifies the parts list filter to be removed from the Filters/Group field.
Erase | Boolean, default value = True; input-only; optional. Specifies whether or not the parts list filter is eternally erased, TRUE, or not, FALSE.
Returns

None


IMcadPartList2 Interface
Summary

A part list symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3
Visual Basic
Public Interface IMcadPartList2
Inherits IMcadPartList
Links
IMcadPartList2 Members, SymBBAuto Library


IMcadPartList2 Members
Summary

The following tables list the members exposed by IMcadPartList2.

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


IMcadPartList2::ColumnSplitEnabled Property
Summary

Property that specifies whether the Parts List column split is enabled.

Visual Basic
Property ColumnSplitEnabled() As VARIANT_BOOL


IMcadPartList2::ColumnSplitRows Property
Summary

Property that specifies the Parts List column split rows.

Visual Basic
Property ColumnSplitRows() As long


IMcadPartList2::ColumnSplitSections Property
Summary

Property that specifies the Parts List column split sections.

Visual Basic
Property ColumnSplitSections() As long


IMcadPartList2::ColumnSplitStyle Property
Summary

Property that specifies the Parts List column split style.

Visual Basic
Property ColumnSplitStyle() As McadColumnSplitStyle


IMcadPartList2::ColumnSplitWrap Property
Summary

Property that specifies the Parts List column split wrap direction.

Visual Basic
Property ColumnSplitWrap() As McadColumnSplitWrap


IMcadPartList2::FormulaBarEnabled Property
Summary

Property that specifies whether the Parts List formula bar is enabled.

Visual Basic
Property FormulaBarEnabled() As VARIANT_BOOL


IMcadPartList2::GripFrameEnabled Property
Summary

Property that specifies whether the Parts List grip frame is enabled.

Visual Basic
Property GripFrameEnabled() As VARIANT_BOOL


IMcadPartList2::HeadingTextControl Property
Summary

Property that specifies the Parts List heading text control.

Visual Basic
Property HeadingTextControl() As McadTextControl


IMcadPartList2::ResultBarEnabled Property
Summary

Property that specifies whether the Parts List result bar is enabled.

Visual Basic
Property ResultBarEnabled() As VARIANT_BOOL


IMcadPartList2::RowTextControl Property
Summary

Property that specifies the Parts List row text control.

Visual Basic
Property RowTextControl() As McadTextControl


IMcadPartList2::AddFilterType Method
Summary

Creates a filter of a specified type and adds it to the Parts List.

Visual Basic
Sub AddFilterType(enType As McadFilterType, Filter As [out, retval] IMcadPartListFilter*)
Remarks

Returns the filter object of the specified type.


IMcadPartList3 Interface
Summary

Stores the Parts List symbol settings information.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3
Visual Basic
Public Interface IMcadPartList3
Inherits IMcadPartList2
Links
IMcadPartList3 Members, SymBBAuto Library


IMcadPartList3 Members
Summary

The following tables list the members exposed by IMcadPartList3.

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
setWrapPListAttachPoint | Sets the attach point of a parts list that wraps around the title block.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapAroundTitle | Specifies whether the parts list can be wrapped around the title block.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
WrapTitleBlockId | Specifies the Id of the title block which is wrapped around.
WrapTitleBlockId32 | Specifies the Id of the title block which is wrapped around. Only available for x64 platform.


IMcadPartList3::WrapAroundTitle Property
Summary

Specifies whether the parts list can be wrapped around the title block.

Visual Basic
Property WrapAroundTitle() As VARIANT_BOOL


IMcadPartList3::WrapTitleBlockId Property
Summary

Specifies the Id of the title block which is wrapped around.

Visual Basic
Property WrapTitleBlockId() As LONG_PTR
Remarks

Also calculates the title block height.


IMcadPartList3::WrapTitleBlockId32 Property
Summary

Specifies the Id of the title block which is wrapped around. Only available for x64 platform.

Visual Basic
Property WrapTitleBlockId32() As LONG
Remarks

Calculates title block height.


IMcadPartList3::setWrapPListAttachPoint Method
Summary

Sets the attach point of a parts list that wraps around the title block.

Visual Basic
Sub setWrapPListAttachPoint(pVal As [out, retval] VARIANT)
Parameters
Parameters | Description
pVal | Variant; output only. Specifies the insertion point of the parts list.


IMcadPartListBalloonedFilter Interface
Summary

A filter object that filters the contents of a Parts List by ballooned parts.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter
Visual Basic
Public Interface IMcadPartListBalloonedFilter
Inherits IMcadPartListFilter2
Links
SymBBAuto Library


IMcadPartListCustomFilter Interface
Summary

A filter object that filters the contents of a Parts List by a BOM property.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter
Visual Basic
Public Interface IMcadPartListCustomFilter
Inherits IMcadPartListFilter2
Links
IMcadPartListCustomFilter Members, SymBBAuto Library


IMcadPartListCustomFilter Members
Summary

The following tables list the members exposed by IMcadPartListCustomFilter.

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.


IMcadPartListCustomFilter::Operator Property
Summary

Specifies the filter operator used by the Parts List custom filter to filter parts.

Visual Basic
Property Operator() As McadFilterOperator*


IMcadPartListCustomFilter::PropertyName Property
Summary

Specifies the BOM property name used by the Parts List custom filter to filter parts.

Visual Basic
Property PropertyName() As BSTR*


IMcadPartListCustomFilter::PropertyValue Property
Summary

Specifies the BOM property value used by the Parts List custom filter to filter parts.

Visual Basic
Property PropertyValue() As BSTR*


IMcadPartListCustomFilter::SetCondition Method
Summary

Specifies the filter condition used by the Parts List custom filter to filter parts.

Visual Basic
Sub SetCondition(strPropertyName As String, enOperator As McadFilterOperator, strPropertyValue As String)
Parameters
Parameters | Description
strPropertyName | Input parameter. The BOM property name used by the Parts List custom filter to filter parts.
enOperator | Input parameter. The filter operator used by the Parts List custom filter to filter parts.
strPropertyValue | Input parameter. The BOM property value used by the Parts List custom filter to filter parts.


IMcadPartListFilter Interface
Summary

An object that filters the contents of a parts list.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
Visual Basic
Public Interface IMcadPartListFilter
Inherits IAcadObject
Links
IMcadPartListFilter Members, SymBBAuto Library


IMcadPartListFilter Members
Summary

The following tables list the members exposed by IMcadPartListFilter.

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
Properties
Name | Description
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.


IMcadPartListFilter::IsOn Property
Summary

Specifies whether the part list filter is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsOn() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • A newly added parts list filter only take effect until the IsOn property is a TRUE. To add a new parts list filter, use the McadPartList > AddFilter method.


IMcadPartListFilter::Name Property
Summary

Specifies the name of the parts list filter.

Visual Basic
Property Name() As BSTR*
Remarks

This property is a String.


IMcadPartListFilter::Evaluate Method
Summary

Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.

Visual Basic
Sub Evaluate(Item As IMcadBOMItem, Pass As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item to evaluate the filter on.
Returns

Boolean


IMcadPartListFilter2 Interface
Summary

An object that filters the contents of a parts list.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter
        IMcadPartListCustomFilter
Visual Basic
Public Interface IMcadPartListFilter2
Inherits IMcadPartListFilter
Links
IMcadPartListFilter2 Members, SymBBAuto Library


IMcadPartListFilter2 Members
Summary

The following tables list the members exposed by IMcadPartListFilter2.

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Type | Property that specifies the filter type of a Parts List filter.


IMcadPartListFilter2::Excluded Property
Summary

Property that specifies whether a Parts List filter type is excluded from use in the current context.

Visual Basic
Property Excluded() As VARIANT_BOOL*
Remarks

This property always returns VARIANT_FALSE.


IMcadPartListFilter2::Type Property
Summary

Property that specifies the filter type of a Parts List filter.

Visual Basic
Property Type() As McadFilterType*
Remarks

This property always returns sbFilterBasic.


IMcadPartListFilters Interface
Summary

A collection of McadPartListFilter objects

Class Hierarchy

Declaration syntax

IMcadPartListFilters
Visual Basic
Public Interface IMcadPartListFilters
Inherits IDispatch
Links
IMcadPartListFilters Members, SymBBAuto Library


IMcadPartListFilters Members
Summary

The following tables list the members exposed by IMcadPartListFilters.

Methods
Name | Description
Add | Adds a parts list filter to the collection used in this parts list.
Item | Obtains a specified parts list filter from the collection used in this parts list.
Remove | Removes the specified parts list filters from the collection used in this parts list.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts list filters in the collection used in a parts list.


IMcadPartListFilters::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadPartListFilters::Count Property
Summary

Gets the total number of parts list filters in the collection used in a parts list.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadPartListFilters::Add Method
Summary

Adds a parts list filter to the collection used in this parts list.

Visual Basic
Sub Add(Item As IMcadPartListFilter)
Parameters
Parameters | Description
Item | McadPartListFilter object; input-only. Specifies the new parts list filter to add to the collection.
Returns

None


IMcadPartListFilters::Item Method
Summary

Obtains a specified parts list filter from the collection used in this parts list.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartListFilter*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the parts list filter to obtain.
Returns

McadPartListFilter object


IMcadPartListFilters::Remove Method
Summary

Removes the specified parts list filters from the collection used in this parts list.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the parts list filter to be removed.
Returns

None


IMcadPartListGOST Interface
Summary

Interface for interacting with the GOST part list created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartListGOST
Visual Basic
Public Interface IMcadPartListGOST
Inherits IMcadPartList
Remarks

The McadPartListGOST COM object is the wrapper for the AcmPartListGOST class.

Links
IMcadPartListGOST Members, SymBBAuto Library


IMcadPartListGOST Members
Summary

The following tables list the members exposed by IMcadPartListGOST.

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SkipAfterPart | Specifies if empty line is to be inserted after each part.
SkipLines | Specifies the number of empty lines to insert after the last item of each category.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


IMcadPartListGOST::SkipAfterPart Property
Summary

Specifies if empty line is to be inserted after each part.

Visual Basic
Property SkipAfterPart() As VARIANT_BOOL


IMcadPartListGOST::SkipLines Property
Summary

Specifies the number of empty lines to insert after the last item of each category.

Visual Basic
Property SkipLines() As LONG


IMcadPartLists Interface
Summary

A collection of McadPartList objects

Class Hierarchy

Declaration syntax

IMcadPartLists
Visual Basic
Public Interface IMcadPartLists
Inherits IDispatch
Links
IMcadPartLists Members, SymBBAuto Library


IMcadPartLists Members
Summary

The following tables list the members exposed by IMcadPartLists.

Methods
Name | Description
Add | Adds a parts list to the collection used in this drawing.
Item | Obtains a specified parts list from the collection used in this drawing.
Remove | Removes the specified parts lists from the collection used in this drawing.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts lists in the collection used in a drawing.


IMcadPartLists::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadPartLists::Count Property
Summary

Gets the total number of parts lists in the collection used in a drawing.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadPartLists::Add Method
Summary

Adds a parts list to the collection used in this drawing.

Visual Basic
Sub Add(Item As IMcadPartList)
Parameters
Parameters | Description
Item | McadPartList object; input-only. Specifies the new parts list to add to the collection.
Returns

None


IMcadPartLists::Item Method
Summary

Obtains a specified parts list from the collection used in this drawing.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartList*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the parts list to obtain.


IMcadPartLists::Remove Method
Summary

Removes the specified parts lists from the collection used in this drawing.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the parts list to be removed.
Returns

None


IMcadPartListStandard Interface
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
Visual Basic
Public Interface IMcadPartListStandard
Inherits IDispatch
Links
IMcadPartListStandard Members, SymBBAuto Library


IMcadPartListStandard Members
Summary

The following tables list the members exposed by IMcadPartListStandard.

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


IMcadPartListStandard::ActualRowTextHeight Property
Summary

Gets the actual height of the text in a row of parts lists referencing this standard.

Visual Basic
Property ActualRowTextHeight() As double*
Remarks

This property is a Double.


IMcadPartListStandard::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

This property is a AcadmApplication object. AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadPartListStandard::AttachmentPoint Property
Summary

Specifies the placement of the base point for the part lists referencing this standard.

Visual Basic
Property AttachmentPoint() As McadAttachmentPoint
Remarks

This property is a McadAttachmentPoint enumeration.


IMcadPartListStandard::BOMStandard Property
Summary

Gets the BOM standard that are associated with parts list referencing this standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks
  • This property is a McadBOMStandard object.
  • This property is a equivalent to using the GetCurrentSymbolStandard with the class name "cmBOMStd".


IMcadPartListStandard::ColumnList Property
Summary

Specifies the indices for the columns that are used in parts lists referencing this standard.

Visual Basic
Property ColumnList() As VARIANT
Remarks

This property is a Variant (array of Longs)


IMcadPartListStandard::CustomBlockName Property
Summary

Specifies the custom block scheme name used to display parts lists referencing this standard.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.


IMcadPartListStandard::CustomBlocks Property
Summary

Gets the custom blocks used for the parts lists referencing this standard.

Visual Basic
Property CustomBlocks() As VARIANT*
Remarks

This property is a Variant (2-element array of AcadBlock objects).


IMcadPartListStandard::FilterEmptyBlocks Property
Summary

Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.

Visual Basic
Property FilterEmptyBlocks() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartListStandard::FrameColor Property
Summary

Specifies the color of the frame for the parts lists referencing this standard.

Visual Basic
Property FrameColor() As ACAD_COLOR
Remarks

This property is a cLineWeight enumeration. The initial value for this property is a cLnWtByBlock. Available lineweight values include:

  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault
  • cLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211
  • Lineweight values consist of standard settings including BYLAYER, BYBLOCK, and DEFAULT. The DEFAULT value is set by the LWDEFAULT system variable and defaults to a value of 0.01 in. or 0.25 mm. All new objects and layers have a default setting of DEFAULT. The lineweight value of 0 plots at the thinnest lineweight available on the specified plotting device and is displayed at one pixel wide in model space.


IMcadPartListStandard::HeadingGap Property
Summary

Property that specifies the Parts List heading text gap.

Visual Basic
Property HeadingGap() As double
Remarks

Writing to this property sets the Parts List heading text gap. In addition, writing to this property sets the Parts List heading text top, left, bottom and right margins. This is the same as writing to the HeadingTextMarginTop, HeadingTextMarginLeft, HeadingTextMarginBottom, and HeadingTextMarginRightproperties.

This property is a replaced by the HeadingTextMarginTop, HeadingTextMarginLeft, HeadingTextMarginBottom and HeadingTextMarginRight properties.


IMcadPartListStandard::HeadingHeight Property
Summary

Specifies the heading height for parts lists referencing this standard.

Visual Basic
Property HeadingHeight() As double*
Remarks

This property is a Double.


IMcadPartListStandard::HeadingTextColor Property
Summary

Specifies the heading text color for parts lists referencing this standard.

Visual Basic
Property HeadingTextColor() As ACAD_COLOR
Remarks

The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:

  • sbByBlock: If sbByBlock is specified, new heading texts are displayed in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
  • sbByLayer: If sbByLayer is specified, new heading texts assume the color of the layer upon which they are drawn.
  • sbRed
  • sbYellow
  • sbGreen
  • sbCyan
  • sbBlue
  • sbMagenta
  • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadPartListStandard::HeadingTextHeight Property
Summary

Specifies the heading text height for parts lists referencing this standard.

Visual Basic
Property HeadingTextHeight() As double
Remarks

This property is a Double.


IMcadPartListStandard::IsCustomBlockUsed Property
Summary

Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadPartListStandard::IsHeadingEnabled Property
Summary

Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property IsHeadingEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartListStandard::IsTitleEnabled Property
Summary

Specifies whether the title is by default enabled for parts lists referencing this standard.

Visual Basic
Property IsTitleEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartListStandard::MulipleRow Property
Summary

Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.

Visual Basic
Property MulipleRow() As long
Remarks

Valid values include 1, 2, or 3.

This property is a Long.


IMcadPartListStandard::Revision Property
Summary

Specifies the revision version of a parts list standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.


IMcadPartListStandard::RevisionYear Property
Summary

Gets the revision version year of a parts list standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.


IMcadPartListStandard::RowGap Property
Summary

Property that specifies the Parts List row text gap.

Visual Basic
Property RowGap() As double
Remarks

Writing to this property sets the Parts List row text gap. In addition, writing to this property sets the Parts List row text top, left, bottom and right margins. This is the same as writing to the RowTextMarginTop, RowTextMarginLeft, RowTextMarginBottom, and RowTextMarginRight properties.

This property is a replaced by the RowTextMarginTop, RowTextMarginLeft, RowTextMarginBottom, and RowTextMarginRight properties..


IMcadPartListStandard::RowHeight Property
Summary

Specifies the row height for parts lists referencing this standard.

Visual Basic
Property RowHeight() As double*
Remarks

This property is a Double.


IMcadPartListStandard::UseMapping Property
Summary

Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.

Visual Basic
Property UseMapping() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadPartListStandard::WrapText Property
Summary

Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.

Visual Basic
Property WrapText() As VARIANT_BOOL
Remarks

Can set the wrap state for both header and data text, but the wrap state for header text will not be returned. Setting individual header and data text wrap states is not supported. Reading from this property retrieves the row text wrap state. When this property is a VARIANT_TRUE, reading from the RowTextControl property returns sbWrap to indicate the same row text wrap state. Writing to this property sets the heading and row text wrap states. This is the same as writing to both the HeadingTextControl and RowTextControl properties, setting them to sbWrap.

This property is a replaced by the HeadingTextControl and RowTextControl properties.


IMcadPartListStandard::RemoveColumn Method
Summary

Removes the specified column, by index, from the parts lists referencing this standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the column to be removed.
Returns

None


IMcadPartListStandard::SetToDefaults Method
Summary

Sets the properties of the standard parts list to the factory default values.

Visual Basic
Sub SetToDefaults()


IMcadPartListStandard2 Interface
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
Visual Basic
Public Interface IMcadPartListStandard2
Inherits IMcadPartListStandard
Links
IMcadPartListStandard2 Members, SymBBAuto Library


IMcadPartListStandard2 Members
Summary

The following tables list the members exposed by IMcadPartListStandard2.

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


IMcadPartListStandard2::FrameTrueColor Property
Summary

Specifies the true color of frames for parts lists referencing this standard.

Visual Basic
Property FrameTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.


IMcadPartListStandard2::HeadingTextTrueColor Property
Summary

Specifies the true color of the heading texts for parts lists referencing this standard.

Visual Basic
Property HeadingTextTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX documentation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.


IMcadPartListStandard3 Interface
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4
Visual Basic
Public Interface IMcadPartListStandard3
Inherits IMcadPartListStandard2
Links
IMcadPartListStandard3 Members, SymBBAuto Library


IMcadPartListStandard3 Members
Summary

The following tables list the members exposed by IMcadPartListStandard3.

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


IMcadPartListStandard3::BoldVerticalLine Property
Summary

Property that specifies whether the Parts List line style is bold.

Visual Basic
Property BoldVerticalLine() As VARIANT_BOOL


IMcadPartListStandard3::ColumnSplitEnabled Property
Summary

Property that specifies whether the Parts List column split is enabled.

Visual Basic
Property ColumnSplitEnabled() As VARIANT_BOOL


IMcadPartListStandard3::ColumnSplitRows Property
Summary

Property that specifies the Parts List column split rows.

Visual Basic
Property ColumnSplitRows() As long


IMcadPartListStandard3::ColumnSplitSections Property
Summary

Property that specifies the Parts List column split sections.

Visual Basic
Property ColumnSplitSections() As long


IMcadPartListStandard3::ColumnSplitStyle Property
Summary

Property that specifies the Parts List column split style.

Visual Basic
Property ColumnSplitStyle() As McadColumnSplitStyle


IMcadPartListStandard3::ColumnSplitWrap Property
Summary

Property that specifies the Parts List column split wrap direction.

Visual Basic
Property ColumnSplitWrap() As McadColumnSplitWrap


IMcadPartListStandard3::GripFrameEnabled Property
Summary

Property that specifies whether the Parts List grip frame is enabled.

Visual Basic
Property GripFrameEnabled() As VARIANT_BOOL


IMcadPartListStandard3::HeadingTextControl Property
Summary

Property that specifies the Parts List heading text control.

Visual Basic
Property HeadingTextControl() As McadTextControl


IMcadPartListStandard3::HeadingTextMarginBottom Property
Summary

Property that specifies the Parts List heading text bottom margin.

Visual Basic
Property HeadingTextMarginBottom() As double


IMcadPartListStandard3::HeadingTextMarginLeft Property
Summary

Property that specifies the Parts List heading text left margin.

Visual Basic
Property HeadingTextMarginLeft() As double


IMcadPartListStandard3::HeadingTextMarginRight Property
Summary

Property that specifies the Parts List heading text right margin.

Visual Basic
Property HeadingTextMarginRight() As double


IMcadPartListStandard3::HeadingTextMarginTop Property
Summary

Property that specifies the Parts List heading text top margin.

Visual Basic
Property HeadingTextMarginTop() As double


IMcadPartListStandard3::HeadingTextStyle Property
Summary

Property that specifies the Parts List heading text style.

Visual Basic
Property HeadingTextStyle() As IAcadTextStyle*


IMcadPartListStandard3::RowTextColor Property
Summary

Property that specifies the Parts List row text color

Visual Basic
Property RowTextColor() As ACAD_COLOR


IMcadPartListStandard3::RowTextControl Property
Summary

Property that specifies the Parts List row text control.

Visual Basic
Property RowTextControl() As McadTextControl


IMcadPartListStandard3::RowTextHeight Property
Summary

Property that specifies the Parts List row text height.

Visual Basic
Property RowTextHeight() As double


IMcadPartListStandard3::RowTextMarginBottom Property
Summary

Property that specifies the Parts List row text bottom margin.

Visual Basic
Property RowTextMarginBottom() As double


IMcadPartListStandard3::RowTextMarginLeft Property
Summary

Property that specifies the Parts List row text left margin.

Visual Basic
Property RowTextMarginLeft() As double


IMcadPartListStandard3::RowTextMarginRight Property
Summary

Property that specifies the Parts List row text left margin.

Visual Basic
Property RowTextMarginRight() As double


IMcadPartListStandard3::RowTextMarginTop Property
Summary

Property that specifies the Parts List row text top margin.

Visual Basic
Property RowTextMarginTop() As double


IMcadPartListStandard3::RowTextStyle Property
Summary

Property that specifies the Parts List row text style.

Visual Basic
Property RowTextStyle() As IAcadTextStyle*


IMcadPartListStandard3::RowTextTrueColor Property
Summary

Property that specifies the Parts List row text color.

Visual Basic
Property RowTextTrueColor() As IAcadAcCmColor*


IMcadPartListStandard4 Interface
Summary

Stores the Parts List standard setting information.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4
Visual Basic
Public Interface IMcadPartListStandard4
Inherits IMcadPartListStandard3
Links
IMcadPartListStandard4 Members, SymBBAuto Library


IMcadPartListStandard4 Members
Summary

The following tables list the members exposed by IMcadPartListStandard4.

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
ColumnSplitWrapAroundTitle | Specifies whether the parts list can be wrapped around the title block in this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property
Summary

Specifies whether the parts list can be wrapped around the title block in this standard.

Visual Basic
Property ColumnSplitWrapAroundTitle() As VARIANT_BOOL


IMcadPartListStdPartsFilter Interface
Summary

A filter object that filters the contents of a Parts List by Standard parts.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter
Visual Basic
Public Interface IMcadPartListStdPartsFilter
Inherits IMcadPartListCustomFilter
Links
IMcadPartListStdPartsFilter Members, SymBBAuto Library


IMcadPartListStdPartsFilter Members
Summary

The following tables list the members exposed by IMcadPartListStdPartsFilter.

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
Option | Property that specifies the filter option used by the Parts List Standard parts filter to display parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.


IMcadPartListStdPartsFilter::Option Property
Summary

Property that specifies the filter option used by the Parts List Standard parts filter to display parts.

Visual Basic
Property Option() As McadStdPartsFilterOption


IMcadPartReference Interface
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
Visual Basic
Public Interface IMcadPartReference
Inherits IMcadSymbol2
Links
IMcadPartReference Members, SymBBAuto Library


IMcadPartReference Members
Summary

The following tables list the members exposed by IMcadPartReference.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadPartReference::Data Property
Summary

Specifies the bill of materials table data.

Visual Basic
Property Data() As VARIANT
Remarks

The data is represented as a two dimensional array of strings of key value pairs.


IMcadPartReference::Quantity Property
Summary

Specifies the quantity value of the part reference.

Visual Basic
Property Quantity() As long
Remarks

This property is a useful if you prefer to insert only one part reference in the drawing, but you want to enter a bigger Qty in the BOM database. The default value is 1, and only positive integer values can be entered.

This property is a Long.


IMcadPartReference2 Interface
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3
Visual Basic
Public Interface IMcadPartReference2
Inherits IMcadPartReference
Links
IMcadPartReference2 Members, SymBBAuto Library


IMcadPartReference2 Members
Summary

The following tables list the members exposed by IMcadPartReference2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadPartReference2::SetAttributePreDefinedListValue Method
Summary

Sets a specific value within the predefined list for the specified attribute

Visual Basic
Sub SetAttributePreDefinedListValue(attributeName As String, preDefineListValue As String)
Parameters
Parameters | Description
attributeName | Name of attribute which is a predefined list.
preDefineListValue | The specific value within the predefined list to set to. This value must be a valid key in the predefined list.


IMcadPartReference3 Interface
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3
Visual Basic
Public Interface IMcadPartReference3
Inherits IMcadPartReference2
Links
IMcadPartReference3 Members, SymBBAuto Library


IMcadPartReference3 Members
Summary

The following tables list the members exposed by IMcadPartReference3.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachExternalBom | Method that attaches the specified BOM from the specified xref drawing to this part reference.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachExternalBom | Method that detaches the external BOM, if any, from this part reference.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetBomOverride | Method that checks if there is a bom override for the specified attribute/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveAttribute | Method to remove the local attribute value if any from this part reference. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachedExternalBom | Property that specifies the attached external BOM, if any, of this part reference.
AttachedExternalBomXrefBlock | Property that specifies the Acad block of the external BOM of this part reference, if any.
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadPartReference3::AttachedExternalBom Property
Summary

Property that specifies the attached external BOM, if any, of this part reference.

Visual Basic
Property AttachedExternalBom() As IMcadBOM *


IMcadPartReference3::AttachedExternalBomXrefBlock Property
Summary

Property that specifies the Acad block of the external BOM of this part reference, if any.

Visual Basic
Property AttachedExternalBomXrefBlock() As IAcadBlock **
Remarks

The path of the xref can be obtained by checking the path of the Acad block.


IMcadPartReference3::AttachExternalBom Method
Summary

Method that attaches the specified BOM from the specified xref drawing to this part reference.

Visual Basic
Sub AttachExternalBom(xrefPath As String, bomName As String)
Parameters
Parameters | Description
xrefPath | Full pathname of the xref drawing.
bomName | Name of the BOM from the xref drawing to attach to.
Remarks

The path of the xref can be obtained by checking the path of the Acad block.


IMcadPartReference3::DetachExternalBom Method
Summary

Method that detaches the external BOM, if any, from this part reference.

Visual Basic
Sub DetachExternalBom(detachXref As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
detachXref | Indicates if the xref drawing itself should be detached as well.
Remarks

The path of the xref can be obtained by checking the path of the Acad block.


IMcadPartReference3::GetBomOverride Method
Summary

Method that checks if there is a bom override for the specified attribute/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.

Visual Basic
Sub GetBomOverride(attributeName As String, ByRef originalValue As String, ByRef originalData As String, ByRef currentValue As String, ByRef currentData As String, ByRef editable As VARIANT_BOOL, overrideType As [out, retval] McadBomOverrideType)
Parameters
Parameters | Description
attributeName | Name of attribute/column to check.
originalValue | The original evaluated value (what would be there if there is no override). Would be empty if there is no bom override.
originalData | The original unevaluated data (what would be there if there is no override). Would be empty if there is no bom override.
currentValue | The current evaluated value.
currentData | The current unevaluated data.
editable | Indicates if the attribute can be edited.


IMcadPartReference3::RemoveAttribute Method
Summary

Method to remove the local attribute value if any from this part reference. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.

Visual Basic
Sub RemoveAttribute(attributeName As String)
Parameters
Parameters | Description
attributeName | Name of attribute/column to remove.
Remarks

Note that Quantity can’t be an attribute of part reference, so this method will not work for quantity override.


IMcadPartReferences Interface
Summary

This is class IMcadPartReferences.

Class Hierarchy

Declaration syntax

IMcadPartReferences
Visual Basic
Public Interface IMcadPartReferences
Inherits IDispatch
Links
IMcadPartReferences Members, SymBBAuto Library


IMcadPartReferences Members
Summary

The following tables list the members exposed by IMcadPartReferences.

Methods
Name | Description
Add | This is Add, a member of class IMcadPartReferences.
Item | This is Item, a member of class IMcadPartReferences.
Remove | This is Remove, a member of class IMcadPartReferences.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadPartReferences.
Application | This is Application, a member of class IMcadPartReferences.
Count | This is Count, a member of class IMcadPartReferences.


IMcadPartReferences::_NewEnum Property
Summary

This is _NewEnum, a member of class IMcadPartReferences.

Visual Basic
Property _NewEnum() As LPUNKNOWN*


IMcadPartReferences::Application Property
Summary

This is Application, a member of class IMcadPartReferences.

Visual Basic
Property Application() As IDispatch**


IMcadPartReferences::Count Property
Summary

This is Count, a member of class IMcadPartReferences.

Visual Basic
Property Count() As long*


IMcadPartReferences::Add Method
Summary

This is Add, a member of class IMcadPartReferences.

Visual Basic
Sub Add(Item As IMcadPartReference)


IMcadPartReferences::Item Method
Summary

This is Item, a member of class IMcadPartReferences.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartReference*)


IMcadPartReferences::Remove Method
Summary

This is Remove, a member of class IMcadPartReferences.

Visual Basic
Sub Remove(Index As long)


IMcadRevisionList Interface
Summary

Interface that represents the revision list created in the drawing.

Class Hierarchy

Declaration syntax

IMcadRevisionList
Visual Basic
Public Interface IMcadRevisionList
Inherits IDispatch
Links
IMcadRevisionList Members, SymBBAuto Library


IMcadRevisionList Members
Summary

The following tables list the members exposed by IMcadRevisionList.

Methods
Name | Description
Add | Add a revision to the end of the revision list.
Item | Returns the data set for a specified revision in this revision list.
Set | Sets a revision list entry to a specific value.
Properties
Name | Description
Border | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Border32 | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Count | Gets the total number of items in the collection.
Position | Property that returns the input position of the revision list.
Ref | Property that returns a reference to the title/border object.
Ref32 | Read-only property that returns the object ID of this revision list.


IMcadRevisionList::Border Property
Summary

Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.

Visual Basic
Property Border() As LONG_PTR*


IMcadRevisionList::Border32 Property
Summary

Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.

Visual Basic
Property Border32() As LONG*
Remarks

For 64-bit platform only. This is the same as Border property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.


IMcadRevisionList::Count Property
Summary

Gets the total number of items in the collection.

Visual Basic
Property Count() As LONG*


IMcadRevisionList::Position Property
Summary

Property that returns the input position of the revision list.

Visual Basic
Property Position() As VARIANT*


IMcadRevisionList::Ref Property
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref() As LONG_PTR*


IMcadRevisionList::Ref32 Property
Summary

Read-only property that returns the object ID of this revision list.

Visual Basic
Property Ref32() As LONG*
Remarks

This is the same as Ref property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.


IMcadRevisionList::Add Method
Summary

Add a revision to the end of the revision list.

Visual Basic
Sub Add(attributes As VARIANT, pRet As [out, retval]VARIANT_BOOL)
Parameters
Parameters | Description
attributes | New revision data set (see the Item method).
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.


IMcadRevisionList::Item Method
Summary

Returns the data set for a specified revision in this revision list.

Visual Basic
Sub Item(index As VARIANT, pAttributes As [out, retval] VARIANT)
Parameters
Parameters | Description
index | Data set for revision.
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.


IMcadRevisionList::Set Method
Summary

Sets a revision list entry to a specific value.

Visual Basic
Sub Set(index As VARIANT, attributes As VARIANT)
Parameters
Parameters | Description
index | Index of revision to set.
attributes | New revision data set.
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.


IMcadRevisionListDescriptor Interface
Summary

Interface for interacting with all data associated with a revision list.

Class Hierarchy

Declaration syntax

IMcadRevisionListDescriptor
Visual Basic
Public Interface IMcadRevisionListDescriptor
Inherits IDispatch
Links
IMcadRevisionListDescriptor Members, SymBBAuto Library


IMcadRevisionListDescriptor Members
Summary

The following tables list the members exposed by IMcadRevisionListDescriptor.

Properties
Name | Description
Attributes | Property that gets and sets the attributes of the revision list. You can create a new revision list with the attributes specified in descriptor object.
Border | Returns a pointer to the object id of the associated title block border with this revision list.
Border32 | Returns a pointer to the object id of the associated title block border with this revision list.
Position | Property that sets and gets the position of the revision list.


IMcadRevisionListDescriptor::Attributes Property
Summary

Property that gets and sets the attributes of the revision list. You can create a new revision list with the attributes specified in descriptor object.

Visual Basic
Property Attributes() As VARIANT
Remarks

Retreiving the attributes property of newly created descriptor object will get the attributes with key and empty values. You can specify some attribute values and pass them back to the descriptor object for creating a new revision list.

If you want to retrieve the attributes for the existing revision list object, please call the methods of revision list object.


IMcadRevisionListDescriptor::Border Property
Summary

Returns a pointer to the object id of the associated title block border with this revision list.

Visual Basic
Property Border() As VARIANT


IMcadRevisionListDescriptor::Border32 Property
Summary

Returns a pointer to the object id of the associated title block border with this revision list.

Visual Basic
Property Border32() As LONG*
Remarks

For 64-bit platform only. This is the same as Border property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.


IMcadRevisionListDescriptor::Position Property
Summary

Property that sets and gets the position of the revision list.

Visual Basic
Property Position() As VARIANT


IMcadRevisionLists Interface
Summary

Interface for working with a collection of revision list objects.

Class Hierarchy

Declaration syntax

IMcadRevisionLists
Visual Basic
Public Interface IMcadRevisionLists
Inherits IDispatch
Links
IMcadRevisionLists Members, SymBBAuto Library


IMcadRevisionLists Members
Summary

The following tables list the members exposed by IMcadRevisionLists.

Methods
Name | Description
Item | Obtains a specified title/border from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Property that returns number of revisions in this revision list.


IMcadRevisionLists::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**


IMcadRevisionLists::Count Property
Summary

Property that returns number of revisions in this revision list.

Visual Basic
Property Count() As long*


IMcadRevisionLists::Item Method
Summary

Obtains a specified title/border from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadRevisionList*)
Parameters
Parameters | Description
Index | Input long value that specifies an index of the selected title/border object in the collection. Values range from 0 to one less than the total number of objects.


IMcadRevisionMgr Interface
Summary

Interface for working with the general functionality of a revision list.

Class Hierarchy

Declaration syntax

IMcadRevisionMgr
Visual Basic
Public Interface IMcadRevisionMgr
Inherits IDispatch
Links
IMcadRevisionMgr Members, SymBBAuto Library


IMcadRevisionMgr Members
Summary

The following tables list the members exposed by IMcadRevisionMgr.

Methods
Name | Description
CreateRevisionList | Creates a new revision list.
DeleteRevisionList | Removes a revision list from the drawing. Return TRUE if the specified revision list has been deleted successfully, otherwise return FALSE.
GetRevisionListFromRef | Returns the revision list object referred by object in the drawing.
NewDescriptor | Creates and initializes a new title border descriptor. Returns a new revision list descriptor object.
Properties
Name | Description
RevisionLists | Property that returns the collection object containing all the revision lists maintained by the manager.


IMcadRevisionMgr::RevisionLists Property
Summary

Property that returns the collection object containing all the revision lists maintained by the manager.

Visual Basic
Property RevisionLists() As IMcadRevisionLists**


IMcadRevisionMgr::CreateRevisionList Method
Summary

Creates a new revision list.

Visual Basic
Sub CreateRevisionList(pDesc As IMcadRevisionListDescriptor, pRevList As [out, retval] IMcadRevisionList *)
Parameters
Parameters | Description
pDesc | Input revision list descriptor object which specifies all data associated with the newly created revision list object.


IMcadRevisionMgr::DeleteRevisionList Method
Summary

Removes a revision list from the drawing. Return TRUE if the specified revision list has been deleted successfully, otherwise return FALSE.

Visual Basic
Sub DeleteRevisionList(pRevList As IMcadRevisionList, bRet As [out, retval]VARIANT_BOOL)
Parameters
Parameters | Description
pRevList | Specify the revision list which will be deleted from the drawing.


IMcadRevisionMgr::GetRevisionListFromRef Method
Summary

Returns the revision list object referred by object in the drawing.

Visual Basic
Sub GetRevisionListFromRef(revId As VARIANT, pRevList As [out, retval] IMcadRevisionList *)
Parameters
Parameters | Description
revId | Input object ID of itself or its entity part in the drawing


IMcadRevisionMgr::NewDescriptor Method
Summary

Creates and initializes a new title border descriptor. Returns a new revision list descriptor object.

Visual Basic
Sub NewDescriptor(ppDesc As [out, retval] IMcadRevisionListDescriptor*)


IMcadScaleArea Interface
Summary

This object represents the scale area created in the model space.

Class Hierarchy

Declaration syntax

IMcadScaleArea
Visual Basic
Public Interface IMcadScaleArea
Inherits IDispatch
Links
IMcadScaleArea Members, SymBBAuto Library


IMcadScaleArea Members
Summary

The following tables list the members exposed by IMcadScaleArea.

Methods
Name | Description
CreateViewPort | Creates viewport on specified layout.
DeleteViewPort | Delete viewport for the scale area.
GetAttachedViewportIds | Gets object IDs of all viewports that are attached to the scale area.
GetAttachedViewportIds32 | Gets object IDs of all viewports that are attached to the scale area.
MoveBorder | Moves the border of the scale area.
RescaleObjects | Performs rescaling of specified objects.
SetBasicScale | Sets text scaling factor as the model scale.
Properties
Name | Description
AttachObjectId | Property that specifies the object ID of the defining object, which is the closed curve for the border.
AttachObjectId32 | Property that specifies the object ID of the defining object, which is the closed curve for the border.
LengthScalingFactor | Specifies the length scaling factor of the scale area.
ScaleType | Specifies the type of scale to be text scaling or length scaling.
TextScalingFactor | Specifies the text scaling factor of the scale area.


IMcadScaleArea::AttachObjectId Property
Summary

Property that specifies the object ID of the defining object, which is the closed curve for the border.

Visual Basic
Property AttachObjectId() As LONG_PTR*


IMcadScaleArea::AttachObjectId32 Property
Summary

Property that specifies the object ID of the defining object, which is the closed curve for the border.

Visual Basic
Property AttachObjectId32() As LONG*


IMcadScaleArea::LengthScalingFactor Property
Summary

Specifies the length scaling factor of the scale area.

Visual Basic
Property LengthScalingFactor() As double
Remarks

Before setting this property, ScaleType has to be set to sbScaleDf.


IMcadScaleArea::ScaleType Property
Summary

Specifies the type of scale to be text scaling or length scaling.

Visual Basic
Property ScaleType() As McadScaleType


IMcadScaleArea::TextScalingFactor Property
Summary

Specifies the text scaling factor of the scale area.

Visual Basic
Property TextScalingFactor() As double
Remarks

Before setting this property, ScaleType has to be set to sbScalePf.


IMcadScaleArea::CreateViewPort Method
Summary

Creates viewport on specified layout.

Visual Basic
Sub CreateViewPort(layoutName As String, viewPosition As VARIANT)
Parameters
Parameters | Description
layoutName | Input name of the layout
viewPosition | Input position to place the viewport in the layout. The VARIANT is a 3-element array of doubles for x, y and z points.


IMcadScaleArea::DeleteViewPort Method
Summary

Delete viewport for the scale area.

Visual Basic
Sub DeleteViewPort()


IMcadScaleArea::GetAttachedViewportIds Method
Summary

Gets object IDs of all viewports that are attached to the scale area.

Visual Basic
Sub GetAttachedViewportIds(viewPortIds As [out, retval]VARIANT)


IMcadScaleArea::GetAttachedViewportIds32 Method
Summary

Gets object IDs of all viewports that are attached to the scale area.

Visual Basic
Sub GetAttachedViewportIds32(viewPortIds As [out, retval]VARIANT)


IMcadScaleArea::MoveBorder Method
Summary

Moves the border of the scale area.

Visual Basic
Sub MoveBorder(targetPosition As VARIANT)
Parameters
Parameters | Description
targetPosition | Input target position in WCS coordinates. The VARIANT is a 3-element array of doubles for x, y and z points.


IMcadScaleArea::RescaleObjects Method
Summary

Performs rescaling of specified objects.

Visual Basic
Sub RescaleObjects(objectIds As VARIANT)
Parameters
Parameters | Description
ObjectIDs | Input array of object IDs to be rescaled. The variant is array of long or int64.


IMcadScaleArea::SetBasicScale Method
Summary

Sets text scaling factor as the model scale.

Visual Basic
Sub SetBasicScale()
Remarks

Before setting this property, ScaleType has to be set to sbScaleDf.


IMcadScaleAreaMgr Interface
Summary

This object is used to create and find a scale area in the modelspace.

Class Hierarchy

Declaration syntax

IMcadScaleAreaMgr
Visual Basic
Public Interface IMcadScaleAreaMgr
Inherits IDispatch
Links
IMcadScaleAreaMgr Members, SymBBAuto Library


IMcadScaleAreaMgr Members
Summary

The following tables list the members exposed by IMcadScaleAreaMgr.

Methods
Name | Description
CreateScaleArea | Create a new scale area and append it to the current layout.
DeleteScaleArea | Delete scale area.
FindScaleArea | Search the scale area attached to the given object.


IMcadScaleAreaMgr::CreateScaleArea Method
Summary

Create a new scale area and append it to the current layout.

Visual Basic
Sub CreateScaleArea(borderId As VARIANT, scaleArea As [out, retval] IMcadScaleArea*)
Parameters
Parameters | Description
borderId | Input object ID of the closed curve for the border


IMcadScaleAreaMgr::DeleteScaleArea Method
Summary

Delete scale area.

Visual Basic
Sub DeleteScaleArea(scaleArea As IMcadScaleArea)
Parameters
Parameters | Description
scaleArea | Input scale area object


IMcadScaleAreaMgr::FindScaleArea Method
Summary

Search the scale area attached to the given object.

Visual Basic
Sub FindScaleArea(borderId As VARIANT, searchAllLayouts As [in, defaultvalue(FALSE)] VARIANT_BOOL, scaleArea As [out, retval] IMcadScaleArea*)
Parameters
Parameters | Description
borderId | Input object ID of the closed curve for the border
searchAllLayouts | Input VARIANT_TRUE if search in all layouts. VARIANT_FALSE (Default) if search in current layout only


IMcadSectionLine Interface
Summary

The object represents the section line creating in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSectionLine
Visual Basic
Public Interface IMcadSectionLine
Inherits IMcadSymbol2
Links
IMcadSectionLine Members, SymBBAuto Library


IMcadSectionLine Members
Summary

The following tables list the members exposed by IMcadSectionLine.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSectionPoint | Adds a vertex to section line.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LabelName | Specifes the name of label in the section line.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetLabelNames | Specifies the label names of the section line.
SetSectionArcPointAt | Sets arc vertex to section line at specified index.
SetSectionPointAt | Sets a vertex to the section line at a specific index.
SetSectionPoints | Sets vertexes of section lines.
SetSectionViewOrigin | Specifies section view origin of the section line.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelNamesCount | Returns the number of label names.
LabelPattern | Specifies the label pattern for the section line.
LabelText | Property to get the evaluated pattern (with label name and scale).
LabelVisibility | Specifies the visibility of label in the section line.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LineVisibility | Specifies visibility style of the section line.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
PlaneSymbolsVisibility | Specifies the visibility of plane symbols.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SectionPoints | Property to get the array of section point. The VARIANT is a 3-element array of doubles for x, y and z points.
SectionSide | Specifies the direction side of section line symbol. The VARIANT is a 3-element of doubles for x, y and z point.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadSectionLine::ArrowVisibility Property
Summary

Specifies whether arrow is visible or hidden at the end of the section line.

Visual Basic
Property ArrowVisibility() As VARIANT_BOOL


IMcadSectionLine::LabelNamesCount Property
Summary

Returns the number of label names.

Visual Basic
Property LabelNamesCount() As int*


IMcadSectionLine::LabelPattern Property
Summary

Specifies the label pattern for the section line.

Visual Basic
Property LabelPattern() As String
Remarks

This string can be set using the strings, "<SECTION_LABEL_FIRST>" and "<SECTION_LABEL_LAST>", such as “=<SECTION_LABEL_FIRST>-<SECTION_LABEL_LAST>”.


IMcadSectionLine::LabelText Property
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*


IMcadSectionLine::LabelVisibility Property
Summary

Specifies the visibility of label in the section line.

Visual Basic
Property LabelVisibility() As VARIANT_BOOL


IMcadSectionLine::LineVisibility Property
Summary

Specifies visibility style of the section line.

Visual Basic
Property LineVisibility() As McadLineVisibility


IMcadSectionLine::PlaneSymbolsVisibility Property
Summary

Specifies the visibility of plane symbols.

Visual Basic
Property PlaneSymbolsVisibility() As VARIANT_BOOL


IMcadSectionLine::SectionPoints Property
Summary

Property to get the array of section point. The VARIANT is a 3-element array of doubles for x, y and z points.

Visual Basic
Property SectionPoints() As VARIANT*


IMcadSectionLine::SectionSide Property
Summary

Specifies the direction side of section line symbol. The VARIANT is a 3-element of doubles for x, y and z point.

Visual Basic
Property SectionSide() As VARIANT


IMcadSectionLine::AddSectionPoint Method
Summary

Adds a vertex to section line.

Visual Basic
Sub AddSectionPoint(point As VARIANT)
Parameters
Parameters | Description
point | New vertex.


IMcadSectionLine::LabelName Method
Summary

Specifes the name of label in the section line.

Visual Basic
Sub LabelName(Index As [in, optional] VARIANT, pVal As [out, retval] BSTR)


IMcadSectionLine::SetLabelNames Method
Summary

Specifies the label names of the section line.

Visual Basic
Sub SetLabelNames(newVal As VARIANT)
Parameters
Parameters | Description
newVal | Labels names. The Variant is a array of BSTR.


IMcadSectionLine::SetSectionArcPointAt Method
Summary

Sets arc vertex to section line at specified index.

Visual Basic
Sub SetSectionArcPointAt(Index As long, Point As VARIANT, LineSegmentType As McadSectionLineSegmentType)
Parameters
Parameters | Description
Index | _nt_
Point | _nt_
LineSegmentType | _nt_


IMcadSectionLine::SetSectionPointAt Method
Summary

Sets a vertex to the section line at a specific index.

Visual Basic
Sub SetSectionPointAt(Index As long, Point As VARIANT)
Parameters
Parameters | Description
Index | Index of vertex.
Point | location of vertex.


IMcadSectionLine::SetSectionPoints Method
Summary

Sets vertexes of section lines.

Visual Basic
Sub SetSectionPoints(Points As VARIANT, ArcPoints As [in, optional] VARIANT, LineSegmentTypes As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | A variant. A 3-element array of doubles for x, y and z points.
ArcPoints | A variant. A 3-element array of doubles for x, y and z points.
LineSegmentTypes | A variant. An array of McadSectionLineSegmentType value.


IMcadSectionLine::SetSectionViewOrigin Method
Summary

Specifies section view origin of the section line.

Visual Basic
Sub SetSectionViewOrigin(Origin As VARIANT)
Parameters
Parameters | Description
Origin | Section view origin.
Remarks

This function must be invoked after posting the section line symbol to the database.


IMcadSectionLineStandard Interface
Summary

Interface for working with the standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2
Visual Basic
Public Interface IMcadSectionLineStandard
Inherits IMcadSymbolStandard3
Links
IMcadSectionLineStandard Members, SymBBAuto Library


IMcadSectionLineStandard Members
Summary

The following tables list the members exposed by IMcadSectionLineStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelPattern | Specifies the label pattern used by the section view.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSectionLineStandard::ArrowTowardsLine Property
Summary

Gets whether arrow is drawn as pointing towards or away from the line.

Visual Basic
Property ArrowTowardsLine() As VARIANT_BOOL*


IMcadSectionLineStandard::ArrowVisibility Property
Summary

Specifies whether arrow is visible or hidden at the end of the section line.

Visual Basic
Property ArrowVisibility() As VARIANT_BOOL


IMcadSectionLineStandard::LabelAbove Property
Summary

Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.

Visual Basic
Property LabelAbove() As VARIANT_BOOL


IMcadSectionLineStandard::LabelPattern Property
Summary

Specifies the label pattern used by the section view.

Visual Basic
Property LabelPattern() As String
Remarks

This string can be set using the strings, "<SECTION_LABEL_FIRST>" and "<SECTION_LABEL_LAST>", such as “=<SECTION_LABEL_FIRST>-<SECTION_LABEL_LAST>”.


IMcadSectionLineStandard::LabelVisibility Property
Summary

Specifies whether section view label is visible or hidden.

Visual Basic
Property LabelVisibility() As VARIANT_BOOL


IMcadSectionLineStandard::LineColor Property
Summary

Specifies the color of section line.

Visual Basic
Property LineColor() As ACAD_COLOR
Parameters
Parameters | Description
Color | _nt_


IMcadSectionLineStandard::LineTrueColor Property
Summary

Specifies the color of section line.

Visual Basic
Property LineTrueColor() As IAcadAcCmColor*


IMcadSectionLineStandard::LineVisibility Property
Summary

Specifies visibility style of the section line.

Visual Basic
Property LineVisibility() As McadLineVisibility


IMcadSectionLineStandard::LineWeight Property
Summary

Specifies the default weight of section line.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT
Remarks

This property is a cLineWeight enumeration. The initial value for this property is a cLnWtByBlock. Available lineweight values include:

  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault
  • cLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211

Lineweight values consist of standard settings including BYLAYER, BYBLOCK, and DEFAULT. The DEFAULT value is set by the LWDEFAULT system variable and defaults to a value of 0.01 in. or 0.25 mm. All new objects and layers have a default setting of DEFAULT. The lineweight value of 0 plots at the thinnest lineweight available on the specified plotting device and is displayed at one pixel wide in model space.


IMcadSectionLineStandard::MultipleNamesSupported Property
Summary

Specifies whether is to use continuous names for plane symbols.

Visual Basic
Property MultipleNamesSupported() As VARIANT_BOOL


IMcadSectionLineStandard::PlaneSymbolsVisibility Property
Summary

Specifies whether annotation is to be showed at each vertex.

Visual Basic
Property PlaneSymbolsVisibility() As VARIANT_BOOL


IMcadSectionLineStandard2 Interface

IMcadSectionLineStandard2 Interface MG2013New
Summary

This interface is derived from IMcadSectionLineStandard. It is for the section view standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2
Visual Basic
Public Interface IMcadSectionLineStandard2
Inherits IMcadSectionLineStandard
Links
IMcadSectionLineStandard2 Members, SymBBAuto Library


IMcadSectionLineStandard2 Members
Summary

The following tables list the members exposed by IMcadSectionLineStandard2.

Methods
Name | Description
GetByStandard | Gets if the specified section view property follow the standard.
SetByStandard | Sets if the specified section view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowLineLength | Specifies the extension length of the arrow line.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
BendLineLength | Specifies the bend line length.
EndArrowType | Specifies the arrow type of the end arrow.
EndBendLineType | Specifies the linetype of end and bend line.
EndLineLength | Specifies the end line length.
EndLineOvershoot | Specifies the end line overshoot.
IdentifierExcludeCharacters | Specifies a string of characters that are to be excluded or invalid for the identifier of section view.
IdentifierOffset | Specifies the identifier offset from section view.
IdentifierPosition | Specifies the identifier position.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern used by the section view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneLineColor | Specifies the color of cutting plane line.
PlaneLineType | Specifies the linetype of cutting plane line.
PlaneLineWeight | Specifies the line weight of cutting plane line.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSectionLineStandard2::IdentifierExcludeCharacters Property

IMcadSectionLineStandard2::IdentifierExcludeCharacters Property MG2013New
Summary

Specifies a string of characters that are to be excluded or invalid for the identifier of section view.

Visual Basic
Property IdentifierExcludeCharacters() As String


IMcadSectionLineStandard2::EndArrowType Property

IMcadSectionLineStandard2::EndArrowType Property MG2013New
Summary

Specifies the arrow type of the end arrow.

Visual Basic
Property EndArrowType() As McadArrowType


IMcadSectionLineStandard2::ArrowLineLength Property

IMcadSectionLineStandard2::ArrowLineLength Property MG2013New
Summary

Specifies the extension length of the arrow line.

Visual Basic
Property ArrowLineLength() As double


IMcadSectionLineStandard2::IdentifierPosition Property

IMcadSectionLineStandard2::IdentifierPosition Property MG2013New
Summary

Specifies the identifier position.

Visual Basic
Property IdentifierPosition() As McadIdentifierPositionType


IMcadSectionLineStandard2::EndBendLineType Property

IMcadSectionLineStandard2::EndBendLineType Property MG2013New
Summary

Specifies the linetype of end and bend line.

Visual Basic
Property EndBendLineType() As IAcadLineType*


IMcadSectionLineStandard2::EndLineLength Property

IMcadSectionLineStandard2::EndLineLength Property MG2013New
Summary

Specifies the end line length.

Visual Basic
Property EndLineLength() As double


IMcadSectionLineStandard2::EndLineOvershoot Property

IMcadSectionLineStandard2::EndLineOvershoot Property MG2013New
Summary

Specifies the end line overshoot.

Visual Basic
Property EndLineOvershoot() As double


IMcadSectionLineStandard2::BendLineLength Property

IMcadSectionLineStandard2::BendLineLength Property MG2013New
Summary

Specifies the bend line length.

Visual Basic
Property BendLineLength() As double


IMcadSectionLineStandard2::PlaneLineColor Property

IMcadSectionLineStandard2::PlaneLineColor Property MG2013New
Summary

Specifies the color of cutting plane line.

Visual Basic
Property PlaneLineColor() As IAcadAcCmColor*


IMcadSectionLineStandard2::PlaneLineType Property

IMcadSectionLineStandard2::PlaneLineType Property MG2013New
Summary

Specifies the linetype of cutting plane line.

Visual Basic
Property PlaneLineType() As IAcadLineType*


IMcadSectionLineStandard2::PlaneLineWeight Property

IMcadSectionLineStandard2::PlaneLineWeight Property MG2013New
Summary

Specifies the line weight of cutting plane line.

Visual Basic
Property PlaneLineWeight() As ACAD_LWEIGHT


IMcadSectionLineStandard2::LabelTextStyle Property

IMcadSectionLineStandard2::LabelTextStyle Property MG2013New
Summary

Specifies the text style of view label.

Visual Basic
Property LabelTextStyle() As IAcadTextStyle*


IMcadSectionLineStandard2::LabelTextColor Property

IMcadSectionLineStandard2::LabelTextColor Property MG2013New
Summary

Specifies the text color of view label.

Visual Basic
Property LabelTextColor() As IAcadAcCmColor*


IMcadSectionLineStandard2::LabelTextHeight Property

IMcadSectionLineStandard2::LabelTextHeight Property MG2013New
Summary

Specifies the text height of view label.

Visual Basic
Property LabelTextHeight() As double


IMcadSectionLineStandard2::LabelOffset Property

IMcadSectionLineStandard2::LabelOffset Property MG2013New
Summary

Specifies the label offset from section view.

Visual Basic
Property LabelOffset() As double


IMcadSectionLineStandard2::GetByStandard Method

IMcadSectionLineStandard2::GetByStandard Method MG2013New
Summary

Gets if the specified section view property follow the standard.

Visual Basic
Sub GetByStandard(propType As McadSectionLineStandardPropType, pVal As [out, retval] VARIANT_BOOL)


IMcadSectionLineStandard2::SetByStandard Method

IMcadSectionLineStandard2::SetByStandard Method MG2013New
Summary

Sets if the specified section view property follow the standard.

Visual Basic
Sub SetByStandard(propType As McadSectionLineStandardPropType, newVal As VARIANT_BOOL)


IMcadSectionLineStandard2::IdentifierOffset Property

IMcadSectionLineStandard2::IdentifierOffset Property MG2013New
Summary

Specifies the identifier offset from section view.

Visual Basic
Property IdentifierOffset() As double


IMcadStandard Interface
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
Visual Basic
Public Interface IMcadStandard
Inherits IAcadObject
Links
IMcadStandard Members, SymBBAuto Library


IMcadStandard Members
Summary

The following tables list the members exposed by IMcadStandard.

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


IMcadStandard::AllSymbolStandards Property
Summary

Gets all of the symbol standards contained by this standard.

Visual Basic
Property AllSymbolStandards() As IMcadSymbolStandards**
Remarks

This property is a McadSymbolStandards collection.


IMcadStandard::ArrowScale Property
Summary

Specifies the arrow scale of symbols based on this standard.

Visual Basic
Property ArrowScale() As double
Remarks

This property is a Double.


IMcadStandard::ArrowType Property
Summary

Specifies the leader arrow type for symbols based on this standard.

Visual Basic
Property ArrowType() As McadArrowType
Remarks

This property is a McadArrowType enumeration.


IMcadStandard::BaseName Property
Summary

Gets the name of the standard that this standard was originally based on.

Visual Basic
Property BaseName() As BSTR*
Remarks

This property is a String. It is specified for a standard by the McadStandardMgr > AddStandard method.


IMcadStandard::BOMStandard Property
Summary

Gets the BOM standard based on this standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmBOMStd.

This property is a McadBOMStandard object.


IMcadStandard::Current Property
Summary

Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.

Visual Basic
Property Current() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadStandard::CurrentSymbolStandards Property
Summary

Gets all of the symbol standards that are currently used in this standard.

Visual Basic
Property CurrentSymbolStandards() As IMcadSymbolStandards**
Remarks

This property is a McadSymbolStandards collection.


IMcadStandard::DatumStandard Property
Summary

Gets the datum symbol standard contained by this standard.

Visual Basic
Property DatumStandard() As IMcadDatumStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmDatumStd.

This property is a McadDatumStandard object.


IMcadStandard::FCFStandard Property
Summary

Gets the feature control frame symbol standard contained by this standard.

Visual Basic
Property FCFStandard() As IMcadFCFStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmFCFStd.

This property is a McadFCFStandard object.


IMcadStandard::IdentifierStandard Property
Summary

Gets the identifier symbol standard contained by this standard.

Visual Basic
Property IdentifierStandard() As IMcadIdentifierStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmIdStd.

This property is a McadIdentifierStandard object.


IMcadStandard::IsMetric Property
Summary

Specifies whether the standard is metric-based.

Visual Basic
Property IsMetric() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadStandard::LeaderColor Property
Summary

Specifies the color of leader lines created based on this standard.

Visual Basic
Property LeaderColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadStandard::Name Property
Summary

Gets the name of a standard.

Visual Basic
Property Name() As String
Remarks

This property is a String. It is specified by the McadStandardMgr > AddStandard method.


IMcadStandard::Scale Property
Summary

Specifies the scale used to create any new symbols based on this standard.

Visual Basic
Property Scale() As double
Remarks

This property is a Double.


IMcadStandard::StandardMgr Property
Summary

Gets the standard manager for this standard.

Visual Basic
Property StandardMgr() As IMcadStandardMgr**
Remarks

This property is a McadStandardMgr object.


IMcadStandard::SurfaceTextureStandard Property
Summary

Gets the surface texture symbol standard contained by this standard.

Visual Basic
Property SurfaceTextureStandard() As IMcadSurfaceTextureStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmSurfTextStd.

This property is a McadSurfaceTextureStandard object.


IMcadStandard::SymbolColor Property
Summary

Specifies the color of symbols created based on this standard.

Visual Basic
Property SymbolColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadStandard::SymbolStandardsSupported Property
Summary

Gets the class names of all of the symbol standards that are registered with this standard.

Visual Basic
Property SymbolStandardsSupported() As VARIANT*
Remarks

This property is a Variant (array of Strings).


IMcadStandard::TextColor Property
Summary

Specifies the color of text in symbols created based on this standard.

Visual Basic
Property TextColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadStandard::TextHeight Property
Summary

Specifies the height of text in symbols created based on this standard.

Visual Basic
Property TextHeight() As double
Remarks

This is a Double.


IMcadStandard::TextHeightList Property
Summary

Gets the list of valid heights for text.

Visual Basic
Property TextHeightList() As VARIANT*
Remarks

This property is a Variant (array of Doubles).


IMcadStandard::TextStyle Property
Summary

Specifies the text style for symbols based on this standard.

Visual Basic
Property TextStyle() As IAcadTextStyle*
Remarks
  • This property is a cadTextStyle object. AcadTextStyle (TextStyle) is an object in the AutoCAD Active Automation. The initial value for this property is a STANDARD.
  • This property overrides the value of the DIMTXSTY system variable for the given dimension.


IMcadStandard::TextStyleName Property
Summary

Specifies the name of the text style for symbols created based on this standard.

Visual Basic
Property TextStyleName() As String
Remarks

This property is a String.


IMcadStandard::WeldingStandard Property
Summary

Gets the welding symbol standard contained by this standard.

Visual Basic
Property WeldingStandard() As IMcadWeldingStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmWeldingStd.

This property is a McadWeldingStandard object.


IMcadStandard::AddSymbolStandard Method
Summary

Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.

Visual Basic
Sub AddSymbolStandard(ClassName As String, MakeCurrent As [in, defaultvalue(TRUE)] VARIANT_BOOL, SymbolStandard As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
ClassName | String; input-only. Specifies the class name of the symbol standard to add to the standard.
MakeCurrent | Boolean, default value = True; input-only; optional. Specifies whether to set the new symbol standard as current, TRUE, or not, FALSE.
Returns

McadSymbolStandard object

Remarks
  • If MakeCurrent is TRUE, use the McadStandard > GetCurrentSymbolStandard method to obtain this symbol standard that is currently used in the standard.
  • If MakeCurrent is False, use McadStandard > SetCurrentSymnolStandard method to set it as current for this standard at a later time.
  • To remove this symbol standard, use the McadStandard > RemoveSymbolStandard method


IMcadStandard::GetCurrentSymbolStandard Method
Summary

Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.

Visual Basic
Sub GetCurrentSymbolStandard(Name As String, Standard As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
Name | Name String; input-only. Specifies the class name for the symbol standard to obtain.
Returns

McadSymbolStandard object


IMcadStandard::RemoveSymbolStandard Method
Summary

Removes the specified symbol standard from this standard.

Visual Basic
Sub RemoveSymbolStandard(SymbolStandard As IMcadSymbolStandard)
Parameters
Parameters | Description
SymbolStandard | McadSymbolStandard object; input-only. Specifies the symbol standard to remove from this standard.
Returns

None


IMcadStandard::SetCurrentSymbolStandard Method
Summary

Sets the specified symbol standard current in the standard.

Visual Basic
Sub SetCurrentSymbolStandard(SymbolStandard As IMcadSymbolStandard)
Parameters
Parameters | Description
SymbolStandard | McadSymbolStandard object; input-only. Specifies the symbol standard to set as current for this standard.
Returns

None

Remarks

This method is valid for symbol standards that are returned by the McadStandard > AddSymbolStandard method with the parameter MakeCurrent = FALSE.


IMcadStandard::SetToDefaults Method
Summary

Sets the properties of this standard to the factory default values.

Visual Basic
Sub SetToDefaults()


IMcadStandard2 Interface
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
Visual Basic
Public Interface IMcadStandard2
Inherits IMcadStandard
Links
IMcadStandard2 Members, SymBBAuto Library


IMcadStandard2 Members
Summary

The following tables list the members exposed by IMcadStandard2.

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


IMcadStandard2::LeaderTrueColor Property
Summary

Specifies the true color of leader in symbol that belongs to this symbol standard.

Visual Basic
Property LeaderTrueColor() As IAcadAcCmColor *


IMcadStandard2::SymbolTrueColor Property
Summary

Specifies the true color of symbols created based on this standard.

Visual Basic
Property SymbolTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.


IMcadStandard2::TextTrueColor Property
Summary

Specifies the true color of text in symbols created based on this standard.

Visual Basic
Property TextTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.


IMcadStandard3 Interface
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4
Visual Basic
Public Interface IMcadStandard3
Inherits IMcadStandard2
Links
IMcadStandard3 Members, SymBBAuto Library


IMcadStandard3 Members
Summary

The following tables list the members exposed by IMcadStandard3.

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


IMcadStandard3::AnnotationViewStandard Property
Summary

Gets the Annotation View Standard contained by this standard.

Visual Basic
Property AnnotationViewStandard() As IMcadAnnotationViewStandard**


IMcadStandard3::DetailSymbolStandard Property
Summary

Property to get the Detail symbol standard.

Visual Basic
Property DetailSymbolStandard() As IMcadDetailSymbolStandard**


IMcadStandard3::EdgeStandard Property
Summary

Property to get the edge symbol standard.

Visual Basic
Property EdgeStandard() As IMcadEdgeStandard**


IMcadStandard3::MarkStampStandard Property
Summary

Gets the marking/stamping symbol standard contained by this standard.

Visual Basic
Property MarkStampStandard() As IMcadMarkStampStandard**


IMcadStandard3::NoteStandard Property
Summary

Property to get the Note symbol standard

Visual Basic
Property NoteStandard() As IMcadNoteStandard**


IMcadStandard3::TaperStandard Property
Summary

Property to get the taper symbol standard.

Visual Basic
Property TaperStandard() As IMcadTaperStandard**


IMcadStandard3::TitleBorderStandard Property
Summary

Property to get the title border standard.

Visual Basic
Property TitleBorderStandard() As IMcadTitleBorderStandard**


IMcadStandard4 Interface
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4
Visual Basic
Public Interface IMcadStandard4
Inherits IMcadStandard3
Links
IMcadStandard4 Members, SymBBAuto Library


IMcadStandard4 Members
Summary

The following tables list the members exposed by IMcadStandard4.

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
SupportedArrowTypes | This is SupportedArrowTypes, a member of class IMcadStandard4.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
JointStandard | This is JointStandard, a member of class IMcadStandard4.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
SectionLineStandard | Gets the section line symbol standard contained by this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


IMcadStandard4::JointStandard Property
Summary

This is JointStandard, a member of class IMcadStandard4.

Visual Basic
Property JointStandard() As IMcadJointStandard**


IMcadStandard4::SectionLineStandard Property
Summary

Gets the section line symbol standard contained by this standard.

Visual Basic
Property SectionLineStandard() As IMcadSectionLineStandard**


IMcadStandard4::SupportedArrowTypes Method
Summary

This is SupportedArrowTypes, a member of class IMcadStandard4.

Visual Basic
Sub SupportedArrowTypes(allSrv As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] VARIANT)


IMcadStandardMgr Interface
Summary

The symbol standards manager object

Class Hierarchy

Declaration syntax

IMcadStandardMgr
Visual Basic
Public Interface IMcadStandardMgr
Inherits IDispatch
Links
IMcadStandardMgr Members, SymBBAuto Library


IMcadStandardMgr Members
Summary

The following tables list the members exposed by IMcadStandardMgr.

Methods
Name | Description
AddStandard | Created a new standard based on an original standard, and optionally sets the new standard as current.
CopyStandard | Creates a copy of an existing standard to the specified new name.
GetStandard | Gets the standard with the specified name.
RemoveStandard | Removes the specified standard from the standard manager. This is equivalent to calling the McadStandard > Delete method on a specified standard to be removed.
UpdateSymbols | Updates all symbols with respect to changes made to their standards.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentStandard | Specifies the current standard for the document.
CurrentStandardName | Specifies the name of the current standard for the document.
DefaultStandard | Gets the name of the default standard.
StandardCount | Gets the number of symbol standards loaded.
StandardNames | Gets the names of all registered standards.
Standards | Gets all standards for the current document.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for the document.


IMcadStandardMgr::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadStandardMgr::CurrentStandard Property
Summary

Specifies the current standard for the document.

Visual Basic
Property CurrentStandard() As IMcadStandard*
Remarks

This property is a McadStandard object.


IMcadStandardMgr::CurrentStandardName Property
Summary

Specifies the name of the current standard for the document.

Visual Basic
Property CurrentStandardName() As String
Remarks

This is String.


IMcadStandardMgr::DefaultStandard Property
Summary

Gets the name of the default standard.

Visual Basic
Property DefaultStandard() As BSTR*
Remarks

This property is a String.


IMcadStandardMgr::StandardCount Property
Summary

Gets the number of symbol standards loaded.

Visual Basic
Property StandardCount() As long*
Remarks

This property is a Long.


IMcadStandardMgr::StandardNames Property
Summary

Gets the names of all registered standards.

Visual Basic
Property StandardNames() As VARIANT*
Remarks

This property is a Variant (array of Strings).


IMcadStandardMgr::Standards Property
Summary

Gets all standards for the current document.

Visual Basic
Property Standards() As IMcadStandards**
Remarks

This property is a McadStandards collection.


IMcadStandardMgr::SymbolBBMgr Property
Summary

Gets the Symbol BOM and Balloon manager object for the document.

Visual Basic
Property SymbolBBMgr() As IMcadSymbolBBMgr**
Remarks

This property is a McadSymbolBBMgr object.


IMcadStandardMgr::AddStandard Method
Summary

Created a new standard based on an original standard, and optionally sets the new standard as current.

Visual Basic
Sub AddStandard(BaseName As String, Current As [in, defaultvalue(TRUE)] VARIANT_BOOL, Name As [in, optional] VARIANT, Standard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
BaseName | String; input-only. Specifies the base standard that a new standard is originally created based on.
Current | Boolean, default value = True; input-only. Specifies whether to set this new standard as current, TRUE, or not, FALSE.
Name | Variant (String); input-only; optional. If specified, a new standard based on the specified base standard definition is created with the specified name.
Returns

McadStandard object


IMcadStandardMgr::CopyStandard Method
Summary

Creates a copy of an existing standard to the specified new name.

Visual Basic
Sub CopyStandard(BaseStandard As IMcadStandard, Name As String, NewStandard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
BaseStandard | McadStandard object; input-only. Specifies the standard to copy.
Name | String; input-only. Specifies the name for the newly copied standard.
Returns

McadStandard object


IMcadStandardMgr::GetStandard Method
Summary

Gets the standard with the specified name.

Visual Basic
Sub GetStandard(Name As String, Standard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the standard to obtain.
Returns

McadStandard object


IMcadStandardMgr::RemoveStandard Method
Summary

Removes the specified standard from the standard manager. This is equivalent to calling the McadStandard > Delete method on a specified standard to be removed.

Visual Basic
Sub RemoveStandard(Name As String)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the standard to remove.
Returns

None


IMcadStandardMgr::UpdateSymbols Method
Summary

Updates all symbols with respect to changes made to their standards.

Visual Basic
Sub UpdateSymbols()
Returns

None


IMcadStandards Interface
Summary

A collection of McadStandard objects

Class Hierarchy

Declaration syntax

IMcadStandards
Visual Basic
Public Interface IMcadStandards
Inherits IDispatch
Links
IMcadStandards Members, SymBBAuto Library


IMcadStandards Members
Summary

The following tables list the members exposed by IMcadStandards.

Methods
Name | Description
Add | Add a new standard to the collection.
Item | Obtains a specified standard from the collection.
Remove | Removes the specified standard from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of the standards in the collection.


IMcadStandards::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadStandards::Count Property
Summary

Specifies the total number of the standards in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadStandards::Add Method
Summary

Add a new standard to the collection.

Visual Basic
Sub Add(Item As IMcadStandard)
Parameters
Parameters | Description
Item | McadStandard object; input-only. Specifies the standard to add to the collection.
Returns

None


IMcadStandards::Item Method
Summary

Obtains a specified standard from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the standard to obtain.
Returns

McadStandard object


IMcadStandards::Remove Method
Summary

Removes the specified standard from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the standard to be removed
Returns

None


IMcadSurfaceTexture Interface
Summary

A surface texture symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
Visual Basic
Public Interface IMcadSurfaceTexture
Inherits IMcadSymbol2
Links
IMcadSurfaceTexture Members, SymBBAuto Library


IMcadSurfaceTexture Members
Summary

The following tables list the members exposed by IMcadSurfaceTexture.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
WavinessValue | Specifies the value of the waviness field for the surface texture.


IMcadSurfaceTexture::AllowanceValue Property
Summary

Specifies the value of the machining allowance field.

Visual Basic
Property AllowanceValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::Angle Property
Summary

Specifies the angle in degrees for the surface texture.

Visual Basic
Property Angle() As double
Remarks

This property is a Double.


IMcadSurfaceTexture::AutomaticAdjust Property
Summary

Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.

Visual Basic
Property AutomaticAdjust() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTexture::CommentValue Property
Summary

Specifies the value of the general comment field.

Visual Basic
Property CommentValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::CutoffValue Property
Summary

Specifies the value of the cutoff field for a surface texture.

Visual Basic
Property CutoffValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::IsAllAround Property
Summary

Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.

Visual Basic
Property IsAllAround() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTexture::IsForceTail Property
Summary

Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.

Visual Basic
Property IsForceTail() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTexture::IsMajority Property
Summary

Specifies whether the surface texture is majority, TRUE, or not, FALSE.

Visual Basic
Property IsMajority() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTexture::LayDirection Property
Summary

Specifies the direction of machining lay for the surface texture.

Visual Basic
Property LayDirection() As McadDirectionLayType
Remarks

This property is a McadDirectionLayType enumeration.


IMcadSurfaceTexture::LayDirectionValue Property
Summary

Specifies the value of the direction of machining lay for the surface texture.

Visual Basic
Property LayDirectionValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::MaximumSpacingValue Property
Summary

Specifies the value of the maximum roughness spacing field for the surface texture.

Visual Basic
Property MaximumSpacingValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::OtherMinimumValue Property
Summary

Specifies the value of the other roughness minimum field for the surface texture.

Visual Basic
Property OtherMinimumValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::OtherValue Property
Summary

Specifies the value of the other field for the surface texture.

Visual Basic
Property OtherValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::Production2Value Property
Summary

Specifies the value of the secondary production field for the surface texture.

Visual Basic
Property Production2Value() As String
Remarks

This property is a String.


IMcadSurfaceTexture::ProductionValue Property
Summary

Specifies the value of the production field for the surface texture.

Visual Basic
Property ProductionValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::RaMaximumValue Property
Summary

Specifies the value of the surface roughness average maximum value field for the surface texture.

Visual Basic
Property RaMaximumValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::RaMinimumValue Property
Summary

Specifies the value of the surface roughness average minimum value field for the surface texture.

Visual Basic
Property RaMinimumValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::ReferenceValue Property
Summary

Specifies the value of the reference field for the surface texture.

Visual Basic
Property ReferenceValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::SamplingLengthValue Property
Summary

Specifies the value of the sampling length field for the surface texture.

Visual Basic
Property SamplingLengthValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture::SurfaceTexture Property
Summary

Specifies the surface type of the surface texture.

Visual Basic
Property SurfaceTexture() As McadSurfaceTextureType
Remarks

This property is a McadSurfaceTextureType enumeration.


IMcadSurfaceTexture::WavinessValue Property
Summary

Specifies the value of the waviness field for the surface texture.

Visual Basic
Property WavinessValue() As String
Remarks

This property is a String.


IMcadSurfaceTexture2 Interface
Summary

A surface texture symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
Visual Basic
Public Interface IMcadSurfaceTexture2
Inherits IMcadSurfaceTexture
Links
IMcadSurfaceTexture2 Members, SymBBAuto Library


IMcadSurfaceTexture2 Members
Summary

The following tables list the members exposed by IMcadSurfaceTexture2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


IMcadSurfaceTexture2::FirstRequirement Property
Summary

Specifies the first requirement for the surface.

Visual Basic
Property FirstRequirement() As String


IMcadSurfaceTexture2::FourthRequirement Property
Summary

Specifies the value of the fourth requirement field for the surface texture.

Visual Basic
Property FourthRequirement() As String


IMcadSurfaceTexture2::SecondRequirement Property
Summary

Specifies the second requirement for the surface.

Visual Basic
Property SecondRequirement() As String


IMcadSurfaceTexture2::ThirdRequirement Property
Summary

Specifies the value of the third requirement field for the surface texture.

Visual Basic
Property ThirdRequirement() As String


IMcadSurfaceTexture3 Interface
Summary

This is class IMcadSurfaceTexture3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4
Visual Basic
Public Interface IMcadSurfaceTexture3
Inherits IMcadSurfaceTexture2
Links
IMcadSurfaceTexture3 Members, SymBBAuto Library


IMcadSurfaceTexture3 Members
Summary

The following tables list the members exposed by IMcadSurfaceTexture3.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


IMcadSurfaceTexture3::SurfExtLinesOffset Property
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.


IMcadSurfaceTexture3::SurfExtLinesOvershot Property
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double


IMcadSurfaceTexture4 Interface
Summary

A surface texture symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4
                        IMcadSurfaceTexture5
Visual Basic
Public Interface IMcadSurfaceTexture4
Inherits IMcadSurfaceTexture3
Links
IMcadSurfaceTexture4 Members, SymBBAuto Library


IMcadSurfaceTexture4 Members
Summary

The following tables list the members exposed by IMcadSurfaceTexture4.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSurfIndLeader | Adds the surface indication leader for the surface texture symbol
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


IMcadSurfaceTexture4::AddSurfIndLeader Method
Summary

Adds the surface indication leader for the surface texture symbol

Visual Basic
Sub AddSurfIndLeader(Points As VARIANT)


IMcadSurfaceTexture5 Interface
Summary

This is class IMcadSurfaceTexture5.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4
                        IMcadSurfaceTexture5
Visual Basic
Public Interface IMcadSurfaceTexture5
Inherits IMcadSurfaceTexture4
Links
IMcadSurfaceTexture5 Members, SymBBAuto Library


IMcadSurfaceTexture5 Members
Summary

The following tables list the members exposed by IMcadSurfaceTexture5.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSurfIndLeader | Adds the surface indication leader for the surface texture symbol
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
IsAttachToFCF | This is IsAttachToFCF, a member of class IMcadSurfaceTexture5.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


IMcadSurfaceTexture5::IsAttachToFCF Method
Summary

This is IsAttachToFCF, a member of class IMcadSurfaceTexture5.

Visual Basic
Sub IsAttachToFCF(Attach As [out, retval] VARIANT_BOOL)


IMcadSurfaceTextureLibrary Interface
Summary

This object represents the surface texture library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadSurfaceTextureLibrary
Visual Basic
Public Interface IMcadSurfaceTextureLibrary
Inherits IMcadSymbolLibrary
Links
SymBBAuto Library


IMcadSurfaceTextureLibraryObject Interface
Summary

The IMcadSurfaceTextureLibraryObject interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadSurfaceTextureLibraryObject
Visual Basic
Public Interface IMcadSurfaceTextureLibraryObject
Inherits IMcadSymbolLibraryObject
Links
IMcadSurfaceTextureLibraryObject Members, SymBBAuto Library


IMcadSurfaceTextureLibraryObject Members
Summary

The following tables list the members exposed by IMcadSurfaceTextureLibraryObject.

Methods
Name | Description
RequirementValue | Property to get the requirement value of a surface texture library object.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsForceTail | Get force tail status.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
SubSymbolType | Get the symbol type of a surface texture library object.
symbolStandardClassName | Get the symbol standard class name.


IMcadSurfaceTextureLibraryObject::IsAllAround Property
Summary

Get the usage of the "all around" symbol.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*


IMcadSurfaceTextureLibraryObject::IsForceTail Property
Summary

Get force tail status.

Visual Basic
Property IsForceTail() As VARIANT_BOOL*


IMcadSurfaceTextureLibraryObject::IsMajority Property
Summary

Get the usage of the majority symbol.

Visual Basic
Property IsMajority() As VARIANT_BOOL*


IMcadSurfaceTextureLibraryObject::SubSymbolType Property
Summary

Get the symbol type of a surface texture library object.

Visual Basic
Property SubSymbolType() As McadSurfaceTextureType*


IMcadSurfaceTextureLibraryObject::RequirementValue Method
Summary

Property to get the requirement value of a surface texture library object.

Visual Basic
Sub RequirementValue(variable As McadSurfaceTextureRequirement, pVal As [out,retval] BSTR)


IMcadSurfaceTextureStandard Interface
Summary

A surface texture symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
Visual Basic
Public Interface IMcadSurfaceTextureStandard
Inherits IMcadSymbolStandard3
Links
IMcadSurfaceTextureStandard Members, SymBBAuto Library


IMcadSurfaceTextureStandard Members
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSurfaceTextureStandard::AllAroundAllowed Property
Summary

Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property AllAroundAllowed() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::AvailableLaySymbols Property
Summary

Gets the list of machining lay symbols that are available for this standard.

Visual Basic
Property AvailableLaySymbols() As VARIANT*
Remarks

The McadSurfaceTextureStandard > OfferedLaySymbols property specifies which of these available machining lay specification types are offered during creation and editing.

This property is a Variant (array of McadDirectionLayType enumerations).


IMcadSurfaceTextureStandard::FitCircle Property
Summary

Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property FitCircle() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::ForceTail Property
Summary

Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property ForceTail() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::FullList Property
Summary

Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.

Visual Basic
Property FullList() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::MajorityAllowed Property
Summary

Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property MajorityAllowed() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::Multiline Property
Summary

Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property Multiline() As VARIANT_BOOL
Remarks

This property is a Boolean.


IMcadSurfaceTextureStandard::OfferedLaySymbols Property
Summary

Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedLaySymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableLaySymbols, they are ignored.

This property is a Variant (array of McadDirectionLayType enumerations).


IMcadSurfaceTextureStandard2 Interface
Summary

A surface texture symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3
Visual Basic
Public Interface IMcadSurfaceTextureStandard2
Inherits IMcadSurfaceTextureStandard
Links
IMcadSurfaceTextureStandard2 Members, SymBBAuto Library


IMcadSurfaceTextureStandard2 Members
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard2.

Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSurfaceTextureStandard2::IsRequirementSupported Method
Summary

Gets whether the surface texture requirement is supported by this standard.

Visual Basic
Sub IsRequirementSupported(Requirement As McadSurfaceTextureRequirement, Supported As [out, retval] VARIANT_BOOL)
Remarks
Member | Description | Value
sbSurfTextRaMax | Roughness value Ra | 0
sbSurfTextRaMin | Roughness value Ra - minimum | 1
sbSurfTextProduction | Production method | 2
sbSurfTextProduction2 | Production method | 3
sbSurfTextAllowance | Finish allowance | 4
sbSurfTextDirLay | Direction of lay | 5
sbSurfTextSampLength | Sampling length or waviness height | 6
sbSurfTextCutoff | Cutoff value and evaluation length | 7
sbSurfTextOtherValue | Other roughness value | 8
sbSurfTextOtherMin | Other roughness minimum value | 9
sbSurfTextMaxRspac | Maximum spacing | 10
sbSurfTextReference | Reference length and evaluation length | 11
sbSurfTextWavines | Surface waviness | 12
sbSurfTextComment | Comment | 13
sbSurfTextFirstRequirement | First requirement | 65
sbSurfTextSecondRequirement | Second requirement | 66
sbSurfTextThirdRequirement | Third requirement | 67
sbSurfTextFourthRequirement | Fourth requirement | 68


IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method
Summary

Sets the preset list of values for all surface texture requirements to the factory default values.

Visual Basic
Sub SetAllSuggestedListsToDefaults()


IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method
Summary

Sets the preset list of values for the surface texture requirement to the factory default values.

Visual Basic
Sub SetSuggestedListToDefaults(Requirement As McadSurfaceTextureRequirement)
Parameters
Parameters | Description
Requirement | See table at IsRequirementSupported


IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)
Summary

Specifies the preset list of values for the surface texture requirement.

Visual Basic
Sub SuggestedList(Requirement As McadSurfaceTextureRequirement, Lists As VARIANT)
Parameters
Parameters | Description
Requirement | _nt_
Lists | _nt_ See list at IsRequirementSupported


IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)
Summary

Specifies the preset list of values for the surface texture requirement.

Visual Basic
Sub SuggestedList(Requirement As McadSurfaceTextureRequirement, Lists As [out, retval] VARIANT)
Parameters
Parameters | Description
Requirement | _nt_
Lists | _nt_ See list at IsRequirementSupported


IMcadSurfaceTextureStandard3 Interface
Summary

A surface texture symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3
Visual Basic
Public Interface IMcadSurfaceTextureStandard3
Inherits IMcadSurfaceTextureStandard2
Links
IMcadSurfaceTextureStandard3 Members, SymBBAuto Library


IMcadSurfaceTextureStandard3 Members
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard3.

Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | Specifies the setting of surface indication leader arrowhead scale.
SurfIndLeaderArrowType | Specifies the setting of surface indication leader arrowhead type.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property
Summary

Specifies the setting of surface indication leader arrowhead scale.

Visual Basic
Property SurfIndLeaderArrowScale() As double


IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property
Summary

Specifies the setting of surface indication leader arrowhead type.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType


IMcadSymbol Interface
Summary

A symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
Visual Basic
Public Interface IMcadSymbol
Inherits IAcadEntity
Links
IMcadSymbol Members, SymBBAuto Library


IMcadSymbol Members
Summary

The following tables list the members exposed by IMcadSymbol.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadSymbol::CoordinateSystem Property
Summary

Specifies the coordinate system for the symbol.

Visual Basic
Property CoordinateSystem() As VARIANT
Remarks

This property is a Variant (4*4 array of doubles).


IMcadSymbol::IsAttached Property
Summary

Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.

Visual Basic
Property IsAttached() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadSymbol::LeaderCount Property
Summary

Gets the number of leaders attached to a specific symbol.

Visual Basic
Property LeaderCount() As long*
Remarks

This property is a Long.


IMcadSymbol::Origin Property
Summary

Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.

Visual Basic
Property Origin() As VARIANT
Remarks

This property is a Variant (3-element array of doubles).


IMcadSymbol::Scale Property
Summary

Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.

Visual Basic
Property Scale() As double
Remarks

This property is a Double.


IMcadSymbol::Standard Property
Summary

Gets the standard this symbol is used in.

Visual Basic
Property Standard() As IMcadStandard*
Remarks

This property is a McadStandard object.


IMcadSymbol::SymbolStandard Property
Summary

Specifies the symbol standard for a symbol.

Visual Basic
Property SymbolStandard() As IMcadSymbolStandard*
Remarks

This property is a McadSymbolStandard object.


IMcadSymbol::AddLeader Method
Summary

Adds a leader with the specified nodes to a symbol.

Visual Basic
Sub AddLeader(Points As VARIANT, Index As [in, optional] VARIANT, AfterNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | Variant (array of doubles); input-only. Specifies the new leader nodes to be added in the 3D WCS coordinates. You must provide at least two points to define the leader. The third point is optional.
Index | Variant (long); input-only; optional. Specifies the existing leader to which the new node points are appended. If the balloon symbol already contains any number of leaders, the Index element must be specified.
AfterNode | Variant (3 element array of doubles); input-only; optional. Specifies an existing node point to add a branch to, or to append the new node points to a specific branch.
Returns

None

Remarks

This method is not supported by McadDetailSymbol, McadSectionLine or McadDetailSymbolLabel.


IMcadSymbol::AttachGeometry Method
Summary

Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.

Visual Basic
Sub AttachGeometry(Geometry As IDispatch, ArrowheadLocation As VARIANT, ViewId As [in, optional] VARIANT, Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | McadGeometry object from the Mcad ActiveX Automation server; input-only. Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
ArrowheadLocation | Variant (3-element array of doubles); input-only. Specifies the location to place the leader arrowhead.
ViewId | Variant (long); input-only; optional. Specifies if the symbol's leader is attached to the view.
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to attach to the geometry. If the symbol contains multiple leaders, the Index element must be specified.
LeafNode | Variant (3-element array of doubles); input-only; optional. Specifies the leaf or arrowhead node to attach to the geometry. If the leader being attached has multiple leaf nodes, the LeafNode element must be specified.
Returns

None

Remarks

If the leader start point is not located on the attached geometry, this function adds a surface extension line. Surface extension line is supported by arc, line and polyline.


IMcadSymbol::DetachGeometry Method
Summary

Detaches the specified symbol's leader from any attached geometry references or views.

Visual Basic
Sub DetachGeometry(Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Index | Variant (Long); input-only; optional. Specifies which of several leaders to detach from their attached geometry references or views.
LeafNode | Variant (3-element array of doubles);input-only; optional. Specifies the only one leaf node to detach from its attached geometry reference or view.
Returns

None

Remarks

If a surface extension line exists, it will be deleted.


IMcadSymbol::GetLeader Method
Summary

Gets the positions of the nodes of the specified leader.

Visual Basic
Sub GetLeader(Index As long, OnlyLeafNodes As [in, defaultvalue(FALSE)] VARIANT_BOOL, Nodes As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only. Specifies which leader to get the positions of leaf nodes for.
OnlyLeafNodes | Boolean, default value is False; input-only; optional (TBD)
Returns

Variant (array of arrays of points (3 element array of doubles))


IMcadSymbol::GetLeaderAttachment Method
Summary

Gets the attached geometry reference object, if present, for the symbol's leader.

Visual Basic
Sub GetLeaderAttachment(ViewId As [out, optional] VARIANT, Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT, Geometry As [out, retval] IDispatch*)
Parameters
Parameters | Description
ViewId | Variant (long); input-only; optional. Specifies which of multiple leaders to get the attached geometry for. If the symbol contains multiple leaders, the Index element must be specified.
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to get the attached geometry for. If the symbol contains multiple leaders, the Index element must be specified.
LeafNode | Variant (3-element array of doubles); input-only; optional. Specifies the leaf or arrowhead node to get to the attached geometry for. If the leader being attached has multiple leaf nodes, the LeafNode element must be specified.
Returns

AcadObject. This can be any of the drawing objects.

Remarks

This method has no implementation and is currently unsupported.


IMcadSymbol::InsertLeaderNode Method
Summary

Inserts the specified node point into a symbol's leader before the specified existing node.

Visual Basic
Sub InsertLeaderNode(Point As VARIANT, Before As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
Point | Variant (3-element array of doubles); input-only. Specifies the location of the new node point.
Before | Variant (3-element array of doubles); input-only. Specifies the existing node before which a new node is to be inserted.
Index | Variant (Long); input-only; optional. Specifies the leader to find the existing node on.
Returns

None


IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)
Summary

Specifies the leader arrow type for the selected symbol leaders.

Visual Basic
Sub LeaderArrowType(Index As [in, optional] VARIANT, Type As McadArrowType)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of the multiple leaders to specify the arrow type for.
Remarks

This property is a McadArrowType enumeration.


IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)
Summary

Specifies the leader arrow type for the selected symbol leaders.

Visual Basic
Sub LeaderArrowType(Index As [in, optional] VARIANT, Type As [out, retval] McadArrowType)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of the multiple leaders to specify the arrow type for.
Remarks

This property is a McadArrowType enumeration.


IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)
Summary

Specifies the color of a symbol's leader line.

Visual Basic
Sub LeaderColor(Index As [in, optional] VARIANT, Color As ACAD_COLOR)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the color for.
Remarks
  • The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new symbol's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)
Summary

Specifies the color of a symbol's leader line.

Visual Basic
Sub LeaderColor(Index As [in, optional] VARIANT, Color As [out, retval] ACAD_COLOR)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the color for.
Remarks
  • The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new symbol's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.


IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)
Summary

Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.

Visual Basic
Sub LeaderLanding(Index As [in, optional] VARIANT, Vector As VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
Remarks

This property is a Variant (3-element array of doubles).


IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Summary

Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.

Visual Basic
Sub LeaderLanding(Index As [in, optional] VARIANT, Vector As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
Remarks

This property is a Variant (3-element array of doubles).


IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)
Summary

Specifies the linetype for a specific symbol's leader.

Visual Basic
Sub LeaderLineType(Index As [in, optional] VARIANT, Type As IAcadLineType)
Parameters
Parameters | Description
Index | Index Variant (long); optional. Specifies the leader to specify the linetype for.
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.


IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)
Summary

Specifies the linetype for a specific symbol's leader.

Visual Basic
Sub LeaderLineType(Index As [in, optional] VARIANT, Type As [out, retval] IAcadLineType*)
Parameters
Parameters | Description
Index | Index Variant (long); optional. Specifies the leader to specify the linetype for.
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.


IMcadSymbol::MoveLeaderNode Method
Summary

Moves the specified leader node associated with a symbol to a new position.

Visual Basic
Sub MoveLeaderNode(NodePoint As VARIANT, ToPoint As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
NodePoint | Variant (3-element array of doubles); input-only. Specifies the node point to be moved.
ToPoint | Variant (3-element array of doubles); input-only. Specifies the new position of the selected node point.
Index | Variant (Long); input-only; optional. Specifies the leader to find the node point on. If a symbol contains multiple leaders, the Index element must be specified.
Returns

None


IMcadSymbol::RemoveLeader Method
Summary

Removes the specified leader from a symbol.

Visual Basic
Sub RemoveLeader(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the leader to be removed from a symbol.
Returns

None

Remarks

When a leader with an attached surface extension line is deleted, the surface extension line will be removed as well.

This method is not supported by McadDetailSymbol, McadSectionLine or McadDetailSymbolLabel.


IMcadSymbol::RemoveLeaderNode Method
Summary

Removes the specified leader nodes from the symbol's leader.

Visual Basic
Sub RemoveLeaderNode(Point As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
Point | Variant (3-element array of doubles); input-only. Specifies the node point on which you want to remove leaders.
Index | Variant (Long); input-only; optional. Specifies the leader to find the node point on. If a symbol contains multiple leaders and the Index element is not specified, the first leader is removed.
Returns

None


IMcadSymbol::SetToDefaults Method
Summary

Sets the properties of this symbol to the factory default values.

Visual Basic
Sub SetToDefaults()


IMcadSymbol2 Interface
Summary

A symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel
        IMcadBalloon
        IMcadDatumTarget
        IMcadDetailSymbol
        IMcadDetailSymbolLabel
        IMcadEdge
        IMcadFeatureControlFrame
        IMcadIdentifier
        IMcadJoint
        IMcadMarkStamp
        IMcadNote
        IMcadPartList
        IMcadPartReference
        IMcadSectionLine
        IMcadSurfaceTexture
        IMcadTaper
        IMcadWelding
Visual Basic
Public Interface IMcadSymbol2
Inherits IMcadSymbol
Links
IMcadSymbol2 Members, SymBBAuto Library


IMcadSymbol2 Members
Summary

The following tables list the members exposed by IMcadSymbol2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadSymbol2::UpdateToAttachedObject Method
Summary

Update symbol when attached object is modified.

Visual Basic
Sub UpdateToAttachedObject()


IMcadSymbolBBMgr Interface
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
Visual Basic
Public Interface IMcadSymbolBBMgr
Inherits IDispatch
Links
IMcadSymbolBBMgr Members, SymBBAuto Library


IMcadSymbolBBMgr Members
Summary

The following tables list the members exposed by IMcadSymbolBBMgr.

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
StandardMgr | Gets the StandardMgr object.
Properties
Name | Description
Application | Gets the AcadmApplication object.


IMcadSymbolBBMgr::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadSymbolBBMgr::BOMMgr Method
Summary

Gets the BOM manager object.

Visual Basic
Sub BOMMgr(Document As [in, optional] VARIANT, BOMMgr As [out, retval] IMcadBOMMgr*)
Remarks

This property is read-only and returns a McadBOMMgr object.


IMcadSymbolBBMgr::StandardMgr Method
Summary

Gets the StandardMgr object.

Visual Basic
Sub StandardMgr(Document As [in, optional] VARIANT, StandardMgr As [out, retval] IMcadStandardMgr*)
Remarks

This property is read-only and returns an McadStandardMgr object.


IMcadSymbolBBMgr2 Interface
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3
Visual Basic
Public Interface IMcadSymbolBBMgr2
Inherits IMcadSymbolBBMgr
Links
IMcadSymbolBBMgr2 Members, SymBBAuto Library


IMcadSymbolBBMgr2 Members
Summary

The following tables list the members exposed by IMcadSymbolBBMgr2.

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
TitleBorderMgr | Read-only property that gets the title border manager object.
Properties
Name | Description
Application | Gets the AcadmApplication object.


IMcadSymbolBBMgr2::ScaleAreaMgr Method
Summary

Read-only property that gets the manager object for scale area.

Visual Basic
Sub ScaleAreaMgr(Document As [in,optional] VARIANT, ScareaMgr As [out, retval] IMcadScaleAreaMgr*)


IMcadSymbolBBMgr2::TitleBorderMgr Method
Summary

Read-only property that gets the title border manager object.

Visual Basic
Sub TitleBorderMgr(Document As [in,optional] VARIANT, TitBrdMgr As [out, retval] IMcadTitleBorderMgr*)


IMcadSymbolBBMgr3 Interface
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3
Visual Basic
Public Interface IMcadSymbolBBMgr3
Inherits IMcadSymbolBBMgr2
Links
IMcadSymbolBBMgr3 Members, SymBBAuto Library


IMcadSymbolBBMgr3 Members
Summary

The following tables list the members exposed by IMcadSymbolBBMgr3.

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
RevisionListMgr | Read-only property that gets the revision list manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
SymbolLibrary | This read-only property is used to get the symbol library.
TitleBorderMgr | Read-only property that gets the title border manager object.
Properties
Name | Description
Application | Gets the AcadmApplication object.


IMcadSymbolBBMgr3::RevisionListMgr Method
Summary

Read-only property that gets the revision list manager object.

Visual Basic
Sub RevisionListMgr(Document As [in,optional] VARIANT, RevListMgr As [out, retval] IMcadRevisionMgr*)


IMcadSymbolBBMgr3::SymbolLibrary Method
Summary

This read-only property is used to get the symbol library.

Visual Basic
Sub SymbolLibrary(type As McadSymBBSymbolLibraryType, Document As [in,optional] VARIANT, bCreateIfNotExist As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] IMcadSymbolLibrary*)


IMcadSymbolLibrary Interface
Summary

The IMcadSymbolLibrary interface. The grouping of library object is based on the combination of standard and standard revision type.

In each group, there is only one default.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadEdgeLibrary
    IMcadFCFLibrary
    IMcadSurfaceTextureLibrary
    IMcadWeldingLibrary
Visual Basic
Public Interface IMcadSymbolLibrary
Inherits IAcadDictionary
Links
IMcadSymbolLibrary Members, SymBBAuto Library


IMcadSymbolLibrary Members
Summary

The following tables list the members exposed by IMcadSymbolLibrary.

Methods
Name | Description
appendItem | Add the data in this SymId to the library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
modifyItem | Update the data in this library object.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.


IMcadSymbolLibrary::appendItem Method
Summary

Add the data in this SymId to the library.

Visual Basic
Sub appendItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.


IMcadSymbolLibrary::DefaultItem Method
Summary

Get the default symbol library object of a symbol library.

Visual Basic
Sub DefaultItem(standardName As String, symbolStandardClassName As String, pNewVal As [out, retval] IMcadSymbolLibraryObject *)
Parameters
Parameters | Description
standardName | Base standard name
symbolStandardClassName | Symbol standard class name


IMcadSymbolLibrary::findItem Method
Summary

Get a symbol library object. Return the Symbol standard class name.

Visual Basic
Sub findItem(itemName As String, standardName As String, symbolStandardClassName As String, pNewVal As [out,retval] IMcadSymbolLibraryObject *)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | The Symbol Standard Class Name


IMcadSymbolLibrary::findList Method
Summary

Get a list of symbol library objects.

Visual Basic
Sub findList(standardName As String, symbolStandardClassName As String, LibItems As [out,retval] IMcadSymbolLibraryObjects *)
Parameters
Parameters | Description
standardName | Base standard name
symbolStandardClassName | Symbol standard class name


IMcadSymbolLibrary::isItemExist Method
Summary

Check the existence of a symbol library object. Return the Symbol standard class name.

Visual Basic
Sub isItemExist(itemName As String, standardName As String, symbolStandardClassName As String, pStatus As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | The Symbol standard class name.


IMcadSymbolLibrary::loadItem Method
Summary

Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.

Visual Basic
Sub loadItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.


IMcadSymbolLibrary::modifyItem Method
Summary

Update the data in this library object.

Visual Basic
Sub modifyItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.


IMcadSymbolLibrary::removeItem Method
Summary

Remove a symbol library object from a symbol library.

Visual Basic
Sub removeItem(itemName As String, standardName As String, symbolStandardClassName As String)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name


IMcadSymbolLibrary::renameItem Method
Summary

Update the name of the library object, itemName, with newName.

Visual Basic
Sub renameItem(itemName As String, newName As String, standardName As String, symbolStandardClassName As String)
Parameters
Parameters | Description
itemName | Name of library object.
newName | New name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name


IMcadSymbolLibrary::setIsDefaultItem Method
Summary

Set the default status of the library object.

Visual Basic
Sub setIsDefaultItem(itemName As String, standardName As String, symbolStandardClassName As String, newVal As VARIANT_BOOL)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
newVal | True or False
Remarks

There is one default for every standard and symbol standard class name combination. This property will unset the previous default, if necessary.


IMcadSymbolLibraryObject Interface
Summary

Represents the library of symbol objects.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject
    IMcadFCFLibraryObject
    IMcadSurfaceTextureLibraryObject
    IMcadWeldingLibraryObject
Visual Basic
Public Interface IMcadSymbolLibraryObject
Inherits IAcadObject
Links
IMcadSymbolLibraryObject Members, SymBBAuto Library


IMcadSymbolLibraryObject Members
Summary

The following tables list the members exposed by IMcadSymbolLibraryObject.

Properties
Name | Description
entryName | Specifies the name of a symbol library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.


IMcadSymbolLibraryObject::entryName Property
Summary

Specifies the name of a symbol library object.

Visual Basic
Property entryName() As String
Remarks

User is responsible to check the uniqueness of this name.


IMcadSymbolLibraryObject::isDefault Property
Summary

Change the default of this object. There will be only one default in for each standard and symbol standard.

Visual Basic
Property isDefault() As VARIANT_BOOL


IMcadSymbolLibraryObject::standardName Property
Summary

Gets the standard name of a library object.

Visual Basic
Property standardName() As BSTR*
Remarks

The standard name here refers to the base standard name.


IMcadSymbolLibraryObject::symbolStandardClassName Property
Summary

Get the symbol standard class name.

Visual Basic
Property symbolStandardClassName() As BSTR*


IMcadSymbolLibraryObjects Interface
Summary

The IMcadSymbolLibrary Objects interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObjects
Visual Basic
Public Interface IMcadSymbolLibraryObjects
Inherits IDispatch
Links
IMcadSymbolLibraryObjects Members, SymBBAuto Library


IMcadSymbolLibraryObjects Members
Summary

The following tables list the members exposed by IMcadSymbolLibraryObjects.

Methods
Name | Description
Add | Add a symbol library object to the collection.
Item | Obtains a specified library object from the collection.
Remove | Removes a library object from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.


IMcadSymbolLibraryObjects::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadSymbolLibraryObjects::Count Property
Summary

Gets the total number of objects in the collection.

Visual Basic
Property Count() As long*


IMcadSymbolLibraryObjects::Add Method
Summary

Add a symbol library object to the collection.

Visual Basic
Sub Add(Item As IMcadSymbolLibraryObject)
Parameters
Parameters | Description
Item | Symbol library object to add.


IMcadSymbolLibraryObjects::Item Method
Summary

Obtains a specified library object from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadSymbolLibraryObject*)
Parameters
Parameters | Description
Index | Index of library object to return


IMcadSymbolLibraryObjects::Remove Method
Summary

Removes a library object from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Index of object to remove


IMcadSymbolStandard Interface
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
Visual Basic
Public Interface IMcadSymbolStandard
Inherits IAcadObject
Links
IMcadSymbolStandard Members, SymBBAuto Library


IMcadSymbolStandard Members
Summary

The following tables list the members exposed by IMcadSymbolStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
Properties
Name | Description
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.


IMcadSymbolStandard::Revision Property
Summary

Gets the revision version of a symbol standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.


IMcadSymbolStandard::RevisionYear Property
Summary

Gets the revision version year of a symbol standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.


IMcadSymbolStandard::Standard Property
Summary

Gets the standard that a symbol standard is used in.

Visual Basic
Property Standard() As IMcadStandard**
Remarks

This property is a McadStandard object.


IMcadSymbolStandard::SetToDefaults Method
Summary

Sets the properties of this symbol standard to the factory default values.

Visual Basic
Sub SetToDefaults()


IMcadSymbolStandard2 Interface
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
Visual Basic
Public Interface IMcadSymbolStandard2
Inherits IMcadSymbolStandard
Links
IMcadSymbolStandard2 Members, SymBBAuto Library


IMcadSymbolStandard2 Members
Summary

The following tables list the members exposed by IMcadSymbolStandard2.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSymbolStandard2::ArrowScale Property
Summary

Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.

Visual Basic
Property ArrowScale() As double


IMcadSymbolStandard2::ArrowType Property
Summary

Specifies the arrow type of leader in symbol that belongs to this symbol standard.

Visual Basic
Property ArrowType() As McadArrowType


IMcadSymbolStandard2::LeaderTrueColor Property
Summary

Specifies the true color of leader in symbol that belongs to this symbol standard.

Visual Basic
Property LeaderTrueColor() As IAcadAcCmColor *


IMcadSymbolStandard2::TextHeight Property
Summary

Specifies the height of text in symbol that belongs to this symbol standard.

Visual Basic
Property TextHeight() As double


IMcadSymbolStandard2::TextTrueColor Property
Summary

Specifies the true color of text in a symbol that belongs to this symbol standard.

Visual Basic
Property TextTrueColor() As IAcadAcCmColor *


IMcadSymbolStandard2::SetToDefaultTextLeader Method
Summary

Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.

Visual Basic
Sub SetToDefaultTextLeader()


IMcadSymbolStandard3 Interface
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard
            IMcadBOMStandard
            IMcadDatumStandard
            IMcadDetailSymbolStandard
            IMcadEdgeStandard
            IMcadFCFStandard
            IMcadIdentifierStandard
            IMcadJointStandard
            IMcadMarkStampStandard
            IMcadNoteStandard
            IMcadSectionLineStandard
            IMcadSurfaceTextureStandard
            IMcadTaperStandard
            IMcadTitleBorderStandard
            IMcadWeldingStandard
Visual Basic
Public Interface IMcadSymbolStandard3
Inherits IMcadSymbolStandard2
Links
IMcadSymbolStandard3 Members, SymBBAuto Library


IMcadSymbolStandard3 Members
Summary

The following tables list the members exposed by IMcadSymbolStandard3.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadSymbolStandard3::SymbolStandardClassName Property
Summary

Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.

Visual Basic
Property SymbolStandardClassName() As BSTR*
Remarks

This property is read-only.


IMcadSymbolStandard3::SupportedArrowTypes Method
Summary

Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.

Visual Basic
Sub SupportedArrowTypes(allSrv As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] VARIANT)
Remarks

This property is read-only.


IMcadSymbolStandards Interface
Summary

A collection of McadSymbolStandard objects

Class Hierarchy

Declaration syntax

IMcadSymbolStandards
Visual Basic
Public Interface IMcadSymbolStandards
Inherits IDispatch
Links
IMcadSymbolStandards Members, SymBBAuto Library


IMcadSymbolStandards Members
Summary

The following tables list the members exposed by IMcadSymbolStandards.

Methods
Name | Description
Add | Adds a symbol standard to the collection.
Item | Gets a specified symbol standard from the collection.
Remove | Removes the specified symbol standard from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the symbol standards in the collection.


IMcadSymbolStandards::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.


IMcadSymbolStandards::Count Property
Summary

Gets the total number of the symbol standards in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IMcadSymbolStandards::Add Method
Summary

Adds a symbol standard to the collection.

Visual Basic
Sub Add(Item As IMcadSymbolStandard)
Parameters
Parameters | Description
Item | McadSymbolStandard object; input-only. Specifies the symbol standard to add to the collection.
Returns

None


IMcadSymbolStandards::Item Method
Summary

Gets a specified symbol standard from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the symbol standard to return.
Returns

None


IMcadSymbolStandards::Remove Method
Summary

Removes the specified symbol standard from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the item to be removed.
Returns

None


IMcadTaper Interface
Summary

This object represents the taper symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadTaper
Visual Basic
Public Interface IMcadTaper
Inherits IMcadSymbol2
Links
IMcadTaper Members, SymBBAuto Library


IMcadTaper Members
Summary

The following tables list the members exposed by IMcadTaper.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustReferenceLine | Adjust the angle of the landing and symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AboveCurve | Specifies if the symbol is above the curve.
CoordinateSystem | Specifies the coordinate system for the symbol.
DisplayString | Specifies the string of the symbol text.
HasLeader | Property to specify if the symbol has leader.
Inspect | Specifies if the theoretically exact frame is turned on or off.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the taper symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubSymbolType | Specifies the type of symbol. Currently the type of sbTaper2 only can be set for GB standard.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadTaper::AboveCurve Property
Summary

Specifies if the symbol is above the curve.

Visual Basic
Property AboveCurve() As VARIANT_BOOL


IMcadTaper::DisplayString Property
Summary

Specifies the string of the symbol text.

Visual Basic
Property DisplayString() As String


IMcadTaper::HasLeader Property
Summary

Property to specify if the symbol has leader.

Visual Basic
Property HasLeader() As VARIANT_BOOL*


IMcadTaper::Inspect Property
Summary

Specifies if the theoretically exact frame is turned on or off.

Visual Basic
Property Inspect() As VARIANT_BOOL


IMcadTaper::Orientation Property
Summary

Specifies the orientation of the taper symbol.

Visual Basic
Property Orientation() As McadOrientation


IMcadTaper::SubSymbolType Property
Summary

Specifies the type of symbol. Currently the type of sbTaper2 only can be set for GB standard.

Visual Basic
Property SubSymbolType() As McadTaperSlopeSymType


IMcadTaper::AdjustReferenceLine Method
Summary

Adjust the angle of the landing and symbol.

Visual Basic
Sub AdjustReferenceLine(angle As double)
Parameters
Parameters | Description
Angle | Input angle in radian.


IMcadTaperStandard Interface
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2
Visual Basic
Public Interface IMcadTaperStandard
Inherits IMcadSymbolStandard3
Links
IMcadTaperStandard Members, SymBBAuto Library


IMcadTaperStandard Members
Summary

The following tables list the members exposed by IMcadTaperStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadTaperStandard::OfferedSymbols Property
Summary

Specifies the list of symbols that are selected for the standard.

Visual Basic
Property OfferedSymbols() As VARIANT*
Remarks

The variant is an array of LONG. The index of the array is the value of McadTaperType. This property is read-only.


IMcadTaperStandard2 Interface
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2
Visual Basic
Public Interface IMcadTaperStandard2
Inherits IMcadTaperStandard
Links
IMcadTaperStandard2 Members, SymBBAuto Library


IMcadTaperStandard2 Members
Summary

The following tables list the members exposed by IMcadTaperStandard2.

Methods
Name | Description
GetDimensionType | Gets or sets preferred dimension type by current taper standard.
SetDimensionType | Sets the preferred dimension type by current taper standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadTaperStandard2::GetDimensionType Method
Summary

Gets or sets preferred dimension type by current taper standard.

Visual Basic
Sub GetDimensionType(ByRef dimType As McadTaperDimensionType, ByRef ratioFormat As McadTaperRatioFormatType, ByRef separator As String)
Parameters
Parameters | Description
dimType | Taper Dim type enum
ratioFormat | Taper Ratio enum
separator | All alpha-numeric characters including spaces are accepted as valid separators. The default separator is a colon “:”


IMcadTaperStandard2::SetDimensionType Method
Summary

Sets the preferred dimension type by current taper standard.

Visual Basic
Sub SetDimensionType(dimType As McadTaperDimensionType, rationFormat As McadTaperRatioFormatType, separator As String)
Parameters
Parameters | Description
dimType | Taper Dim type enum
separator | All alpha-numeric characters including spaces are accepted as valid separators. The default separator is a colon “:”
ratioFormat | Taper Ratio enum


IMcadTitle Interface
Summary

This object represents the title block of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadTitle
    IMcadTitle2
Visual Basic
Public Interface IMcadTitle
Inherits IDispatch
Links
IMcadTitle Members, SymBBAuto Library


IMcadTitle Members
Summary

The following tables list the members exposed by IMcadTitle.

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.


IMcadTitle::Attributes Property
Summary

Property that specifies all the attributes for the title block.

Visual Basic
Property Attributes() As VARIANT


IMcadTitle::InActive Property
Summary

Property that specifies the title block is inactive or invisible.

Visual Basic
Property InActive() As VARIANT_BOOL


IMcadTitle::Name Property
Summary

Property that specifies the name identifier of the title block.

Visual Basic
Property Name() As String


IMcadTitle::Position Property
Summary

Property that returns the position of the title block.

Visual Basic
Property Position() As VARIANT*


IMcadTitle::SetToDefaultAttributes Method
Summary

Initialize default attributes of the title block.

Visual Basic
Sub SetToDefaultAttributes(ret As [out, retval]VARIANT_BOOL)


IMcadTitle2 Interface
Summary

This is class IMcadTitle2.

Class Hierarchy

Declaration syntax

IMcadTitle
    IMcadTitle2
Visual Basic
Public Interface IMcadTitle2
Inherits IMcadTitle
Links
IMcadTitle2 Members, SymBBAuto Library


IMcadTitle2 Members
Summary

The following tables list the members exposed by IMcadTitle2.

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
BlockId | This is BlockId, a member of class IMcadTitle2.
BlockId32 | This is BlockId32, a member of class IMcadTitle2.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.


IMcadTitle2::BlockId Property
Summary

This is BlockId, a member of class IMcadTitle2.

Visual Basic
Property BlockId() As LONG_PTR*


IMcadTitle2::BlockId32 Property
Summary

This is BlockId32, a member of class IMcadTitle2.

Visual Basic
Property BlockId32() As LONG*


IMcadTitleBorder Interface
Summary

This object represents the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadTitleBorder
Visual Basic
Public Interface IMcadTitleBorder
Inherits IDispatch
Links
IMcadTitleBorder Members, SymBBAuto Library


IMcadTitleBorder Members
Summary

The following tables list the members exposed by IMcadTitleBorder.

Methods
Name | Description
Modify | Modifies this title/border.
Properties
Name | Description
Descriptor | Property that returns the descriptor for this title/border.
Ref | Property that returns a reference to the title/border object.
Ref32 | Property that returns a reference to the title/border object.


IMcadTitleBorder::Descriptor Property
Summary

Property that returns the descriptor for this title/border.

Visual Basic
Property Descriptor() As IMcadTitleBorderDescriptor**


IMcadTitleBorder::Ref Property
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref() As LONG_PTR*


IMcadTitleBorder::Ref32 Property
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref32() As LONG*
Remarks

For 64-bit platform only.


IMcadTitleBorder::Modify Method
Summary

Modifies this title/border.

Visual Basic
Sub Modify(context As [in,defaultvalue(0)]IMcadTitleBorderContext, ret As [out,retval]VARIANT_BOOL)
Parameters
Parameters | Description
context | Input title border descriptor object which specifies the modified settings data associated with the title/border.


IMcadTitleBorderContext Interface
Summary

This new object contains all option settings associated with a title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderContext
Visual Basic
Public Interface IMcadTitleBorderContext
Inherits IDispatch
Links
IMcadTitleBorderContext Members, SymBBAuto Library


IMcadTitleBorderContext Members
Summary

The following tables list the members exposed by IMcadTitleBorderContext.

Methods
Name | Description
GetMoveObjectsIDs | Get list of objects to be moved within the drawing border.
GetMoveObjectsIDs32 | Get list of objects to be moved within the drawing border.
GetMoveObjectsToPoint | Get destination point within the drawing border.
GetPartReference | Get objectId of the part reference to retrieve the attribute from.
GetPartReference32 | Get objectId of the part reference to retrieve the attribute from.
SetMoveObjects | Set list of objects to be moved and destination point within the drawing border.
SetPartReference | Set object ID of the part reference to retrieve the attribute from.
Properties
Name | Description
AutomaticPlacement | Property that specifies option for automatic placement.
BaseScale | Property that specifies option to set base scale factor.
DwgDefault | Property that specifies option to set drawing defaults.
MoveObjects | Property that specifies option to move specified objects within the drawing border.
Rescale | Property that specifies option to perform rescale.
RetrieveFromAsmProp | Property that specifies option to retrieve from assembly properties.
RetrieveFromPartRef | Property that specifies option to retrieve from part reference.
ThawAllLayers | Property that specifies option to thaw all layers for position of the title/border.


IMcadTitleBorderContext::AutomaticPlacement Property
Summary

Property that specifies option for automatic placement.

Visual Basic
Property AutomaticPlacement() As VARIANT_BOOL
Remarks

This property will not be set and return E_FAIL if the MoveObjects property is a false.


IMcadTitleBorderContext::BaseScale Property
Summary

Property that specifies option to set base scale factor.

Visual Basic
Property BaseScale() As VARIANT_BOOL


IMcadTitleBorderContext::DwgDefault Property
Summary

Property that specifies option to set drawing defaults.

Visual Basic
Property DwgDefault() As VARIANT_BOOL


IMcadTitleBorderContext::MoveObjects Property
Summary

Property that specifies option to move specified objects within the drawing border.

Visual Basic
Property MoveObjects() As VARIANT_BOOL
Remarks

When this property is a set to false, the ThawAllLayers and AutomaticPlacement properties will automatically be set to false.


IMcadTitleBorderContext::Rescale Property
Summary

Property that specifies option to perform rescale.

Visual Basic
Property Rescale() As VARIANT_BOOL


IMcadTitleBorderContext::RetrieveFromAsmProp Property
Summary

Property that specifies option to retrieve from assembly properties.

Visual Basic
Property RetrieveFromAsmProp() As VARIANT_BOOL
Remarks

When this property is a set to true, the RetrieveFromPartRef property will automatically be set to false.


IMcadTitleBorderContext::RetrieveFromPartRef Property
Summary

Property that specifies option to retrieve from part reference.

Visual Basic
Property RetrieveFromPartRef() As VARIANT_BOOL
Remarks

When this property is a set to true, the RetrieveFromAsmProp property will automatically be set to false.


IMcadTitleBorderContext::ThawAllLayers Property
Summary

Property that specifies option to thaw all layers for position of the title/border.

Visual Basic
Property ThawAllLayers() As VARIANT_BOOL
Remarks

This property will not be set and return E_FAIL if the MoveObjects property is a false.


IMcadTitleBorderContext::GetMoveObjectsIDs Method
Summary

Get list of objects to be moved within the drawing border.

Visual Basic
Sub GetMoveObjectsIDs(ObjectIDs As [out,retval] VARIANT)


IMcadTitleBorderContext::GetMoveObjectsIDs32 Method
Summary

Get list of objects to be moved within the drawing border.

Visual Basic
Sub GetMoveObjectsIDs32(ObjectIDs As [out,retval] VARIANT)


IMcadTitleBorderContext::GetMoveObjectsToPoint Method
Summary

Get destination point within the drawing border.

Visual Basic
Sub GetMoveObjectsToPoint(ToPoint As [out,retval] VARIANT)


IMcadTitleBorderContext::GetPartReference Method
Summary

Get objectId of the part reference to retrieve the attribute from.

Visual Basic
Sub GetPartReference(ObjectID As [out,retval] LONG_PTR)


IMcadTitleBorderContext::GetPartReference32 Method
Summary

Get objectId of the part reference to retrieve the attribute from.

Visual Basic
Sub GetPartReference32(ObjectID As [out,retval] LONG)


IMcadTitleBorderContext::SetMoveObjects Method
Summary

Set list of objects to be moved and destination point within the drawing border.

Visual Basic
Sub SetMoveObjects(ObjectIDs As VARIANT, ToPoint As VARIANT)
Parameters
Parameters | Description
ObjectIDs | The list of objects to be moved. The VARIANT is an array of long. This is needed if newVal = VARIANT_TRUE.
ToPoint | The position for the objects to move to. The VARIANT is a 3-element array of doubles for x, y and z points.
Remarks

This method will return E_FAIL if the MoveObjects property is false.


IMcadTitleBorderContext::SetPartReference Method
Summary

Set object ID of the part reference to retrieve the attribute from.

Visual Basic
Sub SetPartReference(ObjectID As VARIANT)
Parameters
Parameters | Description
ObjectID | The object ID of the part reference. The VARIANT is long.
Remarks

This method will return E_FAIL if the RetrieveFromPartRef property is a false.


IMcadTitleBorderDescriptor Interface
Summary

This object contains all data associated with a title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderDescriptor
Visual Basic
Public Interface IMcadTitleBorderDescriptor
Inherits IDispatch
Links
IMcadTitleBorderDescriptor Members, SymBBAuto Library


IMcadTitleBorderDescriptor Members
Summary

The following tables list the members exposed by IMcadTitleBorderDescriptor.

Properties
Name | Description
Border | Property that returns the drawing border for the title/border.
Position | Property that specifies the position of the title/border.
Title | Property that returns the title block for the title/border.
TitleBorderScale | Property that specifies scale for title/border.


IMcadTitleBorderDescriptor::Border Property
Summary

Property that returns the drawing border for the title/border.

Visual Basic
Property Border() As IMcadBorder**


IMcadTitleBorderDescriptor::Position Property
Summary

Property that specifies the position of the title/border.

Visual Basic
Property Position() As VARIANT


IMcadTitleBorderDescriptor::Title Property
Summary

Property that returns the title block for the title/border.

Visual Basic
Property Title() As IMcadTitle**


IMcadTitleBorderDescriptor::TitleBorderScale Property
Summary

Property that specifies scale for title/border.

Visual Basic
Property TitleBorderScale() As double


IMcadTitleBorderMgr Interface
Summary

This object is used for general functionality for title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderMgr
Visual Basic
Public Interface IMcadTitleBorderMgr
Inherits IDispatch
Links
IMcadTitleBorderMgr Members, SymBBAuto Library


IMcadTitleBorderMgr Members
Summary

The following tables list the members exposed by IMcadTitleBorderMgr.

Methods
Name | Description
CreateTitleBorder | Creates a new title/border.
DeleteTitleBorder | Removes the specified title/border from the drawing.
GetTitleBorderFromRef | Gets title border object from the specified object ID.
NewContext | Creates and initializes a new title border context.
NewDescriptor | Creates and initializes a new title border descriptor.
Properties
Name | Description
TitleBorders | Property that returns the list of all titles/borders in the drawing.


IMcadTitleBorderMgr::TitleBorders Property
Summary

Property that returns the list of all titles/borders in the drawing.

Visual Basic
Property TitleBorders() As IMcadTitleBorders**


IMcadTitleBorderMgr::CreateTitleBorder Method
Summary

Creates a new title/border.

Visual Basic
Sub CreateTitleBorder(desc As IMcadTitleBorderDescriptor, context As IMcadTitleBorderContext, titleBorder As [out,retval] IMcadTitleBorder*)
Parameters
Parameters | Description
desc | Input title border descriptor object which specifies all data associated with the title/border.
context | Input title border context object which specifies all option settings associated with the title/border.


IMcadTitleBorderMgr::DeleteTitleBorder Method
Summary

Removes the specified title/border from the drawing.

Visual Basic
Sub DeleteTitleBorder(titleBorder As IMcadTitleBorder, ret As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
titleBorder | Input title/border to be deleted.


IMcadTitleBorderMgr::GetTitleBorderFromRef Method
Summary

Gets title border object from the specified object ID.

Visual Basic
Sub GetTitleBorderFromRef(objectId As VARIANT, titleBorder As [out,retval] IMcadTitleBorder*)
Parameters
Parameters | Description
ObjectID | Input object ID of title border object in the drawing


IMcadTitleBorderMgr::NewContext Method
Summary

Creates and initializes a new title border context.

Visual Basic
Sub NewContext(context As [out, retval] IMcadTitleBorderContext *)


IMcadTitleBorderMgr::NewDescriptor Method
Summary

Creates and initializes a new title border descriptor.

Visual Basic
Sub NewDescriptor(desc As [out,retval] IMcadTitleBorderDescriptor*)


IMcadTitleBorders Interface
Summary

This object is a collection of title/border objects.

Class Hierarchy

Declaration syntax

IMcadTitleBorders
Visual Basic
Public Interface IMcadTitleBorders
Inherits IDispatch
Links
IMcadTitleBorders Members, SymBBAuto Library


IMcadTitleBorders Members
Summary

The following tables list the members exposed by IMcadTitleBorders.

Methods
Name | Description
Item | Obtains a specified title/border from the collection.
Properties
Name | Description
Application | Property that returns the application object.
Count | Property that returns the total number of title/border objects in the collection.


IMcadTitleBorders::Application Property
Summary

Property that returns the application object.

Visual Basic
Property Application() As IDispatch**


IMcadTitleBorders::Count Property
Summary

Property that returns the total number of title/border objects in the collection.

Visual Basic
Property Count() As long*


IMcadTitleBorders::Item Method
Summary

Obtains a specified title/border from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadTitleBorder*)
Parameters
Parameters | Description
Index | Input long value that specifies an index of the selected title/border object in the collection. Values range from 0 to one less than the total number of objects.


IMcadTitleBorderStandard Interface
Summary

This object represents the Drawing Sheet standard element.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2
Visual Basic
Public Interface IMcadTitleBorderStandard
Inherits IMcadSymbolStandard3
Links
IMcadTitleBorderStandard Members, SymBBAuto Library


IMcadTitleBorderStandard Members
Summary

The following tables list the members exposed by IMcadTitleBorderStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.


IMcadTitleBorderStandard::DefaultPaperFormat Property
Summary

Property that specifies the default paper format for the title/border.

Visual Basic
Property DefaultPaperFormat() As String


IMcadTitleBorderStandard::DefaultRevisionList Property
Summary

Property that specifies the default revision list.

Visual Basic
Property DefaultRevisionList() As String


IMcadTitleBorderStandard::DefaultTitleBlock Property
Summary

Property that specifies the default title block for the title/border.

Visual Basic
Property DefaultTitleBlock() As String


IMcadTitleBorderStandard::PaperFormats Property
Summary

Property that returns the available paper formats in the Drawing Sheet standard element.

Visual Basic
Property PaperFormats() As VARIANT*


IMcadTitleBorderStandard::RevisionLists Property
Summary

Property that returns available revision lists in the Drawing Sheet standard element.

Visual Basic
Property RevisionLists() As VARIANT*


IMcadTitleBorderStandard::TitleBlocks Property
Summary

Property that returns available title blocks in the Drawing Sheet standard element.

Visual Basic
Property TitleBlocks() As VARIANT*


IMcadTitleBorderStandard2 Interface
Summary

This is class IMcadTitleBorderStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2
Visual Basic
Public Interface IMcadTitleBorderStandard2
Inherits IMcadTitleBorderStandard
Links
IMcadTitleBorderStandard2 Members, SymBBAuto Library


IMcadTitleBorderStandard2 Members
Summary

The following tables list the members exposed by IMcadTitleBorderStandard2.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
InsertInvertPart | Specifies if an inverted drawing number block will be inserted when a title border is created.
InvertPartBorderHeight | Specifies the height of the inverted drawing number block.
InvertPartBorderWidth | Specifies the width of the inverted drawing number block.
InvertPartTextHeight | Specifies the height of the text in the inverted drawing number block.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.


IMcadTitleBorderStandard2::InsertInvertPart Property
Summary

Specifies if an inverted drawing number block will be inserted when a title border is created.

Visual Basic
Property InsertInvertPart() As VARIANT_BOOL


IMcadTitleBorderStandard2::InvertPartBorderHeight Property
Summary

Specifies the height of the inverted drawing number block.

Visual Basic
Property InvertPartBorderHeight() As double


IMcadTitleBorderStandard2::InvertPartBorderWidth Property
Summary

Specifies the width of the inverted drawing number block.

Visual Basic
Property InvertPartBorderWidth() As double


IMcadTitleBorderStandard2::InvertPartTextHeight Property
Summary

Specifies the height of the text in the inverted drawing number block.

Visual Basic
Property InvertPartTextHeight() As double


IMcadTransaction Interface
Summary

The McadTransaction object.

Class Hierarchy

Declaration syntax

IMcadTransaction
Visual Basic
Public Interface IMcadTransaction
Inherits IDispatch
Remarks

These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.

To end a transaction, set the transaction object to Null. Nested transactions are not supported.

To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete.

To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.

Links
IMcadTransaction Members, SymBBAuto Library


IMcadTransaction Members
Summary

The following tables list the members exposed by IMcadTransaction.

Properties
Name | Description
Application | Gets the AcadmApplication object.


IMcadTransaction::Application Property
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**


IMcadWelding Interface
Summary

A weld symbol object

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2
Visual Basic
Public Interface IMcadWelding
Inherits IMcadSymbol2
Links
IMcadWelding Members, SymBBAuto Library


IMcadWelding Members
Summary

The following tables list the members exposed by IMcadWelding.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadWelding::Orientation Property
Summary

Specifies the orientation of the arrow data and other data for a weld symbol.

Visual Basic
Property Orientation() As McadOrientation
Remarks

This property is a McadOrientation enumeration.


IMcadWelding::SubWeldingCount Property
Summary

Gets the number of subwelding symbols for a weld symbol.

Visual Basic
Property SubWeldingCount() As long*
Remarks

This property is a Long.


IMcadWelding::AddSubWelding Method
Summary

Add a new subweld symbol to the weld symbol.

Visual Basic
Sub AddSubWelding(Before As [in, optional] VARIANT)
Parameters
Parameters | Description
Before | Before Variant (Long); input-only; optional. If specified, the new symbol is inserted before an existing subweld symbol at the specified index; otherwise, the new subweld symbol is added as the last subweld symbol.
Returns

None


IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.

Visual Basic
Sub AngleValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary value is specified.
Remarks

This property is a String.


IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.

Visual Basic
Sub AngleValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary value is specified.
Remarks

This property is a String.


IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Summary

Specifies the type of the supplementary weld symbol describing the weld area.

Visual Basic
Sub AreaType(SubWelding As [in, defaultvalue(0)] long, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the symbol type for.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Summary

Specifies the type of the supplementary weld symbol describing the weld area.

Visual Basic
Sub AreaType(SubWelding As [in, defaultvalue(0)] long, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the symbol type for.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)
Summary

Specifies the weld association type for the weld symbol.

Visual Basic
Sub AssociationType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldAssociation)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadWeldAssociation enumeration.


IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)
Summary

Specifies the weld association type for the weld symbol.

Visual Basic
Sub AssociationType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldAssociation)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadWeldAssociation enumeration.


IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the backing field for the weld symbol.

Visual Basic
Sub BackingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the backing field for the weld symbol.

Visual Basic
Sub BackingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)
Summary

Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub Brazing(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Brazing As VARIANT_BOOL)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a Boolean.


IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)
Summary

Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub Brazing(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Brazing As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a Boolean.


IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the brazing field for the weld symbol.

Visual Basic
Sub BrazingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the brazing field for the weld symbol.

Visual Basic
Sub BrazingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the clearance field for the weld symbol.

Visual Basic
Sub ClearanceValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the clearance field for the weld symbol.

Visual Basic
Sub ClearanceValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
Summary

Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub ClosedTail(SubWelding As [in, defaultvalue(0)] long, Closed As VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the tail for.
Remarks

This property is a Boolean.


IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
Summary

Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub ClosedTail(SubWelding As [in, defaultvalue(0)] long, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the tail for.
Remarks

This property is a Boolean.


IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
Summary

Specifies the type of the contour symbol.

Visual Basic
Sub ContourType(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
Summary

Specifies the type of the contour symbol.

Visual Basic
Sub ContourType(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the contour field for the weld symbol.

Visual Basic
Sub ContourValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the contour field for the weld symbol.

Visual Basic
Sub ContourValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the weld control category field for the weld symbol.

Visual Basic
Sub ControlCategoryValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the weld control category field for the weld symbol.

Visual Basic
Sub ControlCategoryValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the depth field for a weld symbol.

Visual Basic
Sub DepthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the depth field for a weld symbol.

Visual Basic
Sub DepthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the weld designation field for the weld symbol.

Visual Basic
Sub DesignationValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the weld designation field for the weld symbol.

Visual Basic
Sub DesignationValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
Summary

Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub FieldWeld(SubWelding As [in, defaultvalue(0)] long, On As VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a Boolean.


IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
Summary

Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub FieldWeld(SubWelding As [in, defaultvalue(0)] long, On As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a Boolean.


IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the finishing method field for the contour weld symbol.

Visual Basic
Sub FinishingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the finishing method field for the contour weld symbol.

Visual Basic
Sub FinishingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the size of the gap between weldments.

Visual Basic
Sub GapValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks
  • This property is a String.
  • This property is a only available for specific weld symbol types only when the pertinent Brazing property is a false.


IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the size of the gap between weldments.

Visual Basic
Sub GapValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks
  • This property is a String.
  • This property is a only available for specific weld symbol types only when the pertinent Brazing property is a false.


IMcadWelding::HighlightSubWelding Method
Summary

Highlights the subwelding symbol at the specified index.

Visual Basic
Sub HighlightSubWelding(Highlight As VARIANT_BOOL, Index As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
Highlight | Highlight Boolean; input-only. Specifies whether the subwelding symbol is highlighted, TRUE, or not, False.
Index | Index Long, default value = 0; input-only; optional. Specifies the index of the subwelding symbol to be highlighted.
Returns

None


IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)
Summary

Specifies the type of identification line used for the weld symbol.

Visual Basic
Sub IdentificationLine(SubWelding As [in, defaultvalue(0)] long, Type As McadIdentificationType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadIdentificationType enumeration.


IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)
Summary

Specifies the type of identification line used for the weld symbol.

Visual Basic
Sub IdentificationLine(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadIdentificationType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadIdentificationType enumeration.


IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the total count of index field for the weld symbol.

Visual Basic
Sub IndexTotalValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Parameters
Parameters | Description
SubWelding | _nt_
Value | _nt_


IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the total count of index field for the weld symbol.

Visual Basic
Sub IndexTotalValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the index number field for the weld symbol.

Visual Basic
Sub IndexValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the index number field for the weld symbol.

Visual Basic
Sub IndexValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the length field for the weld symbol.

Visual Basic
Sub LengthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the length field for the weld symbol.

Visual Basic
Sub LengthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the supplementary data in the notes field for a weld symbol.

Visual Basic
Sub NotesValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the supplementary data in the notes field for a weld symbol.

Visual Basic
Sub NotesValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.


IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the number of welds for specific weld symbol types.

Visual Basic
Sub NumberValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld


IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the number of welds for specific weld symbol types.

Visual Basic
Sub NumberValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld


IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the distance between the centers of the welds for specific weld symbol types.

Visual Basic
Sub PitchValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld


IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the distance between the centers of the welds for specific weld symbol types.

Visual Basic
Sub PitchValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld


IMcadWelding::RemoveSubWelding Method
Summary

Removes the subwelding symbol at the specified index.

Visual Basic
Sub RemoveSubWelding(Index As long)
Parameters
Parameters | Description
Index | Index Long; input-only. Specifies the index of the subwelding symbol to be removed.
Returns

None


IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Summary

Specifies the type of the secondary symbol type for the weld symbol.

Visual Basic
Sub SecondarySymType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldSymbolType)


IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Summary

Specifies the type of the secondary symbol type for the weld symbol.

Visual Basic
Sub SecondarySymType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldSymbolType)


IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the secondary symbol type field for specific weld symbol types.

Visual Basic
Sub SecondarySymTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the secondary symbol type field for specific weld symbol types.

Visual Basic
Sub SecondarySymTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the size 2 field for specific weld symbol types.

Visual Basic
Sub Size2Value(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the size 2 field for specific weld symbol types.

Visual Basic
Sub Size2Value(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Summary

Specifies the type of the size for the weld symbol.

Visual Basic
Sub SizeType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldSymbolType)


IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Summary

Specifies the type of the size for the weld symbol.

Visual Basic
Sub SizeType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldSymbolType)


IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the size type field for specific weld symbol types.

Visual Basic
Sub SizeTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the size type field for specific weld symbol types.

Visual Basic
Sub SizeTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the size field for specific weld symbol types.

Visual Basic
Sub SizeValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbMeltThrough
  • sbPlugWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld


IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the size field for specific weld symbol types.

Visual Basic
Sub SizeValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbMeltThrough
  • sbPlugWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld


IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the spacing field for specific weld symbol types.

Visual Basic
Sub SpacingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbStudWeld


IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the spacing field for specific weld symbol types.

Visual Basic
Sub SpacingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbStudWeld


IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the weld specification field for the weld symbol.

Visual Basic
Sub SpecificationValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the weld specification field for the weld symbol.

Visual Basic
Sub SpecificationValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the weld standard field for the weld symbol.

Visual Basic
Sub StandardValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the weld standard field for the weld symbol.

Visual Basic
Sub StandardValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Summary

Specifies the value of the technical requirements field for the weld symbol.

Visual Basic
Sub TechnicalReqValue(SubWelding As [in, defaultvalue(0)] long, Value As String)


IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Summary

Specifies the value of the technical requirements field for the weld symbol.

Visual Basic
Sub TechnicalReqValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)


IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Summary

Specifies the value of the thickness field for specific weld symbol types.

Visual Basic
Sub ThicknessValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the AreaType property for this weld symbol is one of the following enumeration:

  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld


IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Summary

Specifies the value of the thickness field for specific weld symbol types.

Visual Basic
Sub ThicknessValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the AreaType property for this weld symbol is one of the following enumeration:

  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld


IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
Summary

Specifies the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
Summary

Specifies the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.


IMcadWelding2 Interface
Summary

This is class IMcadWelding2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2
Visual Basic
Public Interface IMcadWelding2
Inherits IMcadWelding
Links
IMcadWelding2 Members, SymBBAuto Library


IMcadWelding2 Members
Summary

The following tables list the members exposed by IMcadWelding2.

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
InsertProcess | This is InsertProcess, a member of class IMcadWelding2.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.


IMcadWelding2::InsertProcess Method
Summary

This is InsertProcess, a member of class IMcadWelding2.

Visual Basic
Sub InsertProcess(process As String, withPrefix As [in, defaultvalue(FALSE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long)


IMcadWeldingLibrary Interface
Summary

The IMcadWeldingLibrary interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadWeldingLibrary
Visual Basic
Public Interface IMcadWeldingLibrary
Inherits IMcadSymbolLibrary
Links
IMcadWeldingLibrary Members, SymBBAuto Library


IMcadWeldingLibrary Members
Summary

The following tables list the members exposed by IMcadWeldingLibrary.

Methods
Name | Description
appendItem | Add the data in this SymId to the library.
appendItemFromSubWelding | Append a subwelding symbol at the specified index to the welding symbol library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
loadItemToSubWelding | Load a subwelding symbol library object to a weld symbol at the specified index.
modifyItem | Update the data in this library object.
modifyItemFromSubWelding | Update the data in library object, itemName, with SymId at index, SubWeldingIndex.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.


IMcadWeldingLibrary::appendItemFromSubWelding Method
Summary

Append a subwelding symbol at the specified index to the welding symbol library.

Visual Basic
Sub appendItemFromSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.


IMcadWeldingLibrary::loadItemToSubWelding Method
Summary

Load a subwelding symbol library object to a weld symbol at the specified index.

Visual Basic
Sub loadItemToSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.


IMcadWeldingLibrary::modifyItemFromSubWelding Method
Summary

Update the data in library object, itemName, with SymId at index, SubWeldingIndex.

Visual Basic
Sub modifyItemFromSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.


IMcadWeldingLibraryObject Interface
Summary

The IMcadWeldingLibraryObject interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadWeldingLibraryObject
Visual Basic
Public Interface IMcadWeldingLibraryObject
Inherits IMcadSymbolLibraryObject
Links
IMcadWeldingLibraryObject Members, SymBBAuto Library


IMcadWeldingLibraryObject Members
Summary

The following tables list the members exposed by IMcadWeldingLibraryObject.

Methods
Name | Description
ArrowSideReqValue | Get the arrow side requirement value of welding library object.
OtherSideReqValue | Get the requirement value for other side of welding symbol type.
RequirementValue | Get the main requirement value for welding symbol type.
setIsDefault | Change the default of this object.
Type | Get the type of the symbol for a weld symbol.
Properties
Name | Description
AreaType | Get the type of supplementary weld symbol describing the weld area.
AssociationType | Get the weld association type for a welding library object.
ClosedTail | Get whether the tail is closed for a welding library object.
entryName | Specifies the name of a symbol library object.
FieldWeld | Get whether the field weld is set for a welding library object.
IdentificationLine | Get the location of the identification line for a welding library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.


IMcadWeldingLibraryObject::AreaType Property
Summary

Get the type of supplementary weld symbol describing the weld area.

Visual Basic
Property AreaType() As McadWeldSymbolType*


IMcadWeldingLibraryObject::AssociationType Property
Summary

Get the weld association type for a welding library object.

Visual Basic
Property AssociationType() As McadWeldAssociation*


IMcadWeldingLibraryObject::ClosedTail Property
Summary

Get whether the tail is closed for a welding library object.

Visual Basic
Property ClosedTail() As VARIANT_BOOL*


IMcadWeldingLibraryObject::FieldWeld Property
Summary

Get whether the field weld is set for a welding library object.

Visual Basic
Property FieldWeld() As VARIANT_BOOL*


IMcadWeldingLibraryObject::IdentificationLine Property
Summary

Get the location of the identification line for a welding library object.

Visual Basic
Property IdentificationLine() As McadIdentificationType*


IMcadWeldingLibraryObject::ArrowSideReqValue Method
Summary

Get the arrow side requirement value of welding library object.

Visual Basic
Sub ArrowSideReqValue(variable As McadWeldingRequirement, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out,retval] BSTR)


IMcadWeldingLibraryObject::OtherSideReqValue Method
Summary

Get the requirement value for other side of welding symbol type.

Visual Basic
Sub OtherSideReqValue(variable As McadWeldingRequirement, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out,retval] BSTR)


IMcadWeldingLibraryObject::RequirementValue Method
Summary

Get the main requirement value for welding symbol type.

Visual Basic
Sub RequirementValue(variable As McadWeldingRequirement, pVal As [out,retval] BSTR)


IMcadWeldingLibraryObject::setIsDefault Method
Summary

Change the default of this object.

Visual Basic
Sub setIsDefault(symbolStandardClassName As String, Val As VARIANT_BOOL)
Parameters
Parameters | Description
symbolStandardClassName | Symbol standard class name
Val | True or False


IMcadWeldingLibraryObject::Type Method
Summary

Get the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)


IMcadWeldingStandard Interface
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
Visual Basic
Public Interface IMcadWeldingStandard
Inherits IMcadSymbolStandard3
Links
IMcadWeldingStandard Members, SymBBAuto Library


IMcadWeldingStandard Members
Summary

The following tables list the members exposed by IMcadWeldingStandard.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


IMcadWeldingStandard::AvailableBackingSymbols Property
Summary

Gets the list of backing weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableBackingSymbols() As VARIANT*
Remarks

The OfferedBackingSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard::AvailableContourSymbols Property
Summary

Gets the list of contour weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableContourSymbols() As VARIANT*
Remarks

The OfferedContourSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard::AvailableWeldSymbols Property
Summary

Gets the list of weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableWeldSymbols() As VARIANT*
Remarks

The OfferedWeldSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard::ClosedTailAllowed Property
Summary

Gets whether a closed tail is allowed for symbols referencing this standard.

Visual Basic
Property ClosedTailAllowed() As VARIANT_BOOL*


IMcadWeldingStandard::IdentificationLineAllowed Property
Summary

Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property IdentificationLineAllowed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadWeldingStandard::IdentificationLineGap Property
Summary

Specifies the gap distance between identification lines for weld symbols referencing this standard.

Visual Basic
Property IdentificationLineGap() As double
Remarks

This property is a Double.


IMcadWeldingStandard::IdentificationLinetype Property
Summary

Specifies the linetype of the identification line for weld symbols referencing this standard.

Visual Basic
Property IdentificationLinetype() As IAcadLineType*
Remarks
  • This property type is AcadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX Automation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.


IMcadWeldingStandard::IdentificationLinetypeName Property
Summary

Specifies the linetype name of the identification line for weld symbols referencing this standard.

Visual Basic
Property IdentificationLinetypeName() As String
Remarks

This property is a String.


IMcadWeldingStandard::MultipleSymbolsAllowed Property
Summary

Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property MultipleSymbolsAllowed() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IMcadWeldingStandard::OfferedBackingSymbols Property
Summary

Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.

Visual Basic
Property OfferedBackingSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableBackingSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard::OfferedContourSymbols Property
Summary

Specifies the list of contour symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedContourSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableContourSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard::OfferedWeldSymbols Property
Summary

Specifies the list of weld symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedWeldSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableWeldSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).


IMcadWeldingStandard2 Interface
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3
Visual Basic
Public Interface IMcadWeldingStandard2
Inherits IMcadWeldingStandard
Links
IMcadWeldingStandard2 Members, SymBBAuto Library


IMcadWeldingStandard2 Members
Summary

The following tables list the members exposed by IMcadWeldingStandard2.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number


IMcadWeldingStandard2::WeldProcessPrefix Property
Summary

Specifies the prefix string to prepend to the process number

Visual Basic
Property WeldProcessPrefix() As BSTR*


IMcadWeldingStandard3 Interface
Summary

This is class IMcadWeldingStandard3.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3
Visual Basic
Public Interface IMcadWeldingStandard3
Inherits IMcadWeldingStandard2
Links
IMcadWeldingStandard3 Members, SymBBAuto Library


IMcadWeldingStandard3 Members
Summary

The following tables list the members exposed by IMcadWeldingStandard3.

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
ProcessGap | This is ProcessGap, a member of class IMcadWeldingStandard3.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ScaleFactor | This is ScaleFactor, a member of class IMcadWeldingStandard3.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number


IMcadWeldingStandard3::ProcessGap Property
Summary

This is ProcessGap, a member of class IMcadWeldingStandard3.

Visual Basic
Property ProcessGap() As double


IMcadWeldingStandard3::ScaleFactor Property
Summary

This is ScaleFactor, a member of class IMcadWeldingStandard3.

Visual Basic
Property ScaleFactor() As double


McadAlignmentType Enumeration
Summary

Enumerates all available alignment types for a drawing document element, such as captions and data in a column of a BOM database.

Visual Basic
Public Enum McadAlignmentType
  sbLeft = 0
  sbCenter = 1
  sbRight = 2
End Enum
Members
Members | Description
sbLeft | Sets Left as the alignment type for a drawing document element.
sbCenter | Sets Center as the alignment type for a drawing document element.
sbRight | Sets Right as the alignment type for a drawing document element.
Links
SymBBAuto Library


McadAnnotationViewLabel CoClass
Summary

Annotation view label entity.

Class Hierarchy

Declaration syntax

SymBBAuto::McadAnnotationViewLabel
Visual Basic
Public Class McadAnnotationViewLabel
Links
SymBBAuto Library


McadAnnotationViewStandard CoClass
Summary

Annotation view label standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadAnnotationViewStandard
Visual Basic
Public Class McadAnnotationViewStandard
Links
SymBBAuto Library


McadAnnotViewLabelPositionType Enumeration
Summary

McadAnnotViewLabelPositionType defines position of annotation view label.

Visual Basic
Public Enum McadAnnotViewLabelPositionType
  sbAnnotLabelBelow = 1
  sbAnnotLabelAbove = 2
End Enum
Members
Members | Description
sbAnnotLabelBelow | Label is below annotation view sub view
sbAnnotLabelAbove | Label is above annotation view sub view
Links
SymBBAuto Library


McadArrowType Enumeration
Summary

Enumerates all available arrow types for a symbol leader.

sbNoArrow : Indicates that no arrow is attached to the symbol leader.

sbArrowOpen : Indicates that the open arrow is attached to the symbol leader.

sbArrowOpen15 : Indicates that the open 15-degree arrow is attached to the symbol leader.

sbArrowOpen30 : Indicates that the open 30-dergee arrow is attached to the symbol leader.

sbArrowOpen60 : Indicates that the open 60-degree arrow is attached to the symbol leader.

sbArrowOpen90 : Indicates that the open 90-degree arrow is attached to the symbol leader.

sbArrowEmpty : Indicates that the empty arrow is attached to the symbol leader.

sbArrowEmpty15 : Indicates that the empty 15-degree arrow is attached to the symbol leader.

sbArrowEmpty30 : Indicates that the empty 30-degree arrow is attached to the symbol leader.

sbArrowEmpty60 : Indicates that the empty 60-degree arrow is attached to the symbol leader.

sbArrowEmpty90 : Indicates that the empty 90-degree arrow is attached to the symbol leader.

sbArrowClosed : Indicates that the closed arrow is attached to the symbol leader.

sbArrowClosed15 : Indicates that the closed 15-degree arrow is attached to the symbol leader.

sbArrowClosed30 : Indicates that the closed 30-degree arrow is attached to the symbol leader.

sbArrowClosed60 : Indicates that the closed 60-degree arrow is attached to the symbol leader.

sbArrowClosed90 : Indicates that the closed 90-degree arrow is attached to the symbol leader.

sbArrowFilled : Indicates that the filled arrow is attached to the symbol leader.

sbArrowFilled15 : Indicates that the filled 15-degree arrow is attached to the symbol leader.

sbArrowFilled30 : Indicates that the filled 30-degree arrow is attached to the symbol leader.

sbArrowFilled60 : Indicates that the filled 60-degree arrow is attached to the symbol leader.

sbArrowFilled90 : Indicates that the filled 90-degree arrow is attached to the symbol leader.

sbArrowBoxBlank : Indicates that the blank arrow is attached to the symbol leader.

sbArrowBoxFilled : Indicates that the box filled arrow is attached to the symbol leader.

sbArrowDatumBlank45 : Indicates that the datum blank 45-degree arrow is attached to the symbol leader.

sbArrowDatumFilled45 : Indicates that the datum filled 45-degree arrow is attached to the symbol leader.

sbArrowDatumBlank60 : Indicates that the datum blank 60-degree arrow is attached to the symbol leader.

sbArrowDatumFilled60 : Indicates that the datum blank 90-degree arrow is attached to the symbol leader.

sbArrowDot : Indicates that the dot arrow is attached to the symbol leader.

sbArrowDotBlank : Indicates that the dot blank arrow is attached to the symbol leader.

sbArrowOblique : Indicates that the oblique arrow is attached to the symbol leader.

sbArrowOrigin : Indicates that the origin arrow is attached to the symbol leader.

sbByStandard : Indicates that the arrow is attached to the symbol leader by standard.

sbArrowDatumThickLine : Indicates that the datum thick line arrow is attached to the symbol leader.

sbUserArrowType : Indicates that the user-defined arrow is attached to the symbol leader.

sbArrowDotSmall : Indicates that the dot small arrow is attached to the symbol leader.

sbArrowDotBlankSmall : Indicates that the dot blank arrow is attached to the symbol leader.

Visual Basic
Public Enum McadArrowType
  sbNoArrow = 0
  sbArrowOpen = 1
  sbArrowOpen15 = 2
  sbArrowOpen30 = 3
  sbArrowOpen60 = 4
  sbArrowOpen90 = 5
  sbArrowEmpty = 6
  sbArrowEmpty15 = 7
  sbArrowEmpty30 = 8
  sbArrowEmpty60 = 9
  sbArrowEmpty90 = 10
  sbArrowClosed = 11
  sbArrowClosed15 = 12
  sbArrowClosed30 = 13
  sbArrowClosed60 = 14
  sbArrowClosed90 = 15
  sbArrowFilled = 16
  sbArrowFilled15 = 17
  sbArrowFilled30 = 18
  sbArrowFilled60 = 19
  sbArrowFilled90 = 20
  sbArrowBoxBlank = 21
  sbArrowBoxFilled = 22
  sbArrowDatumBlank45 = 23
  sbArrowDatumFilled45 = 24
  sbArrowDatumBlank60 = 25
  sbArrowDatumFilled60 = 26
  sbArrowDot = 27
  sbArrowDotBlank = 28
  sbArrowOblique = 29
  sbArrowOrigin = 30
  sbByStandard = 31
  sbArrowDatumThickLine = 32
  sbArrowDotSmall = 33
  sbArrowDotBlankSmall = 34
  sbArrowFilledHalf = 35
  sbArrowEmptyHalf = 36
  sbArrowAcadArchTick = 37
  sbArrowAcadBoxBlank = 38
  sbArrowAcadBoxFilled = 39
  sbArrowAcadClosed = 40
  sbArrowAcadClosedBlank = 41
  sbArrowAcadClosedFilled = 42
  sbArrowAcadDatumBlank = 43
  sbArrowAcadDatumFilled = 44
  sbArrowAcadDot = 45
  sbArrowAcadDotBlank = 46
  sbArrowAcadDotSmall = 47
  sbArrowAcadIntegral = 48
  sbArrowAcadNone = 49
  sbArrowAcadOblique = 50
  sbArrowAcadOpen = 51
  sbArrowAcadOpen30 = 52
  sbArrowAcadOpen90 = 53
  sbArrowAcadOrigin = 54
  sbArrowAcadOrigin2 = 55
  sbArrowAcadSmall = 56
  sbUserArrowDialog = 57
  sbVaries = 58
  sbArrowFilled20 = 59
  sbUserArrowType = 1000
End Enum
Links
SymBBAuto Library


McadAttachmentPoint Enumeration
Summary

Enumerates all available points for attaching a leader to symbols.

sbTopLeft : Places the leader to the top-left of symbols.

sbBottomLeft : Places the leader to the bottom-left of symbols.

sbBottomRight : Places the leader to the bottom-right of symbols.

sbTopRight : Places the leader to the top-right of symbols.

Visual Basic
Public Enum McadAttachmentPoint
  sbTopLeft = 0
  sbBottomLeft = 1
  sbBottomRight = 2
  sbTopRight = 3
End Enum
Links
SymBBAuto Library


McadAttachmentType Enumeration
Summary

Enumerates all available leader attachment point types for symbols.

sbToCenter : Attaches the leader to the center of symbols.

sbToExtents : Attaches the leader to the extents of symbols.

sbToOrigin : Attaches the leader to the origin of symbols in the coordinate system.

Visual Basic
Public Enum McadAttachmentType
  sbToCenter = 0
  sbToExtents = 1
  sbToOrigin = 2
End Enum
Links
SymBBAuto Library


McadAttachPosition Enumeration
Summary

This is record McadAttachPosition.

Visual Basic
Public Enum McadAttachPosition
  sbAttachLeft = 0
  sbAttachRight = 1
  sbAttachTop = 2
  sbAttachBottom = 3
End Enum
Links
SymBBAuto Library


McadAttributeAssociativity Enumeration
Summary

Enumerates all available behaviors of the attribute when the object that the attribute is attached to is copied.

mcDefault : If the McadAttributeAssociativity element is not specified in pertinent methods, the default associativity behavior is used.

mcCopyAlways : Indicates this attribute is always copied.

mcShareAlways : Indicates this attribute is always shared.

mcIgnoreAlways : Indicates this attribute is always ignored.

Visual Basic
Public Enum McadAttributeAssociativity
  mcDefault = 0
  mcCopyAlways = 1
  mcShareAlways = 2
  mcIgnoreAlways = 3
End Enum
Links
SymBBAuto Library


McadBalloon CoClass
Summary

A balloon symbol object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloon
Visual Basic
Public Class McadBalloon
Links
SymBBAuto Library


McadBalloonCollectionType Enumeration
Summary

Enumerates all available alignment types of collected balloons for selected part references. The orientation of collected balloons depends on the position of the last leader segment.

sbHorizontal : Aligns collected balloons horizontally.

sbVertical : Aligns collected balloons vertically.

Visual Basic
Public Enum McadBalloonCollectionType
  sbHorizontal = 0
  sbVertical = 1
End Enum
Links
SymBBAuto Library


McadBalloons CoClass
Summary

A collection of McadBalloon objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloons
Visual Basic
Public Class McadBalloons
Links
SymBBAuto Library


McadBalloonStandard CoClass
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloonStandard
Visual Basic
Public Class McadBalloonStandard
Links
SymBBAuto Library


McadBalloonType Enumeration
Summary

Enumerates all available balloon patterns that can be used to override when creating new balloon symbols by a specific standard.

sbByStandardBalloon : Sets the standard option as the balloon pattern in a drawing document. The standard balloon is defined by the drawing manager.

sbNoBalloon :

Sets the open option as the balloon pattern in a drawing document.

sbCircularBalloon :

Sets the predefined Circular option as the balloon pattern in a drawing document.

sbCircular2Balloon :

Sets the predefined Circular2 option as the balloon pattern in a drawing document.

sbLinearBalloon :

Sets the predefined Linear option as the balloon pattern in a drawing document.

sbEmptyBalloon :

Sets the predefined zigzag option as the balloon pattern in a drawing document.

sbNAngleBalloon :

Sets the predefined polygon option as the balloon pattern in a drawing document.

sbUserBalloon : Sets the custom balloon as the balloon pattern in a drawing document.

Visual Basic
Public Enum McadBalloonType
  sbByStandardBalloon = 0
  sbNoBalloon = 1
  sbCircularBalloon = 2
  sbCircular2Balloon = 3
  sbLinearBalloon = 4
  sbEmptyBalloon = 5
  sbNAngleBalloon = 6
  sbZigZagBalloon = 7
  sbUserBalloon = 8
End Enum
Members
Members | Description
sbZigZagBalloon | Sets the predefined Zigzag option as the balloon pattern in a drawing document.
Links
SymBBAuto Library


McadBOM CoClass
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOM
Visual Basic
Public Class McadBOM
Links
SymBBAuto Library


McadBOMExportFormatType Enumeration
Summary

Enumerates all available BOM table export formats.

exTXT : Indicates the export format of text separated with tabulator.

exCSV : Indicates the export format of text separated with semicolon.

exHTML : Indicates the export format of HTML.

exMDB : Indicates the export format of the current Microsoft Access.

exMDB97 : Indicates the export format of Microsoft Access 97.

exEXCEL97 : Indicates the export format of Microsoft Excel 97.

exEXCEL95 : Indicates the export format of Microsoft Excel 95.

exDB5 : Indicates the export format of dBase 5.

exDBIV : Indicates the export format of dBase IV.

exDBIII : Indicates the export format of dBase III.

exFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0.

exFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6.

exFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5.

Visual Basic
Public Enum McadBOMExportFormatType
  exMDB = 1
  exMDB97 = 2
  exEXCEL97 = 3
  exEXCEL95 = 4
  exDB5 = 5
  exDBIV = 6
  exDBIII = 7
  exFOXVIS = 8
  exFOX26 = 9
  exFOX25 = 10
  exTXT = 11
  exCSV = 12
  exHTML = 13
End Enum
Links
SymBBAuto Library


McadBOMImportFormatType Enumeration
Summary

Enumerates all available BOM table import formats.

imMDB : Indicates the import format of the current Microsoft Access.

imEXCEL97 : Indicates the import format of Microsoft Excel 97.

imEXCEL95 : Indicates the import format of Microsoft Excel 95.

imDB5 : Indicates the export format of dBase 5.

imDBIV : Indicates the export format of dBase IV.

imDBIII : Indicates the export format of dBase III.

imimFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0.

imFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6.

imFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5.

imTXT : Indicates the export format of text separated with tabulator.

imCSV : Indicates the import format of HTML.

Visual Basic
Public Enum McadBOMImportFormatType
  imMDB = 1
  imEXCEL97 = 2
  imEXCEL95 = 3
  imDB5 = 4
  imDBIV = 5
  imDBIII = 6
  imimFOXVIS = 7
  imFOX26 = 8
  imFOX25 = 9
  imTXT = 10
  imCSV = 11
End Enum
Links
SymBBAuto Library


McadBOMItem CoClass
Summary

A bill of materials item or row object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMItem
Visual Basic
Public Class McadBOMItem
Links
SymBBAuto Library


McadBOMItemDefinitionType Enumeration
Summary

Enumerates all available BOM item definition types.

Unknown : Indicates that the BOM item definition type is unknown.

NonModal : Indicates that the BOM item definition type is User-Defined.

PartRef : Indicates that the BOM item definition type is AutoCAD Mechanical Part Reference.

BlockDef : Indicates that the BOM item definition type is Block Definition.

CompDef : Indicates that the BOM item definition type is AutoCAD Mechanical/Mechanical Desktop Component Definition.

Visual Basic
Public Enum McadBOMItemDefinitionType
  Unknown
  NonModal
  PartRef
  BlockDef
  CompDef
End Enum
Links
SymBBAuto Library


McadBOMItems CoClass
Summary

A collection of McadBOMItem objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMItems
Visual Basic
Public Class McadBOMItems
Links
SymBBAuto Library


McadBOMMgr CoClass
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMMgr
Visual Basic
Public Class McadBOMMgr
Links
SymBBAuto Library


McadBomOverrideType Enumeration
Summary
Public Enum McadBomOverrideType
  sbNoOverride = 0
  sbQtyOverride = 1
  sbFormulaOverride = 2
  sbImportOverride = 3
  sbContentOverride = 4
  sbMassOverride = 5
End Enum
Members
Members | Description
sbNoOverride | Has no bom override.
sbQtyOverride | Is a quantity override.
sbFormulaOverride | Is a formula override.
sbImportOverride | Is an import override.
sbContentOverride | Is a content override type.
sbMassOverride | Is a mass override.
Description

Enumerator for BOM override types.

Links
SymBBAuto Library


McadBOMs CoClass
Summary

A collection of McadBOM objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMs
Visual Basic
Public Class McadBOMs
Links
SymBBAuto Library


McadBOMStandard CoClass
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMStandard
Visual Basic
Public Class McadBOMStandard
Links
SymBBAuto Library


McadBOMUOMType Enumeration
Summary

Enumerates all available BOM UOM (Unit of Measurement) types.

Each : Indicates that the BOM UOM type is per item.

sqm : Indicates that the BOM UOM type is per each square meter.

sqcm : Indicates that the BOM UOM type is per each square centimeter.

sqft : Indicates that the BOM UOM type is per each square foot.

sqin : Indicates that the BOM UOM type is per each square inch.

gal : Indicates that the BOM UOM type is per gallon

qt : Indicates that the BOM UOM type is per qt.

lqd_oz : Indicates that the BOM UOM type is liquid ounce.

l : Indicates that the BOM UOM type is per liter.

ml : Indicates that the BOM UOM type is per milliliter.

yd : Indicates that the BOM UOM type is per yard.

ft : Indicates that the BOM UOM type is per foot.

in : Indicates that the BOM UOM type is per inch.

m : Indicates that the BOM UOM type is per meter.

cm : Indicates that the BOM UOM type is per centimeter.

mm : Indicates that the BOM UOM type is per millimeter.

lb : Indicates that the BOM UOM type is per pound.

oz : Indicates that the BOM UOM type is per ounce.

g : Indicates that the BOM UOM type is per gram.

mg : Indicates that the BOM UOM type is per milligram.

bx : Indicates that the BOM UOM type is per box.

Visual Basic
Public Enum McadBOMUOMType
  Each = 0
  sqm
  sqcm
  sqft
  sqin
  gal
  qt
  lqd_oz
  l
  ml
  yd
  ft
  in
  m
  cm
  mm
  lb
  oz
  g
  mg
  bx
End Enum
Links
SymBBAuto Library


McadBorder CoClass
Summary

This object represents the drawing border of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBorder
Visual Basic
Public Class McadBorder
Links
SymBBAuto Library


McadColumnDefinition CoClass
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

SymBBAuto::McadColumnDefinition
Visual Basic
Public Class McadColumnDefinition
Links
SymBBAuto Library


McadColumnDefinitions CoClass
Summary

A collection of McadColumnDefinition objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadColumnDefinitions
Visual Basic
Public Class McadColumnDefinitions
Links
SymBBAuto Library


McadColumnSplitStyle Enumeration
Summary

Enumerates all available column split styles for a Parts List.

sbSplitRows : Specifies that a Parts List is split by rows in a column split.

sbSplitSections : Specifies that a Parts List is split by sections in a column split.

Visual Basic
Public Enum McadColumnSplitStyle
  sbSplitRows = 0
  sbSplitSections = 1
End Enum
Links
SymBBAuto Library


McadColumnSplitWrap Enumeration
Summary

Enumerates all available column split wrap directions for a Parts List.

sbSplitLeft : Specifies that a Parts List wraps to the left in a column split.

sbSplitRight : Specifies that a Parts List wraps to the right in a column split.

Visual Basic
Public Enum McadColumnSplitWrap
  sbSplitLeft = 0
  sbSplitRight = 1
End Enum
Links
SymBBAuto Library


McadColumnType Enumeration
Summary

Enumerates all column types available in this BOM database for drawing documents. This ColumnType element is the internal name of the column attribute.

sbPartID : Specifies the object ID of this BOM item.

sbItem : Specifies the item number for this BOM item.

sbQuantity : Specifies the quantity of part references for this BOM item.

sbPartListName : Specifies the parts list name that is created from this BOM database.

sbPartListPath : Specifies the path to store the parts list that is created from this BOM database.

sbDescription : Specifies the supplementary data for this BOM database.

sbDescription2 : Specifies the secondary supplementary data for this BOM database.

sbStandard : Specifies the standard that this BOM database is used in.

sbStandard2 : Specifies the secondary standard that this BOM database is used in.

sbMaterial : Specifies the material for assemblies that are created using Structure in this BOM database.

sbMaterial2 : Specifies the secondary material for assemblies that are created using structure in this BOM database.

sbUserID : Specifies who is currently editing this BOM database.

sbMass : Specifies the mass for assemblies that are created using structure in this BOM database.

sbPrice : Specifies the price for assemblies that are created using structure in this BOM database.

sbDimension : Specifies the dimension measurement for assemblies that are created using structure in this BOM database.

sbUser1 : Specifies the first user-defined column in this BOM database.

sbUser2 : Specifies the second user-defined column in this BOM database.

sbUser3 : Specifies the third user-defined column in this BOM database.

sbUser4 : Specifies the fourth user-defined column in this BOM database.

sbUser5 : Specifies the fifth user-defined column in this BOM database.

sbUser6 : Specifies the sixth user-defined column in this BOM database.

sbUser7 : Specifies the seventh user-defined column in this BOM database.

sbUser8 : Specifies the eighth user-defined column in this BOM database.

sbFilter : Specifies the filter for this BOM database.

sbNote : Specifies the note column to give additional information to this BOM database.

sbVendor : Specifies the vendor information that relates to this BOM database.

sbAssembly : Specifies the assembly that relates to this BOM database.

sbDrawingManagerID : Specifies the object ID of the drawing manager that relates to this BOM database.

sbName : Specifies the name of this BOM database.

sbUnknownType : Specifies the unknown column type that is being used in this BOM database.

Visual Basic
Public Enum McadColumnType
  sbPartID = 0
  sbItem = 1
  sbQuantity = 2
  sbPartListName = 3
  sbPartListPath = 4
  sbDescription = 5
  sbDescription2 = 6
  sbStandard = 7
  sbStandard2 = 8
  sbMaterial = 9
  sbMaterial2 = 10
  sbUserID = 11
  sbMass = 12
  sbPrice = 13
  sbDimension = 14
  sbUser1 = 15
  sbUser2 = 16
  sbUser3 = 17
  sbUser4 = 18
  sbUser5 = 19
  sbUser6 = 20
  sbUser7 = 21
  sbUser8 = 22
  sbFilter = 23
  sbNote = 24
  sbVendor = 25
  sbAssembly = 26
  sbDrawingManagerID = 27
  sbName = 28
  sbUnknownType = 29
  sbUnitOfMeasure = 30
  sbCategory = 31
  sbFormat = 32
  sbZone = 33
  sbComments = 34
  sbPartNumber = 35
  sbTotalMass = 36
End Enum
Links
SymBBAuto Library


McadDataType Enumeration
Summary

Enumerates all data types that can be used for columns in this BOM database.

sbGeneralText : Sets the general text as the data type for columns in this BOM database.

sbInteger : Sets Integer as the data type for columns in this BOM database.

sbReal : Sets Real as the data type for columns in this BOM database.

Visual Basic
Public Enum McadDataType
  sbGeneralText = 0
  sbInteger = 1
  sbReal = 2
End Enum
Links
SymBBAuto Library


McadDatumIdentifier CoClass
Summary

Implements datum identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumIdentifier
Visual Basic
Public Class McadDatumIdentifier
Links
SymBBAuto Library


McadDatumStandard CoClass
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumStandard
Visual Basic
Public Class McadDatumStandard
Links
SymBBAuto Library


McadDatumTarget CoClass
Summary

A datum target symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumTarget
Visual Basic
Public Class McadDatumTarget
Links
SymBBAuto Library


McadDetailSymbol CoClass
Summary

This object represents the detail symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbol
Visual Basic
Public Class McadDetailSymbol
Links
SymBBAuto Library


McadDetailSymbolLabel CoClass
Summary

This object represents the detail symbol label created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbolLabel
Visual Basic
Public Class McadDetailSymbolLabel
Links
SymBBAuto Library


McadDetailSymbolStandard CoClass
Summary

This object represents the Detail symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbolStandard
Visual Basic
Public Class McadDetailSymbolStandard
Links
SymBBAuto Library


McadDetailSymbolStandardPropType Enumeration

McadDetailSymbolStandardPropType Enumeration MG2013New
Summary

Enumerates the property types for detail view standard that can be set to ByStandard.

Visual Basic
Public Enum McadDetailSymbolStandardPropType
  sbDetailViewIdentifierTextStyle = 0
  sbDetailViewIdentifierTextColor = 1
  sbDetailViewIdentifierTextHeight = 2
  sbDetailViewSymbol = 3
  sbDetailViewSymbolColor = 4
  sbDetailViewBoundaryLineColor = 5
  sbDetailViewBoundaryLineType = 6
  sbDetailViewBoundaryLineWeight = 7
  sbDetailViewBorderLineColor = 8
  sbDetailViewBorderLineType = 9
  sbDetailViewBorderLineWeight = 10
  sbDetailViewConnectionLineColor = 11
  sbDetailViewConnectionLineType = 12
  sbDetailViewConnectionLineWeight = 13
  sbDetailViewLabelTextStyle = 14
  sbDetailViewLabelTextColor = 15
  sbDetailViewLabelTextHeight = 16
End Enum
Members
Members | Description
sbDetailViewIdentifierTextStyle | Identifier Text style property.
sbDetailViewIdentifierTextColor | Identifier Text color property.
sbDetailViewIdentifierTextHeight | Identifier Text height property.
sbDetailViewSymbol | Arrangment Symbol property.
sbDetailViewSymbolColor | Arrangment Symbol color property.
sbDetailViewBoundaryLineColor | Boundary line Line color property.
sbDetailViewBoundaryLineType | Boundary line Linetype property.
sbDetailViewBoundaryLineWeight | Boundary line Line weight property.
sbDetailViewBorderLineColor | Model edge Linecolor property.
sbDetailViewBorderLineType | Model edge Linetype property.
sbDetailViewBorderLineWeight | Model edge Line color property.
sbDetailViewConnectionLineColor | Connection line Line color property.
sbDetailViewConnectionLineType | Connection line Linetype property.
sbDetailViewConnectionLineWeight | Connection line Lineweight property.
sbDetailViewLabelTextStyle | Label Text style property.
sbDetailViewLabelTextColor | Label Textcolor property.
sbDetailViewLabelTextHeight | Label Textheight property.
Links
SymBBAuto Library


McadDirectionLayType Enumeration
Summary

Enumerates all available directions of machining lay specifications for a surface texture symbol in a drawing document.

sbNotSpecified : No directions of machining lay specifications are available.

sbParallelToPlane :

Sets Parallel to Plane of Projection for the direction of machining lay specification of a surface texture symbol.

sbPerpendicularToPlane :

Sets Perpendicular to Plane of Projection for the direction of machining lay specification of a surface texture symbol.

sbCrossedIn2SlantDirections :

Sets Angular in Both Directions for the direction of machining lay specification of a surface texture symbol.

sbMultiDirection :

Sets Multidirectional for the direction of machining lay specification of a surface texture symbol.

sbCircularRelativeToCenter :

Sets Circular Relative to Center for the direction of machining lay specification of a surface texture symbol.

sbRadialRelativeToCenter :

Sets Radial Relative to Center for the direction of machining lay specification of a surface texture symbol.

sbParticulateNonDirectional :

Sets Particulate, Non-directional for the direction of machining lay specification of a surface texture symbol.

sbUserDirectionLayType : Sets the user-defined direction of machining lay specification of a surface texture symbol.

Visual Basic
Public Enum McadDirectionLayType
  sbNotSpecified = 0
  sbParallelToPlane = 1
  sbPerpendicularToPlane = 2
  sbCrossedIn2SlantDirections = 3
  sbMultiDirection = 4
  sbCircularRelativeToCenter = 5
  sbRadialRelativeToCenter = 6
  sbParticulateNonDirectional = 7
  sbUserDirectionLayType = 1000
End Enum
Links
SymBBAuto Library


McadEdge CoClass
Summary

This object represents the edge symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdge
Visual Basic
Public Class McadEdge
Links
SymBBAuto Library


McadEdgeLibrary CoClass
Summary

This is class SymBBAuto::McadEdgeLibrary.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeLibrary
Visual Basic
Public Class McadEdgeLibrary
Links
SymBBAuto Library


McadEdgeLibraryObject CoClass
Summary

This is class SymBBAuto::McadEdgeLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeLibraryObject
Visual Basic
Public Class McadEdgeLibraryObject
Links
SymBBAuto Library


McadEdgeRequirement Enumeration
Summary

Enumerates all available requirements for Edge library object.

Visual Basic
Public Enum McadEdgeRequirement
  sbEdgeMax = 0
  sbEdgeMin = 1
  sbEdgeSign = 2
End Enum
Members
Members | Description
sbEdgeMax | Specifies the value of the edge maximum
sbEdgeMin | Specifies the value of the edge minimum
sbEdgeSign | Specifies the value of the edge sign
Links
SymBBAuto Library


McadEdgeStandard CoClass
Summary

This object represents the edge symbol standard, Edges of Workpieces standard element.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeStandard
Visual Basic
Public Class McadEdgeStandard
Links
SymBBAuto Library


McadFCFLibrary CoClass
Summary

This is class SymBBAuto::McadFCFLibrary.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFLibrary
Visual Basic
Public Class McadFCFLibrary
Links
SymBBAuto Library


McadFCFLibraryObject CoClass
Summary

This is class SymBBAuto::McadFCFLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFLibraryObject
Visual Basic
Public Class McadFCFLibraryObject
Links
SymBBAuto Library


McadFCFRequirement Enumeration
Summary

Enumerates all available requirements for FCF library object.

Visual Basic
Public Enum McadFCFRequirement
  sbSymbol = 0
  sbSymbol2 = 1
  sbTolerance = 2
  sbTolerance2 = 3
  sbToleranceB = 4
  sbToleranceB2 = 5
  sbDatumPrimary = 6
  sbDatumPrimary2 = 7
  sbDatumSecondary = 8
  sbDatumSecondary2 = 9
  sbDatumTertiary = 10
  sbDatumTertiary2 = 11
  sbProjectedZone = 12
  sbDatumId = 13
  sbTopNote = 14
  sbBottomNote = 15
End Enum
Members
Members | Description
sbSymbol | Specifies the Geometric symbol 1 of the feature control frame.
sbSymbol2 | Specifies the Geometric symbol 2 of the feature control frame.
sbTolerance | Specifies the Tolerance of the feature control frame.
sbTolerance2 | Specifies the Tolerance2 of the feature control frame.
sbToleranceB | Specifies the Tolerance B of the feature control frame.
sbToleranceB2 | Specifies the Tolerance B2 of the feature control frame.
sbDatumPrimary | Specifies the DatumPrimary of the feature control frame
sbDatumPrimary2 | Specifies the DatumPrimary2 of the feature control frame
sbDatumSecondary | Specifies the DatumSecondary of the feature control frame
sbDatumSecondary2 | Specifies the DatumSecondary2 of the feature control frame
sbDatumTertiary | Specifies the DatumTertiary of the feature control frame
sbDatumTertiary2 | Specifies the DatumTertiary2 of the feature control frame
sbProjectedZone | Specifies the Projected Zone of the feature control frame
sbDatumId | Specifies the DatumId of the feature control frame.
sbTopNote | Specifies the Top Note of the feature control frame.
sbBottomNote | Specifies the Bottom Note of the feature control frame
Links
SymBBAuto Library


McadFCFStandard CoClass
Summary

A feature control frame symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFStandard
Visual Basic
Public Class McadFCFStandard
Links
SymBBAuto Library


McadFeatureControlFrame CoClass
Summary

Implements feature control frame symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFeatureControlFrame
Visual Basic
Public Class McadFeatureControlFrame
Links
SymBBAuto Library


McadFeatureIdentifier CoClass
Summary

A feature identifier symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadFeatureIdentifier
Visual Basic
Public Class McadFeatureIdentifier
Links
SymBBAuto Library


McadFilterOperator Enumeration
Summary

Enumerates all available filter operator for a Parts List custom filter.

sbContains : Specifies a "contains" operator.

sbDoesNotCont : Specifies a "does not contain" operator.

sbEqual : Specifies a "equal" operator.

sbNotEqual : Specifies a "not equal" operator.

sbLess : Specifies a "less than" operator

sbGreater : Specifies a "greater than" operator.

sbLessEqual : Specifies a "less than or equal" operator.

sbGreaterEqual : Specifies a "greater than or equal" operator.

Visual Basic
Public Enum McadFilterOperator
  sbContains = 0
  sbDoesNotCont = 1
  sbEqual = 2
  sbNotEqual = 3
  sbLess = 4
  sbGreater = 5
  sbLessEqual = 6
  sbGreaterEqual = 7
End Enum
Links
SymBBAuto Library


McadFilterType Enumeration
Summary

Enumerates all available filter types for a Parts List.

sbFilterBasic : Specifies a basic filter type for a Parts List.

sbFilterBallooned : Specifies a filter that filters the contents of a Parts List by ballooned parts.

sbFilterCustom : Specifies a filter that filters the contents of a Parts List by a BOM property.

sbFilterParts : Specifies a filter that filters the contents of a Parts List by selected parts.

sbFilterStdParts : Specifies a filter that filters the contents of a Parts List by Standard parts.

sbFilterSheet : Specifies a filter that filters the contents of a Parts List by a drawing layout.

sbFilterView : Specifies a filter that filters the contents of a Parts List by a drawing view.

sbFilterRange : Not Used.

Visual Basic
Public Enum McadFilterType
  sbFilterBasic = 0
  sbFilterBallooned = 1
  sbFilterCustom = 2
  sbFilterParts = 3
  sbFilterStdParts = 4
  sbFilterSheet = 5
  sbFilterView = 6
  sbFilterRange = 7
End Enum
Links
SymBBAuto Library


McadGDTSymbolType Enumeration
Summary

Enumerates all symbol types available for a feature control frame symbol. All the enumeration symbol types can be rolled into two groups: Geometric Characteristic and Material Removal Modifier.

sbStraightness :

Sets Straightness as the GDT symbol type for a feature control frame symbol.

sbFlatness :

Sets Flatness as the GDT symbol type for a feature control frame symbol.

sbCircularity :

Sets Circularity as the GDT symbol type for a feature control frame symbol.

sbCylindricity :

Sets Cylindricity as the GDT symbol type for a feature control frame symbol.

sbProfileLine :

Sets Profile of a Line as the GDT symbol type for a feature control frame symbol.

sbProfileSurface :

Sets Profile of a Surface as the GDT symbol type for a feature control frame symbol.

sbAngularity :

Sets Angularity as the GDT symbol type for a feature control frame symbol.

sbPerpendicularity :

Sets Perpendicularity as the GDT symbol type for a feature control frame symbol.

sbParallelism :

Sets Parallelism as the GDT symbol type for a feature control frame symbol.

sbPosition :

Sets Position as the GDT symbol type for a feature control frame symbol.

sbConcentricity :

Sets Concentricity as the GDT symbol type for a feature control frame symbol.

sbSymmetry :

Sets as Symmetry the GDT symbol type for a feature control frame symbol.

sbRunoutCircular :

Sets Circular Runout as the GDT symbol type for a feature control frame symbol.

sbRunoutTotal :

Sets Total Runout as the GDT symbol type for a feature control frame symbol.

sbLeastMaterialCondition :

Sets At Least Material Condition as the GDT symbol type for a feature control frame symbol.

sbMaximumMaterialCondition :

Sets At Maximum Material Condition as the GDT symbol type for a feature control frame symbol.

sbProjectedToleranceZone :

Sets Projected Tolerance Zone as the GDT symbol type for a feature control frame symbol.

sbTangentPlane :

Sets Tangent Plane as the GDT symbol type for a feature control frame symbol.

sbFreeState :

Sets Free State as the GDT symbol type for a feature control frame symbol.

sbEnvelope : Not implemented yet. Sets Envelope as the GDT symbol type for a feature control frame symbol.

sbRegardlessOfFeatureSize :

Sets Regardless of Feature Size, Material Modifier as the GDT symbol type for a feature control frame symbol.

sbStatisticalTolerance :

Sets Statistical Tolerance as the GDT symbol type for a feature control frame symbol.

sbDiameter :

Sets Diameter as the GDT symbol type for a feature control frame symbol.

sbBetween :

Sets Between as the GDT symbol type for a feature control frame symbol.

sbReciprocityCondition : Sets Reciprocity as the GDT symbol type for a feature control frame symbol.

sbSquare : Sets Square as the GDT symbol type for a feature control frame symbol.

sbUserSymbolGDT : Sets the user-defined GDT symbol type for a feature control frame symbol.

Visual Basic
Public Enum McadGDTSymbolType
  sbStraightness = 1
  sbFlatness = 2
  sbCircularity = 3
  sbCylindricity = 4
  sbProfileLine = 5
  sbProfileSurface = 6
  sbAngularity = 7
  sbPerpendicularity = 8
  sbParallelism = 9
  sbPosition = 10
  sbConcentricity = 11
  sbSymmetry = 12
  sbRunoutCircular = 13
  sbRunoutTotal = 14
  sbLeastMaterialCondition = 15
  sbMaximumMaterialCondition = 16
  sbProjectedToleranceZone = 17
  sbTangentPlane = 18
  sbFreeState = 19
  sbEnvelope = 20
  sbRegardlessOfFeatureSize = 21
  sbStatisticalTolerance = 22
  sbDiameter = 23
  sbBetween = 24
  sbReciprocityCondition = 25
  sbSquare = 26
  sbProfileSection = 27
  sbAxiality = 28
  sbRunoutCircularFilled = 29
  sbRunoutTotalFilled = 30
  sbUserSymbolGDT = 1000
End Enum
Links
SymBBAuto Library


McadIdentificationType Enumeration
Summary

Enumerates all available types of identification line used for a weld symbol. Identification lines are not available for ANSI standard.

sbNoIdentificationLine : Places no identification line on either the arrow side or the other side for a weld symbol.

sbIdentificationOtherSide :

Places the identification line on the other side of the arrow.

sbIdentificationArrowSide :

Places the identification line on the arrow side.

Visual Basic
Public Enum McadIdentificationType
  sbNoIdentificationLine = 0
  sbIdentificationOtherSide = 1
  sbIdentificationArrowSide = 2
End Enum
Links
SymBBAuto Library


McadIdentifier CoClass
Summary

Implements functionalty common to Datum Identifier symbols and Feature Identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadIdentifier
Visual Basic
Public Class McadIdentifier
Links
SymBBAuto Library


McadIdentifierPositionType Enumeration

McadIdentifierPositionType Enumeration MG2013New
Summary

Enumerates the identifier position type for section line.

Visual Basic
Public Enum McadIdentifierPositionType
  sbEndCuttingPlane = 0
  sbAboveDirectionArrowLine = 1
  sbAboveDirectionArrowSymbol = 2
  sbStartDirectionArrow = 3
  sbEndDirectionArrow = 4
End Enum
Members
Members | Description
sbEndCuttingPlane | End of cutting plane.
sbAboveDirectionArrowLine | Outside direction arrow line.
sbAboveDirectionArrowSymbol | Outside direction arrow symbol.
sbStartDirectionArrow | Start of direction arrow.
sbEndDirectionArrow | End of direction arrow.
Links
SymBBAuto Library


McadIdentifierStandard CoClass
Summary

Defines the drafting standard settings for Datym and Feature Identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadIdentifierStandard
Visual Basic
Public Class McadIdentifierStandard
Links
SymBBAuto Library


McadJoint CoClass
Summary

This is class SymBBAuto::McadJoint.

Class Hierarchy

Declaration syntax

SymBBAuto::McadJoint
Visual Basic
Public Class McadJoint
Links
SymBBAuto Library


McadJointStandard CoClass
Summary

This object represents a Dead Joint symbol standard created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadJointStandard
Visual Basic
Public Class McadJointStandard
Links
SymBBAuto Library


McadJointType Enumeration
Summary
Enum | Value | Description
sbSoldering | 0 | Soldering Dead Joint symbol
sbGluing | 1 | Gluing Dead Joint symbol
sbStitching | 2 | Stitching Joint symbol
sbOverlapping | 3 | Stitching with staples (Overlapping) Dead Joint symbol
sbCorner | 4 | Stitching with staples (Corner) Joint symbol
Visual Basic
Public Enum McadJointType
  sbSoldering = 0
  sbGluing = 1
  sbStitching = 2
  sbOverlapping = 3
  sbCorner = 4
End Enum
Links
SymBBAuto Library


McadLineVisibility Enumeration
Summary

Enumerates the available line visibility types.

Visual Basic
Public Enum McadLineVisibility
  sbContinuous = 0
  sbNoLines = 1
  sbBetweenPlanes = 2
End Enum
Members
Members | Description
sbContinuous | Value 0. The whole cutting plane is marked with one linetype of one color.
sbNoLines | Value 1. Only the breaks in cutting plane are marked.
sbBetweenPlanes | Value 2. The break have one linetype and color, the lines between them have diff. color.
Links
SymBBAuto Library


McadMarkStamp CoClass
Summary

A marking or stamping symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadMarkStamp
Visual Basic
Public Class McadMarkStamp
Links
SymBBAuto Library


McadMarkStampStandard CoClass
Summary

A marking/stamping symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadMarkStampStandard
Visual Basic
Public Class McadMarkStampStandard
Links
SymBBAuto Library


McadNote CoClass
Summary

This object represents the Note symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadNote
Visual Basic
Public Class McadNote
Links
SymBBAuto Library


McadNoteAttachPointType Enumeration
Summary

Enumerates all available note attach point types.

Visual Basic
Public Enum McadNoteAttachPointType
  sbNoPoint = 0
  sbTopText
  sbTopTopLine
  sbMiddleTopLine
  sbBottomTopLine
  sbMiddleText
  sbTopBottomLine
  sbMiddleBottomLine
  sbBottomBottomLine
  sbBottomText
  sbTopLineRefLine
  sbUnderlineAllText
End Enum
Remarks

Left/Right side is recognized by the symbol's orientation variable.

Links
SymBBAuto Library


McadNoteStandard CoClass
Summary

This object represents the Note symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadNoteStandard
Visual Basic
Public Class McadNoteStandard
Links
SymBBAuto Library


McadNoteTemplateGroupType Enumeration
Summary

Enumerator for note template group type.

Visual Basic
Public Enum McadNoteTemplateGroupType
  sbHoleDrilled = 1
  sbCounterBore = 2
  sbCounterSink = 3
  sbFillet = 10
  sbChamfer = 11
  sbPattern = 21
  sbPart = 30
  sbOther = 1000
End Enum
Members
Members | Description
sbHoleDrilled | Value 1.
sbCounterBore | Value 2.
sbCounterSink | Value 3.
sbFillet | Value 10.
sbChamfer | Value 11.
sbPattern | Value 21.
sbPart | Value 30.
sbOther | Value 1000.
Links
SymBBAuto Library


McadOrientation Enumeration
Summary

Enumerates all available orientations of welding symbol elements.

sbLeftSide :

Places a weld tail to the left of the arrow.

sbRightSide :

Places a weld tail to the right of the arrow.

sbBelow :

Place symbols on the arrow side upward the weld tail.

sbAbove :

Place symbols on the other side of the arrow upward the weld tail.

Visual Basic
Public Enum McadOrientation
  sbLeftSide = 0
  sbRightSide = 1
  sbBelow = 2
  sbAbove = 3
End Enum
Links
SymBBAuto Library


McadPartList CoClass
Summary

A part list symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartList
Visual Basic
Public Class McadPartList
Links
SymBBAuto Library


McadPartListBalloonedFilter CoClass
Summary

A filter object that filters the contents of a parts List by ballooned parts.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListBalloonedFilter
Visual Basic
Public Class McadPartListBalloonedFilter
Links
SymBBAuto Library


McadPartListCustomFilter CoClass
Summary

A filter object that filters the contents of a parts list by a BOM property.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListCustomFilter
Visual Basic
Public Class McadPartListCustomFilter
Links
SymBBAuto Library


McadPartListFilter CoClass
Summary

An object that filters the contents of a parts list

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListFilter
Visual Basic
Public Class McadPartListFilter
Links
SymBBAuto Library


McadPartListFilters CoClass
Summary

A collection of McadPartListFilter objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListFilters
Visual Basic
Public Class McadPartListFilters
Links
SymBBAuto Library


McadPartListGOST CoClass
Summary

A part list object

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListGOST
Visual Basic
Public Class McadPartListGOST
Links
SymBBAuto Library


McadPartLists CoClass
Summary

A collection of McadPartList objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartLists
Visual Basic
Public Class McadPartLists
Links
SymBBAuto Library


McadPartListStandard CoClass
Summary

The part list-specific information of a bill of materials symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListStandard
Visual Basic
Public Class McadPartListStandard
Links
SymBBAuto Library


McadPartListStdPartsFilter CoClass
Summary

A filter object that filters the contents of a parts list by Standard parts.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListStdPartsFilter
Visual Basic
Public Class McadPartListStdPartsFilter
Links
SymBBAuto Library


McadPartReference CoClass
Summary

A part reference symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartReference
Visual Basic
Public Class McadPartReference
Links
SymBBAuto Library


McadPartReferences CoClass
Summary

This is class SymBBAuto::McadPartReferences.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartReferences
Visual Basic
Public Class McadPartReferences
Links
SymBBAuto Library


McadRevisionList CoClass
Summary

This object represents the revision list created in the drawing. The interface is IMcadRevisionList.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionList
Visual Basic
Public Class McadRevisionList
Links
SymBBAuto Library


McadRevisionListDescriptor CoClass
Summary

This object contains all data associated with a revision list.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionListDescriptor
Visual Basic
Public Class McadRevisionListDescriptor
Remarks

The interface is IMcadRevisionListDescriptor.

Links
SymBBAuto Library


McadRevisionLists CoClass
Summary

This object is a collection of revision list objects.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionLists
Visual Basic
Public Class McadRevisionLists
Remarks

The interface is IMcadRevisionLists.

Links
SymBBAuto Library


McadRevisionMgr CoClass
Summary

This object is used for general functionality of revision lists.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionMgr
Visual Basic
Public Class McadRevisionMgr
Remarks

The interface is IMcadRevisionMgr.

Links
SymBBAuto Library


McadScaleArea CoClass
Summary

This object represents the scale area created in the model space.

Class Hierarchy

Declaration syntax

SymBBAuto::McadScaleArea
Visual Basic
Public Class McadScaleArea
Links
SymBBAuto Library


McadScaleAreaMgr CoClass
Summary

This object is used to create and find a scale area in the model space.

Class Hierarchy

Declaration syntax

SymBBAuto::McadScaleAreaMgr
Visual Basic
Public Class McadScaleAreaMgr
Links
SymBBAuto Library


McadScaleType Enumeration
Summary

Enumerator for scale type.

Visual Basic
Public Enum McadScaleType
  sbScalePf = 2
  sbScaleDf = 4
End Enum
Members
Members | Description
sbScalePf | Value 2.
sbScaleDf | Value 4.
Links
SymBBAuto Library


McadSectionLine CoClass
Summary

The object represents the section line creating in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSectionLine
Visual Basic
Public Class McadSectionLine
Remarks

The interface is IMcadSectionLine.

Links
SymBBAuto Library


McadSectionLineSegmentType Enumeration
Summary

Enumerates the available line segment types.

Visual Basic
Public Enum McadSectionLineSegmentType
  sbLineSegment = 0
  sbArcSegmentSecond = 1
  sbArcSegmentCenter = 2
End Enum
Members
Members | Description
sbLineSegment | Value 0 . Section line segment is line.
sbArcSegmentSecond | Value 1. Three point to define a Arc, picked point is on the Arc.
sbArcSegmentCenter | Value 2. Picked point is the center point of the Arc.
Links
SymBBAuto Library


McadSectionLineStandard CoClass
Summary

This object represents the standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSectionLineStandard
Visual Basic
Public Class McadSectionLineStandard
Remarks

The interface is IMcadSectionLineStandard.

In the extended interface, IMcadStandard3, add the property to get the new section line standard.

Links
SymBBAuto Library


McadSectionLineStandardPropType Enumeration

McadSectionLineStandardPropType Enumeration MG2013New
Summary

Enumerates the property types for section view standard, which can be set to ByStandard.

Visual Basic
Public Enum McadSectionLineStandardPropType
  sbSectionViewIdentifierTextStyle = 0
  sbSectionViewIdentifierTextColor = 1
  sbSectionViewIdentifierTextHeight = 2
  sbSectionViewStartSymbol = 3
  sbSectionViewEndSymbol = 4
  sbSectionViewSymbolColor = 5
  sbSectionViewEndBendLineColor = 6
  sbSectionViewEndBendLineType = 7
  sbSectionViewEndBendLineWeight = 8
  sbSectionViewPlaneLineColor = 9
  sbSectionViewPlaneLineType = 10
  sbSectionViewPlaneLineWeight = 11
  sbSectionViewLabelTextStyle = 12
  sbSectionViewLabelTextColor = 13
  sbSectionViewLabelTextHeight = 14
End Enum
Members
Members | Description
sbSectionViewIdentifierTextStyle | Identifier Text style property.
sbSectionViewIdentifierTextColor | Identifier Text color property.
sbSectionViewIdentifierTextHeight | Identifier Text height property.
sbSectionViewStartSymbol | Direction arrows Start symbol property.
sbSectionViewEndSymbol | Direction arrows End symbol property.
sbSectionViewSymbolColor | Direction arrows Symbol color property.
sbSectionViewEndBendLineColor | End and bend lines Line color property.
sbSectionViewEndBendLineType | End and bend lines Linetype property.
sbSectionViewEndBendLineWeight |
sbSectionViewPlaneLineColor | Cutting plane lines Line color property.
sbSectionViewPlaneLineType | Cutting plane lines Linetype property.
sbSectionViewPlaneLineWeight | Cutting plane lines Lineweight property.
sbSectionViewLabelTextStyle | Label Text style property.
sbSectionViewLabelTextColor | Label Text color property.
sbSectionViewLabelTextHeight | Label Text height property.
Links
SymBBAuto Library


McadStandard CoClass
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandard
Visual Basic
Public Class McadStandard
Links
SymBBAuto Library


McadStandardMgr CoClass
Summary

The symbol standards manager object

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandardMgr
Visual Basic
Public Class McadStandardMgr
Links
SymBBAuto Library


McadStandards CoClass
Summary

A collection of McadStandard objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandards
Visual Basic
Public Class McadStandards
Links
SymBBAuto Library


McadStdPartsFilterOption Enumeration
Summary

Enumerates all available filter options for a Parts List Standard parts filter.

sbStdPartsOnly : Specifies a Standard parts filter that filters the contents of a Parts List by Standard parts.

sbExcludeStdParts : Specifies a Standard parts filter that filters the contents of a Parts List by non-Standard parts.

Visual Basic
Public Enum McadStdPartsFilterOption
  sbStdPartsOnly = 0
  sbExcludeStdParts = 1
End Enum
Links
SymBBAuto Library


McadSurfaceTexture CoClass
Summary

A surface texture symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTexture
Visual Basic
Public Class McadSurfaceTexture
Links
SymBBAuto Library


McadSurfaceTextureLibrary CoClass
Summary

This is the object representing the surface texture library.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureLibrary
Visual Basic
Public Class McadSurfaceTextureLibrary
Links
SymBBAuto Library


McadSurfaceTextureLibraryObject CoClass
Summary

Implements the IMcadSurfaceTextureLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureLibraryObject
Visual Basic
Public Class McadSurfaceTextureLibraryObject
Links
SymBBAuto Library


McadSurfaceTextureRequirement Enumeration
Summary

Surface Texture Requirement information.

sbSurfTextRaMax : Roughness value Ra

sbSurfTextRaMin : Roughness value Ra - minimum

sbSurfTextProduction : Production method

sbSurfTextProduction2 : Production method

sbSurfTextAllowance : Finish allowance

sbSurfTextDirLay : Direction of lay

sbSurfTextSampLength : Sampling length or waviness height

sbSurfTextCutoff : Cutoff value and evaluation length

sbSurfTextOtherValue : Other roughness value

sbSurfTextOtherMin : Other roughness minimum value

sbSurfTextMaxRspac : Maximum spacing

sbSurfTextReference : Reference length and evaluation length

sbSurfTextWavines : Surface waviness

sbSurfTextComment : Comment

sbSurfTextFirstRequirement : First requirement

sbSurfTextSecondRequirement : Second requirement

sbSurfTextThirdRequirement : Third requirement

Visual Basic
Public Enum McadSurfaceTextureRequirement
  sbSurfTextRaMax = 0
  sbSurfTextRaMin = 1
  sbSurfTextProduction = 2
  sbSurfTextProduction2 = 3
  sbSurfTextAllowance = 4
  sbSurfTextDirLay = 5
  sbSurfTextSampLength = 6
  sbSurfTextCutoff = 7
  sbSurfTextOtherValue = 8
  sbSurfTextOtherMin = 9
  sbSurfTextMaxRspac = 10
  sbSurfTextReference = 11
  sbSurfTextWavines = 12
  sbSurfTextComment = 13
  sbSurfTextFirstRequirement = 65
  sbSurfTextSecondRequirement = 66
  sbSurfTextThirdRequirement = 67
  sbSurfTextFourthRequirement = 68
End Enum
Members
Members | Description
sbSurfTextFourthRequirement | Fourth requirement
Links
SymBBAuto Library


McadSurfaceTextureStandard CoClass
Summary

A surface texture symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureStandard
Visual Basic
Public Class McadSurfaceTextureStandard
Links
SymBBAuto Library


McadSurfaceTextureType Enumeration
Summary

Enumerates all available surface types for a surface texture symbol.

sbBasic :

Set the Basic surface type for a surface texture symbol.

sbRemovalOfMaterialRequired :

Set the Removal of Material Required surface type for a surface texture symbol.

sbRemovalOfMaterialProhibited :

Set the Removal of Material Prohibited surface type for a surface texture symbol.

sbRemovalAllowanceSpecified : Set the Removal of Allowance Specified surface type for a surface texture symbol.

Visual Basic
Public Enum McadSurfaceTextureType
  sbBasic = 0
  sbRemovalOfMaterialRequired = 1
  sbRemovalOfMaterialProhibited = 2
  sbRemovalAllowanceSpecified = 3
End Enum
Links
SymBBAuto Library


McadSymBBSymbolLibraryType Enumeration
Summary

Enumerates the available Symbol Library Type.

Visual Basic
Public Enum McadSymBBSymbolLibraryType
  sbSurfaceTextureLibrary = 0
  sbWeldingLibrary = 1
  sbEdgeLibrary = 2
  sbFCFLibrary = 3
End Enum
Members
Members | Description
sbSurfaceTextureLibrary | Value 0. Surface texture symbol library.
sbWeldingLibrary | Value 1. Welding symbol library.
sbEdgeLibrary | Value 2. Edge symbol library.
sbFCFLibrary | Value 3. FCF symbol library.
Links
SymBBAuto Library


McadSymbol CoClass
Summary

A symbol object.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbol
Visual Basic
Public Class McadSymbol
Links
SymBBAuto Library


McadSymbolBBMgr CoClass
Summary

This existing object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolBBMgr
Visual Basic
Public Class McadSymbolBBMgr
Links
SymBBAuto Library


McadSymbolLibrary CoClass
Summary

Implements the IMcadSymbolLibrary interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibrary
Visual Basic
Public Class McadSymbolLibrary
Remarks

The grouping of library objects is based on the combination of standard and standard revision.

In each group, there is one default. For legacy objects, e.g. welding symbol library, the standard revision is not defined.

Links
SymBBAuto Library


McadSymbolLibraryObject CoClass
Summary

Implements the IMcadSymbolLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibraryObject
Visual Basic
Public Class McadSymbolLibraryObject
Links
SymBBAuto Library


McadSymbolLibraryObjects CoClass
Summary

Implements the IMcadSymbolLibraryObjects interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibraryObjects
Visual Basic
Public Class McadSymbolLibraryObjects
Links
SymBBAuto Library


McadSymbolStandard CoClass
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolStandard
Visual Basic
Public Class McadSymbolStandard
Links
SymBBAuto Library


McadSymbolStandards CoClass
Summary

A collection of McadSymbolStandard objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolStandards
Visual Basic
Public Class McadSymbolStandards
Links
SymBBAuto Library


McadTaper CoClass
Summary

This object represents the taper symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTaper
Visual Basic
Public Class McadTaper
Links
SymBBAuto Library


McadTaperDimensionType Enumeration
Summary

Enumerates the available taper dimension type.

Visual Basic
Public Enum McadTaperDimensionType
  sbRatio = 0
  sbPercentage = 1
End Enum
Members
Members | Description
sbRatio | Value 0. Use ratio format to display dimension value.
sbPercentage | Value 1. Use percentage format to display dimension value.
Links
SymBBAuto Library


McadTaperRatioFormatType Enumeration
Summary

Enumerates the available ratio format type.

Visual Basic
Public Enum McadTaperRatioFormatType
  sbFraction = 0
  sbNoFraction = 1
  sbNumber = 2
End Enum
Members
Members | Description
sbFraction | Value 0. The format of ratio is 1:X
sbNoFraction | Value 1. The format of ratio is X:1
sbNumber | Value 2. The format of ratio is X.
Links
SymBBAuto Library


McadTaperSlopeSymType Enumeration
Summary

Enumerator for taper slope symbol type.

Visual Basic
Public Enum McadTaperSlopeSymType
  sbTaper1 = 0
  sbTaper2 = 1
  sbSlope1 = 2
  sbSlope2 = 3
End Enum
Members
Members | Description
sbTaper1 | Value 2. Slope1 symbol type.
sbTaper2 | Value 3. Slope2 symbol type.
sbSlope1 | Value 0. Taper1 symbol type.
sbSlope2 | Value 1. Taper2 symbol type.
Links
SymBBAuto Library


McadTaperStandard CoClass
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTaperStandard
Visual Basic
Public Class McadTaperStandard
Links
SymBBAuto Library


McadTargetType Enumeration
Summary

Enumerates all available termination types for a datum target symbol.

sbNoTarget :

Set the None termination type for a datum target symbol.

sbBalloon : Not implemented yet. Set the None termination type for a datum target symbol.

sbPoint :

Set the None termination type for a datum target symbol.

sbLine :

Set the None termination type for a datum target symbol.

sbCircular :

Set the None termination type for a datum target symbol.

sbRectangular :

Set the None termination type for a datum target symbol.

sbAttach :

Set the None termination type for a datum target symbol.

Visual Basic
Public Enum McadTargetType
  sbNoTarget = 0
  sbBalloon = 1
  sbPoint = 2
  sbLine = 3
  sbCircular = 4
  sbRectangular = 5
  sbAttach = 6
End Enum
Links
SymBBAuto Library


McadTextControl Enumeration
Summary

Enumerates all available text controls for a Parts List.

sbNone : Specifies that a Parts List text is not controlled. The text overruns the column width when the length of the text exceeds the column width.

sbFit : Specifies that a Parts List text fits within the column when the length of the text exceeds the column width.

sbWrap : Specifies that a Parts List text wraps to the next line when the length of the text exceeds the column width.

Visual Basic
Public Enum McadTextControl
  sbNone = 0
  sbFit = 1
  sbWrap = 2
End Enum
Links
SymBBAuto Library


McadTitle CoClass
Summary

This object represents the title block of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitle
Visual Basic
Public Class McadTitle
Links
SymBBAuto Library


McadTitleBorder CoClass
Summary

This object represents the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorder
Visual Basic
Public Class McadTitleBorder
Links
SymBBAuto Library


McadTitleBorderContext CoClass
Summary

This new object contains all option settings associated with a title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderContext
Visual Basic
Public Class McadTitleBorderContext
Links
SymBBAuto Library


McadTitleBorderDescriptor CoClass
Summary

This object contains all data associated with a title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderDescriptor
Visual Basic
Public Class McadTitleBorderDescriptor
Links
SymBBAuto Library


McadTitleBorderMgr CoClass
Summary

This object is used for general functionality for title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderMgr
Visual Basic
Public Class McadTitleBorderMgr
Links
SymBBAuto Library


McadTitleBorders CoClass
Summary

This object is a collection of title/border objects.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorders
Visual Basic
Public Class McadTitleBorders
Links
SymBBAuto Library


McadTitleBorderStandard CoClass
Summary

This object represents the Drawing Sheet standard element.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderStandard
Visual Basic
Public Class McadTitleBorderStandard
Links
SymBBAuto Library


McadUndefinedSize Enumeration
Summary

Enumerates the undefined size's cases for edge symbol

Visual Basic
Public Enum McadUndefinedSize
  sbDefSize = 0
  sbWithBurr = 1
  sbWithoutBurr = 2
End Enum
Links
SymBBAuto Library


McadUndefinedSizeDirection Enumeration
Summary

Enumerates the undefined size's direction for edge symbol

Visual Basic
Public Enum McadUndefinedSizeDirection
  sbTop = 0
  sbSide = 1
  sbUserDirect = 2
End Enum
Links
SymBBAuto Library


McadViewDefLockType Enumeration
Summary

Enumerates the lock type of the folder definition or component view definition in mechanical structure.

mc2DSNoLock : Specifies no lock in mechanical structure.

mc2DSXrefLock : Specifies the lock of the Xref objects in mechanical structure.

mc2DSStdPartLock : Specifies the lock of standard parts in mechanical structure.

mc2DSUserLock : Specifies the user-defined lock in mechanical structure.

Visual Basic
Public Enum McadViewDefLockType
  mc2DSNoLock = &H0000
  mc2DSXrefLock = &H0001
  mc2DSStdPartLock = &H0002
  mc2DSUserLock = &H0004
End Enum
Links
SymBBAuto Library


McadWeldAssociation Enumeration
Summary

Enumerates all available association types between two fillet weld symbols for the staggered weldment.

sbNoAssociation : Sets no association.

sbAssociationSpacer : Space the fillet symbols.

sbAssociationMoveStagger : Staggers the fillet symbols.

sbAssociationMirrorStagger : Mirrors the fillet symbols.

sbAssociationSpecialStagger : Staggers the fillet symbols in a special way.

sbAssociationBacking : Back the fillet symbols.

Visual Basic
Public Enum McadWeldAssociation
  sbNoAssociation = 0
  sbAssociationSpacer = 1
  sbAssociationMoveStagger = 2
  sbAssociationMirrorStagger = 3
  sbAssociationSpecialStagger = 4
  sbAssociationBacking = 5
End Enum
Links
SymBBAuto Library


McadWelding CoClass
Summary

Implements weld symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWelding
Visual Basic
Public Class McadWelding
Links
SymBBAuto Library


McadWeldingLibrary CoClass
Summary

Implements the IMcadWeldingLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingLibrary
Visual Basic
Public Class McadWeldingLibrary
Links
SymBBAuto Library


McadWeldingLibraryObject CoClass
Summary

Implemented the IMcadWeldingLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingLibraryObject
Visual Basic
Public Class McadWeldingLibraryObject
Links
SymBBAuto Library


McadWeldingRequirement Enumeration
Summary

Enumerates the available Weld requirements variable.

Visual Basic
Public Enum McadWeldingRequirement
  sbWeldSize = 0
  sbWeldThickness = 1
  sbWeldLength = 2
  sbWeldNumber = 3
  sbWeldSpacing = 4
  sbWeldAngle = 5
  sbWeldDepth = 6
  sbWeldPitch = 7
  sbWeldGap = 8
  sbWeldClearance = 9
  sbWeldBacking = 10
  sbWeldBrazing = 11
  sbWeldFinishing = 12
  sbWeldContour = 13
  sbWeldNotes = 14
  sbWeldIndex = 15
  sbWeldIndexTotal = 16
  sbWeldStandard = 17
  sbWeldDesignation = 18
  sbWeldSpecification = 19
  sbWeldControlCategory = 20
  sbWeldTechnicalReq = 21
  sbWeldSize2 = 22
  sbWeldSizeSymbol = 23
  sbWeldSecondarySymbol = 24
End Enum
Members
Members | Description
sbWeldSize | Value 0. Specifies the size of the weld.
sbWeldThickness | Value 1. Specifies the thickness of the weld.
sbWeldLength | Value 2. Specifies the Length of the weld.
sbWeldNumber | Value 3. Specifies the number of the welds.
sbWeldSpacing | Value 4. Specifies the distance between welds.
sbWeldAngle | Value 5. Specifies the groove angle of the weld.
sbWeldDepth | Value 6. Specifies the groove depth of the weld.
sbWeldPitch | Value 7. Specifies the distance between weld centers.
sbWeldGap | Value 8. Specifies the root gap between welds.
sbWeldClearance | Value 9. Specifies the root gap between welds.
sbWeldBacking | Value 10. Specifies the value of the backing field for the weld symbol.
sbWeldBrazing | Value 11. Specifies the usage of brazing.
sbWeldFinishing | Value 12. Specifies the value of the finishing method field for the contour weld symbol.
sbWeldContour | Value 13. Specifies the contour or shape of the weld surface.
sbWeldNotes | Value 14. Specifies the supplementary data in the notes field for a weld symbol.
sbWeldIndex | Value 15. Specifies the value of the index number field for the weld symbol.
sbWeldIndexTotal | Value 16. Specifies the value of the total count of index field for the weld symbol.
sbWeldStandard | Value 17. Specifies the value of the weld standard field for the weld symbol.
sbWeldDesignation | Value 18. Specifies the value of the weld designation field for the weld symbol.
sbWeldSpecification | Value 19. Specifies the value of the weld specification field for the weld symbol.
sbWeldControlCategory | Value 20. Specifies the weld control category.
sbWeldTechnicalReq | Value 21. Specifies the value of the technical requirements field for the weld symbol.
sbWeldSize2 | Value 22.
sbWeldSizeSymbol | Value 23.
sbWeldSecondarySymbol | Value 24. Specifies the second weld size value.
Links
SymBBAuto Library


McadWeldingStandard CoClass
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingStandard
Visual Basic
Public Class McadWeldingStandard
Links
SymBBAuto Library


McadWeldSymbolType Enumeration
Summary

Enumerates all available weld symbol types for a weld symbol standard. All the enumeration weld symbol types can be rolled into three groups: Weld Symbols, Contour Symbols, and Backing Symbols. A weld symbol type may use different signs in different standard, such as ANSI, BSI, and ISO.

sbNoSymbol : Sets no weld symbol type for a weld symbol standard.

sbFilletWeld :

Sets the Fillet Weld symbol type for a weld symbol standard. Available for ANSI

sbSecondaryFillet : Sets the Secondary Fillet Weld symbol type for a weld symbol standard.

sbPlugWeld :

Sets the Plug Weld symbol type for a weld symbol standard.

sbSlotWeld :

Sets the Slot Weld symbol type for a weld symbol standard.

sbStudWeld :

Sets the Stud Weld symbol type for a weld symbol standard.

sbSpotWeld :

Sets the Spot or Projection Weld symbol type for a weld symbol standard.

sbSpotOnRefLineWeld :

Sets the Spot Weld on Reference Line symbol type for a weld symbol standard.

sbSeamWeld :

Sets the Seam Weld symbol type for a weld symbol standard.

sbSeamOnRefLineWeld :

Sets the Seam Weld on Reference Line symbol type for a weld symbol standard.

sbBackWeld :

Sets the Backing Run, Back or Backing Weld symbol type for a weld symbol standard.

sbSurfacingWeld :

Sets the Surfacing Weld symbol type for a weld symbol standard.

sbFlangeEdgeWeld :

Sets the Flange Edge Weld symbol type for a weld symbol standard.

sbFlangeCornerWeld :

Sets the Flange Corner Weld symbol type for a weld symbol standard.

sbSqureGrooveWeld :

Sets the Square Groove Weld symbol type for a weld symbol standard. Available for ANSI

sbScarfGrooveWeld :

Sets the Scarf Groove Weld symbol type for a weld symbol standard.

sbVGrooveWeld :

Sets the V Groove Weld symbol type for a weld symbol standard.

sbBevelGrooveWeld :

Sets the Bevel Groove Weld symbol type for a weld symbol standard.

sbUGrooveWeld :

Sets the U Groove Weld symbol type for a weld symbol standard.

sbJGrooveWeld :

Sets the J Groove Weld symbol type for a weld symbol standard.

sbFlareVGrooveWeld :

Sets the Flare V Groove Weld symbol type for a weld symbol standard.

sbFlareBevelGrooveWeld :

Sets the Flare Bevel Groove Weld symbol type for a weld symbol standard.

sbEdgeWeld :

Sets the Edge Weld symbol type for a weld symbol standard.

sbFoldJointWeld :

Sets the Fold Joint symbol type for a weld symbol standard.

sbInclinedJointWeld :

Sets the Inclined Joint symbol type for a weld symbol standard.

sbSurfaceJointWeld :

Sets the Surface Joint symbol type for a weld symbol standard.

sbSteepFlankedVWeld :

Sets the Steep Flanked V Butt Weld symbol type for a weld symbol standard.

sbSteepFlankedBevelWeld :

Sets the Steep Flanked Bevel Butt Weld symbol type for a weld symbol standard.

sbSingleVBroadRootFace :

Sets the Flare Single Bevel Groove Weld symbol type for a weld symbol standard.

sbSingleBevelBroadRootFace :

Sets the Flare Single V Groove Weld symbol type for a weld symbol standard.

sbPermanentBackingStripWeld :

Sets the Permanent Backing Strip symbol type for a weld symbol standard.

sbRemovableBackingStripWeld :

Sets the Removable Backing Strip symbol type for a weld symbol standard.

sbMeltThrough :

Sets the Melt Through symbol type for a weld symbol standard.

sbConsInsert :

Sets the Converse Insert Weld symbol type for a weld symbol standard.

sbFlushContour :

Sets the Flat/FLush Contour symbol type for a weld symbol standard.

sbConvexContour :

Sets the Convex Contour symbol type for a weld symbol standard.

sbConcaveContour :

Sets the Concave Contour symbol type for a weld symbol standard.

sbSmoothContour :

Sets the Toes Shall Be Blended Smoothly symbol type for a weld symbol standard.

sbFlushFinishedContour :

Sets the Flush Finished Contour symbol type for a weld symbol standard.

sbWeldingTail : Sets the Tail Weld symbol type for a weld symbol standard.

sbWeldAllAround : Sets the All Around Weld symbol type for a weld symbol standard.

sbFieldWeld : Sets the Field Weld symbol type for a weld symbol standard.

sbSpecialStaggerWeld : Sets the Special Stagger Weld symbol type for a weld symbol standard.

sbBevelGrooveShapeWeld : Sets the Bevel Groove Shape Weld symbol type for a weld symbol standard.

sbWeldAllAroundSquare : Sets the All Around Square Weld symbol type for a weld symbol standard.

sbFieldWeldEmpty : Sets the Field Weld Empty symbol type for a weld symbol standard.

sbExamination :

Sets the Nondestructive Examination symbol type for a weld symbol standard.

sbBackLendingWeld :

Sets the Backing Strip symbol type for a weld symbol standard.

sbRoundedWeld : Sets the Rounded Weld symbol type for a weld symbol standard.

sbHalfRoundedWeld : Sets the Half Rounded Weld symbol type for a weld symbol standard.

sbHalfWWeld :

Sets the Half W Welding symbol type for a weld symbol standard.

sbWWeld :

Sets the W Welding symbol type for a weld symbol standard

sbWeldMullded : Sets the Grooved Mullded Weld symbol type for a weld symbol standard.

sbWeldGroovedRoot :

Sets the Groove Root Welding symbol type for a weld symbol standard.

sbWWeld2 :

Sets the W-svar symbol type for a weld symbol standard.

sbUVWeld :

Sets the UV-svar symbol type for a weld symbol standard.

sbConcaveSmoothContour :

Sets the Welds with Machined Fillets contour symbol type for a weld symbol standard.

sbUserSymbolType : Sets the user-defined symbol type for a weld symbol standard.

Visual Basic
Public Enum McadWeldSymbolType
  sbNoSymbol = 0
  sbFilletWeld = 6
  sbSecondaryFillet = 7
  sbPlugWeld = 8
  sbSlotWeld = 9
  sbStudWeld = 10
  sbSpotWeld = 11
  sbSpotOnRefLineWeld = 12
  sbSeamWeld = 13
  sbSeamOnRefLineWeld = 14
  sbBackWeld = 15
  sbSurfacingWeld = 16
  sbFlangeEdgeWeld = 17
  sbFlangeCornerWeld = 18
  sbSqureGrooveWeld = 19
  sbScarfGrooveWeld = 20
  sbVGrooveWeld = 21
  sbBevelGrooveWeld = 22
  sbUGrooveWeld = 23
  sbJGrooveWeld = 24
  sbFlareVGrooveWeld = 25
  sbFlareBevelGrooveWeld = 26
  sbEdgeWeld = 27
  sbFoldJointWeld = 28
  sbInclinedJointWeld = 29
  sbSurfaceJointWeld = 30
  sbSteepFlankedVWeld = 31
  sbSteepFlankedBevelWeld = 32
  sbSingleVBroadRootFace = 33
  sbSingleBevelBroadRootFace = 34
  sbPermanentBackingStripWeld = 35
  sbRemovableBackingStripWeld = 36
  sbMeltThrough = 37
  sbConsInsert = 38
  sbFlushContour = 39
  sbConvexContour = 40
  sbConcaveContour = 41
  sbSmoothContour = 42
  sbFlushFinishedContour = 43
  sbWeldingTail = 44
  sbWeldAllAround = 45
  sbFieldWeld = 46
  sbSpecialStaggerWeld = 47
  sbBevelGrooveShapeWeld = 48
  sbWeldAllAroundSquare = 49
  sbFieldWeldEmpty = 50
  sbExamination = 51
  sbBackLendingWeld = 52
  sbRoundedWeld = 53
  sbHalfRoundedWeld = 54
  sbHalfWWeld = 55
  sbWWeld = 56
  sbWeldMullded = 57
  sbWeldGroovedRoot = 58
  sbWWeld2 = 59
  sbUVWeld = 60
  sbConcaveSmoothContour = 61
  sbCutEnforceWeld = 62
  sbSmoothWeld = 63
  sbOpenContourWeld = 64
  sbIntermittentWeld = 65
  sbZigzagWeld = 66
  sbUserSymbolType = 1000
End Enum
Links
SymBBAuto Library


GEAuto Library
Summary

The Autodesk GEAuto Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.

Remarks

Additional GE objects can also be directly created by the library user. GE objects are taken in as the data specification in geometric editing functions. The GE library supports geometry query and manipulation.

The geometry entities in the GEAuto Object Model are strictly geometric representations useful for geometric calculations or geometric property communications. They are not database-resident objects as the AcadEntity objects are in the AutoCAD Object Model. Conversion between the two needs to be done by querying the geometric data from one and using it to construct or set the data in the other.

Points, point list, vector, and matrices are represented in the AutoCAD Object Model as Variant arrays of Doubles, but as objects in the GEAuto Object Model. You can use the GEAuto GePoint, GePoints, GeVector, and GeMatrix objects in place of the Variant array of Doubles when using the AutoCAD Object Model by relying on the AsArray and AsArray2d properties on these objects.

When specifying the value of these objects as input to a property or method on an AutoCAD object expecting a Variant array of Doubles, use the AsArray property on the GEAuto objects to pass the object's data contents as an array of Doubles. The GePoints collection object has an AsArray2d property to pass the collection of points as an array of two-dimensional points (the Z coordinate of the points is ignored).

CoClasses
Name | Description
GeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
GeAugmentedLine | A multisegmented curve with normal information at the nodes.
GeBoundBlock | A spatial bounding volume.
GeBoundedSurface | Surface with trimming boundary information.
GeCircularArc | A circle or circular arc curve.
GeCompositeCurve | A curve composed of multiple component curves connected end to end.
GeCone | A bounded right circular cone.
GeCurveBoundaries | A collection of GeCurveBoundary objects.
GeCurveBoundary | A representation for one of a surface's boundaries.
GeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves.
GeCurves | A collection of GeCurve objects.
GeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
GeCylinder | A cylindrical surface.
GeEllipticalArc | An ellipse or elliptical arc.
GeEntities | A collection of GeEntity objects.
GeInterval | Represents an interval of the real axis to define bounds.
GeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
GeLine | An unbounded line.
GeLineSegment | A bounded line segment.
GeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
GeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
GeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
GeOffsetCurve | An exact offset of another curve.
GeOffsetSurface | An exact offset of another surface.
GePlane | An infinite plane in three dimensional space.
GePoint | A three-dimensional point object.
GePoints | A collection of GePoint objects.
GeRay | A line bounded at one end.
GeSphere | A spherical surface.
GeSurfaces | A collection of GeSurface objects.
GeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
GeTolerance | Encapsulates tolerance values to use in calculations.
GeTorus | A toroid or toroidal segment surface.
GeVector | A vector in three-dimensional space.
GeVectors | A collection of GeVector objects.
Enumerations
Name | Description
GeCollectionType | Enumerates all collection types of geometry entity objects.
GeCurveCurveIntConfiguration | Enumerates the characterization of the intersection between curves, circles, or circular arcs. This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.
GeCurveSurfIntConfiguration | Enumerates all intersection characterization in the neighborhood just above and below the intersection between the curve and the surface.
GeNurbSurfaceProperties | type GeNurbSurfaceProperties geOpen : Description to come geClosed : Description to come gePeriodic : Description to come geRational : Description to come geNoPoles : Description to come gePoleAtMin : Description to come gePoleAtMax : Description to come gePoleAtBoth : Description to come
GeSurfSurfIntConfiguration | Enumerates all intersection characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
GeSurfSurfIntType | Enumerates all intersection types between two surfaces.
Interfaces
Name | Description
IGeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
IGeAugmentedLine | A multisegmented curve with normal information at the nodes.
IGeBoundBlock | A spatial bounding volume.
IGeBoundedSurface | Surface with trimming boundary information.
IGeCircularArc | A circle or circular arc curve.
IGeCompositeCurve | A curve composed of multiple component curves connected end to end.
IGeCone | A bounded right circular cone.
IGeCurve | A generic curve entity.
IGeCurveBoundaries | A collection of GeCurveBoundary objects.
IGeCurveBoundary | A representation for one of a surface's boundaries.
IGeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves. This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.
IGeCurves | A collection of GeCurve objects.
IGeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
IGeCylinder | A cylindrical surface.
IGeEllipticalArc | An ellipse or elliptical arc.
IGeEntities | A collection of GeEntity objects.
IGeEntity | A generic geometric entity. Subtypes: GeBoundBlock, IGeCurve, GePoint, IGeSurface.
IGeInterval | Represents an interval of the real axis to define bounds.
IGeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
IGeLine | An unbounded line.
IGeLinearEntity | A generic linear entity.
IGeLineSegment | A bounded line segment.
IGeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
IGeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
IGeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
IGeOffsetCurve | An exact offset of another curve.
IGeOffsetSurface | An exact offset of another surface.
IGePlane | An infinite plane in three-dimensional space.
IGePoint | A three-dimensional point object.
IGePoints | A collection of GePoint objects.
IGeRay | A line bounded at one end.
IGeSphere | A spherical surface.
IGeSurface | A generic surface entity.
IGeSurfaces | A collection of GeSurface objects.
IGeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
IGeTolerance | Encapsulates tolerance values to use in calculations.
IGeTorus | A toroid or toroidal segment surface.
IGeVector | A vector in three-dimensional space.
IGeVectors | A collection of GeVector objects.


GeApplication CoClass
Summary

An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

GEAuto::GeApplication
Visual Basic
Public Class GeApplication
Links
GEAuto Library


GeAugmentedLine CoClass
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

GEAuto::GeAugmentedLine
Visual Basic
Public Class GeAugmentedLine
Links
GEAuto Library


GeBoundBlock CoClass
Summary

A spatial bounding volume.

Class Hierarchy

Declaration syntax

GEAuto::GeBoundBlock
Visual Basic
Public Class GeBoundBlock
Links
GEAuto Library


GeBoundedSurface CoClass
Summary

Surface with trimming boundary information.

Class Hierarchy

Declaration syntax

GEAuto::GeBoundedSurface
Visual Basic
Public Class GeBoundedSurface
Links
GEAuto Library


GeCircularArc CoClass
Summary

A circle or circular arc curve.

Class Hierarchy

Declaration syntax

GEAuto::GeCircularArc
Visual Basic
Public Class GeCircularArc
Links
GEAuto Library


GeCollectionType Enumeration
Summary

Enumerates all collection types of geometry entity objects.

Visual Basic
Public Enum GeCollectionType
  geCurveBoundaries = 1
  geCurves = 2
  geEntities = 3
  gePoints = 4
  geSurfaces = 5
  geVectors = 6
End Enum
Members
Members | Description
geCurveBoundaries | A collection of GeCurveBoundary objects.
geCurves | A collection of GeCurve objects.
geEntities | A collection of GeEntity objects.
gePoints | A collection of GePoint objects.
geSurfaces | A collection of GeSurface objects.
geVectors | A collection of GeVector objects.
Links
GEAuto Library


GeCompositeCurve CoClass
Summary

A curve composed of multiple component curves connected end to end.

Class Hierarchy

Declaration syntax

GEAuto::GeCompositeCurve
Visual Basic
Public Class GeCompositeCurve
Remarks

For instance, a composite curve could consist of four straight line segments that form a square. Each of the component curves must be bounded curves, which means that infinite lines and rays may not be used as component curves of a composite. The component curves are not required to all lie in the same plane. The start parameter of a composite is 0.0. The parameter value at the end point of the first component curve will be the approximate length of the first curve (call this value l1). The parameter value at the end point of the second curve will be l1 + the approximate length of the second curve, and so on.

Links
GEAuto Library


GeCone CoClass
Summary

A bounded right circular cone.

Class Hierarchy

Declaration syntax

GEAuto::GeCone
Visual Basic
Public Class GeCone
Links
GEAuto Library


GeCurveBoundaries CoClass
Summary

A collection of GeCurveBoundary objects.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveBoundaries
Visual Basic
Public Class GeCurveBoundaries
Links
GEAuto Library


GeCurveBoundary CoClass
Summary

A representation for one of a surface's boundaries.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveBoundary
Visual Basic
Public Class GeCurveBoundary
Links
GEAuto Library


GeCurveCurveIntConfiguration Enumeration
Summary

Enumerates the characterization of the intersection between curves, circles, or circular arcs. This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.

Visual Basic
Public Enum GeCurveCurveIntConfiguration
  geNotDefined = &H1
  geUnknownType = &H2
  geLeftRight = &H4
  geRightLeft = &H8
  geLeftLeft = &H10
  geRightRight = &H20
  gePointLeft = &H40
  gePointRight = &H80
  geLeftOverlap = &H100
  geOverlapLeft = &H200
  geRightOverlap = &H400
  geOverlapRight = &H800
  geOverlapStart = &H1000
  geOverlapEnd = &H2000
  geOverlapOverlap = &H4000
End Enum
Members
Members | Description
geNotDefined | Indicates that the intersection type is not defined.
geUnknownType | Indicates that the intersection type is unknown.
geLeftRight | Indicates that one curve crosses the other curve from left to right with respect to the other curve and with respect to the curve plane's normal.
geRightLeft | Indicates that one curve crosses the other curve from right to left with respect to the other curve and with respect to the curve plane's normal.
geLeftLeft | Indicates that one curve crosses the other curve always on the left side with respect to the other curve and with respect to the curve plane's normal.
geRightRight | Indicates that one curve crosses the other curve always on the right side with respect to the other curve and with respect to the curve plane's normal.
gePointLeft | Indicates that one curve crosses the other curve from one point to the left with respect to the other curve and with respect to the curve plane's normal.
gePointRight | Indicates that one curve crosses the other curve from one point to the right with respect to the other curve and with respect to the curve plane's normal.
geLeftOverlap | Indicates that one curve crosses the other curve from the left side with respect to the other curve and with respect to the curve plane's normal and then overlap with each other.
geOverlapLeft | Indicates that one curve starts overlapping with the other curve and then crosses with the other curve from the left with respect to the other curve and with respect to the curve plane's normal.
geRightOverlap | Indicates that one curve crosses the other curve from the right side with respect to the other curve and with respect to the curve plane's normal and then overlap with each other.
geOverlapRight | Indicates that one curve starts overlapping with the other curve and then crosses with the other curve from the right with respect to the other curve and with respect to the curve plane's normal.
geOverlapStart | Indicates that one curve starts overlapping with the other curve at the start point.
geOverlapEnd | Indicates that one curve starts overlapping with the other curve at the end point.
geOverlapOverlap | Indicates that two curves overlaps with each other completely.
Links
GEAuto Library


GeCurveCurveIntersection CoClass
Summary

Calculates and provides access to the intersection properties between two curves.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveCurveIntersection
Visual Basic
Public Class GeCurveCurveIntersection
Remarks

This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.

Links
GEAuto Library


GeCurves CoClass
Summary

A collection of GeCurve objects.

Class Hierarchy

Declaration syntax

GEAuto::GeCurves
Visual Basic
Public Class GeCurves
Links
GEAuto Library


GeCurveSurfaceIntersection CoClass
Summary

Calculates and provides access to the intersection properties between a curve and a surface.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveSurfaceIntersection
Visual Basic
Public Class GeCurveSurfaceIntersection
Links
GEAuto Library


GeCurveSurfIntConfiguration Enumeration
Summary

Enumerates all intersection characterization in the neighborhood just above and below the intersection between the curve and the surface.

Visual Basic
Public Enum GeCurveSurfIntConfiguration
  geUnknown = 0
  geOutside = 1
  geInside = 2
  geTangentOutside = 3
  geTangentInside = 4
  geCoincident = 5
  geCoincidentUnbounded = 6
End Enum
Members
Members | Description
geUnknown | Indicates that the intersection is not defined.
geOutside | Indicates the intersection is outside the surface with respect to the orientation of the surface's normal.
geInside | Indicates the intersection is inside the surface with respect to the orientation of the surface's normal.
geTangentOutside | Indicates the intersection is tangent with each other and is outside the surface with respect to the orientation of the surface's normal.
geTangentInside | Indicates the intersection is tangent with each other and is inside the surface with respect to the orientation of the surface's normal.
geCoincident | Indicates that the intersection between the curve and surface is coincident.
geCoincidentUnbounded | Indicates that the intersection between the curve and surface is coincident on an unbounded base.
Links
GEAuto Library


GeCylinder CoClass
Summary

A cylindrical surface.

Class Hierarchy

Declaration syntax

GEAuto::GeCylinder
Visual Basic
Public Class GeCylinder
Links
GEAuto Library


GeEllipticalArc CoClass
Summary

An ellipse or elliptical arc.

Class Hierarchy

Declaration syntax

GEAuto::GeEllipticalArc
Visual Basic
Public Class GeEllipticalArc
Remarks

The angle of a point on the ellipse is measured by drawing a full circle with the same center as the ellipse and radius equal to the ellipse major radius and projecting the point onto the circle along a vector perpendicular to the major axis. If a vector is then drawn from the ellipse center to this projected point, the angle between the major axis and this vector (measured counterclockwise about the cross product of the major and minor axes) is the angle of the point on the ellipse. endAngle must be greater than startAngle. To construct a full ellipse, the difference between EndAngle and StartAngle should be 2*pi.

Links
GEAuto Library


GeEntities CoClass
Summary

A collection of GeEntity objects.

Class Hierarchy

Declaration syntax

GEAuto::GeEntities
Visual Basic
Public Class GeEntities
Links
GEAuto Library


GeInterval CoClass
Summary

Represents an interval of the real axis to define bounds.

Class Hierarchy

Declaration syntax

GEAuto::GeInterval
Visual Basic
Public Class GeInterval
Links
GEAuto Library


GeKnotVector CoClass
Summary

An ordered sequence knot values making up a knot vector for NURB entities.

Class Hierarchy

Declaration syntax

GEAuto::GeKnotVector
Visual Basic
Public Class GeKnotVector
Remarks

The intervals between two consecutive knots partition a spline into polynomial or rational pieces.

Links
GEAuto Library


GeLine CoClass
Summary

An unbounded line.

Class Hierarchy

Declaration syntax

GEAuto::GeLine
Visual Basic
Public Class GeLine
Links
GEAuto Library


GeLineSegment CoClass
Summary

A bounded line segment.

Class Hierarchy

Declaration syntax

GEAuto::GeLineSegment
Visual Basic
Public Class GeLineSegment
Links
GEAuto Library


GeMatrix CoClass
Summary

A 4 x 4 matrix representing an affine transformation including translation.

Class Hierarchy

Declaration syntax

GEAuto::GeMatrix
Visual Basic
Public Class GeMatrix
Links
GEAuto Library


GeNurbCurve CoClass
Summary

A Non-Uniform Rational B-spline, or NURB curve.

Class Hierarchy

Declaration syntax

GEAuto::GeNurbCurve
Visual Basic
Public Class GeNurbCurve
Links
GEAuto Library


GeNurbSurface CoClass
Summary

A Non-Uniform Rational B-spline, or NURB surface.

Class Hierarchy

Declaration syntax

GEAuto::GeNurbSurface
Visual Basic
Public Class GeNurbSurface
Links
GEAuto Library


GeNurbSurfaceProperties Enumeration
Summary

type GeNurbSurfaceProperties

geOpen : Description to come

geClosed : Description to come

gePeriodic : Description to come

geRational : Description to come

geNoPoles : Description to come

gePoleAtMin : Description to come

gePoleAtMax : Description to come

gePoleAtBoth : Description to come

Visual Basic
Public Enum GeNurbSurfaceProperties
  geOpen = &H01
  geClosed = &H02
  gePeriodic = &H04
  geRational = &H08
  geNoPoles = &H10
  gePoleAtMin = &H20
  gePoleAtMax = &H40
  gePoleAtBoth = &H80
End Enum
Links
GEAuto Library


GeOffsetCurve CoClass
Summary

An exact offset of another curve.

Class Hierarchy

Declaration syntax

GEAuto::GeOffsetCurve
Visual Basic
Public Class GeOffsetCurve
Links
GEAuto Library


GeOffsetSurface CoClass
Summary

An exact offset of another surface.

Class Hierarchy

Declaration syntax

GEAuto::GeOffsetSurface
Visual Basic
Public Class GeOffsetSurface
Links
GEAuto Library


GePlane CoClass
Summary

An infinite plane in three dimensional space.

Class Hierarchy

Declaration syntax

GEAuto::GePlane
Visual Basic
Public Class GePlane
Links
GEAuto Library


GePoint CoClass
Summary

A three-dimensional point object.

Class Hierarchy

Declaration syntax

GEAuto::GePoint
Visual Basic
Public Class GePoint
Links
GEAuto Library


GePoints CoClass
Summary

A collection of GePoint objects.

Class Hierarchy

Declaration syntax

GEAuto::GePoints
Visual Basic
Public Class GePoints
Links
GEAuto Library


GeRay CoClass
Summary

A line bounded at one end.

Class Hierarchy

Declaration syntax

GEAuto::GeRay
Visual Basic
Public Class GeRay
Links
GEAuto Library


GeSphere CoClass
Summary

A spherical surface.

Class Hierarchy

Declaration syntax

GEAuto::GeSphere
Visual Basic
Public Class GeSphere
Links
GEAuto Library


GeSurfaces CoClass
Summary

A collection of GeSurface objects.

Class Hierarchy

Declaration syntax

GEAuto::GeSurfaces
Visual Basic
Public Class GeSurfaces
Links
GEAuto Library


GeSurfaceSurfaceIntersection CoClass
Summary

Calculates the intersection between two surfaces.

Class Hierarchy

Declaration syntax

GEAuto::GeSurfaceSurfaceIntersection
Visual Basic
Public Class GeSurfaceSurfaceIntersection
Links
GEAuto Library


GeSurfSurfIntConfiguration Enumeration
Summary

Enumerates all intersection characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.

Visual Basic
Public Enum GeSurfSurfIntConfiguration
  geSSIUnknown = 0
  geSSIOutside = 1
  geSSIInside = 2
  geSSICoincident = 3
End Enum
Members
Members | Description
geSSIUnknown | Indicates the intersection characterization is not defined.
geSSIOutside | Indicates that the neighborhood is outside the second surface with respect to the surface normal orientation of the first surface.
geSSIInside | Indicates that the neighborhood is inside the second surface with respect to the surface normal orientation of the first surface.
geSSICoincident | Indicates that two surfaces are coincident.
Links
GEAuto Library


GeSurfSurfIntType Enumeration
Summary

Enumerates all intersection types between two surfaces.

Visual Basic
Public Enum GeSurfSurfIntType
  geTransverse = 0
  geTangent = 1
  geAntiTangent = 2
End Enum
Members
Members | Description
geTransverse | Indicates that two surfaces are transverse with each other.
geTangent | Indicates that two surfaces are tangent with each other.
geAntiTangent | Indicates that two surfaces are anti-tangent with each other.
Links
GEAuto Library


GeTolerance CoClass
Summary

Encapsulates tolerance values to use in calculations.

Class Hierarchy

Declaration syntax

GEAuto::GeTolerance
Visual Basic
Public Class GeTolerance
Links
GEAuto Library


GeTorus CoClass
Summary

A toroid or toroidal segment surface.

Class Hierarchy

Declaration syntax

GEAuto::GeTorus
Visual Basic
Public Class GeTorus
Links
GEAuto Library


GeVector CoClass
Summary

A vector in three-dimensional space.

Class Hierarchy

Declaration syntax

GEAuto::GeVector
Visual Basic
Public Class GeVector
Links
GEAuto Library


GeVectors CoClass
Summary

A collection of GeVector objects.

Class Hierarchy

Declaration syntax

GEAuto::GeVectors
Visual Basic
Public Class GeVectors
Links
GEAuto Library


IGeApplication Interface
Summary

An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IGeApplication
Visual Basic
Public Interface IGeApplication
Inherits IDispatch
Links
IGeApplication Members, GEAuto Library


IGeApplication Members
Summary

The following tables list the members exposed by IGeApplication.

Methods
Name | Description
AugmentedLine | Creates a new GeAugmentedLine object.
BoundBlock | Create a new GeBoundBlock object.
CircularArc | Creates a GeCircularArc object.
Collection | Creates a new collection object of the specified type.
CompositeCurve | Creates a new GeCompositeCurve object.
Cone | Creates a GeCone object.
CurveBoundary | Creates a GeCurveBoundary object.
Cylinder | Creates a GeCylinder object.
EllipticalArc | Creates a new GeEllipticalArc object.
Interval | Creates a new GeInterval object.
KnotVector | Creates a new GeKnotVector object.
Line | Creates a new GeLine object.
LineSegment | Creates a new GeLineSegment object.
Matrix | Creates a new GeMatrix object set to identity.
NurbCurve | Creates a new GeNurbCurve object, which is a 3D rational spline by a knot vector, control points, and weights.
NurbSurface | Creates a new GeNurbSurface object.
OffsetCurve | Creates a new GeOffsetCurve object.
OffsetSurface | Creates a new GeOffsetSurface object.
Plane | Creates a new GePlane object.
Point | Creates a new GePoint object.
Ray | Creates a new GeRay object.
Sphere | Creates a new GeSphere object.
Tolerance | Creates a new GeTolerance object.
Torus | Creates a new GeTorus object.
Vector | Creates a new GeVector object.
Properties
Name | Description
Application | Gets the GeApplication object.


IGeApplication::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeApplication::AugmentedLine Method
Summary

Creates a new GeAugmentedLine object.

Visual Basic
Sub AugmentedLine(Points As [in, optional]VARIANT, Normals As [in, optional]VARIANT, Line As [out, retval]IGeAugmentedLine*)
Parameters
Parameters | Description
Points | Variant (GePoints collection); input-only; optional. Specifies the points of the polyline.
Normals | Variant (GeVectors collection); input-only; optional. Specifies the normals at the corresponding point.
Returns

GeAugmentedLine object


IGeApplication::BoundBlock Method
Summary

Create a new GeBoundBlock object.

Visual Basic
Sub BoundBlock(Base As [in, optional]VARIANT, PointDirection1 As [in, optional]VARIANT, Direction2 As [in, optional]VARIANT, Direction3 As [in, optional]VARIANT, Block As [out, retval]IGeBoundBlock*)
Parameters
Parameters | Description
Base | Variant ( GePoint object); input-only; optional. Specifies the base bound point.
PointDirection1 | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point of a parallelepiped, or the first vector of three describing the sides.
Direction2 | Variant ( GeVector object); input-only; optional. Specifies the second vector of three describing the sides.
Direction3 | Variant ( GeVector object); input-only; optional. Specifies the third vector of three describing the sides.
Returns

GeBoundBlock object


IGeApplication::CircularArc Method
Summary

Creates a GeCircularArc object.

Visual Basic
Sub CircularArc(Center As [in, optional]VARIANT, Normal As [in, optional]VARIANT, Radius As [in, optional]VARIANT, ReferenceVector As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Arc As [out, retval]IGeCircularArc*)
Parameters
Parameters | Description
Center | Variant ( GePoint object); input-only; optional. Specifies the center point of the circle.
Normal | Variant ( GeVector object); input-only; optional. Specifies the normal vector of the arc.
Radius | Variant (Double); input-only; optional. Specifies the radius of the circle or arc.
ReferenceVector | Variant ( GeVector object); input-only; optional. Specifies the reference vector for the arc.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the arc.
Returns

GeCircularArc object


IGeApplication::Collection Method
Summary

Creates a new collection object of the specified type.

Visual Basic
Sub Collection(Type As GeCollectionType, Collection As [out, retval] LPDISPATCH)
Parameters
Parameters | Description
Type | Integer; input-only. Specifies the collection type to create.
Returns

It returns the specified collection object.

Remarks

Valid types include:

  • GeCurveBoundaries
  • geCurves
  • geEntities
  • gePoints
  • GeSurfaces
  • geVectors


IGeApplication::CompositeCurve Method
Summary

Creates a new GeCompositeCurve object.

Visual Basic
Sub CompositeCurve(Curves As [in, optional]VARIANT, Curve As [out, retval]IGeCompositeCurve*)
Parameters
Parameters | Description
Curves | Variant ( GeCurves collection); input-only; optional. Specifies the curves that make up the composite curve. The end points of the curves specified by the Curves element should be equal to the start point of any consecutive curves in the list (no verification of this is performed). If the Curves element is not specified, the composite curve will consist of a single element which is a line segment from 0,0,0 to 1,0,0.
Returns

GeCompositeCurve object


IGeApplication::Cone Method
Summary

Creates a GeCone object.

Visual Basic
Sub Cone(Cosine As [in, optional]VARIANT, Sine As [in, optional]VARIANT, Origin As [in, optional]VARIANT, Radius As [in, optional]VARIANT, SymmetryAxis As [in, optional]VARIANT, ReferenceAxis As [in, optional]VARIANT, Height As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Cone As [out, retval]IGeCone*)
Parameters
Parameters | Description
Cosine | Variant (Double); input-only; optional. Specifies the cosine of the angle formed by the cone generated and its axis.
Sine | Variant (Double); input-only; optional. Specifies the sine of the angle formed by the cone generated and its axis.
Origin | Variant ( GePoint object); input-only; optional. Specifies the center point of the base.
Radius | Variant (Double); input-only; optional. Specifies the radius of the circular base.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector on the base.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cone.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

GeCone object

Remarks

The default cone is Initialized with the sine angle to -sin(PI/4), the cosine angle to cos(PI/4), the axis of symmetry to <0,1,0>, the reference axis to <1,0,0>, the base origin to <0,0,0>, and the base radius to 2.0.


IGeApplication::CurveBoundary Method
Summary

Creates a GeCurveBoundary object.

Visual Basic
Sub CurveBoundary(Geometry3d As [in, optional] VARIANT, Geometry2d As [in, optional] VARIANT, Orientation3d As [in, optional] VARIANT, Orientation2d As [in, optional] VARIANT, Boundary As [out, retval] IGeCurveBoundary*)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); input-only; optional.
Geometry2d | Variant (array of GeCurve objects); input-only; optional.
Orientation3d | Variant(array of Booleans); input-only; optional. Specifies the logical orientation of the corresponding entity in the Geometry3d element.
Orientation2d | Variant(array of Booleans); input-only; optional. Specifies the logical orientation of the corresponding curves in the Geometry2d element.
Returns

GeCurveBoundary object

Remarks

If any of the optional elements are specified:

  • They all must be specified.
  • The length of all of the arrays must be the same.


IGeApplication::Cylinder Method
Summary

Creates a GeCylinder object.

Visual Basic
Sub Cylinder(Radius As [in, optional]VARIANT, Origin As [in, optional]VARIANT, SymmetryAxis As [in, optional]VARIANT, ReferenceAxis As [in, optional]VARIANT, Height As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Cylinder As [out, retval]IGeCylinder*)
Parameters
Parameters | Description
Radius | Variant (Double); input-only; optional. Specifies the radius of the cylinder.
Origin | Variant ( GePoint object); input-only. The base point on the cylinder axis.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the cylinder's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector on the base.
Height | Variant ( GeInterval object); input-only; optional. The interval height of the cylinder.
StartAngle | Variant (Double); input-only; optional. The start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. The end angle on the base circle.
Returns

GeCylinder object


IGeApplication::EllipticalArc Method
Summary

Creates a new GeEllipticalArc object.

Visual Basic
Sub EllipticalArc(Center As [in, optional]VARIANT, MajorAxis As [in, optional]VARIANT, MinorAxis As [in, optional]VARIANT, MajorRadius As [in, optional]VARIANT, MinorRadius As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Arc As [out, retval]IGeEllipticalArc*)
Parameters
Parameters | Description
Center | Variant ( GePoint object), Specifies the default value is (0,0,0); input-only; optional. Specifies Specifies the center point of the ellipse.
MajorAxis | Variant ( GeVector object), the default value is (1,0,0); input-only; optional. Specifies the major axis of the ellipse.
MinorAxis | Variant ( GeVector object), the default value is (0,1,0); input-only; optional. Specifies the minor axis of the ellipse.
MajorRadius | Variant (Double), the default value is 1; input-only; optional. Specifies the major radius of the ellipse.
MinorRadius | Variant (Double), the default value is 1; input-only; optional. Specifies the minor radius of the ellipse.
StartAngle | Variant (Double), the default value is 0; input-only; optional. Specifies the angle of the elliptical arc start point.
EndAngle | Variant (Double), the default value is 2*pi; input-only; optional. Specifies the angle of the elliptical arc end point.
Returns

GeEllipticalArc object


IGeApplication::Interval Method
Summary

Creates a new GeInterval object.

Visual Basic
Sub Interval(Lower As [in, optional]VARIANT, Upper As [in, optional]VARIANT, Tolerance As [in, optional]VARIANT, Interval As [out, retval]IGeInterval*)
Parameters
Parameters | Description
Lower | Variant (Double); input-only; optional. Specifies the lower interval bound.
Upper | Variant (Double); input-only; optional. The upper interval bound.
Tolerance | Variant (Double), the default value is 1.0e-12; input-only; optional. Specifies the boundary tolerance of Specifies the interval.
Remarks

If Specifies the Lower and Upper bounds are not specified, creates an infinite interval.


IGeApplication::KnotVector Method
Summary

Creates a new GeKnotVector object.

Visual Basic
Sub KnotVector(Tolerance As [in, defaultvalue(1.0e-9)] double, pKnot As [out, retval]IGeKnotVector*)
Parameters
Parameters | Description
Tolerance | Double, the default value is 1.0e-9; input-only; optional. Specifies the tolerance used for calculations.
Returns

GeKnotVector object


IGeApplication::Line Method
Summary

Creates a new GeLine object.

Visual Basic
Sub Line(Point As [in, optional]VARIANT, PointVector As [in, optional]VARIANT, Line As [out, retval]IGeLine*)
Parameters
Parameters | Description
Point | Variant ( GePoint object); input-only; optional. Specifies a point that the line passes through.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point, or direction vector from the first point to define the line.
Returns

GeLine object


IGeApplication::LineSegment Method
Summary

Creates a new GeLineSegment object.

Visual Basic
Sub LineSegment(Point As [in, optional]VARIANT, PointVector As [in, optional]VARIANT, Line As [out, retval]IGeLineSegment*)
Parameters
Parameters | Description
Point | Variant ( GePoint object); input-only; optional. Specifies the start point of the line segment.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point, or vector from the start point of the line segment.
Returns

GeLineSegment object


IGeApplication::Matrix Method
Summary

Creates a new GeMatrix object set to identity.

Visual Basic
Sub Matrix(Matrix As [out, retval]IGeMatrix*)
Returns

GeMatrix object


IGeApplication::NurbCurve Method
Summary

Creates a new GeNurbCurve object, which is a 3D rational spline by a knot vector, control points, and weights.

Visual Basic
Sub NurbCurve(Degree As [in, optional] VARIANT, Knots As [in, optional] VARIANT, ControlPoints As [in, optional] VARIANT, Weights As [in, optional] VARIANT, Periodic As [in, optional] VARIANT, Curve As [out, retval] IGeNurbCurve*)
Parameters
Parameters | Description
Degree | Variant (Integer); input-only; optional. Specifies the degree of the spline (order 1) .
Knots | Variant ( GeKnotVector object); input-only; optional. Specifies an array of knot values, partitioning spline's domain into rational pieces.
ControlPoints | Variant ( GePoints collection); input-only; optional. Specifies the control points of the spline.
Weights | Variant (array of Doubles); input-only; optional. Specifies an array of weight values. If not specified, the curve is non-rational.
Periodic | Variant (Boolean), the default value is FALSE; input-only; optional. Specifies whether the spline is closed, FALSE, or periodic, TRUE.
Returns

GeNurbCurve object

Remarks
  • ControlPoints and Weights must have same length.
  • If Periodic is FALSE, the length of the knot vector must be greater than length of the control point collection by degree + 1; If Periodic is TRUE then the knot vector and the control point collection must have same length and the first and the last control points as well as the corresponding weights must be identical.


IGeApplication::NurbSurface Method
Summary

Creates a new GeNurbSurface object.

Visual Basic
Sub NurbSurface(DegreeU As [in, optional] VARIANT, DegreeV As [in, optional] VARIANT, PropertiesU As [in, optional] VARIANT, PropertiesV As [in, optional] VARIANT, PointsInU As [in, optional] VARIANT, PointsInV As [in, optional] VARIANT, Points As [in, optional] VARIANT, Weights As [in, optional] VARIANT, KnotsU As [in, optional] VARIANT, KnotsV As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Surface As [out, retval] IGeNurbSurface*)
Parameters
Parameters | Description
DegreeU | Variant (integer); input-only; optional. Specifies the degree in the U direction.
DegreeV | Variant (integer); input-only; optional. Specifies the degree in the V direction.
PropertiesU | Variant (integer); input-only; optional. Specifies the properties in the U direction.
PropertiesV | Variant (integer); input-only; optional. Specifies the properties in the V direction.
PointsInU | Variant (Integer); input-only; optional. Specifies the number of U control points.
PointsInV | Variant (Integer); input-only; optional. Specifies the number of V control points.
Points | Variant ( GePoints collection object); input-only; optional. Specifies the control points.
Weights | Variant (array of Doubles); input-only; optional. Specifies the weights at the control points..
KnotsU | Variant ( GeKnotVector object); input-only; optional. Specifies the knots in the U direction.
KnotsV | Variant ( GeKnotVector object); input-only; optional. Specifies the knots in the V direction.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance used for calculations.
Returns

GeNurbSurface object

Remarks
  • If no arguments are specified an empty surface is constructed; otherwise, all elements must be specified with an exception of the tolerance which is optional.
  • The parameter direction properties are a combination of the following enumeration members in GeNurbSurfaceProperties.


IGeApplication::OffsetCurve Method
Summary

Creates a new GeOffsetCurve object.

Visual Basic
Sub OffsetCurve(Curve As IGeCurve, Normal As IGeVector, Offset As [in, defaultvalue(0.0)] double, OffsetCurve As [out, retval] IGeOffsetCurve*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the planar Curve to offset.
Normal | GeVector object; input-only. The normal in the plane of the curve.
Offset | Double, the default value is 0.0; input-only; optional. Specifies the offset distance.
Returns

GeOffsetCurve object


IGeApplication::OffsetSurface Method
Summary

Creates a new GeOffsetSurface object.

Visual Basic
Sub OffsetSurface(Surface As [in, optional] VARIANT, Offset As [in, optional] VARIANT, OffsetSurface As [out, retval] IGeOffsetSurface*)
Parameters
Parameters | Description
Surface | Variant ( GeSurface object); input-only; optional. Specifies the surface to offset.
Offset | Variant (Double), the default value is 0.0; input-only; optional. Specifies the offset distance.
Returns

GeOffsetSurface object


IGeApplication::Plane Method
Summary

Creates a new GePlane object.

Visual Basic
Sub Plane(Origin As [in, optional] VARIANT, Normal As [in, optional] VARIANT, Plane As [out, retval] IGePlane*)
Parameters
Parameters | Description
Origin | Variant ( GePoint object), the default value is (0,0,0); input-only; optional. Specifies the origin point of the plane.
Normal | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the normal vector of the plane.
Returns

GePlane object


IGeApplication::Point Method
Summary

Creates a new GePoint object.

Visual Basic
Sub Point(X As [in, defaultvalue(0.0)]double, Y As [in, defaultvalue(0.0)]double, Z As [in, defaultvalue(0.0)]double, Point As [out, retval]IGePoint*)
Parameters
Parameters | Description
X | Double, the default value is 0; input-only; optional. Specifies the X coordinate of the point.
Y | Double, the default value is 0; input-only; optional. Specifies the Y coordinate of the point.
Z | Double, the default value is 0; input-only; optional. Specifies the Z coordinate of the point.
Returns

GePoint object


IGeApplication::Ray Method
Summary

Creates a new GeRay object.

Visual Basic
Sub Ray(Origin As [in, optional] VARIANT, PointVector As [in, optional] VARIANT, Ray As [out, retval] IGeRay*)
Parameters
Parameters | Description
Origin | Variant ( GePoint object); input-only; optional. Specifies the start point of the ray.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point on the ray, or a vector indicating the ray direction.
Returns

GeRay object

Remarks

The default ray constructed starts at (0,0,0) and is in the (1,0,0) direction.


IGeApplication::Sphere Method
Summary

Creates a new GeSphere object.

Visual Basic
Sub Sphere(Radius As [in, defaultvalue(1.0)] double, Center As [in, optional] VARIANT, NorthAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT, Sphere As [out, retval] IGeSphere*)
Parameters
Parameters | Description
Radius | Double, the default value is 1.0; input-only; optional. Specifies the radius of the sphere.
Center | Variant ( GePoint object), default (0,0,0); input-only; optional. Specifies the center point of the sphere.
NorthAxis | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the direction of the north pole of the sphere.
ReferenceAxis | Variant (GeVector object), the default value is (1,0,0); input-only; optional. Specifies the reference vector for the measured angles.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitude angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitude angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitude angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitude angle.
Returns

GeSphere object


IGeApplication::Tolerance Method
Summary

Creates a new GeTolerance object.

Visual Basic
Sub Tolerance(EqualPoint As [in, defaultvalue(1.0e-10)] double, EqualVector As [in, defaultvalue(1.0e-10)] double, Tolerance As [out, retval] IGeTolerance*)
Parameters
Parameters | Description
EqualPoint | Double, the default value is 1.0e-10; input-only; optional.
EqualVector | Double, the default value is 1.0e-10; input-only; optional.
Returns

GeTolerance object


IGeApplication::Torus Method
Summary

Creates a new GeTorus object.

Visual Basic
Sub Torus(MajorRadius As [in, defaultvalue(1.0)] double, MinorRadius As [in, defaultvalue(2.0)] double, Origin As [in, optional] VARIANT, Axis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT, Torus As [out, retval] IGeTorus*)
Parameters
Parameters | Description
MajorRadius | Double, the default value is 1.0; input-only; optional. Specifies the major radius of the torus.
MinorRadius | Double; default 2.0; input-only; optional. Specifies the minor radius of the torus.
Origin | Variant ( GePoint object); default (0,0,0); input-only; optional . The center point of the torus.
Axis | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the axis of symmetry of the torus.
ReferenceAxis | Variant (GeVector object), the default value is (1,0,0); input-only; optional. Specifies the reference vector for the measured angles.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitude angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitude angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitude angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitude angle.
Returns

GeTorus object


IGeApplication::Vector Method
Summary

Creates a new GeVector object.

Visual Basic
Sub Vector(X As [in, defaultvalue(0)]double, Y As [in, defaultvalue(0)]double, Z As [in, defaultvalue(0)]double, Vector As [out, retval]IGeVector*)
Parameters
Parameters | Description
X | Double, the default value is 0; input-only; optional. Specifies the X coordinate of the vector.
Y | Double, the default value is 0; input-only; optional. Specifies the Y coordinate of the point.
Z | Double, the default value is 0; input-only; optional. Specifies the Z coordinate of the vector.
Returns

GeVector object


IGeAugmentedLine Interface
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeAugmentedLine
Visual Basic
Public Interface IGeAugmentedLine
Inherits IGeCurve
Links
IGeAugmentedLine Members, GEAuto Library


IGeAugmentedLine Members
Summary

The following tables list the members exposed by IGeAugmentedLine.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PointAt | Specifies the point at the specified index on this augmented line.
PointAt | Specifies the point at the specified index on this augmented line.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
Set | Changes the definition of the augmented line to pass through the specified turning points respectively in the direction of the specified vectors.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
VectorAt | Specifies the normal vector at the specified index on this augmented line.
VectorAt | Specifies the normal vector at the specified index on this augmented line.
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.
Points | Gets the list of points defining the augmented line.
SecondDerivatives | Gets the list of second order derivative vectors from this augmented line.
Vectors | Gets the list of vectors at the points that define this augmented line.


IGeAugmentedLine::Points Property
Summary

Gets the list of points defining the augmented line.

Visual Basic
Property Points() As IGePoints**
Remarks

This property is a gePoints collection.


IGeAugmentedLine::SecondDerivatives Property
Summary

Gets the list of second order derivative vectors from this augmented line.

Visual Basic
Property SecondDerivatives() As IGeVectors**
Remarks

This property is a geVectors object.


IGeAugmentedLine::Vectors Property
Summary

Gets the list of vectors at the points that define this augmented line.

Visual Basic
Property Vectors() As IGeVectors**
Remarks

This property is a geVectors object.


IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)
Summary

Specifies the point at the specified index on this augmented line.

Visual Basic
Sub PointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point on this augmented line.
Remarks

This property is a GePoint object.


IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)
Summary

Specifies the point at the specified index on this augmented line.

Visual Basic
Sub PointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point on this augmented line.
Remarks

This property is a GePoint object.


IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)
Summary

Specifies the second order derivative vector at the specified index on the augmented line.

Visual Basic
Sub SecondDerivativeAt(Index As long, Vector As IGeVector)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the second order derivative vector.
Remarks

This property is a GeVector object.


IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)
Summary

Specifies the second order derivative vector at the specified index on the augmented line.

Visual Basic
Sub SecondDerivativeAt(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the second order derivative vector.
Remarks

This property is a GeVector object.


IGeAugmentedLine::Set Method
Summary

Changes the definition of the augmented line to pass through the specified turning points respectively in the direction of the specified vectors.

Visual Basic
Sub Set(Points As IGePoints, Vectors As IGeVectors)
Parameters
Parameters | Description
Points | GePoints collection object; input-only. Specifies a series of continuous turning points for the definition of the augmented line.
Vectors | GeVectors collection object; input-only. Specifies a series of direction vectors that correspond to each turning point.
Returns

None


IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)
Summary

Specifies the normal vector at the specified index on this augmented line.

Visual Basic
Sub VectorAt(Index As long, Vector As IGeVector)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the normal vector.
Remarks

This property is a GeVector object.


IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)
Summary

Specifies the normal vector at the specified index on this augmented line.

Visual Basic
Sub VectorAt(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the normal vector.
Remarks

This property is a GeVector object.


IGeBoundBlock Interface
Summary

A spatial bounding volume.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeBoundBlock
Visual Basic
Public Interface IGeBoundBlock
Inherits IGeEntity
Links
IGeBoundBlock Members, GEAuto Library


IGeBoundBlock Members
Summary

The following tables list the members exposed by IGeBoundBlock.

Methods
Name | Description
Contains | Determines whether the specified point lies within the bounding box, TRUE, or not, FALSE.
Extend | Extends the bounding box to include the specified point.
IsDisjoint | Determines whether the specified bounding box does not intersect or is disjoint with this bounding box, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Swell | Expands the bounding box on all sides by the specified distance.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BasePoint | Specifies the base point of the bounding block.
Direction1 | Specifies the first edge from the base point of the bounding box.
Direction2 | Specifies the second edge from the base point of the bounding box.
Direction3 | Specifies the third edge from the base point of the bounding box.
IsBox | Specifies whether the bounding box is an orthogonal coordinate box, TRUE, or not, FALSE.
MaxPoint | Specifies the maximum point of the bounding box.
MinPoint | Specifies the minimum point of the bounding box.


IGeBoundBlock::BasePoint Property
Summary

Specifies the base point of the bounding block.

Visual Basic
Property BasePoint() As IGePoint*
Remarks

This property is a GePoint object.


IGeBoundBlock::Direction1 Property
Summary

Specifies the first edge from the base point of the bounding box.

Visual Basic
Property Direction1() As IGeVector*
Remarks

This property is a GeVector object.


IGeBoundBlock::Direction2 Property
Summary

Specifies the second edge from the base point of the bounding box.

Visual Basic
Property Direction2() As IGeVector*
Remarks

This property is a GeVector object.


IGeBoundBlock::Direction3 Property
Summary

Specifies the third edge from the base point of the bounding box.

Visual Basic
Property Direction3() As IGeVector*
Remarks

This property is a GeVector object.


IGeBoundBlock::IsBox Property
Summary

Specifies whether the bounding box is an orthogonal coordinate box, TRUE, or not, FALSE.

Visual Basic
Property IsBox() As VARIANT_BOOL
Remarks

This property is a Boolean.


IGeBoundBlock::MaxPoint Property
Summary

Specifies the maximum point of the bounding box.

Visual Basic
Property MaxPoint() As IGePoint*
Remarks

This property is a GePoint object.


IGeBoundBlock::MinPoint Property
Summary

Specifies the minimum point of the bounding box.

Visual Basic
Property MinPoint() As IGePoint*
Remarks

This property is a GePoint object.


IGeBoundBlock::Contains Method
Summary

Determines whether the specified point lies within the bounding box, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Point As IGePoint, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Returns

Boolean


IGeBoundBlock::Extend Method
Summary

Extends the bounding box to include the specified point.

Visual Basic
Sub Extend(Point As IGePoint)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to include to the bounding box.
Returns

None


IGeBoundBlock::IsDisjoint Method
Summary

Determines whether the specified bounding box does not intersect or is disjoint with this bounding box, TRUE, or not, FALSE.

Visual Basic
Sub IsDisjoint(Bound As IGeBoundBlock, Disjoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Bound | GeBoundBlock object; input-only. Specifies the other bounding box to perform the check.
Returns

Boolean


IGeBoundBlock::Swell Method
Summary

Expands the bounding box on all sides by the specified distance.

Visual Basic
Sub Swell(Distance As double)
Parameters
Parameters | Description
Distance | Double; input-only. Specifies the distance in which to expand the bounding box.
Returns

None


IGeBoundedSurface Interface
Summary

Surface with trimming boundary information.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeBoundedSurface
Visual Basic
Public Interface IGeBoundedSurface
Inherits IGeSurface
Links
IGeBoundedSurface Members, GEAuto Library


IGeBoundedSurface Members
Summary

The following tables list the members exposed by IGeBoundedSurface.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Gets the unbounded base surface geometry.
ContourCount | Gets the number of contour boundaries on the surface.
Contours | Obtains the contour objects that make up the boundary loops on this bounded surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeBoundedSurface::BaseSurface Property
Summary

Gets the unbounded base surface geometry.

Visual Basic
Property BaseSurface() As IGeSurface**
Remarks

This property is a GeSurface object.


IGeBoundedSurface::ContourCount Property
Summary

Gets the number of contour boundaries on the surface.

Visual Basic
Property ContourCount() As long*
Remarks

This property is a Long.


IGeBoundedSurface::Contours Property
Summary

Obtains the contour objects that make up the boundary loops on this bounded surface.

Visual Basic
Property Contours() As IGeCurveBoundaries**
Remarks

This property is a geCurveBoundaries collection.


IGeCircularArc Interface
Summary

A circle or circular arc curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeCircularArc
Visual Basic
Public Interface IGeCircularArc
Inherits IGeCurve
Links
IGeCircularArc Members, GEAuto Library


IGeCircularArc Members
Summary

The following tables list the members exposed by IGeCircularArc.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this circular arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the circular arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the circular arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TangentAt | Determines whether the input point lies on the circular arc, TRUE, or not, FALSE.
TangentTangentRadius | Changes the definition of the circular arc to be tangent to the two input curves and have the specified radius and returns whether this method succeeds, TRUE, or fails, FALSE.
TangentTangentTangent | Changes the definition of the arc to be a circle tangent to the three input curves if possible and returns whether this method succeeds, TRUE, or fails, FALSE.
ThreePoint | Changes the definition of the arc to have the specified start and end points and pass through the specified point.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the circular arc.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this circular arc.
Radius | Specifies the radius of the circular arc.
ReferenceVector | Specifies the reference vector of the circular arc from which the start and end angles are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.


IGeCircularArc::Center Property
Summary

Specifies the center point of the arc.

Visual Basic
Property Center() As IGePoint*
Remarks

This property is a GePoint object.


IGeCircularArc::EndAngle Property
Summary

Specifies the angle of the end point with respect to the reference vector in the plane of the circular arc.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.


IGeCircularArc::Normal Property
Summary

Specifies the normal vector of this circular arc.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.


IGeCircularArc::Radius Property
Summary

Specifies the radius of the circular arc.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.


IGeCircularArc::ReferenceVector Property
Summary

Specifies the reference vector of the circular arc from which the start and end angles are measured.

Visual Basic
Property ReferenceVector() As IGeVector*
Remarks

This property is a GeVector object.


IGeCircularArc::StartAngle Property
Summary

Specifies the angle of the start point with respect to the reference vector in the plane of the arc.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.


IGeCircularArc::IntersectWith Method
Summary

Determines whether the specified geometry entity intersects with this circular arc, TRUE, or not, FALSE. They do not need to lie in the same plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Direction As [in, optional] VARIANT, LinePoint1 As [in, out, optional] VARIANT, LinePoint2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersects As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeCircularArc , GeLinearEntity, or GePlane object.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Direction | Variant ( GeVector object); input-only; optional. Specifies the normal of a plane that this circular arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when the GeEntity element is a GeLinearEntity.
LinePoint1 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
LinePoint2 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCircularArc::IsInside Method
Summary

Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the circular arc, FALSE.

Visual Basic
Sub IsInside(Point As IGePoint, Tolerance As [in, optional] VARIANT, Inside As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

This method treats the arc as a full circle or ellipse even if it is bounded and determines if the specified point lies inside of the full circle or ellipse.


IGeCircularArc::Set Method
Summary

Sets the circular arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.

Visual Basic
Sub Set(Center As IGePoint, Normal As IGeVector, Radius As double, ReferenceVector As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Center | GePoint object; input-only. Specifies the center point of the circular arc.
Normal | GeVector object; input-only. Specifies the normal vector of the circular arc.
Radius | Double; input-only. Specifies the radius of the circular arc.
ReferenceVector | Variant ( GeVector object); input-only; optional. Specifies the reference vector for the circular arc.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the circular arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the circular arc.
Returns

None

Remarks

If the reference vector, start or end angles are specified, they all must be specified.


IGeCircularArc::TangentAt Method
Summary

Determines whether the input point lies on the circular arc, TRUE, or not, FALSE.

Visual Basic
Sub TangentAt(Point As IGePoint, ByRef Line As IGeLine*, Tolerance As [in, optional] VARIANT, Tangent As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to locate the tangent of.
Line | GeLine object; output-only. Specifies the tangent line at the point. The tangent line will be only set if the method returns TRUE.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCircularArc::TangentTangentRadius Method
Summary

Changes the definition of the circular arc to be tangent to the two input curves and have the specified radius and returns whether this method succeeds, TRUE, or fails, FALSE.

Visual Basic
Sub TangentTangentRadius(Curve1 As IGeCurve, Curve2 As IGeCurve, Radius As double, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to define the circular arc.
Curve2 | GeCurve object; input-only. Specifies the second curve to define the circular arc.
Radius | Double; input-only. Specifies the radius to define the circular arc.
Parameter1 | Variant (Double); optional. Specifies the parameter on Curve1 where the arc is tangent.
Parameter2 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Returns

Boolean

Remarks
  • The two input curves must be coplanar.
  • This method computes an arc whose endpoints are the points on the two input curves that correspond to the Parameter1 and Parameter2 elements.
  • If this method fails to compute the arc, it returns FALSE and the arc is not changed.


IGeCircularArc::TangentTangentTangent Method
Summary

Changes the definition of the arc to be a circle tangent to the three input curves if possible and returns whether this method succeeds, TRUE, or fails, FALSE.

Visual Basic
Sub TangentTangentTangent(Curve1 As IGeCurve, Curve2 As IGeCurve, Curve3 As IGeCurve, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Parameter3 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to define the circular arc.
Curve2 | GeCurve object; input-only. Specifies the second curve to define the circular arc.
Curve3 | GeCurve object; input-only. Specifies the third curve to define the circular arc.
Parameter1 | Variant (Double); optional. Specifies the parameter on Curve1 where the arc is tangent.
Parameter2 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Parameter3 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Returns

Boolean

Remarks
  • The input curves must be coplanar.
  • This method computes an arc whose endpoints are the points on the input curves that correspond to Parameter1, Parameter2, and Parameter3.
  • If this method fails to compute the arc, it returns FALSE and the arc is not changed.


IGeCircularArc::ThreePoint Method
Summary

Changes the definition of the arc to have the specified start and end points and pass through the specified point.

Visual Basic
Sub ThreePoint(Point1 As IGePoint, Point2 As IGePoint, Point3 As IGePoint)
Parameters
Parameters | Description
Point1 | GePoint object; input-only. Specifies the first point to define the circular arc.
Point2 | GePoint object; input-only. Specifies the second point to define the circular arc.
Point3 | GePoint object; input-only. Specifies the third point to define the circular arc.
Returns

None

Remarks

  • None of the three points may be coincindent and they may not be colinear.
  • This method always returns a bounded circular arc.


IGeCompositeCurve Interface
Summary

A curve composed of multiple component curves connected end to end.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeCompositeCurve
Visual Basic
Public Interface IGeCompositeCurve
Inherits IGeCurve
Remarks

For instance, a composite curve could consist of four straight line segments that form a square. Each of the component curves must be bounded curves, which means that infinite lines and rays may not be used as component curves of a composite. The component curves are not required to all lie in the same plane. The start parameter of a composite is 0.0. The parameter value at the end point of the first component curve will be the approximate length of the first curve (call this value l1). The parameter value at the end point of the second curve will be l1 + the approximate length of the second curve, and so on.

Links
IGeCompositeCurve Members, GEAuto Library


IGeCompositeCurve Members
Summary

The following tables list the members exposed by IGeCompositeCurve.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
GlobalToLocal | Determines the parameter value on the specified component curve corresponding to the specified parameter value on the overall composite curve.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
LocalToGlobal | Determines the parameter value on the composite curve corresponding to the specified parameter value on the composite curve at the specified index.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Curves | Specifies the component curves that make up the composite curve.
Interval | Sets the interval of the curve and returns the index of the interval.


IGeCompositeCurve::Curves Property
Summary

Specifies the component curves that make up the composite curve.

Visual Basic
Property Curves() As IGeCurves*
Remarks

This property is a geCurves collection.


IGeCompositeCurve::GlobalToLocal Method
Summary

Determines the parameter value on the specified component curve corresponding to the specified parameter value on the overall composite curve.

Visual Basic
Sub GlobalToLocal(Global As double, ByRef Index As long, Local As [out, retval] double)
Parameters
Parameters | Description
Global | Double; input-only. Specifies the parameter value on the composite curve.
Index | Integer; input-only. Specifies the index of the component curve to which to map the parameter.
Returns

Double


IGeCompositeCurve::LocalToGlobal Method
Summary

Determines the parameter value on the composite curve corresponding to the specified parameter value on the composite curve at the specified index.

Visual Basic
Sub LocalToGlobal(Local As double, Index As long, Global As [out, retval] double)
Parameters
Parameters | Description
Local | Double; input-only. Specifies the parameter value on the component curve.
Index | Integer; input-only. Specifies the index of the component curve.
Returns

Double


IGeCone Interface
Summary

A bounded right circular cone.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeCone
Visual Basic
Public Interface IGeCone
Inherits IGeSurface
Links
IGeCone Members, GEAuto Library


IGeCone Members
Summary

The following tables list the members exposed by IGeCone.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
HeightAt | Computes the parameter on the axis of symmetry corresponding to the specified height parameter value of the cone.
IntersectWith | Computes the intersection between the cone and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosed | Specifies whether this cone is a full cone, TRUE, or a conic section, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cone by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Apex | Specifies the apex vertex of the cone.
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cone.
BaseRadius | Specifies the base radius of the cone.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
HalfAngle | Specifies the angle between the axis of symmetry and the generated cone.
Height | Specifies the parameter interval height of the cone.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cone.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cone.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeCone::Apex Property
Summary

Specifies the apex vertex of the cone.

Visual Basic
Property Apex() As IGePoint**
Remarks

This property is a GePoint object.


IGeCone::AxisOfSymmetry Property
Summary

Specifies the axis of symmetry of this cone.

Visual Basic
Property AxisOfSymmetry() As IGeVector**
Remarks

This property is a GeVector object.


IGeCone::BaseRadius Property
Summary

Specifies the base radius of the cone.

Visual Basic
Property BaseRadius() As double
Remarks

This property is a Double.


IGeCone::EndAngle Property
Summary

Specifies the angle of the end point with respect to the reference vector in the base of the cone.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.


IGeCone::HalfAngle Property
Summary

Specifies the angle between the axis of symmetry and the generated cone.

Visual Basic
Property HalfAngle() As double*
Remarks

This property is a Double.


IGeCone::Height Property
Summary

Specifies the parameter interval height of the cone.

Visual Basic
Property Height() As IGeInterval*
Remarks

This property is a GeInterval object.


IGeCone::Origin Property
Summary

Gets the center of the base of the cone.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.


IGeCone::ReferenceVector Property
Summary

Specifies the reference vector from which the start angle and end angle are measured.

Visual Basic
Property ReferenceVector() As IGeVector**
Remarks

This property is a GeVector object.


IGeCone::StartAngle Property
Summary

Specifies the angle of the start point with respect to the reference vector in the base of the cone.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.


IGeCone::HeightAt Method
Summary

Computes the parameter on the axis of symmetry corresponding to the specified height parameter value of the cone.

Visual Basic
Sub HeightAt(Parameter As double, Height As [out, retval] double)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the height parameter value of the cone on the axis of symmetry.
Returns

Double


IGeCone::IntersectWith Method
Summary

Computes the intersection between the cone and a linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersects As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this cone.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.


IGeCone::IsClosed Method
Summary

Specifies whether this cone is a full cone, TRUE, or a conic section, FALSE.

Visual Basic
Sub IsClosed(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeCone::Set Method
Summary

Changes the definition of this cone by the specified parameters.

Visual Basic
Sub Set(Cosine As double, Sine As double, Center As IGePoint, Radius As double, SymmetryAxis As IGeVector, ReferenceAxis As [in, optional] VARIANT, Height As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Cosine | Double; input-only. Specifies the cosine of the angle formed by the cone generated and its axis.
Sine | Double; input-only. Specifies the sine of the angle formed by the cone generated and its axis.
Center | GePoint object; input-only. Specifies the center point of the circular base.
Radius | Double; input-only. Specifies the radius of the circular base.
SymmetryAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies the reference vector on the circular base.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cone.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

None


IGeCurve Interface
Summary

A generic curve entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeAugmentedLine
        IGeCircularArc
        IGeCompositeCurve
        IGeEllipticalArc
        IGeLinearEntity
        IGeNurbCurve
        IGeOffsetCurve
Visual Basic
Public Interface IGeCurve
Inherits IGeEntity
Links
IGeCurve Members, GEAuto Library


IGeCurve Members
Summary

The following tables list the members exposed by IGeCurve.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.


IGeCurve::Interval Property
Summary

Sets the interval of the curve and returns the index of the interval.

Visual Basic
Property Interval() As IGeInterval**
Remarks

This property is a GeInterval object.


IGeCurve::BoundBlock Method
Summary

Computes the bounding box around the curve or the curve interval.

Visual Basic
Sub BoundBlock(Range As [in, optional] VARIANT, Ortho As [in, optional] VARIANT, Block As [out, retval] IGeBoundBlock*)
Parameters
Parameters | Description
Range | GeInterval object; input-only; optional. Specifies the parameter interval for which to compute the bounding box.
Ortho | Variant (Boolean); input-only; optional. Specifies whether to force a bounding box orthogonal to the coordinate axis, TRUE, or not, FALSE.
Returns

GeBoundBlock object


IGeCurve::ClosestPointTo Method
Summary

Calculates the closest point on this curve to the specified point.

Visual Basic
Sub ClosestPointTo(Point As IGePoint, Parameter As [in, out, optional] VARIANT, ProjectionDirection As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Parameter | Variant (Double); optional. Specifies the parameter of the closest point.
ProjectionDirection | Variant ( GeVector object); input-only; optional. Specifies the normal of the plane to project the curve and point onto.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks

For GeCurve objects: If the optional projection direction element is provided the returned point is the point on the curve which when projected onto a plane whose normal is the projection direction is closest to the specified point. This provides a line of sight closest point to the curve which may not be the actual closest point.

If the optional ProjectDirection element is specified, the returned point is the point on the curve which is closest to the specified point when the curve is projected onto a plane whose normal is the projection direction. This provides a line of sight closest point to the curve which may not be the actual closest point.


IGeCurve::ClosestPointToCurve Method
Summary

Calculates the closest point on this curve to the specified curve.

Visual Basic
Sub ClosestPointToCurve(Curve As IGeCurve, ThisParameter As [in, out, optional] VARIANT, OtherParameter As [in, out, optional] VARIANT, Direction As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to calculate the closest point to.
ThisParameter | Variant (Double); optional. Specifies the parameter value on this circular arc of the closest point.
OtherParameter | Variant (Double); optional. Specifies the parameter value on the other curve of the closest point.
Direction | Variant ( GeVector object); input-only; optional. Specifies the normal of the plane to project the circular arc and the other curve onto before the calculation.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks

If the optional ProjectDirection element is specified, the returned point is the point on the curve which is closest to the specified curve when the curve and curve are projected onto the same plane whose normal is the projection direction. This provides a line of sight closest point to the curve which may not be the actual closest point between the curves.


IGeCurve::DistanceTo Method
Summary

Calculates the minimum distance between this curve to the specified geometry entity.

Visual Basic
Sub DistanceTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Distance As [out, retval] double)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the geometry entity to calculate the minimum distance.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double


IGeCurve::EvaluatePoint Method
Summary

Returns the point on the curve corresponding to the specified parameter value.

Visual Basic
Sub EvaluatePoint(Parameter As double, DerivativeOrder As [in, optional] VARIANT, Derivatives As [in, out, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value to evaluate the point at.
DerivativeOrder | Variant (Integer); input-only; optional. Specifies the requested derivative order with limit to a value of 2.
Derivatives | Variant ( geVectors Collection); optional. Specifies the derivative arrays up to the order specified by the derivative order. Derivatives are returned as (order 1) dU or (order 2) dU, dUdU.
Returns

GePoint object

Remarks

If the optional Derivatives element is specified, the DerivativeOrder element must be specified.


IGeCurve::GetArea Method
Summary

Gets the area of the interval of the curve defined by the specified start parameter and end parameter.

Visual Basic
Sub GetArea(StartParameter As double, EndParameter As double, Tolerance As [in, optional] VARIANT, Area As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the start parameter to define an area of the circular arc.
EndParameter | Double; input-only. Specifies the end parameter to define an area of the circular arc.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks
  • The curve must be planar to successfully calculate the area.
  • If the points at StartParameter and EndParameter are the same, this function will return the area of the closed curve; if the points are different, this function will connect the two points with a line segment and return the signed area between the curve and the line segment.
  • If the line segment does not intersect the curve at any points between startParameter and EndParameter, the returned area will be positive; if the line segment intersects the curves at any points between StartParameter and EndParameter, the returned area will be the sum of the sub-areas created by the intersection of the line segment with the curve. Each sub-area will have a positive or negative area depending on whether the curve lies above or below the line segment. The total area returned by this function can therefore be positive, negative, or 0.


IGeCurve::GetCurvature Method
Summary

Gets the curvature of the curve at the specified parameter value.

Visual Basic
Sub GetCurvature(Parameter As double, Curvature As [out, retval] double)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value on the curve to calculate the curvature.
Returns

Double

Remarks

This function fails if the derivative at the specified parameter value is zero.


IGeCurve::GetLength Method
Summary

Gets the length of the curve between the two parameter values within the specified tolerance.

Visual Basic
Sub GetLength(StartParameter As double, EndParameter As double, Tolerance As [in, optional] VARIANT, Length As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the start parameter from which to calculate the length.
EndParameter | Double; input-only. Specifies the end parameter from which to calculate the length.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double


IGeCurve::GetSamplePoints Method
Summary

Evaluates a sampling of points along the curve.

Visual Basic
Sub GetSamplePoints(Number As [in, optional] VARIANT, From As [in, optional] VARIANT, To As [in, optional] VARIANT, Deviation As [in, optional] VARIANT, Parameters As [in, out, optional] VARIANT, Points As [out, retval] IGePoints*)
Parameters
Parameters
Description
Number
Variant (Integer); input-only; optional. Specifies the number of sample points to be returned.

  • If specified, the parameter interval of the circular arc is equally subdivided by the number. For instance, if the interval of the circular arc [0,1] and Number is 5, the parameter values of the returned points will be 0,.25,.5,.75, and 1.
  • If specified, all other arguments are ignored.
  • If not specified, the circular arc is sampled between From and To with the specified maximum deviation.

From
Variant (Double); input-only; optional. Specifies the starting parameter value on the polyline from which to evaluate the sampling points.
To
Variant (Double); input-only; optional. Specifies the ending parameter value on the circular arc from which to evaluate the sampling points.
Deviation
Variant (Double); input-only; optional. Specifies the chordal deviation tolerance to be maintained. The arc segment between any two consecutive sample points will not deviate by more than Deviation from the curve.
Returns

gePoints collection


IGeCurve::GetSplitCurves Method
Summary

Gets two segments which are obtained by splitting the curve at the specified parameter value.

Visual Basic
Sub GetSplitCurves(Parameter As double, ByRef Piece1 As IGeCurve*, ByRef Piece2 As IGeCurve*)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value at which the circular arc is split.
Piece1 | GeCurve object; output-only. Specifies the first polyline segment.
Piece2 | GeCurve object; output-only. Specifies the second curve segment.
Returns

None


IGeCurve::HasEndPoint Method
Summary

Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.

Visual Basic
Sub HasEndPoint(Point As [in, out, optional] VARIANT, HasEndPoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); output-only; optional. Returns the end point if this method returns TRUE.
Remarks

This property is a Boolean.


IGeCurve::HasStartPoint Method
Summary

Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.

Visual Basic
Sub HasStartPoint(Point As [in, out, optional] VARIANT, HasStartPoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); optional. Returns the start point if this method returns TRUE.
Remarks

This property is a Boolean.


IGeCurve::IntersectWithCurve Method
Summary

Calculates the intersection with the specified curve within the specified tolerance.

Visual Basic
Sub IntersectWithCurve(OtherCurve As IGeCurve, RangeThis As [in, optional] VARIANT, RangeOther As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeCurveCurveIntersection*)
Parameters
Parameters | Description
OtherCurve | GeCurve object; input-only. Specifies the curve to intersect with the curve.
RangeThis | Variant ( GeInterval object); input-only; optional. Specifies the interval range of the curve.
RangeOther | Variant ( GeInterval object); input-only; optional. Specifies the interval range of the specified curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeCurveCurveIntersection object


IGeCurve::IntersectWithSurface Method
Summary

Calculates the intersection with the specified surface within the specified tolerance.

Visual Basic
Sub IntersectWithSurface(Surface As IGeSurface, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeCurveSurfaceIntersection*)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the surface to intersect with the curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeCurveSurfaceIntersection object


IGeCurve::IsClosed Method
Summary

Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.

Visual Basic
Sub IsClosed(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeCurve::IsCoplanarWith Method
Summary

Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.

Visual Basic
Sub IsCoplanarWith(Curve As IGeCurve, Plane As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Coplanar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to perform the check.
Plane | Variant ( GePlane object); output-only; optional. If the curves are coplanar, the plane on which they lie is returned in the optional plane argument.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCurve::IsDegenerate Method
Summary

Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.

Visual Basic
Sub IsDegenerate(Entity As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Degenerate As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Variant ( GeEntity object); output-only; optional. Specifies the entity that the curve degenerates into.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCurve::IsLinear Method
Summary

Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsLinear(Line As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Linear As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Variant ( GeLine object); optional. Specifies the unbounded line on which this curve lies.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCurve::IsOnInterval Method
Summary

Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.

Visual Basic
Sub IsOnInterval(Parameter As double, Tolerance As [in, optional] VARIANT, OnInterval As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeCurve::IsPeriodic Method
Summary

Gets whether this curve is periodic, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodic(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); optional. Specifies the period of the polyline to perform the check.
Remarks
  • This property is a Boolean.
  • The curve is periodic only if it is closed and the two points EvaluatePoint(t) and EvaluatePoint(t+period) are always the same point for all values of t.


IGeCurve::IsPlanar Method
Summary

Gets whether this curve is planar, TRUE, or not, FALSE.

Visual Basic
Sub IsPlanar(Tolerance As [in, optional] VARIANT, Plane As [in, out, optional] VARIANT, Planar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Plane | Variant ( GePlane object); optional. Specifies the other plane whether this circular arc is parallel with.
Remarks

Variant ( GePlane object); optional. Specifies the other plane whether this curve is parallel with.


IGeCurve::LocalClosestPointTo Method
Summary

Computes the closest point to the curve within the specified parameter interval.

Visual Basic
Sub LocalClosestPointTo(Point As IGePoint, Parameter As [in, out] double, Range As IGeInterval, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. The point to find the closest point to.
Parameter | Double. On input, specifies the starting parameter for the search; on output, specifies the parameter value of the closest point on the curve interval.
Range | GeInterval object; input-only. Specifies the parameter range to search.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object


IGeCurve::LocalClosestPointToCurve Method
Summary

Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.

Visual Basic
Sub LocalClosestPointToCurve(Curve As IGeCurve, ParameterOnThis As [in, out] double, ParameterOnOther As [in, out] double, RangeOnThis As IGeInterval, RangeOnOther As IGeInterval, Tolerance As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to find the closest point to.
ParameterOnThis | Double. On input, specifies the starting parameter on this curve for the search; on output, specifies the parameter value of the closest point on this curve.
ParameterOnOther | Double. On input, specifies the starting parameter on the specified curve for the search; on output, specifies the parameter value of the closest point on the specified curve.
RangeOnThis | GeInterval object; input-only. Specifies the parameter range on this curve to search.
RangeOnOther | GeInterval object; input-only. Specifies the parameter range on the specified curve to search.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object


IGeCurve::NormalPoint Method
Summary

Finds the point on the curve whose normal passes through the specified point.

Visual Basic
Sub NormalPoint(Point As IGePoint, Parameter As [in, out] double, Tolerance As [in, optional] VARIANT, NormalPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point for which to find a normal point.
Parameter | Double; input-only. Specifies the parameter value of the normal point. The initial value of the Param element is assumed to contain the parameter value of an initial guess.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks
  • The returned parameters evaluated point will lie on a plane that also contains the input point and is perpendicular to the curve tangent at that point. Therefore, the returned point will be at a local minimum or a local maximum from the input point.
  • The curve does not need to be planar. If the curve is planar, the input point does not need to lie in the plane of the curve.
  • If there is more than one normal point on the curve, the returned point will be the one whose parameter value is closest to the input parameter value.


IGeCurve::ParameterAtLength Method
Summary

Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.

Visual Basic
Sub ParameterAtLength(StartParameter As double, Length As double, Direction As [in, defaultvalue(TRUE)] VARIANT_BOOL, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the starting parameter from which to measure the length.
Length | Double; input-only. Specifies the arc length distance to find the parameter of.
Direction | Boolean, the default value is TRUE; input-only; optional. Specifies whether the length will be measured in a positive, TRUE, or negative, FALSE direction from the starting parameter.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double


IGeCurve::ParameterOf Method
Summary

Calculates the parameter value on this curve, which corresponds to the specified point.

Visual Basic
Sub ParameterOf(Point As IGePoint, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the parameter value. It should lie on the curve within the specified tolerance; otherwise, the results may be unpredictable.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double


IGeCurve::Project Method
Summary

Returns the entity that is the projection of the curve onto the projection plane in the specified direction.

Visual Basic
Sub Project(Plane As IGePlane, Direction As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Entity As [out, retval] IGeEntity*)
Parameters
Parameters
Description
Plane
GePlane object; input-only. Specifies the plane to project this circular arc.
Direction
Variant ( GeVector object); input-only; optional. Specifies the direction in which to project the circular arc. Note that:

  • The projection direction vector must not be parallel to the projection plane.
  • If the projection direction is not provided, an orthogonal projection onto the specified plane is performed.

Tolerance
Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeEntity object

Remarks

The returned entity may not be of the same type as the original curve and may not even be a curve. For instance, a line will project into a point if it is parallel to the project direction.


IGeCurve::Reverse Method
Summary

Reverses the parametric direction of the curve.

Visual Basic
Sub Reverse()
Returns

None

Remarks

The point set of the curve is unchanged, but the direction of the curve is reversed.


IGeCurveBoundaries Interface
Summary

A collection of GeCurveBoundary objects.

Class Hierarchy

Declaration syntax

IGeCurveBoundaries
Visual Basic
Public Interface IGeCurveBoundaries
Inherits IDispatch
Links
IGeCurveBoundaries Members, GEAuto Library


IGeCurveBoundaries Members
Summary

The following tables list the members exposed by IGeCurveBoundaries.

Methods
Name | Description
Add | Appends a new curve boundary to the collection.
Item | Gets the curve boundary at the specified index.
Remove | Removes the specified curve boundary from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curve boundaries in a curve boundary collection.


IGeCurveBoundaries::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeCurveBoundaries::Count Property
Summary

Gets the total number of the curve boundaries in a curve boundary collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGeCurveBoundaries::Add Method
Summary

Appends a new curve boundary to the collection.

Visual Basic
Sub Add(Boundary As IGeCurveBoundary)
Parameters
Parameters | Description
Boundary | GeCurveBoundary object; input-only. Specifies the new curve boundary to add to the collection.
Returns

None


IGeCurveBoundaries::Item Method
Summary

Gets the curve boundary at the specified index.

Visual Basic
Sub Item(Index As long, Boundary As [out, retval] IGeCurveBoundary*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the curve boundary to get from the collection.
Returns

GeCurveBoundary object


IGeCurveBoundaries::Remove Method
Summary

Removes the specified curve boundary from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the curve boundary to be removed.
Returns

None


IGeCurveBoundary Interface
Summary

A representation for one of a surface's boundaries.

Class Hierarchy

Declaration syntax

IGeCurveBoundary
Visual Basic
Public Interface IGeCurveBoundary
Inherits IDispatch
Links
IGeCurveBoundary Members, GEAuto Library


IGeCurveBoundary Members
Summary

The following tables list the members exposed by IGeCurveBoundary.

Methods
Name | Description
GetBoundary | Gets the three space and parameter space curves and their corresponding logical orientation.
IsDegenerate | Determines whether the curve boundary consists of a single element and is degenerate to a point, TRUE, or not, FALSE.
SetBoundary | Sets the 3D and parameter space curves and their corresponding logical orientation that make up the curve boundary.
Properties
Name | Description
Application | Gets the GeApplication object.
Elements | Gets the number of elements that make up the curve boundary.
Geometry2d | Gets the 2D parameter space geometry for the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Geometry3d | Gets the 3D geometry that makes up the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Orientation2d | Gets the logical orientation or sense of the 2D parameter space geometry for the curve boundary.
Orientation3d | Gets the logical orientation or sense of the 3D geometry for the curve boundary.


IGeCurveBoundary::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeCurveBoundary::Elements Property
Summary

Gets the number of elements that make up the curve boundary.

Visual Basic
Property Elements() As long*
Remarks

This property is a Long.


IGeCurveBoundary::Geometry2d Property
Summary

Gets the 2D parameter space geometry for the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.

Visual Basic
Property Geometry2d() As VARIANT*
Remarks

This property is a Variant (array of GeCurve objects).


IGeCurveBoundary::Geometry3d Property
Summary

Gets the 3D geometry that makes up the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.

Visual Basic
Property Geometry3d() As VARIANT*
Remarks

This property is a Variant (array of GeCurve or GePoint objects).


IGeCurveBoundary::Orientation2d Property
Summary

Gets the logical orientation or sense of the 2D parameter space geometry for the curve boundary.

Visual Basic
Property Orientation2d() As VARIANT*
Remarks

This property is a Variant (array of Booleans).


IGeCurveBoundary::Orientation3d Property
Summary

Gets the logical orientation or sense of the 3D geometry for the curve boundary.

Visual Basic
Property Orientation3d() As VARIANT*
Remarks

This property is a Variant (array of Booleans).


IGeCurveBoundary::GetBoundary Method
Summary

Gets the three space and parameter space curves and their corresponding logical orientation.

Visual Basic
Sub GetBoundary(ByRef Geometry3d As VARIANT, ByRef Geometry2d As VARIANT, ByRef Orientation3d As VARIANT, ByRef Orientation2d As VARIANT)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); output-only. Specifies the 3D space curves or points on a curve boundary.
Geometry2d | Variant (array of GeCurve objects); output-only. Specifies the 2D space curves on a curve boundary.
Orientation3d | Variant (array of Booleans); output-only. Specifies the logical orientation of the corresponding curve or point defined in the Geometry3d element.
Orientation2d | Variant (array of Booleans); output-only. Specifies the logical orientation of the corresponding curves defined in the Geometry2d element.
Returns

None


IGeCurveBoundary::IsDegenerate Method
Summary

Determines whether the curve boundary consists of a single element and is degenerate to a point, TRUE, or not, FALSE.

Visual Basic
Sub IsDegenerate(Point As [in, out, optional] VARIANT, Curve As [in, out, optional] VARIANT, Degenerate As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); output-only; optional. Specifies the point that the curve boundary degenerates to. This element will only be set when this method returns TRUE.
Curve | Variant ( GeCurve object); output-only; optional. Specifies the parameter space curve on the curve boundary that would degenerate to the point when evaluated. This element will only be set when the method returns TRUE.
Returns

Boolean


IGeCurveBoundary::SetBoundary Method
Summary

Sets the 3D and parameter space curves and their corresponding logical orientation that make up the curve boundary.

Visual Basic
Sub SetBoundary(Geometry3d As VARIANT, Geometry2d As VARIANT, Orientation3d As VARIANT, Orientation2d As VARIANT)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); input-only. Specifies the 3D space curves or points on a curve boundary.
Geometry2d | Variant (array of GeCurve objects); input-only. Specifies the 2D space curves on a curve boundary.
Orientation3d | Variant (array of Booleans); input-only. Specifies the logical orientation of the corresponding curve or point defined in the Geometry3d element.
Orientation2d | Variant (array of Booleans); input-only. Specifies the logical orientation of the corresponding curves defined in the Geometry2d element.
Returns

None

Remarks

The length of the arrays of all four elements must be the same size.


IGeCurveCurveIntersection Interface
Summary

Calculates and provides access to the intersection properties between two curves. This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.

Class Hierarchy

Declaration syntax

IGeCurveCurveIntersection
Visual Basic
Public Interface IGeCurveCurveIntersection
Inherits IDispatch
Links
IGeCurveCurveIntersection Members, GEAuto Library


IGeCurveCurveIntersection Members
Summary

The following tables list the members exposed by IGeCurveCurveIntersection.

Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the parameter value of the intersection point.
GetOverlapRanges | Gets the interval ranges of overlap for the specified interval of overlap for two curves being intersected.
IntersectionPoint | Gets the intersection point at the specified intersection index.
IntersectionPointTolerance | Gets the tolerance used to find the point at the specified intersection index.
IsTangential | Gets whether the intersection is tangential at the specified intersection index, TRUE, or not, FALSE.
IsTransversal | Gets whether the intersection is transversal at the specified intersection index, TRUE, or not, FALSE.
ParameterOnCurve1 | Gets the curve parameter value on the first curve at the specified intersection point.
ParameterOnCurve2 | Gets the curve parameter value on the second curve at the specified intersection point.
Set | Sets the two curves being intersected and optionally the tolerance used in the calculation and the interval ranges on the corresponding curves to be considered in the calculation.
Properties
Name | Description
Curve1 | Specifies the first curve operand for intersection.
Curve2 | Specifies the second curve operand for intersection.
IntersectionPointCount | Gets the number of intersection points.
IntervalRange1 | Specifies the interval range on the first curve that is considered in the intersection calculation.
IntervalRange2 | Specifies the interval range on the second curve that is considered in the intersection calculation.
OverlapCount | Gets the number of overlap intervals between two curves.
OverlapDirection | Gets whether the curves are oriented in the same direction where they overlap, TRUE, or not, FALSE.
Tolerance | Specifies the tolerance used in intersection calculations.


IGeCurveCurveIntersection::Curve1 Property
Summary

Specifies the first curve operand for intersection.

Visual Basic
Property Curve1() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.


IGeCurveCurveIntersection::Curve2 Property
Summary

Specifies the second curve operand for intersection.

Visual Basic
Property Curve2() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.


IGeCurveCurveIntersection::IntersectionPointCount Property
Summary

Gets the number of intersection points.

Visual Basic
Property IntersectionPointCount() As long*
Remarks

This property is a Long.


IGeCurveCurveIntersection::IntervalRange1 Property
Summary

Specifies the interval range on the first curve that is considered in the intersection calculation.

Visual Basic
Property IntervalRange1() As IGeInterval*
Remarks
  • This property is a GeInterval object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.


IGeCurveCurveIntersection::IntervalRange2 Property
Summary

Specifies the interval range on the second curve that is considered in the intersection calculation.

Visual Basic
Property IntervalRange2() As IGeInterval*
Remarks
  • This property is a GeInterval object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.


IGeCurveCurveIntersection::OverlapCount Property
Summary

Gets the number of overlap intervals between two curves.

Visual Basic
Property OverlapCount() As long*
Remarks

This property is a Long.


IGeCurveCurveIntersection::OverlapDirection Property
Summary

Gets whether the curves are oriented in the same direction where they overlap, TRUE, or not, FALSE.

Visual Basic
Property OverlapDirection() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeCurveCurveIntersection::Tolerance Property
Summary

Specifies the tolerance used in intersection calculations.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.


IGeCurveCurveIntersection::GetAllIntersections Method
Summary

Gets all intersection points and the parameters on the intersection operands for every intersection point.

Visual Basic
Sub GetAllIntersections(ByRef Points As IGePoints*, ByRef Curve1Parameters As VARIANT, ByRef Curve2Parameters As VARIANT)
Parameters
Parameters | Description
Points | GePoints collection; output-only. Specifies all intersection points between two curves, Curve1 and Curve2 .
Curve1Parameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the first curve.
Curve2Parameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the second curve.
Returns

None


IGeCurveCurveIntersection::GetIntersectionConfiguration Method
Summary

Gets the characterization of the specified intersection in the neighborhood just above and below the parameter value of the intersection point.

Visual Basic
Sub GetIntersectionConfiguration(Index As long, ByRef Config1WRT2 As GeCurveCurveIntConfiguration, ByRef Config2WRT1 As GeCurveCurveIntConfiguration)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection for which to get the characterization.
Config1WRT2 | GeCurveCurveIntConfiguration enumeration; output-only. Specifies the configuration of the first curve with respect to the second curve at the intersection point. For instance, if the returned configuration of Config1WRT2 is geRightLeft, it indicates that the first curve crosses the second curve from right to left with respect to the second curve and with respect to the curve plane's normal.
Config2WRT1 | GeCurveCurveIntConfiguration enumeration; output-only. Specifies the configuration of the second curve with respect to the first curve at the intersection point. For instance, if the returned configuration of Config2WRT1 is geRightLeft, it indicates that the second curve crosses the first curve from right to left with respect to the first curve and with respect to the curve plane's normal.
Returns

None

Remarks

This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.


IGeCurveCurveIntersection::GetOverlapRanges Method
Summary

Gets the interval ranges of overlap for the specified interval of overlap for two curves being intersected.

Visual Basic
Sub GetOverlapRanges(Index As long, ByRef Range1 As IGeInterval*, ByRef Range2 As IGeInterval*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an overlap interval for which to get the interval range.
Range1 | GeInterval object; output-only. Specifies the interval range on the first curve, <ICurve1> .
Range2 | GeInterval object; output-only. Specifies the interval range on the second curve, <ICurve2> .
Returns

None


IGeCurveCurveIntersection::IntersectionPoint Method
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for which to get the intersection point.
Remarks

This property is a GePoint object.


IGeCurveCurveIntersection::IntersectionPointTolerance Method
Summary

Gets the tolerance used to find the point at the specified intersection index.

Visual Basic
Sub IntersectionPointTolerance(Index As long, Tolerance As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the intersection for which to get the calculation tolerance.
Remarks

This property is a Double.


IGeCurveCurveIntersection::IsTangential Method
Summary

Gets whether the intersection is tangential at the specified intersection index, TRUE, or not, FALSE.

Visual Basic
Sub IsTangential(Index As long, Tangential As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the check.
Remarks

This property is a Boolean.


IGeCurveCurveIntersection::IsTransversal Method
Summary

Gets whether the intersection is transversal at the specified intersection index, TRUE, or not, FALSE.

Visual Basic
Sub IsTransversal(Index As long, Transversal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the check.
Remarks

This property is a Boolean.


IGeCurveCurveIntersection::ParameterOnCurve1 Method
Summary

Gets the curve parameter value on the first curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve1(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.


IGeCurveCurveIntersection::ParameterOnCurve2 Method
Summary

Gets the curve parameter value on the second curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve2(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.


IGeCurveCurveIntersection::Set Method
Summary

Sets the two curves being intersected and optionally the tolerance used in the calculation and the interval ranges on the corresponding curves to be considered in the calculation.

Visual Basic
Sub Set(Curve1 As IGeCurve, Curve2 As IGeCurve, Range1 As [in, optional] VARIANT, Range2 As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve for intersection. This element can be later obtained by the GeCurveCurveIntersection > Curve1 property.
Curve2 | GeCurve object; input-only. Specifies the second curve for intersection. This element can be later obtained by the GeCurveCurveIntersection > Curve2 property.
Range1 | GeInterval object; input-only. Specifies the interval range on the first curve. This element can be later obtained by the GeCurveCurveIntersection > IntervalRange1 property.
Range2 | GeInterval object; input-only. Specifies the interval range on the second curve. This element can be later obtained by the GeCurveCurveIntersection > IntervalRange2 property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks

If either optional interval range is specified they both must be specified.


IGeCurves Interface
Summary

A collection of GeCurve objects.

Class Hierarchy

Declaration syntax

IGeCurves
Visual Basic
Public Interface IGeCurves
Inherits IDispatch
Links
IGeCurves Members, GEAuto Library


IGeCurves Members
Summary

The following tables list the members exposed by IGeCurves.

Methods
Name | Description
Add | Appends a new curve to the collection.
Item | Gets the curve at the specified index.
Remove | Removes the specified curve from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curves in a curve collection.


IGeCurves::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeCurves::Count Property
Summary

Gets the total number of the curves in a curve collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGeCurves::Add Method
Summary

Appends a new curve to the collection.

Visual Basic
Sub Add(Curve As IGeCurve)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the new curve to add to the collection.
Returns

None


IGeCurves::Item Method
Summary

Gets the curve at the specified index.

Visual Basic
Sub Item(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the curve to get from the collection.
Returns

GeCurve object


IGeCurves::Remove Method
Summary

Removes the specified curve from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the curve to be removed.
Returns

None


IGeCurveSurfaceIntersection Interface
Summary

Calculates and provides access to the intersection properties between a curve and a surface.

Class Hierarchy

Declaration syntax

IGeCurveSurfaceIntersection
Visual Basic
Public Interface IGeCurveSurfaceIntersection
Inherits IDispatch
Links
IGeCurveSurfaceIntersection Members, GEAuto Library


IGeCurveSurfaceIntersection Members
Summary

The following tables list the members exposed by IGeCurveSurfaceIntersection.

Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the intersection with respect to the curve parameterization.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterOnCurve | Gets the parameter values on the curve at the specified intersection point.
ParameterOnSurface | Gets the parameter values on the surface at the specified intersection point.
Set | Sets the curve and surface being intersected and optionally the tolerance used in the calculation.
Properties
Name | Description
Curve | Specifies the curve for intersection.
IntersectionPointCount | Gets the number of intersection points.
Surface | Specifies the surface for intersection.
Tolerance | Specifies the tolerance used in intersection calculations.


IGeCurveSurfaceIntersection::Curve Property
Summary

Specifies the curve for intersection.

Visual Basic
Property Curve() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveSurfaceIntersection > Set method.


IGeCurveSurfaceIntersection::IntersectionPointCount Property
Summary

Gets the number of intersection points.

Visual Basic
Property IntersectionPointCount() As long*
Remarks

This property is a Long.


IGeCurveSurfaceIntersection::Surface Property
Summary

Specifies the surface for intersection.

Visual Basic
Property Surface() As IGeSurface*
Remarks
  • This property is a GeSurface object.
  • This property is a determined by the GeCurveSurfaceIntersection > Set method.


IGeCurveSurfaceIntersection::Tolerance Property
Summary

Specifies the tolerance used in intersection calculations.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.


IGeCurveSurfaceIntersection::GetAllIntersections Method
Summary

Gets all intersection points and the parameters on the intersection operands for every intersection point.

Visual Basic
Sub GetAllIntersections(ByRef Points As IGePoints*, ByRef CurveParameters As VARIANT, ByRef SurfaceParameters As IGePoints*)
Parameters
Parameters | Description
Points | GePoints collection; output-only. Specifies all intersection points between the curve and the surface.
CurveParameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the curve.
SurfaceParameters | GePoints collection; output-only. Specifies the 2D parameter space points on the intersection operands for every intersection point on the surface.
Returns

None


IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method
Summary

Gets the characterization of the specified intersection in the neighborhood just above and below the intersection with respect to the curve parameterization.

Visual Basic
Sub GetIntersectionConfiguration(Index As long, ByRef Lower As GeCurveSurfIntConfiguration, ByRef Upper As GeCurveSurfIntConfiguration, ByRef SmallAngle As VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection for which to get the intersection characterization.
Lower | GeCurveSurfIntConfiguration enumeration; output-only. Specifies the characterization of the intersection in the neighborhood below the intersection with respect to the curve parameterization.
Upper | GeCurveSurfIntConfiguration enumeration; output-only. Specifies the characterization of the intersection in the neighborhood above the intersection with respect to the curve parameterization.
SmallAngle | Boolean; input-only.
Returns

None

Remarks

If an intersection is not empty, coincident or tangent, it is transverse.


IGeCurveSurfaceIntersection::IntersectionPoint Method
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for which to get the intersection point.
Remarks

This property is a GePoint object.


IGeCurveSurfaceIntersection::ParameterOnCurve Method
Summary

Gets the parameter values on the curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.


IGeCurveSurfaceIntersection::ParameterOnSurface Method
Summary

Gets the parameter values on the surface at the specified intersection point.

Visual Basic
Sub ParameterOnSurface(Index As long, Parameters As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.


IGeCurveSurfaceIntersection::Set Method
Summary

Sets the curve and surface being intersected and optionally the tolerance used in the calculation.

Visual Basic
Sub Set(Curve As IGeCurve, Surface As IGeSurface, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve for intersection. This element can be later obtained by the GeCurveSurfaceIntersection > Curve property.
Surface | GeSurface object; input-only. Specifies the surface for intersection. This element can be later obtained by the GeCurveSurfaceIntersection > Surface property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None


IGeCylinder Interface
Summary

A cylindrical surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeCylinder
Visual Basic
Public Interface IGeCylinder
Inherits IGeSurface
Links
IGeCylinder Members, GEAuto Library


IGeCylinder Members
Summary

The following tables list the members exposed by IGeCylinder.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the cylinder and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cylinder by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cylinder.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
Height | Specifies the parameter interval height of the cylinder.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cylinder.
Radius | Specifies the radius of the cylinder.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cylinder.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeCylinder::AxisOfSymmetry Property
Summary

Specifies the axis of symmetry of this cylinder.

Visual Basic
Property AxisOfSymmetry() As IGeVector**


IGeCylinder::EndAngle Property
Summary

Specifies the angle of the end point with respect to the reference vector in the base of the cone.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.


IGeCylinder::Height Property
Summary

Specifies the parameter interval height of the cylinder.

Visual Basic
Property Height() As IGeInterval*
Remarks

This property is a GeInterval object.


IGeCylinder::Origin Property
Summary

Gets the center of the base of the cylinder.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.


IGeCylinder::Radius Property
Summary

Specifies the radius of the cylinder.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.


IGeCylinder::ReferenceVector Property
Summary

Specifies the reference vector from which the start angle and end angle are measured.

Visual Basic
Property ReferenceVector() As IGeVector**
Remarks

This property is a GeVector object.


IGeCylinder::StartAngle Property
Summary

Specifies the angle of the start point with respect to the reference vector in the base of the cylinder.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.


IGeCylinder::IntersectWith Method
Summary

Computes the intersection between the cylinder and a linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this cylinder.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.


IGeCylinder::Set Method
Summary

Changes the definition of this cylinder by the specified parameters.

Visual Basic
Sub Set(Radius As double, Center As IGePoint, SymmetryAxis As IGeVector, ReferenceAxis As [in, optional] VARIANT, Height As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Radius | Double; input-only. Specifies the radius of the cylinder.
Center | GePoint object; input-only. Specifies the center point of the circular base.
SymmetryAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cylinder.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

None


IGeEllipticalArc Interface
Summary

An ellipse or elliptical arc.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeEllipticalArc
Visual Basic
Public Interface IGeEllipticalArc
Inherits IGeCurve
Remarks

The angle of a point on the ellipse is measured by drawing a full circle with the same center as the ellipse and radius equal to the ellipse major radius and projecting the point onto the circle along a vector perpendicular to the major axis. If a vector is then drawn from the ellipse center to this projected point, the angle between the major axis and this vector (measured counterclockwise about the cross product of the major and minor axes) is the angle of the point on the ellipse. endAngle must be greater than startAngle. To construct a full ellipse, the difference between EndAngle and StartAngle should be 2*pi.

Links
IGeEllipticalArc Members, GEAuto Library


IGeEllipticalArc Members
Summary

The following tables list the members exposed by IGeEllipticalArc.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this elliptical arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the elliptical arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the elliptical arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the elliptical arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.
EndPoint | Gets the end point of this elliptical arc.
Interval | Sets the interval of the curve and returns the index of the interval.
IsCircular | Gets whether the ellipse is a circular arc, TRUE, or not, FALSE.
MajorAxis | Specifies the major axis of the ellipse.
MajorRadius | Specifies the major radius of the ellipse.
MinorAxis | Specifies the minor axis of the ellipse.
MinorRadius | Specifies the minor radius of the ellipse.
Normal | Specifies the normal vector of this elliptical arc.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.
StartPoint | Gets the start point of this elliptical arc.


IGeEllipticalArc::Center Property
Summary

Specifies the center point of the elliptical arc.

Visual Basic
Property Center() As IGePoint*
Remarks

This property is a GePoint object.


IGeEllipticalArc::EndAngle Property
Summary

Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.

Visual Basic
Property EndAngle() As double
Remarks

Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.


IGeEllipticalArc::EndPoint Property
Summary

Gets the end point of this elliptical arc.

Visual Basic
Property EndPoint() As IGePoint**
Remarks

This property is a GePoint object.


IGeEllipticalArc::IsCircular Property
Summary

Gets whether the ellipse is a circular arc, TRUE, or not, FALSE.

Visual Basic
Property IsCircular() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeEllipticalArc::MajorAxis Property
Summary

Specifies the major axis of the ellipse.

Visual Basic
Property MajorAxis() As IGeVector*
Remarks

This property is a GeVector object.


IGeEllipticalArc::MajorRadius Property
Summary

Specifies the major radius of the ellipse.

Visual Basic
Property MajorRadius() As double
Remarks

This property is a Double.


IGeEllipticalArc::MinorAxis Property
Summary

Specifies the minor axis of the ellipse.

Visual Basic
Property MinorAxis() As IGeVector*
Remarks

This property is a GeVector object.


IGeEllipticalArc::MinorRadius Property
Summary

Specifies the minor radius of the ellipse.

Visual Basic
Property MinorRadius() As double
Remarks

This property is a Double.


IGeEllipticalArc::Normal Property
Summary

Specifies the normal vector of this elliptical arc.

Visual Basic
Property Normal() As IGeVector**
Remarks

This property is a GeVector object.


IGeEllipticalArc::StartAngle Property
Summary

Specifies the angle of the start point with respect to the reference vector in the plane of the arc.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.


IGeEllipticalArc::StartPoint Property
Summary

Gets the start point of this elliptical arc.

Visual Basic
Property StartPoint() As IGePoint**
Remarks

This property is a GePoint object.


IGeEllipticalArc::IntersectWith Method
Summary

Determines whether the specified geometry entity intersects with this elliptical arc, TRUE, or not, FALSE. They do not need to lie in the same plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, ProjectionDirection As [in, optional] VARIANT, LinePoint1 As [in, out, optional] VARIANT, LinePoint2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeCircularArc , GeLinearEntity, or GePlane object.
Intersections | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
ProjectionDirection | Variant ( GeVector object); input-only; optional. Specifies the normal of a plane that this elliptical arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when the GeEntity element is a GeLinearEntity.
LinePoint1 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
LinePoint2 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeEllipticalArc::IsInside Method
Summary

Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the elliptical arc, FALSE.

Visual Basic
Sub IsInside(Point As IGePoint, Tolerance As [in, optional] VARIANT, Inside As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

This method treats the arc as a full circle or ellipse even if it is bounded and determines if the specified point lies inside of the full circle or ellipse.


IGeEllipticalArc::Set Method
Summary

Sets the elliptical arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.

Visual Basic
Sub Set(Center As IGePoint, MajorAxis As IGeVector, MinorAxis As IGeVector, MajorRadius As double, MinorRadius As double, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Center | GePoint object; input-only. Specifies the center point of the elliptical arc.
MajorAxis | GeVector object; input-only. Specifies the major axis of the ellipse.
MinorAxis | GeVector object; input-only. Specifies the minor axis of the ellipse.
MajorRadius | Double; input-only. Specifies the major radius of the ellipse.
MinorRadius | Double; input-only. Specifies the minor radius of the ellipse.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the elliptical arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the elliptical arc.
Returns

None

Remarks

If the reference vector, start or end angles are specified, they all must be specified.


IGeEntities Interface
Summary

A collection of GeEntity objects.

Class Hierarchy

Declaration syntax

IGeEntities
Visual Basic
Public Interface IGeEntities
Inherits IDispatch
Links
IGeEntities Members, GEAuto Library


IGeEntities Members
Summary

The following tables list the members exposed by IGeEntities.

Methods
Name | Description
Add | Appends a new geometry entity to the collection.
Item | Gets the geometry entity at the specified index.
Remove | Removes the specified geometry entity from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the geometry entities in a geometry entity collection.


IGeEntities::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeEntities::Count Property
Summary

Gets the total number of the geometry entities in a geometry entity collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGeEntities::Add Method
Summary

Appends a new geometry entity to the collection.

Visual Basic
Sub Add(Entity As IGeEntity)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the new geometry entity to add to the collection.
Returns

None


IGeEntities::Item Method
Summary

Gets the geometry entity at the specified index.

Visual Basic
Sub Item(Index As long, Entity As [out, retval] IGeEntity*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the geometry entity to get from the collection.
Returns

GeEntity object


IGeEntities::Remove Method
Summary

Removes the specified geometry entity from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the geometry entity to be removed.
Returns

None


IGeEntity Interface
Summary

A generic geometric entity. Subtypes: GeBoundBlock, IGeCurve, GePoint, IGeSurface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeBoundBlock
    IGeCurve
    IGePoint
    IGeSurface
Visual Basic
Public Interface IGeEntity
Inherits IDispatch
Links
IGeEntity Members, GEAuto Library


IGeEntity Members
Summary

The following tables list the members exposed by IGeEntity.

Methods
Name | Description
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.


IGeEntity::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeEntity::IsEqualTo Method
Summary

Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, IsEqual As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other entity to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

Two entities are considered to be equal only if they are of the same type and they represent the same 3D point set. For instance, if the two entities are of types GeCircularArc and GeEllipticalArc , they are not considered equal even if the ellipse is completely coincident with the circle.


IGeEntity::IsOn Method
Summary

Determines whether the specified point lies on the entity, TRUE, or not, FALSE.

Visual Basic
Sub IsOn(Point As IGePoint, Tolerance As [in, optional] VARIANT, IsOn As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.


IGeEntity::Mirror Method
Summary

Mirrors this entity about the specified plane.

Visual Basic
Sub Mirror(Plane As IGePlane)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane with respect to which this entity is mirrored.
Returns

None


IGeEntity::RotateBy Method
Summary

Rotates this entity around the line with the specified direction vector passing through the specified point.

Visual Basic
Sub RotateBy(Angle As double, Vector As IGeVector, Point As IGePoint)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this polyline. The positive direction of rotation is defined by the right hand rule.
Vector | GeVector object; input-only. Specifies the polar vector to rotate this entity.
Point | GePoint object; input-only. Specifies the base point to rotate this entity.
Returns

None


IGeEntity::ScaleBy Method
Summary

Multiplies this entity by the scale factor.

Visual Basic
Sub ScaleBy(Factor As double, BasePoint As IGePoint)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the scale factor to change the size of this entity.
BasePoint | GePoint object; input-only. Specifies the point that remains in the same location as the selected objects change their sizes and thus move away from the stationary base point.
Returns

None


IGeEntity::TransformBy Method
Summary

Transforms this entity by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As IGeMatrix)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix by which to transform this entity.
Returns

None


IGeEntity::TranslateBy Method
Summary

Translates or moves the entity by the specified translation vector.

Visual Basic
Sub TranslateBy(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the translation vector to translate or move this entity.
Returns

None


IGeInterval Interface
Summary

Represents an interval of the real axis to define bounds.

Class Hierarchy

Declaration syntax

IGeInterval
Visual Basic
Public Interface IGeInterval
Inherits IDispatch
Links
IGeInterval Members, GEAuto Library


IGeInterval Members
Summary

The following tables list the members exposed by IGeInterval.

Methods
Name | Description
Contains | Determines whether the specified parameter value or sub-interval is contained by this interval, TRUE, or not, FALSE.
IsContinuousAtUpper | Determines whether this interval is continuous at the upper bound with the specified interval, TRUE, or not, FALSE.
IsDisjoint | Determines whether the specified interval does not intersect with this interval within this interval's boundary tolerance, TRUE, or not, FALSE.
IsOverlapAtUpper | Determines whether the specified interval overlaps this interval at the upper bound, TRUE, or not, FALSE.
Properties
Name | Description
Application | Gets the GeApplication object.
Bounded | Gets whether the interval is bounded in both directions, TRUE, or not, FALSE.
BoundedAbove | Gets whether the interval has an upper bound, TRUE, or not, FALSE.
BoundedBelow | Gets whether the interval has a lower bound, TRUE, or not, FALSE.
IsSingleton | Gets whether the interval is bounded and the lower and upper bounds are equal, TRUE, or not, FALSE.
IsUnBounded | Gets whether the interval is unbounded, TRUE, or not, FALSE.
Length | Gets the length of the interval.
Lower | Specifies the lower bound of the interval.
Upper | Specifies the upper bound of the interval.


IGeInterval::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeInterval::Bounded Property
Summary

Gets whether the interval is bounded in both directions, TRUE, or not, FALSE.

Visual Basic
Property Bounded() As VARIANT_BOOL
Remarks

This property is a Boolean.


IGeInterval::BoundedAbove Property
Summary

Gets whether the interval has an upper bound, TRUE, or not, FALSE.

Visual Basic
Property BoundedAbove() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeInterval::BoundedBelow Property
Summary

Gets whether the interval has a lower bound, TRUE, or not, FALSE.

Visual Basic
Property BoundedBelow() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeInterval::IsSingleton Property
Summary

Gets whether the interval is bounded and the lower and upper bounds are equal, TRUE, or not, FALSE.

Visual Basic
Property IsSingleton() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeInterval::IsUnBounded Property
Summary

Gets whether the interval is unbounded, TRUE, or not, FALSE.

Visual Basic
Property IsUnBounded() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeInterval::Length Property
Summary

Gets the length of the interval.

Visual Basic
Property Length() As double*
Remarks

  • This property is a Double.
  • This property will only succeed if the interval is bounded.


IGeInterval::Lower Property
Summary

Specifies the lower bound of the interval.

Visual Basic
Property Lower() As double
Remarks

This property is a Double.


IGeInterval::Upper Property
Summary

Specifies the upper bound of the interval.

Visual Basic
Property Upper() As double
Remarks

This property is a Double.


IGeInterval::Contains Method
Summary

Determines whether the specified parameter value or sub-interval is contained by this interval, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Value As VARIANT, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Variant (Double or GeInterval object); input-only. Specifies the parameter value or sub-interval to perform the check.
Returns

Boolean


IGeInterval::IsContinuousAtUpper Method
Summary

Determines whether this interval is continuous at the upper bound with the specified interval, TRUE, or not, FALSE.

Visual Basic
Sub IsContinuousAtUpper(Interval As IGeInterval, Continuous As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
Returns

Boolean

Remarks

This method returns TRUE when:

  • This interval is bounded above.
  • The specified interval is bounded below.
  • The upper bound of this interval is equal to the lower bound of the specified interval within the boundary tolerance of this interval


IGeInterval::IsDisjoint Method
Summary

Determines whether the specified interval does not intersect with this interval within this interval's boundary tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsDisjoint(Interval As IGeInterval, Disjoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
Returns

Boolean


IGeInterval::IsOverlapAtUpper Method
Summary

Determines whether the specified interval overlaps this interval at the upper bound, TRUE, or not, FALSE.

Visual Basic
Sub IsOverlapAtUpper(Interval As IGeInterval, OverlapInterval As [in, out, optional] VARIANT, Overlap As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
OverlapInterval | Variant ( GeInterval object); output-only; optional. Specifies the overlapped segment between two intervals. This element will only bet set when this method returns TRUE.
Remarks

This method returns TRUE when:

  • This interval is bounded above.
  • The specified interval is bounded below.
  • Both intervals are not singleton .
  • Their intersection is not empty and does not coincide with this interval.
  • The upper bound of this interval is contained in the specified interval, and the lower bound of the specified interval is contained in this interval.


IGeKnotVector Interface
Summary

An ordered sequence knot values making up a knot vector for NURB entities.

Class Hierarchy

Declaration syntax

IGeKnotVector
Visual Basic
Public Interface IGeKnotVector
Inherits IDispatch
Remarks

The intervals between two consecutive knots partition a spline into polynomial or rational pieces.

Links
IGeKnotVector Members, GEAuto Library


IGeKnotVector Members
Summary

The following tables list the members exposed by IGeKnotVector.

Methods
Name | Description
AddKnot | Appends the specified value to the knot vector.
AddKnotVector | Performs a linear transformation (k = a * k + b), with appropriate coefficients a and b, on this vector and on tail vector.
Contains | Determines whether the specified parameter is within the range of the first and last knot value, TRUE, or not, FALSE.
Insert | Inserts the specified value into the appropriate knot interval.
InsertKnot | Inserts the specified value into the knot vector at the specified index.
Interval | Computes the knot interval containing the specified parameter and returns the index of the knot interval.
IsEqualTo | Determines whether this knot vector is equal to the specified knot vector, TRUE, or not, FALSE.
Item | Gets the knot value at the specified index.
Item | Gets the knot value at the specified index.
MultiplicityAt | Computes and returns the knot multiplicity of the knot value at the specified index.
RemoveKnotAt | Removes the knot at the specified index.
RemoveRange | Removes all knots within the specified index range.
Reverse | Performs a linear transformation on the knot sequence so the first knot is mapped to the maximal value, and vice versa, the last knot is mapped to the minimal value.
SetRange | Performs a linear transformation k = a * k + b of the knot sequence in order to place all the values between the specified lower and upper values.
Split | Splits the knot sequence at the specified parameter value. The knot value at the end of the first piece and at the beginning of the second piece is inserted or deleted to satisfy the specified multiplicity values.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the knot values as an array of Doubles.
DistinctKnots | Gets the sequence of all knot values in the vector without duplicates within the vectors tolerance.
EndParameter | Gets the last knot value of the knot vector.
IsEmpty | Gets whether the knot vector is empty, TRUE, or not, FALSE.
Length | Gets the length of the knot values of the knot vector.
NumberOfIntervals | Gets the number of the non-zero intervals between knots.
StartParameter | Gets the first knot value of the knot vector.
Tolerance | Specifies the knot value tolerance used by the knot vector.


IGeKnotVector::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeKnotVector::AsArray Property
Summary

Specifies the knot values as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).


IGeKnotVector::DistinctKnots Property
Summary

Gets the sequence of all knot values in the vector without duplicates within the vectors tolerance.

Visual Basic
Property DistinctKnots() As VARIANT*
Remarks

This property is a Variant (array of Doubles).


IGeKnotVector::EndParameter Property
Summary

Gets the last knot value of the knot vector.

Visual Basic
Property EndParameter() As double*
Remarks

This property is a Double.


IGeKnotVector::IsEmpty Property
Summary

Gets whether the knot vector is empty, TRUE, or not, FALSE.

Visual Basic
Property IsEmpty() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeKnotVector::Length Property
Summary

Gets the length of the knot values of the knot vector.

Visual Basic
Property Length() As long*
Remarks

This property is a Long.


IGeKnotVector::NumberOfIntervals Property
Summary

Gets the number of the non-zero intervals between knots.

Visual Basic
Property NumberOfIntervals() As long*
Remarks

This property is a Long.


IGeKnotVector::StartParameter Property
Summary

Gets the first knot value of the knot vector.

Visual Basic
Property StartParameter() As double*
Remarks

This property is a Double.


IGeKnotVector::Tolerance Property
Summary

Specifies the knot value tolerance used by the knot vector.

Visual Basic
Property Tolerance() As double
Remarks

This property is a Double.


IGeKnotVector::AddKnot Method
Summary

Appends the specified value to the knot vector.

Visual Basic
Sub AddKnot(Value As double, Index As [out, retval] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to append to the knot vector.
Returns

Long


IGeKnotVector::AddKnotVector Method
Summary

Performs a linear transformation (k = a * k + b), with appropriate coefficients a and b, on this vector and on tail vector.

Visual Basic
Sub AddKnotVector(Vector As IGeKnotVector, Ratio As [in, defaultvalue(0.0)] double)
Parameters
Parameters | Description
Vector | GeKnotVector object; input-only. Specifies the knot vector based on which to perform the linear transformation.
Ratio | Double, the default value is 0.0; input-only; optional. Specifies the ratio for the knot vector. If the knot ratio is zero, no scaling takes place and this vector is appended with the tail part.
Returns

None

Remarks

The ratio of their lengths becomes equal to specified knot ratio and the tail sequence immediately follows this vector.


IGeKnotVector::Contains Method
Summary

Determines whether the specified parameter is within the range of the first and last knot value, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Value As double, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Variant (Double); input-only. Specifies the parameter to perform the check.
Returns

Boolean


IGeKnotVector::Insert Method
Summary

Inserts the specified value into the appropriate knot interval.

Visual Basic
Sub Insert(Value As double)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to insert.
Returns

None


IGeKnotVector::InsertKnot Method
Summary

Inserts the specified value into the knot vector at the specified index.

Visual Basic
Sub InsertKnot(Value As double, Index As long, Multplicity As [in, defaultvalue(1)] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to insert.
Index | Integer; input-only. Specifies the index for the knot vector.
Multiplicity | Integer, the default value is 1; input-only; optional. Specifies the multiplicity to increment the knot. If the specified value is within the knot vectors tolerance of an existing knot value, the multiplicity of the knot is incremented by one.
Returns

None


IGeKnotVector::Interval Method
Summary

Computes the knot interval containing the specified parameter and returns the index of the knot interval.

Visual Basic
Sub Interval(Order As long, Value As double, ByRef Interval As IGeInterval*, Index As [out, retval] long)
Parameters
Parameters | Description
Order | Integer; input-only. Specifies the order of the spline.
Value | Double; input-only. Specifies the parameter value contained in the knot interval. The parameter must be between the knot values indexed by (order - 1) and (number of knots - order), where order is the spline order.
Interval | GeInterval object; output-only. Specifies the knot interval containing the parameter.
Returns

Long


IGeKnotVector::IsEqualTo Method
Summary

Determines whether this knot vector is equal to the specified knot vector, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Vector As IGeKnotVector, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeKnotVector object; input-only. Specifies the other knot vector to perform the check.
Returns

Boolean

Remarks

Two entities are considered to be equal only if they are of the same type and they represent the same 3d point set.


IGeKnotVector::Item Method ([in] long, [in] double)
Summary

Gets the knot value at the specified index.

Visual Basic
Sub Item(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to perform the calculation.
Remarks

This property is a Double.


IGeKnotVector::Item Method ([in] long, [out, retval] double*)
Summary

Gets the knot value at the specified index.

Visual Basic
Sub Item(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to perform the calculation.
Remarks

This property is a Double.


IGeKnotVector::MultiplicityAt Method
Summary

Computes and returns the knot multiplicity of the knot value at the specified index.

Visual Basic
Sub MultiplicityAt(Index As long, Multiplicity As [out, retval] long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the knot vector to perform the calculation.
Returns

Long

Remarks

If two consecutive knots differ by less than the vectors tolerance they are considered identical and their multiplicities are combined.


IGeKnotVector::RemoveKnotAt Method
Summary

Removes the knot at the specified index.

Visual Basic
Sub RemoveKnotAt(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the knot to remove.
Returns

None


IGeKnotVector::RemoveRange Method
Summary

Removes all knots within the specified index range.

Visual Basic
Sub RemoveRange(Start As long, End As long)
Parameters
Parameters | Description
Start | Integer; input-only. Specifies the start index of the range for the knots to remove.
End | Integer; input-only. Specifies the end index of the range for the knots to remove.
Returns

None


IGeKnotVector::Reverse Method
Summary

Performs a linear transformation on the knot sequence so the first knot is mapped to the maximal value, and vice versa, the last knot is mapped to the minimal value.

Visual Basic
Sub Reverse()
Returns

None

Remarks
  • The first knot in the new sequence is the image of the largest knot of the original vector, the second one is the image of the second to the largest one, and so on.
  • The knot vector boundaries remain the same.


IGeKnotVector::SetRange Method
Summary

Performs a linear transformation k = a * k + b of the knot sequence in order to place all the values between the specified lower and upper values.

Visual Basic
Sub SetRange(Lower As double, Upper As double)
Parameters
Parameters | Description
Lower | Double; input-only. Specifies the lower value to perform the linear transformation.
Upper | Double; input-only. Specifies the upper value to perform the linear transformation.
Returns

None


IGeKnotVector::Split Method
Summary

Splits the knot sequence at the specified parameter value. The knot value at the end of the first piece and at the beginning of the second piece is inserted or deleted to satisfy the specified multiplicity values.

Visual Basic
Sub Split(Value As double, ByRef Head As IGeKnotVector*, HeadMultiplicity As long, ByRef Tail As IGeKnotVector*, TailMultiplicity As long, Index As [out, retval] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the parameter value at which to split the knot sequence.
Head | GeKnotVector object; output-only. Specifies the first piece of the knot sequence.
HeadMultiplicity | Long; input-only. Specifies the multiplicity for the first piece of the knot sequence.
Tail | GeKnotVector object; output-only. Specifies the second piece of the knot sequence.
TailMultiplicity | Long; input-only. Specifies the multiplicity for the second piece of the knot sequence.
Returns

Long


IGeLine Interface
Summary

An unbounded line.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine
Visual Basic
Public Interface IGeLine
Inherits IGeLinearEntity
Links
IGeLine Members, GEAuto Library


IGeLine Members
Summary

The following tables list the members exposed by IGeLine.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


IGeLine::Set Method
Summary

Changes the definition of the line to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this line passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this ray respects on the specified point.
Returns

None


IGeLinearEntity Interface
Summary

A generic linear entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine
            IGeLineSegment
            IGeRay
Visual Basic
Public Interface IGeLinearEntity
Inherits IGeCurve
Links
IGeLinearEntity Members, GEAuto Library


IGeLinearEntity Members
Summary

The following tables list the members exposed by IGeLinearEntity.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


IGeLinearEntity::Direction Property
Summary

Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.

Visual Basic
Property Direction() As IGeVector**


IGeLinearEntity::PointOnLine Property
Summary

Gets an arbitrary point on the linear entity.

Visual Basic
Property PointOnLine() As IGePoint**


IGeLinearEntity::IntersectWith Method
Summary

For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Point As IGePoint*, Direction As [in, optional] VARIANT, Point2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | .
Point | .
Direction | .
Point2 | .
Tolerance | .
Remarks

If this method returns TRUE then Intersections will be set to either 1 or 2, otherwise it will be set to 0. Point1 will only be set if the number of intersection is greater than zero, and Point2 will only be set if the number of intersections is greater than one. The two arcs do not need to lie in the same plane. The optional projection direction can be used to specify the normal of a plane that this arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when Curve is a GeLinearEntity. LinePoint1 and LinePoint2 return the possible intersection points on the linear entity when using the projection direction option.

For GeLinearEntity objects: Determines whether the line intersects with the specified linear or plane entity. The Point value is only set if this method returns TRUE. The optional projection direction can be used to specify the normal of a plane that this and the specified linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the linear entities. This option is only available when Entity is a GeLinearEntity. The LinePoint element returns the intersection point on the other linear entity when using the projection direction option.

For GeCone and GeCylinder objects: Computes the intersection between the cone, cylinder, or elliptical arc and a linear entity. The method returns False if there is no intersection.

For GePlane objects: Computes the intersection between the plane and the specified linear entity or other plane.

For GeSphere objects: Computes the intersection between the sphere and the specified linear entity.

For GeTorus objects: Computes the intersection between the torus and the specified linear entity.


IGeLinearEntity::IsColinearTo Method
Summary

Determines if this line is collinear to the specified line.

Visual Basic
Sub IsColinearTo(Line As IGeLinearEntity, Tolerance As [in, optional] VARIANT, Colinear As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Line GeLinearEntity object; input-only .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .


IGeLinearEntity::IsOnPlane Method
Summary

Determines if the line lies on the specified plane.

Visual Basic
Sub IsOnPlane(Plane As IGePlane, Tolerance As [in, optional] VARIANT, OnPlane As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Plane | Plane GePlane object; input-only .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .


IGeLinearEntity::IsParallelTo Method
Summary

Determines if the specified entity is parallel to this entity.

Visual Basic
Sub IsParallelTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Entity GeLinearEntity or GePlane object; input-only; .Entity GeVector object; input-only; .Entity GePlane or GeLinearEntity object; input-only; .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .


IGeLinearEntity::IsPerpendicularTo Method
Summary

For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.

Visual Basic
Sub IsPerpendicularTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Entity GeLinearEntity or GePlane object; input-only; .Entity GeVector object; input-only; .Entity GeLinearEntity or GePlane object; input-only; .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .


IGeLinearEntity::Overlap Method
Summary

Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.

Visual Basic
Sub Overlap(Line As IGeLinearEntity, ByRef Overlap As IGeLinearEntity*, Tolerance As [in, optional] VARIANT, DoOverlap As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Line GeLinearEntity object; input-only. The linear entity to check for overlap.
Overlap | Overlap GeLinearEntity object. The region of overlap.
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional. The tolerance used in the calculation.


IGeLinearEntity::PerpendicularPlane Method
Summary

Calculates a plane perpendicular to the line at the specified point

Visual Basic
Sub PerpendicularPlane(Point As IGePoint, Plane As [out, retval] IGePlane*)
Parameters
Parameters | Description
Point | Point GePoint object; input-only.


IGeLineSegment Interface
Summary

A bounded line segment.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLineSegment
Visual Basic
Public Interface IGeLineSegment
Inherits IGeLinearEntity
Links
IGeLineSegment Members, GEAuto Library


IGeLineSegment Members
Summary

The following tables list the members exposed by IGeLineSegment.

Methods
Name | Description
BaryComb | Returns the point that is the weighted average of the start and end points of the line segment.
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line segment to pass through the specified point in the direction of the specified vector.
TangentTangent | Changes the definition of the line segment so that the line segment is tangent to the two input curves.
TangentTo | Changes the definition of the line segment so that the line segment passes through the specified point and is tangent to the specified curve.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Bisector | Gets the unbounded plane that is perpendicular to the line segment and passes through its midpoint.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
EndPoint | Specifies the end point of the line segment.
Interval | Sets the interval of the curve and returns the index of the interval.
MidPoint | Gets the midpoint of the line segment.
PointOnLine | Gets an arbitrary point on the linear entity.
StartPoint | Specifies the start point of the line segment.


IGeLineSegment::Bisector Property
Summary

Gets the unbounded plane that is perpendicular to the line segment and passes through its midpoint.

Visual Basic
Property Bisector() As IGePlane**
Remarks

This property is a GePlane object.


IGeLineSegment::EndPoint Property
Summary

Specifies the end point of the line segment.

Visual Basic
Property EndPoint() As IGePoint*
Remarks

This property is a GePoint object.


IGeLineSegment::MidPoint Property
Summary

Gets the midpoint of the line segment.

Visual Basic
Property MidPoint() As IGePoint**
Remarks

This property is a GePoint object.


IGeLineSegment::StartPoint Property
Summary

Specifies the start point of the line segment.

Visual Basic
Property StartPoint() As IGePoint*
Remarks

This property is a GePoint object.


IGeLineSegment::BaryComb Method
Summary

Returns the point that is the weighted average of the start and end points of the line segment.

Visual Basic
Sub BaryComb(BlendCoefficient As double, Point As [out, retval] IGePoint*)
Parameters
Parameters
Description
BlendCoefficient
Double; input-only. Specifies the blend coefficient.

  • If the blend coefficient is zero, this method returns the start point of the line segment.
  • If the blend coefficient is 1, this method returns the end point of the line segment.
  • If the blend coefficient is 0.5, this method returns the midpoint of the line segment.
  • If the blend coefficient is between 0 and 1, the returned point will lie on the line segment; Otherwise the returned point will not lie on the line segment but will lie on the unbounded line that is coincident with the line segment.

Returns

GePoint object


IGeLineSegment::Set Method
Summary

Changes the definition of the line segment to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this ray passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this line segment respects on the specified point.
Returns

None


IGeLineSegment::TangentTangent Method
Summary

Changes the definition of the line segment so that the line segment is tangent to the two input curves.

Visual Basic
Sub TangentTangent(Curve1 As IGeCurve, Curve2 As IGeCurve, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to be tangent to.
Curve2 | GeCurve object; input-only. Specifies the second curve to be tangent to.
Parameter1 | Variant (Double); optional. Specifies the tangent point on the first curve and the initial guess.
Parameter2 | Variant (Double); optional. Specifies the tangent point on the second curve and the initial guess.
Returns

Boolean

Remarks
  • On input, existing values of the Parameter1 and Parameter2 elements are used as initial guess values to the parameters of the two tangent points.
  • If the tangent line segment was computed successfully, the method returns TRUE, otherwise FALSE and the line segment is unchanged.


IGeLineSegment::TangentTo Method
Summary

Changes the definition of the line segment so that the line segment passes through the specified point and is tangent to the specified curve.

Visual Basic
Sub TangentTo(Curve As IGeCurve, Point As IGePoint, Parameter As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to be tangent to.
Point | GePoint object; input-only. Specifies the point for the line segment to pass through.
Parameter | Variant (Double); optional. Specifies the tangent point on the curve and the initial guess.
Returns

Boolean

Remarks
  • The curve must be planar and the specified point must lie on the plane of the curve.
  • On input, any existing value of the Parameter element is used as an initial guess value to the parameter of the tangent point.
  • If the tangent line segment was computed successfully, the method returns TRUE, otherwise FALSE and the line segment is unchanged.


IGeMatrix Interface
Summary

A 4 x 4 matrix representing an affine transformation including translation.

Class Hierarchy

Declaration syntax

IGeMatrix
Visual Basic
Public Interface IGeMatrix
Inherits IDispatch
Links
IGeMatrix Members, GEAuto Library


IGeMatrix Members
Summary

The following tables list the members exposed by IGeMatrix.

Methods
Name | Description
GetCoordinateSystem | Gets the origin point and axis direction vectors of the coordinate system that this matrix maps to.
Invert | Sets the matrix to be equal to its inverse.
IsEqualTo | Determines whether this matrix is equal to the specified matrix within the specified tolerance, TRUE, or not, FALSE.
IsOrthogonal | Gets whether the column vectors of the linear portion of the matrix are orthogonal or perpendicular with each other, TRUE, or not, FALSE.
IsSingular | Gets whether any column vector of the linear portion of the matrix is in zero length or whether any two column vectors of the linear portion of the matrix are parallel, TRUE, or not, FALSE.
IsUniformScaledOrtho | Gets whether this matrix is orthogonal or perpendicular to each other, and uniformly scaled, TRUE, or not, FALSE.
Item | Specifies the matrix element value at the specified row and column.
Item | Specifies the matrix element value at the specified row and column.
PostMultiply | Computes the matrix resulting from this matrix multiplied by the specified matrix.
PreMultiply | Computes the matrix resulting from the specified matrix multiplied by this matrix.
Product | Returns the product of this matrix and the specified matrix.
SetToAlignCoordinateSystem | Sets this matrix to the matrix which maps from one specified coordinate system to another specified coordinate system.
SetToCoordinateSystem | Sets this matrix to the matrix which maps the standard coordinate system with the origin (0, 0, 0) and axes (1, 0, 0), (0, 1, 0) and (0, 0, 1) to the specified coordinate system.
SetToIdentity | Sets this matrix to the identity matrix.
SetToMirroring | Sets this matrix to the matrix of mirroring with respect to the specified entity.
SetToProduct | Sets this matrix to the product of the two specified matrices.
SetToProjection | Sets this matrix to the matrix with the parallel projection into the specified plane.
SetToRotation | Sets this matrix to the matrix with the rotation by the specified angle around the specified axis vector.
SetToScaling | Sets this matrix to the matrix with the uniform scaling by the specified scale factor with respect to the specified point.
SetToTranslation | Sets this matrix to the matrix with translation by the specified vector.
TransposeIt | Sets this matrix to its current transpose.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the elements of the 4 x 4 matrix by row from top to bottom.
Determinant | Gets the determinant of this matrix.
Inverse | Gets the inverse matrix of this matrix.
Scale | Multiplies the matrix by the scale factor.
Translation | Specifies the translation portion of the matrix.
Transpose | Gets the transposition matrix of this matrix.


IGeMatrix::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeMatrix::AsArray Property
Summary

Specifies the elements of the 4 x 4 matrix by row from top to bottom.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant(array of Doubles).


IGeMatrix::Determinant Property
Summary

Gets the determinant of this matrix.

Visual Basic
Property Determinant() As double*
Remarks

This property is a Double.


IGeMatrix::Inverse Property
Summary

Gets the inverse matrix of this matrix.

Visual Basic
Property Inverse() As IGeMatrix**
Remarks

This property is a GeMatrix object.


IGeMatrix::Scale Property
Summary

Multiplies the matrix by the scale factor.

Visual Basic
Property Scale() As double*
Remarks

This property is a Double.


IGeMatrix::Translation Property
Summary

Specifies the translation portion of the matrix.

Visual Basic
Property Translation() As IGeVector*
Remarks

This property is a GeVector object.


IGeMatrix::Transpose Property
Summary

Gets the transposition matrix of this matrix.

Visual Basic
Property Transpose() As IGeMatrix**
Remarks

This property is a GeMatrix object.


IGeMatrix::GetCoordinateSystem Method
Summary

Gets the origin point and axis direction vectors of the coordinate system that this matrix maps to.

Visual Basic
Sub GetCoordinateSystem(ByRef Origin As IGePoint*, ByRef Axis1 As IGeVector*, ByRef Axis2 As IGeVector*, ByRef Axis3 As IGeVector*)
Parameters
Parameters | Description
Origin | GePoint object; output-only. Returns the origin point of the coordinate system.
Axis1 | GeVector object; output-only. Returns the X axis of the coordinate system.
Axis2 | GeVector object; output-only. Returns the Y axis of the coordinate system.
Axis3 | GeVector object; output-only. Returns the Z axis of the coordinate system.
Returns

None


IGeMatrix::Invert Method
Summary

Sets the matrix to be equal to its inverse.

Visual Basic
Sub Invert()
Returns

None


IGeMatrix::IsEqualTo Method
Summary

Determines whether this matrix is equal to the specified matrix within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Matrix As IGeMatrix, Tolerance As [in, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeMatrix::IsOrthogonal Method
Summary

Gets whether the column vectors of the linear portion of the matrix are orthogonal or perpendicular with each other, TRUE, or not, FALSE.

Visual Basic
Sub IsOrthogonal(Tolerance As [in, optional] VARIANT, Orthogonal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeMatrix::IsSingular Method
Summary

Gets whether any column vector of the linear portion of the matrix is in zero length or whether any two column vectors of the linear portion of the matrix are parallel, TRUE, or not, FALSE.

Visual Basic
Sub IsSingular(Tolerance As [in, optional] VARIANT, Singular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeMatrix::IsUniformScaledOrtho Method
Summary

Gets whether this matrix is orthogonal or perpendicular to each other, and uniformly scaled, TRUE, or not, FALSE.

Visual Basic
Sub IsUniformScaledOrtho(Tolerance As [in, optional] VARIANT, UniformOrtho As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeMatrix::Item Method ([in] long, [in] long, [in] double)
Summary

Specifies the matrix element value at the specified row and column.

Visual Basic
Sub Item(I As long, J As long, Value As double)
Parameters
Parameters | Description
I | Long; input-only. Specifies the row where the matrix element lies.
J | Long; input-only. Specifies the column where the matrix element lies.
Remarks

This property is a Double.


IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)
Summary

Specifies the matrix element value at the specified row and column.

Visual Basic
Sub Item(I As long, J As long, Value As [out, retval] double)
Parameters
Parameters | Description
I | Long; input-only. Specifies the row where the matrix element lies.
J | Long; input-only. Specifies the column where the matrix element lies.
Remarks

This property is a Double.


IGeMatrix::PostMultiply Method
Summary

Computes the matrix resulting from this matrix multiplied by the specified matrix.

Visual Basic
Sub PostMultiply(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to multiple this matrix for calculation.
Returns

GeMatrix object


IGeMatrix::PreMultiply Method
Summary

Computes the matrix resulting from the specified matrix multiplied by this matrix.

Visual Basic
Sub PreMultiply(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to be multiplied by this matrix for calculation.
Returns

GeMatrix object


IGeMatrix::Product Method
Summary

Returns the product of this matrix and the specified matrix.

Visual Basic
Sub Product(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to calculate the product.
Returns

GeMatrix object


IGeMatrix::SetToAlignCoordinateSystem Method
Summary

Sets this matrix to the matrix which maps from one specified coordinate system to another specified coordinate system.

Visual Basic
Sub SetToAlignCoordinateSystem(FromOrigin As IGePoint, FromAxis1 As IGeVector, FromAxis2 As IGeVector, FromAxis3 As IGeVector, ToOrigin As IGePoint, ToAxis1 As IGeVector, ToAxis2 As IGeVector, ToAxis3 As IGeVector)
Parameters
Parameters | Description
FromOrigin | GePoint object; input-only. Specifies the origin point of the start coordinate system.
FromAxis1 | GeVector object; input-only. Specifies the X axis of the start coordinate system.
FromAxis2 | GeVector object; input-only. Specifies the Y axis of the start coordinate system.
FromAxis3 | GeVector object; input-only. Specifies the Z axis of the start coordinate system.
ToOrigin | GePoint object; input-only. Specifies the origin point of the target coordinate system.
ToAxis1 | GeVector object; input-only. Specifies the X axis of the end coordinate system.
ToAxis2 | GeVector object; input-only. Specifies the Y axis of the end coordinate system.
ToAxis3 | GeVector object; input-only. Specifies the Z axis of the target coordinate system.
Returns

None


IGeMatrix::SetToCoordinateSystem Method
Summary

Sets this matrix to the matrix which maps the standard coordinate system with the origin (0, 0, 0) and axes (1, 0, 0), (0, 1, 0) and (0, 0, 1) to the specified coordinate system.

Visual Basic
Sub SetToCoordinateSystem(Origin As IGePoint, Axis1 As IGeVector, Axis2 As IGeVector, Axis3 As IGeVector)
Parameters
Parameters | Description
Origin | GePoint object; input-only. Specifies the origin point of the target coordinate system.
Axis1 | GeVector object; input-only. Specifies the X axis of the target coordinate system.
Axis2 | GeVector object; input-only. Specifies the Y axis of the end coordinate system.
Axis3 | GeVector object; input-only. Specifies the Z axis of the target coordinate system.
Returns

None


IGeMatrix::SetToIdentity Method
Summary

Sets this matrix to the identity matrix.

Visual Basic
Sub SetToIdentity()
Returns

None


IGeMatrix::SetToMirroring Method
Summary

Sets this matrix to the matrix of mirroring with respect to the specified entity.

Visual Basic
Sub SetToMirroring(Entity As IGeEntity)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity about which to mirror this matrix. It can be a GePlane , GeLine , or GePoint object.
Returns

None


IGeMatrix::SetToProduct Method
Summary

Sets this matrix to the product of the two specified matrices.

Visual Basic
Sub SetToProduct(Matrix1 As IGeMatrix, Matrix2 As IGeMatrix)
Parameters
Parameters | Description
Matrix1 | GeMatrix object; input-only. Specifies one matrix to get the product matrix.
Matrix2 | GeMatrix object; input-only. Specifies the other matrix to get the product matrix.
Returns

None


IGeMatrix::SetToProjection Method
Summary

Sets this matrix to the matrix with the parallel projection into the specified plane.

Visual Basic
Sub SetToProjection(Plane As IGePlane, Direction As IGeVector)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane to implement the parallel projection of this matrix.
Direction | GeVector object; input-only. Specifies the direction of the parallel projection.
Returns

None


IGeMatrix::SetToRotation Method
Summary

Sets this matrix to the matrix with the rotation by the specified angle around the specified axis vector.

Visual Basic
Sub SetToRotation(Angle As double, Axis As IGeVector, Center As IGePoint)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this matrix. The direction of the rotation satisfies the right hand rule.
Axis | GeVector object; input-only. Specifies the axis vector around which to rotate this matrix.
Center | GePoint object; input-only. Specifies a point that the axis vector passes through.
Returns

None


IGeMatrix::SetToScaling Method
Summary

Sets this matrix to the matrix with the uniform scaling by the specified scale factor with respect to the specified point.

Visual Basic
Sub SetToScaling(Factor As double, Center As IGePoint)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the factor in which to scale this matrix.
Center | GePoint object; input-only. Specifies the base point to scale this matrix.
Returns

None


IGeMatrix::SetToTranslation Method
Summary

Sets this matrix to the matrix with translation by the specified vector.

Visual Basic
Sub SetToTranslation(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the vector in which to translate or move this matrix.
Returns

None


IGeMatrix::TransposeIt Method
Summary

Sets this matrix to its current transpose.

Visual Basic
Sub TransposeIt()
Returns

None


IGeNurbCurve Interface
Summary

A Non-Uniform Rational B-spline, or NURB curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeNurbCurve
Visual Basic
Public Interface IGeNurbCurve
Inherits IGeCurve
Links
IGeNurbCurve Members, GEAuto Library


IGeNurbCurve Members
Summary

The following tables list the members exposed by IGeNurbCurve.

Methods
Name
Description
AddFitPointAt
Inserts the specified point into the fit points at the specified index.
AddKnot
Adds the knot value into the curve's knot sequence.
BoundBlock
Computes the bounding box around the curve or the curve interval.
ClosestPointTo
Calculates the closest point on this curve to the specified point.
ClosestPointToCurve
Calculates the closest point on this curve to the specified curve.
ContinuityAtKnot
Gets the degree of the highest derivative that is continuous at a knot. For example, if this NURB curve does not have its first derivative at the specified knot index, the value 0 is returned.
ControlPointAt
Specifies the control point at the specified index.
ControlPointAt
Specifies the control point at the specified index.
DistanceTo
Calculates the minimum distance between this curve to the specified geometry entity.
ElevateDegree
Elevates the degree of the NURB curve by the specified amount.
EvaluatePoint
Returns the point on the curve corresponding to the specified parameter value.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
GetArea
Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature
Gets the curvature of the curve at the specified parameter value.
GetDefinitionData
Gets all the data that defines this NURB curve.
GetFitData
Gets the fit data used by the fit curve.
GetLength
Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints
Evaluates a sampling of points along the curve.
GetSplitCurves
Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint
Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint
Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve
Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface
Calculates the intersection with the specified surface within the specified tolerance.
IsClosed
Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith
Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate
Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo
Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear
Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn
Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval
Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic
Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar
Gets whether this curve is planar, TRUE, or not, FALSE.
JoinWith
Recomputes this NURB curve by joining the specified NURB curve to the end of this NURB curve.
KnotAt
Specifies the knot value at the specified index.
KnotAt
Specifies the knot value at the specified index.
LocalClosestPointTo
Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve
Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
MakeClosed
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this NURB curve to form a smooth closed curve.
  • If the Option element is FALSE and if the curve is closed, it is made open by removing the span between the last and next-to-last knots.
MakePeriodic
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this curve to form a smooth closed curve, and then is made into a periodic curve.
  • If the Option element is FALSE and if the curve is periodic, it is made non-periodic by assigning full knot multiplicity at the first and last knots.
MakeRational
Sets this NURB curve as rational and sets the weight of each control point to the specified weight.
Mirror
Mirrors this entity about the specified plane.
NormalPoint
Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength
Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf
Calculates the parameter value on this curve, which corresponds to the specified point.
ParametersOfC1
Checks whether there are any C1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
ParametersOfG1
Checks whether there are any G1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
Project
Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
PurgeFitData
Removes all fit data from the NURB curve.
RemoveFitPointAt
Removes the fit point at the specified index.
Reverse
Reverses the parametric direction of the curve.
RotateBy
Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy
Multiplies this entity by the scale factor.
SetDefinitionData
Sets the definition data of the NURB curve from the specified parameters.
SetFitData
Recomputes this NURB curve from the specified knot vector, fit points, start and end tangents, and fit tolerance.
TransformBy
Transforms this entity by the specified matrix.
TranslateBy
Translates or moves the entity by the specified translation vector.
TrimByParameters
Trims this NURB curve to the new start and end parameters.
WeightAt
Specifies the weight value for the control point at the specified index.
WeightAt
Specifies the weight value for the control point at the specified index.
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPointCount | Gets the number of control points on this NURB curve.
ControlPoints | Gets all control points on this NURB curve.
Degree | Gets the degree of this NURB curve.
EndParameter | Gets the end parameter value of this NURB curve.
EndPoint | Gets the end point of this NURB curve.
EvaluatorMode | Specifies the curve evaluation optimization mode.
FitEndTangent | Specifies the tangent at the end of a fit curve.
FitPointCount | Gets the number of fit points used to construct this NURB curve.
FitPoints | Gets the fit points used to construct this NURB curve.
FitStartTangent | Specifies the tangent at the start of a fit curve.
FitTolerance | Specifies the tolerance used for interpolating this NURB curve from the fit data.
HasFitData | Gets whether the NURB curve has interpolating fit data.
Interval | Sets the interval of the curve and returns the index of the interval.
IsRational | Gets whether this NURB curve is rational, TRUE, or not, FALSE.
KnotCount | Gets the length of the knot vector for this NURB curve.
Knots | Gets the knot vector from this NURB curve.
Order | Gets the order of this NURB curve.
StartParameter | Gets the start parameter of this NURB curve.
StartPoint | Gets the start point of this NURB curve.
WeightCount | Gets the number of weights for this NURB curve.
Weights | Gets all weights of control points.


IGeNurbCurve::ControlPointCount Property
Summary

Gets the number of control points on this NURB curve.

Visual Basic
Property ControlPointCount() As long*
Remarks

This property is a Long.


IGeNurbCurve::ControlPoints Property
Summary

Gets all control points on this NURB curve.

Visual Basic
Property ControlPoints() As IGePoints**
Remarks

This property is a gePoints collection.


IGeNurbCurve::Degree Property
Summary

Gets the degree of this NURB curve.

Visual Basic
Property Degree() As long*
Remarks

This property is a Long.


IGeNurbCurve::EndParameter Property
Summary

Gets the end parameter value of this NURB curve.

Visual Basic
Property EndParameter() As double*
Remarks

This property is a Double.


IGeNurbCurve::EndPoint Property
Summary

Gets the end point of this NURB curve.

Visual Basic
Property EndPoint() As IGePoint**
Remarks

This property is a GePoint object.


IGeNurbCurve::EvaluatorMode Property
Summary

Specifies the curve evaluation optimization mode.

Visual Basic
Property EvaluatorMode() As VARIANT_BOOL
Remarks

This property is a Boolean:

  • FALSE: There is no optimization of an internal evaluator. This mode generally should be used if only one or two values per interval between two consecutive knots are evaluated.
  • TRUE: The evaluator optimization is turned on. This will provide better performance if three or more values per knot interval are computed.


IGeNurbCurve::FitEndTangent Property
Summary

Specifies the tangent at the end of a fit curve.

Visual Basic
Property FitEndTangent() As IGeVector*
Remarks
  • This property is a GeVector object.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::FitPointCount Property
Summary

Gets the number of fit points used to construct this NURB curve.

Visual Basic
Property FitPointCount() As long*
Remarks
  • This property is a Long.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::FitPoints Property
Summary

Gets the fit points used to construct this NURB curve.

Visual Basic
Property FitPoints() As IGePoints**
Remarks
  • This property is a gePoints collection.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::FitStartTangent Property
Summary

Specifies the tangent at the start of a fit curve.

Visual Basic
Property FitStartTangent() As IGeVector*
Remarks
  • This property is a GeVector object.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::FitTolerance Property
Summary

Specifies the tolerance used for interpolating this NURB curve from the fit data.

Visual Basic
Property FitTolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.


IGeNurbCurve::HasFitData Property
Summary

Gets whether the NURB curve has interpolating fit data.

Visual Basic
Property HasFitData() As VARIANT_BOOL*
Remarks

  • This property is a Boolean.
  • A NURB curve will only have fit data associated if it has been constructed with fit data.
  • Any direct editing of the underlying NURB curve data, such as setting a control point position, a knot value, or a weight, will remove the fit data.


IGeNurbCurve::IsRational Property
Summary

Gets whether this NURB curve is rational, TRUE, or not, FALSE.

Visual Basic
Property IsRational() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeNurbCurve::KnotCount Property
Summary

Gets the length of the knot vector for this NURB curve.

Visual Basic
Property KnotCount() As long*
Remarks

This property is a Long.


IGeNurbCurve::Knots Property
Summary

Gets the knot vector from this NURB curve.

Visual Basic
Property Knots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.


IGeNurbCurve::Order Property
Summary

Gets the order of this NURB curve.

Visual Basic
Property Order() As long*
Remarks

  • This property is a Long.
  • The curve is defined on the interval between knot values indexed by order - 1 and numberOfKnots - order. The order is greater than the spline degree by 1.


IGeNurbCurve::StartParameter Property
Summary

Gets the start parameter of this NURB curve.

Visual Basic
Property StartParameter() As double*
Remarks

This property is a Double.


IGeNurbCurve::StartPoint Property
Summary

Gets the start point of this NURB curve.

Visual Basic
Property StartPoint() As IGePoint**
Remarks

This property is a GePoint object.


IGeNurbCurve::WeightCount Property
Summary

Gets the number of weights for this NURB curve.

Visual Basic
Property WeightCount() As long*
Remarks

  • This property is a Long.
  • If the curve is not rational, the number of weights will be zero; otherwise, the number of weights will be equal to the number of control points.


IGeNurbCurve::Weights Property
Summary

Gets all weights of control points.

Visual Basic
Property Weights() As VARIANT*
Remarks

This property is a Variant (array of Doubles).


IGeNurbCurve::AddFitPointAt Method
Summary

Inserts the specified point into the fit points at the specified index.

Visual Basic
Sub AddFitPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the new fit point to insert.
Point | GePoint object; input-only. Specifies the new fit point to insert.
Returns

None


IGeNurbCurve::AddKnot Method
Summary

Adds the knot value into the curve's knot sequence.

Visual Basic
Sub AddKnot(Value As double, Add As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the knot value to add.
Add | Boolean, the default value is False; input-only; optional. If the knot value already exists and the Add element is FALSE, the knot is not added; otherwise, the multiplicity of the knot is increased by one.
Returns

None


IGeNurbCurve::ContinuityAtKnot Method
Summary

Gets the degree of the highest derivative that is continuous at a knot. For example, if this NURB curve does not have its first derivative at the specified knot index, the value 0 is returned.

Visual Basic
Sub ContinuityAtKnot(Index As long, Tolerance As [in, optional] VARIANT, Continuity As [out, retval] long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the knot index to perform the calculation.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Long.


IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)
Summary

Specifies the control point at the specified index.

Visual Basic
Sub ControlPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index at which to get the control point.
Remarks

This property is a GePoint object.


IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)
Summary

Specifies the control point at the specified index.

Visual Basic
Sub ControlPointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index at which to get the control point.
Remarks

This property is a GePoint object.


IGeNurbCurve::ElevateDegree Method
Summary

Elevates the degree of the NURB curve by the specified amount.

Visual Basic
Sub ElevateDegree(Value As long)
Parameters
Parameters | Description
Value | Long; input-only. Specifies the amount in which to elevate the degree the NURB curve. It can only be a positive value.
Returns

None


IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)
Summary

Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.

Visual Basic
Sub FitPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point.
Remarks
  • This property is a GePoint object.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)
Summary

Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.

Visual Basic
Sub FitPointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point.
Remarks
  • This property is a GePoint object.
  • This property is a only available if this NURB curve has fit data, HasFitData .


IGeNurbCurve::GetDefinitionData Method
Summary

Gets all the data that defines this NURB curve.

Visual Basic
Sub GetDefinitionData(ByRef Degree As long, ByRef Rational As VARIANT_BOOL, ByRef Periodic As VARIANT_BOOL, ByRef Knots As IGeKnotVector*, ByRef Points As IGePoints*, ByRef Weights As VARIANT)
Parameters
Parameters | Description
Degree | Long; output-only. Returns the degree of the NURB curve.
Rational | Boolean; output-only. Returns whether this NURB curve is rational, TRUE, or not, FALSE.
Periodic | Boolean; output-only. Returns whether this NURB curve is periodic, TRUE, or not, FALSE.
Knots | GeKnotVector object; output-only. Returns the knot vector of the NURB curve.
Points | gePoints collection; output-only. Returns the controlling points of the NURB curve.
Weights | Variant (array of Doubles); output-only. Returns the weights of the NURB curve. If the NURB curve is not rational, the array of weights will be empty.
Returns

None


IGeNurbCurve::GetFitData Method
Summary

Gets the fit data used by the fit curve.

Visual Basic
Sub GetFitData(ByRef Points As IGePoints*, ByRef Tolerance As IGeTolerance*, ByRef HasTangents As VARIANT_BOOL, ByRef StartTangent As IGeVector*, ByRef EndTangent As IGeVector*)
Parameters
Parameters | Description
Points | gePoints collection; output-only. Returns the fit points of the NURB curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
HasTangents | Boolean; output-only. Returns whether the tangents exist, TRUE, or not, FALSE.
StartTangent | GeVector object; output-only. Returns the start tangent if it exists; otherwise, this element will not be set.
EndTangent | GeVector object; output-only. Returns the end tangent if it exists; otherwise, this element will not be set.
Returns

None

Remarks

These fit data are only available if the NURB curve has fit data, HasFitData .


IGeNurbCurve::JoinWith Method
Summary

Recomputes this NURB curve by joining the specified NURB curve to the end of this NURB curve.

Visual Basic
Sub JoinWith(Curve As IGeNurbCurve)
Parameters
Parameters | Description
Curve | GeNurbCurve object; input-only. Specifies the NURB curve to join with this NURB curve,
Returns

None

Remarks

Neither NURB curve may be closed and the start point of the specified NURB curve must be equal to the end point of this NURB curve.


IGeNurbCurve::KnotAt Method ([in] long, [in] double)
Summary

Specifies the knot value at the specified index.

Visual Basic
Sub KnotAt(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to get the value.
Remarks

This property is a Double.


IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)
Summary

Specifies the knot value at the specified index.

Visual Basic
Sub KnotAt(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to get the value.
Remarks

This property is a Double.


IGeNurbCurve::MakeClosed Method
Summary

Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this NURB curve to form a smooth closed curve.
  • If the Option element is FALSE and if the curve is closed, it is made open by removing the span between the last and next-to-last knots.
Visual Basic
Sub MakeClosed(Option As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Option | Boolean, the default value is TRUE; input-only; optional.
Returns

None


IGeNurbCurve::MakePeriodic Method
Summary

Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this curve to form a smooth closed curve, and then is made into a periodic curve.
  • If the Option element is FALSE and if the curve is periodic, it is made non-periodic by assigning full knot multiplicity at the first and last knots.
Visual Basic
Sub MakePeriodic(Option As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Option | Boolean, the default value is TRUE; input-only; optional.
Returns

None


IGeNurbCurve::MakeRational Method
Summary

Sets this NURB curve as rational and sets the weight of each control point to the specified weight.

Visual Basic
Sub MakeRational(Weight As [in, defaultvalue(1.0)] double)
Parameters
Parameters | Description
Weight | Double, the default value is 1.0; input-only; optional. Specifies the weight for each control point on the rational NURB curve.
Returns

None

Remarks

If the curve is already rational, the weight at each control point is set to the specified weight.


IGeNurbCurve::ParametersOfC1 Method
Summary

Checks whether there are any C1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.

Visual Basic
Sub ParametersOfC1(ByRef Parameters As VARIANT, Tolerance As [in, optional] VARIANT, Exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeNurbCurve::ParametersOfG1 Method
Summary

Checks whether there are any G1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.

Visual Basic
Sub ParametersOfG1(ByRef Parameters As VARIANT, Tolerance As [in, optional] VARIANT, Exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeNurbCurve::PurgeFitData Method
Summary

Removes all fit data from the NURB curve.

Visual Basic
Sub PurgeFitData()
Returns

None

Remarks

The curve geometric definition is not changed, for instance, control points, knots, and weights remain the same.


IGeNurbCurve::RemoveFitPointAt Method
Summary

Removes the fit point at the specified index.

Visual Basic
Sub RemoveFitPointAt(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point to remove.
Returns

None


IGeNurbCurve::SetDefinitionData Method
Summary

Sets the definition data of the NURB curve from the specified parameters.

Visual Basic
Sub SetDefinitionData(Degree As long, Knots As IGeKnotVector, Points As IGePoints, Periodic As VARIANT_BOOL, Weights As [in, optional] VARIANT)
Parameters
Parameters | Description
Degree | Long; input-only. Specifies the degree for the NURB curve.
Knots | GeKnotVector object; input-only. Specifies the knot vector for the NURB curve.
Points | gePoints collection; input-only. Specifies the control points for the NURB curve.
Periodic | Boolean; input-only. Specifies whether the NURB curve is periodic, TRUE, or not, FALSE.
Weights | Variant (array of Doubles); input-only; optional. Specifies the weights for the NURB curve; if not specified, the NURB curve is set as non-rational.
Returns

None


IGeNurbCurve::SetFitData Method
Summary

Recomputes this NURB curve from the specified knot vector, fit points, start and end tangents, and fit tolerance.

Visual Basic
Sub SetFitData(Points As IGePoints, StartTangent As [in, optional] VARIANT, EndTangent As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | gePoints collection; input-only. Specifies the control points to recompute this NURB curve.
StartTangent | Variant ( GeVector object); input-only; optional. Specifies the start tangent for this NURB curve.
EndTangent | Variant ( GeVector object); input-only; optional. Specifies the end tangent for this NURB curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks
  • If the fit tolerance equal point is not 0, then the constructed spline may not pass through the fit points but the maximum distance from any fit point to the constructed spline will be no greater than tolerance equal point.
  • If either of the fit tangents are specified, the other fit tangent must be specified as well.


IGeNurbCurve::TrimByParameters Method
Summary

Trims this NURB curve to the new start and end parameters.

Visual Basic
Sub TrimByParameters(Start As double, End As double)
Parameters
Parameters | Description
Start | Double; input-only. Specifies the start parameter from which to trim this NURB curve.
End | Double; input-only. Specifies the start parameter to which to trim this NURB curve.
Returns

None

Remarks

This is done by adding and removing control points and knots, but is not done by just resetting the interval on which this NURB curve is defined.


IGeNurbCurve::WeightAt Method ([in] long, [in] double)
Summary

Specifies the weight value for the control point at the specified index.

Visual Basic
Sub WeightAt(Index As long, Weight As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the control point for which to calculate the weight value.
Remarks

This property is a Double.


IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)
Summary

Specifies the weight value for the control point at the specified index.

Visual Basic
Sub WeightAt(Index As long, Weight As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the control point for which to calculate the weight value.
Remarks

This property is a Double.


IGeNurbSurface Interface
Summary

A Non-Uniform Rational B-spline, or NURB surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeNurbSurface
Visual Basic
Public Interface IGeNurbSurface
Inherits IGeSurface
Links
IGeNurbSurface Members, GEAuto Library


IGeNurbSurface Members
Summary

The following tables list the members exposed by IGeNurbSurface.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetDefinitionData | Gets the definition data from this NURB surface.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsPeriodicInU | Gets whether this NURB surface is periodic in the U parameter direction, and obtains the period, TRUE, or not, FALSE.
IsPeriodicInV | Gets whether this NURB surface is periodic in the V parameter direction, and obtains the period, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SetDefinitionData | Sets the definition data for this NURB surface.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPoints | Gets all control points on this NURB surface
DegreeInU | Gets the degree of this NURB surface in the U parameter direction.
DegreeInV | Gets the degree of this NURB surface in the V parameter direction.
IsClosedInU | Gets whether this NURB surface is closed in the U parameter direction, TRUE, or not, FALSE.
IsClosedInV | Gets whether this NURB surface is closed in the V parameter direction, TRUE, or not, FALSE.
IsRationalInU | Gets whether this NURB surface is rational in the U parameter direction, TRUE, or not, FALSE.
IsRationalInV | Gets whether this NURB surface is rational in the V parameter direction, TRUE, or not, FALSE.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
SingularityInU | Gets the characterization of any singularity in the U parameter direction.
SingularityInV | Gets the characterization of any singularity in the V parameter direction.
UControlPointCount | Gets the number of control points in the U parameter direction.
UKnotCount | Gets the number of knots in the U parameter direction.
UKnots | Gets the U knot vector on this NURB surface in the U parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VControlPointCount | Gets the number of control points in the V parameter direction.
VKnotCount | Gets the number of knots in the V parameter direction.
VKnots | Gets the U knot vector on this NURB surface in the V parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Weights | Gets the weights of all control points on this NURB surface.


IGeNurbSurface::ControlPoints Property
Summary

Gets all control points on this NURB surface

Visual Basic
Property ControlPoints() As IGePoints**
Remarks

This property is a gePoints collection.


IGeNurbSurface::DegreeInU Property
Summary

Gets the degree of this NURB surface in the U parameter direction.

Visual Basic
Property DegreeInU() As long*
Remarks

This property is a Long.


IGeNurbSurface::DegreeInV Property
Summary

Gets the degree of this NURB surface in the V parameter direction.

Visual Basic
Property DegreeInV() As long*
Remarks

This property is a Long.


IGeNurbSurface::IsClosedInU Property
Summary

Gets whether this NURB surface is closed in the U parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsClosedInU() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeNurbSurface::IsClosedInV Property
Summary

Gets whether this NURB surface is closed in the V parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsClosedInV() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeNurbSurface::IsRationalInU Property
Summary

Gets whether this NURB surface is rational in the U parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsRationalInU() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeNurbSurface::IsRationalInV Property
Summary

Gets whether this NURB surface is rational in the V parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsRationalInV() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeNurbSurface::SingularityInU Property
Summary

Gets the characterization of any singularity in the U parameter direction.

Visual Basic
Property SingularityInU() As long*
Remarks
  • This property is a Long.
  • Singularity types include: geNoPoles, gePoleAtMin, gePoleAtMax, and gePoleAtBoth.


IGeNurbSurface::SingularityInV Property
Summary

Gets the characterization of any singularity in the V parameter direction.

Visual Basic
Property SingularityInV() As long*
Remarks
  • This property is a Long.
  • Singularity types include: geNoPoles, gePoleAtMin, gePoleAtMax, and gePoleAtBoth.


IGeNurbSurface::UControlPointCount Property
Summary

Gets the number of control points in the U parameter direction.

Visual Basic
Property UControlPointCount() As long*
Remarks

This property is a Long.


IGeNurbSurface::UKnotCount Property
Summary

Gets the number of knots in the U parameter direction.

Visual Basic
Property UKnotCount() As long*
Remarks

This property is a Long.


IGeNurbSurface::UKnots Property
Summary

Gets the U knot vector on this NURB surface in the U parameter direction.

Visual Basic
Property UKnots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.


IGeNurbSurface::VControlPointCount Property
Summary

Gets the number of control points in the V parameter direction.

Visual Basic
Property VControlPointCount() As long*
Remarks

This property is a Long.


IGeNurbSurface::VKnotCount Property
Summary

Gets the number of knots in the V parameter direction.

Visual Basic
Property VKnotCount() As long*
Remarks

This property is a Long.


IGeNurbSurface::VKnots Property
Summary

Gets the U knot vector on this NURB surface in the V parameter direction.

Visual Basic
Property VKnots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.


IGeNurbSurface::Weights Property
Summary

Gets the weights of all control points on this NURB surface.

Visual Basic
Property Weights() As VARIANT*
Remarks

This property is a Variant (array of Doubles).


IGeNurbSurface::GetDefinitionData Method
Summary

Gets the definition data from this NURB surface.

Visual Basic
Sub GetDefinitionData(ByRef DegreeU As long, ByRef DegreeV As long, ByRef PropertiesU As long, ByRef PropertiesV As long, ByRef PointsInU As long, ByRef PointsInV As long, ByRef Points As IGePoints*, ByRef Weights As VARIANT, ByRef KnotsU As IGeKnotVector*, ByRef KnotsV As IGeKnotVector*)
Parameters
Parameters | Description
DegreeU | Long; output-only. Returns the degree of this NURB surface in the U parameter direction.
DegreeV | Long; output-only. Returns the degree of this NURB surface in the V parameter direction.
PropertiesU | Long; output-only. Returns the U direction properties of this NURB surface.
PropertiesV | Long; output-only. Returns the V direction properties of this NURB surface.
PointsInU | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
PointsInV | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
Points | gePoints collection; output-only. Returns all control points on this NURB surface.
Weights | Variant (array of Doubles); output-only. Returns the weights of all control points on this NURB surface.
KnotsU | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the U parameter direction.
KnotsV | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the V parameter direction.
Returns

None

Remarks
  • The control points contains first the U and then the V control points as indicated by the number of control points in U and in V.
  • The weights are similarly partitioned and correspond one to one with the control points.


IGeNurbSurface::IsPeriodicInU Method
Summary

Gets whether this NURB surface is periodic in the U parameter direction, and obtains the period, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodicInU(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); output-only; optional. Returns the period of this NURB surface in the U parameter direction. The period will only be set if this NURB surface is periodic in the U parameter direction.
Remarks

This property is a Boolean.


IGeNurbSurface::IsPeriodicInV Method
Summary

Gets whether this NURB surface is periodic in the V parameter direction, and obtains the period, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodicInV(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); output-only; optional. Returns the period of this NURB surface in the V parameter direction. The period will only be set if this NURB surface is periodic in the V parameter direction.
Remarks

This property is a Boolean.


IGeNurbSurface::SetDefinitionData Method
Summary

Sets the definition data for this NURB surface.

Visual Basic
Sub SetDefinitionData(DegreeU As long, DegreeV As long, PropertiesU As long, PropertiesV As long, PointsInU As long, PointsInV As long, Points As IGePoints, Weights As VARIANT, KnotsU As IGeKnotVector, KnotsV As IGeKnotVector, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
DegreeU | Long; input-only. Specifies the degree of this NURB surface in the U parameter direction.
DegreeV | Long; output-only. Returns the degree of this NURB surface in the V parameter direction.
PropertiesU | Long; output-only. Returns the U direction properties of this NURB surface.
PropertiesV | Long; output-only. Returns the V direction properties of this NURB surface.
PointsInU | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
PointsInV | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
Points | gePoints collection; output-only. Returns all control points on this NURB surface.
Weights | Variant (array of Doubles); output-only. Returns the weights of all control points on this NURB surface.
KnotsU | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the U parameter direction.
KnotsV | GeKnotVector object; input-only. Specifies the knot vector of this NURB surface in the V parameter direction.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks

The length of the control points collection and the weights array should be equal to the sum of the specified number of control points in the U parameter direction and the specified number of control points in the V parameter direction.


IGeOffsetCurve Interface
Summary

An exact offset of another curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeOffsetCurve
Visual Basic
Public Interface IGeOffsetCurve
Inherits IGeCurve
Links
IGeOffsetCurve Members, GEAuto Library


IGeOffsetCurve Members
Summary

The following tables list the members exposed by IGeOffsetCurve.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseCurve | Specifies the base curve that this curve is an offset of.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this offset curve.
OffsetDistance | Specifies the offset distance of this offset curve.
ParameterDirection | Gets whether the parameter direction of this offset curve is the same as the base curve , TRUE, or not, FALSE.
Transformation | Returns the transformation matrix that was applied to the offset curve by calling TransformBy .


IGeOffsetCurve::BaseCurve Property
Summary

Specifies the base curve that this curve is an offset of.

Visual Basic
Property BaseCurve() As IGeCurve*
Remarks

This property is a GeCurve object.


IGeOffsetCurve::Normal Property
Summary

Specifies the normal vector of this offset curve.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.


IGeOffsetCurve::OffsetDistance Property
Summary

Specifies the offset distance of this offset curve.

Visual Basic
Property OffsetDistance() As double
Remarks

This property is a Double.


IGeOffsetCurve::ParameterDirection Property
Summary

Gets whether the parameter direction of this offset curve is the same as the base curve , TRUE, or not, FALSE.

Visual Basic
Property ParameterDirection() As VARIANT_BOOL*
Remarks

This property is a Boolean.


IGeOffsetCurve::Transformation Property
Summary

Returns the transformation matrix that was applied to the offset curve by calling TransformBy .

Visual Basic
Property Transformation() As IGeMatrix**
Remarks
  • This property is a GeMatrix object.
  • If TransformBy has never been called for this offset curve, the matrix returned will be the identity matrix; if TransformBy has been called more than once, the matrix returned will be the concatenation of all of the transformation matrices.


IGeOffsetSurface Interface
Summary

An exact offset of another surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeOffsetSurface
Visual Basic
Public Interface IGeOffsetSurface
Inherits IGeSurface
Links
IGeOffsetSurface Members, GEAuto Library


IGeOffsetSurface Members
Summary

The following tables list the members exposed by IGeOffsetSurface.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
ConvertedSurface | Computes the simple surface equivalent to the offset surface.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Specifies the base surface of the offset surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
OffsetDistance | Specifies the offset distance of this surface.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeOffsetSurface::BaseSurface Property
Summary

Specifies the base surface of the offset surface.

Visual Basic
Property BaseSurface() As IGeSurface*
Remarks

This property is a GeSurface object.


IGeOffsetSurface::OffsetDistance Property
Summary

Specifies the offset distance of this surface.

Visual Basic
Property OffsetDistance() As double
Remarks

This property is a Double.


IGeOffsetSurface::ConvertedSurface Method
Summary

Computes the simple surface equivalent to the offset surface.

Visual Basic
Sub ConvertedSurface(Surface As [out, retval] IGeSurface*)
Returns

GeSurface object


IGePlane Interface
Summary

An infinite plane in three-dimensional space.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGePlane
Visual Basic
Public Interface IGePlane
Inherits IGeSurface
Links
IGePlane Members, GEAuto Library


IGePlane Members
Summary

The following tables list the members exposed by IGePlane.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
CoordinateSystem | Gets the coordinate system of this plane.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetCoefficients | Gets the coefficients of the equation of the plane, namely a*x + b*y + c*z + d, where a, b, c, and d are the coefficients of the normal to this plane.
IntersectWith | Computes the intersection between the plane and the specified linear entity or other plane.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsCoplanarWith | Determines whether this plane is coplanar to the specified plane, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsParallelTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this plane.
SignedDistanceTo | Computes the signed distance from the specified point to this plane.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Normal | Specifies the normal vector of this plane.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the origin of the plane.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGePlane::Normal Property
Summary

Specifies the normal vector of this plane.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.


IGePlane::Origin Property
Summary

Gets the origin of the plane.

Visual Basic
Property Origin() As IGePoint*
Remarks

This property is a GePoint object.


IGePlane::CoordinateSystem Method
Summary

Gets the coordinate system of this plane.

Visual Basic
Sub CoordinateSystem(ByRef Origin As IGePoint*, ByRef Axis1 As IGeVector*, ByRef Axis2 As IGeVector*)
Parameters
Parameters | Description
Origin | GePoint object. Specifies the origin point of this plane.
Axis1 | GeVector object. Specifies the U axis direction of this plane.
Axis2 | GeVector object. Specifies the V axis direction of this plane.
Returns

None


IGePlane::GetCoefficients Method
Summary

Gets the coefficients of the equation of the plane, namely a*x + b*y + c*z + d, where a, b, c, and d are the coefficients of the normal to this plane.

Visual Basic
Sub GetCoefficients(ByRef A As double, ByRef B As double, ByRef C As double, ByRef D As double)
Parameters
Parameters | Description
A | Double; output-only.
B | Double; output-only.
C | Double; output-only.
D | Double; output-only.
Returns

None


IGePlane::IntersectWith Method
Summary

Computes the intersection between the plane and the specified linear entity or other plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Result As IGeEntity*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeLinearEntity or GePlane object.
Returns

GeEntity object; output-only. Returns the intersection region between this plane and the specified geometry entity.

  • It can be any type of geometry entity, depending on the intersection result.
  • This element will only be set if this method returns TRUE.

Tolerance : Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.

Remarks

Boolean


IGePlane::IsCoplanarWith Method
Summary

Determines whether this plane is coplanar to the specified plane, TRUE, or not, FALSE.

Visual Basic
Sub IsCoplanarWith(Plane As IGePlane, Tolerance As [in, optional] VARIANT, Coplanar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Plane | Variant ( GePlane object); input-only. Specifies the other plan to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGePlane::IsParallelTo Method
Summary

Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.

Visual Basic
Sub IsParallelTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity to check the equality with this plane.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGePlane::IsPerpendicularTo Method
Summary

Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.

Visual Basic
Sub IsPerpendicularTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity to check the equality with this plane.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGePlane::Set Method
Summary

Sets the definition data of this plane.

Visual Basic
Sub Set(Argument1 As VARIANT, Argument2 As VARIANT, Argument3 As [in, optional] VARIANT, Argument4 As [in, optional] VARIANT)
Parameters
Parameters | Description
Argument1 | Variant ( GePoint object or Double); input-only. Specifies the origin of the plane or the first coefficient.
Argument2 | Variant ( GeVector or GePoint object, or Double); input-only. Specifies the normal of this plane, or a point or vector from the origin in the U parameter direction, or the second coefficient.
Argument3 | Variant ( GeVector or GePoint object, or Double); input-only. Specifies a point or vector from the origin in the V parameter direction, or the third coefficient.
Argument4 | Variant (Double); input-only; optional. Specifies the fourth coefficient.
Returns

None

Remarks

The plane can be specified in three different ways of setting parameters:

  • Origin point and normal vector.
  • Origin point, a point or vector in the U parameter direction, and a point or vector in the V parameter direction.
  • Four coefficients making up the plane, a, b, c, and d (ax + by + cz + d = 0).


IGePlane::SignedDistanceTo Method
Summary

Computes the signed distance from the specified point to this plane.

Visual Basic
Sub SignedDistanceTo(Point As IGePoint, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point from which to calculate the signed distance to this plane.
Returns

Double

Remarks

The sign of the result is the same as the sign of the dot product of the vector from the specified point to the origin of the plane and the normal to the plane ( Vector(Point, Origin).DotProduct(Normal) ).


IGePoint Interface
Summary

A three-dimensional point object.

Class Hierarchy

Declaration syntax

IGeEntity
    IGePoint
Visual Basic
Public Interface IGePoint
Inherits IGeEntity
Links
IGePoint Members, GEAuto Library


IGePoint Members
Summary

The following tables list the members exposed by IGePoint.

Methods
Name | Description
AsVector | Creates a vector from the point values.
DistanceTo | Calculates the minimum distance between this point and the specified point.
Get | Gets the coordinate system data from this point.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Item | Specifies the item value of this point at the specified index.
Item | Specifies the item value of this point at the specified index.
Mirror | Mirrors this entity about the specified plane.
ProjectToPlane | Returns the 3D point which results from the projection of this point into the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this point by the specified coordinates.
Sum | Returns the point equal to this point offset by the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the coordinate data of this point as an array of Doubles.
X | Specifies the X coordinate data of this point.
Y | Specifies the Y coordinate data of this point.
Z | Specifies the Z coordinate data of this point.


IGePoint::AsArray Property
Summary

Specifies the coordinate data of this point as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).


IGePoint::X Property
Summary

Specifies the X coordinate data of this point.

Visual Basic
Property X() As double
Remarks

This property is a Double.


IGePoint::Y Property
Summary

Specifies the Y coordinate data of this point.

Visual Basic
Property Y() As double
Remarks

This property is a Double.


IGePoint::Z Property
Summary

Specifies the Z coordinate data of this point.

Visual Basic
Property Z() As double
Remarks

This property is a Double.


IGePoint::AsVector Method
Summary

Creates a vector from the point values.

Visual Basic
Sub AsVector(Vector As [out, retval] IGeVector*)
Remarks

GeVector object


IGePoint::DistanceTo Method
Summary

Calculates the minimum distance between this point and the specified point.

Visual Basic
Sub DistanceTo(Point As IGePoint, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the other point to which to calculate the minimum distance.
Returns

Double


IGePoint::Get Method
Summary

Gets the coordinate system data from this point.

Visual Basic
Sub Get(ByRef X As double, ByRef Y As double, ByRef Z As double)
Parameters
Parameters | Description
X | Double; output-only. Returns the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the Y axis.
Z | Double; output-only. Returns the coordinate data of the Z axis.
Returns

None


IGePoint::Item Method ([in] long, [in] double)
Summary

Specifies the item value of this point at the specified index.

Visual Basic
Sub Item(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index to get the item value of this point.
Remarks

This property is a Double.


IGePoint::Item Method ([in] long, [out, retval] double*)
Summary

Specifies the item value of this point at the specified index.

Visual Basic
Sub Item(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index to get the item value of this point.
Remarks

This property is a Double.


IGePoint::ProjectToPlane Method
Summary

Returns the 3D point which results from the projection of this point into the specified plane.

Visual Basic
Sub ProjectToPlane(Plane As IGePlane, Direction As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane with respect onto which this point is projected.
Direction | Variant ( GeVector object); input-only; optional. Specifies the direction in which to project this point; if not specified, the projection is orthogonal to the plane.
Returns

GePoint object


IGePoint::Set Method
Summary

Sets the definition data of this point by the specified coordinates.

Visual Basic
Sub Set(X As double, Y As double, Z As double)
Parameters
Parameters | Description
X | Double; input-only. Specifies the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the X axis.
Z | Double; input-only. Specifies the coordinate data of the X axis.
Returns

None


IGePoint::Sum Method
Summary

Returns the point equal to this point offset by the specified vector.

Visual Basic
Sub Sum(Vector As IGeVector, Result As [out, retval] IGePoint*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the offset vector to perform the calculation.
Returns

GePoint object


IGePoints Interface
Summary

A collection of GePoint objects.

Class Hierarchy

Declaration syntax

IGePoints
Visual Basic
Public Interface IGePoints
Inherits IDispatch
Links
IGePoints Members, GEAuto Library


IGePoints Members
Summary

The following tables list the members exposed by IGePoints.

Methods
Name | Description
Add | Appends a new point to the collection.
Item | Gets the point at the specified index.
Remove | Removes the specified point from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | For GePoint objects: Specifies the coordinates of the point as an array of Doubles. For GePoints Collection objects: Specifies the coordinates of the points in the collection as an array of Doubles. The array size must be a multiple of three. Setting the array values clears the current collection and creates new GePoint objects with the new values. For GeKnotVector objects: Specifies the knot values as an array of Doubles. For GeMatrix objects: Specifies the elements of the 4 x 4 matrix by row from top to bottom.
AsArray2d | Specifies the coordinates of the points in the collection as an array of Doubles, two for each point in the collection.
Count | Gets the total number of the points in a point collection.


IGePoints::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGePoints::AsArray Property
Summary

For GePoint objects: Specifies the coordinates of the point as an array of Doubles.

For GePoints Collection objects: Specifies the coordinates of the points in the collection as an array of Doubles. The array size must be a multiple of three. Setting the array values clears the current collection and creates new GePoint objects with the new values.

For GeKnotVector objects: Specifies the knot values as an array of Doubles.

For GeMatrix objects: Specifies the elements of the 4 x 4 matrix by row from top to bottom.

Visual Basic
Property AsArray() As VARIANT


IGePoints::AsArray2d Property
Summary

Specifies the coordinates of the points in the collection as an array of Doubles, two for each point in the collection.

Visual Basic
Property AsArray2d() As VARIANT
Remarks

The array size must be a multiple of two. Setting the array values clears the current collection and creates new GePoint objects with the new values.


IGePoints::Count Property
Summary

Gets the total number of the points in a point collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGePoints::Add Method
Summary

Appends a new point to the collection.

Visual Basic
Sub Add(Point As IGePoint)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the new point to add to the collection.
Returns

None


IGePoints::Item Method
Summary

Gets the point at the specified index.

Visual Basic
Sub Item(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the point to get from the collection.
Returns

GePoint object


IGePoints::Remove Method
Summary

Removes the specified point from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the point to be removed.
Returns

None


IGeRay Interface
Summary

A line bounded at one end.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeRay
Visual Basic
Public Interface IGeRay
Inherits IGeLinearEntity
Links
IGeRay Members, GEAuto Library


IGeRay Members
Summary

The following tables list the members exposed by IGeRay.

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the ray to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


IGeRay::Set Method
Summary

Changes the definition of the ray to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this ray passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this ray respects on the specified point.
Returns

None


IGeSphere Interface
Summary

A spherical surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeSphere
Visual Basic
Public Interface IGeSphere
Inherits IGeSurface
Links
IGeSphere Members, GEAuto Library


IGeSphere Members
Summary

The following tables list the members exposed by IGeSphere.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between this sphere and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this sphere is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this sphere by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
EndLatitude | Specifies the end angle in the latitudinal parameter direction.
EndLongitude | Specifies the end angle in the longitudinal parameter direction.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
NorthAxis | Gets the direction from the origin of the north pole.
NorthPole | Gets the north pole point of this sphere.
Origin | Gets the center of this sphere.
Radius | Specifies the radius of this sphere.
ReferenceAxis | Gets the direction of the zero meridian.
SouthPole | Gets the south pole point of this sphere.
StartLatitude | Specifies the start angle in the latitudinal parameter direction.
StartLongitude | Specifies the start angle in the longitudinal parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeSphere::EndLatitude Property
Summary

Specifies the end angle in the latitudinal parameter direction.

Visual Basic
Property EndLatitude() As double
Remarks

This property is a Double.


IGeSphere::EndLongitude Property
Summary

Specifies the end angle in the longitudinal parameter direction.

Visual Basic
Property EndLongitude() As double
Remarks

This property is a Double.


IGeSphere::NorthAxis Property
Summary

Gets the direction from the origin of the north pole.

Visual Basic
Property NorthAxis() As IGeVector**
Remarks

This property is a GeVector object.


IGeSphere::NorthPole Property
Summary

Gets the north pole point of this sphere.

Visual Basic
Property NorthPole() As IGePoint**
Remarks

This property is a GePoint object.


IGeSphere::Origin Property
Summary

Gets the center of this sphere.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.


IGeSphere::Radius Property
Summary

Specifies the radius of this sphere.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.


IGeSphere::ReferenceAxis Property
Summary

Gets the direction of the zero meridian.

Visual Basic
Property ReferenceAxis() As IGeVector**
Remarks

This property is a GeVector object.


IGeSphere::SouthPole Property
Summary

Gets the south pole point of this sphere.

Visual Basic
Property SouthPole() As IGePoint**
Remarks

This property is a GePoint object.


IGeSphere::StartLatitude Property
Summary

Specifies the start angle in the latitudinal parameter direction.

Visual Basic
Property StartLatitude() As double
Remarks

This property is a Double.


IGeSphere::StartLongitude Property
Summary

Specifies the start angle in the longitudinal parameter direction.

Visual Basic
Property StartLongitude() As double
Remarks

This property is a Double.


IGeSphere::IntersectWith Method
Summary

Computes the intersection between this sphere and the specified linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this sphere.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.


IGeSphere::IsClosedInU Method
Summary

Gets whether this sphere is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInU(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeSphere::Set Method
Summary

Changes the definition of this sphere by the specified parameters.

Visual Basic
Sub Set(Radius As double, Center As IGePoint, NorthAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT)
Parameters
Parameters | Description
Radius | Double; input-only. Specifies the radius of the sphere.
Center | GePoint object; input-only. Specifies the center point of the sphere.
NorthAxis | Variant ( GeVector object); input-only; optional. Specifies the north pole axis direction of the sphere.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies the reference vector from which longitudinal angles are measured.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitudinal angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitudinal angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitudinal angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitudinal angle.
Returns

None


IGeSurface Interface
Summary

A generic surface entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeBoundedSurface
        IGeCone
        IGeCylinder
        IGeNurbSurface
        IGeOffsetSurface
        IGePlane
        IGeSphere
        IGeTorus
Visual Basic
Public Interface IGeSurface
Inherits IGeEntity
Links
IGeSurface Members, GEAuto Library


IGeSurface Members
Summary

The following tables list the members exposed by IGeSurface.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeSurface::NormalFlipped Property
Summary

Specifies whether the surface normal is flipped, TRUE, or not, FALSE.

Visual Basic
Property NormalFlipped() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The surface normal is computed as the normal of dU cross product dV. When NormalFlipped is set to TRUE, the surface normal is computed as the negative of the normal of dU cross product dV.


IGeSurface::UParameterEnvelope Property
Summary

Gets the surface's parameter range in the U parameter direction.

Visual Basic
Property UParameterEnvelope() As IGeInterval**
Remarks

This property is a GeInterval object.


IGeSurface::VParameterEnvelope Property
Summary

Gets the surface's parameter range in the V parameter direction.

Visual Basic
Property VParameterEnvelope() As IGeInterval**
Remarks

This property is a GeInterval object.


IGeSurface::ClosestPointTo Method
Summary

Calculates the closest point on this surface to the specified point.

Visual Basic
Sub ClosestPointTo(Point As IGePoint, Parameter As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Parameter | Variant (Double); optional. Specifies the parameter of the closest point.
Tolerance | Variant (GeTolerance object); input-only; optional. Specifies the tolerance used in the calculation.
Returns

GePoint object


IGeSurface::DistanceTo Method
Summary

Calculates the minimum distance between the surface and the specified point.

Visual Basic
Sub DistanceTo(Point As IGePoint, Tolerance As [in, optional] VARIANT, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Tolerance | Variant (GeTolerance object); input-only; optional. Specifies the tolerance used in the calculation.
Returns

Double


IGeSurface::EvaluatePoint Method
Summary

Returns the point on the surface corresponding to the specified parameter value.

Visual Basic
Sub EvaluatePoint(ParameterPoint As IGePoint, DerivativeOrder As [in, optional] VARIANT, Derivatives As [in, out, optional] VARIANT, Normal As [in, out, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
ParameterPoint | GePoint object; input-only. Specifies the point to calculate the closest point to.
DerivativeOrder | Variant (Integer); input-only; optional. Specifies the requested derivative order with limit to a value of 2.
Derivatives | Variant ( GeVectors Collection); optional. Specifies the derivative arrays up to the order specified by the derivative order. Derivatives are returned as (order 1) dU or (order 2) dU, dUdU.
Normal | Variant ( GeVector object); optional. Specifies the normal vector at the evaluated point.
Returns

GePoint object

Remarks

If either the optional Derivatives or Normal element is specified, the DerivativeOrder element must be specified.


IGeSurface::IntersectWithSurface Method
Summary

Calculates the intersection between this surface and the specified surface.

Visual Basic
Sub IntersectWithSurface(Surface As IGeSurface, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeSurfaceSurfaceIntersection*)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the surface to intersect with this surface.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeSurfaceSurfaceIntersection object


IGeSurface::ParameterOf Method
Summary

Calculates the 2D parameter point on this surface, which corresponds to the specified point.

Visual Basic
Sub ParameterOf(Point As IGePoint, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the parameter value. It should lie on the surface within the specified tolerance; otherwise, the results may be unpredictable.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object


IGeSurfaces Interface
Summary

A collection of GeSurface objects.

Class Hierarchy

Declaration syntax

IGeSurfaces
Visual Basic
Public Interface IGeSurfaces
Inherits IDispatch
Links
IGeSurfaces Members, GEAuto Library


IGeSurfaces Members
Summary

The following tables list the members exposed by IGeSurfaces.

Methods
Name | Description
Add | Appends a new surface to the collection.
Item | Gets the surface at the specified index.
Remove | Removes the specified surface from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the surfaces in a surface collection.


IGeSurfaces::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeSurfaces::Count Property
Summary

Gets the total number of the surfaces in a surface collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGeSurfaces::Add Method
Summary

Appends a new surface to the collection.

Visual Basic
Sub Add(Surface As IGeSurface)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the new surface to add to the collection.
Returns

None


IGeSurfaces::Item Method
Summary

Gets the surface at the specified index.

Visual Basic
Sub Item(Index As long, Surface As [out, retval] IGeSurface*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the surface to get from the collection.
Returns

GeSurface object


IGeSurfaces::Remove Method
Summary

Removes the specified surface from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the surface to be removed.
Returns

None


IGeSurfaceSurfaceIntersection Interface
Summary

Calculates the intersection between two surfaces.

Class Hierarchy

Declaration syntax

IGeSurfaceSurfaceIntersection
Visual Basic
Public Interface IGeSurfaceSurfaceIntersection
Inherits IDispatch
Links
IGeSurfaceSurfaceIntersection Members, GEAuto Library


IGeSurfaceSurfaceIntersection Members
Summary

The following tables list the members exposed by IGeSurfaceSurfaceIntersection.

Methods
Name | Description
GetIntersectionCofiguration | Gets the characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
IntersectionCurve | Gets the intersection curve at the specified intersection index.
IntersectionDimension | Gets the dimension of the intersection at the specified intersection index.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterCurveOnSurface1 | Gets the parametric curve on the first surface at the specified intersection index.
ParameterCurveOnSurface2 | Gets the parametric curve on the second surface at the specified intersection index.
ParameterOnSurface1 | Gets the surface parameter values on the first surface at the specified intersection index.
ParameterOnSurface2 | Gets the surface parameter values on the second surface at the specified intersection point. This property will fail if the intersection dimension at the specified intersection index is not 0.
Set | Sets the two surfaces being intersected and optionally the tolerance used in the calculation.
Properties
Name | Description
IntersectionCount | Gets the number of intersections calculated.
Surface1 | Specifies the first surface for this intersection.
Surface2 | Specifies the second surface for this intersection.
Tolerance | Specifies the tolerance used in the intersection calculation.


IGeSurfaceSurfaceIntersection::IntersectionCount Property
Summary

Gets the number of intersections calculated.

Visual Basic
Property IntersectionCount() As long*
Remarks

This property is a Long.


IGeSurfaceSurfaceIntersection::Surface1 Property
Summary

Specifies the first surface for this intersection.

Visual Basic
Property Surface1() As IGeSurface*
Remarks

This property is a GeSurface object.


IGeSurfaceSurfaceIntersection::Surface2 Property
Summary

Specifies the second surface for this intersection.

Visual Basic
Property Surface2() As IGeSurface*
Remarks

This property is a GeSurface object.


IGeSurfaceSurfaceIntersection::Tolerance Property
Summary

Specifies the tolerance used in the intersection calculation.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.


IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method
Summary

Gets the characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.

Visual Basic
Sub GetIntersectionCofiguration(Index As long, ByRef Surf1Left As GeSurfSurfIntConfiguration, ByRef Surf1Right As GeSurfSurfIntConfiguration, ByRef Surf2Left As GeSurfSurfIntConfiguration, ByRef Surf2Right As GeSurfSurfIntConfiguration, ByRef Type As GeSurfSurfIntType, ByRef Dimension As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the second surface that intersects with this surface.
Surf1Left | GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection characterization of the intersection curve on this surface that is left to its surface normal orientation and the direction of the curve parameterization.
Surf1Right | GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection type of the intersection curve on this surface that is right to its surface normal orientation and the direction of the curve parameterization.
Surf2Left | GeSurfSurfIntConfiguration enumeration; output-only. GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection type of the intersection curve on the specified surface that is left to its surface normal orientation and the direction of the curve parameterization.
Surf2Right | GeSurfSurfIntConfiguration enumeration; output-only. GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection characterization of the intersection curve on the specified surface that is right to its surface normal orientation and the direction of the curve parameterization.
Type | GeSurfSurfIntType enumeration; output-only. Returns the intersection type of the specified intersection between this surface and the specified surface.
Dimension | Description to come
Returns

None


IGeSurfaceSurfaceIntersection::IntersectionCurve Method
Summary

Gets the intersection curve at the specified intersection index.

Visual Basic
Sub IntersectionCurve(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension property, IntersectionDimension , at the specified index is not 1.


IGeSurfaceSurfaceIntersection::IntersectionDimension Method
Summary

Gets the dimension of the intersection at the specified intersection index.

Visual Basic
Sub IntersectionDimension(Index As long, Dimension As [out, retval] long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a Long.
  • A dimension of zero indicates the surface-surface intersection is a point; a dimension of 1 indicates the surfaces intersection is a curve.


IGeSurfaceSurfaceIntersection::IntersectionPoint Method
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GePoint object.
  • This property will fail if the intersection dimension property, IntersectionDimension , at the specified intersection index is not 0.


IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method
Summary

Gets the parametric curve on the first surface at the specified intersection index.

Visual Basic
Sub ParameterCurveOnSurface1(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension at the specified index is not 1.


IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method
Summary

Gets the parametric curve on the second surface at the specified intersection index.

Visual Basic
Sub ParameterCurveOnSurface2(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension at the specified index is not 1.


IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method
Summary

Gets the surface parameter values on the first surface at the specified intersection index.

Visual Basic
Sub ParameterOnSurface1(Index As long, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a GePoint object.
  • This property will fail if the intersection dimension at the specified intersection index is not 0.


IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method
Summary

Gets the surface parameter values on the second surface at the specified intersection point. This property will fail if the intersection dimension at the specified intersection index is not 0.

Visual Basic
Sub ParameterOnSurface2(Index As long, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a GePoint object.
  • This property will fail if the intersection dimension at the specified intersection index is not 0.


IGeSurfaceSurfaceIntersection::Set Method
Summary

Sets the two surfaces being intersected and optionally the tolerance used in the calculation.

Visual Basic
Sub Set(Surface1 As IGeSurface, Surface2 As IGeSurface, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Surface1 | GeSurface object; input-only. Specifies the first surface being intersected. This element can be later obtained by the GeSurfaceSurfaceIntersection > Surface1 property.
Surface2 | GeSurface object; input-only. Specifies the second surface being intersected. This element can be later obtained by the GeSurfaceSurfaceIntersection > Surface2 property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None


IGeTolerance Interface
Summary

Encapsulates tolerance values to use in calculations.

Class Hierarchy

Declaration syntax

IGeTolerance
Visual Basic
Public Interface IGeTolerance
Inherits IDispatch
Links
IGeTolerance Members, GEAuto Library


IGeTolerance Members
Summary

The following tables list the members exposed by IGeTolerance.

Properties
Name | Description
Application | Gets the GeApplication object.
EqualPoint | Specifies the distance between two points at which they are considered equal.
EqualVector | Specifies the tolerance to determine whether two vectors are considered equal, parallel, or perpendicular.


IGeTolerance::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeTolerance::EqualPoint Property
Summary

Specifies the distance between two points at which they are considered equal.

Visual Basic
Property EqualPoint() As double
Remarks

This property is a Double.


IGeTolerance::EqualVector Property
Summary

Specifies the tolerance to determine whether two vectors are considered equal, parallel, or perpendicular.

Visual Basic
Property EqualVector() As double
Remarks

This property is a Double.


IGeTorus Interface
Summary

A toroid or toroidal segment surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeTorus
Visual Basic
Public Interface IGeTorus
Inherits IGeSurface
Links
IGeTorus Members, GEAuto Library


IGeTorus Members
Summary

The following tables list the members exposed by IGeTorus.

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the torus and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this torus is closed in the U parameterization direction.
IsClosedInV | Gets whether this torus is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the torus with the specified center point and major and minor radii, and optionally with the axis of symmetry direction and start and ending angles in the U and V parameter directions.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Gets the axis of symmetry of the torus.
EndAngleInU | Specifies the end angle in the U parameter direction.
EndAngleInV | Specifies the end angle in the V parameter direction.
MajorRadius | Specifies the major radius of this torus.
MinorRadius | Specifies the minor radius of this torus.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of this torus.
ReferenceAxis | Gets the direction of the zero meridian.
StartAngleInU | Specifies the start angle in the U parameter direction.
StartAngleInV | Specifies the start angle in the V parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


IGeTorus::AxisOfSymmetry Property
Summary

Gets the axis of symmetry of the torus.

Visual Basic
Property AxisOfSymmetry() As IGeVector**
Remarks

This property is a GeVector object.


IGeTorus::EndAngleInU Property
Summary

Specifies the end angle in the U parameter direction.

Visual Basic
Property EndAngleInU() As double
Remarks

This property is a Double.


IGeTorus::EndAngleInV Property
Summary

Specifies the end angle in the V parameter direction.

Visual Basic
Property EndAngleInV() As double
Remarks

This property is a Double.


IGeTorus::MajorRadius Property
Summary

Specifies the major radius of this torus.

Visual Basic
Property MajorRadius() As double
Remarks

This property is a Double.


IGeTorus::MinorRadius Property
Summary

Specifies the minor radius of this torus.

Visual Basic
Property MinorRadius() As double
Remarks

This property is a Double.


IGeTorus::Origin Property
Summary

Gets the center of this torus.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.


IGeTorus::ReferenceAxis Property
Summary

Gets the direction of the zero meridian.

Visual Basic
Property ReferenceAxis() As IGeVector**
Remarks

This property is a GeVector object.


IGeTorus::StartAngleInU Property
Summary

Specifies the start angle in the U parameter direction.

Visual Basic
Property StartAngleInU() As double
Remarks

This property is a Double.


IGeTorus::StartAngleInV Property
Summary

Specifies the start angle in the V parameter direction.

Visual Basic
Property StartAngleInV() As double
Remarks

This property is a Double.


IGeTorus::IntersectWith Method
Summary

Computes the intersection between the torus and the specified linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, ByRef Point3 As IGePoint*, ByRef Point4 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this torus.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Point3 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
Point4 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeTorus::IsClosedInU Method
Summary

Gets whether this torus is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInU(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeTorus::IsClosedInV Method
Summary

Gets whether this torus is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInV(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeTorus::Set Method
Summary

Sets the torus with the specified center point and major and minor radii, and optionally with the axis of symmetry direction and start and ending angles in the U and V parameter directions.

Visual Basic
Sub Set(MajorRadius As double, MinorRadius As double, Center As IGePoint, SymmetryAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartUAngle As [in, optional] VARIANT, EndUAngle As [in, optional] VARIANT, StartVAngle As [in, optional] VARIANT, EndVAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
MajorRadius | Double; input-only. Specifies the major radius of this torus.
MinorRadius | Double; input-only. Specifies the minor radius of this torus.
Center | GePoint object; input-only. Specifies the center point of this torus.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the torus axis of symmetry direction.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector from which U angles are measured.
StartUAngle | Variant (Double); input-only; optional. Specifies the start U parameter angle.
EndUAngle | Variant (Double); input-only; optional. Specifies the end U parameter angle.
StartVAngle | Variant (Double); input-only; optional. Specifies the start V parameter angle.
EndVAngle | Variant (Double); input-only; optional. Specifies the end V parameter angle.
Returns

None


IGeVector Interface
Summary

A vector in three-dimensional space.

Class Hierarchy

Declaration syntax

IGeVector
Visual Basic
Public Interface IGeVector
Inherits IDispatch
Links
IGeVector Members, GEAuto Library


IGeVector Members
Summary

The following tables list the members exposed by IGeVector.

Methods
Name | Description
AngleTo | Computes the angle between this vector and the specified vector.
CrossProduct | Computes the cross product of this vector and the specified vector.
DotProduct | Computes the dot product of this vector and the specified vector.
Get | Gets the coordinate data from this vector.
IsCodirectionalTo | Determines whether this vector is codirectional to the specified vector, TRUE, or not, FALSE.
IsEqualTo | Determines whether this vector is equal to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsParallelTo | Determines whether this vector is parallel with the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this vector is perpendicular to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsUnitLength | Gets whether this vector is of unit length, TRUE, or not, FALSE.
IsZeroLength | Gets whether this vector is zero length, TRUE, or not, FALSE.
Item | Specifies the item value at the specified index.
Item | Specifies the item value at the specified index.
Mirror | Mirrors this vector about the specified plane.
MultiplyBy | Computes the vector equal to this vector multiplied by the specified scale factor.
Negate | Sets this vector to be equal to its current opposite vector.
Normalize | Sets this vector to be equal to its normal vector.
PerpendicularVector | Calculates a vector orthogonal to this vector.
Product | Returns the vector equal to the product of the specified matrix and this vector.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
RotateBy | Rotates this vector around the line with the specified direction vector passing through the origin. The specified Rotation angle's positive direction of rotation is defined by the right hand rule.
ScaleBy | Multiplies this vector by the scale factor.
Set | Sets the vector as this vector from the specified start point to the specified end point.
SetToProduct | Sets this vector to the product of the specified matrix and the specified vector.
SetToSum | Sets this vector equal to the sum of the two specified vectors.
Sum | Returns the vector equal to the sum of this vector and the specified vector.
TransformBy | Transforms this vector by the specified matrix.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Returns the coordinates of elements in unit length on this vector as an array of Doubles.
LargestElement | Gets the index of the largest absolute value coordinate of this vector.
Length | Gets this length of the vector.
Negative | Gets the vector opposite to this vector.
Normal | Returns the unit vector codirectional to this vector.
X | Specifies the X coordinate data of this vector.
Y | Specifies the Y coordinate data of this vector.
Z | Specifies the Z coordinate data of this vector.


IGeVector::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeVector::AsArray Property
Summary

Returns the coordinates of elements in unit length on this vector as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).


IGeVector::LargestElement Property
Summary

Gets the index of the largest absolute value coordinate of this vector.

Visual Basic
Property LargestElement() As long*
Remarks

This property is a Long.


IGeVector::Length Property
Summary

Gets this length of the vector.

Visual Basic
Property Length() As double*
Remarks

This property is a Double.


IGeVector::Negative Property
Summary

Gets the vector opposite to this vector.

Visual Basic
Property Negative() As IGeVector**
Remarks

This property is a GeVector object.


IGeVector::Normal Property
Summary

Returns the unit vector codirectional to this vector.

Visual Basic
Property Normal() As IGeVector**
Remarks

This property is a GeVector object.


IGeVector::X Property
Summary

Specifies the X coordinate data of this vector.

Visual Basic
Property X() As double
Remarks

This property is a Double.


IGeVector::Y Property
Summary

Specifies the Y coordinate data of this vector.

Visual Basic
Property Y() As double
Remarks

This property is a Double.


IGeVector::Z Property
Summary

Specifies the Z coordinate data of this vector.

Visual Basic
Property Z() As double
Remarks

This property is a Double.


IGeVector::AngleTo Method
Summary

Computes the angle between this vector and the specified vector.

Visual Basic
Sub AngleTo(Vector As IGeVector, ReferenceVector As [in, optional] VARIANT, Angle As [out, retval] double)
Parameters
Parameters
Description
Vector
GeVector object; input-only. Specifies the other vector to perform the calculation.
ReferenceVector
GeVector object; input-only; optional. Specifies the reference vector to perform the calculation.

  • If not specified, the angle returned is in the range [0, PI].
  • If specified and (RefVec.DotProduct(This.CrossProduct(Vector)) >= 0.0 ), the return value coincides with the return value of the method without the reference vector specified; otherwise the return value is 2*PI minus the return value of the method without the reference vector specified.

Returns

Double


IGeVector::CrossProduct Method
Summary

Computes the cross product of this vector and the specified vector.

Visual Basic
Sub CrossProduct(Vector As IGeVector, CrossProduct As [out, retval] IGeVector*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

GeVector object


IGeVector::DotProduct Method
Summary

Computes the dot product of this vector and the specified vector.

Visual Basic
Sub DotProduct(Vector As IGeVector, DotProduct As [out, retval] double)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

Double


IGeVector::Get Method
Summary

Gets the coordinate data from this vector.

Visual Basic
Sub Get(ByRef X As double, ByRef Y As double, ByRef Z As double)
Parameters
Parameters | Description
X | Double; output-only. Returns the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the Y axis.
Z | Double; output-only. Returns the coordinate data of the Z axis.
Returns

None


IGeVector::IsCodirectionalTo Method
Summary

Determines whether this vector is codirectional to the specified vector, TRUE, or not, FALSE.

Visual Basic
Sub IsCodirectionalTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Codirectional As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeVector::IsEqualTo Method
Summary

Determines whether this vector is equal to the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeVector::IsParallelTo Method
Summary

Determines whether this vector is parallel with the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsParallelTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeVector::IsPerpendicularTo Method
Summary

Determines whether this vector is perpendicular to the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsPerpendicularTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean


IGeVector::IsUnitLength Method
Summary

Gets whether this vector is of unit length, TRUE, or not, FALSE.

Visual Basic
Sub IsUnitLength(Tolerance As [in, optional] VARIANT, UnitLength As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeVector::IsZeroLength Method
Summary

Gets whether this vector is zero length, TRUE, or not, FALSE.

Visual Basic
Sub IsZeroLength(Tolerance As [in, optional] VARIANT, ZeroLength As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.


IGeVector::Item Method ([in] long, [in] double)
Summary

Specifies the item value at the specified index.

Visual Basic
Sub Item(Item As long, Value As double)
Parameters
Parameters | Description
Item | Long; input-only. Specifies the index to get the item value.
Remarks

This property is a Double.


IGeVector::Item Method ([in] long, [out, retval] double*)
Summary

Specifies the item value at the specified index.

Visual Basic
Sub Item(Item As long, Value As [out, retval] double)
Parameters
Parameters | Description
Item | Long; input-only. Specifies the index to get the item value.
Remarks

This property is a Double.


IGeVector::Mirror Method
Summary

Mirrors this vector about the specified plane.

Visual Basic
Sub Mirror(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GePlane object; input-only. Specifies the plane with respect to which this vector is mirrored.
Returns

None


IGeVector::MultiplyBy Method
Summary

Computes the vector equal to this vector multiplied by the specified scale factor.

Visual Basic
Sub MultiplyBy(Scale As double, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Scale | Double; input-only. Specifies the scale factor to perform the calculation.
Returns

GeVector object


IGeVector::Negate Method
Summary

Sets this vector to be equal to its current opposite vector.

Visual Basic
Sub Negate()
Returns

None


IGeVector::Normalize Method
Summary

Sets this vector to be equal to its normal vector.

Visual Basic
Sub Normalize()
Returns

None


IGeVector::PerpendicularVector Method
Summary

Calculates a vector orthogonal to this vector.

Visual Basic
Sub PerpendicularVector(Vector As [out, retval] IGeVector*)
Returns

GeVector object

Remarks

The perpendicular vector is determined by the arbitrary axis algorithm.


IGeVector::Product Method
Summary

Returns the vector equal to the product of the specified matrix and this vector.

Visual Basic
Sub Product(Matrix As IGeMatrix, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix based on which to perform the calculation.
Returns

GeVector object

Remarks

The order of multiplication is matrix * vector, where vectors are considered as columns.


IGeVector::Project Method
Summary

Returns the entity that is the projection of the curve onto the projection plane in the specified direction.

Visual Basic
Sub Project(Normal As IGeVector, Direction As [in, optional] VARIANT, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Normal | GeVector object; input-only. Specifies the normal of the plane to which to project this vector.
Direction | Variant ( GeVector object); input-only; optional. Specifies the direction in which to project this vector; if not specified, the projection is orthogonal to the plane.
Returns

GeVector object


IGeVector::RotateBy Method
Summary

Rotates this vector around the line with the specified direction vector passing through the origin. The specified Rotation angle's positive direction of rotation is defined by the right hand rule.

Visual Basic
Sub RotateBy(Angle As double, Vector As IGeVector)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this vector. The positive direction of rotation is defined by the right hand rule.
Vector | GeVector object; input-only. Specifies the polar vector to rotate this vector.
Returns

None


IGeVector::ScaleBy Method
Summary

Multiplies this vector by the scale factor.

Visual Basic
Sub ScaleBy(Factor As double)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the scale factor to change the size of this vector.
Returns

None


IGeVector::Set Method
Summary

Sets the vector as this vector from the specified start point to the specified end point.

Visual Basic
Sub Set(StartPoint As IGePoint, EndPoint As IGePoint)
Parameters
Parameters | Description
StartPoint | GePoint object; input-only. Specifies the start point to define this vector.
EndPoint | GePoint object; input-only. Specifies the end point to define this vector.
Returns

None


IGeVector::SetToProduct Method
Summary

Sets this vector to the product of the specified matrix and the specified vector.

Visual Basic
Sub SetToProduct(Matrix As IGeMatrix, Vector As IGeVector)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix to perform the calculation.
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

None

Remarks

The order of multiplication is matrix * vector, where vectors are considered as columns.


IGeVector::SetToSum Method
Summary

Sets this vector equal to the sum of the two specified vectors.

Visual Basic
Sub SetToSum(Vector1 As IGeVector, Vector2 As IGeVector)
Parameters
Parameters | Description
Vector1 | GeVector object; input-only. Specifies the first vector to perform the calculation.
Vector2 | GeVector object; input-only. Specifies the second vector to perform the calculation.
Returns

None


IGeVector::Sum Method
Summary

Returns the vector equal to the sum of this vector and the specified vector.

Visual Basic
Sub Sum(Vector As IGeVector, Result As [out, retval] IGeVector*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

GeVector object


IGeVector::TransformBy Method
Summary

Transforms this vector by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As IGeMatrix)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix by which to transform this vector.
Returns

None


IGeVectors Interface
Summary

A collection of GeVector objects.

Class Hierarchy

Declaration syntax

IGeVectors
Visual Basic
Public Interface IGeVectors
Inherits IDispatch
Links
IGeVectors Members, GEAuto Library


IGeVectors Members
Summary

The following tables list the members exposed by IGeVectors.

Methods
Name | Description
Add | Appends a new vector to the collection.
Item | Gets the vector at the specified index.
Remove | Removes the specified vector from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the vectors in a vector collection.


IGeVectors::Application Property
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.


IGeVectors::Count Property
Summary

Gets the total number of the vectors in a vector collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.


IGeVectors::Add Method
Summary

Appends a new vector to the collection.

Visual Basic
Sub Add(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the new vector to add to the collection.
Returns

None


IGeVectors::Item Method
Summary

Gets the vector at the specified index.

Visual Basic
Sub Item(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the vector to get from the collection.
Returns

GeVector object


IGeVectors::Remove Method
Summary

Removes the specified vector from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the point to be removed.
Returns

None


Mcad2DSPreview

Mechanical Structure Preview ActiveX Control (Mcad2DSPreview). Allows users to display a thumbnail bitmap of a block, a list of entities, a folder, a component view, or an entire component (tiled views).

Remarks

For detailed information about McadFolderDescriptor and McadComponentViewDescriptor, refer to the Symbol, Balloon, and Bill of Materials (SymBBAuto) section in this Reference Guide.

Descriptor Property

When dropping the control on a form, sets the Descriptor property to an McadFolderDescriptor or a McadComponentViewDescriptor:

  • Displays a preview of the definition on the current model space background color if the descriptor actually points to a folder or a component view.
  • Displays a set of model space entities by creating an McadFolderDescriptor and setting the Entities property to a set of ObjectIDs of entities in model space.
  • Displays the contents of a block by creating an McadFolderDescriptor and placing a single element in the Entites member which is the ObjectID of an AcadBlock.


Sample Code
Sample Code

This Reference Guide includes some VBA sample code snippets for typical methods or properties, located in relevant Example sections. However, for many more detailed examples, please refer to the Developer Guide.

Also, for more complete sample code projects, including use of mechanical structure methods, please refer to the sample projects in the SDK (Software Developers Kit).


Example
McadAnnotationViewDefinition CoClass

Refer to SDK Samples: CreateStructure.dvb


Example
IAcadmApplication::GetFormulaEvaluator Method

Refer to SDK Samples: FormulaEvaluator.dvb


Example
IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::GetNextComponentDefinitionName Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::HasComponentDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::Is2DStructureEnabled Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::IsEntityAllowed Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcad2DStructureMgr::IsFreeEntity Method

Refer to SDK Samples: CreateStructure.dvb


Example
IMcadAnnotationViewDefinition2 Interface

Refer to SDK Samples: CreateStructure.dvb


Example
IMcadAnnotationViewDefinition Interface

Refer to SDK Samples: CreateStructure.dvb


Example
IMcadAnnotationViewDefinition::AddComponentView Method

Refer to SDK Samples: CreateStructure.dvb


See Also
IMcadBOMMgr2::ExportPartList Method
See Also

McadBOMMgr Object


Example
IMcadComplexHideSituation::AddLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Concealed Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Definition Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Explode Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::HiddenLinesInvisible Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::HideAppropriateObjectsOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::HideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::IsModifiedStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::IsStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::LevelCount Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::LookupLevelName Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::MoveLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Name Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::NextLevelName Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::RemoveLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::RemoveLevelByIdx Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Reverse Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::Suppressed Property

Refer to SDK Samples: amshide2d.dvb


Example
IMcadComplexHideSituation::SysName Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComplexHideSituation::UpdateBgSelection Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadComponent::CopyDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Example
IMcadComponent::ReplaceDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Example
IMcadFolder::CopyEntities Method

Refer to SDK Samples: RestructureView.dvb


Example
IMcadFolder::CopyView Method

Refer to SDK Samples: RestructureView.dvb


Example
IMcadFolder::CopyViewDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Example
IMcadFolder::ViewScale Property

Refer to SDK Samples: RestructureView.dvb


Example
IMcadFolderDefinition::AddComplexHideSituation Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::AddHideSituation Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::ComplexHideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::FindHideSituations Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::GetHidesSuppressState Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::HideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadFolderDefinition::SetHidesSuppressState Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::AddMSSubent Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::AddMSSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::AddSubent Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::AddSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::AutoSelectBackground Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::BgSelectionName Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::ClearSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::Concealed Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::ContoursOnlyInForeground Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::Definition Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::FgSelectionName Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::HiddenLinesInvisible Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::HideAppropriateObjectsOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::IgnoreBgExclude Property

Refer to SDK Samples: amshide2d.dvb


Example
IMcadHideSituation::IgnoreFgExclude Property

Refer to SDK Samples: amshide2d.dvb


Example
IMcadHideSituation::IgnoreUpperBgExclude Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::InverseForeground Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::IsComplexHideLevel Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::IsLastLevel Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::IsModifiedStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::IsStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::LevelIndex Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::Name Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::OuterContourOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::ParentHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::RemoveSubentByIdx Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::SaveSimplifiedOuterContour Property

Refer to SDK Samples: amshide2d.dvb


Example
IMcadHideSituation::Subents Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::Suppressed Property

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::SwapFgAndBg Method

Refer to SDK Samples: AMSHide2D.dvb


Example
IMcadHideSituation::SysName Property

Refer to SDK Samples: AMSHide2D.dvb


Contents
Introduction
Type Libraries and Object Models
API Reference
AcadmAuto Library
AcadmApplication CoClass
IAcadmApplication Interface
IAcadmApplication Members
IAcadmApplication::ActiveDocument Property
IAcadmApplication::Application Property
IAcadmApplication::AttributeClasses Property
IAcadmApplication::Documents Property
IAcadmApplication::StructureModeEditEntity Property
IAcadmApplication::AddAttributeClass Method
IAcadmApplication::DocumentFromHost Method
IAcadmApplication::GetAttributeClassFields Method
IAcadmApplication::GetFormulaEvaluator Method
IAcadmApplication::ReadAttributeClass Method
IAcadmApplication::RemoveAttributeClass Method
IAcadmApplication::WriteAttributeClass Method
IAcadmApplicationVersion Interface
IAcadmApplicationVersion Members
IAcadmApplicationVersion::GetVersionNumber Method
IMcad2dComplexStdPartCompGroupDescriptor Interface
IMcad2dComplexStdPartCompGroupDescriptor Members
IMcad2dComplexStdPartCompGroupDescriptor::Views Property
IMcad2dComplexStdPartCompGroupDescriptor::AddView Method
IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method
IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method
IMcad2dComponentDescriptor Interface
IMcad2dComponentDescriptor Members
IMcad2dComponentDescriptor::Component Property
IMcad2dComponentDescriptor::ComponentDefinition Property
IMcad2dComponentDescriptor::ComponentViews Property
IMcad2dComponentDescriptor::OwningComponentDefinition Property
IMcad2dComponentDescriptor::AddComponentView Method
IMcad2dComponentDescriptor::CreateComponent Method
IMcad2dComponentDescriptor::HasEqualTypeWithView Method
IMcad2dComponentDescriptor::RemoveComponentView Method
IMcad2dShaftCompGroupDescriptor Interface
IMcad2dShaftCompGroupDescriptor Members
IMcad2dShaftCompGroupDescriptor::Views Property
IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dStdPartComponentDescriptor Interface
IMcad2DStructureDescriptor Interface
IMcad2DStructureDescriptor Members
IMcad2DStructureDescriptor::Name Property
IMcad2DStructureMgr Interface
IMcad2DStructureMgr Members
IMcad2DStructureMgr::Application Property
IMcad2DStructureMgr::EditTarget Property
IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr::AddNewComponentDefinition Method
IMcad2DStructureMgr::AddNewComponentView Method
IMcad2DStructureMgr::AddNewComponentViewDefinition Method
IMcad2DStructureMgr::AddNewFolder Method
IMcad2DStructureMgr::AddNewFolderDefinition Method
IMcad2DStructureMgr::CopyComponentFromDatabase Method
IMcad2DStructureMgr::CopyFolderFromDatabase Method
IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method
IMcad2DStructureMgr::Create2dComponentDescriptor Method
IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method
IMcad2DStructureMgr::CreateBlocksFromStructure Method
IMcad2DStructureMgr::CreateComponentViewDescriptor Method
IMcad2DStructureMgr::CreateFolderDescriptor Method
IMcad2DStructureMgr::CreateStructureFromBlocks Method
IMcad2DStructureMgr::ExternalStructureDatabases Method
IMcad2DStructureMgr::GetComplexStdPartsForMigr Method
IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method
IMcad2DStructureMgr::GetComponentDefinitions Method
IMcad2DStructureMgr::GetComponentViewDefinitions Method
IMcad2DStructureMgr::GetFolderDefinitions Method
IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method
IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
IMcad2DStructureMgr::GetNextComponentDefinitionName Method
IMcad2DStructureMgr::GetNextFolderDefinitionName Method
IMcad2DStructureMgr::GetSelection Method
IMcad2DStructureMgr::GetShaftsForMigr Method
IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method
IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method
IMcad2DStructureMgr::GetStructureFromEntity Method
IMcad2DStructureMgr::HasComponentDefinition Method
IMcad2DStructureMgr::HasFolderDefinition Method
IMcad2DStructureMgr::Highlight Method
IMcad2DStructureMgr::Is2DStructureEnabled Method
IMcad2DStructureMgr::IsEntityAllowed Method
IMcad2DStructureMgr::IsFreeEntity Method
IMcad2DStructureMgr::IsInActiveTarget Method
IMcad2DStructureMgr::IsStructureBlock Method
IMcad2DStructureMgr::PurgeAll2DS Method
IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method
IMcad2DStructureMgr::PurgeComponentDefinitions Method
IMcad2DStructureMgr::PurgeComponentViewDefinitions Method
IMcad2DStructureMgr::PurgeFolderDefinitions Method
IMcad2DStructureMgr::RestructureViews Method
IMcad2DStructureMgr::RootComponentDefinition Method
IMcad2DStructureMgr::RootViewDefinition Method
IMcad2DStructureMgr::Update Method
IMcad2DStructureMgr::UpdateEntities Method
IMcad2DStructureMgr2 Interface
IMcad2DStructureMgr2 Members
IMcad2DStructureMgr2::StartTransaction Property
IMcad2DStructureMgr3 Interface
IMcad2DStructureMgr3 Members
IMcad2DStructureMgr3::AddNewAnnotationView Method
IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr3::UpdateEntities Method
IMcad2DStructureMgr4 Interface
IMcad2DStructureMgr4 Members
IMcad2DStructureMgr4::SelectionLockMode Property
IMcad2DStructureMgr4::SelectionOrderMode Property
IMcad2DStructureMgr4::GetReferenceLockMode Method
IMcad2DStructureMgr4::GetStructureMode Method
IMcad2DStructureMgr4::SetReferenceLockMode Method
IMcad2DStructureMgr4::SetStructureMode Method
IMcad2DStructureMgr5 Interface
IMcad2DStructureMgr5 Members
IMcad2DStructureMgr5::CreateRootViewDefinition Method
IMcad2DStructureMgr5::ExistsStructure Method
IMcadAnnotationViewDefinition Interface
IMcadAnnotationViewDefinition Members
IMcadAnnotationViewDefinition::ComponentDefinition Property
IMcadAnnotationViewDefinition::AddComponentView Method
IMcadAnnotationViewDefinition::RemoveComponentView Method
IMcadAnnotationViewDefinition2 Interface
IMcadAnnotationViewDefinition2 Members
IMcadAnnotationViewDefinition2::AnnotationViewLabel Method
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method
IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method
IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method
IMcadAnnotationViewDefinitions Interface
IMcadAnnotationViewDefinitions Members
IMcadAnnotationViewDefinitions::Application Property
IMcadAnnotationViewDefinitions::Count Property
IMcadAnnotationViewDefinitions::Add Method
IMcadAnnotationViewDefinitions::Item Method
IMcadAnnotationViewDefinitions::Remove Method
IMcadArc Interface
IMcadAttribute Interface
IMcadAttribute Members
IMcadAttribute::Application Property
IMcadAttribute::ClassName Property
IMcadAttribute::Document Property
IMcadAttribute::FieldCount Property
IMcadAttribute::Holders Property
IMcadAttribute::ObjectID Property
IMcadAttribute::ObjectID32 Property
IMcadAttribute::FieldDescription Method
IMcadAttribute::FieldName Method
IMcadAttribute::FieldType Method
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute::GetFieldIndex Method
IMcadAttributeField Interface
IMcadAttributeField Members
IMcadAttributeField::Application Property
IMcadAttributeField::Description Property
IMcadAttributeField::FieldType Property
IMcadAttributeField::Name Property
IMcadAttributeField::Static Property
IMcadAttributeFields Interface
IMcadAttributeFields Members
IMcadAttributeFields::Application Property
IMcadAttributeFields::Count Property
IMcadAttributeFields::Add Method
IMcadAttributeFields::Item Method
IMcadAttributeFields::Remove Method
IMcadAttributes Interface
IMcadAttributes Members
IMcadAttributes::Application Property
IMcadAttributes::Count Property
IMcadAttributes::Add Method
IMcadAttributes::Item Method
IMcadAttributes::Remove Method
IMcadAugmentedLine Interface
IMcadComplexHideSituation Interface
IMcadComplexHideSituation Members
IMcadComplexHideSituation::Concealed Property
IMcadComplexHideSituation::Definition Property
IMcadComplexHideSituation::HiddenLinesInvisible Property
IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
IMcadComplexHideSituation::HideSituations Property
IMcadComplexHideSituation::IsModifiedStandardPartHide Property
IMcadComplexHideSituation::IsStandardPartHide Property
IMcadComplexHideSituation::LevelCount Property
IMcadComplexHideSituation::Name Property
IMcadComplexHideSituation::NextLevelName Property
IMcadComplexHideSituation::Suppressed Property
IMcadComplexHideSituation::SysName Property
IMcadComplexHideSituation::AddLevel Method
IMcadComplexHideSituation::Explode Method
IMcadComplexHideSituation::InitFromHide Method
IMcadComplexHideSituation::LookupLevelName Method
IMcadComplexHideSituation::MoveLevel Method
IMcadComplexHideSituation::RemoveLevel Method
IMcadComplexHideSituation::RemoveLevelByIdx Method
IMcadComplexHideSituation::Reverse Method
IMcadComplexHideSituation::UpdateBgSelection Method
IMcadComplexHideSituations Interface
IMcadComplexHideSituations Members
IMcadComplexHideSituations::Application Property
IMcadComplexHideSituations::Count Property
IMcadComplexHideSituations::Add Method
IMcadComplexHideSituations::Item Method
IMcadComplexHideSituations::Remove Method
IMcadComponent Interface
IMcadComponent Members
IMcadComponent::Children Property
IMcadComponent::ComponentViews Property
IMcadComponent::Definition Property
IMcadComponent::hasExternalDef Property
IMcadComponent::HasGhostViews Property
IMcadComponent::HasOverrideProperties Property
IMcadComponent::is2D Property
IMcadComponent::Name Property
IMcadComponent::Owner Property
IMcadComponent::Position Property
IMcadComponent::Reference Property
IMcadComponent::Visible Property
IMcadComponent::AddAttribute Method
IMcadComponent::ClearOverrideProperties Method
IMcadComponent::ColorOverride Method
IMcadComponent::ContainingComponent Method
IMcadComponent::CopyDefinition Method
IMcadComponent::GetAttributes Method
IMcadComponent::GetComponentInDefinition Method
IMcadComponent::PredefinedReferenceOverride Method
IMcadComponent::RemoveAttribute Method
IMcadComponent::ReplaceDefinition Method
IMcadComponent::SortChildren Method
IMcadComponent::VisibilityOverride Method
IMcadComponentDefinition Interface
IMcadComponentDefinition Members
IMcadComponentDefinition::Children Property
IMcadComponentDefinition::ComponentViewDefinitions Property
IMcadComponentDefinition::ExternalPath Property
IMcadComponentDefinition::is2D Property
IMcadComponentDefinition::is2DAssembly Property
IMcadComponentDefinition::IsExternal Property
IMcadComponentDefinition::isFeature Property
IMcadComponentDefinition::IsLeafNode Property
IMcadComponentDefinition::IsRoot Property
IMcadComponentDefinition::isShaft Property
IMcadComponentDefinition::isStandardPart Property
IMcadComponentDefinition::Name Property
IMcadComponentDefinition::PhantomState Property
IMcadComponentDefinition::AddAttribute Method
IMcadComponentDefinition::AddComponent Method
IMcadComponentDefinition::CopyDefinition Method
IMcadComponentDefinition::Externalize Method
IMcadComponentDefinition::GetAttributes Method
IMcadComponentDefinition::GetInstances Method
IMcadComponentDefinition::GetNextComponentViewDefinitionName Method
IMcadComponentDefinition::HasComponentViewDefinition Method
IMcadComponentDefinition::Localize2DS Method
IMcadComponentDefinition::RemoveAttribute Method
IMcadComponentDefinition::RemoveComponent Method
IMcadComponentDefinition::SortChildren Method
IMcadComponentDefinition::Update Method
IMcadComponentDefinitions Interface
IMcadComponentDefinitions Members
IMcadComponentDefinitions::Application Property
IMcadComponentDefinitions::Count Property
IMcadComponentDefinitions::Add Method
IMcadComponentDefinitions::Item Method
IMcadComponentDefinitions::Remove Method
IMcadComponents Interface
IMcadComponents Members
IMcadComponents::Application Property
IMcadComponents::Count Property
IMcadComponents::Add Method
IMcadComponents::Item Method
IMcadComponents::Remove Method
IMcadComponentView Interface
IMcadComponentView Members
IMcadComponentView::Component Property
IMcadComponentView::isFeature Property
IMcadComponentView::IsGhostView Method
IMcadComponentViewDefinition Interface
IMcadComponentViewDefinition Members
IMcadComponentViewDefinition::IsFeature Property
IMcadComponentViewDefinition::Owner Property
IMcadComponentViewDefinition::AddComponentView Method
IMcadComponentViewDefinition::RemoveComponentView Method
IMcadComponentViewDefinitions Interface
IMcadComponentViewDefinitions Members
IMcadComponentViewDefinitions::Application Property
IMcadComponentViewDefinitions::Count Property
IMcadComponentViewDefinitions::Add Method
IMcadComponentViewDefinitions::Item Method
IMcadComponentViewDefinitions::Remove Method
IMcadComponentViewDescriptor Interface
IMcadComponentViewDescriptor Members
IMcadComponentViewDescriptor::Component Property
IMcadComponentViewDescriptor::FullViewName Property
IMcadComponentViewDescriptor::CreateComponentView Method
IMcadComponentViews Interface
IMcadComponentViews Members
IMcadComponentViews::Application Property
IMcadComponentViews::Count Property
IMcadComponentViews::Add Method
IMcadComponentViews::Item Method
IMcadComponentViews::Remove Method
IMcadCurve Interface
IMcadDescriptor Interface
IMcadDescriptor Members
IMcadDescriptor::Application Property
IMcadDescriptor::Document Property
IMcadDocuments Interface
IMcadDocuments Members
IMcadDocuments::Application Property
IMcadDocuments::Count Property
IMcadDocuments::Item Method
IMcadDocumentVersion Interface
IMcadDocumentVersion Members
IMcadDocumentVersion::GetVersionNumber Method
IMcadEllipse Interface
IMcadFolder Interface
IMcadFolder Members
IMcadFolder::BasePoint Property
IMcadFolder::Children Property
IMcadFolder::ContextDefinition Property
IMcadFolder::Definition Property
IMcadFolder::Entities Property
IMcadFolder::Entities32 Property
IMcadFolder::ExtentsMaximum Property
IMcadFolder::ExtentsMinimum Property
IMcadFolder::GeomPathName Property
IMcadFolder::HasExternalDef Property
IMcadFolder::HasOverrideProperties Property
IMcadFolder::IsInstance Property
IMcadFolder::IsLeaf Property
IMcadFolder::IsLocked Property
IMcadFolder::Owner Property
IMcadFolder::Position Property
IMcadFolder::ViewName Property
IMcadFolder::ViewScale Property
IMcadFolder::Visible Property
IMcadFolder::AddEntities Method
IMcadFolder::ClearLeaf Method
IMcadFolder::ClearOverrideProperties Method
IMcadFolder::ColorOverride Method
IMcadFolder::CopyEntities Method
IMcadFolder::CopyView Method
IMcadFolder::CopyViewDefinition Method
IMcadFolder::Explode Method
IMcadFolder::IsSubentityOf Method
IMcadFolder::PredefinedReferenceOverride Method
IMcadFolder::RemoveEntities Method
IMcadFolder::ReplaceDefinition Method
IMcadFolder::VisibilityOverride Method
IMcadFolder2 Interface
IMcadFolder2 Members
IMcadFolder2::OwningSpace Property
IMcadFolderDefinition Interface
IMcadFolderDefinition Members
IMcadFolderDefinition::ChildrenCount Property
IMcadFolderDefinition::ComplexHideSituations Property
IMcadFolderDefinition::FullName Property
IMcadFolderDefinition::HideSituations Property
IMcadFolderDefinition::InstanceCount Property
IMcadFolderDefinition::IsAnnotation Property
IMcadFolderDefinition::IsDetail Property
IMcadFolderDefinition::IsLocked Property
IMcadFolderDefinition::IsRoot Property
IMcadFolderDefinition::LockType Property
IMcadFolderDefinition::Name Property
IMcadFolderDefinition::ViewType Property
IMcadFolderDefinition::AddComplexHideSituation Method
IMcadFolderDefinition::AddFolder Method
IMcadFolderDefinition::AddFromExistingEntities Method
IMcadFolderDefinition::AddHideSituation Method
IMcadFolderDefinition::Children Method
IMcadFolderDefinition::Extents Method
IMcadFolderDefinition::Externalize Method
IMcadFolderDefinition::FindHideSituations Method
IMcadFolderDefinition::GetHidesSuppressState Method
IMcadFolderDefinition::Instances Method
IMcadFolderDefinition::InstancesDefinition Method
IMcadFolderDefinition::IsExternal Method
IMcadFolderDefinition::Localize Method
IMcadFolderDefinition::LookupViewName Method
IMcadFolderDefinition::NextViewName Method
IMcadFolderDefinition::Occurrences Method
IMcadFolderDefinition::RemoveFolder Method
IMcadFolderDefinition::SetHidesSuppressState Method
IMcadFolderDefinition::SortChildren Method
IMcadFolderDefinitions Interface
IMcadFolderDefinitions Members
IMcadFolderDefinitions::Application Property
IMcadFolderDefinitions::Count Property
IMcadFolderDefinitions::Add Method
IMcadFolderDefinitions::Item Method
IMcadFolderDefinitions::Remove Method
IMcadFolderDescriptor Interface
IMcadFolderDescriptor Members
IMcadFolderDescriptor::Definition Property
IMcadFolderDescriptor::Entities Property
IMcadFolderDescriptor::Entities32 Property
IMcadFolderDescriptor::Position Property
IMcadFolderDescriptor::PowerObjectType Property
IMcadFolderDescriptor::TargetView Property
IMcadFolderDescriptor::ViewKey Property
IMcadFolderDescriptor::ViewName Property
IMcadFolderDescriptor::Views Property
IMcadFolderDescriptor::CreateFolder Method
IMcadFolders Interface
IMcadFolders Members
IMcadFolders::Application Property
IMcadFolders::Count Property
IMcadFolders::Add Method
IMcadFolders::Item Method
IMcadFolders::Remove Method
IMcadFormulaEvaluator Interface
IMcadFormulaEvaluator Members
IMcadFormulaEvaluator::Application Property
IMcadFormulaEvaluator::Evaluate Method
IMcadFormulaEvaluator::Exist Method
IMcadFormulaEvaluator::GetAllAttribs Method
IMcadFormulaEvaluator::GetAllAttribsData Method
IMcadFormulaEvaluator::GetAllAttribValues Method
IMcadFormulaEvaluator::GetData Method
IMcadFormulaEvaluator::IsEditable Method
IMcadFormulaEvaluator::SetData Method
IMcadFormulaEvaluator::SetDataProvider Method
IMcadGeometry Interface
IMcadGeometry Members
IMcadGeometry::Geometry Property
IMcadGeometry::AddAttribute Method
IMcadGeometry::ContainingComponent Method
IMcadGeometry::GetAttributes Method
IMcadGeometry::HasChanged Method
IMcadGeometry::RemoveAttribute Method
IMcadHideSituation Interface
IMcadHideSituation Members
IMcadHideSituation::BgSelectionName Property
IMcadHideSituation::Concealed Property
IMcadHideSituation::ContoursOnlyInForeground Property
IMcadHideSituation::Definition Property
IMcadHideSituation::FgSelectionName Property
IMcadHideSituation::HiddenLinesInvisible Property
IMcadHideSituation::HideAppropriateObjectsOnly Property
IMcadHideSituation::IgnoreBgExclude Property
IMcadHideSituation::IgnoreFgExclude Property
IMcadHideSituation::IgnoreUpperBgExclude Property
IMcadHideSituation::InverseForeground Property
IMcadHideSituation::IsComplexHideLevel Property
IMcadHideSituation::IsLastLevel Property
IMcadHideSituation::IsMigrated Property
IMcadHideSituation::IsModifiedStandardPartHide Property
IMcadHideSituation::IsStandardPartHide Property
IMcadHideSituation::LevelIndex Property
IMcadHideSituation::Name Property
IMcadHideSituation::OuterContourOnly Property
IMcadHideSituation::ParentHide Property
IMcadHideSituation::SaveSimplifiedOuterContour Property
IMcadHideSituation::Suppressed Property
IMcadHideSituation::SysName Property
IMcadHideSituation::AddMSSubent Method
IMcadHideSituation::AddMSSubents Method
IMcadHideSituation::AddSubent Method
IMcadHideSituation::AddSubents Method
IMcadHideSituation::AutoSelectBackground Method
IMcadHideSituation::ClearSubents Method
IMcadHideSituation::RemoveSubent Method
IMcadHideSituation::RemoveSubentByIdx Method
IMcadHideSituation::Subents Method
IMcadHideSituation::SwapFgAndBg Method
IMcadHideSituations Interface
IMcadHideSituations Members
IMcadHideSituations::Application Property
IMcadHideSituations::Count Property
IMcadHideSituations::Add Method
IMcadHideSituations::Item Method
IMcadHideSituations::Remove Method
IMcadLayerCfg Interface
IMcadLayerCfg Members
IMcadLayerCfg::AssocObjects Property
IMcadLayerCfg::Desc Property
IMcadLayerCfg::Invisible Property
IMcadLayerCfg::Key Property
IMcadLayerCfg::LineType Property
IMcadLayerCfg::LineTypeId Property
IMcadLayerCfg::LineTypeId32 Property
IMcadLayerCfg::LineWeight Property
IMcadLayerCfg::Name Property
IMcadLayerCfg::NoPlot Property
IMcadLayerCfg::NoReplicateInLayerGroup Property
IMcadLayerCfg::OverrideColorByLayerGroup Property
IMcadLayerCfg::TrueColor Property
IMcadLayerCfgs Interface
IMcadLayerCfgs Members
IMcadLayerCfgs::_NewEnum Property
IMcadLayerCfgs::Application Property
IMcadLayerCfgs::Count Property
IMcadLayerCfgs::Add Method
IMcadLayerCfgs::Item Method
IMcadLayerCfgs::Remove Method
IMcadLayerGroupMgr Interface
IMcadLayerGroupMgr Members
IMcadLayerGroupMgr::Document Property
IMcadLayerGroupMgr::GetLayerGroupEntities Method
IMcadLayerGroupMgr::GetLayerGroupEntities32 Method
IMcadLayerGroupMgr::GetLayerGroupNames Method
IMcadLayerGroupMgr::GetLayersFromGroup Method
IMcadLayerGroupMgr::MoveLayerGroupEntities Method
IMcadLayerObjectCfg Interface
IMcadLayerObjectCfg Members
IMcadLayerObjectCfg::Hide Property
IMcadLayerObjectCfg::LayerName Property
IMcadLayerObjectCfg::LayerObjKey Property
IMcadLayerObjectCfg::LineType Property
IMcadLayerObjectCfg::LineTypeId Property
IMcadLayerObjectCfg::LineTypeId32 Property
IMcadLayerObjectCfg::LineWeight Property
IMcadLayerObjectCfg::TrueColor Property
IMcadLayerObjectCfgs Interface
IMcadLayerObjectCfgs Members
IMcadLayerObjectCfgs::_NewEnum Property
IMcadLayerObjectCfgs::Application Property
IMcadLayerObjectCfgs::Count Property
IMcadLayerObjectCfgs::Add Method
IMcadLayerObjectCfgs::Item Method
IMcadLayerObjectCfgs::Remove Method
IMcadLayerObjectMgr Interface
IMcadLayerObjectMgr Members
IMcadLayerObjectMgr::Document Property
IMcadLayerObjectMgr::CreateLayer Method
IMcadLayerObjectMgr::GetAllLayerObjs Method
IMcadLayerObjectMgr::GetAllLayers Method
IMcadLayerObjectMgr::GetLayerObjProperty Method
IMcadLayerObjectMgr::GetLayerProperty Method
IMcadLayerObjectMgr::ImportLayerObj Method
IMcadLayerObjectMgr::SetLayerObjDefault Method
IMcadLine Interface
IMcadObject Interface
IMcadObject Members
IMcadObject::Application Property
IMcadObject::Document Property
IMcadObject::Editable Property
IMcadObject::WasErased Property
IMcadObject::Delete Method
IMcadObject::Highlight Method
IMcadObject::IsEqualTo Method
IMcadObject::MakePersistent Method
IMcadObjects Interface
IMcadObjects Members
IMcadObjects::Application Property
IMcadObjects::Count Property
IMcadObjects::Add Method
IMcadObjects::Item Method
IMcadObjects::Remove Method
IMcadPick Interface
IMcadPick Members
IMcadPick::Application Property
IMcadPick::ObjectType Property
IMcadPick::PickPoint Property
IMcadPolyline Interface
IMcadPowObjViewGroupDescriptor Interface
IMcadPowObjViewGroupDescriptor Members
IMcadPowObjViewGroupDescriptor::Entities Property
IMcadPowObjViewGroupDescriptor::Entities32 Property
IMcadPowObjViewGroupDescriptor::PowerObjectType Property
IMcadPowObjViewGroupDescriptor::TargetView Property
IMcadSpline Interface
IMcadStdPartComponentViewDescriptor Interface
IMcadUtility Interface
IMcadUtility Members
IMcadUtility::Application Property
IMcadUtility::Document Property
IMcadUtility::CreateAttribute Method
IMcadUtility::CreateAttributeField Method
IMcadUtility::CreateCollection Method
IMcadUtility::CreatePickObject Method
IMcadUtility::CreateSystemAttribute Method
IMcadUtility::GetAllAttributes Method
IMcadUtility::GetAttributeFromID Method
IMcadUtility::GetAttributeFromID32 Method
IMcadUtility::GetGeometryFromPick Method
IMcadUtility::GetIdsFromObject Method
IMcadUtility::GetIdsFromObject32 Method
IMcadUtility::GetObjectFromID Method
IMcadUtility::GetObjectFromID32 Method
IMcadUtility::GetObjectFromPick Method
IMcadUtility::Pick Method
IMcadUtility2 Interface
IMcadUtility2 Members
IMcadUtility2::RefocusObject Method
IMcadUtility3 Interface
IMcadUtility3 Members
IMcadUtility3::GetDrawingType Method
Mcad2dComplexStdPartCompGroupDescriptor CoClass
Mcad2dComponentDescriptor CoClass
Mcad2dShaftCompGroupDescriptor CoClass
Mcad2dStdPartComponentDescriptor CoClass
Mcad2DStructureDescriptor CoClass
Mcad2DStructureMgr CoClass
Mcad2DSViewType Enumeration
McadAnnotationViewDefinition CoClass
McadAnnotationViewDefinitions CoClass
McadArc CoClass
McadAttribute CoClass
McadAttributeField CoClass
McadAttributeFields CoClass
McadAttributes CoClass
McadAugmentedLine CoClass
McadCollectionType Enumeration
McadComplexHideSituation CoClass
McadComplexHideSituations CoClass
McadComponent CoClass
McadComponentDefinition CoClass
McadComponentDefinitions CoClass
McadComponents CoClass
McadComponentView CoClass
McadComponentViewDefinition CoClass
McadComponentViewDefinitions CoClass
McadComponentViewDescriptor CoClass
McadComponentViews CoClass
McadDocDrawingType Enumeration
McadDocument CoClass
McadDocuments CoClass
McadEllipse CoClass
McadFieldType Enumeration
McadFolder CoClass
McadFolderDefinition CoClass
McadFolderDefinitions CoClass
McadFolderDescriptor CoClass
McadFolders CoClass
McadFormulaEvaluator CoClass
McadHideSituation CoClass
McadHideSituationRefType Enumeration
McadHideSituations CoClass
McadHideSituationSubentType Enumeration
McadLayerCfg CoClass
McadLayerCfgs CoClass
McadLayerGroupMgr CoClass
McadLayerObjectCfg CoClass
McadLayerObjectCfgs CoClass
McadLayerObjectHideType Enumeration
McadLayerObjectMgr CoClass
McadLine CoClass
McadObjects CoClass
McadObjectType Enumeration
McadPhantomState Enumeration
McadPick CoClass
McadPolyline CoClass
McadPowerObjectType Enumeration
McadPowObjViewGroupDescriptor CoClass
McadSelectionOrderOption Enumeration
McadSpline CoClass
McadStdPartComponentViewDescriptor CoClass
McadTransaction CoClass
McadUtility CoClass
SymBBAuto Library
IMcadAnnotationViewLabel Interface
IMcadAnnotationViewLabel Members
IMcadAnnotationViewLabel::LabelPattern Property
IMcadAnnotationViewLabel::LabelText Property
IMcadAnnotationViewStandard Interface
IMcadAnnotationViewStandard Members
IMcadAnnotationViewStandard::LabelPattern Property
IMcadAnnotationViewStandard::LabelPatternVariables Property
IMcadAnnotationViewStandard::LabelPosition Property
IMcadBalloon Interface
IMcadBalloon Members
IMcadBalloon::AttachmentType Property
IMcadBalloon::BalloonType Property
IMcadBalloon::BOM Property
IMcadBalloon::BOMItems Property
IMcadBalloon::CollectionType Property
IMcadBalloon::CustomBlock Property
IMcadBalloon::CustomBlockName Property
IMcadBalloon::IsCustomBlockUsed Property
IMcadBalloon::AppendBOMItem Method
IMcadBalloon::RemoveBOMItem Method
IMcadBalloons Interface
IMcadBalloons Members
IMcadBalloons::Application Property
IMcadBalloons::Count Property
IMcadBalloons::Add Method
IMcadBalloons::Item Method
IMcadBalloons::Remove Method
IMcadBalloonStandard Interface
IMcadBalloonStandard Members
IMcadBalloonStandard::Application Property
IMcadBalloonStandard::ArrowType Property
IMcadBalloonStandard::AttachmentType Property
IMcadBalloonStandard::AuxiliaryArrowType Property
IMcadBalloonStandard::BalloonType Property
IMcadBalloonStandard::BOMStandard Property
IMcadBalloonStandard::Color Property
IMcadBalloonStandard::ColumnList Property
IMcadBalloonStandard::CustomBlockName Property
IMcadBalloonStandard::IsAuxiliaryArrowUsed Property
IMcadBalloonStandard::IsCustomBlockUsed Property
IMcadBalloonStandard::MaximumColumns Property
IMcadBalloonStandard::Revision Property
IMcadBalloonStandard::RevisionYear Property
IMcadBalloonStandard::TextHeight Property
IMcadBalloonStandard::RemoveColumn Method
IMcadBalloonStandard::SetToDefaults Method
IMcadBalloonStandard2 Interface
IMcadBalloonStandard2 Members
IMcadBalloonStandard2::TrueColor Property
IMcadBOM Interface
IMcadBOM Members
IMcadBOM::Data Property
IMcadBOM::PartLists Property
IMcadBOM::Target Property
IMcadBOM::AddItem Method
IMcadBOM::AddUnassociatedItem Method
IMcadBOM::Items Method
IMcadBOM2 Interface
IMcadBOM2 Members
IMcadBOM2::applySort Method
IMcadBOM2::GetProperties Method
IMcadBOM2::GetProperties32 Method
IMcadBOM2::SetProperties Method
IMcadBOM3 Interface
IMcadBOM3 Members
IMcadBOM3::IsBorder Property
IMcadBOM3::IsVisible Property
IMcadBOM3::GetStructuredChildItems Method
IMcadBOM3::GetStructuredParentItem Method
IMcadBOM3::MergeItems Method
IMcadBOM4 Interface
IMcadBOM4 Members
IMcadBOM4::SplitItem Method
IMcadBOMItem Interface
IMcadBOMItem Members
IMcadBOMItem::AutoCalculateEnabled Property
IMcadBOMItem::Balloons Property
IMcadBOMItem::BOM Property
IMcadBOMItem::Data Property
IMcadBOMItem::Expanded Property
IMcadBOMItem::IsExpandable Property
IMcadBOMItem::ItemNumber Property
IMcadBOMItem::Quantity Property
IMcadBOMItem::AddReference Method
IMcadBOMItem::GetReferences Method
IMcadBOMItem::GetReferences32 Method
IMcadBOMItem::ReferenceExists Method
IMcadBOMItem::RemoveReference Method
IMcadBOMItem2 Interface
IMcadBOMItem2 Members
IMcadBOMItem2::ExcludeFromPartList Property
IMcadBOMItem2::Phantomed Property
IMcadBOMItem2::GetAttribute Method
IMcadBOMItem2::GetCalculatedQuantity Method
IMcadBOMItem2::GetItemDefinition Method
IMcadBOMItem2::GetItemDefinition32 Method
IMcadBOMItem2::GetPartBalloons Method
IMcadBOMItem2::SetAttribute Method
IMcadBOMItem3 Interface
IMcadBOMItem3 Members
IMcadBOMItem3::SortPriority Property
IMcadBOMItem3::GetItemPartDefinition Method
IMcadBOMItem3::GetItemPartDefinition32 Method
IMcadBOMItem3::SetAttributePreDefinedListValue Method
IMcadBOMItem4 Interface
IMcadBOMItem4 Members
IMcadBOMItem4::GetBomOverride Method
IMcadBOMItem4::RemoveAttribute Method
IMcadBOMItems Interface
IMcadBOMItems Members
IMcadBOMItems::Application Property
IMcadBOMItems::Count Property
IMcadBOMItems::Add Method
IMcadBOMItems::Item Method
IMcadBOMItems::Remove Method
IMcadBOMMgr Interface
IMcadBOMMgr Members
IMcadBOMMgr::Application Property
IMcadBOMMgr::SymbolBBMgr Property
IMcadBOMMgr::AddBOMTable Method
IMcadBOMMgr::AddPartData Method
IMcadBOMMgr::BOMTableExists Method
IMcadBOMMgr::ExportBOM Method
IMcadBOMMgr::GetAllBOMTables Method
IMcadBOMMgr::GetBOMTable Method
IMcadBOMMgr::GetPartData Method
IMcadBOMMgr::ImportBOM Method
IMcadBOMMgr::RemoveBOMTable Method
IMcadBOMMgr::SelectBOMEntity Method
IMcadBOMMgr::SelectBOMEntity32 Method
IMcadBOMMgr::SetPartData Method
IMcadBOMMgr2 Interface
IMcadBOMMgr2 Members
IMcadBOMMgr2::CurrentBOM Property
IMcadBOMMgr2::AddBorderBOMTable Method
IMcadBOMMgr2::AddPartGrfDef Method
IMcadBOMMgr2::ExportBOM2 Method
IMcadBOMMgr2::ExportPartList Method
IMcadBOMMgr2::GetBOMTableByCompDefId Method
IMcadBOMMgr2::GetBOMTableByCompDefId32 Method
IMcadBOMMgr2::GetBOMTableByName Method
IMcadBOMMgr2::GetBorderBOMTable Method
IMcadBOMMgr2::GetEvaluatedPartData Method
IMcadBOMMgr2::GetPartAttribute Method
IMcadBOMMgr2::GetSheetBOMTable Method
IMcadBOMMgr2::ImportBOM2 Method
IMcadBOMMgr2::ImportPartList Method
IMcadBOMMgr2::RemovePartGrfDef Method
IMcadBOMMgr2::SetPartAttribute Method
IMcadBOMMgr3 Interface
IMcadBOMMgr3 Members
IMcadBOMMgr3::GetBOMTableByCompDefHandle Method
IMcadBOMMgr4 Interface
IMcadBOMMgr4 Members
IMcadBOMMgr4::GetAllPartReferences Method
IMcadBOMs Interface
IMcadBOMs Members
IMcadBOMs::Application Property
IMcadBOMs::Count Property
IMcadBOMs::Add Method
IMcadBOMs::Item Method
IMcadBOMs::Remove Method
IMcadBOMStandard Interface
IMcadBOMStandard Members
IMcadBOMStandard::BalloonStandard Property
IMcadBOMStandard::ColumnCount Property
IMcadBOMStandard::Columns Property
IMcadBOMStandard::PartListStandard Property
IMcadBOMStandard::AddColumn Method
IMcadBOMStandard::GetColumn Method
IMcadBOMStandard::MoveColumn Method
IMcadBOMStandard::RemoveColumn Method
IMcadBOMStandard2 Interface
IMcadBOMStandard2 Members
IMcadBOMStandard2::GetUOMName Method
IMcadBorder Interface
IMcadBorder Members
IMcadBorder::Attributes Property
IMcadBorder::Extends Property
IMcadBorder::Name Property
IMcadBorder::Position Property
IMcadBorder::SetToDefaultAttributes Method
IMcadBorder2 Interface
IMcadBorder2 Members
IMcadBorder2::BlockId Property
IMcadBorder2::BlockId32 Property
IMcadColumnDefinition Interface
IMcadColumnDefinition Members
IMcadColumnDefinition::Application Property
IMcadColumnDefinition::Caption Property
IMcadColumnDefinition::CaptionAlignment Property
IMcadColumnDefinition::ColumnType Property
IMcadColumnDefinition::DataAlignment Property
IMcadColumnDefinition::DataType Property
IMcadColumnDefinition::Equivalents Property
IMcadColumnDefinition::Index Property
IMcadColumnDefinition::Name Property
IMcadColumnDefinition::Precision Property
IMcadColumnDefinition::Size Property
IMcadColumnDefinition::Width Property
IMcadColumnDefinition2 Interface
IMcadColumnDefinition2 Members
IMcadColumnDefinition2::IsVisible Property
IMcadColumnDefinition3 Interface
IMcadColumnDefinition3 Members
IMcadColumnDefinition3::BOMCaptionAlignment Property
IMcadColumnDefinition3::BOMDataAlignment Property
IMcadColumnDefinition3::IsPreDefinedList Property
IMcadColumnDefinition3::PartListCaptionAlignment Property
IMcadColumnDefinition3::PartListDataAlignment Property
IMcadColumnDefinition3::GetPreDefinedList Method
IMcadColumnDefinition3::RemovePreDefinedList Method
IMcadColumnDefinition3::SetPreDefinedList Method
IMcadColumnDefinitions Interface
IMcadColumnDefinitions Members
IMcadColumnDefinitions::Application Property
IMcadColumnDefinitions::Count Property
IMcadColumnDefinitions::Add Method
IMcadColumnDefinitions::Item Method
IMcadColumnDefinitions::Remove Method
IMcadDatumIdentifier Interface
IMcadDatumIdentifier2 Interface
IMcadDatumIdentifier2 Members
IMcadDatumIdentifier2::SurfExtLinesOffset Property
IMcadDatumIdentifier2::SurfExtLinesOvershot Property
IMcadDatumIdentifier2::AddStdCompliantLeader Method
IMcadDatumIdentifier3 Interface
IMcadDatumIdentifier3 Members
IMcadDatumIdentifier3::DatumNote Property
IMcadDatumIdentifier3::FarSideStatus Property
IMcadDatumIdentifier3::SurfIndLeaderArrowType Property
IMcadDatumIdentifier3::ThreadNote Property
IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method
IMcadDatumIdentifier3::GetSurfIndLeader Method
IMcadDatumIdentifier4 Interface
IMcadDatumIdentifier4 Members
IMcadDatumIdentifier4::IsAttachToFCF Method
IMcadDatumStandard Interface
IMcadDatumStandard Members
IMcadDatumStandard::BorderLineType Property
IMcadDatumStandard::BorderLineTypeName Property
IMcadDatumStandard::DrawLeaderArrow Property
IMcadDatumStandard::HatchAngle Property
IMcadDatumStandard::HatchDistance Property
IMcadDatumStandard::HiddenLeaderLineType Property
IMcadDatumStandard::HiddenLeaderLineTypeName Property
IMcadDatumStandard::PointColor Property
IMcadDatumStandard::PointSize Property
IMcadDatumStandard2 Interface
IMcadDatumStandard2 Members
IMcadDatumStandard2::PointTrueColor Property
IMcadDatumTarget Interface
IMcadDatumTarget Members
IMcadDatumTarget::CircleRadius Property
IMcadDatumTarget::DatumValue Property
IMcadDatumTarget::DimensionValue Property
IMcadDatumTarget::DrawLine Property
IMcadDatumTarget::DrawPoint Property
IMcadDatumTarget::LeaderLinetypeHidden Property
IMcadDatumTarget::LineEndPoint Property
IMcadDatumTarget::LineFactor Property
IMcadDatumTarget::LineMidPoint Property
IMcadDatumTarget::RectangleAngle Property
IMcadDatumTarget::RectangleXSize Property
IMcadDatumTarget::RectangleYSize Property
IMcadDatumTarget::TargetOrigin Property
IMcadDatumTarget::TargetType Property
IMcadDatumTarget2 Interface
IMcadDatumTarget2 Members
IMcadDatumTarget2::RectangleCornerPoint Property
IMcadDatumTarget2::SetTargetAttach Method
IMcadDetailSymbol Interface
IMcadDetailSymbol Members
IMcadDetailSymbol::AnnotationOffset Property
IMcadDetailSymbol::BaseViewScale Property
IMcadDetailSymbol::CorrectionScaleFactor Property
IMcadDetailSymbol::DetailScale Property
IMcadDetailSymbol::IsAssociativeDetail Property
IMcadDetailSymbol::LabelEntity Property
IMcadDetailSymbol::LabelEntityOffset Property
IMcadDetailSymbol::LabelName Property
IMcadDetailSymbol::LabelPattern Property
IMcadDetailSymbol::LabelText Property
IMcadDetailSymbol::Radius Property
IMcadDetailSymbol::ShowAnnotationLeader Property
IMcadDetailSymbol::ShowBorder Property
IMcadDetailSymbol::ShowLeader Property
IMcadDetailSymbol::SpecByAbsoluteScale Property
IMcadDetailSymbol::CreateLabelEntity Method
IMcadDetailSymbol::SetSourceGeometry Method
IMcadDetailSymbolLabel Interface
IMcadDetailSymbolLabel Members
IMcadDetailSymbolLabel::AnnotationOffset Property
IMcadDetailSymbolLabel::LabelAbove Property
IMcadDetailSymbolLabel::LabelText Property
IMcadDetailSymbolLabel::SymbolEntity Property
IMcadDetailSymbolStandard Interface
IMcadDetailSymbolStandard Members
IMcadDetailSymbolStandard::AllowedScales Property
IMcadDetailSymbolStandard::BorderLineType Property
IMcadDetailSymbolStandard::LabelAbove Property
IMcadDetailSymbolStandard::LabelPattern Property
IMcadDetailSymbolStandard::ShowAnnotationLeader Property
IMcadDetailSymbolStandard::ShowBorder Property
IMcadDetailSymbolStandard::ShowLeader Property
IMcadDetailSymbolStandard::AddAllowedScale Method
IMcadDetailSymbolStandard::EraseAllowedScales Method
IMcadDetailSymbolStandard2 Interface MG2013New
IMcadDetailSymbolStandard2 Members
IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineColor Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineType Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineWeight Property MG2013New
IMcadDetailSymbolStandard2::BorderLineColor Property MG2013New
IMcadDetailSymbolStandard2::BorderLineLineType Property MG2013New
IMcadDetailSymbolStandard2::BorderLineWeight Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineType Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineColor Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineWeight Property MG2013New
IMcadDetailSymbolStandard2::ShowLabel Property MG2013New
IMcadDetailSymbolStandard2::LabelTextStyle Property MG2013New
IMcadDetailSymbolStandard2::LabelTextColor Property MG2013New
IMcadDetailSymbolStandard2::LabelTextHeight Property MG2013New
IMcadDetailSymbolStandard2::LabelOffset Property MG2013New
IMcadDetailSymbolStandard2::GetByStandard Method MG2013New
IMcadDetailSymbolStandard2::SetByStandard Method MG2013New
IMcadDocument Interface
IMcadDocument Members
IMcadDocument::Application Property
IMcadDocument::LayerGroupMgr Property
IMcadDocument::LayerObjectMgr Property
IMcadDocument::StructureMgr2D Property
IMcadDocument::Utility Property
IMcadEdge Interface
IMcadEdge Members
IMcadEdge::AllAround Property
IMcadEdge::Direction Property
IMcadEdge::Majority Property
IMcadEdge::MaxValue Property
IMcadEdge::MinValue Property
IMcadEdge::NewSymbolRev Property
IMcadEdge::SignValue Property
IMcadEdge::StandardNumber Property
IMcadEdge::UndefsizeDirection Property
IMcadEdgeLibrary Interface
IMcadEdgeLibraryObject Interface
IMcadEdgeLibraryObject Members
IMcadEdgeLibraryObject::IsAllAround Property
IMcadEdgeLibraryObject::IsDefinedDirection Property
IMcadEdgeLibraryObject::IsMajority Property
IMcadEdgeLibraryObject::StandardNumber Property
IMcadEdgeLibraryObject::UndefsizeDirection Property
IMcadEdgeLibraryObject::RequirementValue Method
IMcadEdgeStandard Interface
IMcadEdgeStandard Members
IMcadEdgeStandard::AllAroundAllowed Property
IMcadEdgeStandard::FullList Property
IMcadEdgeStandard::MajorityAllowed Property
IMcadEdgeStandard::StandardNumAllowed Property
IMcadFCFLibrary Interface
IMcadFCFLibraryObject Interface
IMcadFCFLibraryObject Members
IMcadFCFLibraryObject::IsAllAround Property
IMcadFCFLibraryObject::Symbol Property
IMcadFCFLibraryObject::Symbol2 Property
IMcadFCFLibraryObject::Symbol3 Property
IMcadFCFLibraryObject::RequirementValue Method
IMcadFCFStandard Interface
IMcadFCFStandard Members
IMcadFCFStandard::AvailableAuxiliarySymbols Property
IMcadFCFStandard::AvailableGDTSymbols Property
IMcadFCFStandard::EndPadding Property
IMcadFCFStandard::FrameGap Property
IMcadFCFStandard::GDTTextFont Property
IMcadFCFStandard::GDTTextStyle Property
IMcadFCFStandard::GDTTextStyleName Property
IMcadFCFStandard::MergeDatum Property
IMcadFCFStandard::MergeSymbol Property
IMcadFCFStandard::MergeTolerance Property
IMcadFCFStandard::OfferedAuxiliarySymbols Property
IMcadFCFStandard::OfferedGDTSymbols Property
IMcadFCFStandard::SeparateDatumID Property
IMcadFCFStandard::SeparateProjected Property
IMcadFCFStandard::GetSymbolImplementation Method
IMcadFCFStandard2 Interface
IMcadFCFStandard2 Members
IMcadFCFStandard2::SurfIndLeaderArrowScale Property
IMcadFCFStandard2::SurfIndLeaderArrowType Property
IMcadFeatureControlFrame Interface
IMcadFeatureControlFrame Members
IMcadFeatureControlFrame::DatumIDValue Property
IMcadFeatureControlFrame::DatumPrimary2Value Property
IMcadFeatureControlFrame::DatumPrimary3Value Property
IMcadFeatureControlFrame::DatumPrimaryValue Property
IMcadFeatureControlFrame::DatumSecondary2Value Property
IMcadFeatureControlFrame::DatumSecondary3Value Property
IMcadFeatureControlFrame::DatumSecondaryValue Property
IMcadFeatureControlFrame::DatumTertiary2Value Property
IMcadFeatureControlFrame::DatumTertiary3Value Property
IMcadFeatureControlFrame::DatumTertiaryValue Property
IMcadFeatureControlFrame::IsAllAround Property
IMcadFeatureControlFrame::ProjectedValue Property
IMcadFeatureControlFrame::Symbol Property
IMcadFeatureControlFrame::Symbol2 Property
IMcadFeatureControlFrame::Symbol3 Property
IMcadFeatureControlFrame::Tolerance2Value Property
IMcadFeatureControlFrame::Tolerance3Value Property
IMcadFeatureControlFrame::ToleranceB2Value Property
IMcadFeatureControlFrame::ToleranceBValue Property
IMcadFeatureControlFrame::ToleranceValue Property
IMcadFeatureControlFrame2 Interface
IMcadFeatureControlFrame2 Members
IMcadFeatureControlFrame2::BottomNoteValue Property
IMcadFeatureControlFrame2::TopNoteValue Property
IMcadFeatureControlFrame3 Interface
IMcadFeatureControlFrame3 Members
IMcadFeatureControlFrame3::SurfExtLinesOffset Property
IMcadFeatureControlFrame3::SurfExtLinesOvershot Property
IMcadFeatureControlFrame3::AddStdCompliantLeader Method
IMcadFeatureControlFrame4 Interface
IMcadFeatureControlFrame4 Members
IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property
IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method
IMcadFeatureControlFrame4::AddSurfIndLeader Method
IMcadFeatureControlFrame4::GetSurfIndLeader Method
IMcadFeatureControlFrame4::RemoveSurfIndLeader Method
IMcadFeatureIdentifier Interface
IMcadFeatureIdentifier2 Interface
IMcadFeatureIdentifier2 Members
IMcadFeatureIdentifier2::SurfExtLinesOffset Property
IMcadFeatureIdentifier2::SurfExtLinesOvershot Property
IMcadFeatureIdentifier2::AddStdCompliantLeader Method
IMcadIdentifier Interface
IMcadIdentifier Members
IMcadIdentifier::Value Property
IMcadIdentifierStandard Interface
IMcadIdentifierStandard Members
IMcadIdentifierStandard::DefaultArrowType Property
IMcadIdentifierStandard::IsDatumIDSupported Property
IMcadIdentifierStandard::IsFeatureIDSupported Property
IMcadIdentifierStandard2 Interface
IMcadIdentifierStandard2 Members
IMcadIdentifierStandard2::FarSideLeaderLineType Property
IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property
IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property
IMcadIdentifierStandard2::SurfIndLeaderArrowType Property
IMcadJoint Interface
IMcadJoint Members
IMcadJoint::AllAround Property
IMcadJoint::Annotation Property
IMcadJoint::Orientation Property
IMcadJoint::SecAnnotation Property
IMcadJoint::SymbolType Property
IMcadJointStandard Interface
IMcadMarkStamp Interface
IMcadMarkStamp Members
IMcadMarkStamp::ContentValue Property
IMcadMarkStamp::MethodValue Property
IMcadMarkStamp::SymbolType Property
IMcadMarkStamp::TechnicalReqValue Property
IMcadMarkStampStandard Interface
IMcadMarkStampStandard Members
IMcadMarkStampStandard::AvailableMarkingContents Property
IMcadMarkStampStandard::AvailableMarkingMethods Property
IMcadMarkStampStandard::AvailableStampingContents Property
IMcadMarkStampStandard::AvailableStampingMethods Property
IMcadMarkStampStandard::OfferedMarkingContents Property
IMcadMarkStampStandard::OfferedMarkingMethods Property
IMcadMarkStampStandard::OfferedStampingContents Property
IMcadMarkStampStandard::OfferedStampingMethods Property
IMcadNote Interface
IMcadNote Members
IMcadNote::EvaluatedNoteText Property
IMcadNote::IsLeftOriented Property
IMcadNote::Landing Property
IMcadNote::LeaderAttachPoint Property
IMcadNote::NoteText Property
IMcadNote::TextAlignment Property
IMcadNote::AdjustLanding Method
IMcadNote::CreateNoteText Method
IMcadNoteStandard Interface
IMcadNoteStandard Members
IMcadNoteStandard::Landing Property
IMcadNoteStandard::LeaderAttachPoint Property
IMcadNoteStandard::AddTemplate Method
IMcadNoteStandard::ChangeTemplateValue Method
IMcadNoteStandard::DeleteAllTemplates Method
IMcadNoteStandard::DeleteTemplate Method
IMcadNoteStandard::GetAllTemplates Method
IMcadNoteStandard::GetFeatureTypes Method
IMcadNoteStandard::GetTemplateGroup Method
IMcadNoteStandard::GetTemplateValue Method
IMcadNoteStandard::NumberOfTemplateGroups Method
IMcadNoteStandard::RenameTemplate Method
IMcadNoteStandard::SetCompatibilityCondition Method
IMcadNoteStandard::SetToDefaultTemplate Method
IMcadPartList Interface
IMcadPartList Members
IMcadPartList::AttachmentPoint Property
IMcadPartList::BOM Property
IMcadPartList::CustomBlockName Property
IMcadPartList::CustomBlocks Property
IMcadPartList::FilterEmptyBlocks Property
IMcadPartList::Filters Property
IMcadPartList::Height Property
IMcadPartList::IsCustomBlockUsed Property
IMcadPartList::IsHeadingEnabled Property
IMcadPartList::IsTitleEnabled Property
IMcadPartList::ItemList Property
IMcadPartList::MappingName Property
IMcadPartList::MultipleRow Property
IMcadPartList::Title Property
IMcadPartList::ViewID Property
IMcadPartList::ViewID32 Property
IMcadPartList::Width Property
IMcadPartList::WrapText Property
IMcadPartList::AddFilter Method
IMcadPartList::RemoveFilter Method
IMcadPartList2 Interface
IMcadPartList2 Members
IMcadPartList2::ColumnSplitEnabled Property
IMcadPartList2::ColumnSplitRows Property
IMcadPartList2::ColumnSplitSections Property
IMcadPartList2::ColumnSplitStyle Property
IMcadPartList2::ColumnSplitWrap Property
IMcadPartList2::FormulaBarEnabled Property
IMcadPartList2::GripFrameEnabled Property
IMcadPartList2::HeadingTextControl Property
IMcadPartList2::ResultBarEnabled Property
IMcadPartList2::RowTextControl Property
IMcadPartList2::AddFilterType Method
IMcadPartList3 Interface
IMcadPartList3 Members
IMcadPartList3::WrapAroundTitle Property
IMcadPartList3::WrapTitleBlockId Property
IMcadPartList3::WrapTitleBlockId32 Property
IMcadPartList3::setWrapPListAttachPoint Method
IMcadPartListBalloonedFilter Interface
IMcadPartListCustomFilter Interface
IMcadPartListCustomFilter Members
IMcadPartListCustomFilter::Operator Property
IMcadPartListCustomFilter::PropertyName Property
IMcadPartListCustomFilter::PropertyValue Property
IMcadPartListCustomFilter::SetCondition Method
IMcadPartListFilter Interface
IMcadPartListFilter Members
IMcadPartListFilter::IsOn Property
IMcadPartListFilter::Name Property
IMcadPartListFilter::Evaluate Method
IMcadPartListFilter2 Interface
IMcadPartListFilter2 Members
IMcadPartListFilter2::Excluded Property
IMcadPartListFilter2::Type Property
IMcadPartListFilters Interface
IMcadPartListFilters Members
IMcadPartListFilters::Application Property
IMcadPartListFilters::Count Property
IMcadPartListFilters::Add Method
IMcadPartListFilters::Item Method
IMcadPartListFilters::Remove Method
IMcadPartListGOST Interface
IMcadPartListGOST Members
IMcadPartListGOST::SkipAfterPart Property
IMcadPartListGOST::SkipLines Property
IMcadPartLists Interface
IMcadPartLists Members
IMcadPartLists::Application Property
IMcadPartLists::Count Property
IMcadPartLists::Add Method
IMcadPartLists::Item Method
IMcadPartLists::Remove Method
IMcadPartListStandard Interface
IMcadPartListStandard Members
IMcadPartListStandard::ActualRowTextHeight Property
IMcadPartListStandard::Application Property
IMcadPartListStandard::AttachmentPoint Property
IMcadPartListStandard::BOMStandard Property
IMcadPartListStandard::ColumnList Property
IMcadPartListStandard::CustomBlockName Property
IMcadPartListStandard::CustomBlocks Property
IMcadPartListStandard::FilterEmptyBlocks Property
IMcadPartListStandard::FrameColor Property
IMcadPartListStandard::HeadingGap Property
IMcadPartListStandard::HeadingHeight Property
IMcadPartListStandard::HeadingTextColor Property
IMcadPartListStandard::HeadingTextHeight Property
IMcadPartListStandard::IsCustomBlockUsed Property
IMcadPartListStandard::IsHeadingEnabled Property
IMcadPartListStandard::IsTitleEnabled Property
IMcadPartListStandard::MulipleRow Property
IMcadPartListStandard::Revision Property
IMcadPartListStandard::RevisionYear Property
IMcadPartListStandard::RowGap Property
IMcadPartListStandard::RowHeight Property
IMcadPartListStandard::UseMapping Property
IMcadPartListStandard::WrapText Property
IMcadPartListStandard::RemoveColumn Method
IMcadPartListStandard::SetToDefaults Method
IMcadPartListStandard2 Interface
IMcadPartListStandard2 Members
IMcadPartListStandard2::FrameTrueColor Property
IMcadPartListStandard2::HeadingTextTrueColor Property
IMcadPartListStandard3 Interface
IMcadPartListStandard3 Members
IMcadPartListStandard3::BoldVerticalLine Property
IMcadPartListStandard3::ColumnSplitEnabled Property
IMcadPartListStandard3::ColumnSplitRows Property
IMcadPartListStandard3::ColumnSplitSections Property
IMcadPartListStandard3::ColumnSplitStyle Property
IMcadPartListStandard3::ColumnSplitWrap Property
IMcadPartListStandard3::GripFrameEnabled Property
IMcadPartListStandard3::HeadingTextControl Property
IMcadPartListStandard3::HeadingTextMarginBottom Property
IMcadPartListStandard3::HeadingTextMarginLeft Property
IMcadPartListStandard3::HeadingTextMarginRight Property
IMcadPartListStandard3::HeadingTextMarginTop Property
IMcadPartListStandard3::HeadingTextStyle Property
IMcadPartListStandard3::RowTextColor Property
IMcadPartListStandard3::RowTextControl Property
IMcadPartListStandard3::RowTextHeight Property
IMcadPartListStandard3::RowTextMarginBottom Property
IMcadPartListStandard3::RowTextMarginLeft Property
IMcadPartListStandard3::RowTextMarginRight Property
IMcadPartListStandard3::RowTextMarginTop Property
IMcadPartListStandard3::RowTextStyle Property
IMcadPartListStandard3::RowTextTrueColor Property
IMcadPartListStandard4 Interface
IMcadPartListStandard4 Members
IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property
IMcadPartListStdPartsFilter Interface
IMcadPartListStdPartsFilter Members
IMcadPartListStdPartsFilter::Option Property
IMcadPartReference Interface
IMcadPartReference Members
IMcadPartReference::Data Property
IMcadPartReference::Quantity Property
IMcadPartReference2 Interface
IMcadPartReference2 Members
IMcadPartReference2::SetAttributePreDefinedListValue Method
IMcadPartReference3 Interface
IMcadPartReference3 Members
IMcadPartReference3::AttachedExternalBom Property
IMcadPartReference3::AttachedExternalBomXrefBlock Property
IMcadPartReference3::AttachExternalBom Method
IMcadPartReference3::DetachExternalBom Method
IMcadPartReference3::GetBomOverride Method
IMcadPartReference3::RemoveAttribute Method
IMcadPartReferences Interface
IMcadPartReferences Members
IMcadPartReferences::_NewEnum Property
IMcadPartReferences::Application Property
IMcadPartReferences::Count Property
IMcadPartReferences::Add Method
IMcadPartReferences::Item Method
IMcadPartReferences::Remove Method
IMcadRevisionList Interface
IMcadRevisionList Members
IMcadRevisionList::Border Property
IMcadRevisionList::Border32 Property
IMcadRevisionList::Count Property
IMcadRevisionList::Position Property
IMcadRevisionList::Ref Property
IMcadRevisionList::Ref32 Property
IMcadRevisionList::Add Method
IMcadRevisionList::Item Method
IMcadRevisionList::Set Method
IMcadRevisionListDescriptor Interface
IMcadRevisionListDescriptor Members
IMcadRevisionListDescriptor::Attributes Property
IMcadRevisionListDescriptor::Border Property
IMcadRevisionListDescriptor::Border32 Property
IMcadRevisionListDescriptor::Position Property
IMcadRevisionLists Interface
IMcadRevisionLists Members
IMcadRevisionLists::Application Property
IMcadRevisionLists::Count Property
IMcadRevisionLists::Item Method
IMcadRevisionMgr Interface
IMcadRevisionMgr Members
IMcadRevisionMgr::RevisionLists Property
IMcadRevisionMgr::CreateRevisionList Method
IMcadRevisionMgr::DeleteRevisionList Method
IMcadRevisionMgr::GetRevisionListFromRef Method
IMcadRevisionMgr::NewDescriptor Method
IMcadScaleArea Interface
IMcadScaleArea Members
IMcadScaleArea::AttachObjectId Property
IMcadScaleArea::AttachObjectId32 Property
IMcadScaleArea::LengthScalingFactor Property
IMcadScaleArea::ScaleType Property
IMcadScaleArea::TextScalingFactor Property
IMcadScaleArea::CreateViewPort Method
IMcadScaleArea::DeleteViewPort Method
IMcadScaleArea::GetAttachedViewportIds Method
IMcadScaleArea::GetAttachedViewportIds32 Method
IMcadScaleArea::MoveBorder Method
IMcadScaleArea::RescaleObjects Method
IMcadScaleArea::SetBasicScale Method
IMcadScaleAreaMgr Interface
IMcadScaleAreaMgr Members
IMcadScaleAreaMgr::CreateScaleArea Method
IMcadScaleAreaMgr::DeleteScaleArea Method
IMcadScaleAreaMgr::FindScaleArea Method
IMcadSectionLine Interface
IMcadSectionLine Members
IMcadSectionLine::ArrowVisibility Property
IMcadSectionLine::LabelNamesCount Property
IMcadSectionLine::LabelPattern Property
IMcadSectionLine::LabelText Property
IMcadSectionLine::LabelVisibility Property
IMcadSectionLine::LineVisibility Property
IMcadSectionLine::PlaneSymbolsVisibility Property
IMcadSectionLine::SectionPoints Property
IMcadSectionLine::SectionSide Property
IMcadSectionLine::AddSectionPoint Method
IMcadSectionLine::LabelName Method
IMcadSectionLine::SetLabelNames Method
IMcadSectionLine::SetSectionArcPointAt Method
IMcadSectionLine::SetSectionPointAt Method
IMcadSectionLine::SetSectionPoints Method
IMcadSectionLine::SetSectionViewOrigin Method
IMcadSectionLineStandard Interface
IMcadSectionLineStandard Members
IMcadSectionLineStandard::ArrowTowardsLine Property
IMcadSectionLineStandard::ArrowVisibility Property
IMcadSectionLineStandard::LabelAbove Property
IMcadSectionLineStandard::LabelPattern Property
IMcadSectionLineStandard::LabelVisibility Property
IMcadSectionLineStandard::LineColor Property
IMcadSectionLineStandard::LineTrueColor Property
IMcadSectionLineStandard::LineVisibility Property
IMcadSectionLineStandard::LineWeight Property
IMcadSectionLineStandard::MultipleNamesSupported Property
IMcadSectionLineStandard::PlaneSymbolsVisibility Property
IMcadSectionLineStandard2 Interface MG2013New
IMcadSectionLineStandard2 Members
IMcadSectionLineStandard2::IdentifierExcludeCharacters Property MG2013New
IMcadSectionLineStandard2::EndArrowType Property MG2013New
IMcadSectionLineStandard2::ArrowLineLength Property MG2013New
IMcadSectionLineStandard2::IdentifierPosition Property MG2013New
IMcadSectionLineStandard2::EndBendLineType Property MG2013New
IMcadSectionLineStandard2::EndLineLength Property MG2013New
IMcadSectionLineStandard2::EndLineOvershoot Property MG2013New
IMcadSectionLineStandard2::BendLineLength Property MG2013New
IMcadSectionLineStandard2::PlaneLineColor Property MG2013New
IMcadSectionLineStandard2::PlaneLineType Property MG2013New
IMcadSectionLineStandard2::PlaneLineWeight Property MG2013New
IMcadSectionLineStandard2::LabelTextStyle Property MG2013New
IMcadSectionLineStandard2::LabelTextColor Property MG2013New
IMcadSectionLineStandard2::LabelTextHeight Property MG2013New
IMcadSectionLineStandard2::LabelOffset Property MG2013New
IMcadSectionLineStandard2::GetByStandard Method MG2013New
IMcadSectionLineStandard2::SetByStandard Method MG2013New
IMcadSectionLineStandard2::IdentifierOffset Property MG2013New
IMcadStandard Interface
IMcadStandard Members
IMcadStandard::AllSymbolStandards Property
IMcadStandard::ArrowScale Property
IMcadStandard::ArrowType Property
IMcadStandard::BaseName Property
IMcadStandard::BOMStandard Property
IMcadStandard::Current Property
IMcadStandard::CurrentSymbolStandards Property
IMcadStandard::DatumStandard Property
IMcadStandard::FCFStandard Property
IMcadStandard::IdentifierStandard Property
IMcadStandard::IsMetric Property
IMcadStandard::LeaderColor Property
IMcadStandard::Name Property
IMcadStandard::Scale Property
IMcadStandard::StandardMgr Property
IMcadStandard::SurfaceTextureStandard Property
IMcadStandard::SymbolColor Property
IMcadStandard::SymbolStandardsSupported Property
IMcadStandard::TextColor Property
IMcadStandard::TextHeight Property
IMcadStandard::TextHeightList Property
IMcadStandard::TextStyle Property
IMcadStandard::TextStyleName Property
IMcadStandard::WeldingStandard Property
IMcadStandard::AddSymbolStandard Method
IMcadStandard::GetCurrentSymbolStandard Method
IMcadStandard::RemoveSymbolStandard Method
IMcadStandard::SetCurrentSymbolStandard Method
IMcadStandard::SetToDefaults Method
IMcadStandard2 Interface
IMcadStandard2 Members
IMcadStandard2::LeaderTrueColor Property
IMcadStandard2::SymbolTrueColor Property
IMcadStandard2::TextTrueColor Property
IMcadStandard3 Interface
IMcadStandard3 Members
IMcadStandard3::AnnotationViewStandard Property
IMcadStandard3::DetailSymbolStandard Property
IMcadStandard3::EdgeStandard Property
IMcadStandard3::MarkStampStandard Property
IMcadStandard3::NoteStandard Property
IMcadStandard3::TaperStandard Property
IMcadStandard3::TitleBorderStandard Property
IMcadStandard4 Interface
IMcadStandard4 Members
IMcadStandard4::JointStandard Property
IMcadStandard4::SectionLineStandard Property
IMcadStandard4::SupportedArrowTypes Method
IMcadStandardMgr Interface
IMcadStandardMgr Members
IMcadStandardMgr::Application Property
IMcadStandardMgr::CurrentStandard Property
IMcadStandardMgr::CurrentStandardName Property
IMcadStandardMgr::DefaultStandard Property
IMcadStandardMgr::StandardCount Property
IMcadStandardMgr::StandardNames Property
IMcadStandardMgr::Standards Property
IMcadStandardMgr::SymbolBBMgr Property
IMcadStandardMgr::AddStandard Method
IMcadStandardMgr::CopyStandard Method
IMcadStandardMgr::GetStandard Method
IMcadStandardMgr::RemoveStandard Method
IMcadStandardMgr::UpdateSymbols Method
IMcadStandards Interface
IMcadStandards Members
IMcadStandards::Application Property
IMcadStandards::Count Property
IMcadStandards::Add Method
IMcadStandards::Item Method
IMcadStandards::Remove Method
IMcadSurfaceTexture Interface
IMcadSurfaceTexture Members
IMcadSurfaceTexture::AllowanceValue Property
IMcadSurfaceTexture::Angle Property
IMcadSurfaceTexture::AutomaticAdjust Property
IMcadSurfaceTexture::CommentValue Property
IMcadSurfaceTexture::CutoffValue Property
IMcadSurfaceTexture::IsAllAround Property
IMcadSurfaceTexture::IsForceTail Property
IMcadSurfaceTexture::IsMajority Property
IMcadSurfaceTexture::LayDirection Property
IMcadSurfaceTexture::LayDirectionValue Property
IMcadSurfaceTexture::MaximumSpacingValue Property
IMcadSurfaceTexture::OtherMinimumValue Property
IMcadSurfaceTexture::OtherValue Property
IMcadSurfaceTexture::Production2Value Property
IMcadSurfaceTexture::ProductionValue Property
IMcadSurfaceTexture::RaMaximumValue Property
IMcadSurfaceTexture::RaMinimumValue Property
IMcadSurfaceTexture::ReferenceValue Property
IMcadSurfaceTexture::SamplingLengthValue Property
IMcadSurfaceTexture::SurfaceTexture Property
IMcadSurfaceTexture::WavinessValue Property
IMcadSurfaceTexture2 Interface
IMcadSurfaceTexture2 Members
IMcadSurfaceTexture2::FirstRequirement Property
IMcadSurfaceTexture2::FourthRequirement Property
IMcadSurfaceTexture2::SecondRequirement Property
IMcadSurfaceTexture2::ThirdRequirement Property
IMcadSurfaceTexture3 Interface
IMcadSurfaceTexture3 Members
IMcadSurfaceTexture3::SurfExtLinesOffset Property
IMcadSurfaceTexture3::SurfExtLinesOvershot Property
IMcadSurfaceTexture4 Interface
IMcadSurfaceTexture4 Members
IMcadSurfaceTexture4::AddSurfIndLeader Method
IMcadSurfaceTexture5 Interface
IMcadSurfaceTexture5 Members
IMcadSurfaceTexture5::IsAttachToFCF Method
IMcadSurfaceTextureLibrary Interface
IMcadSurfaceTextureLibraryObject Interface
IMcadSurfaceTextureLibraryObject Members
IMcadSurfaceTextureLibraryObject::IsAllAround Property
IMcadSurfaceTextureLibraryObject::IsForceTail Property
IMcadSurfaceTextureLibraryObject::IsMajority Property
IMcadSurfaceTextureLibraryObject::SubSymbolType Property
IMcadSurfaceTextureLibraryObject::RequirementValue Method
IMcadSurfaceTextureStandard Interface
IMcadSurfaceTextureStandard Members
IMcadSurfaceTextureStandard::AllAroundAllowed Property
IMcadSurfaceTextureStandard::AvailableLaySymbols Property
IMcadSurfaceTextureStandard::FitCircle Property
IMcadSurfaceTextureStandard::ForceTail Property
IMcadSurfaceTextureStandard::FullList Property
IMcadSurfaceTextureStandard::MajorityAllowed Property
IMcadSurfaceTextureStandard::Multiline Property
IMcadSurfaceTextureStandard::OfferedLaySymbols Property
IMcadSurfaceTextureStandard2 Interface
IMcadSurfaceTextureStandard2 Members
IMcadSurfaceTextureStandard2::IsRequirementSupported Method
IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method
IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)
IMcadSurfaceTextureStandard3 Interface
IMcadSurfaceTextureStandard3 Members
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property
IMcadSymbol Interface
IMcadSymbol Members
IMcadSymbol::CoordinateSystem Property
IMcadSymbol::IsAttached Property
IMcadSymbol::LeaderCount Property
IMcadSymbol::Origin Property
IMcadSymbol::Scale Property
IMcadSymbol::Standard Property
IMcadSymbol::SymbolStandard Property
IMcadSymbol::AddLeader Method
IMcadSymbol::AttachGeometry Method
IMcadSymbol::DetachGeometry Method
IMcadSymbol::GetLeader Method
IMcadSymbol::GetLeaderAttachment Method
IMcadSymbol::InsertLeaderNode Method
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)
IMcadSymbol::MoveLeaderNode Method
IMcadSymbol::RemoveLeader Method
IMcadSymbol::RemoveLeaderNode Method
IMcadSymbol::SetToDefaults Method
IMcadSymbol2 Interface
IMcadSymbol2 Members
IMcadSymbol2::UpdateToAttachedObject Method
IMcadSymbolBBMgr Interface
IMcadSymbolBBMgr Members
IMcadSymbolBBMgr::Application Property
IMcadSymbolBBMgr::BOMMgr Method
IMcadSymbolBBMgr::StandardMgr Method
IMcadSymbolBBMgr2 Interface
IMcadSymbolBBMgr2 Members
IMcadSymbolBBMgr2::ScaleAreaMgr Method
IMcadSymbolBBMgr2::TitleBorderMgr Method
IMcadSymbolBBMgr3 Interface
IMcadSymbolBBMgr3 Members
IMcadSymbolBBMgr3::RevisionListMgr Method
IMcadSymbolBBMgr3::SymbolLibrary Method
IMcadSymbolLibrary Interface
IMcadSymbolLibrary Members
IMcadSymbolLibrary::appendItem Method
IMcadSymbolLibrary::DefaultItem Method
IMcadSymbolLibrary::findItem Method
IMcadSymbolLibrary::findList Method
IMcadSymbolLibrary::isItemExist Method
IMcadSymbolLibrary::loadItem Method
IMcadSymbolLibrary::modifyItem Method
IMcadSymbolLibrary::removeItem Method
IMcadSymbolLibrary::renameItem Method
IMcadSymbolLibrary::setIsDefaultItem Method
IMcadSymbolLibraryObject Interface
IMcadSymbolLibraryObject Members
IMcadSymbolLibraryObject::entryName Property
IMcadSymbolLibraryObject::isDefault Property
IMcadSymbolLibraryObject::standardName Property
IMcadSymbolLibraryObject::symbolStandardClassName Property
IMcadSymbolLibraryObjects Interface
IMcadSymbolLibraryObjects Members
IMcadSymbolLibraryObjects::Application Property
IMcadSymbolLibraryObjects::Count Property
IMcadSymbolLibraryObjects::Add Method
IMcadSymbolLibraryObjects::Item Method
IMcadSymbolLibraryObjects::Remove Method
IMcadSymbolStandard Interface
IMcadSymbolStandard Members
IMcadSymbolStandard::Revision Property
IMcadSymbolStandard::RevisionYear Property
IMcadSymbolStandard::Standard Property
IMcadSymbolStandard::SetToDefaults Method
IMcadSymbolStandard2 Interface
IMcadSymbolStandard2 Members
IMcadSymbolStandard2::ArrowScale Property
IMcadSymbolStandard2::ArrowType Property
IMcadSymbolStandard2::LeaderTrueColor Property
IMcadSymbolStandard2::TextHeight Property
IMcadSymbolStandard2::TextTrueColor Property
IMcadSymbolStandard2::SetToDefaultTextLeader Method
IMcadSymbolStandard3 Interface
IMcadSymbolStandard3 Members
IMcadSymbolStandard3::SymbolStandardClassName Property
IMcadSymbolStandard3::SupportedArrowTypes Method
IMcadSymbolStandards Interface
IMcadSymbolStandards Members
IMcadSymbolStandards::Application Property
IMcadSymbolStandards::Count Property
IMcadSymbolStandards::Add Method
IMcadSymbolStandards::Item Method
IMcadSymbolStandards::Remove Method
IMcadTaper Interface
IMcadTaper Members
IMcadTaper::AboveCurve Property
IMcadTaper::DisplayString Property
IMcadTaper::HasLeader Property
IMcadTaper::Inspect Property
IMcadTaper::Orientation Property
IMcadTaper::SubSymbolType Property
IMcadTaper::AdjustReferenceLine Method
IMcadTaperStandard Interface
IMcadTaperStandard Members
IMcadTaperStandard::OfferedSymbols Property
IMcadTaperStandard2 Interface
IMcadTaperStandard2 Members
IMcadTaperStandard2::GetDimensionType Method
IMcadTaperStandard2::SetDimensionType Method
IMcadTitle Interface
IMcadTitle Members
IMcadTitle::Attributes Property
IMcadTitle::InActive Property
IMcadTitle::Name Property
IMcadTitle::Position Property
IMcadTitle::SetToDefaultAttributes Method
IMcadTitle2 Interface
IMcadTitle2 Members
IMcadTitle2::BlockId Property
IMcadTitle2::BlockId32 Property
IMcadTitleBorder Interface
IMcadTitleBorder Members
IMcadTitleBorder::Descriptor Property
IMcadTitleBorder::Ref Property
IMcadTitleBorder::Ref32 Property
IMcadTitleBorder::Modify Method
IMcadTitleBorderContext Interface
IMcadTitleBorderContext Members
IMcadTitleBorderContext::AutomaticPlacement Property
IMcadTitleBorderContext::BaseScale Property
IMcadTitleBorderContext::DwgDefault Property
IMcadTitleBorderContext::MoveObjects Property
IMcadTitleBorderContext::Rescale Property
IMcadTitleBorderContext::RetrieveFromAsmProp Property
IMcadTitleBorderContext::RetrieveFromPartRef Property
IMcadTitleBorderContext::ThawAllLayers Property
IMcadTitleBorderContext::GetMoveObjectsIDs Method
IMcadTitleBorderContext::GetMoveObjectsIDs32 Method
IMcadTitleBorderContext::GetMoveObjectsToPoint Method
IMcadTitleBorderContext::GetPartReference Method
IMcadTitleBorderContext::GetPartReference32 Method
IMcadTitleBorderContext::SetMoveObjects Method
IMcadTitleBorderContext::SetPartReference Method
IMcadTitleBorderDescriptor Interface
IMcadTitleBorderDescriptor Members
IMcadTitleBorderDescriptor::Border Property
IMcadTitleBorderDescriptor::Position Property
IMcadTitleBorderDescriptor::Title Property
IMcadTitleBorderDescriptor::TitleBorderScale Property
IMcadTitleBorderMgr Interface
IMcadTitleBorderMgr Members
IMcadTitleBorderMgr::TitleBorders Property
IMcadTitleBorderMgr::CreateTitleBorder Method
IMcadTitleBorderMgr::DeleteTitleBorder Method
IMcadTitleBorderMgr::GetTitleBorderFromRef Method
IMcadTitleBorderMgr::NewContext Method
IMcadTitleBorderMgr::NewDescriptor Method
IMcadTitleBorders Interface
IMcadTitleBorders Members
IMcadTitleBorders::Application Property
IMcadTitleBorders::Count Property
IMcadTitleBorders::Item Method
IMcadTitleBorderStandard Interface
IMcadTitleBorderStandard Members
IMcadTitleBorderStandard::DefaultPaperFormat Property
IMcadTitleBorderStandard::DefaultRevisionList Property
IMcadTitleBorderStandard::DefaultTitleBlock Property
IMcadTitleBorderStandard::PaperFormats Property
IMcadTitleBorderStandard::RevisionLists Property
IMcadTitleBorderStandard::TitleBlocks Property
IMcadTitleBorderStandard2 Interface
IMcadTitleBorderStandard2 Members
IMcadTitleBorderStandard2::InsertInvertPart Property
IMcadTitleBorderStandard2::InvertPartBorderHeight Property
IMcadTitleBorderStandard2::InvertPartBorderWidth Property
IMcadTitleBorderStandard2::InvertPartTextHeight Property
IMcadTransaction Interface
IMcadTransaction Members
IMcadTransaction::Application Property
IMcadWelding Interface
IMcadWelding Members
IMcadWelding::Orientation Property
IMcadWelding::SubWeldingCount Property
IMcadWelding::AddSubWelding Method
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::HighlightSubWelding Method
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::RemoveSubWelding Method
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding2 Interface
IMcadWelding2 Members
IMcadWelding2::InsertProcess Method
IMcadWeldingLibrary Interface
IMcadWeldingLibrary Members
IMcadWeldingLibrary::appendItemFromSubWelding Method
IMcadWeldingLibrary::loadItemToSubWelding Method
IMcadWeldingLibrary::modifyItemFromSubWelding Method
IMcadWeldingLibraryObject Interface
IMcadWeldingLibraryObject Members
IMcadWeldingLibraryObject::AreaType Property
IMcadWeldingLibraryObject::AssociationType Property
IMcadWeldingLibraryObject::ClosedTail Property
IMcadWeldingLibraryObject::FieldWeld Property
IMcadWeldingLibraryObject::IdentificationLine Property
IMcadWeldingLibraryObject::ArrowSideReqValue Method
IMcadWeldingLibraryObject::OtherSideReqValue Method
IMcadWeldingLibraryObject::RequirementValue Method
IMcadWeldingLibraryObject::setIsDefault Method
IMcadWeldingLibraryObject::Type Method
IMcadWeldingStandard Interface
IMcadWeldingStandard Members
IMcadWeldingStandard::AvailableBackingSymbols Property
IMcadWeldingStandard::AvailableContourSymbols Property
IMcadWeldingStandard::AvailableWeldSymbols Property
IMcadWeldingStandard::ClosedTailAllowed Property
IMcadWeldingStandard::IdentificationLineAllowed Property
IMcadWeldingStandard::IdentificationLineGap Property
IMcadWeldingStandard::IdentificationLinetype Property
IMcadWeldingStandard::IdentificationLinetypeName Property
IMcadWeldingStandard::MultipleSymbolsAllowed Property
IMcadWeldingStandard::OfferedBackingSymbols Property
IMcadWeldingStandard::OfferedContourSymbols Property
IMcadWeldingStandard::OfferedWeldSymbols Property
IMcadWeldingStandard2 Interface
IMcadWeldingStandard2 Members
IMcadWeldingStandard2::WeldProcessPrefix Property
IMcadWeldingStandard3 Interface
IMcadWeldingStandard3 Members
IMcadWeldingStandard3::ProcessGap Property
IMcadWeldingStandard3::ScaleFactor Property
McadAlignmentType Enumeration
McadAnnotationViewLabel CoClass
McadAnnotationViewStandard CoClass
McadAnnotViewLabelPositionType Enumeration
McadArrowType Enumeration
McadAttachmentPoint Enumeration
McadAttachmentType Enumeration
McadAttachPosition Enumeration
McadAttributeAssociativity Enumeration
McadBalloon CoClass
McadBalloonCollectionType Enumeration
McadBalloons CoClass
McadBalloonStandard CoClass
McadBalloonType Enumeration
McadBOM CoClass
McadBOMExportFormatType Enumeration
McadBOMImportFormatType Enumeration
McadBOMItem CoClass
McadBOMItemDefinitionType Enumeration
McadBOMItems CoClass
McadBOMMgr CoClass
McadBomOverrideType Enumeration
McadBOMs CoClass
McadBOMStandard CoClass
McadBOMUOMType Enumeration
McadBorder CoClass
McadColumnDefinition CoClass
McadColumnDefinitions CoClass
McadColumnSplitStyle Enumeration
McadColumnSplitWrap Enumeration
McadColumnType Enumeration
McadDataType Enumeration
McadDatumIdentifier CoClass
McadDatumStandard CoClass
McadDatumTarget CoClass
McadDetailSymbol CoClass
McadDetailSymbolLabel CoClass
McadDetailSymbolStandard CoClass
McadDetailSymbolStandardPropType Enumeration MG2013New
McadDirectionLayType Enumeration
McadEdge CoClass
McadEdgeLibrary CoClass
McadEdgeLibraryObject CoClass
McadEdgeRequirement Enumeration
McadEdgeStandard CoClass
McadFCFLibrary CoClass
McadFCFLibraryObject CoClass
McadFCFRequirement Enumeration
McadFCFStandard CoClass
McadFeatureControlFrame CoClass
McadFeatureIdentifier CoClass
McadFilterOperator Enumeration
McadFilterType Enumeration
McadGDTSymbolType Enumeration
McadIdentificationType Enumeration
McadIdentifier CoClass
McadIdentifierPositionType Enumeration MG2013New
McadIdentifierStandard CoClass
McadJoint CoClass
McadJointStandard CoClass
McadJointType Enumeration
McadLineVisibility Enumeration
McadMarkStamp CoClass
McadMarkStampStandard CoClass
McadNote CoClass
McadNoteAttachPointType Enumeration
McadNoteStandard CoClass
McadNoteTemplateGroupType Enumeration
McadOrientation Enumeration
McadPartList CoClass
McadPartListBalloonedFilter CoClass
McadPartListCustomFilter CoClass
McadPartListFilter CoClass
McadPartListFilters CoClass
McadPartListGOST CoClass
McadPartLists CoClass
McadPartListStandard CoClass
McadPartListStdPartsFilter CoClass
McadPartReference CoClass
McadPartReferences CoClass
McadRevisionList CoClass
McadRevisionListDescriptor CoClass
McadRevisionLists CoClass
McadRevisionMgr CoClass
McadScaleArea CoClass
McadScaleAreaMgr CoClass
McadScaleType Enumeration
McadSectionLine CoClass
McadSectionLineSegmentType Enumeration
McadSectionLineStandard CoClass
McadSectionLineStandardPropType Enumeration MG2013New
McadStandard CoClass
McadStandardMgr CoClass
McadStandards CoClass
McadStdPartsFilterOption Enumeration
McadSurfaceTexture CoClass
McadSurfaceTextureLibrary CoClass
McadSurfaceTextureLibraryObject CoClass
McadSurfaceTextureRequirement Enumeration
McadSurfaceTextureStandard CoClass
McadSurfaceTextureType Enumeration
McadSymBBSymbolLibraryType Enumeration
McadSymbol CoClass
McadSymbolBBMgr CoClass
McadSymbolLibrary CoClass
McadSymbolLibraryObject CoClass
McadSymbolLibraryObjects CoClass
McadSymbolStandard CoClass
McadSymbolStandards CoClass
McadTaper CoClass
McadTaperDimensionType Enumeration
McadTaperRatioFormatType Enumeration
McadTaperSlopeSymType Enumeration
McadTaperStandard CoClass
McadTargetType Enumeration
McadTextControl Enumeration
McadTitle CoClass
McadTitleBorder CoClass
McadTitleBorderContext CoClass
McadTitleBorderDescriptor CoClass
McadTitleBorderMgr CoClass
McadTitleBorders CoClass
McadTitleBorderStandard CoClass
McadUndefinedSize Enumeration
McadUndefinedSizeDirection Enumeration
McadViewDefLockType Enumeration
McadWeldAssociation Enumeration
McadWelding CoClass
McadWeldingLibrary CoClass
McadWeldingLibraryObject CoClass
McadWeldingRequirement Enumeration
McadWeldingStandard CoClass
McadWeldSymbolType Enumeration
GEAuto Library
GeApplication CoClass
GeAugmentedLine CoClass
GeBoundBlock CoClass
GeBoundedSurface CoClass
GeCircularArc CoClass
GeCollectionType Enumeration
GeCompositeCurve CoClass
GeCone CoClass
GeCurveBoundaries CoClass
GeCurveBoundary CoClass
GeCurveCurveIntConfiguration Enumeration
GeCurveCurveIntersection CoClass
GeCurves CoClass
GeCurveSurfaceIntersection CoClass
GeCurveSurfIntConfiguration Enumeration
GeCylinder CoClass
GeEllipticalArc CoClass
GeEntities CoClass
GeInterval CoClass
GeKnotVector CoClass
GeLine CoClass
GeLineSegment CoClass
GeMatrix CoClass
GeNurbCurve CoClass
GeNurbSurface CoClass
GeNurbSurfaceProperties Enumeration
GeOffsetCurve CoClass
GeOffsetSurface CoClass
GePlane CoClass
GePoint CoClass
GePoints CoClass
GeRay CoClass
GeSphere CoClass
GeSurfaces CoClass
GeSurfaceSurfaceIntersection CoClass
GeSurfSurfIntConfiguration Enumeration
GeSurfSurfIntType Enumeration
GeTolerance CoClass
GeTorus CoClass
GeVector CoClass
GeVectors CoClass
IGeApplication Interface
IGeApplication Members
IGeApplication::Application Property
IGeApplication::AugmentedLine Method
IGeApplication::BoundBlock Method
IGeApplication::CircularArc Method
IGeApplication::Collection Method
IGeApplication::CompositeCurve Method
IGeApplication::Cone Method
IGeApplication::CurveBoundary Method
IGeApplication::Cylinder Method
IGeApplication::EllipticalArc Method
IGeApplication::Interval Method
IGeApplication::KnotVector Method
IGeApplication::Line Method
IGeApplication::LineSegment Method
IGeApplication::Matrix Method
IGeApplication::NurbCurve Method
IGeApplication::NurbSurface Method
IGeApplication::OffsetCurve Method
IGeApplication::OffsetSurface Method
IGeApplication::Plane Method
IGeApplication::Point Method
IGeApplication::Ray Method
IGeApplication::Sphere Method
IGeApplication::Tolerance Method
IGeApplication::Torus Method
IGeApplication::Vector Method
IGeAugmentedLine Interface
IGeAugmentedLine Members
IGeAugmentedLine::Points Property
IGeAugmentedLine::SecondDerivatives Property
IGeAugmentedLine::Vectors Property
IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)
IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)
IGeAugmentedLine::Set Method
IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)
IGeBoundBlock Interface
IGeBoundBlock Members
IGeBoundBlock::BasePoint Property
IGeBoundBlock::Direction1 Property
IGeBoundBlock::Direction2 Property
IGeBoundBlock::Direction3 Property
IGeBoundBlock::IsBox Property
IGeBoundBlock::MaxPoint Property
IGeBoundBlock::MinPoint Property
IGeBoundBlock::Contains Method
IGeBoundBlock::Extend Method
IGeBoundBlock::IsDisjoint Method
IGeBoundBlock::Swell Method
IGeBoundedSurface Interface
IGeBoundedSurface Members
IGeBoundedSurface::BaseSurface Property
IGeBoundedSurface::ContourCount Property
IGeBoundedSurface::Contours Property
IGeCircularArc Interface
IGeCircularArc Members
IGeCircularArc::Center Property
IGeCircularArc::EndAngle Property
IGeCircularArc::Normal Property
IGeCircularArc::Radius Property
IGeCircularArc::ReferenceVector Property
IGeCircularArc::StartAngle Property
IGeCircularArc::IntersectWith Method
IGeCircularArc::IsInside Method
IGeCircularArc::Set Method
IGeCircularArc::TangentAt Method
IGeCircularArc::TangentTangentRadius Method
IGeCircularArc::TangentTangentTangent Method
IGeCircularArc::ThreePoint Method
IGeCompositeCurve Interface
IGeCompositeCurve Members
IGeCompositeCurve::Curves Property
IGeCompositeCurve::GlobalToLocal Method
IGeCompositeCurve::LocalToGlobal Method
IGeCone Interface
IGeCone Members
IGeCone::Apex Property
IGeCone::AxisOfSymmetry Property
IGeCone::BaseRadius Property
IGeCone::EndAngle Property
IGeCone::HalfAngle Property
IGeCone::Height Property
IGeCone::Origin Property
IGeCone::ReferenceVector Property
IGeCone::StartAngle Property
IGeCone::HeightAt Method
IGeCone::IntersectWith Method
IGeCone::IsClosed Method
IGeCone::Set Method
IGeCurve Interface
IGeCurve Members
IGeCurve::Interval Property
IGeCurve::BoundBlock Method
IGeCurve::ClosestPointTo Method
IGeCurve::ClosestPointToCurve Method
IGeCurve::DistanceTo Method
IGeCurve::EvaluatePoint Method
IGeCurve::GetArea Method
IGeCurve::GetCurvature Method
IGeCurve::GetLength Method
IGeCurve::GetSamplePoints Method
IGeCurve::GetSplitCurves Method
IGeCurve::HasEndPoint Method
IGeCurve::HasStartPoint Method
IGeCurve::IntersectWithCurve Method
IGeCurve::IntersectWithSurface Method
IGeCurve::IsClosed Method
IGeCurve::IsCoplanarWith Method
IGeCurve::IsDegenerate Method
IGeCurve::IsLinear Method
IGeCurve::IsOnInterval Method
IGeCurve::IsPeriodic Method
IGeCurve::IsPlanar Method
IGeCurve::LocalClosestPointTo Method
IGeCurve::LocalClosestPointToCurve Method
IGeCurve::NormalPoint Method
IGeCurve::ParameterAtLength Method
IGeCurve::ParameterOf Method
IGeCurve::Project Method
IGeCurve::Reverse Method
IGeCurveBoundaries Interface
IGeCurveBoundaries Members
IGeCurveBoundaries::Application Property
IGeCurveBoundaries::Count Property
IGeCurveBoundaries::Add Method
IGeCurveBoundaries::Item Method
IGeCurveBoundaries::Remove Method
IGeCurveBoundary Interface
IGeCurveBoundary Members
IGeCurveBoundary::Application Property
IGeCurveBoundary::Elements Property
IGeCurveBoundary::Geometry2d Property
IGeCurveBoundary::Geometry3d Property
IGeCurveBoundary::Orientation2d Property
IGeCurveBoundary::Orientation3d Property
IGeCurveBoundary::GetBoundary Method
IGeCurveBoundary::IsDegenerate Method
IGeCurveBoundary::SetBoundary Method
IGeCurveCurveIntersection Interface
IGeCurveCurveIntersection Members
IGeCurveCurveIntersection::Curve1 Property
IGeCurveCurveIntersection::Curve2 Property
IGeCurveCurveIntersection::IntersectionPointCount Property
IGeCurveCurveIntersection::IntervalRange1 Property
IGeCurveCurveIntersection::IntervalRange2 Property
IGeCurveCurveIntersection::OverlapCount Property
IGeCurveCurveIntersection::OverlapDirection Property
IGeCurveCurveIntersection::Tolerance Property
IGeCurveCurveIntersection::GetAllIntersections Method
IGeCurveCurveIntersection::GetIntersectionConfiguration Method
IGeCurveCurveIntersection::GetOverlapRanges Method
IGeCurveCurveIntersection::IntersectionPoint Method
IGeCurveCurveIntersection::IntersectionPointTolerance Method
IGeCurveCurveIntersection::IsTangential Method
IGeCurveCurveIntersection::IsTransversal Method
IGeCurveCurveIntersection::ParameterOnCurve1 Method
IGeCurveCurveIntersection::ParameterOnCurve2 Method
IGeCurveCurveIntersection::Set Method
IGeCurves Interface
IGeCurves Members
IGeCurves::Application Property
IGeCurves::Count Property
IGeCurves::Add Method
IGeCurves::Item Method
IGeCurves::Remove Method
IGeCurveSurfaceIntersection Interface
IGeCurveSurfaceIntersection Members
IGeCurveSurfaceIntersection::Curve Property
IGeCurveSurfaceIntersection::IntersectionPointCount Property
IGeCurveSurfaceIntersection::Surface Property
IGeCurveSurfaceIntersection::Tolerance Property
IGeCurveSurfaceIntersection::GetAllIntersections Method
IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method
IGeCurveSurfaceIntersection::IntersectionPoint Method
IGeCurveSurfaceIntersection::ParameterOnCurve Method
IGeCurveSurfaceIntersection::ParameterOnSurface Method
IGeCurveSurfaceIntersection::Set Method
IGeCylinder Interface
IGeCylinder Members
IGeCylinder::AxisOfSymmetry Property
IGeCylinder::EndAngle Property
IGeCylinder::Height Property
IGeCylinder::Origin Property
IGeCylinder::Radius Property
IGeCylinder::ReferenceVector Property
IGeCylinder::StartAngle Property
IGeCylinder::IntersectWith Method
IGeCylinder::Set Method
IGeEllipticalArc Interface
IGeEllipticalArc Members
IGeEllipticalArc::Center Property
IGeEllipticalArc::EndAngle Property
IGeEllipticalArc::EndPoint Property
IGeEllipticalArc::IsCircular Property
IGeEllipticalArc::MajorAxis Property
IGeEllipticalArc::MajorRadius Property
IGeEllipticalArc::MinorAxis Property
IGeEllipticalArc::MinorRadius Property
IGeEllipticalArc::Normal Property
IGeEllipticalArc::StartAngle Property
IGeEllipticalArc::StartPoint Property
IGeEllipticalArc::IntersectWith Method
IGeEllipticalArc::IsInside Method
IGeEllipticalArc::Set Method
IGeEntities Interface
IGeEntities Members
IGeEntities::Application Property
IGeEntities::Count Property
IGeEntities::Add Method
IGeEntities::Item Method
IGeEntities::Remove Method
IGeEntity Interface
IGeEntity Members
IGeEntity::Application Property
IGeEntity::IsEqualTo Method
IGeEntity::IsOn Method
IGeEntity::Mirror Method
IGeEntity::RotateBy Method
IGeEntity::ScaleBy Method
IGeEntity::TransformBy Method
IGeEntity::TranslateBy Method
IGeInterval Interface
IGeInterval Members
IGeInterval::Application Property
IGeInterval::Bounded Property
IGeInterval::BoundedAbove Property
IGeInterval::BoundedBelow Property
IGeInterval::IsSingleton Property
IGeInterval::IsUnBounded Property
IGeInterval::Length Property
IGeInterval::Lower Property
IGeInterval::Upper Property
IGeInterval::Contains Method
IGeInterval::IsContinuousAtUpper Method
IGeInterval::IsDisjoint Method
IGeInterval::IsOverlapAtUpper Method
IGeKnotVector Interface
IGeKnotVector Members
IGeKnotVector::Application Property
IGeKnotVector::AsArray Property
IGeKnotVector::DistinctKnots Property
IGeKnotVector::EndParameter Property
IGeKnotVector::IsEmpty Property
IGeKnotVector::Length Property
IGeKnotVector::NumberOfIntervals Property
IGeKnotVector::StartParameter Property
IGeKnotVector::Tolerance Property
IGeKnotVector::AddKnot Method
IGeKnotVector::AddKnotVector Method
IGeKnotVector::Contains Method
IGeKnotVector::Insert Method
IGeKnotVector::InsertKnot Method
IGeKnotVector::Interval Method
IGeKnotVector::IsEqualTo Method
IGeKnotVector::Item Method ([in] long, [in] double)
IGeKnotVector::Item Method ([in] long, [out, retval] double*)
IGeKnotVector::MultiplicityAt Method
IGeKnotVector::RemoveKnotAt Method
IGeKnotVector::RemoveRange Method
IGeKnotVector::Reverse Method
IGeKnotVector::SetRange Method
IGeKnotVector::Split Method
IGeLine Interface
IGeLine Members
IGeLine::Set Method
IGeLinearEntity Interface
IGeLinearEntity Members
IGeLinearEntity::Direction Property
IGeLinearEntity::PointOnLine Property
IGeLinearEntity::IntersectWith Method
IGeLinearEntity::IsColinearTo Method
IGeLinearEntity::IsOnPlane Method
IGeLinearEntity::IsParallelTo Method
IGeLinearEntity::IsPerpendicularTo Method
IGeLinearEntity::Overlap Method
IGeLinearEntity::PerpendicularPlane Method
IGeLineSegment Interface
IGeLineSegment Members
IGeLineSegment::Bisector Property
IGeLineSegment::EndPoint Property
IGeLineSegment::MidPoint Property
IGeLineSegment::StartPoint Property
IGeLineSegment::BaryComb Method
IGeLineSegment::Set Method
IGeLineSegment::TangentTangent Method
IGeLineSegment::TangentTo Method
IGeMatrix Interface
IGeMatrix Members
IGeMatrix::Application Property
IGeMatrix::AsArray Property
IGeMatrix::Determinant Property
IGeMatrix::Inverse Property
IGeMatrix::Scale Property
IGeMatrix::Translation Property
IGeMatrix::Transpose Property
IGeMatrix::GetCoordinateSystem Method
IGeMatrix::Invert Method
IGeMatrix::IsEqualTo Method
IGeMatrix::IsOrthogonal Method
IGeMatrix::IsSingular Method
IGeMatrix::IsUniformScaledOrtho Method
IGeMatrix::Item Method ([in] long, [in] long, [in] double)
IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)
IGeMatrix::PostMultiply Method
IGeMatrix::PreMultiply Method
IGeMatrix::Product Method
IGeMatrix::SetToAlignCoordinateSystem Method
IGeMatrix::SetToCoordinateSystem Method
IGeMatrix::SetToIdentity Method
IGeMatrix::SetToMirroring Method
IGeMatrix::SetToProduct Method
IGeMatrix::SetToProjection Method
IGeMatrix::SetToRotation Method
IGeMatrix::SetToScaling Method
IGeMatrix::SetToTranslation Method
IGeMatrix::TransposeIt Method
IGeNurbCurve Interface
IGeNurbCurve Members
IGeNurbCurve::ControlPointCount Property
IGeNurbCurve::ControlPoints Property
IGeNurbCurve::Degree Property
IGeNurbCurve::EndParameter Property
IGeNurbCurve::EndPoint Property
IGeNurbCurve::EvaluatorMode Property
IGeNurbCurve::FitEndTangent Property
IGeNurbCurve::FitPointCount Property
IGeNurbCurve::FitPoints Property
IGeNurbCurve::FitStartTangent Property
IGeNurbCurve::FitTolerance Property
IGeNurbCurve::HasFitData Property
IGeNurbCurve::IsRational Property
IGeNurbCurve::KnotCount Property
IGeNurbCurve::Knots Property
IGeNurbCurve::Order Property
IGeNurbCurve::StartParameter Property
IGeNurbCurve::StartPoint Property
IGeNurbCurve::WeightCount Property
IGeNurbCurve::Weights Property
IGeNurbCurve::AddFitPointAt Method
IGeNurbCurve::AddKnot Method
IGeNurbCurve::ContinuityAtKnot Method
IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve::ElevateDegree Method
IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve::GetDefinitionData Method
IGeNurbCurve::GetFitData Method
IGeNurbCurve::JoinWith Method
IGeNurbCurve::KnotAt Method ([in] long, [in] double)
IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)
IGeNurbCurve::MakeClosed Method
IGeNurbCurve::MakePeriodic Method
IGeNurbCurve::MakeRational Method
IGeNurbCurve::ParametersOfC1 Method
IGeNurbCurve::ParametersOfG1 Method
IGeNurbCurve::PurgeFitData Method
IGeNurbCurve::RemoveFitPointAt Method
IGeNurbCurve::SetDefinitionData Method
IGeNurbCurve::SetFitData Method
IGeNurbCurve::TrimByParameters Method
IGeNurbCurve::WeightAt Method ([in] long, [in] double)
IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)
IGeNurbSurface Interface
IGeNurbSurface Members
IGeNurbSurface::ControlPoints Property
IGeNurbSurface::DegreeInU Property
IGeNurbSurface::DegreeInV Property
IGeNurbSurface::IsClosedInU Property
IGeNurbSurface::IsClosedInV Property
IGeNurbSurface::IsRationalInU Property
IGeNurbSurface::IsRationalInV Property
IGeNurbSurface::SingularityInU Property
IGeNurbSurface::SingularityInV Property
IGeNurbSurface::UControlPointCount Property
IGeNurbSurface::UKnotCount Property
IGeNurbSurface::UKnots Property
IGeNurbSurface::VControlPointCount Property
IGeNurbSurface::VKnotCount Property
IGeNurbSurface::VKnots Property
IGeNurbSurface::Weights Property
IGeNurbSurface::GetDefinitionData Method
IGeNurbSurface::IsPeriodicInU Method
IGeNurbSurface::IsPeriodicInV Method
IGeNurbSurface::SetDefinitionData Method
IGeOffsetCurve Interface
IGeOffsetCurve Members
IGeOffsetCurve::BaseCurve Property
IGeOffsetCurve::Normal Property
IGeOffsetCurve::OffsetDistance Property
IGeOffsetCurve::ParameterDirection Property
IGeOffsetCurve::Transformation Property
IGeOffsetSurface Interface
IGeOffsetSurface Members
IGeOffsetSurface::BaseSurface Property
IGeOffsetSurface::OffsetDistance Property
IGeOffsetSurface::ConvertedSurface Method
IGePlane Interface
IGePlane Members
IGePlane::Normal Property
IGePlane::Origin Property
IGePlane::CoordinateSystem Method
IGePlane::GetCoefficients Method
IGePlane::IntersectWith Method
IGePlane::IsCoplanarWith Method
IGePlane::IsParallelTo Method
IGePlane::IsPerpendicularTo Method
IGePlane::Set Method
IGePlane::SignedDistanceTo Method
IGePoint Interface
IGePoint Members
IGePoint::AsArray Property
IGePoint::X Property
IGePoint::Y Property
IGePoint::Z Property
IGePoint::AsVector Method
IGePoint::DistanceTo Method
IGePoint::Get Method
IGePoint::Item Method ([in] long, [in] double)
IGePoint::Item Method ([in] long, [out, retval] double*)
IGePoint::ProjectToPlane Method
IGePoint::Set Method
IGePoint::Sum Method
IGePoints Interface
IGePoints Members
IGePoints::Application Property
IGePoints::AsArray Property
IGePoints::AsArray2d Property
IGePoints::Count Property
IGePoints::Add Method
IGePoints::Item Method
IGePoints::Remove Method
IGeRay Interface
IGeRay Members
IGeRay::Set Method
IGeSphere Interface
IGeSphere Members
IGeSphere::EndLatitude Property
IGeSphere::EndLongitude Property
IGeSphere::NorthAxis Property
IGeSphere::NorthPole Property
IGeSphere::Origin Property
IGeSphere::Radius Property
IGeSphere::ReferenceAxis Property
IGeSphere::SouthPole Property
IGeSphere::StartLatitude Property
IGeSphere::StartLongitude Property
IGeSphere::IntersectWith Method
IGeSphere::IsClosedInU Method
IGeSphere::Set Method
IGeSurface Interface
IGeSurface Members
IGeSurface::NormalFlipped Property
IGeSurface::UParameterEnvelope Property
IGeSurface::VParameterEnvelope Property
IGeSurface::ClosestPointTo Method
IGeSurface::DistanceTo Method
IGeSurface::EvaluatePoint Method
IGeSurface::IntersectWithSurface Method
IGeSurface::ParameterOf Method
IGeSurfaces Interface
IGeSurfaces Members
IGeSurfaces::Application Property
IGeSurfaces::Count Property
IGeSurfaces::Add Method
IGeSurfaces::Item Method
IGeSurfaces::Remove Method
IGeSurfaceSurfaceIntersection Interface
IGeSurfaceSurfaceIntersection Members
IGeSurfaceSurfaceIntersection::IntersectionCount Property
IGeSurfaceSurfaceIntersection::Surface1 Property
IGeSurfaceSurfaceIntersection::Surface2 Property
IGeSurfaceSurfaceIntersection::Tolerance Property
IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method
IGeSurfaceSurfaceIntersection::IntersectionCurve Method
IGeSurfaceSurfaceIntersection::IntersectionDimension Method
IGeSurfaceSurfaceIntersection::IntersectionPoint Method
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method
IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method
IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method
IGeSurfaceSurfaceIntersection::Set Method
IGeTolerance Interface
IGeTolerance Members
IGeTolerance::Application Property
IGeTolerance::EqualPoint Property
IGeTolerance::EqualVector Property
IGeTorus Interface
IGeTorus Members
IGeTorus::AxisOfSymmetry Property
IGeTorus::EndAngleInU Property
IGeTorus::EndAngleInV Property
IGeTorus::MajorRadius Property
IGeTorus::MinorRadius Property
IGeTorus::Origin Property
IGeTorus::ReferenceAxis Property
IGeTorus::StartAngleInU Property
IGeTorus::StartAngleInV Property
IGeTorus::IntersectWith Method
IGeTorus::IsClosedInU Method
IGeTorus::IsClosedInV Method
IGeTorus::Set Method
IGeVector Interface
IGeVector Members
IGeVector::Application Property
IGeVector::AsArray Property
IGeVector::LargestElement Property
IGeVector::Length Property
IGeVector::Negative Property
IGeVector::Normal Property
IGeVector::X Property
IGeVector::Y Property
IGeVector::Z Property
IGeVector::AngleTo Method
IGeVector::CrossProduct Method
IGeVector::DotProduct Method
IGeVector::Get Method
IGeVector::IsCodirectionalTo Method
IGeVector::IsEqualTo Method
IGeVector::IsParallelTo Method
IGeVector::IsPerpendicularTo Method
IGeVector::IsUnitLength Method
IGeVector::IsZeroLength Method
IGeVector::Item Method ([in] long, [in] double)
IGeVector::Item Method ([in] long, [out, retval] double*)
IGeVector::Mirror Method
IGeVector::MultiplyBy Method
IGeVector::Negate Method
IGeVector::Normalize Method
IGeVector::PerpendicularVector Method
IGeVector::Product Method
IGeVector::Project Method
IGeVector::RotateBy Method
IGeVector::ScaleBy Method
IGeVector::Set Method
IGeVector::SetToProduct Method
IGeVector::SetToSum Method
IGeVector::Sum Method
IGeVector::TransformBy Method
IGeVectors Interface
IGeVectors Members
IGeVectors::Application Property
IGeVectors::Count Property
IGeVectors::Add Method
IGeVectors::Item Method
IGeVectors::Remove Method
Mcad2DSPreview
Sample Code


Index

Search Result

Index

_ | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

_

_NewEnum

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadPartReferences interface

A

AboveCurve

IMcadTaper interface

AcadmApplication

AcadmApplication coclass

about AcadmApplication coclass

AcadmApplication interface

about IAcadmApplication interface

ActiveDocument

AddAttributeClass

Application

AttributeClasses

DocumentFromHost

Documents

GetAttributeClassFields

GetFormulaEvaluator

IAcadmApplication members

ReadAttributeClass

RemoveAttributeClass

StructureModeEditEntity

WriteAttributeClass

AcadmApplication::ActiveDocument

AcadmApplication::ActiveDocument property

AcadmApplication::AddAttributeClass

AcadmApplication::AddAttributeClass method

AcadmApplication::Application

AcadmApplication::Application property

AcadmApplication::AttributeClasses

AcadmApplication::AttributeClasses property

AcadmApplication::DocumentFromHost

AcadmApplication::DocumentFromHost method

AcadmApplication::Documents

AcadmApplication::Documents property

AcadmApplication::GetAttributeClassFields

AcadmApplication::GetAttributeClassFields method

AcadmApplication::GetFormulaEvaluator

AcadmApplication::GetFormulaEvaluator method

AcadmApplication::ReadAttributeClass

AcadmApplication::ReadAttributeClass method

AcadmApplication::RemoveAttributeClass

AcadmApplication::RemoveAttributeClass method

AcadmApplication::StructureModeEditEntity

AcadmApplication::StructureModeEditEntity property

AcadmApplication::WriteAttributeClass

AcadmApplication::WriteAttributeClass method

AcadmApplicationVersion

AcadmApplicationVersion interface

about IAcadmApplicationVersion interface

GetVersionNumber

IAcadmApplicationVersion members

AcadmApplicationVersion::GetVersionNumber

AcadmApplicationVersion::GetVersionNumber method

AcadmAuto

AcadmAuto library

AcadmAuto::AcadmApplication

AcadmAuto::Mcad2dComplexStdPartCompGroupDescriptor

AcadmAuto::Mcad2dComponentDescriptor

AcadmAuto::Mcad2dShaftCompGroupDescriptor

AcadmAuto::Mcad2dStdPartComponentDescriptor

AcadmAuto::Mcad2DStructureDescriptor

AcadmAuto::Mcad2DStructureMgr

AcadmAuto::McadAnnotationViewDefinition

AcadmAuto::McadAnnotationViewDefinitions

AcadmAuto::McadArc

AcadmAuto::McadAttribute

AcadmAuto::McadAttributeField

AcadmAuto::McadAttributeFields

AcadmAuto::McadAttributes

AcadmAuto::McadAugmentedLine

AcadmAuto::McadComplexHideSituation

AcadmAuto::McadComplexHideSituations

AcadmAuto::McadComponent

AcadmAuto::McadComponentDefinition

AcadmAuto::McadComponentDefinitions

AcadmAuto::McadComponents

AcadmAuto::McadComponentView

AcadmAuto::McadComponentViewDefinition

AcadmAuto::McadComponentViewDefinitions

AcadmAuto::McadComponentViewDescriptor

AcadmAuto::McadComponentViews

AcadmAuto::McadDocument

AcadmAuto::McadDocuments

AcadmAuto::McadEllipse

AcadmAuto::McadFolder

AcadmAuto::McadFolderDefinition

AcadmAuto::McadFolderDefinitions

AcadmAuto::McadFolderDescriptor

AcadmAuto::McadFolders

AcadmAuto::McadFormulaEvaluator

AcadmAuto::McadHideSituation

AcadmAuto::McadHideSituations

AcadmAuto::McadLayerCfg

AcadmAuto::McadLayerCfgs

AcadmAuto::McadLayerGroupMgr

AcadmAuto::McadLayerObjectCfg

AcadmAuto::McadLayerObjectCfgs

AcadmAuto::McadLayerObjectMgr

AcadmAuto::McadLine

AcadmAuto::McadObjects

AcadmAuto::McadPick

AcadmAuto::McadPolyline

AcadmAuto::McadPowObjViewGroupDescriptor

AcadmAuto::McadSpline

AcadmAuto::McadStdPartComponentViewDescriptor

AcadmAuto::McadTransaction

AcadmAuto::McadUtility

ActiveDocument

IAcadmApplication interface

ActualRowTextHeight

IMcadPartListStandard interface

Add

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

AddAllowedScale

IMcadDetailSymbolStandard interface

AddAttribute

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

AddAttributeClass

IAcadmApplication interface

AddBOMTable

IMcadBOMMgr interface

AddBorderBOMTable

IMcadBOMMgr2 interface

AddColumn

IMcadBOMStandard interface

AddComplexHideSituation

IMcadFolderDefinition interface

AddComponent

IMcadComponentDefinition interface

AddComponentView

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

IMcadComponentViewDefinition interface

AddEntities

IMcadFolder interface

AddFilter

IMcadPartList interface

AddFilterType

IMcadPartList2 interface

AddFitPointAt

IGeNurbCurve interface

AddFolder

IMcadFolderDefinition interface

AddFromExistingEntities

IMcadFolderDefinition interface

AddHideSituation

IMcadFolderDefinition interface

AddItem

IMcadBOM interface

AddKnot

IGeKnotVector interface

IGeNurbCurve interface

AddKnotVector

IGeKnotVector interface

AddLeader

IMcadSymbol interface

AddLeaderWithSurfIndLeader

IMcadDatumIdentifier3 interface

IMcadFeatureControlFrame4 interface

AddLevel

IMcadComplexHideSituation interface

AddMSSubent

IMcadHideSituation interface

AddMSSubents

IMcadHideSituation interface

AddNewAnnotationView

IMcad2DStructureMgr3 interface

AddNewAnnotationViewDefinition

IMcad2DStructureMgr interface

IMcad2DStructureMgr3 interface

AddNewComponentDefinition

IMcad2DStructureMgr interface

AddNewComponentView

IMcad2DStructureMgr interface

AddNewComponentViewDefinition

IMcad2DStructureMgr interface

AddNewFolder

IMcad2DStructureMgr interface

AddNewFolderDefinition

IMcad2DStructureMgr interface

AddPartData

IMcadBOMMgr interface

AddPartGrfDef

IMcadBOMMgr2 interface

AddReference

IMcadBOMItem interface

AddSectionPoint

IMcadSectionLine interface

AddStandard

IMcadStandardMgr interface

AddStdCompliantLeader

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

AddSubent

IMcadHideSituation interface

AddSubents

IMcadHideSituation interface

AddSubWelding

IMcadWelding interface

AddSurfIndLeader

IMcadFeatureControlFrame4 interface

IMcadSurfaceTexture4 interface

AddSymbolStandard

IMcadStandard interface

AddTemplate

IMcadNoteStandard interface

AddUnassociatedItem

IMcadBOM interface

AddView

IMcad2dComplexStdPartCompGroupDescriptor interface

AdjustLanding

IMcadNote interface

AdjustReferenceLine

IMcadTaper interface

AllAround

IMcadEdge interface

IMcadJoint interface

AllAroundAllowed

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

AllowanceValue

IMcadSurfaceTexture interface

AllowedScales

IMcadDetailSymbolStandard interface

AllSymbolStandards

IMcadStandard interface

Angle

IMcadSurfaceTexture interface

AngleTo

IGeVector interface

AngleValue

IMcadWelding interface

IMcadWelding interface

Annotation

IMcadJoint interface

AnnotationOffset

IMcadDetailSymbol interface

IMcadDetailSymbolLabel interface

AnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

AnnotationViewLabelPattern

IMcadAnnotationViewDefinition2 interface

IMcadAnnotationViewDefinition2 interface

AnnotationViewStandard

IMcadStandard3 interface

Apex

IGeCone interface

API Reference

AppendBOMItem

IMcadBalloon interface

appendItem

IMcadSymbolLibrary interface

appendItemFromSubWelding

IMcadWeldingLibrary interface

Application

IAcadmApplication interface

IGeApplication interface

IGeCurveBoundaries interface

IGeCurveBoundary interface

IGeCurves interface

IGeEntities interface

IGeEntity interface

IGeInterval interface

IGeKnotVector interface

IGeMatrix interface

IGePoints interface

IGeSurfaces interface

IGeTolerance interface

IGeVector interface

IGeVectors interface

IMcad2DStructureMgr interface

IMcadAnnotationViewDefinitions interface

IMcadAttribute interface

IMcadAttributeField interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBalloonStandard interface

IMcadBOMItems interface

IMcadBOMMgr interface

IMcadBOMs interface

IMcadColumnDefinition interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDescriptor interface

IMcadDocument interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadFormulaEvaluator interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObject interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartListStandard interface

IMcadPartReferences interface

IMcadPick interface

IMcadRevisionLists interface

IMcadStandardMgr interface

IMcadStandards interface

IMcadSymbolBBMgr interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

IMcadTransaction interface

IMcadUtility interface

applySort

IMcadBOM2 interface

AreaType

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

ArrowLineLength

IMcadSectionLineStandard2 interface

ArrowScale

IMcadStandard interface

IMcadSymbolStandard2 interface

ArrowSideReqValue

IMcadWeldingLibraryObject interface

ArrowTowardsLine

IMcadSectionLineStandard interface

ArrowType

IMcadBalloonStandard interface

IMcadStandard interface

IMcadSymbolStandard2 interface

ArrowVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

AsArray

IGeKnotVector interface

IGeMatrix interface

IGePoint interface

IGePoints interface

IGeVector interface

AsArray2d

IGePoints interface

AssociationType

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

AssocObjects

IMcadLayerCfg interface

AsVector

IGePoint interface

AttachedExternalBom

IMcadPartReference3 interface

AttachedExternalBomXrefBlock

IMcadPartReference3 interface

AttachExternalBom

IMcadPartReference3 interface

AttachGeometry

IMcadSymbol interface

AttachmentPoint

IMcadPartList interface

IMcadPartListStandard interface

AttachmentType

IMcadBalloon interface

IMcadBalloonStandard interface

AttachObjectId

IMcadScaleArea interface

AttachObjectId32

IMcadScaleArea interface

AttributeClasses

IAcadmApplication interface

Attributes

IMcadBorder interface

IMcadRevisionListDescriptor interface

IMcadTitle interface

AugmentedLine

IGeApplication interface

AutoCalculateEnabled

IMcadBOMItem interface

AutomaticAdjust

IMcadSurfaceTexture interface

AutomaticPlacement

IMcadTitleBorderContext interface

AutoSelectBackground

IMcadHideSituation interface

AuxiliaryArrowType

IMcadBalloonStandard interface

AvailableAuxiliarySymbols

IMcadFCFStandard interface

AvailableBackingSymbols

IMcadWeldingStandard interface

AvailableContourSymbols

IMcadWeldingStandard interface

AvailableGDTSymbols

IMcadFCFStandard interface

AvailableLaySymbols

IMcadSurfaceTextureStandard interface

AvailableMarkingContents

IMcadMarkStampStandard interface

AvailableMarkingMethods

IMcadMarkStampStandard interface

AvailableStampingContents

IMcadMarkStampStandard interface

AvailableStampingMethods

IMcadMarkStampStandard interface

AvailableWeldSymbols

IMcadWeldingStandard interface

AxisOfSymmetry

IGeCone interface

IGeCylinder interface

IGeTorus interface

B

BackingValue

IMcadWelding interface

IMcadWelding interface

Balloons

IMcadBOMItem interface

BalloonStandard

IMcadBOMStandard interface

BalloonType

IMcadBalloon interface

IMcadBalloonStandard interface

BaryComb

IGeLineSegment interface

BaseCurve

IGeOffsetCurve interface

BaseName

IMcadStandard interface

BasePoint

IGeBoundBlock interface

IMcadFolder interface

BaseRadius

IGeCone interface

BaseScale

IMcadTitleBorderContext interface

BaseSurface

IGeBoundedSurface interface

IGeOffsetSurface interface

BaseViewScale

IMcadDetailSymbol interface

BendLineLength

IMcadSectionLineStandard2 interface

BgSelectionName

IMcadHideSituation interface

Bisector

IGeLineSegment interface

BlockDef enumeration member

BlockId

IMcadBorder2 interface

IMcadTitle2 interface

BlockId32

IMcadBorder2 interface

IMcadTitle2 interface

BoldVerticalLine

IMcadPartListStandard3 interface

BOM

IMcadBalloon interface

IMcadBOMItem interface

IMcadPartList interface

BOMCaptionAlignment

IMcadColumnDefinition3 interface

BOMDataAlignment

IMcadColumnDefinition3 interface

BOMItems

IMcadBalloon interface

BOMMgr

IMcadSymbolBBMgr interface

BOMStandard

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadStandard interface

BOMTableExists

IMcadBOMMgr interface

Border

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

IMcadTitleBorderDescriptor interface

Border32

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

BorderLineColor

IMcadDetailSymbolStandard2 interface

BorderLineLineType

IMcadDetailSymbolStandard2 interface

BorderLineType

IMcadDatumStandard interface

IMcadDetailSymbolStandard interface

BorderLineTypeName

IMcadDatumStandard interface

BorderLineWeight

IMcadDetailSymbolStandard2 interface

BottomNoteValue

IMcadFeatureControlFrame2 interface

BoundaryLineColor

IMcadDetailSymbolStandard2 interface

BoundaryLineType

IMcadDetailSymbolStandard2 interface

BoundaryLineWeight

IMcadDetailSymbolStandard2 interface

BoundBlock

IGeApplication interface

IGeCurve interface

Bounded

IGeInterval interface

BoundedAbove

IGeInterval interface

BoundedBelow

IGeInterval interface

Brazing

IMcadWelding interface

IMcadWelding interface

BrazingValue

IMcadWelding interface

IMcadWelding interface

bx enumeration member

C

Caption

IMcadColumnDefinition interface

CaptionAlignment

IMcadColumnDefinition interface

Center

IGeCircularArc interface

IGeEllipticalArc interface

ChangeTemplateValue

IMcadNoteStandard interface

Children

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolder interface

IMcadFolderDefinition interface

ChildrenCount

IMcadFolderDefinition interface

CircleRadius

IMcadDatumTarget interface

CircularArc

IGeApplication interface

ClassName

IMcadAttribute interface

ClearanceValue

IMcadWelding interface

IMcadWelding interface

ClearLeaf

IMcadFolder interface

ClearOverrideProperties

IMcadComponent interface

IMcadFolder interface

ClearSubents

IMcadHideSituation interface

ClosedTail

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

ClosedTailAllowed

IMcadWeldingStandard interface

ClosestPointTo

IGeCurve interface

IGeSurface interface

ClosestPointToCurve

IGeCurve interface

cm enumeration member

Collection

IGeApplication interface

CollectionType

IMcadBalloon interface

Color

IMcadBalloonStandard interface

ColorOverride

IMcadComponent interface

IMcadFolder interface

ColumnCount

IMcadBOMStandard interface

ColumnList

IMcadBalloonStandard interface

IMcadPartListStandard interface

Columns

IMcadBOMStandard interface

ColumnSplitEnabled

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitRows

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitSections

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitStyle

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitWrap

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitWrapAroundTitle

IMcadPartListStandard4 interface

ColumnType

IMcadColumnDefinition interface

CommentValue

IMcadSurfaceTexture interface

CompDef enumeration member

ComplexHideSituations

IMcadFolderDefinition interface

Component

IMcad2dComponentDescriptor interface

IMcadComponentView interface

IMcadComponentViewDescriptor interface

ComponentDefinition

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

ComponentViewDefinitions

IMcadComponentDefinition interface

ComponentViews

IMcad2dComponentDescriptor interface

IMcadComponent interface

CompositeCurve

IGeApplication interface

Concealed

IMcadComplexHideSituation interface

IMcadHideSituation interface

Cone

IGeApplication interface

ConnectionLineColor

IMcadDetailSymbolStandard2 interface

ConnectionLineType

IMcadDetailSymbolStandard2 interface

ConnectionLineWeight

IMcadDetailSymbolStandard2 interface

ContainingComponent

IMcadComponent interface

IMcadGeometry interface

Contains

IGeBoundBlock interface

IGeInterval interface

IGeKnotVector interface

ContentValue

IMcadMarkStamp interface

ContextDefinition

IMcadFolder interface

ContinuityAtKnot

IGeNurbCurve interface

ContourCount

IGeBoundedSurface interface

Contours

IGeBoundedSurface interface

ContoursOnlyInForeground

IMcadHideSituation interface

ContourType

IMcadWelding interface

IMcadWelding interface

ContourValue

IMcadWelding interface

IMcadWelding interface

ControlCategoryValue

IMcadWelding interface

IMcadWelding interface

ControlPointAt

IGeNurbCurve interface

IGeNurbCurve interface

ControlPointCount

IGeNurbCurve interface

ControlPoints

IGeNurbCurve interface

IGeNurbSurface interface

ConvertedSurface

IGeOffsetSurface interface

CoordinateSystem

IGePlane interface

IMcadSymbol interface

CopyComponentFromDatabase

IMcad2DStructureMgr interface

CopyDefinition

IMcadComponent interface

IMcadComponentDefinition interface

CopyEntities

IMcadFolder interface

CopyFolderFromDatabase

IMcad2DStructureMgr interface

CopyStandard

IMcadStandardMgr interface

CopyView

IMcadFolder interface

CopyViewDefinition

IMcadFolder interface

CorrectionScaleFactor

IMcadDetailSymbol interface

Count

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadRevisionLists interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

Create2dComplexStdPartCompGroupDescriptor

IMcad2DStructureMgr interface

Create2dComponentDescriptor

IMcad2DStructureMgr interface

Create2dStdPartComponentDescriptor

IMcad2DStructureMgr interface

CreateAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

CreateAnnotationViewLabels

IMcadAnnotationViewDefinition2 interface

CreateAttribute

IMcadUtility interface

CreateAttributeField

IMcadUtility interface

CreateBlocksFromStructure

IMcad2DStructureMgr interface

CreateCollection

IMcadUtility interface

CreateComponent

IMcad2dComponentDescriptor interface

CreateComponentView

IMcadComponentViewDescriptor interface

CreateComponentViewDescriptor

IMcad2DStructureMgr interface

CreateFolder

IMcadFolderDescriptor interface

CreateFolderDescriptor

IMcad2DStructureMgr interface

CreateLabelEntity

IMcadDetailSymbol interface

CreateLayer

IMcadLayerObjectMgr interface

CreateNoteText

IMcadNote interface

CreatePickObject

IMcadUtility interface

CreateRevisionList

IMcadRevisionMgr interface

CreateRootViewDefinition

IMcad2DStructureMgr5 interface

CreateScaleArea

IMcadScaleAreaMgr interface

CreateStructureFromBlocks

IMcad2DStructureMgr interface

CreateSystemAttribute

IMcadUtility interface

CreateTitleBorder

IMcadTitleBorderMgr interface

CreateViewPort

IMcadScaleArea interface

CrossProduct

IGeVector interface

Current

IMcadStandard interface

CurrentBOM

IMcadBOMMgr2 interface

CurrentStandard

IMcadStandardMgr interface

CurrentStandardName

IMcadStandardMgr interface

CurrentSymbolStandards

IMcadStandard interface

Curve

IGeCurveSurfaceIntersection interface

Curve1

IGeCurveCurveIntersection interface

Curve2

IGeCurveCurveIntersection interface

CurveBoundary

IGeApplication interface

Curves

IGeCompositeCurve interface

CustomBlock

IMcadBalloon interface

CustomBlockName

IMcadBalloon interface

IMcadBalloonStandard interface

IMcadPartList interface

IMcadPartListStandard interface

CustomBlocks

IMcadPartList interface

IMcadPartListStandard interface

CutoffValue

IMcadSurfaceTexture interface

Cylinder

IGeApplication interface

D

Data

IMcadBOM interface

IMcadBOMItem interface

IMcadPartReference interface

DataAlignment

IMcadColumnDefinition interface

DataType

IMcadColumnDefinition interface

DatumIDValue

IMcadFeatureControlFrame interface

DatumNote

IMcadDatumIdentifier3 interface

DatumPrimary2Value

IMcadFeatureControlFrame interface

DatumPrimary3Value

IMcadFeatureControlFrame interface

DatumPrimaryValue

IMcadFeatureControlFrame interface

DatumSecondary2Value

IMcadFeatureControlFrame interface

DatumSecondary3Value

IMcadFeatureControlFrame interface

DatumSecondaryValue

IMcadFeatureControlFrame interface

DatumStandard

IMcadStandard interface

DatumTertiary2Value

IMcadFeatureControlFrame interface

DatumTertiary3Value

IMcadFeatureControlFrame interface

DatumTertiaryValue

IMcadFeatureControlFrame interface

DatumValue

IMcadDatumTarget interface

DefaultArrowType

IMcadIdentifierStandard interface

DefaultItem

IMcadSymbolLibrary interface

DefaultPaperFormat

IMcadTitleBorderStandard interface

DefaultRevisionList

IMcadTitleBorderStandard interface

DefaultStandard

IMcadStandardMgr interface

DefaultTitleBlock

IMcadTitleBorderStandard interface

Definition

IMcadComplexHideSituation interface

IMcadComponent interface

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadHideSituation interface

Degree

IGeNurbCurve interface

DegreeInU

IGeNurbSurface interface

DegreeInV

IGeNurbSurface interface

Delete

IMcadObject interface

DeleteAllTemplates

IMcadNoteStandard interface

DeleteRevisionList

IMcadRevisionMgr interface

DeleteScaleArea

IMcadScaleAreaMgr interface

DeleteTemplate

IMcadNoteStandard interface

DeleteTitleBorder

IMcadTitleBorderMgr interface

DeleteViewPort

IMcadScaleArea interface

DepthValue

IMcadWelding interface

IMcadWelding interface

Desc

IMcadLayerCfg interface

Description

IMcadAttributeField interface

Descriptor

IMcadTitleBorder interface

DesignationValue

IMcadWelding interface

IMcadWelding interface

DetachExternalBom

IMcadPartReference3 interface

DetachGeometry

IMcadSymbol interface

DetailScale

IMcadDetailSymbol interface

DetailSymbolStandard

IMcadStandard3 interface

Determinant

IGeMatrix interface

DimensionValue

IMcadDatumTarget interface

Direction

IGeLinearEntity interface

IMcadEdge interface

Direction1

IGeBoundBlock interface

Direction2

IGeBoundBlock interface

Direction3

IGeBoundBlock interface

DisplayString

IMcadTaper interface

DistanceTo

IGeCurve interface

IGePoint interface

IGeSurface interface

DistinctKnots

IGeKnotVector interface

Document

IMcadAttribute interface

IMcadDescriptor interface

IMcadLayerGroupMgr interface

IMcadLayerObjectMgr interface

IMcadObject interface

IMcadUtility interface

DocumentFromHost

IAcadmApplication interface

Documents

IAcadmApplication interface

DotProduct

IGeVector interface

DrawLeaderArrow

IMcadDatumStandard interface

DrawLine

IMcadDatumTarget interface

DrawPoint

IMcadDatumTarget interface

DwgDefault

IMcadTitleBorderContext interface

E

Each enumeration member

EdgeStandard

IMcadStandard3 interface

Editable

IMcadObject interface

EditTarget

IMcad2DStructureMgr interface

Elements

IGeCurveBoundary interface

ElevateDegree

IGeNurbCurve interface

EllipticalArc

IGeApplication interface

EndAngle

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

EndAngleInU

IGeTorus interface

EndAngleInV

IGeTorus interface

EndArrowType

IMcadSectionLineStandard2 interface

EndBendLineType

IMcadSectionLineStandard2 interface

EndLatitude

IGeSphere interface

EndLineLength

IMcadSectionLineStandard2 interface

EndLineOvershoot

IMcadSectionLineStandard2 interface

EndLongitude

IGeSphere interface

EndPadding

IMcadFCFStandard interface

EndParameter

IGeKnotVector interface

IGeNurbCurve interface

EndPoint

IGeEllipticalArc interface

IGeLineSegment interface

IGeNurbCurve interface

Entities

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

Entities32

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

entryName

IMcadSymbolLibraryObject interface

EqualPoint

IGeTolerance interface

EqualVector

IGeTolerance interface

Equivalents

IMcadColumnDefinition interface

EraseAllowedScales

IMcadDetailSymbolStandard interface

EraseAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

Evaluate

IMcadFormulaEvaluator interface

IMcadPartListFilter interface

EvaluatedNoteText

IMcadNote interface

EvaluatePoint

IGeCurve interface

IGeSurface interface

EvaluatorMode

IGeNurbCurve interface

Excluded

IMcadPartListFilter2 interface

ExcludeFromPartList

IMcadBOMItem2 interface

exCSV enumeration member

exDB5 enumeration member

exDBIII enumeration member

exDBIV enumeration member

exEXCEL95 enumeration member

exEXCEL97 enumeration member

exFOX25 enumeration member

exFOX26 enumeration member

exFOXVIS enumeration member

exHTML enumeration member

Exist

IMcadFormulaEvaluator interface

ExistsStructure

IMcad2DStructureMgr5 interface

exMDB enumeration member

exMDB97 enumeration member

Expanded

IMcadBOMItem interface

Explode

IMcadComplexHideSituation interface

IMcadFolder interface

ExportBOM

IMcadBOMMgr interface

ExportBOM2

IMcadBOMMgr2 interface

ExportPartList

IMcadBOMMgr2 interface

Extend

IGeBoundBlock interface

Extends

IMcadBorder interface

Extents

IMcadFolderDefinition interface

ExtentsMaximum

IMcadFolder interface

ExtentsMinimum

IMcadFolder interface

Externalize

IMcadComponentDefinition interface

IMcadFolderDefinition interface

ExternalPath

IMcadComponentDefinition interface

ExternalStructureDatabases

IMcad2DStructureMgr interface

exTXT enumeration member

F

FarSideLeaderLineType

IMcadIdentifierStandard2 interface

FarSideLeaderLineTypeName

IMcadIdentifierStandard2 interface

FarSideStatus

IMcadDatumIdentifier3 interface

FCFStandard

IMcadStandard interface

FgSelectionName

IMcadHideSituation interface

FieldCount

IMcadAttribute interface

FieldDescription

IMcadAttribute interface

FieldName

IMcadAttribute interface

FieldType

IMcadAttribute interface

IMcadAttributeField interface

FieldValue

IMcadAttribute interface

IMcadAttribute interface

FieldValue32

IMcadAttribute interface

IMcadAttribute interface

FieldWeld

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

FilterEmptyBlocks

IMcadPartList interface

IMcadPartListStandard interface

Filters

IMcadPartList interface

FindHideSituations

IMcadFolderDefinition interface

findItem

IMcadSymbolLibrary interface

findList

IMcadSymbolLibrary interface

FindScaleArea

IMcadScaleAreaMgr interface

FinishingValue

IMcadWelding interface

IMcadWelding interface

FirstRequirement

IMcadSurfaceTexture2 interface

FitCircle

IMcadSurfaceTextureStandard interface

FitEndTangent

IGeNurbCurve interface

FitPointAt

IGeNurbCurve interface

IGeNurbCurve interface

FitPointCount

IGeNurbCurve interface

FitPoints

IGeNurbCurve interface

FitStartTangent

IGeNurbCurve interface

FitTolerance

IGeNurbCurve interface

ForceTail

IMcadSurfaceTextureStandard interface

FormulaBarEnabled

IMcadPartList2 interface

FourthRequirement

IMcadSurfaceTexture2 interface

FrameColor

IMcadPartListStandard interface

FrameGap

IMcadFCFStandard interface

FrameTrueColor

IMcadPartListStandard2 interface

ft enumeration member

FullList

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

FullName

IMcadFolderDefinition interface

FullViewName

IMcadComponentViewDescriptor interface

G

g enumeration member

gal enumeration member

GapValue

IMcadWelding interface

IMcadWelding interface

GDTTextFont

IMcadFCFStandard interface

GDTTextStyle

IMcadFCFStandard interface

GDTTextStyleName

IMcadFCFStandard interface

geAntiTangent enumeration member

GeApplication

GeApplication coclass

about GeApplication coclass

GeApplication interface

about IGeApplication interface

Application

AugmentedLine

BoundBlock

CircularArc

Collection

CompositeCurve

Cone

CurveBoundary

Cylinder

EllipticalArc

IGeApplication members

Interval

KnotVector

Line

LineSegment

Matrix

NurbCurve

NurbSurface

OffsetCurve

OffsetSurface

Plane

Point

Ray

Sphere

Tolerance

Torus

Vector

GeApplication::Application

GeApplication::Application property

GeApplication::AugmentedLine

GeApplication::AugmentedLine method

GeApplication::BoundBlock

GeApplication::BoundBlock method

GeApplication::CircularArc

GeApplication::CircularArc method

GeApplication::Collection

GeApplication::Collection method

GeApplication::CompositeCurve

GeApplication::CompositeCurve method

GeApplication::Cone

GeApplication::Cone method

GeApplication::CurveBoundary

GeApplication::CurveBoundary method

GeApplication::Cylinder

GeApplication::Cylinder method

GeApplication::EllipticalArc

GeApplication::EllipticalArc method

GeApplication::Interval

GeApplication::Interval method

GeApplication::KnotVector

GeApplication::KnotVector method

GeApplication::Line

GeApplication::Line method

GeApplication::LineSegment

GeApplication::LineSegment method

GeApplication::Matrix

GeApplication::Matrix method

GeApplication::NurbCurve

GeApplication::NurbCurve method

GeApplication::NurbSurface

GeApplication::NurbSurface method

GeApplication::OffsetCurve

GeApplication::OffsetCurve method

GeApplication::OffsetSurface

GeApplication::OffsetSurface method

GeApplication::Plane

GeApplication::Plane method

GeApplication::Point

GeApplication::Point method

GeApplication::Ray

GeApplication::Ray method

GeApplication::Sphere

GeApplication::Sphere method

GeApplication::Tolerance

GeApplication::Tolerance method

GeApplication::Torus

GeApplication::Torus method

GeApplication::Vector

GeApplication::Vector method

GeAugmentedLine

GeAugmentedLine coclass

about GeAugmentedLine coclass

GeAugmentedLine interface

about IGeAugmentedLine interface

IGeAugmentedLine members

PointAt

PointAt

Points

SecondDerivativeAt

SecondDerivativeAt

SecondDerivatives

Set

VectorAt

VectorAt

Vectors

GeAugmentedLine::PointAt

GeAugmentedLine::PointAt method

GeAugmentedLine::Points

GeAugmentedLine::Points property

GeAugmentedLine::SecondDerivativeAt

GeAugmentedLine::SecondDerivativeAt method

GeAugmentedLine::SecondDerivatives

GeAugmentedLine::SecondDerivatives property

GeAugmentedLine::Set

GeAugmentedLine::Set method

GeAugmentedLine::VectorAt

GeAugmentedLine::VectorAt method

GeAugmentedLine::Vectors

GeAugmentedLine::Vectors property

GEAuto

GEAuto library

GEAuto::GeApplication

GEAuto::GeAugmentedLine

GEAuto::GeBoundBlock

GEAuto::GeBoundedSurface

GEAuto::GeCircularArc

GEAuto::GeCompositeCurve

GEAuto::GeCone

GEAuto::GeCurveBoundaries

GEAuto::GeCurveBoundary

GEAuto::GeCurveCurveIntersection

GEAuto::GeCurves

GEAuto::GeCurveSurfaceIntersection

GEAuto::GeCylinder

GEAuto::GeEllipticalArc

GEAuto::GeEntities

GEAuto::GeInterval

GEAuto::GeKnotVector

GEAuto::GeLine

GEAuto::GeLineSegment

GEAuto::GeMatrix

GEAuto::GeNurbCurve

GEAuto::GeNurbSurface

GEAuto::GeOffsetCurve

GEAuto::GeOffsetSurface

GEAuto::GePlane

GEAuto::GePoint

GEAuto::GePoints

GEAuto::GeRay

GEAuto::GeSphere

GEAuto::GeSurfaces

GEAuto::GeSurfaceSurfaceIntersection

GEAuto::GeTolerance

GEAuto::GeTorus

GEAuto::GeVector

GEAuto::GeVectors

GeBoundBlock

GeBoundBlock coclass

about GeBoundBlock coclass

GeBoundBlock interface

about IGeBoundBlock interface

BasePoint

Contains

Direction1

Direction2

Direction3

Extend

IGeBoundBlock members

IsBox

IsDisjoint

MaxPoint

MinPoint

Swell

GeBoundBlock::BasePoint

GeBoundBlock::BasePoint property

GeBoundBlock::Contains

GeBoundBlock::Contains method

GeBoundBlock::Direction1

GeBoundBlock::Direction1 property

GeBoundBlock::Direction2

GeBoundBlock::Direction2 property

GeBoundBlock::Direction3

GeBoundBlock::Direction3 property

GeBoundBlock::Extend

GeBoundBlock::Extend method

GeBoundBlock::IsBox

GeBoundBlock::IsBox property

GeBoundBlock::IsDisjoint

GeBoundBlock::IsDisjoint method

GeBoundBlock::MaxPoint

GeBoundBlock::MaxPoint property

GeBoundBlock::MinPoint

GeBoundBlock::MinPoint property

GeBoundBlock::Swell

GeBoundBlock::Swell method

GeBoundedSurface

GeBoundedSurface coclass

about GeBoundedSurface coclass

GeBoundedSurface interface

about IGeBoundedSurface interface

BaseSurface

ContourCount

Contours

IGeBoundedSurface members

GeBoundedSurface::BaseSurface

GeBoundedSurface::BaseSurface property

GeBoundedSurface::ContourCount

GeBoundedSurface::ContourCount property

GeBoundedSurface::Contours

GeBoundedSurface::Contours property

GeCircularArc

GeCircularArc coclass

about GeCircularArc coclass

GeCircularArc interface

about IGeCircularArc interface

Center

EndAngle

IGeCircularArc members

IntersectWith

IsInside

Normal

Radius

ReferenceVector

Set

StartAngle

TangentAt

TangentTangentRadius

TangentTangentTangent

ThreePoint

GeCircularArc::Center

GeCircularArc::Center property

GeCircularArc::EndAngle

GeCircularArc::EndAngle property

GeCircularArc::IntersectWith

GeCircularArc::IntersectWith method

GeCircularArc::IsInside

GeCircularArc::IsInside method

GeCircularArc::Normal

GeCircularArc::Normal property

GeCircularArc::Radius

GeCircularArc::Radius property

GeCircularArc::ReferenceVector

GeCircularArc::ReferenceVector property

GeCircularArc::Set

GeCircularArc::Set method

GeCircularArc::StartAngle

GeCircularArc::StartAngle property

GeCircularArc::TangentAt

GeCircularArc::TangentAt method

GeCircularArc::TangentTangentRadius

GeCircularArc::TangentTangentRadius method

GeCircularArc::TangentTangentTangent

GeCircularArc::TangentTangentTangent method

GeCircularArc::ThreePoint

GeCircularArc::ThreePoint method

geClosed enumeration member

geCoincident enumeration member

geCoincidentUnbounded enumeration member

GeCollectionType

GeCollectionType enumeration

GeCompositeCurve

GeCompositeCurve coclass

about GeCompositeCurve coclass

GeCompositeCurve interface

about IGeCompositeCurve interface

Curves

GlobalToLocal

IGeCompositeCurve members

LocalToGlobal

GeCompositeCurve::Curves

GeCompositeCurve::Curves property

GeCompositeCurve::GlobalToLocal

GeCompositeCurve::GlobalToLocal method

GeCompositeCurve::LocalToGlobal

GeCompositeCurve::LocalToGlobal method

GeCone

GeCone coclass

about GeCone coclass

GeCone interface

about IGeCone interface

Apex

AxisOfSymmetry

BaseRadius

EndAngle

HalfAngle

Height

HeightAt

IGeCone members

IntersectWith

IsClosed

Origin

ReferenceVector

Set

StartAngle

GeCone::Apex

GeCone::Apex property

GeCone::AxisOfSymmetry

GeCone::AxisOfSymmetry property

GeCone::BaseRadius

GeCone::BaseRadius property

GeCone::EndAngle

GeCone::EndAngle property

GeCone::HalfAngle

GeCone::HalfAngle property

GeCone::Height

GeCone::Height property

GeCone::HeightAt

GeCone::HeightAt method

GeCone::IntersectWith

GeCone::IntersectWith method

GeCone::IsClosed

GeCone::IsClosed method

GeCone::Origin

GeCone::Origin property

GeCone::ReferenceVector

GeCone::ReferenceVector property

GeCone::Set

GeCone::Set method

GeCone::StartAngle

GeCone::StartAngle property

GeCurve

GeCurve interface

about IGeCurve interface

BoundBlock

ClosestPointTo

ClosestPointToCurve

DistanceTo

EvaluatePoint

GetArea

GetCurvature

GetLength

GetSamplePoints

GetSplitCurves

HasEndPoint

HasStartPoint

IGeCurve members

IntersectWithCurve

IntersectWithSurface

Interval

IsClosed

IsCoplanarWith

IsDegenerate

IsLinear

IsOnInterval

IsPeriodic

IsPlanar

LocalClosestPointTo

LocalClosestPointToCurve

NormalPoint

ParameterAtLength

ParameterOf

Project

Reverse

GeCurve::BoundBlock

GeCurve::BoundBlock method

GeCurve::ClosestPointTo

GeCurve::ClosestPointTo method

GeCurve::ClosestPointToCurve

GeCurve::ClosestPointToCurve method

GeCurve::DistanceTo

GeCurve::DistanceTo method

GeCurve::EvaluatePoint

GeCurve::EvaluatePoint method

GeCurve::GetArea

GeCurve::GetArea method

GeCurve::GetCurvature

GeCurve::GetCurvature method

GeCurve::GetLength

GeCurve::GetLength method

GeCurve::GetSamplePoints

GeCurve::GetSamplePoints method

GeCurve::GetSplitCurves

GeCurve::GetSplitCurves method

GeCurve::HasEndPoint

GeCurve::HasEndPoint method

GeCurve::HasStartPoint

GeCurve::HasStartPoint method

GeCurve::IntersectWithCurve

GeCurve::IntersectWithCurve method

GeCurve::IntersectWithSurface

GeCurve::IntersectWithSurface method

GeCurve::Interval

GeCurve::Interval property

GeCurve::IsClosed

GeCurve::IsClosed method

GeCurve::IsCoplanarWith

GeCurve::IsCoplanarWith method

GeCurve::IsDegenerate

GeCurve::IsDegenerate method

GeCurve::IsLinear

GeCurve::IsLinear method

GeCurve::IsOnInterval

GeCurve::IsOnInterval method

GeCurve::IsPeriodic

GeCurve::IsPeriodic method

GeCurve::IsPlanar

GeCurve::IsPlanar method

GeCurve::LocalClosestPointTo

GeCurve::LocalClosestPointTo method

GeCurve::LocalClosestPointToCurve

GeCurve::LocalClosestPointToCurve method

GeCurve::NormalPoint

GeCurve::NormalPoint method

GeCurve::ParameterAtLength

GeCurve::ParameterAtLength method

GeCurve::ParameterOf

GeCurve::ParameterOf method

GeCurve::Project

GeCurve::Project method

GeCurve::Reverse

GeCurve::Reverse method

GeCurveBoundaries

GeCurveBoundaries coclass

about GeCurveBoundaries coclass

geCurveBoundaries enumeration member

GeCurveBoundaries interface

about IGeCurveBoundaries interface

Add

Application

Count

IGeCurveBoundaries members

Item

Remove

GeCurveBoundaries::Add

GeCurveBoundaries::Add method

GeCurveBoundaries::Application

GeCurveBoundaries::Application property

GeCurveBoundaries::Count

GeCurveBoundaries::Count property

GeCurveBoundaries::Item

GeCurveBoundaries::Item method

GeCurveBoundaries::Remove

GeCurveBoundaries::Remove method

GeCurveBoundary

GeCurveBoundary coclass

about GeCurveBoundary coclass

GeCurveBoundary interface

about IGeCurveBoundary interface

Application

Elements

Geometry2d

Geometry3d

GetBoundary

IGeCurveBoundary members

IsDegenerate

Orientation2d

Orientation3d

SetBoundary

GeCurveBoundary::Application

GeCurveBoundary::Application property

GeCurveBoundary::Elements

GeCurveBoundary::Elements property

GeCurveBoundary::Geometry2d

GeCurveBoundary::Geometry2d property

GeCurveBoundary::Geometry3d

GeCurveBoundary::Geometry3d property

GeCurveBoundary::GetBoundary

GeCurveBoundary::GetBoundary method

GeCurveBoundary::IsDegenerate

GeCurveBoundary::IsDegenerate method

GeCurveBoundary::Orientation2d

GeCurveBoundary::Orientation2d property

GeCurveBoundary::Orientation3d

GeCurveBoundary::Orientation3d property

GeCurveBoundary::SetBoundary

GeCurveBoundary::SetBoundary method

GeCurveCurveIntConfiguration

GeCurveCurveIntConfiguration enumeration

GeCurveCurveIntersection

GeCurveCurveIntersection coclass

about GeCurveCurveIntersection coclass

GeCurveCurveIntersection interface

about IGeCurveCurveIntersection interface

Curve1

Curve2

GetAllIntersections

GetIntersectionConfiguration

GetOverlapRanges

IGeCurveCurveIntersection members

IntersectionPoint

IntersectionPointCount

IntersectionPointTolerance

IntervalRange1

IntervalRange2

IsTangential

IsTransversal

OverlapCount

OverlapDirection

ParameterOnCurve1

ParameterOnCurve2

Set

Tolerance

GeCurveCurveIntersection::Curve1

GeCurveCurveIntersection::Curve1 property

GeCurveCurveIntersection::Curve2

GeCurveCurveIntersection::Curve2 property

GeCurveCurveIntersection::GetAllIntersections

GeCurveCurveIntersection::GetAllIntersections method

GeCurveCurveIntersection::GetIntersectionConfiguration

GeCurveCurveIntersection::GetIntersectionConfiguration method

GeCurveCurveIntersection::GetOverlapRanges

GeCurveCurveIntersection::GetOverlapRanges method

GeCurveCurveIntersection::IntersectionPoint

GeCurveCurveIntersection::IntersectionPoint method

GeCurveCurveIntersection::IntersectionPointCount

GeCurveCurveIntersection::IntersectionPointCount property

GeCurveCurveIntersection::IntersectionPointTolerance

GeCurveCurveIntersection::IntersectionPointTolerance method

GeCurveCurveIntersection::IntervalRange1

GeCurveCurveIntersection::IntervalRange1 property

GeCurveCurveIntersection::IntervalRange2

GeCurveCurveIntersection::IntervalRange2 property

GeCurveCurveIntersection::IsTangential

GeCurveCurveIntersection::IsTangential method

GeCurveCurveIntersection::IsTransversal

GeCurveCurveIntersection::IsTransversal method

GeCurveCurveIntersection::OverlapCount

GeCurveCurveIntersection::OverlapCount property

GeCurveCurveIntersection::OverlapDirection

GeCurveCurveIntersection::OverlapDirection property

GeCurveCurveIntersection::ParameterOnCurve1

GeCurveCurveIntersection::ParameterOnCurve1 method

GeCurveCurveIntersection::ParameterOnCurve2

GeCurveCurveIntersection::ParameterOnCurve2 method

GeCurveCurveIntersection::Set

GeCurveCurveIntersection::Set method

GeCurveCurveIntersection::Tolerance

GeCurveCurveIntersection::Tolerance property

GeCurves

GeCurves coclass

about GeCurves coclass

geCurves enumeration member

GeCurves interface

about IGeCurves interface

Add

Application

Count

IGeCurves members

Item

Remove

GeCurves::Add

GeCurves::Add method

GeCurves::Application

GeCurves::Application property

GeCurves::Count

GeCurves::Count property

GeCurves::Item

GeCurves::Item method

GeCurves::Remove

GeCurves::Remove method

GeCurveSurfaceIntersection

GeCurveSurfaceIntersection coclass

about GeCurveSurfaceIntersection coclass

GeCurveSurfaceIntersection interface

about IGeCurveSurfaceIntersection interface

Curve

GetAllIntersections

GetIntersectionConfiguration

IGeCurveSurfaceIntersection members

IntersectionPoint

IntersectionPointCount

ParameterOnCurve

ParameterOnSurface

Set

Surface

Tolerance

GeCurveSurfaceIntersection::Curve

GeCurveSurfaceIntersection::Curve property

GeCurveSurfaceIntersection::GetAllIntersections

GeCurveSurfaceIntersection::GetAllIntersections method

GeCurveSurfaceIntersection::GetIntersectionConfiguration

GeCurveSurfaceIntersection::GetIntersectionConfiguration method

GeCurveSurfaceIntersection::IntersectionPoint

GeCurveSurfaceIntersection::IntersectionPoint method

GeCurveSurfaceIntersection::IntersectionPointCount

GeCurveSurfaceIntersection::IntersectionPointCount property

GeCurveSurfaceIntersection::ParameterOnCurve

GeCurveSurfaceIntersection::ParameterOnCurve method

GeCurveSurfaceIntersection::ParameterOnSurface

GeCurveSurfaceIntersection::ParameterOnSurface method

GeCurveSurfaceIntersection::Set

GeCurveSurfaceIntersection::Set method

GeCurveSurfaceIntersection::Surface

GeCurveSurfaceIntersection::Surface property

GeCurveSurfaceIntersection::Tolerance

GeCurveSurfaceIntersection::Tolerance property

GeCurveSurfIntConfiguration

GeCurveSurfIntConfiguration enumeration

GeCylinder

GeCylinder coclass

about GeCylinder coclass

GeCylinder interface

about IGeCylinder interface

AxisOfSymmetry

EndAngle

Height

IGeCylinder members

IntersectWith

Origin

Radius

ReferenceVector

Set

StartAngle

GeCylinder::AxisOfSymmetry

GeCylinder::AxisOfSymmetry property

GeCylinder::EndAngle

GeCylinder::EndAngle property

GeCylinder::Height

GeCylinder::Height property

GeCylinder::IntersectWith

GeCylinder::IntersectWith method

GeCylinder::Origin

GeCylinder::Origin property

GeCylinder::Radius

GeCylinder::Radius property

GeCylinder::ReferenceVector

GeCylinder::ReferenceVector property

GeCylinder::Set

GeCylinder::Set method

GeCylinder::StartAngle

GeCylinder::StartAngle property

GeEllipticalArc

GeEllipticalArc coclass

about GeEllipticalArc coclass

GeEllipticalArc interface

about IGeEllipticalArc interface

Center

EndAngle

EndPoint

IGeEllipticalArc members

IntersectWith

IsCircular

IsInside

MajorAxis

MajorRadius

MinorAxis

MinorRadius

Normal

Set

StartAngle

StartPoint

GeEllipticalArc::Center

GeEllipticalArc::Center property

GeEllipticalArc::EndAngle

GeEllipticalArc::EndAngle property

GeEllipticalArc::EndPoint

GeEllipticalArc::EndPoint property

GeEllipticalArc::IntersectWith

GeEllipticalArc::IntersectWith method

GeEllipticalArc::IsCircular

GeEllipticalArc::IsCircular property

GeEllipticalArc::IsInside

GeEllipticalArc::IsInside method

GeEllipticalArc::MajorAxis

GeEllipticalArc::MajorAxis property

GeEllipticalArc::MajorRadius

GeEllipticalArc::MajorRadius property

GeEllipticalArc::MinorAxis

GeEllipticalArc::MinorAxis property

GeEllipticalArc::MinorRadius

GeEllipticalArc::MinorRadius property

GeEllipticalArc::Normal

GeEllipticalArc::Normal property

GeEllipticalArc::Set

GeEllipticalArc::Set method

GeEllipticalArc::StartAngle

GeEllipticalArc::StartAngle property

GeEllipticalArc::StartPoint

GeEllipticalArc::StartPoint property

GeEntities

GeEntities coclass

about GeEntities coclass

geEntities enumeration member

GeEntities interface

about IGeEntities interface

Add

Application

Count

IGeEntities members

Item

Remove

GeEntities::Add

GeEntities::Add method

GeEntities::Application

GeEntities::Application property

GeEntities::Count

GeEntities::Count property

GeEntities::Item

GeEntities::Item method

GeEntities::Remove

GeEntities::Remove method

GeEntity

GeEntity interface

about IGeEntity interface

Application

IGeEntity members

IsEqualTo

IsOn

Mirror

RotateBy

ScaleBy

TransformBy

TranslateBy

GeEntity::Application

GeEntity::Application property

GeEntity::IsEqualTo

GeEntity::IsEqualTo method

GeEntity::IsOn

GeEntity::IsOn method

GeEntity::Mirror

GeEntity::Mirror method

GeEntity::RotateBy

GeEntity::RotateBy method

GeEntity::ScaleBy

GeEntity::ScaleBy method

GeEntity::TransformBy

GeEntity::TransformBy method

GeEntity::TranslateBy

GeEntity::TranslateBy method

geInside enumeration member

GeInterval

GeInterval coclass

about GeInterval coclass

GeInterval interface

about IGeInterval interface

Application

Bounded

BoundedAbove

BoundedBelow

Contains

IGeInterval members

IsContinuousAtUpper

IsDisjoint

IsOverlapAtUpper

IsSingleton

IsUnBounded

Length

Lower

Upper

GeInterval::Application

GeInterval::Application property

GeInterval::Bounded

GeInterval::Bounded property

GeInterval::BoundedAbove

GeInterval::BoundedAbove property

GeInterval::BoundedBelow

GeInterval::BoundedBelow property

GeInterval::Contains

GeInterval::Contains method

GeInterval::IsContinuousAtUpper

GeInterval::IsContinuousAtUpper method

GeInterval::IsDisjoint

GeInterval::IsDisjoint method

GeInterval::IsOverlapAtUpper

GeInterval::IsOverlapAtUpper method

GeInterval::IsSingleton

GeInterval::IsSingleton property

GeInterval::IsUnBounded

GeInterval::IsUnBounded property

GeInterval::Length

GeInterval::Length property

GeInterval::Lower

GeInterval::Lower property

GeInterval::Upper

GeInterval::Upper property

GeKnotVector

GeKnotVector coclass

about GeKnotVector coclass

GeKnotVector interface

about IGeKnotVector interface

AddKnot

AddKnotVector

Application

AsArray

Contains

DistinctKnots

EndParameter

IGeKnotVector members

Insert

InsertKnot

Interval

IsEmpty

IsEqualTo

Item

Item

Length

MultiplicityAt

NumberOfIntervals

RemoveKnotAt

RemoveRange

Reverse

SetRange

Split

StartParameter

Tolerance

GeKnotVector::AddKnot

GeKnotVector::AddKnot method

GeKnotVector::AddKnotVector

GeKnotVector::AddKnotVector method

GeKnotVector::Application

GeKnotVector::Application property

GeKnotVector::AsArray

GeKnotVector::AsArray property

GeKnotVector::Contains

GeKnotVector::Contains method

GeKnotVector::DistinctKnots

GeKnotVector::DistinctKnots property

GeKnotVector::EndParameter

GeKnotVector::EndParameter property

GeKnotVector::Insert

GeKnotVector::Insert method

GeKnotVector::InsertKnot

GeKnotVector::InsertKnot method

GeKnotVector::Interval

GeKnotVector::Interval method

GeKnotVector::IsEmpty

GeKnotVector::IsEmpty property

GeKnotVector::IsEqualTo

GeKnotVector::IsEqualTo method

GeKnotVector::Item

GeKnotVector::Item method

GeKnotVector::Length

GeKnotVector::Length property

GeKnotVector::MultiplicityAt

GeKnotVector::MultiplicityAt method

GeKnotVector::NumberOfIntervals

GeKnotVector::NumberOfIntervals property

GeKnotVector::RemoveKnotAt

GeKnotVector::RemoveKnotAt method

GeKnotVector::RemoveRange

GeKnotVector::RemoveRange method

GeKnotVector::Reverse

GeKnotVector::Reverse method

GeKnotVector::SetRange

GeKnotVector::SetRange method

GeKnotVector::Split

GeKnotVector::Split method

GeKnotVector::StartParameter

GeKnotVector::StartParameter property

GeKnotVector::Tolerance

GeKnotVector::Tolerance property

geLeftLeft enumeration member

geLeftOverlap enumeration member

geLeftRight enumeration member

GeLine

GeLine coclass

about GeLine coclass

GeLine interface

about IGeLine interface

IGeLine members

Set

GeLine::Set

GeLine::Set method

GeLinearEntity

GeLinearEntity interface

about IGeLinearEntity interface

Direction

IGeLinearEntity members

IntersectWith

IsColinearTo

IsOnPlane

IsParallelTo

IsPerpendicularTo

Overlap

PerpendicularPlane

PointOnLine

GeLinearEntity::Direction

GeLinearEntity::Direction property

GeLinearEntity::IntersectWith

GeLinearEntity::IntersectWith method

GeLinearEntity::IsColinearTo

GeLinearEntity::IsColinearTo method

GeLinearEntity::IsOnPlane

GeLinearEntity::IsOnPlane method

GeLinearEntity::IsParallelTo

GeLinearEntity::IsParallelTo method

GeLinearEntity::IsPerpendicularTo

GeLinearEntity::IsPerpendicularTo method

GeLinearEntity::Overlap

GeLinearEntity::Overlap method

GeLinearEntity::PerpendicularPlane

GeLinearEntity::PerpendicularPlane method

GeLinearEntity::PointOnLine

GeLinearEntity::PointOnLine property

GeLineSegment

GeLineSegment coclass

about GeLineSegment coclass

GeLineSegment interface

about IGeLineSegment interface

BaryComb

Bisector

EndPoint

IGeLineSegment members

MidPoint

Set

StartPoint

TangentTangent

TangentTo

GeLineSegment::BaryComb

GeLineSegment::BaryComb method

GeLineSegment::Bisector

GeLineSegment::Bisector property

GeLineSegment::EndPoint

GeLineSegment::EndPoint property

GeLineSegment::MidPoint

GeLineSegment::MidPoint property

GeLineSegment::Set

GeLineSegment::Set method

GeLineSegment::StartPoint

GeLineSegment::StartPoint property

GeLineSegment::TangentTangent

GeLineSegment::TangentTangent method

GeLineSegment::TangentTo

GeLineSegment::TangentTo method

GeMatrix

GeMatrix coclass

about GeMatrix coclass

GeMatrix interface

about IGeMatrix interface

Application

AsArray

Determinant

GetCoordinateSystem

IGeMatrix members

Inverse

Invert

IsEqualTo

IsOrthogonal

IsSingular

IsUniformScaledOrtho

Item

Item

PostMultiply

PreMultiply

Product

Scale

SetToAlignCoordinateSystem

SetToCoordinateSystem

SetToIdentity

SetToMirroring

SetToProduct

SetToProjection

SetToRotation

SetToScaling

SetToTranslation

Translation

Transpose

TransposeIt

GeMatrix::Application

GeMatrix::Application property

GeMatrix::AsArray

GeMatrix::AsArray property

GeMatrix::Determinant

GeMatrix::Determinant property

GeMatrix::GetCoordinateSystem

GeMatrix::GetCoordinateSystem method

GeMatrix::Inverse

GeMatrix::Inverse property

GeMatrix::Invert

GeMatrix::Invert method

GeMatrix::IsEqualTo

GeMatrix::IsEqualTo method

GeMatrix::IsOrthogonal

GeMatrix::IsOrthogonal method

GeMatrix::IsSingular

GeMatrix::IsSingular method

GeMatrix::IsUniformScaledOrtho

GeMatrix::IsUniformScaledOrtho method

GeMatrix::Item

GeMatrix::Item method

GeMatrix::PostMultiply

GeMatrix::PostMultiply method

GeMatrix::PreMultiply

GeMatrix::PreMultiply method

GeMatrix::Product

GeMatrix::Product method

GeMatrix::Scale

GeMatrix::Scale property

GeMatrix::SetToAlignCoordinateSystem

GeMatrix::SetToAlignCoordinateSystem method

GeMatrix::SetToCoordinateSystem

GeMatrix::SetToCoordinateSystem method

GeMatrix::SetToIdentity

GeMatrix::SetToIdentity method

GeMatrix::SetToMirroring

GeMatrix::SetToMirroring method

GeMatrix::SetToProduct

GeMatrix::SetToProduct method

GeMatrix::SetToProjection

GeMatrix::SetToProjection method

GeMatrix::SetToRotation

GeMatrix::SetToRotation method

GeMatrix::SetToScaling

GeMatrix::SetToScaling method

GeMatrix::SetToTranslation

GeMatrix::SetToTranslation method

GeMatrix::Translation

GeMatrix::Translation property

GeMatrix::Transpose

GeMatrix::Transpose property

GeMatrix::TransposeIt

GeMatrix::TransposeIt method

geNoPoles enumeration member

geNotDefined enumeration member

GeNurbCurve

GeNurbCurve coclass

about GeNurbCurve coclass

GeNurbCurve interface

about IGeNurbCurve interface

AddFitPointAt

AddKnot

ContinuityAtKnot

ControlPointAt

ControlPointAt

ControlPointCount

ControlPoints

Degree

ElevateDegree

EndParameter

EndPoint

EvaluatorMode

FitEndTangent

FitPointAt

FitPointAt

FitPointCount

FitPoints

FitStartTangent

FitTolerance

GetDefinitionData

GetFitData

HasFitData

IGeNurbCurve members

IsRational

JoinWith

KnotAt

KnotAt

KnotCount

Knots

MakeClosed

MakePeriodic

MakeRational

Order

ParametersOfC1

ParametersOfG1

PurgeFitData

RemoveFitPointAt

SetDefinitionData

SetFitData

StartParameter

StartPoint

TrimByParameters

WeightAt

WeightAt

WeightCount

Weights

GeNurbCurve::AddFitPointAt

GeNurbCurve::AddFitPointAt method

GeNurbCurve::AddKnot

GeNurbCurve::AddKnot method

GeNurbCurve::ContinuityAtKnot

GeNurbCurve::ContinuityAtKnot method

GeNurbCurve::ControlPointAt

GeNurbCurve::ControlPointAt method

GeNurbCurve::ControlPointCount

GeNurbCurve::ControlPointCount property

GeNurbCurve::ControlPoints

GeNurbCurve::ControlPoints property

GeNurbCurve::Degree

GeNurbCurve::Degree property

GeNurbCurve::ElevateDegree

GeNurbCurve::ElevateDegree method

GeNurbCurve::EndParameter

GeNurbCurve::EndParameter property

GeNurbCurve::EndPoint

GeNurbCurve::EndPoint property

GeNurbCurve::EvaluatorMode

GeNurbCurve::EvaluatorMode property

GeNurbCurve::FitEndTangent

GeNurbCurve::FitEndTangent property

GeNurbCurve::FitPointAt

GeNurbCurve::FitPointAt method

GeNurbCurve::FitPointCount

GeNurbCurve::FitPointCount property

GeNurbCurve::FitPoints

GeNurbCurve::FitPoints property

GeNurbCurve::FitStartTangent

GeNurbCurve::FitStartTangent property

GeNurbCurve::FitTolerance

GeNurbCurve::FitTolerance property

GeNurbCurve::GetDefinitionData

GeNurbCurve::GetDefinitionData method

GeNurbCurve::GetFitData

GeNurbCurve::GetFitData method

GeNurbCurve::HasFitData

GeNurbCurve::HasFitData property

GeNurbCurve::IsRational

GeNurbCurve::IsRational property

GeNurbCurve::JoinWith

GeNurbCurve::JoinWith method

GeNurbCurve::KnotAt

GeNurbCurve::KnotAt method

GeNurbCurve::KnotCount

GeNurbCurve::KnotCount property

GeNurbCurve::Knots

GeNurbCurve::Knots property

GeNurbCurve::MakeClosed

GeNurbCurve::MakeClosed method

GeNurbCurve::MakePeriodic

GeNurbCurve::MakePeriodic method

GeNurbCurve::MakeRational

GeNurbCurve::MakeRational method

GeNurbCurve::Order

GeNurbCurve::Order property

GeNurbCurve::ParametersOfC1

GeNurbCurve::ParametersOfC1 method

GeNurbCurve::ParametersOfG1

GeNurbCurve::ParametersOfG1 method

GeNurbCurve::PurgeFitData

GeNurbCurve::PurgeFitData method

GeNurbCurve::RemoveFitPointAt

GeNurbCurve::RemoveFitPointAt method

GeNurbCurve::SetDefinitionData

GeNurbCurve::SetDefinitionData method

GeNurbCurve::SetFitData

GeNurbCurve::SetFitData method

GeNurbCurve::StartParameter

GeNurbCurve::StartParameter property

GeNurbCurve::StartPoint

GeNurbCurve::StartPoint property

GeNurbCurve::TrimByParameters

GeNurbCurve::TrimByParameters method

GeNurbCurve::WeightAt

GeNurbCurve::WeightAt method

GeNurbCurve::WeightCount

GeNurbCurve::WeightCount property

GeNurbCurve::Weights

GeNurbCurve::Weights property

GeNurbSurface

GeNurbSurface coclass

about GeNurbSurface coclass

GeNurbSurface interface

about IGeNurbSurface interface

ControlPoints

DegreeInU

DegreeInV

GetDefinitionData

IGeNurbSurface members

IsClosedInU

IsClosedInV

IsPeriodicInU

IsPeriodicInV

IsRationalInU

IsRationalInV

SetDefinitionData

SingularityInU

SingularityInV

UControlPointCount

UKnotCount

UKnots

VControlPointCount

VKnotCount

VKnots

Weights

GeNurbSurface::ControlPoints

GeNurbSurface::ControlPoints property

GeNurbSurface::DegreeInU

GeNurbSurface::DegreeInU property

GeNurbSurface::DegreeInV

GeNurbSurface::DegreeInV property

GeNurbSurface::GetDefinitionData

GeNurbSurface::GetDefinitionData method

GeNurbSurface::IsClosedInU

GeNurbSurface::IsClosedInU property

GeNurbSurface::IsClosedInV

GeNurbSurface::IsClosedInV property

GeNurbSurface::IsPeriodicInU

GeNurbSurface::IsPeriodicInU method

GeNurbSurface::IsPeriodicInV

GeNurbSurface::IsPeriodicInV method

GeNurbSurface::IsRationalInU

GeNurbSurface::IsRationalInU property

GeNurbSurface::IsRationalInV

GeNurbSurface::IsRationalInV property

GeNurbSurface::SetDefinitionData

GeNurbSurface::SetDefinitionData method

GeNurbSurface::SingularityInU

GeNurbSurface::SingularityInU property

GeNurbSurface::SingularityInV

GeNurbSurface::SingularityInV property

GeNurbSurface::UControlPointCount

GeNurbSurface::UControlPointCount property

GeNurbSurface::UKnotCount

GeNurbSurface::UKnotCount property

GeNurbSurface::UKnots

GeNurbSurface::UKnots property

GeNurbSurface::VControlPointCount

GeNurbSurface::VControlPointCount property

GeNurbSurface::VKnotCount

GeNurbSurface::VKnotCount property

GeNurbSurface::VKnots

GeNurbSurface::VKnots property

GeNurbSurface::Weights

GeNurbSurface::Weights property

GeNurbSurfaceProperties

GeNurbSurfaceProperties enumeration

GeOffsetCurve

GeOffsetCurve coclass

about GeOffsetCurve coclass

GeOffsetCurve interface

about IGeOffsetCurve interface

BaseCurve

IGeOffsetCurve members

Normal

OffsetDistance

ParameterDirection

Transformation

GeOffsetCurve::BaseCurve

GeOffsetCurve::BaseCurve property

GeOffsetCurve::Normal

GeOffsetCurve::Normal property

GeOffsetCurve::OffsetDistance

GeOffsetCurve::OffsetDistance property

GeOffsetCurve::ParameterDirection

GeOffsetCurve::ParameterDirection property

GeOffsetCurve::Transformation

GeOffsetCurve::Transformation property

GeOffsetSurface

GeOffsetSurface coclass

about GeOffsetSurface coclass

GeOffsetSurface interface

about IGeOffsetSurface interface

BaseSurface

ConvertedSurface

IGeOffsetSurface members

OffsetDistance

GeOffsetSurface::BaseSurface

GeOffsetSurface::BaseSurface property

GeOffsetSurface::ConvertedSurface

GeOffsetSurface::ConvertedSurface method

GeOffsetSurface::OffsetDistance

GeOffsetSurface::OffsetDistance property

Geometry

IMcadGeometry interface

Geometry2d

IGeCurveBoundary interface

Geometry3d

IGeCurveBoundary interface

GeomPathName

IMcadFolder interface

geOpen enumeration member

geOutside enumeration member

geOverlapEnd enumeration member

geOverlapLeft enumeration member

geOverlapOverlap enumeration member

geOverlapRight enumeration member

geOverlapStart enumeration member

gePeriodic enumeration member

GePlane

GePlane coclass

about GePlane coclass

GePlane interface

about IGePlane interface

CoordinateSystem

GetCoefficients

IGePlane members

IntersectWith

IsCoplanarWith

IsParallelTo

IsPerpendicularTo

Normal

Origin

Set

SignedDistanceTo

GePlane::CoordinateSystem

GePlane::CoordinateSystem method

GePlane::GetCoefficients

GePlane::GetCoefficients method

GePlane::IntersectWith

GePlane::IntersectWith method

GePlane::IsCoplanarWith

GePlane::IsCoplanarWith method

GePlane::IsParallelTo

GePlane::IsParallelTo method

GePlane::IsPerpendicularTo

GePlane::IsPerpendicularTo method

GePlane::Normal

GePlane::Normal property

GePlane::Origin

GePlane::Origin property

GePlane::Set

GePlane::Set method

GePlane::SignedDistanceTo

GePlane::SignedDistanceTo method

GePoint

GePoint coclass

about GePoint coclass

GePoint interface

about IGePoint interface

AsArray

AsVector

DistanceTo

Get

IGePoint members

Item

Item

ProjectToPlane

Set

Sum

X

Y

Z

GePoint::AsArray

GePoint::AsArray property

GePoint::AsVector

GePoint::AsVector method

GePoint::DistanceTo

GePoint::DistanceTo method

GePoint::Get

GePoint::Get method

GePoint::Item

GePoint::Item method

GePoint::ProjectToPlane

GePoint::ProjectToPlane method

GePoint::Set

GePoint::Set method

GePoint::Sum

GePoint::Sum method

GePoint::X

GePoint::X property

GePoint::Y

GePoint::Y property

GePoint::Z

GePoint::Z property

gePointLeft enumeration member

gePointRight enumeration member

GePoints

GePoints coclass

about GePoints coclass

gePoints enumeration member

GePoints interface

about IGePoints interface

Add

Application

AsArray

AsArray2d

Count

IGePoints members

Item

Remove

GePoints::Add

GePoints::Add method

GePoints::Application

GePoints::Application property

GePoints::AsArray

GePoints::AsArray property

GePoints::AsArray2d

GePoints::AsArray2d property

GePoints::Count

GePoints::Count property

GePoints::Item

GePoints::Item method

GePoints::Remove

GePoints::Remove method

gePoleAtBoth enumeration member

gePoleAtMax enumeration member

gePoleAtMin enumeration member

geRational enumeration member

GeRay

GeRay coclass

about GeRay coclass

GeRay interface

about IGeRay interface

IGeRay members

Set

GeRay::Set

GeRay::Set method

geRightLeft enumeration member

geRightOverlap enumeration member

geRightRight enumeration member

GeSphere

GeSphere coclass

about GeSphere coclass

GeSphere interface

about IGeSphere interface

EndLatitude

EndLongitude

IGeSphere members

IntersectWith

IsClosedInU

NorthAxis

NorthPole

Origin

Radius

ReferenceAxis

Set

SouthPole

StartLatitude

StartLongitude

GeSphere::EndLatitude

GeSphere::EndLatitude property

GeSphere::EndLongitude

GeSphere::EndLongitude property

GeSphere::IntersectWith

GeSphere::IntersectWith method

GeSphere::IsClosedInU

GeSphere::IsClosedInU method

GeSphere::NorthAxis

GeSphere::NorthAxis property

GeSphere::NorthPole

GeSphere::NorthPole property

GeSphere::Origin

GeSphere::Origin property

GeSphere::Radius

GeSphere::Radius property

GeSphere::ReferenceAxis

GeSphere::ReferenceAxis property

GeSphere::Set

GeSphere::Set method

GeSphere::SouthPole

GeSphere::SouthPole property

GeSphere::StartLatitude

GeSphere::StartLatitude property

GeSphere::StartLongitude

GeSphere::StartLongitude property

geSSICoincident enumeration member

geSSIInside enumeration member

geSSIOutside enumeration member

geSSIUnknown enumeration member

GeSurface

GeSurface interface

about IGeSurface interface

ClosestPointTo

DistanceTo

EvaluatePoint

IGeSurface members

IntersectWithSurface

NormalFlipped

ParameterOf

UParameterEnvelope

VParameterEnvelope

GeSurface::ClosestPointTo

GeSurface::ClosestPointTo method

GeSurface::DistanceTo

GeSurface::DistanceTo method

GeSurface::EvaluatePoint

GeSurface::EvaluatePoint method

GeSurface::IntersectWithSurface

GeSurface::IntersectWithSurface method

GeSurface::NormalFlipped

GeSurface::NormalFlipped property

GeSurface::ParameterOf

GeSurface::ParameterOf method

GeSurface::UParameterEnvelope

GeSurface::UParameterEnvelope property

GeSurface::VParameterEnvelope

GeSurface::VParameterEnvelope property

GeSurfaces

GeSurfaces coclass

about GeSurfaces coclass

geSurfaces enumeration member

GeSurfaces interface

about IGeSurfaces interface

Add

Application

Count

IGeSurfaces members

Item

Remove

GeSurfaces::Add

GeSurfaces::Add method

GeSurfaces::Application

GeSurfaces::Application property

GeSurfaces::Count

GeSurfaces::Count property

GeSurfaces::Item

GeSurfaces::Item method

GeSurfaces::Remove

GeSurfaces::Remove method

GeSurfaceSurfaceIntersection

GeSurfaceSurfaceIntersection coclass

about GeSurfaceSurfaceIntersection coclass

GeSurfaceSurfaceIntersection interface

about IGeSurfaceSurfaceIntersection interface

GetIntersectionCofiguration

IGeSurfaceSurfaceIntersection members

IntersectionCount

IntersectionCurve

IntersectionDimension

IntersectionPoint

ParameterCurveOnSurface1

ParameterCurveOnSurface2

ParameterOnSurface1

ParameterOnSurface2

Set

Surface1

Surface2

Tolerance

GeSurfaceSurfaceIntersection::GetIntersectionCofiguration

GeSurfaceSurfaceIntersection::GetIntersectionCofiguration method

GeSurfaceSurfaceIntersection::IntersectionCount

GeSurfaceSurfaceIntersection::IntersectionCount property

GeSurfaceSurfaceIntersection::IntersectionCurve

GeSurfaceSurfaceIntersection::IntersectionCurve method

GeSurfaceSurfaceIntersection::IntersectionDimension

GeSurfaceSurfaceIntersection::IntersectionDimension method

GeSurfaceSurfaceIntersection::IntersectionPoint

GeSurfaceSurfaceIntersection::IntersectionPoint method

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface1

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 method

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface2

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 method

GeSurfaceSurfaceIntersection::ParameterOnSurface1

GeSurfaceSurfaceIntersection::ParameterOnSurface1 method

GeSurfaceSurfaceIntersection::ParameterOnSurface2

GeSurfaceSurfaceIntersection::ParameterOnSurface2 method

GeSurfaceSurfaceIntersection::Set

GeSurfaceSurfaceIntersection::Set method

GeSurfaceSurfaceIntersection::Surface1

GeSurfaceSurfaceIntersection::Surface1 property

GeSurfaceSurfaceIntersection::Surface2

GeSurfaceSurfaceIntersection::Surface2 property

GeSurfaceSurfaceIntersection::Tolerance

GeSurfaceSurfaceIntersection::Tolerance property

GeSurfSurfIntConfiguration

GeSurfSurfIntConfiguration enumeration

GeSurfSurfIntType

GeSurfSurfIntType enumeration

Get

IGePoint interface

IGeVector interface

GetAllAttribs

IMcadFormulaEvaluator interface

GetAllAttribsData

IMcadFormulaEvaluator interface

GetAllAttributes

IMcadUtility interface

GetAllAttribValues

IMcadFormulaEvaluator interface

GetAllBOMTables

IMcadBOMMgr interface

GetAllIntersections

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

GetAllLayerObjs

IMcadLayerObjectMgr interface

GetAllLayers

IMcadLayerObjectMgr interface

GetAllPartReferences

IMcadBOMMgr4 interface

GetAllTemplates

IMcadNoteStandard interface

geTangent enumeration member

geTangentInside enumeration member

geTangentOutside enumeration member

GetArea

IGeCurve interface

GetAttachedViewportIds

IMcadScaleArea interface

GetAttachedViewportIds32

IMcadScaleArea interface

GetAttribute

IMcadBOMItem2 interface

GetAttributeClassFields

IAcadmApplication interface

GetAttributeFromID

IMcadUtility interface

GetAttributeFromID32

IMcadUtility interface

GetAttributes

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

GetBomOverride

IMcadBOMItem4 interface

IMcadPartReference3 interface

GetBOMTable

IMcadBOMMgr interface

GetBOMTableByCompDefHandle

IMcadBOMMgr3 interface

GetBOMTableByCompDefId

IMcadBOMMgr2 interface

GetBOMTableByCompDefId32

IMcadBOMMgr2 interface

GetBOMTableByName

IMcadBOMMgr2 interface

GetBorderBOMTable

IMcadBOMMgr2 interface

GetBoundary

IGeCurveBoundary interface

GetByStandard

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

GetCalculatedQuantity

IMcadBOMItem2 interface

GetCoefficients

IGePlane interface

GetColumn

IMcadBOMStandard interface

GetComplexStdPartsForMigr

IMcad2DStructureMgr interface

GetComplexStdPartViewsForMigr

IMcad2DStructureMgr interface

GetComponentDefinitions

IMcad2DStructureMgr interface

GetComponentInDefinition

IMcadComponent interface

GetComponentViewDefinitions

IMcad2DStructureMgr interface

GetCoordinateSystem

IGeMatrix interface

GetCurrentSymbolStandard

IMcadStandard interface

GetCurvature

IGeCurve interface

GetData

IMcadFormulaEvaluator interface

GetDefinitionData

IGeNurbCurve interface

IGeNurbSurface interface

GetDimensionType

IMcadTaperStandard2 interface

GetDrawingType

IMcadUtility3 interface

GetEvaluatedPartData

IMcadBOMMgr2 interface

GetFeatureTypes

IMcadNoteStandard interface

GetFieldIndex

IMcadAttribute interface

GetFitData

IGeNurbCurve interface

GetFolderDefinitions

IMcad2DStructureMgr interface

GetFolderPowerObjectsForMigr

IMcad2DStructureMgr interface

GetFormulaEvaluator

IAcadmApplication interface

GetGeometryFromPick

IMcadUtility interface

GetHidesSuppressState

IMcadFolderDefinition interface

GetIdsFromObject

IMcadUtility interface

GetIdsFromObject32

IMcadUtility interface

GetInstances

IMcadComponentDefinition interface

GetIntersectionCofiguration

IGeSurfaceSurfaceIntersection interface

GetIntersectionConfiguration

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

GetItemDefinition

IMcadBOMItem2 interface

GetItemDefinition32

IMcadBOMItem2 interface

GetItemPartDefinition

IMcadBOMItem3 interface

GetItemPartDefinition32

IMcadBOMItem3 interface

GetLayerGroupEntities

IMcadLayerGroupMgr interface

GetLayerGroupEntities32

IMcadLayerGroupMgr interface

GetLayerGroupNames

IMcadLayerGroupMgr interface

GetLayerObjProperty

IMcadLayerObjectMgr interface

GetLayerProperty

IMcadLayerObjectMgr interface

GetLayersFromGroup

IMcadLayerGroupMgr interface

GetLeader

IMcadSymbol interface

GetLeaderAttachment

IMcadSymbol interface

GetLength

IGeCurve interface

GetMoveObjectsIDs

IMcadTitleBorderContext interface

GetMoveObjectsIDs32

IMcadTitleBorderContext interface

GetMoveObjectsToPoint

IMcadTitleBorderContext interface

GetNextAnnotationViewDefinitionName

IMcad2DStructureMgr interface

GetNextComponentDefinitionName

IMcad2DStructureMgr interface

GetNextComponentViewDefinitionName

IMcadComponentDefinition interface

GetNextFolderDefinitionName

IMcad2DStructureMgr interface

GetObjectFromID

IMcadUtility interface

GetObjectFromID32

IMcadUtility interface

GetObjectFromPick

IMcadUtility interface

GeTolerance

GeTolerance coclass

about GeTolerance coclass

GeTolerance interface

about IGeTolerance interface

Application

EqualPoint

EqualVector

IGeTolerance members

GeTolerance::Application

GeTolerance::Application property

GeTolerance::EqualPoint

GeTolerance::EqualPoint property

GeTolerance::EqualVector

GeTolerance::EqualVector property

GeTorus

GeTorus coclass

about GeTorus coclass

GeTorus interface

about IGeTorus interface

AxisOfSymmetry

EndAngleInU

EndAngleInV

IGeTorus members

IntersectWith

IsClosedInU

IsClosedInV

MajorRadius

MinorRadius

Origin

ReferenceAxis

Set

StartAngleInU

StartAngleInV

GeTorus::AxisOfSymmetry

GeTorus::AxisOfSymmetry property

GeTorus::EndAngleInU

GeTorus::EndAngleInU property

GeTorus::EndAngleInV

GeTorus::EndAngleInV property

GeTorus::IntersectWith

GeTorus::IntersectWith method

GeTorus::IsClosedInU

GeTorus::IsClosedInU method

GeTorus::IsClosedInV

GeTorus::IsClosedInV method

GeTorus::MajorRadius

GeTorus::MajorRadius property

GeTorus::MinorRadius

GeTorus::MinorRadius property

GeTorus::Origin

GeTorus::Origin property

GeTorus::ReferenceAxis

GeTorus::ReferenceAxis property

GeTorus::Set

GeTorus::Set method

GeTorus::StartAngleInU

GeTorus::StartAngleInU property

GeTorus::StartAngleInV

GeTorus::StartAngleInV property

GetOverlapRanges

IGeCurveCurveIntersection interface

GetPartAttribute

IMcadBOMMgr2 interface

GetPartBalloons

IMcadBOMItem2 interface

GetPartData

IMcadBOMMgr interface

GetPartReference

IMcadTitleBorderContext interface

GetPartReference32

IMcadTitleBorderContext interface

GetPreDefinedList

IMcadColumnDefinition3 interface

GetProperties

IMcadBOM2 interface

GetProperties32

IMcadBOM2 interface

geTransverse enumeration member

GetReferenceLockMode

IMcad2DStructureMgr4 interface

GetReferences

IMcadBOMItem interface

GetReferences32

IMcadBOMItem interface

GetRevisionListFromRef

IMcadRevisionMgr interface

GetSamplePoints

IGeCurve interface

GetSelection

IMcad2DStructureMgr interface

GetShaftsForMigr

IMcad2DStructureMgr interface

GetSheetBOMTable

IMcadBOMMgr2 interface

GetSingleStdPartComponentsForMigr

IMcad2DStructureMgr interface

GetSingleStdPartViewsForMigr

IMcad2DStructureMgr interface

GetSplitCurves

IGeCurve interface

GetStandard

IMcadStandardMgr interface

GetStructuredChildItems

IMcadBOM3 interface

GetStructuredParentItem

IMcadBOM3 interface

GetStructureFromEntity

IMcad2DStructureMgr interface

GetStructureMode

IMcad2DStructureMgr4 interface

GetSurfIndLeader

IMcadDatumIdentifier3 interface

IMcadFeatureControlFrame4 interface

GetSymbolImplementation

IMcadFCFStandard interface

GetTemplateGroup

IMcadNoteStandard interface

GetTemplateValue

IMcadNoteStandard interface

GetTitleBorderFromRef

IMcadTitleBorderMgr interface

GetUOMName

IMcadBOMStandard2 interface

GetVersionNumber

IAcadmApplicationVersion interface

IMcadDocumentVersion interface

geUnknown enumeration member

geUnknownType enumeration member

GeVector

GeVector coclass

about GeVector coclass

GeVector interface

about IGeVector interface

AngleTo

Application

AsArray

CrossProduct

DotProduct

Get

IGeVector members

IsCodirectionalTo

IsEqualTo

IsParallelTo

IsPerpendicularTo

IsUnitLength

IsZeroLength

Item

Item

LargestElement

Length

Mirror

MultiplyBy

Negate

Negative

Normal

Normalize

PerpendicularVector

Product

Project

RotateBy

ScaleBy

Set

SetToProduct

SetToSum

Sum

TransformBy

X

Y

Z

GeVector::AngleTo

GeVector::AngleTo method

GeVector::Application

GeVector::Application property

GeVector::AsArray

GeVector::AsArray property

GeVector::CrossProduct

GeVector::CrossProduct method

GeVector::DotProduct

GeVector::DotProduct method

GeVector::Get

GeVector::Get method

GeVector::IsCodirectionalTo

GeVector::IsCodirectionalTo method

GeVector::IsEqualTo

GeVector::IsEqualTo method

GeVector::IsParallelTo

GeVector::IsParallelTo method

GeVector::IsPerpendicularTo

GeVector::IsPerpendicularTo method

GeVector::IsUnitLength

GeVector::IsUnitLength method

GeVector::IsZeroLength

GeVector::IsZeroLength method

GeVector::Item

GeVector::Item method

GeVector::LargestElement

GeVector::LargestElement property

GeVector::Length

GeVector::Length property

GeVector::Mirror

GeVector::Mirror method

GeVector::MultiplyBy

GeVector::MultiplyBy method

GeVector::Negate

GeVector::Negate method

GeVector::Negative

GeVector::Negative property

GeVector::Normal

GeVector::Normal property

GeVector::Normalize

GeVector::Normalize method

GeVector::PerpendicularVector

GeVector::PerpendicularVector method

GeVector::Product

GeVector::Product method

GeVector::Project

GeVector::Project method

GeVector::RotateBy

GeVector::RotateBy method

GeVector::ScaleBy

GeVector::ScaleBy method

GeVector::Set

GeVector::Set method

GeVector::SetToProduct

GeVector::SetToProduct method

GeVector::SetToSum

GeVector::SetToSum method

GeVector::Sum

GeVector::Sum method

GeVector::TransformBy

GeVector::TransformBy method

GeVector::X

GeVector::X property

GeVector::Y

GeVector::Y property

GeVector::Z

GeVector::Z property

GeVectors

GeVectors coclass

about GeVectors coclass

geVectors enumeration member

GeVectors interface

about IGeVectors interface

Add

Application

Count

IGeVectors members

Item

Remove

GeVectors::Add

GeVectors::Add method

GeVectors::Application

GeVectors::Application property

GeVectors::Count

GeVectors::Count property

GeVectors::Item

GeVectors::Item method

GeVectors::Remove

GeVectors::Remove method

GlobalToLocal

IGeCompositeCurve interface

GripFrameEnabled

IMcadPartList2 interface

IMcadPartListStandard3 interface

H

HalfAngle

IGeCone interface

HasAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

HasChanged

IMcadGeometry interface

HasComponentDefinition

IMcad2DStructureMgr interface

HasComponentViewDefinition

IMcadComponentDefinition interface

HasEndPoint

IGeCurve interface

HasEqualTypeWithView

IMcad2dComponentDescriptor interface

HasEqualTypeWithViewGroup

IMcad2dComplexStdPartCompGroupDescriptor interface

hasExternalDef

IMcadComponent interface

HasExternalDef

IMcadFolder interface

HasFitData

IGeNurbCurve interface

HasFolderDefinition

IMcad2DStructureMgr interface

HasGhostViews

IMcadComponent interface

HasLeader

IMcadTaper interface

HasOverrideProperties

IMcadComponent interface

IMcadFolder interface

HasStartPoint

IGeCurve interface

HatchAngle

IMcadDatumStandard interface

HatchDistance

IMcadDatumStandard interface

HeadingGap

IMcadPartListStandard interface

HeadingHeight

IMcadPartListStandard interface

HeadingTextColor

IMcadPartListStandard interface

HeadingTextControl

IMcadPartList2 interface

IMcadPartListStandard3 interface

HeadingTextHeight

IMcadPartListStandard interface

HeadingTextMarginBottom

IMcadPartListStandard3 interface

HeadingTextMarginLeft

IMcadPartListStandard3 interface

HeadingTextMarginRight

IMcadPartListStandard3 interface

HeadingTextMarginTop

IMcadPartListStandard3 interface

HeadingTextStyle

IMcadPartListStandard3 interface

HeadingTextTrueColor

IMcadPartListStandard2 interface

Height

IGeCone interface

IGeCylinder interface

IMcadPartList interface

HeightAt

IGeCone interface

HiddenLeaderLineType

IMcadDatumStandard interface

HiddenLeaderLineTypeName

IMcadDatumStandard interface

HiddenLinesInvisible

IMcadComplexHideSituation interface

IMcadHideSituation interface

Hide

IMcadLayerObjectCfg interface

HideAppropriateObjectsOnly

IMcadComplexHideSituation interface

IMcadHideSituation interface

HideSituations

IMcadComplexHideSituation interface

IMcadFolderDefinition interface

Highlight

IMcad2DStructureMgr interface

IMcadObject interface

HighlightSubWelding

IMcadWelding interface

Holders

IMcadAttribute interface

I

IdentificationLine

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

IdentificationLineAllowed

IMcadWeldingStandard interface

IdentificationLineGap

IMcadWeldingStandard interface

IdentificationLinetype

IMcadWeldingStandard interface

IdentificationLinetypeName

IMcadWeldingStandard interface

IdentifierExcludeCharacters

IMcadSectionLineStandard2 interface

IdentifierOffset

IMcadSectionLineStandard2 interface

IdentifierOutsideBoundary

IMcadDetailSymbolStandard2 interface

IdentifierPosition

IMcadSectionLineStandard2 interface

IdentifierStandard

IMcadStandard interface

IgnoreBgExclude

IMcadHideSituation interface

IgnoreFgExclude

IMcadHideSituation interface

IgnoreUpperBgExclude

IMcadHideSituation interface

imCSV enumeration member

imDB5 enumeration member

imDBIII enumeration member

imDBIV enumeration member

imEXCEL95 enumeration member

imEXCEL97 enumeration member

imFOX25 enumeration member

imFOX26 enumeration member

imimFOXVIS enumeration member

imMDB enumeration member

ImportBOM

IMcadBOMMgr interface

ImportBOM2

IMcadBOMMgr2 interface

ImportLayerObj

IMcadLayerObjectMgr interface

ImportPartList

IMcadBOMMgr2 interface

imTXT enumeration member

in enumeration member

InActive

IMcadTitle interface

Index

IMcadColumnDefinition interface

IndexTotalValue

IMcadWelding interface

IMcadWelding interface

IndexValue

IMcadWelding interface

IMcadWelding interface

InitFromHide

IMcadComplexHideSituation interface

Insert

IGeKnotVector interface

InsertInvertPart

IMcadTitleBorderStandard2 interface

InsertKnot

IGeKnotVector interface

InsertLeaderNode

IMcadSymbol interface

InsertProcess

IMcadWelding2 interface

Inspect

IMcadTaper interface

InstanceCount

IMcadFolderDefinition interface

Instances

IMcadFolderDefinition interface

InstancesDefinition

IMcadFolderDefinition interface

IntersectionCount

IGeSurfaceSurfaceIntersection interface

IntersectionCurve

IGeSurfaceSurfaceIntersection interface

IntersectionDimension

IGeSurfaceSurfaceIntersection interface

IntersectionPoint

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeSurfaceSurfaceIntersection interface

IntersectionPointCount

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IntersectionPointTolerance

IGeCurveCurveIntersection interface

IntersectWith

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

IGeLinearEntity interface

IGePlane interface

IGeSphere interface

IGeTorus interface

IntersectWithCurve

IGeCurve interface

IntersectWithSurface

IGeCurve interface

IGeSurface interface

Interval

IGeApplication interface

IGeCurve interface

IGeKnotVector interface

IntervalRange1

IGeCurveCurveIntersection interface

IntervalRange2

IGeCurveCurveIntersection interface

Introduction

Inverse

IGeMatrix interface

InverseForeground

IMcadHideSituation interface

Invert

IGeMatrix interface

InvertPartBorderHeight

IMcadTitleBorderStandard2 interface

InvertPartBorderWidth

IMcadTitleBorderStandard2 interface

InvertPartTextHeight

IMcadTitleBorderStandard2 interface

Invisible

IMcadLayerCfg interface

is2D

IMcadComponent interface

IMcadComponentDefinition interface

is2DAssembly

IMcadComponentDefinition interface

Is2DStructureEnabled

IMcad2DStructureMgr interface

IsAllAround

IMcadEdgeLibraryObject interface

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsAnnotation

IMcadFolderDefinition interface

IsAssociativeDetail

IMcadDetailSymbol interface

IsAttached

IMcadSymbol interface

IsAttachToFCF

IMcadDatumIdentifier4 interface

IMcadSurfaceTexture5 interface

IsAuxiliaryArrowUsed

IMcadBalloonStandard interface

IsBorder

IMcadBOM3 interface

IsBox

IGeBoundBlock interface

IsCircular

IGeEllipticalArc interface

IsClosed

IGeCone interface

IGeCurve interface

IsClosedInU

IGeNurbSurface interface

IGeSphere interface

IGeTorus interface

IsClosedInV

IGeNurbSurface interface

IGeTorus interface

IsCodirectionalTo

IGeVector interface

IsColinearTo

IGeLinearEntity interface

IsComplexHideLevel

IMcadHideSituation interface

IsContinuousAtUpper

IGeInterval interface

IsCoplanarWith

IGeCurve interface

IGePlane interface

IsCustomBlockUsed

IMcadBalloon interface

IMcadBalloonStandard interface

IMcadPartList interface

IMcadPartListStandard interface

IsDatumIDSupported

IMcadIdentifierStandard interface

isDefault

IMcadSymbolLibraryObject interface

IsDefinedDirection

IMcadEdgeLibraryObject interface

IsDegenerate

IGeCurve interface

IGeCurveBoundary interface

IsDetail

IMcadFolderDefinition interface

IsDisjoint

IGeBoundBlock interface

IGeInterval interface

IsEditable

IMcadFormulaEvaluator interface

IsEmpty

IGeKnotVector interface

IsEntityAllowed

IMcad2DStructureMgr interface

IsEqualTo

IGeEntity interface

IGeKnotVector interface

IGeMatrix interface

IGeVector interface

IMcadObject interface

IsExpandable

IMcadBOMItem interface

IsExternal

IMcadComponentDefinition interface

IMcadFolderDefinition interface

isFeature

IMcadComponentDefinition interface

IMcadComponentView interface

IsFeature

IMcadComponentViewDefinition interface

IsFeatureIDSupported

IMcadIdentifierStandard interface

IsForceTail

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsFreeEntity

IMcad2DStructureMgr interface

IsGhostView

IMcadComponentView interface

IsHeadingEnabled

IMcadPartList interface

IMcadPartListStandard interface

IsInActiveTarget

IMcad2DStructureMgr interface

IsInside

IGeCircularArc interface

IGeEllipticalArc interface

IsInstance

IMcadFolder interface

isItemExist

IMcadSymbolLibrary interface

IsLastLevel

IMcadHideSituation interface

IsLeaf

IMcadFolder interface

IsLeafNode

IMcadComponentDefinition interface

IsLeftOriented

IMcadNote interface

IsLinear

IGeCurve interface

IsLocked

IMcadFolder interface

IMcadFolderDefinition interface

IsMajority

IMcadEdgeLibraryObject interface

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsMetric

IMcadStandard interface

IsMigrated

IMcadHideSituation interface

IsModifiedStandardPartHide

IMcadComplexHideSituation interface

IMcadHideSituation interface

IsOn

IGeEntity interface

IMcadPartListFilter interface

IsOnInterval

IGeCurve interface

IsOnPlane

IGeLinearEntity interface

IsOrthogonal

IGeMatrix interface

IsOverlapAtUpper

IGeInterval interface

IsParallelTo

IGeLinearEntity interface

IGePlane interface

IGeVector interface

IsPeriodic

IGeCurve interface

IsPeriodicInU

IGeNurbSurface interface

IsPeriodicInV

IGeNurbSurface interface

IsPerpendicularTo

IGeLinearEntity interface

IGePlane interface

IGeVector interface

IsPlanar

IGeCurve interface

IsPreDefinedList

IMcadColumnDefinition3 interface

IsRational

IGeNurbCurve interface

IsRationalInU

IGeNurbSurface interface

IsRationalInV

IGeNurbSurface interface

IsRequirementSupported

IMcadSurfaceTextureStandard2 interface

IsRoot

IMcadComponentDefinition interface

IMcadFolderDefinition interface

isShaft

IMcadComponentDefinition interface

IsSingleton

IGeInterval interface

IsSingular

IGeMatrix interface

isStandardPart

IMcadComponentDefinition interface

IsStandardPartHide

IMcadComplexHideSituation interface

IMcadHideSituation interface

IsStructureBlock

IMcad2DStructureMgr interface

IsSubentityOf

IMcadFolder interface

IsTangential

IGeCurveCurveIntersection interface

IsTitleEnabled

IMcadPartList interface

IMcadPartListStandard interface

IsTransversal

IGeCurveCurveIntersection interface

IsUnBounded

IGeInterval interface

IsUniformScaledOrtho

IGeMatrix interface

IsUnitLength

IGeVector interface

IsVisible

IMcadBOM3 interface

IMcadColumnDefinition2 interface

IsZeroLength

IGeVector interface

Item

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGeKnotVector interface

IGeKnotVector interface

IGeMatrix interface

IGeMatrix interface

IGePoint interface

IGePoint interface

IGePoints interface

IGeSurfaces interface

IGeVector interface

IGeVector interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadRevisionLists interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

ItemList

IMcadPartList interface

ItemNumber

IMcadBOMItem interface

Items

IMcadBOM interface

J

JointStandard

IMcadStandard4 interface

JoinWith

IGeNurbCurve interface

K

Key

IMcadLayerCfg interface

KnotAt

IGeNurbCurve interface

IGeNurbCurve interface

KnotCount

IGeNurbCurve interface

Knots

IGeNurbCurve interface

KnotVector

IGeApplication interface

L

l enumeration member

LabelAbove

IMcadDetailSymbolLabel interface

IMcadDetailSymbolStandard interface

IMcadSectionLineStandard interface

LabelEntity

IMcadDetailSymbol interface

LabelEntityOffset

IMcadDetailSymbol interface

LabelName

IMcadDetailSymbol interface

IMcadSectionLine interface

LabelNamesCount

IMcadSectionLine interface

LabelOffset

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelPattern

IMcadAnnotationViewLabel interface

IMcadAnnotationViewStandard interface

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

IMcadSectionLine interface

IMcadSectionLineStandard interface

LabelPatternVariables

IMcadAnnotationViewStandard interface

LabelPosition

IMcadAnnotationViewStandard interface

LabelText

IMcadAnnotationViewLabel interface

IMcadDetailSymbol interface

IMcadDetailSymbolLabel interface

IMcadSectionLine interface

LabelTextColor

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelTextHeight

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelTextStyle

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

Landing

IMcadNote interface

IMcadNoteStandard interface

LargestElement

IGeVector interface

LayDirection

IMcadSurfaceTexture interface

LayDirectionValue

IMcadSurfaceTexture interface

LayerGroupMgr

IMcadDocument interface

LayerName

IMcadLayerObjectCfg interface

LayerObjectMgr

IMcadDocument interface

LayerObjKey

IMcadLayerObjectCfg interface

lb enumeration member

LeaderArrowType

IMcadSymbol interface

IMcadSymbol interface

LeaderAttachPoint

IMcadNote interface

IMcadNoteStandard interface

LeaderColor

IMcadStandard interface

IMcadSymbol interface

IMcadSymbol interface

LeaderCount

IMcadSymbol interface

LeaderLanding

IMcadSymbol interface

IMcadSymbol interface

LeaderLineType

IMcadSymbol interface

IMcadSymbol interface

LeaderLinetypeHidden

IMcadDatumTarget interface

LeaderTrueColor

IMcadStandard2 interface

IMcadSymbolStandard2 interface

Length

IGeInterval interface

IGeKnotVector interface

IGeVector interface

LengthScalingFactor

IMcadScaleArea interface

LengthValue

IMcadWelding interface

IMcadWelding interface

LevelCount

IMcadComplexHideSituation interface

LevelIndex

IMcadHideSituation interface

Line

IGeApplication interface

LineColor

IMcadSectionLineStandard interface

LineEndPoint

IMcadDatumTarget interface

LineFactor

IMcadDatumTarget interface

LineMidPoint

IMcadDatumTarget interface

LineSegment

IGeApplication interface

LineTrueColor

IMcadSectionLineStandard interface

LineType

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineTypeId

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineTypeId32

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

LineWeight

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

IMcadSectionLineStandard interface

loadItem

IMcadSymbolLibrary interface

loadItemToSubWelding

IMcadWeldingLibrary interface

LocalClosestPointTo

IGeCurve interface

LocalClosestPointToCurve

IGeCurve interface

Localize

IMcadFolderDefinition interface

Localize2DS

IMcadComponentDefinition interface

LocalToGlobal

IGeCompositeCurve interface

LockType

IMcadFolderDefinition interface

LookupLevelName

IMcadComplexHideSituation interface

LookupViewName

IMcadFolderDefinition interface

Lower

IGeInterval interface

lqd_oz enumeration member

M

m enumeration member

MajorAxis

IGeEllipticalArc interface

Majority

IMcadEdge interface

MajorityAllowed

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

MajorRadius

IGeEllipticalArc interface

IGeTorus interface

MakeClosed

IGeNurbCurve interface

MakePeriodic

IGeNurbCurve interface

MakePersistent

IMcadObject interface

MakeRational

IGeNurbCurve interface

MappingName

IMcadPartList interface

MarkStampStandard

IMcadStandard3 interface

Matrix

IGeApplication interface

MaximumColumns

IMcadBalloonStandard interface

MaximumSpacingValue

IMcadSurfaceTexture interface

MaxPoint

IGeBoundBlock interface

MaxValue

IMcadEdge interface

mc2DSAllRef enumeration member

mc2DSAuxiliaryView enumeration member

mc2DSBackView enumeration member

mc2DSBGEnt enumeration member

mc2DSBGExclEnt enumeration member

mc2DSBottomView enumeration member

mc2DSDetailView enumeration member

mc2DSDirectRef enumeration member

mc2DSFGEnt enumeration member

mc2DSFGExclEnt enumeration member

mc2DSFrontView enumeration member

mc2DSHalfSectionView enumeration member

mc2DSHalfSectionVisibleView enumeration member

mc2DSNoEnt enumeration member

mc2DSNoLock enumeration member

mc2DSPartialRef enumeration member

mc2DSPartialView enumeration member

mc2DSSectionView enumeration member

mc2DSSideLeftView enumeration member

mc2DSSideRightView enumeration member

mc2DSSideView enumeration member

mc2DSStdPartLock enumeration member

mc2DSSubEntRef enumeration member

mc2DSTopView enumeration member

mc2DSUndefinedView enumeration member

mc2DSUpperBGExclEnt enumeration member

mc2DSUserLock enumeration member

mc2DSXrefLock enumeration member

mcAaugmentedLine enumeration member

mcAcad enumeration member

mcAcadM enumeration member

mcAcadMStruct enumeration member

Mcad2dComplexStdPartCompGroupDescriptor

Mcad2dComplexStdPartCompGroupDescriptor coclass

about Mcad2dComplexStdPartCompGroupDescriptor coclass

Mcad2dComplexStdPartCompGroupDescriptor interface

about IMcad2dComplexStdPartCompGroupDescriptor interface

AddView

HasEqualTypeWithViewGroup

IMcad2dComplexStdPartCompGroupDescriptor members

MigrateTo2DStructure

RemoveView

Views

Mcad2dComplexStdPartCompGroupDescriptor::AddView

Mcad2dComplexStdPartCompGroupDescriptor::AddView method

Mcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup

Mcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup method

Mcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure

Mcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure method

Mcad2dComplexStdPartCompGroupDescriptor::RemoveView

Mcad2dComplexStdPartCompGroupDescriptor::RemoveView method

Mcad2dComplexStdPartCompGroupDescriptor::Views

Mcad2dComplexStdPartCompGroupDescriptor::Views property

Mcad2dComponentDescriptor

Mcad2dComponentDescriptor coclass

about Mcad2dComponentDescriptor coclass

Mcad2dComponentDescriptor interface

about IMcad2dComponentDescriptor interface

AddComponentView

Component

ComponentDefinition

ComponentViews

CreateComponent

HasEqualTypeWithView

IMcad2dComponentDescriptor members

OwningComponentDefinition

RemoveComponentView

Mcad2dComponentDescriptor::AddComponentView

Mcad2dComponentDescriptor::AddComponentView method

Mcad2dComponentDescriptor::Component

Mcad2dComponentDescriptor::Component property

Mcad2dComponentDescriptor::ComponentDefinition

Mcad2dComponentDescriptor::ComponentDefinition property

Mcad2dComponentDescriptor::ComponentViews

Mcad2dComponentDescriptor::ComponentViews property

Mcad2dComponentDescriptor::CreateComponent

Mcad2dComponentDescriptor::CreateComponent method

Mcad2dComponentDescriptor::HasEqualTypeWithView

Mcad2dComponentDescriptor::HasEqualTypeWithView method

Mcad2dComponentDescriptor::OwningComponentDefinition

Mcad2dComponentDescriptor::OwningComponentDefinition property

Mcad2dComponentDescriptor::RemoveComponentView

Mcad2dComponentDescriptor::RemoveComponentView method

Mcad2dShaftCompGroupDescriptor

Mcad2dShaftCompGroupDescriptor coclass

about Mcad2dShaftCompGroupDescriptor coclass

Mcad2dShaftCompGroupDescriptor interface

about IMcad2dShaftCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor members

MigrateTo2DStructure

Views

Mcad2dShaftCompGroupDescriptor::MigrateTo2DStructure

Mcad2dShaftCompGroupDescriptor::MigrateTo2DStructure method

Mcad2dShaftCompGroupDescriptor::Views

Mcad2dShaftCompGroupDescriptor::Views property

Mcad2DSPreview

Mcad2dStdPartComponentDescriptor

Mcad2dStdPartComponentDescriptor coclass

about Mcad2dStdPartComponentDescriptor coclass

Mcad2dStdPartComponentDescriptor interface

about IMcad2dStdPartComponentDescriptor interface

Mcad2DStructureDescriptor

Mcad2DStructureDescriptor coclass

about Mcad2DStructureDescriptor coclass

Mcad2DStructureDescriptor interface

about IMcad2DStructureDescriptor interface

IMcad2DStructureDescriptor members

Name

Mcad2DStructureDescriptor::Name

Mcad2DStructureDescriptor::Name property

Mcad2DStructureMgr

Mcad2DStructureMgr coclass

about Mcad2DStructureMgr coclass

Mcad2DStructureMgr interface

about IMcad2DStructureMgr interface

AddNewAnnotationViewDefinition

AddNewComponentDefinition

AddNewComponentView

AddNewComponentViewDefinition

AddNewFolder

AddNewFolderDefinition

Application

CopyComponentFromDatabase

CopyFolderFromDatabase

Create2dComplexStdPartCompGroupDescriptor

Create2dComponentDescriptor

Create2dStdPartComponentDescriptor

CreateBlocksFromStructure

CreateComponentViewDescriptor

CreateFolderDescriptor

CreateStructureFromBlocks

EditTarget

ExternalStructureDatabases

GetComplexStdPartsForMigr

GetComplexStdPartViewsForMigr

GetComponentDefinitions

GetComponentViewDefinitions

GetFolderDefinitions

GetFolderPowerObjectsForMigr

GetNextAnnotationViewDefinitionName

GetNextComponentDefinitionName

GetNextFolderDefinitionName

GetSelection

GetShaftsForMigr

GetSingleStdPartComponentsForMigr

GetSingleStdPartViewsForMigr

GetStructureFromEntity

HasComponentDefinition

HasFolderDefinition

Highlight

IMcad2DStructureMgr members

Is2DStructureEnabled

IsEntityAllowed

IsFreeEntity

IsInActiveTarget

IsStructureBlock

PurgeAll2DS

PurgeAnnotationViewDefinitions

PurgeComponentDefinitions

PurgeComponentViewDefinitions

PurgeFolderDefinitions

RestructureViews

RootComponentDefinition

RootViewDefinition

Update

UpdateEntities

Mcad2DStructureMgr::AddNewAnnotationViewDefinition

Mcad2DStructureMgr::AddNewAnnotationViewDefinition method

Mcad2DStructureMgr::AddNewComponentDefinition

Mcad2DStructureMgr::AddNewComponentDefinition method

Mcad2DStructureMgr::AddNewComponentView

Mcad2DStructureMgr::AddNewComponentView method

Mcad2DStructureMgr::AddNewComponentViewDefinition

Mcad2DStructureMgr::AddNewComponentViewDefinition method

Mcad2DStructureMgr::AddNewFolder

Mcad2DStructureMgr::AddNewFolder method

Mcad2DStructureMgr::AddNewFolderDefinition

Mcad2DStructureMgr::AddNewFolderDefinition method

Mcad2DStructureMgr::Application

Mcad2DStructureMgr::Application property

Mcad2DStructureMgr::CopyComponentFromDatabase

Mcad2DStructureMgr::CopyComponentFromDatabase method

Mcad2DStructureMgr::CopyFolderFromDatabase

Mcad2DStructureMgr::CopyFolderFromDatabase method

Mcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor

Mcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor method

Mcad2DStructureMgr::Create2dComponentDescriptor

Mcad2DStructureMgr::Create2dComponentDescriptor method

Mcad2DStructureMgr::Create2dStdPartComponentDescriptor

Mcad2DStructureMgr::Create2dStdPartComponentDescriptor method

Mcad2DStructureMgr::CreateBlocksFromStructure

Mcad2DStructureMgr::CreateBlocksFromStructure method

Mcad2DStructureMgr::CreateComponentViewDescriptor

Mcad2DStructureMgr::CreateComponentViewDescriptor method

Mcad2DStructureMgr::CreateFolderDescriptor

Mcad2DStructureMgr::CreateFolderDescriptor method

Mcad2DStructureMgr::CreateStructureFromBlocks

Mcad2DStructureMgr::CreateStructureFromBlocks method

Mcad2DStructureMgr::EditTarget

Mcad2DStructureMgr::EditTarget property

Mcad2DStructureMgr::ExternalStructureDatabases

Mcad2DStructureMgr::ExternalStructureDatabases method

Mcad2DStructureMgr::GetComplexStdPartsForMigr

Mcad2DStructureMgr::GetComplexStdPartsForMigr method

Mcad2DStructureMgr::GetComplexStdPartViewsForMigr

Mcad2DStructureMgr::GetComplexStdPartViewsForMigr method

Mcad2DStructureMgr::GetComponentDefinitions

Mcad2DStructureMgr::GetComponentDefinitions method

Mcad2DStructureMgr::GetComponentViewDefinitions

Mcad2DStructureMgr::GetComponentViewDefinitions method

Mcad2DStructureMgr::GetFolderDefinitions

Mcad2DStructureMgr::GetFolderDefinitions method

Mcad2DStructureMgr::GetFolderPowerObjectsForMigr

Mcad2DStructureMgr::GetFolderPowerObjectsForMigr method

Mcad2DStructureMgr::GetNextAnnotationViewDefinitionName

Mcad2DStructureMgr::GetNextAnnotationViewDefinitionName method

Mcad2DStructureMgr::GetNextComponentDefinitionName

Mcad2DStructureMgr::GetNextComponentDefinitionName method

Mcad2DStructureMgr::GetNextFolderDefinitionName

Mcad2DStructureMgr::GetNextFolderDefinitionName method

Mcad2DStructureMgr::GetSelection

Mcad2DStructureMgr::GetSelection method

Mcad2DStructureMgr::GetShaftsForMigr

Mcad2DStructureMgr::GetShaftsForMigr method

Mcad2DStructureMgr::GetSingleStdPartComponentsForMigr

Mcad2DStructureMgr::GetSingleStdPartComponentsForMigr method

Mcad2DStructureMgr::GetSingleStdPartViewsForMigr

Mcad2DStructureMgr::GetSingleStdPartViewsForMigr method

Mcad2DStructureMgr::GetStructureFromEntity

Mcad2DStructureMgr::GetStructureFromEntity method

Mcad2DStructureMgr::HasComponentDefinition

Mcad2DStructureMgr::HasComponentDefinition method

Mcad2DStructureMgr::HasFolderDefinition

Mcad2DStructureMgr::HasFolderDefinition method

Mcad2DStructureMgr::Highlight

Mcad2DStructureMgr::Highlight method

Mcad2DStructureMgr::Is2DStructureEnabled

Mcad2DStructureMgr::Is2DStructureEnabled method

Mcad2DStructureMgr::IsEntityAllowed

Mcad2DStructureMgr::IsEntityAllowed method

Mcad2DStructureMgr::IsFreeEntity

Mcad2DStructureMgr::IsFreeEntity method

Mcad2DStructureMgr::IsInActiveTarget

Mcad2DStructureMgr::IsInActiveTarget method

Mcad2DStructureMgr::IsStructureBlock

Mcad2DStructureMgr::IsStructureBlock method

Mcad2DStructureMgr::PurgeAll2DS

Mcad2DStructureMgr::PurgeAll2DS method

Mcad2DStructureMgr::PurgeAnnotationViewDefinitions

Mcad2DStructureMgr::PurgeAnnotationViewDefinitions method

Mcad2DStructureMgr::PurgeComponentDefinitions

Mcad2DStructureMgr::PurgeComponentDefinitions method

Mcad2DStructureMgr::PurgeComponentViewDefinitions

Mcad2DStructureMgr::PurgeComponentViewDefinitions method

Mcad2DStructureMgr::PurgeFolderDefinitions

Mcad2DStructureMgr::PurgeFolderDefinitions method

Mcad2DStructureMgr::RestructureViews

Mcad2DStructureMgr::RestructureViews method

Mcad2DStructureMgr::RootComponentDefinition

Mcad2DStructureMgr::RootComponentDefinition method

Mcad2DStructureMgr::RootViewDefinition

Mcad2DStructureMgr::RootViewDefinition method

Mcad2DStructureMgr::Update

Mcad2DStructureMgr::Update method

Mcad2DStructureMgr::UpdateEntities

Mcad2DStructureMgr::UpdateEntities method

Mcad2DStructureMgr2

Mcad2DStructureMgr2 interface

about IMcad2DStructureMgr2 interface

IMcad2DStructureMgr2 members

StartTransaction

Mcad2DStructureMgr2::StartTransaction

Mcad2DStructureMgr2::StartTransaction property

Mcad2DStructureMgr3

Mcad2DStructureMgr3 interface

about IMcad2DStructureMgr3 interface

AddNewAnnotationView

AddNewAnnotationViewDefinition

IMcad2DStructureMgr3 members

UpdateEntities

Mcad2DStructureMgr3::AddNewAnnotationView

Mcad2DStructureMgr3::AddNewAnnotationView method

Mcad2DStructureMgr3::AddNewAnnotationViewDefinition

Mcad2DStructureMgr3::AddNewAnnotationViewDefinition method

Mcad2DStructureMgr3::UpdateEntities

Mcad2DStructureMgr3::UpdateEntities method

Mcad2DStructureMgr4

Mcad2DStructureMgr4 interface

about IMcad2DStructureMgr4 interface

GetReferenceLockMode

GetStructureMode

IMcad2DStructureMgr4 members

SelectionLockMode

SelectionOrderMode

SetReferenceLockMode

SetStructureMode

Mcad2DStructureMgr4::GetReferenceLockMode

Mcad2DStructureMgr4::GetReferenceLockMode method

Mcad2DStructureMgr4::GetStructureMode

Mcad2DStructureMgr4::GetStructureMode method

Mcad2DStructureMgr4::SelectionLockMode

Mcad2DStructureMgr4::SelectionLockMode property

Mcad2DStructureMgr4::SelectionOrderMode

Mcad2DStructureMgr4::SelectionOrderMode property

Mcad2DStructureMgr4::SetReferenceLockMode

Mcad2DStructureMgr4::SetReferenceLockMode method

Mcad2DStructureMgr4::SetStructureMode

Mcad2DStructureMgr4::SetStructureMode method

Mcad2DStructureMgr5

Mcad2DStructureMgr5 interface

about IMcad2DStructureMgr5 interface

CreateRootViewDefinition

ExistsStructure

IMcad2DStructureMgr5 members

Mcad2DStructureMgr5::CreateRootViewDefinition

Mcad2DStructureMgr5::CreateRootViewDefinition method

Mcad2DStructureMgr5::ExistsStructure

Mcad2DStructureMgr5::ExistsStructure method

Mcad2DSViewType

Mcad2DSViewType enumeration

McadAlignmentType

McadAlignmentType enumeration

McadAnnotationViewDefinition

McadAnnotationViewDefinition coclass

about McadAnnotationViewDefinition coclass

McadAnnotationViewDefinition interface

about IMcadAnnotationViewDefinition interface

AddComponentView

ComponentDefinition

IMcadAnnotationViewDefinition members

RemoveComponentView

McadAnnotationViewDefinition::AddComponentView

McadAnnotationViewDefinition::AddComponentView method

McadAnnotationViewDefinition::ComponentDefinition

McadAnnotationViewDefinition::ComponentDefinition property

McadAnnotationViewDefinition::RemoveComponentView

McadAnnotationViewDefinition::RemoveComponentView method

McadAnnotationViewDefinition2

McadAnnotationViewDefinition2 interface

about IMcadAnnotationViewDefinition2 interface

AnnotationViewLabel

AnnotationViewLabelPattern

AnnotationViewLabelPattern

CreateAnnotationViewLabel

CreateAnnotationViewLabels

EraseAnnotationViewLabel

HasAnnotationViewLabel

IMcadAnnotationViewDefinition2 members

McadAnnotationViewDefinition2::AnnotationViewLabel

McadAnnotationViewDefinition2::AnnotationViewLabel method

McadAnnotationViewDefinition2::AnnotationViewLabelPattern

McadAnnotationViewDefinition2::AnnotationViewLabelPattern method

McadAnnotationViewDefinition2::CreateAnnotationViewLabel

McadAnnotationViewDefinition2::CreateAnnotationViewLabel method

McadAnnotationViewDefinition2::CreateAnnotationViewLabels

McadAnnotationViewDefinition2::CreateAnnotationViewLabels method

McadAnnotationViewDefinition2::EraseAnnotationViewLabel

McadAnnotationViewDefinition2::EraseAnnotationViewLabel method

McadAnnotationViewDefinition2::HasAnnotationViewLabel

McadAnnotationViewDefinition2::HasAnnotationViewLabel method

McadAnnotationViewDefinitions

McadAnnotationViewDefinitions coclass

about McadAnnotationViewDefinitions coclass

McadAnnotationViewDefinitions interface

about IMcadAnnotationViewDefinitions interface

Add

Application

Count

IMcadAnnotationViewDefinitions members

Item

Remove

McadAnnotationViewDefinitions::Add

McadAnnotationViewDefinitions::Add method

McadAnnotationViewDefinitions::Application

McadAnnotationViewDefinitions::Application property

McadAnnotationViewDefinitions::Count

McadAnnotationViewDefinitions::Count property

McadAnnotationViewDefinitions::Item

McadAnnotationViewDefinitions::Item method

McadAnnotationViewDefinitions::Remove

McadAnnotationViewDefinitions::Remove method

McadAnnotationViewLabel

McadAnnotationViewLabel coclass

about McadAnnotationViewLabel coclass

McadAnnotationViewLabel interface

about IMcadAnnotationViewLabel interface

IMcadAnnotationViewLabel members

LabelPattern

LabelText

McadAnnotationViewLabel::LabelPattern

McadAnnotationViewLabel::LabelPattern property

McadAnnotationViewLabel::LabelText

McadAnnotationViewLabel::LabelText property

McadAnnotationViewStandard

McadAnnotationViewStandard coclass

about McadAnnotationViewStandard coclass

McadAnnotationViewStandard interface

about IMcadAnnotationViewStandard interface

IMcadAnnotationViewStandard members

LabelPattern

LabelPatternVariables

LabelPosition

McadAnnotationViewStandard::LabelPattern

McadAnnotationViewStandard::LabelPattern property

McadAnnotationViewStandard::LabelPatternVariables

McadAnnotationViewStandard::LabelPatternVariables property

McadAnnotationViewStandard::LabelPosition

McadAnnotationViewStandard::LabelPosition property

McadAnnotViewLabelPositionType

McadAnnotViewLabelPositionType enumeration

McadArc

McadArc coclass

about McadArc coclass

McadArc interface

about IMcadArc interface

McadArrowType

McadArrowType enumeration

McadAttachmentPoint

McadAttachmentPoint enumeration

McadAttachmentType

McadAttachmentType enumeration

McadAttachPosition

McadAttachPosition enumeration

McadAttribute

McadAttribute coclass

about McadAttribute coclass

McadAttribute interface

about IMcadAttribute interface

Application

ClassName

Document

FieldCount

FieldDescription

FieldName

FieldType

FieldValue

FieldValue

FieldValue32

FieldValue32

GetFieldIndex

Holders

IMcadAttribute members

ObjectID

ObjectID32

McadAttribute::Application

McadAttribute::Application property

McadAttribute::ClassName

McadAttribute::ClassName property

McadAttribute::Document

McadAttribute::Document property

McadAttribute::FieldCount

McadAttribute::FieldCount property

McadAttribute::FieldDescription

McadAttribute::FieldDescription method

McadAttribute::FieldName

McadAttribute::FieldName method

McadAttribute::FieldType

McadAttribute::FieldType method

McadAttribute::FieldValue

McadAttribute::FieldValue method

McadAttribute::FieldValue32

McadAttribute::FieldValue32 method

McadAttribute::GetFieldIndex

McadAttribute::GetFieldIndex method

McadAttribute::Holders

McadAttribute::Holders property

McadAttribute::ObjectID

McadAttribute::ObjectID property

McadAttribute::ObjectID32

McadAttribute::ObjectID32 property

McadAttributeAssociativity

McadAttributeAssociativity enumeration

McadAttributeField

McadAttributeField coclass

about McadAttributeField coclass

McadAttributeField interface

about IMcadAttributeField interface

Application

Description

FieldType

IMcadAttributeField members

Name

Static

McadAttributeField::Application

McadAttributeField::Application property

McadAttributeField::Description

McadAttributeField::Description property

McadAttributeField::FieldType

McadAttributeField::FieldType property

McadAttributeField::Name

McadAttributeField::Name property

McadAttributeField::Static

McadAttributeField::Static property

McadAttributeFields

McadAttributeFields coclass

about McadAttributeFields coclass

McadAttributeFields interface

about IMcadAttributeFields interface

Add

Application

Count

IMcadAttributeFields members

Item

Remove

McadAttributeFields::Add

McadAttributeFields::Add method

McadAttributeFields::Application

McadAttributeFields::Application property

McadAttributeFields::Count

McadAttributeFields::Count property

McadAttributeFields::Item

McadAttributeFields::Item method

McadAttributeFields::Remove

McadAttributeFields::Remove method

McadAttributes

McadAttributes coclass

about McadAttributes coclass

McadAttributes interface

about IMcadAttributes interface

Add

Application

Count

IMcadAttributes members

Item

Remove

McadAttributes::Add

McadAttributes::Add method

McadAttributes::Application

McadAttributes::Application property

McadAttributes::Count

McadAttributes::Count property

McadAttributes::Item

McadAttributes::Item method

McadAttributes::Remove

McadAttributes::Remove method

McadAugmentedLine

McadAugmentedLine coclass

about McadAugmentedLine coclass

McadAugmentedLine interface

about IMcadAugmentedLine interface

McadBalloon

McadBalloon coclass

about McadBalloon coclass

McadBalloon interface

about IMcadBalloon interface

AppendBOMItem

AttachmentType

BalloonType

BOM

BOMItems

CollectionType

CustomBlock

CustomBlockName

IMcadBalloon members

IsCustomBlockUsed

RemoveBOMItem

McadBalloon::AppendBOMItem

McadBalloon::AppendBOMItem method

McadBalloon::AttachmentType

McadBalloon::AttachmentType property

McadBalloon::BalloonType

McadBalloon::BalloonType property

McadBalloon::BOM

McadBalloon::BOM property

McadBalloon::BOMItems

McadBalloon::BOMItems property

McadBalloon::CollectionType

McadBalloon::CollectionType property

McadBalloon::CustomBlock

McadBalloon::CustomBlock property

McadBalloon::CustomBlockName

McadBalloon::CustomBlockName property

McadBalloon::IsCustomBlockUsed

McadBalloon::IsCustomBlockUsed property

McadBalloon::RemoveBOMItem

McadBalloon::RemoveBOMItem method

McadBalloonCollectionType

McadBalloonCollectionType enumeration

McadBalloons

McadBalloons coclass

about McadBalloons coclass

McadBalloons interface

about IMcadBalloons interface

Add

Application

Count

IMcadBalloons members

Item

Remove

McadBalloons::Add

McadBalloons::Add method

McadBalloons::Application

McadBalloons::Application property

McadBalloons::Count

McadBalloons::Count property

McadBalloons::Item

McadBalloons::Item method

McadBalloons::Remove

McadBalloons::Remove method

McadBalloonStandard

McadBalloonStandard coclass

about McadBalloonStandard coclass

McadBalloonStandard interface

about IMcadBalloonStandard interface

Application

ArrowType

AttachmentType

AuxiliaryArrowType

BalloonType

BOMStandard

Color

ColumnList

CustomBlockName

IMcadBalloonStandard members

IsAuxiliaryArrowUsed

IsCustomBlockUsed

MaximumColumns

RemoveColumn

Revision

RevisionYear

SetToDefaults

TextHeight

McadBalloonStandard::Application

McadBalloonStandard::Application property

McadBalloonStandard::ArrowType

McadBalloonStandard::ArrowType property

McadBalloonStandard::AttachmentType

McadBalloonStandard::AttachmentType property

McadBalloonStandard::AuxiliaryArrowType

McadBalloonStandard::AuxiliaryArrowType property

McadBalloonStandard::BalloonType

McadBalloonStandard::BalloonType property

McadBalloonStandard::BOMStandard

McadBalloonStandard::BOMStandard property

McadBalloonStandard::Color

McadBalloonStandard::Color property

McadBalloonStandard::ColumnList

McadBalloonStandard::ColumnList property

McadBalloonStandard::CustomBlockName

McadBalloonStandard::CustomBlockName property

McadBalloonStandard::IsAuxiliaryArrowUsed

McadBalloonStandard::IsAuxiliaryArrowUsed property

McadBalloonStandard::IsCustomBlockUsed

McadBalloonStandard::IsCustomBlockUsed property

McadBalloonStandard::MaximumColumns

McadBalloonStandard::MaximumColumns property

McadBalloonStandard::RemoveColumn

McadBalloonStandard::RemoveColumn method

McadBalloonStandard::Revision

McadBalloonStandard::Revision property

McadBalloonStandard::RevisionYear

McadBalloonStandard::RevisionYear property

McadBalloonStandard::SetToDefaults

McadBalloonStandard::SetToDefaults method

McadBalloonStandard::TextHeight

McadBalloonStandard::TextHeight property

McadBalloonStandard2

McadBalloonStandard2 interface

about IMcadBalloonStandard2 interface

IMcadBalloonStandard2 members

TrueColor

McadBalloonStandard2::TrueColor

McadBalloonStandard2::TrueColor property

McadBalloonType

McadBalloonType enumeration

McadBOM

McadBOM coclass

about McadBOM coclass

McadBOM interface

about IMcadBOM interface

AddItem

AddUnassociatedItem

Data

IMcadBOM members

Items

PartLists

Target

McadBOM::AddItem

McadBOM::AddItem method

McadBOM::AddUnassociatedItem

McadBOM::AddUnassociatedItem method

McadBOM::Data

McadBOM::Data property

McadBOM::Items

McadBOM::Items method

McadBOM::PartLists

McadBOM::PartLists property

McadBOM::Target

McadBOM::Target property

McadBOM2

McadBOM2 interface

about IMcadBOM2 interface

applySort

GetProperties

GetProperties32

IMcadBOM2 members

SetProperties

McadBOM2::applySort

McadBOM2::applySort method

McadBOM2::GetProperties

McadBOM2::GetProperties method

McadBOM2::GetProperties32

McadBOM2::GetProperties32 method

McadBOM2::SetProperties

McadBOM2::SetProperties method

McadBOM3

McadBOM3 interface

about IMcadBOM3 interface

GetStructuredChildItems

GetStructuredParentItem

IMcadBOM3 members

IsBorder

IsVisible

MergeItems

McadBOM3::GetStructuredChildItems

McadBOM3::GetStructuredChildItems method

McadBOM3::GetStructuredParentItem

McadBOM3::GetStructuredParentItem method

McadBOM3::IsBorder

McadBOM3::IsBorder property

McadBOM3::IsVisible

McadBOM3::IsVisible property

McadBOM3::MergeItems

McadBOM3::MergeItems method

McadBOM4

McadBOM4 interface

about IMcadBOM4 interface

IMcadBOM4 members

SplitItem

McadBOM4::SplitItem

McadBOM4::SplitItem method

McadBOMExportFormatType

McadBOMExportFormatType enumeration

McadBOMImportFormatType

McadBOMImportFormatType enumeration

McadBOMItem

McadBOMItem coclass

about McadBOMItem coclass

McadBOMItem interface

about IMcadBOMItem interface

AddReference

AutoCalculateEnabled

Balloons

BOM

Data

Expanded

GetReferences

GetReferences32

IMcadBOMItem members

IsExpandable

ItemNumber

Quantity

ReferenceExists

RemoveReference

McadBOMItem::AddReference

McadBOMItem::AddReference method

McadBOMItem::AutoCalculateEnabled

McadBOMItem::AutoCalculateEnabled property

McadBOMItem::Balloons

McadBOMItem::Balloons property

McadBOMItem::BOM

McadBOMItem::BOM property

McadBOMItem::Data

McadBOMItem::Data property

McadBOMItem::Expanded

McadBOMItem::Expanded property

McadBOMItem::GetReferences

McadBOMItem::GetReferences method

McadBOMItem::GetReferences32

McadBOMItem::GetReferences32 method

McadBOMItem::IsExpandable

McadBOMItem::IsExpandable property

McadBOMItem::ItemNumber

McadBOMItem::ItemNumber property

McadBOMItem::Quantity

McadBOMItem::Quantity property

McadBOMItem::ReferenceExists

McadBOMItem::ReferenceExists method

McadBOMItem::RemoveReference

McadBOMItem::RemoveReference method

McadBOMItem2

McadBOMItem2 interface

about IMcadBOMItem2 interface

ExcludeFromPartList

GetAttribute

GetCalculatedQuantity

GetItemDefinition

GetItemDefinition32

GetPartBalloons

IMcadBOMItem2 members

Phantomed

SetAttribute

McadBOMItem2::ExcludeFromPartList

McadBOMItem2::ExcludeFromPartList property

McadBOMItem2::GetAttribute

McadBOMItem2::GetAttribute method

McadBOMItem2::GetCalculatedQuantity

McadBOMItem2::GetCalculatedQuantity method

McadBOMItem2::GetItemDefinition

McadBOMItem2::GetItemDefinition method

McadBOMItem2::GetItemDefinition32

McadBOMItem2::GetItemDefinition32 method

McadBOMItem2::GetPartBalloons

McadBOMItem2::GetPartBalloons method

McadBOMItem2::Phantomed

McadBOMItem2::Phantomed property

McadBOMItem2::SetAttribute

McadBOMItem2::SetAttribute method

McadBOMItem3

McadBOMItem3 interface

about IMcadBOMItem3 interface

GetItemPartDefinition

GetItemPartDefinition32

IMcadBOMItem3 members

SetAttributePreDefinedListValue

SortPriority

McadBOMItem3::GetItemPartDefinition

McadBOMItem3::GetItemPartDefinition method

McadBOMItem3::GetItemPartDefinition32

McadBOMItem3::GetItemPartDefinition32 method

McadBOMItem3::SetAttributePreDefinedListValue

McadBOMItem3::SetAttributePreDefinedListValue method

McadBOMItem3::SortPriority

McadBOMItem3::SortPriority property

McadBOMItem4

McadBOMItem4 interface

about IMcadBOMItem4 interface

GetBomOverride

IMcadBOMItem4 members

RemoveAttribute

McadBOMItem4::GetBomOverride

McadBOMItem4::GetBomOverride method

McadBOMItem4::RemoveAttribute

McadBOMItem4::RemoveAttribute method

McadBOMItemDefinitionType

McadBOMItemDefinitionType enumeration

McadBOMItems

McadBOMItems coclass

about McadBOMItems coclass

McadBOMItems interface

about IMcadBOMItems interface

Add

Application

Count

IMcadBOMItems members

Item

Remove

McadBOMItems::Add

McadBOMItems::Add method

McadBOMItems::Application

McadBOMItems::Application property

McadBOMItems::Count

McadBOMItems::Count property

McadBOMItems::Item

McadBOMItems::Item method

McadBOMItems::Remove

McadBOMItems::Remove method

McadBOMMgr

McadBOMMgr coclass

about McadBOMMgr coclass

McadBOMMgr interface

about IMcadBOMMgr interface

AddBOMTable

AddPartData

Application

BOMTableExists

ExportBOM

GetAllBOMTables

GetBOMTable

GetPartData

IMcadBOMMgr members

ImportBOM

RemoveBOMTable

SelectBOMEntity

SelectBOMEntity32

SetPartData

SymbolBBMgr

McadBOMMgr::AddBOMTable

McadBOMMgr::AddBOMTable method

McadBOMMgr::AddPartData

McadBOMMgr::AddPartData method

McadBOMMgr::Application

McadBOMMgr::Application property

McadBOMMgr::BOMTableExists

McadBOMMgr::BOMTableExists method

McadBOMMgr::ExportBOM

McadBOMMgr::ExportBOM method

McadBOMMgr::GetAllBOMTables

McadBOMMgr::GetAllBOMTables method

McadBOMMgr::GetBOMTable

McadBOMMgr::GetBOMTable method

McadBOMMgr::GetPartData

McadBOMMgr::GetPartData method

McadBOMMgr::ImportBOM

McadBOMMgr::ImportBOM method

McadBOMMgr::RemoveBOMTable

McadBOMMgr::RemoveBOMTable method

McadBOMMgr::SelectBOMEntity

McadBOMMgr::SelectBOMEntity method

McadBOMMgr::SelectBOMEntity32

McadBOMMgr::SelectBOMEntity32 method

McadBOMMgr::SetPartData

McadBOMMgr::SetPartData method

McadBOMMgr::SymbolBBMgr

McadBOMMgr::SymbolBBMgr property

McadBOMMgr2

McadBOMMgr2 interface

about IMcadBOMMgr2 interface

AddBorderBOMTable

AddPartGrfDef

CurrentBOM

ExportBOM2

ExportPartList

GetBOMTableByCompDefId

GetBOMTableByCompDefId32

GetBOMTableByName

GetBorderBOMTable

GetEvaluatedPartData

GetPartAttribute

GetSheetBOMTable

IMcadBOMMgr2 members

ImportBOM2

ImportPartList

RemovePartGrfDef

SetPartAttribute

McadBOMMgr2::AddBorderBOMTable

McadBOMMgr2::AddBorderBOMTable method

McadBOMMgr2::AddPartGrfDef

McadBOMMgr2::AddPartGrfDef method

McadBOMMgr2::CurrentBOM

McadBOMMgr2::CurrentBOM property

McadBOMMgr2::ExportBOM2

McadBOMMgr2::ExportBOM2 method

McadBOMMgr2::ExportPartList

McadBOMMgr2::ExportPartList method

McadBOMMgr2::GetBOMTableByCompDefId

McadBOMMgr2::GetBOMTableByCompDefId method

McadBOMMgr2::GetBOMTableByCompDefId32

McadBOMMgr2::GetBOMTableByCompDefId32 method

McadBOMMgr2::GetBOMTableByName

McadBOMMgr2::GetBOMTableByName method

McadBOMMgr2::GetBorderBOMTable

McadBOMMgr2::GetBorderBOMTable method

McadBOMMgr2::GetEvaluatedPartData

McadBOMMgr2::GetEvaluatedPartData method

McadBOMMgr2::GetPartAttribute

McadBOMMgr2::GetPartAttribute method

McadBOMMgr2::GetSheetBOMTable

McadBOMMgr2::GetSheetBOMTable method

McadBOMMgr2::ImportBOM2

McadBOMMgr2::ImportBOM2 method

McadBOMMgr2::ImportPartList

McadBOMMgr2::ImportPartList method

McadBOMMgr2::RemovePartGrfDef

McadBOMMgr2::RemovePartGrfDef method

McadBOMMgr2::SetPartAttribute

McadBOMMgr2::SetPartAttribute method

McadBOMMgr3

McadBOMMgr3 interface

about IMcadBOMMgr3 interface

GetBOMTableByCompDefHandle

IMcadBOMMgr3 members

McadBOMMgr3::GetBOMTableByCompDefHandle

McadBOMMgr3::GetBOMTableByCompDefHandle method

McadBOMMgr4

McadBOMMgr4 interface

about IMcadBOMMgr4 interface

GetAllPartReferences

IMcadBOMMgr4 members

McadBOMMgr4::GetAllPartReferences

McadBOMMgr4::GetAllPartReferences method

McadBomOverrideType

McadBomOverrideType enumeration

McadBOMs

McadBOMs coclass

about McadBOMs coclass

McadBOMs interface

about IMcadBOMs interface

Add

Application

Count

IMcadBOMs members

Item

Remove

McadBOMs::Add

McadBOMs::Add method

McadBOMs::Application

McadBOMs::Application property

McadBOMs::Count

McadBOMs::Count property

McadBOMs::Item

McadBOMs::Item method

McadBOMs::Remove

McadBOMs::Remove method

McadBOMStandard

McadBOMStandard coclass

about McadBOMStandard coclass

McadBOMStandard interface

about IMcadBOMStandard interface

AddColumn

BalloonStandard

ColumnCount

Columns

GetColumn

IMcadBOMStandard members

MoveColumn

PartListStandard

RemoveColumn

McadBOMStandard::AddColumn

McadBOMStandard::AddColumn method

McadBOMStandard::BalloonStandard

McadBOMStandard::BalloonStandard property

McadBOMStandard::ColumnCount

McadBOMStandard::ColumnCount property

McadBOMStandard::Columns

McadBOMStandard::Columns property

McadBOMStandard::GetColumn

McadBOMStandard::GetColumn method

McadBOMStandard::MoveColumn

McadBOMStandard::MoveColumn method

McadBOMStandard::PartListStandard

McadBOMStandard::PartListStandard property

McadBOMStandard::RemoveColumn

McadBOMStandard::RemoveColumn method

McadBOMStandard2

McadBOMStandard2 interface

about IMcadBOMStandard2 interface

GetUOMName

IMcadBOMStandard2 members

McadBOMStandard2::GetUOMName

McadBOMStandard2::GetUOMName method

McadBOMUOMType

McadBOMUOMType enumeration

McadBorder

McadBorder coclass

about McadBorder coclass

McadBorder interface

about IMcadBorder interface

Attributes

Extends

IMcadBorder members

Name

Position

SetToDefaultAttributes

McadBorder::Attributes

McadBorder::Attributes property

McadBorder::Extends

McadBorder::Extends property

McadBorder::Name

McadBorder::Name property

McadBorder::Position

McadBorder::Position property

McadBorder::SetToDefaultAttributes

McadBorder::SetToDefaultAttributes method

McadBorder2

McadBorder2 interface

about IMcadBorder2 interface

BlockId

BlockId32

IMcadBorder2 members

McadBorder2::BlockId

McadBorder2::BlockId property

McadBorder2::BlockId32

McadBorder2::BlockId32 property

McadCollectionType

McadCollectionType enumeration

McadColumnDefinition

McadColumnDefinition coclass

about McadColumnDefinition coclass

McadColumnDefinition interface

about IMcadColumnDefinition interface

Application

Caption

CaptionAlignment

ColumnType

DataAlignment

DataType

Equivalents

IMcadColumnDefinition members

Index

Name

Precision

Size

Width

McadColumnDefinition::Application

McadColumnDefinition::Application property

McadColumnDefinition::Caption

McadColumnDefinition::Caption property

McadColumnDefinition::CaptionAlignment

McadColumnDefinition::CaptionAlignment property

McadColumnDefinition::ColumnType

McadColumnDefinition::ColumnType property

McadColumnDefinition::DataAlignment

McadColumnDefinition::DataAlignment property

McadColumnDefinition::DataType

McadColumnDefinition::DataType property

McadColumnDefinition::Equivalents

McadColumnDefinition::Equivalents property

McadColumnDefinition::Index

McadColumnDefinition::Index property

McadColumnDefinition::Name

McadColumnDefinition::Name property

McadColumnDefinition::Precision

McadColumnDefinition::Precision property

McadColumnDefinition::Size

McadColumnDefinition::Size property

McadColumnDefinition::Width

McadColumnDefinition::Width property

McadColumnDefinition2

McadColumnDefinition2 interface

about IMcadColumnDefinition2 interface

IMcadColumnDefinition2 members

IsVisible

McadColumnDefinition2::IsVisible

McadColumnDefinition2::IsVisible property

McadColumnDefinition3

McadColumnDefinition3 interface

about IMcadColumnDefinition3 interface

BOMCaptionAlignment

BOMDataAlignment

GetPreDefinedList

IMcadColumnDefinition3 members

IsPreDefinedList

PartListCaptionAlignment

PartListDataAlignment

RemovePreDefinedList

SetPreDefinedList

McadColumnDefinition3::BOMCaptionAlignment

McadColumnDefinition3::BOMCaptionAlignment property

McadColumnDefinition3::BOMDataAlignment

McadColumnDefinition3::BOMDataAlignment property

McadColumnDefinition3::GetPreDefinedList

McadColumnDefinition3::GetPreDefinedList method

McadColumnDefinition3::IsPreDefinedList

McadColumnDefinition3::IsPreDefinedList property

McadColumnDefinition3::PartListCaptionAlignment

McadColumnDefinition3::PartListCaptionAlignment property

McadColumnDefinition3::PartListDataAlignment

McadColumnDefinition3::PartListDataAlignment property

McadColumnDefinition3::RemovePreDefinedList

McadColumnDefinition3::RemovePreDefinedList method

McadColumnDefinition3::SetPreDefinedList

McadColumnDefinition3::SetPreDefinedList method

McadColumnDefinitions

McadColumnDefinitions coclass

about McadColumnDefinitions coclass

McadColumnDefinitions interface

about IMcadColumnDefinitions interface

Add

Application

Count

IMcadColumnDefinitions members

Item

Remove

McadColumnDefinitions::Add

McadColumnDefinitions::Add method

McadColumnDefinitions::Application

McadColumnDefinitions::Application property

McadColumnDefinitions::Count

McadColumnDefinitions::Count property

McadColumnDefinitions::Item

McadColumnDefinitions::Item method

McadColumnDefinitions::Remove

McadColumnDefinitions::Remove method

McadColumnSplitStyle

McadColumnSplitStyle enumeration

McadColumnSplitWrap

McadColumnSplitWrap enumeration

McadColumnType

McadColumnType enumeration

McadComplexHideSituation

McadComplexHideSituation coclass

about McadComplexHideSituation coclass

McadComplexHideSituation interface

about IMcadComplexHideSituation interface

AddLevel

Concealed

Definition

Explode

HiddenLinesInvisible

HideAppropriateObjectsOnly

HideSituations

IMcadComplexHideSituation members

InitFromHide

IsModifiedStandardPartHide

IsStandardPartHide

LevelCount

LookupLevelName

MoveLevel

Name

NextLevelName

RemoveLevel

RemoveLevelByIdx

Reverse

Suppressed

SysName

UpdateBgSelection

McadComplexHideSituation::AddLevel

McadComplexHideSituation::AddLevel method

McadComplexHideSituation::Concealed

McadComplexHideSituation::Concealed property

McadComplexHideSituation::Definition

McadComplexHideSituation::Definition property

McadComplexHideSituation::Explode

McadComplexHideSituation::Explode method

McadComplexHideSituation::HiddenLinesInvisible

McadComplexHideSituation::HiddenLinesInvisible property

McadComplexHideSituation::HideAppropriateObjectsOnly

McadComplexHideSituation::HideAppropriateObjectsOnly property

McadComplexHideSituation::HideSituations

McadComplexHideSituation::HideSituations property

McadComplexHideSituation::InitFromHide

McadComplexHideSituation::InitFromHide method

McadComplexHideSituation::IsModifiedStandardPartHide

McadComplexHideSituation::IsModifiedStandardPartHide property

McadComplexHideSituation::IsStandardPartHide

McadComplexHideSituation::IsStandardPartHide property

McadComplexHideSituation::LevelCount

McadComplexHideSituation::LevelCount property

McadComplexHideSituation::LookupLevelName

McadComplexHideSituation::LookupLevelName method

McadComplexHideSituation::MoveLevel

McadComplexHideSituation::MoveLevel method

McadComplexHideSituation::Name

McadComplexHideSituation::Name property

McadComplexHideSituation::NextLevelName

McadComplexHideSituation::NextLevelName property

McadComplexHideSituation::RemoveLevel

McadComplexHideSituation::RemoveLevel method

McadComplexHideSituation::RemoveLevelByIdx

McadComplexHideSituation::RemoveLevelByIdx method

McadComplexHideSituation::Reverse

McadComplexHideSituation::Reverse method

McadComplexHideSituation::Suppressed

McadComplexHideSituation::Suppressed property

McadComplexHideSituation::SysName

McadComplexHideSituation::SysName property

McadComplexHideSituation::UpdateBgSelection

McadComplexHideSituation::UpdateBgSelection method

McadComplexHideSituations

McadComplexHideSituations coclass

about McadComplexHideSituations coclass

McadComplexHideSituations interface

about IMcadComplexHideSituations interface

Add

Application

Count

IMcadComplexHideSituations members

Item

Remove

McadComplexHideSituations::Add

McadComplexHideSituations::Add method

McadComplexHideSituations::Application

McadComplexHideSituations::Application property

McadComplexHideSituations::Count

McadComplexHideSituations::Count property

McadComplexHideSituations::Item

McadComplexHideSituations::Item method

McadComplexHideSituations::Remove

McadComplexHideSituations::Remove method

McadComponent

McadComponent coclass

about McadComponent coclass

McadComponent interface

about IMcadComponent interface

AddAttribute

Children

ClearOverrideProperties

ColorOverride

ComponentViews

ContainingComponent

CopyDefinition

Definition

GetAttributes

GetComponentInDefinition

hasExternalDef

HasGhostViews

HasOverrideProperties

IMcadComponent members

is2D

Name

Owner

Position

PredefinedReferenceOverride

Reference

RemoveAttribute

ReplaceDefinition

SortChildren

VisibilityOverride

Visible

McadComponent::AddAttribute

McadComponent::AddAttribute method

McadComponent::Children

McadComponent::Children property

McadComponent::ClearOverrideProperties

McadComponent::ClearOverrideProperties method

McadComponent::ColorOverride

McadComponent::ColorOverride method

McadComponent::ComponentViews

McadComponent::ComponentViews property

McadComponent::ContainingComponent

McadComponent::ContainingComponent method

McadComponent::CopyDefinition

McadComponent::CopyDefinition method

McadComponent::Definition

McadComponent::Definition property

McadComponent::GetAttributes

McadComponent::GetAttributes method

McadComponent::GetComponentInDefinition

McadComponent::GetComponentInDefinition method

McadComponent::hasExternalDef

McadComponent::hasExternalDef property

McadComponent::HasGhostViews

McadComponent::HasGhostViews property

McadComponent::HasOverrideProperties

McadComponent::HasOverrideProperties property

McadComponent::is2D

McadComponent::is2D property

McadComponent::Name

McadComponent::Name property

McadComponent::Owner

McadComponent::Owner property

McadComponent::Position

McadComponent::Position property

McadComponent::PredefinedReferenceOverride

McadComponent::PredefinedReferenceOverride method

McadComponent::Reference

McadComponent::Reference property

McadComponent::RemoveAttribute

McadComponent::RemoveAttribute method

McadComponent::ReplaceDefinition

McadComponent::ReplaceDefinition method

McadComponent::SortChildren

McadComponent::SortChildren method

McadComponent::VisibilityOverride

McadComponent::VisibilityOverride method

McadComponent::Visible

McadComponent::Visible property

McadComponentDefinition

McadComponentDefinition coclass

about McadComponentDefinition coclass

McadComponentDefinition interface

about IMcadComponentDefinition interface

AddAttribute

AddComponent

Children

ComponentViewDefinitions

CopyDefinition

Externalize

ExternalPath

GetAttributes

GetInstances

GetNextComponentViewDefinitionName

HasComponentViewDefinition

IMcadComponentDefinition members

is2D

is2DAssembly

IsExternal

isFeature

IsLeafNode

IsRoot

isShaft

isStandardPart

Localize2DS

Name

PhantomState

RemoveAttribute

RemoveComponent

SortChildren

Update

McadComponentDefinition::AddAttribute

McadComponentDefinition::AddAttribute method

McadComponentDefinition::AddComponent

McadComponentDefinition::AddComponent method

McadComponentDefinition::Children

McadComponentDefinition::Children property

McadComponentDefinition::ComponentViewDefinitions

McadComponentDefinition::ComponentViewDefinitions property

McadComponentDefinition::CopyDefinition

McadComponentDefinition::CopyDefinition method

McadComponentDefinition::Externalize

McadComponentDefinition::Externalize method

McadComponentDefinition::ExternalPath

McadComponentDefinition::ExternalPath property

McadComponentDefinition::GetAttributes

McadComponentDefinition::GetAttributes method

McadComponentDefinition::GetInstances

McadComponentDefinition::GetInstances method

McadComponentDefinition::GetNextComponentViewDefinitionName

McadComponentDefinition::GetNextComponentViewDefinitionName method

McadComponentDefinition::HasComponentViewDefinition

McadComponentDefinition::HasComponentViewDefinition method

McadComponentDefinition::is2D

McadComponentDefinition::is2D property

McadComponentDefinition::is2DAssembly

McadComponentDefinition::is2DAssembly property

McadComponentDefinition::IsExternal

McadComponentDefinition::IsExternal property

McadComponentDefinition::isFeature

McadComponentDefinition::isFeature property

McadComponentDefinition::IsLeafNode

McadComponentDefinition::IsLeafNode property

McadComponentDefinition::IsRoot

McadComponentDefinition::IsRoot property

McadComponentDefinition::isShaft

McadComponentDefinition::isShaft property

McadComponentDefinition::isStandardPart

McadComponentDefinition::isStandardPart property

McadComponentDefinition::Localize2DS

McadComponentDefinition::Localize2DS method

McadComponentDefinition::Name

McadComponentDefinition::Name property

McadComponentDefinition::PhantomState

McadComponentDefinition::PhantomState property

McadComponentDefinition::RemoveAttribute

McadComponentDefinition::RemoveAttribute method

McadComponentDefinition::RemoveComponent

McadComponentDefinition::RemoveComponent method

McadComponentDefinition::SortChildren

McadComponentDefinition::SortChildren method

McadComponentDefinition::Update

McadComponentDefinition::Update method

McadComponentDefinitions

McadComponentDefinitions coclass

about McadComponentDefinitions coclass

McadComponentDefinitions interface

about IMcadComponentDefinitions interface

Add

Application

Count

IMcadComponentDefinitions members

Item

Remove

McadComponentDefinitions::Add

McadComponentDefinitions::Add method

McadComponentDefinitions::Application

McadComponentDefinitions::Application property

McadComponentDefinitions::Count

McadComponentDefinitions::Count property

McadComponentDefinitions::Item

McadComponentDefinitions::Item method

McadComponentDefinitions::Remove

McadComponentDefinitions::Remove method

McadComponents

McadComponents coclass

about McadComponents coclass

McadComponents interface

about IMcadComponents interface

Add

Application

Count

IMcadComponents members

Item

Remove

McadComponents::Add

McadComponents::Add method

McadComponents::Application

McadComponents::Application property

McadComponents::Count

McadComponents::Count property

McadComponents::Item

McadComponents::Item method

McadComponents::Remove

McadComponents::Remove method

McadComponentView

McadComponentView coclass

about McadComponentView coclass

McadComponentView interface

about IMcadComponentView interface

Component

IMcadComponentView members

isFeature

IsGhostView

McadComponentView::Component

McadComponentView::Component property

McadComponentView::isFeature

McadComponentView::isFeature property

McadComponentView::IsGhostView

McadComponentView::IsGhostView method

McadComponentViewDefinition

McadComponentViewDefinition coclass

about McadComponentViewDefinition coclass

McadComponentViewDefinition interface

about IMcadComponentViewDefinition interface

AddComponentView

IMcadComponentViewDefinition members

IsFeature

Owner

RemoveComponentView

McadComponentViewDefinition::AddComponentView

McadComponentViewDefinition::AddComponentView method

McadComponentViewDefinition::IsFeature

McadComponentViewDefinition::IsFeature property

McadComponentViewDefinition::Owner

McadComponentViewDefinition::Owner property

McadComponentViewDefinition::RemoveComponentView

McadComponentViewDefinition::RemoveComponentView method

McadComponentViewDefinitions

McadComponentViewDefinitions coclass

about McadComponentViewDefinitions coclass

McadComponentViewDefinitions interface

about IMcadComponentViewDefinitions interface

Add

Application

Count

IMcadComponentViewDefinitions members

Item

Remove

McadComponentViewDefinitions::Add

McadComponentViewDefinitions::Add method

McadComponentViewDefinitions::Application

McadComponentViewDefinitions::Application property

McadComponentViewDefinitions::Count

McadComponentViewDefinitions::Count property

McadComponentViewDefinitions::Item

McadComponentViewDefinitions::Item method

McadComponentViewDefinitions::Remove

McadComponentViewDefinitions::Remove method

McadComponentViewDescriptor

McadComponentViewDescriptor coclass

about McadComponentViewDescriptor coclass

McadComponentViewDescriptor interface

about IMcadComponentViewDescriptor interface

Component

CreateComponentView

FullViewName

IMcadComponentViewDescriptor members

McadComponentViewDescriptor::Component

McadComponentViewDescriptor::Component property

McadComponentViewDescriptor::CreateComponentView

McadComponentViewDescriptor::CreateComponentView method

McadComponentViewDescriptor::FullViewName

McadComponentViewDescriptor::FullViewName property

McadComponentViews

McadComponentViews coclass

about McadComponentViews coclass

McadComponentViews interface

about IMcadComponentViews interface

Add

Application

Count

IMcadComponentViews members

Item

Remove

McadComponentViews::Add

McadComponentViews::Add method

McadComponentViews::Application

McadComponentViews::Application property

McadComponentViews::Count

McadComponentViews::Count property

McadComponentViews::Item

McadComponentViews::Item method

McadComponentViews::Remove

McadComponentViews::Remove method

McadCurve

McadCurve interface

about IMcadCurve interface

McadDataType

McadDataType enumeration

McadDatumIdentifier

McadDatumIdentifier coclass

about McadDatumIdentifier coclass

McadDatumIdentifier interface

about IMcadDatumIdentifier interface

McadDatumIdentifier2

McadDatumIdentifier2 interface

about IMcadDatumIdentifier2 interface

AddStdCompliantLeader

IMcadDatumIdentifier2 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadDatumIdentifier2::AddStdCompliantLeader

McadDatumIdentifier2::AddStdCompliantLeader method

McadDatumIdentifier2::SurfExtLinesOffset

McadDatumIdentifier2::SurfExtLinesOffset property

McadDatumIdentifier2::SurfExtLinesOvershot

McadDatumIdentifier2::SurfExtLinesOvershot property

McadDatumIdentifier3

McadDatumIdentifier3 interface

about IMcadDatumIdentifier3 interface

AddLeaderWithSurfIndLeader

DatumNote

FarSideStatus

GetSurfIndLeader

IMcadDatumIdentifier3 members

SurfIndLeaderArrowType

ThreadNote

McadDatumIdentifier3::AddLeaderWithSurfIndLeader

McadDatumIdentifier3::AddLeaderWithSurfIndLeader method

McadDatumIdentifier3::DatumNote

McadDatumIdentifier3::DatumNote property

McadDatumIdentifier3::FarSideStatus

McadDatumIdentifier3::FarSideStatus property

McadDatumIdentifier3::GetSurfIndLeader

McadDatumIdentifier3::GetSurfIndLeader method

McadDatumIdentifier3::SurfIndLeaderArrowType

McadDatumIdentifier3::SurfIndLeaderArrowType property

McadDatumIdentifier3::ThreadNote

McadDatumIdentifier3::ThreadNote property

McadDatumIdentifier4

McadDatumIdentifier4 interface

about IMcadDatumIdentifier4 interface

IMcadDatumIdentifier4 members

IsAttachToFCF

McadDatumIdentifier4::IsAttachToFCF

McadDatumIdentifier4::IsAttachToFCF method

McadDatumStandard

McadDatumStandard coclass

about McadDatumStandard coclass

McadDatumStandard interface

about IMcadDatumStandard interface

BorderLineType

BorderLineTypeName

DrawLeaderArrow

HatchAngle

HatchDistance

HiddenLeaderLineType

HiddenLeaderLineTypeName

IMcadDatumStandard members

PointColor

PointSize

McadDatumStandard::BorderLineType

McadDatumStandard::BorderLineType property

McadDatumStandard::BorderLineTypeName

McadDatumStandard::BorderLineTypeName property

McadDatumStandard::DrawLeaderArrow

McadDatumStandard::DrawLeaderArrow property

McadDatumStandard::HatchAngle

McadDatumStandard::HatchAngle property

McadDatumStandard::HatchDistance

McadDatumStandard::HatchDistance property

McadDatumStandard::HiddenLeaderLineType

McadDatumStandard::HiddenLeaderLineType property

McadDatumStandard::HiddenLeaderLineTypeName

McadDatumStandard::HiddenLeaderLineTypeName property

McadDatumStandard::PointColor

McadDatumStandard::PointColor property

McadDatumStandard::PointSize

McadDatumStandard::PointSize property

McadDatumStandard2

McadDatumStandard2 interface

about IMcadDatumStandard2 interface

IMcadDatumStandard2 members

PointTrueColor

McadDatumStandard2::PointTrueColor

McadDatumStandard2::PointTrueColor property

McadDatumTarget

McadDatumTarget coclass

about McadDatumTarget coclass

McadDatumTarget interface

about IMcadDatumTarget interface

CircleRadius

DatumValue

DimensionValue

DrawLine

DrawPoint

IMcadDatumTarget members

LeaderLinetypeHidden

LineEndPoint

LineFactor

LineMidPoint

RectangleAngle

RectangleXSize

RectangleYSize

TargetOrigin

TargetType

McadDatumTarget::CircleRadius

McadDatumTarget::CircleRadius property

McadDatumTarget::DatumValue

McadDatumTarget::DatumValue property

McadDatumTarget::DimensionValue

McadDatumTarget::DimensionValue property

McadDatumTarget::DrawLine

McadDatumTarget::DrawLine property

McadDatumTarget::DrawPoint

McadDatumTarget::DrawPoint property

McadDatumTarget::LeaderLinetypeHidden

McadDatumTarget::LeaderLinetypeHidden property

McadDatumTarget::LineEndPoint

McadDatumTarget::LineEndPoint property

McadDatumTarget::LineFactor

McadDatumTarget::LineFactor property

McadDatumTarget::LineMidPoint

McadDatumTarget::LineMidPoint property

McadDatumTarget::RectangleAngle

McadDatumTarget::RectangleAngle property

McadDatumTarget::RectangleXSize

McadDatumTarget::RectangleXSize property

McadDatumTarget::RectangleYSize

McadDatumTarget::RectangleYSize property

McadDatumTarget::TargetOrigin

McadDatumTarget::TargetOrigin property

McadDatumTarget::TargetType

McadDatumTarget::TargetType property

McadDatumTarget2

McadDatumTarget2 interface

about IMcadDatumTarget2 interface

IMcadDatumTarget2 members

RectangleCornerPoint

SetTargetAttach

McadDatumTarget2::RectangleCornerPoint

McadDatumTarget2::RectangleCornerPoint property

McadDatumTarget2::SetTargetAttach

McadDatumTarget2::SetTargetAttach method

McadDescriptor

McadDescriptor interface

about IMcadDescriptor interface

Application

Document

IMcadDescriptor members

McadDescriptor::Application

McadDescriptor::Application property

McadDescriptor::Document

McadDescriptor::Document property

McadDetailSymbol

McadDetailSymbol coclass

about McadDetailSymbol coclass

McadDetailSymbol interface

about IMcadDetailSymbol interface

AnnotationOffset

BaseViewScale

CorrectionScaleFactor

CreateLabelEntity

DetailScale

IMcadDetailSymbol members

IsAssociativeDetail

LabelEntity

LabelEntityOffset

LabelName

LabelPattern

LabelText

Radius

SetSourceGeometry

ShowAnnotationLeader

ShowBorder

ShowLeader

SpecByAbsoluteScale

McadDetailSymbol::AnnotationOffset

McadDetailSymbol::AnnotationOffset property

McadDetailSymbol::BaseViewScale

McadDetailSymbol::BaseViewScale property

McadDetailSymbol::CorrectionScaleFactor

McadDetailSymbol::CorrectionScaleFactor property

McadDetailSymbol::CreateLabelEntity

McadDetailSymbol::CreateLabelEntity method

McadDetailSymbol::DetailScale

McadDetailSymbol::DetailScale property

McadDetailSymbol::IsAssociativeDetail

McadDetailSymbol::IsAssociativeDetail property

McadDetailSymbol::LabelEntity

McadDetailSymbol::LabelEntity property

McadDetailSymbol::LabelEntityOffset

McadDetailSymbol::LabelEntityOffset property

McadDetailSymbol::LabelName

McadDetailSymbol::LabelName property

McadDetailSymbol::LabelPattern

McadDetailSymbol::LabelPattern property

McadDetailSymbol::LabelText

McadDetailSymbol::LabelText property

McadDetailSymbol::Radius

McadDetailSymbol::Radius property

McadDetailSymbol::SetSourceGeometry

McadDetailSymbol::SetSourceGeometry method

McadDetailSymbol::ShowAnnotationLeader

McadDetailSymbol::ShowAnnotationLeader property

McadDetailSymbol::ShowBorder

McadDetailSymbol::ShowBorder property

McadDetailSymbol::ShowLeader

McadDetailSymbol::ShowLeader property

McadDetailSymbol::SpecByAbsoluteScale

McadDetailSymbol::SpecByAbsoluteScale property

McadDetailSymbolLabel

McadDetailSymbolLabel coclass

about McadDetailSymbolLabel coclass

McadDetailSymbolLabel interface

about IMcadDetailSymbolLabel interface

AnnotationOffset

IMcadDetailSymbolLabel members

LabelAbove

LabelText

SymbolEntity

McadDetailSymbolLabel::AnnotationOffset

McadDetailSymbolLabel::AnnotationOffset property

McadDetailSymbolLabel::LabelAbove

McadDetailSymbolLabel::LabelAbove property

McadDetailSymbolLabel::LabelText

McadDetailSymbolLabel::LabelText property

McadDetailSymbolLabel::SymbolEntity

McadDetailSymbolLabel::SymbolEntity property

McadDetailSymbolStandard

McadDetailSymbolStandard coclass

about McadDetailSymbolStandard coclass

McadDetailSymbolStandard interface

about IMcadDetailSymbolStandard interface

AddAllowedScale

AllowedScales

BorderLineType

EraseAllowedScales

IMcadDetailSymbolStandard members

LabelAbove

LabelPattern

ShowAnnotationLeader

ShowBorder

ShowLeader

McadDetailSymbolStandard::AddAllowedScale

McadDetailSymbolStandard::AddAllowedScale method

McadDetailSymbolStandard::AllowedScales

McadDetailSymbolStandard::AllowedScales property

McadDetailSymbolStandard::BorderLineType

McadDetailSymbolStandard::BorderLineType property

McadDetailSymbolStandard::EraseAllowedScales

McadDetailSymbolStandard::EraseAllowedScales method

McadDetailSymbolStandard::LabelAbove

McadDetailSymbolStandard::LabelAbove property

McadDetailSymbolStandard::LabelPattern

McadDetailSymbolStandard::LabelPattern property

McadDetailSymbolStandard::ShowAnnotationLeader

McadDetailSymbolStandard::ShowAnnotationLeader property

McadDetailSymbolStandard::ShowBorder

McadDetailSymbolStandard::ShowBorder property

McadDetailSymbolStandard::ShowLeader

McadDetailSymbolStandard::ShowLeader property

McadDetailSymbolStandard2

McadDetailSymbolStandard2 interface

about IMcadDetailSymbolStandard2 interface

BorderLineColor

BorderLineLineType

BorderLineWeight

BoundaryLineColor

BoundaryLineType

BoundaryLineWeight

ConnectionLineColor

ConnectionLineType

ConnectionLineWeight

GetByStandard

IdentifierOutsideBoundary

IMcadDetailSymbolStandard2 members

LabelOffset

LabelTextColor

LabelTextHeight

LabelTextStyle

SetByStandard

ShowLabel

McadDetailSymbolStandard2::BorderLineColor

McadDetailSymbolStandard2::BorderLineColor property

McadDetailSymbolStandard2::BorderLineLineType

McadDetailSymbolStandard2::BorderLineLineType property

McadDetailSymbolStandard2::BorderLineWeight

McadDetailSymbolStandard2::BorderLineWeight property

McadDetailSymbolStandard2::BoundaryLineColor

McadDetailSymbolStandard2::BoundaryLineColor property

McadDetailSymbolStandard2::BoundaryLineType

McadDetailSymbolStandard2::BoundaryLineType property

McadDetailSymbolStandard2::BoundaryLineWeight

McadDetailSymbolStandard2::BoundaryLineWeight property

McadDetailSymbolStandard2::ConnectionLineColor

McadDetailSymbolStandard2::ConnectionLineColor property

McadDetailSymbolStandard2::ConnectionLineType

McadDetailSymbolStandard2::ConnectionLineType property

McadDetailSymbolStandard2::ConnectionLineWeight

McadDetailSymbolStandard2::ConnectionLineWeight property

McadDetailSymbolStandard2::GetByStandard

McadDetailSymbolStandard2::GetByStandard method

McadDetailSymbolStandard2::IdentifierOutsideBoundary

McadDetailSymbolStandard2::IdentifierOutsideBoundary property

McadDetailSymbolStandard2::LabelOffset

McadDetailSymbolStandard2::LabelOffset property

McadDetailSymbolStandard2::LabelTextColor

McadDetailSymbolStandard2::LabelTextColor property

McadDetailSymbolStandard2::LabelTextHeight

McadDetailSymbolStandard2::LabelTextHeight property

McadDetailSymbolStandard2::LabelTextStyle

McadDetailSymbolStandard2::LabelTextStyle property

McadDetailSymbolStandard2::SetByStandard

McadDetailSymbolStandard2::SetByStandard method

McadDetailSymbolStandard2::ShowLabel

McadDetailSymbolStandard2::ShowLabel property

McadDetailSymbolStandardPropType

McadDetailSymbolStandardPropType enumeration

McadDirectionLayType

McadDirectionLayType enumeration

McadDocDrawingType

McadDocDrawingType enumeration

McadDocument

McadDocument coclass

about McadDocument coclass

McadDocument interface

about IMcadDocument interface

Application

IMcadDocument members

LayerGroupMgr

LayerObjectMgr

StructureMgr2D

Utility

McadDocument::Application

McadDocument::Application property

McadDocument::LayerGroupMgr

McadDocument::LayerGroupMgr property

McadDocument::LayerObjectMgr

McadDocument::LayerObjectMgr property

McadDocument::StructureMgr2D

McadDocument::StructureMgr2D property

McadDocument::Utility

McadDocument::Utility property

McadDocuments

McadDocuments coclass

about McadDocuments coclass

McadDocuments interface

about IMcadDocuments interface

Application

Count

IMcadDocuments members

Item

McadDocuments::Application

McadDocuments::Application property

McadDocuments::Count

McadDocuments::Count property

McadDocuments::Item

McadDocuments::Item method

McadDocumentVersion

McadDocumentVersion interface

about IMcadDocumentVersion interface

GetVersionNumber

IMcadDocumentVersion members

McadDocumentVersion::GetVersionNumber

McadDocumentVersion::GetVersionNumber method

McadEdge

McadEdge coclass

about McadEdge coclass

McadEdge interface

about IMcadEdge interface

AllAround

Direction

IMcadEdge members

Majority

MaxValue

MinValue

NewSymbolRev

SignValue

StandardNumber

UndefsizeDirection

McadEdge::AllAround

McadEdge::AllAround property

McadEdge::Direction

McadEdge::Direction property

McadEdge::Majority

McadEdge::Majority property

McadEdge::MaxValue

McadEdge::MaxValue property

McadEdge::MinValue

McadEdge::MinValue property

McadEdge::NewSymbolRev

McadEdge::NewSymbolRev property

McadEdge::SignValue

McadEdge::SignValue property

McadEdge::StandardNumber

McadEdge::StandardNumber property

McadEdge::UndefsizeDirection

McadEdge::UndefsizeDirection property

McadEdgeLibrary

McadEdgeLibrary coclass

about McadEdgeLibrary coclass

McadEdgeLibrary interface

about IMcadEdgeLibrary interface

McadEdgeLibraryObject

McadEdgeLibraryObject coclass

about McadEdgeLibraryObject coclass

McadEdgeLibraryObject interface

about IMcadEdgeLibraryObject interface

IMcadEdgeLibraryObject members

IsAllAround

IsDefinedDirection

IsMajority

RequirementValue

StandardNumber

UndefsizeDirection

McadEdgeLibraryObject::IsAllAround

McadEdgeLibraryObject::IsAllAround property

McadEdgeLibraryObject::IsDefinedDirection

McadEdgeLibraryObject::IsDefinedDirection property

McadEdgeLibraryObject::IsMajority

McadEdgeLibraryObject::IsMajority property

McadEdgeLibraryObject::RequirementValue

McadEdgeLibraryObject::RequirementValue method

McadEdgeLibraryObject::StandardNumber

McadEdgeLibraryObject::StandardNumber property

McadEdgeLibraryObject::UndefsizeDirection

McadEdgeLibraryObject::UndefsizeDirection property

McadEdgeRequirement

McadEdgeRequirement enumeration

McadEdgeStandard

McadEdgeStandard coclass

about McadEdgeStandard coclass

McadEdgeStandard interface

about IMcadEdgeStandard interface

AllAroundAllowed

FullList

IMcadEdgeStandard members

MajorityAllowed

StandardNumAllowed

McadEdgeStandard::AllAroundAllowed

McadEdgeStandard::AllAroundAllowed property

McadEdgeStandard::FullList

McadEdgeStandard::FullList property

McadEdgeStandard::MajorityAllowed

McadEdgeStandard::MajorityAllowed property

McadEdgeStandard::StandardNumAllowed

McadEdgeStandard::StandardNumAllowed property

McadEllipse

McadEllipse coclass

about McadEllipse coclass

McadEllipse interface

about IMcadEllipse interface

McadFCFLibrary

McadFCFLibrary coclass

about McadFCFLibrary coclass

McadFCFLibrary interface

about IMcadFCFLibrary interface

McadFCFLibraryObject

McadFCFLibraryObject coclass

about McadFCFLibraryObject coclass

McadFCFLibraryObject interface

about IMcadFCFLibraryObject interface

IMcadFCFLibraryObject members

IsAllAround

RequirementValue

Symbol

Symbol2

Symbol3

McadFCFLibraryObject::IsAllAround

McadFCFLibraryObject::IsAllAround property

McadFCFLibraryObject::RequirementValue

McadFCFLibraryObject::RequirementValue method

McadFCFLibraryObject::Symbol

McadFCFLibraryObject::Symbol property

McadFCFLibraryObject::Symbol2

McadFCFLibraryObject::Symbol2 property

McadFCFLibraryObject::Symbol3

McadFCFLibraryObject::Symbol3 property

McadFCFRequirement

McadFCFRequirement enumeration

McadFCFStandard

McadFCFStandard coclass

about McadFCFStandard coclass

McadFCFStandard interface

about IMcadFCFStandard interface

AvailableAuxiliarySymbols

AvailableGDTSymbols

EndPadding

FrameGap

GDTTextFont

GDTTextStyle

GDTTextStyleName

GetSymbolImplementation

IMcadFCFStandard members

MergeDatum

MergeSymbol

MergeTolerance

OfferedAuxiliarySymbols

OfferedGDTSymbols

SeparateDatumID

SeparateProjected

McadFCFStandard::AvailableAuxiliarySymbols

McadFCFStandard::AvailableAuxiliarySymbols property

McadFCFStandard::AvailableGDTSymbols

McadFCFStandard::AvailableGDTSymbols property

McadFCFStandard::EndPadding

McadFCFStandard::EndPadding property

McadFCFStandard::FrameGap

McadFCFStandard::FrameGap property

McadFCFStandard::GDTTextFont

McadFCFStandard::GDTTextFont property

McadFCFStandard::GDTTextStyle

McadFCFStandard::GDTTextStyle property

McadFCFStandard::GDTTextStyleName

McadFCFStandard::GDTTextStyleName property

McadFCFStandard::GetSymbolImplementation

McadFCFStandard::GetSymbolImplementation method

McadFCFStandard::MergeDatum

McadFCFStandard::MergeDatum property

McadFCFStandard::MergeSymbol

McadFCFStandard::MergeSymbol property

McadFCFStandard::MergeTolerance

McadFCFStandard::MergeTolerance property

McadFCFStandard::OfferedAuxiliarySymbols

McadFCFStandard::OfferedAuxiliarySymbols property

McadFCFStandard::OfferedGDTSymbols

McadFCFStandard::OfferedGDTSymbols property

McadFCFStandard::SeparateDatumID

McadFCFStandard::SeparateDatumID property

McadFCFStandard::SeparateProjected

McadFCFStandard::SeparateProjected property

McadFCFStandard2

McadFCFStandard2 interface

about IMcadFCFStandard2 interface

IMcadFCFStandard2 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadFCFStandard2::SurfIndLeaderArrowScale

McadFCFStandard2::SurfIndLeaderArrowScale property

McadFCFStandard2::SurfIndLeaderArrowType

McadFCFStandard2::SurfIndLeaderArrowType property

McadFeatureControlFrame

McadFeatureControlFrame coclass

about McadFeatureControlFrame coclass

McadFeatureControlFrame interface

about IMcadFeatureControlFrame interface

DatumIDValue

DatumPrimary2Value

DatumPrimary3Value

DatumPrimaryValue

DatumSecondary2Value

DatumSecondary3Value

DatumSecondaryValue

DatumTertiary2Value

DatumTertiary3Value

DatumTertiaryValue

IMcadFeatureControlFrame members

IsAllAround

ProjectedValue

Symbol

Symbol2

Symbol3

Tolerance2Value

Tolerance3Value

ToleranceB2Value

ToleranceBValue

ToleranceValue

McadFeatureControlFrame::DatumIDValue

McadFeatureControlFrame::DatumIDValue property

McadFeatureControlFrame::DatumPrimary2Value

McadFeatureControlFrame::DatumPrimary2Value property

McadFeatureControlFrame::DatumPrimary3Value

McadFeatureControlFrame::DatumPrimary3Value property

McadFeatureControlFrame::DatumPrimaryValue

McadFeatureControlFrame::DatumPrimaryValue property

McadFeatureControlFrame::DatumSecondary2Value

McadFeatureControlFrame::DatumSecondary2Value property

McadFeatureControlFrame::DatumSecondary3Value

McadFeatureControlFrame::DatumSecondary3Value property

McadFeatureControlFrame::DatumSecondaryValue

McadFeatureControlFrame::DatumSecondaryValue property

McadFeatureControlFrame::DatumTertiary2Value

McadFeatureControlFrame::DatumTertiary2Value property

McadFeatureControlFrame::DatumTertiary3Value

McadFeatureControlFrame::DatumTertiary3Value property

McadFeatureControlFrame::DatumTertiaryValue

McadFeatureControlFrame::DatumTertiaryValue property

McadFeatureControlFrame::IsAllAround

McadFeatureControlFrame::IsAllAround property

McadFeatureControlFrame::ProjectedValue

McadFeatureControlFrame::ProjectedValue property

McadFeatureControlFrame::Symbol

McadFeatureControlFrame::Symbol property

McadFeatureControlFrame::Symbol2

McadFeatureControlFrame::Symbol2 property

McadFeatureControlFrame::Symbol3

McadFeatureControlFrame::Symbol3 property

McadFeatureControlFrame::Tolerance2Value

McadFeatureControlFrame::Tolerance2Value property

McadFeatureControlFrame::Tolerance3Value

McadFeatureControlFrame::Tolerance3Value property

McadFeatureControlFrame::ToleranceB2Value

McadFeatureControlFrame::ToleranceB2Value property

McadFeatureControlFrame::ToleranceBValue

McadFeatureControlFrame::ToleranceBValue property

McadFeatureControlFrame::ToleranceValue

McadFeatureControlFrame::ToleranceValue property

McadFeatureControlFrame2

McadFeatureControlFrame2 interface

about IMcadFeatureControlFrame2 interface

BottomNoteValue

IMcadFeatureControlFrame2 members

TopNoteValue

McadFeatureControlFrame2::BottomNoteValue

McadFeatureControlFrame2::BottomNoteValue property

McadFeatureControlFrame2::TopNoteValue

McadFeatureControlFrame2::TopNoteValue property

McadFeatureControlFrame3

McadFeatureControlFrame3 interface

about IMcadFeatureControlFrame3 interface

AddStdCompliantLeader

IMcadFeatureControlFrame3 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadFeatureControlFrame3::AddStdCompliantLeader

McadFeatureControlFrame3::AddStdCompliantLeader method

McadFeatureControlFrame3::SurfExtLinesOffset

McadFeatureControlFrame3::SurfExtLinesOffset property

McadFeatureControlFrame3::SurfExtLinesOvershot

McadFeatureControlFrame3::SurfExtLinesOvershot property

McadFeatureControlFrame4

McadFeatureControlFrame4 interface

about IMcadFeatureControlFrame4 interface

AddLeaderWithSurfIndLeader

AddSurfIndLeader

GetSurfIndLeader

IMcadFeatureControlFrame4 members

RemoveSurfIndLeader

SurfIndLeaderArrowType

McadFeatureControlFrame4::AddLeaderWithSurfIndLeader

McadFeatureControlFrame4::AddLeaderWithSurfIndLeader method

McadFeatureControlFrame4::AddSurfIndLeader

McadFeatureControlFrame4::AddSurfIndLeader method

McadFeatureControlFrame4::GetSurfIndLeader

McadFeatureControlFrame4::GetSurfIndLeader method

McadFeatureControlFrame4::RemoveSurfIndLeader

McadFeatureControlFrame4::RemoveSurfIndLeader method

McadFeatureControlFrame4::SurfIndLeaderArrowType

McadFeatureControlFrame4::SurfIndLeaderArrowType property

McadFeatureIdentifier

McadFeatureIdentifier coclass

about McadFeatureIdentifier coclass

McadFeatureIdentifier interface

about IMcadFeatureIdentifier interface

McadFeatureIdentifier2

McadFeatureIdentifier2 interface

about IMcadFeatureIdentifier2 interface

AddStdCompliantLeader

IMcadFeatureIdentifier2 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadFeatureIdentifier2::AddStdCompliantLeader

McadFeatureIdentifier2::AddStdCompliantLeader method

McadFeatureIdentifier2::SurfExtLinesOffset

McadFeatureIdentifier2::SurfExtLinesOffset property

McadFeatureIdentifier2::SurfExtLinesOvershot

McadFeatureIdentifier2::SurfExtLinesOvershot property

McadFieldType

McadFieldType enumeration

McadFilterOperator

McadFilterOperator enumeration

McadFilterType

McadFilterType enumeration

McadFolder

McadFolder coclass

about McadFolder coclass

McadFolder interface

about IMcadFolder interface

AddEntities

BasePoint

Children

ClearLeaf

ClearOverrideProperties

ColorOverride

ContextDefinition

CopyEntities

CopyView

CopyViewDefinition

Definition

Entities

Entities32

Explode

ExtentsMaximum

ExtentsMinimum

GeomPathName

HasExternalDef

HasOverrideProperties

IMcadFolder members

IsInstance

IsLeaf

IsLocked

IsSubentityOf

Owner

Position

PredefinedReferenceOverride

RemoveEntities

ReplaceDefinition

ViewName

ViewScale

VisibilityOverride

Visible

McadFolder::AddEntities

McadFolder::AddEntities method

McadFolder::BasePoint

McadFolder::BasePoint property

McadFolder::Children

McadFolder::Children property

McadFolder::ClearLeaf

McadFolder::ClearLeaf method

McadFolder::ClearOverrideProperties

McadFolder::ClearOverrideProperties method

McadFolder::ColorOverride

McadFolder::ColorOverride method

McadFolder::ContextDefinition

McadFolder::ContextDefinition property

McadFolder::CopyEntities

McadFolder::CopyEntities method

McadFolder::CopyView

McadFolder::CopyView method

McadFolder::CopyViewDefinition

McadFolder::CopyViewDefinition method

McadFolder::Definition

McadFolder::Definition property

McadFolder::Entities

McadFolder::Entities property

McadFolder::Entities32

McadFolder::Entities32 property

McadFolder::Explode

McadFolder::Explode method

McadFolder::ExtentsMaximum

McadFolder::ExtentsMaximum property

McadFolder::ExtentsMinimum

McadFolder::ExtentsMinimum property

McadFolder::GeomPathName

McadFolder::GeomPathName property

McadFolder::HasExternalDef

McadFolder::HasExternalDef property

McadFolder::HasOverrideProperties

McadFolder::HasOverrideProperties property

McadFolder::IsInstance

McadFolder::IsInstance property

McadFolder::IsLeaf

McadFolder::IsLeaf property

McadFolder::IsLocked

McadFolder::IsLocked property

McadFolder::IsSubentityOf

McadFolder::IsSubentityOf method

McadFolder::Owner

McadFolder::Owner property

McadFolder::Position

McadFolder::Position property

McadFolder::PredefinedReferenceOverride

McadFolder::PredefinedReferenceOverride method

McadFolder::RemoveEntities

McadFolder::RemoveEntities method

McadFolder::ReplaceDefinition

McadFolder::ReplaceDefinition method

McadFolder::ViewName

McadFolder::ViewName property

McadFolder::ViewScale

McadFolder::ViewScale property

McadFolder::VisibilityOverride

McadFolder::VisibilityOverride method

McadFolder::Visible

McadFolder::Visible property

McadFolder2

McadFolder2 interface

about IMcadFolder2 interface

IMcadFolder2 members

OwningSpace

McadFolder2::OwningSpace

McadFolder2::OwningSpace property

McadFolderDefinition

McadFolderDefinition coclass

about McadFolderDefinition coclass

McadFolderDefinition interface

about IMcadFolderDefinition interface

AddComplexHideSituation

AddFolder

AddFromExistingEntities

AddHideSituation

Children

ChildrenCount

ComplexHideSituations

Extents

Externalize

FindHideSituations

FullName

GetHidesSuppressState

HideSituations

IMcadFolderDefinition members

InstanceCount

Instances

InstancesDefinition

IsAnnotation

IsDetail

IsExternal

IsLocked

IsRoot

Localize

LockType

LookupViewName

Name

NextViewName

Occurrences

RemoveFolder

SetHidesSuppressState

SortChildren

ViewType

McadFolderDefinition::AddComplexHideSituation

McadFolderDefinition::AddComplexHideSituation method

McadFolderDefinition::AddFolder

McadFolderDefinition::AddFolder method

McadFolderDefinition::AddFromExistingEntities

McadFolderDefinition::AddFromExistingEntities method

McadFolderDefinition::AddHideSituation

McadFolderDefinition::AddHideSituation method

McadFolderDefinition::Children

McadFolderDefinition::Children method

McadFolderDefinition::ChildrenCount

McadFolderDefinition::ChildrenCount property

McadFolderDefinition::ComplexHideSituations

McadFolderDefinition::ComplexHideSituations property

McadFolderDefinition::Extents

McadFolderDefinition::Extents method

McadFolderDefinition::Externalize

McadFolderDefinition::Externalize method

McadFolderDefinition::FindHideSituations

McadFolderDefinition::FindHideSituations method

McadFolderDefinition::FullName

McadFolderDefinition::FullName property

McadFolderDefinition::GetHidesSuppressState

McadFolderDefinition::GetHidesSuppressState method

McadFolderDefinition::HideSituations

McadFolderDefinition::HideSituations property

McadFolderDefinition::InstanceCount

McadFolderDefinition::InstanceCount property

McadFolderDefinition::Instances

McadFolderDefinition::Instances method

McadFolderDefinition::InstancesDefinition

McadFolderDefinition::InstancesDefinition method

McadFolderDefinition::IsAnnotation

McadFolderDefinition::IsAnnotation property

McadFolderDefinition::IsDetail

McadFolderDefinition::IsDetail property

McadFolderDefinition::IsExternal

McadFolderDefinition::IsExternal method

McadFolderDefinition::IsLocked

McadFolderDefinition::IsLocked property

McadFolderDefinition::IsRoot

McadFolderDefinition::IsRoot property

McadFolderDefinition::Localize

McadFolderDefinition::Localize method

McadFolderDefinition::LockType

McadFolderDefinition::LockType property

McadFolderDefinition::LookupViewName

McadFolderDefinition::LookupViewName method

McadFolderDefinition::Name

McadFolderDefinition::Name property

McadFolderDefinition::NextViewName

McadFolderDefinition::NextViewName method

McadFolderDefinition::Occurrences

McadFolderDefinition::Occurrences method

McadFolderDefinition::RemoveFolder

McadFolderDefinition::RemoveFolder method

McadFolderDefinition::SetHidesSuppressState

McadFolderDefinition::SetHidesSuppressState method

McadFolderDefinition::SortChildren

McadFolderDefinition::SortChildren method

McadFolderDefinition::ViewType

McadFolderDefinition::ViewType property

McadFolderDefinitions

McadFolderDefinitions coclass

about McadFolderDefinitions coclass

McadFolderDefinitions interface

about IMcadFolderDefinitions interface

Add

Application

Count

IMcadFolderDefinitions members

Item

Remove

McadFolderDefinitions::Add

McadFolderDefinitions::Add method

McadFolderDefinitions::Application

McadFolderDefinitions::Application property

McadFolderDefinitions::Count

McadFolderDefinitions::Count property

McadFolderDefinitions::Item

McadFolderDefinitions::Item method

McadFolderDefinitions::Remove

McadFolderDefinitions::Remove method

McadFolderDescriptor

McadFolderDescriptor coclass

about McadFolderDescriptor coclass

McadFolderDescriptor interface

about IMcadFolderDescriptor interface

CreateFolder

Definition

Entities

Entities32

IMcadFolderDescriptor members

Position

PowerObjectType

TargetView

ViewKey

ViewName

Views

McadFolderDescriptor::CreateFolder

McadFolderDescriptor::CreateFolder method

McadFolderDescriptor::Definition

McadFolderDescriptor::Definition property

McadFolderDescriptor::Entities

McadFolderDescriptor::Entities property

McadFolderDescriptor::Entities32

McadFolderDescriptor::Entities32 property

McadFolderDescriptor::Position

McadFolderDescriptor::Position property

McadFolderDescriptor::PowerObjectType

McadFolderDescriptor::PowerObjectType property

McadFolderDescriptor::TargetView

McadFolderDescriptor::TargetView property

McadFolderDescriptor::ViewKey

McadFolderDescriptor::ViewKey property

McadFolderDescriptor::ViewName

McadFolderDescriptor::ViewName property

McadFolderDescriptor::Views

McadFolderDescriptor::Views property

McadFolders

McadFolders coclass

about McadFolders coclass

McadFolders interface

about IMcadFolders interface

Add

Application

Count

IMcadFolders members

Item

Remove

McadFolders::Add

McadFolders::Add method

McadFolders::Application

McadFolders::Application property

McadFolders::Count

McadFolders::Count property

McadFolders::Item

McadFolders::Item method

McadFolders::Remove

McadFolders::Remove method

McadFormulaEvaluator

McadFormulaEvaluator coclass

about McadFormulaEvaluator coclass

McadFormulaEvaluator interface

about IMcadFormulaEvaluator interface

Application

Evaluate

Exist

GetAllAttribs

GetAllAttribsData

GetAllAttribValues

GetData

IMcadFormulaEvaluator members

IsEditable

SetData

SetDataProvider

McadFormulaEvaluator::Application

McadFormulaEvaluator::Application property

McadFormulaEvaluator::Evaluate

McadFormulaEvaluator::Evaluate method

McadFormulaEvaluator::Exist

McadFormulaEvaluator::Exist method

McadFormulaEvaluator::GetAllAttribs

McadFormulaEvaluator::GetAllAttribs method

McadFormulaEvaluator::GetAllAttribsData

McadFormulaEvaluator::GetAllAttribsData method

McadFormulaEvaluator::GetAllAttribValues

McadFormulaEvaluator::GetAllAttribValues method

McadFormulaEvaluator::GetData

McadFormulaEvaluator::GetData method

McadFormulaEvaluator::IsEditable

McadFormulaEvaluator::IsEditable method

McadFormulaEvaluator::SetData

McadFormulaEvaluator::SetData method

McadFormulaEvaluator::SetDataProvider

McadFormulaEvaluator::SetDataProvider method

McadGDTSymbolType

McadGDTSymbolType enumeration

McadGeometry

McadGeometry interface

about IMcadGeometry interface

AddAttribute

ContainingComponent

Geometry

GetAttributes

HasChanged

IMcadGeometry members

RemoveAttribute

McadGeometry::AddAttribute

McadGeometry::AddAttribute method

McadGeometry::ContainingComponent

McadGeometry::ContainingComponent method

McadGeometry::Geometry

McadGeometry::Geometry property

McadGeometry::GetAttributes

McadGeometry::GetAttributes method

McadGeometry::HasChanged

McadGeometry::HasChanged method

McadGeometry::RemoveAttribute

McadGeometry::RemoveAttribute method

McadHideSituation

McadHideSituation coclass

about McadHideSituation coclass

McadHideSituation interface

about IMcadHideSituation interface

AddMSSubent

AddMSSubents

AddSubent

AddSubents

AutoSelectBackground

BgSelectionName

ClearSubents

Concealed

ContoursOnlyInForeground

Definition

FgSelectionName

HiddenLinesInvisible

HideAppropriateObjectsOnly

IgnoreBgExclude

IgnoreFgExclude

IgnoreUpperBgExclude

IMcadHideSituation members

InverseForeground

IsComplexHideLevel

IsLastLevel

IsMigrated

IsModifiedStandardPartHide

IsStandardPartHide

LevelIndex

Name

OuterContourOnly

ParentHide

RemoveSubent

RemoveSubentByIdx

SaveSimplifiedOuterContour

Subents

Suppressed

SwapFgAndBg

SysName

McadHideSituation::AddMSSubent

McadHideSituation::AddMSSubent method

McadHideSituation::AddMSSubents

McadHideSituation::AddMSSubents method

McadHideSituation::AddSubent

McadHideSituation::AddSubent method

McadHideSituation::AddSubents

McadHideSituation::AddSubents method

McadHideSituation::AutoSelectBackground

McadHideSituation::AutoSelectBackground method

McadHideSituation::BgSelectionName

McadHideSituation::BgSelectionName property

McadHideSituation::ClearSubents

McadHideSituation::ClearSubents method

McadHideSituation::Concealed

McadHideSituation::Concealed property

McadHideSituation::ContoursOnlyInForeground

McadHideSituation::ContoursOnlyInForeground property

McadHideSituation::Definition

McadHideSituation::Definition property

McadHideSituation::FgSelectionName

McadHideSituation::FgSelectionName property

McadHideSituation::HiddenLinesInvisible

McadHideSituation::HiddenLinesInvisible property

McadHideSituation::HideAppropriateObjectsOnly

McadHideSituation::HideAppropriateObjectsOnly property

McadHideSituation::IgnoreBgExclude

McadHideSituation::IgnoreBgExclude property

McadHideSituation::IgnoreFgExclude

McadHideSituation::IgnoreFgExclude property

McadHideSituation::IgnoreUpperBgExclude

McadHideSituation::IgnoreUpperBgExclude property

McadHideSituation::InverseForeground

McadHideSituation::InverseForeground property

McadHideSituation::IsComplexHideLevel

McadHideSituation::IsComplexHideLevel property

McadHideSituation::IsLastLevel

McadHideSituation::IsLastLevel property

McadHideSituation::IsMigrated

McadHideSituation::IsMigrated property

McadHideSituation::IsModifiedStandardPartHide

McadHideSituation::IsModifiedStandardPartHide property

McadHideSituation::IsStandardPartHide

McadHideSituation::IsStandardPartHide property

McadHideSituation::LevelIndex

McadHideSituation::LevelIndex property

McadHideSituation::Name

McadHideSituation::Name property

McadHideSituation::OuterContourOnly

McadHideSituation::OuterContourOnly property

McadHideSituation::ParentHide

McadHideSituation::ParentHide property

McadHideSituation::RemoveSubent

McadHideSituation::RemoveSubent method

McadHideSituation::RemoveSubentByIdx

McadHideSituation::RemoveSubentByIdx method

McadHideSituation::SaveSimplifiedOuterContour

McadHideSituation::SaveSimplifiedOuterContour property

McadHideSituation::Subents

McadHideSituation::Subents method

McadHideSituation::Suppressed

McadHideSituation::Suppressed property

McadHideSituation::SwapFgAndBg

McadHideSituation::SwapFgAndBg method

McadHideSituation::SysName

McadHideSituation::SysName property

McadHideSituationRefType

McadHideSituationRefType enumeration

McadHideSituations

McadHideSituations coclass

about McadHideSituations coclass

McadHideSituations interface

about IMcadHideSituations interface

Add

Application

Count

IMcadHideSituations members

Item

Remove

McadHideSituations::Add

McadHideSituations::Add method

McadHideSituations::Application

McadHideSituations::Application property

McadHideSituations::Count

McadHideSituations::Count property

McadHideSituations::Item

McadHideSituations::Item method

McadHideSituations::Remove

McadHideSituations::Remove method

McadHideSituationSubentType

McadHideSituationSubentType enumeration

McadIdentificationType

McadIdentificationType enumeration

McadIdentifier

McadIdentifier coclass

about McadIdentifier coclass

McadIdentifier interface

about IMcadIdentifier interface

IMcadIdentifier members

Value

McadIdentifier::Value

McadIdentifier::Value property

McadIdentifierPositionType

McadIdentifierPositionType enumeration

McadIdentifierStandard

McadIdentifierStandard coclass

about McadIdentifierStandard coclass

McadIdentifierStandard interface

about IMcadIdentifierStandard interface

DefaultArrowType

IMcadIdentifierStandard members

IsDatumIDSupported

IsFeatureIDSupported

McadIdentifierStandard::DefaultArrowType

McadIdentifierStandard::DefaultArrowType property

McadIdentifierStandard::IsDatumIDSupported

McadIdentifierStandard::IsDatumIDSupported property

McadIdentifierStandard::IsFeatureIDSupported

McadIdentifierStandard::IsFeatureIDSupported property

McadIdentifierStandard2

McadIdentifierStandard2 interface

about IMcadIdentifierStandard2 interface

FarSideLeaderLineType

FarSideLeaderLineTypeName

IMcadIdentifierStandard2 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadIdentifierStandard2::FarSideLeaderLineType

McadIdentifierStandard2::FarSideLeaderLineType property

McadIdentifierStandard2::FarSideLeaderLineTypeName

McadIdentifierStandard2::FarSideLeaderLineTypeName property

McadIdentifierStandard2::SurfIndLeaderArrowScale

McadIdentifierStandard2::SurfIndLeaderArrowScale property

McadIdentifierStandard2::SurfIndLeaderArrowType

McadIdentifierStandard2::SurfIndLeaderArrowType property

McadJoint

McadJoint coclass

about McadJoint coclass

McadJoint interface

about IMcadJoint interface

AllAround

Annotation

IMcadJoint members

Orientation

SecAnnotation

SymbolType

McadJoint::AllAround

McadJoint::AllAround property

McadJoint::Annotation

McadJoint::Annotation property

McadJoint::Orientation

McadJoint::Orientation property

McadJoint::SecAnnotation

McadJoint::SecAnnotation property

McadJoint::SymbolType

McadJoint::SymbolType property

McadJointStandard

McadJointStandard coclass

about McadJointStandard coclass

McadJointStandard interface

about IMcadJointStandard interface

McadJointType

McadJointType enumeration

McadLayerCfg

McadLayerCfg coclass

about McadLayerCfg coclass

McadLayerCfg interface

about IMcadLayerCfg interface

AssocObjects

Desc

IMcadLayerCfg members

Invisible

Key

LineType

LineTypeId

LineTypeId32

LineWeight

Name

NoPlot

NoReplicateInLayerGroup

OverrideColorByLayerGroup

TrueColor

McadLayerCfg::AssocObjects

McadLayerCfg::AssocObjects property

McadLayerCfg::Desc

McadLayerCfg::Desc property

McadLayerCfg::Invisible

McadLayerCfg::Invisible property

McadLayerCfg::Key

McadLayerCfg::Key property

McadLayerCfg::LineType

McadLayerCfg::LineType property

McadLayerCfg::LineTypeId

McadLayerCfg::LineTypeId property

McadLayerCfg::LineTypeId32

McadLayerCfg::LineTypeId32 property

McadLayerCfg::LineWeight

McadLayerCfg::LineWeight property

McadLayerCfg::Name

McadLayerCfg::Name property

McadLayerCfg::NoPlot

McadLayerCfg::NoPlot property

McadLayerCfg::NoReplicateInLayerGroup

McadLayerCfg::NoReplicateInLayerGroup property

McadLayerCfg::OverrideColorByLayerGroup

McadLayerCfg::OverrideColorByLayerGroup property

McadLayerCfg::TrueColor

McadLayerCfg::TrueColor property

McadLayerCfgs

McadLayerCfgs coclass

about McadLayerCfgs coclass

McadLayerCfgs interface

_NewEnum

about IMcadLayerCfgs interface

Add

Application

Count

IMcadLayerCfgs members

Item

Remove

McadLayerCfgs::_NewEnum

McadLayerCfgs::_NewEnum property

McadLayerCfgs::Add

McadLayerCfgs::Add method

McadLayerCfgs::Application

McadLayerCfgs::Application property

McadLayerCfgs::Count

McadLayerCfgs::Count property

McadLayerCfgs::Item

McadLayerCfgs::Item method

McadLayerCfgs::Remove

McadLayerCfgs::Remove method

McadLayerGroupMgr

McadLayerGroupMgr coclass

about McadLayerGroupMgr coclass

McadLayerGroupMgr interface

about IMcadLayerGroupMgr interface

Document

GetLayerGroupEntities

GetLayerGroupEntities32

GetLayerGroupNames

GetLayersFromGroup

IMcadLayerGroupMgr members

MoveLayerGroupEntities

McadLayerGroupMgr::Document

McadLayerGroupMgr::Document property

McadLayerGroupMgr::GetLayerGroupEntities

McadLayerGroupMgr::GetLayerGroupEntities method

McadLayerGroupMgr::GetLayerGroupEntities32

McadLayerGroupMgr::GetLayerGroupEntities32 method

McadLayerGroupMgr::GetLayerGroupNames

McadLayerGroupMgr::GetLayerGroupNames method

McadLayerGroupMgr::GetLayersFromGroup

McadLayerGroupMgr::GetLayersFromGroup method

McadLayerGroupMgr::MoveLayerGroupEntities

McadLayerGroupMgr::MoveLayerGroupEntities method

McadLayerObjectCfg

McadLayerObjectCfg coclass

about McadLayerObjectCfg coclass

McadLayerObjectCfg interface

about IMcadLayerObjectCfg interface

Hide

IMcadLayerObjectCfg members

LayerName

LayerObjKey

LineType

LineTypeId

LineTypeId32

LineWeight

TrueColor

McadLayerObjectCfg::Hide

McadLayerObjectCfg::Hide property

McadLayerObjectCfg::LayerName

McadLayerObjectCfg::LayerName property

McadLayerObjectCfg::LayerObjKey

McadLayerObjectCfg::LayerObjKey property

McadLayerObjectCfg::LineType

McadLayerObjectCfg::LineType property

McadLayerObjectCfg::LineTypeId

McadLayerObjectCfg::LineTypeId property

McadLayerObjectCfg::LineTypeId32

McadLayerObjectCfg::LineTypeId32 property

McadLayerObjectCfg::LineWeight

McadLayerObjectCfg::LineWeight property

McadLayerObjectCfg::TrueColor

McadLayerObjectCfg::TrueColor property

McadLayerObjectCfgs

McadLayerObjectCfgs coclass

about McadLayerObjectCfgs coclass

McadLayerObjectCfgs interface

_NewEnum

about IMcadLayerObjectCfgs interface

Add

Application

Count

IMcadLayerObjectCfgs members

Item

Remove

McadLayerObjectCfgs::_NewEnum

McadLayerObjectCfgs::_NewEnum property

McadLayerObjectCfgs::Add

McadLayerObjectCfgs::Add method

McadLayerObjectCfgs::Application

McadLayerObjectCfgs::Application property

McadLayerObjectCfgs::Count

McadLayerObjectCfgs::Count property

McadLayerObjectCfgs::Item

McadLayerObjectCfgs::Item method

McadLayerObjectCfgs::Remove

McadLayerObjectCfgs::Remove method

McadLayerObjectHideType

McadLayerObjectHideType enumeration

McadLayerObjectMgr

McadLayerObjectMgr coclass

about McadLayerObjectMgr coclass

McadLayerObjectMgr interface

about IMcadLayerObjectMgr interface

CreateLayer

Document

GetAllLayerObjs

GetAllLayers

GetLayerObjProperty

GetLayerProperty

IMcadLayerObjectMgr members

ImportLayerObj

SetLayerObjDefault

McadLayerObjectMgr::CreateLayer

McadLayerObjectMgr::CreateLayer method

McadLayerObjectMgr::Document

McadLayerObjectMgr::Document property

McadLayerObjectMgr::GetAllLayerObjs

McadLayerObjectMgr::GetAllLayerObjs method

McadLayerObjectMgr::GetAllLayers

McadLayerObjectMgr::GetAllLayers method

McadLayerObjectMgr::GetLayerObjProperty

McadLayerObjectMgr::GetLayerObjProperty method

McadLayerObjectMgr::GetLayerProperty

McadLayerObjectMgr::GetLayerProperty method

McadLayerObjectMgr::ImportLayerObj

McadLayerObjectMgr::ImportLayerObj method

McadLayerObjectMgr::SetLayerObjDefault

McadLayerObjectMgr::SetLayerObjDefault method

McadLine

McadLine coclass

about McadLine coclass

McadLine interface

about IMcadLine interface

McadLineVisibility

McadLineVisibility enumeration

McadMarkStamp

McadMarkStamp coclass

about McadMarkStamp coclass

McadMarkStamp interface

about IMcadMarkStamp interface

ContentValue

IMcadMarkStamp members

MethodValue

SymbolType

TechnicalReqValue

McadMarkStamp::ContentValue

McadMarkStamp::ContentValue property

McadMarkStamp::MethodValue

McadMarkStamp::MethodValue property

McadMarkStamp::SymbolType

McadMarkStamp::SymbolType property

McadMarkStamp::TechnicalReqValue

McadMarkStamp::TechnicalReqValue property

McadMarkStampStandard

McadMarkStampStandard coclass

about McadMarkStampStandard coclass

McadMarkStampStandard interface

about IMcadMarkStampStandard interface

AvailableMarkingContents

AvailableMarkingMethods

AvailableStampingContents

AvailableStampingMethods

IMcadMarkStampStandard members

OfferedMarkingContents

OfferedMarkingMethods

OfferedStampingContents

OfferedStampingMethods

McadMarkStampStandard::AvailableMarkingContents

McadMarkStampStandard::AvailableMarkingContents property

McadMarkStampStandard::AvailableMarkingMethods

McadMarkStampStandard::AvailableMarkingMethods property

McadMarkStampStandard::AvailableStampingContents

McadMarkStampStandard::AvailableStampingContents property

McadMarkStampStandard::AvailableStampingMethods

McadMarkStampStandard::AvailableStampingMethods property

McadMarkStampStandard::OfferedMarkingContents

McadMarkStampStandard::OfferedMarkingContents property

McadMarkStampStandard::OfferedMarkingMethods

McadMarkStampStandard::OfferedMarkingMethods property

McadMarkStampStandard::OfferedStampingContents

McadMarkStampStandard::OfferedStampingContents property

McadMarkStampStandard::OfferedStampingMethods

McadMarkStampStandard::OfferedStampingMethods property

McadNote

McadNote coclass

about McadNote coclass

McadNote interface

about IMcadNote interface

AdjustLanding

CreateNoteText

EvaluatedNoteText

IMcadNote members

IsLeftOriented

Landing

LeaderAttachPoint

NoteText

TextAlignment

McadNote::AdjustLanding

McadNote::AdjustLanding method

McadNote::CreateNoteText

McadNote::CreateNoteText method

McadNote::EvaluatedNoteText

McadNote::EvaluatedNoteText property

McadNote::IsLeftOriented

McadNote::IsLeftOriented property

McadNote::Landing

McadNote::Landing property

McadNote::LeaderAttachPoint

McadNote::LeaderAttachPoint property

McadNote::NoteText

McadNote::NoteText property

McadNote::TextAlignment

McadNote::TextAlignment property

McadNoteAttachPointType

McadNoteAttachPointType enumeration

McadNoteStandard

McadNoteStandard coclass

about McadNoteStandard coclass

McadNoteStandard interface

about IMcadNoteStandard interface

AddTemplate

ChangeTemplateValue

DeleteAllTemplates

DeleteTemplate

GetAllTemplates

GetFeatureTypes

GetTemplateGroup

GetTemplateValue

IMcadNoteStandard members

Landing

LeaderAttachPoint

NumberOfTemplateGroups

RenameTemplate

SetCompatibilityCondition

SetToDefaultTemplate

McadNoteStandard::AddTemplate

McadNoteStandard::AddTemplate method

McadNoteStandard::ChangeTemplateValue

McadNoteStandard::ChangeTemplateValue method

McadNoteStandard::DeleteAllTemplates

McadNoteStandard::DeleteAllTemplates method

McadNoteStandard::DeleteTemplate

McadNoteStandard::DeleteTemplate method

McadNoteStandard::GetAllTemplates

McadNoteStandard::GetAllTemplates method

McadNoteStandard::GetFeatureTypes

McadNoteStandard::GetFeatureTypes method

McadNoteStandard::GetTemplateGroup

McadNoteStandard::GetTemplateGroup method

McadNoteStandard::GetTemplateValue

McadNoteStandard::GetTemplateValue method

McadNoteStandard::Landing

McadNoteStandard::Landing property

McadNoteStandard::LeaderAttachPoint

McadNoteStandard::LeaderAttachPoint property

McadNoteStandard::NumberOfTemplateGroups

McadNoteStandard::NumberOfTemplateGroups method

McadNoteStandard::RenameTemplate

McadNoteStandard::RenameTemplate method

McadNoteStandard::SetCompatibilityCondition

McadNoteStandard::SetCompatibilityCondition method

McadNoteStandard::SetToDefaultTemplate

McadNoteStandard::SetToDefaultTemplate method

McadNoteTemplateGroupType

McadNoteTemplateGroupType enumeration

McadObject

McadObject interface

about IMcadObject interface

Application

Delete

Document

Editable

Highlight

IMcadObject members

IsEqualTo

MakePersistent

WasErased

McadObject::Application

McadObject::Application property

McadObject::Delete

McadObject::Delete method

McadObject::Document

McadObject::Document property

McadObject::Editable

McadObject::Editable property

McadObject::Highlight

McadObject::Highlight method

McadObject::IsEqualTo

McadObject::IsEqualTo method

McadObject::MakePersistent

McadObject::MakePersistent method

McadObject::WasErased

McadObject::WasErased property

McadObjects

McadObjects coclass

about McadObjects coclass

McadObjects interface

about IMcadObjects interface

Add

Application

Count

IMcadObjects members

Item

Remove

McadObjects::Add

McadObjects::Add method

McadObjects::Application

McadObjects::Application property

McadObjects::Count

McadObjects::Count property

McadObjects::Item

McadObjects::Item method

McadObjects::Remove

McadObjects::Remove method

McadObjectType

McadObjectType enumeration

McadOrientation

McadOrientation enumeration

McadPartList

McadPartList coclass

about McadPartList coclass

McadPartList interface

about IMcadPartList interface

AddFilter

AttachmentPoint

BOM

CustomBlockName

CustomBlocks

FilterEmptyBlocks

Filters

Height

IMcadPartList members

IsCustomBlockUsed

IsHeadingEnabled

IsTitleEnabled

ItemList

MappingName

MultipleRow

RemoveFilter

Title

ViewID

ViewID32

Width

WrapText

McadPartList::AddFilter

McadPartList::AddFilter method

McadPartList::AttachmentPoint

McadPartList::AttachmentPoint property

McadPartList::BOM

McadPartList::BOM property

McadPartList::CustomBlockName

McadPartList::CustomBlockName property

McadPartList::CustomBlocks

McadPartList::CustomBlocks property

McadPartList::FilterEmptyBlocks

McadPartList::FilterEmptyBlocks property

McadPartList::Filters

McadPartList::Filters property

McadPartList::Height

McadPartList::Height property

McadPartList::IsCustomBlockUsed

McadPartList::IsCustomBlockUsed property

McadPartList::IsHeadingEnabled

McadPartList::IsHeadingEnabled property

McadPartList::IsTitleEnabled

McadPartList::IsTitleEnabled property

McadPartList::ItemList

McadPartList::ItemList property

McadPartList::MappingName

McadPartList::MappingName property

McadPartList::MultipleRow

McadPartList::MultipleRow property

McadPartList::RemoveFilter

McadPartList::RemoveFilter method

McadPartList::Title

McadPartList::Title property

McadPartList::ViewID

McadPartList::ViewID property

McadPartList::ViewID32

McadPartList::ViewID32 property

McadPartList::Width

McadPartList::Width property

McadPartList::WrapText

McadPartList::WrapText property

McadPartList2

McadPartList2 interface

about IMcadPartList2 interface

AddFilterType

ColumnSplitEnabled

ColumnSplitRows

ColumnSplitSections

ColumnSplitStyle

ColumnSplitWrap

FormulaBarEnabled

GripFrameEnabled

HeadingTextControl

IMcadPartList2 members

ResultBarEnabled

RowTextControl

McadPartList2::AddFilterType

McadPartList2::AddFilterType method

McadPartList2::ColumnSplitEnabled

McadPartList2::ColumnSplitEnabled property

McadPartList2::ColumnSplitRows

McadPartList2::ColumnSplitRows property

McadPartList2::ColumnSplitSections

McadPartList2::ColumnSplitSections property

McadPartList2::ColumnSplitStyle

McadPartList2::ColumnSplitStyle property

McadPartList2::ColumnSplitWrap

McadPartList2::ColumnSplitWrap property

McadPartList2::FormulaBarEnabled

McadPartList2::FormulaBarEnabled property

McadPartList2::GripFrameEnabled

McadPartList2::GripFrameEnabled property

McadPartList2::HeadingTextControl

McadPartList2::HeadingTextControl property

McadPartList2::ResultBarEnabled

McadPartList2::ResultBarEnabled property

McadPartList2::RowTextControl

McadPartList2::RowTextControl property

McadPartList3

McadPartList3 interface

about IMcadPartList3 interface

IMcadPartList3 members

setWrapPListAttachPoint

WrapAroundTitle

WrapTitleBlockId

WrapTitleBlockId32

McadPartList3::setWrapPListAttachPoint

McadPartList3::setWrapPListAttachPoint method

McadPartList3::WrapAroundTitle

McadPartList3::WrapAroundTitle property

McadPartList3::WrapTitleBlockId

McadPartList3::WrapTitleBlockId property

McadPartList3::WrapTitleBlockId32

McadPartList3::WrapTitleBlockId32 property

McadPartListBalloonedFilter

McadPartListBalloonedFilter coclass

about McadPartListBalloonedFilter coclass

McadPartListBalloonedFilter interface

about IMcadPartListBalloonedFilter interface

McadPartListCustomFilter

McadPartListCustomFilter coclass

about McadPartListCustomFilter coclass

McadPartListCustomFilter interface

about IMcadPartListCustomFilter interface

IMcadPartListCustomFilter members

Operator

PropertyName

PropertyValue

SetCondition

McadPartListCustomFilter::Operator

McadPartListCustomFilter::Operator property

McadPartListCustomFilter::PropertyName

McadPartListCustomFilter::PropertyName property

McadPartListCustomFilter::PropertyValue

McadPartListCustomFilter::PropertyValue property

McadPartListCustomFilter::SetCondition

McadPartListCustomFilter::SetCondition method

McadPartListFilter

McadPartListFilter coclass

about McadPartListFilter coclass

McadPartListFilter interface

about IMcadPartListFilter interface

Evaluate

IMcadPartListFilter members

IsOn

Name

McadPartListFilter::Evaluate

McadPartListFilter::Evaluate method

McadPartListFilter::IsOn

McadPartListFilter::IsOn property

McadPartListFilter::Name

McadPartListFilter::Name property

McadPartListFilter2

McadPartListFilter2 interface

about IMcadPartListFilter2 interface

Excluded

IMcadPartListFilter2 members

Type

McadPartListFilter2::Excluded

McadPartListFilter2::Excluded property

McadPartListFilter2::Type

McadPartListFilter2::Type property

McadPartListFilters

McadPartListFilters coclass

about McadPartListFilters coclass

McadPartListFilters interface

about IMcadPartListFilters interface

Add

Application

Count

IMcadPartListFilters members

Item

Remove

McadPartListFilters::Add

McadPartListFilters::Add method

McadPartListFilters::Application

McadPartListFilters::Application property

McadPartListFilters::Count

McadPartListFilters::Count property

McadPartListFilters::Item

McadPartListFilters::Item method

McadPartListFilters::Remove

McadPartListFilters::Remove method

McadPartListGOST

McadPartListGOST coclass

about McadPartListGOST coclass

McadPartListGOST interface

about IMcadPartListGOST interface

IMcadPartListGOST members

SkipAfterPart

SkipLines

McadPartListGOST::SkipAfterPart

McadPartListGOST::SkipAfterPart property

McadPartListGOST::SkipLines

McadPartListGOST::SkipLines property

McadPartLists

McadPartLists coclass

about McadPartLists coclass

McadPartLists interface

about IMcadPartLists interface

Add

Application

Count

IMcadPartLists members

Item

Remove

McadPartLists::Add

McadPartLists::Add method

McadPartLists::Application

McadPartLists::Application property

McadPartLists::Count

McadPartLists::Count property

McadPartLists::Item

McadPartLists::Item method

McadPartLists::Remove

McadPartLists::Remove method

McadPartListStandard

McadPartListStandard coclass

about McadPartListStandard coclass

McadPartListStandard interface

about IMcadPartListStandard interface

ActualRowTextHeight

Application

AttachmentPoint

BOMStandard

ColumnList

CustomBlockName

CustomBlocks

FilterEmptyBlocks

FrameColor

HeadingGap

HeadingHeight

HeadingTextColor

HeadingTextHeight

IMcadPartListStandard members

IsCustomBlockUsed

IsHeadingEnabled

IsTitleEnabled

MulipleRow

RemoveColumn

Revision

RevisionYear

RowGap

RowHeight

SetToDefaults

UseMapping

WrapText

McadPartListStandard::ActualRowTextHeight

McadPartListStandard::ActualRowTextHeight property

McadPartListStandard::Application

McadPartListStandard::Application property

McadPartListStandard::AttachmentPoint

McadPartListStandard::AttachmentPoint property

McadPartListStandard::BOMStandard

McadPartListStandard::BOMStandard property

McadPartListStandard::ColumnList

McadPartListStandard::ColumnList property

McadPartListStandard::CustomBlockName

McadPartListStandard::CustomBlockName property

McadPartListStandard::CustomBlocks

McadPartListStandard::CustomBlocks property

McadPartListStandard::FilterEmptyBlocks

McadPartListStandard::FilterEmptyBlocks property

McadPartListStandard::FrameColor

McadPartListStandard::FrameColor property

McadPartListStandard::HeadingGap

McadPartListStandard::HeadingGap property

McadPartListStandard::HeadingHeight

McadPartListStandard::HeadingHeight property

McadPartListStandard::HeadingTextColor

McadPartListStandard::HeadingTextColor property

McadPartListStandard::HeadingTextHeight

McadPartListStandard::HeadingTextHeight property

McadPartListStandard::IsCustomBlockUsed

McadPartListStandard::IsCustomBlockUsed property

McadPartListStandard::IsHeadingEnabled

McadPartListStandard::IsHeadingEnabled property

McadPartListStandard::IsTitleEnabled

McadPartListStandard::IsTitleEnabled property

McadPartListStandard::MulipleRow

McadPartListStandard::MulipleRow property

McadPartListStandard::RemoveColumn

McadPartListStandard::RemoveColumn method

McadPartListStandard::Revision

McadPartListStandard::Revision property

McadPartListStandard::RevisionYear

McadPartListStandard::RevisionYear property

McadPartListStandard::RowGap

McadPartListStandard::RowGap property

McadPartListStandard::RowHeight

McadPartListStandard::RowHeight property

McadPartListStandard::SetToDefaults

McadPartListStandard::SetToDefaults method

McadPartListStandard::UseMapping

McadPartListStandard::UseMapping property

McadPartListStandard::WrapText

McadPartListStandard::WrapText property

McadPartListStandard2

McadPartListStandard2 interface

about IMcadPartListStandard2 interface

FrameTrueColor

HeadingTextTrueColor

IMcadPartListStandard2 members

McadPartListStandard2::FrameTrueColor

McadPartListStandard2::FrameTrueColor property

McadPartListStandard2::HeadingTextTrueColor

McadPartListStandard2::HeadingTextTrueColor property

McadPartListStandard3

McadPartListStandard3 interface

about IMcadPartListStandard3 interface

BoldVerticalLine

ColumnSplitEnabled

ColumnSplitRows

ColumnSplitSections

ColumnSplitStyle

ColumnSplitWrap

GripFrameEnabled

HeadingTextControl

HeadingTextMarginBottom

HeadingTextMarginLeft

HeadingTextMarginRight

HeadingTextMarginTop

HeadingTextStyle

IMcadPartListStandard3 members

RowTextColor

RowTextControl

RowTextHeight

RowTextMarginBottom

RowTextMarginLeft

RowTextMarginRight

RowTextMarginTop

RowTextStyle

RowTextTrueColor

McadPartListStandard3::BoldVerticalLine

McadPartListStandard3::BoldVerticalLine property

McadPartListStandard3::ColumnSplitEnabled

McadPartListStandard3::ColumnSplitEnabled property

McadPartListStandard3::ColumnSplitRows

McadPartListStandard3::ColumnSplitRows property

McadPartListStandard3::ColumnSplitSections

McadPartListStandard3::ColumnSplitSections property

McadPartListStandard3::ColumnSplitStyle

McadPartListStandard3::ColumnSplitStyle property

McadPartListStandard3::ColumnSplitWrap

McadPartListStandard3::ColumnSplitWrap property

McadPartListStandard3::GripFrameEnabled

McadPartListStandard3::GripFrameEnabled property

McadPartListStandard3::HeadingTextControl

McadPartListStandard3::HeadingTextControl property

McadPartListStandard3::HeadingTextMarginBottom

McadPartListStandard3::HeadingTextMarginBottom property

McadPartListStandard3::HeadingTextMarginLeft

McadPartListStandard3::HeadingTextMarginLeft property

McadPartListStandard3::HeadingTextMarginRight

McadPartListStandard3::HeadingTextMarginRight property

McadPartListStandard3::HeadingTextMarginTop

McadPartListStandard3::HeadingTextMarginTop property

McadPartListStandard3::HeadingTextStyle

McadPartListStandard3::HeadingTextStyle property

McadPartListStandard3::RowTextColor

McadPartListStandard3::RowTextColor property

McadPartListStandard3::RowTextControl

McadPartListStandard3::RowTextControl property

McadPartListStandard3::RowTextHeight

McadPartListStandard3::RowTextHeight property

McadPartListStandard3::RowTextMarginBottom

McadPartListStandard3::RowTextMarginBottom property

McadPartListStandard3::RowTextMarginLeft

McadPartListStandard3::RowTextMarginLeft property

McadPartListStandard3::RowTextMarginRight

McadPartListStandard3::RowTextMarginRight property

McadPartListStandard3::RowTextMarginTop

McadPartListStandard3::RowTextMarginTop property

McadPartListStandard3::RowTextStyle

McadPartListStandard3::RowTextStyle property

McadPartListStandard3::RowTextTrueColor

McadPartListStandard3::RowTextTrueColor property

McadPartListStandard4

McadPartListStandard4 interface

about IMcadPartListStandard4 interface

ColumnSplitWrapAroundTitle

IMcadPartListStandard4 members

McadPartListStandard4::ColumnSplitWrapAroundTitle

McadPartListStandard4::ColumnSplitWrapAroundTitle property

McadPartListStdPartsFilter

McadPartListStdPartsFilter coclass

about McadPartListStdPartsFilter coclass

McadPartListStdPartsFilter interface

about IMcadPartListStdPartsFilter interface

IMcadPartListStdPartsFilter members

Option

McadPartListStdPartsFilter::Option

McadPartListStdPartsFilter::Option property

McadPartReference

McadPartReference coclass

about McadPartReference coclass

McadPartReference interface

about IMcadPartReference interface

Data

IMcadPartReference members

Quantity

McadPartReference::Data

McadPartReference::Data property

McadPartReference::Quantity

McadPartReference::Quantity property

McadPartReference2

McadPartReference2 interface

about IMcadPartReference2 interface

IMcadPartReference2 members

SetAttributePreDefinedListValue

McadPartReference2::SetAttributePreDefinedListValue

McadPartReference2::SetAttributePreDefinedListValue method

McadPartReference3

McadPartReference3 interface

about IMcadPartReference3 interface

AttachedExternalBom

AttachedExternalBomXrefBlock

AttachExternalBom

DetachExternalBom

GetBomOverride

IMcadPartReference3 members

RemoveAttribute

McadPartReference3::AttachedExternalBom

McadPartReference3::AttachedExternalBom property

McadPartReference3::AttachedExternalBomXrefBlock

McadPartReference3::AttachedExternalBomXrefBlock property

McadPartReference3::AttachExternalBom

McadPartReference3::AttachExternalBom method

McadPartReference3::DetachExternalBom

McadPartReference3::DetachExternalBom method

McadPartReference3::GetBomOverride

McadPartReference3::GetBomOverride method

McadPartReference3::RemoveAttribute

McadPartReference3::RemoveAttribute method

McadPartReferences

McadPartReferences coclass

about McadPartReferences coclass

McadPartReferences interface

_NewEnum

about IMcadPartReferences interface

Add

Application

Count

IMcadPartReferences members

Item

Remove

McadPartReferences::_NewEnum

McadPartReferences::_NewEnum property

McadPartReferences::Add

McadPartReferences::Add method

McadPartReferences::Application

McadPartReferences::Application property

McadPartReferences::Count

McadPartReferences::Count property

McadPartReferences::Item

McadPartReferences::Item method

McadPartReferences::Remove

McadPartReferences::Remove method

McadPhantomState

McadPhantomState enumeration

McadPick

McadPick coclass

about McadPick coclass

McadPick interface

about IMcadPick interface

Application

IMcadPick members

ObjectType

PickPoint

McadPick::Application

McadPick::Application property

McadPick::ObjectType

McadPick::ObjectType property

McadPick::PickPoint

McadPick::PickPoint property

McadPolyline

McadPolyline coclass

about McadPolyline coclass

McadPolyline interface

about IMcadPolyline interface

McadPowerObjectType

McadPowerObjectType enumeration

McadPowObjViewGroupDescriptor

McadPowObjViewGroupDescriptor coclass

about McadPowObjViewGroupDescriptor coclass

McadPowObjViewGroupDescriptor interface

about IMcadPowObjViewGroupDescriptor interface

Entities

Entities32

IMcadPowObjViewGroupDescriptor members

PowerObjectType

TargetView

McadPowObjViewGroupDescriptor::Entities

McadPowObjViewGroupDescriptor::Entities property

McadPowObjViewGroupDescriptor::Entities32

McadPowObjViewGroupDescriptor::Entities32 property

McadPowObjViewGroupDescriptor::PowerObjectType

McadPowObjViewGroupDescriptor::PowerObjectType property

McadPowObjViewGroupDescriptor::TargetView

McadPowObjViewGroupDescriptor::TargetView property

McadRevisionList

McadRevisionList coclass

about McadRevisionList coclass

McadRevisionList interface

about IMcadRevisionList interface

Add

Border

Border32

Count

IMcadRevisionList members

Item

Position

Ref

Ref32

Set

McadRevisionList::Add

McadRevisionList::Add method

McadRevisionList::Border

McadRevisionList::Border property

McadRevisionList::Border32

McadRevisionList::Border32 property

McadRevisionList::Count

McadRevisionList::Count property

McadRevisionList::Item

McadRevisionList::Item method

McadRevisionList::Position

McadRevisionList::Position property

McadRevisionList::Ref

McadRevisionList::Ref property

McadRevisionList::Ref32

McadRevisionList::Ref32 property

McadRevisionList::Set

McadRevisionList::Set method

McadRevisionListDescriptor

McadRevisionListDescriptor coclass

about McadRevisionListDescriptor coclass

McadRevisionListDescriptor interface

about IMcadRevisionListDescriptor interface

Attributes

Border

Border32

IMcadRevisionListDescriptor members

Position

McadRevisionListDescriptor::Attributes

McadRevisionListDescriptor::Attributes property

McadRevisionListDescriptor::Border

McadRevisionListDescriptor::Border property

McadRevisionListDescriptor::Border32

McadRevisionListDescriptor::Border32 property

McadRevisionListDescriptor::Position

McadRevisionListDescriptor::Position property

McadRevisionLists

McadRevisionLists coclass

about McadRevisionLists coclass

McadRevisionLists interface

about IMcadRevisionLists interface

Application

Count

IMcadRevisionLists members

Item

McadRevisionLists::Application

McadRevisionLists::Application property

McadRevisionLists::Count

McadRevisionLists::Count property

McadRevisionLists::Item

McadRevisionLists::Item method

McadRevisionMgr

McadRevisionMgr coclass

about McadRevisionMgr coclass

McadRevisionMgr interface

about IMcadRevisionMgr interface

CreateRevisionList

DeleteRevisionList

GetRevisionListFromRef

IMcadRevisionMgr members

NewDescriptor

RevisionLists

McadRevisionMgr::CreateRevisionList

McadRevisionMgr::CreateRevisionList method

McadRevisionMgr::DeleteRevisionList

McadRevisionMgr::DeleteRevisionList method

McadRevisionMgr::GetRevisionListFromRef

McadRevisionMgr::GetRevisionListFromRef method

McadRevisionMgr::NewDescriptor

McadRevisionMgr::NewDescriptor method

McadRevisionMgr::RevisionLists

McadRevisionMgr::RevisionLists property

McadScaleArea

McadScaleArea coclass

about McadScaleArea coclass

McadScaleArea interface

about IMcadScaleArea interface

AttachObjectId

AttachObjectId32

CreateViewPort

DeleteViewPort

GetAttachedViewportIds

GetAttachedViewportIds32

IMcadScaleArea members

LengthScalingFactor

MoveBorder

RescaleObjects

ScaleType

SetBasicScale

TextScalingFactor

McadScaleArea::AttachObjectId

McadScaleArea::AttachObjectId property

McadScaleArea::AttachObjectId32

McadScaleArea::AttachObjectId32 property

McadScaleArea::CreateViewPort

McadScaleArea::CreateViewPort method

McadScaleArea::DeleteViewPort

McadScaleArea::DeleteViewPort method

McadScaleArea::GetAttachedViewportIds

McadScaleArea::GetAttachedViewportIds method

McadScaleArea::GetAttachedViewportIds32

McadScaleArea::GetAttachedViewportIds32 method

McadScaleArea::LengthScalingFactor

McadScaleArea::LengthScalingFactor property

McadScaleArea::MoveBorder

McadScaleArea::MoveBorder method

McadScaleArea::RescaleObjects

McadScaleArea::RescaleObjects method

McadScaleArea::ScaleType

McadScaleArea::ScaleType property

McadScaleArea::SetBasicScale

McadScaleArea::SetBasicScale method

McadScaleArea::TextScalingFactor

McadScaleArea::TextScalingFactor property

McadScaleAreaMgr

McadScaleAreaMgr coclass

about McadScaleAreaMgr coclass

McadScaleAreaMgr interface

about IMcadScaleAreaMgr interface

CreateScaleArea

DeleteScaleArea

FindScaleArea

IMcadScaleAreaMgr members

McadScaleAreaMgr::CreateScaleArea

McadScaleAreaMgr::CreateScaleArea method

McadScaleAreaMgr::DeleteScaleArea

McadScaleAreaMgr::DeleteScaleArea method

McadScaleAreaMgr::FindScaleArea

McadScaleAreaMgr::FindScaleArea method

McadScaleType

McadScaleType enumeration

McadSectionLine

McadSectionLine coclass

about McadSectionLine coclass

McadSectionLine interface

about IMcadSectionLine interface

AddSectionPoint

ArrowVisibility

IMcadSectionLine members

LabelName

LabelNamesCount

LabelPattern

LabelText

LabelVisibility

LineVisibility

PlaneSymbolsVisibility

SectionPoints

SectionSide

SetLabelNames

SetSectionArcPointAt

SetSectionPointAt

SetSectionPoints

SetSectionViewOrigin

McadSectionLine::AddSectionPoint

McadSectionLine::AddSectionPoint method

McadSectionLine::ArrowVisibility

McadSectionLine::ArrowVisibility property

McadSectionLine::LabelName

McadSectionLine::LabelName method

McadSectionLine::LabelNamesCount

McadSectionLine::LabelNamesCount property

McadSectionLine::LabelPattern

McadSectionLine::LabelPattern property

McadSectionLine::LabelText

McadSectionLine::LabelText property

McadSectionLine::LabelVisibility

McadSectionLine::LabelVisibility property

McadSectionLine::LineVisibility

McadSectionLine::LineVisibility property

McadSectionLine::PlaneSymbolsVisibility

McadSectionLine::PlaneSymbolsVisibility property

McadSectionLine::SectionPoints

McadSectionLine::SectionPoints property

McadSectionLine::SectionSide

McadSectionLine::SectionSide property

McadSectionLine::SetLabelNames

McadSectionLine::SetLabelNames method

McadSectionLine::SetSectionArcPointAt

McadSectionLine::SetSectionArcPointAt method

McadSectionLine::SetSectionPointAt

McadSectionLine::SetSectionPointAt method

McadSectionLine::SetSectionPoints

McadSectionLine::SetSectionPoints method

McadSectionLine::SetSectionViewOrigin

McadSectionLine::SetSectionViewOrigin method

McadSectionLineSegmentType

McadSectionLineSegmentType enumeration

McadSectionLineStandard

McadSectionLineStandard coclass

about McadSectionLineStandard coclass

McadSectionLineStandard interface

about IMcadSectionLineStandard interface

ArrowTowardsLine

ArrowVisibility

IMcadSectionLineStandard members

LabelAbove

LabelPattern

LabelVisibility

LineColor

LineTrueColor

LineVisibility

LineWeight

MultipleNamesSupported

PlaneSymbolsVisibility

McadSectionLineStandard::ArrowTowardsLine

McadSectionLineStandard::ArrowTowardsLine property

McadSectionLineStandard::ArrowVisibility

McadSectionLineStandard::ArrowVisibility property

McadSectionLineStandard::LabelAbove

McadSectionLineStandard::LabelAbove property

McadSectionLineStandard::LabelPattern

McadSectionLineStandard::LabelPattern property

McadSectionLineStandard::LabelVisibility

McadSectionLineStandard::LabelVisibility property

McadSectionLineStandard::LineColor

McadSectionLineStandard::LineColor property

McadSectionLineStandard::LineTrueColor

McadSectionLineStandard::LineTrueColor property

McadSectionLineStandard::LineVisibility

McadSectionLineStandard::LineVisibility property

McadSectionLineStandard::LineWeight

McadSectionLineStandard::LineWeight property

McadSectionLineStandard::MultipleNamesSupported

McadSectionLineStandard::MultipleNamesSupported property

McadSectionLineStandard::PlaneSymbolsVisibility

McadSectionLineStandard::PlaneSymbolsVisibility property

McadSectionLineStandard2

McadSectionLineStandard2 interface

about IMcadSectionLineStandard2 interface

ArrowLineLength

BendLineLength

EndArrowType

EndBendLineType

EndLineLength

EndLineOvershoot

GetByStandard

IdentifierExcludeCharacters

IdentifierOffset

IdentifierPosition

IMcadSectionLineStandard2 members

LabelOffset

LabelTextColor

LabelTextHeight

LabelTextStyle

PlaneLineColor

PlaneLineType

PlaneLineWeight

SetByStandard

McadSectionLineStandard2::ArrowLineLength

McadSectionLineStandard2::ArrowLineLength property

McadSectionLineStandard2::BendLineLength

McadSectionLineStandard2::BendLineLength property

McadSectionLineStandard2::EndArrowType

McadSectionLineStandard2::EndArrowType property

McadSectionLineStandard2::EndBendLineType

McadSectionLineStandard2::EndBendLineType property

McadSectionLineStandard2::EndLineLength

McadSectionLineStandard2::EndLineLength property

McadSectionLineStandard2::EndLineOvershoot

McadSectionLineStandard2::EndLineOvershoot property

McadSectionLineStandard2::GetByStandard

McadSectionLineStandard2::GetByStandard method

McadSectionLineStandard2::IdentifierExcludeCharacters

McadSectionLineStandard2::IdentifierExcludeCharacters property

McadSectionLineStandard2::IdentifierOffset

McadSectionLineStandard2::IdentifierOffset property

McadSectionLineStandard2::IdentifierPosition

McadSectionLineStandard2::IdentifierPosition property

McadSectionLineStandard2::LabelOffset

McadSectionLineStandard2::LabelOffset property

McadSectionLineStandard2::LabelTextColor

McadSectionLineStandard2::LabelTextColor property

McadSectionLineStandard2::LabelTextHeight

McadSectionLineStandard2::LabelTextHeight property

McadSectionLineStandard2::LabelTextStyle

McadSectionLineStandard2::LabelTextStyle property

McadSectionLineStandard2::PlaneLineColor

McadSectionLineStandard2::PlaneLineColor property

McadSectionLineStandard2::PlaneLineType

McadSectionLineStandard2::PlaneLineType property

McadSectionLineStandard2::PlaneLineWeight

McadSectionLineStandard2::PlaneLineWeight property

McadSectionLineStandard2::SetByStandard

McadSectionLineStandard2::SetByStandard method

McadSectionLineStandardPropType

McadSectionLineStandardPropType enumeration

McadSelectionOrderOption

McadSelectionOrderOption enumeration

McadSpline

McadSpline coclass

about McadSpline coclass

McadSpline interface

about IMcadSpline interface

McadStandard

McadStandard coclass

about McadStandard coclass

McadStandard interface

about IMcadStandard interface

AddSymbolStandard

AllSymbolStandards

ArrowScale

ArrowType

BaseName

BOMStandard

Current

CurrentSymbolStandards

DatumStandard

FCFStandard

GetCurrentSymbolStandard

IdentifierStandard

IMcadStandard members

IsMetric

LeaderColor

Name

RemoveSymbolStandard

Scale

SetCurrentSymbolStandard

SetToDefaults

StandardMgr

SurfaceTextureStandard

SymbolColor

SymbolStandardsSupported

TextColor

TextHeight

TextHeightList

TextStyle

TextStyleName

WeldingStandard

McadStandard::AddSymbolStandard

McadStandard::AddSymbolStandard method

McadStandard::AllSymbolStandards

McadStandard::AllSymbolStandards property

McadStandard::ArrowScale

McadStandard::ArrowScale property

McadStandard::ArrowType

McadStandard::ArrowType property

McadStandard::BaseName

McadStandard::BaseName property

McadStandard::BOMStandard

McadStandard::BOMStandard property

McadStandard::Current

McadStandard::Current property

McadStandard::CurrentSymbolStandards

McadStandard::CurrentSymbolStandards property

McadStandard::DatumStandard

McadStandard::DatumStandard property

McadStandard::FCFStandard

McadStandard::FCFStandard property

McadStandard::GetCurrentSymbolStandard

McadStandard::GetCurrentSymbolStandard method

McadStandard::IdentifierStandard

McadStandard::IdentifierStandard property

McadStandard::IsMetric

McadStandard::IsMetric property

McadStandard::LeaderColor

McadStandard::LeaderColor property

McadStandard::Name

McadStandard::Name property

McadStandard::RemoveSymbolStandard

McadStandard::RemoveSymbolStandard method

McadStandard::Scale

McadStandard::Scale property

McadStandard::SetCurrentSymbolStandard

McadStandard::SetCurrentSymbolStandard method

McadStandard::SetToDefaults

McadStandard::SetToDefaults method

McadStandard::StandardMgr

McadStandard::StandardMgr property

McadStandard::SurfaceTextureStandard

McadStandard::SurfaceTextureStandard property

McadStandard::SymbolColor

McadStandard::SymbolColor property

McadStandard::SymbolStandardsSupported

McadStandard::SymbolStandardsSupported property

McadStandard::TextColor

McadStandard::TextColor property

McadStandard::TextHeight

McadStandard::TextHeight property

McadStandard::TextHeightList

McadStandard::TextHeightList property

McadStandard::TextStyle

McadStandard::TextStyle property

McadStandard::TextStyleName

McadStandard::TextStyleName property

McadStandard::WeldingStandard

McadStandard::WeldingStandard property

McadStandard2

McadStandard2 interface

about IMcadStandard2 interface

IMcadStandard2 members

LeaderTrueColor

SymbolTrueColor

TextTrueColor

McadStandard2::LeaderTrueColor

McadStandard2::LeaderTrueColor property

McadStandard2::SymbolTrueColor

McadStandard2::SymbolTrueColor property

McadStandard2::TextTrueColor

McadStandard2::TextTrueColor property

McadStandard3

McadStandard3 interface

about IMcadStandard3 interface

AnnotationViewStandard

DetailSymbolStandard

EdgeStandard

IMcadStandard3 members

MarkStampStandard

NoteStandard

TaperStandard

TitleBorderStandard

McadStandard3::AnnotationViewStandard

McadStandard3::AnnotationViewStandard property

McadStandard3::DetailSymbolStandard

McadStandard3::DetailSymbolStandard property

McadStandard3::EdgeStandard

McadStandard3::EdgeStandard property

McadStandard3::MarkStampStandard

McadStandard3::MarkStampStandard property

McadStandard3::NoteStandard

McadStandard3::NoteStandard property

McadStandard3::TaperStandard

McadStandard3::TaperStandard property

McadStandard3::TitleBorderStandard

McadStandard3::TitleBorderStandard property

McadStandard4

McadStandard4 interface

about IMcadStandard4 interface

IMcadStandard4 members

JointStandard

SectionLineStandard

SupportedArrowTypes

McadStandard4::JointStandard

McadStandard4::JointStandard property

McadStandard4::SectionLineStandard

McadStandard4::SectionLineStandard property

McadStandard4::SupportedArrowTypes

McadStandard4::SupportedArrowTypes method

McadStandardMgr

McadStandardMgr coclass

about McadStandardMgr coclass

McadStandardMgr interface

about IMcadStandardMgr interface

AddStandard

Application

CopyStandard

CurrentStandard

CurrentStandardName

DefaultStandard

GetStandard

IMcadStandardMgr members

RemoveStandard

StandardCount

StandardNames

Standards

SymbolBBMgr

UpdateSymbols

McadStandardMgr::AddStandard

McadStandardMgr::AddStandard method

McadStandardMgr::Application

McadStandardMgr::Application property

McadStandardMgr::CopyStandard

McadStandardMgr::CopyStandard method

McadStandardMgr::CurrentStandard

McadStandardMgr::CurrentStandard property

McadStandardMgr::CurrentStandardName

McadStandardMgr::CurrentStandardName property

McadStandardMgr::DefaultStandard

McadStandardMgr::DefaultStandard property

McadStandardMgr::GetStandard

McadStandardMgr::GetStandard method

McadStandardMgr::RemoveStandard

McadStandardMgr::RemoveStandard method

McadStandardMgr::StandardCount

McadStandardMgr::StandardCount property

McadStandardMgr::StandardNames

McadStandardMgr::StandardNames property

McadStandardMgr::Standards

McadStandardMgr::Standards property

McadStandardMgr::SymbolBBMgr

McadStandardMgr::SymbolBBMgr property

McadStandardMgr::UpdateSymbols

McadStandardMgr::UpdateSymbols method

McadStandards

McadStandards coclass

about McadStandards coclass

McadStandards interface

about IMcadStandards interface

Add

Application

Count

IMcadStandards members

Item

Remove

McadStandards::Add

McadStandards::Add method

McadStandards::Application

McadStandards::Application property

McadStandards::Count

McadStandards::Count property

McadStandards::Item

McadStandards::Item method

McadStandards::Remove

McadStandards::Remove method

McadStdPartComponentViewDescriptor

McadStdPartComponentViewDescriptor coclass

about McadStdPartComponentViewDescriptor coclass

McadStdPartComponentViewDescriptor interface

about IMcadStdPartComponentViewDescriptor interface

McadStdPartsFilterOption

McadStdPartsFilterOption enumeration

McadSurfaceTexture

McadSurfaceTexture coclass

about McadSurfaceTexture coclass

McadSurfaceTexture interface

about IMcadSurfaceTexture interface

AllowanceValue

Angle

AutomaticAdjust

CommentValue

CutoffValue

IMcadSurfaceTexture members

IsAllAround

IsForceTail

IsMajority

LayDirection

LayDirectionValue

MaximumSpacingValue

OtherMinimumValue

OtherValue

Production2Value

ProductionValue

RaMaximumValue

RaMinimumValue

ReferenceValue

SamplingLengthValue

SurfaceTexture

WavinessValue

McadSurfaceTexture::AllowanceValue

McadSurfaceTexture::AllowanceValue property

McadSurfaceTexture::Angle

McadSurfaceTexture::Angle property

McadSurfaceTexture::AutomaticAdjust

McadSurfaceTexture::AutomaticAdjust property

McadSurfaceTexture::CommentValue

McadSurfaceTexture::CommentValue property

McadSurfaceTexture::CutoffValue

McadSurfaceTexture::CutoffValue property

McadSurfaceTexture::IsAllAround

McadSurfaceTexture::IsAllAround property

McadSurfaceTexture::IsForceTail

McadSurfaceTexture::IsForceTail property

McadSurfaceTexture::IsMajority

McadSurfaceTexture::IsMajority property

McadSurfaceTexture::LayDirection

McadSurfaceTexture::LayDirection property

McadSurfaceTexture::LayDirectionValue

McadSurfaceTexture::LayDirectionValue property

McadSurfaceTexture::MaximumSpacingValue

McadSurfaceTexture::MaximumSpacingValue property

McadSurfaceTexture::OtherMinimumValue

McadSurfaceTexture::OtherMinimumValue property

McadSurfaceTexture::OtherValue

McadSurfaceTexture::OtherValue property

McadSurfaceTexture::Production2Value

McadSurfaceTexture::Production2Value property

McadSurfaceTexture::ProductionValue

McadSurfaceTexture::ProductionValue property

McadSurfaceTexture::RaMaximumValue

McadSurfaceTexture::RaMaximumValue property

McadSurfaceTexture::RaMinimumValue

McadSurfaceTexture::RaMinimumValue property

McadSurfaceTexture::ReferenceValue

McadSurfaceTexture::ReferenceValue property

McadSurfaceTexture::SamplingLengthValue

McadSurfaceTexture::SamplingLengthValue property

McadSurfaceTexture::SurfaceTexture

McadSurfaceTexture::SurfaceTexture property

McadSurfaceTexture::WavinessValue

McadSurfaceTexture::WavinessValue property

McadSurfaceTexture2

McadSurfaceTexture2 interface

about IMcadSurfaceTexture2 interface

FirstRequirement

FourthRequirement

IMcadSurfaceTexture2 members

SecondRequirement

ThirdRequirement

McadSurfaceTexture2::FirstRequirement

McadSurfaceTexture2::FirstRequirement property

McadSurfaceTexture2::FourthRequirement

McadSurfaceTexture2::FourthRequirement property

McadSurfaceTexture2::SecondRequirement

McadSurfaceTexture2::SecondRequirement property

McadSurfaceTexture2::ThirdRequirement

McadSurfaceTexture2::ThirdRequirement property

McadSurfaceTexture3

McadSurfaceTexture3 interface

about IMcadSurfaceTexture3 interface

IMcadSurfaceTexture3 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadSurfaceTexture3::SurfExtLinesOffset

McadSurfaceTexture3::SurfExtLinesOffset property

McadSurfaceTexture3::SurfExtLinesOvershot

McadSurfaceTexture3::SurfExtLinesOvershot property

McadSurfaceTexture4

McadSurfaceTexture4 interface

about IMcadSurfaceTexture4 interface

AddSurfIndLeader

IMcadSurfaceTexture4 members

McadSurfaceTexture4::AddSurfIndLeader

McadSurfaceTexture4::AddSurfIndLeader method

McadSurfaceTexture5

McadSurfaceTexture5 interface

about IMcadSurfaceTexture5 interface

IMcadSurfaceTexture5 members

IsAttachToFCF

McadSurfaceTexture5::IsAttachToFCF

McadSurfaceTexture5::IsAttachToFCF method

McadSurfaceTextureLibrary

McadSurfaceTextureLibrary coclass

about McadSurfaceTextureLibrary coclass

McadSurfaceTextureLibrary interface

about IMcadSurfaceTextureLibrary interface

McadSurfaceTextureLibraryObject

McadSurfaceTextureLibraryObject coclass

about McadSurfaceTextureLibraryObject coclass

McadSurfaceTextureLibraryObject interface

about IMcadSurfaceTextureLibraryObject interface

IMcadSurfaceTextureLibraryObject members

IsAllAround

IsForceTail

IsMajority

RequirementValue

SubSymbolType

McadSurfaceTextureLibraryObject::IsAllAround

McadSurfaceTextureLibraryObject::IsAllAround property

McadSurfaceTextureLibraryObject::IsForceTail

McadSurfaceTextureLibraryObject::IsForceTail property

McadSurfaceTextureLibraryObject::IsMajority

McadSurfaceTextureLibraryObject::IsMajority property

McadSurfaceTextureLibraryObject::RequirementValue

McadSurfaceTextureLibraryObject::RequirementValue method

McadSurfaceTextureLibraryObject::SubSymbolType

McadSurfaceTextureLibraryObject::SubSymbolType property

McadSurfaceTextureRequirement

McadSurfaceTextureRequirement enumeration

McadSurfaceTextureStandard

McadSurfaceTextureStandard coclass

about McadSurfaceTextureStandard coclass

McadSurfaceTextureStandard interface

about IMcadSurfaceTextureStandard interface

AllAroundAllowed

AvailableLaySymbols

FitCircle

ForceTail

FullList

IMcadSurfaceTextureStandard members

MajorityAllowed

Multiline

OfferedLaySymbols

McadSurfaceTextureStandard::AllAroundAllowed

McadSurfaceTextureStandard::AllAroundAllowed property

McadSurfaceTextureStandard::AvailableLaySymbols

McadSurfaceTextureStandard::AvailableLaySymbols property

McadSurfaceTextureStandard::FitCircle

McadSurfaceTextureStandard::FitCircle property

McadSurfaceTextureStandard::ForceTail

McadSurfaceTextureStandard::ForceTail property

McadSurfaceTextureStandard::FullList

McadSurfaceTextureStandard::FullList property

McadSurfaceTextureStandard::MajorityAllowed

McadSurfaceTextureStandard::MajorityAllowed property

McadSurfaceTextureStandard::Multiline

McadSurfaceTextureStandard::Multiline property

McadSurfaceTextureStandard::OfferedLaySymbols

McadSurfaceTextureStandard::OfferedLaySymbols property

McadSurfaceTextureStandard2

McadSurfaceTextureStandard2 interface

about IMcadSurfaceTextureStandard2 interface

IMcadSurfaceTextureStandard2 members

IsRequirementSupported

SetAllSuggestedListsToDefaults

SetSuggestedListToDefaults

SuggestedList

SuggestedList

McadSurfaceTextureStandard2::IsRequirementSupported

McadSurfaceTextureStandard2::IsRequirementSupported method

McadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults

McadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults method

McadSurfaceTextureStandard2::SetSuggestedListToDefaults

McadSurfaceTextureStandard2::SetSuggestedListToDefaults method

McadSurfaceTextureStandard2::SuggestedList

McadSurfaceTextureStandard2::SuggestedList method

McadSurfaceTextureStandard3

McadSurfaceTextureStandard3 interface

about IMcadSurfaceTextureStandard3 interface

IMcadSurfaceTextureStandard3 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadSurfaceTextureStandard3::SurfIndLeaderArrowScale

McadSurfaceTextureStandard3::SurfIndLeaderArrowScale property

McadSurfaceTextureStandard3::SurfIndLeaderArrowType

McadSurfaceTextureStandard3::SurfIndLeaderArrowType property

McadSurfaceTextureType

McadSurfaceTextureType enumeration

McadSymBBSymbolLibraryType

McadSymBBSymbolLibraryType enumeration

McadSymbol

McadSymbol coclass

about McadSymbol coclass

McadSymbol interface

about IMcadSymbol interface

AddLeader

AttachGeometry

CoordinateSystem

DetachGeometry

GetLeader

GetLeaderAttachment

IMcadSymbol members

InsertLeaderNode

IsAttached

LeaderArrowType

LeaderArrowType

LeaderColor

LeaderColor

LeaderCount

LeaderLanding

LeaderLanding

LeaderLineType

LeaderLineType

MoveLeaderNode

Origin

RemoveLeader

RemoveLeaderNode

Scale

SetToDefaults

Standard

SymbolStandard

McadSymbol::AddLeader

McadSymbol::AddLeader method

McadSymbol::AttachGeometry

McadSymbol::AttachGeometry method

McadSymbol::CoordinateSystem

McadSymbol::CoordinateSystem property

McadSymbol::DetachGeometry

McadSymbol::DetachGeometry method

McadSymbol::GetLeader

McadSymbol::GetLeader method

McadSymbol::GetLeaderAttachment

McadSymbol::GetLeaderAttachment method

McadSymbol::InsertLeaderNode

McadSymbol::InsertLeaderNode method

McadSymbol::IsAttached

McadSymbol::IsAttached property

McadSymbol::LeaderArrowType

McadSymbol::LeaderArrowType method

McadSymbol::LeaderColor

McadSymbol::LeaderColor method

McadSymbol::LeaderCount

McadSymbol::LeaderCount property

McadSymbol::LeaderLanding

McadSymbol::LeaderLanding method

McadSymbol::LeaderLineType

McadSymbol::LeaderLineType method

McadSymbol::MoveLeaderNode

McadSymbol::MoveLeaderNode method

McadSymbol::Origin

McadSymbol::Origin property

McadSymbol::RemoveLeader

McadSymbol::RemoveLeader method

McadSymbol::RemoveLeaderNode

McadSymbol::RemoveLeaderNode method

McadSymbol::Scale

McadSymbol::Scale property

McadSymbol::SetToDefaults

McadSymbol::SetToDefaults method

McadSymbol::Standard

McadSymbol::Standard property

McadSymbol::SymbolStandard

McadSymbol::SymbolStandard property

McadSymbol2

McadSymbol2 interface

about IMcadSymbol2 interface

IMcadSymbol2 members

UpdateToAttachedObject

McadSymbol2::UpdateToAttachedObject

McadSymbol2::UpdateToAttachedObject method

McadSymbolBBMgr

McadSymbolBBMgr coclass

about McadSymbolBBMgr coclass

McadSymbolBBMgr interface

about IMcadSymbolBBMgr interface

Application

BOMMgr

IMcadSymbolBBMgr members

StandardMgr

McadSymbolBBMgr::Application

McadSymbolBBMgr::Application property

McadSymbolBBMgr::BOMMgr

McadSymbolBBMgr::BOMMgr method

McadSymbolBBMgr::StandardMgr

McadSymbolBBMgr::StandardMgr method

McadSymbolBBMgr2

McadSymbolBBMgr2 interface

about IMcadSymbolBBMgr2 interface

IMcadSymbolBBMgr2 members

ScaleAreaMgr

TitleBorderMgr

McadSymbolBBMgr2::ScaleAreaMgr

McadSymbolBBMgr2::ScaleAreaMgr method

McadSymbolBBMgr2::TitleBorderMgr

McadSymbolBBMgr2::TitleBorderMgr method

McadSymbolBBMgr3

McadSymbolBBMgr3 interface

about IMcadSymbolBBMgr3 interface

IMcadSymbolBBMgr3 members

RevisionListMgr

SymbolLibrary

McadSymbolBBMgr3::RevisionListMgr

McadSymbolBBMgr3::RevisionListMgr method

McadSymbolBBMgr3::SymbolLibrary

McadSymbolBBMgr3::SymbolLibrary method

McadSymbolLibrary

McadSymbolLibrary coclass

about McadSymbolLibrary coclass

McadSymbolLibrary interface

about IMcadSymbolLibrary interface

appendItem

DefaultItem

findItem

findList

IMcadSymbolLibrary members

isItemExist

loadItem

modifyItem

removeItem

renameItem

setIsDefaultItem

McadSymbolLibrary::appendItem

McadSymbolLibrary::appendItem method

McadSymbolLibrary::DefaultItem

McadSymbolLibrary::DefaultItem method

McadSymbolLibrary::findItem

McadSymbolLibrary::findItem method

McadSymbolLibrary::findList

McadSymbolLibrary::findList method

McadSymbolLibrary::isItemExist

McadSymbolLibrary::isItemExist method

McadSymbolLibrary::loadItem

McadSymbolLibrary::loadItem method

McadSymbolLibrary::modifyItem

McadSymbolLibrary::modifyItem method

McadSymbolLibrary::removeItem

McadSymbolLibrary::removeItem method

McadSymbolLibrary::renameItem

McadSymbolLibrary::renameItem method

McadSymbolLibrary::setIsDefaultItem

McadSymbolLibrary::setIsDefaultItem method

McadSymbolLibraryObject

McadSymbolLibraryObject coclass

about McadSymbolLibraryObject coclass

McadSymbolLibraryObject interface

about IMcadSymbolLibraryObject interface

entryName

IMcadSymbolLibraryObject members

isDefault

standardName

symbolStandardClassName

McadSymbolLibraryObject::entryName

McadSymbolLibraryObject::entryName property

McadSymbolLibraryObject::isDefault

McadSymbolLibraryObject::isDefault property

McadSymbolLibraryObject::standardName

McadSymbolLibraryObject::standardName property

McadSymbolLibraryObject::symbolStandardClassName

McadSymbolLibraryObject::symbolStandardClassName property

McadSymbolLibraryObjects

McadSymbolLibraryObjects coclass

about McadSymbolLibraryObjects coclass

McadSymbolLibraryObjects interface

about IMcadSymbolLibraryObjects interface

Add

Application

Count

IMcadSymbolLibraryObjects members

Item

Remove

McadSymbolLibraryObjects::Add

McadSymbolLibraryObjects::Add method

McadSymbolLibraryObjects::Application

McadSymbolLibraryObjects::Application property

McadSymbolLibraryObjects::Count

McadSymbolLibraryObjects::Count property

McadSymbolLibraryObjects::Item

McadSymbolLibraryObjects::Item method

McadSymbolLibraryObjects::Remove

McadSymbolLibraryObjects::Remove method

McadSymbolStandard

McadSymbolStandard coclass

about McadSymbolStandard coclass

McadSymbolStandard interface

about IMcadSymbolStandard interface

IMcadSymbolStandard members

Revision

RevisionYear

SetToDefaults

Standard

McadSymbolStandard::Revision

McadSymbolStandard::Revision property

McadSymbolStandard::RevisionYear

McadSymbolStandard::RevisionYear property

McadSymbolStandard::SetToDefaults

McadSymbolStandard::SetToDefaults method

McadSymbolStandard::Standard

McadSymbolStandard::Standard property

McadSymbolStandard2

McadSymbolStandard2 interface

about IMcadSymbolStandard2 interface

ArrowScale

ArrowType

IMcadSymbolStandard2 members

LeaderTrueColor

SetToDefaultTextLeader

TextHeight

TextTrueColor

McadSymbolStandard2::ArrowScale

McadSymbolStandard2::ArrowScale property

McadSymbolStandard2::ArrowType

McadSymbolStandard2::ArrowType property

McadSymbolStandard2::LeaderTrueColor

McadSymbolStandard2::LeaderTrueColor property

McadSymbolStandard2::SetToDefaultTextLeader

McadSymbolStandard2::SetToDefaultTextLeader method

McadSymbolStandard2::TextHeight

McadSymbolStandard2::TextHeight property

McadSymbolStandard2::TextTrueColor

McadSymbolStandard2::TextTrueColor property

McadSymbolStandard3

McadSymbolStandard3 interface

about IMcadSymbolStandard3 interface

IMcadSymbolStandard3 members

SupportedArrowTypes

SymbolStandardClassName

McadSymbolStandard3::SupportedArrowTypes

McadSymbolStandard3::SupportedArrowTypes method

McadSymbolStandard3::SymbolStandardClassName

McadSymbolStandard3::SymbolStandardClassName property

McadSymbolStandards

McadSymbolStandards coclass

about McadSymbolStandards coclass

McadSymbolStandards interface

about IMcadSymbolStandards interface

Add

Application

Count

IMcadSymbolStandards members

Item

Remove

McadSymbolStandards::Add

McadSymbolStandards::Add method

McadSymbolStandards::Application

McadSymbolStandards::Application property

McadSymbolStandards::Count

McadSymbolStandards::Count property

McadSymbolStandards::Item

McadSymbolStandards::Item method

McadSymbolStandards::Remove

McadSymbolStandards::Remove method

McadTaper

McadTaper coclass

about McadTaper coclass

McadTaper interface

about IMcadTaper interface

AboveCurve

AdjustReferenceLine

DisplayString

HasLeader

IMcadTaper members

Inspect

Orientation

SubSymbolType

McadTaper::AboveCurve

McadTaper::AboveCurve property

McadTaper::AdjustReferenceLine

McadTaper::AdjustReferenceLine method

McadTaper::DisplayString

McadTaper::DisplayString property

McadTaper::HasLeader

McadTaper::HasLeader property

McadTaper::Inspect

McadTaper::Inspect property

McadTaper::Orientation

McadTaper::Orientation property

McadTaper::SubSymbolType

McadTaper::SubSymbolType property

McadTaperDimensionType

McadTaperDimensionType enumeration

McadTaperRatioFormatType

McadTaperRatioFormatType enumeration

McadTaperSlopeSymType

McadTaperSlopeSymType enumeration

McadTaperStandard

McadTaperStandard coclass

about McadTaperStandard coclass

McadTaperStandard interface

about IMcadTaperStandard interface

IMcadTaperStandard members

OfferedSymbols

McadTaperStandard::OfferedSymbols

McadTaperStandard::OfferedSymbols property

McadTaperStandard2

McadTaperStandard2 interface

about IMcadTaperStandard2 interface

GetDimensionType

IMcadTaperStandard2 members

SetDimensionType

McadTaperStandard2::GetDimensionType

McadTaperStandard2::GetDimensionType method

McadTaperStandard2::SetDimensionType

McadTaperStandard2::SetDimensionType method

McadTargetType

McadTargetType enumeration

McadTextControl

McadTextControl enumeration

McadTitle

McadTitle coclass

about McadTitle coclass

McadTitle interface

about IMcadTitle interface

Attributes

IMcadTitle members

InActive

Name

Position

SetToDefaultAttributes

McadTitle::Attributes

McadTitle::Attributes property

McadTitle::InActive

McadTitle::InActive property

McadTitle::Name

McadTitle::Name property

McadTitle::Position

McadTitle::Position property

McadTitle::SetToDefaultAttributes

McadTitle::SetToDefaultAttributes method

McadTitle2

McadTitle2 interface

about IMcadTitle2 interface

BlockId

BlockId32

IMcadTitle2 members

McadTitle2::BlockId

McadTitle2::BlockId property

McadTitle2::BlockId32

McadTitle2::BlockId32 property

McadTitleBorder

McadTitleBorder coclass

about McadTitleBorder coclass

McadTitleBorder interface

about IMcadTitleBorder interface

Descriptor

IMcadTitleBorder members

Modify

Ref

Ref32

McadTitleBorder::Descriptor

McadTitleBorder::Descriptor property

McadTitleBorder::Modify

McadTitleBorder::Modify method

McadTitleBorder::Ref

McadTitleBorder::Ref property

McadTitleBorder::Ref32

McadTitleBorder::Ref32 property

McadTitleBorderContext

McadTitleBorderContext coclass

about McadTitleBorderContext coclass

McadTitleBorderContext interface

about IMcadTitleBorderContext interface

AutomaticPlacement

BaseScale

DwgDefault

GetMoveObjectsIDs

GetMoveObjectsIDs32

GetMoveObjectsToPoint

GetPartReference

GetPartReference32

IMcadTitleBorderContext members

MoveObjects

Rescale

RetrieveFromAsmProp

RetrieveFromPartRef

SetMoveObjects

SetPartReference

ThawAllLayers

McadTitleBorderContext::AutomaticPlacement

McadTitleBorderContext::AutomaticPlacement property

McadTitleBorderContext::BaseScale

McadTitleBorderContext::BaseScale property

McadTitleBorderContext::DwgDefault

McadTitleBorderContext::DwgDefault property

McadTitleBorderContext::GetMoveObjectsIDs

McadTitleBorderContext::GetMoveObjectsIDs method

McadTitleBorderContext::GetMoveObjectsIDs32

McadTitleBorderContext::GetMoveObjectsIDs32 method

McadTitleBorderContext::GetMoveObjectsToPoint

McadTitleBorderContext::GetMoveObjectsToPoint method

McadTitleBorderContext::GetPartReference

McadTitleBorderContext::GetPartReference method

McadTitleBorderContext::GetPartReference32

McadTitleBorderContext::GetPartReference32 method

McadTitleBorderContext::MoveObjects

McadTitleBorderContext::MoveObjects property

McadTitleBorderContext::Rescale

McadTitleBorderContext::Rescale property

McadTitleBorderContext::RetrieveFromAsmProp

McadTitleBorderContext::RetrieveFromAsmProp property

McadTitleBorderContext::RetrieveFromPartRef

McadTitleBorderContext::RetrieveFromPartRef property

McadTitleBorderContext::SetMoveObjects

McadTitleBorderContext::SetMoveObjects method

McadTitleBorderContext::SetPartReference

McadTitleBorderContext::SetPartReference method

McadTitleBorderContext::ThawAllLayers

McadTitleBorderContext::ThawAllLayers property

McadTitleBorderDescriptor

McadTitleBorderDescriptor coclass

about McadTitleBorderDescriptor coclass

McadTitleBorderDescriptor interface

about IMcadTitleBorderDescriptor interface

Border

IMcadTitleBorderDescriptor members

Position

Title

TitleBorderScale

McadTitleBorderDescriptor::Border

McadTitleBorderDescriptor::Border property

McadTitleBorderDescriptor::Position

McadTitleBorderDescriptor::Position property

McadTitleBorderDescriptor::Title

McadTitleBorderDescriptor::Title property

McadTitleBorderDescriptor::TitleBorderScale

McadTitleBorderDescriptor::TitleBorderScale property

McadTitleBorderMgr

McadTitleBorderMgr coclass

about McadTitleBorderMgr coclass

McadTitleBorderMgr interface

about IMcadTitleBorderMgr interface

CreateTitleBorder

DeleteTitleBorder

GetTitleBorderFromRef

IMcadTitleBorderMgr members

NewContext

NewDescriptor

TitleBorders

McadTitleBorderMgr::CreateTitleBorder

McadTitleBorderMgr::CreateTitleBorder method

McadTitleBorderMgr::DeleteTitleBorder

McadTitleBorderMgr::DeleteTitleBorder method

McadTitleBorderMgr::GetTitleBorderFromRef

McadTitleBorderMgr::GetTitleBorderFromRef method

McadTitleBorderMgr::NewContext

McadTitleBorderMgr::NewContext method

McadTitleBorderMgr::NewDescriptor

McadTitleBorderMgr::NewDescriptor method

McadTitleBorderMgr::TitleBorders

McadTitleBorderMgr::TitleBorders property

McadTitleBorders

McadTitleBorders coclass

about McadTitleBorders coclass

McadTitleBorders interface

about IMcadTitleBorders interface

Application

Count

IMcadTitleBorders members

Item

McadTitleBorders::Application

McadTitleBorders::Application property

McadTitleBorders::Count

McadTitleBorders::Count property

McadTitleBorders::Item

McadTitleBorders::Item method

McadTitleBorderStandard

McadTitleBorderStandard coclass

about McadTitleBorderStandard coclass

McadTitleBorderStandard interface

about IMcadTitleBorderStandard interface

DefaultPaperFormat

DefaultRevisionList

DefaultTitleBlock

IMcadTitleBorderStandard members

PaperFormats

RevisionLists

TitleBlocks

McadTitleBorderStandard::DefaultPaperFormat

McadTitleBorderStandard::DefaultPaperFormat property

McadTitleBorderStandard::DefaultRevisionList

McadTitleBorderStandard::DefaultRevisionList property

McadTitleBorderStandard::DefaultTitleBlock

McadTitleBorderStandard::DefaultTitleBlock property

McadTitleBorderStandard::PaperFormats

McadTitleBorderStandard::PaperFormats property

McadTitleBorderStandard::RevisionLists

McadTitleBorderStandard::RevisionLists property

McadTitleBorderStandard::TitleBlocks

McadTitleBorderStandard::TitleBlocks property

McadTitleBorderStandard2

McadTitleBorderStandard2 interface

about IMcadTitleBorderStandard2 interface

IMcadTitleBorderStandard2 members

InsertInvertPart

InvertPartBorderHeight

InvertPartBorderWidth

InvertPartTextHeight

McadTitleBorderStandard2::InsertInvertPart

McadTitleBorderStandard2::InsertInvertPart property

McadTitleBorderStandard2::InvertPartBorderHeight

McadTitleBorderStandard2::InvertPartBorderHeight property

McadTitleBorderStandard2::InvertPartBorderWidth

McadTitleBorderStandard2::InvertPartBorderWidth property

McadTitleBorderStandard2::InvertPartTextHeight

McadTitleBorderStandard2::InvertPartTextHeight property

McadTransaction

McadTransaction coclass

about McadTransaction coclass

McadTransaction interface

about IMcadTransaction interface

Application

IMcadTransaction members

McadTransaction::Application

McadTransaction::Application property

McadUndefinedSize

McadUndefinedSize enumeration

McadUndefinedSizeDirection

McadUndefinedSizeDirection enumeration

McadUtility

McadUtility coclass

about McadUtility coclass

McadUtility interface

about IMcadUtility interface

Application

CreateAttribute

CreateAttributeField

CreateCollection

CreatePickObject

CreateSystemAttribute

Document

GetAllAttributes

GetAttributeFromID

GetAttributeFromID32

GetGeometryFromPick

GetIdsFromObject

GetIdsFromObject32

GetObjectFromID

GetObjectFromID32

GetObjectFromPick

IMcadUtility members

Pick

McadUtility::Application

McadUtility::Application property

McadUtility::CreateAttribute

McadUtility::CreateAttribute method

McadUtility::CreateAttributeField

McadUtility::CreateAttributeField method

McadUtility::CreateCollection

McadUtility::CreateCollection method

McadUtility::CreatePickObject

McadUtility::CreatePickObject method

McadUtility::CreateSystemAttribute

McadUtility::CreateSystemAttribute method

McadUtility::Document

McadUtility::Document property

McadUtility::GetAllAttributes

McadUtility::GetAllAttributes method

McadUtility::GetAttributeFromID

McadUtility::GetAttributeFromID method

McadUtility::GetAttributeFromID32

McadUtility::GetAttributeFromID32 method

McadUtility::GetGeometryFromPick

McadUtility::GetGeometryFromPick method

McadUtility::GetIdsFromObject

McadUtility::GetIdsFromObject method

McadUtility::GetIdsFromObject32

McadUtility::GetIdsFromObject32 method

McadUtility::GetObjectFromID

McadUtility::GetObjectFromID method

McadUtility::GetObjectFromID32

McadUtility::GetObjectFromID32 method

McadUtility::GetObjectFromPick

McadUtility::GetObjectFromPick method

McadUtility::Pick

McadUtility::Pick method

McadUtility2

McadUtility2 interface

about IMcadUtility2 interface

IMcadUtility2 members

RefocusObject

McadUtility2::RefocusObject

McadUtility2::RefocusObject method

McadUtility3

McadUtility3 interface

about IMcadUtility3 interface

GetDrawingType

IMcadUtility3 members

McadUtility3::GetDrawingType

McadUtility3::GetDrawingType method

McadViewDefLockType

McadViewDefLockType enumeration

McadWeldAssociation

McadWeldAssociation enumeration

McadWelding

McadWelding coclass

about McadWelding coclass

McadWelding interface

about IMcadWelding interface

AddSubWelding

AngleValue

AngleValue

AreaType

AreaType

AssociationType

AssociationType

BackingValue

BackingValue

Brazing

Brazing

BrazingValue

BrazingValue

ClearanceValue

ClearanceValue

ClosedTail

ClosedTail

ContourType

ContourType

ContourValue

ContourValue

ControlCategoryValue

ControlCategoryValue

DepthValue

DepthValue

DesignationValue

DesignationValue

FieldWeld

FieldWeld

FinishingValue

FinishingValue

GapValue

GapValue

HighlightSubWelding

IdentificationLine

IdentificationLine

IMcadWelding members

IndexTotalValue

IndexTotalValue

IndexValue

IndexValue

LengthValue

LengthValue

NotesValue

NotesValue

NumberValue

NumberValue

Orientation

PitchValue

PitchValue

RemoveSubWelding

SecondarySymType

SecondarySymType

SecondarySymTypeValue

SecondarySymTypeValue

Size2Value

Size2Value

SizeType

SizeType

SizeTypeValue

SizeTypeValue

SizeValue

SizeValue

SpacingValue

SpacingValue

SpecificationValue

SpecificationValue

StandardValue

StandardValue

SubWeldingCount

TechnicalReqValue

TechnicalReqValue

ThicknessValue

ThicknessValue

Type

Type

McadWelding::AddSubWelding

McadWelding::AddSubWelding method

McadWelding::AngleValue

McadWelding::AngleValue method

McadWelding::AreaType

McadWelding::AreaType method

McadWelding::AssociationType

McadWelding::AssociationType method

McadWelding::BackingValue

McadWelding::BackingValue method

McadWelding::Brazing

McadWelding::Brazing method

McadWelding::BrazingValue

McadWelding::BrazingValue method

McadWelding::ClearanceValue

McadWelding::ClearanceValue method

McadWelding::ClosedTail

McadWelding::ClosedTail method

McadWelding::ContourType

McadWelding::ContourType method

McadWelding::ContourValue

McadWelding::ContourValue method

McadWelding::ControlCategoryValue

McadWelding::ControlCategoryValue method

McadWelding::DepthValue

McadWelding::DepthValue method

McadWelding::DesignationValue

McadWelding::DesignationValue method

McadWelding::FieldWeld

McadWelding::FieldWeld method

McadWelding::FinishingValue

McadWelding::FinishingValue method

McadWelding::GapValue

McadWelding::GapValue method

McadWelding::HighlightSubWelding

McadWelding::HighlightSubWelding method

McadWelding::IdentificationLine

McadWelding::IdentificationLine method

McadWelding::IndexTotalValue

McadWelding::IndexTotalValue method

McadWelding::IndexValue

McadWelding::IndexValue method

McadWelding::LengthValue

McadWelding::LengthValue method

McadWelding::NotesValue

McadWelding::NotesValue method

McadWelding::NumberValue

McadWelding::NumberValue method

McadWelding::Orientation

McadWelding::Orientation property

McadWelding::PitchValue

McadWelding::PitchValue method

McadWelding::RemoveSubWelding

McadWelding::RemoveSubWelding method

McadWelding::SecondarySymType

McadWelding::SecondarySymType method

McadWelding::SecondarySymTypeValue

McadWelding::SecondarySymTypeValue method

McadWelding::Size2Value

McadWelding::Size2Value method

McadWelding::SizeType

McadWelding::SizeType method

McadWelding::SizeTypeValue

McadWelding::SizeTypeValue method

McadWelding::SizeValue

McadWelding::SizeValue method

McadWelding::SpacingValue

McadWelding::SpacingValue method

McadWelding::SpecificationValue

McadWelding::SpecificationValue method

McadWelding::StandardValue

McadWelding::StandardValue method

McadWelding::SubWeldingCount

McadWelding::SubWeldingCount property

McadWelding::TechnicalReqValue

McadWelding::TechnicalReqValue method

McadWelding::ThicknessValue

McadWelding::ThicknessValue method

McadWelding::Type

McadWelding::Type method

McadWelding2

McadWelding2 interface

about IMcadWelding2 interface

IMcadWelding2 members

InsertProcess

McadWelding2::InsertProcess

McadWelding2::InsertProcess method

McadWeldingLibrary

McadWeldingLibrary coclass

about McadWeldingLibrary coclass

McadWeldingLibrary interface

about IMcadWeldingLibrary interface

appendItemFromSubWelding

IMcadWeldingLibrary members

loadItemToSubWelding

modifyItemFromSubWelding

McadWeldingLibrary::appendItemFromSubWelding

McadWeldingLibrary::appendItemFromSubWelding method

McadWeldingLibrary::loadItemToSubWelding

McadWeldingLibrary::loadItemToSubWelding method

McadWeldingLibrary::modifyItemFromSubWelding

McadWeldingLibrary::modifyItemFromSubWelding method

McadWeldingLibraryObject

McadWeldingLibraryObject coclass

about McadWeldingLibraryObject coclass

McadWeldingLibraryObject interface

about IMcadWeldingLibraryObject interface

AreaType

ArrowSideReqValue

AssociationType

ClosedTail

FieldWeld

IdentificationLine

IMcadWeldingLibraryObject members

OtherSideReqValue

RequirementValue

setIsDefault

Type

McadWeldingLibraryObject::AreaType

McadWeldingLibraryObject::AreaType property

McadWeldingLibraryObject::ArrowSideReqValue

McadWeldingLibraryObject::ArrowSideReqValue method

McadWeldingLibraryObject::AssociationType

McadWeldingLibraryObject::AssociationType property

McadWeldingLibraryObject::ClosedTail

McadWeldingLibraryObject::ClosedTail property

McadWeldingLibraryObject::FieldWeld

McadWeldingLibraryObject::FieldWeld property

McadWeldingLibraryObject::IdentificationLine

McadWeldingLibraryObject::IdentificationLine property

McadWeldingLibraryObject::OtherSideReqValue

McadWeldingLibraryObject::OtherSideReqValue method

McadWeldingLibraryObject::RequirementValue

McadWeldingLibraryObject::RequirementValue method

McadWeldingLibraryObject::setIsDefault

McadWeldingLibraryObject::setIsDefault method

McadWeldingLibraryObject::Type

McadWeldingLibraryObject::Type method

McadWeldingRequirement

McadWeldingRequirement enumeration

McadWeldingStandard

McadWeldingStandard coclass

about McadWeldingStandard coclass

McadWeldingStandard interface

about IMcadWeldingStandard interface

AvailableBackingSymbols

AvailableContourSymbols

AvailableWeldSymbols

ClosedTailAllowed

IdentificationLineAllowed

IdentificationLineGap

IdentificationLinetype

IdentificationLinetypeName

IMcadWeldingStandard members

MultipleSymbolsAllowed

OfferedBackingSymbols

OfferedContourSymbols

OfferedWeldSymbols

McadWeldingStandard::AvailableBackingSymbols

McadWeldingStandard::AvailableBackingSymbols property

McadWeldingStandard::AvailableContourSymbols

McadWeldingStandard::AvailableContourSymbols property

McadWeldingStandard::AvailableWeldSymbols

McadWeldingStandard::AvailableWeldSymbols property

McadWeldingStandard::ClosedTailAllowed

McadWeldingStandard::ClosedTailAllowed property

McadWeldingStandard::IdentificationLineAllowed

McadWeldingStandard::IdentificationLineAllowed property

McadWeldingStandard::IdentificationLineGap

McadWeldingStandard::IdentificationLineGap property

McadWeldingStandard::IdentificationLinetype

McadWeldingStandard::IdentificationLinetype property

McadWeldingStandard::IdentificationLinetypeName

McadWeldingStandard::IdentificationLinetypeName property

McadWeldingStandard::MultipleSymbolsAllowed

McadWeldingStandard::MultipleSymbolsAllowed property

McadWeldingStandard::OfferedBackingSymbols

McadWeldingStandard::OfferedBackingSymbols property

McadWeldingStandard::OfferedContourSymbols

McadWeldingStandard::OfferedContourSymbols property

McadWeldingStandard::OfferedWeldSymbols

McadWeldingStandard::OfferedWeldSymbols property

McadWeldingStandard2

McadWeldingStandard2 interface

about IMcadWeldingStandard2 interface

IMcadWeldingStandard2 members

WeldProcessPrefix

McadWeldingStandard2::WeldProcessPrefix

McadWeldingStandard2::WeldProcessPrefix property

McadWeldingStandard3

McadWeldingStandard3 interface

about IMcadWeldingStandard3 interface

IMcadWeldingStandard3 members

ProcessGap

ScaleFactor

McadWeldingStandard3::ProcessGap

McadWeldingStandard3::ProcessGap property

McadWeldingStandard3::ScaleFactor

McadWeldingStandard3::ScaleFactor property

McadWeldSymbolType

McadWeldSymbolType enumeration

mcAllFolderPowerObj enumeration member

mcAnnotationViewDefinition enumeration member

mcAnnotationViewDefinitions enumeration member

mcArc enumeration member

mcAttributeFields enumeration member

mcAttributes enumeration member

mcBottomUp enumeration member

mcCamCalcObj enumeration member

mcCharacter enumeration member

mcComplexHideSituations enumeration member

mcComponent enumeration member

mcComponentDefinition enumeration member

mcComponentDefinitions enumeration member

mcComponents enumeration member

mcComponentView enumeration member

mcComponentViewDefinition enumeration member

mcComponentViewDefinitions enumeration member

mcComponentViews enumeration member

mcCopyAlways enumeration member

mcCurve enumeration member

mcDefault enumeration member

mcDeflLineObj enumeration member

mcDontHide enumeration member

mcDouble enumeration member

mcDoubleArray enumeration member

mcEllipse enumeration member

mcFEAObj enumeration member

mcFolder enumeration member

mcFolderDefinition enumeration member

mcFolderDefinitions enumeration member

mcFolders enumeration member

mcGeometry enumeration member

mcHideBg enumeration member

mcHideFg enumeration member

mcHideFgBg enumeration member

mcHideSituations enumeration member

mcIgnoreAlways enumeration member

mcInventorLink enumeration member

mcLine enumeration member

mcLong enumeration member

mcLongArray enumeration member

mcMcadObject enumeration member

mcMcadObjectArray enumeration member

mcMDT enumeration member

mcMDTPart enumeration member

mcMomOfInertiaObj enumeration member

mcNoObj enumeration member

mcNormalDef enumeration member

mcObject enumeration member

mcObjectID enumeration member

mcObjectIDArray enumeration member

mcObjects enumeration member

mcPartFeatObj enumeration member

mcPhantomDef enumeration member

mcPhantomDefInCurrent enumeration member

mcPolyline enumeration member

mcScrewConObj enumeration member

mcShaftCalcObj enumeration member

mcShaftObj enumeration member

mcShareAlways enumeration member

mcShort enumeration member

mcShortArray enumeration member

mcSpline enumeration member

mcString enumeration member

mcTopDown enumeration member

mcUndefined enumeration member

MergeDatum

IMcadFCFStandard interface

MergeItems

IMcadBOM3 interface

MergeSymbol

IMcadFCFStandard interface

MergeTolerance

IMcadFCFStandard interface

MethodValue

IMcadMarkStamp interface

mg enumeration member

MidPoint

IGeLineSegment interface

MigrateTo2DStructure

IMcad2dComplexStdPartCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor interface

MinorAxis

IGeEllipticalArc interface

MinorRadius

IGeEllipticalArc interface

IGeTorus interface

MinPoint

IGeBoundBlock interface

MinValue

IMcadEdge interface

Mirror

IGeEntity interface

IGeVector interface

ml enumeration member

mm enumeration member

Modify

IMcadTitleBorder interface

modifyItem

IMcadSymbolLibrary interface

modifyItemFromSubWelding

IMcadWeldingLibrary interface

MoveBorder

IMcadScaleArea interface

MoveColumn

IMcadBOMStandard interface

MoveLayerGroupEntities

IMcadLayerGroupMgr interface

MoveLeaderNode

IMcadSymbol interface

MoveLevel

IMcadComplexHideSituation interface

MoveObjects

IMcadTitleBorderContext interface

MulipleRow

IMcadPartListStandard interface

Multiline

IMcadSurfaceTextureStandard interface

MultipleNamesSupported

IMcadSectionLineStandard interface

MultipleRow

IMcadPartList interface

MultipleSymbolsAllowed

IMcadWeldingStandard interface

MultiplicityAt

IGeKnotVector interface

MultiplyBy

IGeVector interface

N

Name

IMcad2DStructureDescriptor interface

IMcadAttributeField interface

IMcadBorder interface

IMcadColumnDefinition interface

IMcadComplexHideSituation interface

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolderDefinition interface

IMcadHideSituation interface

IMcadLayerCfg interface

IMcadPartListFilter interface

IMcadStandard interface

IMcadTitle interface

Negate

IGeVector interface

Negative

IGeVector interface

NewContext

IMcadTitleBorderMgr interface

NewDescriptor

IMcadRevisionMgr interface

IMcadTitleBorderMgr interface

NewSymbolRev

IMcadEdge interface

NextLevelName

IMcadComplexHideSituation interface

NextViewName

IMcadFolderDefinition interface

NonModal enumeration member

NoPlot

IMcadLayerCfg interface

NoReplicateInLayerGroup

IMcadLayerCfg interface

Normal

IGeCircularArc interface

IGeEllipticalArc interface

IGeOffsetCurve interface

IGePlane interface

IGeVector interface

NormalFlipped

IGeSurface interface

Normalize

IGeVector interface

NormalPoint

IGeCurve interface

NorthAxis

IGeSphere interface

NorthPole

IGeSphere interface

NoteStandard

IMcadStandard3 interface

NotesValue

IMcadWelding interface

IMcadWelding interface

NoteText

IMcadNote interface

NumberOfIntervals

IGeKnotVector interface

NumberOfTemplateGroups

IMcadNoteStandard interface

NumberValue

IMcadWelding interface

IMcadWelding interface

NurbCurve

IGeApplication interface

NurbSurface

IGeApplication interface

O

ObjectID

IMcadAttribute interface

ObjectID32

IMcadAttribute interface

ObjectType

IMcadPick interface

Occurrences

IMcadFolderDefinition interface

OfferedAuxiliarySymbols

IMcadFCFStandard interface

OfferedBackingSymbols

IMcadWeldingStandard interface

OfferedContourSymbols

IMcadWeldingStandard interface

OfferedGDTSymbols

IMcadFCFStandard interface

OfferedLaySymbols

IMcadSurfaceTextureStandard interface

OfferedMarkingContents

IMcadMarkStampStandard interface

OfferedMarkingMethods

IMcadMarkStampStandard interface

OfferedStampingContents

IMcadMarkStampStandard interface

OfferedStampingMethods

IMcadMarkStampStandard interface

OfferedSymbols

IMcadTaperStandard interface

OfferedWeldSymbols

IMcadWeldingStandard interface

OffsetCurve

IGeApplication interface

OffsetDistance

IGeOffsetCurve interface

IGeOffsetSurface interface

OffsetSurface

IGeApplication interface

Operator

IMcadPartListCustomFilter interface

Option

IMcadPartListStdPartsFilter interface

Order

IGeNurbCurve interface

Orientation

IMcadJoint interface

IMcadTaper interface

IMcadWelding interface

Orientation2d

IGeCurveBoundary interface

Orientation3d

IGeCurveBoundary interface

Origin

IGeCone interface

IGeCylinder interface

IGePlane interface

IGeSphere interface

IGeTorus interface

IMcadSymbol interface

OtherMinimumValue

IMcadSurfaceTexture interface

OtherSideReqValue

IMcadWeldingLibraryObject interface

OtherValue

IMcadSurfaceTexture interface

OuterContourOnly

IMcadHideSituation interface

Overlap

IGeLinearEntity interface

OverlapCount

IGeCurveCurveIntersection interface

OverlapDirection

IGeCurveCurveIntersection interface

OverrideColorByLayerGroup

IMcadLayerCfg interface

Owner

IMcadComponent interface

IMcadComponentViewDefinition interface

IMcadFolder interface

OwningComponentDefinition

IMcad2dComponentDescriptor interface

OwningSpace

IMcadFolder2 interface

oz enumeration member

P

PaperFormats

IMcadTitleBorderStandard interface

ParameterAtLength

IGeCurve interface

ParameterCurveOnSurface1

IGeSurfaceSurfaceIntersection interface

ParameterCurveOnSurface2

IGeSurfaceSurfaceIntersection interface

ParameterDirection

IGeOffsetCurve interface

ParameterOf

IGeCurve interface

IGeSurface interface

ParameterOnCurve

IGeCurveSurfaceIntersection interface

ParameterOnCurve1

IGeCurveCurveIntersection interface

ParameterOnCurve2

IGeCurveCurveIntersection interface

ParameterOnSurface

IGeCurveSurfaceIntersection interface

ParameterOnSurface1

IGeSurfaceSurfaceIntersection interface

ParameterOnSurface2

IGeSurfaceSurfaceIntersection interface

ParametersOfC1

IGeNurbCurve interface

ParametersOfG1

IGeNurbCurve interface

ParentHide

IMcadHideSituation interface

PartListCaptionAlignment

IMcadColumnDefinition3 interface

PartListDataAlignment

IMcadColumnDefinition3 interface

PartLists

IMcadBOM interface

PartListStandard

IMcadBOMStandard interface

PartRef enumeration member

PerpendicularPlane

IGeLinearEntity interface

PerpendicularVector

IGeVector interface

Phantomed

IMcadBOMItem2 interface

PhantomState

IMcadComponentDefinition interface

Pick

IMcadUtility interface

PickPoint

IMcadPick interface

PitchValue

IMcadWelding interface

IMcadWelding interface

Plane

IGeApplication interface

PlaneLineColor

IMcadSectionLineStandard2 interface

PlaneLineType

IMcadSectionLineStandard2 interface

PlaneLineWeight

IMcadSectionLineStandard2 interface

PlaneSymbolsVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

Point

IGeApplication interface

PointAt

IGeAugmentedLine interface

IGeAugmentedLine interface

PointColor

IMcadDatumStandard interface

PointOnLine

IGeLinearEntity interface

Points

IGeAugmentedLine interface

PointSize

IMcadDatumStandard interface

PointTrueColor

IMcadDatumStandard2 interface

Position

IMcadBorder interface

IMcadComponent interface

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

IMcadTitle interface

IMcadTitleBorderDescriptor interface

PostMultiply

IGeMatrix interface

PowerObjectType

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

Precision

IMcadColumnDefinition interface

PredefinedReferenceOverride

IMcadComponent interface

IMcadFolder interface

PreMultiply

IGeMatrix interface

ProcessGap

IMcadWeldingStandard3 interface

Product

IGeMatrix interface

IGeVector interface

Production2Value

IMcadSurfaceTexture interface

ProductionValue

IMcadSurfaceTexture interface

Project

IGeCurve interface

IGeVector interface

ProjectedValue

IMcadFeatureControlFrame interface

ProjectToPlane

IGePoint interface

PropertyName

IMcadPartListCustomFilter interface

PropertyValue

IMcadPartListCustomFilter interface

PurgeAll2DS

IMcad2DStructureMgr interface

PurgeAnnotationViewDefinitions

IMcad2DStructureMgr interface

PurgeComponentDefinitions

IMcad2DStructureMgr interface

PurgeComponentViewDefinitions

IMcad2DStructureMgr interface

PurgeFitData

IGeNurbCurve interface

PurgeFolderDefinitions

IMcad2DStructureMgr interface

Q

qt enumeration member

Quantity

IMcadBOMItem interface

IMcadPartReference interface

R

Radius

IGeCircularArc interface

IGeCylinder interface

IGeSphere interface

IMcadDetailSymbol interface

RaMaximumValue

IMcadSurfaceTexture interface

RaMinimumValue

IMcadSurfaceTexture interface

Ray

IGeApplication interface

ReadAttributeClass

IAcadmApplication interface

RectangleAngle

IMcadDatumTarget interface

RectangleCornerPoint

IMcadDatumTarget2 interface

RectangleXSize

IMcadDatumTarget interface

RectangleYSize

IMcadDatumTarget interface

Ref

IMcadRevisionList interface

IMcadTitleBorder interface

Ref32

IMcadRevisionList interface

IMcadTitleBorder interface

Reference

IMcadComponent interface

ReferenceAxis

IGeSphere interface

IGeTorus interface

ReferenceExists

IMcadBOMItem interface

ReferenceValue

IMcadSurfaceTexture interface

ReferenceVector

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

RefocusObject

IMcadUtility2 interface

Remove

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

RemoveAttribute

IMcadBOMItem4 interface

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

IMcadPartReference3 interface

RemoveAttributeClass

IAcadmApplication interface

RemoveBOMItem

IMcadBalloon interface

RemoveBOMTable

IMcadBOMMgr interface

RemoveColumn

IMcadBalloonStandard interface

IMcadBOMStandard interface

IMcadPartListStandard interface

RemoveComponent

IMcadComponentDefinition interface

RemoveComponentView

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

IMcadComponentViewDefinition interface

RemoveEntities

IMcadFolder interface

RemoveFilter

IMcadPartList interface

RemoveFitPointAt

IGeNurbCurve interface

RemoveFolder

IMcadFolderDefinition interface

removeItem

IMcadSymbolLibrary interface

RemoveKnotAt

IGeKnotVector interface

RemoveLeader

IMcadSymbol interface

RemoveLeaderNode

IMcadSymbol interface

RemoveLevel

IMcadComplexHideSituation interface

RemoveLevelByIdx

IMcadComplexHideSituation interface

RemovePartGrfDef

IMcadBOMMgr2 interface

RemovePreDefinedList

IMcadColumnDefinition3 interface

RemoveRange

IGeKnotVector interface

RemoveReference

IMcadBOMItem interface

RemoveStandard

IMcadStandardMgr interface

RemoveSubent

IMcadHideSituation interface

RemoveSubentByIdx

IMcadHideSituation interface

RemoveSubWelding

IMcadWelding interface

RemoveSurfIndLeader

IMcadFeatureControlFrame4 interface

RemoveSymbolStandard

IMcadStandard interface

RemoveView

IMcad2dComplexStdPartCompGroupDescriptor interface

renameItem

IMcadSymbolLibrary interface

RenameTemplate

IMcadNoteStandard interface

ReplaceDefinition

IMcadComponent interface

IMcadFolder interface

RequirementValue

IMcadEdgeLibraryObject interface

IMcadFCFLibraryObject interface

IMcadSurfaceTextureLibraryObject interface

IMcadWeldingLibraryObject interface

Rescale

IMcadTitleBorderContext interface

RescaleObjects

IMcadScaleArea interface

RestructureViews

IMcad2DStructureMgr interface

ResultBarEnabled

IMcadPartList2 interface

RetrieveFromAsmProp

IMcadTitleBorderContext interface

RetrieveFromPartRef

IMcadTitleBorderContext interface

Reverse

IGeCurve interface

IGeKnotVector interface

IMcadComplexHideSituation interface

Revision

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadSymbolStandard interface

RevisionListMgr

IMcadSymbolBBMgr3 interface

RevisionLists

IMcadRevisionMgr interface

IMcadTitleBorderStandard interface

RevisionYear

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadSymbolStandard interface

RootComponentDefinition

IMcad2DStructureMgr interface

RootViewDefinition

IMcad2DStructureMgr interface

RotateBy

IGeEntity interface

IGeVector interface

RowGap

IMcadPartListStandard interface

RowHeight

IMcadPartListStandard interface

RowTextColor

IMcadPartListStandard3 interface

RowTextControl

IMcadPartList2 interface

IMcadPartListStandard3 interface

RowTextHeight

IMcadPartListStandard3 interface

RowTextMarginBottom

IMcadPartListStandard3 interface

RowTextMarginLeft

IMcadPartListStandard3 interface

RowTextMarginRight

IMcadPartListStandard3 interface

RowTextMarginTop

IMcadPartListStandard3 interface

RowTextStyle

IMcadPartListStandard3 interface

RowTextTrueColor

IMcadPartListStandard3 interface

S

Sample Code

SamplingLengthValue

IMcadSurfaceTexture interface

SaveSimplifiedOuterContour

IMcadHideSituation interface

sbAbove enumeration member

sbAboveDirectionArrowLine enumeration member

sbAboveDirectionArrowSymbol enumeration member

sbAngularity enumeration member

sbAnnotLabelAbove enumeration member

sbAnnotLabelBelow enumeration member

sbArcSegmentCenter enumeration member

sbArcSegmentSecond enumeration member

sbArrowAcadArchTick enumeration member

sbArrowAcadBoxBlank enumeration member

sbArrowAcadBoxFilled enumeration member

sbArrowAcadClosed enumeration member

sbArrowAcadClosedBlank enumeration member

sbArrowAcadClosedFilled enumeration member

sbArrowAcadDatumBlank enumeration member

sbArrowAcadDatumFilled enumeration member

sbArrowAcadDot enumeration member

sbArrowAcadDotBlank enumeration member

sbArrowAcadDotSmall enumeration member

sbArrowAcadIntegral enumeration member

sbArrowAcadNone enumeration member

sbArrowAcadOblique enumeration member

sbArrowAcadOpen enumeration member

sbArrowAcadOpen30 enumeration member

sbArrowAcadOpen90 enumeration member

sbArrowAcadOrigin enumeration member

sbArrowAcadOrigin2 enumeration member

sbArrowAcadSmall enumeration member

sbArrowBoxBlank enumeration member

sbArrowBoxFilled enumeration member

sbArrowClosed enumeration member

sbArrowClosed15 enumeration member

sbArrowClosed30 enumeration member

sbArrowClosed60 enumeration member

sbArrowClosed90 enumeration member

sbArrowDatumBlank45 enumeration member

sbArrowDatumBlank60 enumeration member

sbArrowDatumFilled45 enumeration member

sbArrowDatumFilled60 enumeration member

sbArrowDatumThickLine enumeration member

sbArrowDot enumeration member

sbArrowDotBlank enumeration member

sbArrowDotBlankSmall enumeration member

sbArrowDotSmall enumeration member

sbArrowEmpty enumeration member

sbArrowEmpty15 enumeration member

sbArrowEmpty30 enumeration member

sbArrowEmpty60 enumeration member

sbArrowEmpty90 enumeration member

sbArrowEmptyHalf enumeration member

sbArrowFilled enumeration member

sbArrowFilled15 enumeration member

sbArrowFilled20 enumeration member

sbArrowFilled30 enumeration member

sbArrowFilled60 enumeration member

sbArrowFilled90 enumeration member

sbArrowFilledHalf enumeration member

sbArrowOblique enumeration member

sbArrowOpen enumeration member

sbArrowOpen15 enumeration member

sbArrowOpen30 enumeration member

sbArrowOpen60 enumeration member

sbArrowOpen90 enumeration member

sbArrowOrigin enumeration member

sbAssembly enumeration member

sbAssociationBacking enumeration member

sbAssociationMirrorStagger enumeration member

sbAssociationMoveStagger enumeration member

sbAssociationSpacer enumeration member

sbAssociationSpecialStagger enumeration member

sbAttach enumeration member

sbAttachBottom enumeration member

sbAttachLeft enumeration member

sbAttachRight enumeration member

sbAttachTop enumeration member

sbAxiality enumeration member

sbBackLendingWeld enumeration member

sbBackWeld enumeration member

sbBalloon enumeration member

sbBasic enumeration member

sbBelow enumeration member

sbBetween enumeration member

sbBetweenPlanes enumeration member

sbBevelGrooveShapeWeld enumeration member

sbBevelGrooveWeld enumeration member

sbBottomBottomLine enumeration member

sbBottomLeft enumeration member

sbBottomNote enumeration member

sbBottomRight enumeration member

sbBottomText enumeration member

sbBottomTopLine enumeration member

sbByStandard enumeration member

sbByStandardBalloon enumeration member

sbCategory enumeration member

sbCenter enumeration member

sbChamfer enumeration member

sbCircular enumeration member

sbCircular2Balloon enumeration member

sbCircularBalloon enumeration member

sbCircularity enumeration member

sbCircularRelativeToCenter enumeration member

sbComments enumeration member

sbConcaveContour enumeration member

sbConcaveSmoothContour enumeration member

sbConcentricity enumeration member

sbConsInsert enumeration member

sbContains enumeration member

sbContentOverride enumeration member

sbContinuous enumeration member

sbConvexContour enumeration member

sbCorner enumeration member

sbCounterBore enumeration member

sbCounterSink enumeration member

sbCrossedIn2SlantDirections enumeration member

sbCutEnforceWeld enumeration member

sbCylindricity enumeration member

sbDatumId enumeration member

sbDatumPrimary enumeration member

sbDatumPrimary2 enumeration member

sbDatumSecondary enumeration member

sbDatumSecondary2 enumeration member

sbDatumTertiary enumeration member

sbDatumTertiary2 enumeration member

sbDefSize enumeration member

sbDescription enumeration member

sbDescription2 enumeration member

sbDetailViewBorderLineColor enumeration member

sbDetailViewBorderLineType enumeration member

sbDetailViewBorderLineWeight enumeration member

sbDetailViewBoundaryLineColor enumeration member

sbDetailViewBoundaryLineType enumeration member

sbDetailViewBoundaryLineWeight enumeration member

sbDetailViewConnectionLineColor enumeration member

sbDetailViewConnectionLineType enumeration member

sbDetailViewConnectionLineWeight enumeration member

sbDetailViewIdentifierTextColor enumeration member

sbDetailViewIdentifierTextHeight enumeration member

sbDetailViewIdentifierTextStyle enumeration member

sbDetailViewLabelTextColor enumeration member

sbDetailViewLabelTextHeight enumeration member

sbDetailViewLabelTextStyle enumeration member

sbDetailViewSymbol enumeration member

sbDetailViewSymbolColor enumeration member

sbDiameter enumeration member

sbDimension enumeration member

sbDoesNotCont enumeration member

sbDrawingManagerID enumeration member

sbEdgeLibrary enumeration member

sbEdgeMax enumeration member

sbEdgeMin enumeration member

sbEdgeSign enumeration member

sbEdgeWeld enumeration member

sbEmptyBalloon enumeration member

sbEndCuttingPlane enumeration member

sbEndDirectionArrow enumeration member

sbEnvelope enumeration member

sbEqual enumeration member

sbExamination enumeration member

sbExcludeStdParts enumeration member

sbFCFLibrary enumeration member

sbFieldWeld enumeration member

sbFieldWeldEmpty enumeration member

sbFillet enumeration member

sbFilletWeld enumeration member

sbFilter enumeration member

sbFilterBallooned enumeration member

sbFilterBasic enumeration member

sbFilterCustom enumeration member

sbFilterParts enumeration member

sbFilterRange enumeration member

sbFilterSheet enumeration member

sbFilterStdParts enumeration member

sbFilterView enumeration member

sbFit enumeration member

sbFlangeCornerWeld enumeration member

sbFlangeEdgeWeld enumeration member

sbFlareBevelGrooveWeld enumeration member

sbFlareVGrooveWeld enumeration member

sbFlatness enumeration member

sbFlushContour enumeration member

sbFlushFinishedContour enumeration member

sbFoldJointWeld enumeration member

sbFormat enumeration member

sbFormulaOverride enumeration member

sbFraction enumeration member

sbFreeState enumeration member

sbGeneralText enumeration member

sbGluing enumeration member

sbGreater enumeration member

sbGreaterEqual enumeration member

sbHalfRoundedWeld enumeration member

sbHalfWWeld enumeration member

sbHoleDrilled enumeration member

sbHorizontal enumeration member

sbIdentificationArrowSide enumeration member

sbIdentificationOtherSide enumeration member

sbImportOverride enumeration member

sbInclinedJointWeld enumeration member

sbInteger enumeration member

sbIntermittentWeld enumeration member

sbItem enumeration member

sbJGrooveWeld enumeration member

sbLeastMaterialCondition enumeration member

sbLeft enumeration member

sbLeftSide enumeration member

sbLess enumeration member

sbLessEqual enumeration member

sbLine enumeration member

sbLinearBalloon enumeration member

sbLineSegment enumeration member

sbMass enumeration member

sbMassOverride enumeration member

sbMaterial enumeration member

sbMaterial2 enumeration member

sbMaximumMaterialCondition enumeration member

sbMeltThrough enumeration member

sbMiddleBottomLine enumeration member

sbMiddleText enumeration member

sbMiddleTopLine enumeration member

sbMultiDirection enumeration member

sbName enumeration member

sbNAngleBalloon enumeration member

sbNoArrow enumeration member

sbNoAssociation enumeration member

sbNoBalloon enumeration member

sbNoFraction enumeration member

sbNoIdentificationLine enumeration member

sbNoLines enumeration member

sbNone enumeration member

sbNoOverride enumeration member

sbNoPoint enumeration member

sbNoSymbol enumeration member

sbNoTarget enumeration member

sbNote enumeration member

sbNotEqual enumeration member

sbNotSpecified enumeration member

sbNumber enumeration member

sbOpenContourWeld enumeration member

sbOther enumeration member

sbOverlapping enumeration member

sbParallelism enumeration member

sbParallelToPlane enumeration member

sbPart enumeration member

sbParticulateNonDirectional enumeration member

sbPartID enumeration member

sbPartListName enumeration member

sbPartListPath enumeration member

sbPartNumber enumeration member

sbPattern enumeration member

sbPercentage enumeration member

sbPermanentBackingStripWeld enumeration member

sbPerpendicularity enumeration member

sbPerpendicularToPlane enumeration member

sbPlugWeld enumeration member

sbPoint enumeration member

sbPosition enumeration member

sbPrice enumeration member

sbProfileLine enumeration member

sbProfileSection enumeration member

sbProfileSurface enumeration member

sbProjectedToleranceZone enumeration member

sbProjectedZone enumeration member

sbQtyOverride enumeration member

sbQuantity enumeration member

sbRadialRelativeToCenter enumeration member

sbRatio enumeration member

sbReal enumeration member

sbReciprocityCondition enumeration member

sbRectangular enumeration member

sbRegardlessOfFeatureSize enumeration member

sbRemovableBackingStripWeld enumeration member

sbRemovalAllowanceSpecified enumeration member

sbRemovalOfMaterialProhibited enumeration member

sbRemovalOfMaterialRequired enumeration member

sbRight enumeration member

sbRightSide enumeration member

sbRoundedWeld enumeration member

sbRunoutCircular enumeration member

sbRunoutCircularFilled enumeration member

sbRunoutTotal enumeration member

sbRunoutTotalFilled enumeration member

sbScaleDf enumeration member

sbScalePf enumeration member

sbScarfGrooveWeld enumeration member

sbSeamOnRefLineWeld enumeration member

sbSeamWeld enumeration member

sbSecondaryFillet enumeration member

sbSectionViewEndBendLineColor enumeration member

sbSectionViewEndBendLineType enumeration member

sbSectionViewEndBendLineWeight enumeration member

sbSectionViewEndSymbol enumeration member

sbSectionViewIdentifierTextColor enumeration member

sbSectionViewIdentifierTextHeight enumeration member

sbSectionViewIdentifierTextStyle enumeration member

sbSectionViewLabelTextColor enumeration member

sbSectionViewLabelTextHeight enumeration member

sbSectionViewLabelTextStyle enumeration member

sbSectionViewPlaneLineColor enumeration member

sbSectionViewPlaneLineType enumeration member

sbSectionViewPlaneLineWeight enumeration member

sbSectionViewStartSymbol enumeration member

sbSectionViewSymbolColor enumeration member

sbSide enumeration member

sbSingleBevelBroadRootFace enumeration member

sbSingleVBroadRootFace enumeration member

sbSlope1 enumeration member

sbSlope2 enumeration member

sbSlotWeld enumeration member

sbSmoothContour enumeration member

sbSmoothWeld enumeration member

sbSoldering enumeration member

sbSpecialStaggerWeld enumeration member

sbSplitLeft enumeration member

sbSplitRight enumeration member

sbSplitRows enumeration member

sbSplitSections enumeration member

sbSpotOnRefLineWeld enumeration member

sbSpotWeld enumeration member

sbSquare enumeration member

sbSqureGrooveWeld enumeration member

sbStandard enumeration member

sbStandard2 enumeration member

sbStartDirectionArrow enumeration member

sbStatisticalTolerance enumeration member

sbStdPartsOnly enumeration member

sbSteepFlankedBevelWeld enumeration member

sbSteepFlankedVWeld enumeration member

sbStitching enumeration member

sbStraightness enumeration member

sbStudWeld enumeration member

sbSurfaceJointWeld enumeration member

sbSurfaceTextureLibrary enumeration member

sbSurfacingWeld enumeration member

sbSurfTextAllowance enumeration member

sbSurfTextComment enumeration member

sbSurfTextCutoff enumeration member

sbSurfTextDirLay enumeration member

sbSurfTextFirstRequirement enumeration member

sbSurfTextFourthRequirement enumeration member

sbSurfTextMaxRspac enumeration member

sbSurfTextOtherMin enumeration member

sbSurfTextOtherValue enumeration member

sbSurfTextProduction enumeration member

sbSurfTextProduction2 enumeration member

sbSurfTextRaMax enumeration member

sbSurfTextRaMin enumeration member

sbSurfTextReference enumeration member

sbSurfTextSampLength enumeration member

sbSurfTextSecondRequirement enumeration member

sbSurfTextThirdRequirement enumeration member

sbSurfTextWavines enumeration member

sbSymbol enumeration member

sbSymbol2 enumeration member

sbSymmetry enumeration member

sbTangentPlane enumeration member

sbTaper1 enumeration member

sbTaper2 enumeration member

sbToCenter enumeration member

sbToExtents enumeration member

sbTolerance enumeration member

sbTolerance2 enumeration member

sbToleranceB enumeration member

sbToleranceB2 enumeration member

sbToOrigin enumeration member

sbTop enumeration member

sbTopBottomLine enumeration member

sbTopLeft enumeration member

sbTopLineRefLine enumeration member

sbTopNote enumeration member

sbTopRight enumeration member

sbTopText enumeration member

sbTopTopLine enumeration member

sbTotalMass enumeration member

sbUGrooveWeld enumeration member

sbUnderlineAllText enumeration member

sbUnitOfMeasure enumeration member

sbUnknownType enumeration member

sbUser1 enumeration member

sbUser2 enumeration member

sbUser3 enumeration member

sbUser4 enumeration member

sbUser5 enumeration member

sbUser6 enumeration member

sbUser7 enumeration member

sbUser8 enumeration member

sbUserArrowDialog enumeration member

sbUserArrowType enumeration member

sbUserBalloon enumeration member

sbUserDirect enumeration member

sbUserDirectionLayType enumeration member

sbUserID enumeration member

sbUserSymbolGDT enumeration member

sbUserSymbolType enumeration member

sbUVWeld enumeration member

sbVaries enumeration member

sbVendor enumeration member

sbVertical enumeration member

sbVGrooveWeld enumeration member

sbWeldAllAround enumeration member

sbWeldAllAroundSquare enumeration member

sbWeldAngle enumeration member

sbWeldBacking enumeration member

sbWeldBrazing enumeration member

sbWeldClearance enumeration member

sbWeldContour enumeration member

sbWeldControlCategory enumeration member

sbWeldDepth enumeration member

sbWeldDesignation enumeration member

sbWeldFinishing enumeration member

sbWeldGap enumeration member

sbWeldGroovedRoot enumeration member

sbWeldIndex enumeration member

sbWeldIndexTotal enumeration member

sbWeldingLibrary enumeration member

sbWeldingTail enumeration member

sbWeldLength enumeration member

sbWeldMullded enumeration member

sbWeldNotes enumeration member

sbWeldNumber enumeration member

sbWeldPitch enumeration member

sbWeldSecondarySymbol enumeration member

sbWeldSize enumeration member

sbWeldSize2 enumeration member

sbWeldSizeSymbol enumeration member

sbWeldSpacing enumeration member

sbWeldSpecification enumeration member

sbWeldStandard enumeration member

sbWeldTechnicalReq enumeration member

sbWeldThickness enumeration member

sbWithBurr enumeration member

sbWithoutBurr enumeration member

sbWrap enumeration member

sbWWeld enumeration member

sbWWeld2 enumeration member

sbZigZagBalloon enumeration member

sbZigzagWeld enumeration member

sbZone enumeration member

Scale

IGeMatrix interface

IMcadStandard interface

IMcadSymbol interface

ScaleAreaMgr

IMcadSymbolBBMgr2 interface

ScaleBy

IGeEntity interface

IGeVector interface

ScaleFactor

IMcadWeldingStandard3 interface

ScaleType

IMcadScaleArea interface

SecAnnotation

IMcadJoint interface

SecondarySymType

IMcadWelding interface

IMcadWelding interface

SecondarySymTypeValue

IMcadWelding interface

IMcadWelding interface

SecondDerivativeAt

IGeAugmentedLine interface

IGeAugmentedLine interface

SecondDerivatives

IGeAugmentedLine interface

SecondRequirement

IMcadSurfaceTexture2 interface

SectionLineStandard

IMcadStandard4 interface

SectionPoints

IMcadSectionLine interface

SectionSide

IMcadSectionLine interface

SelectBOMEntity

IMcadBOMMgr interface

SelectBOMEntity32

IMcadBOMMgr interface

SelectionLockMode

IMcad2DStructureMgr4 interface

SelectionOrderMode

IMcad2DStructureMgr4 interface

SeparateDatumID

IMcadFCFStandard interface

SeparateProjected

IMcadFCFStandard interface

Set

IGeAugmentedLine interface

IGeCircularArc interface

IGeCone interface

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeCylinder interface

IGeEllipticalArc interface

IGeLine interface

IGeLineSegment interface

IGePlane interface

IGePoint interface

IGeRay interface

IGeSphere interface

IGeSurfaceSurfaceIntersection interface

IGeTorus interface

IGeVector interface

IMcadRevisionList interface

SetAllSuggestedListsToDefaults

IMcadSurfaceTextureStandard2 interface

SetAttribute

IMcadBOMItem2 interface

SetAttributePreDefinedListValue

IMcadBOMItem3 interface

IMcadPartReference2 interface

SetBasicScale

IMcadScaleArea interface

SetBoundary

IGeCurveBoundary interface

SetByStandard

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

SetCompatibilityCondition

IMcadNoteStandard interface

SetCondition

IMcadPartListCustomFilter interface

SetCurrentSymbolStandard

IMcadStandard interface

SetData

IMcadFormulaEvaluator interface

SetDataProvider

IMcadFormulaEvaluator interface

SetDefinitionData

IGeNurbCurve interface

IGeNurbSurface interface

SetDimensionType

IMcadTaperStandard2 interface

SetFitData

IGeNurbCurve interface

SetHidesSuppressState

IMcadFolderDefinition interface

setIsDefault

IMcadWeldingLibraryObject interface

setIsDefaultItem

IMcadSymbolLibrary interface

SetLabelNames

IMcadSectionLine interface

SetLayerObjDefault

IMcadLayerObjectMgr interface

SetMoveObjects

IMcadTitleBorderContext interface

SetPartAttribute

IMcadBOMMgr2 interface

SetPartData

IMcadBOMMgr interface

SetPartReference

IMcadTitleBorderContext interface

SetPreDefinedList

IMcadColumnDefinition3 interface

SetProperties

IMcadBOM2 interface

SetRange

IGeKnotVector interface

SetReferenceLockMode

IMcad2DStructureMgr4 interface

SetSectionArcPointAt

IMcadSectionLine interface

SetSectionPointAt

IMcadSectionLine interface

SetSectionPoints

IMcadSectionLine interface

SetSectionViewOrigin

IMcadSectionLine interface

SetSourceGeometry

IMcadDetailSymbol interface

SetStructureMode

IMcad2DStructureMgr4 interface

SetSuggestedListToDefaults

IMcadSurfaceTextureStandard2 interface

SetTargetAttach

IMcadDatumTarget2 interface

SetToAlignCoordinateSystem

IGeMatrix interface

SetToCoordinateSystem

IGeMatrix interface

SetToDefaultAttributes

IMcadBorder interface

IMcadTitle interface

SetToDefaults

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadStandard interface

IMcadSymbol interface

IMcadSymbolStandard interface

SetToDefaultTemplate

IMcadNoteStandard interface

SetToDefaultTextLeader

IMcadSymbolStandard2 interface

SetToIdentity

IGeMatrix interface

SetToMirroring

IGeMatrix interface

SetToProduct

IGeMatrix interface

IGeVector interface

SetToProjection

IGeMatrix interface

SetToRotation

IGeMatrix interface

SetToScaling

IGeMatrix interface

SetToSum

IGeVector interface

SetToTranslation

IGeMatrix interface

setWrapPListAttachPoint

IMcadPartList3 interface

ShowAnnotationLeader

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

ShowBorder

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

ShowLabel

IMcadDetailSymbolStandard2 interface

ShowLeader

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

SignedDistanceTo

IGePlane interface

SignValue

IMcadEdge interface

SingularityInU

IGeNurbSurface interface

SingularityInV

IGeNurbSurface interface

Size

IMcadColumnDefinition interface

Size2Value

IMcadWelding interface

IMcadWelding interface

SizeType

IMcadWelding interface

IMcadWelding interface

SizeTypeValue

IMcadWelding interface

IMcadWelding interface

SizeValue

IMcadWelding interface

IMcadWelding interface

SkipAfterPart

IMcadPartListGOST interface

SkipLines

IMcadPartListGOST interface

SortChildren

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolderDefinition interface

SortPriority

IMcadBOMItem3 interface

SouthPole

IGeSphere interface

SpacingValue

IMcadWelding interface

IMcadWelding interface

SpecByAbsoluteScale

IMcadDetailSymbol interface

SpecificationValue

IMcadWelding interface

IMcadWelding interface

Sphere

IGeApplication interface

Split

IGeKnotVector interface

SplitItem

IMcadBOM4 interface

sqcm enumeration member

sqft enumeration member

sqin enumeration member

sqm enumeration member

Standard

IMcadSymbol interface

IMcadSymbolStandard interface

StandardCount

IMcadStandardMgr interface

StandardMgr

IMcadStandard interface

IMcadSymbolBBMgr interface

standardName

IMcadSymbolLibraryObject interface

StandardNames

IMcadStandardMgr interface

StandardNumAllowed

IMcadEdgeStandard interface

StandardNumber

IMcadEdge interface

IMcadEdgeLibraryObject interface

Standards

IMcadStandardMgr interface

StandardValue

IMcadWelding interface

IMcadWelding interface

StartAngle

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

StartAngleInU

IGeTorus interface

StartAngleInV

IGeTorus interface

StartLatitude

IGeSphere interface

StartLongitude

IGeSphere interface

StartParameter

IGeKnotVector interface

IGeNurbCurve interface

StartPoint

IGeEllipticalArc interface

IGeLineSegment interface

IGeNurbCurve interface

StartTransaction

IMcad2DStructureMgr2 interface

Static

IMcadAttributeField interface

StructureMgr2D

IMcadDocument interface

StructureModeEditEntity

IAcadmApplication interface

Subents

IMcadHideSituation interface

SubSymbolType

IMcadSurfaceTextureLibraryObject interface

IMcadTaper interface

SubWeldingCount

IMcadWelding interface

SuggestedList

IMcadSurfaceTextureStandard2 interface

IMcadSurfaceTextureStandard2 interface

Sum

IGePoint interface

IGeVector interface

SupportedArrowTypes

IMcadStandard4 interface

IMcadSymbolStandard3 interface

Suppressed

IMcadComplexHideSituation interface

IMcadHideSituation interface

Surface

IGeCurveSurfaceIntersection interface

Surface1

IGeSurfaceSurfaceIntersection interface

Surface2

IGeSurfaceSurfaceIntersection interface

SurfaceTexture

IMcadSurfaceTexture interface

SurfaceTextureStandard

IMcadStandard interface

SurfExtLinesOffset

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

IMcadSurfaceTexture3 interface

SurfExtLinesOvershot

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

IMcadSurfaceTexture3 interface

SurfIndLeaderArrowScale

IMcadFCFStandard2 interface

IMcadIdentifierStandard2 interface

IMcadSurfaceTextureStandard3 interface

SurfIndLeaderArrowType

IMcadDatumIdentifier3 interface

IMcadFCFStandard2 interface

IMcadFeatureControlFrame4 interface

IMcadIdentifierStandard2 interface

IMcadSurfaceTextureStandard3 interface

SwapFgAndBg

IMcadHideSituation interface

Swell

IGeBoundBlock interface

SymBBAuto

SymBBAuto library

SymBBAuto::McadAnnotationViewLabel

SymBBAuto::McadAnnotationViewStandard

SymBBAuto::McadBalloon

SymBBAuto::McadBalloons

SymBBAuto::McadBalloonStandard

SymBBAuto::McadBOM

SymBBAuto::McadBOMItem

SymBBAuto::McadBOMItems

SymBBAuto::McadBOMMgr

SymBBAuto::McadBOMs

SymBBAuto::McadBOMStandard

SymBBAuto::McadBorder

SymBBAuto::McadColumnDefinition

SymBBAuto::McadColumnDefinitions

SymBBAuto::McadDatumIdentifier

SymBBAuto::McadDatumStandard

SymBBAuto::McadDatumTarget

SymBBAuto::McadDetailSymbol

SymBBAuto::McadDetailSymbolLabel

SymBBAuto::McadDetailSymbolStandard

SymBBAuto::McadEdge

SymBBAuto::McadEdgeLibrary

SymBBAuto::McadEdgeLibraryObject

SymBBAuto::McadEdgeStandard

SymBBAuto::McadFCFLibrary

SymBBAuto::McadFCFLibraryObject

SymBBAuto::McadFCFStandard

SymBBAuto::McadFeatureControlFrame

SymBBAuto::McadFeatureIdentifier

SymBBAuto::McadIdentifier

SymBBAuto::McadIdentifierStandard

SymBBAuto::McadJoint

SymBBAuto::McadJointStandard

SymBBAuto::McadMarkStamp

SymBBAuto::McadMarkStampStandard

SymBBAuto::McadNote

SymBBAuto::McadNoteStandard

SymBBAuto::McadPartList

SymBBAuto::McadPartListBalloonedFilter

SymBBAuto::McadPartListCustomFilter

SymBBAuto::McadPartListFilter

SymBBAuto::McadPartListFilters

SymBBAuto::McadPartListGOST

SymBBAuto::McadPartLists

SymBBAuto::McadPartListStandard

SymBBAuto::McadPartListStdPartsFilter

SymBBAuto::McadPartReference

SymBBAuto::McadPartReferences

SymBBAuto::McadRevisionList

SymBBAuto::McadRevisionListDescriptor

SymBBAuto::McadRevisionLists

SymBBAuto::McadRevisionMgr

SymBBAuto::McadScaleArea

SymBBAuto::McadScaleAreaMgr

SymBBAuto::McadSectionLine

SymBBAuto::McadSectionLineStandard

SymBBAuto::McadStandard

SymBBAuto::McadStandardMgr

SymBBAuto::McadStandards

SymBBAuto::McadSurfaceTexture

SymBBAuto::McadSurfaceTextureLibrary

SymBBAuto::McadSurfaceTextureLibraryObject

SymBBAuto::McadSurfaceTextureStandard

SymBBAuto::McadSymbol

SymBBAuto::McadSymbolBBMgr

SymBBAuto::McadSymbolLibrary

SymBBAuto::McadSymbolLibraryObject

SymBBAuto::McadSymbolLibraryObjects

SymBBAuto::McadSymbolStandard

SymBBAuto::McadSymbolStandards

SymBBAuto::McadTaper

SymBBAuto::McadTaperStandard

SymBBAuto::McadTitle

SymBBAuto::McadTitleBorder

SymBBAuto::McadTitleBorderContext

SymBBAuto::McadTitleBorderDescriptor

SymBBAuto::McadTitleBorderMgr

SymBBAuto::McadTitleBorders

SymBBAuto::McadTitleBorderStandard

SymBBAuto::McadWelding

SymBBAuto::McadWeldingLibrary

SymBBAuto::McadWeldingLibraryObject

SymBBAuto::McadWeldingStandard

Symbol

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

Symbol2

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

Symbol3

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

SymbolBBMgr

IMcadBOMMgr interface

IMcadStandardMgr interface

SymbolColor

IMcadStandard interface

SymbolEntity

IMcadDetailSymbolLabel interface

SymbolLibrary

IMcadSymbolBBMgr3 interface

SymbolStandard

IMcadSymbol interface

symbolStandardClassName

IMcadSymbolLibraryObject interface

SymbolStandardClassName

IMcadSymbolStandard3 interface

SymbolStandardsSupported

IMcadStandard interface

SymbolTrueColor

IMcadStandard2 interface

SymbolType

IMcadJoint interface

IMcadMarkStamp interface

SysName

IMcadComplexHideSituation interface

IMcadHideSituation interface

T

TangentAt

IGeCircularArc interface

TangentTangent

IGeLineSegment interface

TangentTangentRadius

IGeCircularArc interface

TangentTangentTangent

IGeCircularArc interface

TangentTo

IGeLineSegment interface

TaperStandard

IMcadStandard3 interface

Target

IMcadBOM interface

TargetOrigin

IMcadDatumTarget interface

TargetType

IMcadDatumTarget interface

TargetView

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

TechnicalReqValue

IMcadMarkStamp interface

IMcadWelding interface

IMcadWelding interface

TextAlignment

IMcadNote interface

TextColor

IMcadStandard interface

TextHeight

IMcadBalloonStandard interface

IMcadStandard interface

IMcadSymbolStandard2 interface

TextHeightList

IMcadStandard interface

TextScalingFactor

IMcadScaleArea interface

TextStyle

IMcadStandard interface

TextStyleName

IMcadStandard interface

TextTrueColor

IMcadStandard2 interface

IMcadSymbolStandard2 interface

ThawAllLayers

IMcadTitleBorderContext interface

ThicknessValue

IMcadWelding interface

IMcadWelding interface

ThirdRequirement

IMcadSurfaceTexture2 interface

ThreadNote

IMcadDatumIdentifier3 interface

ThreePoint

IGeCircularArc interface

Title

IMcadPartList interface

IMcadTitleBorderDescriptor interface

TitleBlocks

IMcadTitleBorderStandard interface

TitleBorderMgr

IMcadSymbolBBMgr2 interface

TitleBorders

IMcadTitleBorderMgr interface

TitleBorderScale

IMcadTitleBorderDescriptor interface

TitleBorderStandard

IMcadStandard3 interface

Tolerance

IGeApplication interface

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeKnotVector interface

IGeSurfaceSurfaceIntersection interface

Tolerance2Value

IMcadFeatureControlFrame interface

Tolerance3Value

IMcadFeatureControlFrame interface

ToleranceB2Value

IMcadFeatureControlFrame interface

ToleranceBValue

IMcadFeatureControlFrame interface

ToleranceValue

IMcadFeatureControlFrame interface

TopNoteValue

IMcadFeatureControlFrame2 interface

Torus

IGeApplication interface

Transformation

IGeOffsetCurve interface

TransformBy

IGeEntity interface

IGeVector interface

TranslateBy

IGeEntity interface

Translation

IGeMatrix interface

Transpose

IGeMatrix interface

TransposeIt

IGeMatrix interface

TrimByParameters

IGeNurbCurve interface

TrueColor

IMcadBalloonStandard2 interface

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

Type

IMcadPartListFilter2 interface

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

Type Libraries and Object Models

U

UControlPointCount

IGeNurbSurface interface

UKnotCount

IGeNurbSurface interface

UKnots

IGeNurbSurface interface

UndefsizeDirection

IMcadEdge interface

IMcadEdgeLibraryObject interface

Unknown enumeration member

UParameterEnvelope

IGeSurface interface

Update

IMcad2DStructureMgr interface

IMcadComponentDefinition interface

UpdateBgSelection

IMcadComplexHideSituation interface

UpdateEntities

IMcad2DStructureMgr interface

IMcad2DStructureMgr3 interface

UpdateSymbols

IMcadStandardMgr interface

UpdateToAttachedObject

IMcadSymbol2 interface

Upper

IGeInterval interface

UseMapping

IMcadPartListStandard interface

Utility

IMcadDocument interface

V

Value

IMcadIdentifier interface

VControlPointCount

IGeNurbSurface interface

Vector

IGeApplication interface

VectorAt

IGeAugmentedLine interface

IGeAugmentedLine interface

Vectors

IGeAugmentedLine interface

ViewID

IMcadPartList interface

ViewID32

IMcadPartList interface

ViewKey

IMcadFolderDescriptor interface

ViewName

IMcadFolder interface

IMcadFolderDescriptor interface

Views

IMcad2dComplexStdPartCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor interface

IMcadFolderDescriptor interface

ViewScale

IMcadFolder interface

ViewType

IMcadFolderDefinition interface

VisibilityOverride

IMcadComponent interface

IMcadFolder interface

Visible

IMcadComponent interface

IMcadFolder interface

VKnotCount

IGeNurbSurface interface

VKnots

IGeNurbSurface interface

VParameterEnvelope

IGeSurface interface

W

WasErased

IMcadObject interface

WavinessValue

IMcadSurfaceTexture interface

WeightAt

IGeNurbCurve interface

IGeNurbCurve interface

WeightCount

IGeNurbCurve interface

Weights

IGeNurbCurve interface

IGeNurbSurface interface

WeldingStandard

IMcadStandard interface

WeldProcessPrefix

IMcadWeldingStandard2 interface

Width

IMcadColumnDefinition interface

IMcadPartList interface

WrapAroundTitle

IMcadPartList3 interface

WrapText

IMcadPartList interface

IMcadPartListStandard interface

WrapTitleBlockId

IMcadPartList3 interface

WrapTitleBlockId32

IMcadPartList3 interface

WriteAttributeClass

IAcadmApplication interface

X

X

IGePoint interface

IGeVector interface

Y

Y

IGePoint interface

IGeVector interface

yd enumeration member

Z

Z

IGePoint interface

IGeVector interface


Introduction
Introduction

This Reference Guide briefly introduces the basics for COM objects, and their associated methods and properties in AutoCAD Mechanical ActiveX Automation, which provides a mechanism to manipulate AutoCAD Mechanical programmatically from within or outside of AutoCAD Mechanical. It does this by exposing various objects to the "outside world." Once these objects are exposed, they can be accessed by many different programming languages and environments, or from within other applications such as Microsoft Word VBA™ or Excel VBA™.

AutoCAD Mechanical ActiveX Automation contains three parts of type libraries, including SymBBAuto (Symbols, Balloons, and Bills Of Materials), AcadmAuto (AutoCAD Mechanical), and GEAuto (Geometry), as well as Mcad2DSPreview Active Control Module.

An object is the main building block of any ActiveX Automation application. The objects are structured in a hierarchical fashion, with the AcadmApplication object at the root. The object hierarchy fits into the AutoCAD Mechanical object hierarchy and both work together to represent various aspects of a concrete mechanical design model.