What's New

You are here: What's New
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
What's New
Send Feedback
New in SymBBAuto
Topic | Summary
IMcadWeldingStandard3 Interface | Use this class to handle settings to weld symbols in current standard.
Copyright (c) 2014. All rights reserved.
Contents | Index
What do you think about this topic? Send feedback!


Introduction

You are here: Introduction
Introduction
Send Feedback
Introduction

This Reference Guide briefly introduces the basics for COM objects, and their associated methods and properties in AutoCAD Mechanical ActiveX Automation, which provides a mechanism to manipulate AutoCAD Mechanical programmatically from within or outside of AutoCAD Mechanical. It does this by exposing various objects to the "outside world." Once these objects are exposed, they can be accessed by many different programming languages and environments, or from within other applications such as Microsoft Word VBA™ or Excel VBA™.

AutoCAD Mechanical ActiveX Automation contains three parts of type libraries, including SymBBAuto (Symbols, Balloons, and Bills Of Materials), AcadmAuto (AutoCAD Mechanical), and GeAuto (Geometry), as well as Mcad2DSPreview Active Control Module.

An object is the main building block of any ActiveX Automation application. The objects are structured in a hierarchical fashion, with the AcadmApplication object at the root. The object hierarchy fits into the AutoCAD Mechanical object hierarchy and both work together to represent various aspects of a concrete mechanical design model.

Copyright (c) 2014. All rights reserved.
Contents | Index | Home


Type Libraries and Object Models

You are here: Type Libraries and Object Models
Type Libraries and Object Models
Send Feedback
Type Libraries and Object Models

A type library file contains standard descriptions of exposed objects, methods, and properties that are available for Automation. AutoCAD Mechanical ActiveX Automation contains the following type libraries:

Type Library | Description
AcadmAuto | Autodesk AutoCAD Mechanical (AcadmAuto) 1.0 Type Library is used for mechanical structure objects and provides access to the root of the object hierarchy in AutoCAD Mechnical ActiveX Automation.
SymBBAuto | Autodesk SymBBAuto 3.0 Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided. Note: the file name of the library on disk is symbbauto[xxx].tlb where xxx denotes the language version, for example 'enu' for English.
GeAuto | Autodesk GeAuto 2.0 Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.

To start the Microsoft Visual Basic Editor, open the AutoCAD Mechanical. On the toolbar, click Assist > Macro > Visual Basic Editor. The Microsoft Visual Basic window is displayed. To use the AutoCAD Mechanical type libraries, you must set a reference to specified type libraries:

  1. In the Microsoft Visual Basic Editor, click Tools > References.
  2. In the References dialog box, select the check boxes for the type libraries as shown in the following image:

In addition to the preceding three type libraries, AutoCAD Mechnical provides an Mcad2DSPreview Active Control Module that is installed under the root path of Mechnical Desktop. In the Visual Basic Editor, when editing a user form, you can add this control:

  1. Click Tools > Additional Controls.
  2. In the Additional Controls dialog box, select the Mcad2DSPreview Control check box as show below:

Note: Mechnical Desktop VBA can interact with the above type libraries through the AutoCAD Mechnical API to get the related support and achieve a high degree of integration between AutoCAD-based applications.

Object Models

The following diagrams show the object model for each type library:

AcadmAuto

SymBBAuto

GeAuto

Copyright (c) 2014. All rights reserved.


API Reference

You are here: API Reference
API Reference
Libraries Topics Send Feedback
Libraries
Name | Description
AcadmAuto | The Autodesk AutoCAD Mechanical Type Library is used for AutoCAD Mechanical ActiveX Automation. It contains the classes, functions, and properties pertaining to 2D structure.
SymBBAuto | The Autodesk SymBBAuto 3.0 Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided.
GEAuto | The Autodesk GeAuto Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.
Topics
Name | Description
Mcad2DSPreview | Mechanical Structure Preview ActiveX Control (Mcad2DSPreview). Allows users to display a thumbnail bitmap of a block, a list of entities, a folder, a component view, or an entire component (tiled views).
Links
Libraries, Topics
Copyright (c) 2014. All rights reserved.


AcadmAuto Library

You are here: API Reference > AcadmAuto Library
AcadmAuto Library
CoClasses Enumerations API Reference Interfaces Legend Send Feedback
Summary

The Autodesk AutoCAD Mechanical Type Library is used for AutoCAD Mechanical ActiveX Automation. It contains the classes, functions, and properties pertaining to 2D structure.

CoClasses
Name | Description
AcadmApplication | The AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
Mcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group. The types of complex standard parts are screw connections and part features.
Mcad2dComponentDescriptor | Provides a description of a 2D component.
Mcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
Mcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
Mcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
Mcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
McadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing. Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.
McadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
McadArc | An arc curve.
McadAttribute | Represents an instance of an attribute.
McadAttributeField | Represents the description of a single attribute field.
McadAttributeFields | A collection of McadAttributeField objects.
McadAttributes | A collection of McadAttribute objects.
McadAugmentedLine | A multisegmented curve with normal information at the nodes.
McadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
McadComplexHideSituations | A collection of McadComplexHideSituation objects
McadComponent | References an instance of a component definition in the assembly.
McadComponentDefinition | References the definition of an assembly component.
McadComponentDefinitions | A collection of McadcomponentDefinition objects.
McadComponents | A collection of McadComponent objects.
McadComponentView | A collection of McadComponentView objects.
McadComponentViewDefinition | References the definition of a component view.
McadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
McadComponentViewDescriptor | Encapsulates the description of a 2D component view.
McadComponentViews | A collection of McadComponentView objects.
McadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
McadDocuments | The collection of McadDocument objects present in the application.
McadEllipse | An ellipse or elliptical arc object.
McadFolder | References an instance of a folder definition.
McadFolderDefinition | A collection of McadFolderDefinition objects.
McadFolderDefinitions | A collection of McadFolderDefinition objects.
McadFolderDescriptor | Encapsulates the description of a folder.
McadFolders | A collection of McadFolder objects.
McadFormulaEvaluator | This object provides general methods for Standard Data provider
McadHideSituation | This object provides general methods for 2D structure hide situations.
McadHideSituations | This object provides general methods for 2D structure hide situations.
McadLayerCfg | This is class AcadmAuto::McadLayerCfg.
McadLayerCfgs | This is class AcadmAuto::McadLayerCfgs.
McadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
McadLayerObjectCfg | This is class AcadmAuto::McadLayerObjectCfg.
McadLayerObjectCfgs | This is class AcadmAuto::McadLayerObjectCfgs.
McadLayerObjectMgr | This is class AcadmAuto::McadLayerObjectMgr.
McadLine | An unbounded line object.
McadObjects | A collection of IMcadObject subtype objects.
McadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
McadPolyline | A polyline object.
McadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
McadSpline | A spline object.
McadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
McadTransaction | The McadTransaction object. These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.
McadUtility | This API provides some general utility methods.
Enumerations
Name | Description
Mcad2DSViewType | Enumerates the 2D structure view types.
McadCollectionType | Enumerates all collection types for which to create the new collection. Some of collection types can only be used in Mechanical Desktop. mcAttributeFields : Specifies the collection of attribute fields. mcAttributes : Specifies the collection of attributes. mcComponentDefinitions : Specifies the collection of component definitions. mcComponents : Specifies the collection of components. mcObjects : Specifies the collection of Mcad objects. mcComponentViews : Specifies the collection of component views. mcComponentViewDefinitions : Specifies the collection of component view definitions. mcFolders : Specifies the collection of folders. mcFolderDefinitions : Specifies the collection of folder definitions. mcAnnotationViewDefinitions : Specifies the collection of the annotation... more
McadDocDrawingType | type McadDocDrawingType
McadFieldType | Enumerates the field value types. mcShort : Indicates the field value is Short. mcLong : Indicates the field value is Long. mcDouble : Indicates the field value is a Double. mcCharacter : Indicates the field value is Character. mcShortArray : Indicates the field value is Array of Short. mcLongArray : Indicates the field value is Array of Long. mcDoubleArray : Indicates the field value is Array of Double. mcString : Indicates the field value is String. mcObjectID : Indicates the field value is Object ID. mcObjectIDArray : Indicates the field value is Array of Object IDs. mcMcadObject : Indicates the... more
McadHideSituationRefType | Enumerates all referenced types for this hide situation. mc2DSDirectRef : Indicates that the leaf or view instance is directly referred by hide situation. mc2DSSubEntRef : Indicates that the leaf or view instance of a subentity of the view is referenced by hide situation. mc2DSPartialRef : Indicates that the view instance is partially or fully referred by hide situation. mc2DSAllRef : It is equivalent to mc2DSDirectRef | mc2DSSubEntRef.
McadHideSituationSubentType | Enumerates all referenced hide subentity types for this hide situation. mc2DSNoEnt : Indicates that there are no subentities. mc2DSFGEnt : Indicates the foreground hide situation. mc2DSBGEnt : Indicates the background hide situation. mc2DSFGExclEnt : Indicates the foreground excluded hide situation. mc2DSBGExclEnt : Indicates the background excluded hide situation. mc2DSUpperBGExclEnt : Indicates the upper background excluded hide situation.
McadLayerObjectHideType | This is record McadLayerObjectHideType.
McadObjectType | Enumerates all generic objects within the Mechanical Desktop or AutoCAD. mcObject : Specifies the McadObject type of the object. mcGeometry : Specifies the McadObject type of the geometry. mcCurve : Specifies the McadObject type of the curve. mcLine : Specifies the McadObject type of the line. mcArc : Specifies the McadObject type of the arc. mcEllipse : Specifies the McadObject type of the ellipse. mcSpline : Specifies the McadObject type of the spline. mcPolyline : Specifies the McadObject type of the polyline. mcAaugmentedLine : Specifies the McadObject type of the augmented line. mcComponent : Specifies the McadObject type of the... more
McadPhantomState | Enumerates all phantom states. mcNormalDef : Specifies the normal state, with a value of 0. mcPhantomDef : Specifies the phantom state, with a value of 1. mcPhantomDefInCurrent : Specifies the phantom state in the current drawing, with a value of 2.
McadPowerObjectType | Enumerates the power object types. mcNoObj : Specifies no power object. mcShaftCalcObj : Specifies the shaft calculation power object. mcCamCalcObj : Specifies the cam calculation power object. mcFEAObj : Specifies the FEA power object. mcMomOfInertiaObj : Specifies the momentum of inertia power object. mcDeflLineObj : Specifies the line power object. mcScrewConObj : Specifies the screw connection of the power object. mcPartFeatObj : Specifies the part feature power object. mcShaftObj : Specifies the shaft power object. mcAllFolderPowerObj : Specifies the all folders power object.
McadSelectionOrderOption | Enumerates all available 2D Structure selection order options.
Group

API Reference

Interfaces
Name | Description
IAcadmApplication | AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
IAcadmApplicationVersion | Version of AutoCAD Mechanical application that is running
IMcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group.
IMcad2dComponentDescriptor | Provides a description of a 2D component.
IMcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
IMcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
IMcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
IMcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr2 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr3 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr4 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr5 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinition2 | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
IMcadArc | An arc curve.
IMcadAttribute | Represents an instance of an attribute.
IMcadAttributeField | Represents the description of a single attribute field.
IMcadAttributeFields | A collection of McadAttributeField objects.
IMcadAttributes | A collection of McadAttribute objects.
IMcadAugmentedLine | A multisegmented curve with normal information at the nodes.
IMcadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
IMcadComplexHideSituations | A collection of McadComplexHideSituation objects
IMcadComponent | References an instance of a component definition in the assembly.
IMcadComponentDefinition | References the definition of an assembly component.
IMcadComponentDefinitions | A collection of McadcomponentDefinition objects.
IMcadComponents | A collection of McadComponent objects.
IMcadComponentView | A collection of McadComponentView objects.
IMcadComponentViewDefinition | References the definition of a component view.
IMcadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
IMcadComponentViewDescriptor | Encapsulates the description of a 2D component view.
IMcadComponentViews | A collection of McadComponentView objects.
IMcadCurve | A generic curve entity.
IMcadDescriptor | A generic descriptor object that contains the overall description of an object.
IMcadDocuments | The collection of McadDocument objects present in the application.
IMcadDocumentVersion | Version of AutoCAD Mechanical that saved the file.
IMcadEllipse | An ellipse or elliptical arc object.
IMcadFolder | References an instance of a folder definition.
IMcadFolder2 | References an instance of a folder definition.
IMcadFolderDefinition | A collection of McadFolderDefinition objects.
IMcadFolderDefinitions | A collection of McadFolderDefinition objects.
IMcadFolderDescriptor | Encapsulates the description of a folder.
IMcadFolders | A collection of McadFolder objects.
IMcadFormulaEvaluator | This object provides general methods for Standard Data provider
IMcadGeometry | This is class IMcadGeometry.
IMcadHideSituation | This object provides general methods for 2D structure hide situations.
IMcadHideSituations | A collection of AMSHide objects.
IMcadLayerCfg | This class contains the configuration settings for a mechanical layer.
IMcadLayerCfgs | This is class IMcadLayerCfgs.
IMcadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
IMcadLayerObjectCfg | This class contains the configuration settings for a mechanical object.
IMcadLayerObjectCfgs | This is class IMcadLayerObjectCfgs.
IMcadLayerObjectMgr | This class is for accessing the layer object settings.
IMcadLine | An unbounded line object.
IMcadObject | A reference to a generic object or sub-object within the Mechanical Desktop, AutoCAD or AutoCAD Mechanical.
IMcadObjects | A collection of IMcadObject subtype objects.
IMcadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
IMcadPolyline | A polyline object.
IMcadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
IMcadSpline | A spline object.
IMcadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
IMcadUtility | This API provides some general utility methods.
IMcadUtility2 | This is class IMcadUtility2.
IMcadUtility3 | This is class IMcadUtility3.
Links
CoClasses, Enumerations, API Reference, Interfaces, Legend


AcadmApplication CoClass

You are here: API Reference > AcadmAuto Library > AcadmApplication CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
AcadmApplication CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

The AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

AcadmAuto::AcadmApplication
Visual Basic
Public Class AcadmApplication
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2dComplexStdPartCompGroupDescriptor CoClass

You are here: API Reference > AcadmAuto Library > Mcad2dComplexStdPartCompGroupDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2dComplexStdPartCompGroupDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of a 2D complex standard part component group. The types of complex standard parts are screw connections and part features.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dComplexStdPartCompGroupDescriptor
Visual Basic
Public Class Mcad2dComplexStdPartCompGroupDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2dComponentDescriptor CoClass

You are here: API Reference > AcadmAuto Library > Mcad2dComponentDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2dComponentDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of a 2D component.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dComponentDescriptor
Visual Basic
Public Class Mcad2dComponentDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2dShaftCompGroupDescriptor CoClass

You are here: API Reference > AcadmAuto Library > Mcad2dShaftCompGroupDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2dShaftCompGroupDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of the group of shaft and standard part objects that comprise a shaft power object.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dShaftCompGroupDescriptor
Visual Basic
Public Class Mcad2dShaftCompGroupDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2dStdPartComponentDescriptor CoClass

You are here: API Reference > AcadmAuto Library > Mcad2dStdPartComponentDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2dStdPartComponentDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of the 2D standard part component.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2dStdPartComponentDescriptor
Visual Basic
Public Class Mcad2dStdPartComponentDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2DStructureDescriptor CoClass

You are here: API Reference > AcadmAuto Library > Mcad2DStructureDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2DStructureDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object is the base class for 2D structure descriptors.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2DStructureDescriptor
Visual Basic
Public Class Mcad2DStructureDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


Mcad2DStructureMgr CoClass

You are here: API Reference > AcadmAuto Library > Mcad2DStructureMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2DStructureMgr CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

AcadmAuto::Mcad2DStructureMgr
Visual Basic
Public Class Mcad2DStructureMgr
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAnnotationViewDefinition CoClass

You are here: API Reference > AcadmAuto Library > McadAnnotationViewDefinition CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAnnotationViewDefinition CoClass
AcadmAuto Library Class Hierarchy Example Send Feedback
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing. Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAnnotationViewDefinition
Visual Basic
Public Class McadAnnotationViewDefinition
Example

Refer to SDK Samples: CreateStructure.dvb

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy, Example


McadAnnotationViewDefinitions CoClass

You are here: API Reference > AcadmAuto Library > McadAnnotationViewDefinitions CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAnnotationViewDefinitions CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAnnotationViewDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAnnotationViewDefinitions
Visual Basic
Public Class McadAnnotationViewDefinitions
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadArc CoClass

You are here: API Reference > AcadmAuto Library > McadArc CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadArc CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An arc curve.

Class Hierarchy

Declaration syntax

AcadmAuto::McadArc
Visual Basic
Public Class McadArc
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAttribute CoClass

You are here: API Reference > AcadmAuto Library > McadAttribute CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttribute CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Represents an instance of an attribute.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttribute
Visual Basic
Public Class McadAttribute
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAttributeField CoClass

You are here: API Reference > AcadmAuto Library > McadAttributeField CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttributeField CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Represents the description of a single attribute field.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributeField
Visual Basic
Public Class McadAttributeField
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAttributeFields CoClass

You are here: API Reference > AcadmAuto Library > McadAttributeFields CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttributeFields CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAttributeField objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributeFields
Visual Basic
Public Class McadAttributeFields
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAttributes CoClass

You are here: API Reference > AcadmAuto Library > McadAttributes CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttributes CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAttribute objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAttributes
Visual Basic
Public Class McadAttributes
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAugmentedLine CoClass

You are here: API Reference > AcadmAuto Library > McadAugmentedLine CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAugmentedLine CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

AcadmAuto::McadAugmentedLine
Visual Basic
Public Class McadAugmentedLine
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComplexHideSituation CoClass

You are here: API Reference > AcadmAuto Library > McadComplexHideSituation CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComplexHideSituation CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for 2D structure complex hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComplexHideSituation
Visual Basic
Public Class McadComplexHideSituation
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComplexHideSituations CoClass

You are here: API Reference > AcadmAuto Library > McadComplexHideSituations CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComplexHideSituations CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComplexHideSituation objects

Class Hierarchy

Declaration syntax

AcadmAuto::McadComplexHideSituations
Visual Basic
Public Class McadComplexHideSituations
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponent CoClass

You are here: API Reference > AcadmAuto Library > McadComponent CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponent CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

References an instance of a component definition in the assembly.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponent
Visual Basic
Public Class McadComponent
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentDefinition CoClass

You are here: API Reference > AcadmAuto Library > McadComponentDefinition CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentDefinition CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

References the definition of an assembly component.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentDefinition
Visual Basic
Public Class McadComponentDefinition
Remarks

From this definition, an instance of it can be created in an assembly. A component instance is represented by an McadComponent object. This component is visible as a node in the assembly browser. In order to have a representation of this visible in model space, one of its associated component view definitions must be instanced. This instantiation is known as a component view. A component view instance is represented by an McadComponentView object.

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentDefinitions CoClass

You are here: API Reference > AcadmAuto Library > McadComponentDefinitions CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentDefinitions CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadcomponentDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentDefinitions
Visual Basic
Public Class McadComponentDefinitions
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponents CoClass

You are here: API Reference > AcadmAuto Library > McadComponents CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponents CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponent objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponents
Visual Basic
Public Class McadComponents
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentView CoClass

You are here: API Reference > AcadmAuto Library > McadComponentView CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentView CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentView
Visual Basic
Public Class McadComponentView
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentViewDefinition CoClass

You are here: API Reference > AcadmAuto Library > McadComponentViewDefinition CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentViewDefinition CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

References the definition of a component view.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDefinition
Visual Basic
Public Class McadComponentViewDefinition
Remarks

Each component view definition has an associated component definition. The component view definition defines a particular view of a component definition. From this component view definition, an instance of it can be created in an assembly. The definition itself is not visible in the model; only instances of it are visible. It is important to note that a component view definition can exist without any component view instances referencing it in the assembly. The relationship between McadComponentViewDefinition and McadComponentView objects is similar to that of the AutoCAD Block and BlockRef objects.

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentViewDefinitions CoClass

You are here: API Reference > AcadmAuto Library > McadComponentViewDefinitions CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentViewDefinitions CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentViewDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDefinitions
Visual Basic
Public Class McadComponentViewDefinitions
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentViewDescriptor CoClass

You are here: API Reference > AcadmAuto Library > McadComponentViewDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentViewDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a 2D component view.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViewDescriptor
Visual Basic
Public Class McadComponentViewDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadComponentViews CoClass

You are here: API Reference > AcadmAuto Library > McadComponentViews CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadComponentViews CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadComponentViews
Visual Basic
Public Class McadComponentViews
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDocument CoClass

You are here: API Reference > AcadmAuto Library > McadDocument CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDocument CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.

Class Hierarchy

Declaration syntax

AcadmAuto::McadDocument
Visual Basic
Public Class McadDocument
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDocuments CoClass

You are here: API Reference > AcadmAuto Library > McadDocuments CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDocuments CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

The collection of McadDocument objects present in the application.

Class Hierarchy

Declaration syntax

AcadmAuto::McadDocuments
Visual Basic
Public Class McadDocuments
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadEllipse CoClass

You are here: API Reference > AcadmAuto Library > McadEllipse CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEllipse CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An ellipse or elliptical arc object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadEllipse
Visual Basic
Public Class McadEllipse
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFolder CoClass

You are here: API Reference > AcadmAuto Library > McadFolder CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFolder CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolder
Visual Basic
Public Class McadFolder
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFolderDefinition CoClass

You are here: API Reference > AcadmAuto Library > McadFolderDefinition CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFolderDefinition CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDefinition
Visual Basic
Public Class McadFolderDefinition
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFolderDefinitions CoClass

You are here: API Reference > AcadmAuto Library > McadFolderDefinitions CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFolderDefinitions CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDefinitions
Visual Basic
Public Class McadFolderDefinitions
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFolderDescriptor CoClass

You are here: API Reference > AcadmAuto Library > McadFolderDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFolderDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a folder.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolderDescriptor
Visual Basic
Public Class McadFolderDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFolders CoClass

You are here: API Reference > AcadmAuto Library > McadFolders CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFolders CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolder objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadFolders
Visual Basic
Public Class McadFolders
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFormulaEvaluator CoClass

You are here: API Reference > AcadmAuto Library > McadFormulaEvaluator CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFormulaEvaluator CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for Standard Data provider

Class Hierarchy

Declaration syntax

AcadmAuto::McadFormulaEvaluator
Visual Basic
Public Class McadFormulaEvaluator
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadHideSituation CoClass

You are here: API Reference > AcadmAuto Library > McadHideSituation CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadHideSituation CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadHideSituation
Visual Basic
Public Class McadHideSituation
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadHideSituations CoClass

You are here: API Reference > AcadmAuto Library > McadHideSituations CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadHideSituations CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

AcadmAuto::McadHideSituations
Visual Basic
Public Class McadHideSituations
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerCfg CoClass

You are here: API Reference > AcadmAuto Library > McadLayerCfg CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerCfg CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class AcadmAuto::McadLayerCfg.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerCfg
Visual Basic
Public Class McadLayerCfg
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerCfgs CoClass

You are here: API Reference > AcadmAuto Library > McadLayerCfgs CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerCfgs CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class AcadmAuto::McadLayerCfgs.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerCfgs
Visual Basic
Public Class McadLayerCfgs
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerGroupMgr CoClass

You are here: API Reference > AcadmAuto Library > McadLayerGroupMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerGroupMgr CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides access to methods and properties used to manage layers in documents.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerGroupMgr
Visual Basic
Public Class McadLayerGroupMgr
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerObjectCfg CoClass

You are here: API Reference > AcadmAuto Library > McadLayerObjectCfg CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerObjectCfg CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class AcadmAuto::McadLayerObjectCfg.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectCfg
Visual Basic
Public Class McadLayerObjectCfg
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerObjectCfgs CoClass

You are here: API Reference > AcadmAuto Library > McadLayerObjectCfgs CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerObjectCfgs CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class AcadmAuto::McadLayerObjectCfgs.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectCfgs
Visual Basic
Public Class McadLayerObjectCfgs
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLayerObjectMgr CoClass

You are here: API Reference > AcadmAuto Library > McadLayerObjectMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerObjectMgr CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class AcadmAuto::McadLayerObjectMgr.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLayerObjectMgr
Visual Basic
Public Class McadLayerObjectMgr
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadLine CoClass

You are here: API Reference > AcadmAuto Library > McadLine CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLine CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An unbounded line object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadLine
Visual Basic
Public Class McadLine
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadObjects CoClass

You are here: API Reference > AcadmAuto Library > McadObjects CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadObjects CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of IMcadObject subtype objects.

Class Hierarchy

Declaration syntax

AcadmAuto::McadObjects
Visual Basic
Public Class McadObjects
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPick CoClass

You are here: API Reference > AcadmAuto Library > McadPick CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPick CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPick
Visual Basic
Public Class McadPick
Remarks

The McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties. Using a pick object it is possible to get the subentity paths, pick point (point used for selection of entity) pick vector type of object, and so on.

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPolyline CoClass

You are here: API Reference > AcadmAuto Library > McadPolyline CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPolyline CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A polyline object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPolyline
Visual Basic
Public Class McadPolyline
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPowObjViewGroupDescriptor CoClass

You are here: API Reference > AcadmAuto Library > McadPowObjViewGroupDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPowObjViewGroupDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadPowObjViewGroupDescriptor
Visual Basic
Public Class McadPowObjViewGroupDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSpline CoClass

You are here: API Reference > AcadmAuto Library > McadSpline CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSpline CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A spline object.

Class Hierarchy

Declaration syntax

AcadmAuto::McadSpline
Visual Basic
Public Class McadSpline
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadStdPartComponentViewDescriptor CoClass

You are here: API Reference > AcadmAuto Library > McadStdPartComponentViewDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadStdPartComponentViewDescriptor CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a component view of a standard part.

Class Hierarchy

Declaration syntax

AcadmAuto::McadStdPartComponentViewDescriptor
Visual Basic
Public Class McadStdPartComponentViewDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTransaction CoClass

You are here: API Reference > AcadmAuto Library > McadTransaction CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTransaction CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

The McadTransaction object. These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.

Class Hierarchy

Declaration syntax

AcadmAuto::McadTransaction
Visual Basic
Public Class McadTransaction
Remarks

To end a transaction, set the transaction object to Null. Nested transactions are not supported. To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete. To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.

Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadUtility CoClass

You are here: API Reference > AcadmAuto Library > McadUtility CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadUtility CoClass
AcadmAuto Library Class Hierarchy Send Feedback
Summary

This API provides some general utility methods.

Class Hierarchy

Declaration syntax

AcadmAuto::McadUtility
Visual Basic
Public Class McadUtility
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IAcadmApplication Interface

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication Interface
IAcadmApplication Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IAcadmApplication
Visual Basic
Public Interface IAcadmApplication
Inherits IDispatch
Library

AcadmAuto Library

Links
IAcadmApplication Members, AcadmAuto Library, Class Hierarchy


IAcadmApplication Members

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication Members
IAcadmApplication Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IAcadmApplication.

Interface

IAcadmApplication Interface

Methods
Name | Description
AddAttributeClass | Creates a new attribute class definition using the specified fields.
DocumentFromHost | Gets the corresponding McadDocument from the specified host application's document.
GetAttributeClassFields | Gets the field information from the specified attribute class definition.
GetFormulaEvaluator | Gets the formula evaluator from the specified Acad object.
ReadAttributeClass | Reads one or more class definitions in a file.
RemoveAttributeClass | Removes the specified attribute class definition.
WriteAttributeClass | Writes the specified attribute class definition to the specified file.
Properties
Name | Description
ActiveDocument | Gets the currently active document (drawing).
Application | Gets the AcadmApplication object.
AttributeClasses | Gets the names of the currently defined attribute classes.
Documents | Gets the collection of all documents for the application.
StructureModeEditEntity | Gets the status of the structure entity edit mode in the editor state.
Links
IAcadmApplication Interface, Legend, Methods, Properties


IAcadmApplication::ActiveDocument Property

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::ActiveDocument Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::ActiveDocument Property
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the currently active document (drawing).

Visual Basic
Property ActiveDocument() As IMcadDocument**
Remarks

This property is an McadDocument object.

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::Application Property

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::Application Property
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This is an AcadmApplication object.

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::AttributeClasses Property

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::AttributeClasses Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::AttributeClasses Property
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the names of the currently defined attribute classes.

Visual Basic
Property AttributeClasses() As VARIANT*
Remarks

This property is a Variant.

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::Documents Property

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::Documents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::Documents Property
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the collection of all documents for the application.

Visual Basic
Property Documents() As IMcadDocuments**
Remarks

This property is a n McadDocuments collection.

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::StructureModeEditEntity Property

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::StructureModeEditEntity Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::StructureModeEditEntity Property
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the status of the structure entity edit mode in the editor state.

Visual Basic
Property StructureModeEditEntity() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::AddAttributeClass Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::AddAttributeClass Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::AddAttributeClass Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Creates a new attribute class definition using the specified fields.

Visual Basic
Sub AddAttributeClass(Name As String, Fields As IMcadAttributeFields)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the attribute.
Fields | McadAttributeFields collection; input-only. Specifies the fields that are used to add the new attribute.
Returns

None

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::DocumentFromHost Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::DocumentFromHost Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::DocumentFromHost Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Sub DocumentFromHost(HostDocument As IDispatch, Document As [out, retval] IMcadDocument*)
Parameters
Parameters | Description
HostDocument | AcadObject object; input-only. Specifies the host application's document from which to get the corresponding document.
Returns

McadDocument object

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::GetAttributeClassFields Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::GetAttributeClassFields Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::GetAttributeClassFields Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Gets the field information from the specified attribute class definition.

Visual Basic
Sub GetAttributeClassFields(Name As String, Fields As [out, retval] IMcadAttributeFields*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute class definition from which to get the corresponding fields.
Returns

McadAttributeFields collection

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::GetFormulaEvaluator Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::GetFormulaEvaluator Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::GetFormulaEvaluator Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Example Send Feedback
Summary

Gets the formula evaluator from the specified Acad object.

Visual Basic
Sub GetFormulaEvaluator(object As IAcadObject, evaluator As [out, retval] IMcadFormulaEvaluator *)
Parameters
Parameters | Description
object | AcadObject object; input-only. Specifies the object for which to get the formula evaluator.
Returns

McadFormulaEvaluator object

Remarks

The McadFormulaEvaluator uses data providers from acad objects to evaluate formulas.

Example

Refer to SDK Samples: FormulaEvaluator.dvb

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface, Example


IAcadmApplication::ReadAttributeClass Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::ReadAttributeClass Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::ReadAttributeClass Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Reads one or more class definitions in a file.

Visual Basic
Sub ReadAttributeClass(FileName As String)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file from which to read the attribute class definitions.
Returns

None

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::RemoveAttributeClass Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::RemoveAttributeClass Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::RemoveAttributeClass Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Removes the specified attribute class definition.

Visual Basic
Sub RemoveAttributeClass(Name As String)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute class definition to remove.
Returns

None

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplication::WriteAttributeClass Method

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::WriteAttributeClass Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication::WriteAttributeClass Method
IAcadmApplication Interface IAcadmApplication Members IAcadmApplication Interface Send Feedback
Summary

Writes the specified attribute class definition to the specified file.

Visual Basic
Sub WriteAttributeClass(FileName As String, Append As [in, defaultvalue(TRUE)] VARIANT_BOOL, Class As [in, optional] VARIANT)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file to which to write the new attribute class definition.
Append | Boolean, default value is TRUE; input-only. Specifies whether the new attribute class definition is appended to the specified class.
Class | Variant (String); input-only. Specifies the class to which to append the new attribute class definition.
Returns

None

Interface

IAcadmApplication Interface

Links
IAcadmApplication Interface, IAcadmApplication Members, IAcadmApplication Interface


IAcadmApplicationVersion Interface

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplicationVersion Interface
IAcadmApplicationVersion Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Version of AutoCAD Mechanical application that is running

Class Hierarchy

Declaration syntax

IAcadmApplicationVersion
Visual Basic
Public Interface IAcadmApplicationVersion
Inherits IUnknown
Library

AcadmAuto Library

Links
IAcadmApplicationVersion Members, AcadmAuto Library, Class Hierarchy


IAcadmApplicationVersion Members

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface > IAcadmApplicationVersion Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplicationVersion Members
IAcadmApplicationVersion Interface Legend Methods Send Feedback
Summary

The following tables list the members exposed by IAcadmApplicationVersion.

Interface

IAcadmApplicationVersion Interface

Methods
Name | Description
GetVersionNumber | Gets the version of AutoCAD Mechanical application that is running.
Links
IAcadmApplicationVersion Interface, Legend, Methods


IAcadmApplicationVersion::GetVersionNumber Method

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface > IAcadmApplicationVersion::GetVersionNumber Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplicationVersion::GetVersionNumber Method
IAcadmApplicationVersion Interface IAcadmApplicationVersion Members IAcadmApplicationVersion Interface Send Feedback
Summary

Gets the version of AutoCAD Mechanical application that is running.

Visual Basic
Sub GetVersionNumber(ByRef Major As long, ByRef Minor As long, ByRef Patch As long)
Parameters
Parameters | Description
Major | Long. Major release number.
Minor | Long. Minor release number
Patch | Long. Patch number.
Interface

IAcadmApplicationVersion Interface

Links
IAcadmApplicationVersion Interface, IAcadmApplicationVersion Members, IAcadmApplicationVersion Interface


IMcad2dComplexStdPartCompGroupDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor Interface
IMcad2dComplexStdPartCompGroupDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of a 2D complex standard part component group.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor
Visual Basic
Public Interface IMcad2dComplexStdPartCompGroupDescriptor
Inherits IMcad2DStructureDescriptor
Remarks

The types of complex standard parts are screw connections and part features.

Library

AcadmAuto Library

Links
IMcad2dComplexStdPartCompGroupDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcad2dComplexStdPartCompGroupDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor Members
IMcad2dComplexStdPartCompGroupDescriptor Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2dComplexStdPartCompGroupDescriptor.

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Methods
Name | Description
AddView | Adds a view group descriptor to a 2D complex standard part component group descriptor.
HasEqualTypeWithViewGroup | Checks if a 2D complex standard part component group descriptor has equal type with a given power object view group descriptor, TRUE, or not, FALSE.
MigrateTo2DStructure | Migrates a 2D complex standard part component group to 2D structure. New 2D standard part components with standard part views are created.
RemoveView | Removes the view group descriptor from a 2D complex standard part component group descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D complex standard part component group descriptor.
Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, Legend, Methods, Properties


IMcad2dComplexStdPartCompGroupDescriptor::Views Property

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor::Views Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor::Views Property
IMcad2dComplexStdPartCompGroupDescriptor Interface IMcad2dComplexStdPartCompGroupDescriptor Members IMcad2dComplexStdPartCompGroupDescriptor Interface Send Feedback
Summary

Gets view group descriptors from the 2D complex standard part component group descriptor.

Visual Basic
Property Views() As VARIANT *
Remarks

This property is a Variant (an array of McadComponentView or McadFolder objects).

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, IMcad2dComplexStdPartCompGroupDescriptor Members, IMcad2dComplexStdPartCompGroupDescriptor Interface


IMcad2dComplexStdPartCompGroupDescriptor::AddView Method

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor::AddView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor::AddView Method
IMcad2dComplexStdPartCompGroupDescriptor Interface IMcad2dComplexStdPartCompGroupDescriptor Members IMcad2dComplexStdPartCompGroupDescriptor Interface Send Feedback
Summary

Adds a view group descriptor to a 2D complex standard part component group descriptor.

Visual Basic
Sub AddView(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor object; input-only. Specifies a power object view group descriptor to add to the complex standard part descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, IMcad2dComplexStdPartCompGroupDescriptor Members, IMcad2dComplexStdPartCompGroupDescriptor Interface


IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method
IMcad2dComplexStdPartCompGroupDescriptor Interface IMcad2dComplexStdPartCompGroupDescriptor Members IMcad2dComplexStdPartCompGroupDescriptor Interface Send Feedback
Summary

Checks if a 2D complex standard part component group descriptor has equal type with a given power object view group descriptor, TRUE, or not, FALSE.

Visual Basic
Sub HasEqualTypeWithViewGroup(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor, EqualType As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor object; input-only. Specifies a power object view group descriptor to check for equal type with this 2D complex standard part descriptor.
Remarks

This property is a Boolean.

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, IMcad2dComplexStdPartCompGroupDescriptor Members, IMcad2dComplexStdPartCompGroupDescriptor Interface


IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dComplexStdPartCompGroupDescriptor Interface IMcad2dComplexStdPartCompGroupDescriptor Members IMcad2dComplexStdPartCompGroupDescriptor Interface Send Feedback
Summary

Migrates a 2D complex standard part component group to 2D structure. New 2D standard part components with standard part views are created.

Visual Basic
Sub MigrateTo2DStructure()
Returns

None

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, IMcad2dComplexStdPartCompGroupDescriptor Members, IMcad2dComplexStdPartCompGroupDescriptor Interface


IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method
IMcad2dComplexStdPartCompGroupDescriptor Interface IMcad2dComplexStdPartCompGroupDescriptor Members IMcad2dComplexStdPartCompGroupDescriptor Interface Send Feedback
Summary

Removes the view group descriptor from a 2D complex standard part component group descriptor.

Visual Basic
Sub RemoveView(PowObjViewGroupDescriptor As IMcadPowObjViewGroupDescriptor)
Parameters
Parameters | Description
PowObjViewGroupDescriptor | McadPowObjViewGroupDescriptor to be removed; input-only. Specifies a power object view group descriptor to remove from the complex standard part descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.

Interface

IMcad2dComplexStdPartCompGroupDescriptor Interface

Links
IMcad2dComplexStdPartCompGroupDescriptor Interface, IMcad2dComplexStdPartCompGroupDescriptor Members, IMcad2dComplexStdPartCompGroupDescriptor Interface


IMcad2dComponentDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor Interface
IMcad2dComponentDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of a 2D component.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor
Visual Basic
Public Interface IMcad2dComponentDescriptor
Inherits IMcad2DStructureDescriptor
Library

AcadmAuto Library

Links
IMcad2dComponentDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcad2dComponentDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor Members
IMcad2dComponentDescriptor Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2dComponentDescriptor.

Interface

IMcad2dComponentDescriptor Interface

Methods
Name | Description
AddComponentView | Adds a component view descriptor to a 2D component descriptor.
CreateComponent | Creates a new 2D component from a 2D component descriptor.
HasEqualTypeWithView | Checks if a 2D component descriptor has equal type with a given component view descriptor, TRUE, or not, FALSE.
RemoveComponentView | Removes the specified component view descriptor from a 2D component descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets the component from the component descriptor.
ComponentDefinition | Gets and sets the component definition for the component descriptor.
ComponentViews | Gets component view descriptors from the component descriptor.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
OwningComponentDefinition | Gets and sets the owning component definitions on the component descriptor.
Links
IMcad2dComponentDescriptor Interface, Legend, Methods, Properties


IMcad2dComponentDescriptor::Component Property

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::Component Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::Component Property
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Gets the component from the component descriptor.

Visual Basic
Property Component() As VARIANT*
Remarks

This property is a Variant ( McadComponent object).

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::ComponentDefinition Property

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::ComponentDefinition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::ComponentDefinition Property
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Gets and sets the component definition for the component descriptor.

Visual Basic
Property ComponentDefinition() As VARIANT
Remarks

This property is a Variant ( McadComponentDefinition object).

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::ComponentViews Property

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::ComponentViews Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::ComponentViews Property
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Gets component view descriptors from the component descriptor.

Visual Basic
Property ComponentViews() As VARIANT*
Remarks

This property is a Variant (array of McadComponentViewDescriptor objects).

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::OwningComponentDefinition Property

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::OwningComponentDefinition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::OwningComponentDefinition Property
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Gets and sets the owning component definitions on the component descriptor.

Visual Basic
Property OwningComponentDefinition() As VARIANT
Remarks

This property is a Variant ( McadComponentDefinition object).

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::AddComponentView Method

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::AddComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::AddComponentView Method
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Adds a component view descriptor to a 2D component descriptor.

Visual Basic
Sub AddComponentView(pDescriptor As IMcadComponentViewDescriptor)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies the component view descriptor to added to this component descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::CreateComponent Method

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::CreateComponent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::CreateComponent Method
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Creates a new 2D component from a 2D component descriptor.

Visual Basic
Sub CreateComponent()
Returns

None

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::HasEqualTypeWithView Method

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::HasEqualTypeWithView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::HasEqualTypeWithView Method
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Checks if a 2D component descriptor has equal type with a given component view descriptor, TRUE, or not, FALSE.

Visual Basic
Sub HasEqualTypeWithView(pDescriptor As IMcadComponentViewDescriptor, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies a component view descriptor to check for equal type with this 2D component descriptor.
Remarks

This property is a Boolean.

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dComponentDescriptor::RemoveComponentView Method

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor::RemoveComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor::RemoveComponentView Method
IMcad2dComponentDescriptor Interface IMcad2dComponentDescriptor Members IMcad2dComponentDescriptor Interface Send Feedback
Summary

Removes the specified component view descriptor from a 2D component descriptor.

Visual Basic
Sub RemoveComponentView(pDescriptor As IMcadComponentViewDescriptor)
Parameters
Parameters | Description
pDescriptor | McadComponentViewDescriptor object; input-only. Specifies the component view descriptor to remove from this component descriptor.
Remarks

All descriptors derived from Ami2DSDescrip hold information that will be used when creating structure. Descriptor APIs are meant for structure migration but not to modify structure. The component view will not be added or removed from structure.

Interface

IMcad2dComponentDescriptor Interface

Links
IMcad2dComponentDescriptor Interface, IMcad2dComponentDescriptor Members, IMcad2dComponentDescriptor Interface


IMcad2dShaftCompGroupDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor Interface
IMcad2dShaftCompGroupDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of the group of shaft and standard part objects that comprise a shaft power object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dShaftCompGroupDescriptor
Visual Basic
Public Interface IMcad2dShaftCompGroupDescriptor
Inherits IMcad2DStructureDescriptor
Library

AcadmAuto Library

Links
IMcad2dShaftCompGroupDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcad2dShaftCompGroupDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor Members
IMcad2dShaftCompGroupDescriptor Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2dShaftCompGroupDescriptor.

Interface

IMcad2dShaftCompGroupDescriptor Interface

Methods
Name | Description
MigrateTo2DStructure | Migrates a 2D shaft component group to 2D structure. A new 2D shaft component with standard parts is created.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D shaft component group descriptor.
Links
IMcad2dShaftCompGroupDescriptor Interface, Legend, Methods, Properties


IMcad2dShaftCompGroupDescriptor::Views Property

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor::Views Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor::Views Property
IMcad2dShaftCompGroupDescriptor Interface IMcad2dShaftCompGroupDescriptor Members IMcad2dShaftCompGroupDescriptor Interface Send Feedback
Summary

Gets view group descriptors from the 2D shaft component group descriptor.

Visual Basic
Property Views() As VARIANT*
Remarks

This property is a Variant (array of McadComponentView or McadFolder objects).

Interface

IMcad2dShaftCompGroupDescriptor Interface

Links
IMcad2dShaftCompGroupDescriptor Interface, IMcad2dShaftCompGroupDescriptor Members, IMcad2dShaftCompGroupDescriptor Interface


IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dShaftCompGroupDescriptor Interface IMcad2dShaftCompGroupDescriptor Members IMcad2dShaftCompGroupDescriptor Interface Send Feedback
Summary

Migrates a 2D shaft component group to 2D structure. A new 2D shaft component with standard parts is created.

Visual Basic
Sub MigrateTo2DStructure()
Returns

None

Interface

IMcad2dShaftCompGroupDescriptor Interface

Links
IMcad2dShaftCompGroupDescriptor Interface, IMcad2dShaftCompGroupDescriptor Members, IMcad2dShaftCompGroupDescriptor Interface


IMcad2dStdPartComponentDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcad2dStdPartComponentDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dStdPartComponentDescriptor Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides a description of the 2D standard part component.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor
Visual Basic
Public Interface IMcad2dStdPartComponentDescriptor
Inherits IMcad2dComponentDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcad2DStructureDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureDescriptor Interface
IMcad2DStructureDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object is the base class for 2D structure descriptors.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor
        IMcad2dComponentDescriptor
        IMcad2dShaftCompGroupDescriptor
        IMcadFolderDescriptor
        IMcadPowObjViewGroupDescriptor
Visual Basic
Public Interface IMcad2DStructureDescriptor
Inherits IMcadDescriptor
Library

AcadmAuto Library

Links
IMcad2DStructureDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface > IMcad2DStructureDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureDescriptor Members
IMcad2DStructureDescriptor Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureDescriptor.

Interface

IMcad2DStructureDescriptor Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Links
IMcad2DStructureDescriptor Interface, Legend, Properties


IMcad2DStructureDescriptor::Name Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface > IMcad2DStructureDescriptor::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureDescriptor::Name Property
IMcad2DStructureDescriptor Interface IMcad2DStructureDescriptor Members IMcad2DStructureDescriptor Interface Send Feedback
Summary

Gets and sets the name of a 2D structure descriptor.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Interface

IMcad2DStructureDescriptor Interface

Links
IMcad2DStructureDescriptor Interface, IMcad2DStructureDescriptor Members, IMcad2DStructureDescriptor Interface


IMcad2DStructureMgr Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr Interface
IMcad2DStructureMgr Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
Visual Basic
Public Interface IMcad2DStructureMgr
Inherits IDispatch
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Library

AcadmAuto Library

Links
IMcad2DStructureMgr Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureMgr Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr Members
IMcad2DStructureMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureMgr.

Interface

IMcad2DStructureMgr Interface

Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
Links
IMcad2DStructureMgr Interface, Legend, Methods, Properties


IMcad2DStructureMgr::Application Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Application Property
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::EditTarget Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::EditTarget Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::EditTarget Property
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Sets or gets either a folder or component view in 2D structure as the edit target.

Visual Basic
Property EditTarget() As IMcadFolder*
Remarks

  • This property is a Variant (McadFolder object).
  • To set the edit target to the MVD, specifies an empty or null string.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Create an annotation view and definition based on the specified component definition and component view definitions.

Visual Basic
Sub AddNewAnnotationViewDefinition(ByRef pNewAnnotationViewDef As IMcadAnnotationViewDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, matrices As VARIANT, pCompDef As IMcadComponentDefinition, pCompViewDefs As IMcadComponentViewDefinitions, Name As [in, optional ] VARIANT)
Parameters
Parameters | Description
pNewAnnotationViewDef | McadAnnotationViewDefinition object; output-only. Specifies the new annotation view definition to create.
pNewFolderInst | McadFolder object; output-only. Specifies the parent folder for the new annotation view definition.
pMat | GeMatrix object; input-only. Specifies the base position for the new annotation view.
matrices | Variant (array of GeMatrix objects); input-only. Specifies the array of matrices for the new position of each of the new views.
pCompDef | McadComponentDefinition object; input-only. Specifies a valid component based on which to create the new annotation view.
pCompViewDefs | McadComponentViewDefinitions collection; input-only. Specifies an array of component view definitions of pCompDefKey whose corresponding annotation view position are specified in arMatrices.
Name | Variant (String); input-only. Specifies the name of the new annotation view definition. If not specified, system will generate an appropriate name.
Returns

None

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::AddNewComponentDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewComponentDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewComponentDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new component definition in mechanical structure.

Visual Basic
Sub AddNewComponentDefinition(Name As [in, optional] VARIANT, pVal As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Name | Variant (String); input-only. Specifies the name of the component definition. If not specified, the default automatic name is used.
Returns

McadComponentDefinition object

Remarks

Component definition is a nongraphical description of a mechanical structure component that AutoCAD Mechanical saves in data area of a drawing, similar to how it saves a block definition.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::AddNewComponentView Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewComponentView Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new component view in mechanical structure.

Visual Basic
Sub AddNewComponentView(pDefToInst As IMcadComponentViewDefinition, pCompInst As IMcadComponent, pMat As IGeMatrix, ByRef pNewViewInst As IMcadComponentView*, pTargetView As [in, optional] VARIANT)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition for the component view.
pCompInst | McadComponent object; input-only. Specifies the new or existing component instance to add a component view for.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pNewViewInst | McadComponentView object; output-only, Specifies the new component view.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created component view is placed. If not specified, this component view is created in the active view.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::AddNewComponentViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewComponentViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewComponentViewDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new component view definition in mechanical structure.

Visual Basic
Sub AddNewComponentViewDefinition(ByRef pNewViewDef As IMcadComponentViewDefinition*, ByRef pNewViewInst As IMcadComponentView*, pCompInst As IMcadComponent, pMat As IGeMatrix, pAddViews As [in, optional] VARIANT, entityIds As [in, optional] VARIANT, pTargetView As [in, optional] VARIANT, Name As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewViewDef | McadComponentViewDefinition object; output-only. Specifies the new component view definition.
pNewViewInst | McadComponentView object; output-only. Specifies the new component view.
pCompInst | McadComponent object; input-only. Specifies the new or existing component instance to add a component view for.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pAddViews | Variant ( McadFolders collection); input-only; optional. Specifies the new component views or folders to add to the new component view definition.
entityIds | Variant (Array of Longs); input-only; optional. Specifies the Object IDs of drawing objects to be added to this component view.
pTargetView | Variant ( McadFolder object); input-only; optional. Specifies the parent view where the created component view is placed. If not specified, this component view is created in the active view.
Name | Variant (String); input-only; optional. Specifies the name of the component view. If not specified, the default automatic name is used.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::AddNewFolder Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewFolder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewFolder Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new folder in mechanical structure.

Visual Basic
Sub AddNewFolder(pDefToInst As IMcadFolderDefinition, pMat As IGeMatrix, ByRef pNewViewInst As IMcadFolder*, pTargetView As [in, optional] VARIANT)
Parameters
Parameters | Description
pDefToInst | McadFolderDefinition object; input-only. Specifies the folder definition for the folder.
pMat | GeMatrix object; input-only. Specifies the position to place the new folder.
pNewViewInst | McadFolder object; out-put only. Specifies the new folder.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created folder is placed. If not specified, this folder is created in the active view.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::AddNewFolderDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewFolderDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::AddNewFolderDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new folder definition in mechanical structure.

Visual Basic
Sub AddNewFolderDefinition(ByRef pNewFolderDef As IMcadFolderDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, pAddViews As [in, optional] VARIANT, entityIds As [in, optional] VARIANT, pTargetView As [in, optional] VARIANT, Name As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewFolderDef | McadFolderDefinition object; output only. Specifies the new folder definition.
pNewFolderInst | McadFolder object; output only. Specifies the new folder.
pMat | GeMatrix object; input-only. Specifies the position to place the new component view.
pAddViews | Variant ( McadFolders collection); input only; optional. Specifies the new component views or folders to add to the new folder definition.
entityIds | Variant (Array of Longs);input; optional. Specifies the Object IDs of drawing objects to be added to this folder.
pTargetView | Variant ( McadFolder object); input; optional. Specifies the parent view where the created folder is placed. If not specified, this folder is created in the active view.
Name | Variant (String); input; optional. Specifies the name of the component view; if not specified, the default automatic name is used.
Returns

None

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CopyComponentFromDatabase Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CopyComponentFromDatabase Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CopyComponentFromDatabase Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.

Visual Basic
Sub CopyComponentFromDatabase(sourcedef As IMcadComponentDefinition, database As IAcadDatabase, ByRef newdef As IMcadComponentDefinition*)
Parameters
Parameters | Description
sourcedef | Variant ( McadComponentViewDefinition object); input-only. Specifies the source component view definition to copy from the AcadDatabase database.
Database | AcadDatabase database; input-only. Specifies the AcadDatabase to implement the copy.
newDef | Variant ( McadComponentViewDefinition object); output-only. Specifies the new copied component view definition.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CopyFolderFromDatabase Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CopyFolderFromDatabase Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CopyFolderFromDatabase Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.

Visual Basic
Sub CopyFolderFromDatabase(sourcedef As IMcadFolderDefinition, database As IAcadDatabase, ByRef newdef As IMcadFolderDefinition*)
Parameters
Parameters | Description
sourcedef | Variant ( McadFolderDefinition object); input-only. Specifies the source folder definition in 2D structure to copy from the AcadDatabase database.
Database | AcadDatabase database; input-only. Specifies the AcadDatabase to implement the copy.
newDef | Variant ( McadFolderDefinition object); input-only. Specifies the new copied folder definition in 2D structure.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new empty 2D complex standard part descriptor.

Visual Basic
Sub Create2dComplexStdPartCompGroupDescriptor(Descriptor As [out, retval] IMcad2dComplexStdPartCompGroupDescriptor*)
Returns

Mcad2dComplexStdPartCompGroupDescriptor object

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Create2dComponentDescriptor Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Create2dComponentDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Create2dComponentDescriptor Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new empty 2D component descriptor.

Visual Basic
Sub Create2dComponentDescriptor(Descriptor As [out, retval] IMcad2dComponentDescriptor*)
Returns

Mcad2dComponentDescriptor object

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new empty 2D standard part component descriptor.

Visual Basic
Sub Create2dStdPartComponentDescriptor(Descriptor As [out, retval] IMcad2dStdPartComponentDescriptor*)
Returns

Mcad2dStdPartComponentDescriptor object

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CreateBlocksFromStructure Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CreateBlocksFromStructure Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CreateBlocksFromStructure Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Migrates the 2D structure component views and folders to blocks.

Visual Basic
Sub CreateBlocksFromStructure(removeStructure As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
removeStructure | Boolean, default value = TRUE; input-only. Specifies whether all local 2D Structure folders, component views and components are removed after converting to blocks.
Returns

None

Remarks

  • AutoCAD Mechanical objects of drawings are created with versions of AutoCAD Mechanical that did not support mechanical structure or drawings created with the structure option disabled.
  • Hide situations and occurrence property overrides will not be maintained after converting to block.
  • Xref components will not be converted to blocks.
  • The name of the block that is converted from a component view will use the format, _. For example, the component view, COMP1:1(Top) will be converted to a block with name COMP1_Top. The name of the block that is converted from folder will be the same as the name of the folder definition. For example, the folder, FOLDER1:1 will be converted to a block with name FOLDER1.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CreateComponentViewDescriptor Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CreateComponentViewDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CreateComponentViewDescriptor Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new empty component view descriptor.

Visual Basic
Sub CreateComponentViewDescriptor(Descriptor As [out, retval] IMcadComponentViewDescriptor*)
Returns

McadComponentViewDescriptor object

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CreateFolderDescriptor Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CreateFolderDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CreateFolderDescriptor Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates a new empty folder descriptor.

Visual Basic
Sub CreateFolderDescriptor(Descriptor As [out, retval] IMcadFolderDescriptor*)
Returns

McadFolderDescriptor object

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::CreateStructureFromBlocks Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::CreateStructureFromBlocks Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::CreateStructureFromBlocks Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Creates an array of 2D structure component or folder descriptors based on existing block definitions.

Visual Basic
Sub CreateStructureFromBlocks(componentDescriptors As VARIANT, folderDescriptors As VARIANT)
Parameters
Parameters | Description
componentDescriptors | Variant (array of Mcad2DComponentDescriptor objects); input-only. Specifies the new component descriptors to create in the 2D structure.
FolderDescriptors | Variant (array of McadFolderDescriptor objects); input-only. Specifies the new folder descriptors to create in the 2D structure.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::ExternalStructureDatabases Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::ExternalStructureDatabases Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::ExternalStructureDatabases Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.

Visual Basic
Sub ExternalStructureDatabases(database As IAcadDatabase, Databases As [out, retval] VARIANT)
Parameters
Parameters | Description
Database | AcadDatabase database; input-only. Specifies the xref database to get the corresponding AcadDatabase objects for.
Remarks

  • This property is a Variant (array of AcadDatabase objects).
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetComplexStdPartsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetComplexStdPartsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetComplexStdPartsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.

Visual Basic
Sub GetComplexStdPartsForMigr(entityGroups As VARIANT, PowerObjectType As [in, defaultvalue(mcScrewConObj | mcPartFeatObj)] long, ViewGroupDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
entityGroups | Variant (array of arrays of object IDs (array of arrays of Longs)); input-only; defining view groups. The function ami2DSGetComplexStdPartsForMigr returns the descriptors of complex standard parts (CSPs) to be migrated. Entity groups help to assign CSP view group descriptors to CSP component group descriptors. An entity group is similar to a parent assembly view of the CPS, so each created CSP descriptor contains only one view group from each entity group. If the array of entity groups is empty, then each created CSP descriptor has only one view group.
PowerObjectType | Long, default value = mcScrewConObj | mcPartFeatObj; input-only.
Returns

Variant (array of Mcad2dComplexStdPartCompGroupDescriptor objects)

Remarks

mcScrewConObj and mcPartFeatObj are two types in McadPowerObjectType enumeration.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.

Visual Basic
Sub GetComplexStdPartViewsForMigr(PowerObjType As [in, defaultvalue(mcScrewConObj | mcPartFeatObj)] long, ViewGroupDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
PowerObjType | Long; input-only; default value = mcScrewConObj | mcPartFeatObj.
Returns

Variant (array of McadPowObjViewGroupDescriptor objects)

Remarks

mcScrewConObj and mcPartFeatObj are two types in McadPowerObjectType enumeration.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetComponentDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetComponentDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetComponentDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Returns a list of component definitions in the current document or in the specified database.

Visual Basic
Sub GetComponentDefinitions(ByRef componentdefs As IMcadComponentDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
componentdefs | McadComponentDefinitions collection; output-only. Returns the list of component definitions.
includeExternals | Boolean; input-only. Specifies whether the external component definitions that are referenced from the hose database are included, TRUE, or not, FALSE.
Database | Variant (AcadDatabase database), default value = NULL; input-only; optional. Specifies the AcadDatabase for the external component definitions to perform the method.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetComponentViewDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetComponentViewDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetComponentViewDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Returns a list of component view definitions in the current document or in the specified database.

Visual Basic
Sub GetComponentViewDefinitions(ByRef compViewDefs As IMcadComponentViewDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
compViewDefs | McadComponentViewDefinitions collection; output-only. Returns the list of component definitions.
includeExternals | Boolean; input-only. Specifies whether the external component view definitions that are referenced from the hose database are included, TRUE, or not, FALSE.
Database | Variant (AcadDatabase database), default value = NULL; input-only; optional. Specifies the AcadDatabase for the external component definitions to perform the method.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetFolderDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetFolderDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetFolderDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.

Visual Basic
Sub GetFolderDefinitions(ByRef folderdefs As IMcadFolderDefinitions*, includeExternals As VARIANT_BOOL, database As [in, optional] VARIANT)
Parameters
Parameters | Description
folderdefs | McadFolderDefinitions collection; output-only. Specifies the collection of folder definitions to get.
includeExternals | Boolean; input-only. Specifies whether the external folder definitions are get, TRUE, or not, FALSE.
Database | AcadDatabase database; input-only; optional. Specifies the AcadDatabase for external folder definitions to get.
Returns

None

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of power object folder descriptors to be migrated to 2D structure.

Visual Basic
Sub GetFolderPowerObjectsForMigr(PowerObjectType As [in, defaultvalue(mcAllFolderPowerObj)] long, FolderDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
PowerObjectType | Long, default value = mcAllFolderPowerObj; input-only.
Returns

Variant (array of McadFolderDescriptor objects)

Remarks

mcAllFolderPowerObj is one type in McadPowerObjectType enumeration.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Gets the next unique annotation view definition name based on a specified component definition.

Visual Basic
Sub GetNextAnnotationViewDefinitionName(pCompDef As IMcadComponentDefinition, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pCompDef | McadComponentDefinition object; input-only. Specifies the component definition for the next unique annotation view definition.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database for the next unique annotation view definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::GetNextComponentDefinitionName Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetNextComponentDefinitionName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetNextComponentDefinitionName Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Gets the name of the next unique component definition based on the specified name.

Visual Basic
Sub GetNextComponentDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the name of the current component definition. By default, the component name specified in the user options is used.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database of the next unique component definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::GetNextFolderDefinitionName Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetNextFolderDefinitionName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetNextFolderDefinitionName Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the name of the next unique folder definition based on a specified name.

Visual Basic
Sub GetNextFolderDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the name of the current folder definition. By default, the component name specified in the user options is used.
pDatabase | AcadDatabase object, default value = NULL; input-only; optional. Specifies the database of the next unique folder definition. By default, the host database of the document is used.
Returns

String

Remarks

AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetSelection Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetSelection Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetSelection Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Get the currently selected folders and/or component views in 2D structure.

Visual Basic
Sub GetSelection(ByRef Views As IMcadFolders*)
Parameters
Parameters | Description
views | Variant ( McadFolders collection); output-only. Specifies the folders to get. Both folders and component views are specified in the selected folders.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetShaftsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetShaftsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetShaftsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of shaft component group descriptors to be migrated to 2D structure.

Visual Basic
Sub GetShaftsForMigr(GroupDescriptors As [out, retval] VARIANT)
Returns

Variant (array of Mcad2dShaftCompGroupDescriptor objects); output-only.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of single standard component descriptors to be migrated to 2D structure.

Visual Basic
Sub GetSingleStdPartComponentsForMigr(entityGroups As VARIANT, StdPartDescriptors As [out, retval] VARIANT)
Parameters
Parameters | Description
entityGroups | Variant (array of arrays of object IDs (array of arrays of Longs)); input-only. The function ami2DSGetSglStdPartCompsForMigr returns the descriptors of single standard components to be migrated. Entity groups help to assign view group descriptors to component group descriptors. An entity group is similar to a parent assembly view of the component group, so each created descriptor contains only one view group from each entity group. If the array of entity groups is empty, then each created descriptor has only one view group.
Returns

Variant (array of Mcad2dComponentDescriptor objects); output-only

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the array of single standard part view descriptors to be migrated to 2D structure.

Visual Basic
Sub GetSingleStdPartViewsForMigr(ComponentViewDescriptors As [out, retval] VARIANT)
Returns

Variant (array of McadStdPartComponentViewDescriptor objects); output-only

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::GetStructureFromEntity Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetStructureFromEntity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::GetStructureFromEntity Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Get the a McadFolder or McadComponentView for an entity in model space.

Visual Basic
Sub GetStructureFromEntity(ent As IAcadEntity, pView As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
ent | AcadEntity; input-only. Specifies the entity in model space to get the corresponding 2D structure from.
Returns

Variant ( McadFolder object)

Remarks

If the mspace entity is not in 2D structure, this method returns an empty string.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::HasComponentDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::HasComponentDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::HasComponentDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.

Visual Basic
Sub HasComponentDefinition(pName As String, ByRef pCompDef As IMcadComponentDefinition*, pHasCompDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the component definition to perform the check.
pCompDef | McadComponentDefinition object; output-only. Returns the component definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::HasFolderDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::HasFolderDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::HasFolderDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.

Visual Basic
Sub HasFolderDefinition(pName As String, ByRef pFolderDef As IMcadFolderDefinition*, pHasFolderDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the folder definition to perform the check.
pFolderDef | McadfolderDefinition object; output-only. Returns the folder definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Highlight Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Highlight Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Highlight Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.

Visual Basic
Sub Highlight(pViews As IMcadFolders, highlight As VARIANT_BOOL)
Parameters
Parameters | Description
pViews | McadFolders collection; input-only. Specifies the collection of one or more folders and/or component views to be highlighted.
Highlight | Boolean; input-only. Specifies whether to highlight the specified collection of component views or folders, TRUE, or not, FALSE.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Is2DStructureEnabled Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Is2DStructureEnabled Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Is2DStructureEnabled Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.

Visual Basic
Sub Is2DStructureEnabled(pIsStructureEnabled As [out, retval] VARIANT_BOOL)
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::IsEntityAllowed Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsEntityAllowed Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::IsEntityAllowed Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.

Visual Basic
Sub IsEntityAllowed(pEntity As IAcadEntity, pIsAllowed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity object for which to perform the determination.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::IsFreeEntity Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsFreeEntity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::IsFreeEntity Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Example Send Feedback
Summary

Check whether an entity is a free entity, TRUE, or not, FALSE.

Visual Basic
Sub IsFreeEntity(pEntity As IAcadEntity, pIsFree As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity object for which to perform the check.
Returns

Boolean

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface, Example


IMcad2DStructureMgr::IsInActiveTarget Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsInActiveTarget Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::IsInActiveTarget Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Checks whether an entity is in the active target, TRUE, or not, FALSE.

Visual Basic
Sub IsInActiveTarget(pEntity As IAcadEntity, pIsInActiveTarget As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pEntity | AcadEntity object; input-only. Specifies the entity to perform the check.
Returns

Boolean

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::IsStructureBlock Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsStructureBlock Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::IsStructureBlock Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Checks whether a block is block structure rather than mechanical structure.

Visual Basic
Sub IsStructureBlock(Block As IAcadBlock, IsStructureBlock As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Block | AcadBlock object; input-only. Specifies the block to perform the check.
Returns

Boolean

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::PurgeAll2DS Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::PurgeAll2DS Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::PurgeAll2DS Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Purges all 2D structure definitions whose name matches the pattern.

Visual Basic
Sub PurgeAll2DS(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all 2D structure definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the Object Arx documentation of acutWcMatch() for details of the wildcard characters.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Purges all annotation view definitions whose name matches the pattern.

Visual Basic
Sub PurgeAnnotationViewDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all annotation view definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the Object Arx documentation of acutWcMatch() for details of the wildcard characters.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::PurgeComponentDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::PurgeComponentDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::PurgeComponentDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Purges all component definitions whose name matches the pattern.

Visual Basic
Sub PurgeComponentDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all component definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the Object Arx documentation of acutWcMatch() for details of the wildcard characters.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::PurgeComponentViewDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::PurgeComponentViewDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::PurgeComponentViewDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Purges all component view definitions whose name matches the pattern.

Visual Basic
Sub PurgeComponentViewDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all component view definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the Object Arx documentation of acutWcMatch() for details of the wildcard characters.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::PurgeFolderDefinitions Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::PurgeFolderDefinitions Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::PurgeFolderDefinitions Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Purges all folder definitions whose name matches the pattern.

Visual Basic
Sub PurgeFolderDefinitions(matchName As [in, defaultvalue(FALSE)] VARIANT_BOOL, namePattern As [in, defaultvalue("*")] BSTR)
Parameters
Parameters | Description
matchName | Boolean, default value = FALSE; input-only; optional. Specifies whether this method uses the namePattern to match the definitions to be purged, TRUE, or purge all folder definitions regardless of name.
namePattern | Boolean, default value = * (match everything); input-only; optional. Refer to the Object Arx documentation of acutWcMatch() for details of the wildcard characters.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::RestructureViews Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::RestructureViews Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::RestructureViews Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.

Visual Basic
Sub RestructureViews(pViews As IMcadFolders, pTarget As IMcadFolder)
Parameters
Parameters | Description
pViews | Variant ( McadFolders collection); input-only. Specifies the collection of component views or folders in 2D structure to restructure.
pTarget | Variant ( McadFolder object); optional; input-only. Specifies the parent folder or component view where the specified collection of component views or folders are placed.
Returns

None

Remarks

  • An error will be returned if this operation violates parent child rules.
  • To restructure the master (root) view definition, set pTarget = Nothing.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::RootComponentDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::RootComponentDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::RootComponentDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the root, or top level component definition in which 2D structure components are inserted into in this document.

Visual Basic
Sub RootComponentDefinition(Database As [in, optional] VARIANT, pVal As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database to get the root for; if not specified, the root for the host database of the document is used.
Remarks

  • This property is a McadComponentDefinition object.
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is a equal to TRUE.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::RootViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::RootViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::RootViewDefinition Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.

Visual Basic
Sub RootViewDefinition(Database As [in, optional] VARIANT, pVal As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database to get the root for; if not specified, the root for the host database of the document is used.
Remarks
  • This property is a McadComponentViewDefinition object.
  • AcadDatabase (Database) object specifies the contents of an XRef block from AutoCAD ActiveX Automation. This object provides access to the contents of an external reference block. It is only available on blocks whose IsXRef property is equal to TRUE.
Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::Update Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Update Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::Update Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Forces an immediate update of 2D structure.

Visual Basic
Sub Update(ForceAll As VARIANT_BOOL)
Parameters
Parameters | Description
ForceAll | Boolean, default value = TRUE; input-only. Specifies whether to update all 2D structure in the document, TRUE, or not, FALSE. It is not recommended to set ForceAll to TRUE.
Returns

None

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr::UpdateEntities Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::UpdateEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr::UpdateEntities Method
IMcad2DStructureMgr Interface IMcad2DStructureMgr Members IMcad2DStructureMgr Interface Send Feedback
Summary

Updates 2D structure with entity changes in model space.

Visual Basic
Sub UpdateEntities()
Returns

None

Remarks

When a new entity is added to an active target in 2D structure or a structure entity is modified / deleted, using AutoCAD API, execute this method to update the 2D structure with the entity changes.

Interface

IMcad2DStructureMgr Interface

Links
IMcad2DStructureMgr Interface, IMcad2DStructureMgr Members, IMcad2DStructureMgr Interface


IMcad2DStructureMgr2 Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr2 Interface
IMcad2DStructureMgr2 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
Visual Basic
Public Interface IMcad2DStructureMgr2
Inherits IMcad2DStructureMgr
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Library

AcadmAuto Library

Links
IMcad2DStructureMgr2 Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureMgr2 Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr2 Members
IMcad2DStructureMgr2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureMgr2.

Interface

IMcad2DStructureMgr2 Interface

Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.
Links
IMcad2DStructureMgr2 Interface, Legend, Methods, Properties


IMcad2DStructureMgr2::StartTransaction Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2::StartTransaction Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr2::StartTransaction Property
IMcad2DStructureMgr2 Interface IMcad2DStructureMgr2 Members IMcad2DStructureMgr2 Interface Send Feedback
Summary

Starts a new transaction and returns an McadTransaction object.

Visual Basic
Property StartTransaction() As IMcadTransaction**
Remarks

To end a transaction, set the transaction object to Null.

To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete. To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.

Interface

IMcad2DStructureMgr2 Interface

Links
IMcad2DStructureMgr2 Interface, IMcad2DStructureMgr2 Members, IMcad2DStructureMgr2 Interface


IMcad2DStructureMgr3 Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3 Interface
IMcad2DStructureMgr3 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
Visual Basic
Public Interface IMcad2DStructureMgr3
Inherits IMcad2DStructureMgr2
Remarks

This object replaces the obsolete Mcad2dAssemblyMgr. Note that Mcad2DAssemblyMgr can still be supported in AutoCAD Mechanical ActiveX Automation.

Library

AcadmAuto Library

Links
IMcad2DStructureMgr3 Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureMgr3 Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3 Members
IMcad2DStructureMgr3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureMgr3.

Interface

IMcad2DStructureMgr3 Interface

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.
Links
IMcad2DStructureMgr3 Interface, Legend, Methods, Properties


IMcad2DStructureMgr3::AddNewAnnotationView Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3::AddNewAnnotationView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3::AddNewAnnotationView Method
IMcad2DStructureMgr3 Interface IMcad2DStructureMgr3 Members IMcad2DStructureMgr3 Interface Send Feedback
Summary

Creates new annotation view

Visual Basic
Sub AddNewAnnotationView(pDefToInst As IMcadAnnotationViewDefinition, pMat As IGeMatrix, ByRef pNewViewInst As IMcadFolder*, OwningSpace As [in, optional] VARIANT)
Interface

IMcad2DStructureMgr3 Interface

Links
IMcad2DStructureMgr3 Interface, IMcad2DStructureMgr3 Members, IMcad2DStructureMgr3 Interface


IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr3 Interface IMcad2DStructureMgr3 Members IMcad2DStructureMgr3 Interface Example Send Feedback
Summary

Create an annotation view and definition based on the specified component definition and component view definitions.

Visual Basic
Sub AddNewAnnotationViewDefinition(ByRef pNewAnnotationViewDef As IMcadAnnotationViewDefinition*, ByRef pNewFolderInst As IMcadFolder*, pMat As IGeMatrix, matrices As VARIANT, pCompDef As IMcadComponentDefinition, pCompViewDefs As IMcadComponentViewDefinitions, Name As [in, optional] VARIANT, CreateLabels As [in, optional] VARIANT, LabelPattern As [in, optional] VARIANT, OwningSpace As [in, optional] VARIANT)
Parameters
Parameters | Description
pNewAnnotationViewDef | McadAnnotationViewDefinition object; output-only. Specifies the new annotation view definition to create.
pNewFolderInst | McadFolder object; output-only. Specifies the parent folder for the new annotation view definition.
pMat | GeMatrix object; input-only. Specifies the base position for the new annotation view.
matrices | Variant (array of GeMatrix objects); input-only. Specifies the array of matrices for the new position of each of the new views.
pCompDef | McadComponentDefinition object; input-only. Specifies a valid component based on which to create the new annotation view.
pCompViewDefs | McadComponentViewDefinitions collection; input-only. Specifies an array of component view definitions of pCompDefKey whose corresponding annotation view position are specified in arMatrices.
Name | Variant (String); input-only. Specifies the name of the new annotation view definition. If not specified, system will generate an appropriate name.
CreateLabels | _nt_
LabelPattern | _nt_
OwningSpace | _nt_
Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcad2DStructureMgr3 Interface

Links
IMcad2DStructureMgr3 Interface, IMcad2DStructureMgr3 Members, IMcad2DStructureMgr3 Interface, Example


IMcad2DStructureMgr3::UpdateEntities Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3::UpdateEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3::UpdateEntities Method
IMcad2DStructureMgr3 Interface IMcad2DStructureMgr3 Members IMcad2DStructureMgr3 Interface Send Feedback
Summary

Updates 2D structure with entity changes in model space.

Visual Basic
Sub UpdateEntities(Database As [in, optional] VARIANT)
Remarks

When a new entity is added to an active target in 2D structure or a structure entity is modified / deleted, using AutoCAD API, execute this method to update the 2D structure with the entity changes.

Interface

IMcad2DStructureMgr3 Interface

Links
IMcad2DStructureMgr3 Interface, IMcad2DStructureMgr3 Members, IMcad2DStructureMgr3 Interface


IMcad2DStructureMgr4 Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4 Interface
IMcad2DStructureMgr4 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5
Visual Basic
Public Interface IMcad2DStructureMgr4
Inherits IMcad2DStructureMgr3
Library

AcadmAuto Library

Links
IMcad2DStructureMgr4 Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureMgr4 Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4 Members
IMcad2DStructureMgr4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureMgr4.

Interface

IMcad2DStructureMgr4 Interface

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.
Links
IMcad2DStructureMgr4 Interface, Legend, Methods, Properties


IMcad2DStructureMgr4::SelectionLockMode Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::SelectionLockMode Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::SelectionLockMode Property
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Property that specifies the state of the 2D Structure selection lock mode.

Visual Basic
Property SelectionLockMode() As VARIANT_BOOL
Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr4::SelectionOrderMode Property

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::SelectionOrderMode Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::SelectionOrderMode Property
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Property that specifies the state of the 2D Structure selection order mode.

Visual Basic
Property SelectionOrderMode() As McadSelectionOrderOption
Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr4::GetReferenceLockMode Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::GetReferenceLockMode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::GetReferenceLockMode Method
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Gets the state of the 2D Structure reference lock mode for a database.

Visual Basic
Sub GetReferenceLockMode(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pMode As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | Optional. Default is NULL. The database to retrieve the state of the 2D Structure reference lock mode. By default, the current database is used.
Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr4::GetStructureMode Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::GetStructureMode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::GetStructureMode Method
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Gets the state of the 2D Structure mode for a database.

Visual Basic
Sub GetStructureMode(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pMode As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | Optional. Default is NULL. The database to retrieve the state of the 2D Structure mode. By default, the current database is used.
Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr4::SetReferenceLockMode Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::SetReferenceLockMode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::SetReferenceLockMode Method
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Sets the state of the 2D Structure reference lock mode for a database.

Visual Basic
Sub SetReferenceLockMode(bMode As VARIANT_BOOL, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase)
Parameters
Parameters | Description
bMode | The state of the 2D Structure reference lock mode to set.
pDatabase | Optional. Default is NULL. The database to set the state of the 2D Structure reference lock mode. By default, the current database is used.
Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr4::SetStructureMode Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4::SetStructureMode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4::SetStructureMode Method
IMcad2DStructureMgr4 Interface IMcad2DStructureMgr4 Members IMcad2DStructureMgr4 Interface Send Feedback
Summary

Sets the state of the 2D structure mode for a database.

Visual Basic
Sub SetStructureMode(bMode As VARIANT_BOOL, pDatabase As [in, defaultvalue(NULL)] IAcadDatabase)
Parameters
Parameters | Description
bMode | The state of the 2d Structure mode to set.
pDatabase | Optional. Default is NULL. The database to set the state of the 2D Structure mode. By default, the current database is used.
Remarks

Raises an error when setting the state of the 2D Structure mode to false for a database that has 2D Structure.

Interface

IMcad2DStructureMgr4 Interface

Links
IMcad2DStructureMgr4 Interface, IMcad2DStructureMgr4 Members, IMcad2DStructureMgr4 Interface


IMcad2DStructureMgr5 Interface

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5 Interface
IMcad2DStructureMgr5 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for creating descriptors for 2D structure and getting objects for migration.

Class Hierarchy

Declaration syntax

IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5
Visual Basic
Public Interface IMcad2DStructureMgr5
Inherits IMcad2DStructureMgr4
Library

AcadmAuto Library

Links
IMcad2DStructureMgr5 Members, AcadmAuto Library, Class Hierarchy


IMcad2DStructureMgr5 Members

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5 Members
IMcad2DStructureMgr5 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcad2DStructureMgr5.

Interface

IMcad2DStructureMgr5 Interface

Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateRootViewDefinition | Creates a master view definition in the specified database. If the database already contains a master view definition, it returns the existing one.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExistsStructure | Checks for the existence of mechanical structure in the specified database.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.
Links
IMcad2DStructureMgr5 Interface, Legend, Methods, Properties


IMcad2DStructureMgr5::CreateRootViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5::CreateRootViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5::CreateRootViewDefinition Method
IMcad2DStructureMgr5 Interface IMcad2DStructureMgr5 Members IMcad2DStructureMgr5 Interface Send Feedback
Summary

Creates a master view definition in the specified database. If the database already contains a master view definition, it returns the existing one.

Visual Basic
Sub CreateRootViewDefinition(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pVal As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
pDatabase | AcadDatabase object; default value = NULL; input-only; optional. Specifies the database to check. If NULL, the host database of the current document is assumed.
pVal | MCadFolderDefinition object; output only. Specifies the created or existing master view definition.
Remarks

Read-only.

Interface

IMcad2DStructureMgr5 Interface

Links
IMcad2DStructureMgr5 Interface, IMcad2DStructureMgr5 Members, IMcad2DStructureMgr5 Interface


IMcad2DStructureMgr5::ExistsStructure Method

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5::ExistsStructure Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5::ExistsStructure Method
IMcad2DStructureMgr5 Interface IMcad2DStructureMgr5 Members IMcad2DStructureMgr5 Interface Send Feedback
Summary

Checks for the existence of mechanical structure in the specified database.

Visual Basic
Sub ExistsStructure(pDatabase As [in, defaultvalue(NULL)] IAcadDatabase, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pDatabase | AcadDatabase object; default value = NULL; input-only; optional. Specifies the database to check. If NULL, the host database of the current document is assumed.
pVal | Variant (Boolean); output only. True, if the database contains view or folder definitions.
Remarks

Read-only.

Interface

IMcad2DStructureMgr5 Interface

Links
IMcad2DStructureMgr5 Interface, IMcad2DStructureMgr5 Members, IMcad2DStructureMgr5 Interface


IMcadAnnotationViewDefinition Interface

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition Interface
IMcadAnnotationViewDefinition Members AcadmAuto Library Class Hierarchy Example Send Feedback
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2
Visual Basic
Public Interface IMcadAnnotationViewDefinition
Inherits IMcadFolderDefinition
Remarks

Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Example

Refer to SDK Samples: CreateStructure.dvb

Library

AcadmAuto Library

Links
IMcadAnnotationViewDefinition Members, AcadmAuto Library, Class Hierarchy, Example


IMcadAnnotationViewDefinition Members

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition Members
IMcadAnnotationViewDefinition Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinition.

Interface

IMcadAnnotationViewDefinition Interface

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadAnnotationViewDefinition Interface, Legend, Methods, Properties


IMcadAnnotationViewDefinition::ComponentDefinition Property

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition::ComponentDefinition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition::ComponentDefinition Property
IMcadAnnotationViewDefinition Interface IMcadAnnotationViewDefinition Members IMcadAnnotationViewDefinition Interface Send Feedback
Summary

Extracts the component definition that the annotation view is based on.

Visual Basic
Property ComponentDefinition() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.

Interface

IMcadAnnotationViewDefinition Interface

Links
IMcadAnnotationViewDefinition Interface, IMcadAnnotationViewDefinition Members, IMcadAnnotationViewDefinition Interface


IMcadAnnotationViewDefinition::AddComponentView Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition::AddComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition::AddComponentView Method
IMcadAnnotationViewDefinition Interface IMcadAnnotationViewDefinition Members IMcadAnnotationViewDefinition Interface Example Send Feedback
Summary

Add an annotation view for the specified component view definition.

Visual Basic
Sub AddComponentView(pDefToInst As IMcadComponentViewDefinition, pMat As IGeMatrix, pVal As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition whose annotation is to be created.
pMat | GeMatrix object; input-only. Specifies the position to place the annotation view.
Returns

McadComponentView object

Remarks

GeMatrix object defines a 4 x 4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Example

Refer to SDK Samples: CreateStructure.dvb

Interface

IMcadAnnotationViewDefinition Interface

Links
IMcadAnnotationViewDefinition Interface, IMcadAnnotationViewDefinition Members, IMcadAnnotationViewDefinition Interface, Example


IMcadAnnotationViewDefinition::RemoveComponentView Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition::RemoveComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition::RemoveComponentView Method
IMcadAnnotationViewDefinition Interface IMcadAnnotationViewDefinition Members IMcadAnnotationViewDefinition Interface Send Feedback
Summary

Removes the specified child component view of this annotation view definition.

Visual Basic
Sub RemoveComponentView(pCompView As IMcadComponentView)
Parameters
Parameters | Description
pCompView | McadComponentView object; input-only. Specifies the child component view to be removed.
Returns

None

Interface

IMcadAnnotationViewDefinition Interface

Links
IMcadAnnotationViewDefinition Interface, IMcadAnnotationViewDefinition Members, IMcadAnnotationViewDefinition Interface


IMcadAnnotationViewDefinition2 Interface

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2 Interface
IMcadAnnotationViewDefinition2 Members AcadmAuto Library Class Hierarchy Example Send Feedback
Summary

An annotation view is a component view instance that is created exclusively for the purpose of detailing.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2
Visual Basic
Public Interface IMcadAnnotationViewDefinition2
Inherits IMcadAnnotationViewDefinition
Remarks

Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.

Example

Refer to SDK Samples: CreateStructure.dvb

Library

AcadmAuto Library

Links
IMcadAnnotationViewDefinition2 Members, AcadmAuto Library, Class Hierarchy, Example


IMcadAnnotationViewDefinition2 Members

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2 Members
IMcadAnnotationViewDefinition2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinition2.

Interface

IMcadAnnotationViewDefinition2 Interface

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
AnnotationViewLabel | Returns annotation view label for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
Children | Gets the children of the folder definition.
CreateAnnotationViewLabel | Creates annotation view label for subview of annotation view
CreateAnnotationViewLabels | Creates annotation view label for subview of annotation view
Delete | Deletes the object being referenced.
EraseAnnotationViewLabel | Erase annotation view label for subview of annotation view
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
HasAnnotationViewLabel | Erase annotation view label for subview of annotation view
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadAnnotationViewDefinition2 Interface, Legend, Methods, Properties


IMcadAnnotationViewDefinition2::AnnotationViewLabel Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::AnnotationViewLabel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::AnnotationViewLabel Method
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Returns annotation view label for subview of annotation view

Visual Basic
Sub AnnotationViewLabel(pSubView As IMcadComponentView, pLabelPath As [out, retval] IMcadFolder*)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Returns annotation view label pattern for subview of annotation view

Visual Basic
Sub AnnotationViewLabelPattern(pSubView As IMcadComponentView, LabelPattern As String)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Returns annotation view label pattern for subview of annotation view

Visual Basic
Sub AnnotationViewLabelPattern(pSubView As IMcadComponentView, pLabelPattern As [out, retval] BSTR)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Creates annotation view label for subview of annotation view

Visual Basic
Sub CreateAnnotationViewLabel(pSubView As IMcadComponentView, LabelPattern As [in, optional] VARIANT)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Creates annotation view label for subview of annotation view

Visual Basic
Sub CreateAnnotationViewLabels(LabelPattern As [in, optional] VARIANT)
Parameters
Parameters | Description
LabelPattern | _nt_
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Erase annotation view label for subview of annotation view

Visual Basic
Sub EraseAnnotationViewLabel(pSubView As IMcadComponentView)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method
IMcadAnnotationViewDefinition2 Interface IMcadAnnotationViewDefinition2 Members IMcadAnnotationViewDefinition2 Interface Send Feedback
Summary

Erase annotation view label for subview of annotation view

Visual Basic
Sub HasAnnotationViewLabel(pSubView As IMcadComponentView, pHasLabel As [out, retval] VARIANT_BOOL)
Interface

IMcadAnnotationViewDefinition2 Interface

Links
IMcadAnnotationViewDefinition2 Interface, IMcadAnnotationViewDefinition2 Members, IMcadAnnotationViewDefinition2 Interface


IMcadAnnotationViewDefinitions Interface

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions Interface
IMcadAnnotationViewDefinitions Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAnnotationViewDefinition objects.

Class Hierarchy

Declaration syntax

IMcadAnnotationViewDefinitions
Visual Basic
Public Interface IMcadAnnotationViewDefinitions
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadAnnotationViewDefinitions Members, AcadmAuto Library, Class Hierarchy


IMcadAnnotationViewDefinitions Members

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions Members
IMcadAnnotationViewDefinitions Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAnnotationViewDefinitions.

Interface

IMcadAnnotationViewDefinitions Interface

Methods
Name | Description
Add | Appends a new annotation view definition to the collection.
Item | Gets the annotation view definition at the specified index.
Remove | Removes the specified annotation view definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of annotation view definitions in the collection.
Links
IMcadAnnotationViewDefinitions Interface, Legend, Methods, Properties


IMcadAnnotationViewDefinitions::Application Property

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions::Application Property
IMcadAnnotationViewDefinitions Interface IMcadAnnotationViewDefinitions Members IMcadAnnotationViewDefinitions Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadAnnotationViewDefinitions Interface

Links
IMcadAnnotationViewDefinitions Interface, IMcadAnnotationViewDefinitions Members, IMcadAnnotationViewDefinitions Interface


IMcadAnnotationViewDefinitions::Count Property

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions::Count Property
IMcadAnnotationViewDefinitions Interface IMcadAnnotationViewDefinitions Members IMcadAnnotationViewDefinitions Interface Send Feedback
Summary

Gets the total number of annotation view definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadAnnotationViewDefinitions Interface

Links
IMcadAnnotationViewDefinitions Interface, IMcadAnnotationViewDefinitions Members, IMcadAnnotationViewDefinitions Interface


IMcadAnnotationViewDefinitions::Add Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions::Add Method
IMcadAnnotationViewDefinitions Interface IMcadAnnotationViewDefinitions Members IMcadAnnotationViewDefinitions Interface Send Feedback
Summary

Appends a new annotation view definition to the collection.

Visual Basic
Sub Add(Definition As IMcadAnnotationViewDefinition)
Parameters
Parameters | Description
Definition | McadAnnotationViewDefinition object; input-only. Specifies the new annotation view definition to add to the collection.
Returns

None

Interface

IMcadAnnotationViewDefinitions Interface

Links
IMcadAnnotationViewDefinitions Interface, IMcadAnnotationViewDefinitions Members, IMcadAnnotationViewDefinitions Interface


IMcadAnnotationViewDefinitions::Item Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions::Item Method
IMcadAnnotationViewDefinitions Interface IMcadAnnotationViewDefinitions Members IMcadAnnotationViewDefinitions Interface Send Feedback
Summary

Gets the annotation view definition at the specified index.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadAnnotationViewDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the annotation view definition to get from the collection.
Returns

McadAnnotationViewDefinition object

Interface

IMcadAnnotationViewDefinitions Interface

Links
IMcadAnnotationViewDefinitions Interface, IMcadAnnotationViewDefinitions Members, IMcadAnnotationViewDefinitions Interface


IMcadAnnotationViewDefinitions::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions::Remove Method
IMcadAnnotationViewDefinitions Interface IMcadAnnotationViewDefinitions Members IMcadAnnotationViewDefinitions Interface Send Feedback
Summary

Removes the specified annotation view definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the annotation view definition to get from the collection.
Returns

None

Interface

IMcadAnnotationViewDefinitions Interface

Links
IMcadAnnotationViewDefinitions Interface, IMcadAnnotationViewDefinitions Members, IMcadAnnotationViewDefinitions Interface


IMcadArc Interface

You are here: API Reference > AcadmAuto Library > IMcadArc Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadArc Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An arc curve.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc
Visual Basic
Public Interface IMcadArc
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadAttribute Interface

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute Interface
IMcadAttribute Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Represents an instance of an attribute.

Class Hierarchy

Declaration syntax

IMcadAttribute
Visual Basic
Public Interface IMcadAttribute
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadAttribute Members, AcadmAuto Library, Class Hierarchy


IMcadAttribute Members

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute Members
IMcadAttribute Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAttribute.

Interface

IMcadAttribute Interface

Methods
Name | Description
FieldDescription | Gets the description for the specified attribute field.
FieldName | Gets the name of the specified attribute field.
FieldType | Gets the data type held by the specified field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
GetFieldIndex | Gets the index associated with the specified attribute field name.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ClassName | Gets the name of the attribute's class definition.
Document | Gets the document containing this object.
FieldCount | Gets the number of fields in the attribute.
Holders | Gets references to the object that this attribute is attached to.
ObjectID | Gets the object ID of the attribute object.
ObjectID32 | Gets the object ID of the attribute object.
Links
IMcadAttribute Interface, Legend, Methods, Properties


IMcadAttribute::Application Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::Application Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::ClassName Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::ClassName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::ClassName Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the name of the attribute's class definition.

Visual Basic
Property ClassName() As BSTR*
Remarks

This property is a String.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::Document Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::Document Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the document containing this object.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldCount Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldCount Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the number of fields in the attribute.

Visual Basic
Property FieldCount() As long*
Remarks

This property is a Long.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::Holders Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::Holders Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::Holders Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets references to the object that this attribute is attached to.

Visual Basic
Property Holders() As IMcadObjects**
Remarks

This property is a McadObjects collection.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::ObjectID Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::ObjectID Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::ObjectID Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the object ID of the attribute object.

Visual Basic
Property ObjectID() As LONG_PTR*
Remarks

This property is a Long.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::ObjectID32 Property

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::ObjectID32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::ObjectID32 Property
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the object ID of the attribute object.

Visual Basic
Property ObjectID32() As LONG*
Remarks

This property is a Long.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldDescription Method

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldDescription Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldDescription Method
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the description for the specified attribute field.

Visual Basic
Sub FieldDescription(Index As [in, optional] VARIANT, Description As [out, retval] BSTR)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the description for. If not specified, the description of the first field is returned.
Remarks
  • This property is a String.
  • The Index element can be obtained from the GetFieldIndex method.
Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldName Method

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldName Method
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the name of the specified attribute field.

Visual Basic
Sub FieldName(Index As [in, defaultvalue(0)] long, Name As [out, retval] BSTR)
Parameters
Parameters | Description
Index | Long, default value = 0; input-only; optional. Specifies the index for the attribute field to get the name for.
Remarks

This property is a String.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldType Method

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldType Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldType Method
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the data type held by the specified field.

Visual Basic
Sub FieldType(Index As [in, optional] VARIANT, Type As [out, retval] McadFieldType)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the field type for. If not specified, the type of the first field is returned.
Remarks

This property is a McadFieldType enumeration.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue(Index As [in, optional] VARIANT, Value As VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Remarks

This property is a Variant determined by FieldType .

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue(Index As [in, optional] VARIANT, Value As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Remarks

This property is a Variant determined by FieldType .

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue32(Index As [in, optional] VARIANT, Value As VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Value | _nt_
Remarks

This property is a Variant determined by FieldType.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Specifies the data value for the specified attribute field.

Visual Basic
Sub FieldValue32(Index As [in, optional] VARIANT, Value As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (String or Long); input-only; optional. Specifies either the string name or the index number of the attribute field to get the data value for. If not specified, the data value of the first field is returned.
Value | _nt_
Remarks

This property is a Variant determined by FieldType.

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttribute::GetFieldIndex Method

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute::GetFieldIndex Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute::GetFieldIndex Method
IMcadAttribute Interface IMcadAttribute Members IMcadAttribute Interface Send Feedback
Summary

Gets the index associated with the specified attribute field name.

Visual Basic
Sub GetFieldIndex(Name As String, Index As [out, retval] long)
Parameters
Parameters | Description
Name | String; input-only. Specifies the attribute field name.
Returns

Long

Interface

IMcadAttribute Interface

Links
IMcadAttribute Interface, IMcadAttribute Members, IMcadAttribute Interface


IMcadAttributeField Interface

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField Interface
IMcadAttributeField Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Represents the description of a single attribute field.

Class Hierarchy

Declaration syntax

IMcadAttributeField
Visual Basic
Public Interface IMcadAttributeField
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadAttributeField Members, AcadmAuto Library, Class Hierarchy


IMcadAttributeField Members

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField Members
IMcadAttributeField Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAttributeField.

Interface

IMcadAttributeField Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Description | Specifies the text description or comment describing the contents of the attribute field.
FieldType | Specifies the data type held by the specified attribute field.
Name | Specifies the name of the attribute field.
Static | Specifies whether the fields data is static, TRUE, or shared across all instances of the attribute, FALSE.
Links
IMcadAttributeField Interface, Legend, Properties


IMcadAttributeField::Application Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField::Application Property
IMcadAttributeField Interface IMcadAttributeField Members IMcadAttributeField Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadAttributeField Interface

Links
IMcadAttributeField Interface, IMcadAttributeField Members, IMcadAttributeField Interface


IMcadAttributeField::Description Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField::Description Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField::Description Property
IMcadAttributeField Interface IMcadAttributeField Members IMcadAttributeField Interface Send Feedback
Summary

Specifies the text description or comment describing the contents of the attribute field.

Visual Basic
Property Description() As String
Remarks
  • This property is a String.
  • Setting or changing the field description only has an effect when the McadAttributeField is used to define an attribute class.
Interface

IMcadAttributeField Interface

Links
IMcadAttributeField Interface, IMcadAttributeField Members, IMcadAttributeField Interface


IMcadAttributeField::FieldType Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField::FieldType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField::FieldType Property
IMcadAttributeField Interface IMcadAttributeField Members IMcadAttributeField Interface Send Feedback
Summary

Specifies the data type held by the specified attribute field.

Visual Basic
Property FieldType() As McadFieldType
Remarks
  • This property is a McadFieldType enumeration.
  • Setting or changing the field type only has an effect when the McadAttributeField is used to define an attribute class.
Interface

IMcadAttributeField Interface

Links
IMcadAttributeField Interface, IMcadAttributeField Members, IMcadAttributeField Interface


IMcadAttributeField::Name Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField::Name Property
IMcadAttributeField Interface IMcadAttributeField Members IMcadAttributeField Interface Send Feedback
Summary

Specifies the name of the attribute field.

Visual Basic
Property Name() As String
Remarks
  • This property is a String.
  • Setting or changing this property only has an effect when the McadAttributeField is used to define an attribute class.
Interface

IMcadAttributeField Interface

Links
IMcadAttributeField Interface, IMcadAttributeField Members, IMcadAttributeField Interface


IMcadAttributeField::Static Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField::Static Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField::Static Property
IMcadAttributeField Interface IMcadAttributeField Members IMcadAttributeField Interface Send Feedback
Summary

Specifies whether the fields data is static, TRUE, or shared across all instances of the attribute, FALSE.

Visual Basic
Property Static() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Setting or changing this property only has an effect when the McadAttributeField is used to define an attribute class.
Interface

IMcadAttributeField Interface

Links
IMcadAttributeField Interface, IMcadAttributeField Members, IMcadAttributeField Interface


IMcadAttributeFields Interface

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields Interface
IMcadAttributeFields Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAttributeField objects.

Class Hierarchy

Declaration syntax

IMcadAttributeFields
Visual Basic
Public Interface IMcadAttributeFields
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadAttributeFields Members, AcadmAuto Library, Class Hierarchy


IMcadAttributeFields Members

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields Members
IMcadAttributeFields Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAttributeFields.

Interface

IMcadAttributeFields Interface

Methods
Name | Description
Add | Appends an attribute field to the collection.
Item | Gets the attribute field at the specified index.
Remove | Removes the specified attribute field from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of attribute fields in the collection.
Links
IMcadAttributeFields Interface, Legend, Methods, Properties


IMcadAttributeFields::Application Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields::Application Property
IMcadAttributeFields Interface IMcadAttributeFields Members IMcadAttributeFields Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadAttributeFields Interface

Links
IMcadAttributeFields Interface, IMcadAttributeFields Members, IMcadAttributeFields Interface


IMcadAttributeFields::Count Property

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields::Count Property
IMcadAttributeFields Interface IMcadAttributeFields Members IMcadAttributeFields Interface Send Feedback
Summary

Gets the total number of attribute fields in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadAttributeFields Interface

Links
IMcadAttributeFields Interface, IMcadAttributeFields Members, IMcadAttributeFields Interface


IMcadAttributeFields::Add Method

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields::Add Method
IMcadAttributeFields Interface IMcadAttributeFields Members IMcadAttributeFields Interface Send Feedback
Summary

Appends an attribute field to the collection.

Visual Basic
Sub Add(Field As IMcadAttributeField)
Parameters
Parameters | Description
Field | McadAttributeField object; input-only. Specifies the new attribute field to add to the collection.
Returns

None

Interface

IMcadAttributeFields Interface

Links
IMcadAttributeFields Interface, IMcadAttributeFields Members, IMcadAttributeFields Interface


IMcadAttributeFields::Item Method

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields::Item Method
IMcadAttributeFields Interface IMcadAttributeFields Members IMcadAttributeFields Interface Send Feedback
Summary

Gets the attribute field at the specified index.

Visual Basic
Sub Item(Index As long, Field As [out, retval] IMcadAttributeField*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute field to get from the collection.
Returns

McadAttributeField object

Interface

IMcadAttributeFields Interface

Links
IMcadAttributeFields Interface, IMcadAttributeFields Members, IMcadAttributeFields Interface


IMcadAttributeFields::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields::Remove Method
IMcadAttributeFields Interface IMcadAttributeFields Members IMcadAttributeFields Interface Send Feedback
Summary

Removes the specified attribute field from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute field to remove from the collection.
Returns

None

Interface

IMcadAttributeFields Interface

Links
IMcadAttributeFields Interface, IMcadAttributeFields Members, IMcadAttributeFields Interface


IMcadAttributes Interface

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes Interface
IMcadAttributes Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadAttribute objects.

Class Hierarchy

Declaration syntax

IMcadAttributes
Visual Basic
Public Interface IMcadAttributes
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadAttributes Members, AcadmAuto Library, Class Hierarchy


IMcadAttributes Members

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes Members
IMcadAttributes Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAttributes.

Interface

IMcadAttributes Interface

Methods
Name | Description
Add | Appends an attribute to a the collection.
Item | Gets the attribute at the specified index.
Remove | Removes the specified attribute from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of items in the collection.
Links
IMcadAttributes Interface, Legend, Methods, Properties


IMcadAttributes::Application Property

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes::Application Property
IMcadAttributes Interface IMcadAttributes Members IMcadAttributes Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadAttributes Interface

Links
IMcadAttributes Interface, IMcadAttributes Members, IMcadAttributes Interface


IMcadAttributes::Count Property

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes::Count Property
IMcadAttributes Interface IMcadAttributes Members IMcadAttributes Interface Send Feedback
Summary

Gets the total number of items in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadAttributes Interface

Links
IMcadAttributes Interface, IMcadAttributes Members, IMcadAttributes Interface


IMcadAttributes::Add Method

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes::Add Method
IMcadAttributes Interface IMcadAttributes Members IMcadAttributes Interface Send Feedback
Summary

Appends an attribute to a the collection.

Visual Basic
Sub Add(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the collection.
Returns

None

Interface

IMcadAttributes Interface

Links
IMcadAttributes Interface, IMcadAttributes Members, IMcadAttributes Interface


IMcadAttributes::Item Method

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes::Item Method
IMcadAttributes Interface IMcadAttributes Members IMcadAttributes Interface Send Feedback
Summary

Gets the attribute at the specified index.

Visual Basic
Sub Item(Index As long, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute to get from the collection.
Returns

McadAttribute object

Interface

IMcadAttributes Interface

Links
IMcadAttributes Interface, IMcadAttributes Members, IMcadAttributes Interface


IMcadAttributes::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes::Remove Method
IMcadAttributes Interface IMcadAttributes Members IMcadAttributes Interface Send Feedback
Summary

Removes the specified attribute from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the attribute to get from the collection.
Returns

None

Interface

IMcadAttributes Interface

Links
IMcadAttributes Interface, IMcadAttributes Members, IMcadAttributes Interface


IMcadAugmentedLine Interface

You are here: API Reference > AcadmAuto Library > IMcadAugmentedLine Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAugmentedLine Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadAugmentedLine
Visual Basic
Public Interface IMcadAugmentedLine
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadComplexHideSituation Interface

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation Interface
IMcadComplexHideSituation Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for 2D structure complex hide situations.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComplexHideSituation
Visual Basic
Public Interface IMcadComplexHideSituation
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadComplexHideSituation Members, AcadmAuto Library, Class Hierarchy


IMcadComplexHideSituation Members

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation Members
IMcadComplexHideSituation Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComplexHideSituation.

Interface

IMcadComplexHideSituation Interface

Methods
Name | Description
AddLevel | Adds new level to complex hide, new hide situation pNewHide is created for the new level, or existing hide situation is used as level if it was specified in pNewHide.
Delete | Deletes the object being referenced.
Explode | Converts complex hide situation to normal hide situations. Each levels of complex hide create simple independent hide situation. The foreground and background will be set from the position of the level in the complex hide situation.
Highlight | Highlights the topological entity on the model.
InitFromHide | Initializes the complex hide situation from the specified normal hide situation. The complex hide will has two levels. First level is foreground of the specified hide and the second level is background of the specified hide.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
LookupLevelName | Looks up the level with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
MoveLevel | Changes the position of the level (hide) within the complex hide levels.
RemoveLevel | Removes the specified level (hide) from the complex hide situation.
RemoveLevelByIdx | Removes the level (hide) with the given index from the complex hide situation.
Reverse | Reverses the order of all levels in the complex hide situation.
UpdateBgSelection | Recalculates the background selections based on the current foreground selections.
Properties
Name
Description
Application
Gets the AcadmApplication object.
Concealed
Gets or sets whether the complex hide situation is concealed, TRUE, or not, FALSE.
Definition
Gets or sets the parent folder definition for this complex hide situation.
Document
Gets the corresponding McadDocument from the specified host application's document.
Editable
Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
HiddenLinesInvisible
Gets whether the hidden lines are invisible, TRUE, or dashed, FALSE.
HideAppropriateObjectsOnly
Specifies how background objects are processed:

  • TRUE: A filter is applied and objects that have their 'Usage in Hide' property set to 'Ignore in Hide' or 'Foreground only' (via the Layer/Object property).
  • FALSE: All objects selected for the background are hidden.
HideSituations
Returns all hide situations from this complex hide situation.
IsModifiedStandardPartHide
Gets whether the complex hide situation has been modified by users, TRUE, or not, FALSE.
IsStandardPartHide
Gets whether hide situations was automatically created by standard parts, TRUE, or not, FALSE.
LevelCount
Returns the number of levels in complex hide situation.
Name
Gets or sets the complex hide situation.
NextLevelName
Returns the default name for the next new level in the complex hide situation.
Suppressed
Gets whether the complex hide situation is suppressed, TRUE, or not, FALSE.
SysName
Gets the complex hide situation system name.
WasErased
Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadComplexHideSituation Interface, Legend, Methods, Properties


IMcadComplexHideSituation::Concealed Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Concealed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Concealed Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets or sets whether the complex hide situation is concealed, TRUE, or not, FALSE.

Visual Basic
Property Concealed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::Definition Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Definition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Definition Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets or sets the parent folder definition for this complex hide situation.

Visual Basic
Property Definition() As IMcadFolderDefinition*
Remarks

This property is a McadFolderDefinition object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::HiddenLinesInvisible Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HiddenLinesInvisible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::HiddenLinesInvisible Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets whether the hidden lines are invisible, TRUE, or dashed, FALSE.

Visual Basic
Property HiddenLinesInvisible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::HideAppropriateObjectsOnly Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Specifies how background objects are processed:

  • TRUE: A filter is applied and objects that have their 'Usage in Hide' property set to 'Ignore in Hide' or 'Foreground only' (via the Layer/Object property).
  • FALSE: All objects selected for the background are hidden.
Visual Basic
Property HideAppropriateObjectsOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::HideSituations Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HideSituations Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::HideSituations Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Returns all hide situations from this complex hide situation.

Visual Basic
Property HideSituations() As IMcadHideSituations* *
Remarks

This property is a McadHideSituations enumeration.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::IsModifiedStandardPartHide Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::IsModifiedStandardPartHide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::IsModifiedStandardPartHide Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets whether the complex hide situation has been modified by users, TRUE, or not, FALSE.

Visual Basic
Property IsModifiedStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::IsStandardPartHide Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::IsStandardPartHide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::IsStandardPartHide Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets whether hide situations was automatically created by standard parts, TRUE, or not, FALSE.

Visual Basic
Property IsStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::LevelCount Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::LevelCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::LevelCount Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Returns the number of levels in complex hide situation.

Visual Basic
Property LevelCount() As long*
Remarks

This property is a Long.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::Name Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Name Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets or sets the complex hide situation.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::NextLevelName Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::NextLevelName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::NextLevelName Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Returns the default name for the next new level in the complex hide situation.

Visual Basic
Property NextLevelName() As BSTR*
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::Suppressed Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Suppressed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Suppressed Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets whether the complex hide situation is suppressed, TRUE, or not, FALSE.

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The hide situation is not computed when it is suppressed.
Example

Refer to SDK Samples: amshide2d.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::SysName Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::SysName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::SysName Property
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Gets the complex hide situation system name.

Visual Basic
Property SysName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::AddLevel Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::AddLevel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::AddLevel Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Adds new level to complex hide, new hide situation pNewHide is created for the new level, or existing hide situation is used as level if it was specified in pNewHide.

Visual Basic
Sub AddLevel(levelIdx As long, pNewHide As [in, out] IMcadHideSituation*)
Parameters
Parameters | Description
levelIdx | Long; input-only. Specifies the index for the level of the hide situation.
pNewHide | McadHideSituation enumeration; input-only. New empty hide situation will be created in the new level with given index. If pNewHide exists, then this hide situation will be used for given index.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::Explode Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Explode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Explode Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Converts complex hide situation to normal hide situations. Each levels of complex hide create simple independent hide situation. The foreground and background will be set from the position of the level in the complex hide situation.

Visual Basic
Sub Explode()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::InitFromHide Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::InitFromHide Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::InitFromHide Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Send Feedback
Summary

Initializes the complex hide situation from the specified normal hide situation. The complex hide will has two levels. First level is foreground of the specified hide and the second level is background of the specified hide.

Visual Basic
Sub InitFromHide(pHide As IMcadHideSituation)
Parameters
Parameters | Description
pHide | McadHideSituation object; input-only. Specifies the normal hide situation with which to initialize the complex hide situation.
Returns

None

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface


IMcadComplexHideSituation::LookupLevelName Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::LookupLevelName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::LookupLevelName Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Looks up the level with the specified name.

Visual Basic
Sub LookupLevelName(levelName As String, pFound As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
levelName | String; input-only. Specifies the name of the level to look up.
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::MoveLevel Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::MoveLevel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::MoveLevel Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Changes the position of the level (hide) within the complex hide levels.

Visual Basic
Sub MoveLevel(srcIdx As long, destIdx As long)
Parameters
Parameters | Description
srcIdx | Long; input-only. Specifies the index of the source level to reposition.
destIdx | Long; input-only. Specifies the index of the destination level to reposition.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::RemoveLevel Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::RemoveLevel Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::RemoveLevel Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Removes the specified level (hide) from the complex hide situation.

Visual Basic
Sub RemoveLevel(pHide As IMcadHideSituation)
Parameters
Parameters | Description
pHide | McadHideSituation enumeration; input-only. Specifies the level (hide) to remove.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::RemoveLevelByIdx Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::RemoveLevelByIdx Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::RemoveLevelByIdx Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Removes the level (hide) with the given index from the complex hide situation.

Visual Basic
Sub RemoveLevelByIdx(levelIdx As long)
Parameters
Parameters | Description
levelIdx | Long; input-only. Specifies the index for the level (hide) to remove.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::Reverse Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Reverse Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::Reverse Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Reverses the order of all levels in the complex hide situation.

Visual Basic
Sub Reverse()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituation::UpdateBgSelection Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::UpdateBgSelection Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation::UpdateBgSelection Method
IMcadComplexHideSituation Interface IMcadComplexHideSituation Members IMcadComplexHideSituation Interface Example Send Feedback
Summary

Recalculates the background selections based on the current foreground selections.

Visual Basic
Sub UpdateBgSelection()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadComplexHideSituation Interface

Links
IMcadComplexHideSituation Interface, IMcadComplexHideSituation Members, IMcadComplexHideSituation Interface, Example


IMcadComplexHideSituations Interface

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations Interface
IMcadComplexHideSituations Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComplexHideSituation objects

Class Hierarchy

Declaration syntax

IMcadComplexHideSituations
Visual Basic
Public Interface IMcadComplexHideSituations
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadComplexHideSituations Members, AcadmAuto Library, Class Hierarchy


IMcadComplexHideSituations Members

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations Members
IMcadComplexHideSituations Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComplexHideSituations.

Interface

IMcadComplexHideSituations Interface

Methods
Name | Description
Add | Appends an complex hide situation to the collection.
Item | Gets the complex hide object at the specified index from the collection.
Remove | Removes the specified Complex hide from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of complex hide situations in the collection.
Links
IMcadComplexHideSituations Interface, Legend, Methods, Properties


IMcadComplexHideSituations::Application Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations::Application Property
IMcadComplexHideSituations Interface IMcadComplexHideSituations Members IMcadComplexHideSituations Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a GeApplication object.

Interface

IMcadComplexHideSituations Interface

Links
IMcadComplexHideSituations Interface, IMcadComplexHideSituations Members, IMcadComplexHideSituations Interface


IMcadComplexHideSituations::Count Property

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations::Count Property
IMcadComplexHideSituations Interface IMcadComplexHideSituations Members IMcadComplexHideSituations Interface Send Feedback
Summary

Gets the total number of complex hide situations in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadComplexHideSituations Interface

Links
IMcadComplexHideSituations Interface, IMcadComplexHideSituations Members, IMcadComplexHideSituations Interface


IMcadComplexHideSituations::Add Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations::Add Method
IMcadComplexHideSituations Interface IMcadComplexHideSituations Members IMcadComplexHideSituations Interface Send Feedback
Summary

Appends an complex hide situation to the collection.

Visual Basic
Sub Add(Component As IMcadComplexHideSituation)
Parameters
Parameters | Description
Component | McadComplexHideSituation object; input-only. Specifies the complex hide situation to add to the collection.
Returns

None

Interface

IMcadComplexHideSituations Interface

Links
IMcadComplexHideSituations Interface, IMcadComplexHideSituations Members, IMcadComplexHideSituations Interface


IMcadComplexHideSituations::Item Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations::Item Method
IMcadComplexHideSituations Interface IMcadComplexHideSituations Members IMcadComplexHideSituations Interface Send Feedback
Summary

Gets the complex hide object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComplexHideSituation*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the complex hide situation to get.
Returns

McadComplexHideSituation object

Interface

IMcadComplexHideSituations Interface

Links
IMcadComplexHideSituations Interface, IMcadComplexHideSituations Members, IMcadComplexHideSituations Interface


IMcadComplexHideSituations::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations::Remove Method
IMcadComplexHideSituations Interface IMcadComplexHideSituations Members IMcadComplexHideSituations Interface Send Feedback
Summary

Removes the specified Complex hide from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the complex hide situation to remove.
Returns

None

Interface

IMcadComplexHideSituations Interface

Links
IMcadComplexHideSituations Interface, IMcadComplexHideSituations Members, IMcadComplexHideSituations Interface


IMcadComponent Interface

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent Interface
IMcadComponent Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

References an instance of a component definition in the assembly.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComponent
Visual Basic
Public Interface IMcadComponent
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadComponent Members, AcadmAuto Library, Class Hierarchy


IMcadComponent Members

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent Members
IMcadComponent Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponent.

Interface

IMcadComponent Interface

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ClearOverrideProperties | Clears all override properties of this component if any exists.
ColorOverride | Sets the color override for all the component's views.
ContainingComponent | Returns the lowest level component that this object is inserted into.
CopyDefinition | Creates a copy of the definition for the specified folder or component view as in AMSCOPYDEF.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
GetComponentInDefinition | Gets the component equivalent to this component in the scope of the component's owning component definition.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for all the component's views.
RemoveAttribute | Removes the specified attribute from this component.
ReplaceDefinition | Replaces a specified component with a new definition as in AMSREPLACEDEF.
SortChildren | Sorts the children of this component.
VisibilityOverride | Sets the visibility override for all the component's views.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the occurrences of the children of the component.
ComponentViews | Gets all component views contained in this component.
Definition | Gets the definition for the component.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
hasExternalDef | Gets whether this component has external definitions, TRUE, or not, FALSE.
HasGhostViews | Specifies whether a component has a ghost component view, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether this component has override properties, TRUE, or not, FALSE.
is2D | Gets whether this component is in 2D structure.
Name | Specifies the name associated with the referenced object.
Owner | Gets the definition of the owner for the component.
Position |
Reference | Specifies whether a component is referenced by an external file.
Visible | Gets or sets the visibility of the component.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadComponent Interface, Legend, Methods, Properties


IMcadComponent::Children Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Children Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Children Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets the occurrences of the children of the component.

Visual Basic
Property Children() As IMcadComponents**
Remarks

This property is a McadComponents collection.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::ComponentViews Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ComponentViews Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::ComponentViews Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets all component views contained in this component.

Visual Basic
Property ComponentViews() As IMcadComponentViews**
Remarks

This property is a McadComponentViews collection.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Definition Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Definition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Definition Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets the definition for the component.

Visual Basic
Property Definition() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::hasExternalDef Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::hasExternalDef Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::hasExternalDef Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets whether this component has external definitions, TRUE, or not, FALSE.

Visual Basic
Property hasExternalDef() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::HasGhostViews Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::HasGhostViews Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::HasGhostViews Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Specifies whether a component has a ghost component view, TRUE, or not, FALSE.

Visual Basic
Property HasGhostViews() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::HasOverrideProperties Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::HasOverrideProperties Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::HasOverrideProperties Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Checks whether this component has override properties, TRUE, or not, FALSE.

Visual Basic
Property HasOverrideProperties() As VARIANT_BOOL *
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::is2D Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::is2D Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::is2D Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets whether this component is in 2D structure.

Visual Basic
Property is2D() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Name Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Name Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Specifies the name associated with the referenced object.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Owner Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Owner Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Owner Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets the definition of the owner for the component.

Visual Basic
Property Owner() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Position Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Position Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Visual Basic
Property Position() As IGeMatrix*
Remarks

This property has no implementation and is currently unsupported.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Reference Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Reference Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Reference Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Specifies whether a component is referenced by an external file.

Visual Basic
Property Reference() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::Visible Property

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::Visible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::Visible Property
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets or sets the visibility of the component.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::AddAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::AddAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::AddAttribute Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the component.
Associativity | McadAttributeAssociativity enumeration, default value = 0; input-only; optional. Specifies the behavior of the attribute when the object that the attribute is attached to is copied. If not specified, the default associativity behavior is used.
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::ClearOverrideProperties Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ClearOverrideProperties Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::ClearOverrideProperties Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Clears all override properties of this component if any exists.

Visual Basic
Sub ClearOverrideProperties()
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::ColorOverride Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ColorOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::ColorOverride Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Sets the color override for all the component's views.

Visual Basic
Sub ColorOverride(bColor As VARIANT_BOOL, bContoursColorOnly As VARIANT_BOOL, trueColor As [in,defaultvalue(NULL)] IAcadAcCmColor)
Parameters
Parameters | Description
bColor | Boolean; input-only. Specifies whether the color is set, TRUE, or not, FALSE.
bContoursColorOnly | Boolean; input-only. Specifies whether this method only sets the color for contours, TRUE, or not, FALSE.
trueColor | AcadAcCmColor object, default value =NULL; input-only; optional. Points to the color to set to. By default, it is NULL which results in the color value to be unchanged.
Returns

None

Remarks

Since color overrides applies only when predefined reference is FALSE, this method will fail if the predefined reference has already been set.

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::ContainingComponent Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ContainingComponent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::ContainingComponent Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Returns the lowest level component that this object is inserted into.

Visual Basic
Sub ContainingComponent(Component As [out, retval] IMcadComponent*)
Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::CopyDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::CopyDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::CopyDefinition Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Example Send Feedback
Summary

Creates a copy of the definition for the specified folder or component view as in AMSCOPYDEF.

Visual Basic
Sub CopyDefinition(newDefName As String)
Parameters
Parameters | Description
newDefName | String; input-only. Specifies the unique name for the copied component definition.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface, Example


IMcadComponent::GetAttributes Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::GetAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::GetAttributes Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = FALSE; input-only; optional. Specifies whether the exact match is used.
Returns

McadAttributes collection

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::GetComponentInDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::GetComponentInDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::GetComponentInDefinition Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Gets the component equivalent to this component in the scope of the component's owning component definition.

Visual Basic
Sub GetComponentInDefinition(Component As [out, retval] IMcadComponent*)
Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::PredefinedReferenceOverride Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::PredefinedReferenceOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::PredefinedReferenceOverride Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Sets the predefined reference override for all the component's views.

Visual Basic
Sub PredefinedReferenceOverride(bPredefinedRef As VARIANT_BOOL)
Parameters
Parameters | Description
bPredefinedRef | Boolean; input-only. Specifies whether to set predefined reference override property, TRUE, or not, FALSE. Visibility of everything except contours is turned off. Contour lines are changed to the configured linetype and color of the phantom line layer (AM_11 by default).
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::RemoveAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::RemoveAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::RemoveAttribute Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Removes the specified attribute from this component.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the attribute to be removed.
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::ReplaceDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ReplaceDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::ReplaceDefinition Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Example Send Feedback
Summary

Replaces a specified component with a new definition as in AMSREPLACEDEF.

Visual Basic
Sub ReplaceDefinition(newDef As IMcadComponentDefinition)
Parameters
Parameters | Description
newDef | McadComponentDefinition object; input-only. Specifies the new definition that already exists to perform the replacement.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface, Example


IMcadComponent::SortChildren Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::SortChildren Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::SortChildren Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Sorts the children of this component.

Visual Basic
Sub SortChildren()
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponent::VisibilityOverride Method

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::VisibilityOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent::VisibilityOverride Method
IMcadComponent Interface IMcadComponent Members IMcadComponent Interface Send Feedback
Summary

Sets the visibility override for all the component's views.

Visual Basic
Sub VisibilityOverride(bContoursOnly As VARIANT_BOOL, bHiddenLines As VARIANT_BOOL, bCenterLines As VARIANT_BOOL)
Parameters
Parameters | Description
bContoursOnly | Boolean; input-only. Specifies whether to isolates the contour (continuous) lines in a folder or view, TRUE, or not, FALSE. It can be used in conjunction with Centerline visibility and Color, but is not available in conjunction with Hidden Line visibility. If predefined override is set, then bContoursOnly and bHiddenLines will be ignored.
bHiddenLines | Boolean; input-only. Specifies whether to turns off visibility of hidden lines in a folder or view, TRUE, or not, FALSE. This option is not applicable when the Contours Only visibility is set.
bCenterLines | Boolean; input-only. Specifies whether to turn on the centerline visibility, TRUE, or not, FALSE.
Returns

None

Interface

IMcadComponent Interface

Links
IMcadComponent Interface, IMcadComponent Members, IMcadComponent Interface


IMcadComponentDefinition Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition Interface
IMcadComponentDefinition Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

References the definition of an assembly component.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComponentDefinition
Visual Basic
Public Interface IMcadComponentDefinition
Inherits IMcadObject
Remarks

From this definition, an instance of it can be created in an assembly. A component instance is represented by an McadComponent object. This component is visible as a node in the assembly browser.

In order to have a representation of this visible in model space, one of its associated component view definitions must be instanced. This instantiation is a component view.

A component view instance is represented by an McadComponentView object.

Library

AcadmAuto Library

Links
IMcadComponentDefinition Members, AcadmAuto Library, Class Hierarchy


IMcadComponentDefinition Members

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition Members
IMcadComponentDefinition Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentDefinition.

Interface

IMcadComponentDefinition Interface

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
AddComponent | Adds an instance of the specified component definition to this component definition.
CopyDefinition | Creates a copy of the component definition.
Delete | Deletes the object being referenced.
Externalize | Externalizes the component definition to the specified file name.
GetAttributes | Gets the attributes attached to the object being referenced.
GetInstances | Get all instances of this definition in a given scope.
GetNextComponentViewDefinitionName | Gets the name of the next unique component view definition based on the specified name.
HasComponentViewDefinition | Checks whether a component view definition with the specified name exists in a component definition, TRUE, or not, FALSE.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
Localize2DS | Localizes the component definition into the document.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.
RemoveComponent | Removes the specified component instance from the subassembly component definition.
SortChildren | Sorts the children in this component definition.
Update | Causes an update or a regeneration of any pending changes on the object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the component instances inserted into a subassembly component definition.
ComponentViewDefinitions | Gets the collection of component view definitions contained in this component definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
ExternalPath | Specifies the file name including path for the drawing used by an external component definition.
is2D | Gets whether this component definition is in 2D structure.
is2DAssembly | Gets whether this component definition is associated with 2D assembly.
IsExternal | Gets whether the component definition is to an externally referenced drawing.
isFeature | Gets whether this component definition is associated with a feature.
IsLeafNode | Gets whether the component definition is a leaf node component definition.
IsRoot | Gets whether the component definition is the root component definition.
isShaft | This is isShaft, a member of class IMcadComponentDefinition.
isStandardPart | This is isStandardPart, a member of class IMcadComponentDefinition.
Name | Gets and sets the name of the component definition.
PhantomState | Gets the phantom state of this component definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadComponentDefinition Interface, Legend, Methods, Properties


IMcadComponentDefinition::Children Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::Children Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::Children Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets the component instances inserted into a subassembly component definition.

Visual Basic
Property Children() As IMcadComponents**
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::ComponentViewDefinitions Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::ComponentViewDefinitions Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::ComponentViewDefinitions Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets the collection of component view definitions contained in this component definition.

Visual Basic
Property ComponentViewDefinitions() As IMcadComponentViewDefinitions**
Remarks

This property is a McadComponentViewDefinitions collection.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::ExternalPath Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::ExternalPath Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::ExternalPath Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Specifies the file name including path for the drawing used by an external component definition.

Visual Basic
Property ExternalPath() As BSTR*
Remarks

This property is a String.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::is2D Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::is2D Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::is2D Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether this component definition is in 2D structure.

Visual Basic
Property is2D() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::is2DAssembly Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::is2DAssembly Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::is2DAssembly Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether this component definition is associated with 2D assembly.

Visual Basic
Property is2DAssembly() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::IsExternal Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::IsExternal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::IsExternal Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether the component definition is to an externally referenced drawing.

Visual Basic
Property IsExternal() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::isFeature Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::isFeature Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::isFeature Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether this component definition is associated with a feature.

Visual Basic
Property isFeature() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::IsLeafNode Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::IsLeafNode Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::IsLeafNode Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether the component definition is a leaf node component definition.

Visual Basic
Property IsLeafNode() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::IsRoot Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::IsRoot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::IsRoot Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets whether the component definition is the root component definition.

Visual Basic
Property IsRoot() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::isShaft Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::isShaft Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::isShaft Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

This is isShaft, a member of class IMcadComponentDefinition.

Visual Basic
Property isShaft() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::isStandardPart Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::isStandardPart Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::isStandardPart Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

This is isStandardPart, a member of class IMcadComponentDefinition.

Visual Basic
Property isStandardPart() As VARIANT_BOOL*
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::Name Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::Name Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets and sets the name of the component definition.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::PhantomState Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::PhantomState Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::PhantomState Property
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets the phantom state of this component definition.

Visual Basic
Property PhantomState() As McadPhantomState
Remarks

This property is a McadPhantomState enumeration.

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::AddAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::AddAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::AddAttribute Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the new attribute to add to the component definition.
Associativity | McadAttributeAssociativity enumeration, default value = 0; input-only; optional. Specifies the behavior of the attribute when the object that the attribute is attached to is copied. If not specified, the default associativity behavior is used.
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::AddComponent Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::AddComponent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::AddComponent Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Adds an instance of the specified component definition to this component definition.

Visual Basic
Sub AddComponent(Definition As IMcadComponentDefinition, Position As IGeMatrix, Component As [out, retval] IMcadComponent*)
Parameters
Parameters | Description
Definition | McadComponentDefinition Object; input-only. Specifies the definition to add an instance of.
Position | GeMatrix object; input-only. Input required but not applicable to this product.
Returns

McadComponent object

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::CopyDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::CopyDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::CopyDefinition Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Creates a copy of the component definition.

Visual Basic
Sub CopyDefinition(Name As [in, optional] VARIANT, Definition As [out, retval] IMcadComponentDefinition*)
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::Externalize Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::Externalize Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::Externalize Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Externalizes the component definition to the specified file name.

Visual Basic
Sub Externalize(FileName As String)
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::GetAttributes Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::GetAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::GetAttributes Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = False; input-only; optional. Specifies whether the exact match is used.
Returns

McadAttributes collection

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::GetInstances Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::GetInstances Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::GetInstances Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Get all instances of this definition in a given scope.

Visual Basic
Sub GetInstances(ComponentDefinition As [in, optional] VARIANT, Instances As [out, retval] IMcadComponents*)
Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::GetNextComponentViewDefinitionName Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::GetNextComponentViewDefinitionName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::GetNextComponentViewDefinitionName Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Gets the name of the next unique component view definition based on the specified name.

Visual Basic
Sub GetNextComponentViewDefinitionName(pBaseName As [in, defaultvalue(NULL)] BSTR, pNextName As [out,retval] BSTR)
Parameters
Parameters | Description
pBaseName | String, default value = NULL; input-only; optional. Specifies the base name to get the next component view definition name. If the value is NULL, one of the unused component view names specified in the user options is used as the base name.
Returns

String

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::HasComponentViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::HasComponentViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::HasComponentViewDefinition Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Checks whether a component view definition with the specified name exists in a component definition, TRUE, or not, FALSE.

Visual Basic
Sub HasComponentViewDefinition(pName As String, ByRef pCompViewDef As IMcadComponentViewDefinition*, pHasViewDef As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
pName | String; input-only Specifies the name of the the component view definition to perform the check.
pCompViewDef | McadComponentViewDefinition object; output-only. Returns the component view definition with the specified name if it exists. Otherwise, NULL is returned.
Returns

Boolean

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::Localize2DS Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::Localize2DS Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::Localize2DS Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Localizes the component definition into the document.

Visual Basic
Sub Localize2DS(LocalizeAll As VARIANT_BOOL)
Parameters
Parameters | Description
LocalizeAll | Boolean; input-only. Specifies whether all children are localized, TRUE, or only this component definition is localized, FALSE.
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::RemoveAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::RemoveAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::RemoveAttribute Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Removes the specified attribute from the object being referenced.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)
Parameters
Parameters | Description
Attribute | McadAttribute object; input-only. Specifies the attribute to remove from the object.
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::RemoveComponent Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::RemoveComponent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::RemoveComponent Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Removes the specified component instance from the subassembly component definition.

Visual Basic
Sub RemoveComponent(Component As IMcadComponent)
Parameters
Parameters | Description
Component | McadComponent object; input-only
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::SortChildren Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::SortChildren Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::SortChildren Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Sorts the children in this component definition.

Visual Basic
Sub SortChildren()
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinition::Update Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition::Update Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition::Update Method
IMcadComponentDefinition Interface IMcadComponentDefinition Members IMcadComponentDefinition Interface Send Feedback
Summary

Causes an update or a regeneration of any pending changes on the object.

Visual Basic
Sub Update(Force As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
Force | Boolean, default value = FALSE; input-only; optional. Specifies whether the object is forced to update regardless of whether there are any pending changes.
Returns

None

Interface

IMcadComponentDefinition Interface

Links
IMcadComponentDefinition Interface, IMcadComponentDefinition Members, IMcadComponentDefinition Interface


IMcadComponentDefinitions Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions Interface
IMcadComponentDefinitions Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadcomponentDefinition objects.

Class Hierarchy

Declaration syntax

IMcadComponentDefinitions
Visual Basic
Public Interface IMcadComponentDefinitions
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadComponentDefinitions Members, AcadmAuto Library, Class Hierarchy


IMcadComponentDefinitions Members

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions Members
IMcadComponentDefinitions Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentDefinitions.

Interface

IMcadComponentDefinitions Interface

Methods
Name | Description
Add | Appends a new component definition to the collection.
Item | Gets the component definition at the specified index from the collection.
Remove | Removes the specified component definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component definitions in the collection.
Links
IMcadComponentDefinitions Interface, Legend, Methods, Properties


IMcadComponentDefinitions::Application Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions::Application Property
IMcadComponentDefinitions Interface IMcadComponentDefinitions Members IMcadComponentDefinitions Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadComponentDefinitions Interface

Links
IMcadComponentDefinitions Interface, IMcadComponentDefinitions Members, IMcadComponentDefinitions Interface


IMcadComponentDefinitions::Count Property

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions::Count Property
IMcadComponentDefinitions Interface IMcadComponentDefinitions Members IMcadComponentDefinitions Interface Send Feedback
Summary

Gets the total number of component definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadComponentDefinitions Interface

Links
IMcadComponentDefinitions Interface, IMcadComponentDefinitions Members, IMcadComponentDefinitions Interface


IMcadComponentDefinitions::Add Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions::Add Method
IMcadComponentDefinitions Interface IMcadComponentDefinitions Members IMcadComponentDefinitions Interface Send Feedback
Summary

Appends a new component definition to the collection.

Visual Basic
Sub Add(Definition As IMcadComponentDefinition)
Parameters
Parameters | Description
Definition | McadComponentDefinition object; input-only. Specifies the new component definitions to add to the collection.
Returns

None

Interface

IMcadComponentDefinitions Interface

Links
IMcadComponentDefinitions Interface, IMcadComponentDefinitions Members, IMcadComponentDefinitions Interface


IMcadComponentDefinitions::Item Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions::Item Method
IMcadComponentDefinitions Interface IMcadComponentDefinitions Members IMcadComponentDefinitions Interface Send Feedback
Summary

Gets the component definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadComponentDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component definition to return.
Returns

McadComponentDefinition object

Interface

IMcadComponentDefinitions Interface

Links
IMcadComponentDefinitions Interface, IMcadComponentDefinitions Members, IMcadComponentDefinitions Interface


IMcadComponentDefinitions::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions::Remove Method
IMcadComponentDefinitions Interface IMcadComponentDefinitions Members IMcadComponentDefinitions Interface Send Feedback
Summary

Removes the specified component definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component definition to remove.
Returns

None

Interface

IMcadComponentDefinitions Interface

Links
IMcadComponentDefinitions Interface, IMcadComponentDefinitions Members, IMcadComponentDefinitions Interface


IMcadComponents Interface

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents Interface
IMcadComponents Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponent objects.

Class Hierarchy

Declaration syntax

IMcadComponents
Visual Basic
Public Interface IMcadComponents
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadComponents Members, AcadmAuto Library, Class Hierarchy


IMcadComponents Members

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents Members
IMcadComponents Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponents.

Interface

IMcadComponents Interface

Methods
Name | Description
Add | Appends a new component to the collection.
Item | Gets the component at the specified index from the collection.
Remove | Removes the specified component from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of components in the collection.
Links
IMcadComponents Interface, Legend, Methods, Properties


IMcadComponents::Application Property

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents::Application Property
IMcadComponents Interface IMcadComponents Members IMcadComponents Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadComponents Interface

Links
IMcadComponents Interface, IMcadComponents Members, IMcadComponents Interface


IMcadComponents::Count Property

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents::Count Property
IMcadComponents Interface IMcadComponents Members IMcadComponents Interface Send Feedback
Summary

Gets the total number of components in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadComponents Interface

Links
IMcadComponents Interface, IMcadComponents Members, IMcadComponents Interface


IMcadComponents::Add Method

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents::Add Method
IMcadComponents Interface IMcadComponents Members IMcadComponents Interface Send Feedback
Summary

Appends a new component to the collection.

Visual Basic
Sub Add(Component As IMcadComponent)
Parameters
Parameters | Description
Component | McadComponent object; input-only. Specifies the new components to add to the collection.
Returns

None

Interface

IMcadComponents Interface

Links
IMcadComponents Interface, IMcadComponents Members, IMcadComponents Interface


IMcadComponents::Item Method

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents::Item Method
IMcadComponents Interface IMcadComponents Members IMcadComponents Interface Send Feedback
Summary

Gets the component at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComponent*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component to return.
Returns

McadComponent object

Interface

IMcadComponents Interface

Links
IMcadComponents Interface, IMcadComponents Members, IMcadComponents Interface


IMcadComponents::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents::Remove Method
IMcadComponents Interface IMcadComponents Members IMcadComponents Interface Send Feedback
Summary

Removes the specified component from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component to remove.
Returns

None

Interface

IMcadComponents Interface

Links
IMcadComponents Interface, IMcadComponents Members, IMcadComponents Interface


IMcadComponentView Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView Interface
IMcadComponentView Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView
Visual Basic
Public Interface IMcadComponentView
Inherits IMcadFolder2
Library

AcadmAuto Library

Links
IMcadComponentView Members, AcadmAuto Library, Class Hierarchy


IMcadComponentView Members

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView Members
IMcadComponentView Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentView.

Interface

IMcadComponentView Interface

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsGhostView | Specifies whether a component view is a ghost component view, TRUE, or not, FALSE.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
Component | Gets the component of the component view.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
isFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadComponentView Interface, Legend, Methods, Properties


IMcadComponentView::Component Property

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView::Component Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView::Component Property
IMcadComponentView Interface IMcadComponentView Members IMcadComponentView Interface Send Feedback
Summary

Gets the component of the component view.

Visual Basic
Property Component() As IMcadComponent**
Remarks

This property is a McadComponent object.

Interface

IMcadComponentView Interface

Links
IMcadComponentView Interface, IMcadComponentView Members, IMcadComponentView Interface


IMcadComponentView::isFeature Property

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView::isFeature Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView::isFeature Property
IMcadComponentView Interface IMcadComponentView Members IMcadComponentView Interface Send Feedback
Summary

Gets whether the component view is the view of a feature, TRUE, or not, FALSE.

Visual Basic
Property isFeature() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponentView Interface

Links
IMcadComponentView Interface, IMcadComponentView Members, IMcadComponentView Interface


IMcadComponentView::IsGhostView Method

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView::IsGhostView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView::IsGhostView Method
IMcadComponentView Interface IMcadComponentView Members IMcadComponentView Interface Send Feedback
Summary

Specifies whether a component view is a ghost component view, TRUE, or not, FALSE.

Visual Basic
Sub IsGhostView(bTreatFeatAsNonGhost As [in, defaultvalue(TRUE)] VARIANT_BOOL, pIsGhost As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
bTreatFeatAsNonGhost | Boolean, default value = TRUE; input-only; optional. Specifies whether a feature view should be treated as a non-ghost view.
Returns

Boolean

Remarks

When one or more component views are restructured, remained component views are held temporarily on a ghost until they are too restructured.

Interface

IMcadComponentView Interface

Links
IMcadComponentView Interface, IMcadComponentView Members, IMcadComponentView Interface


IMcadComponentViewDefinition Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition Interface
IMcadComponentViewDefinition Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

References the definition of a component view.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadComponentViewDefinition
Visual Basic
Public Interface IMcadComponentViewDefinition
Inherits IMcadFolderDefinition
Remarks

Each component view definition has an associated component definition. The component view definition defines a particular view of a component definition. From this component view definition, an instance of it can be created in an assembly. The definition itself is not visible in the model; only instances of it are visible.

It is important to note that a component view definition can exist without any component view instances referencing it in the assembly. The relationship between McadComponentViewDefinition and McadComponentView objects is similar to that of the AutoCAD Block and BlockRef objects.

Library

AcadmAuto Library

Links
IMcadComponentViewDefinition Members, AcadmAuto Library, Class Hierarchy


IMcadComponentViewDefinition Members

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition Members
IMcadComponentViewDefinition Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentViewDefinition.

Interface

IMcadComponentViewDefinition Interface

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Adds a component view to a specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified component view from this component view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
Owner | Gets the owner of this component definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadComponentViewDefinition Interface, Legend, Methods, Properties


IMcadComponentViewDefinition::IsFeature Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition::IsFeature Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition::IsFeature Property
IMcadComponentViewDefinition Interface IMcadComponentViewDefinition Members IMcadComponentViewDefinition Interface Send Feedback
Summary

Gets whether the component view is the view of a feature, TRUE, or not, FALSE.

Visual Basic
Property IsFeature() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadComponentViewDefinition Interface

Links
IMcadComponentViewDefinition Interface, IMcadComponentViewDefinition Members, IMcadComponentViewDefinition Interface


IMcadComponentViewDefinition::Owner Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition::Owner Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition::Owner Property
IMcadComponentViewDefinition Interface IMcadComponentViewDefinition Members IMcadComponentViewDefinition Interface Send Feedback
Summary

Gets the owner of this component definition.

Visual Basic
Property Owner() As IMcadComponentDefinition**
Remarks

This property is a McadComponentDefinition object.

Interface

IMcadComponentViewDefinition Interface

Links
IMcadComponentViewDefinition Interface, IMcadComponentViewDefinition Members, IMcadComponentViewDefinition Interface


IMcadComponentViewDefinition::AddComponentView Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition::AddComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition::AddComponentView Method
IMcadComponentViewDefinition Interface IMcadComponentViewDefinition Members IMcadComponentViewDefinition Interface Send Feedback
Summary

Adds a component view to a specified component view definition.

Visual Basic
Sub AddComponentView(pDefToInst As IMcadComponentViewDefinition, pCompInst As IMcadComponent, pMat As IGeMatrix, pVal As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
pDefToInst | McadComponentViewDefinition object; input-only. Specifies the component view definition to add the component view to.
pCompInst | McadComponent object; input-only. Specifies the new component view to add.
pMat | GeMatrix object; input-only. Specifies the position for the new component view.
Returns

McadComponentView object

Remarks

GeMatrix object is a 4x4 matrix representing an affine transformation including translation in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcadComponentViewDefinition Interface

Links
IMcadComponentViewDefinition Interface, IMcadComponentViewDefinition Members, IMcadComponentViewDefinition Interface


IMcadComponentViewDefinition::RemoveComponentView Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition::RemoveComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition::RemoveComponentView Method
IMcadComponentViewDefinition Interface IMcadComponentViewDefinition Members IMcadComponentViewDefinition Interface Send Feedback
Summary

Removes the specified component view from this component view definition.

Visual Basic
Sub RemoveComponentView(pCompView As IMcadComponentView)
Parameters
Parameters | Description
pCompView | McadComponentView object; input-only. Specifies the component view to remove from this definition.
Returns

None

Interface

IMcadComponentViewDefinition Interface

Links
IMcadComponentViewDefinition Interface, IMcadComponentViewDefinition Members, IMcadComponentViewDefinition Interface


IMcadComponentViewDefinitions Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions Interface
IMcadComponentViewDefinitions Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentViewDefinition objects.

Class Hierarchy

Declaration syntax

IMcadComponentViewDefinitions
Visual Basic
Public Interface IMcadComponentViewDefinitions
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadComponentViewDefinitions Members, AcadmAuto Library, Class Hierarchy


IMcadComponentViewDefinitions Members

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions Members
IMcadComponentViewDefinitions Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentViewDefinitions.

Interface

IMcadComponentViewDefinitions Interface

Methods
Name | Description
Add | Appends a new component view definition to the collection.
Item | Gets the component view definition at the specified index from the collection.
Remove | Removes the specified component view definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component view definitions in the collection.
Links
IMcadComponentViewDefinitions Interface, Legend, Methods, Properties


IMcadComponentViewDefinitions::Application Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions::Application Property
IMcadComponentViewDefinitions Interface IMcadComponentViewDefinitions Members IMcadComponentViewDefinitions Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadComponentViewDefinitions Interface

Links
IMcadComponentViewDefinitions Interface, IMcadComponentViewDefinitions Members, IMcadComponentViewDefinitions Interface


IMcadComponentViewDefinitions::Count Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions::Count Property
IMcadComponentViewDefinitions Interface IMcadComponentViewDefinitions Members IMcadComponentViewDefinitions Interface Send Feedback
Summary

Gets the total number of component view definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadComponentViewDefinitions Interface

Links
IMcadComponentViewDefinitions Interface, IMcadComponentViewDefinitions Members, IMcadComponentViewDefinitions Interface


IMcadComponentViewDefinitions::Add Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions::Add Method
IMcadComponentViewDefinitions Interface IMcadComponentViewDefinitions Members IMcadComponentViewDefinitions Interface Send Feedback
Summary

Appends a new component view definition to the collection.

Visual Basic
Sub Add(Definition As IMcadComponentViewDefinition)
Parameters
Parameters | Description
Definition | McadComponentViewDefinition object; input-only. Specifies the new component view definitions to add to the collection.
Returns

None

Interface

IMcadComponentViewDefinitions Interface

Links
IMcadComponentViewDefinitions Interface, IMcadComponentViewDefinitions Members, IMcadComponentViewDefinitions Interface


IMcadComponentViewDefinitions::Item Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions::Item Method
IMcadComponentViewDefinitions Interface IMcadComponentViewDefinitions Members IMcadComponentViewDefinitions Interface Send Feedback
Summary

Gets the component view definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadComponentViewDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view definition to return.
Returns

McadComponentViewDefinition object

Interface

IMcadComponentViewDefinitions Interface

Links
IMcadComponentViewDefinitions Interface, IMcadComponentViewDefinitions Members, IMcadComponentViewDefinitions Interface


IMcadComponentViewDefinitions::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions::Remove Method
IMcadComponentViewDefinitions Interface IMcadComponentViewDefinitions Members IMcadComponentViewDefinitions Interface Send Feedback
Summary

Removes the specified component view definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view definition to remove.
Returns

None

Interface

IMcadComponentViewDefinitions Interface

Links
IMcadComponentViewDefinitions Interface, IMcadComponentViewDefinitions Members, IMcadComponentViewDefinitions Interface


IMcadComponentViewDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor Interface
IMcadComponentViewDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a 2D component view.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor
Visual Basic
Public Interface IMcadComponentViewDescriptor
Inherits IMcadFolderDescriptor
Library

AcadmAuto Library

Links
IMcadComponentViewDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcadComponentViewDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor Members
IMcadComponentViewDescriptor Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentViewDescriptor.

Interface

IMcadComponentViewDescriptor Interface

Methods
Name | Description
CreateComponentView | Creates a new component view from this descriptor.
CreateFolder | Creates a new folder from the folder descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets and sets the component for the component view descriptor.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
FullViewName | Gets the full component name for this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.
Links
IMcadComponentViewDescriptor Interface, Legend, Methods, Properties


IMcadComponentViewDescriptor::Component Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor::Component Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor::Component Property
IMcadComponentViewDescriptor Interface IMcadComponentViewDescriptor Members IMcadComponentViewDescriptor Interface Send Feedback
Summary

Gets and sets the component for the component view descriptor.

Visual Basic
Property Component() As VARIANT
Remarks

This property is a Variant ( McadComponent object).

Interface

IMcadComponentViewDescriptor Interface

Links
IMcadComponentViewDescriptor Interface, IMcadComponentViewDescriptor Members, IMcadComponentViewDescriptor Interface


IMcadComponentViewDescriptor::FullViewName Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor::FullViewName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor::FullViewName Property
IMcadComponentViewDescriptor Interface IMcadComponentViewDescriptor Members IMcadComponentViewDescriptor Interface Send Feedback
Summary

Gets the full component name for this descriptor.

Visual Basic
Property FullViewName() As BSTR*
Remarks

This property is a String.

Interface

IMcadComponentViewDescriptor Interface

Links
IMcadComponentViewDescriptor Interface, IMcadComponentViewDescriptor Members, IMcadComponentViewDescriptor Interface


IMcadComponentViewDescriptor::CreateComponentView Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor::CreateComponentView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor::CreateComponentView Method
IMcadComponentViewDescriptor Interface IMcadComponentViewDescriptor Members IMcadComponentViewDescriptor Interface Send Feedback
Summary

Creates a new component view from this descriptor.

Visual Basic
Sub CreateComponentView()
Returns

None

Interface

IMcadComponentViewDescriptor Interface

Links
IMcadComponentViewDescriptor Interface, IMcadComponentViewDescriptor Members, IMcadComponentViewDescriptor Interface


IMcadComponentViews Interface

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews Interface
IMcadComponentViews Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadComponentView objects.

Class Hierarchy

Declaration syntax

IMcadComponentViews
Visual Basic
Public Interface IMcadComponentViews
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadComponentViews Members, AcadmAuto Library, Class Hierarchy


IMcadComponentViews Members

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews Members
IMcadComponentViews Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadComponentViews.

Interface

IMcadComponentViews Interface

Methods
Name | Description
Add | Appends a new component view to the collection.
Item | Gets the component view at the specified index from the collection.
Remove | Removes the specified component view from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component views in the collection.
Links
IMcadComponentViews Interface, Legend, Methods, Properties


IMcadComponentViews::Application Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews::Application Property
IMcadComponentViews Interface IMcadComponentViews Members IMcadComponentViews Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadComponentViews Interface

Links
IMcadComponentViews Interface, IMcadComponentViews Members, IMcadComponentViews Interface


IMcadComponentViews::Count Property

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews::Count Property
IMcadComponentViews Interface IMcadComponentViews Members IMcadComponentViews Interface Send Feedback
Summary

Gets the total number of component views in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadComponentViews Interface

Links
IMcadComponentViews Interface, IMcadComponentViews Members, IMcadComponentViews Interface


IMcadComponentViews::Add Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews::Add Method
IMcadComponentViews Interface IMcadComponentViews Members IMcadComponentViews Interface Send Feedback
Summary

Appends a new component view to the collection.

Visual Basic
Sub Add(Component As IMcadComponentView)
Parameters
Parameters | Description
Component | McadComponentView object; input-only. Specifies the new components to add to the collection.
Returns

None

Interface

IMcadComponentViews Interface

Links
IMcadComponentViews Interface, IMcadComponentViews Members, IMcadComponentViews Interface


IMcadComponentViews::Item Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews::Item Method
IMcadComponentViews Interface IMcadComponentViews Members IMcadComponentViews Interface Send Feedback
Summary

Gets the component view at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadComponentView*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view to return.
Returns

McadComponentView object

Interface

IMcadComponentViews Interface

Links
IMcadComponentViews Interface, IMcadComponentViews Members, IMcadComponentViews Interface


IMcadComponentViews::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews::Remove Method
IMcadComponentViews Interface IMcadComponentViews Members IMcadComponentViews Interface Send Feedback
Summary

Removes the specified component view from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the component view to remove.
Returns

None

Interface

IMcadComponentViews Interface

Links
IMcadComponentViews Interface, IMcadComponentViews Members, IMcadComponentViews Interface


IMcadCurve Interface

You are here: API Reference > AcadmAuto Library > IMcadCurve Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadCurve Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A generic curve entity.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc
            IMcadAugmentedLine
            IMcadEllipse
            IMcadLine
            IMcadPolyline
            IMcadSpline
Visual Basic
Public Interface IMcadCurve
Inherits IMcadGeometry
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDescriptor Interface
IMcadDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A generic descriptor object that contains the overall description of an object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
Visual Basic
Public Interface IMcadDescriptor
Inherits IDispatch
Remarks

A descriptor is used as a convenience to handle a variable, and potentially large and interdependent set of specific properties and information that make up the description of an object. A descriptor can be obtained from an object to query information, or used in the creation of new objects conforming to the description.

Library

AcadmAuto Library

Links
IMcadDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcadDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDescriptor Members
IMcadDescriptor Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDescriptor.

Interface

IMcadDescriptor Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Links
IMcadDescriptor Interface, Legend, Properties


IMcadDescriptor::Application Property

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDescriptor::Application Property
IMcadDescriptor Interface IMcadDescriptor Members IMcadDescriptor Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks
  • This property is a cadmApplication object.
  • AcadmApplication object is an instance of the AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadDescriptor Interface

Links
IMcadDescriptor Interface, IMcadDescriptor Members, IMcadDescriptor Interface


IMcadDescriptor::Document Property

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDescriptor::Document Property
IMcadDescriptor Interface IMcadDescriptor Members IMcadDescriptor Interface Send Feedback
Summary

Gets the document containing this object.

Visual Basic
Property Document() As IMcadDocument**
Interface

IMcadDescriptor Interface

Links
IMcadDescriptor Interface, IMcadDescriptor Members, IMcadDescriptor Interface


IMcadDocuments Interface

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments Interface
IMcadDocuments Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

The collection of McadDocument objects present in the application.

Class Hierarchy

Declaration syntax

IMcadDocuments
Visual Basic
Public Interface IMcadDocuments
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadDocuments Members, AcadmAuto Library, Class Hierarchy


IMcadDocuments Members

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments Members
IMcadDocuments Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDocuments.

Interface

IMcadDocuments Interface

Methods
Name | Description
Item | Gets the document at the specified index from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of documents in the collection.
Links
IMcadDocuments Interface, Legend, Methods, Properties


IMcadDocuments::Application Property

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments::Application Property
IMcadDocuments Interface IMcadDocuments Members IMcadDocuments Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadDocuments Interface

Links
IMcadDocuments Interface, IMcadDocuments Members, IMcadDocuments Interface


IMcadDocuments::Count Property

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments::Count Property
IMcadDocuments Interface IMcadDocuments Members IMcadDocuments Interface Send Feedback
Summary

Gets the total number of documents in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadDocuments Interface

Links
IMcadDocuments Interface, IMcadDocuments Members, IMcadDocuments Interface


IMcadDocuments::Item Method

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments::Item Method
IMcadDocuments Interface IMcadDocuments Members IMcadDocuments Interface Send Feedback
Summary

Gets the document at the specified index from the collection.

Visual Basic
Sub Item(Index As VARIANT, Document As [out, retval] IMcadDocument*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the document to return.
Returns

McadDocument object

Interface

IMcadDocuments Interface

Links
IMcadDocuments Interface, IMcadDocuments Members, IMcadDocuments Interface


IMcadDocumentVersion Interface

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocumentVersion Interface
IMcadDocumentVersion Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Version of AutoCAD Mechanical that saved the file.

Class Hierarchy

Declaration syntax

IMcadDocumentVersion
Visual Basic
Public Interface IMcadDocumentVersion
Inherits IUnknown
Library

AcadmAuto Library

Links
IMcadDocumentVersion Members, AcadmAuto Library, Class Hierarchy


IMcadDocumentVersion Members

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface > IMcadDocumentVersion Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocumentVersion Members
IMcadDocumentVersion Interface Legend Methods Send Feedback
Summary

The following tables list the members exposed by IMcadDocumentVersion.

Interface

IMcadDocumentVersion Interface

Methods
Name | Description
GetVersionNumber | Version of AutoCAD Mechanical that saved the file.
Links
IMcadDocumentVersion Interface, Legend, Methods


IMcadDocumentVersion::GetVersionNumber Method

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface > IMcadDocumentVersion::GetVersionNumber Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocumentVersion::GetVersionNumber Method
IMcadDocumentVersion Interface IMcadDocumentVersion Members IMcadDocumentVersion Interface Send Feedback
Summary

Version of AutoCAD Mechanical that saved the file.

Visual Basic
Sub GetVersionNumber(ByRef Major As long, ByRef Minor As long, ByRef Patch As long)
Parameters
Parameters | Description
Major | Long. Major revision number.
Minor | Long. Minor revision number.
Patch | Long. Patch number.
Interface

IMcadDocumentVersion Interface

Links
IMcadDocumentVersion Interface, IMcadDocumentVersion Members, IMcadDocumentVersion Interface


IMcadEllipse Interface

You are here: API Reference > AcadmAuto Library > IMcadEllipse Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEllipse Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An ellipse or elliptical arc object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadEllipse
Visual Basic
Public Interface IMcadEllipse
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadFolder Interface

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder Interface
IMcadFolder Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
Visual Basic
Public Interface IMcadFolder
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadFolder Members, AcadmAuto Library, Class Hierarchy


IMcadFolder Members

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder Members
IMcadFolder Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolder.

Interface

IMcadFolder Interface

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadFolder Interface, Legend, Methods, Properties


IMcadFolder::BasePoint Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::BasePoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::BasePoint Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

This is BasePoint, a member of class IMcadFolder.

Visual Basic
Property BasePoint() As IGePoint*
Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Children Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Children Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Children Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the occurrence of the children views of the folder.

Visual Basic
Property Children() As IMcadFolders**
Remarks

This property is a McadFolders collection.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ContextDefinition Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ContextDefinition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ContextDefinition Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.

Visual Basic
Property ContextDefinition() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Definition Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Definition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Definition Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the definition of the folder.

Visual Basic
Property Definition() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Entities Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Entities Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Entities Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the entities of the folder in model space.

Visual Basic
Property Entities() As VARIANT*
Remarks

This property is a Variant (array of Longs).

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Entities32 Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Entities32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Entities32 Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the entities of the folder in model space.

Visual Basic
Property Entities32() As VARIANT*
Remarks

This property is a Variant (array of Longs).

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ExtentsMaximum Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ExtentsMaximum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ExtentsMaximum Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the upper right point of the extents for the folder or component view

Visual Basic
Property ExtentsMaximum() As IGePoint**
Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ExtentsMinimum Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ExtentsMinimum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ExtentsMinimum Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the lower left point of the extents for the folder or component view.

Visual Basic
Property ExtentsMinimum() As IGePoint**
Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::GeomPathName Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::GeomPathName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::GeomPathName Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the occurrence path of the folder.

Visual Basic
Property GeomPathName() As BSTR*
Remarks

This property is a String.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::HasExternalDef Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::HasExternalDef Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::HasExternalDef Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Checks whether this folder has an external folder definition, TRUE, or not, FALSE.

Visual Basic
Property HasExternalDef() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::HasOverrideProperties Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::HasOverrideProperties Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::HasOverrideProperties Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.

Visual Basic
Property HasOverrideProperties() As VARIANT_BOOL *
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::IsInstance Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::IsInstance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::IsInstance Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Checks whether it is the path to the folder instance, TRUE, or not, FALSE.

Visual Basic
Property IsInstance() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::IsLeaf Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::IsLeaf Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::IsLeaf Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.

Visual Basic
Property IsLeaf() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::IsLocked Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::IsLocked Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::IsLocked Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.

Visual Basic
Property IsLocked() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Owner Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Owner Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Owner Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the definition of the owner for the folder.

Visual Basic
Property Owner() As IMcadFolderDefinition**
Remarks

This property is a McadFolderDefinition object.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::Position Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Position Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets or sets the position of the folder or component view in model space.

Visual Basic
Property Position() As IGeMatrix*
Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ViewName Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ViewName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ViewName Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets the name of the folder.

Visual Basic
Property ViewName() As String
Remarks
  • This property is a String.
  • Setting the folder name has not been implemented.
Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ViewScale Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ViewScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ViewScale Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Example Send Feedback
Summary

Sets the view scale of the view.

Visual Basic
Property ViewScale() As double
Remarks

This property is a Double.

Example

Refer to SDK Samples: RestructureView.dvb

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface, Example


IMcadFolder::Visible Property

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Visible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Visible Property
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Gets or sets the visibility of the folder.

Visual Basic
Property Visible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::AddEntities Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::AddEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::AddEntities Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.

Visual Basic
Sub AddEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the object IDs of the entities to add.
Returns

None

Remarks

The added entities can be removed using the RemoveEntities method.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ClearLeaf Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ClearLeaf Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ClearLeaf Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Modifies this path from Leaf path to Instance path.

Visual Basic
Sub ClearLeaf()
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ClearOverrideProperties Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ClearOverrideProperties Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ClearOverrideProperties Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Clears all property overrides for the folder or component view if any exists.

Visual Basic
Sub ClearOverrideProperties()
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ColorOverride Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ColorOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ColorOverride Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Sets the color override for the folder or component view.

Visual Basic
Sub ColorOverride(bColor As VARIANT_BOOL, bContoursColorOnly As VARIANT_BOOL, trueColor As [in,defaultvalue(NULL)] IAcadAcCmColor)
Parameters
Parameters | Description
bColor | Boolean; input-only. Specifies whether the color is set, TRUE, or not, FALSE.
bContoursColorOnly | Boolean; input-only. Specifies whether this method only sets the color for contours, TRUE, or not, FALSE.
trueColor | AcadAcCmColor object, default value =NULL; input-only; optional. Points to the color to set to. By default, it is NULL which results in the color value to be unchanged.
Returns

None

Remarks

Since color overrides applies only when predefined reference is FALSE, this method will fail if the predefined reference has already been set.

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::CopyEntities Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::CopyEntities Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Example Send Feedback
Summary

Copies the entities to this folder or component view as in Content - Copy.

Visual Basic
Sub CopyEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (Array of Longs); input-only. Specifies the array of AcDbObjectIds of entities to copy.
Returns

None

Example

Refer to SDK Samples: RestructureView.dvb

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface, Example


IMcadFolder::CopyView Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyView Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::CopyView Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Example Send Feedback
Summary

Copies the specified view to this view as in Content - Copy

Visual Basic
Sub CopyView(pFolderToCopy As IMcadFolder)
Parameters
Parameters | Description
pFolderToCopy | McadFolder object; input-only. Specifies the folder to copy.
Returns

None

Example

Refer to SDK Samples: RestructureView.dvb

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface, Example


IMcadFolder::CopyViewDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyViewDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::CopyViewDefinition Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Example Send Feedback
Summary

Creates a copy of the definition for the specified folder or component view as in Break Link.

Visual Basic
Sub CopyViewDefinition(newDefName As String)
Parameters
Parameters | Description
newDefName | String; input-only. Specifies the new unique definition name.
Returns

None

Example

Refer to SDK Samples: XrefStructure.dvb

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface, Example


IMcadFolder::Explode Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::Explode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::Explode Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Explode the specified folder or component view to the model space.

Visual Basic
Sub Explode()
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::IsSubentityOf Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::IsSubentityOf Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::IsSubentityOf Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Checks whether this is subentity of the specified pOther view.

Visual Basic
Sub IsSubentityOf(pOther As IMcadFolder, IsEqual As [in, defaultvalue(FALSE)] VARIANT_BOOL, pVal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pOther | McadFolder object; input-only. Specifies the view to check the subentity relationship.
IsEqual | Boolean, default value = False; input-only; optional. Specifies if this and pOther paths are equal. If TRUE, this method returns True.
Returns

Boolean

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::PredefinedReferenceOverride Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::PredefinedReferenceOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::PredefinedReferenceOverride Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Sets the predefined reference override for the folder or component view.

Visual Basic
Sub PredefinedReferenceOverride(bPredefinedRef As VARIANT_BOOL)
Parameters
Parameters | Description
bPredefinedRef | Boolean; input-only. Specifies whether to set predefined reference override property, TRUE, or not, FALSE. Visibility of everything except contours is turned off. Contour lines are changed to the configured linetype and color of the phantom line layer (AM_11 by default).
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::RemoveEntities Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::RemoveEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::RemoveEntities Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.

Visual Basic
Sub RemoveEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the object IDs of the entities to be removed.
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::ReplaceDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ReplaceDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::ReplaceDefinition Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Replace the definitions of a folder with another definition as in AMSREPLACEDEF.

Visual Basic
Sub ReplaceDefinition(newDef As IMcadFolderDefinition)
Parameters
Parameters | Description
newDef | McadFolderDefinition object; input only. Specifies the new definition to perform the replacement.
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder::VisibilityOverride Method

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::VisibilityOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder::VisibilityOverride Method
IMcadFolder Interface IMcadFolder Members IMcadFolder Interface Send Feedback
Summary

Sets the visibility override for the folder or component view.

Visual Basic
Sub VisibilityOverride(bContoursOnly As VARIANT_BOOL, bHiddenLines As VARIANT_BOOL, bCenterLines As VARIANT_BOOL)
Parameters
Parameters | Description
bContoursOnly | Boolean; input-only. Specifies whether to isolates the contour (continuous) lines in a folder or view, TRUE, or not, FALSE. It can be used in conjunction with Centerline visibility and Color, but is not available in conjunction with Hidden Line visibility. If predefined override is set, then bContoursOnly and bHiddenLines will be ignored.
bHiddenLines | Boolean; input-only. Specifies whether to turns off visibility of hidden lines in a folder or view, TRUE, or not, FALSE. This option is not applicable when the Contours Only visibility is set.
bCenterLines | Boolean; input-only. Specifies whether to turn on the centerline visibility, TRUE, or not, FALSE.
Returns

None

Interface

IMcadFolder Interface

Links
IMcadFolder Interface, IMcadFolder Members, IMcadFolder Interface


IMcadFolder2 Interface

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder2 Interface
IMcadFolder2 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

References an instance of a folder definition.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView
Visual Basic
Public Interface IMcadFolder2
Inherits IMcadFolder
Library

AcadmAuto Library

Links
IMcadFolder2 Members, AcadmAuto Library, Class Hierarchy


IMcadFolder2 Members

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder2 Members
IMcadFolder2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolder2.

Interface

IMcadFolder2 Interface

Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadFolder2 Interface, Legend, Methods, Properties


IMcadFolder2::OwningSpace Property

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2::OwningSpace Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder2::OwningSpace Property
IMcadFolder2 Interface IMcadFolder2 Members IMcadFolder2 Interface Send Feedback
Summary

Returns owning space of view, model space or layout block table record

Visual Basic
Property OwningSpace() As IAcadBlock**
Interface

IMcadFolder2 Interface

Links
IMcadFolder2 Interface, IMcadFolder2 Members, IMcadFolder2 Interface


IMcadFolderDefinition Interface

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition Interface
IMcadFolderDefinition Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
        IMcadComponentViewDefinition
Visual Basic
Public Interface IMcadFolderDefinition
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadFolderDefinition Members, AcadmAuto Library, Class Hierarchy


IMcadFolderDefinition Members

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition Members
IMcadFolderDefinition Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolderDefinition.

Interface

IMcadFolderDefinition Interface

Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadFolderDefinition Interface, Legend, Methods, Properties


IMcadFolderDefinition::ChildrenCount Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::ChildrenCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::ChildrenCount Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the total number of the children for the folder.

Visual Basic
Property ChildrenCount() As int *
Remarks

This property is a Integer.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::ComplexHideSituations Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::ComplexHideSituations Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::ComplexHideSituations Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Returns all complex hide situations from this folder definition.

Visual Basic
Property ComplexHideSituations() As IMcadComplexHideSituations* *
Remarks

This property is a McadComplexHideSituations collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::FullName Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::FullName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::FullName Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the full name of this folder definition.

Visual Basic
Property FullName() As BSTR*
Remarks

  • This property is a String.
  • This method returns the same string as Name method in case of folder definition.
Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::HideSituations Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::HideSituations Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::HideSituations Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Returns all hide situations from this folder definition.

Visual Basic
Property HideSituations() As IMcadHideSituations* *
Remarks

This property is a McadHideSituations collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::InstanceCount Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::InstanceCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::InstanceCount Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the total number of the folder instances.

Visual Basic
Property InstanceCount() As int *
Remarks

This property is a Integer.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::IsAnnotation Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::IsAnnotation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::IsAnnotation Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets whether this is an annotation view definition, TRUE, or not, FALSE.

Visual Basic
Property IsAnnotation() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::IsDetail Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::IsDetail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::IsDetail Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets whether this is a detail view definition, TRUE, or not, FALSE.

Visual Basic
Property IsDetail() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::IsLocked Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::IsLocked Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::IsLocked Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.

Visual Basic
Property IsLocked() As VARIANT_BOOL
Remarks

No modifications to the folder definition are allowed when it is in the locked state.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::IsRoot Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::IsRoot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::IsRoot Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Checks whether this folder definition is root view definition, TRUE, or not, FALSE.

Visual Basic
Property IsRoot() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::LockType Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::LockType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::LockType Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the lock type of this folder definition.

Visual Basic
Property LockType() As long*
Remarks

This method returns the bits combination of values from the McadViewDefLockName enumeration.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::Name Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Name Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets or sets the name of this folder definition.

Visual Basic
Property Name() As String
Remarks
  • This property is a String.
  • This property returns the same string as FullName method in case of the folder definition.
Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::ViewType Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::ViewType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::ViewType Property
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets or sets the view type of this folder definition.

Visual Basic
Property ViewType() As Mcad2DSViewType
Remarks

This property is a Mcad2DSViewType enumeration.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::AddComplexHideSituation Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddComplexHideSituation Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::AddComplexHideSituation Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Creates a new complex hide situation with the specified name in this folder definition.

Visual Basic
Sub AddComplexHideSituation(Name As String, pHides As IMcadHideSituations, ByRef HideSituation As IMcadComplexHideSituation*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the new complex hide situation.
pHides | McadHideSituations collection; input-only. Specifies the pointer to collection of Simple hide object keys in a size of 2.
HideSituation | McadComplexHideSituation object; output-only. Returns pointer to the new complex hide situation object.
Returns

None

Remarks

You must set the collection of simple hide object keys with a size of 2. The complex hide can be created only if it merges 3 and up simple hide situation. Otherwise complex hide will be erased.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::AddFolder Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddFolder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::AddFolder Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.

Visual Basic
Sub AddFolder(pDefToInst As IMcadFolderDefinition, pMat As IGeMatrix, pVal As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
pDefToInst | McadFolderDefinition object; input-only. Specifies the folder definition to add.
pMat | GeMatrix object; input-only. Specifies the position for the folder or folder.
Returns

McadFolder object

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::AddFromExistingEntities Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddFromExistingEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::AddFromExistingEntities Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Add entities in an existing database to this folder definition.

Visual Basic
Sub AddFromExistingEntities(entityIds As VARIANT)
Parameters
Parameters | Description
entityIds | Variant (array of Longs); input-only. Specifies the IDs of the entities to add to this folder definition.
Returns

None

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::AddHideSituation Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddHideSituation Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::AddHideSituation Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.

Visual Basic
Sub AddHideSituation(Name As String, ByRef HideSituation As IMcadHideSituation*, foregroundEntityIds As VARIANT, backgroundEntityIds As VARIANT, pFgEnts As [in , defaultvalue(NULL)] IMcadFolders, pBgEnts As [in , defaultvalue(NULL)] IMcadFolders)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the new hide situation.
HideSituation | McadHideSituation object; output-only. Returns pointer to the new hide situation object.
foregroundEntityIds | VARIANT (array of 4 byte signed integers); input-only. Specifies the array of Object IDs for foreground free Model Space entities for hide situation. This parameter must be set. Otherwise hide will be erased.
backgroundEntityIds | VARIANT (array of 4 byte signed integers); input-only. Specifies the array of Object IDs for background free Model Space entities for hide situation.
pFgEnts | McadFolders collection, default value = NULL; input-only. Specifies the pointer to collection of foreground folder object keys.
pBgEnts | McadFolders collection, default value = NULL; input-only. Specifies the pointer to collection of background folder object keys.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::Children Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Children Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Children Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the children of the folder definition.

Visual Basic
Sub Children(ByRef ParentView As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
ParentView | Variant; input-only. To get views expressed in context of the master view definition, specify the instance of this folder definition in ParentView parameter.
Remarks

This property is a McadFolders collection. Returned views are expressed by default as local to this folder definition.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::Extents Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Extents Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Extents Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.

Visual Basic
Sub Extents(ByRef lowerLeft As IGePoint*, ByRef upperRight As IGePoint*)
Parameters
Parameters | Description
lowerLeft | GePoint object; output-only. Specifies the lower left point of the extents for the folder.
upperRight | GePoint object; output-only. Specifies the upper right point of the extents for the folder.
Remarks

GePoint object defines a three dimensional object in the AutoCAD Mechanical ActiveX Automation GeAuto Type Library.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::Externalize Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Externalize Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Externalize Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Externalizes the folder definition.

Visual Basic
Sub Externalize(FileName As String, ByRef TemplateName As VARIANT)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the name of the new file in which the folder definition is to be stored.
TemplateName | Variant; input-only; optional. Specifies the template used to create new file.
Returns

None

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::FindHideSituations Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::FindHideSituations Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::FindHideSituations Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.

Visual Basic
Sub FindHideSituations(pSubent As IMcadFolder, ByRef referringHides As IMcadHideSituations*, ByRef referredToAs As VARIANT, refType As [in , defaultvalue(mc2DSAllRef)] McadHideSituationRefType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity/view which references the searched hide situations.
referringHides | McadHideSituations collection; output-only. Returns pointer to collection of hide objects found with given reference type.
referredToAs | Variant (array of 4 byte signed integers); output-only. Returns pointer to the array of reference type (flag) for each hide from previous hide collection. This flag indicates whether the HideSituation refers to entity/view as a background (BG), foreground (FG), BG exclude or FG exclude.
refType | McadHideSituationRefType enumeration, default=value = mc2DSAllRef; input-only; optional. Specifies the combination of reference types towards the given Entity/view.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::GetHidesSuppressState Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::GetHidesSuppressState Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::GetHidesSuppressState Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.

Visual Basic
Sub GetHidesSuppressState(bSuppressed As VARIANT_BOOL, ByRef bState As VARIANT_BOOL, ByRef bHasHides As VARIANT_BOOL)
Parameters
Parameters
Description
bSuppressed
Boolean; input-only. Specifies whether to check either suppressed or unsuppressed hide situations.

  • TRUE: Checks the suppressed hide situations. The bState output parameter is TRUE if the view definition or its child views have at least one suppressed hide situation.
  • FALSE: Checks the unsuppressed hide situations. The bState output parameter is FALSE if the view definition or its child views have at least one unsuppressed hide situation.

bState
Boolean; output-only. Returns whether the view definition or its child views have at least one suppressed or unsuppressed hide situation.
bHasHides
Boolean; output-only. Returns whether if the view definition or its child views have hide situations, TRUE, or not, FALSE.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::Instances Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Instances Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Instances Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the instances of the folder definition.

Visual Basic
Sub Instances(ByRef database As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database in which to get the instances of the folder definition; if not specified, the host database of the document is used.
Remarks

This property is a McadFolders collection.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::InstancesDefinition Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::InstancesDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::InstancesDefinition Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Checks whether this folder or component view definition has an instance of the specified folder or component view definition.

Visual Basic
Sub InstancesDefinition(pFolderDef As IMcadFolderDefinition, bInstances As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
pFolderDef | McadFolderDefinition object; input-only. Specifies the parent folder definition to check the descendent relationship.
Remarks

If this method returns TRUE, then this folder definition is a descendent of pFolderDef and cannot be instanced into pFolderDef.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::IsExternal Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::IsExternal Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::IsExternal Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Checks whether folder definition is external to the given database, TRUE, or not, FALSE.

Visual Basic
Sub IsExternal(ByRef relativeDatabase As VARIANT, External As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
relativeDatabase | AcadDatabase database; input-only; optional. Specifies the AcadDatabase to check. The host database is used by default.
Remarks

This property is a Boolean.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::Localize Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Localize Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Localize Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Localizes the specified folder definition or all children.

Visual Basic
Sub Localize(LocalizeAll As VARIANT_BOOL)
Parameters
Parameters | Description
LocalizeAll | Boolean; input-only. Specifies whether all children are localized, TRUE, or only this folder definition is localized, FALSE.
Returns

None

Remarks

This method is applicable only to McadFolderDefinition and not to McadComponentViewDefinition . It is necessary to localize the component definition and this operation will localize all its view definitions.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::LookupViewName Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::LookupViewName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::LookupViewName Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Look up for the view with the specified name.

Visual Basic
Sub LookupViewName(viewName As String, ByRef pFound As VARIANT_BOOL, ByRef database As VARIANT)
Parameters
Parameters | Description
pFound | Boolean; output-only. Specifies whether the specified view is found, TRUE, or not, FALSE.
ViewName | String; input-only. Specifies the view name for the view to look up.
Database | Variant (AcadDatabase object); input-only; optional. Specify the database in which to look up for the view; if not specified, the host database of the document is used.
Returns

None

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::NextViewName Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::NextViewName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::NextViewName Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the name of the next view instance for this folder definition.

Visual Basic
Sub NextViewName(ByRef database As VARIANT, pVal As [out, retval] BSTR)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the database in which to look up for duplicate view names; if not specified, the host database of the document is used.
Remarks
  • This property is a String.
  • For example, for the folder definition Folder1 with one instance Folder1:1, this property returns the name Folder1:2. It is the valid name for the next view instance of this definition.
Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::Occurrences Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::Occurrences Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::Occurrences Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Gets the occurrences of the folder definition from the specified database.

Visual Basic
Sub Occurrences(ByRef database As VARIANT, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify the attached database in which to get the occurrences; if not specified, occurrences from all databases are returned.
Remarks

This property is a McadFolders collection.

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::RemoveFolder Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::RemoveFolder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::RemoveFolder Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Removes a folder from a folder definition.

Visual Basic
Sub RemoveFolder(pFolder As IMcadFolder)
Parameters
Parameters | Description
pFolder | McadFolder object; input-only. Specifies the folder to remove from this definition.
Returns

None

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinition::SetHidesSuppressState Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::SetHidesSuppressState Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::SetHidesSuppressState Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Example Send Feedback
Summary

Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.

Visual Basic
Sub SetHidesSuppressState(bSuppressed As VARIANT_BOOL)
Parameters
Parameters | Description
bSuppressed | Boolean; input-only. Specifies whether to suppress all hide situations, TRUE, or unsuppress all hide situations, FALSE.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface, Example


IMcadFolderDefinition::SortChildren Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::SortChildren Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition::SortChildren Method
IMcadFolderDefinition Interface IMcadFolderDefinition Members IMcadFolderDefinition Interface Send Feedback
Summary

Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.

Visual Basic
Sub SortChildren()
Returns

None

Interface

IMcadFolderDefinition Interface

Links
IMcadFolderDefinition Interface, IMcadFolderDefinition Members, IMcadFolderDefinition Interface


IMcadFolderDefinitions Interface

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions Interface
IMcadFolderDefinitions Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolderDefinition objects.

Class Hierarchy

Declaration syntax

IMcadFolderDefinitions
Visual Basic
Public Interface IMcadFolderDefinitions
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadFolderDefinitions Members, AcadmAuto Library, Class Hierarchy


IMcadFolderDefinitions Members

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions Members
IMcadFolderDefinitions Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolderDefinitions.

Interface

IMcadFolderDefinitions Interface

Methods
Name | Description
Add | Appends a new folder definition to the collection.
Item | Gets the folder definition at the specified index from the collection.
Remove | Removes the specified folder definition from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folder definition definitions in the collection.
Links
IMcadFolderDefinitions Interface, Legend, Methods, Properties


IMcadFolderDefinitions::Application Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions::Application Property
IMcadFolderDefinitions Interface IMcadFolderDefinitions Members IMcadFolderDefinitions Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadFolderDefinitions Interface

Links
IMcadFolderDefinitions Interface, IMcadFolderDefinitions Members, IMcadFolderDefinitions Interface


IMcadFolderDefinitions::Count Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions::Count Property
IMcadFolderDefinitions Interface IMcadFolderDefinitions Members IMcadFolderDefinitions Interface Send Feedback
Summary

Gets the total number of folder definition definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadFolderDefinitions Interface

Links
IMcadFolderDefinitions Interface, IMcadFolderDefinitions Members, IMcadFolderDefinitions Interface


IMcadFolderDefinitions::Add Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions::Add Method
IMcadFolderDefinitions Interface IMcadFolderDefinitions Members IMcadFolderDefinitions Interface Send Feedback
Summary

Appends a new folder definition to the collection.

Visual Basic
Sub Add(Definition As IMcadFolderDefinition)
Parameters
Parameters | Description
Definition | McadFolderDefinition object; input-only. Specifies the new folder definition definitions to add to the collection.
Returns

None

Interface

IMcadFolderDefinitions Interface

Links
IMcadFolderDefinitions Interface, IMcadFolderDefinitions Members, IMcadFolderDefinitions Interface


IMcadFolderDefinitions::Item Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions::Item Method
IMcadFolderDefinitions Interface IMcadFolderDefinitions Members IMcadFolderDefinitions Interface Send Feedback
Summary

Gets the folder definition at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Definition As [out, retval] IMcadFolderDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder definition to return.
Returns

McadFolderDefinition object

Interface

IMcadFolderDefinitions Interface

Links
IMcadFolderDefinitions Interface, IMcadFolderDefinitions Members, IMcadFolderDefinitions Interface


IMcadFolderDefinitions::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions::Remove Method
IMcadFolderDefinitions Interface IMcadFolderDefinitions Members IMcadFolderDefinitions Interface Send Feedback
Summary

Removes the specified folder definition from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder definition to remove.
Returns

None

Interface

IMcadFolderDefinitions Interface

Links
IMcadFolderDefinitions Interface, IMcadFolderDefinitions Members, IMcadFolderDefinitions Interface


IMcadFolderDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor Interface
IMcadFolderDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a folder.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
Visual Basic
Public Interface IMcadFolderDescriptor
Inherits IMcad2DStructureDescriptor
Library

AcadmAuto Library

Links
IMcadFolderDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcadFolderDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor Members
IMcadFolderDescriptor Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolderDescriptor.

Interface

IMcadFolderDescriptor Interface

Methods
Name | Description
CreateFolder | Creates a new folder from the folder descriptor.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.
Links
IMcadFolderDescriptor Interface, Legend, Methods, Properties


IMcadFolderDescriptor::Definition Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::Definition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::Definition Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets folder definition using this descriptor.

Visual Basic
Property Definition() As VARIANT
Remarks

This property is a Variant ( McadFolderDefinition object).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::Entities Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::Entities Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::Entities Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets entities on this descriptor.

Visual Basic
Property Entities() As VARIANT
Remarks

This property is a Variant (array of object IDs (Long)).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::Entities32 Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::Entities32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::Entities32 Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets entities on this descriptor.

Visual Basic
Property Entities32() As VARIANT
Remarks

This property is a Variant (array of object IDs (Long)).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::Position Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::Position Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets or sets the position of the folder.

Visual Basic
Property Position() As IGeMatrix*
Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::PowerObjectType Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::PowerObjectType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::PowerObjectType Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets the power object type for this descriptor.

Visual Basic
Property PowerObjectType() As McadPowerObjectType*
Remarks

This property is a McadPowerObjectType object.

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::TargetView Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::TargetView Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::TargetView Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets the target (parent) view for this descriptor.

Visual Basic
Property TargetView() As VARIANT
Remarks

This property is a Variant (McadObject object).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::ViewKey Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::ViewKey Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::ViewKey Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets the view key for this descriptor.

Visual Basic
Property ViewKey() As VARIANT*
Remarks

This property is a Variant ( McadFolder object).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::ViewName Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::ViewName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::ViewName Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets the view name for this descriptor.

Visual Basic
Property ViewName() As String
Remarks

This property is a String.

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::Views Property

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::Views Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::Views Property
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Gets and sets child views from this descriptor.

Visual Basic
Property Views() As VARIANT
Remarks

This property is a Variant (array of McadFolder objects).

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolderDescriptor::CreateFolder Method

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor::CreateFolder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor::CreateFolder Method
IMcadFolderDescriptor Interface IMcadFolderDescriptor Members IMcadFolderDescriptor Interface Send Feedback
Summary

Creates a new folder from the folder descriptor.

Visual Basic
Sub CreateFolder()
Returns

None

Interface

IMcadFolderDescriptor Interface

Links
IMcadFolderDescriptor Interface, IMcadFolderDescriptor Members, IMcadFolderDescriptor Interface


IMcadFolders Interface

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders Interface
IMcadFolders Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadFolder objects.

Class Hierarchy

Declaration syntax

IMcadFolders
Visual Basic
Public Interface IMcadFolders
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadFolders Members, AcadmAuto Library, Class Hierarchy


IMcadFolders Members

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders Members
IMcadFolders Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFolders.

Interface

IMcadFolders Interface

Methods
Name | Description
Add | Appends a new folder to the collection.
Item | Gets the folder at the specified index from the collection.
Remove | Removes the specified folder from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folders in the collection.
Links
IMcadFolders Interface, Legend, Methods, Properties


IMcadFolders::Application Property

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders::Application Property
IMcadFolders Interface IMcadFolders Members IMcadFolders Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadFolders Interface

Links
IMcadFolders Interface, IMcadFolders Members, IMcadFolders Interface


IMcadFolders::Count Property

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders::Count Property
IMcadFolders Interface IMcadFolders Members IMcadFolders Interface Send Feedback
Summary

Gets the total number of folders in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadFolders Interface

Links
IMcadFolders Interface, IMcadFolders Members, IMcadFolders Interface


IMcadFolders::Add Method

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders::Add Method
IMcadFolders Interface IMcadFolders Members IMcadFolders Interface Send Feedback
Summary

Appends a new folder to the collection.

Visual Basic
Sub Add(Component As IMcadFolder)
Parameters
Parameters | Description
Component | McadFolder object; input-only. Specifies the new folder to add to the collection.
Interface

IMcadFolders Interface

Links
IMcadFolders Interface, IMcadFolders Members, IMcadFolders Interface


IMcadFolders::Item Method

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders::Item Method
IMcadFolders Interface IMcadFolders Members IMcadFolders Interface Send Feedback
Summary

Gets the folder at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadFolder*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder to return.
Returns

McadFolder object

Interface

IMcadFolders Interface

Links
IMcadFolders Interface, IMcadFolders Members, IMcadFolders Interface


IMcadFolders::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders::Remove Method
IMcadFolders Interface IMcadFolders Members IMcadFolders Interface Send Feedback
Summary

Removes the specified folder from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the folder to remove.
Returns

None

Interface

IMcadFolders Interface

Links
IMcadFolders Interface, IMcadFolders Members, IMcadFolders Interface


IMcadFormulaEvaluator Interface

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator Interface
IMcadFormulaEvaluator Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for Standard Data provider

Class Hierarchy

Declaration syntax

IMcadFormulaEvaluator
Visual Basic
Public Interface IMcadFormulaEvaluator
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadFormulaEvaluator Members, AcadmAuto Library, Class Hierarchy


IMcadFormulaEvaluator Members

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator Members
IMcadFormulaEvaluator Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFormulaEvaluator.

Interface

IMcadFormulaEvaluator Interface

Methods
Name | Description
Evaluate | Evaluates the expression using the all data providers, which were set in McadFormulaEvaluator. If the attribute in expression cannot by evaluated, the attribute name is returned.
Exist | Checks whether the data providers of formula evaluator have the specified attribute, TRUE, or not, FALSE.
GetAllAttribs | Gets all attributes in the given data providers.
GetAllAttribsData | Gets all information about the specified attribute from first data provider of formula evaluator and returns TRUE if this method can be implemented correctly.
GetAllAttribValues | Gets all values for the specified attribute from all providers that supply this attribute.
GetData | Gets the data for the specified attribute name from the first data provider of formula evaluator.
IsEditable | Checks whether the specified attribute data can be modified in the data provider, TRUE, or not, FALSE.
SetData | Sets a new value for the specified attribute in all data providers that contain this attribute.
SetDataProvider | Sets the additional data provider to Mcad Formula evaluator, TRUE, or not, FALSE.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Links
IMcadFormulaEvaluator Interface, Legend, Methods, Properties


IMcadFormulaEvaluator::Application Property

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::Application Property
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::Evaluate Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::Evaluate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::Evaluate Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Evaluates the expression using the all data providers, which were set in McadFormulaEvaluator. If the attribute in expression cannot by evaluated, the attribute name is returned.

Visual Basic
Sub Evaluate(formula As String, value As [out, retval] BSTR)
Parameters
Parameters | Description
formula | String; input-only. Specifies the formula expression to perform the check. The expression must be start with "=". The attribute name must by between "<>". Example "=Type: "
Returns

String

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::Exist Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::Exist Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::Exist Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Checks whether the data providers of formula evaluator have the specified attribute, TRUE, or not, FALSE.

Visual Basic
Sub Exist(attName As String, exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name to perform the check.
Returns

Boolean.

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::GetAllAttribs Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::GetAllAttribs Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::GetAllAttribs Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Gets all attributes in the given data providers.

Visual Basic
Sub GetAllAttribs(attribs As [out, retval] VARIANT)
Returns

Variant

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::GetAllAttribsData Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::GetAllAttribsData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::GetAllAttribsData Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Gets all information about the specified attribute from first data provider of formula evaluator and returns TRUE if this method can be implemented correctly.

Visual Basic
Sub GetAllAttribsData(attrib As String, ByRef value As String, ByRef data As String, ByRef editFlag As VARIANT_BOOL, result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attrib | String; input-only. Specifies the attribute name.
data | String; output-only. Returns the raw attribute data in the formula that is not evaluated.
editFlag | Boolean; output-only. Returns whether the attribute is editable, TRUE, or not, FALSE.
Value | String; output-only. Returns the evaluated attribute data.
Returns

Boolean

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::GetAllAttribValues Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::GetAllAttribValues Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::GetAllAttribValues Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Gets all values for the specified attribute from all providers that supply this attribute.

Visual Basic
Sub GetAllAttribValues(value As String, values As [out, retval] VARIANT)
Parameters
Parameters | Description
Value | String; input-only. Specifies the attribute value to perform the check.
Returns

Variant (array of Strings)

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::GetData Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::GetData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::GetData Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Gets the data for the specified attribute name from the first data provider of formula evaluator.

Visual Basic
Sub GetData(attName As String, value As [out, retval] BSTR)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name for which to get the evaluated data.
Returns

String

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::IsEditable Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::IsEditable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::IsEditable Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Checks whether the specified attribute data can be modified in the data provider, TRUE, or not, FALSE.

Visual Basic
Sub IsEditable(attName As String, isEditable As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
attName | String; input-only. Specifies the attribute name to perform the check.
Returns

Boolean

Remarks

Typically global attributes created by user are editable but standard part attributes are not editable.

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::SetData Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::SetData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::SetData Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Sets a new value for the specified attribute in all data providers that contain this attribute.

Visual Basic
Sub SetData(attName As String, data As String)
Parameters
Parameters | Description
attName | String; input-only. Specifies the name of the attribute for which to set a new value.
data | String; input-only. Specifies the new value to set for the specified attribute.
Returns

None

Remarks

You need to check whether this attribute is editable using the IsEditable method beforehand.

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadFormulaEvaluator::SetDataProvider Method

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator::SetDataProvider Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator::SetDataProvider Method
IMcadFormulaEvaluator Interface IMcadFormulaEvaluator Members IMcadFormulaEvaluator Interface Send Feedback
Summary

Sets the additional data provider to Mcad Formula evaluator, TRUE, or not, FALSE.

Visual Basic
Sub SetDataProvider(object As IAcadObject, result As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | AcadObject object; input-only. Specifies the entity ID which determines the data provider.
Returns

Boolean

Interface

IMcadFormulaEvaluator Interface

Links
IMcadFormulaEvaluator Interface, IMcadFormulaEvaluator Members, IMcadFormulaEvaluator Interface


IMcadGeometry Interface

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry Interface
IMcadGeometry Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadGeometry.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
Visual Basic
Public Interface IMcadGeometry
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadGeometry Members, AcadmAuto Library, Class Hierarchy


IMcadGeometry Members

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry Members
IMcadGeometry Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadGeometry.

Interface

IMcadGeometry Interface

Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ContainingComponent | Returns the lowest level component that this object is inserted into.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
HasChanged | Provides passive notification of whether the referenced geometry has changed since the geometry reference object was created or was last checked (and the state reset).
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Geometry | Specifies the geometric representation of the geometry being referenced.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadGeometry Interface, Legend, Methods, Properties


IMcadGeometry::Geometry Property

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::Geometry Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::Geometry Property
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Specifies the geometric representation of the geometry being referenced.

Visual Basic
Property Geometry() As IGeEntity*
Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadGeometry::AddAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::AddAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::AddAttribute Method
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Adds the specified attribute to the object being referenced by this object.

Visual Basic
Sub AddAttribute(Attribute As IMcadAttribute, Associativity As [in, defaultvalue(mcDefault)] McadAttributeAssociativity)
Remarks

The optional associativity type specifies the behavior of the attribute when the object that the attribute is attached to is copied.

Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadGeometry::ContainingComponent Method

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::ContainingComponent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::ContainingComponent Method
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Returns the lowest level component that this object is inserted into.

Visual Basic
Sub ContainingComponent(Component As [out, retval] IMcadComponent*)
Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadGeometry::GetAttributes Method

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::GetAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::GetAttributes Method
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Gets the attributes attached to the object being referenced.

Visual Basic
Sub GetAttributes(ExactMatch As [in, defaultvalue(TRUE)] VARIANT_BOOL, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
ExactMatch | Boolean, default value = False; input-only; optional. Specifies whether the exact match is used.
Attributes | _nt_
Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadGeometry::HasChanged Method

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::HasChanged Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::HasChanged Method
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Provides passive notification of whether the referenced geometry has changed since the geometry reference object was created or was last checked (and the state reset).

Visual Basic
Sub HasChanged(Reset As [in, defaultvalue(TRUE)] VARIANT_BOOL, Changed As [out, retval] VARIANT_BOOL)
Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadGeometry::RemoveAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry::RemoveAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry::RemoveAttribute Method
IMcadGeometry Interface IMcadGeometry Members IMcadGeometry Interface Send Feedback
Summary

Removes the specified attribute from the object being referenced.

Visual Basic
Sub RemoveAttribute(Attribute As IMcadAttribute)
Interface

IMcadGeometry Interface

Links
IMcadGeometry Interface, IMcadGeometry Members, IMcadGeometry Interface


IMcadHideSituation Interface

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation Interface
IMcadHideSituation Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This object provides general methods for 2D structure hide situations.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadHideSituation
Visual Basic
Public Interface IMcadHideSituation
Inherits IMcadObject
Library

AcadmAuto Library

Links
IMcadHideSituation Members, AcadmAuto Library, Class Hierarchy


IMcadHideSituation Members

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation Members
IMcadHideSituation Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadHideSituation.

Interface

IMcadHideSituation Interface

Methods
Name | Description
AddMSSubent | Adds the model space entity to this hide situation.
AddMSSubents | Adds model space entities to hide situation.
AddSubent | Adds the entity/view to this hide situation.
AddSubents | Adds the entities/views to this hide situation.
AutoSelectBackground | Automatically selects background objects and adds them to a new or existing level.
ClearSubents | Clears the hide situation sub-entities with the given sub-entity type.
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveSubent | Removes the entity/view from this hide situation with the given sub-entity type.
RemoveSubentByIdx | Removes the entity/view from this hide situation with the given sub-entity type and index number.
Subents | Gets the hide subentities of this hide situation.
SwapFgAndBg | Swaps foreground and background hide sub-entities.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BgSelectionName | Gets or sets the name for the background selection set.
Concealed | Gets or sets whether the hide situation is concealed, TRUE, or not, FALSE.
ContoursOnlyInForeground | Gets or sets the flag how the foreground entities set is used in this hide calculation.
Definition | Gets or sets the parent folder definition of the hide situation.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FgSelectionName | Gets or sets the name for the foreground selection set.
HiddenLinesInvisible | Gets or sets the hide style for lines is dashed, TRUE, or invisible, FALSE.
HideAppropriateObjectsOnly | Specifies how background objects are hidden, TRUE, or not, FALSE.
IgnoreBgExclude | Gets or sets the BgExclude flag.
IgnoreFgExclude | Gets or sets the FgExclude flag.
IgnoreUpperBgExclude |
InverseForeground | Gets or sets the flag how we use foreground entities set in this hide calculation.
IsComplexHideLevel | Checks whether this is complex hide situation, TRUE, or not, FALSE.
IsLastLevel | Checks if this hide situation is the last level of one complex hide situation, TRUE, or not, FALSE.
IsMigrated | Checks whether this is migrated hide situation, TRUE, or not, FALSE.
IsModifiedStandardPartHide | Checks whether this is the modified standard part hide situation, TRUE, or not, FALSE.
IsStandardPartHide | Checks whether this is standard part hide situation, TRUE, or not, FALSE.
LevelIndex |
Name | Gets or sets the name of the hide situation.
OuterContourOnly | Gets or sets the flag to define the outer contour property.
ParentHide | Gets the complex hide situation that owns this hide situation if this hide situation is part of one complex hide situation.
SaveSimplifiedOuterContour | Optimizes the outer contour selection and stores the contour for future calculations.
Suppressed | Gets or sets the suppression state of the hide situation, TRUE, or the unsuppression state, FALSE.
SysName | Gets or sets the system name.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadHideSituation Interface, Legend, Methods, Properties


IMcadHideSituation::BgSelectionName Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::BgSelectionName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::BgSelectionName Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the name for the background selection set.

Visual Basic
Property BgSelectionName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::Concealed Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Concealed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::Concealed Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets whether the hide situation is concealed, TRUE, or not, FALSE.

Visual Basic
Property Concealed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::ContoursOnlyInForeground Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ContoursOnlyInForeground Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::ContoursOnlyInForeground Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the flag how the foreground entities set is used in this hide calculation.

Visual Basic
Property ContoursOnlyInForeground() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::Definition Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Definition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::Definition Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the parent folder definition of the hide situation.

Visual Basic
Property Definition() As IMcadFolderDefinition*
Remarks

This property is a McadFolderDefinition object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::FgSelectionName Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::FgSelectionName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::FgSelectionName Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the name for the foreground selection set.

Visual Basic
Property FgSelectionName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::HiddenLinesInvisible Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::HiddenLinesInvisible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::HiddenLinesInvisible Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the hide style for lines is dashed, TRUE, or invisible, FALSE.

Visual Basic
Property HiddenLinesInvisible() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::HideAppropriateObjectsOnly Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::HideAppropriateObjectsOnly Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::HideAppropriateObjectsOnly Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Specifies how background objects are hidden, TRUE, or not, FALSE.

Visual Basic
Property HideAppropriateObjectsOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IgnoreBgExclude Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreBgExclude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IgnoreBgExclude Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the BgExclude flag.

Visual Basic
Property IgnoreBgExclude() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Background exclusion set should not be calculated as a part of the foreground and it will be skipped from hide calculating.
Example

Refer to SDK Samples: amshide2d.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IgnoreFgExclude Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreFgExclude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IgnoreFgExclude Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the FgExclude flag.

Visual Basic
Property IgnoreFgExclude() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • Foreground exclusion set should not be calculated as a part of the foreground and it will be skipped from hide calculating.
Example

Refer to SDK Samples: amshide2d.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IgnoreUpperBgExclude Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreUpperBgExclude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IgnoreUpperBgExclude Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Visual Basic
Property IgnoreUpperBgExclude() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::InverseForeground Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::InverseForeground Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::InverseForeground Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the flag how we use foreground entities set in this hide calculation.

Visual Basic
Property InverseForeground() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IsComplexHideLevel Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsComplexHideLevel Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IsComplexHideLevel Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Checks whether this is complex hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsComplexHideLevel() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IsLastLevel Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsLastLevel Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IsLastLevel Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Checks if this hide situation is the last level of one complex hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsLastLevel() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IsMigrated Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsMigrated Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IsMigrated Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Send Feedback
Summary

Checks whether this is migrated hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsMigrated() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface


IMcadHideSituation::IsModifiedStandardPartHide Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsModifiedStandardPartHide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IsModifiedStandardPartHide Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Checks whether this is the modified standard part hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsModifiedStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::IsStandardPartHide Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsStandardPartHide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::IsStandardPartHide Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Checks whether this is standard part hide situation, TRUE, or not, FALSE.

Visual Basic
Property IsStandardPartHide() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::LevelIndex Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::LevelIndex Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::LevelIndex Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Visual Basic
Property LevelIndex() As long*
Remarks

This property is a Long.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::Name Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::Name Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the name of the hide situation.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::OuterContourOnly Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::OuterContourOnly Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::OuterContourOnly Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the flag to define the outer contour property.

Visual Basic
Property OuterContourOnly() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::ParentHide Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ParentHide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::ParentHide Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets the complex hide situation that owns this hide situation if this hide situation is part of one complex hide situation.

Visual Basic
Property ParentHide() As IMcadComplexHideSituation**
Remarks

This property is a McadComplexHideSituation object.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::SaveSimplifiedOuterContour Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SaveSimplifiedOuterContour Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::SaveSimplifiedOuterContour Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Optimizes the outer contour selection and stores the contour for future calculations.

Visual Basic
Property SaveSimplifiedOuterContour() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • This option should be enabled only if you observe a significant delay in the processing of the hide situation. While this option is selected, changes made to the foreground are not reflected in the hide situation.
Example

Refer to SDK Samples: amshide2d.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::Suppressed Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Suppressed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::Suppressed Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the suppression state of the hide situation, TRUE, or the unsuppression state, FALSE.

Visual Basic
Property Suppressed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::SysName Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SysName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::SysName Property
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets or sets the system name.

Visual Basic
Property SysName() As String
Remarks

This property is a String.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::AddMSSubent Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddMSSubent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::AddMSSubent Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Adds the model space entity to this hide situation.

Visual Basic
Sub AddMSSubent(ent As IAcadEntity, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
ent | AcadEntity object; input-only. Specifies the model space entity to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::AddMSSubents Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddMSSubents Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::AddMSSubents Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Adds model space entities to hide situation.

Visual Basic
Sub AddMSSubents(entityIds As VARIANT, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
entityIds | Variant (array of Long); input-only. Specifies the ID for model space entities to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::AddSubent Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddSubent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::AddSubent Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Adds the entity/view to this hide situation.

Visual Basic
Sub AddSubent(pSubent As IMcadFolder, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity/view to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::AddSubents Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddSubents Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::AddSubents Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Adds the entities/views to this hide situation.

Visual Basic
Sub AddSubents(pSubents As IMcadFolders, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubents | McadFolders collection; input-only. Specifies the collection of entities/views to add.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::AutoSelectBackground Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AutoSelectBackground Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::AutoSelectBackground Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Automatically selects background objects and adds them to a new or existing level.

Visual Basic
Sub AutoSelectBackground(OccurrencesOnly As [in, defaultvalue(FALSE)] VARIANT_BOOL, CreateNewLevel As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
OccurrencesOnly | Boolean, default value = FALSE; input-only; optional. Specifies whether to perform this function to occurrences only.
CreateNewLevel | Boolean, default value = FALSE; input-only; optional. Specifies whether to create a new level or perform this function for the existing level.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::ClearSubents Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ClearSubents Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::ClearSubents Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Clears the hide situation sub-entities with the given sub-entity type.

Visual Basic
Sub ClearSubents(subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::RemoveSubent Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::RemoveSubent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::RemoveSubent Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Send Feedback
Summary

Removes the entity/view from this hide situation with the given sub-entity type.

Visual Basic
Sub RemoveSubent(pSubent As IMcadFolder, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
pSubent | McadFolder object; input-only. Specifies the entity or view to remove.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface


IMcadHideSituation::RemoveSubentByIdx Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::RemoveSubentByIdx Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::RemoveSubentByIdx Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Removes the entity/view from this hide situation with the given sub-entity type and index number.

Visual Basic
Sub RemoveSubentByIdx(subentIdx As long, subentType As McadHideSituationSubentType)
Parameters
Parameters | Description
subentIdx | Long; input-only. Specifies the index for the entity or view to remove.
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the sub-entity type.
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::Subents Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Subents Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::Subents Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Gets the hide subentities of this hide situation.

Visual Basic
Sub Subents(subentType As McadHideSituationSubentType, pVal As [out, retval] IMcadFolders*)
Parameters
Parameters | Description
SubentType | McadHideSituationSubentType enumeration; input-only. Specifies the type of hide subentities to return.
Remarks

This property is a McadFolders collection.

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituation::SwapFgAndBg Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SwapFgAndBg Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation::SwapFgAndBg Method
IMcadHideSituation Interface IMcadHideSituation Members IMcadHideSituation Interface Example Send Feedback
Summary

Swaps foreground and background hide sub-entities.

Visual Basic
Sub SwapFgAndBg()
Returns

None

Example

Refer to SDK Samples: AMSHide2D.dvb

Interface

IMcadHideSituation Interface

Links
IMcadHideSituation Interface, IMcadHideSituation Members, IMcadHideSituation Interface, Example


IMcadHideSituations Interface

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations Interface
IMcadHideSituations Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of AMSHide objects.

Class Hierarchy

Declaration syntax

IMcadHideSituations
Visual Basic
Public Interface IMcadHideSituations
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadHideSituations Members, AcadmAuto Library, Class Hierarchy


IMcadHideSituations Members

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations Members
IMcadHideSituations Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadHideSituations.

Interface

IMcadHideSituations Interface

Methods
Name | Description
Add | Appends a hide situation to the collection.
Item | Gets the hide object at the specified index from the collection.
Remove | Removes the specified Hide from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of hide situations in the collection.
Links
IMcadHideSituations Interface, Legend, Methods, Properties


IMcadHideSituations::Application Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations::Application Property
IMcadHideSituations Interface IMcadHideSituations Members IMcadHideSituations Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadHideSituations Interface

Links
IMcadHideSituations Interface, IMcadHideSituations Members, IMcadHideSituations Interface


IMcadHideSituations::Count Property

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations::Count Property
IMcadHideSituations Interface IMcadHideSituations Members IMcadHideSituations Interface Send Feedback
Summary

Gets the total number of hide situations in the collection.

Visual Basic
Property Count() As long*
Interface

IMcadHideSituations Interface

Links
IMcadHideSituations Interface, IMcadHideSituations Members, IMcadHideSituations Interface


IMcadHideSituations::Add Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations::Add Method
IMcadHideSituations Interface IMcadHideSituations Members IMcadHideSituations Interface Send Feedback
Summary

Appends a hide situation to the collection.

Visual Basic
Sub Add(Component As IMcadHideSituation)
Interface

IMcadHideSituations Interface

Links
IMcadHideSituations Interface, IMcadHideSituations Members, IMcadHideSituations Interface


IMcadHideSituations::Item Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations::Item Method
IMcadHideSituations Interface IMcadHideSituations Members IMcadHideSituations Interface Send Feedback
Summary

Gets the hide object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadHideSituation*)
Interface

IMcadHideSituations Interface

Links
IMcadHideSituations Interface, IMcadHideSituations Members, IMcadHideSituations Interface


IMcadHideSituations::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations::Remove Method
IMcadHideSituations Interface IMcadHideSituations Members IMcadHideSituations Interface Send Feedback
Summary

Removes the specified Hide from the collection.

Visual Basic
Sub Remove(Index As long)
Interface

IMcadHideSituations Interface

Links
IMcadHideSituations Interface, IMcadHideSituations Members, IMcadHideSituations Interface


IMcadLayerCfg Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg Interface
IMcadLayerCfg Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This class contains the configuration settings for a mechanical layer.

Class Hierarchy

Declaration syntax

IMcadLayerCfg
Visual Basic
Public Interface IMcadLayerCfg
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerCfg Members, AcadmAuto Library, Class Hierarchy


IMcadLayerCfg Members

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg Members
IMcadLayerCfg Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerCfg.

Interface

IMcadLayerCfg Interface

Properties
Name | Description
AssocObjects | Specifies objects associated with the layer.
Desc | Specifies the layer description.
Invisible | Specifies the visibility of the layer.
Key | Specifies the layer key.
LineType | Specifies the layer linetype.
LineTypeId | Specifies the layer linetype ID.
LineTypeId32 | Specifies the layer line type ID. Only available for x64 platform.
LineWeight | Specifies the layer lineweight.
Name | Specifies the layer name.
NoPlot | Specifies whether the layer is plotted.
NoReplicateInLayerGroup | Specifies whether the layer is replicated when a new layergroup is created.
OverrideColorByLayerGroup | Specifies whether the color associated with the layer is overridden by the layergroup color.
TrueColor | Specifies the layer color.
Links
IMcadLayerCfg Interface, Legend, Properties


IMcadLayerCfg::AssocObjects Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::AssocObjects Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::AssocObjects Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies objects associated with the layer.

Visual Basic
Property AssocObjects() As VARIANT*
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::Desc Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::Desc Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::Desc Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer description.

Visual Basic
Property Desc() As String
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::Invisible Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::Invisible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::Invisible Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the visibility of the layer.

Visual Basic
Property Invisible() As VARIANT_BOOL
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::Key Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::Key Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::Key Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer key.

Visual Basic
Property Key() As BSTR*
Remarks

Read-only.

Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::LineType Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::LineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::LineType Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer linetype.

Visual Basic
Property LineType() As String
Remarks

Read-only.

Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::LineTypeId Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::LineTypeId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::LineTypeId Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer linetype ID.

Visual Basic
Property LineTypeId() As LONG_PTR
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::LineTypeId32 Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::LineTypeId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::LineTypeId32 Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer line type ID. Only available for x64 platform.

Visual Basic
Property LineTypeId32() As LONG
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::LineWeight Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::LineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::LineWeight Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer lineweight.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::Name Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::Name Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer name.

Visual Basic
Property Name() As String
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::NoPlot Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::NoPlot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::NoPlot Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies whether the layer is plotted.

Visual Basic
Property NoPlot() As VARIANT_BOOL
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::NoReplicateInLayerGroup Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::NoReplicateInLayerGroup Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::NoReplicateInLayerGroup Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies whether the layer is replicated when a new layergroup is created.

Visual Basic
Property NoReplicateInLayerGroup() As VARIANT_BOOL
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::OverrideColorByLayerGroup Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::OverrideColorByLayerGroup Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::OverrideColorByLayerGroup Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies whether the color associated with the layer is overridden by the layergroup color.

Visual Basic
Property OverrideColorByLayerGroup() As VARIANT_BOOL
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfg::TrueColor Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg::TrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg::TrueColor Property
IMcadLayerCfg Interface IMcadLayerCfg Members IMcadLayerCfg Interface Send Feedback
Summary

Specifies the layer color.

Visual Basic
Property TrueColor() As IAcadAcCmColor*
Interface

IMcadLayerCfg Interface

Links
IMcadLayerCfg Interface, IMcadLayerCfg Members, IMcadLayerCfg Interface


IMcadLayerCfgs Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs Interface
IMcadLayerCfgs Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadLayerCfgs.

Class Hierarchy

Declaration syntax

IMcadLayerCfgs
Visual Basic
Public Interface IMcadLayerCfgs
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerCfgs Members, AcadmAuto Library, Class Hierarchy


IMcadLayerCfgs Members

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs Members
IMcadLayerCfgs Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerCfgs.

Interface

IMcadLayerCfgs Interface

Methods
Name | Description
Add | This is Add, a member of class IMcadLayerCfgs.
Item | This is Item, a member of class IMcadLayerCfgs.
Remove | This is Remove, a member of class IMcadLayerCfgs.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.
Links
IMcadLayerCfgs Interface, Legend, Methods, Properties


IMcadLayerCfgs::_NewEnum Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::_NewEnum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::_NewEnum Property
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

This is _NewEnum, a member of class IMcadLayerCfgs.

Visual Basic
Property _NewEnum() As LPUNKNOWN*
Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerCfgs::Application Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::Application Property
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

Returns the application object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is read-only.

Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerCfgs::Count Property

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::Count Property
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

Returns the total number of layer objects in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is read only.

Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerCfgs::Add Method

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::Add Method
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

This is Add, a member of class IMcadLayerCfgs.

Visual Basic
Sub Add(LayerCfg As IMcadLayerCfg)
Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerCfgs::Item Method

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::Item Method
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

This is Item, a member of class IMcadLayerCfgs.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadLayerCfg*)
Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerCfgs::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs::Remove Method
IMcadLayerCfgs Interface IMcadLayerCfgs Members IMcadLayerCfgs Interface Send Feedback
Summary

This is Remove, a member of class IMcadLayerCfgs.

Visual Basic
Sub Remove(Index As long)
Interface

IMcadLayerCfgs Interface

Links
IMcadLayerCfgs Interface, IMcadLayerCfgs Members, IMcadLayerCfgs Interface


IMcadLayerGroupMgr Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr Interface
IMcadLayerGroupMgr Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Provides access to methods and properties used to manage layers in documents.

Class Hierarchy

Declaration syntax

IMcadLayerGroupMgr
Visual Basic
Public Interface IMcadLayerGroupMgr
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerGroupMgr Members, AcadmAuto Library, Class Hierarchy


IMcadLayerGroupMgr Members

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr Members
IMcadLayerGroupMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerGroupMgr.

Interface

IMcadLayerGroupMgr Interface

Methods
Name | Description
GetLayerGroupEntities | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupEntities32 | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupNames | Gets all of the layer group names for the document.
GetLayersFromGroup | Gets the names of all layers in a specified layer group.
MoveLayerGroupEntities | Moves all of the entities in one layer group to another layer group.
Properties
Name | Description
Document | Gets the corresponding McadDocument from the specified host application's document.
Links
IMcadLayerGroupMgr Interface, Legend, Methods, Properties


IMcadLayerGroupMgr::Document Property

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::Document Property
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerGroupMgr::GetLayerGroupEntities Method

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::GetLayerGroupEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::GetLayerGroupEntities Method
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Gets the object IDs for the entities associated with that specified layer group.

Visual Basic
Sub GetLayerGroupEntities(layerGroupName As String, bIgnoreBlocks As [in, defaultvalue(FALSE)] VARIANT_BOOL, bOnlyBlockRefs As [in, defaultvalue(FALSE)] VARIANT_BOOL, bIgnore_FLO_Objects As [in, defaultvalue(FALSE)] VARIANT_BOOL, pEntityIds As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name for which to get entity IDs.
bIgnoreBlocks | Boolean, default value = FALSE; input-only. Denotes that AutoCAD block references are not returned.
bOnlyBlockRefs | Boolean, default value = FALSE; input-only. Denotes that only AutoCAD block references are returned .
bIgnore_FLO_Objects | Boolean, default value = FALSE; input-only. Denotes that entities on Frozen, Locked, or Off layers are not returned.
Returns

Variant (Array of entity IDs (Longs)).

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerGroupMgr::GetLayerGroupEntities32 Method

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::GetLayerGroupEntities32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::GetLayerGroupEntities32 Method
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Gets the object IDs for the entities associated with that specified layer group.

Visual Basic
Sub GetLayerGroupEntities32(layerGroupName As String, bIgnoreBlocks As [in, defaultvalue(FALSE)] VARIANT_BOOL, bOnlyBlockRefs As [in, defaultvalue(FALSE)] VARIANT_BOOL, bIgnore_FLO_Objects As [in, defaultvalue(FALSE)] VARIANT_BOOL, pEntityIds As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name for which to get entity IDs.
bIgnoreBlocks | Boolean, default value = False; input-only. Denotes that AutoCAD block references are not returned.
bOnlyBlockRefs | Boolean, default value = False; input-only. Denotes that only AutoCAD block references are returned .
bIgnore_FLO_Objects | Boolean, default value = False; input-only. Denotes that entities on Frozen, Locked, or Off layers are not returned.
pEntityIds | _nt_
Returns

Variant (Array of entity IDs (Longs)).

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerGroupMgr::GetLayerGroupNames Method

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::GetLayerGroupNames Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::GetLayerGroupNames Method
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Gets all of the layer group names for the document.

Visual Basic
Sub GetLayerGroupNames(pLayerGroupNames As [out, retval] VARIANT)
Returns

Array of Strings

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerGroupMgr::GetLayersFromGroup Method

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::GetLayersFromGroup Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::GetLayersFromGroup Method
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Gets the names of all layers in a specified layer group.

Visual Basic
Sub GetLayersFromGroup(layerGroupName As String, pLayerNames As [out, retval] VARIANT)
Parameters
Parameters | Description
layerGroupName | String; input-only. Specifies the layer group name from which to get the names of all layers.
Returns

Variant (Array of Strings)

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerGroupMgr::MoveLayerGroupEntities Method

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr::MoveLayerGroupEntities Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr::MoveLayerGroupEntities Method
IMcadLayerGroupMgr Interface IMcadLayerGroupMgr Members IMcadLayerGroupMgr Interface Send Feedback
Summary

Moves all of the entities in one layer group to another layer group.

Visual Basic
Sub MoveLayerGroupEntities(sourceGroup As String, targetGroup As String)
Parameters
Parameters | Description
sourceGroup | String; input-only. Specifies the source layer group from which to move all entities.
targetGroup | String; input-only. Specifies the target layer group to which to move all entities.
Remarks

The entities are potentially on different layers in the source group; these layers will be respected upon their transfer to the target layer group.

Interface

IMcadLayerGroupMgr Interface

Links
IMcadLayerGroupMgr Interface, IMcadLayerGroupMgr Members, IMcadLayerGroupMgr Interface


IMcadLayerObjectCfg Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg Interface
IMcadLayerObjectCfg Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This class contains the configuration settings for a mechanical object.

Class Hierarchy

Declaration syntax

IMcadLayerObjectCfg
Visual Basic
Public Interface IMcadLayerObjectCfg
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerObjectCfg Members, AcadmAuto Library, Class Hierarchy


IMcadLayerObjectCfg Members

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg Members
IMcadLayerObjectCfg Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerObjectCfg.

Interface

IMcadLayerObjectCfg Interface

Properties
Name | Description
Hide | Specifies the layer object hide type.
LayerName | Specifies the layer key.
LayerObjKey | Specifies the layer object key. This table lists the layer object keys and their description.
LineType | Specifies the layer object line type.
LineTypeId | Specifies the layer object line type ID.
LineTypeId32 | Specifies the layer object line type ID. Only available for x64 platform.
LineWeight | Specifies the layer object line weight.
TrueColor | Specifies the layer object color.
Links
IMcadLayerObjectCfg Interface, Legend, Properties


IMcadLayerObjectCfg::Hide Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::Hide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::Hide Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object hide type.

Visual Basic
Property Hide() As McadLayerObjectHideType
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LayerName Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LayerName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LayerName Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer key.

Visual Basic
Property LayerName() As String
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LayerObjKey Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LayerObjKey Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LayerObjKey Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object key.

This table lists the layer object keys and their description.

Key | Description
BHNV | Behind
BHNVS | Behind (extra)
BOR2 | Drawing Border Thin Objects
BOR3 | Drawing Border Objects
BOR5 | Drawing Border Thick Objects
CAL2 | Calculation Thin Objects
CAL3 | Calculation Objects
CAL5 | Calculation Thick Objects
CAL7 | Calculation Very Thick Objects
CENN | Centerline, narrow
CENW | Centerline
CLIN | Construction Line
CON1 | Contour 1
CON2 | Contour 2
CON3 | Contour 3
CON4 | Contour 4
DETA | Detail Border
DIAG | Diagonal Cross for Planes
DILI | Dimension/Extension Lines
DIMP | Dimension, parametric
DIMR | Dimension, reference
FEMN | FEA: Mesh
FEMPN | FEA: Number of Points
FEMSP | FEA: Stress
FEMST | FEA: Text for Stress
FEMVN | FEA: Deformation Mesh
FEMVT | FEA: Text for Deformation
HATC | Hatch
HIDN | Hidden Line, narrow
HIDW | Hidden Line
HLIN | Auxiliary Line
HOCN | Hole Circle, narrow
HOCW | Hole Circle
INFO | Part Reference Geometry
LEAD | Leader
N_BHNV | Standard Parts: Behind
N_CON1 | Standard Parts: Contour 1
N_CON2 | Standard Parts: Contour 2
N_CON3 | Standard Parts: Contour 3
N_CON4 | Standard Parts: Contour 4
N_CENN | Standard Parts: Centerline, narrow
N_CENW | Standard Parts: Centerline
N_DILI | Standard Parts: Dimension Line
N_HATC | Standard Parts: Hatch
N_HIDN | Standard Parts: Hidden Line, narrow
N_HIDW | Standard Parts: Hidden Line
N_LEAD | Standard Parts: Leader
N_NGIP | Standard Parts: Non Plottable Objects
N_PHAN | Standard Parts: Phantom
N_TCON | Standard Parts: Thread Contour
N_THLI | Standard Parts: Thread Line
NTLEN | Standard Parts: Thread End at Usable Length
N_VPLI | Standard Parts: Section/Viewing Plane Line
NGIP | Non Plottable Objects
PAL2 | Cell Lines
PAL3 | Grip Frame
PAL5 | Outer Frame
PHAN | Phantom
POSN | Balloon Geometry
RCGN | Reference Circle for Gear Cogwheels, narrow
RCGW | Reference Circle for Gear Cogwheels
SBRK | Break Line Short
SECT | Break Out Line
SYB3 | Calculation Symbols
MSYM | Symbol Geometry
TCON | Thread Contour
THLI | Thread Line
TIT2 | Title Block Thin Objects
TIT3 | Title Block Objects
TIT5 | Title Block Thick Objects
TLEN | Thread End at Usable Length
TRAIL | Trailing Line
TRLI | Transition Line
TXT1 | Text Very Small
TXT2 | Text Small
TXT3 | Text Medium
TXT5 | Text Large
TXT7 | Text Very Large
VIEW | Viewport
VEDH | View Edge, hidden
VEDV | View Edge, visible
VPLI | Section/Viewing Plane Line
ZIZA | Break Line Long (Zig Zag)
Visual Basic
Property LayerObjKey() As BSTR*
Remarks

This property is read-only.

Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LineType Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LineType Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object line type.

Visual Basic
Property LineType() As String
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LineTypeId Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LineTypeId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LineTypeId Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object line type ID.

Visual Basic
Property LineTypeId() As LONG_PTR
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LineTypeId32 Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LineTypeId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LineTypeId32 Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object line type ID. Only available for x64 platform.

Visual Basic
Property LineTypeId32() As LONG
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::LineWeight Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::LineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::LineWeight Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object line weight.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfg::TrueColor Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg::TrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg::TrueColor Property
IMcadLayerObjectCfg Interface IMcadLayerObjectCfg Members IMcadLayerObjectCfg Interface Send Feedback
Summary

Specifies the layer object color.

Visual Basic
Property TrueColor() As IAcadAcCmColor*
Interface

IMcadLayerObjectCfg Interface

Links
IMcadLayerObjectCfg Interface, IMcadLayerObjectCfg Members, IMcadLayerObjectCfg Interface


IMcadLayerObjectCfgs Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs Interface
IMcadLayerObjectCfgs Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadLayerObjectCfgs.

Class Hierarchy

Declaration syntax

IMcadLayerObjectCfgs
Visual Basic
Public Interface IMcadLayerObjectCfgs
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerObjectCfgs Members, AcadmAuto Library, Class Hierarchy


IMcadLayerObjectCfgs Members

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs Members
IMcadLayerObjectCfgs Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerObjectCfgs.

Interface

IMcadLayerObjectCfgs Interface

Methods
Name | Description
Add | This is Add, a member of class IMcadLayerObjectCfgs.
Item | Obtains a specified layer from the collection.
Remove | This is Remove, a member of class IMcadLayerObjectCfgs.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerObjectCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.
Links
IMcadLayerObjectCfgs Interface, Legend, Methods, Properties


IMcadLayerObjectCfgs::_NewEnum Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::_NewEnum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::_NewEnum Property
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

This is _NewEnum, a member of class IMcadLayerObjectCfgs.

Visual Basic
Property _NewEnum() As LPUNKNOWN*
Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectCfgs::Application Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::Application Property
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

Returns the application object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

Read-only.

Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectCfgs::Count Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::Count Property
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

Returns the total number of layer objects in the collection.

Visual Basic
Property Count() As long*
Remarks

Read-only.

Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectCfgs::Add Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::Add Method
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

This is Add, a member of class IMcadLayerObjectCfgs.

Visual Basic
Sub Add(LayObjCfg As IMcadLayerObjectCfg)
Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectCfgs::Item Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::Item Method
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

Obtains a specified layer from the collection.

Visual Basic
Sub Item(Index As long, Component As [out, retval] IMcadLayerObjectCfg*)
Parameters
Parameters | Description
Index | Long value; input-only. Specifies an index of the selected layer object in the collection. Values range from 0 to one less than the total number of objects.
Component | McadLayerObjectCfg object. Returns the selected layer object in the collection.
Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectCfgs::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs::Remove Method
IMcadLayerObjectCfgs Interface IMcadLayerObjectCfgs Members IMcadLayerObjectCfgs Interface Send Feedback
Summary

This is Remove, a member of class IMcadLayerObjectCfgs.

Visual Basic
Sub Remove(Index As long)
Interface

IMcadLayerObjectCfgs Interface

Links
IMcadLayerObjectCfgs Interface, IMcadLayerObjectCfgs Members, IMcadLayerObjectCfgs Interface


IMcadLayerObjectMgr Interface

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr Interface
IMcadLayerObjectMgr Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This class is for accessing the layer object settings.

Class Hierarchy

Declaration syntax

IMcadLayerObjectMgr
Visual Basic
Public Interface IMcadLayerObjectMgr
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadLayerObjectMgr Members, AcadmAuto Library, Class Hierarchy


IMcadLayerObjectMgr Members

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr Members
IMcadLayerObjectMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadLayerObjectMgr.

Interface

IMcadLayerObjectMgr Interface

Methods
Name | Description
CreateLayer | Creates a mechanical layer for the current drafting standard.
GetAllLayerObjs | Gets all the mechanical objects specified by the standard.
GetAllLayers | Gets all the mechanical layers for the specified standard in the current drawing.
GetLayerObjProperty | Gets the property of the layer object settings according to the layer object key and standard ID.
GetLayerProperty | Gets the property of the layer settings according to the layer name and standard ID.
ImportLayerObj | Imports the layer object settings from the specified drawing.
SetLayerObjDefault | Resets the mechanical layer and object properties to their default values.
Properties
Name | Description
Document | This is Document, a member of class IMcadLayerObjectMgr.
Links
IMcadLayerObjectMgr Interface, Legend, Methods, Properties


IMcadLayerObjectMgr::Document Property

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::Document Property
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

This is Document, a member of class IMcadLayerObjectMgr.

Visual Basic
Property Document() As IMcadDocument**
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::CreateLayer Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::CreateLayer Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::CreateLayer Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Creates a mechanical layer for the current drafting standard.

Visual Basic
Sub CreateLayer(layerName As String, groupName As [in,optional] VARIANT)
Parameters
Parameters | Description
layerName | BSTR object; input only. Specifies the layer name.
groupName | Variant object; input only. Specifies the group name of the layer.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::GetAllLayerObjs Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::GetAllLayerObjs Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::GetAllLayerObjs Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Gets all the mechanical objects specified by the standard.

Visual Basic
Sub GetAllLayerObjs(stdId As [in,optional] VARIANT, arLayObjCfg As [out,retval] IMcadLayerObjectCfgs*)
Parameters
Parameters | Description
stdId | Variant object; input only. Specifies current standard ID.
arLayObjCfg | Returns a list of all the mechanical objects.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::GetAllLayers Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::GetAllLayers Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::GetAllLayers Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Gets all the mechanical layers for the specified standard in the current drawing.

Visual Basic
Sub GetAllLayers(stdId As [in,optional] VARIANT, arLayCfg As [out,retval] IMcadLayerCfgs*)
Parameters
Parameters | Description
stdId | Variant object; input only. Specifies the current standard.
arLayCfg | McadLayerCfgs object. Returns a list of all the layers in the standard.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::GetLayerObjProperty Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::GetLayerObjProperty Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::GetLayerObjProperty Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Gets the property of the layer object settings according to the layer object key and standard ID.

Visual Basic
Sub GetLayerObjProperty(objKey As String, stdId As [in,optional] VARIANT, objProp As [out, retval] IMcadLayerObjectCfg*)
Parameters
Parameters | Description
objKey | BSTR object; input-only. Specifies the layer object key.
stdId | Variant object; input-only; optional. Specifies the standard ID.
objProp | MCadLayerObjectCfg object. Returns the configuration settings for a mechanical object.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::GetLayerProperty Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::GetLayerProperty Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::GetLayerProperty Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Gets the property of the layer settings according to the layer name and standard ID.

Visual Basic
Sub GetLayerProperty(layerName As String, stdId As [in,optional] VARIANT, layerProp As [out, retval] IMcadLayerCfg*)
Parameters
Parameters | Description
layerName | BSTR object; input only. Specifies the layer name.
stdId | Variant object; input-only; optional. Specifies the standard ID.
layerProp | McadLayerCfg object. Returns the configuration settings for a mechanical layer.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::ImportLayerObj Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::ImportLayerObj Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::ImportLayerObj Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Imports the layer object settings from the specified drawing.

Visual Basic
Sub ImportLayerObj(dwgName As String, bReplace As VARIANT_BOOL)
Parameters
Parameters | Description
dwgName | BSTR object; input only. Specifies the drawing name.
bReplace | Variant (Boolean). If true, the attributes of the entities will be changed in the current drawing according to the layer configuration of a foreign database of the source drawing.
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLayerObjectMgr::SetLayerObjDefault Method

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr::SetLayerObjDefault Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr::SetLayerObjDefault Method
IMcadLayerObjectMgr Interface IMcadLayerObjectMgr Members IMcadLayerObjectMgr Interface Send Feedback
Summary

Resets the mechanical layer and object properties to their default values.

Visual Basic
Sub SetLayerObjDefault()
Interface

IMcadLayerObjectMgr Interface

Links
IMcadLayerObjectMgr Interface, IMcadLayerObjectMgr Members, IMcadLayerObjectMgr Interface


IMcadLine Interface

You are here: API Reference > AcadmAuto Library > IMcadLine Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLine Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

An unbounded line object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadLine
Visual Basic
Public Interface IMcadLine
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadObject Interface

You are here: API Reference > AcadmAuto Library > IMcadObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject Interface
IMcadObject Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A reference to a generic object or sub-object within the Mechanical Desktop, AutoCAD or AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadComplexHideSituation
    IMcadComponent
    IMcadComponentDefinition
    IMcadFolder
    IMcadFolderDefinition
    IMcadGeometry
    IMcadHideSituation
Visual Basic
Public Interface IMcadObject
Inherits IDispatch
Remarks

This object is a temporary reference to the object unless it is made persistent using the MakePersistent method, where an identifier is generated for the reference and the reference is stored with the document. In a later session, the identifier can be used to revive the reference object.

Library

AcadmAuto Library

Links
IMcadObject Members, AcadmAuto Library, Class Hierarchy


IMcadObject Members

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject Members
IMcadObject Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadObject.

Interface

IMcadObject Interface

Methods
Name | Description
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.
Links
IMcadObject Interface, Legend, Methods, Properties


IMcadObject::Application Property

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::Application Property
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::Document Property

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::Document Property
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**
Remarks

This property is a McadDocument object.

Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::Editable Property

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::Editable Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::Editable Property
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.

Visual Basic
Property Editable() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • For many object types, this property indicates that the object is not external and can, for example, be deleted or its parameter modifications preserved when the drawing is saved.
Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::WasErased Property

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::WasErased Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::WasErased Property
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Gets whether component view definition was erased, TRUE, or not, FALSE.

Visual Basic
Property WasErased() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::Delete Method

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::Delete Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::Delete Method
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Deletes the object being referenced.

Visual Basic
Sub Delete()
Returns

None

Remarks

This will only be successful for object whose Editable property is a TRUE.

Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::Highlight Method

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::Highlight Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::Highlight Method
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Highlights the topological entity on the model.

Visual Basic
Sub Highlight(Highlight As VARIANT_BOOL, Scale As [in, defaultvalue(1.0)] double)
Parameters
Parameters | Description
Highlight | Boolean; input-only. Specifies whether to highlight the object, TRUE, or not, FALSE.
Scale | Double, default value = 1; input-only; optional. Specifies the scale factor for unbounded objects.
Returns

Boolean

Remarks

Highlighting the entity will only be visible if the outermost block reference, or the solid body itself resides in the model space block record if it is not nested in a block.

Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::IsEqualTo Method

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::IsEqualTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::IsEqualTo Method
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.

Visual Basic
Sub IsEqualTo(Object As IMcadObject, ConsiderComp As [in, defaultvalue(TRUE)] VARIANT_BOOL, DifferInComp As [out, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Object | McadObject object; input-only. Specifies the reference to the object to be compared to.
ConsiderComp | Boolean, default value = TRUE; input-only; optional. Specifies whether differences in component instance focus should be considered for equivalence, TRUE, or not, FALSE.
DifferInComp | Variant (Boolean); optional. Specifies whether the objects differ in component insert scope, TRUE, or not, FALSE.
Returns

Boolean

Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObject::MakePersistent Method

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject::MakePersistent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject::MakePersistent Method
IMcadObject Interface IMcadObject Members IMcadObject Interface Send Feedback
Summary

Assigns a unique identifier for the reference object and stores the reference object with the specified database.

Visual Basic
Sub MakePersistent(Database As [in, optional] VARIANT, Identifier As [out, retval] BSTR)
Parameters
Parameters | Description
Database | Variant (AcadDatabase object); input-only; optional. Specify which database in the document the object is to be stored in. If not specified, the object is stored in the current working database that is either the host database for the document, or the database that is currently being xref edited.
Returns

String

Remarks
  • Database resident objects that are referenced by an object reference include the object being referenced, for example a feature, as well as any objects in the references scope or focus, for example the chain of components that make up the focus of a feature key.
  • If an xref database is specified, this method will fail when the object references database objects that are 'above' the specified database in the xref database graph.
Interface

IMcadObject Interface

Links
IMcadObject Interface, IMcadObject Members, IMcadObject Interface


IMcadObjects Interface

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects Interface
IMcadObjects Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

A collection of IMcadObject subtype objects.

Class Hierarchy

Declaration syntax

IMcadObjects
Visual Basic
Public Interface IMcadObjects
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadObjects Members, AcadmAuto Library, Class Hierarchy


IMcadObjects Members

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects Members
IMcadObjects Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadObjects.

Interface

IMcadObjects Interface

Methods
Name | Description
Add | Appends a new object to the collection.
Item | Gets the object at the specified index from the collection.
Remove | Long; input-only. Specifies the index of the object to remove.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.
Links
IMcadObjects Interface, Legend, Methods, Properties


IMcadObjects::Application Property

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects::Application Property
IMcadObjects Interface IMcadObjects Members IMcadObjects Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadObjects Interface

Links
IMcadObjects Interface, IMcadObjects Members, IMcadObjects Interface


IMcadObjects::Count Property

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects::Count Property
IMcadObjects Interface IMcadObjects Members IMcadObjects Interface Send Feedback
Summary

Gets the total number of objects in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadObjects Interface

Links
IMcadObjects Interface, IMcadObjects Members, IMcadObjects Interface


IMcadObjects::Add Method

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects::Add Method
IMcadObjects Interface IMcadObjects Members IMcadObjects Interface Send Feedback
Summary

Appends a new object to the collection.

Visual Basic
Sub Add(Object As IMcadObject)
Parameters
Parameters | Description
Object | McadObject object; input-only. Specifies the new objects to add to the collection.
Returns

None

Interface

IMcadObjects Interface

Links
IMcadObjects Interface, IMcadObjects Members, IMcadObjects Interface


IMcadObjects::Item Method

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects::Item Method
IMcadObjects Interface IMcadObjects Members IMcadObjects Interface Send Feedback
Summary

Gets the object at the specified index from the collection.

Visual Basic
Sub Item(Index As long, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the object to return.
Returns

McadObject object

Interface

IMcadObjects Interface

Links
IMcadObjects Interface, IMcadObjects Members, IMcadObjects Interface


IMcadObjects::Remove Method

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects::Remove Method
IMcadObjects Interface IMcadObjects Members IMcadObjects Interface Send Feedback
Summary

Long; input-only. Specifies the index of the object to remove.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the object to remove.
Returns

None

Interface

IMcadObjects Interface

Links
IMcadObjects Interface, IMcadObjects Members, IMcadObjects Interface


IMcadPick Interface

You are here: API Reference > AcadmAuto Library > IMcadPick Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick Interface
IMcadPick Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.

Class Hierarchy

Declaration syntax

IMcadPick
Visual Basic
Public Interface IMcadPick
Inherits IDispatch
Remarks

A McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties. Using a pick object it is possible to get the subentity paths, pick point (point used for selection of entity) pick vector type of object, and so on.

Library

AcadmAuto Library

Links
IMcadPick Members, AcadmAuto Library, Class Hierarchy


IMcadPick Members

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick Members
IMcadPick Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPick.

Interface

IMcadPick Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
ObjectType | Specifies the object reference type that the pick is used to select.
PickPoint | Specifies the pick point of the pick object.
Links
IMcadPick Interface, Legend, Properties
Copyright (c) 2014. All rights reserved.


IMcadPick::Application Property

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick::Application Property
IMcadPick Interface IMcadPick Members IMcadPick Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadPick Interface

Links
IMcadPick Interface, IMcadPick Members, IMcadPick Interface


IMcadPick::ObjectType Property

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick::ObjectType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick::ObjectType Property
IMcadPick Interface IMcadPick Members IMcadPick Interface Send Feedback
Summary

Specifies the object reference type that the pick is used to select.

Visual Basic
Property ObjectType() As McadObjectType
Interface

IMcadPick Interface

Links
IMcadPick Interface, IMcadPick Members, IMcadPick Interface


IMcadPick::PickPoint Property

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick::PickPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick::PickPoint Property
IMcadPick Interface IMcadPick Members IMcadPick Interface Send Feedback
Summary

Specifies the pick point of the pick object.

Visual Basic
Property PickPoint() As IGePoint*
Interface

IMcadPick Interface

Links
IMcadPick Interface, IMcadPick Members, IMcadPick Interface


IMcadPolyline Interface

You are here: API Reference > AcadmAuto Library > IMcadPolyline Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPolyline Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A polyline object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadPolyline
Visual Basic
Public Interface IMcadPolyline
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadPowObjViewGroupDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor Interface
IMcadPowObjViewGroupDescriptor Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadPowObjViewGroupDescriptor
Visual Basic
Public Interface IMcadPowObjViewGroupDescriptor
Inherits IMcad2DStructureDescriptor
Library

AcadmAuto Library

Links
IMcadPowObjViewGroupDescriptor Members, AcadmAuto Library, Class Hierarchy


IMcadPowObjViewGroupDescriptor Members

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor Members
IMcadPowObjViewGroupDescriptor Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPowObjViewGroupDescriptor.

Interface

IMcadPowObjViewGroupDescriptor Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Entities | Gets the entities from the view group descriptor in model space.
Entities32 | Gets the entities from the view group descriptor in model space.
Name | Gets and sets the name of a 2D structure descriptor.
PowerObjectType | Gets the power object type from the power object view group descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
Links
IMcadPowObjViewGroupDescriptor Interface, Legend, Properties


IMcadPowObjViewGroupDescriptor::Entities Property

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor::Entities Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor::Entities Property
IMcadPowObjViewGroupDescriptor Interface IMcadPowObjViewGroupDescriptor Members IMcadPowObjViewGroupDescriptor Interface Send Feedback
Summary

Gets the entities from the view group descriptor in model space.

Visual Basic
Property Entities() As VARIANT*
Remarks

This property is a Variant (array of entity IDs (Longs)).

Interface

IMcadPowObjViewGroupDescriptor Interface

Links
IMcadPowObjViewGroupDescriptor Interface, IMcadPowObjViewGroupDescriptor Members, IMcadPowObjViewGroupDescriptor Interface


IMcadPowObjViewGroupDescriptor::Entities32 Property

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor::Entities32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor::Entities32 Property
IMcadPowObjViewGroupDescriptor Interface IMcadPowObjViewGroupDescriptor Members IMcadPowObjViewGroupDescriptor Interface Send Feedback
Summary

Gets the entities from the view group descriptor in model space.

Visual Basic
Property Entities32() As VARIANT*
Remarks

This property is a Variant (array of entity IDs (Longs)).

Interface

IMcadPowObjViewGroupDescriptor Interface

Links
IMcadPowObjViewGroupDescriptor Interface, IMcadPowObjViewGroupDescriptor Members, IMcadPowObjViewGroupDescriptor Interface


IMcadPowObjViewGroupDescriptor::PowerObjectType Property

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor::PowerObjectType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor::PowerObjectType Property
IMcadPowObjViewGroupDescriptor Interface IMcadPowObjViewGroupDescriptor Members IMcadPowObjViewGroupDescriptor Interface Send Feedback
Summary

Gets the power object type from the power object view group descriptor.

Visual Basic
Property PowerObjectType() As McadPowerObjectType*
Remarks

McadPowerObjectType enumeration

Interface

IMcadPowObjViewGroupDescriptor Interface

Links
IMcadPowObjViewGroupDescriptor Interface, IMcadPowObjViewGroupDescriptor Members, IMcadPowObjViewGroupDescriptor Interface


IMcadPowObjViewGroupDescriptor::TargetView Property

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor::TargetView Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor::TargetView Property
IMcadPowObjViewGroupDescriptor Interface IMcadPowObjViewGroupDescriptor Members IMcadPowObjViewGroupDescriptor Interface Send Feedback
Summary

Gets and sets the target (parent) view for this descriptor.

Visual Basic
Property TargetView() As VARIANT
Remarks

This property is a Variant ( McadObject object).

Interface

IMcadPowObjViewGroupDescriptor Interface

Links
IMcadPowObjViewGroupDescriptor Interface, IMcadPowObjViewGroupDescriptor Members, IMcadPowObjViewGroupDescriptor Interface


IMcadSpline Interface

You are here: API Reference > AcadmAuto Library > IMcadSpline Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSpline Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

A spline object.

Class Hierarchy

Declaration syntax

IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadSpline
Visual Basic
Public Interface IMcadSpline
Inherits IMcadCurve
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadStdPartComponentViewDescriptor Interface

You are here: API Reference > AcadmAuto Library > IMcadStdPartComponentViewDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStdPartComponentViewDescriptor Interface
AcadmAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates the description of a component view of a standard part.

Class Hierarchy

Declaration syntax

IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor
Visual Basic
Public Interface IMcadStdPartComponentViewDescriptor
Inherits IMcadComponentViewDescriptor
Library

AcadmAuto Library

Links
AcadmAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadUtility Interface

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility Interface
IMcadUtility Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This API provides some general utility methods.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
Visual Basic
Public Interface IMcadUtility
Inherits IDispatch
Library

AcadmAuto Library

Links
IMcadUtility Members, AcadmAuto Library, Class Hierarchy


IMcadUtility Members

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility Members
IMcadUtility Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadUtility.

Interface

IMcadUtility Interface

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Links
IMcadUtility Interface, Legend, Methods, Properties


IMcadUtility::Application Property

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::Application Property
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::Document Property

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::Document Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::Document Property
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the corresponding McadDocument from the specified host application's document.

Visual Basic
Property Document() As IMcadDocument**
Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::CreateAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::CreateAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::CreateAttribute Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates a new attribute instance using a specified ClassName as input.

Visual Basic
Sub CreateAttribute(ClassName As String, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ClassName | String; input-only. Specifies the class name with which to create the new attribute.
Returns

McadAttribute object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::CreateAttributeField Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::CreateAttributeField Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::CreateAttributeField Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates a new attribute field object.

Visual Basic
Sub CreateAttributeField(Field As [out, retval] IMcadAttributeField*)
Remarks

McadAttributeField object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::CreateCollection Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::CreateCollection Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::CreateCollection Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates a collection object for the specified type.

Visual Basic
Sub CreateCollection(Type As McadCollectionType, Collection As [out, retval] LPDISPATCH)
Parameters
Parameters | Description
Type | McadCollectionType enumeration; input-only. Specifies the collection type for which to create the new collection.
Returns

Mcad collection object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::CreatePickObject Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::CreatePickObject Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::CreatePickObject Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates a new pick object.

Visual Basic
Sub CreatePickObject(Pick As [out, retval] IMcadPick*)
Remarks

Pick objects are usually created with the Pick method, but this method is intended for creating an empty pick object to manually set the data in.

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::CreateSystemAttribute Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::CreateSystemAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::CreateSystemAttribute Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates a new system attribute instance.

Visual Basic
Sub CreateSystemAttribute(Name As String, DataType As McadFieldType, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
Name | Name String
DataType | DataType McadFieldType
Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetAllAttributes Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetAllAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetAllAttributes Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets all of the attributes in the drawing.

Visual Basic
Sub GetAllAttributes(Name As [in, optional] VARIANT, Scope As [in, optional] VARIANT, Attributes As [out, retval] IMcadAttributes*)
Parameters
Parameters | Description
Name | Variant (String); input-only; optional. Limits the attributes to only those in a specified type; if not specified, attributes in all types are returned.
Scope | Variant ( McadObject object); input-only; optional. If specified, limits the search to a specific object, for example a part object would limit the search to all attributes on the part. Note that currently only part objects are allowed for the Scope element.
Returns

McadAttributes collection

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetAttributeFromID Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetAttributeFromID Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetAttributeFromID Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the attribute from a specified object ID.

Visual Basic
Sub GetAttributeFromID(ObjectID As LONG_PTR, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ObjectID | Long; input-only. Specified the object ID from which to get the attribute.
Returns

McadAttribute object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetAttributeFromID32 Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetAttributeFromID32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetAttributeFromID32 Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the attribute object from an object ID.

Visual Basic
Sub GetAttributeFromID32(ObjectID As LONG, Attribute As [out, retval] IMcadAttribute*)
Parameters
Parameters | Description
ObjectID | Long; input-only. Specifies the geometry object ID to perform this method.
Attribute | The IMcadAttribute object.
Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetGeometryFromPick Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetGeometryFromPick Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetGeometryFromPick Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Obtains a geometry reference object of the specified type from the specified pick object.

Visual Basic
Sub GetGeometryFromPick(Type As McadObjectType, Infer As VARIANT_BOOL, Pick1 As IMcadPick, Pick2 As [in, optional] VARIANT, Geometry As [out, retval] IMcadGeometry*)
Parameters
Parameters | Description
Type | McadObjectType enumeration; input-only. Specifies the type to infer from the actual geometry picked.
Infer | Boolean; input-only. Specifies whether the specified type should be inferred from the actual geometry picked. For example, a pick to an arc can be used to request a geometry reference to a line and the axis of the circle would be returned.
Pick1 | McadPick object; input-only. Specifies the pick object when the inferred type would require more than one pick,
Pick2 | Variant ( McadPick object); input-only; optional. Specifies the additional pick object when the inferred type would require more than one pick,
Returns

McadGeometry object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetIdsFromObject Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetIdsFromObject Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetIdsFromObject Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the object ID or multiple object IDs that constitute the object being referenced.

Visual Basic
Sub GetIdsFromObject(Object As IMcadObject, ObjectIDs As [out, retval] VARIANT)
Parameters
Parameters | Description
Object | IMcadObject object; input-only. Specifies the object for which to get object ID(s). It can be McadFolder, McadComponentView, McadHideSituation, and McadComplexHideSituation.
Returns

Variant (array of Longs)

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetIdsFromObject32 Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetIdsFromObject32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetIdsFromObject32 Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Gets the object ID or multiple object IDs that constitute the object being referenced.

Visual Basic
Sub GetIdsFromObject32(Object As IMcadObject, ObjectIDs As [out, retval] VARIANT)
Parameters
Parameters | Description
Object | IMcadObject object; input-only. Specifies the object for which to get object ID(s). It can be McadFolder, McadComponentView, McadHideSituation, and McadComplexHideSituation.
ObjectIDs | _nt_
Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetObjectFromID Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetObjectFromID Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetObjectFromID Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Obtains a geometry reference object of the specified type from the specified object ID.

Visual Basic
Sub GetObjectFromID(Id As LONG_PTR, Type As McadObjectType, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Id | Long; input-only. Specifies the geometry object ID to perform this method.
Type | McadObjectType enumeration; input-only. Specifies the object type to perform this method.
Returns

IMcadObject object

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetObjectFromID32 Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetObjectFromID32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetObjectFromID32 Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Obtains a geometry reference object of the specified type from the specified object ID.

Visual Basic
Sub GetObjectFromID32(Id As LONG, Type As McadObjectType, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Id | Long; input-only. Specifies the geometry object ID to perform this method.
Type | McadObjectType enumeration; input-only. Specifies the object type to perform this method.
Object | The IMcadObject object.
Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::GetObjectFromPick Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::GetObjectFromPick Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::GetObjectFromPick Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Creates an object reference of the specified type from the specified pick object.

Visual Basic
Sub GetObjectFromPick(Pick As IMcadPick, Object As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Pick | McadPick object; input-only. Specifies the McadPick object to create an object reference from.
Returns

McadObject object

Remarks

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen. A McadPick object can be obtained by prompting users for a selection using the McadUtility > Pick method or constructed from its properties.

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility::Pick Method

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility::Pick Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility::Pick Method
IMcadUtility Interface IMcadUtility Members IMcadUtility Interface Send Feedback
Summary

Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.

Visual Basic
Sub Pick(Prompt As String, Type As McadObjectType, AllowGhost As [in, defaultvalue(FALSE)] VARIANT_BOOL, ActiveInstance As [in, defaultvalue(FALSE)] VARIANT_BOOL, KeyWords As [in, optional] VARIANT, KeyWordUsed As [in, out, optional] VARIANT, FilterType As [in, optional] VARIANT, FilterData As [in, optional] VARIANT, Pick As [out, retval] IMcadPick*)
Parameters
Parameters | Description
Prompt | String; input-only. Specifies the string to prompt users for the selection of the object.
Type | McadObjectType enumeration; input-only. Specifies the type of the object to pick.
AllowGhost | Boolean, default value = False; input-only; optional. Specifies whether the ghost selection is enabled, TRUE, or not, FALSE.
ActiveInstance | Boolean, default value = False; input-only; optional. Specifies whether the selection is restricted to the active component instance, TRUE, or not, FALSE.
KeyWords | Variant; input-only; optional. Specifies a list of keywords to be included within the prompt, separated by spaces.
KeyWordUsed | Variant; output-only; optional. If the KeyWords element is supplied and the user chooses a keyword instead of making a selection, the selected keyword is returned in the KeyWordUsed element.
FilterType | Variant; input-only; optional. Specifies the filter type to filter the selection.
FilterData | Variant; input-only; optional. Specifies the filter data to filter the selection.
Returns

McadPick object

Remarks

McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen. A McadPick object can be obtained by prompting users for a selection using this method or constructed from its properties.

Interface

IMcadUtility Interface

Links
IMcadUtility Interface, IMcadUtility Members, IMcadUtility Interface


IMcadUtility2 Interface

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility2 Interface
IMcadUtility2 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadUtility2.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
        IMcadUtility3
Visual Basic
Public Interface IMcadUtility2
Inherits IMcadUtility
Library

AcadmAuto Library

Links
IMcadUtility2 Members, AcadmAuto Library, Class Hierarchy


IMcadUtility2 Members

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility2 Members
IMcadUtility2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadUtility2.

Interface

IMcadUtility2 Interface

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Links
IMcadUtility2 Interface, Legend, Methods, Properties


IMcadUtility2::RefocusObject Method

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2::RefocusObject Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility2::RefocusObject Method
IMcadUtility2 Interface IMcadUtility2 Members IMcadUtility2 Interface Send Feedback
Summary

Repath the folder, component view or hide situation to the target view

Visual Basic
Sub RefocusObject(Object As IMcadObject, Target As IMcadObject, InPlace As [in, defaultvalue(TRUE)] VARIANT_BOOL, Result As [out, retval] IMcadObject*)
Parameters
Parameters | Description
Object | _nt_
Target | _nt_
InPlace | _nt_
Result | _nt_
Remarks

This API is applicable for McadFolder, McadComponentView and McadHideSituation/McadComplexHideSituation.

Interface

IMcadUtility2 Interface

Links
IMcadUtility2 Interface, IMcadUtility2 Members, IMcadUtility2 Interface


IMcadUtility3 Interface

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility3 Interface
IMcadUtility3 Members AcadmAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadUtility3.

Class Hierarchy

Declaration syntax

IMcadUtility
    IMcadUtility2
        IMcadUtility3
Visual Basic
Public Interface IMcadUtility3
Inherits IMcadUtility2
Library

AcadmAuto Library

Links
IMcadUtility3 Members, AcadmAuto Library, Class Hierarchy


IMcadUtility3 Members

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility3 Members
IMcadUtility3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadUtility3.

Interface

IMcadUtility3 Interface

Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetDrawingType | Obtains the DWG drawing type from the side database.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Links
IMcadUtility3 Interface, Legend, Methods, Properties


IMcadUtility3::GetDrawingType Method

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3::GetDrawingType Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility3::GetDrawingType Method
IMcadUtility3 Interface IMcadUtility3 Members IMcadUtility3 Interface Send Feedback
Summary

Obtains the DWG drawing type from the side database.

Visual Basic
Sub GetDrawingType(database As IAcadDatabase, Type As [out, retval] McadDocDrawingType)
Interface

IMcadUtility3 Interface

Links
IMcadUtility3 Interface, IMcadUtility3 Members, IMcadUtility3 Interface


Mcad2DSViewType Enumeration

You are here: API Reference > AcadmAuto Library > Mcad2DSViewType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Mcad2DSViewType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates the 2D structure view types.

Visual Basic
Public Enum Mcad2DSViewType
  mc2DSUndefinedView = 0
  mc2DSFrontView = 1
  mc2DSTopView = 2
  mc2DSBackView = 3
  mc2DSSideView = 4
  mc2DSSideLeftView = 5
  mc2DSSideRightView = 6
  mc2DSBottomView = 7
  mc2DSPartialView = 8
  mc2DSSectionView = 9
  mc2DSDetailView = 10
  mc2DSHalfSectionView = 11
  mc2DSHalfSectionVisibleView = 12
  mc2DSAuxiliaryView = 13
End Enum
Members
Members | Description
mc2DSUndefinedView | Indicates the 2D structure view type is undefined.
mc2DSFrontView | Indicates the 2D structure view type is Front View.
mc2DSTopView | Indicates the 2D structure view type is Top View.
mc2DSBackView | Indicates the 2D structure view type is Back View.
mc2DSSideView | Indicates the 2D structure view type is Side View.
mc2DSSideLeftView | Indicates the 2D structure view type is Side-Left View.
mc2DSSideRightView | Indicates the 2D structure view type is Side-Right View.
mc2DSBottomView | Indicates the 2D structure view type is Bottom View.
mc2DSPartialView | Indicates the 2D structure view type is Partial View.
mc2DSSectionView | Indicates the 2D structure view type is Section View.
mc2DSDetailView | Indicates the 2D structure view type is Detail View.
mc2DSHalfSectionView | Indicates the 2D structure view type is Half-Section View.
mc2DSHalfSectionVisibleView | Indicates the 2D structure view type is Section-Visible View.
mc2DSAuxiliaryView | Indicates the 2D structure view type is Auxiliary View.
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadCollectionType Enumeration

You are here: API Reference > AcadmAuto Library > McadCollectionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadCollectionType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all collection types for which to create the new collection. Some of collection types can only be used in Mechanical Desktop.

mcAttributeFields : Specifies the collection of attribute fields.

mcAttributes : Specifies the collection of attributes.

mcComponentDefinitions : Specifies the collection of component definitions.

mcComponents : Specifies the collection of components.

mcObjects : Specifies the collection of Mcad objects.

mcComponentViews : Specifies the collection of component views.

mcComponentViewDefinitions : Specifies the collection of component view definitions.

mcFolders : Specifies the collection of folders.

mcFolderDefinitions : Specifies the collection of folder definitions.

mcAnnotationViewDefinitions : Specifies the collection of the annotation view definitions.

mcHideSituations : Specifies the collection of normal hide situation objects.

mcComplexHideSituations : Specifies the collection of complex hide situation objects.

Visual Basic
Public Enum McadCollectionType
  mcAttributeFields = 0
  mcAttributes = 1
  mcComponentDefinitions = 2
  mcComponents = 3
  mcObjects = 4
  mcComponentViews = 5
  mcComponentViewDefinitions = 6
  mcFolders = 7
  mcFolderDefinitions = 8
  mcAnnotationViewDefinitions = 9
  mcHideSituations = 10
  mcComplexHideSituations = 11
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadDocDrawingType Enumeration

You are here: API Reference > AcadmAuto Library > McadDocDrawingType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDocDrawingType Enumeration
AcadmAuto Library Send Feedback
Summary

type McadDocDrawingType

Visual Basic
Public Enum McadDocDrawingType
  mcAcad = 0
  mcAcadM = 2
  mcAcadMStruct = 3
  mcMDT = 4
  mcMDTPart = 5
  mcInventorLink = 6
  mcUndefined = 7
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadFieldType Enumeration

You are here: API Reference > AcadmAuto Library > McadFieldType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFieldType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates the field value types.

mcShort : Indicates the field value is Short.

mcLong : Indicates the field value is Long.

mcDouble : Indicates the field value is a Double.

mcCharacter : Indicates the field value is Character.

mcShortArray : Indicates the field value is Array of Short.

mcLongArray : Indicates the field value is Array of Long.

mcDoubleArray : Indicates the field value is Array of Double.

mcString : Indicates the field value is String.

mcObjectID : Indicates the field value is Object ID.

mcObjectIDArray : Indicates the field value is Array of Object IDs.

mcMcadObject : Indicates the field value is Object.

mcMcadObjectArray : Indicates the field value is Array of Objects.

Visual Basic
Public Enum McadFieldType
  mcShort = 0
  mcLong = 1
  mcDouble = 2
  mcCharacter = 3
  mcShortArray = 4
  mcLongArray = 5
  mcDoubleArray = 6
  mcString = 7
  mcObjectID = 8
  mcObjectIDArray = 9
  mcMcadObject = 10
  mcMcadObjectArray = 11
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadHideSituationRefType Enumeration

You are here: API Reference > AcadmAuto Library > McadHideSituationRefType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadHideSituationRefType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all referenced types for this hide situation.

mc2DSDirectRef : Indicates that the leaf or view instance is directly referred by hide situation.

mc2DSSubEntRef : Indicates that the leaf or view instance of a subentity of the view is referenced by hide situation.

mc2DSPartialRef : Indicates that the view instance is partially or fully referred by hide situation.

mc2DSAllRef : It is equivalent to mc2DSDirectRef | mc2DSSubEntRef.

Visual Basic
Public Enum McadHideSituationRefType
  mc2DSDirectRef = &H0001
  mc2DSSubEntRef = &H0002
  mc2DSPartialRef = &H0004
  mc2DSAllRef = mc2DSDirectRef|mc2DSSubEntRef
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadHideSituationSubentType Enumeration

You are here: API Reference > AcadmAuto Library > McadHideSituationSubentType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadHideSituationSubentType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all referenced hide subentity types for this hide situation.

mc2DSNoEnt : Indicates that there are no subentities.

mc2DSFGEnt : Indicates the foreground hide situation.

mc2DSBGEnt : Indicates the background hide situation.

mc2DSFGExclEnt : Indicates the foreground excluded hide situation.

mc2DSBGExclEnt : Indicates the background excluded hide situation.

mc2DSUpperBGExclEnt : Indicates the upper background excluded hide situation.

Visual Basic
Public Enum McadHideSituationSubentType
  mc2DSNoEnt = 0
  mc2DSFGEnt = 1
  mc2DSBGEnt = 2
  mc2DSFGExclEnt = 4
  mc2DSBGExclEnt = 8
  mc2DSUpperBGExclEnt = 16
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadLayerObjectHideType Enumeration

You are here: API Reference > AcadmAuto Library > McadLayerObjectHideType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLayerObjectHideType Enumeration
AcadmAuto Library Send Feedback
Summary

This is record McadLayerObjectHideType.

Visual Basic
Public Enum McadLayerObjectHideType
  mcDontHide = &H00
  mcHideBg = &H01
  mcHideFg = &H02
  mcHideFgBg = &H03
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadObjectType Enumeration

You are here: API Reference > AcadmAuto Library > McadObjectType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadObjectType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all generic objects within the Mechanical Desktop or AutoCAD.

mcObject : Specifies the McadObject type of the object.

mcGeometry : Specifies the McadObject type of the geometry.

mcCurve : Specifies the McadObject type of the curve.

mcLine : Specifies the McadObject type of the line.

mcArc : Specifies the McadObject type of the arc.

mcEllipse : Specifies the McadObject type of the ellipse.

mcSpline : Specifies the McadObject type of the spline.

mcPolyline : Specifies the McadObject type of the polyline.

mcAaugmentedLine : Specifies the McadObject type of the augmented line.

mcComponent : Specifies the McadObject type of the component.

mcComponentDefinition : Specifies the McadObject type of the component definition.

mcComponentView : Specifies the McadObject type of the component view.

mcComponentViewDefinition : Specifies the McadObject type of the component view definition.

mcFolder : Specifies the McadObject type of the folder.

mcFolderDefinition : Specifies the McadObject type of the folder definition.

mcAnnotationViewDefinition : Specifies the McadObject type of the annotation view definition.

Visual Basic
Public Enum McadObjectType
  mcObject = 0
  mcGeometry = 1
  mcCurve = 2
  mcLine = 3
  mcArc = 4
  mcEllipse = 5
  mcSpline = 6
  mcPolyline = 7
  mcAaugmentedLine = 8
  mcComponent = 9
  mcComponentDefinition = 10
  mcComponentView = 11
  mcComponentViewDefinition = 12
  mcFolder = 13
  mcFolderDefinition = 14
  mcAnnotationViewDefinition = 15
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadPhantomState Enumeration

You are here: API Reference > AcadmAuto Library > McadPhantomState Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPhantomState Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all phantom states.

mcNormalDef : Specifies the normal state, with a value of 0.

mcPhantomDef : Specifies the phantom state, with a value of 1.

mcPhantomDefInCurrent : Specifies the phantom state in the current drawing, with a value of 2.

Visual Basic
Public Enum McadPhantomState
  mcNormalDef = 0
  mcPhantomDef = 1
  mcPhantomDefInCurrent = 2
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadPowerObjectType Enumeration

You are here: API Reference > AcadmAuto Library > McadPowerObjectType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPowerObjectType Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates the power object types.

mcNoObj : Specifies no power object.

mcShaftCalcObj : Specifies the shaft calculation power object.

mcCamCalcObj : Specifies the cam calculation power object.

mcFEAObj : Specifies the FEA power object.

mcMomOfInertiaObj : Specifies the momentum of inertia power object.

mcDeflLineObj : Specifies the line power object.

mcScrewConObj : Specifies the screw connection of the power object.

mcPartFeatObj : Specifies the part feature power object.

mcShaftObj : Specifies the shaft power object.

mcAllFolderPowerObj : Specifies the all folders power object.

Visual Basic
Public Enum McadPowerObjectType
  mcNoObj = &H00000000
  mcShaftCalcObj = &H00000001
  mcCamCalcObj = &H00000002
  mcFEAObj = &H00000004
  mcMomOfInertiaObj = &H00000008
  mcDeflLineObj = &H00000010
  mcScrewConObj = &H00000020
  mcPartFeatObj = &H00000040
  mcShaftObj = &H00000080
  mcAllFolderPowerObj = mcShaftCalcObj|mcCamCalcObj|mcFEAObj|mcMomOfInertiaObj|mcDeflLineObj
End Enum
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


McadSelectionOrderOption Enumeration

You are here: API Reference > AcadmAuto Library > McadSelectionOrderOption Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSelectionOrderOption Enumeration
AcadmAuto Library Send Feedback
Summary

Enumerates all available 2D Structure selection order options.

Visual Basic
Public Enum McadSelectionOrderOption
  mcTopDown = 0
  mcBottomUp = 1
End Enum
Members
Members | Description
mcTopDown | Value 0. Specifies that the 2D Structure selection order is from top to bottom.
mcBottomUp | Value 1. Specifies that the 2D Structure selection order is from bottom to top.
Library

AcadmAuto Library

Links
AcadmAuto Library
Copyright (c) 2014. All rights reserved.


SymBBAuto Library

You are here: API Reference > SymBBAuto Library
SymBBAuto Library
CoClasses Enumerations API Reference Interfaces Legend Send Feedback
Summary

The Autodesk SymBBAuto 3.0 Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided.

CoClasses
Name | Description
McadAnnotationViewLabel | Annotation view label entity.
McadAnnotationViewStandard | Annotation view label standard.
McadBalloon | A balloon symbol object
McadBalloons | A collection of McadBalloon objects
McadBalloonStandard | The balloon standards for a bill of materials symbol standard.
McadBOM | A bill of materials database object.
McadBOMItem | A bill of materials item or row object
McadBOMItems | A collection of McadBOMItem objects
McadBOMMgr | A bill of materials manager object
McadBOMs | A collection of McadBOM objects
McadBOMStandard | A bill of materials symbol standard object
McadBorder | This object represents the drawing border of the title/border created in the drawing.
McadColumnDefinition | Stores the BOM column definition information.
McadColumnDefinitions | A collection of McadColumnDefinition objects
McadDatumIdentifier | Implements datum identifier symbols.
McadDatumStandard | A datum target symbol standard
McadDatumTarget | A datum target symbol
McadDetailSymbol | This object represents the detail symbol created in the drawing.
McadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
McadDetailSymbolStandard | This object represents the Detail symbol standard.
McadEdge | This object represents the edge symbol created in the drawing.
McadEdgeLibrary | This is class SymBBAuto::McadEdgeLibrary.
McadEdgeLibraryObject | This is class SymBBAuto::McadEdgeLibraryObject.
McadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
McadFCFLibrary | This is class SymBBAuto::McadFCFLibrary.
McadFCFLibraryObject | This is class SymBBAuto::McadFCFLibraryObject.
McadFCFStandard | A feature control frame symbol standard
McadFeatureControlFrame | Implements feature control frame symbols.
McadFeatureIdentifier | A feature identifier symbol
McadIdentifier | Implements functionalty common to Datum Identifier symbols and Feature Identifier symbols.
McadIdentifierStandard | Defines the drafting standard settings for Datym and Feature Identifier symbols.
McadJoint | This is class SymBBAuto::McadJoint.
McadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
McadMarkStamp | A marking or stamping symbol
McadMarkStampStandard | A marking/stamping symbol standard
McadNote | This object represents the Note symbol created in the drawing.
McadNoteStandard | This object represents the Note symbol standard.
McadPartList | A part list symbol
McadPartListBalloonedFilter | A filter object that filters the contents of a parts List by ballooned parts.
McadPartListCustomFilter | A filter object that filters the contents of a parts list by a BOM property.
McadPartListFilter | An object that filters the contents of a parts list
McadPartListFilters | A collection of McadPartListFilter objects
McadPartListGOST | A part list object
McadPartLists | A collection of McadPartList objects
McadPartListStandard | The part list-specific information of a bill of materials symbol standard
McadPartListStdPartsFilter | A filter object that filters the contents of a parts list by Standard parts.
McadPartReference | A part reference symbol
McadPartReferences | This is class SymBBAuto::McadPartReferences.
McadRevisionList | This object represents the revision list created in the drawing. The interface is IMcadRevisionList.
McadRevisionListDescriptor | This object contains all data associated with a revision list.
McadRevisionLists | This object is a collection of revision list objects.
McadRevisionMgr | This object is used for general functionality of revision lists.
McadScaleArea | This object represents the scale area created in the model space.
McadScaleAreaMgr | This object is used to create and find a scale area in the model space.
McadSectionLine | The object represents the section line creating in the drawing.
McadSectionLineStandard | This object represents the standard.
McadStandard | This existing object represents the standard.
McadStandardMgr | The symbol standards manager object
McadStandards | A collection of McadStandard objects
McadSurfaceTexture | A surface texture symbol
McadSurfaceTextureLibrary | This is the object representing the surface texture library.
McadSurfaceTextureLibraryObject | Implements the IMcadSurfaceTextureLibraryObject interface.
McadSurfaceTextureStandard | A surface texture symbol standard
McadSymbol | A symbol object.
McadSymbolBBMgr | This existing object is the main manager object in SymBBAuto.
McadSymbolLibrary | Implements the IMcadSymbolLibrary interface.
McadSymbolLibraryObject | Implements the IMcadSymbolLibraryObject interface.
McadSymbolLibraryObjects | Implements the IMcadSymbolLibraryObjects interface.
McadSymbolStandard | A symbol standard.
McadSymbolStandards | A collection of McadSymbolStandard objects
McadTaper | This object represents the taper symbol created in the drawing.
McadTaperStandard | This object represents the Taper and Slope symbol standard.
McadTitle | This object represents the title block of the title/border created in the drawing.
McadTitleBorder | This object represents the title/border created in the drawing.
McadTitleBorderContext | This new object contains all option settings associated with a title/border.
McadTitleBorderDescriptor | This object contains all data associated with a title/border.
McadTitleBorderMgr | This object is used for general functionality for title/border.
McadTitleBorders | This object is a collection of title/border objects.
McadTitleBorderStandard | This object represents the Drawing Sheet standard element.
McadWelding | Implements weld symbols.
McadWeldingLibrary | Implements the IMcadWeldingLibraryObject interface.
McadWeldingLibraryObject | Implemented the IMcadWeldingLibraryObject.
McadWeldingStandard | A weld symbol standard.
Enumerations
Name | Description
McadAlignmentType | Enumerates all available alignment types for a drawing document element, such as captions and data in a column of a BOM database.
McadAnnotViewLabelPositionType | McadAnnotViewLabelPositionType defines position of annotation view label.
McadArrowType | Enumerates all available arrow types for a symbol leader. sbNoArrow : Indicates that no arrow is attached to the symbol leader. sbArrowOpen : Indicates that the open arrow is attached to the symbol leader. sbArrowOpen15 : Indicates that the open 15-degree arrow is attached to the symbol leader. sbArrowOpen30 : Indicates that the open 30-dergee arrow is attached to the symbol leader. sbArrowOpen60 : Indicates that the open 60-degree arrow is attached to the symbol leader. sbArrowOpen90 : Indicates that the open 90-degree arrow is attached to the symbol leader. sbArrowEmpty : Indicates that the empty arrow is attached to... more
McadAttachmentPoint | Enumerates all available points for attaching a leader to symbols. sbTopLeft : Places the leader to the top-left of symbols. sbBottomLeft : Places the leader to the bottom-left of symbols. sbBottomRight : Places the leader to the bottom-right of symbols. sbTopRight : Places the leader to the top-right of symbols.
McadAttachmentType | Enumerates all available leader attachment point types for symbols. sbToCenter : Attaches the leader to the center of symbols. sbToExtents : Attaches the leader to the extents of symbols. sbToOrigin : Attaches the leader to the origin of symbols in the coordinate system.
McadAttachPosition | This is record McadAttachPosition.
McadAttributeAssociativity | Enumerates all available behaviors of the attribute when the object that the attribute is attached to is copied. mcDefault : If the McadAttributeAssociativity element is not specified in pertinent methods, the default associativity behavior is used. mcCopyAlways : Indicates this attribute is always copied. mcShareAlways : Indicates this attribute is always shared. mcIgnoreAlways : Indicates this attribute is always ignored.
McadBalloonType | Enumerates all available balloon patterns that can be used to override when creating new balloon symbols by a specific standard. sbByStandardBalloon : Sets the standard option as the balloon pattern in a drawing document. The standard balloon is defined by the drawing manager. sbNoBalloon : Sets the open option as the balloon pattern in a drawing document. sbCircularBalloon : Sets the predefined Circular option as the balloon pattern in a drawing document. sbCircular2Balloon : Sets the predefined Circular2 option as the balloon pattern in a drawing document. sbLinearBalloon : Sets the predefined Linear option as the balloon pattern in a... more
McadBOMExportFormatType | Enumerates all available BOM table export formats. exTXT : Indicates the export format of text separated with tabulator. exCSV : Indicates the export format of text separated with semicolon. exHTML : Indicates the export format of HTML. exMDB : Indicates the export format of the current Microsoft Access. exMDB97 : Indicates the export format of Microsoft Access 97. exEXCEL97 : Indicates the export format of Microsoft Excel 97. exEXCEL95 : Indicates the export format of Microsoft Excel 95. exDB5 : Indicates the export format of dBase 5. exDBIV : Indicates the export format of dBase IV. exDBIII : Indicates the... more
McadBOMImportFormatType | Enumerates all available BOM table import formats. imMDB : Indicates the import format of the current Microsoft Access. imEXCEL97 : Indicates the import format of Microsoft Excel 97. imEXCEL95 : Indicates the import format of Microsoft Excel 95. imDB5 : Indicates the export format of dBase 5. imDBIV : Indicates the export format of dBase IV. imDBIII : Indicates the export format of dBase III. imimFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0. imFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6. imFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5. imTXT :... more
McadBOMItemDefinitionType | Enumerates all available BOM item definition types. Unknown : Indicates that the BOM item definition type is unknown. NonModal : Indicates that the BOM item definition type is User-Defined. PartRef : Indicates that the BOM item definition type is AutoCAD Mechanical Part Reference. BlockDef : Indicates that the BOM item definition type is Block Definition. CompDef : Indicates that the BOM item definition type is AutoCAD Mechanical/Mechanical Desktop Component Definition.
McadBomOverrideType | Enumerator for BOM override types.
McadBOMUOMType | Enumerates all available BOM UOM (Unit of Measurement) types. Each : Indicates that the BOM UOM type is per item. sqm : Indicates that the BOM UOM type is per each square meter. sqcm : Indicates that the BOM UOM type is per each square centimeter. sqft : Indicates that the BOM UOM type is per each square foot. sqin : Indicates that the BOM UOM type is per each square inch. gal : Indicates that the BOM UOM type is per gallon qt : Indicates that the BOM UOM type is per qt. lqd_oz : Indicates that the BOM... more
McadColumnSplitStyle | Enumerates all available column split styles for a Parts List. sbSplitRows : Specifies that a Parts List is split by rows in a column split. sbSplitSections : Specifies that a Parts List is split by sections in a column split.
McadColumnSplitWrap | Enumerates all available column split wrap directions for a Parts List. sbSplitLeft : Specifies that a Parts List wraps to the left in a column split. sbSplitRight : Specifies that a Parts List wraps to the right in a column split.
McadColumnType | Enumerates all column types available in this BOM database for drawing documents. This ColumnType element is the internal name of the column attribute. sbPartID : Specifies the object ID of this BOM item. sbItem : Specifies the item number for this BOM item. sbQuantity : Specifies the quantity of part references for this BOM item. sbPartListName : Specifies the parts list name that is created from this BOM database. sbPartListPath : Specifies the path to store the parts list that is created from this BOM database. sbDescription : Specifies the supplementary data for this BOM database. sbDescription2 : Specifies the... more
McadDataType | Enumerates all data types that can be used for columns in this BOM database. sbGeneralText : Sets the general text as the data type for columns in this BOM database. sbInteger : Sets Integer as the data type for columns in this BOM database. sbReal : Sets Real as the data type for columns in this BOM database.
McadDetailSymbolStandardPropType | Enumerates the property types for detail view standard that can be set to ByStandard.
McadDirectionLayType | Enumerates all available directions of machining lay specifications for a surface texture symbol in a drawing document. sbNotSpecified : No directions of machining lay specifications are available. sbParallelToPlane : Sets Parallel to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbPerpendicularToPlane : Sets Perpendicular to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbCrossedIn2SlantDirections : Sets Angular in Both Directions for the direction of machining lay specification of a surface texture symbol. sbMultiDirection : Sets Multidirectional for the direction of machining lay specification of a surface... more
McadEdgeRequirement | Enumerates all available requirements for Edge library object.
McadFCFRequirement | Enumerates all available requirements for FCF library object.
McadFilterOperator | Enumerates all available filter operator for a Parts List custom filter. sbContains : Specifies a "contains" operator. sbDoesNotCont : Specifies a "does not contain" operator. sbEqual : Specifies a "equal" operator. sbNotEqual : Specifies a "not equal" operator. sbLess : Specifies a "less than" operator sbGreater : Specifies a "greater than" operator. sbLessEqual : Specifies a "less than or equal" operator. sbGreaterEqual : Specifies a "greater than or equal" operator.
McadFilterType | Enumerates all available filter types for a Parts List. sbFilterBasic : Specifies a basic filter type for a Parts List. sbFilterBallooned : Specifies a filter that filters the contents of a Parts List by ballooned parts. sbFilterCustom : Specifies a filter that filters the contents of a Parts List by a BOM property. sbFilterParts : Specifies a filter that filters the contents of a Parts List by selected parts. sbFilterStdParts : Specifies a filter that filters the contents of a Parts List by Standard parts. sbFilterSheet : Specifies a filter that filters the contents of a Parts List by a... more
McadGDTSymbolType | Enumerates all symbol types available for a feature control frame symbol. All the enumeration symbol types can be rolled into two groups: Geometric Characteristic and Material Removal Modifier. sbStraightness : Sets Straightness as the GDT symbol type for a feature control frame symbol. sbFlatness : Sets Flatness as the GDT symbol type for a feature control frame symbol. sbCircularity : Sets Circularity as the GDT symbol type for a feature control frame symbol. sbCylindricity : Sets Cylindricity as the GDT symbol type for a feature control frame symbol. sbProfileLine : Sets Profile of a Line as the GDT symbol type... more
McadIdentificationType | Enumerates all available types of identification line used for a weld symbol. Identification lines are not available for ANSI standard. sbNoIdentificationLine : Places no identification line on either the arrow side or the other side for a weld symbol. sbIdentificationOtherSide : Places the identification line on the other side of the arrow. sbIdentificationArrowSide : Places the identification line on the arrow side.
McadIdentifierPositionType | Enumerates the identifier position type for section line.
McadJointType |
McadLineVisibility | Enumerates the available line visibility types.
McadNoteAttachPointType | Enumerates all available note attach point types.
McadNoteTemplateGroupType | Enumerator for note template group type.
McadOrientation | Enumerates all available orientations of welding symbol elements. sbLeftSide : Places a weld tail to the left of the arrow. sbRightSide : Places a weld tail to the right of the arrow. sbBelow : Place symbols on the arrow side upward the weld tail. sbAbove : Place symbols on the other side of the arrow upward the weld tail.
McadScaleType | Enumerator for scale type.
McadSectionLineSegmentType | Enumerates the available line segment types.
McadSectionLineStandardPropType | Enumerates the property types for section view standard, which can be set to ByStandard.
McadStdPartsFilterOption | Enumerates all available filter options for a Parts List Standard parts filter. sbStdPartsOnly : Specifies a Standard parts filter that filters the contents of a Parts List by Standard parts. sbExcludeStdParts : Specifies a Standard parts filter that filters the contents of a Parts List by non-Standard parts.
McadSurfaceTextureRequirement | Surface Texture Requirement information. sbSurfTextRaMax : Roughness value Ra sbSurfTextRaMin : Roughness value Ra - minimum sbSurfTextProduction : Production method sbSurfTextProduction2 : Production method sbSurfTextAllowance : Finish allowance sbSurfTextDirLay : Direction of lay sbSurfTextSampLength : Sampling length or waviness height sbSurfTextCutoff : Cutoff value and evaluation length sbSurfTextOtherValue : Other roughness value sbSurfTextOtherMin : Other roughness minimum value sbSurfTextMaxRspac : Maximum spacing sbSurfTextReference : Reference length and evaluation length sbSurfTextWavines : Surface waviness sbSurfTextComment : Comment sbSurfTextFirstRequirement : First requirement sbSurfTextSecondRequirement : Second requirement sbSurfTextThirdRequirement : Third requirement
McadSurfaceTextureType | Enumerates all available surface types for a surface texture symbol. sbBasic : Set the Basic surface type for a surface texture symbol. sbRemovalOfMaterialRequired : Set the Removal of Material Required surface type for a surface texture symbol. sbRemovalOfMaterialProhibited : Set the Removal of Material Prohibited surface type for a surface texture symbol. sbRemovalAllowanceSpecified : Set the Removal of Allowance Specified surface type for a surface texture symbol.
McadSymBBSymbolLibraryType | Enumerates the available Symbol Library Type.
McadTaperDimensionType | Enumerates the available taper dimension type.
McadTaperRatioFormatType | Enumerates the available ratio format type.
McadTaperSlopeSymType | Enumerator for taper slope symbol type.
McadTargetType | Enumerates all available termination types for a datum target symbol. sbNoTarget : Set the None termination type for a datum target symbol. sbBalloon : Not implemented yet. Set the None termination type for a datum target symbol. sbPoint : Set the None termination type for a datum target symbol. sbLine : Set the None termination type for a datum target symbol. sbCircular : Set the None termination type for a datum target symbol. sbRectangular : Set the None termination type for a datum target symbol. sbAttach : Set the None termination type for a datum target symbol.
McadTextControl | Enumerates all available text controls for a Parts List. sbNone : Specifies that a Parts List text is not controlled. The text overruns the column width when the length of the text exceeds the column width. sbFit : Specifies that a Parts List text fits within the column when the length of the text exceeds the column width. sbWrap : Specifies that a Parts List text wraps to the next line when the length of the text exceeds the column width.
McadUndefinedSize | Enumerates the undefined size's cases for edge symbol
McadUndefinedSizeDirection | Enumerates the undefined size's direction for edge symbol
McadViewDefLockType | Enumerates the lock type of the folder definition or component view definition in mechanical structure. mc2DSNoLock : Specifies no lock in mechanical structure. mc2DSXrefLock : Specifies the lock of the Xref objects in mechanical structure. mc2DSStdPartLock : Specifies the lock of standard parts in mechanical structure. mc2DSUserLock : Specifies the user-defined lock in mechanical structure.
McadWeldAssociation | Enumerates all available association types between two fillet weld symbols for the staggered weldment. sbNoAssociation : Sets no association. sbAssociationSpacer : Space the fillet symbols. sbAssociationMoveStagger : Staggers the fillet symbols. sbAssociationMirrorStagger : Mirrors the fillet symbols. sbAssociationSpecialStagger : Staggers the fillet symbols in a special way. sbAssociationBacking : Back the fillet symbols.
McadWeldingRequirement | Enumerates the available Weld requirements variable.
McadWeldSymbolType | Enumerates all available weld symbol types for a weld symbol standard. All the enumeration weld symbol types can be rolled into three groups: Weld Symbols, Contour Symbols, and Backing Symbols. A weld symbol type may use different signs in different standard, such as ANSI, BSI, and ISO. sbNoSymbol : Sets no weld symbol type for a weld symbol standard. sbFilletWeld : Sets the Fillet Weld symbol type for a weld symbol standard. Available for ANSI sbSecondaryFillet : Sets the Secondary Fillet Weld symbol type for a weld symbol standard. sbPlugWeld : Sets the Plug Weld symbol type for a weld... more
McadBalloonCollectionType | Enumerates all available alignment types of collected balloons for selected part references. The orientation of collected balloons depends on the position of the last leader segment. sbHorizontal : Aligns collected balloons horizontally. sbVertical : Aligns collected balloons vertically.
Group

API Reference

Interfaces
Name | Description
IMcadAnnotationViewLabel | Annotation view label entity.
IMcadAnnotationViewStandard | Annotation view label standard.
IMcadBalloon | A balloon symbol object.
IMcadBalloons | A collection of McadBalloon objects.
IMcadBalloonStandard | The balloon standards for a bill of materials symbol standard.
IMcadBalloonStandard2 | The balloon standards for a bill of materials symbol standard.
IMcadBOM | A bill of materials database object.
IMcadBOM2 | A bill of materials database object.
IMcadBOM3 | A bill of materials database object.
IMcadBOM4 | A bill of materials database object.
IMcadBOMItem | A bill of materials item or row object.
IMcadBOMItem2 | A bill of materials item or row object.
IMcadBOMItem3 | A bill of materials item or row object.
IMcadBOMItem4 | A bill of materials item, or row object.
IMcadBOMItems | A collection of McadBOMItem objects
IMcadBOMMgr | A bill of materials manager object
IMcadBOMMgr2 | A bill of materials manager object
IMcadBOMMgr3 | A bill of materials manager object.
IMcadBOMMgr4 | A bill of materials manager object.
IMcadBOMs | A collection of McadBOM objects
IMcadBOMStandard | A bill of materials symbol standard object
IMcadBOMStandard2 | A bill of materials symbol standard object
IMcadBorder | This object represents the drawing border of the title/border created in the drawing.
IMcadColumnDefinition | Stores the BOM column definition information.
IMcadColumnDefinition2 | Stores the BOM column definition information.
IMcadColumnDefinition3 | Stores the BOM column definition information.
IMcadColumnDefinitions | A collection of McadColumnDefinition objects
IMcadDatumIdentifier | Implements datum identifier symbols.
IMcadDatumStandard | A datum target symbol standard
IMcadDatumStandard2 | A datum target symbol standard
IMcadDatumTarget | A datum target symbol
IMcadDatumTarget2 | A datum target symbol.
IMcadDetailSymbol | This object represents the detail symbol created in the drawing.
IMcadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
IMcadDetailSymbolStandard | This object represents the Detail symbol standard.
IMcadDetailSymbolStandard2 | This interface is derived from IMcadDetailSymbolStandard. It is used for the detail view standard.
IMcadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
IMcadEdge | This object represents the edge symbol created in the drawing.
IMcadEdgeLibrary | The object representing Edge library.
IMcadEdgeLibraryObject | The Edge library object.
IMcadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
IMcadFCFLibrary | Object representing the Feature Control Frame library.
IMcadFCFLibraryObject | The Feature Control Frame library object.
IMcadFCFStandard | A feature control frame symbol standard
IMcadFeatureControlFrame | Implemets feature control frame symbols.
IMcadFeatureControlFrame2 | IMcadFeatureControlFrame extended interface.
IMcadFeatureIdentifier | A feature identifier symbol.
IMcadIdentifier | An identifier symbol
IMcadIdentifierStandard | An identifier symbol standard
IMcadJoint | The IMcadJoint interface.
IMcadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
IMcadMarkStamp | Interface for working with the Marking/Stamping symbol created in the drawing.
IMcadMarkStampStandard | Interface for working with the Marking/Stamping symbol standard.
IMcadNote | This object represents the Note symbol created in the drawing.
IMcadNoteStandard | This object represents the Note symbol standard.
IMcadPartList | A part list symbol.
IMcadPartList2 | A part list symbol.
IMcadPartList3 | Stores the Parts List symbol settings information.
IMcadPartListBalloonedFilter | A filter object that filters the contents of a Parts List by ballooned parts.
IMcadPartListCustomFilter | A filter object that filters the contents of a Parts List by a BOM property.
IMcadPartListFilter | An object that filters the contents of a parts list.
IMcadPartListFilter2 | An object that filters the contents of a parts list.
IMcadPartListFilters | A collection of McadPartListFilter objects
IMcadPartListGOST | Interface for interacting with the GOST part list created in the drawing.
IMcadPartLists | A collection of McadPartList objects
IMcadPartListStandard | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard2 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard3 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard4 | Stores the Parts List standard setting information.
IMcadPartListStdPartsFilter | A filter object that filters the contents of a Parts List by Standard parts.
IMcadPartReference | A part reference symbol.
IMcadPartReference2 | A part reference symbol.
IMcadPartReference3 | A part reference symbol.
IMcadRevisionList | Interface that represents the revision list created in the drawing.
IMcadRevisionListDescriptor | Interface for interacting with all data associated with a revision list.
IMcadRevisionLists | Interface for working with a collection of revision list objects.
IMcadRevisionMgr | Interface for working with the general functionality of a revision list.
IMcadScaleArea | This object represents the scale area created in the model space.
IMcadScaleAreaMgr | This object is used to create and find a scale area in the modelspace.
IMcadSectionLine | The object represents the section line creating in the drawing.
IMcadSectionLineStandard | Interface for working with the standard.
IMcadSectionLineStandard2 | This interface is derived from IMcadSectionLineStandard. It is for the section view standard.
IMcadStandard | This existing object represents the standard.
IMcadStandard2 | This existing object represents the standard.
IMcadStandard3 | This existing object represents the standard.
IMcadStandard4 | This existing object represents the standard.
IMcadStandardMgr | The symbol standards manager object
IMcadStandards | A collection of McadStandard objects
IMcadSurfaceTexture | A surface texture symbol
IMcadSurfaceTexture2 | A surface texture symbol.
IMcadSurfaceTexture4 | A surface texture symbol.
IMcadSurfaceTextureLibrary | This object represents the surface texture library.
IMcadSurfaceTextureLibraryObject | The IMcadSurfaceTextureLibraryObject interface.
IMcadSurfaceTextureStandard | A surface texture symbol standard
IMcadSurfaceTextureStandard2 | A surface texture symbol standard.
IMcadSurfaceTextureStandard3 | A surface texture symbol standard.
IMcadSymbol | A symbol object.
IMcadSymbol2 | A symbol object.
IMcadSymbolBBMgr | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr2 | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr3 | This object is the main manager object in SymBBAuto.
IMcadSymbolLibrary | The IMcadSymbolLibrary interface. The grouping of library object is based on the combination of standard and standard revision type. In each group, there is only one default.
IMcadSymbolLibraryObject | Represents the library of symbol objects.
IMcadSymbolLibraryObjects | The IMcadSymbolLibrary Objects interface.
IMcadSymbolStandard | A symbol standard.
IMcadSymbolStandard2 | A symbol standard.
IMcadSymbolStandard3 | A symbol standard.
IMcadSymbolStandards | A collection of McadSymbolStandard objects
IMcadTaper | This object represents the taper symbol created in the drawing.
IMcadTaperStandard | This object represents the Taper and Slope symbol standard.
IMcadTaperStandard2 | This object represents the Taper and Slope symbol standard.
IMcadTitle | This object represents the title block of the title/border created in the drawing.
IMcadTitle2 | This is class IMcadTitle2.
IMcadTitleBorder | This object represents the title/border created in the drawing.
IMcadTitleBorderContext | This new object contains all option settings associated with a title/border.
IMcadTitleBorderDescriptor | This object contains all data associated with a title/border.
IMcadTitleBorderMgr | This object is used for general functionality for title/border.
IMcadTitleBorders | This object is a collection of title/border objects.
IMcadTitleBorderStandard | This object represents the Drawing Sheet standard element.
IMcadTitleBorderStandard2 | This is class IMcadTitleBorderStandard2.
IMcadTransaction | The McadTransaction object.
IMcadWelding | A weld symbol object
IMcadWelding2 | This is class IMcadWelding2.
IMcadWeldingLibrary | The IMcadWeldingLibrary interface.
IMcadWeldingLibraryObject | The IMcadWeldingLibraryObject interface.
IMcadWeldingStandard | A weld symbol standard.
IMcadWeldingStandard2 | A weld symbol standard.
IMcadWeldingStandard3 | Use this class to handle settings to weld symbols in current standard.
IMcadBorder2 | This is class IMcadBorder2.
IMcadDatumIdentifier2 | This is class IMcadDatumIdentifier2.
IMcadDatumIdentifier3 | This is class IMcadDatumIdentifier3.
IMcadFCFStandard2 | This is class IMcadFCFStandard2.
IMcadFeatureControlFrame3 | This is class IMcadFeatureControlFrame3.
IMcadFeatureControlFrame4 | This is class IMcadFeatureControlFrame4.
IMcadFeatureIdentifier2 | This is class IMcadFeatureIdentifier2.
IMcadIdentifierStandard2 | This is class IMcadIdentifierStandard2.
IMcadPartReferences | This is class IMcadPartReferences.
IMcadSurfaceTexture3 | This is class IMcadSurfaceTexture3.
Links
CoClasses, Enumerations, API Reference, Interfaces, Legend


McadAnnotationViewLabel CoClass

You are here: API Reference > SymBBAuto Library > McadAnnotationViewLabel CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAnnotationViewLabel CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Annotation view label entity.

Class Hierarchy

Declaration syntax

SymBBAuto::McadAnnotationViewLabel
Visual Basic
Public Class McadAnnotationViewLabel
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadAnnotationViewStandard CoClass

You are here: API Reference > SymBBAuto Library > McadAnnotationViewStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAnnotationViewStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Annotation view label standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadAnnotationViewStandard
Visual Basic
Public Class McadAnnotationViewStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBalloon CoClass

You are here: API Reference > SymBBAuto Library > McadBalloon CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBalloon CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A balloon symbol object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloon
Visual Basic
Public Class McadBalloon
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBalloons CoClass

You are here: API Reference > SymBBAuto Library > McadBalloons CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBalloons CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBalloon objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloons
Visual Basic
Public Class McadBalloons
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBalloonStandard CoClass

You are here: API Reference > SymBBAuto Library > McadBalloonStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBalloonStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBalloonStandard
Visual Basic
Public Class McadBalloonStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOM CoClass

You are here: API Reference > SymBBAuto Library > McadBOM CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOM CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOM
Visual Basic
Public Class McadBOM
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOMItem CoClass

You are here: API Reference > SymBBAuto Library > McadBOMItem CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMItem CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials item or row object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMItem
Visual Basic
Public Class McadBOMItem
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOMItems CoClass

You are here: API Reference > SymBBAuto Library > McadBOMItems CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMItems CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBOMItem objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMItems
Visual Basic
Public Class McadBOMItems
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOMMgr CoClass

You are here: API Reference > SymBBAuto Library > McadBOMMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMMgr
Visual Basic
Public Class McadBOMMgr
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOMs CoClass

You are here: API Reference > SymBBAuto Library > McadBOMs CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMs CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBOM objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMs
Visual Basic
Public Class McadBOMs
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBOMStandard CoClass

You are here: API Reference > SymBBAuto Library > McadBOMStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

SymBBAuto::McadBOMStandard
Visual Basic
Public Class McadBOMStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadBorder CoClass

You are here: API Reference > SymBBAuto Library > McadBorder CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBorder CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the drawing border of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadBorder
Visual Basic
Public Class McadBorder
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadColumnDefinition CoClass

You are here: API Reference > SymBBAuto Library > McadColumnDefinition CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadColumnDefinition CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

SymBBAuto::McadColumnDefinition
Visual Basic
Public Class McadColumnDefinition
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadColumnDefinitions CoClass

You are here: API Reference > SymBBAuto Library > McadColumnDefinitions CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadColumnDefinitions CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadColumnDefinition objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadColumnDefinitions
Visual Basic
Public Class McadColumnDefinitions
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDatumIdentifier CoClass

You are here: API Reference > SymBBAuto Library > McadDatumIdentifier CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDatumIdentifier CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements datum identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumIdentifier
Visual Basic
Public Class McadDatumIdentifier
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDatumStandard CoClass

You are here: API Reference > SymBBAuto Library > McadDatumStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDatumStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumStandard
Visual Basic
Public Class McadDatumStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDatumTarget CoClass

You are here: API Reference > SymBBAuto Library > McadDatumTarget CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDatumTarget CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadDatumTarget
Visual Basic
Public Class McadDatumTarget
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDetailSymbol CoClass

You are here: API Reference > SymBBAuto Library > McadDetailSymbol CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDetailSymbol CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the detail symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbol
Visual Basic
Public Class McadDetailSymbol
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDetailSymbolLabel CoClass

You are here: API Reference > SymBBAuto Library > McadDetailSymbolLabel CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDetailSymbolLabel CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the detail symbol label created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbolLabel
Visual Basic
Public Class McadDetailSymbolLabel
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadDetailSymbolStandard CoClass

You are here: API Reference > SymBBAuto Library > McadDetailSymbolStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDetailSymbolStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Detail symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadDetailSymbolStandard
Visual Basic
Public Class McadDetailSymbolStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadEdge CoClass

You are here: API Reference > SymBBAuto Library > McadEdge CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEdge CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the edge symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdge
Visual Basic
Public Class McadEdge
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadEdgeLibrary CoClass

You are here: API Reference > SymBBAuto Library > McadEdgeLibrary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEdgeLibrary CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadEdgeLibrary.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeLibrary
Visual Basic
Public Class McadEdgeLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadEdgeLibraryObject CoClass

You are here: API Reference > SymBBAuto Library > McadEdgeLibraryObject CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEdgeLibraryObject CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadEdgeLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeLibraryObject
Visual Basic
Public Class McadEdgeLibraryObject
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadEdgeStandard CoClass

You are here: API Reference > SymBBAuto Library > McadEdgeStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEdgeStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the edge symbol standard, Edges of Workpieces standard element.

Class Hierarchy

Declaration syntax

SymBBAuto::McadEdgeStandard
Visual Basic
Public Class McadEdgeStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFCFLibrary CoClass

You are here: API Reference > SymBBAuto Library > McadFCFLibrary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFCFLibrary CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadFCFLibrary.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFLibrary
Visual Basic
Public Class McadFCFLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFCFLibraryObject CoClass

You are here: API Reference > SymBBAuto Library > McadFCFLibraryObject CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFCFLibraryObject CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadFCFLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFLibraryObject
Visual Basic
Public Class McadFCFLibraryObject
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFCFStandard CoClass

You are here: API Reference > SymBBAuto Library > McadFCFStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFCFStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A feature control frame symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadFCFStandard
Visual Basic
Public Class McadFCFStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFeatureControlFrame CoClass

You are here: API Reference > SymBBAuto Library > McadFeatureControlFrame CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFeatureControlFrame CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements feature control frame symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadFeatureControlFrame
Visual Basic
Public Class McadFeatureControlFrame
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadFeatureIdentifier CoClass

You are here: API Reference > SymBBAuto Library > McadFeatureIdentifier CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFeatureIdentifier CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A feature identifier symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadFeatureIdentifier
Visual Basic
Public Class McadFeatureIdentifier
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadIdentifier CoClass

You are here: API Reference > SymBBAuto Library > McadIdentifier CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadIdentifier CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements functionalty common to Datum Identifier symbols and Feature Identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadIdentifier
Visual Basic
Public Class McadIdentifier
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadIdentifierStandard CoClass

You are here: API Reference > SymBBAuto Library > McadIdentifierStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadIdentifierStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Defines the drafting standard settings for Datym and Feature Identifier symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadIdentifierStandard
Visual Basic
Public Class McadIdentifierStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadJoint CoClass

You are here: API Reference > SymBBAuto Library > McadJoint CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadJoint CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadJoint.

Class Hierarchy

Declaration syntax

SymBBAuto::McadJoint
Visual Basic
Public Class McadJoint
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadJointStandard CoClass

You are here: API Reference > SymBBAuto Library > McadJointStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadJointStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents a Dead Joint symbol standard created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadJointStandard
Visual Basic
Public Class McadJointStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadMarkStamp CoClass

You are here: API Reference > SymBBAuto Library > McadMarkStamp CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadMarkStamp CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A marking or stamping symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadMarkStamp
Visual Basic
Public Class McadMarkStamp
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadMarkStampStandard CoClass

You are here: API Reference > SymBBAuto Library > McadMarkStampStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadMarkStampStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A marking/stamping symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadMarkStampStandard
Visual Basic
Public Class McadMarkStampStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadNote CoClass

You are here: API Reference > SymBBAuto Library > McadNote CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadNote CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Note symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadNote
Visual Basic
Public Class McadNote
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadNoteStandard CoClass

You are here: API Reference > SymBBAuto Library > McadNoteStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadNoteStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Note symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadNoteStandard
Visual Basic
Public Class McadNoteStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartList CoClass

You are here: API Reference > SymBBAuto Library > McadPartList CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartList CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part list symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartList
Visual Basic
Public Class McadPartList
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListBalloonedFilter CoClass

You are here: API Reference > SymBBAuto Library > McadPartListBalloonedFilter CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListBalloonedFilter CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a parts List by ballooned parts.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListBalloonedFilter
Visual Basic
Public Class McadPartListBalloonedFilter
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListCustomFilter CoClass

You are here: API Reference > SymBBAuto Library > McadPartListCustomFilter CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListCustomFilter CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a parts list by a BOM property.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListCustomFilter
Visual Basic
Public Class McadPartListCustomFilter
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListFilter CoClass

You are here: API Reference > SymBBAuto Library > McadPartListFilter CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListFilter CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

An object that filters the contents of a parts list

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListFilter
Visual Basic
Public Class McadPartListFilter
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListFilters CoClass

You are here: API Reference > SymBBAuto Library > McadPartListFilters CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListFilters CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadPartListFilter objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListFilters
Visual Basic
Public Class McadPartListFilters
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListGOST CoClass

You are here: API Reference > SymBBAuto Library > McadPartListGOST CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListGOST CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part list object

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListGOST
Visual Basic
Public Class McadPartListGOST
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartLists CoClass

You are here: API Reference > SymBBAuto Library > McadPartLists CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartLists CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadPartList objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartLists
Visual Basic
Public Class McadPartLists
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListStandard CoClass

You are here: API Reference > SymBBAuto Library > McadPartListStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

The part list-specific information of a bill of materials symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListStandard
Visual Basic
Public Class McadPartListStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartListStdPartsFilter CoClass

You are here: API Reference > SymBBAuto Library > McadPartListStdPartsFilter CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartListStdPartsFilter CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a parts list by Standard parts.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartListStdPartsFilter
Visual Basic
Public Class McadPartListStdPartsFilter
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartReference CoClass

You are here: API Reference > SymBBAuto Library > McadPartReference CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartReference CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part reference symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartReference
Visual Basic
Public Class McadPartReference
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadPartReferences CoClass

You are here: API Reference > SymBBAuto Library > McadPartReferences CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadPartReferences CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class SymBBAuto::McadPartReferences.

Class Hierarchy

Declaration syntax

SymBBAuto::McadPartReferences
Visual Basic
Public Class McadPartReferences
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadRevisionList CoClass

You are here: API Reference > SymBBAuto Library > McadRevisionList CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadRevisionList CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the revision list created in the drawing. The interface is IMcadRevisionList.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionList
Visual Basic
Public Class McadRevisionList
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadRevisionListDescriptor CoClass

You are here: API Reference > SymBBAuto Library > McadRevisionListDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadRevisionListDescriptor CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object contains all data associated with a revision list.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionListDescriptor
Visual Basic
Public Class McadRevisionListDescriptor
Remarks

The interface is IMcadRevisionListDescriptor.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadRevisionLists CoClass

You are here: API Reference > SymBBAuto Library > McadRevisionLists CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadRevisionLists CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is a collection of revision list objects.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionLists
Visual Basic
Public Class McadRevisionLists
Remarks

The interface is IMcadRevisionLists.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadRevisionMgr CoClass

You are here: API Reference > SymBBAuto Library > McadRevisionMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadRevisionMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is used for general functionality of revision lists.

Class Hierarchy

Declaration syntax

SymBBAuto::McadRevisionMgr
Visual Basic
Public Class McadRevisionMgr
Remarks

The interface is IMcadRevisionMgr.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadScaleArea CoClass

You are here: API Reference > SymBBAuto Library > McadScaleArea CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadScaleArea CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the scale area created in the model space.

Class Hierarchy

Declaration syntax

SymBBAuto::McadScaleArea
Visual Basic
Public Class McadScaleArea
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadScaleAreaMgr CoClass

You are here: API Reference > SymBBAuto Library > McadScaleAreaMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadScaleAreaMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is used to create and find a scale area in the model space.

Class Hierarchy

Declaration syntax

SymBBAuto::McadScaleAreaMgr
Visual Basic
Public Class McadScaleAreaMgr
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSectionLine CoClass

You are here: API Reference > SymBBAuto Library > McadSectionLine CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSectionLine CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

The object represents the section line creating in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSectionLine
Visual Basic
Public Class McadSectionLine
Remarks

The interface is IMcadSectionLine.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSectionLineStandard CoClass

You are here: API Reference > SymBBAuto Library > McadSectionLineStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSectionLineStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSectionLineStandard
Visual Basic
Public Class McadSectionLineStandard
Remarks

The interface is IMcadSectionLineStandard.

In the extended interface, IMcadStandard3, add the property to get the new section line standard.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadStandard CoClass

You are here: API Reference > SymBBAuto Library > McadStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandard
Visual Basic
Public Class McadStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadStandardMgr CoClass

You are here: API Reference > SymBBAuto Library > McadStandardMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadStandardMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

The symbol standards manager object

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandardMgr
Visual Basic
Public Class McadStandardMgr
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadStandards CoClass

You are here: API Reference > SymBBAuto Library > McadStandards CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadStandards CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadStandard objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadStandards
Visual Basic
Public Class McadStandards
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSurfaceTexture CoClass

You are here: API Reference > SymBBAuto Library > McadSurfaceTexture CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTexture CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTexture
Visual Basic
Public Class McadSurfaceTexture
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSurfaceTextureLibrary CoClass

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureLibrary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTextureLibrary CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is the object representing the surface texture library.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureLibrary
Visual Basic
Public Class McadSurfaceTextureLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSurfaceTextureLibraryObject CoClass

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureLibraryObject CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTextureLibraryObject CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements the IMcadSurfaceTextureLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureLibraryObject
Visual Basic
Public Class McadSurfaceTextureLibraryObject
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSurfaceTextureStandard CoClass

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTextureStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol standard

Class Hierarchy

Declaration syntax

SymBBAuto::McadSurfaceTextureStandard
Visual Basic
Public Class McadSurfaceTextureStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbol CoClass

You are here: API Reference > SymBBAuto Library > McadSymbol CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbol CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol object.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbol
Visual Basic
Public Class McadSymbol
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolBBMgr CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolBBMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolBBMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolBBMgr
Visual Basic
Public Class McadSymbolBBMgr
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolLibrary CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolLibrary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolLibrary CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements the IMcadSymbolLibrary interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibrary
Visual Basic
Public Class McadSymbolLibrary
Remarks

The grouping of library objects is based on the combination of standard and standard revision.

In each group, there is one default. For legacy objects, e.g. welding symbol library, the standard revision is not defined.

Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolLibraryObject CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolLibraryObject CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolLibraryObject CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements the IMcadSymbolLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibraryObject
Visual Basic
Public Class McadSymbolLibraryObject
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolLibraryObjects CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolLibraryObjects CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolLibraryObjects CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements the IMcadSymbolLibraryObjects interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolLibraryObjects
Visual Basic
Public Class McadSymbolLibraryObjects
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolStandard CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolStandard
Visual Basic
Public Class McadSymbolStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadSymbolStandards CoClass

You are here: API Reference > SymBBAuto Library > McadSymbolStandards CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymbolStandards CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadSymbolStandard objects

Class Hierarchy

Declaration syntax

SymBBAuto::McadSymbolStandards
Visual Basic
Public Class McadSymbolStandards
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTaper CoClass

You are here: API Reference > SymBBAuto Library > McadTaper CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTaper CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the taper symbol created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTaper
Visual Basic
Public Class McadTaper
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTaperStandard CoClass

You are here: API Reference > SymBBAuto Library > McadTaperStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTaperStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTaperStandard
Visual Basic
Public Class McadTaperStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitle CoClass

You are here: API Reference > SymBBAuto Library > McadTitle CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitle CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the title block of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitle
Visual Basic
Public Class McadTitle
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorder CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorder CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorder CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the title/border created in the drawing.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorder
Visual Basic
Public Class McadTitleBorder
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorderContext CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorderContext CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorderContext CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This new object contains all option settings associated with a title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderContext
Visual Basic
Public Class McadTitleBorderContext
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorderDescriptor CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorderDescriptor CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorderDescriptor CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object contains all data associated with a title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderDescriptor
Visual Basic
Public Class McadTitleBorderDescriptor
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorderMgr CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorderMgr CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorderMgr CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is used for general functionality for title/border.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderMgr
Visual Basic
Public Class McadTitleBorderMgr
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorders CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorders CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorders CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is a collection of title/border objects.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorders
Visual Basic
Public Class McadTitleBorders
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadTitleBorderStandard CoClass

You are here: API Reference > SymBBAuto Library > McadTitleBorderStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTitleBorderStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Drawing Sheet standard element.

Class Hierarchy

Declaration syntax

SymBBAuto::McadTitleBorderStandard
Visual Basic
Public Class McadTitleBorderStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadWelding CoClass

You are here: API Reference > SymBBAuto Library > McadWelding CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWelding CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements weld symbols.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWelding
Visual Basic
Public Class McadWelding
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadWeldingLibrary CoClass

You are here: API Reference > SymBBAuto Library > McadWeldingLibrary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldingLibrary CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements the IMcadWeldingLibraryObject interface.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingLibrary
Visual Basic
Public Class McadWeldingLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadWeldingLibraryObject CoClass

You are here: API Reference > SymBBAuto Library > McadWeldingLibraryObject CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldingLibraryObject CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implemented the IMcadWeldingLibraryObject.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingLibraryObject
Visual Basic
Public Class McadWeldingLibraryObject
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


McadWeldingStandard CoClass

You are here: API Reference > SymBBAuto Library > McadWeldingStandard CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldingStandard CoClass
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

SymBBAuto::McadWeldingStandard
Visual Basic
Public Class McadWeldingStandard
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadAnnotationViewLabel Interface

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel Interface
IMcadAnnotationViewLabel Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Annotation view label entity.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel
Visual Basic
Public Interface IMcadAnnotationViewLabel
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadAnnotationViewLabel Members, SymBBAuto Library, Class Hierarchy


IMcadAnnotationViewLabel Members

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel Members
IMcadAnnotationViewLabel Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAnnotationViewLabel.

Interface

IMcadAnnotationViewLabel Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelPattern | Property that returns/sets label pattern of annotation view label entity.
LabelText | Property that returns evaluated text defined by label pattern, this text is displayed by annotation view label entity.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadAnnotationViewLabel Interface, Legend, Methods, Properties


IMcadAnnotationViewLabel::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel::LabelPattern Property
IMcadAnnotationViewLabel Interface IMcadAnnotationViewLabel Members IMcadAnnotationViewLabel Interface Send Feedback
Summary

Property that returns/sets label pattern of annotation view label entity.

Visual Basic
Property LabelPattern() As String
Remarks

Label pattern supports variables. List of variables supported by annotation view label standard is accessible by McadAnnotationViewStandard::LabelPatternVariables property.

Interface

IMcadAnnotationViewLabel Interface

Links
IMcadAnnotationViewLabel Interface, IMcadAnnotationViewLabel Members, IMcadAnnotationViewLabel Interface


IMcadAnnotationViewLabel::LabelText Property

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel::LabelText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel::LabelText Property
IMcadAnnotationViewLabel Interface IMcadAnnotationViewLabel Members IMcadAnnotationViewLabel Interface Send Feedback
Summary

Property that returns evaluated text defined by label pattern, this text is displayed by annotation view label entity.

Visual Basic
Property LabelText() As BSTR*
Interface

IMcadAnnotationViewLabel Interface

Links
IMcadAnnotationViewLabel Interface, IMcadAnnotationViewLabel Members, IMcadAnnotationViewLabel Interface


IMcadAnnotationViewStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard Interface
IMcadAnnotationViewStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Annotation view label standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard
Visual Basic
Public Interface IMcadAnnotationViewStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadAnnotationViewStandard Members, SymBBAuto Library, Class Hierarchy


IMcadAnnotationViewStandard Members

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard Members
IMcadAnnotationViewStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadAnnotationViewStandard.

Interface

IMcadAnnotationViewStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LabelPattern | Property that returns/sets default label pattern of annotation view label entity.
LabelPatternVariables | Property that returns array of variables supported in label pattern.
LabelPosition | Property that specifies position of annotation view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadAnnotationViewStandard Interface, Legend, Methods, Properties


IMcadAnnotationViewStandard::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard::LabelPattern Property
IMcadAnnotationViewStandard Interface IMcadAnnotationViewStandard Members IMcadAnnotationViewStandard Interface Send Feedback
Summary

Property that returns/sets default label pattern of annotation view label entity.

Visual Basic
Property LabelPattern() As String
Remarks

Label pattern supports variables. List of variables supported by standard is accessible by McadAnnotationViewStandard::LabelPatternVariables property.

Interface

IMcadAnnotationViewStandard Interface

Links
IMcadAnnotationViewStandard Interface, IMcadAnnotationViewStandard Members, IMcadAnnotationViewStandard Interface


IMcadAnnotationViewStandard::LabelPatternVariables Property

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard::LabelPatternVariables Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard::LabelPatternVariables Property
IMcadAnnotationViewStandard Interface IMcadAnnotationViewStandard Members IMcadAnnotationViewStandard Interface Send Feedback
Summary

Property that returns array of variables supported in label pattern.

Visual Basic
Property LabelPatternVariables() As VARIANT*
Remarks

Here is the default list of supported variables:

  • evaluates to component name of annotation view
  • evaluates to the name of annotation view sub view with attached label
  • evaluates to scale of annotation view sub view with attached label
  • evaluates to scale of annotation view
Interface

IMcadAnnotationViewStandard Interface

Links
IMcadAnnotationViewStandard Interface, IMcadAnnotationViewStandard Members, IMcadAnnotationViewStandard Interface


IMcadAnnotationViewStandard::LabelPosition Property

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard::LabelPosition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard::LabelPosition Property
IMcadAnnotationViewStandard Interface IMcadAnnotationViewStandard Members IMcadAnnotationViewStandard Interface Send Feedback
Summary

Property that specifies position of annotation view label.

Visual Basic
Property LabelPosition() As McadAnnotViewLabelPositionType
Remarks

Annotation view label can be placed below or above of annotation view sub view.

Interface

IMcadAnnotationViewStandard Interface

Links
IMcadAnnotationViewStandard Interface, IMcadAnnotationViewStandard Members, IMcadAnnotationViewStandard Interface


IMcadBalloon Interface

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon Interface
IMcadBalloon Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A balloon symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadBalloon
Visual Basic
Public Interface IMcadBalloon
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadBalloon Members, SymBBAuto Library, Class Hierarchy


IMcadBalloon Members

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon Members
IMcadBalloon Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBalloon.

Interface

IMcadBalloon Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AppendBOMItem | Appends the specified BOM item to the collection of items referenced by this balloon.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveBOMItem | Removes the specified bill of materials item from the collection of items referenced by this balloon.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentType | Specifies the leader attachment point type for balloons created by a specific balloon standard.
BalloonType | Specifies the default pattern of balloons created by a specific standard.
BOM | Specifies the bill of materials table referenced by a specific balloon.
BOMItems | Specifies the collection of bill of material items referenced by a specific balloon.
CollectionType | Specifies the alignment type of the balloon's collection.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlock | Specifies the custom block used by a specific balloon.
CustomBlockName | Specifies the name of the custom block used by a specific balloon.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether a specific balloon is displayed using a custom block, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadBalloon Interface, Legend, Methods, Properties


IMcadBalloon::AttachmentType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::AttachmentType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::AttachmentType Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the leader attachment point type for balloons created by a specific balloon standard.

Visual Basic
Property AttachmentType() As McadAttachmentType
Remarks

This property is a McadAttachmentType enumeration.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::BalloonType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::BalloonType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::BalloonType Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the default pattern of balloons created by a specific standard.

Visual Basic
Property BalloonType() As McadBalloonType
Remarks

This property is a McadBalloonType enumeration.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::BOM Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::BOM Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::BOM Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the bill of materials table referenced by a specific balloon.

Visual Basic
Property BOM() As IMcadBOM**
Remarks

This property is a McadBOM collection.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::BOMItems Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::BOMItems Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::BOMItems Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the collection of bill of material items referenced by a specific balloon.

Visual Basic
Property BOMItems() As IMcadBOMItems*
Remarks

This property is a McadBOMItems object.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::CollectionType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::CollectionType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::CollectionType Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the alignment type of the balloon's collection.

Visual Basic
Property CollectionType() As McadBalloonCollectionType
Remarks

This property affects the display orientation of the balloons when this balloon references multiple items. Valid alignment types include:

  • sbHorizontal: Sets the alignment of the specific collected balloons to be horizontal.
  • sbVertical: Sets the alignment of the specific collected balloons to be vertical.

This property is a McadBalloonCollectionType enumeration.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::CustomBlock Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::CustomBlock Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::CustomBlock Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the custom block used by a specific balloon.

Visual Basic
Property CustomBlock() As IAcadBlock*
Remarks

This property is a cadBlock object.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::CustomBlockName Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::CustomBlockName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::CustomBlockName Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Specifies the name of the custom block used by a specific balloon.

Visual Basic
Property CustomBlockName() As String
Returns

String

Remarks

An empty string, "", is used to indicate to use the standard display.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::IsCustomBlockUsed Property

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::IsCustomBlockUsed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::IsCustomBlockUsed Property
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Gets whether a specific balloon is displayed using a custom block, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

Boolean

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::AppendBOMItem Method

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::AppendBOMItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::AppendBOMItem Method
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Appends the specified BOM item to the collection of items referenced by this balloon.

Visual Basic
Sub AppendBOMItem(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the bill of materials item to append to the collected balloon.
Returns

None

Remarks

You should not call this method more than once when creating a new AcmBalloon object. You should also not call it when editing an existing AcmBalloon object.

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloon::RemoveBOMItem Method

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon::RemoveBOMItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon::RemoveBOMItem Method
IMcadBalloon Interface IMcadBalloon Members IMcadBalloon Interface Send Feedback
Summary

Removes the specified bill of materials item from the collection of items referenced by this balloon.

Visual Basic
Sub RemoveBOMItem(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBalloon Object ; input-only. Specifies the bill of materials item to be removed from the collected balloon.
Returns

None

Interface

IMcadBalloon Interface

Links
IMcadBalloon Interface, IMcadBalloon Members, IMcadBalloon Interface


IMcadBalloons Interface

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons Interface
IMcadBalloons Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBalloon objects.

Class Hierarchy

Declaration syntax

IMcadBalloons
Visual Basic
Public Interface IMcadBalloons
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBalloons Members, SymBBAuto Library, Class Hierarchy


IMcadBalloons Members

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons Members
IMcadBalloons Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBalloons.

Interface

IMcadBalloons Interface

Methods
Name | Description
Add | Appends a new balloon to the collection.
Item | Gets the specific balloon from the collection.
Remove | Removes the specified balloon from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of balloons in the collection.
Links
IMcadBalloons Interface, Legend, Methods, Properties


IMcadBalloons::Application Property

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons::Application Property
IMcadBalloons Interface IMcadBalloons Members IMcadBalloons Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadBalloons Interface

Links
IMcadBalloons Interface, IMcadBalloons Members, IMcadBalloons Interface


IMcadBalloons::Count Property

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons::Count Property
IMcadBalloons Interface IMcadBalloons Members IMcadBalloons Interface Send Feedback
Summary

Gets the total number of balloons in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadBalloons Interface

Links
IMcadBalloons Interface, IMcadBalloons Members, IMcadBalloons Interface


IMcadBalloons::Add Method

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons::Add Method
IMcadBalloons Interface IMcadBalloons Members IMcadBalloons Interface Send Feedback
Summary

Appends a new balloon to the collection.

Visual Basic
Sub Add(Item As IMcadBalloon)
Parameters
Parameters | Description
Item | McadBalloon object; input-only. Specifies the balloon to add to the collection.
Returns

None

Interface

IMcadBalloons Interface

Links
IMcadBalloons Interface, IMcadBalloons Members, IMcadBalloons Interface


IMcadBalloons::Item Method

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons::Item Method
IMcadBalloons Interface IMcadBalloons Members IMcadBalloons Interface Send Feedback
Summary

Gets the specific balloon from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBalloon*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the balloon index to return.
Returns

McadBalloon object

Interface

IMcadBalloons Interface

Links
IMcadBalloons Interface, IMcadBalloons Members, IMcadBalloons Interface


IMcadBalloons::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons::Remove Method
IMcadBalloons Interface IMcadBalloons Members IMcadBalloons Interface Send Feedback
Summary

Removes the specified balloon from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the balloon to be removed.
Returns

None

Interface

IMcadBalloons Interface

Links
IMcadBalloons Interface, IMcadBalloons Members, IMcadBalloons Interface


IMcadBalloonStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard Interface
IMcadBalloonStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadBalloonStandard
    IMcadBalloonStandard2
Visual Basic
Public Interface IMcadBalloonStandard
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBalloonStandard Members, SymBBAuto Library, Class Hierarchy


IMcadBalloonStandard Members

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard Members
IMcadBalloonStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBalloonStandard.

Interface

IMcadBalloonStandard Interface

Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.
Links
IMcadBalloonStandard Interface, Legend, Methods, Properties


IMcadBalloonStandard::Application Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::Application Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

  • This property is an AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::ArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::ArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::ArrowType Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the leader arrow type for balloon symbols based on this standard.

Visual Basic
Property ArrowType() As McadArrowType
Remarks

This property is a McadArrowType object.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::AttachmentType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::AttachmentType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::AttachmentType Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the leader attachment point type for the balloons created from this standard.

Visual Basic
Property AttachmentType() As McadAttachmentType
Remarks

This property is a McadAttachmentType enumeration.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::AuxiliaryArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::AuxiliaryArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::AuxiliaryArrowType Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the auxiliary arrow type for balloon symbols created by this standard.

Visual Basic
Property AuxiliaryArrowType() As McadArrowType
Remarks

This property is a McadArrowType enumeration.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::BalloonType Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::BalloonType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::BalloonType Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the type of the balloons referencing this standard.

Visual Basic
Property BalloonType() As McadBalloonType
Remarks

This property is a McadBalloonType enumeration.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::BOMStandard Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::BOMStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::BOMStandard Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Gets the bill of materials standard object referenced by balloons on this balloon standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks

This property is a McadBOMStandard object.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::Color Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::Color Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::Color Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the color of balloons referencing this standard.

Visual Basic
Property Color() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation documentation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
  • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property. sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::ColumnList Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::ColumnList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::ColumnList Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.

Visual Basic
Property ColumnList() As VARIANT
Remarks

This property is a Variant (array of Longs).

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::CustomBlockName Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::CustomBlockName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::CustomBlockName Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the custom block used for the balloons referencing this standard.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::IsAuxiliaryArrowUsed Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::IsAuxiliaryArrowUsed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::IsAuxiliaryArrowUsed Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.

Visual Basic
Property IsAuxiliaryArrowUsed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::IsCustomBlockUsed Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::IsCustomBlockUsed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::IsCustomBlockUsed Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::MaximumColumns Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::MaximumColumns Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::MaximumColumns Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the maximum number of columns that can be specified for this BalloonType .

Visual Basic
Property MaximumColumns() As long*
Remarks

This property is a Long.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::Revision Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::Revision Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::Revision Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the revision version of this balloon standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::RevisionYear Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::RevisionYear Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::RevisionYear Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the revision version year of this balloon standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::TextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::TextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::TextHeight Property
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Specifies the height of text in balloon symbols created by on this standard.

Visual Basic
Property TextHeight() As double
Remarks

This property defaults to be 0.24 inches.

This property is a Double.

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::RemoveColumn Method

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::RemoveColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::RemoveColumn Method
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the column to be removed.
Returns

None

Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard::SetToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard::SetToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard::SetToDefaults Method
IMcadBalloonStandard Interface IMcadBalloonStandard Members IMcadBalloonStandard Interface Send Feedback
Summary

Sets the properties of the standard balloon symbol to the factory default values.

Visual Basic
Sub SetToDefaults()
Interface

IMcadBalloonStandard Interface

Links
IMcadBalloonStandard Interface, IMcadBalloonStandard Members, IMcadBalloonStandard Interface


IMcadBalloonStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard2 Interface
IMcadBalloonStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The balloon standards for a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadBalloonStandard
    IMcadBalloonStandard2
Visual Basic
Public Interface IMcadBalloonStandard2
Inherits IMcadBalloonStandard
Library

SymBBAuto Library

Links
IMcadBalloonStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadBalloonStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard2 Members
IMcadBalloonStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBalloonStandard2.

Interface

IMcadBalloonStandard2 Interface

Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.
TrueColor | Specifies the true color of balloons referencing this standard.
Links
IMcadBalloonStandard2 Interface, Legend, Methods, Properties


IMcadBalloonStandard2::TrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2::TrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard2::TrueColor Property
IMcadBalloonStandard2 Interface IMcadBalloonStandard2 Members IMcadBalloonStandard2 Interface Send Feedback
Summary

Specifies the true color of balloons referencing this standard.

Visual Basic
Property TrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.
Interface

IMcadBalloonStandard2 Interface

Links
IMcadBalloonStandard2 Interface, IMcadBalloonStandard2 Members, IMcadBalloonStandard2 Interface


IMcadBOM Interface

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM Interface
IMcadBOM Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
Visual Basic
Public Interface IMcadBOM
Inherits IAcadDictionary
Library

SymBBAuto Library

Links
IMcadBOM Members, SymBBAuto Library, Class Hierarchy


IMcadBOM Members

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM Members
IMcadBOM Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOM.

Interface

IMcadBOM Interface

Methods
Name | Description
AddItem | Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem | Creates an unassociated item entry and adds it to the BOM table.
Items | Specifies the collection of bill of materials items contained in the BOM table.
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.
Links
IMcadBOM Interface, Legend, Methods, Properties


IMcadBOM::Data Property

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::Data Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::Data Property
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.

Visual Basic
Property Data() As VARIANT
Remarks

This property is a Variant (two dimension array of Strings).

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM::PartLists Property

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::PartLists Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::PartLists Property
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Gets the list of parts lists associated to the BOM table.

Visual Basic
Property PartLists() As IMcadPartLists**
Remarks

This property is a McadPartLists collection.

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM::Target Property

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::Target Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::Target Property
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Gets the target definition of a BOM table.

Visual Basic
Property Target() As IAcadObject**
Remarks

This property is a cadObject. This can be any of the drawing objects.

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM::AddItem Method

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::AddItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::AddItem Method
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Creates a BOM item for the part reference and adds it to the BOM table.

Visual Basic
Sub AddItem(ReferenceIDs As VARIANT, ItemNo As String, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
ReferenceIDs | Variant (long or array of longs); input-only. Specifies the object ID or array of object IDs for the part reference, usually obtained from the McadBOMMgr > SelectBOMEntity method.
ItemNo | String; input-only. Specifies the item number for the BOM item to be added to the BOM table.
Returns

McadBOMItem object

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM::AddUnassociatedItem Method

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::AddUnassociatedItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::AddUnassociatedItem Method
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Creates an unassociated item entry and adds it to the BOM table.

Visual Basic
Sub AddUnassociatedItem(ItemNo As String, Quantity As long, Data As [in, optional] VARIANT, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
ItemNo | String; input-only. Specifies the number of this item.
Quantity | String; input-only. Specifies the number of this item.
Data | Variant (two dimensional array of strings). Specify the data for the entry in the format specified by the McadBOMItem > Data property.
Returns

McadBOMItem object.

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM::Items Method

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM::Items Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM::Items Method
IMcadBOM Interface IMcadBOM Members IMcadBOM Interface Send Feedback
Summary

Specifies the collection of bill of materials items contained in the BOM table.

Visual Basic
Sub Items(Expanded As [in, defaultvalue(FALSE)] VARIANT_BOOL, Items As [out, retval] IMcadBOMItems*)
Parameters
Parameters | Description
Expanded | Boolean; input-only; optional. The default value is FALSE. If TRUE, expanded items are included in the collection.
Remarks

This property is a McadBOMItems collection.

Interface

IMcadBOM Interface

Links
IMcadBOM Interface, IMcadBOM Members, IMcadBOM Interface


IMcadBOM2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2 Interface
IMcadBOM2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
Visual Basic
Public Interface IMcadBOM2
Inherits IMcadBOM
Library

SymBBAuto Library

Links
IMcadBOM2 Members, SymBBAuto Library, Class Hierarchy


IMcadBOM2 Members

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2 Members
IMcadBOM2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOM2.

Interface

IMcadBOM2 Interface

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Items
Specifies the collection of bill of materials items contained in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects

Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.
Links
IMcadBOM2 Interface, Legend, Methods, Properties


IMcadBOM2::applySort Method

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2::applySort Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2::applySort Method
IMcadBOM2 Interface IMcadBOM2 Members IMcadBOM2 Interface Send Feedback
Summary

Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.

Visual Basic
Sub applySort()
Remarks

This method has no implementation and is currently unsupported.

Interface

IMcadBOM2 Interface

Links
IMcadBOM2 Interface, IMcadBOM2 Members, IMcadBOM2 Interface


IMcadBOM2::GetProperties Method

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2::GetProperties Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2::GetProperties Method
IMcadBOM2 Interface IMcadBOM2 Members IMcadBOM2 Interface Send Feedback
Summary

Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Visual Basic
Sub GetProperties(ByRef isStructuralyExpanded As VARIANT_BOOL, ByRef isUsingAssmPath As VARIANT_BOOL, ByRef structSeparator As String, ByRef assocLayoutIds As VARIANT, ByRef targetId As LONG_PTR)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM representation are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, True, or not, False. This parameter is available when isStructuralyExpanded is False.
structSeparator | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, True, or not, False. This parameter is available when isStructuralyExpanded is False.
assocLayoutIds | Variant; input-only. Specifies the drawing layout associated with the BOM representation.
targetId | Long; input-only. Specifies the BOM representation to get the properties for.
Interface

IMcadBOM2 Interface

Links
IMcadBOM2 Interface, IMcadBOM2 Members, IMcadBOM2 Interface


IMcadBOM2::GetProperties32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2::GetProperties32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2::GetProperties32 Method
IMcadBOM2 Interface IMcadBOM2 Members IMcadBOM2 Interface Send Feedback
Summary

Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Visual Basic
Sub GetProperties32(ByRef isStructuralyExpanded As VARIANT_BOOL, ByRef isUsingAssmPath As VARIANT_BOOL, ByRef structSeparator As String, ByRef assocLayoutIds As VARIANT, ByRef targetId As LONG)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM representation are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the assembly path for the structured BOM representation is displayed, TRUE, or not, FALSE. This parameter is available when isStructuralyExpanded is False.
structSeparator | String; input-only. Specifies the separator for used in the assembly path. This parameter is available when isStructuralyExpanded is False and isUsingAssmPath is True.
assocLayoutIds | Variant; input-only. Specifies the drawing layout associated with the BOM representation.
targetId | Long; input-only. Specifies the BOM representation to get the properties for.
Interface

IMcadBOM2 Interface

Links
IMcadBOM2 Interface, IMcadBOM2 Members, IMcadBOM2 Interface


IMcadBOM2::SetProperties Method

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2::SetProperties Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2::SetProperties Method
IMcadBOM2 Interface IMcadBOM2 Members IMcadBOM2 Interface Send Feedback
Summary

Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects
Visual Basic
Sub SetProperties(isStructuralyExpanded As VARIANT_BOOL, isUsingAssmPath As VARIANT_BOOL, structSeparator As String, assocLayoutIds As VARIANT, ByRef regen As VARIANT_BOOL)
Parameters
Parameters | Description
isStructuralyExpanded | Boolean; input-only. Specifies whether the subassemblies in the BOM table are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
isUsingAssmPath | Boolean; input-only. Specifies whether the subassemblies in the BOM table are expanded, True, or structured, False. The external parts are merged with the internal BOM items.
structSeparator | String; input-only. Specifies the separator for used in the assembly path. This parameter is available when isStructuralyExpanded is False and isUsingAssmPath is True.
assocLayoutIds | Variant (TBD); input-only. Specifies the drawing layout associated with the BOM table.
regen | Boolean; input-only. Specifies whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects, True, or not, False. If True, this method also reindexes the drawing database for optimum display and better object selection performance.
Interface

IMcadBOM2 Interface

Links
IMcadBOM2 Interface, IMcadBOM2 Members, IMcadBOM2 Interface


IMcadBOM3 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3 Interface
IMcadBOM3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4
Visual Basic
Public Interface IMcadBOM3
Inherits IMcadBOM2
Library

SymBBAuto Library

Links
IMcadBOM3 Members, SymBBAuto Library, Class Hierarchy


IMcadBOM3 Members

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3 Members
IMcadBOM3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOM3.

Interface

IMcadBOM3 Interface

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects

Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.
Links
IMcadBOM3 Interface, Legend, Methods, Properties


IMcadBOM3::IsBorder Property

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3::IsBorder Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3::IsBorder Property
IMcadBOM3 Interface IMcadBOM3 Members IMcadBOM3 Interface Send Feedback
Summary

Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.

Visual Basic
Property IsBorder() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadBOM3 Interface

Links
IMcadBOM3 Interface, IMcadBOM3 Members, IMcadBOM3 Interface


IMcadBOM3::IsVisible Property

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3::IsVisible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3::IsVisible Property
IMcadBOM3 Interface IMcadBOM3 Members IMcadBOM3 Interface Send Feedback
Summary

Checks whether the BOM table is visible, TRUE, or not, FALSE.

Visual Basic
Property IsVisible() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • For border BOM, isVisible will be true although it will not be listed in the browser. The BOM table not listed in the BOM Editor dialog will have isVisible set to false.
Interface

IMcadBOM3 Interface

Links
IMcadBOM3 Interface, IMcadBOM3 Members, IMcadBOM3 Interface


IMcadBOM3::GetStructuredChildItems Method

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3::GetStructuredChildItems Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3::GetStructuredChildItems Method
IMcadBOM3 Interface IMcadBOM3 Members IMcadBOM3 Interface Send Feedback
Summary

Gets the immediate child items of a BOM item in a Structured BOM table.

Visual Basic
Sub GetStructuredChildItems(Item As IMcadBOMItem, SkipPhantom As VARIANT_BOOL, Items As [out, retval] IMcadBOMItems*)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item for which to gets the child items.
SkipPhantom | Boolean; input-only. Specifies whether to return the child BOM items if they are phantom parts, TRUE, or not, FALSE. If TRUE, phantom child items will be ignored and its next level child BOM items will be returned.
Items | _nt_
Remarks

This API only applies to Structured BOM table. The parent item must have been expanded so that its child items are present. Any violation of these will return Acad::InvalidInput. Only immediate child items are returned.

Interface

IMcadBOM3 Interface

Links
IMcadBOM3 Interface, IMcadBOM3 Members, IMcadBOM3 Interface


IMcadBOM3::GetStructuredParentItem Method

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3::GetStructuredParentItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3::GetStructuredParentItem Method
IMcadBOM3 Interface IMcadBOM3 Members IMcadBOM3 Interface Send Feedback
Summary

Gets the parent item of the specified child item in the structured BOM representation.

Visual Basic
Sub GetStructuredParentItem(Item As IMcadBOMItem, SkipPhantom As VARIANT_BOOL, ParenItem As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the child BOM item for which to gets the parent item.
SkipPhantom | Boolean; input-only. Specifies whether to return the parent BOM item if it is a phantom part, TRUE, or not, FALSE. If TRUE, phantom parent will be ignored and its next level parent BOM item will be returned.
ParenItem | _nt_
Remarks

This API only applies to Structured BOM table. Only immediate parent item is returned.

Interface

IMcadBOM3 Interface

Links
IMcadBOM3 Interface, IMcadBOM3 Members, IMcadBOM3 Interface


IMcadBOM3::MergeItems Method

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3::MergeItems Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3::MergeItems Method
IMcadBOM3 Interface IMcadBOM3 Members IMcadBOM3 Interface Send Feedback
Summary

Merges the specified BOM items into one row in the BOM table.

Visual Basic
Sub MergeItems(Items As IMcadBOMItems)
Parameters
Parameters | Description
Items | McadBOMItems collection; input-only. Specifies the BOM items to be merged.
Interface

IMcadBOM3 Interface

Links
IMcadBOM3 Interface, IMcadBOM3 Members, IMcadBOM3 Interface


IMcadBOM4 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM4 Interface
IMcadBOM4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials database object.

Class Hierarchy

Declaration syntax

IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4
Visual Basic
Public Interface IMcadBOM4
Inherits IMcadBOM3
Library

SymBBAuto Library

Links
IMcadBOM4 Members, SymBBAuto Library, Class Hierarchy


IMcadBOM4 Members

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM4 Members
IMcadBOM4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOM4.

Interface

IMcadBOM4 Interface

Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects
SplitItem
Splits a row of the bill of materials (BOM) into two items.
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.
Links
IMcadBOM4 Interface, Legend, Methods, Properties


IMcadBOM4::SplitItem Method

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4::SplitItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM4::SplitItem Method
IMcadBOM4 Interface IMcadBOM4 Members IMcadBOM4 Interface Send Feedback
Summary

Splits a row of the bill of materials (BOM) into two items.

Visual Basic
Sub SplitItem(Item As IMcadBOMItem, PartRefIds As [in, optional] VARIANT)
Parameters
Parameters | Description
Item | MCadBOMItem; input only. Specifies the BOM row to be split.
PartRefIds | Input object ID array; optional. Array containing the part references that belong to the BOM row specified by Item. Only the first argument is needed for a non-part reference item.
Interface

IMcadBOM4 Interface

Links
IMcadBOM4 Interface, IMcadBOM4 Members, IMcadBOM4 Interface


IMcadBOMItem Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem Interface
IMcadBOMItem Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
Visual Basic
Public Interface IMcadBOMItem
Inherits IAcadObject
Library

SymBBAuto Library

Links
IMcadBOMItem Members, SymBBAuto Library, Class Hierarchy


IMcadBOMItem Members

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem Members
IMcadBOMItem Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMItem.

Interface

IMcadBOMItem Interface

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Quantity | Specifies the quantity of a BOM item.
Links
IMcadBOMItem Interface, Legend, Methods, Properties


IMcadBOMItem::AutoCalculateEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::AutoCalculateEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::AutoCalculateEnabled Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.

Visual Basic
Property AutoCalculateEnabled() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • If this property is a TRUE, setting a new value for the McadBOMItem > Quantity property fails.
Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::Balloons Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::Balloons Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::Balloons Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies the balloon symbols associated with this BOM item.

Visual Basic
Property Balloons() As IMcadBalloons**
Remarks

This property is a McadBalloons collection.

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::BOM Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::BOM Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::BOM Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies the BOM table that this BOM item is a member of.

Visual Basic
Property BOM() As IMcadBOM**
Remarks

This property is a McadBOM collection.

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::Data Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::Data Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::Data Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.

Visual Basic
Property Data() As VARIANT
Remarks

This property is a Variant (two dimension array of Strings).

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::Expanded Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::Expanded Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::Expanded Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.

Visual Basic
Property Expanded() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The McadBOMItem > IsExpandable property indicates whether or not this BOM item is expandable.
  • To set the Expanded or Structured property (isStructuralyExpanded) for a BOM database collection this BOM item belongs to, use the McadBOM > SetProperties method.
Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::IsExpandable Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::IsExpandable Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::IsExpandable Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies whether this BOM item is expandable, TRUE, or not, FALSE.

Visual Basic
Property IsExpandable() As VARIANT_BOOL*
Remarks
  • This property is a Boolean.
  • The McadBOMItem > Expanded property indicates whether or not this expandable BOM item is expanded.
  • To set the Expanded or Structured property (isStructuralyExpanded) for a BOM database collection this BOM item belongs to, use the McadBOM > SetProperties method.
Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::ItemNumber Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::ItemNumber Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::ItemNumber Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.

Visual Basic
Property ItemNumber() As String
Remarks

This property is a String.

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::Quantity Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::Quantity Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::Quantity Property
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Specifies the quantity of a BOM item.

Visual Basic
Property Quantity() As long
Remarks
  • This property is a Long.
  • Setting a new value for the Quantity property only succeeds until then McadBOMItem > AutoCalculateEnabled property is a FALSE for this item.
Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::AddReference Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::AddReference Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::AddReference Method
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Adds the specified part references to this BOM item.

Visual Basic
Sub AddReference(Reference As VARIANT)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies the object IDs for part references to add to this BOM item.
Returns

None

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::GetReferences Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::GetReferences Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::GetReferences Method
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.

Visual Basic
Sub GetReferences(ByRef Items As VARIANT, References As [out, retval] VARIANT)
Parameters
Parameters | Description
Items | Variant (array of Longs). Specifies the BOM item to get part references for.
Returns

Variant (array of arrays of Longs)

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::GetReferences32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::GetReferences32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::GetReferences32 Method
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.

Visual Basic
Sub GetReferences32(ByRef Items As VARIANT, References As [out, retval] VARIANT)
Parameters
Parameters | Description
Items | Variant (array of Longs). Specifies the BOM item to get part references for.
References | _nt_
Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::ReferenceExists Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::ReferenceExists Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::ReferenceExists Method
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.

Visual Basic
Sub ReferenceExists(Reference As VARIANT, Exists As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies an array of object IDs for the part reference to query for this BOM item.
Returns

Boolean

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem::RemoveReference Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem::RemoveReference Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem::RemoveReference Method
IMcadBOMItem Interface IMcadBOMItem Members IMcadBOMItem Interface Send Feedback
Summary

Removes the specified part reference from this BOM item.

Visual Basic
Sub RemoveReference(Reference As VARIANT)
Parameters
Parameters | Description
Reference | Variant (array of Longs); input-only. Specifies the array of object IDs for the part reference to be removed from this BOM item. If the reference has any balloons associated to it, they will be erased as well.
Returns

None

Interface

IMcadBOMItem Interface

Links
IMcadBOMItem Interface, IMcadBOMItem Members, IMcadBOMItem Interface


IMcadBOMItem2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2 Interface
IMcadBOMItem2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
Visual Basic
Public Interface IMcadBOMItem2
Inherits IMcadBOMItem
Library

SymBBAuto Library

Links
IMcadBOMItem2 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMItem2 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2 Members
IMcadBOMItem2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMItem2.

Interface

IMcadBOMItem2 Interface

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
Links
IMcadBOMItem2 Interface, Legend, Methods, Properties


IMcadBOMItem2::ExcludeFromPartList Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::ExcludeFromPartList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::ExcludeFromPartList Property
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.

Visual Basic
Property ExcludeFromPartList() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::Phantomed Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::Phantomed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::Phantomed Property
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.

Visual Basic
Property Phantomed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::GetAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::GetAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::GetAttribute Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Gets the BOM attribute of a specified key.

Visual Basic
Sub GetAttribute(Key As String, Evaluate As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] BSTR)
Parameters
Parameters | Description
Key | String; input-only. Specifies the attribute key to perform this method.
Evaluate | Boolean, default value = TRUE; input-only; optional. Specifies whether the BOM attribute is returned in evaluated form, TRUE, or in raw form, FALSE.
pVal | _nt_
Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::GetCalculatedQuantity Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::GetCalculatedQuantity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::GetCalculatedQuantity Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Gets the calculated quantity regardless of the AutoCalc flag.

Visual Basic
Sub GetCalculatedQuantity(ByRef Qty As long, ByRef QtyIgnoreRefQty As long)
Parameters
Parameters | Description
Qty | Long; output-only. Returns the total number of parts associated with this BOM item.
QtyIgnoreRefQty | Long; output-only. Returns the total number of parts associated with this BOM item not taking into account the part's reference quantity.
Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::GetItemDefinition Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::GetItemDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::GetItemDefinition Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Gets the definitions of the specified BOM items.

Visual Basic
Sub GetItemDefinition(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

This function is deprecated in favor of the new GetItemPartDefinition.

It will return nothing for eNonModal BOM item, one component definition ID for eCompDef BOM item, and array of part definition IDs for ePartRef and eBlockDef.

Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::GetItemDefinition32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::GetItemDefinition32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::GetItemDefinition32 Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Gets the definitions of the specified BOM items.

Visual Basic
Sub GetItemDefinition32(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

This function is deprecated in favor of the new GetItemPartDefinition.

It will return nothing for eNonModal BOM item, one component definition ID for eCompDef BOM item, and array of part definition IDs for ePartRef and eBlockDef.

Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::GetPartBalloons Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::GetPartBalloons Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::GetPartBalloons Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Gets the attached balloons on the parts.

Visual Basic
Sub GetPartBalloons(Reference As VARIANT, Balloons As [out, retval] IMcadBalloons*)
Parameters
Parameters | Description
Reference | Variant; input-only. Specifies the part(s) associated with the balloons to get. It can be a single part or array of parts object IDs . If no part is given or NULL, all balloons associated with this BOM items will be returned.
Balloons | _nt_
Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem2::SetAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2::SetAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2::SetAttribute Method
IMcadBOMItem2 Interface IMcadBOMItem2 Members IMcadBOMItem2 Interface Send Feedback
Summary

Sets an BOM attribute value at the specified attribute key.

Visual Basic
Sub SetAttribute(Key As String, Val As String)
Parameters
Parameters | Description
Key | String; input-only. Specifies the attribute key for which to give a attribute value.
Val | String; input-only. Specifies the attribute value on the given attribute key.
Interface

IMcadBOMItem2 Interface

Links
IMcadBOMItem2 Interface, IMcadBOMItem2 Members, IMcadBOMItem2 Interface


IMcadBOMItem3 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3 Interface
IMcadBOMItem3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials item or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4
Visual Basic
Public Interface IMcadBOMItem3
Inherits IMcadBOMItem2
Library

SymBBAuto Library

Links
IMcadBOMItem3 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMItem3 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3 Members
IMcadBOMItem3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMItem3.

Interface

IMcadBOMItem3 Interface

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.
Links
IMcadBOMItem3 Interface, Legend, Methods, Properties


IMcadBOMItem3::SortPriority Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3::SortPriority Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3::SortPriority Property
IMcadBOMItem3 Interface IMcadBOMItem3 Members IMcadBOMItem3 Interface Send Feedback
Summary

Property that indicates the priority of the item for purpose of sorting.

Visual Basic
Property SortPriority() As long
Remarks

A smaller value item will be listed first, before a bigger value item. Sort priority will be used for McadBom.applySort() method.

Interface

IMcadBOMItem3 Interface

Links
IMcadBOMItem3 Interface, IMcadBOMItem3 Members, IMcadBOMItem3 Interface


IMcadBOMItem3::GetItemPartDefinition Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3::GetItemPartDefinition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3::GetItemPartDefinition Method
IMcadBOMItem3 Interface IMcadBOMItem3 Members IMcadBOMItem3 Interface Send Feedback
Summary

The method replaces the previous GetItemDefinition method.

Visual Basic
Sub GetItemPartDefinition(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

Returns the definition of the BOM item. It returns one unique definition ID for NonModal and PartRef BOM item; one component definition ID for CompDef BOM item and array of part definition IDs for BlockDef BOM item.

Interface

IMcadBOMItem3 Interface

Links
IMcadBOMItem3 Interface, IMcadBOMItem3 Members, IMcadBOMItem3 Interface


IMcadBOMItem3::GetItemPartDefinition32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3::GetItemPartDefinition32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3::GetItemPartDefinition32 Method
IMcadBOMItem3 Interface IMcadBOMItem3 Members IMcadBOMItem3 Interface Send Feedback
Summary

The method replaces the previous GetItemDefinition32 method.

Visual Basic
Sub GetItemPartDefinition32(ByRef Definitions As VARIANT, ByRef DefType As McadBOMItemDefinitionType)
Remarks

Returns the definition of the BOM item. It returns one unique definition ID for NonModal and PartRef BOM item; one component definition ID for CompDef BOM item and array of part definition IDs for BlockDef BOM item.

Interface

IMcadBOMItem3 Interface

Links
IMcadBOMItem3 Interface, IMcadBOMItem3 Members, IMcadBOMItem3 Interface


IMcadBOMItem3::SetAttributePreDefinedListValue Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3::SetAttributePreDefinedListValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3::SetAttributePreDefinedListValue Method
IMcadBOMItem3 Interface IMcadBOMItem3 Members IMcadBOMItem3 Interface Send Feedback
Summary

Sets a specific value within the predefined list for the specified attribute.

Visual Basic
Sub SetAttributePreDefinedListValue(attributeName As String, preDefineListValue As String)
Parameters
Parameters | Description
attributeName | Name of attribute which is a predefined list.
preDefineListValue | The specific value within the predefined list to set to. This value must be a valid key in the predefined list.
Interface

IMcadBOMItem3 Interface

Links
IMcadBOMItem3 Interface, IMcadBOMItem3 Members, IMcadBOMItem3 Interface


IMcadBOMItem4 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4 Interface
IMcadBOMItem4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials item, or row object.

Class Hierarchy

Declaration syntax

IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4
Visual Basic
Public Interface IMcadBOMItem4
Inherits IMcadBOMItem3
Library

SymBBAuto Library

Links
IMcadBOMItem4 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMItem4 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4 Members
IMcadBOMItem4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMItem4.

Interface

IMcadBOMItem4 Interface

Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetBomOverride | Method that checks if there is a bom override for the specified attrib/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveAttribute | Method to remove the local attribute value if any from this bom item. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.
Links
IMcadBOMItem4 Interface, Legend, Methods, Properties


IMcadBOMItem4::GetBomOverride Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4::GetBomOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4::GetBomOverride Method
IMcadBOMItem4 Interface IMcadBOMItem4 Members IMcadBOMItem4 Interface Send Feedback
Summary

Method that checks if there is a bom override for the specified attrib/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.

Visual Basic
Sub GetBomOverride(attributeName As String, ByRef originalValue As String, ByRef originalData As String, ByRef currentValue As String, ByRef currentData As String, ByRef editable As VARIANT_BOOL, overrideType As [out, retval] McadBomOverrideType)
Parameters
Parameters | Description
attributeName | Name of attribute/column to check.
originalValue | The original evaluated value (what would be there if there is no override). Would be empty if there is no bom override.
originalData | The original unevaluated data (what would be there if there is no override). Would be empty if there is no bom override.
currentValue | The current evaluated value.
currentData | The current unevaluated data.
editable | Indicates if the attribute can be edited.
Interface

IMcadBOMItem4 Interface

Links
IMcadBOMItem4 Interface, IMcadBOMItem4 Members, IMcadBOMItem4 Interface


IMcadBOMItem4::RemoveAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4::RemoveAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4::RemoveAttribute Method
IMcadBOMItem4 Interface IMcadBOMItem4 Members IMcadBOMItem4 Interface Send Feedback
Summary

Method to remove the local attribute value if any from this bom item. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.

Visual Basic
Sub RemoveAttribute(attributeName As String)
Parameters
Parameters | Description
attributeName | Name of attribute/column to remove.
Remarks

Because quantity override is handled differently, this method of McadBomItem will not work for quantity override.

Interface

IMcadBOMItem4 Interface

Links
IMcadBOMItem4 Interface, IMcadBOMItem4 Members, IMcadBOMItem4 Interface


IMcadBOMItems Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems Interface
IMcadBOMItems Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBOMItem objects

Class Hierarchy

Declaration syntax

IMcadBOMItems
Visual Basic
Public Interface IMcadBOMItems
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBOMItems Members, SymBBAuto Library, Class Hierarchy


IMcadBOMItems Members

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems Members
IMcadBOMItems Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMItems.

Interface

IMcadBOMItems Interface

Methods
Name | Description
Add | Appends a specified BOM item to this BOM database table collection.
Item | Specifies the BOM item at a specified index from this BOM database table collection.
Remove | Removes the specified BOM item from this McadBOMItems collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the number of items in a McadBOMItems collection.
Links
IMcadBOMItems Interface, Legend, Methods, Properties


IMcadBOMItems::Application Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems::Application Property
IMcadBOMItems Interface IMcadBOMItems Members IMcadBOMItems Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadBOMItems Interface

Links
IMcadBOMItems Interface, IMcadBOMItems Members, IMcadBOMItems Interface


IMcadBOMItems::Count Property

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems::Count Property
IMcadBOMItems Interface IMcadBOMItems Members IMcadBOMItems Interface Send Feedback
Summary

Specifies the number of items in a McadBOMItems collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadBOMItems Interface

Links
IMcadBOMItems Interface, IMcadBOMItems Members, IMcadBOMItems Interface


IMcadBOMItems::Add Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems::Add Method
IMcadBOMItems Interface IMcadBOMItems Members IMcadBOMItems Interface Send Feedback
Summary

Appends a specified BOM item to this BOM database table collection.

Visual Basic
Sub Add(Item As IMcadBOMItem)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item to be appended to this BOM database table collection.
Returns

None

Interface

IMcadBOMItems Interface

Links
IMcadBOMItems Interface, IMcadBOMItems Members, IMcadBOMItems Interface


IMcadBOMItems::Item Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems::Item Method
IMcadBOMItems Interface IMcadBOMItems Members IMcadBOMItems Interface Send Feedback
Summary

Specifies the BOM item at a specified index from this BOM database table collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBOMItem*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the BOM item to get from the collection.
Returns

McadBOMItem object

Interface

IMcadBOMItems Interface

Links
IMcadBOMItems Interface, IMcadBOMItems Members, IMcadBOMItems Interface


IMcadBOMItems::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems::Remove Method
IMcadBOMItems Interface IMcadBOMItems Members IMcadBOMItems Interface Send Feedback
Summary

Removes the specified BOM item from this McadBOMItems collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specified the index of the BOM item to be removed from this McadBOMItems collection.
Returns

None

Interface

IMcadBOMItems Interface

Links
IMcadBOMItems Interface, IMcadBOMItems Members, IMcadBOMItems Interface


IMcadBOMMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr Interface
IMcadBOMMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
Visual Basic
Public Interface IMcadBOMMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBOMMgr Members, SymBBAuto Library, Class Hierarchy


IMcadBOMMgr Members

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr Members
IMcadBOMMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMMgr.

Interface

IMcadBOMMgr Interface

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddPartData | Creates a part data entry for the specified part reference.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
RemoveBOMTable | Removes the specified BOM table.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.
Links
IMcadBOMMgr Interface, Legend, Methods, Properties


IMcadBOMMgr::Application Property

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::Application Property
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::SymbolBBMgr Property

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::SymbolBBMgr Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::SymbolBBMgr Property
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Gets the Symbol BOM and Balloon manager object for this document.

Visual Basic
Property SymbolBBMgr() As IMcadSymbolBBMgr**
Remarks

This property is a McadSymbolBBMgr object.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::AddBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::AddBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::AddBOMTable Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.

Visual Basic
Sub AddBOMTable(Name As String, Target As [in, optional] VARIANT, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the BOM table to be added for a specified Target block.
Target | Variant (model/paper space block or a Long type component definition id); input-only; optional. Specifies the target to add a BOM table for. If the Target element is not specified, the main BOM table is created.
Returns

McadBOM collection

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::AddPartData Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::AddPartData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::AddPartData Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Creates a part data entry for the specified part reference.

Visual Basic
Sub AddPartData(Part As IAcadObject, Data As VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to create the data entry for.
Data | Variant (two dimensional array of strings); input-only. Specifies the data entry for the specified part reference's symbol, block, or block reference.
Returns

None

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. This method fails if Data is already associated with the specified part.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::BOMTableExists Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::BOMTableExists Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::BOMTableExists Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.

Visual Basic
Sub BOMTableExists(TargetName As [in, optional] VARIANT, Exists As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
TargetName | Variant (AcadBlock object or String); input-only; optional. Specifies the target block object or block name to check. If not specified, the main BOM table is checked.
Returns

Boolean

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::ExportBOM Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::ExportBOM Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::ExportBOM Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Exports the BOM table data to a specified file in a specified format.

Visual Basic
Sub ExportBOM(BOM As IMcadBOM, FileType As String, FileName As String)
Parameters
Parameters | Description
BOM | McadBOM collection; input-only. Specifies the BOM table to be exported.
FileType | String; input-only. Specifies the file type for the exported BOM table. Valid file types include .mdb, .xls, .dbf, .txt, .csv, .html.
FileName | String; input-only. Specifies the file name for the exported BOM table.
Returns

None

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::GetAllBOMTables Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::GetAllBOMTables Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::GetAllBOMTables Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Gets all of the BOM tables in the document.

Visual Basic
Sub GetAllBOMTables(IncludeXREFs As [in, defaultvalue(FALSE)] VARIANT_BOOL, BOMs As [out, retval] IMcadBOMs*)
Parameters
Parameters | Description
IncludeXREFs | Boolean; input-only; optional; default value is FALSE. Specifies whether BOM tables from all the externally referenced drawings for this BOM table are included. If the IncludeXREFs element is TRUE, the BOM tables from all the externally referenced drawings are included.
Returns

McadBOMs collection

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::GetBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::GetBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::GetBOMTable Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Gets the specified BOM table associated with the specified block target.

Visual Basic
Sub GetBOMTable(Target As IAcadObject, ByRef Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Target | AcadObject object; input-only. Specifies the block target to get the BOM table for.
Name | String; input-only. Specifies the name of the BOM table to get.
Returns

McadBOM collection

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::GetPartData Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::GetPartData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::GetPartData Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.

Visual Basic
Sub GetPartData(Part As IAcadObject, Data As [out, retval] VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to get the associated data for.
Returns

Variant (two dimensional array of strings)

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::ImportBOM Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::ImportBOM Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::ImportBOM Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.

Visual Basic
Sub ImportBOM(FileName As String, TableName As String, Target As [in, optional] VARIANT, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
FileName | String; input-only. Specifies the file name for the BOM table data to be imported.
TableName | String; input-only. Specifies the name of the BOM table to be imported.
Target | Variant (AcadBlock object); input-only; optional. Specifies the block target to import the BOM table data for. If not specified, the new data are added to the main BOM table.
Returns

McadBOM collection

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::RemoveBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::RemoveBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::RemoveBOMTable Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Removes the specified BOM table.

Visual Basic
Sub RemoveBOMTable(BOM As IMcadBOM)
Parameters
Parameters | Description
BOM | McadBOM collection; input-only. Specifies the BOM table to be removed.
Returns

None

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::SelectBOMEntity Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::SelectBOMEntity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::SelectBOMEntity Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Prompts for the selection of part references.

Visual Basic
Sub SelectBOMEntity(IntoNested As [in, defaultvalue(FALSE)] VARIANT_BOOL, Path As [out, retval] VARIANT)
Parameters
Parameters | Description
IntoNested | Boolean; input-only; optional; default value is FALSE. Specifies whether or not the nested part references in the BOM table are selected.
Returns

Variant (array of longs)

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. An array of object IDs of the selected parts is returned.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::SelectBOMEntity32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::SelectBOMEntity32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::SelectBOMEntity32 Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Prompts for the selection of part references.

Visual Basic
Sub SelectBOMEntity32(IntoNested As [in, defaultvalue(FALSE)] VARIANT_BOOL, Path As [out, retval] VARIANT)
Parameters
Parameters | Description
IntoNested | Boolean; input-only; optional; default value is False. Specifies whether or not the nested part references in the BOM table are selected.
Path | _nt_
Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. An array of object IDs of the selected parts is returned.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr::SetPartData Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr::SetPartData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr::SetPartData Method
IMcadBOMMgr Interface IMcadBOMMgr Members IMcadBOMMgr Interface Send Feedback
Summary

Sets the data entry associated with the specified part reference.

Visual Basic
Sub SetPartData(Part As IAcadObject, Data As VARIANT)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the part reference to set the data entry for.
Data | Variant (two dimensional array of strings); input-only. Specifies the key value pairs for the data entry to set for the specified part reference.
Returns

None

Remarks

The part reference is specified as the part reference symbol, block, or block reference of the part instance. The data is represented as a two dimensional array of strings of key value pairs.

Interface

IMcadBOMMgr Interface

Links
IMcadBOMMgr Interface, IMcadBOMMgr Members, IMcadBOMMgr Interface


IMcadBOMMgr2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2 Interface
IMcadBOMMgr2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials manager object

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
Visual Basic
Public Interface IMcadBOMMgr2
Inherits IMcadBOMMgr
Library

SymBBAuto Library

Links
IMcadBOMMgr2 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMMgr2 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2 Members
IMcadBOMMgr2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMMgr2.

Interface

IMcadBOMMgr2 Interface

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.
Links
IMcadBOMMgr2 Interface, Legend, Methods, Properties


IMcadBOMMgr2::CurrentBOM Property

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::CurrentBOM Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::CurrentBOM Property
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets or sets the current BOM table.

Visual Basic
Property CurrentBOM() As IMcadBOM*
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::AddBorderBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::AddBorderBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::AddBorderBOMTable Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Creates a new border BOM database with a given border.

Visual Basic
Sub AddBorderBOMTable(BlockRef As IAcadObject, Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
BlockRef | AcadObject object; input-only. Specifies the block reference object, IAcadBlockReference of the title border.
Name | String; input-only. Specifies the BOM table name.
BOM | _nt_
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::AddPartGrfDef Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::AddPartGrfDef Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::AddPartGrfDef Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Add graphical definition such as Part Reference or Block Reference, to represent the same part.

Visual Basic
Sub AddPartGrfDef(Part As IAcadObject, NewGrfDef As IAcadObject)
Parameters
Parameters | Description
Part | AcadObject object; input-only. Specifies the target part for which to add graphical definitions.
NewGrfDef | AcadObject object; input-only. Specifies the graphical definition to be added to the specified part.
Remarks

You can have as many as different definitions linked to a single part data, but all of them must be of same type.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::ExportBOM2 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::ExportBOM2 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::ExportBOM2 Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Exports the BOM table to a file of a specific format.

Visual Basic
Sub ExportBOM2(Format As McadBOMExportFormatType, BOM As IMcadBOM, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::ExportPartList Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::ExportPartList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::ExportPartList Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface See Also Send Feedback
Summary

Exports the parts list to a file of a specific format.

Visual Basic
Sub ExportPartList(Format As McadBOMExportFormatType, PartList As IMcadPartList, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the Part List dialog box. The column formatting is based on the current BOM Standard. In order to BOM Standard first.

See Also

McadBOMMgr Object

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface, See Also


IMcadBOMMgr2::GetBOMTableByCompDefId Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetBOMTableByCompDefId Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetBOMTableByCompDefId Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM table from a given component definition ID.

Visual Basic
Sub GetBOMTableByCompDefId(ObjId As LONG_PTR, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
ObjId | Long; input-only. Specifies the object ID of the component definition to perform this method.
BOM | _nt_
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetBOMTableByCompDefId32 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetBOMTableByCompDefId32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetBOMTableByCompDefId32 Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM table from a given component definition ID.

Visual Basic
Sub GetBOMTableByCompDefId32(ObjId As LONG, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
ObjId | Long; input-only. Specifies the object ID of the component definition to perform this method.
BOM | _nt_
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetBOMTableByName Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetBOMTableByName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetBOMTableByName Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM table from the specified name.

Visual Basic
Sub GetBOMTableByName(Name As String, BOM As [out, retval] IMcadBOM*)
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetBorderBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetBorderBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetBorderBOMTable Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets a border BOM database from a given border.

Visual Basic
Sub GetBorderBOMTable(BlockRef As IAcadObject, ByRef Name As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
BlockRef | AcadObject object; input-only. Specifies the block reference object, IAcadBlockReference of the title border.
Name | String; input-only. Specifies the BOM table name.
BOM | _nt_
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetEvaluatedPartData Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetEvaluatedPartData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetEvaluatedPartData Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM attributes for the specified part

Visual Basic
Sub GetEvaluatedPartData(Part As IAcadObject, Data As [out, retval] VARIANT)
Parameters
Parameters | Description
Part | _nt_
Data | _nt_
Returns

Variant (2-dimensional array data). For each record, the first element is the string Key of the BOM attribute and the second element is the string data of that Key.

Remarks

This is an enhanced version of the current getPartData(partId, valueMap) API, which returns the valueMap with evaluated data and also returns an extra parameter for the numOfItems. Evaluation of the data is based on the bomStdId passed in. If the partId is a data entry id, numOfItems is not applicable.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetPartAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetPartAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetPartAttribute Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM attribute associated with a given key of a specified part.

Visual Basic
Sub GetPartAttribute(Part As IAcadObject, Key As String, evaluated As [in, defaultvalue(TRUE)] VARIANT_BOOL, Data As [out, retval] BSTR)
Parameters
Parameters | Description
Part | _nt_
Key | _nt_
evaluated | _nt_
Data | _nt_
Remarks

This is an equivalence of the current getPartData(partId, valueMap) API which return the attribute of a given key. If evaluate is true, evaluated value will be returned else raw data i.e. formula will be returned.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::GetSheetBOMTable Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::GetSheetBOMTable Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::GetSheetBOMTable Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Gets the BOM table associated to a specific paper space.

Visual Basic
Sub GetSheetBOMTable(Layout As IAcadObject, BOM As [out, retval] IMcadBOM*)
Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::ImportBOM2 Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::ImportBOM2 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::ImportBOM2 Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Imports the data in a file of the specified format into the BOM table.

Visual Basic
Sub ImportBOM2(Format As McadBOMImportFormatType, BOM As IMcadBOM, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the Part List dialog box. The column formatting is based on the current BOM Standard. In order to BOM Standard first.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::ImportPartList Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::ImportPartList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::ImportPartList Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Imports the data in a file of the specified format into the parts list.

Visual Basic
Sub ImportPartList(Format As McadBOMImportFormatType, PartList As IMcadPartList, Path As String, TableName As String, Overwrite As VARIANT_BOOL)
Remarks

This is the API version of the GUI version in the BOM table dialog box. BOM row items for each part imported will be created in the BOM table that owns the part list.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::RemovePartGrfDef Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::RemovePartGrfDef Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::RemovePartGrfDef Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Removes the graphical definition such as Part Reference or Block Reference, from the part reference.

Visual Basic
Sub RemovePartGrfDef(Ref As IAcadObject)
Remarks

After the removal, the Part reference or Block Reference is no longer linked to the original data.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr2::SetPartAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::SetPartAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2::SetPartAttribute Method
IMcadBOMMgr2 Interface IMcadBOMMgr2 Members IMcadBOMMgr2 Interface Send Feedback
Summary

Sets the BOM attribute associated with a given key of a specified part.

Visual Basic
Sub SetPartAttribute(Part As IAcadObject, Key As String, Data As String)
Parameters
Parameters | Description
Part | String; input-only. Specifies the part for which to set the BOM attribute.
Key | String; input-only. Specifies the attribute key on which to set the BOM attribute.
Data | String; input-only. Specifies the BOM attribute value to be set.
Remarks

This is an equivalence of the current setPartData(partId, valueMap) API which set the attribute value for a given key.

Interface

IMcadBOMMgr2 Interface

Links
IMcadBOMMgr2 Interface, IMcadBOMMgr2 Members, IMcadBOMMgr2 Interface


IMcadBOMMgr3 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr3 Interface
IMcadBOMMgr3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials manager object.

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4
Visual Basic
Public Interface IMcadBOMMgr3
Inherits IMcadBOMMgr2
Library

SymBBAuto Library

Links
IMcadBOMMgr3 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMMgr3 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr3 Members
IMcadBOMMgr3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMMgr3.

Interface

IMcadBOMMgr3 Interface

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.
Links
IMcadBOMMgr3 Interface, Legend, Methods, Properties


IMcadBOMMgr3::GetBOMTableByCompDefHandle Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3::GetBOMTableByCompDefHandle Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr3::GetBOMTableByCompDefHandle Method
IMcadBOMMgr3 Interface IMcadBOMMgr3 Members IMcadBOMMgr3 Interface Send Feedback
Summary

Gets the specified BOM table associated with the handle of a component definition

Visual Basic
Sub GetBOMTableByCompDefHandle(Handle As String, BOM As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Handle | _nt_
BOM | _nt_
Interface

IMcadBOMMgr3 Interface

Links
IMcadBOMMgr3 Interface, IMcadBOMMgr3 Members, IMcadBOMMgr3 Interface


IMcadBOMMgr4 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr4 Interface
IMcadBOMMgr4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials manager object.

Class Hierarchy

Declaration syntax

IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4
Visual Basic
Public Interface IMcadBOMMgr4
Inherits IMcadBOMMgr3
Library

SymBBAuto Library

Links
IMcadBOMMgr4 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMMgr4 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr4 Members
IMcadBOMMgr4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMMgr4.

Interface

IMcadBOMMgr4 Interface

Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetAllPartReferences | Gets all the part references from the specified database.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.
Links
IMcadBOMMgr4 Interface, Legend, Methods, Properties


IMcadBOMMgr4::GetAllPartReferences Method

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4::GetAllPartReferences Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr4::GetAllPartReferences Method
IMcadBOMMgr4 Interface IMcadBOMMgr4 Members IMcadBOMMgr4 Interface Send Feedback
Summary

Gets all the part references from the specified database.

Visual Basic
Sub GetAllPartReferences(items As [out, retval] IMcadPartReferences *)
Parameters
Parameters | Description
items | Collection of part references.
Interface

IMcadBOMMgr4 Interface

Links
IMcadBOMMgr4 Interface, IMcadBOMMgr4 Members, IMcadBOMMgr4 Interface


IMcadBOMs Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs Interface
IMcadBOMs Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadBOM objects

Class Hierarchy

Declaration syntax

IMcadBOMs
Visual Basic
Public Interface IMcadBOMs
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBOMs Members, SymBBAuto Library, Class Hierarchy


IMcadBOMs Members

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs Members
IMcadBOMs Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMs.

Interface

IMcadBOMs Interface

Methods
Name | Description
Add | Adds a BOM table to the BOM database collection.
Item | Gets the BOM table at a specified index from the BOM database collection.
Remove | Removes the BOM table at a specified index from the BOM database collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the BOM tables in a BOM database collection.
Links
IMcadBOMs Interface, Legend, Methods, Properties


IMcadBOMs::Application Property

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs::Application Property
IMcadBOMs Interface IMcadBOMs Members IMcadBOMs Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadBOMs Interface

Links
IMcadBOMs Interface, IMcadBOMs Members, IMcadBOMs Interface


IMcadBOMs::Count Property

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs::Count Property
IMcadBOMs Interface IMcadBOMs Members IMcadBOMs Interface Send Feedback
Summary

Gets the total number of the BOM tables in a BOM database collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadBOMs Interface

Links
IMcadBOMs Interface, IMcadBOMs Members, IMcadBOMs Interface


IMcadBOMs::Add Method

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs::Add Method
IMcadBOMs Interface IMcadBOMs Members IMcadBOMs Interface Send Feedback
Summary

Adds a BOM table to the BOM database collection.

Visual Basic
Sub Add(Item As IMcadBOM)
Parameters
Parameters | Description
Item | McadBOM collection. Specifies the BOM table to add to the BOM database collection.
Interface

IMcadBOMs Interface

Links
IMcadBOMs Interface, IMcadBOMs Members, IMcadBOMs Interface


IMcadBOMs::Item Method

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs::Item Method
IMcadBOMs Interface IMcadBOMs Members IMcadBOMs Interface Send Feedback
Summary

Gets the BOM table at a specified index from the BOM database collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadBOM*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the BOM table to get from this BOM database collection.
Returns

McadBOM collection

Interface

IMcadBOMs Interface

Links
IMcadBOMs Interface, IMcadBOMs Members, IMcadBOMs Interface


IMcadBOMs::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs::Remove Method
IMcadBOMs Interface IMcadBOMs Members IMcadBOMs Interface Send Feedback
Summary

Removes the BOM table at a specified index from the BOM database collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Removes the BOM table at a specified index from the BOM database collection.
Returns

None

Interface

IMcadBOMs Interface

Links
IMcadBOMs Interface, IMcadBOMs Members, IMcadBOMs Interface


IMcadBOMStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard Interface
IMcadBOMStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2
Visual Basic
Public Interface IMcadBOMStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadBOMStandard Members, SymBBAuto Library, Class Hierarchy


IMcadBOMStandard Members

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard Members
IMcadBOMStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMStandard.

Interface

IMcadBOMStandard Interface

Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadBOMStandard Interface, Legend, Methods, Properties


IMcadBOMStandard::BalloonStandard Property

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::BalloonStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::BalloonStandard Property
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Gets the specific balloon standard that is associated with a BOM standard.

Visual Basic
Property BalloonStandard() As IMcadBalloonStandard**
Remarks

This property is a McadBalloonStandard object.

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::ColumnCount Property

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::ColumnCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::ColumnCount Property
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Gets the number of columns specified for this BOM standard.

Visual Basic
Property ColumnCount() As long*
Remarks

This property is a Long.

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::Columns Property

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::Columns Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::Columns Property
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Gets the columns definitions for a BOM standard.

Visual Basic
Property Columns() As IMcadColumnDefinitions**
Remarks

This property is a McadColumnDefinitions collection.

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::PartListStandard Property

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::PartListStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::PartListStandard Property
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Gets the specific part list standard that is associated with a BOM standard.

Visual Basic
Property PartListStandard() As IMcadPartListStandard**
Remarks

This property is a McadPartListStandard object.

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::AddColumn Method

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::AddColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::AddColumn Method
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.

Visual Basic
Sub AddColumn(ColumnType As McadColumnType, DataType As McadDataType, ColumnName As String, Caption As [in, optional] VARIANT, Index As [in, optional] VARIANT, Column As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
ColumnType | McadColumnType enumeration; input-only. Specifies the column type for the column to add to the BOM standard. This ColumnType element is the internal name of the column attribute.
DataType | McadDataType enumeration; input-only. Specifies the data type of the column.
ColumnName | String; input-only. Specifies the column name to display in the BOM table.
Caption | Variant (String); input-only; optional. If not specified, the ColumnType value is retrieved for the Caption element.
Index | Variant (Long); input-only; optional. Specifies the index of the collection of McadColumnDefinition objects in the BOM standard.
Returns

McadColumnDefinition object

Remarks

To add a user-defined BOM column, you must set McadColumnType to sbUnknown. The name of the property must match its type. For example, "item" must be of type sbItem. If a property with this name already exists the property will be set to visible. To add a partref to a nested block reference, you must pass an array of object IDs for the parent block references and its block reference.

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::GetColumn Method

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::GetColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::GetColumn Method
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.

Visual Basic
Sub GetColumn(Item As [in, optional] VARIANT, Name As [in, optional] VARIANT, Caption As [in, optional] VARIANT, Index As [in, optional] VARIANT, Type As [in, optional] VARIANT, Column As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
Item | Variant (Long); input-only; optional. Specifies the item number for the column to get from this BOM standard.
Name | Variant (Long); input-only; optional. Specifies the name for the column to get from this BOM database standard.
Caption | Variant (String); input-only; optional. Specifies the caption for the column to get from this BOM database standard.
Index | Variant (String); input-only; optional. Specifies the caption for the column to get from this BOM database standard.
Type | Variant ( McadColumnType enumeration); input-only; optional. Specifies the column type for the column to get from this BOM standard.
Returns

McadColumnDefinition object

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::MoveColumn Method

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::MoveColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::MoveColumn Method
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Moves the specified column at a specified index to a new index.

Visual Basic
Sub MoveColumn(Index As long, ToIndex As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the original index for the collection of McadColumnDefinition objects in the BOM standard.
ToIndex | Long; input-only. Specifies the new index for the collection of McadColumnDefinition objects in the BOM standard.
Returns

None

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard::RemoveColumn Method

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard::RemoveColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard::RemoveColumn Method
IMcadBOMStandard Interface IMcadBOMStandard Members IMcadBOMStandard Interface Send Feedback
Summary

Removes the specified column from this BOM standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Variant (Long); input-only. Specifies the index of the collection of McadColumnDefinition objects in the BOM standard.
Returns

None

Interface

IMcadBOMStandard Interface

Links
IMcadBOMStandard Interface, IMcadBOMStandard Members, IMcadBOMStandard Interface


IMcadBOMStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard2 Interface
IMcadBOMStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A bill of materials symbol standard object

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2
Visual Basic
Public Interface IMcadBOMStandard2
Inherits IMcadBOMStandard
Library

SymBBAuto Library

Links
IMcadBOMStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadBOMStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard2 Members
IMcadBOMStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBOMStandard2.

Interface

IMcadBOMStandard2 Interface

Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
GetUOMName | Get the available UOM (units of measure).
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadBOMStandard2 Interface, Legend, Methods, Properties


IMcadBOMStandard2::GetUOMName Method

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2::GetUOMName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard2::GetUOMName Method
IMcadBOMStandard2 Interface IMcadBOMStandard2 Members IMcadBOMStandard2 Interface Send Feedback
Summary

Get the available UOM (units of measure).

Visual Basic
Sub GetUOMName(UOMType As McadBOMUOMType, pVal As [out, retval] BSTR)
Interface

IMcadBOMStandard2 Interface

Links
IMcadBOMStandard2 Interface, IMcadBOMStandard2 Members, IMcadBOMStandard2 Interface


IMcadBorder Interface

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder Interface
IMcadBorder Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the drawing border of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadBorder
    IMcadBorder2
Visual Basic
Public Interface IMcadBorder
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadBorder Members, SymBBAuto Library, Class Hierarchy


IMcadBorder Members

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder Members
IMcadBorder Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBorder.

Interface

IMcadBorder Interface

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.
Links
IMcadBorder Interface, Legend, Methods, Properties


IMcadBorder::Attributes Property

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder::Attributes Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder::Attributes Property
IMcadBorder Interface IMcadBorder Members IMcadBorder Interface Send Feedback
Summary

Property that specifies all the attributes for the border.

Visual Basic
Property Attributes() As VARIANT
Interface

IMcadBorder Interface

Links
IMcadBorder Interface, IMcadBorder Members, IMcadBorder Interface


IMcadBorder::Extends Property

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder::Extends Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder::Extends Property
IMcadBorder Interface IMcadBorder Members IMcadBorder Interface Send Feedback
Summary

Property that returns the extents of the border.

Visual Basic
Property Extends() As VARIANT*
Interface

IMcadBorder Interface

Links
IMcadBorder Interface, IMcadBorder Members, IMcadBorder Interface


IMcadBorder::Name Property

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder::Name Property
IMcadBorder Interface IMcadBorder Members IMcadBorder Interface Send Feedback
Summary

Property that specifies the name identifier of the border.

Visual Basic
Property Name() As String
Interface

IMcadBorder Interface

Links
IMcadBorder Interface, IMcadBorder Members, IMcadBorder Interface


IMcadBorder::Position Property

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder::Position Property
IMcadBorder Interface IMcadBorder Members IMcadBorder Interface Send Feedback
Summary

Property that returns the position of the border.

Visual Basic
Property Position() As VARIANT*
Interface

IMcadBorder Interface

Links
IMcadBorder Interface, IMcadBorder Members, IMcadBorder Interface


IMcadBorder::SetToDefaultAttributes Method

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder::SetToDefaultAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder::SetToDefaultAttributes Method
IMcadBorder Interface IMcadBorder Members IMcadBorder Interface Send Feedback
Summary

Initialize default attributes of the border.

Visual Basic
Sub SetToDefaultAttributes(ret As [out, retval]VARIANT_BOOL)
Interface

IMcadBorder Interface

Links
IMcadBorder Interface, IMcadBorder Members, IMcadBorder Interface


IMcadColumnDefinition Interface

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition Interface
IMcadColumnDefinition Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
Visual Basic
Public Interface IMcadColumnDefinition
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadColumnDefinition Members, SymBBAuto Library, Class Hierarchy


IMcadColumnDefinition Members

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition Members
IMcadColumnDefinition Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadColumnDefinition.

Interface

IMcadColumnDefinition Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.
Links
IMcadColumnDefinition Interface, Legend, Properties


IMcadColumnDefinition::Application Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Application Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Caption Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Caption Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Caption Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the caption for the column.

Visual Basic
Property Caption() As String
Remarks

This property is a String.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::CaptionAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::CaptionAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::CaptionAlignment Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Property that specifies the BOM and Parts List column caption alignment types.

Visual Basic
Property CaptionAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column caption alignment type. This is the same as reading from the BOMCaptionAlignment property. Writing to this property sets the BOM and Parts List column caption alignment types. This is the same as writing to both the BOMCaptionAlignment and PartListCaptionAlignment properties. This property is a replaced by the BOMCaptionAlignment and PartListCaptionAlignment properties.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::ColumnType Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::ColumnType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::ColumnType Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the type of the column.

Visual Basic
Property ColumnType() As McadColumnType
Remarks

This property is a McadColumnType enumeration.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::DataAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::DataAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::DataAlignment Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Property that specifies the BOM and Parts List column data alignment types.

Visual Basic
Property DataAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column data alignment type. This is the same as reading from the BOMDataAlignment property. Writing to this property sets the BOM and Parts List column data alignment types. This is the same as writing to both the BOMDataAlignment and PartListDataAlignment properties. This property is a replaced by the BOMDataAlignment and PartListDataAlignment properties.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::DataType Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::DataType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::DataType Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the type of the data that the column specifies.

Visual Basic
Property DataType() As McadDataType
Remarks

This property is a McadDataType enumeration.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Equivalents Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Equivalents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Equivalents Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the list of equivalence strings for this column.

Visual Basic
Property Equivalents() As VARIANT
Remarks

If a column data value is defined as “=<equivalentString>” e.g. “=<NAME>”, then this column’s equivalents property will be a string array with the first (and only) element being “NAME”. This means that this column will show the value of the Name column. If we create a single string array with the first (and only) element set to “DESCR” and use this string array to set the equivalents property, then this column will now show the value of the description column.

Note that the equivalents property cannot have multiple string values.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Index Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Index Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Index Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the index of the column.

Visual Basic
Property Index() As long*
Remarks

This property is a Long.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Name Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Name Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the name of the column in a BOM database standard object.

Visual Basic
Property Name() As String
Remarks

This property is a String.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Precision Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Precision Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Precision Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.

Visual Basic
Property Precision() As long
Remarks

This property is a Long.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Size Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Size Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Size Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the data size for the column.

Visual Basic
Property Size() As long
Remarks

This property is a Long.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition::Width Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition::Width Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition::Width Property
IMcadColumnDefinition Interface IMcadColumnDefinition Members IMcadColumnDefinition Interface Send Feedback
Summary

Specifies the width of the column.

Visual Basic
Property Width() As double
Remarks

This property is a Double.

Interface

IMcadColumnDefinition Interface

Links
IMcadColumnDefinition Interface, IMcadColumnDefinition Members, IMcadColumnDefinition Interface


IMcadColumnDefinition2 Interface

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition2 Interface
IMcadColumnDefinition2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3
Visual Basic
Public Interface IMcadColumnDefinition2
Inherits IMcadColumnDefinition
Library

SymBBAuto Library

Links
IMcadColumnDefinition2 Members, SymBBAuto Library, Class Hierarchy


IMcadColumnDefinition2 Members

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface > IMcadColumnDefinition2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition2 Members
IMcadColumnDefinition2 Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadColumnDefinition2.

Interface

IMcadColumnDefinition2 Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.
Links
IMcadColumnDefinition2 Interface, Legend, Properties


IMcadColumnDefinition2::IsVisible Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface > IMcadColumnDefinition2::IsVisible Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition2::IsVisible Property
IMcadColumnDefinition2 Interface IMcadColumnDefinition2 Members IMcadColumnDefinition2 Interface Send Feedback
Summary

Checks whether the BOM table is visible, TRUE, or not, FALSE.

Visual Basic
Property IsVisible() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • For border BOM, isVisible will be true although it will not be listed in the browser. The BOM table not listed in the BOM Editor dialog will have isVisible set to false.
Interface

IMcadColumnDefinition2 Interface

Links
IMcadColumnDefinition2 Interface, IMcadColumnDefinition2 Members, IMcadColumnDefinition2 Interface


IMcadColumnDefinition3 Interface

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3 Interface
IMcadColumnDefinition3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the BOM column definition information.

Class Hierarchy

Declaration syntax

IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3
Visual Basic
Public Interface IMcadColumnDefinition3
Inherits IMcadColumnDefinition2
Library

SymBBAuto Library

Links
IMcadColumnDefinition3 Members, SymBBAuto Library, Class Hierarchy


IMcadColumnDefinition3 Members

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3 Members
IMcadColumnDefinition3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadColumnDefinition3.

Interface

IMcadColumnDefinition3 Interface

Methods
Name | Description
GetPreDefinedList | Retrieves the predefined list associated with this definition if any.
RemovePreDefinedList | Removes the predefined list associated with this definition.
SetPreDefinedList | Sets a predefined list to be associated with this definition.
Properties
Name | Description
Application | Gets the AcadmApplication object.
BOMCaptionAlignment | Property that specifies the BOM column caption alignment type.
BOMDataAlignment | Property that specifies the BOM column data alignment type.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsPreDefinedList | Indicates whether this definition is associated with a pre defined list.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
PartListCaptionAlignment | Property that specifies the Parts List column caption alignment type.
PartListDataAlignment | Property that specifies the Parts List column data alignment type.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.
Links
IMcadColumnDefinition3 Interface, Legend, Methods, Properties


IMcadColumnDefinition3::BOMCaptionAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::BOMCaptionAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::BOMCaptionAlignment Property
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Property that specifies the BOM column caption alignment type.

Visual Basic
Property BOMCaptionAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column caption alignment type. This is the same as reading from the CaptionAlignment property.

Writing to this property sets the BOM column caption alignment type. This is the same writing to the CaptionAlignment property. In addition, writing to the CaptionAlignment property also sets the Parts List column caption alignment type.

Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::BOMDataAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::BOMDataAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::BOMDataAlignment Property
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Property that specifies the BOM column data alignment type.

Visual Basic
Property BOMDataAlignment() As McadAlignmentType
Remarks

Reading from this property retrieves the BOM column data alignment type. This is the same as reading from the DataAlignment property.

Writing to this property sets the BOM column data alignment type. This is the same writing to the DataAlignment property. In addition, writing to the DataAlignment property also sets the Parts List column data alignment type.

Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::IsPreDefinedList Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::IsPreDefinedList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::IsPreDefinedList Property
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Indicates whether this definition is associated with a pre defined list.

Visual Basic
Property IsPreDefinedList() As VARIANT_BOOL*
Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::PartListCaptionAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::PartListCaptionAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::PartListCaptionAlignment Property
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Property that specifies the Parts List column caption alignment type.

Visual Basic
Property PartListCaptionAlignment() As McadAlignmentType
Parameters
Parameters | Description
penAlign | _nt_
Remarks

Writing to this property sets the Parts List column caption alignment type. This is the same writing to the CaptionAlignment property. In addition, writing to the CaptionAlignment property also sets the BOM column caption alignment type.

Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::PartListDataAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::PartListDataAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::PartListDataAlignment Property
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Property that specifies the Parts List column data alignment type.

Visual Basic
Property PartListDataAlignment() As McadAlignmentType
Remarks

Writing to this property sets the Parts List column data alignment type. This is the same writing to the DataAlignment property. In addition, writing to the DataAlignment property also sets the BOM column data alignment type.

Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::GetPreDefinedList Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::GetPreDefinedList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::GetPreDefinedList Method
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Retrieves the predefined list associated with this definition if any.

Visual Basic
Sub GetPreDefinedList(ByRef preList As VARIANT, ByRef def As String)
Parameters
Parameters | Description
preList | Array of string pair containing key, description.
def | The default key string, if any.
Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::RemovePreDefinedList Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::RemovePreDefinedList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::RemovePreDefinedList Method
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Removes the predefined list associated with this definition.

Visual Basic
Sub RemovePreDefinedList()
Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinition3::SetPreDefinedList Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3::SetPreDefinedList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3::SetPreDefinedList Method
IMcadColumnDefinition3 Interface IMcadColumnDefinition3 Members IMcadColumnDefinition3 Interface Send Feedback
Summary

Sets a predefined list to be associated with this definition.

Visual Basic
Sub SetPreDefinedList(preList As VARIANT, def As [in, optional] BSTR)
Parameters
Parameters | Description
preList | Array of string pair containing key, description.
def | The default key string, if any.
Remarks

It is not possible to set predefined list for columns like 'QTY', 'ITEM' and 'BOM_UNITS'.

Interface

IMcadColumnDefinition3 Interface

Links
IMcadColumnDefinition3 Interface, IMcadColumnDefinition3 Members, IMcadColumnDefinition3 Interface


IMcadColumnDefinitions Interface

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions Interface
IMcadColumnDefinitions Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadColumnDefinition objects

Class Hierarchy

Declaration syntax

IMcadColumnDefinitions
Visual Basic
Public Interface IMcadColumnDefinitions
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadColumnDefinitions Members, SymBBAuto Library, Class Hierarchy


IMcadColumnDefinitions Members

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions Members
IMcadColumnDefinitions Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadColumnDefinitions.

Interface

IMcadColumnDefinitions Interface

Methods
Name | Description
Add | Appends a specified column to this BOM database table.
Item | Gets the column at a specified index from this BOM database table.
Remove | Removes the column at a specified index from this BOM database table.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of column definitions in the collection.
Links
IMcadColumnDefinitions Interface, Legend, Methods, Properties


IMcadColumnDefinitions::Application Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions::Application Property
IMcadColumnDefinitions Interface IMcadColumnDefinitions Members IMcadColumnDefinitions Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadColumnDefinitions Interface

Links
IMcadColumnDefinitions Interface, IMcadColumnDefinitions Members, IMcadColumnDefinitions Interface


IMcadColumnDefinitions::Count Property

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions::Count Property
IMcadColumnDefinitions Interface IMcadColumnDefinitions Members IMcadColumnDefinitions Interface Send Feedback
Summary

Specifies the total number of column definitions in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadColumnDefinitions Interface

Links
IMcadColumnDefinitions Interface, IMcadColumnDefinitions Members, IMcadColumnDefinitions Interface


IMcadColumnDefinitions::Add Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions::Add Method
IMcadColumnDefinitions Interface IMcadColumnDefinitions Members IMcadColumnDefinitions Interface Send Feedback
Summary

Appends a specified column to this BOM database table.

Visual Basic
Sub Add(Item As IMcadColumnDefinition)
Parameters
Parameters | Description
Item | McadColumnDefinition object; input-only. Specifies the column to add to this BOM database table.
Returns

None

Interface

IMcadColumnDefinitions Interface

Links
IMcadColumnDefinitions Interface, IMcadColumnDefinitions Members, IMcadColumnDefinitions Interface


IMcadColumnDefinitions::Item Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions::Item Method
IMcadColumnDefinitions Interface IMcadColumnDefinitions Members IMcadColumnDefinitions Interface Send Feedback
Summary

Gets the column at a specified index from this BOM database table.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadColumnDefinition*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the column to get from this BOM database table.
Interface

IMcadColumnDefinitions Interface

Links
IMcadColumnDefinitions Interface, IMcadColumnDefinitions Members, IMcadColumnDefinitions Interface


IMcadColumnDefinitions::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions::Remove Method
IMcadColumnDefinitions Interface IMcadColumnDefinitions Members IMcadColumnDefinitions Interface Send Feedback
Summary

Removes the column at a specified index from this BOM database table.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the column to remove from this BOM database table.
Returns

None

Interface

IMcadColumnDefinitions Interface

Links
IMcadColumnDefinitions Interface, IMcadColumnDefinitions Members, IMcadColumnDefinitions Interface


IMcadDatumIdentifier Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implements datum identifier symbols.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
Visual Basic
Public Interface IMcadDatumIdentifier
Inherits IMcadIdentifier
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadDatumStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard Interface
IMcadDatumStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2
Visual Basic
Public Interface IMcadDatumStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadDatumStandard Members, SymBBAuto Library, Class Hierarchy


IMcadDatumStandard Members

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard Members
IMcadDatumStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumStandard.

Interface

IMcadDatumStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadDatumStandard Interface, Legend, Methods, Properties


IMcadDatumStandard::BorderLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::BorderLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::BorderLineType Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the linetype of a datum standard's border line.

Visual Basic
Property BorderLineType() As IAcadLineType*
Remarks
  • This property is a cadLineType.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.
Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::BorderLineTypeName Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::BorderLineTypeName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::BorderLineTypeName Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the name of the linetype of a datum identifier's border line.

Visual Basic
Property BorderLineTypeName() As String
Remarks

This property is a String.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::DrawLeaderArrow Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::DrawLeaderArrow Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::DrawLeaderArrow Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.

Visual Basic
Property DrawLeaderArrow() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::HatchAngle Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::HatchAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::HatchAngle Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.

Visual Basic
Property HatchAngle() As double
Remarks

This property defaults to the value specified by the HPANG system variable.

This property is a Double.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::HatchDistance Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::HatchDistance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::HatchDistance Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the distance between lines in the hatch pattern.

Visual Basic
Property HatchDistance() As double
Remarks

It defaults to the distance specified by the HPSPACE system variable.

This property is a Double.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::HiddenLeaderLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::HiddenLeaderLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::HiddenLeaderLineType Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the linetype of a datum identifier's hidden leader line.

Visual Basic
Property HiddenLeaderLineType() As IAcadLineType*
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.
Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::HiddenLeaderLineTypeName Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::HiddenLeaderLineTypeName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::HiddenLeaderLineTypeName Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the name of the linetype of a datum identifier's hidden leader line.

Visual Basic
Property HiddenLeaderLineTypeName() As String
Remarks

This property is a String.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::PointColor Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::PointColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::PointColor Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the point color of datum identifiers referencing this standard.

Visual Basic
Property PointColor() As ACAD_COLOR
Remarks

The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:

  • sbByBlock: If sbByBlock is specified, new balloon objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
  • sbByLayer: If sbByLayer is specified, new balloon objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard::PointSize Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard::PointSize Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard::PointSize Property
IMcadDatumStandard Interface IMcadDatumStandard Members IMcadDatumStandard Interface Send Feedback
Summary

Specifies the point size of datum identifiers referencing this standard.

Visual Basic
Property PointSize() As double
Remarks

This property is a Double.

Interface

IMcadDatumStandard Interface

Links
IMcadDatumStandard Interface, IMcadDatumStandard Members, IMcadDatumStandard Interface


IMcadDatumStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard2 Interface
IMcadDatumStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2
Visual Basic
Public Interface IMcadDatumStandard2
Inherits IMcadDatumStandard
Library

SymBBAuto Library

Links
IMcadDatumStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadDatumStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard2 Members
IMcadDatumStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumStandard2.

Interface

IMcadDatumStandard2 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
PointTrueColor | Specifies the true color of a point.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadDatumStandard2 Interface, Legend, Methods, Properties


IMcadDatumStandard2::PointTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2::PointTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard2::PointTrueColor Property
IMcadDatumStandard2 Interface IMcadDatumStandard2 Members IMcadDatumStandard2 Interface Send Feedback
Summary

Specifies the true color of a point.

Visual Basic
Property PointTrueColor() As IAcadAcCmColor *
Parameters
Parameters | Description
pVal | _nt_
Interface

IMcadDatumStandard2 Interface

Links
IMcadDatumStandard2 Interface, IMcadDatumStandard2 Members, IMcadDatumStandard2 Interface


IMcadDatumTarget Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget Interface
IMcadDatumTarget Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2
Visual Basic
Public Interface IMcadDatumTarget
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadDatumTarget Members, SymBBAuto Library, Class Hierarchy


IMcadDatumTarget Members

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget Members
IMcadDatumTarget Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumTarget.

Interface

IMcadDatumTarget Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.
Links
IMcadDatumTarget Interface, Legend, Methods, Properties


IMcadDatumTarget::CircleRadius Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::CircleRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::CircleRadius Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.

Visual Basic
Property CircleRadius() As double
Remarks

Double

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::DatumValue Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::DatumValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::DatumValue Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the value of the Datum field of the datum target.

Visual Basic
Property DatumValue() As String
Remarks

This property is a String.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::DimensionValue Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::DimensionValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::DimensionValue Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the dimension value for a datum target symbol.

Visual Basic
Property DimensionValue() As String
Remarks

This property is a String.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::DrawLine Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::DrawLine Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::DrawLine Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.

Visual Basic
Property DrawLine() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::DrawPoint Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::DrawPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::DrawPoint Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.

Visual Basic
Property DrawPoint() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::LeaderLinetypeHidden Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::LeaderLinetypeHidden Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::LeaderLinetypeHidden Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies whether the datum target leader's linetype is hidden.

Visual Basic
Property LeaderLinetypeHidden() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::LineEndPoint Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::LineEndPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::LineEndPoint Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the end point of the line target.

Visual Basic
Property LineEndPoint() As VARIANT
Remarks

This property is a only valid if the TargetType is sbLine.

This property is a Variant (3-element array of doubles).

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::LineFactor Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::LineFactor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::LineFactor Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.

Visual Basic
Property LineFactor() As double
Remarks

The property is a only valid if the TargetType is sbLine.

This property is a Double.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::LineMidPoint Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::LineMidPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::LineMidPoint Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Gets the midpoint of the line target, or the leader start point.

Visual Basic
Property LineMidPoint() As VARIANT*
Remarks

This property is a only valid if the TargetType is sbLine.

This property is a Variant (3-element array of doubles).

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::RectangleAngle Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::RectangleAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::RectangleAngle Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the angle of the rectangular area target.

Visual Basic
Property RectangleAngle() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::RectangleXSize Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::RectangleXSize Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::RectangleXSize Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the X axis length of the rectangular area target.

Visual Basic
Property RectangleXSize() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::RectangleYSize Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::RectangleYSize Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::RectangleYSize Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the Y axis length of the rectangular area target.

Visual Basic
Property RectangleYSize() As double
Remarks

This property is a only valid if the TargetType is sbRectangular.

This property is a Double.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::TargetOrigin Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::TargetOrigin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::TargetOrigin Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the origin point of the datum target subsymbol.

Visual Basic
Property TargetOrigin() As VARIANT
Remarks

This property is a Variant (3-element array of doubles).

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget::TargetType Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget::TargetType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget::TargetType Property
IMcadDatumTarget Interface IMcadDatumTarget Members IMcadDatumTarget Interface Send Feedback
Summary

Specifies the termination type for a datum target.

Visual Basic
Property TargetType() As McadTargetType
Remarks

This property is a McadTargetType enumeration. It should only be called during the creation of a datum target, as the target type cannot be changed for existing datum target objects.

Interface

IMcadDatumTarget Interface

Links
IMcadDatumTarget Interface, IMcadDatumTarget Members, IMcadDatumTarget Interface


IMcadDatumTarget2 Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2 Interface
IMcadDatumTarget2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A datum target symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2
Visual Basic
Public Interface IMcadDatumTarget2
Inherits IMcadDatumTarget
Library

SymBBAuto Library

Links
IMcadDatumTarget2 Members, SymBBAuto Library, Class Hierarchy


IMcadDatumTarget2 Members

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2 Members
IMcadDatumTarget2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumTarget2.

Interface

IMcadDatumTarget2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetTargetAttach | Specifies the datum target to attach.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleCornerPoint | Specifies the rectangle corner point.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.
Links
IMcadDatumTarget2 Interface, Legend, Methods, Properties


IMcadDatumTarget2::RectangleCornerPoint Property

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2::RectangleCornerPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2::RectangleCornerPoint Property
IMcadDatumTarget2 Interface IMcadDatumTarget2 Members IMcadDatumTarget2 Interface Send Feedback
Summary

Specifies the rectangle corner point.

Visual Basic
Property RectangleCornerPoint() As VARIANT
Remarks

This property is only used for datum targets with McadTargetType = sbRectangular.

Interface

IMcadDatumTarget2 Interface

Links
IMcadDatumTarget2 Interface, IMcadDatumTarget2 Members, IMcadDatumTarget2 Interface


IMcadDatumTarget2::SetTargetAttach Method

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2::SetTargetAttach Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2::SetTargetAttach Method
IMcadDatumTarget2 Interface IMcadDatumTarget2 Members IMcadDatumTarget2 Interface Send Feedback
Summary

Specifies the datum target to attach.

Visual Basic
Sub SetTargetAttach(pDatumTarget As IMcadDatumTarget, Position As McadAttachPosition)
Parameters
Parameters | Description
pDatumTarget | Datum target to attach.
Position | Position of the datum target to attach.
Remarks

This method is only used for datum target with McadTargetType = sbAttach.

Interface

IMcadDatumTarget2 Interface

Links
IMcadDatumTarget2 Interface, IMcadDatumTarget2 Members, IMcadDatumTarget2 Interface


IMcadDetailSymbol Interface

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol Interface
IMcadDetailSymbol Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the detail symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbol
Visual Basic
Public Interface IMcadDetailSymbol
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadDetailSymbol Members, SymBBAuto Library, Class Hierarchy


IMcadDetailSymbol Members

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol Members
IMcadDetailSymbol Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDetailSymbol.

Interface

IMcadDetailSymbol Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateLabelEntity | Create detail symbol label.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetSourceGeometry | Set source geometry for the symbol.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
BaseViewScale | Specifies scale of the base view.
CoordinateSystem | Specifies the coordinate system for the symbol.
CorrectionScaleFactor | Specifies scale factor when specify by factor.
DetailScale | Specifies scale of the detail View.
IsAssociativeDetail | Specifies whether to create associative details.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelEntity | Specifies the detail symbol label object.
LabelEntityOffset | Specifies the offset of the label.
LabelName | Specifies name of the label for the detail view.
LabelPattern | Specifies the label pattern for the detail view.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Radius | Specifies radius of the base view.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
SpecByAbsoluteScale | Specifies detail View to specify by absolute scale.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadDetailSymbol Interface, Legend, Methods, Properties


IMcadDetailSymbol::AnnotationOffset Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::AnnotationOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::AnnotationOffset Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies offset of the annotation.

Visual Basic
Property AnnotationOffset() As VARIANT
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::BaseViewScale Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::BaseViewScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::BaseViewScale Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies scale of the base view.

Visual Basic
Property BaseViewScale() As double
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::CorrectionScaleFactor Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::CorrectionScaleFactor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::CorrectionScaleFactor Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies scale factor when specify by factor.

Visual Basic
Property CorrectionScaleFactor() As double
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::DetailScale Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::DetailScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::DetailScale Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies scale of the detail View.

Visual Basic
Property DetailScale() As double
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::IsAssociativeDetail Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::IsAssociativeDetail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::IsAssociativeDetail Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies whether to create associative details.

Visual Basic
Property IsAssociativeDetail() As VARIANT_BOOL
Remarks

Note that this property is a not available for some standards.

Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::LabelEntity Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::LabelEntity Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::LabelEntity Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies the detail symbol label object.

Visual Basic
Property LabelEntity() As IMcadDetailSymbolLabel*
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::LabelEntityOffset Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::LabelEntityOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::LabelEntityOffset Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies the offset of the label.

Visual Basic
Property LabelEntityOffset() As VARIANT
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::LabelName Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::LabelName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::LabelName Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies name of the label for the detail view.

Visual Basic
Property LabelName() As String
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::LabelPattern Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies the label pattern for the detail view.

Visual Basic
Property LabelPattern() As String
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::LabelText Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::LabelText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::LabelText Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::Radius Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::Radius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::Radius Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies radius of the base view.

Visual Basic
Property Radius() As double
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::ShowAnnotationLeader Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::ShowAnnotationLeader Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::ShowAnnotationLeader Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies to show the annotation leader.

Visual Basic
Property ShowAnnotationLeader() As VARIANT_BOOL
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::ShowBorder Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::ShowBorder Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::ShowBorder Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies to show the view border.

Visual Basic
Property ShowBorder() As VARIANT_BOOL
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::ShowLeader Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::ShowLeader Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::ShowLeader Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies to show the leader.

Visual Basic
Property ShowLeader() As VARIANT_BOOL
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::SpecByAbsoluteScale Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::SpecByAbsoluteScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::SpecByAbsoluteScale Property
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Specifies detail View to specify by absolute scale.

Visual Basic
Property SpecByAbsoluteScale() As VARIANT_BOOL
Remarks

VARIANT_TRUE indicates specify by absolute scale. VARIANT_FALSE indicates specify by factor.

Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::CreateLabelEntity Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::CreateLabelEntity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::CreateLabelEntity Method
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Create detail symbol label.

Visual Basic
Sub CreateLabelEntity(Origin As VARIANT)
Parameters
Parameters | Description
Origin | Input origin of the detail symbol label. The VARIANT is a 3-element array of doubles for x, y, and z points.
Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbol::SetSourceGeometry Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol::SetSourceGeometry Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol::SetSourceGeometry Method
IMcadDetailSymbol Interface IMcadDetailSymbol Members IMcadDetailSymbol Interface Send Feedback
Summary

Set source geometry for the symbol.

Visual Basic
Sub SetSourceGeometry(pVal As IAcadEntity)
Parameters
Parameters | Description
pVal | Geometry to be used as source geometry
Remarks

The entity should be a curve object except for 3D polyline.

Interface

IMcadDetailSymbol Interface

Links
IMcadDetailSymbol Interface, IMcadDetailSymbol Members, IMcadDetailSymbol Interface


IMcadDetailSymbolLabel Interface

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel Interface
IMcadDetailSymbolLabel Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the detail symbol label created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbolLabel
Visual Basic
Public Interface IMcadDetailSymbolLabel
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadDetailSymbolLabel Members, SymBBAuto Library, Class Hierarchy


IMcadDetailSymbolLabel Members

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel Members
IMcadDetailSymbolLabel Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDetailSymbolLabel.

Interface

IMcadDetailSymbolLabel Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelAbove | Specifies position of the label.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolEntity | Specifies the detail symbol object.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadDetailSymbolLabel Interface, Legend, Methods, Properties


IMcadDetailSymbolLabel::AnnotationOffset Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel::AnnotationOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel::AnnotationOffset Property
IMcadDetailSymbolLabel Interface IMcadDetailSymbolLabel Members IMcadDetailSymbolLabel Interface Send Feedback
Summary

Specifies offset of the annotation.

Visual Basic
Property AnnotationOffset() As VARIANT
Interface

IMcadDetailSymbolLabel Interface

Links
IMcadDetailSymbolLabel Interface, IMcadDetailSymbolLabel Members, IMcadDetailSymbolLabel Interface


IMcadDetailSymbolLabel::LabelAbove Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel::LabelAbove Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel::LabelAbove Property
IMcadDetailSymbolLabel Interface IMcadDetailSymbolLabel Members IMcadDetailSymbolLabel Interface Send Feedback
Summary

Specifies position of the label.

Visual Basic
Property LabelAbove() As VARIANT_BOOL
Parameters
Parameters | Description
pVal | VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
Interface

IMcadDetailSymbolLabel Interface

Links
IMcadDetailSymbolLabel Interface, IMcadDetailSymbolLabel Members, IMcadDetailSymbolLabel Interface


IMcadDetailSymbolLabel::LabelText Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel::LabelText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel::LabelText Property
IMcadDetailSymbolLabel Interface IMcadDetailSymbolLabel Members IMcadDetailSymbolLabel Interface Send Feedback
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*
Interface

IMcadDetailSymbolLabel Interface

Links
IMcadDetailSymbolLabel Interface, IMcadDetailSymbolLabel Members, IMcadDetailSymbolLabel Interface


IMcadDetailSymbolLabel::SymbolEntity Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel::SymbolEntity Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel::SymbolEntity Property
IMcadDetailSymbolLabel Interface IMcadDetailSymbolLabel Members IMcadDetailSymbolLabel Interface Send Feedback
Summary

Specifies the detail symbol object.

Visual Basic
Property SymbolEntity() As IMcadDetailSymbol*
Interface

IMcadDetailSymbolLabel Interface

Links
IMcadDetailSymbolLabel Interface, IMcadDetailSymbolLabel Members, IMcadDetailSymbolLabel Interface


IMcadDetailSymbolStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard Interface
IMcadDetailSymbolStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Detail symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2
Visual Basic
Public Interface IMcadDetailSymbolStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadDetailSymbolStandard Members, SymBBAuto Library, Class Hierarchy


IMcadDetailSymbolStandard Members

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard Members
IMcadDetailSymbolStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDetailSymbolStandard.

Interface

IMcadDetailSymbolStandard Interface

Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of the detail border.
LabelAbove | Specifies position of the label.
LabelPattern | Specifies the label pattern for the detail view.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadDetailSymbolStandard Interface, Legend, Methods, Properties


IMcadDetailSymbolStandard::AllowedScales Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::AllowedScales Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::AllowedScales Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies the list of allowable scales.

Visual Basic
Property AllowedScales() As VARIANT
Remarks

The Variant is an array of double.

Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::BorderLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::BorderLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::BorderLineType Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies the linetype of the detail border.

Visual Basic
Property BorderLineType() As String
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::LabelAbove Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::LabelAbove Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::LabelAbove Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies position of the label.

Visual Basic
Property LabelAbove() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::LabelPattern Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies the label pattern for the detail view.

Visual Basic
Property LabelPattern() As String
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::ShowAnnotationLeader Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::ShowAnnotationLeader Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::ShowAnnotationLeader Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies to show the annotation leader.

Visual Basic
Property ShowAnnotationLeader() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::ShowBorder Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::ShowBorder Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::ShowBorder Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies to show the view border.

Visual Basic
Property ShowBorder() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::ShowLeader Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::ShowLeader Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::ShowLeader Property
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Specifies to show the leader.

Visual Basic
Property ShowLeader() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::AddAllowedScale Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::AddAllowedScale Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::AddAllowedScale Method
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Add scale to the list of allowable scales.

Visual Basic
Sub AddAllowedScale(scale As double)
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard::EraseAllowedScales Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard::EraseAllowedScales Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard::EraseAllowedScales Method
IMcadDetailSymbolStandard Interface IMcadDetailSymbolStandard Members IMcadDetailSymbolStandard Interface Send Feedback
Summary

Remove all allowable scales.

Visual Basic
Sub EraseAllowedScales()
Interface

IMcadDetailSymbolStandard Interface

Links
IMcadDetailSymbolStandard Interface, IMcadDetailSymbolStandard Members, IMcadDetailSymbolStandard Interface


IMcadDetailSymbolStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2 Interface MG2013New
IMcadDetailSymbolStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This interface is derived from IMcadDetailSymbolStandard. It is used for the detail view standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2
Visual Basic
Public Interface IMcadDetailSymbolStandard2
Inherits IMcadDetailSymbolStandard
Library

SymBBAuto Library

Links
IMcadDetailSymbolStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadDetailSymbolStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2 Members
IMcadDetailSymbolStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDetailSymbolStandard2.

Interface

IMcadDetailSymbolStandard2 Interface

Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
GetByStandard | Gets if the specified detail view property follow the standard.
SetByStandard | Sets if the specified detail view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineColor | Specifies the color of the border line.
BorderLineLineType | Specifies the linetype of the border line.
BorderLineType | Specifies the linetype of the detail border.
BorderLineWeight | Specifies the lineweight of the border line.
BoundaryLineColor | Specifies the color of the boundary line.
BoundaryLineType | Specifies the linetype of the boundary line.
BoundaryLineWeight | Specifies the lineweight of the boundary line.
ConnectionLineColor | Specifies the color of the connection line.
ConnectionLineType | Specifies the linetype of the connection line.
ConnectionLineWeight | Specifies the lineweight of the connection line.
IdentifierOutsideBoundary | Specifies if the identifier is placed outside the boundary.
LabelAbove | Specifies position of the label.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern for the detail view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLabel | Specifies if show label.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadDetailSymbolStandard2 Interface, Legend, Methods, Properties


IMcadDetailSymbolStandard2::BorderLineColor Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BorderLineColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BorderLineColor Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the color of the border line.

Visual Basic
Property BorderLineColor() As IAcadAcCmColor*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::BorderLineLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BorderLineLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BorderLineLineType Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the linetype of the border line.

Visual Basic
Property BorderLineLineType() As IAcadLineType*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::BorderLineWeight Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BorderLineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BorderLineWeight Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the lineweight of the border line.

Visual Basic
Property BorderLineWeight() As ACAD_LWEIGHT
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::BoundaryLineColor Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BoundaryLineColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BoundaryLineColor Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the color of the boundary line.

Visual Basic
Property BoundaryLineColor() As IAcadAcCmColor*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::BoundaryLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BoundaryLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BoundaryLineType Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the linetype of the boundary line.

Visual Basic
Property BoundaryLineType() As IAcadLineType*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::BoundaryLineWeight Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::BoundaryLineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::BoundaryLineWeight Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the lineweight of the boundary line.

Visual Basic
Property BoundaryLineWeight() As ACAD_LWEIGHT
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::ConnectionLineColor Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::ConnectionLineColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::ConnectionLineColor Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the color of the connection line.

Visual Basic
Property ConnectionLineColor() As IAcadAcCmColor*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::ConnectionLineType Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::ConnectionLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::ConnectionLineType Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the linetype of the connection line.

Visual Basic
Property ConnectionLineType() As IAcadLineType*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::ConnectionLineWeight Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::ConnectionLineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::ConnectionLineWeight Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the lineweight of the connection line.

Visual Basic
Property ConnectionLineWeight() As ACAD_LWEIGHT
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies if the identifier is placed outside the boundary.

Visual Basic
Property IdentifierOutsideBoundary() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::LabelOffset Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::LabelOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::LabelOffset Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the label offset from section view.

Visual Basic
Property LabelOffset() As double
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::LabelTextColor Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::LabelTextColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::LabelTextColor Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the text color of view label.

Visual Basic
Property LabelTextColor() As IAcadAcCmColor*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::LabelTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::LabelTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::LabelTextHeight Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the text height of view label.

Visual Basic
Property LabelTextHeight() As double
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::LabelTextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::LabelTextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::LabelTextStyle Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies the text style of view label.

Visual Basic
Property LabelTextStyle() As IAcadTextStyle*
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::ShowLabel Property

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::ShowLabel Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::ShowLabel Property MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Specifies if show label.

Visual Basic
Property ShowLabel() As VARIANT_BOOL
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::GetByStandard Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::GetByStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::GetByStandard Method MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Gets if the specified detail view property follow the standard.

Visual Basic
Sub GetByStandard(propType As McadDetailSymbolStandardPropType, pVal As [out, retval] VARIANT_BOOL)
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDetailSymbolStandard2::SetByStandard Method

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2::SetByStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2::SetByStandard Method MG2013New
IMcadDetailSymbolStandard2 Interface IMcadDetailSymbolStandard2 Members IMcadDetailSymbolStandard2 Interface Send Feedback
Summary

Sets if the specified detail view property follow the standard.

Visual Basic
Sub SetByStandard(propType As McadDetailSymbolStandardPropType, newVal As VARIANT_BOOL)
Interface

IMcadDetailSymbolStandard2 Interface

Links
IMcadDetailSymbolStandard2 Interface, IMcadDetailSymbolStandard2 Members, IMcadDetailSymbolStandard2 Interface


IMcadDocument Interface

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument Interface
IMcadDocument Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.

Class Hierarchy

Declaration syntax

IMcadDocument
Visual Basic
Public Interface IMcadDocument
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadDocument Members, SymBBAuto Library, Class Hierarchy


IMcadDocument Members

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument Members
IMcadDocument Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDocument.

Interface

IMcadDocument Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
LayerGroupMgr | Returns the layer group manager for the document.
LayerObjectMgr | This is LayerObjectMgr, a member of class IMcadDocument.
StructureMgr2D | Gets the 2D structure manager object for the document.
Utility | Gets the utility object.
Links
IMcadDocument Interface, Legend, Properties


IMcadDocument::Application Property

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument::Application Property
IMcadDocument Interface IMcadDocument Members IMcadDocument Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Remarks

This property is a AcadmApplication object.

Interface

IMcadDocument Interface

Links
IMcadDocument Interface, IMcadDocument Members, IMcadDocument Interface


IMcadDocument::LayerGroupMgr Property

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument::LayerGroupMgr Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument::LayerGroupMgr Property
IMcadDocument Interface IMcadDocument Members IMcadDocument Interface Send Feedback
Summary

Returns the layer group manager for the document.

Visual Basic
Property LayerGroupMgr() As IMcadLayerGroupMgr**
Remarks

This property is a McadLayerGroupMgr object.

Interface

IMcadDocument Interface

Links
IMcadDocument Interface, IMcadDocument Members, IMcadDocument Interface


IMcadDocument::LayerObjectMgr Property

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument::LayerObjectMgr Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument::LayerObjectMgr Property
IMcadDocument Interface IMcadDocument Members IMcadDocument Interface Send Feedback
Summary

This is LayerObjectMgr, a member of class IMcadDocument.

Visual Basic
Property LayerObjectMgr() As IMcadLayerObjectMgr**
Interface

IMcadDocument Interface

Links
IMcadDocument Interface, IMcadDocument Members, IMcadDocument Interface


IMcadDocument::StructureMgr2D Property

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument::StructureMgr2D Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument::StructureMgr2D Property
IMcadDocument Interface IMcadDocument Members IMcadDocument Interface Send Feedback
Summary

Gets the 2D structure manager object for the document.

Visual Basic
Property StructureMgr2D() As IMcad2DStructureMgr2**
Remarks

This property is a Mcad2DStructureMgr object.

Interface

IMcadDocument Interface

Links
IMcadDocument Interface, IMcadDocument Members, IMcadDocument Interface


IMcadDocument::Utility Property

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument::Utility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument::Utility Property
IMcadDocument Interface IMcadDocument Members IMcadDocument Interface Send Feedback
Summary

Gets the utility object.

Visual Basic
Property Utility() As IMcadUtility**
Remarks

This property is a McadUtility object.

Interface

IMcadDocument Interface

Links
IMcadDocument Interface, IMcadDocument Members, IMcadDocument Interface


IMcadEdge Interface

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge Interface
IMcadEdge Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the edge symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadEdge
Visual Basic
Public Interface IMcadEdge
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadEdge Members, SymBBAuto Library, Class Hierarchy


IMcadEdge Members

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge Members
IMcadEdge Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadEdge.

Interface

IMcadEdge Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllAround | Specifies the all-around designation for the edge symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
Direction | Property that specifies if the direction of the edge symbol's size is defined.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Majority | Specifies the appearance of the majority symbol.
MaxValue | Specifies the value of the upper boundary for the edge symbol.
MinValue | Specifies the value of the lower boundary for the edge symbol.
NewSymbolRev | Specifies if the edge symbol follows new standard revision.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SignValue | Specifies the sign ("+" or "-") for the edge symbol.
Standard | Gets the standard this symbol is used in.
StandardNumber | Specifies if the edge symbol displays the standard number.
SymbolStandard | Specifies the symbol standard for a symbol.
UndefsizeDirection | Property that specifies the direction for the edge symbol's undefined size.
Links
IMcadEdge Interface, Legend, Methods, Properties


IMcadEdge::AllAround Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::AllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::AllAround Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies the all-around designation for the edge symbol.

Visual Basic
Property AllAround() As VARIANT_BOOL
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::Direction Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::Direction Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::Direction Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Property that specifies if the direction of the edge symbol's size is defined.

Visual Basic
Property Direction() As VARIANT_BOOL
Remarks

TRUE indicates the direction is defined. FALSE indicates undefined.

Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::Majority Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::Majority Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::Majority Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies the appearance of the majority symbol.

Visual Basic
Property Majority() As VARIANT_BOOL
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::MaxValue Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::MaxValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::MaxValue Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies the value of the upper boundary for the edge symbol.

Visual Basic
Property MaxValue() As String
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::MinValue Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::MinValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::MinValue Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies the value of the lower boundary for the edge symbol.

Visual Basic
Property MinValue() As String
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::NewSymbolRev Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::NewSymbolRev Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::NewSymbolRev Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies if the edge symbol follows new standard revision.

Visual Basic
Property NewSymbolRev() As VARIANT_BOOL
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::SignValue Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::SignValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::SignValue Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies the sign ("+" or "-") for the edge symbol.

Visual Basic
Property SignValue() As McadUndefinedSize
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::StandardNumber Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::StandardNumber Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::StandardNumber Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Specifies if the edge symbol displays the standard number.

Visual Basic
Property StandardNumber() As VARIANT_BOOL
Remarks

This is supported only for DIN standard.

Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdge::UndefsizeDirection Property

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge::UndefsizeDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge::UndefsizeDirection Property
IMcadEdge Interface IMcadEdge Members IMcadEdge Interface Send Feedback
Summary

Property that specifies the direction for the edge symbol's undefined size.

Visual Basic
Property UndefsizeDirection() As McadUndefinedSizeDirection
Interface

IMcadEdge Interface

Links
IMcadEdge Interface, IMcadEdge Members, IMcadEdge Interface


IMcadEdgeLibrary Interface

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibrary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibrary Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

The object representing Edge library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadEdgeLibrary
Visual Basic
Public Interface IMcadEdgeLibrary
Inherits IMcadSymbolLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadEdgeLibraryObject Interface

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject Interface
IMcadEdgeLibraryObject Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The Edge library object.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject
Visual Basic
Public Interface IMcadEdgeLibraryObject
Inherits IMcadSymbolLibraryObject
Library

SymBBAuto Library

Links
IMcadEdgeLibraryObject Members, SymBBAuto Library, Class Hierarchy


IMcadEdgeLibraryObject Members

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject Members
IMcadEdgeLibraryObject Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadEdgeLibraryObject.

Interface

IMcadEdgeLibraryObject Interface

Methods
Name | Description
RequirementValue | Property to get the main requirement value for the Edge symbol type.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" indication.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsDefinedDirection | Get if the direction of the symbol library object's size is defined.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
StandardNumber | Get the usage of the Standard label note for the symbol library object.
symbolStandardClassName | Get the symbol standard class name.
UndefsizeDirection | Get the direction for the symbol library object's undefined size.
Links
IMcadEdgeLibraryObject Interface, Legend, Methods, Properties


IMcadEdgeLibraryObject::IsAllAround Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::IsAllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::IsAllAround Property
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Get the usage of the "all around" indication.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeLibraryObject::IsDefinedDirection Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::IsDefinedDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::IsDefinedDirection Property
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Get if the direction of the symbol library object's size is defined.

Visual Basic
Property IsDefinedDirection() As VARIANT_BOOL*
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeLibraryObject::IsMajority Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::IsMajority Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::IsMajority Property
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Get the usage of the majority symbol.

Visual Basic
Property IsMajority() As VARIANT_BOOL*
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeLibraryObject::StandardNumber Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::StandardNumber Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::StandardNumber Property
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Get the usage of the Standard label note for the symbol library object.

Visual Basic
Property StandardNumber() As VARIANT_BOOL*
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeLibraryObject::UndefsizeDirection Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::UndefsizeDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::UndefsizeDirection Property
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Get the direction for the symbol library object's undefined size.

Visual Basic
Property UndefsizeDirection() As McadUndefinedSizeDirection*
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeLibraryObject::RequirementValue Method

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject::RequirementValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject::RequirementValue Method
IMcadEdgeLibraryObject Interface IMcadEdgeLibraryObject Members IMcadEdgeLibraryObject Interface Send Feedback
Summary

Property to get the main requirement value for the Edge symbol type.

Visual Basic
Sub RequirementValue(variable As McadEdgeRequirement, pVal As [out,retval] BSTR)
Interface

IMcadEdgeLibraryObject Interface

Links
IMcadEdgeLibraryObject Interface, IMcadEdgeLibraryObject Members, IMcadEdgeLibraryObject Interface


IMcadEdgeStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard Interface
IMcadEdgeStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the edge symbol standard, Edges of Workpieces standard element.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadEdgeStandard
Visual Basic
Public Interface IMcadEdgeStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadEdgeStandard Members, SymBBAuto Library, Class Hierarchy


IMcadEdgeStandard Members

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard Members
IMcadEdgeStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadEdgeStandard.

Interface

IMcadEdgeStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all-around designation is allowed in the edge symbol.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
FullList | Specifies whether the majority symbol is full list or simplified.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether the majority symbol is allowed in the edge symbol.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
StandardNumAllowed | Specifies whether the standard number is allowed to be displayed in the edge symbol.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadEdgeStandard Interface, Legend, Methods, Properties


IMcadEdgeStandard::AllAroundAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard::AllAroundAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard::AllAroundAllowed Property
IMcadEdgeStandard Interface IMcadEdgeStandard Members IMcadEdgeStandard Interface Send Feedback
Summary

Specifies whether the all-around designation is allowed in the edge symbol.

Visual Basic
Property AllAroundAllowed() As VARIANT_BOOL
Interface

IMcadEdgeStandard Interface

Links
IMcadEdgeStandard Interface, IMcadEdgeStandard Members, IMcadEdgeStandard Interface


IMcadEdgeStandard::FullList Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard::FullList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard::FullList Property
IMcadEdgeStandard Interface IMcadEdgeStandard Members IMcadEdgeStandard Interface Send Feedback
Summary

Specifies whether the majority symbol is full list or simplified.

Visual Basic
Property FullList() As VARIANT_BOOL
Interface

IMcadEdgeStandard Interface

Links
IMcadEdgeStandard Interface, IMcadEdgeStandard Members, IMcadEdgeStandard Interface


IMcadEdgeStandard::MajorityAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard::MajorityAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard::MajorityAllowed Property
IMcadEdgeStandard Interface IMcadEdgeStandard Members IMcadEdgeStandard Interface Send Feedback
Summary

Specifies whether the majority symbol is allowed in the edge symbol.

Visual Basic
Property MajorityAllowed() As VARIANT_BOOL
Interface

IMcadEdgeStandard Interface

Links
IMcadEdgeStandard Interface, IMcadEdgeStandard Members, IMcadEdgeStandard Interface


IMcadEdgeStandard::StandardNumAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard::StandardNumAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard::StandardNumAllowed Property
IMcadEdgeStandard Interface IMcadEdgeStandard Members IMcadEdgeStandard Interface Send Feedback
Summary

Specifies whether the standard number is allowed to be displayed in the edge symbol.

Visual Basic
Property StandardNumAllowed() As VARIANT_BOOL*
Remarks

The default setting is set to TRUE for DIN standard only.

Interface

IMcadEdgeStandard Interface

Links
IMcadEdgeStandard Interface, IMcadEdgeStandard Members, IMcadEdgeStandard Interface


IMcadFCFLibrary Interface

You are here: API Reference > SymBBAuto Library > IMcadFCFLibrary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibrary Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

Object representing the Feature Control Frame library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadFCFLibrary
Visual Basic
Public Interface IMcadFCFLibrary
Inherits IMcadSymbolLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadFCFLibraryObject Interface

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject Interface
IMcadFCFLibraryObject Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The Feature Control Frame library object.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadFCFLibraryObject
Visual Basic
Public Interface IMcadFCFLibraryObject
Inherits IMcadSymbolLibraryObject
Library

SymBBAuto Library

Links
IMcadFCFLibraryObject Members, SymBBAuto Library, Class Hierarchy


IMcadFCFLibraryObject Members

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject Members
IMcadFCFLibraryObject Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFCFLibraryObject.

Interface

IMcadFCFLibraryObject Interface

Methods
Name | Description
RequirementValue | Property to get the main requirement value for the FCF symbol type.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
Symbol | Get the geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol2 | Get the secondary geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol3 | Get the third geometric dimensioning and tolerancing symbol of a feature control frame library object.
symbolStandardClassName | Get the symbol standard class name.
Links
IMcadFCFLibraryObject Interface, Legend, Methods, Properties


IMcadFCFLibraryObject::IsAllAround Property

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject::IsAllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject::IsAllAround Property
IMcadFCFLibraryObject Interface IMcadFCFLibraryObject Members IMcadFCFLibraryObject Interface Send Feedback
Summary

Get the usage of the "all around" symbol.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*
Interface

IMcadFCFLibraryObject Interface

Links
IMcadFCFLibraryObject Interface, IMcadFCFLibraryObject Members, IMcadFCFLibraryObject Interface


IMcadFCFLibraryObject::Symbol Property

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject::Symbol Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject::Symbol Property
IMcadFCFLibraryObject Interface IMcadFCFLibraryObject Members IMcadFCFLibraryObject Interface Send Feedback
Summary

Get the geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol() As McadGDTSymbolType*
Interface

IMcadFCFLibraryObject Interface

Links
IMcadFCFLibraryObject Interface, IMcadFCFLibraryObject Members, IMcadFCFLibraryObject Interface


IMcadFCFLibraryObject::Symbol2 Property

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject::Symbol2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject::Symbol2 Property
IMcadFCFLibraryObject Interface IMcadFCFLibraryObject Members IMcadFCFLibraryObject Interface Send Feedback
Summary

Get the secondary geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol2() As McadGDTSymbolType*
Interface

IMcadFCFLibraryObject Interface

Links
IMcadFCFLibraryObject Interface, IMcadFCFLibraryObject Members, IMcadFCFLibraryObject Interface


IMcadFCFLibraryObject::Symbol3 Property

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject::Symbol3 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject::Symbol3 Property
IMcadFCFLibraryObject Interface IMcadFCFLibraryObject Members IMcadFCFLibraryObject Interface Send Feedback
Summary

Get the third geometric dimensioning and tolerancing symbol of a feature control frame library object.

Visual Basic
Property Symbol3() As McadGDTSymbolType*
Interface

IMcadFCFLibraryObject Interface

Links
IMcadFCFLibraryObject Interface, IMcadFCFLibraryObject Members, IMcadFCFLibraryObject Interface


IMcadFCFLibraryObject::RequirementValue Method

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject::RequirementValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject::RequirementValue Method
IMcadFCFLibraryObject Interface IMcadFCFLibraryObject Members IMcadFCFLibraryObject Interface Send Feedback
Summary

Property to get the main requirement value for the FCF symbol type.

Visual Basic
Sub RequirementValue(variable As McadFCFRequirement, pVal As [out,retval] BSTR)
Interface

IMcadFCFLibraryObject Interface

Links
IMcadFCFLibraryObject Interface, IMcadFCFLibraryObject Members, IMcadFCFLibraryObject Interface


IMcadFCFStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard Interface
IMcadFCFStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A feature control frame symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2
Visual Basic
Public Interface IMcadFCFStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadFCFStandard Members, SymBBAuto Library, Class Hierarchy


IMcadFCFStandard Members

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard Members
IMcadFCFStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFCFStandard.

Interface

IMcadFCFStandard Interface

Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadFCFStandard Interface, Legend, Methods, Properties


IMcadFCFStandard::AvailableAuxiliarySymbols Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::AvailableAuxiliarySymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::AvailableAuxiliarySymbols Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.

Visual Basic
Property AvailableAuxiliarySymbols() As VARIANT*
Remarks

The OfferedAuxiliarySymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant(array of McadGDTSymbolType enumeration).

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::AvailableGDTSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::AvailableGDTSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::AvailableGDTSymbols Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.

Visual Basic
Property AvailableGDTSymbols() As VARIANT *
Remarks

The OfferedGDTSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant(array of McadGDTSymbolType enumeration).

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::EndPadding Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::EndPadding Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::EndPadding Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property EndPadding() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::FrameGap Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::FrameGap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::FrameGap Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.

Visual Basic
Property FrameGap() As double
Remarks

This property is a Double.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::GDTTextFont Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::GDTTextFont Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::GDTTextFont Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.

Visual Basic
Property GDTTextFont() As BSTR*
Remarks

This property is a String.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::GDTTextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::GDTTextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::GDTTextStyle Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.

Visual Basic
Property GDTTextStyle() As IAcadTextStyle*
Remarks
  • This property is a cadTextStyle object.
  • AcadTextStyle (TextStyle) object is an object the AutoCAD ActiveX and VBA Reference documentation. It is a named and saved collection of settings that determines the appearance of text characters.
Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::GDTTextStyleName Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::GDTTextStyleName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::GDTTextStyleName Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.

Visual Basic
Property GDTTextStyleName() As String
Remarks

This property is a String.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::MergeDatum Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::MergeDatum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::MergeDatum Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeDatum() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::MergeSymbol Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::MergeSymbol Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::MergeSymbol Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeSymbol() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::MergeTolerance Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::MergeTolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::MergeTolerance Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.

Visual Basic
Property MergeTolerance() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::OfferedAuxiliarySymbols Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::OfferedAuxiliarySymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::OfferedAuxiliarySymbols Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.

Visual Basic
Property OfferedAuxiliarySymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableAuxiliarySymbols, they are ignored.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::OfferedGDTSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::OfferedGDTSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::OfferedGDTSymbols Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.

Visual Basic
Property OfferedGDTSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableGDTSymbols, they are ignored.

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::SeparateDatumID Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::SeparateDatumID Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::SeparateDatumID Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether the datum identifier symbol is displayed separate.

Visual Basic
Property SeparateDatumID() As VARIANT_BOOL
Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::SeparateProjected Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::SeparateProjected Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::SeparateProjected Property
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Specifies whether the projected symbol is displayed separate.

Visual Basic
Property SeparateProjected() As VARIANT_BOOL
Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFCFStandard::GetSymbolImplementation Method

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard::GetSymbolImplementation Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard::GetSymbolImplementation Method
IMcadFCFStandard Interface IMcadFCFStandard Members IMcadFCFStandard Interface Send Feedback
Summary

Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.

Visual Basic
Sub GetSymbolImplementation(Type As McadGDTSymbolType, Representation As [out, retval] BSTR)
Parameters
Parameters | Description
Type | McadGDTSymbolType enumeration; input-only. Specifies the symbol type to get the character string implementation representation for.
Returns

String

Interface

IMcadFCFStandard Interface

Links
IMcadFCFStandard Interface, IMcadFCFStandard Members, IMcadFCFStandard Interface


IMcadFeatureControlFrame Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame Interface
IMcadFeatureControlFrame Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Implemets feature control frame symbols.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
Visual Basic
Public Interface IMcadFeatureControlFrame
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadFeatureControlFrame Members, SymBBAuto Library, Class Hierarchy


IMcadFeatureControlFrame Members

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame Members
IMcadFeatureControlFrame Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFeatureControlFrame.

Interface

IMcadFeatureControlFrame Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
Links
IMcadFeatureControlFrame Interface, Legend, Methods, Properties


IMcadFeatureControlFrame::DatumIDValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumIDValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumIDValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Datum ID field of a feature control frame.

Visual Basic
Property DatumIDValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumPrimary2Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumPrimary2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumPrimary2Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the secondary Datum1 field of the feature control frame.

Visual Basic
Property DatumPrimary2Value() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumPrimary3Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumPrimary3Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumPrimary3Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the third Datum1 field of the feature control frame

Visual Basic
Property DatumPrimary3Value() As String
Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumPrimaryValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumPrimaryValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumPrimaryValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Datum1 field of a feature control frame.

Visual Basic
Property DatumPrimaryValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumSecondary2Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumSecondary2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumSecondary2Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the secondary Datum2 field of the feature control frame.

Visual Basic
Property DatumSecondary2Value() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumSecondary3Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumSecondary3Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumSecondary3Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the third Datum2 field of the feature control frame

Visual Basic
Property DatumSecondary3Value() As String
Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumSecondaryValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumSecondaryValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumSecondaryValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Datum2 field of the feature control frame.

Visual Basic
Property DatumSecondaryValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumTertiary2Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumTertiary2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumTertiary2Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the secondary Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiary2Value() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumTertiary3Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumTertiary3Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumTertiary3Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the third Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiary3Value() As String
Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::DatumTertiaryValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::DatumTertiaryValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::DatumTertiaryValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Datum3 field of the feature control frame.

Visual Basic
Property DatumTertiaryValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::IsAllAround Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::IsAllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::IsAllAround Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.

Visual Basic
Property IsAllAround() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::ProjectedValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::ProjectedValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::ProjectedValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Projected Zone field of the feature control frame.

Visual Basic
Property ProjectedValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::Symbol Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::Symbol Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::Symbol Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol() As McadGDTSymbolType
Remarks

This property is a McadGDTSymbolType enumeration.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::Symbol2 Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::Symbol2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::Symbol2 Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol2() As McadGDTSymbolType
Remarks

This property is a McadGDTSymbolType enumeration.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::Symbol3 Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::Symbol3 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::Symbol3 Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.

Visual Basic
Property Symbol3() As McadGDTSymbolType
Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::Tolerance2Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::Tolerance2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::Tolerance2Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the secondary Tolerance 1 field of a feature control frame.

Visual Basic
Property Tolerance2Value() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::Tolerance3Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::Tolerance3Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::Tolerance3Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the third Tolerance 1 field of the feature control frame.

Visual Basic
Property Tolerance3Value() As String
Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::ToleranceB2Value Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::ToleranceB2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::ToleranceB2Value Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the secondary Tolerance 2 field of the feature control frame.

Visual Basic
Property ToleranceB2Value() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::ToleranceBValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::ToleranceBValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::ToleranceBValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Tolerance 2 field of the feature control frame.

Visual Basic
Property ToleranceBValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame::ToleranceValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame::ToleranceValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame::ToleranceValue Property
IMcadFeatureControlFrame Interface IMcadFeatureControlFrame Members IMcadFeatureControlFrame Interface Send Feedback
Summary

Specifies the value of the Tolerance 1 field of the feature control frame.

Visual Basic
Property ToleranceValue() As String
Remarks

This property is a String.

Interface

IMcadFeatureControlFrame Interface

Links
IMcadFeatureControlFrame Interface, IMcadFeatureControlFrame Members, IMcadFeatureControlFrame Interface


IMcadFeatureControlFrame2 Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2 Interface
IMcadFeatureControlFrame2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

IMcadFeatureControlFrame extended interface.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
Visual Basic
Public Interface IMcadFeatureControlFrame2
Inherits IMcadFeatureControlFrame
Library

SymBBAuto Library

Links
IMcadFeatureControlFrame2 Members, SymBBAuto Library, Class Hierarchy


IMcadFeatureControlFrame2 Members

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2 Members
IMcadFeatureControlFrame2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFeatureControlFrame2.

Interface

IMcadFeatureControlFrame2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.
Links
IMcadFeatureControlFrame2 Interface, Legend, Methods, Properties


IMcadFeatureControlFrame2::BottomNoteValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2::BottomNoteValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2::BottomNoteValue Property
IMcadFeatureControlFrame2 Interface IMcadFeatureControlFrame2 Members IMcadFeatureControlFrame2 Interface Send Feedback
Summary

Specifies and places all notes related to the tolerance below the feature control frame symbol.

Visual Basic
Property BottomNoteValue() As String
Interface

IMcadFeatureControlFrame2 Interface

Links
IMcadFeatureControlFrame2 Interface, IMcadFeatureControlFrame2 Members, IMcadFeatureControlFrame2 Interface


IMcadFeatureControlFrame2::TopNoteValue Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2::TopNoteValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2::TopNoteValue Property
IMcadFeatureControlFrame2 Interface IMcadFeatureControlFrame2 Members IMcadFeatureControlFrame2 Interface Send Feedback
Summary

Specifies and places all notes related to the tolerance above the feature control frame symbol.

Visual Basic
Property TopNoteValue() As String
Interface

IMcadFeatureControlFrame2 Interface

Links
IMcadFeatureControlFrame2 Interface, IMcadFeatureControlFrame2 Members, IMcadFeatureControlFrame2 Interface


IMcadFeatureIdentifier Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A feature identifier symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2
Visual Basic
Public Interface IMcadFeatureIdentifier
Inherits IMcadIdentifier
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadIdentifier Interface

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifier Interface
IMcadIdentifier Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

An identifier symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
            IMcadFeatureIdentifier
Visual Basic
Public Interface IMcadIdentifier
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadIdentifier Members, SymBBAuto Library, Class Hierarchy


IMcadIdentifier Members

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifier Members
IMcadIdentifier Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadIdentifier.

Interface

IMcadIdentifier Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.
Links
IMcadIdentifier Interface, Legend, Methods, Properties


IMcadIdentifier::Value Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier::Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifier::Value Property
IMcadIdentifier Interface IMcadIdentifier Members IMcadIdentifier Interface Send Feedback
Summary

Specifies the value of the feature or datum identifier. The maximum length of the value is 2.

Visual Basic
Property Value() As String
Remarks

This property is a String.

Interface

IMcadIdentifier Interface

Links
IMcadIdentifier Interface, IMcadIdentifier Members, IMcadIdentifier Interface


IMcadIdentifierStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard Interface
IMcadIdentifierStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

An identifier symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2
Visual Basic
Public Interface IMcadIdentifierStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadIdentifierStandard Members, SymBBAuto Library, Class Hierarchy


IMcadIdentifierStandard Members

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard Members
IMcadIdentifierStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadIdentifierStandard.

Interface

IMcadIdentifierStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadIdentifierStandard Interface, Legend, Methods, Properties


IMcadIdentifierStandard::DefaultArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard::DefaultArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard::DefaultArrowType Property
IMcadIdentifierStandard Interface IMcadIdentifierStandard Members IMcadIdentifierStandard Interface Send Feedback
Summary

Gets the default arrow type for identifier symbols created referencing this standard.

Visual Basic
Property DefaultArrowType() As McadArrowType*
Remarks

This property is a McadArrowType enumeration.

Interface

IMcadIdentifierStandard Interface

Links
IMcadIdentifierStandard Interface, IMcadIdentifierStandard Members, IMcadIdentifierStandard Interface


IMcadIdentifierStandard::IsDatumIDSupported Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard::IsDatumIDSupported Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard::IsDatumIDSupported Property
IMcadIdentifierStandard Interface IMcadIdentifierStandard Members IMcadIdentifierStandard Interface Send Feedback
Summary

Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.

Visual Basic
Property IsDatumIDSupported() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadIdentifierStandard Interface

Links
IMcadIdentifierStandard Interface, IMcadIdentifierStandard Members, IMcadIdentifierStandard Interface


IMcadIdentifierStandard::IsFeatureIDSupported Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard::IsFeatureIDSupported Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard::IsFeatureIDSupported Property
IMcadIdentifierStandard Interface IMcadIdentifierStandard Members IMcadIdentifierStandard Interface Send Feedback
Summary

Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.

Visual Basic
Property IsFeatureIDSupported() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadIdentifierStandard Interface

Links
IMcadIdentifierStandard Interface, IMcadIdentifierStandard Members, IMcadIdentifierStandard Interface


IMcadJoint Interface

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint Interface
IMcadJoint Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadJoint interface.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadJoint
Visual Basic
Public Interface IMcadJoint
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadJoint Members, SymBBAuto Library, Class Hierarchy


IMcadJoint Members

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint Members
IMcadJoint Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadJoint.

Interface

IMcadJoint Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllAround | Specifes whether the Dead Joint symbol is all around.
Annotation | Specifes the annotation text of Dead Joint symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifes the additional annotation text of Dead Joint symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecAnnotation | Specifes the additional annotation text of Dead Joint symbol.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies the type of Dead Joint symbol.
Links
IMcadJoint Interface, Legend, Methods, Properties


IMcadJoint::AllAround Property

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint::AllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint::AllAround Property
IMcadJoint Interface IMcadJoint Members IMcadJoint Interface Send Feedback
Summary

Specifes whether the Dead Joint symbol is all around.

Visual Basic
Property AllAround() As VARIANT_BOOL
Interface

IMcadJoint Interface

Links
IMcadJoint Interface, IMcadJoint Members, IMcadJoint Interface


IMcadJoint::Annotation Property

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint::Annotation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint::Annotation Property
IMcadJoint Interface IMcadJoint Members IMcadJoint Interface Send Feedback
Summary

Specifes the annotation text of Dead Joint symbol.

Visual Basic
Property Annotation() As String
Interface

IMcadJoint Interface

Links
IMcadJoint Interface, IMcadJoint Members, IMcadJoint Interface


IMcadJoint::Orientation Property

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint::Orientation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint::Orientation Property
IMcadJoint Interface IMcadJoint Members IMcadJoint Interface Send Feedback
Summary

Specifes the additional annotation text of Dead Joint symbol.

Visual Basic
Property Orientation() As McadOrientation
Interface

IMcadJoint Interface

Links
IMcadJoint Interface, IMcadJoint Members, IMcadJoint Interface


IMcadJoint::SecAnnotation Property

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint::SecAnnotation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint::SecAnnotation Property
IMcadJoint Interface IMcadJoint Members IMcadJoint Interface Send Feedback
Summary

Specifes the additional annotation text of Dead Joint symbol.

Visual Basic
Property SecAnnotation() As String
Interface

IMcadJoint Interface

Links
IMcadJoint Interface, IMcadJoint Members, IMcadJoint Interface


IMcadJoint::SymbolType Property

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint::SymbolType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint::SymbolType Property
IMcadJoint Interface IMcadJoint Members IMcadJoint Interface Send Feedback
Summary

Specifies the type of Dead Joint symbol.

Visual Basic
Property SymbolType() As McadJointType
Interface

IMcadJoint Interface

Links
IMcadJoint Interface, IMcadJoint Members, IMcadJoint Interface


IMcadJointStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadJointStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJointStandard Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents a Dead Joint symbol standard created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadJointStandard
Visual Basic
Public Interface IMcadJointStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadMarkStamp Interface

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp Interface
IMcadMarkStamp Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for working with the Marking/Stamping symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadMarkStamp
Visual Basic
Public Interface IMcadMarkStamp
Inherits IMcadSymbol2
Remarks

Interface for McadMarkStamp.

Library

SymBBAuto Library

Links
IMcadMarkStamp Members, SymBBAuto Library, Class Hierarchy


IMcadMarkStamp Members

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp Members
IMcadMarkStamp Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadMarkStamp.

Interface

IMcadMarkStamp Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
ContentValue | Specifies the marking or stamping contents.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MethodValue | Specifies the marking or stamping method.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies whether the symbol is a marking or stamping symbol.
TechnicalReqValue | Specifies a reference to a technical requirement.
Links
IMcadMarkStamp Interface, Legend, Methods, Properties


IMcadMarkStamp::ContentValue Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp::ContentValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp::ContentValue Property
IMcadMarkStamp Interface IMcadMarkStamp Members IMcadMarkStamp Interface Send Feedback
Summary

Specifies the marking or stamping contents.

Visual Basic
Property ContentValue() As String
Interface

IMcadMarkStamp Interface

Links
IMcadMarkStamp Interface, IMcadMarkStamp Members, IMcadMarkStamp Interface


IMcadMarkStamp::MethodValue Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp::MethodValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp::MethodValue Property
IMcadMarkStamp Interface IMcadMarkStamp Members IMcadMarkStamp Interface Send Feedback
Summary

Specifies the marking or stamping method.

Visual Basic
Property MethodValue() As String
Interface

IMcadMarkStamp Interface

Links
IMcadMarkStamp Interface, IMcadMarkStamp Members, IMcadMarkStamp Interface


IMcadMarkStamp::SymbolType Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp::SymbolType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp::SymbolType Property
IMcadMarkStamp Interface IMcadMarkStamp Members IMcadMarkStamp Interface Send Feedback
Summary

Specifies whether the symbol is a marking or stamping symbol.

Visual Basic
Property SymbolType() As BSTR*
Interface

IMcadMarkStamp Interface

Links
IMcadMarkStamp Interface, IMcadMarkStamp Members, IMcadMarkStamp Interface


IMcadMarkStamp::TechnicalReqValue Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp::TechnicalReqValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp::TechnicalReqValue Property
IMcadMarkStamp Interface IMcadMarkStamp Members IMcadMarkStamp Interface Send Feedback
Summary

Specifies a reference to a technical requirement.

Visual Basic
Property TechnicalReqValue() As String
Interface

IMcadMarkStamp Interface

Links
IMcadMarkStamp Interface, IMcadMarkStamp Members, IMcadMarkStamp Interface


IMcadMarkStampStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard Interface
IMcadMarkStampStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for working with the Marking/Stamping symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadMarkStampStandard
Visual Basic
Public Interface IMcadMarkStampStandard
Inherits IMcadSymbolStandard3
Remarks

The McadMarkStampStandard COM object is the wrapper for the AcmMarkStampStd class.

Library

SymBBAuto Library

Links
IMcadMarkStampStandard Members, SymBBAuto Library, Class Hierarchy


IMcadMarkStampStandard Members

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard Members
IMcadMarkStampStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadMarkStampStandard.

Interface

IMcadMarkStampStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableMarkingContents | Gets the list of symbols that are available for marking contents referencing this standard.
AvailableMarkingMethods | Gets the list of symbols that are available for marking methods referencing this standard.
AvailableStampingContents | Gets the list of symbols that are available for stamping contents referencing this standard.
AvailableStampingMethods | Gets the list of symbols that are available for stamping methods referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedMarkingContents | Specifies the list of symbols that are offered for marking contents referencing this standard.
OfferedMarkingMethods | Specifies the list of symbols that are offered for marking methods referencing this standard.
OfferedStampingContents | Specifies the list of symbols that are offered for stamping contents referencing this standard.
OfferedStampingMethods | Specifies the list of symbols that are offered for stamping methods referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadMarkStampStandard Interface, Legend, Methods, Properties


IMcadMarkStampStandard::AvailableMarkingContents Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::AvailableMarkingContents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::AvailableMarkingContents Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Gets the list of symbols that are available for marking contents referencing this standard.

Visual Basic
Property AvailableMarkingContents() As VARIANT*
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::AvailableMarkingMethods Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::AvailableMarkingMethods Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::AvailableMarkingMethods Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Gets the list of symbols that are available for marking methods referencing this standard.

Visual Basic
Property AvailableMarkingMethods() As VARIANT*
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::AvailableStampingContents Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::AvailableStampingContents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::AvailableStampingContents Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Gets the list of symbols that are available for stamping contents referencing this standard.

Visual Basic
Property AvailableStampingContents() As VARIANT*
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::AvailableStampingMethods Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::AvailableStampingMethods Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::AvailableStampingMethods Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Gets the list of symbols that are available for stamping methods referencing this standard.

Visual Basic
Property AvailableStampingMethods() As VARIANT*
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::OfferedMarkingContents Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::OfferedMarkingContents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::OfferedMarkingContents Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Specifies the list of symbols that are offered for marking contents referencing this standard.

Visual Basic
Property OfferedMarkingContents() As VARIANT
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::OfferedMarkingMethods Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::OfferedMarkingMethods Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::OfferedMarkingMethods Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Specifies the list of symbols that are offered for marking methods referencing this standard.

Visual Basic
Property OfferedMarkingMethods() As VARIANT
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::OfferedStampingContents Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::OfferedStampingContents Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::OfferedStampingContents Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Specifies the list of symbols that are offered for stamping contents referencing this standard.

Visual Basic
Property OfferedStampingContents() As VARIANT
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadMarkStampStandard::OfferedStampingMethods Property

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard::OfferedStampingMethods Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard::OfferedStampingMethods Property
IMcadMarkStampStandard Interface IMcadMarkStampStandard Members IMcadMarkStampStandard Interface Send Feedback
Summary

Specifies the list of symbols that are offered for stamping methods referencing this standard.

Visual Basic
Property OfferedStampingMethods() As VARIANT
Interface

IMcadMarkStampStandard Interface

Links
IMcadMarkStampStandard Interface, IMcadMarkStampStandard Members, IMcadMarkStampStandard Interface


IMcadNote Interface

You are here: API Reference > SymBBAuto Library > IMcadNote Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote Interface
IMcadNote Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Note symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadNote
Visual Basic
Public Interface IMcadNote
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadNote Members, SymBBAuto Library, Class Hierarchy


IMcadNote Members

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote Members
IMcadNote Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadNote.

Interface

IMcadNote Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustLanding | Specifies new landing for the note symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateNoteText | Creates text in note symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
EvaluatedNoteText | Property to specify the rendered text of variables or expressions.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsLeftOriented | Specify if text in note symbol is left-aligned.
Landing | Specifies if note symbol has landing (the extension of the leader line that underlines the text).
LeaderAttachPoint | Specifies the justification of the leader in the note symbol.
LeaderCount | Gets the number of leaders attached to a specific symbol.
NoteText | Specifies the text in the note symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TextAlignment | Specifies the alignment of the text in the note symbol.
Links
IMcadNote Interface, Legend, Methods, Properties


IMcadNote::EvaluatedNoteText Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::EvaluatedNoteText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::EvaluatedNoteText Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Property to specify the rendered text of variables or expressions.

Visual Basic
Property EvaluatedNoteText() As BSTR*
Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::IsLeftOriented Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::IsLeftOriented Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::IsLeftOriented Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specify if text in note symbol is left-aligned.

Visual Basic
Property IsLeftOriented() As VARIANT_BOOL
Remarks

The variant is TRUE if left-aligned and FALSE if right-aligned.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::Landing Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::Landing Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::Landing Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specifies if note symbol has landing (the extension of the leader line that underlines the text).

Visual Basic
Property Landing() As VARIANT_BOOL
Remarks

To add a landing the Landing method must be called after CreatNoteText.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::LeaderAttachPoint Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::LeaderAttachPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::LeaderAttachPoint Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specifies the justification of the leader in the note symbol.

Visual Basic
Property LeaderAttachPoint() As McadNoteAttachPointType
Remarks

This method should be called after creating note text.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::NoteText Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::NoteText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::NoteText Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specifies the text in the note symbol.

Visual Basic
Property NoteText() As String
Remarks

To initially add note text, use the CreateNoteText method. The CreateNoteText method will set the text at an offset from the tip of the leader point (so it should be called after adding the leaders). To add a landing (the extension of the leader line that underlines the text), the Landing method must be called after CreatNoteText.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::TextAlignment Property

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::TextAlignment Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::TextAlignment Property
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specifies the alignment of the text in the note symbol.

Visual Basic
Property TextAlignment() As McadAlignmentType
Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::AdjustLanding Method

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::AdjustLanding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::AdjustLanding Method
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Specifies new landing for the note symbol.

Visual Basic
Sub AdjustLanding(newPoint As VARIANT)
Parameters
Parameters | Description
newPoint | _nt_
Remarks

The VARIANT should contain a SAFEARRAY of three doubles. Hint: Use AcAxPoint3d to convert VARIANT to AcGePoint3d.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNote::CreateNoteText Method

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote::CreateNoteText Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote::CreateNoteText Method
IMcadNote Interface IMcadNote Members IMcadNote Interface Send Feedback
Summary

Creates text in note symbol.

Visual Basic
Sub CreateNoteText(newVal As String)
Remarks

This method will set the text at an offset from the tip of leader point. So it should be called after adding leaders. To add a landing (the extension of the leader line that underlines the text), the Landing method must be called after CreatNoteText.

Interface

IMcadNote Interface

Links
IMcadNote Interface, IMcadNote Members, IMcadNote Interface


IMcadNoteStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard Interface
IMcadNoteStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Note symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadNoteStandard
Visual Basic
Public Interface IMcadNoteStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadNoteStandard Members, SymBBAuto Library, Class Hierarchy


IMcadNoteStandard Members

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard Members
IMcadNoteStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadNoteStandard.

Interface

IMcadNoteStandard Interface

Methods
Name | Description
AddTemplate | Adds new template and its value to the specified template group.
ChangeTemplateValue | Changes the value of template in the specified template group.
DeleteAllTemplates | Deletes all templates in all template groups.
DeleteTemplate | Deletes template from the specified template group.
GetAllTemplates | Get all templates for the group with given type.
GetFeatureTypes | Get type of features that the note symbol is attached to.
GetTemplateGroup | Gets the type and name of the template group for the specified index.
GetTemplateValue | Gets the non-evaluated value of the template for specified template type and name.
NumberOfTemplateGroups | Gets number of template groups that the note standard holds.
RenameTemplate | Renames template in the specified template group.
SetCompatibilityCondition | Sets up the feature type(s) you are interested in.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTemplate | Sets the default template in the specified template group.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
Landing | Specifies if note symbol has landing.
LeaderAttachPoint | Specifies default leader justification of the text in note symbol.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadNoteStandard Interface, Legend, Methods, Properties


IMcadNoteStandard::Landing Property

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::Landing Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::Landing Property
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Specifies if note symbol has landing.

Visual Basic
Property Landing() As VARIANT_BOOL
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::LeaderAttachPoint Property

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::LeaderAttachPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::LeaderAttachPoint Property
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Specifies default leader justification of the text in note symbol.

Visual Basic
Property LeaderAttachPoint() As McadNoteAttachPointType
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::AddTemplate Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::AddTemplate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::AddTemplate Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Adds new template and its value to the specified template group.

Visual Basic
Sub AddTemplate(groupType As VARIANT, tempName As String, value As String, allowNewGroup As [in,defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
value | Input value of the template
allowNewGroup | TRUE if allow to create new template group if the specified template group does not exist. Default is TRUE.
tempname | Input name of the template
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::ChangeTemplateValue Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::ChangeTemplateValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::ChangeTemplateValue Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Changes the value of template in the specified template group.

Visual Basic
Sub ChangeTemplateValue(groupType As VARIANT, tempName As String, value As String, updateDimStyles As [in,defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
value | Input new value of the template
updateDimStyles | TRUE if update dimension styles. Default is TRUE.
tempname | Input name of the template
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::DeleteAllTemplates Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::DeleteAllTemplates Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::DeleteAllTemplates Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Deletes all templates in all template groups.

Visual Basic
Sub DeleteAllTemplates(deleteGroups As [in,defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
deleteGroups | TRUE if delete template groups. Default is FALSE.
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::DeleteTemplate Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::DeleteTemplate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::DeleteTemplate Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Deletes template from the specified template group.

Visual Basic
Sub DeleteTemplate(groupType As VARIANT, tempName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
tempname | Input name of the template
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::GetAllTemplates Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::GetAllTemplates Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::GetAllTemplates Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Get all templates for the group with given type.

Visual Basic
Sub GetAllTemplates(groupType As VARIANT, tempNames As [out,retval] VARIANT)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::GetFeatureTypes Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::GetFeatureTypes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::GetFeatureTypes Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Get type of features that the note symbol is attached to.

Visual Basic
Sub GetFeatureTypes(noteSym As IMcadNote, featureType As [out,retval] VARIANT)
Parameters
Parameters | Description
noteSym | Input note symbol object
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::GetTemplateGroup Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::GetTemplateGroup Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::GetTemplateGroup Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Gets the type and name of the template group for the specified index.

Visual Basic
Sub GetTemplateGroup(index As LONG, onlyCompatible As [in,defaultvalue(FALSE)] VARIANT_BOOL, groupType As [out,retval] VARIANT)
Parameters
Parameters | Description
onlyCompatible | Input flag to indicate if only allow compatible template group
Index | Input index of the list of template group.
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::GetTemplateValue Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::GetTemplateValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::GetTemplateValue Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Gets the non-evaluated value of the template for specified template type and name.

Visual Basic
Sub GetTemplateValue(groupType As VARIANT, tempname As String, pValue As [out,retval] BSTR)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
tempname | Input name of the template
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::NumberOfTemplateGroups Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::NumberOfTemplateGroups Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::NumberOfTemplateGroups Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Gets number of template groups that the note standard holds.

Visual Basic
Sub NumberOfTemplateGroups(onlyCompatible As [in,defaultvalue(FALSE)] VARIANT_BOOL, number As [out,retval] int)
Parameters
Parameters | Description
onlyCompatible | Input flag to indicate if only allow compatible template group
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::RenameTemplate Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::RenameTemplate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::RenameTemplate Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Renames template in the specified template group.

Visual Basic
Sub RenameTemplate(groupType As VARIANT, oldTempName As String, newTempName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
oldTempName | Input original name of the template.
newTempName | Input new name of the template.
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::SetCompatibilityCondition Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::SetCompatibilityCondition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::SetCompatibilityCondition Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Sets up the feature type(s) you are interested in.

Visual Basic
Sub SetCompatibilityCondition(groupType As VARIANT)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
Remarks

To reset the condition to allow all groups, use an array with zero logical length as an argument.

Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadNoteStandard::SetToDefaultTemplate Method

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard::SetToDefaultTemplate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard::SetToDefaultTemplate Method
IMcadNoteStandard Interface IMcadNoteStandard Members IMcadNoteStandard Interface Send Feedback
Summary

Sets the default template in the specified template group.

Visual Basic
Sub SetToDefaultTemplate(groupType As VARIANT, temName As String)
Parameters
Parameters | Description
groupType | Input list of template group type. The Variant is array of McadNoteTemplateGroupType.
temName | Input name of the default template.
Interface

IMcadNoteStandard Interface

Links
IMcadNoteStandard Interface, IMcadNoteStandard Members, IMcadNoteStandard Interface


IMcadPartList Interface

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList Interface
IMcadPartList Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part list symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
            IMcadPartListGOST
Visual Basic
Public Interface IMcadPartList
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadPartList Members, SymBBAuto Library, Class Hierarchy


IMcadPartList Members

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList Members
IMcadPartList Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartList.

Interface

IMcadPartList Interface

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
Links
IMcadPartList Interface, Legend, Methods, Properties


IMcadPartList::AttachmentPoint Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::AttachmentPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::AttachmentPoint Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the placement of the base point for the part list.

Visual Basic
Property AttachmentPoint() As McadAttachmentPoint
Remarks

This property is a McadAttachmentPoint enumeration.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::BOM Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::BOM Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::BOM Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the bill of materials table that this parts list is referencing.

Visual Basic
Property BOM() As IMcadBOM*
Remarks

This property is a McadBOM collection.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::CustomBlockName Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::CustomBlockName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::CustomBlockName Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the custom block scheme name used to display this parts list.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::CustomBlocks Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::CustomBlocks Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::CustomBlocks Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Gets the custom blocks used to display this parts list.

Visual Basic
Property CustomBlocks() As VARIANT*
Remarks

This property is a Variant (2-element array of AcadBlock objects).

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::FilterEmptyBlocks Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::FilterEmptyBlocks Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::FilterEmptyBlocks Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.

Visual Basic
Property FilterEmptyBlocks() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::Filters Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::Filters Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::Filters Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Gets the list of filters for a parts list.

Visual Basic
Property Filters() As IMcadPartListFilters**
Remarks

This property is a n McadPartListFilters collection.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::Height Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::Height Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::Height Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the height of a parts list.

Visual Basic
Property Height() As double
Remarks

This property is a Double.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::IsCustomBlockUsed Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::IsCustomBlockUsed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::IsCustomBlockUsed Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::IsHeadingEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::IsHeadingEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::IsHeadingEnabled Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsHeadingEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::IsTitleEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::IsTitleEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::IsTitleEnabled Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsTitleEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::ItemList Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::ItemList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::ItemList Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies all the BOM items included in a part list.

Visual Basic
Property ItemList() As IMcadBOMItems*
Remarks

This property is McadBOMItems collections.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::MappingName Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::MappingName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::MappingName Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the name of the custom mapping.

Visual Basic
Property MappingName() As String
Remarks

This property is a String.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::MultipleRow Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::MultipleRow Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::MultipleRow Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the single, double, or triple lines of text in the rows for the parts list.

Visual Basic
Property MultipleRow() As long
Remarks

Valid values include 1, 2, or 3.

This property is a Long.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::Title Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::Title Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::Title Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the parts list's title text.

Visual Basic
Property Title() As String
Remarks

This is String.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::ViewID Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::ViewID Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::ViewID Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the object ID of the drawing view that this parts list is associated with.

Visual Basic
Property ViewID() As LONG_PTR
Remarks

This property is a Long.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::ViewID32 Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::ViewID32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::ViewID32 Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the object ID of the drawing view that this parts list is associated with.

Visual Basic
Property ViewID32() As LONG
Remarks

This property is a Long.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::Width Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::Width Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::Width Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Specifies the width of a parts list.

Visual Basic
Property Width() As double
Remarks

This property is a Double.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::WrapText Property

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::WrapText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::WrapText Property
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Property that specifies whether the Parts List heading and row text wraps.

Visual Basic
Property WrapText() As VARIANT_BOOL
Remarks

Reading from this property retrieves the row text wrap state. When this property is a VARIANT_TRUE, reading from the RowTextControl property returns sbWrap to indicate the same row text wrap state. Writing to this property sets the heading and row text wrap states. This is the same as writing to both the HeadingTextControl and RowTextControl properties, setting them to sbWrap. This property is a replaced by the HeadingTextControl and RowTextControl properties.

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::AddFilter Method

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::AddFilter Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::AddFilter Method
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Creates a filter of the specified type and adds it to the part list filter list.

Visual Basic
Sub AddFilter(Name As String, Filter As [out, retval] IMcadPartListFilter*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the filter name to be created.
Returns

McadPartListFilter object

Remarks
  • A newly added parts list filter only take effect until the McadPartListFilter > IsOn property is TRUE.
  • The filter name can be obtained using the McadPartListFilter > Name property.
Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList::RemoveFilter Method

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList::RemoveFilter Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList::RemoveFilter Method
IMcadPartList Interface IMcadPartList Members IMcadPartList Interface Send Feedback
Summary

Removes the specified part list filter from this part list.

Visual Basic
Sub RemoveFilter(Filter As IMcadPartListFilter, Erase As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Filter | McadPartListFilter object; input-only. Specifies the parts list filter to be removed from the Filters/Group field.
Erase | Boolean, default value = True; input-only; optional. Specifies whether or not the parts list filter is eternally erased, TRUE, or not, FALSE.
Returns

None

Interface

IMcadPartList Interface

Links
IMcadPartList Interface, IMcadPartList Members, IMcadPartList Interface


IMcadPartList2 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2 Interface
IMcadPartList2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part list symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3
Visual Basic
Public Interface IMcadPartList2
Inherits IMcadPartList
Library

SymBBAuto Library

Links
IMcadPartList2 Members, SymBBAuto Library, Class Hierarchy


IMcadPartList2 Members

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2 Members
IMcadPartList2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartList2.

Interface

IMcadPartList2 Interface

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
Links
IMcadPartList2 Interface, Legend, Methods, Properties


IMcadPartList2::ColumnSplitEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ColumnSplitEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ColumnSplitEnabled Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies whether the Parts List column split is enabled.

Visual Basic
Property ColumnSplitEnabled() As VARIANT_BOOL
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::ColumnSplitRows Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ColumnSplitRows Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ColumnSplitRows Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List column split rows.

Visual Basic
Property ColumnSplitRows() As long
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::ColumnSplitSections Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ColumnSplitSections Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ColumnSplitSections Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List column split sections.

Visual Basic
Property ColumnSplitSections() As long
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::ColumnSplitStyle Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ColumnSplitStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ColumnSplitStyle Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List column split style.

Visual Basic
Property ColumnSplitStyle() As McadColumnSplitStyle
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::ColumnSplitWrap Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ColumnSplitWrap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ColumnSplitWrap Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List column split wrap direction.

Visual Basic
Property ColumnSplitWrap() As McadColumnSplitWrap
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::FormulaBarEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::FormulaBarEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::FormulaBarEnabled Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies whether the Parts List formula bar is enabled.

Visual Basic
Property FormulaBarEnabled() As VARIANT_BOOL
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::GripFrameEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::GripFrameEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::GripFrameEnabled Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies whether the Parts List grip frame is enabled.

Visual Basic
Property GripFrameEnabled() As VARIANT_BOOL
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::HeadingTextControl Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::HeadingTextControl Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::HeadingTextControl Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List heading text control.

Visual Basic
Property HeadingTextControl() As McadTextControl
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::ResultBarEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::ResultBarEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::ResultBarEnabled Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies whether the Parts List result bar is enabled.

Visual Basic
Property ResultBarEnabled() As VARIANT_BOOL
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::RowTextControl Property

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::RowTextControl Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::RowTextControl Property
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Property that specifies the Parts List row text control.

Visual Basic
Property RowTextControl() As McadTextControl
Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList2::AddFilterType Method

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2::AddFilterType Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2::AddFilterType Method
IMcadPartList2 Interface IMcadPartList2 Members IMcadPartList2 Interface Send Feedback
Summary

Creates a filter of a specified type and adds it to the Parts List.

Visual Basic
Sub AddFilterType(enType As McadFilterType, Filter As [out, retval] IMcadPartListFilter*)
Remarks

Returns the filter object of the specified type.

Interface

IMcadPartList2 Interface

Links
IMcadPartList2 Interface, IMcadPartList2 Members, IMcadPartList2 Interface


IMcadPartList3 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3 Interface
IMcadPartList3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the Parts List symbol settings information.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3
Visual Basic
Public Interface IMcadPartList3
Inherits IMcadPartList2
Library

SymBBAuto Library

Links
IMcadPartList3 Members, SymBBAuto Library, Class Hierarchy


IMcadPartList3 Members

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3 Members
IMcadPartList3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartList3.

Interface

IMcadPartList3 Interface

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
setWrapPListAttachPoint | Sets the attach point of a parts list that wraps around the title block.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapAroundTitle | Specifies whether the parts list can be wrapped around the title block.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
WrapTitleBlockId | Specifies the Id of the title block which is wrapped around.
WrapTitleBlockId32 | Specifies the Id of the title block which is wrapped around. Only available for x64 platform.
Links
IMcadPartList3 Interface, Legend, Methods, Properties


IMcadPartList3::WrapAroundTitle Property

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3::WrapAroundTitle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3::WrapAroundTitle Property
IMcadPartList3 Interface IMcadPartList3 Members IMcadPartList3 Interface Send Feedback
Summary

Specifies whether the parts list can be wrapped around the title block.

Visual Basic
Property WrapAroundTitle() As VARIANT_BOOL
Interface

IMcadPartList3 Interface

Links
IMcadPartList3 Interface, IMcadPartList3 Members, IMcadPartList3 Interface


IMcadPartList3::WrapTitleBlockId Property

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3::WrapTitleBlockId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3::WrapTitleBlockId Property
IMcadPartList3 Interface IMcadPartList3 Members IMcadPartList3 Interface Send Feedback
Summary

Specifies the Id of the title block which is wrapped around.

Visual Basic
Property WrapTitleBlockId() As LONG_PTR
Remarks

Also calculates the title block height.

Interface

IMcadPartList3 Interface

Links
IMcadPartList3 Interface, IMcadPartList3 Members, IMcadPartList3 Interface


IMcadPartList3::WrapTitleBlockId32 Property

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3::WrapTitleBlockId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3::WrapTitleBlockId32 Property
IMcadPartList3 Interface IMcadPartList3 Members IMcadPartList3 Interface Send Feedback
Summary

Specifies the Id of the title block which is wrapped around. Only available for x64 platform.

Visual Basic
Property WrapTitleBlockId32() As LONG
Remarks

Calculates title block height.

Interface

IMcadPartList3 Interface

Links
IMcadPartList3 Interface, IMcadPartList3 Members, IMcadPartList3 Interface


IMcadPartList3::setWrapPListAttachPoint Method

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3::setWrapPListAttachPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3::setWrapPListAttachPoint Method
IMcadPartList3 Interface IMcadPartList3 Members IMcadPartList3 Interface Send Feedback
Summary

Sets the attach point of a parts list that wraps around the title block.

Visual Basic
Sub setWrapPListAttachPoint(pVal As [out, retval] VARIANT)
Parameters
Parameters | Description
pVal | Variant; output only. Specifies the insertion point of the parts list.
Interface

IMcadPartList3 Interface

Links
IMcadPartList3 Interface, IMcadPartList3 Members, IMcadPartList3 Interface


IMcadPartListBalloonedFilter Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListBalloonedFilter Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListBalloonedFilter Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a Parts List by ballooned parts.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter
Visual Basic
Public Interface IMcadPartListBalloonedFilter
Inherits IMcadPartListFilter2
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadPartListCustomFilter Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter Interface
IMcadPartListCustomFilter Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a Parts List by a BOM property.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter
Visual Basic
Public Interface IMcadPartListCustomFilter
Inherits IMcadPartListFilter2
Library

SymBBAuto Library

Links
IMcadPartListCustomFilter Members, SymBBAuto Library, Class Hierarchy


IMcadPartListCustomFilter Members

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter Members
IMcadPartListCustomFilter Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListCustomFilter.

Interface

IMcadPartListCustomFilter Interface

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.
Links
IMcadPartListCustomFilter Interface, Legend, Methods, Properties


IMcadPartListCustomFilter::Operator Property

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter::Operator Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter::Operator Property
IMcadPartListCustomFilter Interface IMcadPartListCustomFilter Members IMcadPartListCustomFilter Interface Send Feedback
Summary

Specifies the filter operator used by the Parts List custom filter to filter parts.

Visual Basic
Property Operator() As McadFilterOperator*
Interface

IMcadPartListCustomFilter Interface

Links
IMcadPartListCustomFilter Interface, IMcadPartListCustomFilter Members, IMcadPartListCustomFilter Interface


IMcadPartListCustomFilter::PropertyName Property

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter::PropertyName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter::PropertyName Property
IMcadPartListCustomFilter Interface IMcadPartListCustomFilter Members IMcadPartListCustomFilter Interface Send Feedback
Summary

Specifies the BOM property name used by the Parts List custom filter to filter parts.

Visual Basic
Property PropertyName() As BSTR*
Interface

IMcadPartListCustomFilter Interface

Links
IMcadPartListCustomFilter Interface, IMcadPartListCustomFilter Members, IMcadPartListCustomFilter Interface


IMcadPartListCustomFilter::PropertyValue Property

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter::PropertyValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter::PropertyValue Property
IMcadPartListCustomFilter Interface IMcadPartListCustomFilter Members IMcadPartListCustomFilter Interface Send Feedback
Summary

Specifies the BOM property value used by the Parts List custom filter to filter parts.

Visual Basic
Property PropertyValue() As BSTR*
Interface

IMcadPartListCustomFilter Interface

Links
IMcadPartListCustomFilter Interface, IMcadPartListCustomFilter Members, IMcadPartListCustomFilter Interface


IMcadPartListCustomFilter::SetCondition Method

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter::SetCondition Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter::SetCondition Method
IMcadPartListCustomFilter Interface IMcadPartListCustomFilter Members IMcadPartListCustomFilter Interface Send Feedback
Summary

Specifies the filter condition used by the Parts List custom filter to filter parts.

Visual Basic
Sub SetCondition(strPropertyName As String, enOperator As McadFilterOperator, strPropertyValue As String)
Parameters
Parameters | Description
strPropertyName | Input parameter. The BOM property name used by the Parts List custom filter to filter parts.
enOperator | Input parameter. The filter operator used by the Parts List custom filter to filter parts.
strPropertyValue | Input parameter. The BOM property value used by the Parts List custom filter to filter parts.
Interface

IMcadPartListCustomFilter Interface

Links
IMcadPartListCustomFilter Interface, IMcadPartListCustomFilter Members, IMcadPartListCustomFilter Interface


IMcadPartListFilter Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter Interface
IMcadPartListFilter Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

An object that filters the contents of a parts list.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
Visual Basic
Public Interface IMcadPartListFilter
Inherits IAcadObject
Library

SymBBAuto Library

Links
IMcadPartListFilter Members, SymBBAuto Library, Class Hierarchy


IMcadPartListFilter Members

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter Members
IMcadPartListFilter Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListFilter.

Interface

IMcadPartListFilter Interface

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
Properties
Name | Description
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Links
IMcadPartListFilter Interface, Legend, Methods, Properties


IMcadPartListFilter::IsOn Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter::IsOn Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter::IsOn Property
IMcadPartListFilter Interface IMcadPartListFilter Members IMcadPartListFilter Interface Send Feedback
Summary

Specifies whether the part list filter is enabled, TRUE, or not, FALSE.

Visual Basic
Property IsOn() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • A newly added parts list filter only take effect until the IsOn property is a TRUE. To add a new parts list filter, use the McadPartList > AddFilter method.
Interface

IMcadPartListFilter Interface

Links
IMcadPartListFilter Interface, IMcadPartListFilter Members, IMcadPartListFilter Interface


IMcadPartListFilter::Name Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter::Name Property
IMcadPartListFilter Interface IMcadPartListFilter Members IMcadPartListFilter Interface Send Feedback
Summary

Specifies the name of the parts list filter.

Visual Basic
Property Name() As BSTR*
Remarks

This property is a String.

Interface

IMcadPartListFilter Interface

Links
IMcadPartListFilter Interface, IMcadPartListFilter Members, IMcadPartListFilter Interface


IMcadPartListFilter::Evaluate Method

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter::Evaluate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter::Evaluate Method
IMcadPartListFilter Interface IMcadPartListFilter Members IMcadPartListFilter Interface Send Feedback
Summary

Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.

Visual Basic
Sub Evaluate(Item As IMcadBOMItem, Pass As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Item | McadBOMItem object; input-only. Specifies the BOM item to evaluate the filter on.
Returns

Boolean

Interface

IMcadPartListFilter Interface

Links
IMcadPartListFilter Interface, IMcadPartListFilter Members, IMcadPartListFilter Interface


IMcadPartListFilter2 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2 Interface
IMcadPartListFilter2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

An object that filters the contents of a parts list.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter
        IMcadPartListCustomFilter
Visual Basic
Public Interface IMcadPartListFilter2
Inherits IMcadPartListFilter
Library

SymBBAuto Library

Links
IMcadPartListFilter2 Members, SymBBAuto Library, Class Hierarchy


IMcadPartListFilter2 Members

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2 Members
IMcadPartListFilter2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListFilter2.

Interface

IMcadPartListFilter2 Interface

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Type | Property that specifies the filter type of a Parts List filter.
Links
IMcadPartListFilter2 Interface, Legend, Methods, Properties


IMcadPartListFilter2::Excluded Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2::Excluded Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2::Excluded Property
IMcadPartListFilter2 Interface IMcadPartListFilter2 Members IMcadPartListFilter2 Interface Send Feedback
Summary

Property that specifies whether a Parts List filter type is excluded from use in the current context.

Visual Basic
Property Excluded() As VARIANT_BOOL*
Remarks

This property always returns VARIANT_FALSE.

Interface

IMcadPartListFilter2 Interface

Links
IMcadPartListFilter2 Interface, IMcadPartListFilter2 Members, IMcadPartListFilter2 Interface


IMcadPartListFilter2::Type Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2::Type Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2::Type Property
IMcadPartListFilter2 Interface IMcadPartListFilter2 Members IMcadPartListFilter2 Interface Send Feedback
Summary

Property that specifies the filter type of a Parts List filter.

Visual Basic
Property Type() As McadFilterType*
Remarks

This property always returns sbFilterBasic.

Interface

IMcadPartListFilter2 Interface

Links
IMcadPartListFilter2 Interface, IMcadPartListFilter2 Members, IMcadPartListFilter2 Interface


IMcadPartListFilters Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters Interface
IMcadPartListFilters Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadPartListFilter objects

Class Hierarchy

Declaration syntax

IMcadPartListFilters
Visual Basic
Public Interface IMcadPartListFilters
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadPartListFilters Members, SymBBAuto Library, Class Hierarchy


IMcadPartListFilters Members

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters Members
IMcadPartListFilters Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListFilters.

Interface

IMcadPartListFilters Interface

Methods
Name | Description
Add | Adds a parts list filter to the collection used in this parts list.
Item | Obtains a specified parts list filter from the collection used in this parts list.
Remove | Removes the specified parts list filters from the collection used in this parts list.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts list filters in the collection used in a parts list.
Links
IMcadPartListFilters Interface, Legend, Methods, Properties


IMcadPartListFilters::Application Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters::Application Property
IMcadPartListFilters Interface IMcadPartListFilters Members IMcadPartListFilters Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadPartListFilters Interface

Links
IMcadPartListFilters Interface, IMcadPartListFilters Members, IMcadPartListFilters Interface


IMcadPartListFilters::Count Property

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters::Count Property
IMcadPartListFilters Interface IMcadPartListFilters Members IMcadPartListFilters Interface Send Feedback
Summary

Gets the total number of parts list filters in the collection used in a parts list.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadPartListFilters Interface

Links
IMcadPartListFilters Interface, IMcadPartListFilters Members, IMcadPartListFilters Interface


IMcadPartListFilters::Add Method

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters::Add Method
IMcadPartListFilters Interface IMcadPartListFilters Members IMcadPartListFilters Interface Send Feedback
Summary

Adds a parts list filter to the collection used in this parts list.

Visual Basic
Sub Add(Item As IMcadPartListFilter)
Parameters
Parameters | Description
Item | McadPartListFilter object; input-only. Specifies the new parts list filter to add to the collection.
Returns

None

Interface

IMcadPartListFilters Interface

Links
IMcadPartListFilters Interface, IMcadPartListFilters Members, IMcadPartListFilters Interface


IMcadPartListFilters::Item Method

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters::Item Method
IMcadPartListFilters Interface IMcadPartListFilters Members IMcadPartListFilters Interface Send Feedback
Summary

Obtains a specified parts list filter from the collection used in this parts list.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartListFilter*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the parts list filter to obtain.
Returns

McadPartListFilter object

Interface

IMcadPartListFilters Interface

Links
IMcadPartListFilters Interface, IMcadPartListFilters Members, IMcadPartListFilters Interface


IMcadPartListFilters::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters::Remove Method
IMcadPartListFilters Interface IMcadPartListFilters Members IMcadPartListFilters Interface Send Feedback
Summary

Removes the specified parts list filters from the collection used in this parts list.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the parts list filter to be removed.
Returns

None

Interface

IMcadPartListFilters Interface

Links
IMcadPartListFilters Interface, IMcadPartListFilters Members, IMcadPartListFilters Interface


IMcadPartListGOST Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST Interface
IMcadPartListGOST Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for interacting with the GOST part list created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartListGOST
Visual Basic
Public Interface IMcadPartListGOST
Inherits IMcadPartList
Remarks

The McadPartListGOST COM object is the wrapper for the AcmPartListGOST class.

Library

SymBBAuto Library

Links
IMcadPartListGOST Members, SymBBAuto Library, Class Hierarchy


IMcadPartListGOST Members

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST Members
IMcadPartListGOST Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListGOST.

Interface

IMcadPartListGOST Interface

Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SkipAfterPart | Specifies if empty line is to be inserted after each part.
SkipLines | Specifies the number of empty lines to insert after the last item of each category.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
Links
IMcadPartListGOST Interface, Legend, Methods, Properties


IMcadPartListGOST::SkipAfterPart Property

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST::SkipAfterPart Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST::SkipAfterPart Property
IMcadPartListGOST Interface IMcadPartListGOST Members IMcadPartListGOST Interface Send Feedback
Summary

Specifies if empty line is to be inserted after each part.

Visual Basic
Property SkipAfterPart() As VARIANT_BOOL
Interface

IMcadPartListGOST Interface

Links
IMcadPartListGOST Interface, IMcadPartListGOST Members, IMcadPartListGOST Interface


IMcadPartListGOST::SkipLines Property

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST::SkipLines Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST::SkipLines Property
IMcadPartListGOST Interface IMcadPartListGOST Members IMcadPartListGOST Interface Send Feedback
Summary

Specifies the number of empty lines to insert after the last item of each category.

Visual Basic
Property SkipLines() As LONG
Interface

IMcadPartListGOST Interface

Links
IMcadPartListGOST Interface, IMcadPartListGOST Members, IMcadPartListGOST Interface


IMcadPartLists Interface

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists Interface
IMcadPartLists Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadPartList objects

Class Hierarchy

Declaration syntax

IMcadPartLists
Visual Basic
Public Interface IMcadPartLists
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadPartLists Members, SymBBAuto Library, Class Hierarchy


IMcadPartLists Members

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists Members
IMcadPartLists Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartLists.

Interface

IMcadPartLists Interface

Methods
Name | Description
Add | Adds a parts list to the collection used in this drawing.
Item | Obtains a specified parts list from the collection used in this drawing.
Remove | Removes the specified parts lists from the collection used in this drawing.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts lists in the collection used in a drawing.
Links
IMcadPartLists Interface, Legend, Methods, Properties


IMcadPartLists::Application Property

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists::Application Property
IMcadPartLists Interface IMcadPartLists Members IMcadPartLists Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadPartLists Interface

Links
IMcadPartLists Interface, IMcadPartLists Members, IMcadPartLists Interface


IMcadPartLists::Count Property

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists::Count Property
IMcadPartLists Interface IMcadPartLists Members IMcadPartLists Interface Send Feedback
Summary

Gets the total number of parts lists in the collection used in a drawing.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadPartLists Interface

Links
IMcadPartLists Interface, IMcadPartLists Members, IMcadPartLists Interface


IMcadPartLists::Add Method

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists::Add Method
IMcadPartLists Interface IMcadPartLists Members IMcadPartLists Interface Send Feedback
Summary

Adds a parts list to the collection used in this drawing.

Visual Basic
Sub Add(Item As IMcadPartList)
Parameters
Parameters | Description
Item | McadPartList object; input-only. Specifies the new parts list to add to the collection.
Returns

None

Interface

IMcadPartLists Interface

Links
IMcadPartLists Interface, IMcadPartLists Members, IMcadPartLists Interface


IMcadPartLists::Item Method

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists::Item Method
IMcadPartLists Interface IMcadPartLists Members IMcadPartLists Interface Send Feedback
Summary

Obtains a specified parts list from the collection used in this drawing.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartList*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the parts list to obtain.
Interface

IMcadPartLists Interface

Links
IMcadPartLists Interface, IMcadPartLists Members, IMcadPartLists Interface


IMcadPartLists::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists::Remove Method
IMcadPartLists Interface IMcadPartLists Members IMcadPartLists Interface Send Feedback
Summary

Removes the specified parts lists from the collection used in this drawing.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the parts list to be removed.
Returns

None

Interface

IMcadPartLists Interface

Links
IMcadPartLists Interface, IMcadPartLists Members, IMcadPartLists Interface


IMcadPartListStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard Interface
IMcadPartListStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
Visual Basic
Public Interface IMcadPartListStandard
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadPartListStandard Members, SymBBAuto Library, Class Hierarchy


IMcadPartListStandard Members

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard Members
IMcadPartListStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListStandard.

Interface

IMcadPartListStandard Interface

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.
Links
IMcadPartListStandard Interface, Legend, Methods, Properties


IMcadPartListStandard::ActualRowTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::ActualRowTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::ActualRowTextHeight Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets the actual height of the text in a row of parts lists referencing this standard.

Visual Basic
Property ActualRowTextHeight() As double*
Remarks

This property is a Double.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::Application Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::Application Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

This property is a AcadmApplication object. AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::AttachmentPoint Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::AttachmentPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::AttachmentPoint Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the placement of the base point for the part lists referencing this standard.

Visual Basic
Property AttachmentPoint() As McadAttachmentPoint
Remarks

This property is a McadAttachmentPoint enumeration.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::BOMStandard Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::BOMStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::BOMStandard Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets the BOM standard that are associated with parts list referencing this standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks
  • This property is a McadBOMStandard object.
  • This property is a equivalent to using the GetCurrentSymbolStandard with the class name "cmBOMStd".
Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::ColumnList Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::ColumnList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::ColumnList Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the indices for the columns that are used in parts lists referencing this standard.

Visual Basic
Property ColumnList() As VARIANT
Remarks

This property is a Variant (array of Longs)

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::CustomBlockName Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::CustomBlockName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::CustomBlockName Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the custom block scheme name used to display parts lists referencing this standard.

Visual Basic
Property CustomBlockName() As String
Remarks

An empty string, "", is used to indicate to use the standard display.

This property is a String.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::CustomBlocks Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::CustomBlocks Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::CustomBlocks Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets the custom blocks used for the parts lists referencing this standard.

Visual Basic
Property CustomBlocks() As VARIANT*
Remarks

This property is a Variant (2-element array of AcadBlock objects).

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::FilterEmptyBlocks Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::FilterEmptyBlocks Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::FilterEmptyBlocks Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.

Visual Basic
Property FilterEmptyBlocks() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::FrameColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::FrameColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::FrameColor Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the color of the frame for the parts lists referencing this standard.

Visual Basic
Property FrameColor() As ACAD_COLOR
Remarks

This property is a cLineWeight enumeration. The initial value for this property is a cLnWtByBlock. Available lineweight values include:

  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault
  • cLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211
  • Lineweight values consist of standard settings including BYLAYER, BYBLOCK, and DEFAULT. The DEFAULT value is set by the LWDEFAULT system variable and defaults to a value of 0.01 in. or 0.25 mm. All new objects and layers have a default setting of DEFAULT. The lineweight value of 0 plots at the thinnest lineweight available on the specified plotting device and is displayed at one pixel wide in model space.
Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::HeadingGap Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::HeadingGap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::HeadingGap Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Property that specifies the Parts List heading text gap.

Visual Basic
Property HeadingGap() As double
Remarks

Writing to this property sets the Parts List heading text gap. In addition, writing to this property sets the Parts List heading text top, left, bottom and right margins. This is the same as writing to the HeadingTextMarginTop, HeadingTextMarginLeft, HeadingTextMarginBottom, and HeadingTextMarginRightproperties.

This property is a replaced by the HeadingTextMarginTop, HeadingTextMarginLeft, HeadingTextMarginBottom and HeadingTextMarginRight properties.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::HeadingHeight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::HeadingHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::HeadingHeight Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the heading height for parts lists referencing this standard.

Visual Basic
Property HeadingHeight() As double*
Remarks

This property is a Double.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::HeadingTextColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::HeadingTextColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::HeadingTextColor Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the heading text color for parts lists referencing this standard.

Visual Basic
Property HeadingTextColor() As ACAD_COLOR
Remarks

The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:

  • sbByBlock: If sbByBlock is specified, new heading texts are displayed in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
  • sbByLayer: If sbByLayer is specified, new heading texts assume the color of the layer upon which they are drawn.
  • sbRed
  • sbYellow
  • sbGreen
  • sbCyan
  • sbBlue
  • sbMagenta
  • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::HeadingTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::HeadingTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::HeadingTextHeight Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the heading text height for parts lists referencing this standard.

Visual Basic
Property HeadingTextHeight() As double
Remarks

This property is a Double.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::IsCustomBlockUsed Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::IsCustomBlockUsed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::IsCustomBlockUsed Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.

Visual Basic
Property IsCustomBlockUsed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::IsHeadingEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::IsHeadingEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::IsHeadingEnabled Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property IsHeadingEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::IsTitleEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::IsTitleEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::IsTitleEnabled Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies whether the title is by default enabled for parts lists referencing this standard.

Visual Basic
Property IsTitleEnabled() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::MulipleRow Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::MulipleRow Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::MulipleRow Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.

Visual Basic
Property MulipleRow() As long
Remarks

Valid values include 1, 2, or 3.

This property is a Long.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::Revision Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::Revision Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::Revision Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the revision version of a parts list standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::RevisionYear Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::RevisionYear Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::RevisionYear Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Gets the revision version year of a parts list standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::RowGap Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::RowGap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::RowGap Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Property that specifies the Parts List row text gap.

Visual Basic
Property RowGap() As double
Remarks

Writing to this property sets the Parts List row text gap. In addition, writing to this property sets the Parts List row text top, left, bottom and right margins. This is the same as writing to the RowTextMarginTop, RowTextMarginLeft, RowTextMarginBottom, and RowTextMarginRight properties.

This property is a replaced by the RowTextMarginTop, RowTextMarginLeft, RowTextMarginBottom, and RowTextMarginRight properties..

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::RowHeight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::RowHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::RowHeight Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies the row height for parts lists referencing this standard.

Visual Basic
Property RowHeight() As double*
Remarks

This property is a Double.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::UseMapping Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::UseMapping Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::UseMapping Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.

Visual Basic
Property UseMapping() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::WrapText Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::WrapText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::WrapText Property
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.

Visual Basic
Property WrapText() As VARIANT_BOOL
Remarks

Can set the wrap state for both header and data text, but the wrap state for header text will not be returned. Setting individual header and data text wrap states is not supported. Reading from this property retrieves the row text wrap state. When this property is a VARIANT_TRUE, reading from the RowTextControl property returns sbWrap to indicate the same row text wrap state. Writing to this property sets the heading and row text wrap states. This is the same as writing to both the HeadingTextControl and RowTextControl properties, setting them to sbWrap.

This property is a replaced by the HeadingTextControl and RowTextControl properties.

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::RemoveColumn Method

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::RemoveColumn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::RemoveColumn Method
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Removes the specified column, by index, from the parts lists referencing this standard.

Visual Basic
Sub RemoveColumn(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the column to be removed.
Returns

None

Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard::SetToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard::SetToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard::SetToDefaults Method
IMcadPartListStandard Interface IMcadPartListStandard Members IMcadPartListStandard Interface Send Feedback
Summary

Sets the properties of the standard parts list to the factory default values.

Visual Basic
Sub SetToDefaults()
Interface

IMcadPartListStandard Interface

Links
IMcadPartListStandard Interface, IMcadPartListStandard Members, IMcadPartListStandard Interface


IMcadPartListStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2 Interface
IMcadPartListStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
Visual Basic
Public Interface IMcadPartListStandard2
Inherits IMcadPartListStandard
Library

SymBBAuto Library

Links
IMcadPartListStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadPartListStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2 Members
IMcadPartListStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListStandard2.

Interface

IMcadPartListStandard2 Interface

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.
Links
IMcadPartListStandard2 Interface, Legend, Methods, Properties


IMcadPartListStandard2::FrameTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2::FrameTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2::FrameTrueColor Property
IMcadPartListStandard2 Interface IMcadPartListStandard2 Members IMcadPartListStandard2 Interface Send Feedback
Summary

Specifies the true color of frames for parts lists referencing this standard.

Visual Basic
Property FrameTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.
Interface

IMcadPartListStandard2 Interface

Links
IMcadPartListStandard2 Interface, IMcadPartListStandard2 Members, IMcadPartListStandard2 Interface


IMcadPartListStandard2::HeadingTextTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2::HeadingTextTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2::HeadingTextTrueColor Property
IMcadPartListStandard2 Interface IMcadPartListStandard2 Members IMcadPartListStandard2 Interface Send Feedback
Summary

Specifies the true color of the heading texts for parts lists referencing this standard.

Visual Basic
Property HeadingTextTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX documentation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.
Interface

IMcadPartListStandard2 Interface

Links
IMcadPartListStandard2 Interface, IMcadPartListStandard2 Members, IMcadPartListStandard2 Interface


IMcadPartListStandard3 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3 Interface
IMcadPartListStandard3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The part list specific information of a bill of materials symbol standard.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4
Visual Basic
Public Interface IMcadPartListStandard3
Inherits IMcadPartListStandard2
Library

SymBBAuto Library

Links
IMcadPartListStandard3 Members, SymBBAuto Library, Class Hierarchy


IMcadPartListStandard3 Members

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3 Members
IMcadPartListStandard3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListStandard3.

Interface

IMcadPartListStandard3 Interface

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.
Links
IMcadPartListStandard3 Interface, Legend, Methods, Properties


IMcadPartListStandard3::BoldVerticalLine Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::BoldVerticalLine Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::BoldVerticalLine Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies whether the Parts List line style is bold.

Visual Basic
Property BoldVerticalLine() As VARIANT_BOOL
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::ColumnSplitEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::ColumnSplitEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::ColumnSplitEnabled Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies whether the Parts List column split is enabled.

Visual Basic
Property ColumnSplitEnabled() As VARIANT_BOOL
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::ColumnSplitRows Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::ColumnSplitRows Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::ColumnSplitRows Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List column split rows.

Visual Basic
Property ColumnSplitRows() As long
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::ColumnSplitSections Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::ColumnSplitSections Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::ColumnSplitSections Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List column split sections.

Visual Basic
Property ColumnSplitSections() As long
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::ColumnSplitStyle Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::ColumnSplitStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::ColumnSplitStyle Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List column split style.

Visual Basic
Property ColumnSplitStyle() As McadColumnSplitStyle
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::ColumnSplitWrap Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::ColumnSplitWrap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::ColumnSplitWrap Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List column split wrap direction.

Visual Basic
Property ColumnSplitWrap() As McadColumnSplitWrap
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::GripFrameEnabled Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::GripFrameEnabled Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::GripFrameEnabled Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies whether the Parts List grip frame is enabled.

Visual Basic
Property GripFrameEnabled() As VARIANT_BOOL
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextControl Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextControl Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextControl Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text control.

Visual Basic
Property HeadingTextControl() As McadTextControl
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextMarginBottom Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextMarginBottom Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextMarginBottom Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text bottom margin.

Visual Basic
Property HeadingTextMarginBottom() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextMarginLeft Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextMarginLeft Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextMarginLeft Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text left margin.

Visual Basic
Property HeadingTextMarginLeft() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextMarginRight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextMarginRight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextMarginRight Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text right margin.

Visual Basic
Property HeadingTextMarginRight() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextMarginTop Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextMarginTop Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextMarginTop Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text top margin.

Visual Basic
Property HeadingTextMarginTop() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::HeadingTextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::HeadingTextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::HeadingTextStyle Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List heading text style.

Visual Basic
Property HeadingTextStyle() As IAcadTextStyle*
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextColor Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text color

Visual Basic
Property RowTextColor() As ACAD_COLOR
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextControl Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextControl Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextControl Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text control.

Visual Basic
Property RowTextControl() As McadTextControl
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextHeight Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text height.

Visual Basic
Property RowTextHeight() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextMarginBottom Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextMarginBottom Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextMarginBottom Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text bottom margin.

Visual Basic
Property RowTextMarginBottom() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextMarginLeft Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextMarginLeft Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextMarginLeft Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text left margin.

Visual Basic
Property RowTextMarginLeft() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextMarginRight Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextMarginRight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextMarginRight Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text left margin.

Visual Basic
Property RowTextMarginRight() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextMarginTop Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextMarginTop Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextMarginTop Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text top margin.

Visual Basic
Property RowTextMarginTop() As double
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextStyle Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text style.

Visual Basic
Property RowTextStyle() As IAcadTextStyle*
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard3::RowTextTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3::RowTextTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3::RowTextTrueColor Property
IMcadPartListStandard3 Interface IMcadPartListStandard3 Members IMcadPartListStandard3 Interface Send Feedback
Summary

Property that specifies the Parts List row text color.

Visual Basic
Property RowTextTrueColor() As IAcadAcCmColor*
Interface

IMcadPartListStandard3 Interface

Links
IMcadPartListStandard3 Interface, IMcadPartListStandard3 Members, IMcadPartListStandard3 Interface


IMcadPartListStandard4 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard4 Interface
IMcadPartListStandard4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Stores the Parts List standard setting information.

Class Hierarchy

Declaration syntax

IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4
Visual Basic
Public Interface IMcadPartListStandard4
Inherits IMcadPartListStandard3
Library

SymBBAuto Library

Links
IMcadPartListStandard4 Members, SymBBAuto Library, Class Hierarchy


IMcadPartListStandard4 Members

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard4 Members
IMcadPartListStandard4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListStandard4.

Interface

IMcadPartListStandard4 Interface

Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
ColumnSplitWrapAroundTitle | Specifies whether the parts list can be wrapped around the title block in this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.
Links
IMcadPartListStandard4 Interface, Legend, Methods, Properties


IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property
IMcadPartListStandard4 Interface IMcadPartListStandard4 Members IMcadPartListStandard4 Interface Send Feedback
Summary

Specifies whether the parts list can be wrapped around the title block in this standard.

Visual Basic
Property ColumnSplitWrapAroundTitle() As VARIANT_BOOL
Interface

IMcadPartListStandard4 Interface

Links
IMcadPartListStandard4 Interface, IMcadPartListStandard4 Members, IMcadPartListStandard4 Interface


IMcadPartListStdPartsFilter Interface

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStdPartsFilter Interface
IMcadPartListStdPartsFilter Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A filter object that filters the contents of a Parts List by Standard parts.

Class Hierarchy

Declaration syntax

IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter
Visual Basic
Public Interface IMcadPartListStdPartsFilter
Inherits IMcadPartListCustomFilter
Library

SymBBAuto Library

Links
IMcadPartListStdPartsFilter Members, SymBBAuto Library, Class Hierarchy


IMcadPartListStdPartsFilter Members

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStdPartsFilter Members
IMcadPartListStdPartsFilter Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartListStdPartsFilter.

Interface

IMcadPartListStdPartsFilter Interface

Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
Option | Property that specifies the filter option used by the Parts List Standard parts filter to display parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.
Links
IMcadPartListStdPartsFilter Interface, Legend, Methods, Properties


IMcadPartListStdPartsFilter::Option Property

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter::Option Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStdPartsFilter::Option Property
IMcadPartListStdPartsFilter Interface IMcadPartListStdPartsFilter Members IMcadPartListStdPartsFilter Interface Send Feedback
Summary

Property that specifies the filter option used by the Parts List Standard parts filter to display parts.

Visual Basic
Property Option() As McadStdPartsFilterOption
Interface

IMcadPartListStdPartsFilter Interface

Links
IMcadPartListStdPartsFilter Interface, IMcadPartListStdPartsFilter Members, IMcadPartListStdPartsFilter Interface


IMcadPartReference Interface

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference Interface
IMcadPartReference Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
Visual Basic
Public Interface IMcadPartReference
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadPartReference Members, SymBBAuto Library, Class Hierarchy


IMcadPartReference Members

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference Members
IMcadPartReference Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartReference.

Interface

IMcadPartReference Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadPartReference Interface, Legend, Methods, Properties


IMcadPartReference::Data Property

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference::Data Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference::Data Property
IMcadPartReference Interface IMcadPartReference Members IMcadPartReference Interface Send Feedback
Summary

Specifies the bill of materials table data.

Visual Basic
Property Data() As VARIANT
Remarks

The data is represented as a two dimensional array of strings of key value pairs.

Interface

IMcadPartReference Interface

Links
IMcadPartReference Interface, IMcadPartReference Members, IMcadPartReference Interface


IMcadPartReference::Quantity Property

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference::Quantity Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference::Quantity Property
IMcadPartReference Interface IMcadPartReference Members IMcadPartReference Interface Send Feedback
Summary

Specifies the quantity value of the part reference.

Visual Basic
Property Quantity() As long
Remarks

This property is a useful if you prefer to insert only one part reference in the drawing, but you want to enter a bigger Qty in the BOM database. The default value is 1, and only positive integer values can be entered.

This property is a Long.

Interface

IMcadPartReference Interface

Links
IMcadPartReference Interface, IMcadPartReference Members, IMcadPartReference Interface


IMcadPartReference2 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference2 Interface
IMcadPartReference2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3
Visual Basic
Public Interface IMcadPartReference2
Inherits IMcadPartReference
Library

SymBBAuto Library

Links
IMcadPartReference2 Members, SymBBAuto Library, Class Hierarchy


IMcadPartReference2 Members

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference2 Members
IMcadPartReference2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartReference2.

Interface

IMcadPartReference2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadPartReference2 Interface, Legend, Methods, Properties


IMcadPartReference2::SetAttributePreDefinedListValue Method

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2::SetAttributePreDefinedListValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference2::SetAttributePreDefinedListValue Method
IMcadPartReference2 Interface IMcadPartReference2 Members IMcadPartReference2 Interface Send Feedback
Summary

Sets a specific value within the predefined list for the specified attribute

Visual Basic
Sub SetAttributePreDefinedListValue(attributeName As String, preDefineListValue As String)
Parameters
Parameters | Description
attributeName | Name of attribute which is a predefined list.
preDefineListValue | The specific value within the predefined list to set to. This value must be a valid key in the predefined list.
Interface

IMcadPartReference2 Interface

Links
IMcadPartReference2 Interface, IMcadPartReference2 Members, IMcadPartReference2 Interface


IMcadPartReference3 Interface

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3 Interface
IMcadPartReference3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A part reference symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3
Visual Basic
Public Interface IMcadPartReference3
Inherits IMcadPartReference2
Library

SymBBAuto Library

Links
IMcadPartReference3 Members, SymBBAuto Library, Class Hierarchy


IMcadPartReference3 Members

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3 Members
IMcadPartReference3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartReference3.

Interface

IMcadPartReference3 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachExternalBom | Method that attaches the specified BOM from the specified xref drawing to this part reference.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachExternalBom | Method that detaches the external BOM, if any, from this part reference.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetBomOverride | Method that checks if there is a bom override for the specified attribute/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveAttribute | Method to remove the local attribute value if any from this part reference. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AttachedExternalBom | Property that specifies the attached external BOM, if any, of this part reference.
AttachedExternalBomXrefBlock | Property that specifies the Acad block of the external BOM of this part reference, if any.
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadPartReference3 Interface, Legend, Methods, Properties


IMcadPartReference3::AttachedExternalBom Property

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::AttachedExternalBom Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::AttachedExternalBom Property
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Property that specifies the attached external BOM, if any, of this part reference.

Visual Basic
Property AttachedExternalBom() As IMcadBOM *
Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadPartReference3::AttachedExternalBomXrefBlock Property

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::AttachedExternalBomXrefBlock Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::AttachedExternalBomXrefBlock Property
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Property that specifies the Acad block of the external BOM of this part reference, if any.

Visual Basic
Property AttachedExternalBomXrefBlock() As IAcadBlock **
Remarks

The path of the xref can be obtained by checking the path of the Acad block.

Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadPartReference3::AttachExternalBom Method

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::AttachExternalBom Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::AttachExternalBom Method
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Method that attaches the specified BOM from the specified xref drawing to this part reference.

Visual Basic
Sub AttachExternalBom(xrefPath As String, bomName As String)
Parameters
Parameters | Description
xrefPath | Full pathname of the xref drawing.
bomName | Name of the BOM from the xref drawing to attach to.
Remarks

The path of the xref can be obtained by checking the path of the Acad block.

Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadPartReference3::DetachExternalBom Method

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::DetachExternalBom Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::DetachExternalBom Method
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Method that detaches the external BOM, if any, from this part reference.

Visual Basic
Sub DetachExternalBom(detachXref As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
detachXref | Indicates if the xref drawing itself should be detached as well.
Remarks

The path of the xref can be obtained by checking the path of the Acad block.

Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadPartReference3::GetBomOverride Method

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::GetBomOverride Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::GetBomOverride Method
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Method that checks if there is a bom override for the specified attribute/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.

Visual Basic
Sub GetBomOverride(attributeName As String, ByRef originalValue As String, ByRef originalData As String, ByRef currentValue As String, ByRef currentData As String, ByRef editable As VARIANT_BOOL, overrideType As [out, retval] McadBomOverrideType)
Parameters
Parameters | Description
attributeName | Name of attribute/column to check.
originalValue | The original evaluated value (what would be there if there is no override). Would be empty if there is no bom override.
originalData | The original unevaluated data (what would be there if there is no override). Would be empty if there is no bom override.
currentValue | The current evaluated value.
currentData | The current unevaluated data.
editable | Indicates if the attribute can be edited.
Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadPartReference3::RemoveAttribute Method

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3::RemoveAttribute Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3::RemoveAttribute Method
IMcadPartReference3 Interface IMcadPartReference3 Members IMcadPartReference3 Interface Send Feedback
Summary

Method to remove the local attribute value if any from this part reference. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.

Visual Basic
Sub RemoveAttribute(attributeName As String)
Parameters
Parameters | Description
attributeName | Name of attribute/column to remove.
Remarks

Note that Quantity can’t be an attribute of part reference, so this method will not work for quantity override.

Interface

IMcadPartReference3 Interface

Links
IMcadPartReference3 Interface, IMcadPartReference3 Members, IMcadPartReference3 Interface


IMcadRevisionList Interface

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList Interface
IMcadRevisionList Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface that represents the revision list created in the drawing.

Class Hierarchy

Declaration syntax

IMcadRevisionList
Visual Basic
Public Interface IMcadRevisionList
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadRevisionList Members, SymBBAuto Library, Class Hierarchy


IMcadRevisionList Members

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList Members
IMcadRevisionList Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadRevisionList.

Interface

IMcadRevisionList Interface

Methods
Name | Description
Add | Add a revision to the end of the revision list.
Item | Returns the data set for a specified revision in this revision list.
Set | Sets a revision list entry to a specific value.
Properties
Name | Description
Border | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Border32 | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Count | Gets the total number of items in the collection.
Position | Property that returns the input position of the revision list.
Ref | Property that returns a reference to the title/border object.
Ref32 | Read-only property that returns the object ID of this revision list.
Links
IMcadRevisionList Interface, Legend, Methods, Properties


IMcadRevisionList::Border Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Border Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Border Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.

Visual Basic
Property Border() As LONG_PTR*
Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Border32 Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Border32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Border32 Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.

Visual Basic
Property Border32() As LONG*
Remarks

For 64-bit platform only. This is the same as Border property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.

Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Count Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Count Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Gets the total number of items in the collection.

Visual Basic
Property Count() As LONG*
Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Position Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Position Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Property that returns the input position of the revision list.

Visual Basic
Property Position() As VARIANT*
Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Ref Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Ref Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Ref Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref() As LONG_PTR*
Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Ref32 Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Ref32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Ref32 Property
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Read-only property that returns the object ID of this revision list.

Visual Basic
Property Ref32() As LONG*
Remarks

This is the same as Ref property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.

Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Add Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Add Method
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Add a revision to the end of the revision list.

Visual Basic
Sub Add(attributes As VARIANT, pRet As [out, retval]VARIANT_BOOL)
Parameters
Parameters | Description
attributes | New revision data set (see the Item method).
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.

Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Item Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Item Method
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Returns the data set for a specified revision in this revision list.

Visual Basic
Sub Item(index As VARIANT, pAttributes As [out, retval] VARIANT)
Parameters
Parameters | Description
index | Data set for revision.
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.

Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionList::Set Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList::Set Method
IMcadRevisionList Interface IMcadRevisionList Members IMcadRevisionList Interface Send Feedback
Summary

Sets a revision list entry to a specific value.

Visual Basic
Sub Set(index As VARIANT, attributes As VARIANT)
Parameters
Parameters | Description
index | Index of revision to set.
attributes | New revision data set.
Remarks

The data set is a 2D SAFEARRAY with VARIANT element type. There are two elements for each row in the array: the first one is the KEY of arrtibute, and the second one is its VALUE.

Interface

IMcadRevisionList Interface

Links
IMcadRevisionList Interface, IMcadRevisionList Members, IMcadRevisionList Interface


IMcadRevisionListDescriptor Interface

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor Interface
IMcadRevisionListDescriptor Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for interacting with all data associated with a revision list.

Class Hierarchy

Declaration syntax

IMcadRevisionListDescriptor
Visual Basic
Public Interface IMcadRevisionListDescriptor
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadRevisionListDescriptor Members, SymBBAuto Library, Class Hierarchy


IMcadRevisionListDescriptor Members

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor Members
IMcadRevisionListDescriptor Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadRevisionListDescriptor.

Interface

IMcadRevisionListDescriptor Interface

Properties
Name | Description
Attributes | Property that gets and sets the attributes of the revision list. You can create a new revision list with the attributes specified in descriptor object.
Border | Returns a pointer to the object id of the associated title block border with this revision list.
Border32 | Returns a pointer to the object id of the associated title block border with this revision list.
Position | Property that sets and gets the position of the revision list.
Links
IMcadRevisionListDescriptor Interface, Legend, Properties


IMcadRevisionListDescriptor::Attributes Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor::Attributes Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor::Attributes Property
IMcadRevisionListDescriptor Interface IMcadRevisionListDescriptor Members IMcadRevisionListDescriptor Interface Send Feedback
Summary

Property that gets and sets the attributes of the revision list. You can create a new revision list with the attributes specified in descriptor object.

Visual Basic
Property Attributes() As VARIANT
Remarks

Retreiving the attributes property of newly created descriptor object will get the attributes with key and empty values. You can specify some attribute values and pass them back to the descriptor object for creating a new revision list.

If you want to retrieve the attributes for the existing revision list object, please call the methods of revision list object.

Interface

IMcadRevisionListDescriptor Interface

Links
IMcadRevisionListDescriptor Interface, IMcadRevisionListDescriptor Members, IMcadRevisionListDescriptor Interface


IMcadRevisionListDescriptor::Border Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor::Border Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor::Border Property
IMcadRevisionListDescriptor Interface IMcadRevisionListDescriptor Members IMcadRevisionListDescriptor Interface Send Feedback
Summary

Returns a pointer to the object id of the associated title block border with this revision list.

Visual Basic
Property Border() As VARIANT
Interface

IMcadRevisionListDescriptor Interface

Links
IMcadRevisionListDescriptor Interface, IMcadRevisionListDescriptor Members, IMcadRevisionListDescriptor Interface


IMcadRevisionListDescriptor::Border32 Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor::Border32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor::Border32 Property
IMcadRevisionListDescriptor Interface IMcadRevisionListDescriptor Members IMcadRevisionListDescriptor Interface Send Feedback
Summary

Returns a pointer to the object id of the associated title block border with this revision list.

Visual Basic
Property Border32() As LONG*
Remarks

For 64-bit platform only. This is the same as Border property, but is only available for x64 platform to return LONG objectId for VBA 32-bit out of process.

Interface

IMcadRevisionListDescriptor Interface

Links
IMcadRevisionListDescriptor Interface, IMcadRevisionListDescriptor Members, IMcadRevisionListDescriptor Interface


IMcadRevisionListDescriptor::Position Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor::Position Property
IMcadRevisionListDescriptor Interface IMcadRevisionListDescriptor Members IMcadRevisionListDescriptor Interface Send Feedback
Summary

Property that sets and gets the position of the revision list.

Visual Basic
Property Position() As VARIANT
Interface

IMcadRevisionListDescriptor Interface

Links
IMcadRevisionListDescriptor Interface, IMcadRevisionListDescriptor Members, IMcadRevisionListDescriptor Interface


IMcadRevisionLists Interface

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists Interface
IMcadRevisionLists Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for working with a collection of revision list objects.

Class Hierarchy

Declaration syntax

IMcadRevisionLists
Visual Basic
Public Interface IMcadRevisionLists
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadRevisionLists Members, SymBBAuto Library, Class Hierarchy


IMcadRevisionLists Members

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists Members
IMcadRevisionLists Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadRevisionLists.

Interface

IMcadRevisionLists Interface

Methods
Name | Description
Item | Obtains a specified title/border from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Property that returns number of revisions in this revision list.
Links
IMcadRevisionLists Interface, Legend, Methods, Properties


IMcadRevisionLists::Application Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists::Application Property
IMcadRevisionLists Interface IMcadRevisionLists Members IMcadRevisionLists Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Interface

IMcadRevisionLists Interface

Links
IMcadRevisionLists Interface, IMcadRevisionLists Members, IMcadRevisionLists Interface


IMcadRevisionLists::Count Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists::Count Property
IMcadRevisionLists Interface IMcadRevisionLists Members IMcadRevisionLists Interface Send Feedback
Summary

Property that returns number of revisions in this revision list.

Visual Basic
Property Count() As long*
Interface

IMcadRevisionLists Interface

Links
IMcadRevisionLists Interface, IMcadRevisionLists Members, IMcadRevisionLists Interface


IMcadRevisionLists::Item Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists::Item Method
IMcadRevisionLists Interface IMcadRevisionLists Members IMcadRevisionLists Interface Send Feedback
Summary

Obtains a specified title/border from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadRevisionList*)
Parameters
Parameters | Description
Index | Input long value that specifies an index of the selected title/border object in the collection. Values range from 0 to one less than the total number of objects.
Interface

IMcadRevisionLists Interface

Links
IMcadRevisionLists Interface, IMcadRevisionLists Members, IMcadRevisionLists Interface


IMcadRevisionMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr Interface
IMcadRevisionMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for working with the general functionality of a revision list.

Class Hierarchy

Declaration syntax

IMcadRevisionMgr
Visual Basic
Public Interface IMcadRevisionMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadRevisionMgr Members, SymBBAuto Library, Class Hierarchy


IMcadRevisionMgr Members

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr Members
IMcadRevisionMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadRevisionMgr.

Interface

IMcadRevisionMgr Interface

Methods
Name | Description
CreateRevisionList | Creates a new revision list.
DeleteRevisionList | Removes a revision list from the drawing. Return TRUE if the specified revision list has been deleted successfully, otherwise return FALSE.
GetRevisionListFromRef | Returns the revision list object referred by object in the drawing.
NewDescriptor | Creates and initializes a new title border descriptor. Returns a new revision list descriptor object.
Properties
Name | Description
RevisionLists | Property that returns the collection object containing all the revision lists maintained by the manager.
Links
IMcadRevisionMgr Interface, Legend, Methods, Properties


IMcadRevisionMgr::RevisionLists Property

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr::RevisionLists Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr::RevisionLists Property
IMcadRevisionMgr Interface IMcadRevisionMgr Members IMcadRevisionMgr Interface Send Feedback
Summary

Property that returns the collection object containing all the revision lists maintained by the manager.

Visual Basic
Property RevisionLists() As IMcadRevisionLists**
Interface

IMcadRevisionMgr Interface

Links
IMcadRevisionMgr Interface, IMcadRevisionMgr Members, IMcadRevisionMgr Interface


IMcadRevisionMgr::CreateRevisionList Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr::CreateRevisionList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr::CreateRevisionList Method
IMcadRevisionMgr Interface IMcadRevisionMgr Members IMcadRevisionMgr Interface Send Feedback
Summary

Creates a new revision list.

Visual Basic
Sub CreateRevisionList(pDesc As IMcadRevisionListDescriptor, pRevList As [out, retval] IMcadRevisionList *)
Parameters
Parameters | Description
pDesc | Input revision list descriptor object which specifies all data associated with the newly created revision list object.
Interface

IMcadRevisionMgr Interface

Links
IMcadRevisionMgr Interface, IMcadRevisionMgr Members, IMcadRevisionMgr Interface


IMcadRevisionMgr::DeleteRevisionList Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr::DeleteRevisionList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr::DeleteRevisionList Method
IMcadRevisionMgr Interface IMcadRevisionMgr Members IMcadRevisionMgr Interface Send Feedback
Summary

Removes a revision list from the drawing. Return TRUE if the specified revision list has been deleted successfully, otherwise return FALSE.

Visual Basic
Sub DeleteRevisionList(pRevList As IMcadRevisionList, bRet As [out, retval]VARIANT_BOOL)
Parameters
Parameters | Description
pRevList | Specify the revision list which will be deleted from the drawing.
Interface

IMcadRevisionMgr Interface

Links
IMcadRevisionMgr Interface, IMcadRevisionMgr Members, IMcadRevisionMgr Interface


IMcadRevisionMgr::GetRevisionListFromRef Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr::GetRevisionListFromRef Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr::GetRevisionListFromRef Method
IMcadRevisionMgr Interface IMcadRevisionMgr Members IMcadRevisionMgr Interface Send Feedback
Summary

Returns the revision list object referred by object in the drawing.

Visual Basic
Sub GetRevisionListFromRef(revId As VARIANT, pRevList As [out, retval] IMcadRevisionList *)
Parameters
Parameters | Description
revId | Input object ID of itself or its entity part in the drawing
Interface

IMcadRevisionMgr Interface

Links
IMcadRevisionMgr Interface, IMcadRevisionMgr Members, IMcadRevisionMgr Interface


IMcadRevisionMgr::NewDescriptor Method

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr::NewDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr::NewDescriptor Method
IMcadRevisionMgr Interface IMcadRevisionMgr Members IMcadRevisionMgr Interface Send Feedback
Summary

Creates and initializes a new title border descriptor. Returns a new revision list descriptor object.

Visual Basic
Sub NewDescriptor(ppDesc As [out, retval] IMcadRevisionListDescriptor*)
Interface

IMcadRevisionMgr Interface

Links
IMcadRevisionMgr Interface, IMcadRevisionMgr Members, IMcadRevisionMgr Interface


IMcadScaleArea Interface

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea Interface
IMcadScaleArea Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the scale area created in the model space.

Class Hierarchy

Declaration syntax

IMcadScaleArea
Visual Basic
Public Interface IMcadScaleArea
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadScaleArea Members, SymBBAuto Library, Class Hierarchy


IMcadScaleArea Members

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea Members
IMcadScaleArea Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadScaleArea.

Interface

IMcadScaleArea Interface

Methods
Name | Description
CreateViewPort | Creates viewport on specified layout.
DeleteViewPort | Delete viewport for the scale area.
GetAttachedViewportIds | Gets object IDs of all viewports that are attached to the scale area.
GetAttachedViewportIds32 | Gets object IDs of all viewports that are attached to the scale area.
MoveBorder | Moves the border of the scale area.
RescaleObjects | Performs rescaling of specified objects.
SetBasicScale | Sets text scaling factor as the model scale.
Properties
Name | Description
AttachObjectId | Property that specifies the object ID of the defining object, which is the closed curve for the border.
AttachObjectId32 | Property that specifies the object ID of the defining object, which is the closed curve for the border.
LengthScalingFactor | Specifies the length scaling factor of the scale area.
ScaleType | Specifies the type of scale to be text scaling or length scaling.
TextScalingFactor | Specifies the text scaling factor of the scale area.
Links
IMcadScaleArea Interface, Legend, Methods, Properties


IMcadScaleArea::AttachObjectId Property

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::AttachObjectId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::AttachObjectId Property
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Property that specifies the object ID of the defining object, which is the closed curve for the border.

Visual Basic
Property AttachObjectId() As LONG_PTR*
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::AttachObjectId32 Property

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::AttachObjectId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::AttachObjectId32 Property
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Property that specifies the object ID of the defining object, which is the closed curve for the border.

Visual Basic
Property AttachObjectId32() As LONG*
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::LengthScalingFactor Property

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::LengthScalingFactor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::LengthScalingFactor Property
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Specifies the length scaling factor of the scale area.

Visual Basic
Property LengthScalingFactor() As double
Remarks

Before setting this property, ScaleType has to be set to sbScaleDf.

Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::ScaleType Property

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::ScaleType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::ScaleType Property
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Specifies the type of scale to be text scaling or length scaling.

Visual Basic
Property ScaleType() As McadScaleType
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::TextScalingFactor Property

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::TextScalingFactor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::TextScalingFactor Property
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Specifies the text scaling factor of the scale area.

Visual Basic
Property TextScalingFactor() As double
Remarks

Before setting this property, ScaleType has to be set to sbScalePf.

Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::CreateViewPort Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::CreateViewPort Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::CreateViewPort Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Creates viewport on specified layout.

Visual Basic
Sub CreateViewPort(layoutName As String, viewPosition As VARIANT)
Parameters
Parameters | Description
layoutName | Input name of the layout
viewPosition | Input position to place the viewport in the layout. The VARIANT is a 3-element array of doubles for x, y and z points.
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::DeleteViewPort Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::DeleteViewPort Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::DeleteViewPort Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Delete viewport for the scale area.

Visual Basic
Sub DeleteViewPort()
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::GetAttachedViewportIds Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::GetAttachedViewportIds Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::GetAttachedViewportIds Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Gets object IDs of all viewports that are attached to the scale area.

Visual Basic
Sub GetAttachedViewportIds(viewPortIds As [out, retval]VARIANT)
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::GetAttachedViewportIds32 Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::GetAttachedViewportIds32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::GetAttachedViewportIds32 Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Gets object IDs of all viewports that are attached to the scale area.

Visual Basic
Sub GetAttachedViewportIds32(viewPortIds As [out, retval]VARIANT)
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::MoveBorder Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::MoveBorder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::MoveBorder Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Moves the border of the scale area.

Visual Basic
Sub MoveBorder(targetPosition As VARIANT)
Parameters
Parameters | Description
targetPosition | Input target position in WCS coordinates. The VARIANT is a 3-element array of doubles for x, y and z points.
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::RescaleObjects Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::RescaleObjects Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::RescaleObjects Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Performs rescaling of specified objects.

Visual Basic
Sub RescaleObjects(objectIds As VARIANT)
Parameters
Parameters | Description
ObjectIDs | Input array of object IDs to be rescaled. The variant is array of long or int64.
Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleArea::SetBasicScale Method

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea::SetBasicScale Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea::SetBasicScale Method
IMcadScaleArea Interface IMcadScaleArea Members IMcadScaleArea Interface Send Feedback
Summary

Sets text scaling factor as the model scale.

Visual Basic
Sub SetBasicScale()
Remarks

Before setting this property, ScaleType has to be set to sbScaleDf.

Interface

IMcadScaleArea Interface

Links
IMcadScaleArea Interface, IMcadScaleArea Members, IMcadScaleArea Interface


IMcadScaleAreaMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr Interface
IMcadScaleAreaMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is used to create and find a scale area in the modelspace.

Class Hierarchy

Declaration syntax

IMcadScaleAreaMgr
Visual Basic
Public Interface IMcadScaleAreaMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadScaleAreaMgr Members, SymBBAuto Library, Class Hierarchy


IMcadScaleAreaMgr Members

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr Members
IMcadScaleAreaMgr Interface Legend Methods Send Feedback
Summary

The following tables list the members exposed by IMcadScaleAreaMgr.

Interface

IMcadScaleAreaMgr Interface

Methods
Name | Description
CreateScaleArea | Create a new scale area and append it to the current layout.
DeleteScaleArea | Delete scale area.
FindScaleArea | Search the scale area attached to the given object.
Links
IMcadScaleAreaMgr Interface, Legend, Methods


IMcadScaleAreaMgr::CreateScaleArea Method

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr::CreateScaleArea Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr::CreateScaleArea Method
IMcadScaleAreaMgr Interface IMcadScaleAreaMgr Members IMcadScaleAreaMgr Interface Send Feedback
Summary

Create a new scale area and append it to the current layout.

Visual Basic
Sub CreateScaleArea(borderId As VARIANT, scaleArea As [out, retval] IMcadScaleArea*)
Parameters
Parameters | Description
borderId | Input object ID of the closed curve for the border
Interface

IMcadScaleAreaMgr Interface

Links
IMcadScaleAreaMgr Interface, IMcadScaleAreaMgr Members, IMcadScaleAreaMgr Interface


IMcadScaleAreaMgr::DeleteScaleArea Method

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr::DeleteScaleArea Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr::DeleteScaleArea Method
IMcadScaleAreaMgr Interface IMcadScaleAreaMgr Members IMcadScaleAreaMgr Interface Send Feedback
Summary

Delete scale area.

Visual Basic
Sub DeleteScaleArea(scaleArea As IMcadScaleArea)
Parameters
Parameters | Description
scaleArea | Input scale area object
Interface

IMcadScaleAreaMgr Interface

Links
IMcadScaleAreaMgr Interface, IMcadScaleAreaMgr Members, IMcadScaleAreaMgr Interface


IMcadScaleAreaMgr::FindScaleArea Method

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr::FindScaleArea Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr::FindScaleArea Method
IMcadScaleAreaMgr Interface IMcadScaleAreaMgr Members IMcadScaleAreaMgr Interface Send Feedback
Summary

Search the scale area attached to the given object.

Visual Basic
Sub FindScaleArea(borderId As VARIANT, searchAllLayouts As [in, defaultvalue(FALSE)] VARIANT_BOOL, scaleArea As [out, retval] IMcadScaleArea*)
Parameters
Parameters | Description
borderId | Input object ID of the closed curve for the border
searchAllLayouts | Input VARIANT_TRUE if search in all layouts. VARIANT_FALSE (Default) if search in current layout only
Interface

IMcadScaleAreaMgr Interface

Links
IMcadScaleAreaMgr Interface, IMcadScaleAreaMgr Members, IMcadScaleAreaMgr Interface


IMcadSectionLine Interface

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine Interface
IMcadSectionLine Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The object represents the section line creating in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSectionLine
Visual Basic
Public Interface IMcadSectionLine
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadSectionLine Members, SymBBAuto Library, Class Hierarchy


IMcadSectionLine Members

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine Members
IMcadSectionLine Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSectionLine.

Interface

IMcadSectionLine Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSectionPoint | Adds a vertex to section line.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LabelName | Specifes the name of label in the section line.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetLabelNames | Specifies the label names of the section line.
SetSectionArcPointAt | Sets arc vertex to section line at specified index.
SetSectionPointAt | Sets a vertex to the section line at a specific index.
SetSectionPoints | Sets vertexes of section lines.
SetSectionViewOrigin | Specifies section view origin of the section line.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelNamesCount | Returns the number of label names.
LabelPattern | Specifies the label pattern for the section line.
LabelText | Property to get the evaluated pattern (with label name and scale).
LabelVisibility | Specifies the visibility of label in the section line.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LineVisibility | Specifies visibility style of the section line.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
PlaneSymbolsVisibility | Specifies the visibility of plane symbols.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SectionPoints | Property to get the array of section point. The VARIANT is a 3-element array of doubles for x, y and z points.
SectionSide | Specifies the direction side of section line symbol. The VARIANT is a 3-element of doubles for x, y and z point.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadSectionLine Interface, Legend, Methods, Properties


IMcadSectionLine::ArrowVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::ArrowVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::ArrowVisibility Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies whether arrow is visible or hidden at the end of the section line.

Visual Basic
Property ArrowVisibility() As VARIANT_BOOL
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LabelNamesCount Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LabelNamesCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LabelNamesCount Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Returns the number of label names.

Visual Basic
Property LabelNamesCount() As int*
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LabelPattern Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies the label pattern for the section line.

Visual Basic
Property LabelPattern() As String
Remarks

This string can be set using the strings, "<SECTION_LABEL_FIRST>" and "<SECTION_LABEL_LAST>", such as “=<SECTION_LABEL_FIRST>-<SECTION_LABEL_LAST>”.

Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LabelText Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LabelText Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LabelText Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Property to get the evaluated pattern (with label name and scale).

Visual Basic
Property LabelText() As BSTR*
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LabelVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LabelVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LabelVisibility Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies the visibility of label in the section line.

Visual Basic
Property LabelVisibility() As VARIANT_BOOL
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LineVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LineVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LineVisibility Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies visibility style of the section line.

Visual Basic
Property LineVisibility() As McadLineVisibility
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::PlaneSymbolsVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::PlaneSymbolsVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::PlaneSymbolsVisibility Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies the visibility of plane symbols.

Visual Basic
Property PlaneSymbolsVisibility() As VARIANT_BOOL
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SectionPoints Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SectionPoints Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SectionPoints Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Property to get the array of section point. The VARIANT is a 3-element array of doubles for x, y and z points.

Visual Basic
Property SectionPoints() As VARIANT*
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SectionSide Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SectionSide Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SectionSide Property
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies the direction side of section line symbol. The VARIANT is a 3-element of doubles for x, y and z point.

Visual Basic
Property SectionSide() As VARIANT
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::AddSectionPoint Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::AddSectionPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::AddSectionPoint Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Adds a vertex to section line.

Visual Basic
Sub AddSectionPoint(point As VARIANT)
Parameters
Parameters | Description
point | New vertex.
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::LabelName Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::LabelName Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::LabelName Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifes the name of label in the section line.

Visual Basic
Sub LabelName(Index As [in, optional] VARIANT, pVal As [out, retval] BSTR)
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SetLabelNames Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SetLabelNames Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SetLabelNames Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies the label names of the section line.

Visual Basic
Sub SetLabelNames(newVal As VARIANT)
Parameters
Parameters | Description
newVal | Labels names. The Variant is a array of BSTR.
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SetSectionArcPointAt Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SetSectionArcPointAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SetSectionArcPointAt Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Sets arc vertex to section line at specified index.

Visual Basic
Sub SetSectionArcPointAt(Index As long, Point As VARIANT, LineSegmentType As McadSectionLineSegmentType)
Parameters
Parameters | Description
Index | _nt_
Point | _nt_
LineSegmentType | _nt_
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SetSectionPointAt Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SetSectionPointAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SetSectionPointAt Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Sets a vertex to the section line at a specific index.

Visual Basic
Sub SetSectionPointAt(Index As long, Point As VARIANT)
Parameters
Parameters | Description
Index | Index of vertex.
Point | location of vertex.
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SetSectionPoints Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SetSectionPoints Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SetSectionPoints Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Sets vertexes of section lines.

Visual Basic
Sub SetSectionPoints(Points As VARIANT, ArcPoints As [in, optional] VARIANT, LineSegmentTypes As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | A variant. A 3-element array of doubles for x, y and z points.
ArcPoints | A variant. A 3-element array of doubles for x, y and z points.
LineSegmentTypes | A variant. An array of McadSectionLineSegmentType value.
Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLine::SetSectionViewOrigin Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine::SetSectionViewOrigin Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine::SetSectionViewOrigin Method
IMcadSectionLine Interface IMcadSectionLine Members IMcadSectionLine Interface Send Feedback
Summary

Specifies section view origin of the section line.

Visual Basic
Sub SetSectionViewOrigin(Origin As VARIANT)
Parameters
Parameters | Description
Origin | Section view origin.
Remarks

This function must be invoked after posting the section line symbol to the database.

Interface

IMcadSectionLine Interface

Links
IMcadSectionLine Interface, IMcadSectionLine Members, IMcadSectionLine Interface


IMcadSectionLineStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard Interface
IMcadSectionLineStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Interface for working with the standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2
Visual Basic
Public Interface IMcadSectionLineStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadSectionLineStandard Members, SymBBAuto Library, Class Hierarchy


IMcadSectionLineStandard Members

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard Members
IMcadSectionLineStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSectionLineStandard.

Interface

IMcadSectionLineStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelPattern | Specifies the label pattern used by the section view.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSectionLineStandard Interface, Legend, Methods, Properties


IMcadSectionLineStandard::ArrowTowardsLine Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::ArrowTowardsLine Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::ArrowTowardsLine Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Gets whether arrow is drawn as pointing towards or away from the line.

Visual Basic
Property ArrowTowardsLine() As VARIANT_BOOL*
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::ArrowVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::ArrowVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::ArrowVisibility Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies whether arrow is visible or hidden at the end of the section line.

Visual Basic
Property ArrowVisibility() As VARIANT_BOOL
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LabelAbove Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LabelAbove Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LabelAbove Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.

Visual Basic
Property LabelAbove() As VARIANT_BOOL
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LabelPattern Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LabelPattern Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LabelPattern Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies the label pattern used by the section view.

Visual Basic
Property LabelPattern() As String
Remarks

This string can be set using the strings, "<SECTION_LABEL_FIRST>" and "<SECTION_LABEL_LAST>", such as “=<SECTION_LABEL_FIRST>-<SECTION_LABEL_LAST>”.

Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LabelVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LabelVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LabelVisibility Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies whether section view label is visible or hidden.

Visual Basic
Property LabelVisibility() As VARIANT_BOOL
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LineColor Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LineColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LineColor Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies the color of section line.

Visual Basic
Property LineColor() As ACAD_COLOR
Parameters
Parameters | Description
Color | _nt_
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LineTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LineTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LineTrueColor Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies the color of section line.

Visual Basic
Property LineTrueColor() As IAcadAcCmColor*
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LineVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LineVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LineVisibility Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies visibility style of the section line.

Visual Basic
Property LineVisibility() As McadLineVisibility
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::LineWeight Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::LineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::LineWeight Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies the default weight of section line.

Visual Basic
Property LineWeight() As ACAD_LWEIGHT
Remarks

This property is a cLineWeight enumeration. The initial value for this property is a cLnWtByBlock. Available lineweight values include:

  • acLnWtByLayer
  • acLnWtByBlock
  • acLnWtByLwDefault
  • cLnWt000
  • acLnWt005
  • acLnWt009
  • acLnWt013
  • acLnWt015
  • acLnWt018
  • acLnWt020
  • acLnWt025
  • acLnWt030
  • acLnWt035
  • acLnWt040
  • acLnWt050
  • acLnWt053
  • acLnWt060
  • acLnWt070
  • acLnWt080
  • acLnWt090
  • acLnWt100
  • acLnWt106
  • acLnWt120
  • acLnWt140
  • acLnWt158
  • acLnWt200
  • acLnWt211

Lineweight values consist of standard settings including BYLAYER, BYBLOCK, and DEFAULT. The DEFAULT value is set by the LWDEFAULT system variable and defaults to a value of 0.01 in. or 0.25 mm. All new objects and layers have a default setting of DEFAULT. The lineweight value of 0 plots at the thinnest lineweight available on the specified plotting device and is displayed at one pixel wide in model space.

Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::MultipleNamesSupported Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::MultipleNamesSupported Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::MultipleNamesSupported Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies whether is to use continuous names for plane symbols.

Visual Basic
Property MultipleNamesSupported() As VARIANT_BOOL
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard::PlaneSymbolsVisibility Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard::PlaneSymbolsVisibility Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard::PlaneSymbolsVisibility Property
IMcadSectionLineStandard Interface IMcadSectionLineStandard Members IMcadSectionLineStandard Interface Send Feedback
Summary

Specifies whether annotation is to be showed at each vertex.

Visual Basic
Property PlaneSymbolsVisibility() As VARIANT_BOOL
Interface

IMcadSectionLineStandard Interface

Links
IMcadSectionLineStandard Interface, IMcadSectionLineStandard Members, IMcadSectionLineStandard Interface


IMcadSectionLineStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2 Interface MG2013New
IMcadSectionLineStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This interface is derived from IMcadSectionLineStandard. It is for the section view standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2
Visual Basic
Public Interface IMcadSectionLineStandard2
Inherits IMcadSectionLineStandard
Library

SymBBAuto Library

Links
IMcadSectionLineStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadSectionLineStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2 Members
IMcadSectionLineStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSectionLineStandard2.

Interface

IMcadSectionLineStandard2 Interface

Methods
Name | Description
GetByStandard | Gets if the specified section view property follow the standard.
SetByStandard | Sets if the specified section view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowLineLength | Specifies the extension length of the arrow line.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
BendLineLength | Specifies the bend line length.
EndArrowType | Specifies the arrow type of the end arrow.
EndBendLineType | Specifies the linetype of end and bend line.
EndLineLength | Specifies the end line length.
EndLineOvershoot | Specifies the end line overshoot.
IdentifierExcludeCharacters | Specifies a string of characters that are to be excluded or invalid for the identifier of section view.
IdentifierOffset | Specifies the identifier offset from section view.
IdentifierPosition | Specifies the identifier position.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern used by the section view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneLineColor | Specifies the color of cutting plane line.
PlaneLineType | Specifies the linetype of cutting plane line.
PlaneLineWeight | Specifies the line weight of cutting plane line.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSectionLineStandard2 Interface, Legend, Methods, Properties


IMcadSectionLineStandard2::ArrowLineLength Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::ArrowLineLength Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::ArrowLineLength Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the extension length of the arrow line.

Visual Basic
Property ArrowLineLength() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::BendLineLength Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::BendLineLength Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::BendLineLength Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the bend line length.

Visual Basic
Property BendLineLength() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::EndArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::EndArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::EndArrowType Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the arrow type of the end arrow.

Visual Basic
Property EndArrowType() As McadArrowType
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::EndBendLineType Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::EndBendLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::EndBendLineType Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the linetype of end and bend line.

Visual Basic
Property EndBendLineType() As IAcadLineType*
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::EndLineLength Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::EndLineLength Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::EndLineLength Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the end line length.

Visual Basic
Property EndLineLength() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::EndLineOvershoot Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::EndLineOvershoot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::EndLineOvershoot Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the end line overshoot.

Visual Basic
Property EndLineOvershoot() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::IdentifierExcludeCharacters Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::IdentifierExcludeCharacters Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::IdentifierExcludeCharacters Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies a string of characters that are to be excluded or invalid for the identifier of section view.

Visual Basic
Property IdentifierExcludeCharacters() As String
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::IdentifierOffset Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::IdentifierOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::IdentifierOffset Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the identifier offset from section view.

Visual Basic
Property IdentifierOffset() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::IdentifierPosition Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::IdentifierPosition Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::IdentifierPosition Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the identifier position.

Visual Basic
Property IdentifierPosition() As McadIdentifierPositionType
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::LabelOffset Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::LabelOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::LabelOffset Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the label offset from section view.

Visual Basic
Property LabelOffset() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::LabelTextColor Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::LabelTextColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::LabelTextColor Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the text color of view label.

Visual Basic
Property LabelTextColor() As IAcadAcCmColor*
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::LabelTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::LabelTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::LabelTextHeight Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the text height of view label.

Visual Basic
Property LabelTextHeight() As double
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::LabelTextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::LabelTextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::LabelTextStyle Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the text style of view label.

Visual Basic
Property LabelTextStyle() As IAcadTextStyle*
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::PlaneLineColor Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::PlaneLineColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::PlaneLineColor Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the color of cutting plane line.

Visual Basic
Property PlaneLineColor() As IAcadAcCmColor*
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::PlaneLineType Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::PlaneLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::PlaneLineType Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the linetype of cutting plane line.

Visual Basic
Property PlaneLineType() As IAcadLineType*
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::PlaneLineWeight Property

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::PlaneLineWeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::PlaneLineWeight Property MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Specifies the line weight of cutting plane line.

Visual Basic
Property PlaneLineWeight() As ACAD_LWEIGHT
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::GetByStandard Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::GetByStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::GetByStandard Method MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Gets if the specified section view property follow the standard.

Visual Basic
Sub GetByStandard(propType As McadSectionLineStandardPropType, pVal As [out, retval] VARIANT_BOOL)
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadSectionLineStandard2::SetByStandard Method

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2::SetByStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2::SetByStandard Method MG2013New
IMcadSectionLineStandard2 Interface IMcadSectionLineStandard2 Members IMcadSectionLineStandard2 Interface Send Feedback
Summary

Sets if the specified section view property follow the standard.

Visual Basic
Sub SetByStandard(propType As McadSectionLineStandardPropType, newVal As VARIANT_BOOL)
Interface

IMcadSectionLineStandard2 Interface

Links
IMcadSectionLineStandard2 Interface, IMcadSectionLineStandard2 Members, IMcadSectionLineStandard2 Interface


IMcadStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard Interface
IMcadStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
Visual Basic
Public Interface IMcadStandard
Inherits IAcadObject
Library

SymBBAuto Library

Links
IMcadStandard Members, SymBBAuto Library, Class Hierarchy


IMcadStandard Members

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard Members
IMcadStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandard.

Interface

IMcadStandard Interface

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.
Links
IMcadStandard Interface, Legend, Methods, Properties


IMcadStandard::AllSymbolStandards Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::AllSymbolStandards Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::AllSymbolStandards Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets all of the symbol standards contained by this standard.

Visual Basic
Property AllSymbolStandards() As IMcadSymbolStandards**
Remarks

This property is a McadSymbolStandards collection.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::ArrowScale Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::ArrowScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::ArrowScale Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the arrow scale of symbols based on this standard.

Visual Basic
Property ArrowScale() As double
Remarks

This property is a Double.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::ArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::ArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::ArrowType Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the leader arrow type for symbols based on this standard.

Visual Basic
Property ArrowType() As McadArrowType
Remarks

This property is a McadArrowType enumeration.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::BaseName Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::BaseName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::BaseName Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the name of the standard that this standard was originally based on.

Visual Basic
Property BaseName() As BSTR*
Remarks

This property is a String. It is specified for a standard by the McadStandardMgr > AddStandard method.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::BOMStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::BOMStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::BOMStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the BOM standard based on this standard.

Visual Basic
Property BOMStandard() As IMcadBOMStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmBOMStd.

This property is a McadBOMStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::Current Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::Current Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::Current Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.

Visual Basic
Property Current() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::CurrentSymbolStandards Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::CurrentSymbolStandards Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::CurrentSymbolStandards Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets all of the symbol standards that are currently used in this standard.

Visual Basic
Property CurrentSymbolStandards() As IMcadSymbolStandards**
Remarks

This property is a McadSymbolStandards collection.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::DatumStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::DatumStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::DatumStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the datum symbol standard contained by this standard.

Visual Basic
Property DatumStandard() As IMcadDatumStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmDatumStd.

This property is a McadDatumStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::FCFStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::FCFStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::FCFStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the feature control frame symbol standard contained by this standard.

Visual Basic
Property FCFStandard() As IMcadFCFStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmFCFStd.

This property is a McadFCFStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::IdentifierStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::IdentifierStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::IdentifierStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the identifier symbol standard contained by this standard.

Visual Basic
Property IdentifierStandard() As IMcadIdentifierStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmIdStd.

This property is a McadIdentifierStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::IsMetric Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::IsMetric Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::IsMetric Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies whether the standard is metric-based.

Visual Basic
Property IsMetric() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::LeaderColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::LeaderColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::LeaderColor Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the color of leader lines created based on this standard.

Visual Basic
Property LeaderColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::Name Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::Name Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the name of a standard.

Visual Basic
Property Name() As String
Remarks

This property is a String. It is specified by the McadStandardMgr > AddStandard method.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::Scale Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::Scale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::Scale Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the scale used to create any new symbols based on this standard.

Visual Basic
Property Scale() As double
Remarks

This property is a Double.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::StandardMgr Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::StandardMgr Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::StandardMgr Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the standard manager for this standard.

Visual Basic
Property StandardMgr() As IMcadStandardMgr**
Remarks

This property is a McadStandardMgr object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::SurfaceTextureStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::SurfaceTextureStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::SurfaceTextureStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the surface texture symbol standard contained by this standard.

Visual Basic
Property SurfaceTextureStandard() As IMcadSurfaceTextureStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmSurfTextStd.

This property is a McadSurfaceTextureStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::SymbolColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::SymbolColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::SymbolColor Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the color of symbols created based on this standard.

Visual Basic
Property SymbolColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::SymbolStandardsSupported Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::SymbolStandardsSupported Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::SymbolStandardsSupported Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the class names of all of the symbol standards that are registered with this standard.

Visual Basic
Property SymbolStandardsSupported() As VARIANT*
Remarks

This property is a Variant (array of Strings).

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::TextColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::TextColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::TextColor Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the color of text in symbols created based on this standard.

Visual Basic
Property TextColor() As ACAD_COLOR
Remarks
  • This property is a cColor enumeration in the AutoCAD ActiveX Automation. The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new datum identifier's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::TextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::TextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::TextHeight Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the height of text in symbols created based on this standard.

Visual Basic
Property TextHeight() As double
Remarks

This is a Double.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::TextHeightList Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::TextHeightList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::TextHeightList Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the list of valid heights for text.

Visual Basic
Property TextHeightList() As VARIANT*
Remarks

This property is a Variant (array of Doubles).

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::TextStyle Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::TextStyle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::TextStyle Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the text style for symbols based on this standard.

Visual Basic
Property TextStyle() As IAcadTextStyle*
Remarks
  • This property is a cadTextStyle object. AcadTextStyle (TextStyle) is an object in the AutoCAD Active Automation. The initial value for this property is a STANDARD.
  • This property overrides the value of the DIMTXSTY system variable for the given dimension.
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::TextStyleName Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::TextStyleName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::TextStyleName Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Specifies the name of the text style for symbols created based on this standard.

Visual Basic
Property TextStyleName() As String
Remarks

This property is a String.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::WeldingStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::WeldingStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::WeldingStandard Property
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the welding symbol standard contained by this standard.

Visual Basic
Property WeldingStandard() As IMcadWeldingStandard**
Remarks

This property is a equivalent to the return value using the McadStandard > GetCurrentSymbolStandard with the class Name = AcmWeldingStd.

This property is a McadWeldingStandard object.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::AddSymbolStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::AddSymbolStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::AddSymbolStandard Method
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.

Visual Basic
Sub AddSymbolStandard(ClassName As String, MakeCurrent As [in, defaultvalue(TRUE)] VARIANT_BOOL, SymbolStandard As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
ClassName | String; input-only. Specifies the class name of the symbol standard to add to the standard.
MakeCurrent | Boolean, default value = True; input-only; optional. Specifies whether to set the new symbol standard as current, TRUE, or not, FALSE.
Returns

McadSymbolStandard object

Remarks
  • If MakeCurrent is TRUE, use the McadStandard > GetCurrentSymbolStandard method to obtain this symbol standard that is currently used in the standard.
  • If MakeCurrent is False, use McadStandard > SetCurrentSymnolStandard method to set it as current for this standard at a later time.
  • To remove this symbol standard, use the McadStandard > RemoveSymbolStandard method
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::GetCurrentSymbolStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::GetCurrentSymbolStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::GetCurrentSymbolStandard Method
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.

Visual Basic
Sub GetCurrentSymbolStandard(Name As String, Standard As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
Name | Name String; input-only. Specifies the class name for the symbol standard to obtain.
Returns

McadSymbolStandard object

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::RemoveSymbolStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::RemoveSymbolStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::RemoveSymbolStandard Method
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Removes the specified symbol standard from this standard.

Visual Basic
Sub RemoveSymbolStandard(SymbolStandard As IMcadSymbolStandard)
Parameters
Parameters | Description
SymbolStandard | McadSymbolStandard object; input-only. Specifies the symbol standard to remove from this standard.
Returns

None

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::SetCurrentSymbolStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::SetCurrentSymbolStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::SetCurrentSymbolStandard Method
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Sets the specified symbol standard current in the standard.

Visual Basic
Sub SetCurrentSymbolStandard(SymbolStandard As IMcadSymbolStandard)
Parameters
Parameters | Description
SymbolStandard | McadSymbolStandard object; input-only. Specifies the symbol standard to set as current for this standard.
Returns

None

Remarks

This method is valid for symbol standards that are returned by the McadStandard > AddSymbolStandard method with the parameter MakeCurrent = FALSE.

Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard::SetToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard::SetToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard::SetToDefaults Method
IMcadStandard Interface IMcadStandard Members IMcadStandard Interface Send Feedback
Summary

Sets the properties of this standard to the factory default values.

Visual Basic
Sub SetToDefaults()
Interface

IMcadStandard Interface

Links
IMcadStandard Interface, IMcadStandard Members, IMcadStandard Interface


IMcadStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2 Interface
IMcadStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
Visual Basic
Public Interface IMcadStandard2
Inherits IMcadStandard
Library

SymBBAuto Library

Links
IMcadStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2 Members
IMcadStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandard2.

Interface

IMcadStandard2 Interface

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.
Links
IMcadStandard2 Interface, Legend, Methods, Properties


IMcadStandard2::LeaderTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2::LeaderTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2::LeaderTrueColor Property
IMcadStandard2 Interface IMcadStandard2 Members IMcadStandard2 Interface Send Feedback
Summary

Specifies the true color of leader in symbol that belongs to this symbol standard.

Visual Basic
Property LeaderTrueColor() As IAcadAcCmColor *
Interface

IMcadStandard2 Interface

Links
IMcadStandard2 Interface, IMcadStandard2 Members, IMcadStandard2 Interface


IMcadStandard2::SymbolTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2::SymbolTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2::SymbolTrueColor Property
IMcadStandard2 Interface IMcadStandard2 Members IMcadStandard2 Interface Send Feedback
Summary

Specifies the true color of symbols created based on this standard.

Visual Basic
Property SymbolTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.
Interface

IMcadStandard2 Interface

Links
IMcadStandard2 Interface, IMcadStandard2 Members, IMcadStandard2 Interface


IMcadStandard2::TextTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2::TextTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2::TextTrueColor Property
IMcadStandard2 Interface IMcadStandard2 Members IMcadStandard2 Interface Send Feedback
Summary

Specifies the true color of text in symbols created based on this standard.

Visual Basic
Property TextTrueColor() As IAcadAcCmColor *
Remarks
  • This property is a cadAcCmColor object.
  • AcadAcCmColor (AcCmColor) object is an object in the AutoCAD ActiveX Automation. This object identifies the color for an object and can hold an RGB value, an ACI number (an integer from 1 to 255), or a named color. Using an RGB value, you can choose from millions of colors.
Interface

IMcadStandard2 Interface

Links
IMcadStandard2 Interface, IMcadStandard2 Members, IMcadStandard2 Interface


IMcadStandard3 Interface

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3 Interface
IMcadStandard3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4
Visual Basic
Public Interface IMcadStandard3
Inherits IMcadStandard2
Library

SymBBAuto Library

Links
IMcadStandard3 Members, SymBBAuto Library, Class Hierarchy


IMcadStandard3 Members

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3 Members
IMcadStandard3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandard3.

Interface

IMcadStandard3 Interface

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.
Links
IMcadStandard3 Interface, Legend, Methods, Properties


IMcadStandard3::AnnotationViewStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::AnnotationViewStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::AnnotationViewStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Gets the Annotation View Standard contained by this standard.

Visual Basic
Property AnnotationViewStandard() As IMcadAnnotationViewStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::DetailSymbolStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::DetailSymbolStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::DetailSymbolStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Property to get the Detail symbol standard.

Visual Basic
Property DetailSymbolStandard() As IMcadDetailSymbolStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::EdgeStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::EdgeStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::EdgeStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Property to get the edge symbol standard.

Visual Basic
Property EdgeStandard() As IMcadEdgeStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::MarkStampStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::MarkStampStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::MarkStampStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Gets the marking/stamping symbol standard contained by this standard.

Visual Basic
Property MarkStampStandard() As IMcadMarkStampStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::NoteStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::NoteStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::NoteStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Property to get the Note symbol standard

Visual Basic
Property NoteStandard() As IMcadNoteStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::TaperStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::TaperStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::TaperStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Property to get the taper symbol standard.

Visual Basic
Property TaperStandard() As IMcadTaperStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard3::TitleBorderStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3::TitleBorderStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3::TitleBorderStandard Property
IMcadStandard3 Interface IMcadStandard3 Members IMcadStandard3 Interface Send Feedback
Summary

Property to get the title border standard.

Visual Basic
Property TitleBorderStandard() As IMcadTitleBorderStandard**
Interface

IMcadStandard3 Interface

Links
IMcadStandard3 Interface, IMcadStandard3 Members, IMcadStandard3 Interface


IMcadStandard4 Interface

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4 Interface
IMcadStandard4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This existing object represents the standard.

Class Hierarchy

Declaration syntax

IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4
Visual Basic
Public Interface IMcadStandard4
Inherits IMcadStandard3
Library

SymBBAuto Library

Links
IMcadStandard4 Members, SymBBAuto Library, Class Hierarchy


IMcadStandard4 Members

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4 Members
IMcadStandard4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandard4.

Interface

IMcadStandard4 Interface

Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
SupportedArrowTypes | This is SupportedArrowTypes, a member of class IMcadStandard4.
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
JointStandard | This is JointStandard, a member of class IMcadStandard4.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
SectionLineStandard | Gets the section line symbol standard contained by this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.
Links
IMcadStandard4 Interface, Legend, Methods, Properties


IMcadStandard4::JointStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4::JointStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4::JointStandard Property
IMcadStandard4 Interface IMcadStandard4 Members IMcadStandard4 Interface Send Feedback
Summary

This is JointStandard, a member of class IMcadStandard4.

Visual Basic
Property JointStandard() As IMcadJointStandard**
Interface

IMcadStandard4 Interface

Links
IMcadStandard4 Interface, IMcadStandard4 Members, IMcadStandard4 Interface


IMcadStandard4::SectionLineStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4::SectionLineStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4::SectionLineStandard Property
IMcadStandard4 Interface IMcadStandard4 Members IMcadStandard4 Interface Send Feedback
Summary

Gets the section line symbol standard contained by this standard.

Visual Basic
Property SectionLineStandard() As IMcadSectionLineStandard**
Interface

IMcadStandard4 Interface

Links
IMcadStandard4 Interface, IMcadStandard4 Members, IMcadStandard4 Interface


IMcadStandard4::SupportedArrowTypes Method

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4::SupportedArrowTypes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4::SupportedArrowTypes Method
IMcadStandard4 Interface IMcadStandard4 Members IMcadStandard4 Interface Send Feedback
Summary

This is SupportedArrowTypes, a member of class IMcadStandard4.

Visual Basic
Sub SupportedArrowTypes(allSrv As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] VARIANT)
Interface

IMcadStandard4 Interface

Links
IMcadStandard4 Interface, IMcadStandard4 Members, IMcadStandard4 Interface


IMcadStandardMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr Interface
IMcadStandardMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The symbol standards manager object

Class Hierarchy

Declaration syntax

IMcadStandardMgr
Visual Basic
Public Interface IMcadStandardMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadStandardMgr Members, SymBBAuto Library, Class Hierarchy


IMcadStandardMgr Members

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr Members
IMcadStandardMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandardMgr.

Interface

IMcadStandardMgr Interface

Methods
Name | Description
AddStandard | Created a new standard based on an original standard, and optionally sets the new standard as current.
CopyStandard | Creates a copy of an existing standard to the specified new name.
GetStandard | Gets the standard with the specified name.
RemoveStandard | Removes the specified standard from the standard manager. This is equivalent to calling the McadStandard > Delete method on a specified standard to be removed.
UpdateSymbols | Updates all symbols with respect to changes made to their standards.
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentStandard | Specifies the current standard for the document.
CurrentStandardName | Specifies the name of the current standard for the document.
DefaultStandard | Gets the name of the default standard.
StandardCount | Gets the number of symbol standards loaded.
StandardNames | Gets the names of all registered standards.
Standards | Gets all standards for the current document.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for the document.
Links
IMcadStandardMgr Interface, Legend, Methods, Properties


IMcadStandardMgr::Application Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::Application Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::CurrentStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::CurrentStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::CurrentStandard Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Specifies the current standard for the document.

Visual Basic
Property CurrentStandard() As IMcadStandard*
Remarks

This property is a McadStandard object.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::CurrentStandardName Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::CurrentStandardName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::CurrentStandardName Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Specifies the name of the current standard for the document.

Visual Basic
Property CurrentStandardName() As String
Remarks

This is String.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::DefaultStandard Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::DefaultStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::DefaultStandard Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the name of the default standard.

Visual Basic
Property DefaultStandard() As BSTR*
Remarks

This property is a String.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::StandardCount Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::StandardCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::StandardCount Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the number of symbol standards loaded.

Visual Basic
Property StandardCount() As long*
Remarks

This property is a Long.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::StandardNames Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::StandardNames Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::StandardNames Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the names of all registered standards.

Visual Basic
Property StandardNames() As VARIANT*
Remarks

This property is a Variant (array of Strings).

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::Standards Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::Standards Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::Standards Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets all standards for the current document.

Visual Basic
Property Standards() As IMcadStandards**
Remarks

This property is a McadStandards collection.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::SymbolBBMgr Property

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::SymbolBBMgr Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::SymbolBBMgr Property
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the Symbol BOM and Balloon manager object for the document.

Visual Basic
Property SymbolBBMgr() As IMcadSymbolBBMgr**
Remarks

This property is a McadSymbolBBMgr object.

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::AddStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::AddStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::AddStandard Method
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Created a new standard based on an original standard, and optionally sets the new standard as current.

Visual Basic
Sub AddStandard(BaseName As String, Current As [in, defaultvalue(TRUE)] VARIANT_BOOL, Name As [in, optional] VARIANT, Standard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
BaseName | String; input-only. Specifies the base standard that a new standard is originally created based on.
Current | Boolean, default value = True; input-only. Specifies whether to set this new standard as current, TRUE, or not, FALSE.
Name | Variant (String); input-only; optional. If specified, a new standard based on the specified base standard definition is created with the specified name.
Returns

McadStandard object

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::CopyStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::CopyStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::CopyStandard Method
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Creates a copy of an existing standard to the specified new name.

Visual Basic
Sub CopyStandard(BaseStandard As IMcadStandard, Name As String, NewStandard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
BaseStandard | McadStandard object; input-only. Specifies the standard to copy.
Name | String; input-only. Specifies the name for the newly copied standard.
Returns

McadStandard object

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::GetStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::GetStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::GetStandard Method
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Gets the standard with the specified name.

Visual Basic
Sub GetStandard(Name As String, Standard As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name for the standard to obtain.
Returns

McadStandard object

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::RemoveStandard Method

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::RemoveStandard Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::RemoveStandard Method
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Removes the specified standard from the standard manager. This is equivalent to calling the McadStandard > Delete method on a specified standard to be removed.

Visual Basic
Sub RemoveStandard(Name As String)
Parameters
Parameters | Description
Name | String; input-only. Specifies the name of the standard to remove.
Returns

None

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandardMgr::UpdateSymbols Method

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr::UpdateSymbols Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr::UpdateSymbols Method
IMcadStandardMgr Interface IMcadStandardMgr Members IMcadStandardMgr Interface Send Feedback
Summary

Updates all symbols with respect to changes made to their standards.

Visual Basic
Sub UpdateSymbols()
Returns

None

Interface

IMcadStandardMgr Interface

Links
IMcadStandardMgr Interface, IMcadStandardMgr Members, IMcadStandardMgr Interface


IMcadStandards Interface

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards Interface
IMcadStandards Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadStandard objects

Class Hierarchy

Declaration syntax

IMcadStandards
Visual Basic
Public Interface IMcadStandards
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadStandards Members, SymBBAuto Library, Class Hierarchy


IMcadStandards Members

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards Members
IMcadStandards Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadStandards.

Interface

IMcadStandards Interface

Methods
Name | Description
Add | Add a new standard to the collection.
Item | Obtains a specified standard from the collection.
Remove | Removes the specified standard from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of the standards in the collection.
Links
IMcadStandards Interface, Legend, Methods, Properties


IMcadStandards::Application Property

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards::Application Property
IMcadStandards Interface IMcadStandards Members IMcadStandards Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks
  • This property is a AcadmApplication object.
  • AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.
Interface

IMcadStandards Interface

Links
IMcadStandards Interface, IMcadStandards Members, IMcadStandards Interface


IMcadStandards::Count Property

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards::Count Property
IMcadStandards Interface IMcadStandards Members IMcadStandards Interface Send Feedback
Summary

Specifies the total number of the standards in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadStandards Interface

Links
IMcadStandards Interface, IMcadStandards Members, IMcadStandards Interface


IMcadStandards::Add Method

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards::Add Method
IMcadStandards Interface IMcadStandards Members IMcadStandards Interface Send Feedback
Summary

Add a new standard to the collection.

Visual Basic
Sub Add(Item As IMcadStandard)
Parameters
Parameters | Description
Item | McadStandard object; input-only. Specifies the standard to add to the collection.
Returns

None

Interface

IMcadStandards Interface

Links
IMcadStandards Interface, IMcadStandards Members, IMcadStandards Interface


IMcadStandards::Item Method

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards::Item Method
IMcadStandards Interface IMcadStandards Members IMcadStandards Interface Send Feedback
Summary

Obtains a specified standard from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadStandard*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the standard to obtain.
Returns

McadStandard object

Interface

IMcadStandards Interface

Links
IMcadStandards Interface, IMcadStandards Members, IMcadStandards Interface


IMcadStandards::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards::Remove Method
IMcadStandards Interface IMcadStandards Members IMcadStandards Interface Send Feedback
Summary

Removes the specified standard from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the standard to be removed
Returns

None

Interface

IMcadStandards Interface

Links
IMcadStandards Interface, IMcadStandards Members, IMcadStandards Interface


IMcadSurfaceTexture Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture Interface
IMcadSurfaceTexture Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
Visual Basic
Public Interface IMcadSurfaceTexture
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadSurfaceTexture Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTexture Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture Members
IMcadSurfaceTexture Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTexture.

Interface

IMcadSurfaceTexture Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
WavinessValue | Specifies the value of the waviness field for the surface texture.
Links
IMcadSurfaceTexture Interface, Legend, Methods, Properties


IMcadSurfaceTexture::AllowanceValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::AllowanceValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::AllowanceValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the machining allowance field.

Visual Basic
Property AllowanceValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::Angle Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::Angle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::Angle Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the angle in degrees for the surface texture.

Visual Basic
Property Angle() As double
Remarks

This property is a Double.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::AutomaticAdjust Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::AutomaticAdjust Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::AutomaticAdjust Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.

Visual Basic
Property AutomaticAdjust() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::CommentValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::CommentValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::CommentValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the general comment field.

Visual Basic
Property CommentValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::CutoffValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::CutoffValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::CutoffValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the cutoff field for a surface texture.

Visual Basic
Property CutoffValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::IsAllAround Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::IsAllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::IsAllAround Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.

Visual Basic
Property IsAllAround() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::IsForceTail Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::IsForceTail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::IsForceTail Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.

Visual Basic
Property IsForceTail() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::IsMajority Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::IsMajority Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::IsMajority Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies whether the surface texture is majority, TRUE, or not, FALSE.

Visual Basic
Property IsMajority() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::LayDirection Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::LayDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::LayDirection Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the direction of machining lay for the surface texture.

Visual Basic
Property LayDirection() As McadDirectionLayType
Remarks

This property is a McadDirectionLayType enumeration.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::LayDirectionValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::LayDirectionValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::LayDirectionValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the direction of machining lay for the surface texture.

Visual Basic
Property LayDirectionValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::MaximumSpacingValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::MaximumSpacingValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::MaximumSpacingValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the maximum roughness spacing field for the surface texture.

Visual Basic
Property MaximumSpacingValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::OtherMinimumValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::OtherMinimumValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::OtherMinimumValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the other roughness minimum field for the surface texture.

Visual Basic
Property OtherMinimumValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::OtherValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::OtherValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::OtherValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the other field for the surface texture.

Visual Basic
Property OtherValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::Production2Value Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::Production2Value Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::Production2Value Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the secondary production field for the surface texture.

Visual Basic
Property Production2Value() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::ProductionValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::ProductionValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::ProductionValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the production field for the surface texture.

Visual Basic
Property ProductionValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::RaMaximumValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::RaMaximumValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::RaMaximumValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the surface roughness average maximum value field for the surface texture.

Visual Basic
Property RaMaximumValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::RaMinimumValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::RaMinimumValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::RaMinimumValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the surface roughness average minimum value field for the surface texture.

Visual Basic
Property RaMinimumValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::ReferenceValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::ReferenceValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::ReferenceValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the reference field for the surface texture.

Visual Basic
Property ReferenceValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::SamplingLengthValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::SamplingLengthValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::SamplingLengthValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the sampling length field for the surface texture.

Visual Basic
Property SamplingLengthValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::SurfaceTexture Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::SurfaceTexture Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::SurfaceTexture Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the surface type of the surface texture.

Visual Basic
Property SurfaceTexture() As McadSurfaceTextureType
Remarks

This property is a McadSurfaceTextureType enumeration.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture::WavinessValue Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture::WavinessValue Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture::WavinessValue Property
IMcadSurfaceTexture Interface IMcadSurfaceTexture Members IMcadSurfaceTexture Interface Send Feedback
Summary

Specifies the value of the waviness field for the surface texture.

Visual Basic
Property WavinessValue() As String
Remarks

This property is a String.

Interface

IMcadSurfaceTexture Interface

Links
IMcadSurfaceTexture Interface, IMcadSurfaceTexture Members, IMcadSurfaceTexture Interface


IMcadSurfaceTexture2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2 Interface
IMcadSurfaceTexture2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
Visual Basic
Public Interface IMcadSurfaceTexture2
Inherits IMcadSurfaceTexture
Library

SymBBAuto Library

Links
IMcadSurfaceTexture2 Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTexture2 Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2 Members
IMcadSurfaceTexture2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTexture2.

Interface

IMcadSurfaceTexture2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.
Links
IMcadSurfaceTexture2 Interface, Legend, Methods, Properties


IMcadSurfaceTexture2::FirstRequirement Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2::FirstRequirement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2::FirstRequirement Property
IMcadSurfaceTexture2 Interface IMcadSurfaceTexture2 Members IMcadSurfaceTexture2 Interface Send Feedback
Summary

Specifies the first requirement for the surface.

Visual Basic
Property FirstRequirement() As String
Interface

IMcadSurfaceTexture2 Interface

Links
IMcadSurfaceTexture2 Interface, IMcadSurfaceTexture2 Members, IMcadSurfaceTexture2 Interface


IMcadSurfaceTexture2::FourthRequirement Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2::FourthRequirement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2::FourthRequirement Property
IMcadSurfaceTexture2 Interface IMcadSurfaceTexture2 Members IMcadSurfaceTexture2 Interface Send Feedback
Summary

Specifies the value of the fourth requirement field for the surface texture.

Visual Basic
Property FourthRequirement() As String
Interface

IMcadSurfaceTexture2 Interface

Links
IMcadSurfaceTexture2 Interface, IMcadSurfaceTexture2 Members, IMcadSurfaceTexture2 Interface


IMcadSurfaceTexture2::SecondRequirement Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2::SecondRequirement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2::SecondRequirement Property
IMcadSurfaceTexture2 Interface IMcadSurfaceTexture2 Members IMcadSurfaceTexture2 Interface Send Feedback
Summary

Specifies the second requirement for the surface.

Visual Basic
Property SecondRequirement() As String
Interface

IMcadSurfaceTexture2 Interface

Links
IMcadSurfaceTexture2 Interface, IMcadSurfaceTexture2 Members, IMcadSurfaceTexture2 Interface


IMcadSurfaceTexture2::ThirdRequirement Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2::ThirdRequirement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2::ThirdRequirement Property
IMcadSurfaceTexture2 Interface IMcadSurfaceTexture2 Members IMcadSurfaceTexture2 Interface Send Feedback
Summary

Specifies the value of the third requirement field for the surface texture.

Visual Basic
Property ThirdRequirement() As String
Interface

IMcadSurfaceTexture2 Interface

Links
IMcadSurfaceTexture2 Interface, IMcadSurfaceTexture2 Members, IMcadSurfaceTexture2 Interface


IMcadSurfaceTexture4 Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture4 Interface
IMcadSurfaceTexture4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4
Visual Basic
Public Interface IMcadSurfaceTexture4
Inherits IMcadSurfaceTexture3
Library

SymBBAuto Library

Links
IMcadSurfaceTexture4 Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTexture4 Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture4 Members
IMcadSurfaceTexture4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTexture4.

Interface

IMcadSurfaceTexture4 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSurfIndLeader | Adds the surface indication leader for the surface texture symbol
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.
Links
IMcadSurfaceTexture4 Interface, Legend, Methods, Properties


IMcadSurfaceTexture4::AddSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4::AddSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture4::AddSurfIndLeader Method
IMcadSurfaceTexture4 Interface IMcadSurfaceTexture4 Members IMcadSurfaceTexture4 Interface Send Feedback
Summary

Adds the surface indication leader for the surface texture symbol

Visual Basic
Sub AddSurfIndLeader(Points As VARIANT)
Interface

IMcadSurfaceTexture4 Interface

Links
IMcadSurfaceTexture4 Interface, IMcadSurfaceTexture4 Members, IMcadSurfaceTexture4 Interface


IMcadSurfaceTextureLibrary Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibrary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibrary Interface
SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the surface texture library.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadSurfaceTextureLibrary
Visual Basic
Public Interface IMcadSurfaceTextureLibrary
Inherits IMcadSymbolLibrary
Library

SymBBAuto Library

Links
SymBBAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IMcadSurfaceTextureLibraryObject Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject Interface
IMcadSurfaceTextureLibraryObject Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadSurfaceTextureLibraryObject interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadSurfaceTextureLibraryObject
Visual Basic
Public Interface IMcadSurfaceTextureLibraryObject
Inherits IMcadSymbolLibraryObject
Library

SymBBAuto Library

Links
IMcadSurfaceTextureLibraryObject Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTextureLibraryObject Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject Members
IMcadSurfaceTextureLibraryObject Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTextureLibraryObject.

Interface

IMcadSurfaceTextureLibraryObject Interface

Methods
Name | Description
RequirementValue | Property to get the requirement value of a surface texture library object.
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsForceTail | Get force tail status.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
SubSymbolType | Get the symbol type of a surface texture library object.
symbolStandardClassName | Get the symbol standard class name.
Links
IMcadSurfaceTextureLibraryObject Interface, Legend, Methods, Properties


IMcadSurfaceTextureLibraryObject::IsAllAround Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject::IsAllAround Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject::IsAllAround Property
IMcadSurfaceTextureLibraryObject Interface IMcadSurfaceTextureLibraryObject Members IMcadSurfaceTextureLibraryObject Interface Send Feedback
Summary

Get the usage of the "all around" symbol.

Visual Basic
Property IsAllAround() As VARIANT_BOOL*
Interface

IMcadSurfaceTextureLibraryObject Interface

Links
IMcadSurfaceTextureLibraryObject Interface, IMcadSurfaceTextureLibraryObject Members, IMcadSurfaceTextureLibraryObject Interface


IMcadSurfaceTextureLibraryObject::IsForceTail Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject::IsForceTail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject::IsForceTail Property
IMcadSurfaceTextureLibraryObject Interface IMcadSurfaceTextureLibraryObject Members IMcadSurfaceTextureLibraryObject Interface Send Feedback
Summary

Get force tail status.

Visual Basic
Property IsForceTail() As VARIANT_BOOL*
Interface

IMcadSurfaceTextureLibraryObject Interface

Links
IMcadSurfaceTextureLibraryObject Interface, IMcadSurfaceTextureLibraryObject Members, IMcadSurfaceTextureLibraryObject Interface


IMcadSurfaceTextureLibraryObject::IsMajority Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject::IsMajority Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject::IsMajority Property
IMcadSurfaceTextureLibraryObject Interface IMcadSurfaceTextureLibraryObject Members IMcadSurfaceTextureLibraryObject Interface Send Feedback
Summary

Get the usage of the majority symbol.

Visual Basic
Property IsMajority() As VARIANT_BOOL*
Interface

IMcadSurfaceTextureLibraryObject Interface

Links
IMcadSurfaceTextureLibraryObject Interface, IMcadSurfaceTextureLibraryObject Members, IMcadSurfaceTextureLibraryObject Interface


IMcadSurfaceTextureLibraryObject::SubSymbolType Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject::SubSymbolType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject::SubSymbolType Property
IMcadSurfaceTextureLibraryObject Interface IMcadSurfaceTextureLibraryObject Members IMcadSurfaceTextureLibraryObject Interface Send Feedback
Summary

Get the symbol type of a surface texture library object.

Visual Basic
Property SubSymbolType() As McadSurfaceTextureType*
Interface

IMcadSurfaceTextureLibraryObject Interface

Links
IMcadSurfaceTextureLibraryObject Interface, IMcadSurfaceTextureLibraryObject Members, IMcadSurfaceTextureLibraryObject Interface


IMcadSurfaceTextureLibraryObject::RequirementValue Method

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject::RequirementValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject::RequirementValue Method
IMcadSurfaceTextureLibraryObject Interface IMcadSurfaceTextureLibraryObject Members IMcadSurfaceTextureLibraryObject Interface Send Feedback
Summary

Property to get the requirement value of a surface texture library object.

Visual Basic
Sub RequirementValue(variable As McadSurfaceTextureRequirement, pVal As [out,retval] BSTR)
Interface

IMcadSurfaceTextureLibraryObject Interface

Links
IMcadSurfaceTextureLibraryObject Interface, IMcadSurfaceTextureLibraryObject Members, IMcadSurfaceTextureLibraryObject Interface


IMcadSurfaceTextureStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard Interface
IMcadSurfaceTextureStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol standard

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
Visual Basic
Public Interface IMcadSurfaceTextureStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadSurfaceTextureStandard Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTextureStandard Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard Members
IMcadSurfaceTextureStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard.

Interface

IMcadSurfaceTextureStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSurfaceTextureStandard Interface, Legend, Methods, Properties


IMcadSurfaceTextureStandard::AllAroundAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::AllAroundAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::AllAroundAllowed Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property AllAroundAllowed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::AvailableLaySymbols Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::AvailableLaySymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::AvailableLaySymbols Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Gets the list of machining lay symbols that are available for this standard.

Visual Basic
Property AvailableLaySymbols() As VARIANT*
Remarks

The McadSurfaceTextureStandard > OfferedLaySymbols property specifies which of these available machining lay specification types are offered during creation and editing.

This property is a Variant (array of McadDirectionLayType enumerations).

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::FitCircle Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::FitCircle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::FitCircle Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property FitCircle() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::ForceTail Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::ForceTail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::ForceTail Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property ForceTail() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::FullList Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::FullList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::FullList Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.

Visual Basic
Property FullList() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::MajorityAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::MajorityAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::MajorityAllowed Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property MajorityAllowed() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::Multiline Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::Multiline Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::Multiline Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property Multiline() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard::OfferedLaySymbols Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard::OfferedLaySymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard::OfferedLaySymbols Property
IMcadSurfaceTextureStandard Interface IMcadSurfaceTextureStandard Members IMcadSurfaceTextureStandard Interface Send Feedback
Summary

Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedLaySymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of symbols available for this standard, as specified by AvailableLaySymbols, they are ignored.

This property is a Variant (array of McadDirectionLayType enumerations).

Interface

IMcadSurfaceTextureStandard Interface

Links
IMcadSurfaceTextureStandard Interface, IMcadSurfaceTextureStandard Members, IMcadSurfaceTextureStandard Interface


IMcadSurfaceTextureStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2 Interface
IMcadSurfaceTextureStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3
Visual Basic
Public Interface IMcadSurfaceTextureStandard2
Inherits IMcadSurfaceTextureStandard
Library

SymBBAuto Library

Links
IMcadSurfaceTextureStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTextureStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2 Members
IMcadSurfaceTextureStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard2.

Interface

IMcadSurfaceTextureStandard2 Interface

Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSurfaceTextureStandard2 Interface, Legend, Methods, Properties


IMcadSurfaceTextureStandard2::IsRequirementSupported Method

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2::IsRequirementSupported Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2::IsRequirementSupported Method
IMcadSurfaceTextureStandard2 Interface IMcadSurfaceTextureStandard2 Members IMcadSurfaceTextureStandard2 Interface Send Feedback
Summary

Gets whether the surface texture requirement is supported by this standard.

Visual Basic
Sub IsRequirementSupported(Requirement As McadSurfaceTextureRequirement, Supported As [out, retval] VARIANT_BOOL)
Remarks
Member | Description | Value
sbSurfTextRaMax | Roughness value Ra | 0
sbSurfTextRaMin | Roughness value Ra - minimum | 1
sbSurfTextProduction | Production method | 2
sbSurfTextProduction2 | Production method | 3
sbSurfTextAllowance | Finish allowance | 4
sbSurfTextDirLay | Direction of lay | 5
sbSurfTextSampLength | Sampling length or waviness height | 6
sbSurfTextCutoff | Cutoff value and evaluation length | 7
sbSurfTextOtherValue | Other roughness value | 8
sbSurfTextOtherMin | Other roughness minimum value | 9
sbSurfTextMaxRspac | Maximum spacing | 10
sbSurfTextReference | Reference length and evaluation length | 11
sbSurfTextWavines | Surface waviness | 12
sbSurfTextComment | Comment | 13
sbSurfTextFirstRequirement | First requirement | 65
sbSurfTextSecondRequirement | Second requirement | 66
sbSurfTextThirdRequirement | Third requirement | 67
sbSurfTextFourthRequirement | Fourth requirement | 68
Interface

IMcadSurfaceTextureStandard2 Interface

Links
IMcadSurfaceTextureStandard2 Interface, IMcadSurfaceTextureStandard2 Members, IMcadSurfaceTextureStandard2 Interface


IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method
IMcadSurfaceTextureStandard2 Interface IMcadSurfaceTextureStandard2 Members IMcadSurfaceTextureStandard2 Interface Send Feedback
Summary

Sets the preset list of values for all surface texture requirements to the factory default values.

Visual Basic
Sub SetAllSuggestedListsToDefaults()
Interface

IMcadSurfaceTextureStandard2 Interface

Links
IMcadSurfaceTextureStandard2 Interface, IMcadSurfaceTextureStandard2 Members, IMcadSurfaceTextureStandard2 Interface


IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method
IMcadSurfaceTextureStandard2 Interface IMcadSurfaceTextureStandard2 Members IMcadSurfaceTextureStandard2 Interface Send Feedback
Summary

Sets the preset list of values for the surface texture requirement to the factory default values.

Visual Basic
Sub SetSuggestedListToDefaults(Requirement As McadSurfaceTextureRequirement)
Parameters
Parameters | Description
Requirement | See table at IsRequirementSupported
Interface

IMcadSurfaceTextureStandard2 Interface

Links
IMcadSurfaceTextureStandard2 Interface, IMcadSurfaceTextureStandard2 Members, IMcadSurfaceTextureStandard2 Interface


IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)
IMcadSurfaceTextureStandard2 Interface IMcadSurfaceTextureStandard2 Members IMcadSurfaceTextureStandard2 Interface Send Feedback
Summary

Specifies the preset list of values for the surface texture requirement.

Visual Basic
Sub SuggestedList(Requirement As McadSurfaceTextureRequirement, Lists As VARIANT)
Parameters
Parameters | Description
Requirement | _nt_
Lists | _nt_ See list at IsRequirementSupported
Interface

IMcadSurfaceTextureStandard2 Interface

Links
IMcadSurfaceTextureStandard2 Interface, IMcadSurfaceTextureStandard2 Members, IMcadSurfaceTextureStandard2 Interface


IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)
IMcadSurfaceTextureStandard2 Interface IMcadSurfaceTextureStandard2 Members IMcadSurfaceTextureStandard2 Interface Send Feedback
Summary

Specifies the preset list of values for the surface texture requirement.

Visual Basic
Sub SuggestedList(Requirement As McadSurfaceTextureRequirement, Lists As [out, retval] VARIANT)
Parameters
Parameters | Description
Requirement | _nt_
Lists | _nt_ See list at IsRequirementSupported
Interface

IMcadSurfaceTextureStandard2 Interface

Links
IMcadSurfaceTextureStandard2 Interface, IMcadSurfaceTextureStandard2 Members, IMcadSurfaceTextureStandard2 Interface


IMcadSurfaceTextureStandard3 Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3 Interface
IMcadSurfaceTextureStandard3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A surface texture symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3
Visual Basic
Public Interface IMcadSurfaceTextureStandard3
Inherits IMcadSurfaceTextureStandard2
Library

SymBBAuto Library

Links
IMcadSurfaceTextureStandard3 Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTextureStandard3 Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3 Members
IMcadSurfaceTextureStandard3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTextureStandard3.

Interface

IMcadSurfaceTextureStandard3 Interface

Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | Specifies the setting of surface indication leader arrowhead scale.
SurfIndLeaderArrowType | Specifies the setting of surface indication leader arrowhead type.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSurfaceTextureStandard3 Interface, Legend, Methods, Properties


IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property
IMcadSurfaceTextureStandard3 Interface IMcadSurfaceTextureStandard3 Members IMcadSurfaceTextureStandard3 Interface Send Feedback
Summary

Specifies the setting of surface indication leader arrowhead scale.

Visual Basic
Property SurfIndLeaderArrowScale() As double
Interface

IMcadSurfaceTextureStandard3 Interface

Links
IMcadSurfaceTextureStandard3 Interface, IMcadSurfaceTextureStandard3 Members, IMcadSurfaceTextureStandard3 Interface


IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property
IMcadSurfaceTextureStandard3 Interface IMcadSurfaceTextureStandard3 Members IMcadSurfaceTextureStandard3 Interface Send Feedback
Summary

Specifies the setting of surface indication leader arrowhead type.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType
Interface

IMcadSurfaceTextureStandard3 Interface

Links
IMcadSurfaceTextureStandard3 Interface, IMcadSurfaceTextureStandard3 Members, IMcadSurfaceTextureStandard3 Interface


IMcadSymbol Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol Interface
IMcadSymbol Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
Visual Basic
Public Interface IMcadSymbol
Inherits IAcadEntity
Library

SymBBAuto Library

Links
IMcadSymbol Members, SymBBAuto Library, Class Hierarchy


IMcadSymbol Members

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol Members
IMcadSymbol Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbol.

Interface

IMcadSymbol Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadSymbol Interface, Legend, Methods, Properties


IMcadSymbol::CoordinateSystem Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::CoordinateSystem Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::CoordinateSystem Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the coordinate system for the symbol.

Visual Basic
Property CoordinateSystem() As VARIANT
Remarks

This property is a Variant (4*4 array of doubles).

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::IsAttached Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::IsAttached Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::IsAttached Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.

Visual Basic
Property IsAttached() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderCount Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderCount Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Gets the number of leaders attached to a specific symbol.

Visual Basic
Property LeaderCount() As long*
Remarks

This property is a Long.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::Origin Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::Origin Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.

Visual Basic
Property Origin() As VARIANT
Remarks

This property is a Variant (3-element array of doubles).

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::Scale Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::Scale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::Scale Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.

Visual Basic
Property Scale() As double
Remarks

This property is a Double.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::Standard Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::Standard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::Standard Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Gets the standard this symbol is used in.

Visual Basic
Property Standard() As IMcadStandard*
Remarks

This property is a McadStandard object.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::SymbolStandard Property

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::SymbolStandard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::SymbolStandard Property
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the symbol standard for a symbol.

Visual Basic
Property SymbolStandard() As IMcadSymbolStandard*
Remarks

This property is a McadSymbolStandard object.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::AddLeader Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::AddLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::AddLeader Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Adds a leader with the specified nodes to a symbol.

Visual Basic
Sub AddLeader(Points As VARIANT, Index As [in, optional] VARIANT, AfterNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | Variant (array of doubles); input-only. Specifies the new leader nodes to be added in the 3D WCS coordinates. You must provide at least two points to define the leader. The third point is optional.
Index | Variant (long); input-only; optional. Specifies the existing leader to which the new node points are appended. If the balloon symbol already contains any number of leaders, the Index element must be specified.
AfterNode | Variant (3 element array of doubles); input-only; optional. Specifies an existing node point to add a branch to, or to append the new node points to a specific branch.
Returns

None

Remarks

This method is not supported by McadDetailSymbol, McadSectionLine or McadDetailSymbolLabel.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::AttachGeometry Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::AttachGeometry Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::AttachGeometry Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.

Visual Basic
Sub AttachGeometry(Geometry As IDispatch, ArrowheadLocation As VARIANT, ViewId As [in, optional] VARIANT, Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | McadGeometry object from the Mcad ActiveX Automation server; input-only. Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
ArrowheadLocation | Variant (3-element array of doubles); input-only. Specifies the location to place the leader arrowhead.
ViewId | Variant (long); input-only; optional. Specifies if the symbol's leader is attached to the view.
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to attach to the geometry. If the symbol contains multiple leaders, the Index element must be specified.
LeafNode | Variant (3-element array of doubles); input-only; optional. Specifies the leaf or arrowhead node to attach to the geometry. If the leader being attached has multiple leaf nodes, the LeafNode element must be specified.
Returns

None

Remarks

If the leader start point is not located on the attached geometry, this function adds a surface extension line. Surface extension line is supported by arc, line and polyline.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::DetachGeometry Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::DetachGeometry Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::DetachGeometry Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Detaches the specified symbol's leader from any attached geometry references or views.

Visual Basic
Sub DetachGeometry(Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT)
Parameters
Parameters | Description
Index | Variant (Long); input-only; optional. Specifies which of several leaders to detach from their attached geometry references or views.
LeafNode | Variant (3-element array of doubles);input-only; optional. Specifies the only one leaf node to detach from its attached geometry reference or view.
Returns

None

Remarks

If a surface extension line exists, it will be deleted.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::GetLeader Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::GetLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::GetLeader Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Gets the positions of the nodes of the specified leader.

Visual Basic
Sub GetLeader(Index As long, OnlyLeafNodes As [in, defaultvalue(FALSE)] VARIANT_BOOL, Nodes As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only. Specifies which leader to get the positions of leaf nodes for.
OnlyLeafNodes | Boolean, default value is False; input-only; optional (TBD)
Returns

Variant (array of arrays of points (3 element array of doubles))

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::GetLeaderAttachment Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::GetLeaderAttachment Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::GetLeaderAttachment Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Gets the attached geometry reference object, if present, for the symbol's leader.

Visual Basic
Sub GetLeaderAttachment(ViewId As [out, optional] VARIANT, Index As [in, optional] VARIANT, LeafNode As [in, optional] VARIANT, Geometry As [out, retval] IDispatch*)
Parameters
Parameters | Description
ViewId | Variant (long); input-only; optional. Specifies which of multiple leaders to get the attached geometry for. If the symbol contains multiple leaders, the Index element must be specified.
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to get the attached geometry for. If the symbol contains multiple leaders, the Index element must be specified.
LeafNode | Variant (3-element array of doubles); input-only; optional. Specifies the leaf or arrowhead node to get to the attached geometry for. If the leader being attached has multiple leaf nodes, the LeafNode element must be specified.
Returns

AcadObject. This can be any of the drawing objects.

Remarks

This method has no implementation and is currently unsupported.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::InsertLeaderNode Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::InsertLeaderNode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::InsertLeaderNode Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Inserts the specified node point into a symbol's leader before the specified existing node.

Visual Basic
Sub InsertLeaderNode(Point As VARIANT, Before As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
Point | Variant (3-element array of doubles); input-only. Specifies the location of the new node point.
Before | Variant (3-element array of doubles); input-only. Specifies the existing node before which a new node is to be inserted.
Index | Variant (Long); input-only; optional. Specifies the leader to find the existing node on.
Returns

None

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the leader arrow type for the selected symbol leaders.

Visual Basic
Sub LeaderArrowType(Index As [in, optional] VARIANT, Type As McadArrowType)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of the multiple leaders to specify the arrow type for.
Remarks

This property is a McadArrowType enumeration.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the leader arrow type for the selected symbol leaders.

Visual Basic
Sub LeaderArrowType(Index As [in, optional] VARIANT, Type As [out, retval] McadArrowType)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of the multiple leaders to specify the arrow type for.
Remarks

This property is a McadArrowType enumeration.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the color of a symbol's leader line.

Visual Basic
Sub LeaderColor(Index As [in, optional] VARIANT, Color As ACAD_COLOR)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the color for.
Remarks
  • The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new symbol's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the color of a symbol's leader line.

Visual Basic
Sub LeaderColor(Index As [in, optional] VARIANT, Color As [out, retval] ACAD_COLOR)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the color for.
Remarks
  • The default color designation is sbByLayer. Use a color index number from 0 to 256, or one of the following constants including seven standard colors and two designations:
    • sbByBlock: If sbByBlock is specified, new leader line objects are drawn in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the balloon objects in the block inherit the current setting of the color property.
    • sbByLayer: If sbByLayer is specified, new symbol's leader line objects assume the color of the layer upon which they are drawn.
    • sbRed
    • sbYellow
    • sbGreen
    • sbCyan
    • sbBlue
    • sbMagenta
    • sbWhite
  • This property is a cColor enumeration in the AutoCAD ActiveX documentation.
  • If you use acByBlock, AutoCAD draws new objects in the default color (white or black, depending on your configuration) until they are grouped into the block. When the block is inserted in the drawing, the objects in the block inherit the current setting of the color property.
  • If you use acByLayer, new objects assume the color of the layer upon which they are drawn. The value acByLayer is not valid for a Layer object.
Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.

Visual Basic
Sub LeaderLanding(Index As [in, optional] VARIANT, Vector As VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
Remarks

This property is a Variant (3-element array of doubles).

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.

Visual Basic
Sub LeaderLanding(Index As [in, optional] VARIANT, Vector As [out, retval] VARIANT)
Parameters
Parameters | Description
Index | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
Remarks

This property is a Variant (3-element array of doubles).

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the linetype for a specific symbol's leader.

Visual Basic
Sub LeaderLineType(Index As [in, optional] VARIANT, Type As IAcadLineType)
Parameters
Parameters | Description
Index | Index Variant (long); optional. Specifies the leader to specify the linetype for.
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.
Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Specifies the linetype for a specific symbol's leader.

Visual Basic
Sub LeaderLineType(Index As [in, optional] VARIANT, Type As [out, retval] IAcadLineType*)
Parameters
Parameters | Description
Index | Index Variant (long); optional. Specifies the leader to specify the linetype for.
Remarks
  • This property is a cadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX documentation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.
Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::MoveLeaderNode Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::MoveLeaderNode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::MoveLeaderNode Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Moves the specified leader node associated with a symbol to a new position.

Visual Basic
Sub MoveLeaderNode(NodePoint As VARIANT, ToPoint As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
NodePoint | Variant (3-element array of doubles); input-only. Specifies the node point to be moved.
ToPoint | Variant (3-element array of doubles); input-only. Specifies the new position of the selected node point.
Index | Variant (Long); input-only; optional. Specifies the leader to find the node point on. If a symbol contains multiple leaders, the Index element must be specified.
Returns

None

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::RemoveLeader Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::RemoveLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::RemoveLeader Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Removes the specified leader from a symbol.

Visual Basic
Sub RemoveLeader(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the leader to be removed from a symbol.
Returns

None

Remarks

When a leader with an attached surface extension line is deleted, the surface extension line will be removed as well.

This method is not supported by McadDetailSymbol, McadSectionLine or McadDetailSymbolLabel.

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::RemoveLeaderNode Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::RemoveLeaderNode Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::RemoveLeaderNode Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Removes the specified leader nodes from the symbol's leader.

Visual Basic
Sub RemoveLeaderNode(Point As VARIANT, Index As [in, optional] VARIANT)
Parameters
Parameters | Description
Point | Variant (3-element array of doubles); input-only. Specifies the node point on which you want to remove leaders.
Index | Variant (Long); input-only; optional. Specifies the leader to find the node point on. If a symbol contains multiple leaders and the Index element is not specified, the first leader is removed.
Returns

None

Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol::SetToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol::SetToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol::SetToDefaults Method
IMcadSymbol Interface IMcadSymbol Members IMcadSymbol Interface Send Feedback
Summary

Sets the properties of this symbol to the factory default values.

Visual Basic
Sub SetToDefaults()
Interface

IMcadSymbol Interface

Links
IMcadSymbol Interface, IMcadSymbol Members, IMcadSymbol Interface


IMcadSymbol2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol2 Interface
IMcadSymbol2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol object.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel
        IMcadBalloon
        IMcadDatumTarget
        IMcadDetailSymbol
        IMcadDetailSymbolLabel
        IMcadEdge
        IMcadFeatureControlFrame
        IMcadIdentifier
        IMcadJoint
        IMcadMarkStamp
        IMcadNote
        IMcadPartList
        IMcadPartReference
        IMcadSectionLine
        IMcadSurfaceTexture
        IMcadTaper
        IMcadWelding
Visual Basic
Public Interface IMcadSymbol2
Inherits IMcadSymbol
Library

SymBBAuto Library

Links
IMcadSymbol2 Members, SymBBAuto Library, Class Hierarchy


IMcadSymbol2 Members

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol2 Members
IMcadSymbol2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbol2.

Interface

IMcadSymbol2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadSymbol2 Interface, Legend, Methods, Properties


IMcadSymbol2::UpdateToAttachedObject Method

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2::UpdateToAttachedObject Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol2::UpdateToAttachedObject Method
IMcadSymbol2 Interface IMcadSymbol2 Members IMcadSymbol2 Interface Send Feedback
Summary

Update symbol when attached object is modified.

Visual Basic
Sub UpdateToAttachedObject()
Interface

IMcadSymbol2 Interface

Links
IMcadSymbol2 Interface, IMcadSymbol2 Members, IMcadSymbol2 Interface


IMcadSymbolBBMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr Interface
IMcadSymbolBBMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
Visual Basic
Public Interface IMcadSymbolBBMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadSymbolBBMgr Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolBBMgr Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr Members
IMcadSymbolBBMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolBBMgr.

Interface

IMcadSymbolBBMgr Interface

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
StandardMgr | Gets the StandardMgr object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Links
IMcadSymbolBBMgr Interface, Legend, Methods, Properties


IMcadSymbolBBMgr::Application Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr::Application Property
IMcadSymbolBBMgr Interface IMcadSymbolBBMgr Members IMcadSymbolBBMgr Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadSymbolBBMgr Interface

Links
IMcadSymbolBBMgr Interface, IMcadSymbolBBMgr Members, IMcadSymbolBBMgr Interface


IMcadSymbolBBMgr::BOMMgr Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr::BOMMgr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr::BOMMgr Method
IMcadSymbolBBMgr Interface IMcadSymbolBBMgr Members IMcadSymbolBBMgr Interface Send Feedback
Summary

Gets the BOM manager object.

Visual Basic
Sub BOMMgr(Document As [in, optional] VARIANT, BOMMgr As [out, retval] IMcadBOMMgr*)
Remarks

This property is read-only and returns a McadBOMMgr object.

Interface

IMcadSymbolBBMgr Interface

Links
IMcadSymbolBBMgr Interface, IMcadSymbolBBMgr Members, IMcadSymbolBBMgr Interface


IMcadSymbolBBMgr::StandardMgr Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr::StandardMgr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr::StandardMgr Method
IMcadSymbolBBMgr Interface IMcadSymbolBBMgr Members IMcadSymbolBBMgr Interface Send Feedback
Summary

Gets the StandardMgr object.

Visual Basic
Sub StandardMgr(Document As [in, optional] VARIANT, StandardMgr As [out, retval] IMcadStandardMgr*)
Remarks

This property is read-only and returns an McadStandardMgr object.

Interface

IMcadSymbolBBMgr Interface

Links
IMcadSymbolBBMgr Interface, IMcadSymbolBBMgr Members, IMcadSymbolBBMgr Interface


IMcadSymbolBBMgr2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2 Interface
IMcadSymbolBBMgr2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3
Visual Basic
Public Interface IMcadSymbolBBMgr2
Inherits IMcadSymbolBBMgr
Library

SymBBAuto Library

Links
IMcadSymbolBBMgr2 Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolBBMgr2 Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2 Members
IMcadSymbolBBMgr2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolBBMgr2.

Interface

IMcadSymbolBBMgr2 Interface

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
TitleBorderMgr | Read-only property that gets the title border manager object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Links
IMcadSymbolBBMgr2 Interface, Legend, Methods, Properties


IMcadSymbolBBMgr2::ScaleAreaMgr Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2::ScaleAreaMgr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2::ScaleAreaMgr Method
IMcadSymbolBBMgr2 Interface IMcadSymbolBBMgr2 Members IMcadSymbolBBMgr2 Interface Send Feedback
Summary

Read-only property that gets the manager object for scale area.

Visual Basic
Sub ScaleAreaMgr(Document As [in,optional] VARIANT, ScareaMgr As [out, retval] IMcadScaleAreaMgr*)
Interface

IMcadSymbolBBMgr2 Interface

Links
IMcadSymbolBBMgr2 Interface, IMcadSymbolBBMgr2 Members, IMcadSymbolBBMgr2 Interface


IMcadSymbolBBMgr2::TitleBorderMgr Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2::TitleBorderMgr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2::TitleBorderMgr Method
IMcadSymbolBBMgr2 Interface IMcadSymbolBBMgr2 Members IMcadSymbolBBMgr2 Interface Send Feedback
Summary

Read-only property that gets the title border manager object.

Visual Basic
Sub TitleBorderMgr(Document As [in,optional] VARIANT, TitBrdMgr As [out, retval] IMcadTitleBorderMgr*)
Interface

IMcadSymbolBBMgr2 Interface

Links
IMcadSymbolBBMgr2 Interface, IMcadSymbolBBMgr2 Members, IMcadSymbolBBMgr2 Interface


IMcadSymbolBBMgr3 Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3 Interface
IMcadSymbolBBMgr3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is the main manager object in SymBBAuto.

Class Hierarchy

Declaration syntax

IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3
Visual Basic
Public Interface IMcadSymbolBBMgr3
Inherits IMcadSymbolBBMgr2
Library

SymBBAuto Library

Links
IMcadSymbolBBMgr3 Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolBBMgr3 Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3 Members
IMcadSymbolBBMgr3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolBBMgr3.

Interface

IMcadSymbolBBMgr3 Interface

Methods
Name | Description
BOMMgr | Gets the BOM manager object.
RevisionListMgr | Read-only property that gets the revision list manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
SymbolLibrary | This read-only property is used to get the symbol library.
TitleBorderMgr | Read-only property that gets the title border manager object.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Links
IMcadSymbolBBMgr3 Interface, Legend, Methods, Properties


IMcadSymbolBBMgr3::RevisionListMgr Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3::RevisionListMgr Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3::RevisionListMgr Method
IMcadSymbolBBMgr3 Interface IMcadSymbolBBMgr3 Members IMcadSymbolBBMgr3 Interface Send Feedback
Summary

Read-only property that gets the revision list manager object.

Visual Basic
Sub RevisionListMgr(Document As [in,optional] VARIANT, RevListMgr As [out, retval] IMcadRevisionMgr*)
Interface

IMcadSymbolBBMgr3 Interface

Links
IMcadSymbolBBMgr3 Interface, IMcadSymbolBBMgr3 Members, IMcadSymbolBBMgr3 Interface


IMcadSymbolBBMgr3::SymbolLibrary Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3::SymbolLibrary Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3::SymbolLibrary Method
IMcadSymbolBBMgr3 Interface IMcadSymbolBBMgr3 Members IMcadSymbolBBMgr3 Interface Send Feedback
Summary

This read-only property is used to get the symbol library.

Visual Basic
Sub SymbolLibrary(type As McadSymBBSymbolLibraryType, Document As [in,optional] VARIANT, bCreateIfNotExist As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] IMcadSymbolLibrary*)
Interface

IMcadSymbolBBMgr3 Interface

Links
IMcadSymbolBBMgr3 Interface, IMcadSymbolBBMgr3 Members, IMcadSymbolBBMgr3 Interface


IMcadSymbolLibrary Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary Interface
IMcadSymbolLibrary Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadSymbolLibrary interface. The grouping of library object is based on the combination of standard and standard revision type.

In each group, there is only one default.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadEdgeLibrary
    IMcadFCFLibrary
    IMcadSurfaceTextureLibrary
    IMcadWeldingLibrary
Visual Basic
Public Interface IMcadSymbolLibrary
Inherits IAcadDictionary
Library

SymBBAuto Library

Links
IMcadSymbolLibrary Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolLibrary Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary Members
IMcadSymbolLibrary Interface Legend Methods Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolLibrary.

Interface

IMcadSymbolLibrary Interface

Methods
Name | Description
appendItem | Add the data in this SymId to the library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
modifyItem | Update the data in this library object.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.
Links
IMcadSymbolLibrary Interface, Legend, Methods


IMcadSymbolLibrary::appendItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::appendItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::appendItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Add the data in this SymId to the library.

Visual Basic
Sub appendItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::DefaultItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::DefaultItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::DefaultItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Get the default symbol library object of a symbol library.

Visual Basic
Sub DefaultItem(standardName As String, symbolStandardClassName As String, pNewVal As [out, retval] IMcadSymbolLibraryObject *)
Parameters
Parameters | Description
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::findItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::findItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::findItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Get a symbol library object. Return the Symbol standard class name.

Visual Basic
Sub findItem(itemName As String, standardName As String, symbolStandardClassName As String, pNewVal As [out,retval] IMcadSymbolLibraryObject *)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | The Symbol Standard Class Name
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::findList Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::findList Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::findList Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Get a list of symbol library objects.

Visual Basic
Sub findList(standardName As String, symbolStandardClassName As String, LibItems As [out,retval] IMcadSymbolLibraryObjects *)
Parameters
Parameters | Description
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::isItemExist Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::isItemExist Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::isItemExist Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Check the existence of a symbol library object. Return the Symbol standard class name.

Visual Basic
Sub isItemExist(itemName As String, standardName As String, symbolStandardClassName As String, pStatus As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | The Symbol standard class name.
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::loadItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::loadItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::loadItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.

Visual Basic
Sub loadItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::modifyItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::modifyItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::modifyItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Update the data in this library object.

Visual Basic
Sub modifyItem(itemName As String, Sym As VARIANT)
Parameters
Parameters | Description
itemName | Name of library object.
Sym | Object ID of symbol. This symbol provides the information on standad and symbol standard.
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::removeItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::removeItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::removeItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Remove a symbol library object from a symbol library.

Visual Basic
Sub removeItem(itemName As String, standardName As String, symbolStandardClassName As String)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::renameItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::renameItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::renameItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Update the name of the library object, itemName, with newName.

Visual Basic
Sub renameItem(itemName As String, newName As String, standardName As String, symbolStandardClassName As String)
Parameters
Parameters | Description
itemName | Name of library object.
newName | New name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibrary::setIsDefaultItem Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary::setIsDefaultItem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary::setIsDefaultItem Method
IMcadSymbolLibrary Interface IMcadSymbolLibrary Members IMcadSymbolLibrary Interface Send Feedback
Summary

Set the default status of the library object.

Visual Basic
Sub setIsDefaultItem(itemName As String, standardName As String, symbolStandardClassName As String, newVal As VARIANT_BOOL)
Parameters
Parameters | Description
itemName | Name of library object.
standardName | Base standard name
symbolStandardClassName | Symbol standard class name
newVal | True or False
Remarks

There is one default for every standard and symbol standard class name combination. This property will unset the previous default, if necessary.

Interface

IMcadSymbolLibrary Interface

Links
IMcadSymbolLibrary Interface, IMcadSymbolLibrary Members, IMcadSymbolLibrary Interface


IMcadSymbolLibraryObject Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject Interface
IMcadSymbolLibraryObject Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Represents the library of symbol objects.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject
    IMcadFCFLibraryObject
    IMcadSurfaceTextureLibraryObject
    IMcadWeldingLibraryObject
Visual Basic
Public Interface IMcadSymbolLibraryObject
Inherits IAcadObject
Library

SymBBAuto Library

Links
IMcadSymbolLibraryObject Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolLibraryObject Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject Members
IMcadSymbolLibraryObject Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolLibraryObject.

Interface

IMcadSymbolLibraryObject Interface

Properties
Name | Description
entryName | Specifies the name of a symbol library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.
Links
IMcadSymbolLibraryObject Interface, Legend, Properties


IMcadSymbolLibraryObject::entryName Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject::entryName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject::entryName Property
IMcadSymbolLibraryObject Interface IMcadSymbolLibraryObject Members IMcadSymbolLibraryObject Interface Send Feedback
Summary

Specifies the name of a symbol library object.

Visual Basic
Property entryName() As String
Remarks

User is responsible to check the uniqueness of this name.

Interface

IMcadSymbolLibraryObject Interface

Links
IMcadSymbolLibraryObject Interface, IMcadSymbolLibraryObject Members, IMcadSymbolLibraryObject Interface


IMcadSymbolLibraryObject::isDefault Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject::isDefault Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject::isDefault Property
IMcadSymbolLibraryObject Interface IMcadSymbolLibraryObject Members IMcadSymbolLibraryObject Interface Send Feedback
Summary

Change the default of this object. There will be only one default in for each standard and symbol standard.

Visual Basic
Property isDefault() As VARIANT_BOOL
Interface

IMcadSymbolLibraryObject Interface

Links
IMcadSymbolLibraryObject Interface, IMcadSymbolLibraryObject Members, IMcadSymbolLibraryObject Interface


IMcadSymbolLibraryObject::standardName Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject::standardName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject::standardName Property
IMcadSymbolLibraryObject Interface IMcadSymbolLibraryObject Members IMcadSymbolLibraryObject Interface Send Feedback
Summary

Gets the standard name of a library object.

Visual Basic
Property standardName() As BSTR*
Remarks

The standard name here refers to the base standard name.

Interface

IMcadSymbolLibraryObject Interface

Links
IMcadSymbolLibraryObject Interface, IMcadSymbolLibraryObject Members, IMcadSymbolLibraryObject Interface


IMcadSymbolLibraryObject::symbolStandardClassName Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject::symbolStandardClassName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject::symbolStandardClassName Property
IMcadSymbolLibraryObject Interface IMcadSymbolLibraryObject Members IMcadSymbolLibraryObject Interface Send Feedback
Summary

Get the symbol standard class name.

Visual Basic
Property symbolStandardClassName() As BSTR*
Interface

IMcadSymbolLibraryObject Interface

Links
IMcadSymbolLibraryObject Interface, IMcadSymbolLibraryObject Members, IMcadSymbolLibraryObject Interface


IMcadSymbolLibraryObjects Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects Interface
IMcadSymbolLibraryObjects Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadSymbolLibrary Objects interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObjects
Visual Basic
Public Interface IMcadSymbolLibraryObjects
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadSymbolLibraryObjects Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolLibraryObjects Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects Members
IMcadSymbolLibraryObjects Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolLibraryObjects.

Interface

IMcadSymbolLibraryObjects Interface

Methods
Name | Description
Add | Add a symbol library object to the collection.
Item | Obtains a specified library object from the collection.
Remove | Removes a library object from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.
Links
IMcadSymbolLibraryObjects Interface, Legend, Methods, Properties


IMcadSymbolLibraryObjects::Application Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects::Application Property
IMcadSymbolLibraryObjects Interface IMcadSymbolLibraryObjects Members IMcadSymbolLibraryObjects Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadSymbolLibraryObjects Interface

Links
IMcadSymbolLibraryObjects Interface, IMcadSymbolLibraryObjects Members, IMcadSymbolLibraryObjects Interface


IMcadSymbolLibraryObjects::Count Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects::Count Property
IMcadSymbolLibraryObjects Interface IMcadSymbolLibraryObjects Members IMcadSymbolLibraryObjects Interface Send Feedback
Summary

Gets the total number of objects in the collection.

Visual Basic
Property Count() As long*
Interface

IMcadSymbolLibraryObjects Interface

Links
IMcadSymbolLibraryObjects Interface, IMcadSymbolLibraryObjects Members, IMcadSymbolLibraryObjects Interface


IMcadSymbolLibraryObjects::Add Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects::Add Method
IMcadSymbolLibraryObjects Interface IMcadSymbolLibraryObjects Members IMcadSymbolLibraryObjects Interface Send Feedback
Summary

Add a symbol library object to the collection.

Visual Basic
Sub Add(Item As IMcadSymbolLibraryObject)
Parameters
Parameters | Description
Item | Symbol library object to add.
Interface

IMcadSymbolLibraryObjects Interface

Links
IMcadSymbolLibraryObjects Interface, IMcadSymbolLibraryObjects Members, IMcadSymbolLibraryObjects Interface


IMcadSymbolLibraryObjects::Item Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects::Item Method
IMcadSymbolLibraryObjects Interface IMcadSymbolLibraryObjects Members IMcadSymbolLibraryObjects Interface Send Feedback
Summary

Obtains a specified library object from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadSymbolLibraryObject*)
Parameters
Parameters | Description
Index | Index of library object to return
Interface

IMcadSymbolLibraryObjects Interface

Links
IMcadSymbolLibraryObjects Interface, IMcadSymbolLibraryObjects Members, IMcadSymbolLibraryObjects Interface


IMcadSymbolLibraryObjects::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects::Remove Method
IMcadSymbolLibraryObjects Interface IMcadSymbolLibraryObjects Members IMcadSymbolLibraryObjects Interface Send Feedback
Summary

Removes a library object from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Index of object to remove
Interface

IMcadSymbolLibraryObjects Interface

Links
IMcadSymbolLibraryObjects Interface, IMcadSymbolLibraryObjects Members, IMcadSymbolLibraryObjects Interface


IMcadSymbolStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard Interface
IMcadSymbolStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
Visual Basic
Public Interface IMcadSymbolStandard
Inherits IAcadObject
Library

SymBBAuto Library

Links
IMcadSymbolStandard Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolStandard Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard Members
IMcadSymbolStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolStandard.

Interface

IMcadSymbolStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
Properties
Name | Description
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
Links
IMcadSymbolStandard Interface, Legend, Methods, Properties


IMcadSymbolStandard::Revision Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard::Revision Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard::Revision Property
IMcadSymbolStandard Interface IMcadSymbolStandard Members IMcadSymbolStandard Interface Send Feedback
Summary

Gets the revision version of a symbol standard.

Visual Basic
Property Revision() As BSTR*
Remarks

This property is a String.

Interface

IMcadSymbolStandard Interface

Links
IMcadSymbolStandard Interface, IMcadSymbolStandard Members, IMcadSymbolStandard Interface


IMcadSymbolStandard::RevisionYear Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard::RevisionYear Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard::RevisionYear Property
IMcadSymbolStandard Interface IMcadSymbolStandard Members IMcadSymbolStandard Interface Send Feedback
Summary

Gets the revision version year of a symbol standard.

Visual Basic
Property RevisionYear() As long*
Remarks

This property is a Long.

Interface

IMcadSymbolStandard Interface

Links
IMcadSymbolStandard Interface, IMcadSymbolStandard Members, IMcadSymbolStandard Interface


IMcadSymbolStandard::Standard Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard::Standard Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard::Standard Property
IMcadSymbolStandard Interface IMcadSymbolStandard Members IMcadSymbolStandard Interface Send Feedback
Summary

Gets the standard that a symbol standard is used in.

Visual Basic
Property Standard() As IMcadStandard**
Remarks

This property is a McadStandard object.

Interface

IMcadSymbolStandard Interface

Links
IMcadSymbolStandard Interface, IMcadSymbolStandard Members, IMcadSymbolStandard Interface


IMcadSymbolStandard::SetToDefaults Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard::SetToDefaults Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard::SetToDefaults Method
IMcadSymbolStandard Interface IMcadSymbolStandard Members IMcadSymbolStandard Interface Send Feedback
Summary

Sets the properties of this symbol standard to the factory default values.

Visual Basic
Sub SetToDefaults()
Interface

IMcadSymbolStandard Interface

Links
IMcadSymbolStandard Interface, IMcadSymbolStandard Members, IMcadSymbolStandard Interface


IMcadSymbolStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2 Interface
IMcadSymbolStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
Visual Basic
Public Interface IMcadSymbolStandard2
Inherits IMcadSymbolStandard
Library

SymBBAuto Library

Links
IMcadSymbolStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2 Members
IMcadSymbolStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolStandard2.

Interface

IMcadSymbolStandard2 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSymbolStandard2 Interface, Legend, Methods, Properties


IMcadSymbolStandard2::ArrowScale Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::ArrowScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::ArrowScale Property
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.

Visual Basic
Property ArrowScale() As double
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard2::ArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::ArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::ArrowType Property
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Specifies the arrow type of leader in symbol that belongs to this symbol standard.

Visual Basic
Property ArrowType() As McadArrowType
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard2::LeaderTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::LeaderTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::LeaderTrueColor Property
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Specifies the true color of leader in symbol that belongs to this symbol standard.

Visual Basic
Property LeaderTrueColor() As IAcadAcCmColor *
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard2::TextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::TextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::TextHeight Property
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Specifies the height of text in symbol that belongs to this symbol standard.

Visual Basic
Property TextHeight() As double
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard2::TextTrueColor Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::TextTrueColor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::TextTrueColor Property
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Specifies the true color of text in a symbol that belongs to this symbol standard.

Visual Basic
Property TextTrueColor() As IAcadAcCmColor *
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard2::SetToDefaultTextLeader Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2::SetToDefaultTextLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2::SetToDefaultTextLeader Method
IMcadSymbolStandard2 Interface IMcadSymbolStandard2 Members IMcadSymbolStandard2 Interface Send Feedback
Summary

Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.

Visual Basic
Sub SetToDefaultTextLeader()
Interface

IMcadSymbolStandard2 Interface

Links
IMcadSymbolStandard2 Interface, IMcadSymbolStandard2 Members, IMcadSymbolStandard2 Interface


IMcadSymbolStandard3 Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3 Interface
IMcadSymbolStandard3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard
            IMcadBOMStandard
            IMcadDatumStandard
            IMcadDetailSymbolStandard
            IMcadEdgeStandard
            IMcadFCFStandard
            IMcadIdentifierStandard
            IMcadJointStandard
            IMcadMarkStampStandard
            IMcadNoteStandard
            IMcadSectionLineStandard
            IMcadSurfaceTextureStandard
            IMcadTaperStandard
            IMcadTitleBorderStandard
            IMcadWeldingStandard
Visual Basic
Public Interface IMcadSymbolStandard3
Inherits IMcadSymbolStandard2
Library

SymBBAuto Library

Links
IMcadSymbolStandard3 Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolStandard3 Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3 Members
IMcadSymbolStandard3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolStandard3.

Interface

IMcadSymbolStandard3 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadSymbolStandard3 Interface, Legend, Methods, Properties


IMcadSymbolStandard3::SymbolStandardClassName Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3::SymbolStandardClassName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3::SymbolStandardClassName Property
IMcadSymbolStandard3 Interface IMcadSymbolStandard3 Members IMcadSymbolStandard3 Interface Send Feedback
Summary

Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.

Visual Basic
Property SymbolStandardClassName() As BSTR*
Remarks

This property is read-only.

Interface

IMcadSymbolStandard3 Interface

Links
IMcadSymbolStandard3 Interface, IMcadSymbolStandard3 Members, IMcadSymbolStandard3 Interface


IMcadSymbolStandard3::SupportedArrowTypes Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3::SupportedArrowTypes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3::SupportedArrowTypes Method
IMcadSymbolStandard3 Interface IMcadSymbolStandard3 Members IMcadSymbolStandard3 Interface Send Feedback
Summary

Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.

Visual Basic
Sub SupportedArrowTypes(allSrv As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out, retval] VARIANT)
Remarks

This property is read-only.

Interface

IMcadSymbolStandard3 Interface

Links
IMcadSymbolStandard3 Interface, IMcadSymbolStandard3 Members, IMcadSymbolStandard3 Interface


IMcadSymbolStandards Interface

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards Interface
IMcadSymbolStandards Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A collection of McadSymbolStandard objects

Class Hierarchy

Declaration syntax

IMcadSymbolStandards
Visual Basic
Public Interface IMcadSymbolStandards
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadSymbolStandards Members, SymBBAuto Library, Class Hierarchy


IMcadSymbolStandards Members

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards Members
IMcadSymbolStandards Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSymbolStandards.

Interface

IMcadSymbolStandards Interface

Methods
Name | Description
Add | Adds a symbol standard to the collection.
Item | Gets a specified symbol standard from the collection.
Remove | Removes the specified symbol standard from the collection.
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the symbol standards in the collection.
Links
IMcadSymbolStandards Interface, Legend, Methods, Properties


IMcadSymbolStandards::Application Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards::Application Property
IMcadSymbolStandards Interface IMcadSymbolStandards Members IMcadSymbolStandards Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IDispatch**
Remarks

AcadmApplication object is an instance of the Mechanical Desktop or AutoCAD Mechanical application. The AcadmApplication object is the starting point for any kind of enquiry on the objects contained within AutoCAD Mechanical.

Interface

IMcadSymbolStandards Interface

Links
IMcadSymbolStandards Interface, IMcadSymbolStandards Members, IMcadSymbolStandards Interface


IMcadSymbolStandards::Count Property

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards::Count Property
IMcadSymbolStandards Interface IMcadSymbolStandards Members IMcadSymbolStandards Interface Send Feedback
Summary

Gets the total number of the symbol standards in the collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IMcadSymbolStandards Interface

Links
IMcadSymbolStandards Interface, IMcadSymbolStandards Members, IMcadSymbolStandards Interface


IMcadSymbolStandards::Add Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards::Add Method
IMcadSymbolStandards Interface IMcadSymbolStandards Members IMcadSymbolStandards Interface Send Feedback
Summary

Adds a symbol standard to the collection.

Visual Basic
Sub Add(Item As IMcadSymbolStandard)
Parameters
Parameters | Description
Item | McadSymbolStandard object; input-only. Specifies the symbol standard to add to the collection.
Returns

None

Interface

IMcadSymbolStandards Interface

Links
IMcadSymbolStandards Interface, IMcadSymbolStandards Members, IMcadSymbolStandards Interface


IMcadSymbolStandards::Item Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards::Item Method
IMcadSymbolStandards Interface IMcadSymbolStandards Members IMcadSymbolStandards Interface Send Feedback
Summary

Gets a specified symbol standard from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadSymbolStandard*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the symbol standard to return.
Returns

None

Interface

IMcadSymbolStandards Interface

Links
IMcadSymbolStandards Interface, IMcadSymbolStandards Members, IMcadSymbolStandards Interface


IMcadSymbolStandards::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards::Remove Method
IMcadSymbolStandards Interface IMcadSymbolStandards Members IMcadSymbolStandards Interface Send Feedback
Summary

Removes the specified symbol standard from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the item to be removed.
Returns

None

Interface

IMcadSymbolStandards Interface

Links
IMcadSymbolStandards Interface, IMcadSymbolStandards Members, IMcadSymbolStandards Interface


IMcadTaper Interface

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper Interface
IMcadTaper Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the taper symbol created in the drawing.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadTaper
Visual Basic
Public Interface IMcadTaper
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadTaper Members, SymBBAuto Library, Class Hierarchy


IMcadTaper Members

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper Members
IMcadTaper Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTaper.

Interface

IMcadTaper Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustReferenceLine | Adjust the angle of the landing and symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AboveCurve | Specifies if the symbol is above the curve.
CoordinateSystem | Specifies the coordinate system for the symbol.
DisplayString | Specifies the string of the symbol text.
HasLeader | Property to specify if the symbol has leader.
Inspect | Specifies if the theoretically exact frame is turned on or off.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the taper symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubSymbolType | Specifies the type of symbol. Currently the type of sbTaper2 only can be set for GB standard.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadTaper Interface, Legend, Methods, Properties


IMcadTaper::AboveCurve Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::AboveCurve Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::AboveCurve Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Specifies if the symbol is above the curve.

Visual Basic
Property AboveCurve() As VARIANT_BOOL
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::DisplayString Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::DisplayString Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::DisplayString Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Specifies the string of the symbol text.

Visual Basic
Property DisplayString() As String
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::HasLeader Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::HasLeader Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::HasLeader Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Property to specify if the symbol has leader.

Visual Basic
Property HasLeader() As VARIANT_BOOL*
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::Inspect Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::Inspect Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::Inspect Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Specifies if the theoretically exact frame is turned on or off.

Visual Basic
Property Inspect() As VARIANT_BOOL
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::Orientation Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::Orientation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::Orientation Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Specifies the orientation of the taper symbol.

Visual Basic
Property Orientation() As McadOrientation
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::SubSymbolType Property

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::SubSymbolType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::SubSymbolType Property
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Specifies the type of symbol. Currently the type of sbTaper2 only can be set for GB standard.

Visual Basic
Property SubSymbolType() As McadTaperSlopeSymType
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaper::AdjustReferenceLine Method

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper::AdjustReferenceLine Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper::AdjustReferenceLine Method
IMcadTaper Interface IMcadTaper Members IMcadTaper Interface Send Feedback
Summary

Adjust the angle of the landing and symbol.

Visual Basic
Sub AdjustReferenceLine(angle As double)
Parameters
Parameters | Description
Angle | Input angle in radian.
Interface

IMcadTaper Interface

Links
IMcadTaper Interface, IMcadTaper Members, IMcadTaper Interface


IMcadTaperStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard Interface
IMcadTaperStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2
Visual Basic
Public Interface IMcadTaperStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadTaperStandard Members, SymBBAuto Library, Class Hierarchy


IMcadTaperStandard Members

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard Members
IMcadTaperStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTaperStandard.

Interface

IMcadTaperStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadTaperStandard Interface, Legend, Methods, Properties


IMcadTaperStandard::OfferedSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard::OfferedSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard::OfferedSymbols Property
IMcadTaperStandard Interface IMcadTaperStandard Members IMcadTaperStandard Interface Send Feedback
Summary

Specifies the list of symbols that are selected for the standard.

Visual Basic
Property OfferedSymbols() As VARIANT*
Remarks

The variant is an array of LONG. The index of the array is the value of McadTaperType. This property is read-only.

Interface

IMcadTaperStandard Interface

Links
IMcadTaperStandard Interface, IMcadTaperStandard Members, IMcadTaperStandard Interface


IMcadTaperStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2 Interface
IMcadTaperStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Taper and Slope symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2
Visual Basic
Public Interface IMcadTaperStandard2
Inherits IMcadTaperStandard
Library

SymBBAuto Library

Links
IMcadTaperStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadTaperStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2 Members
IMcadTaperStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTaperStandard2.

Interface

IMcadTaperStandard2 Interface

Methods
Name | Description
GetDimensionType | Gets or sets preferred dimension type by current taper standard.
SetDimensionType | Sets the preferred dimension type by current taper standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadTaperStandard2 Interface, Legend, Methods, Properties


IMcadTaperStandard2::GetDimensionType Method

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2::GetDimensionType Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2::GetDimensionType Method
IMcadTaperStandard2 Interface IMcadTaperStandard2 Members IMcadTaperStandard2 Interface Send Feedback
Summary

Gets or sets preferred dimension type by current taper standard.

Visual Basic
Sub GetDimensionType(ByRef dimType As McadTaperDimensionType, ByRef ratioFormat As McadTaperRatioFormatType, ByRef separator As String)
Parameters
Parameters | Description
dimType | Taper Dim type enum
ratioFormat | Taper Ratio enum
separator | All alpha-numeric characters including spaces are accepted as valid separators. The default separator is a colon “:”
Interface

IMcadTaperStandard2 Interface

Links
IMcadTaperStandard2 Interface, IMcadTaperStandard2 Members, IMcadTaperStandard2 Interface


IMcadTaperStandard2::SetDimensionType Method

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2::SetDimensionType Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2::SetDimensionType Method
IMcadTaperStandard2 Interface IMcadTaperStandard2 Members IMcadTaperStandard2 Interface Send Feedback
Summary

Sets the preferred dimension type by current taper standard.

Visual Basic
Sub SetDimensionType(dimType As McadTaperDimensionType, rationFormat As McadTaperRatioFormatType, separator As String)
Parameters
Parameters | Description
dimType | Taper Dim type enum
separator | All alpha-numeric characters including spaces are accepted as valid separators. The default separator is a colon “:”
ratioFormat | Taper Ratio enum
Interface

IMcadTaperStandard2 Interface

Links
IMcadTaperStandard2 Interface, IMcadTaperStandard2 Members, IMcadTaperStandard2 Interface


IMcadTitle Interface

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle Interface
IMcadTitle Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the title block of the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadTitle
    IMcadTitle2
Visual Basic
Public Interface IMcadTitle
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitle Members, SymBBAuto Library, Class Hierarchy


IMcadTitle Members

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle Members
IMcadTitle Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitle.

Interface

IMcadTitle Interface

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.
Links
IMcadTitle Interface, Legend, Methods, Properties


IMcadTitle::Attributes Property

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle::Attributes Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle::Attributes Property
IMcadTitle Interface IMcadTitle Members IMcadTitle Interface Send Feedback
Summary

Property that specifies all the attributes for the title block.

Visual Basic
Property Attributes() As VARIANT
Interface

IMcadTitle Interface

Links
IMcadTitle Interface, IMcadTitle Members, IMcadTitle Interface


IMcadTitle::InActive Property

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle::InActive Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle::InActive Property
IMcadTitle Interface IMcadTitle Members IMcadTitle Interface Send Feedback
Summary

Property that specifies the title block is inactive or invisible.

Visual Basic
Property InActive() As VARIANT_BOOL
Interface

IMcadTitle Interface

Links
IMcadTitle Interface, IMcadTitle Members, IMcadTitle Interface


IMcadTitle::Name Property

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle::Name Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle::Name Property
IMcadTitle Interface IMcadTitle Members IMcadTitle Interface Send Feedback
Summary

Property that specifies the name identifier of the title block.

Visual Basic
Property Name() As String
Interface

IMcadTitle Interface

Links
IMcadTitle Interface, IMcadTitle Members, IMcadTitle Interface


IMcadTitle::Position Property

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle::Position Property
IMcadTitle Interface IMcadTitle Members IMcadTitle Interface Send Feedback
Summary

Property that returns the position of the title block.

Visual Basic
Property Position() As VARIANT*
Interface

IMcadTitle Interface

Links
IMcadTitle Interface, IMcadTitle Members, IMcadTitle Interface


IMcadTitle::SetToDefaultAttributes Method

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle::SetToDefaultAttributes Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle::SetToDefaultAttributes Method
IMcadTitle Interface IMcadTitle Members IMcadTitle Interface Send Feedback
Summary

Initialize default attributes of the title block.

Visual Basic
Sub SetToDefaultAttributes(ret As [out, retval]VARIANT_BOOL)
Interface

IMcadTitle Interface

Links
IMcadTitle Interface, IMcadTitle Members, IMcadTitle Interface


IMcadTitle2 Interface

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2 Interface
IMcadTitle2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadTitle2.

Class Hierarchy

Declaration syntax

IMcadTitle
    IMcadTitle2
Visual Basic
Public Interface IMcadTitle2
Inherits IMcadTitle
Library

SymBBAuto Library

Links
IMcadTitle2 Members, SymBBAuto Library, Class Hierarchy


IMcadTitle2 Members

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2 Members
IMcadTitle2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitle2.

Interface

IMcadTitle2 Interface

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
BlockId | This is BlockId, a member of class IMcadTitle2.
BlockId32 | This is BlockId32, a member of class IMcadTitle2.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.
Links
IMcadTitle2 Interface, Legend, Methods, Properties


IMcadTitle2::BlockId Property

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2::BlockId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2::BlockId Property
IMcadTitle2 Interface IMcadTitle2 Members IMcadTitle2 Interface Send Feedback
Summary

This is BlockId, a member of class IMcadTitle2.

Visual Basic
Property BlockId() As LONG_PTR*
Interface

IMcadTitle2 Interface

Links
IMcadTitle2 Interface, IMcadTitle2 Members, IMcadTitle2 Interface


IMcadTitle2::BlockId32 Property

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2::BlockId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2::BlockId32 Property
IMcadTitle2 Interface IMcadTitle2 Members IMcadTitle2 Interface Send Feedback
Summary

This is BlockId32, a member of class IMcadTitle2.

Visual Basic
Property BlockId32() As LONG*
Interface

IMcadTitle2 Interface

Links
IMcadTitle2 Interface, IMcadTitle2 Members, IMcadTitle2 Interface


IMcadTitleBorder Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder Interface
IMcadTitleBorder Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the title/border created in the drawing.

Class Hierarchy

Declaration syntax

IMcadTitleBorder
Visual Basic
Public Interface IMcadTitleBorder
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitleBorder Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorder Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder Members
IMcadTitleBorder Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorder.

Interface

IMcadTitleBorder Interface

Methods
Name | Description
Modify | Modifies this title/border.
Properties
Name | Description
Descriptor | Property that returns the descriptor for this title/border.
Ref | Property that returns a reference to the title/border object.
Ref32 | Property that returns a reference to the title/border object.
Links
IMcadTitleBorder Interface, Legend, Methods, Properties


IMcadTitleBorder::Descriptor Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder::Descriptor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder::Descriptor Property
IMcadTitleBorder Interface IMcadTitleBorder Members IMcadTitleBorder Interface Send Feedback
Summary

Property that returns the descriptor for this title/border.

Visual Basic
Property Descriptor() As IMcadTitleBorderDescriptor**
Interface

IMcadTitleBorder Interface

Links
IMcadTitleBorder Interface, IMcadTitleBorder Members, IMcadTitleBorder Interface


IMcadTitleBorder::Ref Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder::Ref Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder::Ref Property
IMcadTitleBorder Interface IMcadTitleBorder Members IMcadTitleBorder Interface Send Feedback
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref() As LONG_PTR*
Interface

IMcadTitleBorder Interface

Links
IMcadTitleBorder Interface, IMcadTitleBorder Members, IMcadTitleBorder Interface


IMcadTitleBorder::Ref32 Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder::Ref32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder::Ref32 Property
IMcadTitleBorder Interface IMcadTitleBorder Members IMcadTitleBorder Interface Send Feedback
Summary

Property that returns a reference to the title/border object.

Visual Basic
Property Ref32() As LONG*
Remarks

For 64-bit platform only.

Interface

IMcadTitleBorder Interface

Links
IMcadTitleBorder Interface, IMcadTitleBorder Members, IMcadTitleBorder Interface


IMcadTitleBorder::Modify Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder::Modify Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder::Modify Method
IMcadTitleBorder Interface IMcadTitleBorder Members IMcadTitleBorder Interface Send Feedback
Summary

Modifies this title/border.

Visual Basic
Sub Modify(context As [in,defaultvalue(0)]IMcadTitleBorderContext, ret As [out,retval]VARIANT_BOOL)
Parameters
Parameters | Description
context | Input title border descriptor object which specifies the modified settings data associated with the title/border.
Interface

IMcadTitleBorder Interface

Links
IMcadTitleBorder Interface, IMcadTitleBorder Members, IMcadTitleBorder Interface


IMcadTitleBorderContext Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext Interface
IMcadTitleBorderContext Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This new object contains all option settings associated with a title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderContext
Visual Basic
Public Interface IMcadTitleBorderContext
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitleBorderContext Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorderContext Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext Members
IMcadTitleBorderContext Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorderContext.

Interface

IMcadTitleBorderContext Interface

Methods
Name | Description
GetMoveObjectsIDs | Get list of objects to be moved within the drawing border.
GetMoveObjectsIDs32 | Get list of objects to be moved within the drawing border.
GetMoveObjectsToPoint | Get destination point within the drawing border.
GetPartReference | Get objectId of the part reference to retrieve the attribute from.
GetPartReference32 | Get objectId of the part reference to retrieve the attribute from.
SetMoveObjects | Set list of objects to be moved and destination point within the drawing border.
SetPartReference | Set object ID of the part reference to retrieve the attribute from.
Properties
Name | Description
AutomaticPlacement | Property that specifies option for automatic placement.
BaseScale | Property that specifies option to set base scale factor.
DwgDefault | Property that specifies option to set drawing defaults.
MoveObjects | Property that specifies option to move specified objects within the drawing border.
Rescale | Property that specifies option to perform rescale.
RetrieveFromAsmProp | Property that specifies option to retrieve from assembly properties.
RetrieveFromPartRef | Property that specifies option to retrieve from part reference.
ThawAllLayers | Property that specifies option to thaw all layers for position of the title/border.
Links
IMcadTitleBorderContext Interface, Legend, Methods, Properties


IMcadTitleBorderContext::AutomaticPlacement Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::AutomaticPlacement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::AutomaticPlacement Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option for automatic placement.

Visual Basic
Property AutomaticPlacement() As VARIANT_BOOL
Remarks

This property will not be set and return E_FAIL if the MoveObjects property is a false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::BaseScale Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::BaseScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::BaseScale Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to set base scale factor.

Visual Basic
Property BaseScale() As VARIANT_BOOL
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::DwgDefault Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::DwgDefault Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::DwgDefault Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to set drawing defaults.

Visual Basic
Property DwgDefault() As VARIANT_BOOL
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::MoveObjects Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::MoveObjects Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::MoveObjects Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to move specified objects within the drawing border.

Visual Basic
Property MoveObjects() As VARIANT_BOOL
Remarks

When this property is a set to false, the ThawAllLayers and AutomaticPlacement properties will automatically be set to false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::Rescale Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::Rescale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::Rescale Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to perform rescale.

Visual Basic
Property Rescale() As VARIANT_BOOL
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::RetrieveFromAsmProp Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::RetrieveFromAsmProp Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::RetrieveFromAsmProp Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to retrieve from assembly properties.

Visual Basic
Property RetrieveFromAsmProp() As VARIANT_BOOL
Remarks

When this property is a set to true, the RetrieveFromPartRef property will automatically be set to false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::RetrieveFromPartRef Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::RetrieveFromPartRef Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::RetrieveFromPartRef Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to retrieve from part reference.

Visual Basic
Property RetrieveFromPartRef() As VARIANT_BOOL
Remarks

When this property is a set to true, the RetrieveFromAsmProp property will automatically be set to false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::ThawAllLayers Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::ThawAllLayers Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::ThawAllLayers Property
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Property that specifies option to thaw all layers for position of the title/border.

Visual Basic
Property ThawAllLayers() As VARIANT_BOOL
Remarks

This property will not be set and return E_FAIL if the MoveObjects property is a false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::GetMoveObjectsIDs Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::GetMoveObjectsIDs Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::GetMoveObjectsIDs Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Get list of objects to be moved within the drawing border.

Visual Basic
Sub GetMoveObjectsIDs(ObjectIDs As [out,retval] VARIANT)
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::GetMoveObjectsIDs32 Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::GetMoveObjectsIDs32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::GetMoveObjectsIDs32 Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Get list of objects to be moved within the drawing border.

Visual Basic
Sub GetMoveObjectsIDs32(ObjectIDs As [out,retval] VARIANT)
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::GetMoveObjectsToPoint Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::GetMoveObjectsToPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::GetMoveObjectsToPoint Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Get destination point within the drawing border.

Visual Basic
Sub GetMoveObjectsToPoint(ToPoint As [out,retval] VARIANT)
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::GetPartReference Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::GetPartReference Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::GetPartReference Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Get objectId of the part reference to retrieve the attribute from.

Visual Basic
Sub GetPartReference(ObjectID As [out,retval] LONG_PTR)
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::GetPartReference32 Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::GetPartReference32 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::GetPartReference32 Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Get objectId of the part reference to retrieve the attribute from.

Visual Basic
Sub GetPartReference32(ObjectID As [out,retval] LONG)
Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::SetMoveObjects Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::SetMoveObjects Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::SetMoveObjects Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Set list of objects to be moved and destination point within the drawing border.

Visual Basic
Sub SetMoveObjects(ObjectIDs As VARIANT, ToPoint As VARIANT)
Parameters
Parameters | Description
ObjectIDs | The list of objects to be moved. The VARIANT is an array of long. This is needed if newVal = VARIANT_TRUE.
ToPoint | The position for the objects to move to. The VARIANT is a 3-element array of doubles for x, y and z points.
Remarks

This method will return E_FAIL if the MoveObjects property is false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderContext::SetPartReference Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext::SetPartReference Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext::SetPartReference Method
IMcadTitleBorderContext Interface IMcadTitleBorderContext Members IMcadTitleBorderContext Interface Send Feedback
Summary

Set object ID of the part reference to retrieve the attribute from.

Visual Basic
Sub SetPartReference(ObjectID As VARIANT)
Parameters
Parameters | Description
ObjectID | The object ID of the part reference. The VARIANT is long.
Remarks

This method will return E_FAIL if the RetrieveFromPartRef property is a false.

Interface

IMcadTitleBorderContext Interface

Links
IMcadTitleBorderContext Interface, IMcadTitleBorderContext Members, IMcadTitleBorderContext Interface


IMcadTitleBorderDescriptor Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor Interface
IMcadTitleBorderDescriptor Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object contains all data associated with a title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderDescriptor
Visual Basic
Public Interface IMcadTitleBorderDescriptor
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitleBorderDescriptor Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorderDescriptor Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor Members
IMcadTitleBorderDescriptor Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorderDescriptor.

Interface

IMcadTitleBorderDescriptor Interface

Properties
Name | Description
Border | Property that returns the drawing border for the title/border.
Position | Property that specifies the position of the title/border.
Title | Property that returns the title block for the title/border.
TitleBorderScale | Property that specifies scale for title/border.
Links
IMcadTitleBorderDescriptor Interface, Legend, Properties


IMcadTitleBorderDescriptor::Border Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor::Border Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor::Border Property
IMcadTitleBorderDescriptor Interface IMcadTitleBorderDescriptor Members IMcadTitleBorderDescriptor Interface Send Feedback
Summary

Property that returns the drawing border for the title/border.

Visual Basic
Property Border() As IMcadBorder**
Interface

IMcadTitleBorderDescriptor Interface

Links
IMcadTitleBorderDescriptor Interface, IMcadTitleBorderDescriptor Members, IMcadTitleBorderDescriptor Interface


IMcadTitleBorderDescriptor::Position Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor::Position Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor::Position Property
IMcadTitleBorderDescriptor Interface IMcadTitleBorderDescriptor Members IMcadTitleBorderDescriptor Interface Send Feedback
Summary

Property that specifies the position of the title/border.

Visual Basic
Property Position() As VARIANT
Interface

IMcadTitleBorderDescriptor Interface

Links
IMcadTitleBorderDescriptor Interface, IMcadTitleBorderDescriptor Members, IMcadTitleBorderDescriptor Interface


IMcadTitleBorderDescriptor::Title Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor::Title Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor::Title Property
IMcadTitleBorderDescriptor Interface IMcadTitleBorderDescriptor Members IMcadTitleBorderDescriptor Interface Send Feedback
Summary

Property that returns the title block for the title/border.

Visual Basic
Property Title() As IMcadTitle**
Interface

IMcadTitleBorderDescriptor Interface

Links
IMcadTitleBorderDescriptor Interface, IMcadTitleBorderDescriptor Members, IMcadTitleBorderDescriptor Interface


IMcadTitleBorderDescriptor::TitleBorderScale Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor::TitleBorderScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor::TitleBorderScale Property
IMcadTitleBorderDescriptor Interface IMcadTitleBorderDescriptor Members IMcadTitleBorderDescriptor Interface Send Feedback
Summary

Property that specifies scale for title/border.

Visual Basic
Property TitleBorderScale() As double
Interface

IMcadTitleBorderDescriptor Interface

Links
IMcadTitleBorderDescriptor Interface, IMcadTitleBorderDescriptor Members, IMcadTitleBorderDescriptor Interface


IMcadTitleBorderMgr Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr Interface
IMcadTitleBorderMgr Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is used for general functionality for title/border.

Class Hierarchy

Declaration syntax

IMcadTitleBorderMgr
Visual Basic
Public Interface IMcadTitleBorderMgr
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitleBorderMgr Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorderMgr Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr Members
IMcadTitleBorderMgr Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorderMgr.

Interface

IMcadTitleBorderMgr Interface

Methods
Name | Description
CreateTitleBorder | Creates a new title/border.
DeleteTitleBorder | Removes the specified title/border from the drawing.
GetTitleBorderFromRef | Gets title border object from the specified object ID.
NewContext | Creates and initializes a new title border context.
NewDescriptor | Creates and initializes a new title border descriptor.
Properties
Name | Description
TitleBorders | Property that returns the list of all titles/borders in the drawing.
Links
IMcadTitleBorderMgr Interface, Legend, Methods, Properties


IMcadTitleBorderMgr::TitleBorders Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::TitleBorders Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::TitleBorders Property
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Property that returns the list of all titles/borders in the drawing.

Visual Basic
Property TitleBorders() As IMcadTitleBorders**
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorderMgr::CreateTitleBorder Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::CreateTitleBorder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::CreateTitleBorder Method
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Creates a new title/border.

Visual Basic
Sub CreateTitleBorder(desc As IMcadTitleBorderDescriptor, context As IMcadTitleBorderContext, titleBorder As [out,retval] IMcadTitleBorder*)
Parameters
Parameters | Description
desc | Input title border descriptor object which specifies all data associated with the title/border.
context | Input title border context object which specifies all option settings associated with the title/border.
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorderMgr::DeleteTitleBorder Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::DeleteTitleBorder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::DeleteTitleBorder Method
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Removes the specified title/border from the drawing.

Visual Basic
Sub DeleteTitleBorder(titleBorder As IMcadTitleBorder, ret As [out,retval] VARIANT_BOOL)
Parameters
Parameters | Description
titleBorder | Input title/border to be deleted.
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorderMgr::GetTitleBorderFromRef Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::GetTitleBorderFromRef Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::GetTitleBorderFromRef Method
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Gets title border object from the specified object ID.

Visual Basic
Sub GetTitleBorderFromRef(objectId As VARIANT, titleBorder As [out,retval] IMcadTitleBorder*)
Parameters
Parameters | Description
ObjectID | Input object ID of title border object in the drawing
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorderMgr::NewContext Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::NewContext Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::NewContext Method
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Creates and initializes a new title border context.

Visual Basic
Sub NewContext(context As [out, retval] IMcadTitleBorderContext *)
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorderMgr::NewDescriptor Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr::NewDescriptor Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr::NewDescriptor Method
IMcadTitleBorderMgr Interface IMcadTitleBorderMgr Members IMcadTitleBorderMgr Interface Send Feedback
Summary

Creates and initializes a new title border descriptor.

Visual Basic
Sub NewDescriptor(desc As [out,retval] IMcadTitleBorderDescriptor*)
Interface

IMcadTitleBorderMgr Interface

Links
IMcadTitleBorderMgr Interface, IMcadTitleBorderMgr Members, IMcadTitleBorderMgr Interface


IMcadTitleBorders Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders Interface
IMcadTitleBorders Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object is a collection of title/border objects.

Class Hierarchy

Declaration syntax

IMcadTitleBorders
Visual Basic
Public Interface IMcadTitleBorders
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadTitleBorders Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorders Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders Members
IMcadTitleBorders Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorders.

Interface

IMcadTitleBorders Interface

Methods
Name | Description
Item | Obtains a specified title/border from the collection.
Properties
Name | Description
Application | Property that returns the application object.
Count | Property that returns the total number of title/border objects in the collection.
Links
IMcadTitleBorders Interface, Legend, Methods, Properties


IMcadTitleBorders::Application Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders::Application Property
IMcadTitleBorders Interface IMcadTitleBorders Members IMcadTitleBorders Interface Send Feedback
Summary

Property that returns the application object.

Visual Basic
Property Application() As IDispatch**
Interface

IMcadTitleBorders Interface

Links
IMcadTitleBorders Interface, IMcadTitleBorders Members, IMcadTitleBorders Interface


IMcadTitleBorders::Count Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders::Count Property
IMcadTitleBorders Interface IMcadTitleBorders Members IMcadTitleBorders Interface Send Feedback
Summary

Property that returns the total number of title/border objects in the collection.

Visual Basic
Property Count() As long*
Interface

IMcadTitleBorders Interface

Links
IMcadTitleBorders Interface, IMcadTitleBorders Members, IMcadTitleBorders Interface


IMcadTitleBorders::Item Method

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders::Item Method
IMcadTitleBorders Interface IMcadTitleBorders Members IMcadTitleBorders Interface Send Feedback
Summary

Obtains a specified title/border from the collection.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadTitleBorder*)
Parameters
Parameters | Description
Index | Input long value that specifies an index of the selected title/border object in the collection. Values range from 0 to one less than the total number of objects.
Interface

IMcadTitleBorders Interface

Links
IMcadTitleBorders Interface, IMcadTitleBorders Members, IMcadTitleBorders Interface


IMcadTitleBorderStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard Interface
IMcadTitleBorderStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This object represents the Drawing Sheet standard element.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2
Visual Basic
Public Interface IMcadTitleBorderStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadTitleBorderStandard Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorderStandard Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard Members
IMcadTitleBorderStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorderStandard.

Interface

IMcadTitleBorderStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.
Links
IMcadTitleBorderStandard Interface, Legend, Methods, Properties


IMcadTitleBorderStandard::DefaultPaperFormat Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::DefaultPaperFormat Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::DefaultPaperFormat Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that specifies the default paper format for the title/border.

Visual Basic
Property DefaultPaperFormat() As String
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard::DefaultRevisionList Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::DefaultRevisionList Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::DefaultRevisionList Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that specifies the default revision list.

Visual Basic
Property DefaultRevisionList() As String
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard::DefaultTitleBlock Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::DefaultTitleBlock Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::DefaultTitleBlock Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that specifies the default title block for the title/border.

Visual Basic
Property DefaultTitleBlock() As String
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard::PaperFormats Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::PaperFormats Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::PaperFormats Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that returns the available paper formats in the Drawing Sheet standard element.

Visual Basic
Property PaperFormats() As VARIANT*
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard::RevisionLists Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::RevisionLists Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::RevisionLists Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that returns available revision lists in the Drawing Sheet standard element.

Visual Basic
Property RevisionLists() As VARIANT*
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard::TitleBlocks Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard::TitleBlocks Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard::TitleBlocks Property
IMcadTitleBorderStandard Interface IMcadTitleBorderStandard Members IMcadTitleBorderStandard Interface Send Feedback
Summary

Property that returns available title blocks in the Drawing Sheet standard element.

Visual Basic
Property TitleBlocks() As VARIANT*
Interface

IMcadTitleBorderStandard Interface

Links
IMcadTitleBorderStandard Interface, IMcadTitleBorderStandard Members, IMcadTitleBorderStandard Interface


IMcadTitleBorderStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2 Interface
IMcadTitleBorderStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadTitleBorderStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2
Visual Basic
Public Interface IMcadTitleBorderStandard2
Inherits IMcadTitleBorderStandard
Library

SymBBAuto Library

Links
IMcadTitleBorderStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadTitleBorderStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2 Members
IMcadTitleBorderStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTitleBorderStandard2.

Interface

IMcadTitleBorderStandard2 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
InsertInvertPart | Specifies if an inverted drawing number block will be inserted when a title border is created.
InvertPartBorderHeight | Specifies the height of the inverted drawing number block.
InvertPartBorderWidth | Specifies the width of the inverted drawing number block.
InvertPartTextHeight | Specifies the height of the text in the inverted drawing number block.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.
Links
IMcadTitleBorderStandard2 Interface, Legend, Methods, Properties


IMcadTitleBorderStandard2::InsertInvertPart Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2::InsertInvertPart Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2::InsertInvertPart Property
IMcadTitleBorderStandard2 Interface IMcadTitleBorderStandard2 Members IMcadTitleBorderStandard2 Interface Send Feedback
Summary

Specifies if an inverted drawing number block will be inserted when a title border is created.

Visual Basic
Property InsertInvertPart() As VARIANT_BOOL
Interface

IMcadTitleBorderStandard2 Interface

Links
IMcadTitleBorderStandard2 Interface, IMcadTitleBorderStandard2 Members, IMcadTitleBorderStandard2 Interface


IMcadTitleBorderStandard2::InvertPartBorderHeight Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2::InvertPartBorderHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2::InvertPartBorderHeight Property
IMcadTitleBorderStandard2 Interface IMcadTitleBorderStandard2 Members IMcadTitleBorderStandard2 Interface Send Feedback
Summary

Specifies the height of the inverted drawing number block.

Visual Basic
Property InvertPartBorderHeight() As double
Interface

IMcadTitleBorderStandard2 Interface

Links
IMcadTitleBorderStandard2 Interface, IMcadTitleBorderStandard2 Members, IMcadTitleBorderStandard2 Interface


IMcadTitleBorderStandard2::InvertPartBorderWidth Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2::InvertPartBorderWidth Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2::InvertPartBorderWidth Property
IMcadTitleBorderStandard2 Interface IMcadTitleBorderStandard2 Members IMcadTitleBorderStandard2 Interface Send Feedback
Summary

Specifies the width of the inverted drawing number block.

Visual Basic
Property InvertPartBorderWidth() As double
Interface

IMcadTitleBorderStandard2 Interface

Links
IMcadTitleBorderStandard2 Interface, IMcadTitleBorderStandard2 Members, IMcadTitleBorderStandard2 Interface


IMcadTitleBorderStandard2::InvertPartTextHeight Property

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2::InvertPartTextHeight Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2::InvertPartTextHeight Property
IMcadTitleBorderStandard2 Interface IMcadTitleBorderStandard2 Members IMcadTitleBorderStandard2 Interface Send Feedback
Summary

Specifies the height of the text in the inverted drawing number block.

Visual Basic
Property InvertPartTextHeight() As double
Interface

IMcadTitleBorderStandard2 Interface

Links
IMcadTitleBorderStandard2 Interface, IMcadTitleBorderStandard2 Members, IMcadTitleBorderStandard2 Interface


IMcadTransaction Interface

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTransaction Interface
IMcadTransaction Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The McadTransaction object.

Class Hierarchy

Declaration syntax

IMcadTransaction
Visual Basic
Public Interface IMcadTransaction
Inherits IDispatch
Remarks

These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.

To end a transaction, set the transaction object to Null. Nested transactions are not supported.

To temporarily suspend dynamic updates while performing batch modifications of mechanical structure, create a transaction before the changes, then set the transaction to Null once the changes are complete.

To force updates of mechanical structure at any time, call Mcad2DStructureMgr.Update and/or Mcad2DStructureMgr.UpdateEntities.

Library

SymBBAuto Library

Links
IMcadTransaction Members, SymBBAuto Library, Class Hierarchy


IMcadTransaction Members

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface > IMcadTransaction Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTransaction Members
IMcadTransaction Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IMcadTransaction.

Interface

IMcadTransaction Interface

Properties
Name | Description
Application | Gets the AcadmApplication object.
Links
IMcadTransaction Interface, Legend, Properties


IMcadTransaction::Application Property

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface > IMcadTransaction::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTransaction::Application Property
IMcadTransaction Interface IMcadTransaction Members IMcadTransaction Interface Send Feedback
Summary

Gets the AcadmApplication object.

Visual Basic
Property Application() As IAcadmApplication**
Interface

IMcadTransaction Interface

Links
IMcadTransaction Interface, IMcadTransaction Members, IMcadTransaction Interface


IMcadWelding Interface

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding Interface
IMcadWelding Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A weld symbol object

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2
Visual Basic
Public Interface IMcadWelding
Inherits IMcadSymbol2
Library

SymBBAuto Library

Links
IMcadWelding Members, SymBBAuto Library, Class Hierarchy


IMcadWelding Members

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding Members
IMcadWelding Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWelding.

Interface

IMcadWelding Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadWelding Interface, Legend, Methods, Properties


IMcadWelding::Orientation Property

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Orientation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Orientation Property
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the orientation of the arrow data and other data for a weld symbol.

Visual Basic
Property Orientation() As McadOrientation
Remarks

This property is a McadOrientation enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SubWeldingCount Property

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SubWeldingCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SubWeldingCount Property
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Gets the number of subwelding symbols for a weld symbol.

Visual Basic
Property SubWeldingCount() As long*
Remarks

This property is a Long.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AddSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AddSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AddSubWelding Method
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Add a new subweld symbol to the weld symbol.

Visual Basic
Sub AddSubWelding(Before As [in, optional] VARIANT)
Parameters
Parameters | Description
Before | Before Variant (Long); input-only; optional. If specified, the new symbol is inserted before an existing subweld symbol at the specified index; otherwise, the new subweld symbol is added as the last subweld symbol.
Returns

None

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.

Visual Basic
Sub AngleValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary value is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.

Visual Basic
Sub AngleValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary value is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the supplementary weld symbol describing the weld area.

Visual Basic
Sub AreaType(SubWelding As [in, defaultvalue(0)] long, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the symbol type for.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the supplementary weld symbol describing the weld area.

Visual Basic
Sub AreaType(SubWelding As [in, defaultvalue(0)] long, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the symbol type for.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the weld association type for the weld symbol.

Visual Basic
Sub AssociationType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldAssociation)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadWeldAssociation enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the weld association type for the weld symbol.

Visual Basic
Sub AssociationType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldAssociation)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadWeldAssociation enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the backing field for the weld symbol.

Visual Basic
Sub BackingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the backing field for the weld symbol.

Visual Basic
Sub BackingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub Brazing(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Brazing As VARIANT_BOOL)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub Brazing(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Brazing As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the brazing field for the weld symbol.

Visual Basic
Sub BrazingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the brazing field for the weld symbol.

Visual Basic
Sub BrazingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the clearance field for the weld symbol.

Visual Basic
Sub ClearanceValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the clearance field for the weld symbol.

Visual Basic
Sub ClearanceValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub ClosedTail(SubWelding As [in, defaultvalue(0)] long, Closed As VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the tail for.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub ClosedTail(SubWelding As [in, defaultvalue(0)] long, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the tail for.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the contour symbol.

Visual Basic
Sub ContourType(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the contour symbol.

Visual Basic
Sub ContourType(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the contour field for the weld symbol.

Visual Basic
Sub ContourValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the contour field for the weld symbol.

Visual Basic
Sub ContourValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld control category field for the weld symbol.

Visual Basic
Sub ControlCategoryValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld control category field for the weld symbol.

Visual Basic
Sub ControlCategoryValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the depth field for a weld symbol.

Visual Basic
Sub DepthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the depth field for a weld symbol.

Visual Basic
Sub DepthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld designation field for the weld symbol.

Visual Basic
Sub DesignationValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld designation field for the weld symbol.

Visual Basic
Sub DesignationValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub FieldWeld(SubWelding As [in, defaultvalue(0)] long, On As VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.

Visual Basic
Sub FieldWeld(SubWelding As [in, defaultvalue(0)] long, On As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a Boolean.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the finishing method field for the contour weld symbol.

Visual Basic
Sub FinishingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the finishing method field for the contour weld symbol.

Visual Basic
Sub FinishingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the size of the gap between weldments.

Visual Basic
Sub GapValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks
  • This property is a String.
  • This property is a only available for specific weld symbol types only when the pertinent Brazing property is a false.
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the size of the gap between weldments.

Visual Basic
Sub GapValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks
  • This property is a String.
  • This property is a only available for specific weld symbol types only when the pertinent Brazing property is a false.
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::HighlightSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::HighlightSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::HighlightSubWelding Method
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Highlights the subwelding symbol at the specified index.

Visual Basic
Sub HighlightSubWelding(Highlight As VARIANT_BOOL, Index As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
Highlight | Highlight Boolean; input-only. Specifies whether the subwelding symbol is highlighted, TRUE, or not, False.
Index | Index Long, default value = 0; input-only; optional. Specifies the index of the subwelding symbol to be highlighted.
Returns

None

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of identification line used for the weld symbol.

Visual Basic
Sub IdentificationLine(SubWelding As [in, defaultvalue(0)] long, Type As McadIdentificationType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadIdentificationType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of identification line used for the weld symbol.

Visual Basic
Sub IdentificationLine(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadIdentificationType)
Parameters
Parameters | Description
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Remarks

This property is a McadIdentificationType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the total count of index field for the weld symbol.

Visual Basic
Sub IndexTotalValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Parameters
Parameters | Description
SubWelding | _nt_
Value | _nt_
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the total count of index field for the weld symbol.

Visual Basic
Sub IndexTotalValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the index number field for the weld symbol.

Visual Basic
Sub IndexValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the index number field for the weld symbol.

Visual Basic
Sub IndexValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the length field for the weld symbol.

Visual Basic
Sub LengthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the length field for the weld symbol.

Visual Basic
Sub LengthValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the supplementary data in the notes field for a weld symbol.

Visual Basic
Sub NotesValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the supplementary data in the notes field for a weld symbol.

Visual Basic
Sub NotesValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the number of welds for specific weld symbol types.

Visual Basic
Sub NumberValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the number of welds for specific weld symbol types.

Visual Basic
Sub NumberValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the distance between the centers of the welds for specific weld symbol types.

Visual Basic
Sub PitchValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the distance between the centers of the welds for specific weld symbol types.

Visual Basic
Sub PitchValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::RemoveSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::RemoveSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::RemoveSubWelding Method
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Removes the subwelding symbol at the specified index.

Visual Basic
Sub RemoveSubWelding(Index As long)
Parameters
Parameters | Description
Index | Index Long; input-only. Specifies the index of the subwelding symbol to be removed.
Returns

None

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the secondary symbol type for the weld symbol.

Visual Basic
Sub SecondarySymType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldSymbolType)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the secondary symbol type for the weld symbol.

Visual Basic
Sub SecondarySymType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldSymbolType)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the secondary symbol type field for specific weld symbol types.

Visual Basic
Sub SecondarySymTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the secondary symbol type field for specific weld symbol types.

Visual Basic
Sub SecondarySymTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size 2 field for specific weld symbol types.

Visual Basic
Sub Size2Value(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size 2 field for specific weld symbol types.

Visual Basic
Sub Size2Value(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the size for the weld symbol.

Visual Basic
Sub SizeType(SubWelding As [in, defaultvalue(0)] long, Type As McadWeldSymbolType)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the size for the weld symbol.

Visual Basic
Sub SizeType(SubWelding As [in, defaultvalue(0)] long, Type As [out, retval] McadWeldSymbolType)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size type field for specific weld symbol types.

Visual Basic
Sub SizeTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size type field for specific weld symbol types.

Visual Basic
Sub SizeTypeValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size field for specific weld symbol types.

Visual Basic
Sub SizeValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbMeltThrough
  • sbPlugWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the size field for specific weld symbol types.

Visual Basic
Sub SizeValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbBackWeld
  • sbBevelGrooveWeld
  • sbFilletWeld
  • sbFlareVGrooveWeld
  • sbFlareBevelGrooveWeld
  • sbMeltThrough
  • sbPlugWeld
  • sbScarfGrooveWeld
  • sbSecondaryFillet
  • sbSeamWeld
  • sbSeamOnRefLineWeld
  • sbSlotWeld
  • sbSpotWeld
  • sbSpotOnRefLineWeld
  • sbStudWeld
  • sbSqureGrooveWeld
  • sbJGrooveWeld
  • sbUGrooveWeld
  • sbVGrooveWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the spacing field for specific weld symbol types.

Visual Basic
Sub SpacingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbStudWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the spacing field for specific weld symbol types.

Visual Basic
Sub SpacingValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the Type property for this weld symbol is one of the following enumeration:

  • sbPlugWeld
  • sbStudWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld specification field for the weld symbol.

Visual Basic
Sub SpecificationValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld specification field for the weld symbol.

Visual Basic
Sub SpecificationValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld standard field for the weld symbol.

Visual Basic
Sub StandardValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the weld standard field for the weld symbol.

Visual Basic
Sub StandardValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the technical requirements field for the weld symbol.

Visual Basic
Sub TechnicalReqValue(SubWelding As [in, defaultvalue(0)] long, Value As String)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the technical requirements field for the weld symbol.

Visual Basic
Sub TechnicalReqValue(SubWelding As [in, defaultvalue(0)] long, Value As [out, retval] BSTR)
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the thickness field for specific weld symbol types.

Visual Basic
Sub ThicknessValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As String)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the AreaType property for this weld symbol is one of the following enumeration:

  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the value of the thickness field for specific weld symbol types.

Visual Basic
Sub ThicknessValue(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Value As [out, retval] BSTR)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a String. For example, this property is available when the AreaType property for this weld symbol is one of the following enumeration:

  • sbFlangeCornerWeld
  • sbFlangeEdgeWeld
Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding Interface IMcadWelding Members IMcadWelding Interface Send Feedback
Summary

Specifies the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long, Primary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)
Parameters
Parameters | Description
ArrowSide | Boolean, default value = TRUE; optional. Specifies whether the arrow side, or other side subsymbol is specified.
SubWelding | Long, default value = 0; optional. Specifies the index of the sub-welding symbol to specify the value for.
Primary | Boolean, default value = TRUE; optional. Specifies whether the primary or secondary subsymbol is specified.
Remarks

This property is a McadWeldSymbolType enumeration.

Interface

IMcadWelding Interface

Links
IMcadWelding Interface, IMcadWelding Members, IMcadWelding Interface


IMcadWelding2 Interface

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding2 Interface
IMcadWelding2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadWelding2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2
Visual Basic
Public Interface IMcadWelding2
Inherits IMcadWelding
Library

SymBBAuto Library

Links
IMcadWelding2 Members, SymBBAuto Library, Class Hierarchy


IMcadWelding2 Members

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding2 Members
IMcadWelding2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWelding2.

Interface

IMcadWelding2 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
InsertProcess | This is InsertProcess, a member of class IMcadWelding2.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.
Links
IMcadWelding2 Interface, Legend, Methods, Properties


IMcadWelding2::InsertProcess Method

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2::InsertProcess Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding2::InsertProcess Method
IMcadWelding2 Interface IMcadWelding2 Members IMcadWelding2 Interface Send Feedback
Summary

This is InsertProcess, a member of class IMcadWelding2.

Visual Basic
Sub InsertProcess(process As String, withPrefix As [in, defaultvalue(FALSE)] VARIANT_BOOL, SubWelding As [in, defaultvalue(0)] long)
Interface

IMcadWelding2 Interface

Links
IMcadWelding2 Interface, IMcadWelding2 Members, IMcadWelding2 Interface


IMcadWeldingLibrary Interface

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary Interface
IMcadWeldingLibrary Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadWeldingLibrary interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibrary
    IMcadWeldingLibrary
Visual Basic
Public Interface IMcadWeldingLibrary
Inherits IMcadSymbolLibrary
Library

SymBBAuto Library

Links
IMcadWeldingLibrary Members, SymBBAuto Library, Class Hierarchy


IMcadWeldingLibrary Members

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary Members
IMcadWeldingLibrary Interface Legend Methods Send Feedback
Summary

The following tables list the members exposed by IMcadWeldingLibrary.

Interface

IMcadWeldingLibrary Interface

Methods
Name | Description
appendItem | Add the data in this SymId to the library.
appendItemFromSubWelding | Append a subwelding symbol at the specified index to the welding symbol library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
loadItemToSubWelding | Load a subwelding symbol library object to a weld symbol at the specified index.
modifyItem | Update the data in this library object.
modifyItemFromSubWelding | Update the data in library object, itemName, with SymId at index, SubWeldingIndex.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.
Links
IMcadWeldingLibrary Interface, Legend, Methods


IMcadWeldingLibrary::appendItemFromSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary::appendItemFromSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary::appendItemFromSubWelding Method
IMcadWeldingLibrary Interface IMcadWeldingLibrary Members IMcadWeldingLibrary Interface Send Feedback
Summary

Append a subwelding symbol at the specified index to the welding symbol library.

Visual Basic
Sub appendItemFromSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.
Interface

IMcadWeldingLibrary Interface

Links
IMcadWeldingLibrary Interface, IMcadWeldingLibrary Members, IMcadWeldingLibrary Interface


IMcadWeldingLibrary::loadItemToSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary::loadItemToSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary::loadItemToSubWelding Method
IMcadWeldingLibrary Interface IMcadWeldingLibrary Members IMcadWeldingLibrary Interface Send Feedback
Summary

Load a subwelding symbol library object to a weld symbol at the specified index.

Visual Basic
Sub loadItemToSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.
Interface

IMcadWeldingLibrary Interface

Links
IMcadWeldingLibrary Interface, IMcadWeldingLibrary Members, IMcadWeldingLibrary Interface


IMcadWeldingLibrary::modifyItemFromSubWelding Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary::modifyItemFromSubWelding Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary::modifyItemFromSubWelding Method
IMcadWeldingLibrary Interface IMcadWeldingLibrary Members IMcadWeldingLibrary Interface Send Feedback
Summary

Update the data in library object, itemName, with SymId at index, SubWeldingIndex.

Visual Basic
Sub modifyItemFromSubWelding(itemName As String, SymId As VARIANT, SubWeldingIndex As [in, defaultvalue(0)] long)
Parameters
Parameters | Description
itemName | Name of library object.
SymId | Object ID of welding symbol. This symbol provides the information on standad and symbol standard.
SubWeldingIndex | Specify the index of subSymbol to be used.
Interface

IMcadWeldingLibrary Interface

Links
IMcadWeldingLibrary Interface, IMcadWeldingLibrary Members, IMcadWeldingLibrary Interface


IMcadWeldingLibraryObject Interface

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject Interface
IMcadWeldingLibraryObject Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

The IMcadWeldingLibraryObject interface.

Class Hierarchy

Declaration syntax

IMcadSymbolLibraryObject
    IMcadWeldingLibraryObject
Visual Basic
Public Interface IMcadWeldingLibraryObject
Inherits IMcadSymbolLibraryObject
Library

SymBBAuto Library

Links
IMcadWeldingLibraryObject Members, SymBBAuto Library, Class Hierarchy


IMcadWeldingLibraryObject Members

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject Members
IMcadWeldingLibraryObject Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWeldingLibraryObject.

Interface

IMcadWeldingLibraryObject Interface

Methods
Name | Description
ArrowSideReqValue | Get the arrow side requirement value of welding library object.
OtherSideReqValue | Get the requirement value for other side of welding symbol type.
RequirementValue | Get the main requirement value for welding symbol type.
setIsDefault | Change the default of this object.
Type | Get the type of the symbol for a weld symbol.
Properties
Name | Description
AreaType | Get the type of supplementary weld symbol describing the weld area.
AssociationType | Get the weld association type for a welding library object.
ClosedTail | Get whether the tail is closed for a welding library object.
entryName | Specifies the name of a symbol library object.
FieldWeld | Get whether the field weld is set for a welding library object.
IdentificationLine | Get the location of the identification line for a welding library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.
Links
IMcadWeldingLibraryObject Interface, Legend, Methods, Properties


IMcadWeldingLibraryObject::AreaType Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::AreaType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::AreaType Property
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the type of supplementary weld symbol describing the weld area.

Visual Basic
Property AreaType() As McadWeldSymbolType*
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::AssociationType Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::AssociationType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::AssociationType Property
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the weld association type for a welding library object.

Visual Basic
Property AssociationType() As McadWeldAssociation*
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::ClosedTail Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::ClosedTail Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::ClosedTail Property
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get whether the tail is closed for a welding library object.

Visual Basic
Property ClosedTail() As VARIANT_BOOL*
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::FieldWeld Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::FieldWeld Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::FieldWeld Property
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get whether the field weld is set for a welding library object.

Visual Basic
Property FieldWeld() As VARIANT_BOOL*
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::IdentificationLine Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::IdentificationLine Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::IdentificationLine Property
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the location of the identification line for a welding library object.

Visual Basic
Property IdentificationLine() As McadIdentificationType*
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::ArrowSideReqValue Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::ArrowSideReqValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::ArrowSideReqValue Method
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the arrow side requirement value of welding library object.

Visual Basic
Sub ArrowSideReqValue(variable As McadWeldingRequirement, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out,retval] BSTR)
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::OtherSideReqValue Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::OtherSideReqValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::OtherSideReqValue Method
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the requirement value for other side of welding symbol type.

Visual Basic
Sub OtherSideReqValue(variable As McadWeldingRequirement, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, pVal As [out,retval] BSTR)
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::RequirementValue Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::RequirementValue Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::RequirementValue Method
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the main requirement value for welding symbol type.

Visual Basic
Sub RequirementValue(variable As McadWeldingRequirement, pVal As [out,retval] BSTR)
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::setIsDefault Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::setIsDefault Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::setIsDefault Method
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Change the default of this object.

Visual Basic
Sub setIsDefault(symbolStandardClassName As String, Val As VARIANT_BOOL)
Parameters
Parameters | Description
symbolStandardClassName | Symbol standard class name
Val | True or False
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingLibraryObject::Type Method

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject::Type Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject::Type Method
IMcadWeldingLibraryObject Interface IMcadWeldingLibraryObject Members IMcadWeldingLibraryObject Interface Send Feedback
Summary

Get the type of the symbol for a weld symbol.

Visual Basic
Sub Type(ArrowSide As [in, defaultvalue(TRUE)] VARIANT_BOOL, isPrimary As [in, defaultvalue(TRUE)] VARIANT_BOOL, Symbol As [out, retval] McadWeldSymbolType)
Interface

IMcadWeldingLibraryObject Interface

Links
IMcadWeldingLibraryObject Interface, IMcadWeldingLibraryObject Members, IMcadWeldingLibraryObject Interface


IMcadWeldingStandard Interface

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard Interface
IMcadWeldingStandard Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
Visual Basic
Public Interface IMcadWeldingStandard
Inherits IMcadSymbolStandard3
Library

SymBBAuto Library

Links
IMcadWeldingStandard Members, SymBBAuto Library, Class Hierarchy


IMcadWeldingStandard Members

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard Members
IMcadWeldingStandard Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWeldingStandard.

Interface

IMcadWeldingStandard Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadWeldingStandard Interface, Legend, Methods, Properties


IMcadWeldingStandard::AvailableBackingSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::AvailableBackingSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::AvailableBackingSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets the list of backing weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableBackingSymbols() As VARIANT*
Remarks

The OfferedBackingSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::AvailableContourSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::AvailableContourSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::AvailableContourSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets the list of contour weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableContourSymbols() As VARIANT*
Remarks

The OfferedContourSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::AvailableWeldSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::AvailableWeldSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::AvailableWeldSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets the list of weld symbols that are available for backing symbols referencing this standard.

Visual Basic
Property AvailableWeldSymbols() As VARIANT*
Remarks

The OfferedWeldSymbols property specifies which of these available symbol types are offered during symbol creation and editing.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::ClosedTailAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::ClosedTailAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::ClosedTailAllowed Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets whether a closed tail is allowed for symbols referencing this standard.

Visual Basic
Property ClosedTailAllowed() As VARIANT_BOOL*
Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::IdentificationLineAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::IdentificationLineAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::IdentificationLineAllowed Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property IdentificationLineAllowed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::IdentificationLineGap Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::IdentificationLineGap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::IdentificationLineGap Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the gap distance between identification lines for weld symbols referencing this standard.

Visual Basic
Property IdentificationLineGap() As double
Remarks

This property is a Double.

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::IdentificationLinetype Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::IdentificationLinetype Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::IdentificationLinetype Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the linetype of the identification line for weld symbols referencing this standard.

Visual Basic
Property IdentificationLinetype() As IAcadLineType*
Remarks
  • This property type is AcadLineType object.
  • AcadLineType (LineType) object is an object in the AutoCAD ActiveX Automation. This object specifies the line characteristics consisting of combinations of dashes, dots, and spaces.
Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::IdentificationLinetypeName Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::IdentificationLinetypeName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::IdentificationLinetypeName Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the linetype name of the identification line for weld symbols referencing this standard.

Visual Basic
Property IdentificationLinetypeName() As String
Remarks

This property is a String.

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::MultipleSymbolsAllowed Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::MultipleSymbolsAllowed Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::MultipleSymbolsAllowed Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.

Visual Basic
Property MultipleSymbolsAllowed() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::OfferedBackingSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::OfferedBackingSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::OfferedBackingSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.

Visual Basic
Property OfferedBackingSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableBackingSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::OfferedContourSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::OfferedContourSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::OfferedContourSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the list of contour symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedContourSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableContourSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard::OfferedWeldSymbols Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard::OfferedWeldSymbols Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard::OfferedWeldSymbols Property
IMcadWeldingStandard Interface IMcadWeldingStandard Members IMcadWeldingStandard Interface Send Feedback
Summary

Specifies the list of weld symbols that are offered for symbols created referencing this standard.

Visual Basic
Property OfferedWeldSymbols() As VARIANT
Remarks

If symbol types are specified that are not in the list of weld symbols available for this standard, as specified by AvailableWeldSymbols, they are ignored.

This property is a Variant (array of McadWeldSymbolType enumeration).

Interface

IMcadWeldingStandard Interface

Links
IMcadWeldingStandard Interface, IMcadWeldingStandard Members, IMcadWeldingStandard Interface


IMcadWeldingStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard2 Interface
IMcadWeldingStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

A weld symbol standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3
Visual Basic
Public Interface IMcadWeldingStandard2
Inherits IMcadWeldingStandard
Library

SymBBAuto Library

Links
IMcadWeldingStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadWeldingStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard2 Members
IMcadWeldingStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWeldingStandard2.

Interface

IMcadWeldingStandard2 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number
Links
IMcadWeldingStandard2 Interface, Legend, Methods, Properties


IMcadWeldingStandard2::WeldProcessPrefix Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2::WeldProcessPrefix Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard2::WeldProcessPrefix Property
IMcadWeldingStandard2 Interface IMcadWeldingStandard2 Members IMcadWeldingStandard2 Interface Send Feedback
Summary

Specifies the prefix string to prepend to the process number

Visual Basic
Property WeldProcessPrefix() As BSTR*
Interface

IMcadWeldingStandard2 Interface

Links
IMcadWeldingStandard2 Interface, IMcadWeldingStandard2 Members, IMcadWeldingStandard2 Interface


IMcadWeldingStandard3 Interface

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3 Interface MG2015New
IMcadWeldingStandard3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

Use this class to handle settings to weld symbols in current standard.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3
Visual Basic
Public Interface IMcadWeldingStandard3
Inherits IMcadWeldingStandard2
Library

SymBBAuto Library

Links
IMcadWeldingStandard3 Members, SymBBAuto Library, Class Hierarchy


IMcadWeldingStandard3 Members

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3 Members
IMcadWeldingStandard3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadWeldingStandard3.

Interface

IMcadWeldingStandard3 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
ProcessGap | Specifies the scale factor applied to symbols within a welding symbol.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ScaleFactor | Specifies the gap between the 1st and 2nd welding processes within a welding symbol.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number
Links
IMcadWeldingStandard3 Interface, Legend, Methods, Properties


IMcadWeldingStandard3::ProcessGap Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3::ProcessGap Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3::ProcessGap Property
IMcadWeldingStandard3 Interface IMcadWeldingStandard3 Members IMcadWeldingStandard3 Interface Send Feedback
Summary

Specifies the scale factor applied to symbols within a welding symbol.

Visual Basic
Property ProcessGap() As double
Interface

IMcadWeldingStandard3 Interface

Links
IMcadWeldingStandard3 Interface, IMcadWeldingStandard3 Members, IMcadWeldingStandard3 Interface


IMcadWeldingStandard3::ScaleFactor Property

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3::ScaleFactor Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3::ScaleFactor Property
IMcadWeldingStandard3 Interface IMcadWeldingStandard3 Members IMcadWeldingStandard3 Interface Send Feedback
Summary

Specifies the gap between the 1st and 2nd welding processes within a welding symbol.

Visual Basic
Property ScaleFactor() As double
Interface

IMcadWeldingStandard3 Interface

Links
IMcadWeldingStandard3 Interface, IMcadWeldingStandard3 Members, IMcadWeldingStandard3 Interface


IMcadBorder2 Interface

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2 Interface
IMcadBorder2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadBorder2.

Class Hierarchy

Declaration syntax

IMcadBorder
    IMcadBorder2
Visual Basic
Public Interface IMcadBorder2
Inherits IMcadBorder
Library

SymBBAuto Library

Links
IMcadBorder2 Members, SymBBAuto Library, Class Hierarchy


IMcadBorder2 Members

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2 Members
IMcadBorder2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadBorder2.

Interface

IMcadBorder2 Interface

Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
BlockId | This is BlockId, a member of class IMcadBorder2.
BlockId32 | This is BlockId32, a member of class IMcadBorder2.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.
Links
IMcadBorder2 Interface, Legend, Methods, Properties


IMcadBorder2::BlockId Property

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2::BlockId Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2::BlockId Property
IMcadBorder2 Interface IMcadBorder2 Members IMcadBorder2 Interface Send Feedback
Summary

This is BlockId, a member of class IMcadBorder2.

Visual Basic
Property BlockId() As LONG_PTR*
Interface

IMcadBorder2 Interface

Links
IMcadBorder2 Interface, IMcadBorder2 Members, IMcadBorder2 Interface


IMcadBorder2::BlockId32 Property

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2::BlockId32 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2::BlockId32 Property
IMcadBorder2 Interface IMcadBorder2 Members IMcadBorder2 Interface Send Feedback
Summary

This is BlockId32, a member of class IMcadBorder2.

Visual Basic
Property BlockId32() As LONG*
Interface

IMcadBorder2 Interface

Links
IMcadBorder2 Interface, IMcadBorder2 Members, IMcadBorder2 Interface


IMcadDatumIdentifier2 Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2 Interface
IMcadDatumIdentifier2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadDatumIdentifier2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3
Visual Basic
Public Interface IMcadDatumIdentifier2
Inherits IMcadDatumIdentifier
Library

SymBBAuto Library

Links
IMcadDatumIdentifier2 Members, SymBBAuto Library, Class Hierarchy


IMcadDatumIdentifier2 Members

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2 Members
IMcadDatumIdentifier2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumIdentifier2.

Interface

IMcadDatumIdentifier2 Interface

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.
Links
IMcadDatumIdentifier2 Interface, Legend, Methods, Properties


IMcadDatumIdentifier2::SurfExtLinesOffset Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2::SurfExtLinesOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2::SurfExtLinesOffset Property
IMcadDatumIdentifier2 Interface IMcadDatumIdentifier2 Members IMcadDatumIdentifier2 Interface Send Feedback
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.

Interface

IMcadDatumIdentifier2 Interface

Links
IMcadDatumIdentifier2 Interface, IMcadDatumIdentifier2 Members, IMcadDatumIdentifier2 Interface


IMcadDatumIdentifier2::SurfExtLinesOvershot Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2::SurfExtLinesOvershot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2::SurfExtLinesOvershot Property
IMcadDatumIdentifier2 Interface IMcadDatumIdentifier2 Members IMcadDatumIdentifier2 Interface Send Feedback
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double
Interface

IMcadDatumIdentifier2 Interface

Links
IMcadDatumIdentifier2 Interface, IMcadDatumIdentifier2 Members, IMcadDatumIdentifier2 Interface


IMcadDatumIdentifier2::AddStdCompliantLeader Method

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2::AddStdCompliantLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2::AddStdCompliantLeader Method
IMcadDatumIdentifier2 Interface IMcadDatumIdentifier2 Members IMcadDatumIdentifier2 Interface Send Feedback
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().

Interface

IMcadDatumIdentifier2 Interface

Links
IMcadDatumIdentifier2 Interface, IMcadDatumIdentifier2 Members, IMcadDatumIdentifier2 Interface


IMcadDatumIdentifier3 Interface

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3 Interface
IMcadDatumIdentifier3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadDatumIdentifier3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3
Visual Basic
Public Interface IMcadDatumIdentifier3
Inherits IMcadDatumIdentifier2
Library

SymBBAuto Library

Links
IMcadDatumIdentifier3 Members, SymBBAuto Library, Class Hierarchy


IMcadDatumIdentifier3 Members

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3 Members
IMcadDatumIdentifier3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadDatumIdentifier3.

Interface

IMcadDatumIdentifier3 Interface

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumNote | This is DatumNote, a member of class IMcadDatumIdentifier3.
FarSideStatus | This is FarSideStatus, a member of class IMcadDatumIdentifier3.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.
SymbolStandard | Specifies the symbol standard for a symbol.
ThreadNote | This is ThreadNote, a member of class IMcadDatumIdentifier3.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.
Links
IMcadDatumIdentifier3 Interface, Legend, Methods, Properties


IMcadDatumIdentifier3::DatumNote Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::DatumNote Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::DatumNote Property
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is DatumNote, a member of class IMcadDatumIdentifier3.

Visual Basic
Property DatumNote() As String
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadDatumIdentifier3::FarSideStatus Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::FarSideStatus Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::FarSideStatus Property
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is FarSideStatus, a member of class IMcadDatumIdentifier3.

Visual Basic
Property FarSideStatus() As VARIANT_BOOL
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadDatumIdentifier3::SurfIndLeaderArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::SurfIndLeaderArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::SurfIndLeaderArrowType Property
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadDatumIdentifier3::ThreadNote Property

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::ThreadNote Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::ThreadNote Property
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is ThreadNote, a member of class IMcadDatumIdentifier3.

Visual Basic
Property ThreadNote() As String
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.

Visual Basic
Sub AddLeaderWithSurfIndLeader(Points As VARIANT)
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadDatumIdentifier3::GetSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3::GetSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3::GetSurfIndLeader Method
IMcadDatumIdentifier3 Interface IMcadDatumIdentifier3 Members IMcadDatumIdentifier3 Interface Send Feedback
Summary

This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.

Visual Basic
Sub GetSurfIndLeader(pVal As [out, retval]VARIANT)
Interface

IMcadDatumIdentifier3 Interface

Links
IMcadDatumIdentifier3 Interface, IMcadDatumIdentifier3 Members, IMcadDatumIdentifier3 Interface


IMcadFCFStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2 Interface
IMcadFCFStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadFCFStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2
Visual Basic
Public Interface IMcadFCFStandard2
Inherits IMcadFCFStandard
Library

SymBBAuto Library

Links
IMcadFCFStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadFCFStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2 Members
IMcadFCFStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFCFStandard2.

Interface

IMcadFCFStandard2 Interface

Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadFCFStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFCFStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadFCFStandard2 Interface, Legend, Methods, Properties


IMcadFCFStandard2::SurfIndLeaderArrowScale Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2::SurfIndLeaderArrowScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2::SurfIndLeaderArrowScale Property
IMcadFCFStandard2 Interface IMcadFCFStandard2 Members IMcadFCFStandard2 Interface Send Feedback
Summary

This is SurfIndLeaderArrowScale, a member of class IMcadFCFStandard2.

Visual Basic
Property SurfIndLeaderArrowScale() As double
Interface

IMcadFCFStandard2 Interface

Links
IMcadFCFStandard2 Interface, IMcadFCFStandard2 Members, IMcadFCFStandard2 Interface


IMcadFCFStandard2::SurfIndLeaderArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2::SurfIndLeaderArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2::SurfIndLeaderArrowType Property
IMcadFCFStandard2 Interface IMcadFCFStandard2 Members IMcadFCFStandard2 Interface Send Feedback
Summary

This is SurfIndLeaderArrowType, a member of class IMcadFCFStandard2.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType
Interface

IMcadFCFStandard2 Interface

Links
IMcadFCFStandard2 Interface, IMcadFCFStandard2 Members, IMcadFCFStandard2 Interface


IMcadFeatureControlFrame3 Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3 Interface
IMcadFeatureControlFrame3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadFeatureControlFrame3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4
Visual Basic
Public Interface IMcadFeatureControlFrame3
Inherits IMcadFeatureControlFrame2
Library

SymBBAuto Library

Links
IMcadFeatureControlFrame3 Members, SymBBAuto Library, Class Hierarchy


IMcadFeatureControlFrame3 Members

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3 Members
IMcadFeatureControlFrame3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFeatureControlFrame3.

Interface

IMcadFeatureControlFrame3 Interface

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.
Links
IMcadFeatureControlFrame3 Interface, Legend, Methods, Properties


IMcadFeatureControlFrame3::SurfExtLinesOffset Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3::SurfExtLinesOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3::SurfExtLinesOffset Property
IMcadFeatureControlFrame3 Interface IMcadFeatureControlFrame3 Members IMcadFeatureControlFrame3 Interface Send Feedback
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.

Interface

IMcadFeatureControlFrame3 Interface

Links
IMcadFeatureControlFrame3 Interface, IMcadFeatureControlFrame3 Members, IMcadFeatureControlFrame3 Interface


IMcadFeatureControlFrame3::SurfExtLinesOvershot Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3::SurfExtLinesOvershot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3::SurfExtLinesOvershot Property
IMcadFeatureControlFrame3 Interface IMcadFeatureControlFrame3 Members IMcadFeatureControlFrame3 Interface Send Feedback
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double
Interface

IMcadFeatureControlFrame3 Interface

Links
IMcadFeatureControlFrame3 Interface, IMcadFeatureControlFrame3 Members, IMcadFeatureControlFrame3 Interface


IMcadFeatureControlFrame3::AddStdCompliantLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3::AddStdCompliantLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3::AddStdCompliantLeader Method
IMcadFeatureControlFrame3 Interface IMcadFeatureControlFrame3 Members IMcadFeatureControlFrame3 Interface Send Feedback
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().

Interface

IMcadFeatureControlFrame3 Interface

Links
IMcadFeatureControlFrame3 Interface, IMcadFeatureControlFrame3 Members, IMcadFeatureControlFrame3 Interface


IMcadFeatureControlFrame4 Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4 Interface
IMcadFeatureControlFrame4 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadFeatureControlFrame4.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4
Visual Basic
Public Interface IMcadFeatureControlFrame4
Inherits IMcadFeatureControlFrame3
Library

SymBBAuto Library

Links
IMcadFeatureControlFrame4 Members, SymBBAuto Library, Class Hierarchy


IMcadFeatureControlFrame4 Members

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4 Members
IMcadFeatureControlFrame4 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFeatureControlFrame4.

Interface

IMcadFeatureControlFrame4 Interface

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AddSurfIndLeader
This is AddSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadFeatureControlFrame4.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
RemoveSurfIndLeader
This is RemoveSurfIndLeader, a member of class IMcadFeatureControlFrame4.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFeatureControlFrame4.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.
Links
IMcadFeatureControlFrame4 Interface, Legend, Methods, Properties


IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property
IMcadFeatureControlFrame4 Interface IMcadFeatureControlFrame4 Members IMcadFeatureControlFrame4 Interface Send Feedback
Summary

This is SurfIndLeaderArrowType, a member of class IMcadFeatureControlFrame4.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType
Interface

IMcadFeatureControlFrame4 Interface

Links
IMcadFeatureControlFrame4 Interface, IMcadFeatureControlFrame4 Members, IMcadFeatureControlFrame4 Interface


IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method
IMcadFeatureControlFrame4 Interface IMcadFeatureControlFrame4 Members IMcadFeatureControlFrame4 Interface Send Feedback
Summary

This is AddLeaderWithSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub AddLeaderWithSurfIndLeader(Points As VARIANT)
Interface

IMcadFeatureControlFrame4 Interface

Links
IMcadFeatureControlFrame4 Interface, IMcadFeatureControlFrame4 Members, IMcadFeatureControlFrame4 Interface


IMcadFeatureControlFrame4::AddSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4::AddSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4::AddSurfIndLeader Method
IMcadFeatureControlFrame4 Interface IMcadFeatureControlFrame4 Members IMcadFeatureControlFrame4 Interface Send Feedback
Summary

This is AddSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub AddSurfIndLeader(Points As VARIANT)
Interface

IMcadFeatureControlFrame4 Interface

Links
IMcadFeatureControlFrame4 Interface, IMcadFeatureControlFrame4 Members, IMcadFeatureControlFrame4 Interface


IMcadFeatureControlFrame4::GetSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4::GetSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4::GetSurfIndLeader Method
IMcadFeatureControlFrame4 Interface IMcadFeatureControlFrame4 Members IMcadFeatureControlFrame4 Interface Send Feedback
Summary

This is GetSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub GetSurfIndLeader(pVal As [out, retval] VARIANT)
Interface

IMcadFeatureControlFrame4 Interface

Links
IMcadFeatureControlFrame4 Interface, IMcadFeatureControlFrame4 Members, IMcadFeatureControlFrame4 Interface


IMcadFeatureControlFrame4::RemoveSurfIndLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4::RemoveSurfIndLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4::RemoveSurfIndLeader Method
IMcadFeatureControlFrame4 Interface IMcadFeatureControlFrame4 Members IMcadFeatureControlFrame4 Interface Send Feedback
Summary

This is RemoveSurfIndLeader, a member of class IMcadFeatureControlFrame4.

Visual Basic
Sub RemoveSurfIndLeader()
Interface

IMcadFeatureControlFrame4 Interface

Links
IMcadFeatureControlFrame4 Interface, IMcadFeatureControlFrame4 Members, IMcadFeatureControlFrame4 Interface


IMcadFeatureIdentifier2 Interface

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2 Interface
IMcadFeatureIdentifier2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadFeatureIdentifier2.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2
Visual Basic
Public Interface IMcadFeatureIdentifier2
Inherits IMcadFeatureIdentifier
Library

SymBBAuto Library

Links
IMcadFeatureIdentifier2 Members, SymBBAuto Library, Class Hierarchy


IMcadFeatureIdentifier2 Members

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2 Members
IMcadFeatureIdentifier2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadFeatureIdentifier2.

Interface

IMcadFeatureIdentifier2 Interface

Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.
Links
IMcadFeatureIdentifier2 Interface, Legend, Methods, Properties


IMcadFeatureIdentifier2::SurfExtLinesOffset Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2::SurfExtLinesOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2::SurfExtLinesOffset Property
IMcadFeatureIdentifier2 Interface IMcadFeatureIdentifier2 Members IMcadFeatureIdentifier2 Interface Send Feedback
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.

Interface

IMcadFeatureIdentifier2 Interface

Links
IMcadFeatureIdentifier2 Interface, IMcadFeatureIdentifier2 Members, IMcadFeatureIdentifier2 Interface


IMcadFeatureIdentifier2::SurfExtLinesOvershot Property

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2::SurfExtLinesOvershot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2::SurfExtLinesOvershot Property
IMcadFeatureIdentifier2 Interface IMcadFeatureIdentifier2 Members IMcadFeatureIdentifier2 Interface Send Feedback
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double
Interface

IMcadFeatureIdentifier2 Interface

Links
IMcadFeatureIdentifier2 Interface, IMcadFeatureIdentifier2 Members, IMcadFeatureIdentifier2 Interface


IMcadFeatureIdentifier2::AddStdCompliantLeader Method

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2::AddStdCompliantLeader Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2::AddStdCompliantLeader Method
IMcadFeatureIdentifier2 Interface IMcadFeatureIdentifier2 Members IMcadFeatureIdentifier2 Interface Send Feedback
Summary

Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
Visual Basic
Sub AddStdCompliantLeader(Geometry As IDispatch, ArrowheadLocation As VARIANT, point As VARIANT, ViewId As [in, optional] VARIANT)
Parameters
Parameters | Description
Geometry | Requires the attached geometry as an input. It's value is never NULL.
ArrowheadLocation | Position of the arrowhead.
point | Position of the symbol.
ViewId | Optional. If without the view Id, this method is used to create the geometry association in model space. The void pointer is the pointer to the MCAD API geometry key.
Remarks

After calling this, you need not call attachGeometry().

Interface

IMcadFeatureIdentifier2 Interface

Links
IMcadFeatureIdentifier2 Interface, IMcadFeatureIdentifier2 Members, IMcadFeatureIdentifier2 Interface


IMcadIdentifierStandard2 Interface

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2 Interface
IMcadIdentifierStandard2 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadIdentifierStandard2.

Class Hierarchy

Declaration syntax

IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2
Visual Basic
Public Interface IMcadIdentifierStandard2
Inherits IMcadIdentifierStandard
Library

SymBBAuto Library

Links
IMcadIdentifierStandard2 Members, SymBBAuto Library, Class Hierarchy


IMcadIdentifierStandard2 Members

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2 Members
IMcadIdentifierStandard2 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadIdentifierStandard2.

Interface

IMcadIdentifierStandard2 Interface

Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
FarSideLeaderLineType | This is FarSideLeaderLineType, a member of class IMcadIdentifierStandard2.
FarSideLeaderLineTypeName | This is FarSideLeaderLineTypeName, a member of class IMcadIdentifierStandard2.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadIdentifierStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadIdentifierStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
Links
IMcadIdentifierStandard2 Interface, Legend, Methods, Properties


IMcadIdentifierStandard2::FarSideLeaderLineType Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2::FarSideLeaderLineType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2::FarSideLeaderLineType Property
IMcadIdentifierStandard2 Interface IMcadIdentifierStandard2 Members IMcadIdentifierStandard2 Interface Send Feedback
Summary

This is FarSideLeaderLineType, a member of class IMcadIdentifierStandard2.

Visual Basic
Property FarSideLeaderLineType() As IAcadLineType*
Interface

IMcadIdentifierStandard2 Interface

Links
IMcadIdentifierStandard2 Interface, IMcadIdentifierStandard2 Members, IMcadIdentifierStandard2 Interface


IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property
IMcadIdentifierStandard2 Interface IMcadIdentifierStandard2 Members IMcadIdentifierStandard2 Interface Send Feedback
Summary

This is FarSideLeaderLineTypeName, a member of class IMcadIdentifierStandard2.

Visual Basic
Property FarSideLeaderLineTypeName() As String
Interface

IMcadIdentifierStandard2 Interface

Links
IMcadIdentifierStandard2 Interface, IMcadIdentifierStandard2 Members, IMcadIdentifierStandard2 Interface


IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property
IMcadIdentifierStandard2 Interface IMcadIdentifierStandard2 Members IMcadIdentifierStandard2 Interface Send Feedback
Summary

This is SurfIndLeaderArrowScale, a member of class IMcadIdentifierStandard2.

Visual Basic
Property SurfIndLeaderArrowScale() As double
Interface

IMcadIdentifierStandard2 Interface

Links
IMcadIdentifierStandard2 Interface, IMcadIdentifierStandard2 Members, IMcadIdentifierStandard2 Interface


IMcadIdentifierStandard2::SurfIndLeaderArrowType Property

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2::SurfIndLeaderArrowType Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2::SurfIndLeaderArrowType Property
IMcadIdentifierStandard2 Interface IMcadIdentifierStandard2 Members IMcadIdentifierStandard2 Interface Send Feedback
Summary

This is SurfIndLeaderArrowType, a member of class IMcadIdentifierStandard2.

Visual Basic
Property SurfIndLeaderArrowType() As McadArrowType
Interface

IMcadIdentifierStandard2 Interface

Links
IMcadIdentifierStandard2 Interface, IMcadIdentifierStandard2 Members, IMcadIdentifierStandard2 Interface


IMcadPartReferences Interface

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences Interface
IMcadPartReferences Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadPartReferences.

Class Hierarchy

Declaration syntax

IMcadPartReferences
Visual Basic
Public Interface IMcadPartReferences
Inherits IDispatch
Library

SymBBAuto Library

Links
IMcadPartReferences Members, SymBBAuto Library, Class Hierarchy


IMcadPartReferences Members

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences Members
IMcadPartReferences Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadPartReferences.

Interface

IMcadPartReferences Interface

Methods
Name | Description
Add | This is Add, a member of class IMcadPartReferences.
Item | This is Item, a member of class IMcadPartReferences.
Remove | This is Remove, a member of class IMcadPartReferences.
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadPartReferences.
Application | This is Application, a member of class IMcadPartReferences.
Count | This is Count, a member of class IMcadPartReferences.
Links
IMcadPartReferences Interface, Legend, Methods, Properties


IMcadPartReferences::_NewEnum Property

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::_NewEnum Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::_NewEnum Property
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is _NewEnum, a member of class IMcadPartReferences.

Visual Basic
Property _NewEnum() As LPUNKNOWN*
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadPartReferences::Application Property

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::Application Property
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is Application, a member of class IMcadPartReferences.

Visual Basic
Property Application() As IDispatch**
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadPartReferences::Count Property

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::Count Property
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is Count, a member of class IMcadPartReferences.

Visual Basic
Property Count() As long*
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadPartReferences::Add Method

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::Add Method
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is Add, a member of class IMcadPartReferences.

Visual Basic
Sub Add(Item As IMcadPartReference)
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadPartReferences::Item Method

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::Item Method
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is Item, a member of class IMcadPartReferences.

Visual Basic
Sub Item(Index As long, Item As [out, retval] IMcadPartReference*)
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadPartReferences::Remove Method

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences::Remove Method
IMcadPartReferences Interface IMcadPartReferences Members IMcadPartReferences Interface Send Feedback
Summary

This is Remove, a member of class IMcadPartReferences.

Visual Basic
Sub Remove(Index As long)
Interface

IMcadPartReferences Interface

Links
IMcadPartReferences Interface, IMcadPartReferences Members, IMcadPartReferences Interface


IMcadSurfaceTexture3 Interface

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3 Interface
IMcadSurfaceTexture3 Members SymBBAuto Library Class Hierarchy Send Feedback
Summary

This is class IMcadSurfaceTexture3.

Class Hierarchy

Declaration syntax

IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4
Visual Basic
Public Interface IMcadSurfaceTexture3
Inherits IMcadSurfaceTexture2
Library

SymBBAuto Library

Links
IMcadSurfaceTexture3 Members, SymBBAuto Library, Class Hierarchy


IMcadSurfaceTexture3 Members

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3 Members
IMcadSurfaceTexture3 Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IMcadSurfaceTexture3.

Interface

IMcadSurfaceTexture3 Interface

Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.
Links
IMcadSurfaceTexture3 Interface, Legend, Methods, Properties


IMcadSurfaceTexture3::SurfExtLinesOffset Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3::SurfExtLinesOffset Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3::SurfExtLinesOffset Property
IMcadSurfaceTexture3 Interface IMcadSurfaceTexture3 Members IMcadSurfaceTexture3 Interface Send Feedback
Summary

Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.

Visual Basic
Property SurfExtLinesOffset() As double
Remarks

If the symbol is attached to a dimension object, the offset gap is always 0, and cannot be changed.

Interface

IMcadSurfaceTexture3 Interface

Links
IMcadSurfaceTexture3 Interface, IMcadSurfaceTexture3 Members, IMcadSurfaceTexture3 Interface


IMcadSurfaceTexture3::SurfExtLinesOvershot Property

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3::SurfExtLinesOvershot Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3::SurfExtLinesOvershot Property
IMcadSurfaceTexture3 Interface IMcadSurfaceTexture3 Members IMcadSurfaceTexture3 Interface Send Feedback
Summary

Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.

Visual Basic
Property SurfExtLinesOvershot() As double
Interface

IMcadSurfaceTexture3 Interface

Links
IMcadSurfaceTexture3 Interface, IMcadSurfaceTexture3 Members, IMcadSurfaceTexture3 Interface


McadAlignmentType Enumeration

You are here: API Reference > SymBBAuto Library > McadAlignmentType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAlignmentType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available alignment types for a drawing document element, such as captions and data in a column of a BOM database.

Visual Basic
Public Enum McadAlignmentType
  sbLeft = 0
  sbCenter = 1
  sbRight = 2
End Enum
Members
Members | Description
sbLeft | Sets Left as the alignment type for a drawing document element.
sbCenter | Sets Center as the alignment type for a drawing document element.
sbRight | Sets Right as the alignment type for a drawing document element.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadAnnotViewLabelPositionType Enumeration

You are here: API Reference > SymBBAuto Library > McadAnnotViewLabelPositionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAnnotViewLabelPositionType Enumeration
SymBBAuto Library Send Feedback
Summary

McadAnnotViewLabelPositionType defines position of annotation view label.

Visual Basic
Public Enum McadAnnotViewLabelPositionType
  sbAnnotLabelBelow = 1
  sbAnnotLabelAbove = 2
End Enum
Members
Members | Description
sbAnnotLabelBelow | Label is below annotation view sub view
sbAnnotLabelAbove | Label is above annotation view sub view
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadArrowType Enumeration

You are here: API Reference > SymBBAuto Library > McadArrowType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadArrowType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available arrow types for a symbol leader.

sbNoArrow : Indicates that no arrow is attached to the symbol leader.

sbArrowOpen : Indicates that the open arrow is attached to the symbol leader.

sbArrowOpen15 : Indicates that the open 15-degree arrow is attached to the symbol leader.

sbArrowOpen30 : Indicates that the open 30-dergee arrow is attached to the symbol leader.

sbArrowOpen60 : Indicates that the open 60-degree arrow is attached to the symbol leader.

sbArrowOpen90 : Indicates that the open 90-degree arrow is attached to the symbol leader.

sbArrowEmpty : Indicates that the empty arrow is attached to the symbol leader.

sbArrowEmpty15 : Indicates that the empty 15-degree arrow is attached to the symbol leader.

sbArrowEmpty30 : Indicates that the empty 30-degree arrow is attached to the symbol leader.

sbArrowEmpty60 : Indicates that the empty 60-degree arrow is attached to the symbol leader.

sbArrowEmpty90 : Indicates that the empty 90-degree arrow is attached to the symbol leader.

sbArrowClosed : Indicates that the closed arrow is attached to the symbol leader.

sbArrowClosed15 : Indicates that the closed 15-degree arrow is attached to the symbol leader.

sbArrowClosed30 : Indicates that the closed 30-degree arrow is attached to the symbol leader.

sbArrowClosed60 : Indicates that the closed 60-degree arrow is attached to the symbol leader.

sbArrowClosed90 : Indicates that the closed 90-degree arrow is attached to the symbol leader.

sbArrowFilled : Indicates that the filled arrow is attached to the symbol leader.

sbArrowFilled15 : Indicates that the filled 15-degree arrow is attached to the symbol leader.

sbArrowFilled30 : Indicates that the filled 30-degree arrow is attached to the symbol leader.

sbArrowFilled60 : Indicates that the filled 60-degree arrow is attached to the symbol leader.

sbArrowFilled90 : Indicates that the filled 90-degree arrow is attached to the symbol leader.

sbArrowBoxBlank : Indicates that the blank arrow is attached to the symbol leader.

sbArrowBoxFilled : Indicates that the box filled arrow is attached to the symbol leader.

sbArrowDatumBlank45 : Indicates that the datum blank 45-degree arrow is attached to the symbol leader.

sbArrowDatumFilled45 : Indicates that the datum filled 45-degree arrow is attached to the symbol leader.

sbArrowDatumBlank60 : Indicates that the datum blank 60-degree arrow is attached to the symbol leader.

sbArrowDatumFilled60 : Indicates that the datum blank 90-degree arrow is attached to the symbol leader.

sbArrowDot : Indicates that the dot arrow is attached to the symbol leader.

sbArrowDotBlank : Indicates that the dot blank arrow is attached to the symbol leader.

sbArrowOblique : Indicates that the oblique arrow is attached to the symbol leader.

sbArrowOrigin : Indicates that the origin arrow is attached to the symbol leader.

sbByStandard : Indicates that the arrow is attached to the symbol leader by standard.

sbArrowDatumThickLine : Indicates that the datum thick line arrow is attached to the symbol leader.

sbUserArrowType : Indicates that the user-defined arrow is attached to the symbol leader.

sbArrowDotSmall : Indicates that the dot small arrow is attached to the symbol leader.

sbArrowDotBlankSmall : Indicates that the dot blank arrow is attached to the symbol leader.

Visual Basic
Public Enum McadArrowType
  sbNoArrow = 0
  sbArrowOpen = 1
  sbArrowOpen15 = 2
  sbArrowOpen30 = 3
  sbArrowOpen60 = 4
  sbArrowOpen90 = 5
  sbArrowEmpty = 6
  sbArrowEmpty15 = 7
  sbArrowEmpty30 = 8
  sbArrowEmpty60 = 9
  sbArrowEmpty90 = 10
  sbArrowClosed = 11
  sbArrowClosed15 = 12
  sbArrowClosed30 = 13
  sbArrowClosed60 = 14
  sbArrowClosed90 = 15
  sbArrowFilled = 16
  sbArrowFilled15 = 17
  sbArrowFilled30 = 18
  sbArrowFilled60 = 19
  sbArrowFilled90 = 20
  sbArrowBoxBlank = 21
  sbArrowBoxFilled = 22
  sbArrowDatumBlank45 = 23
  sbArrowDatumFilled45 = 24
  sbArrowDatumBlank60 = 25
  sbArrowDatumFilled60 = 26
  sbArrowDot = 27
  sbArrowDotBlank = 28
  sbArrowOblique = 29
  sbArrowOrigin = 30
  sbByStandard = 31
  sbArrowDatumThickLine = 32
  sbArrowDotSmall = 33
  sbArrowDotBlankSmall = 34
  sbArrowFilledHalf = 35
  sbArrowEmptyHalf = 36
  sbArrowAcadArchTick = 37
  sbArrowAcadBoxBlank = 38
  sbArrowAcadBoxFilled = 39
  sbArrowAcadClosed = 40
  sbArrowAcadClosedBlank = 41
  sbArrowAcadClosedFilled = 42
  sbArrowAcadDatumBlank = 43
  sbArrowAcadDatumFilled = 44
  sbArrowAcadDot = 45
  sbArrowAcadDotBlank = 46
  sbArrowAcadDotSmall = 47
  sbArrowAcadIntegral = 48
  sbArrowAcadNone = 49
  sbArrowAcadOblique = 50
  sbArrowAcadOpen = 51
  sbArrowAcadOpen30 = 52
  sbArrowAcadOpen90 = 53
  sbArrowAcadOrigin = 54
  sbArrowAcadOrigin2 = 55
  sbArrowAcadSmall = 56
  sbUserArrowDialog = 57
  sbVaries = 58
  sbArrowFilled20 = 59
  sbUserArrowType = 1000
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadAttachmentPoint Enumeration

You are here: API Reference > SymBBAuto Library > McadAttachmentPoint Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttachmentPoint Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available points for attaching a leader to symbols.

sbTopLeft : Places the leader to the top-left of symbols.

sbBottomLeft : Places the leader to the bottom-left of symbols.

sbBottomRight : Places the leader to the bottom-right of symbols.

sbTopRight : Places the leader to the top-right of symbols.

Visual Basic
Public Enum McadAttachmentPoint
  sbTopLeft = 0
  sbBottomLeft = 1
  sbBottomRight = 2
  sbTopRight = 3
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadAttachmentType Enumeration

You are here: API Reference > SymBBAuto Library > McadAttachmentType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttachmentType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available leader attachment point types for symbols.

sbToCenter : Attaches the leader to the center of symbols.

sbToExtents : Attaches the leader to the extents of symbols.

sbToOrigin : Attaches the leader to the origin of symbols in the coordinate system.

Visual Basic
Public Enum McadAttachmentType
  sbToCenter = 0
  sbToExtents = 1
  sbToOrigin = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadAttachPosition Enumeration

You are here: API Reference > SymBBAuto Library > McadAttachPosition Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttachPosition Enumeration
SymBBAuto Library Send Feedback
Summary

This is record McadAttachPosition.

Visual Basic
Public Enum McadAttachPosition
  sbAttachLeft = 0
  sbAttachRight = 1
  sbAttachTop = 2
  sbAttachBottom = 3
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadAttributeAssociativity Enumeration

You are here: API Reference > SymBBAuto Library > McadAttributeAssociativity Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadAttributeAssociativity Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available behaviors of the attribute when the object that the attribute is attached to is copied.

mcDefault : If the McadAttributeAssociativity element is not specified in pertinent methods, the default associativity behavior is used.

mcCopyAlways : Indicates this attribute is always copied.

mcShareAlways : Indicates this attribute is always shared.

mcIgnoreAlways : Indicates this attribute is always ignored.

Visual Basic
Public Enum McadAttributeAssociativity
  mcDefault = 0
  mcCopyAlways = 1
  mcShareAlways = 2
  mcIgnoreAlways = 3
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBalloonType Enumeration

You are here: API Reference > SymBBAuto Library > McadBalloonType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBalloonType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available balloon patterns that can be used to override when creating new balloon symbols by a specific standard.

sbByStandardBalloon : Sets the standard option as the balloon pattern in a drawing document. The standard balloon is defined by the drawing manager.

sbNoBalloon :

Sets the open option as the balloon pattern in a drawing document.

sbCircularBalloon :

Sets the predefined Circular option as the balloon pattern in a drawing document.

sbCircular2Balloon :

Sets the predefined Circular2 option as the balloon pattern in a drawing document.

sbLinearBalloon :

Sets the predefined Linear option as the balloon pattern in a drawing document.

sbEmptyBalloon :

Sets the predefined zigzag option as the balloon pattern in a drawing document.

sbNAngleBalloon :

Sets the predefined polygon option as the balloon pattern in a drawing document.

sbUserBalloon : Sets the custom balloon as the balloon pattern in a drawing document.

Visual Basic
Public Enum McadBalloonType
  sbByStandardBalloon = 0
  sbNoBalloon = 1
  sbCircularBalloon = 2
  sbCircular2Balloon = 3
  sbLinearBalloon = 4
  sbEmptyBalloon = 5
  sbNAngleBalloon = 6
  sbZigZagBalloon = 7
  sbUserBalloon = 8
End Enum
Members
Members | Description
sbZigZagBalloon | Sets the predefined Zigzag option as the balloon pattern in a drawing document.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBOMExportFormatType Enumeration

You are here: API Reference > SymBBAuto Library > McadBOMExportFormatType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMExportFormatType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available BOM table export formats.

exTXT : Indicates the export format of text separated with tabulator.

exCSV : Indicates the export format of text separated with semicolon.

exHTML : Indicates the export format of HTML.

exMDB : Indicates the export format of the current Microsoft Access.

exMDB97 : Indicates the export format of Microsoft Access 97.

exEXCEL97 : Indicates the export format of Microsoft Excel 97.

exEXCEL95 : Indicates the export format of Microsoft Excel 95.

exDB5 : Indicates the export format of dBase 5.

exDBIV : Indicates the export format of dBase IV.

exDBIII : Indicates the export format of dBase III.

exFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0.

exFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6.

exFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5.

Visual Basic
Public Enum McadBOMExportFormatType
  exMDB = 1
  exMDB97 = 2
  exEXCEL97 = 3
  exEXCEL95 = 4
  exDB5 = 5
  exDBIV = 6
  exDBIII = 7
  exFOXVIS = 8
  exFOX26 = 9
  exFOX25 = 10
  exTXT = 11
  exCSV = 12
  exHTML = 13
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBOMImportFormatType Enumeration

You are here: API Reference > SymBBAuto Library > McadBOMImportFormatType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMImportFormatType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available BOM table import formats.

imMDB : Indicates the import format of the current Microsoft Access.

imEXCEL97 : Indicates the import format of Microsoft Excel 97.

imEXCEL95 : Indicates the import format of Microsoft Excel 95.

imDB5 : Indicates the export format of dBase 5.

imDBIV : Indicates the export format of dBase IV.

imDBIII : Indicates the export format of dBase III.

imimFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0.

imFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6.

imFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5.

imTXT : Indicates the export format of text separated with tabulator.

imCSV : Indicates the import format of HTML.

Visual Basic
Public Enum McadBOMImportFormatType
  imMDB = 1
  imEXCEL97 = 2
  imEXCEL95 = 3
  imDB5 = 4
  imDBIV = 5
  imDBIII = 6
  imimFOXVIS = 7
  imFOX26 = 8
  imFOX25 = 9
  imTXT = 10
  imCSV = 11
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBOMItemDefinitionType Enumeration

You are here: API Reference > SymBBAuto Library > McadBOMItemDefinitionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMItemDefinitionType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available BOM item definition types.

Unknown : Indicates that the BOM item definition type is unknown.

NonModal : Indicates that the BOM item definition type is User-Defined.

PartRef : Indicates that the BOM item definition type is AutoCAD Mechanical Part Reference.

BlockDef : Indicates that the BOM item definition type is Block Definition.

CompDef : Indicates that the BOM item definition type is AutoCAD Mechanical/Mechanical Desktop Component Definition.

Visual Basic
Public Enum McadBOMItemDefinitionType
  Unknown
  NonModal
  PartRef
  BlockDef
  CompDef
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBomOverrideType Enumeration

You are here: API Reference > SymBBAuto Library > McadBomOverrideType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBomOverrideType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerator for BOM override types.

Visual Basic
Public Enum McadBomOverrideType
  sbNoOverride = 0
  sbQtyOverride = 1
  sbFormulaOverride = 2
  sbImportOverride = 3
End Enum
Members
Members | Description
sbNoOverride | Has no bom override.
sbQtyOverride | Is a quantity override.
sbFormulaOverride | Is a formula override.
sbImportOverride | Is an import override.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBOMUOMType Enumeration

You are here: API Reference > SymBBAuto Library > McadBOMUOMType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBOMUOMType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available BOM UOM (Unit of Measurement) types.

Each : Indicates that the BOM UOM type is per item.

sqm : Indicates that the BOM UOM type is per each square meter.

sqcm : Indicates that the BOM UOM type is per each square centimeter.

sqft : Indicates that the BOM UOM type is per each square foot.

sqin : Indicates that the BOM UOM type is per each square inch.

gal : Indicates that the BOM UOM type is per gallon

qt : Indicates that the BOM UOM type is per qt.

lqd_oz : Indicates that the BOM UOM type is liquid ounce.

l : Indicates that the BOM UOM type is per liter.

ml : Indicates that the BOM UOM type is per milliliter.

yd : Indicates that the BOM UOM type is per yard.

ft : Indicates that the BOM UOM type is per foot.

in : Indicates that the BOM UOM type is per inch.

m : Indicates that the BOM UOM type is per meter.

cm : Indicates that the BOM UOM type is per centimeter.

mm : Indicates that the BOM UOM type is per millimeter.

lb : Indicates that the BOM UOM type is per pound.

oz : Indicates that the BOM UOM type is per ounce.

g : Indicates that the BOM UOM type is per gram.

mg : Indicates that the BOM UOM type is per milligram.

bx : Indicates that the BOM UOM type is per box.

Visual Basic
Public Enum McadBOMUOMType
  Each = 0
  sqm
  sqcm
  sqft
  sqin
  gal
  qt
  lqd_oz
  l
  ml
  yd
  ft
  in
  m
  cm
  mm
  lb
  oz
  g
  mg
  bx
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadColumnSplitStyle Enumeration

You are here: API Reference > SymBBAuto Library > McadColumnSplitStyle Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadColumnSplitStyle Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available column split styles for a Parts List.

sbSplitRows : Specifies that a Parts List is split by rows in a column split.

sbSplitSections : Specifies that a Parts List is split by sections in a column split.

Visual Basic
Public Enum McadColumnSplitStyle
  sbSplitRows = 0
  sbSplitSections = 1
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadColumnSplitWrap Enumeration

You are here: API Reference > SymBBAuto Library > McadColumnSplitWrap Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadColumnSplitWrap Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available column split wrap directions for a Parts List.

sbSplitLeft : Specifies that a Parts List wraps to the left in a column split.

sbSplitRight : Specifies that a Parts List wraps to the right in a column split.

Visual Basic
Public Enum McadColumnSplitWrap
  sbSplitLeft = 0
  sbSplitRight = 1
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadColumnType Enumeration

You are here: API Reference > SymBBAuto Library > McadColumnType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadColumnType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all column types available in this BOM database for drawing documents. This ColumnType element is the internal name of the column attribute.

sbPartID : Specifies the object ID of this BOM item.

sbItem : Specifies the item number for this BOM item.

sbQuantity : Specifies the quantity of part references for this BOM item.

sbPartListName : Specifies the parts list name that is created from this BOM database.

sbPartListPath : Specifies the path to store the parts list that is created from this BOM database.

sbDescription : Specifies the supplementary data for this BOM database.

sbDescription2 : Specifies the secondary supplementary data for this BOM database.

sbStandard : Specifies the standard that this BOM database is used in.

sbStandard2 : Specifies the secondary standard that this BOM database is used in.

sbMaterial : Specifies the material for assemblies that are created using Structure in this BOM database.

sbMaterial2 : Specifies the secondary material for assemblies that are created using structure in this BOM database.

sbUserID : Specifies who is currently editing this BOM database.

sbMass : Specifies the mass for assemblies that are created using structure in this BOM database.

sbPrice : Specifies the price for assemblies that are created using structure in this BOM database.

sbDimension : Specifies the dimension measurement for assemblies that are created using structure in this BOM database.

sbUser1 : Specifies the first user-defined column in this BOM database.

sbUser2 : Specifies the second user-defined column in this BOM database.

sbUser3 : Specifies the third user-defined column in this BOM database.

sbUser4 : Specifies the fourth user-defined column in this BOM database.

sbUser5 : Specifies the fifth user-defined column in this BOM database.

sbUser6 : Specifies the sixth user-defined column in this BOM database.

sbUser7 : Specifies the seventh user-defined column in this BOM database.

sbUser8 : Specifies the eighth user-defined column in this BOM database.

sbFilter : Specifies the filter for this BOM database.

sbNote : Specifies the note column to give additional information to this BOM database.

sbVendor : Specifies the vendor information that relates to this BOM database.

sbAssembly : Specifies the assembly that relates to this BOM database.

sbDrawingManagerID : Specifies the object ID of the drawing manager that relates to this BOM database.

sbName : Specifies the name of this BOM database.

sbUnknownType : Specifies the unknown column type that is being used in this BOM database.

Visual Basic
Public Enum McadColumnType
  sbPartID = 0
  sbItem = 1
  sbQuantity = 2
  sbPartListName = 3
  sbPartListPath = 4
  sbDescription = 5
  sbDescription2 = 6
  sbStandard = 7
  sbStandard2 = 8
  sbMaterial = 9
  sbMaterial2 = 10
  sbUserID = 11
  sbMass = 12
  sbPrice = 13
  sbDimension = 14
  sbUser1 = 15
  sbUser2 = 16
  sbUser3 = 17
  sbUser4 = 18
  sbUser5 = 19
  sbUser6 = 20
  sbUser7 = 21
  sbUser8 = 22
  sbFilter = 23
  sbNote = 24
  sbVendor = 25
  sbAssembly = 26
  sbDrawingManagerID = 27
  sbName = 28
  sbUnknownType = 29
  sbUnitOfMeasure = 30
  sbCategory = 31
  sbFormat = 32
  sbZone = 33
  sbComments = 34
  sbPartNumber = 35
  sbTotalMass = 36
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadDataType Enumeration

You are here: API Reference > SymBBAuto Library > McadDataType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDataType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all data types that can be used for columns in this BOM database.

sbGeneralText : Sets the general text as the data type for columns in this BOM database.

sbInteger : Sets Integer as the data type for columns in this BOM database.

sbReal : Sets Real as the data type for columns in this BOM database.

Visual Basic
Public Enum McadDataType
  sbGeneralText = 0
  sbInteger = 1
  sbReal = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadDetailSymbolStandardPropType Enumeration

You are here: API Reference > SymBBAuto Library > McadDetailSymbolStandardPropType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDetailSymbolStandardPropType Enumeration MG2013New
SymBBAuto Library Send Feedback
Summary

Enumerates the property types for detail view standard that can be set to ByStandard.

Visual Basic
Public Enum McadDetailSymbolStandardPropType
  sbDetailViewIdentifierTextStyle = 0
  sbDetailViewIdentifierTextColor = 1
  sbDetailViewIdentifierTextHeight = 2
  sbDetailViewSymbol = 3
  sbDetailViewSymbolColor = 4
  sbDetailViewBoundaryLineColor = 5
  sbDetailViewBoundaryLineType = 6
  sbDetailViewBoundaryLineWeight = 7
  sbDetailViewBorderLineColor = 8
  sbDetailViewBorderLineType = 9
  sbDetailViewBorderLineWeight = 10
  sbDetailViewConnectionLineColor = 11
  sbDetailViewConnectionLineType = 12
  sbDetailViewConnectionLineWeight = 13
  sbDetailViewLabelTextStyle = 14
  sbDetailViewLabelTextColor = 15
  sbDetailViewLabelTextHeight = 16
End Enum
Members
Members | Description
sbDetailViewIdentifierTextStyle | Identifier Text style property.
sbDetailViewIdentifierTextColor | Identifier Text color property.
sbDetailViewIdentifierTextHeight | Identifier Text height property.
sbDetailViewSymbol | Arrangment Symbol property.
sbDetailViewSymbolColor | Arrangment Symbol color property.
sbDetailViewBoundaryLineColor | Boundary line Line color property.
sbDetailViewBoundaryLineType | Boundary line Linetype property.
sbDetailViewBoundaryLineWeight | Boundary line Line weight property.
sbDetailViewBorderLineColor | Model edge Linecolor property.
sbDetailViewBorderLineType | Model edge Linetype property.
sbDetailViewBorderLineWeight | Model edge Line color property.
sbDetailViewConnectionLineColor | Connection line Line color property.
sbDetailViewConnectionLineType | Connection line Linetype property.
sbDetailViewConnectionLineWeight | Connection line Lineweight property.
sbDetailViewLabelTextStyle | Label Text style property.
sbDetailViewLabelTextColor | Label Textcolor property.
sbDetailViewLabelTextHeight | Label Textheight property.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadDirectionLayType Enumeration

You are here: API Reference > SymBBAuto Library > McadDirectionLayType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadDirectionLayType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available directions of machining lay specifications for a surface texture symbol in a drawing document.

sbNotSpecified : No directions of machining lay specifications are available.

sbParallelToPlane :

Sets Parallel to Plane of Projection for the direction of machining lay specification of a surface texture symbol.

sbPerpendicularToPlane :

Sets Perpendicular to Plane of Projection for the direction of machining lay specification of a surface texture symbol.

sbCrossedIn2SlantDirections :

Sets Angular in Both Directions for the direction of machining lay specification of a surface texture symbol.

sbMultiDirection :

Sets Multidirectional for the direction of machining lay specification of a surface texture symbol.

sbCircularRelativeToCenter :

Sets Circular Relative to Center for the direction of machining lay specification of a surface texture symbol.

sbRadialRelativeToCenter :

Sets Radial Relative to Center for the direction of machining lay specification of a surface texture symbol.

sbParticulateNonDirectional :

Sets Particulate, Non-directional for the direction of machining lay specification of a surface texture symbol.

sbUserDirectionLayType : Sets the user-defined direction of machining lay specification of a surface texture symbol.

Visual Basic
Public Enum McadDirectionLayType
  sbNotSpecified = 0
  sbParallelToPlane = 1
  sbPerpendicularToPlane = 2
  sbCrossedIn2SlantDirections = 3
  sbMultiDirection = 4
  sbCircularRelativeToCenter = 5
  sbRadialRelativeToCenter = 6
  sbParticulateNonDirectional = 7
  sbUserDirectionLayType = 1000
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadEdgeRequirement Enumeration

You are here: API Reference > SymBBAuto Library > McadEdgeRequirement Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadEdgeRequirement Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available requirements for Edge library object.

Visual Basic
Public Enum McadEdgeRequirement
  sbEdgeMax = 0
  sbEdgeMin = 1
  sbEdgeSign = 2
End Enum
Members
Members | Description
sbEdgeMax | Specifies the value of the edge maximum
sbEdgeMin | Specifies the value of the edge minimum
sbEdgeSign | Specifies the value of the edge sign
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadFCFRequirement Enumeration

You are here: API Reference > SymBBAuto Library > McadFCFRequirement Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFCFRequirement Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available requirements for FCF library object.

Visual Basic
Public Enum McadFCFRequirement
  sbSymbol = 0
  sbSymbol2 = 1
  sbTolerance = 2
  sbTolerance2 = 3
  sbToleranceB = 4
  sbToleranceB2 = 5
  sbDatumPrimary = 6
  sbDatumPrimary2 = 7
  sbDatumSecondary = 8
  sbDatumSecondary2 = 9
  sbDatumTertiary = 10
  sbDatumTertiary2 = 11
  sbProjectedZone = 12
  sbDatumId = 13
  sbTopNote = 14
  sbBottomNote = 15
End Enum
Members
Members | Description
sbSymbol | Specifies the Geometric symbol 1 of the feature control frame.
sbSymbol2 | Specifies the Geometric symbol 2 of the feature control frame.
sbTolerance | Specifies the Tolerance of the feature control frame.
sbTolerance2 | Specifies the Tolerance2 of the feature control frame.
sbToleranceB | Specifies the Tolerance B of the feature control frame.
sbToleranceB2 | Specifies the Tolerance B2 of the feature control frame.
sbDatumPrimary | Specifies the DatumPrimary of the feature control frame
sbDatumPrimary2 | Specifies the DatumPrimary2 of the feature control frame
sbDatumSecondary | Specifies the DatumSecondary of the feature control frame
sbDatumSecondary2 | Specifies the DatumSecondary2 of the feature control frame
sbDatumTertiary | Specifies the DatumTertiary of the feature control frame
sbDatumTertiary2 | Specifies the DatumTertiary2 of the feature control frame
sbProjectedZone | Specifies the Projected Zone of the feature control frame
sbDatumId | Specifies the DatumId of the feature control frame.
sbTopNote | Specifies the Top Note of the feature control frame.
sbBottomNote | Specifies the Bottom Note of the feature control frame
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadFilterOperator Enumeration

You are here: API Reference > SymBBAuto Library > McadFilterOperator Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFilterOperator Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available filter operator for a Parts List custom filter.

sbContains : Specifies a "contains" operator.

sbDoesNotCont : Specifies a "does not contain" operator.

sbEqual : Specifies a "equal" operator.

sbNotEqual : Specifies a "not equal" operator.

sbLess : Specifies a "less than" operator

sbGreater : Specifies a "greater than" operator.

sbLessEqual : Specifies a "less than or equal" operator.

sbGreaterEqual : Specifies a "greater than or equal" operator.

Visual Basic
Public Enum McadFilterOperator
  sbContains = 0
  sbDoesNotCont = 1
  sbEqual = 2
  sbNotEqual = 3
  sbLess = 4
  sbGreater = 5
  sbLessEqual = 6
  sbGreaterEqual = 7
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadFilterType Enumeration

You are here: API Reference > SymBBAuto Library > McadFilterType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadFilterType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available filter types for a Parts List.

sbFilterBasic : Specifies a basic filter type for a Parts List.

sbFilterBallooned : Specifies a filter that filters the contents of a Parts List by ballooned parts.

sbFilterCustom : Specifies a filter that filters the contents of a Parts List by a BOM property.

sbFilterParts : Specifies a filter that filters the contents of a Parts List by selected parts.

sbFilterStdParts : Specifies a filter that filters the contents of a Parts List by Standard parts.

sbFilterSheet : Specifies a filter that filters the contents of a Parts List by a drawing layout.

sbFilterView : Specifies a filter that filters the contents of a Parts List by a drawing view.

sbFilterRange : Not Used.

Visual Basic
Public Enum McadFilterType
  sbFilterBasic = 0
  sbFilterBallooned = 1
  sbFilterCustom = 2
  sbFilterParts = 3
  sbFilterStdParts = 4
  sbFilterSheet = 5
  sbFilterView = 6
  sbFilterRange = 7
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadGDTSymbolType Enumeration

You are here: API Reference > SymBBAuto Library > McadGDTSymbolType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadGDTSymbolType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all symbol types available for a feature control frame symbol. All the enumeration symbol types can be rolled into two groups: Geometric Characteristic and Material Removal Modifier.

sbStraightness :

Sets Straightness as the GDT symbol type for a feature control frame symbol.

sbFlatness :

Sets Flatness as the GDT symbol type for a feature control frame symbol.

sbCircularity :

Sets Circularity as the GDT symbol type for a feature control frame symbol.

sbCylindricity :

Sets Cylindricity as the GDT symbol type for a feature control frame symbol.

sbProfileLine :

Sets Profile of a Line as the GDT symbol type for a feature control frame symbol.

sbProfileSurface :

Sets Profile of a Surface as the GDT symbol type for a feature control frame symbol.

sbAngularity :

Sets Angularity as the GDT symbol type for a feature control frame symbol.

sbPerpendicularity :

Sets Perpendicularity as the GDT symbol type for a feature control frame symbol.

sbParallelism :

Sets Parallelism as the GDT symbol type for a feature control frame symbol.

sbPosition :

Sets Position as the GDT symbol type for a feature control frame symbol.

sbConcentricity :

Sets Concentricity as the GDT symbol type for a feature control frame symbol.

sbSymmetry :

Sets as Symmetry the GDT symbol type for a feature control frame symbol.

sbRunoutCircular :

Sets Circular Runout as the GDT symbol type for a feature control frame symbol.

sbRunoutTotal :

Sets Total Runout as the GDT symbol type for a feature control frame symbol.

sbLeastMaterialCondition :

Sets At Least Material Condition as the GDT symbol type for a feature control frame symbol.

sbMaximumMaterialCondition :

Sets At Maximum Material Condition as the GDT symbol type for a feature control frame symbol.

sbProjectedToleranceZone :

Sets Projected Tolerance Zone as the GDT symbol type for a feature control frame symbol.

sbTangentPlane :

Sets Tangent Plane as the GDT symbol type for a feature control frame symbol.

sbFreeState :

Sets Free State as the GDT symbol type for a feature control frame symbol.

sbEnvelope : Not implemented yet. Sets Envelope as the GDT symbol type for a feature control frame symbol.

sbRegardlessOfFeatureSize :

Sets Regardless of Feature Size, Material Modifier as the GDT symbol type for a feature control frame symbol.

sbStatisticalTolerance :

Sets Statistical Tolerance as the GDT symbol type for a feature control frame symbol.

sbDiameter :

Sets Diameter as the GDT symbol type for a feature control frame symbol.

sbBetween :

Sets Between as the GDT symbol type for a feature control frame symbol.

sbReciprocityCondition : Sets Reciprocity as the GDT symbol type for a feature control frame symbol.

sbSquare : Sets Square as the GDT symbol type for a feature control frame symbol.

sbUserSymbolGDT : Sets the user-defined GDT symbol type for a feature control frame symbol.

Visual Basic
Public Enum McadGDTSymbolType
  sbStraightness = 1
  sbFlatness = 2
  sbCircularity = 3
  sbCylindricity = 4
  sbProfileLine = 5
  sbProfileSurface = 6
  sbAngularity = 7
  sbPerpendicularity = 8
  sbParallelism = 9
  sbPosition = 10
  sbConcentricity = 11
  sbSymmetry = 12
  sbRunoutCircular = 13
  sbRunoutTotal = 14
  sbLeastMaterialCondition = 15
  sbMaximumMaterialCondition = 16
  sbProjectedToleranceZone = 17
  sbTangentPlane = 18
  sbFreeState = 19
  sbEnvelope = 20
  sbRegardlessOfFeatureSize = 21
  sbStatisticalTolerance = 22
  sbDiameter = 23
  sbBetween = 24
  sbReciprocityCondition = 25
  sbSquare = 26
  sbProfileSection = 27
  sbAxiality = 28
  sbRunoutCircularFilled = 29
  sbRunoutTotalFilled = 30
  sbUserSymbolGDT = 1000
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadIdentificationType Enumeration

You are here: API Reference > SymBBAuto Library > McadIdentificationType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadIdentificationType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available types of identification line used for a weld symbol. Identification lines are not available for ANSI standard.

sbNoIdentificationLine : Places no identification line on either the arrow side or the other side for a weld symbol.

sbIdentificationOtherSide :

Places the identification line on the other side of the arrow.

sbIdentificationArrowSide :

Places the identification line on the arrow side.

Visual Basic
Public Enum McadIdentificationType
  sbNoIdentificationLine = 0
  sbIdentificationOtherSide = 1
  sbIdentificationArrowSide = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadIdentifierPositionType Enumeration

You are here: API Reference > SymBBAuto Library > McadIdentifierPositionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadIdentifierPositionType Enumeration MG2013New
SymBBAuto Library Send Feedback
Summary

Enumerates the identifier position type for section line.

Visual Basic
Public Enum McadIdentifierPositionType
  sbEndCuttingPlane = 0
  sbAboveDirectionArrowLine = 1
  sbAboveDirectionArrowSymbol = 2
  sbStartDirectionArrow = 3
  sbEndDirectionArrow = 4
End Enum
Members
Members | Description
sbEndCuttingPlane | End of cutting plane.
sbAboveDirectionArrowLine | Outside direction arrow line.
sbAboveDirectionArrowSymbol | Outside direction arrow symbol.
sbStartDirectionArrow | Start of direction arrow.
sbEndDirectionArrow | End of direction arrow.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadJointType Enumeration

You are here: API Reference > SymBBAuto Library > McadJointType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadJointType Enumeration
SymBBAuto Library Send Feedback
Summary
Enum | Value | Description
sbSoldering | 0 | Soldering Dead Joint symbol
sbGluing | 1 | Gluing Dead Joint symbol
sbStitching | 2 | Stitching Joint symbol
sbOverlapping | 3 | Stitching with staples (Overlapping) Dead Joint symbol
sbCorner | 4 | Stitching with staples (Corner) Joint symbol
Visual Basic
Public Enum McadJointType
  sbSoldering = 0
  sbGluing = 1
  sbStitching = 2
  sbOverlapping = 3
  sbCorner = 4
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadLineVisibility Enumeration

You are here: API Reference > SymBBAuto Library > McadLineVisibility Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadLineVisibility Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available line visibility types.

Visual Basic
Public Enum McadLineVisibility
  sbContinuous = 0
  sbNoLines = 1
  sbBetweenPlanes = 2
End Enum
Members
Members | Description
sbContinuous | Value 0. The whole cutting plane is marked with one linetype of one color.
sbNoLines | Value 1. Only the breaks in cutting plane are marked.
sbBetweenPlanes | Value 2. The break have one linetype and color, the lines between them have diff. color.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadNoteAttachPointType Enumeration

You are here: API Reference > SymBBAuto Library > McadNoteAttachPointType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadNoteAttachPointType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available note attach point types.

Visual Basic
Public Enum McadNoteAttachPointType
  sbNoPoint = 0
  sbTopText
  sbTopTopLine
  sbMiddleTopLine
  sbBottomTopLine
  sbMiddleText
  sbTopBottomLine
  sbMiddleBottomLine
  sbBottomBottomLine
  sbBottomText
  sbTopLineRefLine
  sbUnderlineAllText
End Enum
Remarks

Left/Right side is recognized by the symbol's orientation variable.

Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadNoteTemplateGroupType Enumeration

You are here: API Reference > SymBBAuto Library > McadNoteTemplateGroupType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadNoteTemplateGroupType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerator for note template group type.

Visual Basic
Public Enum McadNoteTemplateGroupType
  sbHoleDrilled = 1
  sbCounterBore = 2
  sbCounterSink = 3
  sbFillet = 10
  sbChamfer = 11
  sbPattern = 21
  sbPart = 30
  sbOther = 1000
End Enum
Members
Members | Description
sbHoleDrilled | Value 1.
sbCounterBore | Value 2.
sbCounterSink | Value 3.
sbFillet | Value 10.
sbChamfer | Value 11.
sbPattern | Value 21.
sbPart | Value 30.
sbOther | Value 1000.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadOrientation Enumeration

You are here: API Reference > SymBBAuto Library > McadOrientation Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadOrientation Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available orientations of welding symbol elements.

sbLeftSide :

Places a weld tail to the left of the arrow.

sbRightSide :

Places a weld tail to the right of the arrow.

sbBelow :

Place symbols on the arrow side upward the weld tail.

sbAbove :

Place symbols on the other side of the arrow upward the weld tail.

Visual Basic
Public Enum McadOrientation
  sbLeftSide = 0
  sbRightSide = 1
  sbBelow = 2
  sbAbove = 3
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadScaleType Enumeration

You are here: API Reference > SymBBAuto Library > McadScaleType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadScaleType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerator for scale type.

Visual Basic
Public Enum McadScaleType
  sbScalePf = 2
  sbScaleDf = 4
End Enum
Members
Members | Description
sbScalePf | Value 2.
sbScaleDf | Value 4.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadSectionLineSegmentType Enumeration

You are here: API Reference > SymBBAuto Library > McadSectionLineSegmentType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSectionLineSegmentType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available line segment types.

Visual Basic
Public Enum McadSectionLineSegmentType
  sbLineSegment = 0
  sbArcSegmentSecond = 1
  sbArcSegmentCenter = 2
End Enum
Members
Members | Description
sbLineSegment | Value 0 . Section line segment is line.
sbArcSegmentSecond | Value 1. Three point to define a Arc, picked point is on the Arc.
sbArcSegmentCenter | Value 2. Picked point is the center point of the Arc.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadSectionLineStandardPropType Enumeration

You are here: API Reference > SymBBAuto Library > McadSectionLineStandardPropType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSectionLineStandardPropType Enumeration MG2013New
SymBBAuto Library Send Feedback
Summary

Enumerates the property types for section view standard, which can be set to ByStandard.

Visual Basic
Public Enum McadSectionLineStandardPropType
  sbSectionViewIdentifierTextStyle = 0
  sbSectionViewIdentifierTextColor = 1
  sbSectionViewIdentifierTextHeight = 2
  sbSectionViewStartSymbol = 3
  sbSectionViewEndSymbol = 4
  sbSectionViewSymbolColor = 5
  sbSectionViewEndBendLineColor = 6
  sbSectionViewEndBendLineType = 7
  sbSectionViewEndBendLineWeight = 8
  sbSectionViewPlaneLineColor = 9
  sbSectionViewPlaneLineType = 10
  sbSectionViewPlaneLineWeight = 11
  sbSectionViewLabelTextStyle = 12
  sbSectionViewLabelTextColor = 13
  sbSectionViewLabelTextHeight = 14
End Enum
Members
Members | Description
sbSectionViewIdentifierTextStyle | Identifier Text style property.
sbSectionViewIdentifierTextColor | Identifier Text color property.
sbSectionViewIdentifierTextHeight | Identifier Text height property.
sbSectionViewStartSymbol | Direction arrows Start symbol property.
sbSectionViewEndSymbol | Direction arrows End symbol property.
sbSectionViewSymbolColor | Direction arrows Symbol color property.
sbSectionViewEndBendLineColor | End and bend lines Line color property.
sbSectionViewEndBendLineType | End and bend lines Linetype property.
sbSectionViewEndBendLineWeight |
sbSectionViewPlaneLineColor | Cutting plane lines Line color property.
sbSectionViewPlaneLineType | Cutting plane lines Linetype property.
sbSectionViewPlaneLineWeight | Cutting plane lines Lineweight property.
sbSectionViewLabelTextStyle | Label Text style property.
sbSectionViewLabelTextColor | Label Text color property.
sbSectionViewLabelTextHeight | Label Text height property.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadStdPartsFilterOption Enumeration

You are here: API Reference > SymBBAuto Library > McadStdPartsFilterOption Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadStdPartsFilterOption Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available filter options for a Parts List Standard parts filter.

sbStdPartsOnly : Specifies a Standard parts filter that filters the contents of a Parts List by Standard parts.

sbExcludeStdParts : Specifies a Standard parts filter that filters the contents of a Parts List by non-Standard parts.

Visual Basic
Public Enum McadStdPartsFilterOption
  sbStdPartsOnly = 0
  sbExcludeStdParts = 1
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadSurfaceTextureRequirement Enumeration

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureRequirement Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTextureRequirement Enumeration
SymBBAuto Library Send Feedback
Summary

Surface Texture Requirement information.

sbSurfTextRaMax : Roughness value Ra

sbSurfTextRaMin : Roughness value Ra - minimum

sbSurfTextProduction : Production method

sbSurfTextProduction2 : Production method

sbSurfTextAllowance : Finish allowance

sbSurfTextDirLay : Direction of lay

sbSurfTextSampLength : Sampling length or waviness height

sbSurfTextCutoff : Cutoff value and evaluation length

sbSurfTextOtherValue : Other roughness value

sbSurfTextOtherMin : Other roughness minimum value

sbSurfTextMaxRspac : Maximum spacing

sbSurfTextReference : Reference length and evaluation length

sbSurfTextWavines : Surface waviness

sbSurfTextComment : Comment

sbSurfTextFirstRequirement : First requirement

sbSurfTextSecondRequirement : Second requirement

sbSurfTextThirdRequirement : Third requirement

Visual Basic
Public Enum McadSurfaceTextureRequirement
  sbSurfTextRaMax = 0
  sbSurfTextRaMin = 1
  sbSurfTextProduction = 2
  sbSurfTextProduction2 = 3
  sbSurfTextAllowance = 4
  sbSurfTextDirLay = 5
  sbSurfTextSampLength = 6
  sbSurfTextCutoff = 7
  sbSurfTextOtherValue = 8
  sbSurfTextOtherMin = 9
  sbSurfTextMaxRspac = 10
  sbSurfTextReference = 11
  sbSurfTextWavines = 12
  sbSurfTextComment = 13
  sbSurfTextFirstRequirement = 65
  sbSurfTextSecondRequirement = 66
  sbSurfTextThirdRequirement = 67
  sbSurfTextFourthRequirement = 68
End Enum
Members
Members | Description
sbSurfTextFourthRequirement | Fourth requirement
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadSurfaceTextureType Enumeration

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSurfaceTextureType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available surface types for a surface texture symbol.

sbBasic :

Set the Basic surface type for a surface texture symbol.

sbRemovalOfMaterialRequired :

Set the Removal of Material Required surface type for a surface texture symbol.

sbRemovalOfMaterialProhibited :

Set the Removal of Material Prohibited surface type for a surface texture symbol.

sbRemovalAllowanceSpecified : Set the Removal of Allowance Specified surface type for a surface texture symbol.

Visual Basic
Public Enum McadSurfaceTextureType
  sbBasic = 0
  sbRemovalOfMaterialRequired = 1
  sbRemovalOfMaterialProhibited = 2
  sbRemovalAllowanceSpecified = 3
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadSymBBSymbolLibraryType Enumeration

You are here: API Reference > SymBBAuto Library > McadSymBBSymbolLibraryType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadSymBBSymbolLibraryType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available Symbol Library Type.

Visual Basic
Public Enum McadSymBBSymbolLibraryType
  sbSurfaceTextureLibrary = 0
  sbWeldingLibrary = 1
  sbEdgeLibrary = 2
  sbFCFLibrary = 3
End Enum
Members
Members | Description
sbSurfaceTextureLibrary | Value 0. Surface texture symbol library.
sbWeldingLibrary | Value 1. Welding symbol library.
sbEdgeLibrary | Value 2. Edge symbol library.
sbFCFLibrary | Value 3. FCF symbol library.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadTaperDimensionType Enumeration

You are here: API Reference > SymBBAuto Library > McadTaperDimensionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTaperDimensionType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available taper dimension type.

Visual Basic
Public Enum McadTaperDimensionType
  sbRatio = 0
  sbPercentage = 1
End Enum
Members
Members | Description
sbRatio | Value 0. Use ratio format to display dimension value.
sbPercentage | Value 1. Use percentage format to display dimension value.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadTaperRatioFormatType Enumeration

You are here: API Reference > SymBBAuto Library > McadTaperRatioFormatType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTaperRatioFormatType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available ratio format type.

Visual Basic
Public Enum McadTaperRatioFormatType
  sbFraction = 0
  sbNoFraction = 1
  sbNumber = 2
End Enum
Members
Members | Description
sbFraction | Value 0. The format of ratio is 1:X
sbNoFraction | Value 1. The format of ratio is X:1
sbNumber | Value 2. The format of ratio is X.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadTaperSlopeSymType Enumeration

You are here: API Reference > SymBBAuto Library > McadTaperSlopeSymType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTaperSlopeSymType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerator for taper slope symbol type.

Visual Basic
Public Enum McadTaperSlopeSymType
  sbTaper1 = 0
  sbTaper2 = 1
  sbSlope1 = 2
  sbSlope2 = 3
End Enum
Members
Members | Description
sbTaper1 | Value 2. Slope1 symbol type.
sbTaper2 | Value 3. Slope2 symbol type.
sbSlope1 | Value 0. Taper1 symbol type.
sbSlope2 | Value 1. Taper2 symbol type.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadTargetType Enumeration

You are here: API Reference > SymBBAuto Library > McadTargetType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTargetType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available termination types for a datum target symbol.

sbNoTarget :

Set the None termination type for a datum target symbol.

sbBalloon : Not implemented yet. Set the None termination type for a datum target symbol.

sbPoint :

Set the None termination type for a datum target symbol.

sbLine :

Set the None termination type for a datum target symbol.

sbCircular :

Set the None termination type for a datum target symbol.

sbRectangular :

Set the None termination type for a datum target symbol.

sbAttach :

Set the None termination type for a datum target symbol.

Visual Basic
Public Enum McadTargetType
  sbNoTarget = 0
  sbBalloon = 1
  sbPoint = 2
  sbLine = 3
  sbCircular = 4
  sbRectangular = 5
  sbAttach = 6
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadTextControl Enumeration

You are here: API Reference > SymBBAuto Library > McadTextControl Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadTextControl Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available text controls for a Parts List.

sbNone : Specifies that a Parts List text is not controlled. The text overruns the column width when the length of the text exceeds the column width.

sbFit : Specifies that a Parts List text fits within the column when the length of the text exceeds the column width.

sbWrap : Specifies that a Parts List text wraps to the next line when the length of the text exceeds the column width.

Visual Basic
Public Enum McadTextControl
  sbNone = 0
  sbFit = 1
  sbWrap = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadUndefinedSize Enumeration

You are here: API Reference > SymBBAuto Library > McadUndefinedSize Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadUndefinedSize Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the undefined size's cases for edge symbol

Visual Basic
Public Enum McadUndefinedSize
  sbDefSize = 0
  sbWithBurr = 1
  sbWithoutBurr = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadUndefinedSizeDirection Enumeration

You are here: API Reference > SymBBAuto Library > McadUndefinedSizeDirection Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadUndefinedSizeDirection Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the undefined size's direction for edge symbol

Visual Basic
Public Enum McadUndefinedSizeDirection
  sbTop = 0
  sbSide = 1
  sbUserDirect = 2
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadViewDefLockType Enumeration

You are here: API Reference > SymBBAuto Library > McadViewDefLockType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadViewDefLockType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the lock type of the folder definition or component view definition in mechanical structure.

mc2DSNoLock : Specifies no lock in mechanical structure.

mc2DSXrefLock : Specifies the lock of the Xref objects in mechanical structure.

mc2DSStdPartLock : Specifies the lock of standard parts in mechanical structure.

mc2DSUserLock : Specifies the user-defined lock in mechanical structure.

Visual Basic
Public Enum McadViewDefLockType
  mc2DSNoLock = &H0000
  mc2DSXrefLock = &H0001
  mc2DSStdPartLock = &H0002
  mc2DSUserLock = &H0004
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadWeldAssociation Enumeration

You are here: API Reference > SymBBAuto Library > McadWeldAssociation Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldAssociation Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available association types between two fillet weld symbols for the staggered weldment.

sbNoAssociation : Sets no association.

sbAssociationSpacer : Space the fillet symbols.

sbAssociationMoveStagger : Staggers the fillet symbols.

sbAssociationMirrorStagger : Mirrors the fillet symbols.

sbAssociationSpecialStagger : Staggers the fillet symbols in a special way.

sbAssociationBacking : Back the fillet symbols.

Visual Basic
Public Enum McadWeldAssociation
  sbNoAssociation = 0
  sbAssociationSpacer = 1
  sbAssociationMoveStagger = 2
  sbAssociationMirrorStagger = 3
  sbAssociationSpecialStagger = 4
  sbAssociationBacking = 5
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadWeldingRequirement Enumeration

You are here: API Reference > SymBBAuto Library > McadWeldingRequirement Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldingRequirement Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates the available Weld requirements variable.

Visual Basic
Public Enum McadWeldingRequirement
  sbWeldSize = 0
  sbWeldThickness = 1
  sbWeldLength = 2
  sbWeldNumber = 3
  sbWeldSpacing = 4
  sbWeldAngle = 5
  sbWeldDepth = 6
  sbWeldPitch = 7
  sbWeldGap = 8
  sbWeldClearance = 9
  sbWeldBacking = 10
  sbWeldBrazing = 11
  sbWeldFinishing = 12
  sbWeldContour = 13
  sbWeldNotes = 14
  sbWeldIndex = 15
  sbWeldIndexTotal = 16
  sbWeldStandard = 17
  sbWeldDesignation = 18
  sbWeldSpecification = 19
  sbWeldControlCategory = 20
  sbWeldTechnicalReq = 21
  sbWeldSize2 = 22
  sbWeldSizeSymbol = 23
  sbWeldSecondarySymbol = 24
End Enum
Members
Members | Description
sbWeldSize | Value 0. Specifies the size of the weld.
sbWeldThickness | Value 1. Specifies the thickness of the weld.
sbWeldLength | Value 2. Specifies the Length of the weld.
sbWeldNumber | Value 3. Specifies the number of the welds.
sbWeldSpacing | Value 4. Specifies the distance between welds.
sbWeldAngle | Value 5. Specifies the groove angle of the weld.
sbWeldDepth | Value 6. Specifies the groove depth of the weld.
sbWeldPitch | Value 7. Specifies the distance between weld centers.
sbWeldGap | Value 8. Specifies the root gap between welds.
sbWeldClearance | Value 9. Specifies the root gap between welds.
sbWeldBacking | Value 10. Specifies the value of the backing field for the weld symbol.
sbWeldBrazing | Value 11. Specifies the usage of brazing.
sbWeldFinishing | Value 12. Specifies the value of the finishing method field for the contour weld symbol.
sbWeldContour | Value 13. Specifies the contour or shape of the weld surface.
sbWeldNotes | Value 14. Specifies the supplementary data in the notes field for a weld symbol.
sbWeldIndex | Value 15. Specifies the value of the index number field for the weld symbol.
sbWeldIndexTotal | Value 16. Specifies the value of the total count of index field for the weld symbol.
sbWeldStandard | Value 17. Specifies the value of the weld standard field for the weld symbol.
sbWeldDesignation | Value 18. Specifies the value of the weld designation field for the weld symbol.
sbWeldSpecification | Value 19. Specifies the value of the weld specification field for the weld symbol.
sbWeldControlCategory | Value 20. Specifies the weld control category.
sbWeldTechnicalReq | Value 21. Specifies the value of the technical requirements field for the weld symbol.
sbWeldSize2 | Value 22.
sbWeldSizeSymbol | Value 23.
sbWeldSecondarySymbol | Value 24. Specifies the second weld size value.
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadWeldSymbolType Enumeration

You are here: API Reference > SymBBAuto Library > McadWeldSymbolType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadWeldSymbolType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available weld symbol types for a weld symbol standard. All the enumeration weld symbol types can be rolled into three groups: Weld Symbols, Contour Symbols, and Backing Symbols. A weld symbol type may use different signs in different standard, such as ANSI, BSI, and ISO.

sbNoSymbol : Sets no weld symbol type for a weld symbol standard.

sbFilletWeld :

Sets the Fillet Weld symbol type for a weld symbol standard. Available for ANSI

sbSecondaryFillet : Sets the Secondary Fillet Weld symbol type for a weld symbol standard.

sbPlugWeld :

Sets the Plug Weld symbol type for a weld symbol standard.

sbSlotWeld :

Sets the Slot Weld symbol type for a weld symbol standard.

sbStudWeld :

Sets the Stud Weld symbol type for a weld symbol standard.

sbSpotWeld :

Sets the Spot or Projection Weld symbol type for a weld symbol standard.

sbSpotOnRefLineWeld :

Sets the Spot Weld on Reference Line symbol type for a weld symbol standard.

sbSeamWeld :

Sets the Seam Weld symbol type for a weld symbol standard.

sbSeamOnRefLineWeld :

Sets the Seam Weld on Reference Line symbol type for a weld symbol standard.

sbBackWeld :

Sets the Backing Run, Back or Backing Weld symbol type for a weld symbol standard.

sbSurfacingWeld :

Sets the Surfacing Weld symbol type for a weld symbol standard.

sbFlangeEdgeWeld :

Sets the Flange Edge Weld symbol type for a weld symbol standard.

sbFlangeCornerWeld :

Sets the Flange Corner Weld symbol type for a weld symbol standard.

sbSqureGrooveWeld :

Sets the Square Groove Weld symbol type for a weld symbol standard. Available for ANSI

sbScarfGrooveWeld :

Sets the Scarf Groove Weld symbol type for a weld symbol standard.

sbVGrooveWeld :

Sets the V Groove Weld symbol type for a weld symbol standard.

sbBevelGrooveWeld :

Sets the Bevel Groove Weld symbol type for a weld symbol standard.

sbUGrooveWeld :

Sets the U Groove Weld symbol type for a weld symbol standard.

sbJGrooveWeld :

Sets the J Groove Weld symbol type for a weld symbol standard.

sbFlareVGrooveWeld :

Sets the Flare V Groove Weld symbol type for a weld symbol standard.

sbFlareBevelGrooveWeld :

Sets the Flare Bevel Groove Weld symbol type for a weld symbol standard.

sbEdgeWeld :

Sets the Edge Weld symbol type for a weld symbol standard.

sbFoldJointWeld :

Sets the Fold Joint symbol type for a weld symbol standard.

sbInclinedJointWeld :

Sets the Inclined Joint symbol type for a weld symbol standard.

sbSurfaceJointWeld :

Sets the Surface Joint symbol type for a weld symbol standard.

sbSteepFlankedVWeld :

Sets the Steep Flanked V Butt Weld symbol type for a weld symbol standard.

sbSteepFlankedBevelWeld :

Sets the Steep Flanked Bevel Butt Weld symbol type for a weld symbol standard.

sbSingleVBroadRootFace :

Sets the Flare Single Bevel Groove Weld symbol type for a weld symbol standard.

sbSingleBevelBroadRootFace :

Sets the Flare Single V Groove Weld symbol type for a weld symbol standard.

sbPermanentBackingStripWeld :

Sets the Permanent Backing Strip symbol type for a weld symbol standard.

sbRemovableBackingStripWeld :

Sets the Removable Backing Strip symbol type for a weld symbol standard.

sbMeltThrough :

Sets the Melt Through symbol type for a weld symbol standard.

sbConsInsert :

Sets the Converse Insert Weld symbol type for a weld symbol standard.

sbFlushContour :

Sets the Flat/FLush Contour symbol type for a weld symbol standard.

sbConvexContour :

Sets the Convex Contour symbol type for a weld symbol standard.

sbConcaveContour :

Sets the Concave Contour symbol type for a weld symbol standard.

sbSmoothContour :

Sets the Toes Shall Be Blended Smoothly symbol type for a weld symbol standard.

sbFlushFinishedContour :

Sets the Flush Finished Contour symbol type for a weld symbol standard.

sbWeldingTail : Sets the Tail Weld symbol type for a weld symbol standard.

sbWeldAllAround : Sets the All Around Weld symbol type for a weld symbol standard.

sbFieldWeld : Sets the Field Weld symbol type for a weld symbol standard.

sbSpecialStaggerWeld : Sets the Special Stagger Weld symbol type for a weld symbol standard.

sbBevelGrooveShapeWeld : Sets the Bevel Groove Shape Weld symbol type for a weld symbol standard.

sbWeldAllAroundSquare : Sets the All Around Square Weld symbol type for a weld symbol standard.

sbFieldWeldEmpty : Sets the Field Weld Empty symbol type for a weld symbol standard.

sbExamination :

Sets the Nondestructive Examination symbol type for a weld symbol standard.

sbBackLendingWeld :

Sets the Backing Strip symbol type for a weld symbol standard.

sbRoundedWeld : Sets the Rounded Weld symbol type for a weld symbol standard.

sbHalfRoundedWeld : Sets the Half Rounded Weld symbol type for a weld symbol standard.

sbHalfWWeld :

Sets the Half W Welding symbol type for a weld symbol standard.

sbWWeld :

Sets the W Welding symbol type for a weld symbol standard

sbWeldMullded : Sets the Grooved Mullded Weld symbol type for a weld symbol standard.

sbWeldGroovedRoot :

Sets the Groove Root Welding symbol type for a weld symbol standard.

sbWWeld2 :

Sets the W-svar symbol type for a weld symbol standard.

sbUVWeld :

Sets the UV-svar symbol type for a weld symbol standard.

sbConcaveSmoothContour :

Sets the Welds with Machined Fillets contour symbol type for a weld symbol standard.

sbUserSymbolType : Sets the user-defined symbol type for a weld symbol standard.

Visual Basic
Public Enum McadWeldSymbolType
  sbNoSymbol = 0
  sbFilletWeld = 6
  sbSecondaryFillet = 7
  sbPlugWeld = 8
  sbSlotWeld = 9
  sbStudWeld = 10
  sbSpotWeld = 11
  sbSpotOnRefLineWeld = 12
  sbSeamWeld = 13
  sbSeamOnRefLineWeld = 14
  sbBackWeld = 15
  sbSurfacingWeld = 16
  sbFlangeEdgeWeld = 17
  sbFlangeCornerWeld = 18
  sbSqureGrooveWeld = 19
  sbScarfGrooveWeld = 20
  sbVGrooveWeld = 21
  sbBevelGrooveWeld = 22
  sbUGrooveWeld = 23
  sbJGrooveWeld = 24
  sbFlareVGrooveWeld = 25
  sbFlareBevelGrooveWeld = 26
  sbEdgeWeld = 27
  sbFoldJointWeld = 28
  sbInclinedJointWeld = 29
  sbSurfaceJointWeld = 30
  sbSteepFlankedVWeld = 31
  sbSteepFlankedBevelWeld = 32
  sbSingleVBroadRootFace = 33
  sbSingleBevelBroadRootFace = 34
  sbPermanentBackingStripWeld = 35
  sbRemovableBackingStripWeld = 36
  sbMeltThrough = 37
  sbConsInsert = 38
  sbFlushContour = 39
  sbConvexContour = 40
  sbConcaveContour = 41
  sbSmoothContour = 42
  sbFlushFinishedContour = 43
  sbWeldingTail = 44
  sbWeldAllAround = 45
  sbFieldWeld = 46
  sbSpecialStaggerWeld = 47
  sbBevelGrooveShapeWeld = 48
  sbWeldAllAroundSquare = 49
  sbFieldWeldEmpty = 50
  sbExamination = 51
  sbBackLendingWeld = 52
  sbRoundedWeld = 53
  sbHalfRoundedWeld = 54
  sbHalfWWeld = 55
  sbWWeld = 56
  sbWeldMullded = 57
  sbWeldGroovedRoot = 58
  sbWWeld2 = 59
  sbUVWeld = 60
  sbConcaveSmoothContour = 61
  sbCutEnforceWeld = 62
  sbSmoothWeld = 63
  sbOpenContourWeld = 64
  sbIntermittentWeld = 65
  sbZigzagWeld = 66
  sbUserSymbolType = 1000
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


McadBalloonCollectionType Enumeration

You are here: API Reference > SymBBAuto Library > McadBalloonCollectionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
McadBalloonCollectionType Enumeration
SymBBAuto Library Send Feedback
Summary

Enumerates all available alignment types of collected balloons for selected part references. The orientation of collected balloons depends on the position of the last leader segment.

sbHorizontal : Aligns collected balloons horizontally.

sbVertical : Aligns collected balloons vertically.

Visual Basic
Public Enum McadBalloonCollectionType
  sbHorizontal = 0
  sbVertical = 1
End Enum
Library

SymBBAuto Library

Links
SymBBAuto Library
Copyright (c) 2014. All rights reserved.


GEAuto Library

You are here: API Reference > GEAuto Library
GEAuto Library
CoClasses Enumerations API Reference Interfaces Legend Send Feedback
Summary

The Autodesk GeAuto Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.

Remarks

Additional Ge objects can also be directly created by the library user. Ge objects are taken in as the data specification in geometric editing functions. The Ge library supports geometry query and manipulation.

The geometry entities in the GeAuto Object Model are strictly geometric representations useful for geometric calculations or geometric property communications. They are not database-resident objects as the AcadEntity objects are in the AutoCAD Object Model. Conversion between the two needs to be done by querying the geometric data from one and using it to construct or set the data in the other.

Points, point list, vector, and matrices are represented in the AutoCAD Object Model as Variant arrays of Doubles, but as objects in the GeAuto Object Model. You can use the GeAuto GePoint, GePoints, GeVector, and GeMatrix objects in place of the Variant array of Doubles when using the AutoCAD Object Model by relying on the AsArray and AsArray2d properties on these objects.

When specifying the value of these objects as input to a property or method on an AutoCAD object expecting a Variant array of Doubles, use the AsArray property on the GeAuto objects to pass the object's data contents as an array of Doubles. The GePoints collection object has an AsArray2d property to pass the collection of points as an array of two-dimensional points (the Z coordinate of the points is ignored).

CoClasses
Name | Description
GeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
GeAugmentedLine | A multisegmented curve with normal information at the nodes.
GeBoundBlock | A spatial bounding volume.
GeBoundedSurface | Surface with trimming boundary information.
GeCircularArc | A circle or circular arc curve.
GeCompositeCurve | A curve composed of multiple component curves connected end to end.
GeCone | A bounded right circular cone.
GeCurveBoundaries | A collection of GeCurveBoundary objects.
GeCurveBoundary | A representation for one of a surface's boundaries.
GeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves.
GeCurves | A collection of GeCurve objects.
GeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
GeCylinder | A cylindrical surface.
GeEllipticalArc | An ellipse or elliptical arc.
GeEntities | A collection of GeEntity objects.
GeInterval | Represents an interval of the real axis to define bounds.
GeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
GeLine | An unbounded line.
GeLineSegment | A bounded line segment.
GeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
GeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
GeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
GeOffsetCurve | An exact offset of another curve.
GeOffsetSurface | An exact offset of another surface.
GePlane | An infinite plane in three dimensional space.
GePoint | A three-dimensional point object.
GePoints | A collection of GePoint objects.
GeRay | A line bounded at one end.
GeSphere | A spherical surface.
GeSurfaces | A collection of GeSurface objects.
GeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
GeTolerance | Encapsulates tolerance values to use in calculations.
GeTorus | A toroid or toroidal segment surface.
GeVector | A vector in three-dimensional space.
GeVectors | A collection of GeVector objects.
Enumerations
Name | Description
GeCollectionType | Enumerates all collection types of geometry entity objects.
GeCurveCurveIntConfiguration | Enumerates the characterization of the intersection between curves, circles, or circular arcs. This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.
GeCurveSurfIntConfiguration | Enumerates all intersection characterization in the neighborhood just above and below the intersection between the curve and the surface.
GeNurbSurfaceProperties | type GeNurbSurfaceProperties geOpen : Description to come geClosed : Description to come gePeriodic : Description to come geRational : Description to come geNoPoles : Description to come gePoleAtMin : Description to come gePoleAtMax : Description to come gePoleAtBoth : Description to come
GeSurfSurfIntConfiguration | Enumerates all intersection characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
GeSurfSurfIntType | Enumerates all intersection types between two surfaces.
Group

API Reference

Interfaces
Name | Description
IGeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
IGeAugmentedLine | A multisegmented curve with normal information at the nodes.
IGeBoundBlock | A spatial bounding volume.
IGeBoundedSurface | Surface with trimming boundary information.
IGeCircularArc | A circle or circular arc curve.
IGeCompositeCurve | A curve composed of multiple component curves connected end to end.
IGeCone | A bounded right circular cone.
IGeCurve | A generic curve entity.
IGeCurveBoundaries | A collection of GeCurveBoundary objects.
IGeCurveBoundary | A representation for one of a surface's boundaries.
IGeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves. This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.
IGeCurves | A collection of GeCurve objects.
IGeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
IGeCylinder | A cylindrical surface.
IGeEllipticalArc | An ellipse or elliptical arc.
IGeEntities | A collection of GeEntity objects.
IGeEntity | A generic geometric entity. Subtypes: GeBoundBlock, IGeCurve, GePoint, IGeSurface.
IGeInterval | Represents an interval of the real axis to define bounds.
IGeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
IGeLine | An unbounded line.
IGeLinearEntity | A generic linear entity.
IGeLineSegment | A bounded line segment.
IGeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
IGeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
IGeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
IGeOffsetCurve | An exact offset of another curve.
IGeOffsetSurface | An exact offset of another surface.
IGePlane | An infinite plane in three-dimensional space.
IGePoint | A three-dimensional point object.
IGePoints | A collection of GePoint objects.
IGeRay | A line bounded at one end.
IGeSphere | A spherical surface.
IGeSurface | A generic surface entity.
IGeSurfaces | A collection of GeSurface objects.
IGeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
IGeTolerance | Encapsulates tolerance values to use in calculations.
IGeTorus | A toroid or toroidal segment surface.
IGeVector | A vector in three-dimensional space.
IGeVectors | A collection of GeVector objects.
Links
CoClasses, Enumerations, API Reference, Interfaces, Legend


GeApplication CoClass

You are here: API Reference > GEAuto Library > GeApplication CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeApplication CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

GEAuto::GeApplication
Visual Basic
Public Class GeApplication
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeAugmentedLine CoClass

You are here: API Reference > GEAuto Library > GeAugmentedLine CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeAugmentedLine CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

GEAuto::GeAugmentedLine
Visual Basic
Public Class GeAugmentedLine
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeBoundBlock CoClass

You are here: API Reference > GEAuto Library > GeBoundBlock CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeBoundBlock CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A spatial bounding volume.

Class Hierarchy

Declaration syntax

GEAuto::GeBoundBlock
Visual Basic
Public Class GeBoundBlock
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeBoundedSurface CoClass

You are here: API Reference > GEAuto Library > GeBoundedSurface CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeBoundedSurface CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Surface with trimming boundary information.

Class Hierarchy

Declaration syntax

GEAuto::GeBoundedSurface
Visual Basic
Public Class GeBoundedSurface
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCircularArc CoClass

You are here: API Reference > GEAuto Library > GeCircularArc CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCircularArc CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A circle or circular arc curve.

Class Hierarchy

Declaration syntax

GEAuto::GeCircularArc
Visual Basic
Public Class GeCircularArc
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCompositeCurve CoClass

You are here: API Reference > GEAuto Library > GeCompositeCurve CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCompositeCurve CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A curve composed of multiple component curves connected end to end.

Class Hierarchy

Declaration syntax

GEAuto::GeCompositeCurve
Visual Basic
Public Class GeCompositeCurve
Remarks

For instance, a composite curve could consist of four straight line segments that form a square. Each of the component curves must be bounded curves, which means that infinite lines and rays may not be used as component curves of a composite. The component curves are not required to all lie in the same plane. The start parameter of a composite is 0.0. The parameter value at the end point of the first component curve will be the approximate length of the first curve (call this value l1). The parameter value at the end point of the second curve will be l1 + the approximate length of the second curve, and so on.

Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCone CoClass

You are here: API Reference > GEAuto Library > GeCone CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCone CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A bounded right circular cone.

Class Hierarchy

Declaration syntax

GEAuto::GeCone
Visual Basic
Public Class GeCone
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCurveBoundaries CoClass

You are here: API Reference > GEAuto Library > GeCurveBoundaries CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveBoundaries CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeCurveBoundary objects.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveBoundaries
Visual Basic
Public Class GeCurveBoundaries
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCurveBoundary CoClass

You are here: API Reference > GEAuto Library > GeCurveBoundary CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveBoundary CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A representation for one of a surface's boundaries.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveBoundary
Visual Basic
Public Class GeCurveBoundary
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCurveCurveIntersection CoClass

You are here: API Reference > GEAuto Library > GeCurveCurveIntersection CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveCurveIntersection CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates and provides access to the intersection properties between two curves.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveCurveIntersection
Visual Basic
Public Class GeCurveCurveIntersection
Remarks

This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.

Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCurves CoClass

You are here: API Reference > GEAuto Library > GeCurves CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurves CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeCurve objects.

Class Hierarchy

Declaration syntax

GEAuto::GeCurves
Visual Basic
Public Class GeCurves
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCurveSurfaceIntersection CoClass

You are here: API Reference > GEAuto Library > GeCurveSurfaceIntersection CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveSurfaceIntersection CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates and provides access to the intersection properties between a curve and a surface.

Class Hierarchy

Declaration syntax

GEAuto::GeCurveSurfaceIntersection
Visual Basic
Public Class GeCurveSurfaceIntersection
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeCylinder CoClass

You are here: API Reference > GEAuto Library > GeCylinder CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCylinder CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A cylindrical surface.

Class Hierarchy

Declaration syntax

GEAuto::GeCylinder
Visual Basic
Public Class GeCylinder
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeEllipticalArc CoClass

You are here: API Reference > GEAuto Library > GeEllipticalArc CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeEllipticalArc CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An ellipse or elliptical arc.

Class Hierarchy

Declaration syntax

GEAuto::GeEllipticalArc
Visual Basic
Public Class GeEllipticalArc
Remarks

The angle of a point on the ellipse is measured by drawing a full circle with the same center as the ellipse and radius equal to the ellipse major radius and projecting the point onto the circle along a vector perpendicular to the major axis. If a vector is then drawn from the ellipse center to this projected point, the angle between the major axis and this vector (measured counterclockwise about the cross product of the major and minor axes) is the angle of the point on the ellipse. endAngle must be greater than startAngle. To construct a full ellipse, the difference between EndAngle and StartAngle should be 2*pi.

Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeEntities CoClass

You are here: API Reference > GEAuto Library > GeEntities CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeEntities CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeEntity objects.

Class Hierarchy

Declaration syntax

GEAuto::GeEntities
Visual Basic
Public Class GeEntities
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeInterval CoClass

You are here: API Reference > GEAuto Library > GeInterval CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeInterval CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Represents an interval of the real axis to define bounds.

Class Hierarchy

Declaration syntax

GEAuto::GeInterval
Visual Basic
Public Class GeInterval
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeKnotVector CoClass

You are here: API Reference > GEAuto Library > GeKnotVector CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeKnotVector CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An ordered sequence knot values making up a knot vector for NURB entities.

Class Hierarchy

Declaration syntax

GEAuto::GeKnotVector
Visual Basic
Public Class GeKnotVector
Remarks

The intervals between two consecutive knots partition a spline into polynomial or rational pieces.

Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeLine CoClass

You are here: API Reference > GEAuto Library > GeLine CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeLine CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An unbounded line.

Class Hierarchy

Declaration syntax

GEAuto::GeLine
Visual Basic
Public Class GeLine
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeLineSegment CoClass

You are here: API Reference > GEAuto Library > GeLineSegment CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeLineSegment CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A bounded line segment.

Class Hierarchy

Declaration syntax

GEAuto::GeLineSegment
Visual Basic
Public Class GeLineSegment
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeMatrix CoClass

You are here: API Reference > GEAuto Library > GeMatrix CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeMatrix CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A 4 x 4 matrix representing an affine transformation including translation.

Class Hierarchy

Declaration syntax

GEAuto::GeMatrix
Visual Basic
Public Class GeMatrix
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeNurbCurve CoClass

You are here: API Reference > GEAuto Library > GeNurbCurve CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeNurbCurve CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A Non-Uniform Rational B-spline, or NURB curve.

Class Hierarchy

Declaration syntax

GEAuto::GeNurbCurve
Visual Basic
Public Class GeNurbCurve
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeNurbSurface CoClass

You are here: API Reference > GEAuto Library > GeNurbSurface CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeNurbSurface CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A Non-Uniform Rational B-spline, or NURB surface.

Class Hierarchy

Declaration syntax

GEAuto::GeNurbSurface
Visual Basic
Public Class GeNurbSurface
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeOffsetCurve CoClass

You are here: API Reference > GEAuto Library > GeOffsetCurve CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeOffsetCurve CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An exact offset of another curve.

Class Hierarchy

Declaration syntax

GEAuto::GeOffsetCurve
Visual Basic
Public Class GeOffsetCurve
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeOffsetSurface CoClass

You are here: API Reference > GEAuto Library > GeOffsetSurface CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeOffsetSurface CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An exact offset of another surface.

Class Hierarchy

Declaration syntax

GEAuto::GeOffsetSurface
Visual Basic
Public Class GeOffsetSurface
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GePlane CoClass

You are here: API Reference > GEAuto Library > GePlane CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GePlane CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

An infinite plane in three dimensional space.

Class Hierarchy

Declaration syntax

GEAuto::GePlane
Visual Basic
Public Class GePlane
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GePoint CoClass

You are here: API Reference > GEAuto Library > GePoint CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GePoint CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A three-dimensional point object.

Class Hierarchy

Declaration syntax

GEAuto::GePoint
Visual Basic
Public Class GePoint
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GePoints CoClass

You are here: API Reference > GEAuto Library > GePoints CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GePoints CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GePoint objects.

Class Hierarchy

Declaration syntax

GEAuto::GePoints
Visual Basic
Public Class GePoints
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeRay CoClass

You are here: API Reference > GEAuto Library > GeRay CoClass
GeRay CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A line bounded at one end.

Class Hierarchy

Declaration syntax

GEAuto::GeRay
Visual Basic
Public Class GeRay
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeSphere CoClass

You are here: API Reference > GEAuto Library > GeSphere CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeSphere CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A spherical surface.

Class Hierarchy

Declaration syntax

GEAuto::GeSphere
Visual Basic
Public Class GeSphere
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeSurfaces CoClass

You are here: API Reference > GEAuto Library > GeSurfaces CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeSurfaces CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeSurface objects.

Class Hierarchy

Declaration syntax

GEAuto::GeSurfaces
Visual Basic
Public Class GeSurfaces
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeSurfaceSurfaceIntersection CoClass

You are here: API Reference > GEAuto Library > GeSurfaceSurfaceIntersection CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeSurfaceSurfaceIntersection CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates the intersection between two surfaces.

Class Hierarchy

Declaration syntax

GEAuto::GeSurfaceSurfaceIntersection
Visual Basic
Public Class GeSurfaceSurfaceIntersection
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeTolerance CoClass

You are here: API Reference > GEAuto Library > GeTolerance CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeTolerance CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates tolerance values to use in calculations.

Class Hierarchy

Declaration syntax

GEAuto::GeTolerance
Visual Basic
Public Class GeTolerance
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeTorus CoClass

You are here: API Reference > GEAuto Library > GeTorus CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeTorus CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A toroid or toroidal segment surface.

Class Hierarchy

Declaration syntax

GEAuto::GeTorus
Visual Basic
Public Class GeTorus
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeVector CoClass

You are here: API Reference > GEAuto Library > GeVector CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeVector CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A vector in three-dimensional space.

Class Hierarchy

Declaration syntax

GEAuto::GeVector
Visual Basic
Public Class GeVector
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


GeVectors CoClass

You are here: API Reference > GEAuto Library > GeVectors CoClass
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeVectors CoClass
GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeVector objects.

Class Hierarchy

Declaration syntax

GEAuto::GeVectors
Visual Basic
Public Class GeVectors
Library

GEAuto Library

Links
GEAuto Library, Class Hierarchy
Copyright (c) 2014. All rights reserved.


IGeApplication Interface

You are here: API Reference > GEAuto Library > IGeApplication Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication Interface
IGeApplication Members GEAuto Library Class Hierarchy Send Feedback
Summary

An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.

Class Hierarchy

Declaration syntax

IGeApplication
Visual Basic
Public Interface IGeApplication
Inherits IDispatch
Library

GEAuto Library

Links
IGeApplication Members, GEAuto Library, Class Hierarchy


IGeApplication Members

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication Members
IGeApplication Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeApplication.

Interface

IGeApplication Interface

Methods
Name | Description
AugmentedLine | Creates a new GeAugmentedLine object.
BoundBlock | Create a new GeBoundBlock object.
CircularArc | Creates a GeCircularArc object.
Collection | Creates a new collection object of the specified type.
CompositeCurve | Creates a new GeCompositeCurve object.
Cone | Creates a GeCone object.
CurveBoundary | Creates a GeCurveBoundary object.
Cylinder | Creates a GeCylinder object.
EllipticalArc | Creates a new GeEllipticalArc object.
Interval | Creates a new GeInterval object.
KnotVector | Creates a new GeKnotVector object.
Line | Creates a new GeLine object.
LineSegment | Creates a new GeLineSegment object.
Matrix | Creates a new GeMatrix object set to identity.
NurbCurve | Creates a new GeNurbCurve object, which is a 3D rational spline by a knot vector, control points, and weights.
NurbSurface | Creates a new GeNurbSurface object.
OffsetCurve | Creates a new GeOffsetCurve object.
OffsetSurface | Creates a new GeOffsetSurface object.
Plane | Creates a new GePlane object.
Point | Creates a new GePoint object.
Ray | Creates a new GeRay object.
Sphere | Creates a new GeSphere object.
Tolerance | Creates a new GeTolerance object.
Torus | Creates a new GeTorus object.
Vector | Creates a new GeVector object.
Properties
Name | Description
Application | Gets the GeApplication object.
Links
IGeApplication Interface, Legend, Methods, Properties


IGeApplication::Application Property

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Application Property
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::AugmentedLine Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::AugmentedLine Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::AugmentedLine Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeAugmentedLine object.

Visual Basic
Sub AugmentedLine(Points As [in, optional]VARIANT, Normals As [in, optional]VARIANT, Line As [out, retval]IGeAugmentedLine*)
Parameters
Parameters | Description
Points | Variant (GePoints collection); input-only; optional. Specifies the points of the polyline.
Normals | Variant (GeVectors collection); input-only; optional. Specifies the normals at the corresponding point.
Returns

GeAugmentedLine object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::BoundBlock Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::BoundBlock Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::BoundBlock Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Create a new GeBoundBlock object.

Visual Basic
Sub BoundBlock(Base As [in, optional]VARIANT, PointDirection1 As [in, optional]VARIANT, Direction2 As [in, optional]VARIANT, Direction3 As [in, optional]VARIANT, Block As [out, retval]IGeBoundBlock*)
Parameters
Parameters | Description
Base | Variant ( GePoint object); input-only; optional. Specifies the base bound point.
PointDirection1 | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point of a parallelepiped, or the first vector of three describing the sides.
Direction2 | Variant ( GeVector object); input-only; optional. Specifies the second vector of three describing the sides.
Direction3 | Variant ( GeVector object); input-only; optional. Specifies the third vector of three describing the sides.
Returns

GeBoundBlock object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::CircularArc Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::CircularArc Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::CircularArc Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a GeCircularArc object.

Visual Basic
Sub CircularArc(Center As [in, optional]VARIANT, Normal As [in, optional]VARIANT, Radius As [in, optional]VARIANT, ReferenceVector As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Arc As [out, retval]IGeCircularArc*)
Parameters
Parameters | Description
Center | Variant ( GePoint object); input-only; optional. Specifies the center point of the circle.
Normal | Variant ( GeVector object); input-only; optional. Specifies the normal vector of the arc.
Radius | Variant (Double); input-only; optional. Specifies the radius of the circle or arc.
ReferenceVector | Variant ( GeVector object); input-only; optional. Specifies the reference vector for the arc.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the arc.
Returns

GeCircularArc object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Collection Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Collection Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Collection Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new collection object of the specified type.

Visual Basic
Sub Collection(Type As GeCollectionType, Collection As [out, retval] LPDISPATCH)
Parameters
Parameters | Description
Type | Integer; input-only. Specifies the collection type to create.
Returns

It returns the specified collection object.

Remarks

Valid types include:

  • GeCurveBoundaries
  • geCurves
  • geEntities
  • gePoints
  • GeSurfaces
  • geVectors
Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::CompositeCurve Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::CompositeCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::CompositeCurve Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeCompositeCurve object.

Visual Basic
Sub CompositeCurve(Curves As [in, optional]VARIANT, Curve As [out, retval]IGeCompositeCurve*)
Parameters
Parameters | Description
Curves | Variant ( GeCurves collection); input-only; optional. Specifies the curves that make up the composite curve. The end points of the curves specified by the Curves element should be equal to the start point of any consecutive curves in the list (no verification of this is performed). If the Curves element is not specified, the composite curve will consist of a single element which is a line segment from 0,0,0 to 1,0,0.
Returns

GeCompositeCurve object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Cone Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Cone Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Cone Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a GeCone object.

Visual Basic
Sub Cone(Cosine As [in, optional]VARIANT, Sine As [in, optional]VARIANT, Origin As [in, optional]VARIANT, Radius As [in, optional]VARIANT, SymmetryAxis As [in, optional]VARIANT, ReferenceAxis As [in, optional]VARIANT, Height As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Cone As [out, retval]IGeCone*)
Parameters
Parameters | Description
Cosine | Variant (Double); input-only; optional. Specifies the cosine of the angle formed by the cone generated and its axis.
Sine | Variant (Double); input-only; optional. Specifies the sine of the angle formed by the cone generated and its axis.
Origin | Variant ( GePoint object); input-only; optional. Specifies the center point of the base.
Radius | Variant (Double); input-only; optional. Specifies the radius of the circular base.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector on the base.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cone.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

GeCone object

Remarks

The default cone is Initialized with the sine angle to -sin(PI/4), the cosine angle to cos(PI/4), the axis of symmetry to <0,1,0>, the reference axis to <1,0,0>, the base origin to <0,0,0>, and the base radius to 2.0.

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::CurveBoundary Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::CurveBoundary Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::CurveBoundary Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a GeCurveBoundary object.

Visual Basic
Sub CurveBoundary(Geometry3d As [in, optional] VARIANT, Geometry2d As [in, optional] VARIANT, Orientation3d As [in, optional] VARIANT, Orientation2d As [in, optional] VARIANT, Boundary As [out, retval] IGeCurveBoundary*)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); input-only; optional.
Geometry2d | Variant (array of GeCurve objects); input-only; optional.
Orientation3d | Variant(array of Booleans); input-only; optional. Specifies the logical orientation of the corresponding entity in the Geometry3d element.
Orientation2d | Variant(array of Booleans); input-only; optional. Specifies the logical orientation of the corresponding curves in the Geometry2d element.
Returns

GeCurveBoundary object

Remarks

If any of the optional elements are specified:

  • They all must be specified.
  • The length of all of the arrays must be the same.
Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Cylinder Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Cylinder Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Cylinder Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a GeCylinder object.

Visual Basic
Sub Cylinder(Radius As [in, optional]VARIANT, Origin As [in, optional]VARIANT, SymmetryAxis As [in, optional]VARIANT, ReferenceAxis As [in, optional]VARIANT, Height As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Cylinder As [out, retval]IGeCylinder*)
Parameters
Parameters | Description
Radius | Variant (Double); input-only; optional. Specifies the radius of the cylinder.
Origin | Variant ( GePoint object); input-only. The base point on the cylinder axis.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the cylinder's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector on the base.
Height | Variant ( GeInterval object); input-only; optional. The interval height of the cylinder.
StartAngle | Variant (Double); input-only; optional. The start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. The end angle on the base circle.
Returns

GeCylinder object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::EllipticalArc Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::EllipticalArc Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::EllipticalArc Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeEllipticalArc object.

Visual Basic
Sub EllipticalArc(Center As [in, optional]VARIANT, MajorAxis As [in, optional]VARIANT, MinorAxis As [in, optional]VARIANT, MajorRadius As [in, optional]VARIANT, MinorRadius As [in, optional]VARIANT, StartAngle As [in, optional]VARIANT, EndAngle As [in, optional]VARIANT, Arc As [out, retval]IGeEllipticalArc*)
Parameters
Parameters | Description
Center | Variant ( GePoint object), Specifies the default value is (0,0,0); input-only; optional. Specifies Specifies the center point of the ellipse.
MajorAxis | Variant ( GeVector object), the default value is (1,0,0); input-only; optional. Specifies the major axis of the ellipse.
MinorAxis | Variant ( GeVector object), the default value is (0,1,0); input-only; optional. Specifies the minor axis of the ellipse.
MajorRadius | Variant (Double), the default value is 1; input-only; optional. Specifies the major radius of the ellipse.
MinorRadius | Variant (Double), the default value is 1; input-only; optional. Specifies the minor radius of the ellipse.
StartAngle | Variant (Double), the default value is 0; input-only; optional. Specifies the angle of the elliptical arc start point.
EndAngle | Variant (Double), the default value is 2*pi; input-only; optional. Specifies the angle of the elliptical arc end point.
Returns

GeEllipticalArc object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Interval Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Interval Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Interval Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeInterval object.

Visual Basic
Sub Interval(Lower As [in, optional]VARIANT, Upper As [in, optional]VARIANT, Tolerance As [in, optional]VARIANT, Interval As [out, retval]IGeInterval*)
Parameters
Parameters | Description
Lower | Variant (Double); input-only; optional. Specifies the lower interval bound.
Upper | Variant (Double); input-only; optional. The upper interval bound.
Tolerance | Variant (Double), the default value is 1.0e-12; input-only; optional. Specifies the boundary tolerance of Specifies the interval.
Remarks

If Specifies the Lower and Upper bounds are not specified, creates an infinite interval.

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::KnotVector Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::KnotVector Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::KnotVector Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeKnotVector object.

Visual Basic
Sub KnotVector(Tolerance As [in, defaultvalue(1.0e-9)] double, pKnot As [out, retval]IGeKnotVector*)
Parameters
Parameters | Description
Tolerance | Double, the default value is 1.0e-9; input-only; optional. Specifies the tolerance used for calculations.
Returns

GeKnotVector object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Line Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Line Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Line Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeLine object.

Visual Basic
Sub Line(Point As [in, optional]VARIANT, PointVector As [in, optional]VARIANT, Line As [out, retval]IGeLine*)
Parameters
Parameters | Description
Point | Variant ( GePoint object); input-only; optional. Specifies a point that the line passes through.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point, or direction vector from the first point to define the line.
Returns

GeLine object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::LineSegment Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::LineSegment Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::LineSegment Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeLineSegment object.

Visual Basic
Sub LineSegment(Point As [in, optional]VARIANT, PointVector As [in, optional]VARIANT, Line As [out, retval]IGeLineSegment*)
Parameters
Parameters | Description
Point | Variant ( GePoint object); input-only; optional. Specifies the start point of the line segment.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point, or vector from the start point of the line segment.
Returns

GeLineSegment object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Matrix Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Matrix Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Matrix Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeMatrix object set to identity.

Visual Basic
Sub Matrix(Matrix As [out, retval]IGeMatrix*)
Returns

GeMatrix object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::NurbCurve Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::NurbCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::NurbCurve Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeNurbCurve object, which is a 3D rational spline by a knot vector, control points, and weights.

Visual Basic
Sub NurbCurve(Degree As [in, optional] VARIANT, Knots As [in, optional] VARIANT, ControlPoints As [in, optional] VARIANT, Weights As [in, optional] VARIANT, Periodic As [in, optional] VARIANT, Curve As [out, retval] IGeNurbCurve*)
Parameters
Parameters | Description
Degree | Variant (Integer); input-only; optional. Specifies the degree of the spline (order 1) .
Knots | Variant ( GeKnotVector object); input-only; optional. Specifies an array of knot values, partitioning spline's domain into rational pieces.
ControlPoints | Variant ( GePoints collection); input-only; optional. Specifies the control points of the spline.
Weights | Variant (array of Doubles); input-only; optional. Specifies an array of weight values. If not specified, the curve is non-rational.
Periodic | Variant (Boolean), the default value is FALSE; input-only; optional. Specifies whether the spline is closed, FALSE, or periodic, TRUE.
Returns

GeNurbCurve object

Remarks
  • ControlPoints and Weights must have same length.
  • If Periodic is FALSE, the length of the knot vector must be greater than length of the control point collection by degree + 1; If Periodic is TRUE then the knot vector and the control point collection must have same length and the first and the last control points as well as the corresponding weights must be identical.
Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::NurbSurface Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::NurbSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::NurbSurface Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeNurbSurface object.

Visual Basic
Sub NurbSurface(DegreeU As [in, optional] VARIANT, DegreeV As [in, optional] VARIANT, PropertiesU As [in, optional] VARIANT, PropertiesV As [in, optional] VARIANT, PointsInU As [in, optional] VARIANT, PointsInV As [in, optional] VARIANT, Points As [in, optional] VARIANT, Weights As [in, optional] VARIANT, KnotsU As [in, optional] VARIANT, KnotsV As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Surface As [out, retval] IGeNurbSurface*)
Parameters
Parameters | Description
DegreeU | Variant (integer); input-only; optional. Specifies the degree in the U direction.
DegreeV | Variant (integer); input-only; optional. Specifies the degree in the V direction.
PropertiesU | Variant (integer); input-only; optional. Specifies the properties in the U direction.
PropertiesV | Variant (integer); input-only; optional. Specifies the properties in the V direction.
PointsInU | Variant (Integer); input-only; optional. Specifies the number of U control points.
PointsInV | Variant (Integer); input-only; optional. Specifies the number of V control points.
Points | Variant ( GePoints collection object); input-only; optional. Specifies the control points.
Weights | Variant (array of Doubles); input-only; optional. Specifies the weights at the control points..
KnotsU | Variant ( GeKnotVector object); input-only; optional. Specifies the knots in the U direction.
KnotsV | Variant ( GeKnotVector object); input-only; optional. Specifies the knots in the V direction.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance used for calculations.
Returns

GeNurbSurface object

Remarks
  • If no arguments are specified an empty surface is constructed; otherwise, all elements must be specified with an exception of the tolerance which is optional.
  • The parameter direction properties are a combination of the following enumeration members in GeNurbSurfaceProperties.
Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::OffsetCurve Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::OffsetCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::OffsetCurve Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeOffsetCurve object.

Visual Basic
Sub OffsetCurve(Curve As IGeCurve, Normal As IGeVector, Offset As [in, defaultvalue(0.0)] double, OffsetCurve As [out, retval] IGeOffsetCurve*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the planar Curve to offset.
Normal | GeVector object; input-only. The normal in the plane of the curve.
Offset | Double, the default value is 0.0; input-only; optional. Specifies the offset distance.
Returns

GeOffsetCurve object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::OffsetSurface Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::OffsetSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::OffsetSurface Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeOffsetSurface object.

Visual Basic
Sub OffsetSurface(Surface As [in, optional] VARIANT, Offset As [in, optional] VARIANT, OffsetSurface As [out, retval] IGeOffsetSurface*)
Parameters
Parameters | Description
Surface | Variant ( GeSurface object); input-only; optional. Specifies the surface to offset.
Offset | Variant (Double), the default value is 0.0; input-only; optional. Specifies the offset distance.
Returns

GeOffsetSurface object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Plane Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Plane Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Plane Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GePlane object.

Visual Basic
Sub Plane(Origin As [in, optional] VARIANT, Normal As [in, optional] VARIANT, Plane As [out, retval] IGePlane*)
Parameters
Parameters | Description
Origin | Variant ( GePoint object), the default value is (0,0,0); input-only; optional. Specifies the origin point of the plane.
Normal | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the normal vector of the plane.
Returns

GePlane object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Point Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Point Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Point Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GePoint object.

Visual Basic
Sub Point(X As [in, defaultvalue(0.0)]double, Y As [in, defaultvalue(0.0)]double, Z As [in, defaultvalue(0.0)]double, Point As [out, retval]IGePoint*)
Parameters
Parameters | Description
X | Double, the default value is 0; input-only; optional. Specifies the X coordinate of the point.
Y | Double, the default value is 0; input-only; optional. Specifies the Y coordinate of the point.
Z | Double, the default value is 0; input-only; optional. Specifies the Z coordinate of the point.
Returns

GePoint object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Ray Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Ray Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Ray Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeRay object.

Visual Basic
Sub Ray(Origin As [in, optional] VARIANT, PointVector As [in, optional] VARIANT, Ray As [out, retval] IGeRay*)
Parameters
Parameters | Description
Origin | Variant ( GePoint object); input-only; optional. Specifies the start point of the ray.
PointVector | Variant ( GePoint or GeVector object); input-only; optional. Specifies a second point on the ray, or a vector indicating the ray direction.
Returns

GeRay object

Remarks

The default ray constructed starts at (0,0,0) and is in the (1,0,0) direction.

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Sphere Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Sphere Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Sphere Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeSphere object.

Visual Basic
Sub Sphere(Radius As [in, defaultvalue(1.0)] double, Center As [in, optional] VARIANT, NorthAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT, Sphere As [out, retval] IGeSphere*)
Parameters
Parameters | Description
Radius | Double, the default value is 1.0; input-only; optional. Specifies the radius of the sphere.
Center | Variant ( GePoint object), default (0,0,0); input-only; optional. Specifies the center point of the sphere.
NorthAxis | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the direction of the north pole of the sphere.
ReferenceAxis | Variant (GeVector object), the default value is (1,0,0); input-only; optional. Specifies the reference vector for the measured angles.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitude angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitude angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitude angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitude angle.
Returns

GeSphere object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Tolerance Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Tolerance Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Tolerance Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeTolerance object.

Visual Basic
Sub Tolerance(EqualPoint As [in, defaultvalue(1.0e-10)] double, EqualVector As [in, defaultvalue(1.0e-10)] double, Tolerance As [out, retval] IGeTolerance*)
Parameters
Parameters | Description
EqualPoint | Double, the default value is 1.0e-10; input-only; optional.
EqualVector | Double, the default value is 1.0e-10; input-only; optional.
Returns

GeTolerance object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Torus Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Torus Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Torus Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeTorus object.

Visual Basic
Sub Torus(MajorRadius As [in, defaultvalue(1.0)] double, MinorRadius As [in, defaultvalue(2.0)] double, Origin As [in, optional] VARIANT, Axis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT, Torus As [out, retval] IGeTorus*)
Parameters
Parameters | Description
MajorRadius | Double, the default value is 1.0; input-only; optional. Specifies the major radius of the torus.
MinorRadius | Double; default 2.0; input-only; optional. Specifies the minor radius of the torus.
Origin | Variant ( GePoint object); default (0,0,0); input-only; optional . The center point of the torus.
Axis | Variant ( GeVector object), the default value is (0,0,1); input-only; optional. Specifies the axis of symmetry of the torus.
ReferenceAxis | Variant (GeVector object), the default value is (1,0,0); input-only; optional. Specifies the reference vector for the measured angles.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitude angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitude angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitude angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitude angle.
Returns

GeTorus object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeApplication::Vector Method

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication::Vector Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication::Vector Method
IGeApplication Interface IGeApplication Members IGeApplication Interface Send Feedback
Summary

Creates a new GeVector object.

Visual Basic
Sub Vector(X As [in, defaultvalue(0)]double, Y As [in, defaultvalue(0)]double, Z As [in, defaultvalue(0)]double, Vector As [out, retval]IGeVector*)
Parameters
Parameters | Description
X | Double, the default value is 0; input-only; optional. Specifies the X coordinate of the vector.
Y | Double, the default value is 0; input-only; optional. Specifies the Y coordinate of the point.
Z | Double, the default value is 0; input-only; optional. Specifies the Z coordinate of the vector.
Returns

GeVector object

Interface

IGeApplication Interface

Links
IGeApplication Interface, IGeApplication Members, IGeApplication Interface


IGeAugmentedLine Interface

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine Interface
IGeAugmentedLine Members GEAuto Library Class Hierarchy Send Feedback
Summary

A multisegmented curve with normal information at the nodes.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeAugmentedLine
Visual Basic
Public Interface IGeAugmentedLine
Inherits IGeCurve
Library

GEAuto Library

Links
IGeAugmentedLine Members, GEAuto Library, Class Hierarchy


IGeAugmentedLine Members

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine Members
IGeAugmentedLine Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeAugmentedLine.

Interface

IGeAugmentedLine Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PointAt | Specifies the point at the specified index on this augmented line.
PointAt | Specifies the point at the specified index on this augmented line.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
Set | Changes the definition of the augmented line to pass through the specified turning points respectively in the direction of the specified vectors.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
VectorAt | Specifies the normal vector at the specified index on this augmented line.
VectorAt | Specifies the normal vector at the specified index on this augmented line.
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.
Points | Gets the list of points defining the augmented line.
SecondDerivatives | Gets the list of second order derivative vectors from this augmented line.
Vectors | Gets the list of vectors at the points that define this augmented line.
Links
IGeAugmentedLine Interface, Legend, Methods, Properties


IGeAugmentedLine::Points Property

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::Points Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::Points Property
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Gets the list of points defining the augmented line.

Visual Basic
Property Points() As IGePoints**
Remarks

This property is a gePoints collection.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::SecondDerivatives Property

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::SecondDerivatives Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::SecondDerivatives Property
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Gets the list of second order derivative vectors from this augmented line.

Visual Basic
Property SecondDerivatives() As IGeVectors**
Remarks

This property is a geVectors object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::Vectors Property

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::Vectors Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::Vectors Property
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Gets the list of vectors at the points that define this augmented line.

Visual Basic
Property Vectors() As IGeVectors**
Remarks

This property is a geVectors object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the point at the specified index on this augmented line.

Visual Basic
Sub PointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point on this augmented line.
Remarks

This property is a GePoint object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the point at the specified index on this augmented line.

Visual Basic
Sub PointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point on this augmented line.
Remarks

This property is a GePoint object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the second order derivative vector at the specified index on the augmented line.

Visual Basic
Sub SecondDerivativeAt(Index As long, Vector As IGeVector)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the second order derivative vector.
Remarks

This property is a GeVector object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the second order derivative vector at the specified index on the augmented line.

Visual Basic
Sub SecondDerivativeAt(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the second order derivative vector.
Remarks

This property is a GeVector object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::Set Method

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::Set Method
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Changes the definition of the augmented line to pass through the specified turning points respectively in the direction of the specified vectors.

Visual Basic
Sub Set(Points As IGePoints, Vectors As IGeVectors)
Parameters
Parameters | Description
Points | GePoints collection object; input-only. Specifies a series of continuous turning points for the definition of the augmented line.
Vectors | GeVectors collection object; input-only. Specifies a series of direction vectors that correspond to each turning point.
Returns

None

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the normal vector at the specified index on this augmented line.

Visual Basic
Sub VectorAt(Index As long, Vector As IGeVector)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the normal vector.
Remarks

This property is a GeVector object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)
IGeAugmentedLine Interface IGeAugmentedLine Members IGeAugmentedLine Interface Send Feedback
Summary

Specifies the normal vector at the specified index on this augmented line.

Visual Basic
Sub VectorAt(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index that corresponds to the point to calculate the normal vector.
Remarks

This property is a GeVector object.

Interface

IGeAugmentedLine Interface

Links
IGeAugmentedLine Interface, IGeAugmentedLine Members, IGeAugmentedLine Interface


IGeBoundBlock Interface

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock Interface
IGeBoundBlock Members GEAuto Library Class Hierarchy Send Feedback
Summary

A spatial bounding volume.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeBoundBlock
Visual Basic
Public Interface IGeBoundBlock
Inherits IGeEntity
Library

GEAuto Library

Links
IGeBoundBlock Members, GEAuto Library, Class Hierarchy


IGeBoundBlock Members

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock Members
IGeBoundBlock Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeBoundBlock.

Interface

IGeBoundBlock Interface

Methods
Name | Description
Contains | Determines whether the specified point lies within the bounding box, TRUE, or not, FALSE.
Extend | Extends the bounding box to include the specified point.
IsDisjoint | Determines whether the specified bounding box does not intersect or is disjoint with this bounding box, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Swell | Expands the bounding box on all sides by the specified distance.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BasePoint | Specifies the base point of the bounding block.
Direction1 | Specifies the first edge from the base point of the bounding box.
Direction2 | Specifies the second edge from the base point of the bounding box.
Direction3 | Specifies the third edge from the base point of the bounding box.
IsBox | Specifies whether the bounding box is an orthogonal coordinate box, TRUE, or not, FALSE.
MaxPoint | Specifies the maximum point of the bounding box.
MinPoint | Specifies the minimum point of the bounding box.
Links
IGeBoundBlock Interface, Legend, Methods, Properties


IGeBoundBlock::BasePoint Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::BasePoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::BasePoint Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the base point of the bounding block.

Visual Basic
Property BasePoint() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Direction1 Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Direction1 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Direction1 Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the first edge from the base point of the bounding box.

Visual Basic
Property Direction1() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Direction2 Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Direction2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Direction2 Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the second edge from the base point of the bounding box.

Visual Basic
Property Direction2() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Direction3 Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Direction3 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Direction3 Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the third edge from the base point of the bounding box.

Visual Basic
Property Direction3() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::IsBox Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::IsBox Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::IsBox Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies whether the bounding box is an orthogonal coordinate box, TRUE, or not, FALSE.

Visual Basic
Property IsBox() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::MaxPoint Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::MaxPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::MaxPoint Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the maximum point of the bounding box.

Visual Basic
Property MaxPoint() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::MinPoint Property

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::MinPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::MinPoint Property
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Specifies the minimum point of the bounding box.

Visual Basic
Property MinPoint() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Contains Method

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Contains Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Contains Method
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Determines whether the specified point lies within the bounding box, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Point As IGePoint, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Returns

Boolean

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Extend Method

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Extend Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Extend Method
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Extends the bounding box to include the specified point.

Visual Basic
Sub Extend(Point As IGePoint)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to include to the bounding box.
Returns

None

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::IsDisjoint Method

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::IsDisjoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::IsDisjoint Method
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Determines whether the specified bounding box does not intersect or is disjoint with this bounding box, TRUE, or not, FALSE.

Visual Basic
Sub IsDisjoint(Bound As IGeBoundBlock, Disjoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Bound | GeBoundBlock object; input-only. Specifies the other bounding box to perform the check.
Returns

Boolean

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundBlock::Swell Method

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock::Swell Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock::Swell Method
IGeBoundBlock Interface IGeBoundBlock Members IGeBoundBlock Interface Send Feedback
Summary

Expands the bounding box on all sides by the specified distance.

Visual Basic
Sub Swell(Distance As double)
Parameters
Parameters | Description
Distance | Double; input-only. Specifies the distance in which to expand the bounding box.
Returns

None

Interface

IGeBoundBlock Interface

Links
IGeBoundBlock Interface, IGeBoundBlock Members, IGeBoundBlock Interface


IGeBoundedSurface Interface

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface Interface
IGeBoundedSurface Members GEAuto Library Class Hierarchy Send Feedback
Summary

Surface with trimming boundary information.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeBoundedSurface
Visual Basic
Public Interface IGeBoundedSurface
Inherits IGeSurface
Library

GEAuto Library

Links
IGeBoundedSurface Members, GEAuto Library, Class Hierarchy


IGeBoundedSurface Members

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface Members
IGeBoundedSurface Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeBoundedSurface.

Interface

IGeBoundedSurface Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Gets the unbounded base surface geometry.
ContourCount | Gets the number of contour boundaries on the surface.
Contours | Obtains the contour objects that make up the boundary loops on this bounded surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeBoundedSurface Interface, Legend, Methods, Properties


IGeBoundedSurface::BaseSurface Property

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface::BaseSurface Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface::BaseSurface Property
IGeBoundedSurface Interface IGeBoundedSurface Members IGeBoundedSurface Interface Send Feedback
Summary

Gets the unbounded base surface geometry.

Visual Basic
Property BaseSurface() As IGeSurface**
Remarks

This property is a GeSurface object.

Interface

IGeBoundedSurface Interface

Links
IGeBoundedSurface Interface, IGeBoundedSurface Members, IGeBoundedSurface Interface


IGeBoundedSurface::ContourCount Property

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface::ContourCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface::ContourCount Property
IGeBoundedSurface Interface IGeBoundedSurface Members IGeBoundedSurface Interface Send Feedback
Summary

Gets the number of contour boundaries on the surface.

Visual Basic
Property ContourCount() As long*
Remarks

This property is a Long.

Interface

IGeBoundedSurface Interface

Links
IGeBoundedSurface Interface, IGeBoundedSurface Members, IGeBoundedSurface Interface


IGeBoundedSurface::Contours Property

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface::Contours Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface::Contours Property
IGeBoundedSurface Interface IGeBoundedSurface Members IGeBoundedSurface Interface Send Feedback
Summary

Obtains the contour objects that make up the boundary loops on this bounded surface.

Visual Basic
Property Contours() As IGeCurveBoundaries**
Remarks

This property is a geCurveBoundaries collection.

Interface

IGeBoundedSurface Interface

Links
IGeBoundedSurface Interface, IGeBoundedSurface Members, IGeBoundedSurface Interface


IGeCircularArc Interface

You are here: API Reference > GEAuto Library > IGeCircularArc Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc Interface
IGeCircularArc Members GEAuto Library Class Hierarchy Send Feedback
Summary

A circle or circular arc curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeCircularArc
Visual Basic
Public Interface IGeCircularArc
Inherits IGeCurve
Library

GEAuto Library

Links
IGeCircularArc Members, GEAuto Library, Class Hierarchy


IGeCircularArc Members

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc Members
IGeCircularArc Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCircularArc.

Interface

IGeCircularArc Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this circular arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the circular arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the circular arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TangentAt | Determines whether the input point lies on the circular arc, TRUE, or not, FALSE.
TangentTangentRadius | Changes the definition of the circular arc to be tangent to the two input curves and have the specified radius and returns whether this method succeeds, TRUE, or fails, FALSE.
TangentTangentTangent | Changes the definition of the arc to be a circle tangent to the three input curves if possible and returns whether this method succeeds, TRUE, or fails, FALSE.
ThreePoint | Changes the definition of the arc to have the specified start and end points and pass through the specified point.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the circular arc.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this circular arc.
Radius | Specifies the radius of the circular arc.
ReferenceVector | Specifies the reference vector of the circular arc from which the start and end angles are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.
Links
IGeCircularArc Interface, Legend, Methods, Properties


IGeCircularArc::Center Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::Center Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::Center Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the center point of the arc.

Visual Basic
Property Center() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::EndAngle Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::EndAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::EndAngle Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the angle of the end point with respect to the reference vector in the plane of the circular arc.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::Normal Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::Normal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::Normal Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the normal vector of this circular arc.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::Radius Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::Radius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::Radius Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the radius of the circular arc.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::ReferenceVector Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::ReferenceVector Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::ReferenceVector Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the reference vector of the circular arc from which the start and end angles are measured.

Visual Basic
Property ReferenceVector() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::StartAngle Property

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::StartAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::StartAngle Property
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Specifies the angle of the start point with respect to the reference vector in the plane of the arc.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::IntersectWith Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Determines whether the specified geometry entity intersects with this circular arc, TRUE, or not, FALSE. They do not need to lie in the same plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Direction As [in, optional] VARIANT, LinePoint1 As [in, out, optional] VARIANT, LinePoint2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersects As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeCircularArc , GeLinearEntity, or GePlane object.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Direction | Variant ( GeVector object); input-only; optional. Specifies the normal of a plane that this circular arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when the GeEntity element is a GeLinearEntity.
LinePoint1 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
LinePoint2 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::IsInside Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::IsInside Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::IsInside Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the circular arc, FALSE.

Visual Basic
Sub IsInside(Point As IGePoint, Tolerance As [in, optional] VARIANT, Inside As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

This method treats the arc as a full circle or ellipse even if it is bounded and determines if the specified point lies inside of the full circle or ellipse.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::Set Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::Set Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Sets the circular arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.

Visual Basic
Sub Set(Center As IGePoint, Normal As IGeVector, Radius As double, ReferenceVector As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Center | GePoint object; input-only. Specifies the center point of the circular arc.
Normal | GeVector object; input-only. Specifies the normal vector of the circular arc.
Radius | Double; input-only. Specifies the radius of the circular arc.
ReferenceVector | Variant ( GeVector object); input-only; optional. Specifies the reference vector for the circular arc.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the circular arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the circular arc.
Returns

None

Remarks

If the reference vector, start or end angles are specified, they all must be specified.

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::TangentAt Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::TangentAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::TangentAt Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Determines whether the input point lies on the circular arc, TRUE, or not, FALSE.

Visual Basic
Sub TangentAt(Point As IGePoint, ByRef Line As IGeLine*, Tolerance As [in, optional] VARIANT, Tangent As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to locate the tangent of.
Line | GeLine object; output-only. Specifies the tangent line at the point. The tangent line will be only set if the method returns TRUE.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::TangentTangentRadius Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::TangentTangentRadius Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::TangentTangentRadius Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Changes the definition of the circular arc to be tangent to the two input curves and have the specified radius and returns whether this method succeeds, TRUE, or fails, FALSE.

Visual Basic
Sub TangentTangentRadius(Curve1 As IGeCurve, Curve2 As IGeCurve, Radius As double, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to define the circular arc.
Curve2 | GeCurve object; input-only. Specifies the second curve to define the circular arc.
Radius | Double; input-only. Specifies the radius to define the circular arc.
Parameter1 | Variant (Double); optional. Specifies the parameter on Curve1 where the arc is tangent.
Parameter2 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Returns

Boolean

Remarks
  • The two input curves must be coplanar.
  • This method computes an arc whose endpoints are the points on the two input curves that correspond to the Parameter1 and Parameter2 elements.
  • If this method fails to compute the arc, it returns FALSE and the arc is not changed.
Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::TangentTangentTangent Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::TangentTangentTangent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::TangentTangentTangent Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Changes the definition of the arc to be a circle tangent to the three input curves if possible and returns whether this method succeeds, TRUE, or fails, FALSE.

Visual Basic
Sub TangentTangentTangent(Curve1 As IGeCurve, Curve2 As IGeCurve, Curve3 As IGeCurve, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Parameter3 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to define the circular arc.
Curve2 | GeCurve object; input-only. Specifies the second curve to define the circular arc.
Curve3 | GeCurve object; input-only. Specifies the third curve to define the circular arc.
Parameter1 | Variant (Double); optional. Specifies the parameter on Curve1 where the arc is tangent.
Parameter2 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Parameter3 | Variant (Double); optional. Specifies the parameter on Curve2 where the arc is tangent.
Returns

Boolean

Remarks
  • The input curves must be coplanar.
  • This method computes an arc whose endpoints are the points on the input curves that correspond to Parameter1, Parameter2, and Parameter3.
  • If this method fails to compute the arc, it returns FALSE and the arc is not changed.
Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCircularArc::ThreePoint Method

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc::ThreePoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc::ThreePoint Method
IGeCircularArc Interface IGeCircularArc Members IGeCircularArc Interface Send Feedback
Summary

Changes the definition of the arc to have the specified start and end points and pass through the specified point.

Visual Basic
Sub ThreePoint(Point1 As IGePoint, Point2 As IGePoint, Point3 As IGePoint)
Parameters
Parameters | Description
Point1 | GePoint object; input-only. Specifies the first point to define the circular arc.
Point2 | GePoint object; input-only. Specifies the second point to define the circular arc.
Point3 | GePoint object; input-only. Specifies the third point to define the circular arc.
Returns

None

Remarks

  • None of the three points may be coincindent and they may not be colinear.
  • This method always returns a bounded circular arc.
Interface

IGeCircularArc Interface

Links
IGeCircularArc Interface, IGeCircularArc Members, IGeCircularArc Interface


IGeCompositeCurve Interface

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve Interface
IGeCompositeCurve Members GEAuto Library Class Hierarchy Send Feedback
Summary

A curve composed of multiple component curves connected end to end.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeCompositeCurve
Visual Basic
Public Interface IGeCompositeCurve
Inherits IGeCurve
Remarks

For instance, a composite curve could consist of four straight line segments that form a square. Each of the component curves must be bounded curves, which means that infinite lines and rays may not be used as component curves of a composite. The component curves are not required to all lie in the same plane. The start parameter of a composite is 0.0. The parameter value at the end point of the first component curve will be the approximate length of the first curve (call this value l1). The parameter value at the end point of the second curve will be l1 + the approximate length of the second curve, and so on.

Library

GEAuto Library

Links
IGeCompositeCurve Members, GEAuto Library, Class Hierarchy


IGeCompositeCurve Members

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve Members
IGeCompositeCurve Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCompositeCurve.

Interface

IGeCompositeCurve Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
GlobalToLocal | Determines the parameter value on the specified component curve corresponding to the specified parameter value on the overall composite curve.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
LocalToGlobal | Determines the parameter value on the composite curve corresponding to the specified parameter value on the composite curve at the specified index.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Curves | Specifies the component curves that make up the composite curve.
Interval | Sets the interval of the curve and returns the index of the interval.
Links
IGeCompositeCurve Interface, Legend, Methods, Properties


IGeCompositeCurve::Curves Property

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve::Curves Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve::Curves Property
IGeCompositeCurve Interface IGeCompositeCurve Members IGeCompositeCurve Interface Send Feedback
Summary

Specifies the component curves that make up the composite curve.

Visual Basic
Property Curves() As IGeCurves*
Remarks

This property is a geCurves collection.

Interface

IGeCompositeCurve Interface

Links
IGeCompositeCurve Interface, IGeCompositeCurve Members, IGeCompositeCurve Interface


IGeCompositeCurve::GlobalToLocal Method

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve::GlobalToLocal Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve::GlobalToLocal Method
IGeCompositeCurve Interface IGeCompositeCurve Members IGeCompositeCurve Interface Send Feedback
Summary

Determines the parameter value on the specified component curve corresponding to the specified parameter value on the overall composite curve.

Visual Basic
Sub GlobalToLocal(Global As double, ByRef Index As long, Local As [out, retval] double)
Parameters
Parameters | Description
Global | Double; input-only. Specifies the parameter value on the composite curve.
Index | Integer; input-only. Specifies the index of the component curve to which to map the parameter.
Returns

Double

Interface

IGeCompositeCurve Interface

Links
IGeCompositeCurve Interface, IGeCompositeCurve Members, IGeCompositeCurve Interface


IGeCompositeCurve::LocalToGlobal Method

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve::LocalToGlobal Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve::LocalToGlobal Method
IGeCompositeCurve Interface IGeCompositeCurve Members IGeCompositeCurve Interface Send Feedback
Summary

Determines the parameter value on the composite curve corresponding to the specified parameter value on the composite curve at the specified index.

Visual Basic
Sub LocalToGlobal(Local As double, Index As long, Global As [out, retval] double)
Parameters
Parameters | Description
Local | Double; input-only. Specifies the parameter value on the component curve.
Index | Integer; input-only. Specifies the index of the component curve.
Returns

Double

Interface

IGeCompositeCurve Interface

Links
IGeCompositeCurve Interface, IGeCompositeCurve Members, IGeCompositeCurve Interface


IGeCone Interface

You are here: API Reference > GEAuto Library > IGeCone Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone Interface
IGeCone Members GEAuto Library Class Hierarchy Send Feedback
Summary

A bounded right circular cone.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeCone
Visual Basic
Public Interface IGeCone
Inherits IGeSurface
Library

GEAuto Library

Links
IGeCone Members, GEAuto Library, Class Hierarchy


IGeCone Members

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone Members
IGeCone Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCone.

Interface

IGeCone Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
HeightAt | Computes the parameter on the axis of symmetry corresponding to the specified height parameter value of the cone.
IntersectWith | Computes the intersection between the cone and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosed | Specifies whether this cone is a full cone, TRUE, or a conic section, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cone by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Apex | Specifies the apex vertex of the cone.
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cone.
BaseRadius | Specifies the base radius of the cone.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
HalfAngle | Specifies the angle between the axis of symmetry and the generated cone.
Height | Specifies the parameter interval height of the cone.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cone.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cone.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeCone Interface, Legend, Methods, Properties


IGeCone::Apex Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::Apex Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::Apex Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the apex vertex of the cone.

Visual Basic
Property Apex() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::AxisOfSymmetry Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::AxisOfSymmetry Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::AxisOfSymmetry Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the axis of symmetry of this cone.

Visual Basic
Property AxisOfSymmetry() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::BaseRadius Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::BaseRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::BaseRadius Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the base radius of the cone.

Visual Basic
Property BaseRadius() As double
Remarks

This property is a Double.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::EndAngle Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::EndAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::EndAngle Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the angle of the end point with respect to the reference vector in the base of the cone.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::HalfAngle Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::HalfAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::HalfAngle Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the angle between the axis of symmetry and the generated cone.

Visual Basic
Property HalfAngle() As double*
Remarks

This property is a Double.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::Height Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::Height Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::Height Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the parameter interval height of the cone.

Visual Basic
Property Height() As IGeInterval*
Remarks

This property is a GeInterval object.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::Origin Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::Origin Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Gets the center of the base of the cone.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::ReferenceVector Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::ReferenceVector Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::ReferenceVector Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the reference vector from which the start angle and end angle are measured.

Visual Basic
Property ReferenceVector() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::StartAngle Property

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::StartAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::StartAngle Property
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies the angle of the start point with respect to the reference vector in the base of the cone.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::HeightAt Method

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::HeightAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::HeightAt Method
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Computes the parameter on the axis of symmetry corresponding to the specified height parameter value of the cone.

Visual Basic
Sub HeightAt(Parameter As double, Height As [out, retval] double)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the height parameter value of the cone on the axis of symmetry.
Returns

Double

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::IntersectWith Method
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Computes the intersection between the cone and a linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersects As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this cone.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::IsClosed Method

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::IsClosed Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::IsClosed Method
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Specifies whether this cone is a full cone, TRUE, or a conic section, FALSE.

Visual Basic
Sub IsClosed(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCone::Set Method

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone::Set Method
IGeCone Interface IGeCone Members IGeCone Interface Send Feedback
Summary

Changes the definition of this cone by the specified parameters.

Visual Basic
Sub Set(Cosine As double, Sine As double, Center As IGePoint, Radius As double, SymmetryAxis As IGeVector, ReferenceAxis As [in, optional] VARIANT, Height As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Cosine | Double; input-only. Specifies the cosine of the angle formed by the cone generated and its axis.
Sine | Double; input-only. Specifies the sine of the angle formed by the cone generated and its axis.
Center | GePoint object; input-only. Specifies the center point of the circular base.
Radius | Double; input-only. Specifies the radius of the circular base.
SymmetryAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies the reference vector on the circular base.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cone.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

None

Interface

IGeCone Interface

Links
IGeCone Interface, IGeCone Members, IGeCone Interface


IGeCurve Interface

You are here: API Reference > GEAuto Library > IGeCurve Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve Interface
IGeCurve Members GEAuto Library Class Hierarchy Send Feedback
Summary

A generic curve entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeAugmentedLine
        IGeCircularArc
        IGeCompositeCurve
        IGeEllipticalArc
        IGeLinearEntity
        IGeNurbCurve
        IGeOffsetCurve
Visual Basic
Public Interface IGeCurve
Inherits IGeEntity
Library

GEAuto Library

Links
IGeCurve Members, GEAuto Library, Class Hierarchy


IGeCurve Members

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve Members
IGeCurve Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurve.

Interface

IGeCurve Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.
Links
IGeCurve Interface, Legend, Methods, Properties


IGeCurve::Interval Property

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::Interval Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::Interval Property
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Sets the interval of the curve and returns the index of the interval.

Visual Basic
Property Interval() As IGeInterval**
Remarks

This property is a GeInterval object.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::BoundBlock Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::BoundBlock Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::BoundBlock Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Computes the bounding box around the curve or the curve interval.

Visual Basic
Sub BoundBlock(Range As [in, optional] VARIANT, Ortho As [in, optional] VARIANT, Block As [out, retval] IGeBoundBlock*)
Parameters
Parameters | Description
Range | GeInterval object; input-only; optional. Specifies the parameter interval for which to compute the bounding box.
Ortho | Variant (Boolean); input-only; optional. Specifies whether to force a bounding box orthogonal to the coordinate axis, TRUE, or not, FALSE.
Returns

GeBoundBlock object

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::ClosestPointTo Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::ClosestPointTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::ClosestPointTo Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the closest point on this curve to the specified point.

Visual Basic
Sub ClosestPointTo(Point As IGePoint, Parameter As [in, out, optional] VARIANT, ProjectionDirection As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Parameter | Variant (Double); optional. Specifies the parameter of the closest point.
ProjectionDirection | Variant ( GeVector object); input-only; optional. Specifies the normal of the plane to project the curve and point onto.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks

For GeCurve objects: If the optional projection direction element is provided the returned point is the point on the curve which when projected onto a plane whose normal is the projection direction is closest to the specified point. This provides a line of sight closest point to the curve which may not be the actual closest point.

If the optional ProjectDirection element is specified, the returned point is the point on the curve which is closest to the specified point when the curve is projected onto a plane whose normal is the projection direction. This provides a line of sight closest point to the curve which may not be the actual closest point.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::ClosestPointToCurve Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::ClosestPointToCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::ClosestPointToCurve Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the closest point on this curve to the specified curve.

Visual Basic
Sub ClosestPointToCurve(Curve As IGeCurve, ThisParameter As [in, out, optional] VARIANT, OtherParameter As [in, out, optional] VARIANT, Direction As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to calculate the closest point to.
ThisParameter | Variant (Double); optional. Specifies the parameter value on this circular arc of the closest point.
OtherParameter | Variant (Double); optional. Specifies the parameter value on the other curve of the closest point.
Direction | Variant ( GeVector object); input-only; optional. Specifies the normal of the plane to project the circular arc and the other curve onto before the calculation.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks

If the optional ProjectDirection element is specified, the returned point is the point on the curve which is closest to the specified curve when the curve and curve are projected onto the same plane whose normal is the projection direction. This provides a line of sight closest point to the curve which may not be the actual closest point between the curves.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::DistanceTo Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::DistanceTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::DistanceTo Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the minimum distance between this curve to the specified geometry entity.

Visual Basic
Sub DistanceTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Distance As [out, retval] double)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the geometry entity to calculate the minimum distance.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::EvaluatePoint Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::EvaluatePoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::EvaluatePoint Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Returns the point on the curve corresponding to the specified parameter value.

Visual Basic
Sub EvaluatePoint(Parameter As double, DerivativeOrder As [in, optional] VARIANT, Derivatives As [in, out, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value to evaluate the point at.
DerivativeOrder | Variant (Integer); input-only; optional. Specifies the requested derivative order with limit to a value of 2.
Derivatives | Variant ( geVectors Collection); optional. Specifies the derivative arrays up to the order specified by the derivative order. Derivatives are returned as (order 1) dU or (order 2) dU, dUdU.
Returns

GePoint object

Remarks

If the optional Derivatives element is specified, the DerivativeOrder element must be specified.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::GetArea Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::GetArea Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::GetArea Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets the area of the interval of the curve defined by the specified start parameter and end parameter.

Visual Basic
Sub GetArea(StartParameter As double, EndParameter As double, Tolerance As [in, optional] VARIANT, Area As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the start parameter to define an area of the circular arc.
EndParameter | Double; input-only. Specifies the end parameter to define an area of the circular arc.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks
  • The curve must be planar to successfully calculate the area.
  • If the points at StartParameter and EndParameter are the same, this function will return the area of the closed curve; if the points are different, this function will connect the two points with a line segment and return the signed area between the curve and the line segment.
  • If the line segment does not intersect the curve at any points between startParameter and EndParameter, the returned area will be positive; if the line segment intersects the curves at any points between StartParameter and EndParameter, the returned area will be the sum of the sub-areas created by the intersection of the line segment with the curve. Each sub-area will have a positive or negative area depending on whether the curve lies above or below the line segment. The total area returned by this function can therefore be positive, negative, or 0.
Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::GetCurvature Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::GetCurvature Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::GetCurvature Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets the curvature of the curve at the specified parameter value.

Visual Basic
Sub GetCurvature(Parameter As double, Curvature As [out, retval] double)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value on the curve to calculate the curvature.
Returns

Double

Remarks

This function fails if the derivative at the specified parameter value is zero.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::GetLength Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::GetLength Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::GetLength Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets the length of the curve between the two parameter values within the specified tolerance.

Visual Basic
Sub GetLength(StartParameter As double, EndParameter As double, Tolerance As [in, optional] VARIANT, Length As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the start parameter from which to calculate the length.
EndParameter | Double; input-only. Specifies the end parameter from which to calculate the length.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::GetSamplePoints Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::GetSamplePoints Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::GetSamplePoints Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Evaluates a sampling of points along the curve.

Visual Basic
Sub GetSamplePoints(Number As [in, optional] VARIANT, From As [in, optional] VARIANT, To As [in, optional] VARIANT, Deviation As [in, optional] VARIANT, Parameters As [in, out, optional] VARIANT, Points As [out, retval] IGePoints*)
Parameters
Parameters
Description
Number
Variant (Integer); input-only; optional. Specifies the number of sample points to be returned.

  • If specified, the parameter interval of the circular arc is equally subdivided by the number. For instance, if the interval of the circular arc [0,1] and Number is 5, the parameter values of the returned points will be 0,.25,.5,.75, and 1.
  • If specified, all other arguments are ignored.
  • If not specified, the circular arc is sampled between From and To with the specified maximum deviation.

From
Variant (Double); input-only; optional. Specifies the starting parameter value on the polyline from which to evaluate the sampling points.
To
Variant (Double); input-only; optional. Specifies the ending parameter value on the circular arc from which to evaluate the sampling points.
Deviation
Variant (Double); input-only; optional. Specifies the chordal deviation tolerance to be maintained. The arc segment between any two consecutive sample points will not deviate by more than Deviation from the curve.
Returns

gePoints collection

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::GetSplitCurves Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::GetSplitCurves Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::GetSplitCurves Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets two segments which are obtained by splitting the curve at the specified parameter value.

Visual Basic
Sub GetSplitCurves(Parameter As double, ByRef Piece1 As IGeCurve*, ByRef Piece2 As IGeCurve*)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter value at which the circular arc is split.
Piece1 | GeCurve object; output-only. Specifies the first polyline segment.
Piece2 | GeCurve object; output-only. Specifies the second curve segment.
Returns

None

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::HasEndPoint Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::HasEndPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::HasEndPoint Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.

Visual Basic
Sub HasEndPoint(Point As [in, out, optional] VARIANT, HasEndPoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); output-only; optional. Returns the end point if this method returns TRUE.
Remarks

This property is a Boolean.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::HasStartPoint Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::HasStartPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::HasStartPoint Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.

Visual Basic
Sub HasStartPoint(Point As [in, out, optional] VARIANT, HasStartPoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); optional. Returns the start point if this method returns TRUE.
Remarks

This property is a Boolean.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IntersectWithCurve Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IntersectWithCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IntersectWithCurve Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the intersection with the specified curve within the specified tolerance.

Visual Basic
Sub IntersectWithCurve(OtherCurve As IGeCurve, RangeThis As [in, optional] VARIANT, RangeOther As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeCurveCurveIntersection*)
Parameters
Parameters | Description
OtherCurve | GeCurve object; input-only. Specifies the curve to intersect with the curve.
RangeThis | Variant ( GeInterval object); input-only; optional. Specifies the interval range of the curve.
RangeOther | Variant ( GeInterval object); input-only; optional. Specifies the interval range of the specified curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeCurveCurveIntersection object

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IntersectWithSurface Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IntersectWithSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IntersectWithSurface Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the intersection with the specified surface within the specified tolerance.

Visual Basic
Sub IntersectWithSurface(Surface As IGeSurface, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeCurveSurfaceIntersection*)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the surface to intersect with the curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeCurveSurfaceIntersection object

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsClosed Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsClosed Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsClosed Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.

Visual Basic
Sub IsClosed(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsCoplanarWith Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsCoplanarWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsCoplanarWith Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.

Visual Basic
Sub IsCoplanarWith(Curve As IGeCurve, Plane As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Coplanar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to perform the check.
Plane | Variant ( GePlane object); output-only; optional. If the curves are coplanar, the plane on which they lie is returned in the optional plane argument.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsDegenerate Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsDegenerate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsDegenerate Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.

Visual Basic
Sub IsDegenerate(Entity As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Degenerate As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Variant ( GeEntity object); output-only; optional. Specifies the entity that the curve degenerates into.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsLinear Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsLinear Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsLinear Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsLinear(Line As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Linear As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Variant ( GeLine object); optional. Specifies the unbounded line on which this curve lies.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsOnInterval Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsOnInterval Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsOnInterval Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.

Visual Basic
Sub IsOnInterval(Parameter As double, Tolerance As [in, optional] VARIANT, OnInterval As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Parameter | Double; input-only. Specifies the parameter to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsPeriodic Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsPeriodic Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsPeriodic Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets whether this curve is periodic, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodic(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); optional. Specifies the period of the polyline to perform the check.
Remarks
  • This property is a Boolean.
  • The curve is periodic only if it is closed and the two points EvaluatePoint(t) and EvaluatePoint(t+period) are always the same point for all values of t.
Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::IsPlanar Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::IsPlanar Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::IsPlanar Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Gets whether this curve is planar, TRUE, or not, FALSE.

Visual Basic
Sub IsPlanar(Tolerance As [in, optional] VARIANT, Plane As [in, out, optional] VARIANT, Planar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Plane | Variant ( GePlane object); optional. Specifies the other plane whether this circular arc is parallel with.
Remarks

Variant ( GePlane object); optional. Specifies the other plane whether this curve is parallel with.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::LocalClosestPointTo Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::LocalClosestPointTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::LocalClosestPointTo Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Computes the closest point to the curve within the specified parameter interval.

Visual Basic
Sub LocalClosestPointTo(Point As IGePoint, Parameter As [in, out] double, Range As IGeInterval, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. The point to find the closest point to.
Parameter | Double. On input, specifies the starting parameter for the search; on output, specifies the parameter value of the closest point on the curve interval.
Range | GeInterval object; input-only. Specifies the parameter range to search.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::LocalClosestPointToCurve Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::LocalClosestPointToCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::LocalClosestPointToCurve Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.

Visual Basic
Sub LocalClosestPointToCurve(Curve As IGeCurve, ParameterOnThis As [in, out] double, ParameterOnOther As [in, out] double, RangeOnThis As IGeInterval, RangeOnOther As IGeInterval, Tolerance As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to find the closest point to.
ParameterOnThis | Double. On input, specifies the starting parameter on this curve for the search; on output, specifies the parameter value of the closest point on this curve.
ParameterOnOther | Double. On input, specifies the starting parameter on the specified curve for the search; on output, specifies the parameter value of the closest point on the specified curve.
RangeOnThis | GeInterval object; input-only. Specifies the parameter range on this curve to search.
RangeOnOther | GeInterval object; input-only. Specifies the parameter range on the specified curve to search.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::NormalPoint Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::NormalPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::NormalPoint Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Finds the point on the curve whose normal passes through the specified point.

Visual Basic
Sub NormalPoint(Point As IGePoint, Parameter As [in, out] double, Tolerance As [in, optional] VARIANT, NormalPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point for which to find a normal point.
Parameter | Double; input-only. Specifies the parameter value of the normal point. The initial value of the Param element is assumed to contain the parameter value of an initial guess.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Remarks
  • The returned parameters evaluated point will lie on a plane that also contains the input point and is perpendicular to the curve tangent at that point. Therefore, the returned point will be at a local minimum or a local maximum from the input point.
  • The curve does not need to be planar. If the curve is planar, the input point does not need to lie in the plane of the curve.
  • If there is more than one normal point on the curve, the returned point will be the one whose parameter value is closest to the input parameter value.
Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::ParameterAtLength Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::ParameterAtLength Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::ParameterAtLength Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.

Visual Basic
Sub ParameterAtLength(StartParameter As double, Length As double, Direction As [in, defaultvalue(TRUE)] VARIANT_BOOL, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] double)
Parameters
Parameters | Description
StartParameter | Double; input-only. Specifies the starting parameter from which to measure the length.
Length | Double; input-only. Specifies the arc length distance to find the parameter of.
Direction | Boolean, the default value is TRUE; input-only; optional. Specifies whether the length will be measured in a positive, TRUE, or negative, FALSE direction from the starting parameter.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::ParameterOf Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::ParameterOf Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::ParameterOf Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Calculates the parameter value on this curve, which corresponds to the specified point.

Visual Basic
Sub ParameterOf(Point As IGePoint, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the parameter value. It should lie on the curve within the specified tolerance; otherwise, the results may be unpredictable.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Double

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::Project Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::Project Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::Project Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Returns the entity that is the projection of the curve onto the projection plane in the specified direction.

Visual Basic
Sub Project(Plane As IGePlane, Direction As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT, Entity As [out, retval] IGeEntity*)
Parameters
Parameters
Description
Plane
GePlane object; input-only. Specifies the plane to project this circular arc.
Direction
Variant ( GeVector object); input-only; optional. Specifies the direction in which to project the circular arc. Note that:

  • The projection direction vector must not be parallel to the projection plane.
  • If the projection direction is not provided, an orthogonal projection onto the specified plane is performed.

Tolerance
Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeEntity object

Remarks

The returned entity may not be of the same type as the original curve and may not even be a curve. For instance, a line will project into a point if it is parallel to the project direction.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurve::Reverse Method

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve::Reverse Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve::Reverse Method
IGeCurve Interface IGeCurve Members IGeCurve Interface Send Feedback
Summary

Reverses the parametric direction of the curve.

Visual Basic
Sub Reverse()
Returns

None

Remarks

The point set of the curve is unchanged, but the direction of the curve is reversed.

Interface

IGeCurve Interface

Links
IGeCurve Interface, IGeCurve Members, IGeCurve Interface


IGeCurveBoundaries Interface

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries Interface
IGeCurveBoundaries Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeCurveBoundary objects.

Class Hierarchy

Declaration syntax

IGeCurveBoundaries
Visual Basic
Public Interface IGeCurveBoundaries
Inherits IDispatch
Library

GEAuto Library

Links
IGeCurveBoundaries Members, GEAuto Library, Class Hierarchy


IGeCurveBoundaries Members

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries Members
IGeCurveBoundaries Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurveBoundaries.

Interface

IGeCurveBoundaries Interface

Methods
Name | Description
Add | Appends a new curve boundary to the collection.
Item | Gets the curve boundary at the specified index.
Remove | Removes the specified curve boundary from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curve boundaries in a curve boundary collection.
Links
IGeCurveBoundaries Interface, Legend, Methods, Properties


IGeCurveBoundaries::Application Property

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries::Application Property
IGeCurveBoundaries Interface IGeCurveBoundaries Members IGeCurveBoundaries Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeCurveBoundaries Interface

Links
IGeCurveBoundaries Interface, IGeCurveBoundaries Members, IGeCurveBoundaries Interface


IGeCurveBoundaries::Count Property

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries::Count Property
IGeCurveBoundaries Interface IGeCurveBoundaries Members IGeCurveBoundaries Interface Send Feedback
Summary

Gets the total number of the curve boundaries in a curve boundary collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGeCurveBoundaries Interface

Links
IGeCurveBoundaries Interface, IGeCurveBoundaries Members, IGeCurveBoundaries Interface


IGeCurveBoundaries::Add Method

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries::Add Method
IGeCurveBoundaries Interface IGeCurveBoundaries Members IGeCurveBoundaries Interface Send Feedback
Summary

Appends a new curve boundary to the collection.

Visual Basic
Sub Add(Boundary As IGeCurveBoundary)
Parameters
Parameters | Description
Boundary | GeCurveBoundary object; input-only. Specifies the new curve boundary to add to the collection.
Returns

None

Interface

IGeCurveBoundaries Interface

Links
IGeCurveBoundaries Interface, IGeCurveBoundaries Members, IGeCurveBoundaries Interface


IGeCurveBoundaries::Item Method

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries::Item Method
IGeCurveBoundaries Interface IGeCurveBoundaries Members IGeCurveBoundaries Interface Send Feedback
Summary

Gets the curve boundary at the specified index.

Visual Basic
Sub Item(Index As long, Boundary As [out, retval] IGeCurveBoundary*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the curve boundary to get from the collection.
Returns

GeCurveBoundary object

Interface

IGeCurveBoundaries Interface

Links
IGeCurveBoundaries Interface, IGeCurveBoundaries Members, IGeCurveBoundaries Interface


IGeCurveBoundaries::Remove Method

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries::Remove Method
IGeCurveBoundaries Interface IGeCurveBoundaries Members IGeCurveBoundaries Interface Send Feedback
Summary

Removes the specified curve boundary from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the curve boundary to be removed.
Returns

None

Interface

IGeCurveBoundaries Interface

Links
IGeCurveBoundaries Interface, IGeCurveBoundaries Members, IGeCurveBoundaries Interface


IGeCurveBoundary Interface

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary Interface
IGeCurveBoundary Members GEAuto Library Class Hierarchy Send Feedback
Summary

A representation for one of a surface's boundaries.

Class Hierarchy

Declaration syntax

IGeCurveBoundary
Visual Basic
Public Interface IGeCurveBoundary
Inherits IDispatch
Library

GEAuto Library

Links
IGeCurveBoundary Members, GEAuto Library, Class Hierarchy


IGeCurveBoundary Members

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary Members
IGeCurveBoundary Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurveBoundary.

Interface

IGeCurveBoundary Interface

Methods
Name | Description
GetBoundary | Gets the three space and parameter space curves and their corresponding logical orientation.
IsDegenerate | Determines whether the curve boundary consists of a single element and is degenerate to a point, TRUE, or not, FALSE.
SetBoundary | Sets the 3D and parameter space curves and their corresponding logical orientation that make up the curve boundary.
Properties
Name | Description
Application | Gets the GeApplication object.
Elements | Gets the number of elements that make up the curve boundary.
Geometry2d | Gets the 2D parameter space geometry for the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Geometry3d | Gets the 3D geometry that makes up the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Orientation2d | Gets the logical orientation or sense of the 2D parameter space geometry for the curve boundary.
Orientation3d | Gets the logical orientation or sense of the 3D geometry for the curve boundary.
Links
IGeCurveBoundary Interface, Legend, Methods, Properties


IGeCurveBoundary::Application Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Application Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::Elements Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Elements Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Elements Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the number of elements that make up the curve boundary.

Visual Basic
Property Elements() As long*
Remarks

This property is a Long.

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::Geometry2d Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Geometry2d Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Geometry2d Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the 2D parameter space geometry for the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.

Visual Basic
Property Geometry2d() As VARIANT*
Remarks

This property is a Variant (array of GeCurve objects).

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::Geometry3d Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Geometry3d Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Geometry3d Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the 3D geometry that makes up the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.

Visual Basic
Property Geometry3d() As VARIANT*
Remarks

This property is a Variant (array of GeCurve or GePoint objects).

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::Orientation2d Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Orientation2d Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Orientation2d Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the logical orientation or sense of the 2D parameter space geometry for the curve boundary.

Visual Basic
Property Orientation2d() As VARIANT*
Remarks

This property is a Variant (array of Booleans).

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::Orientation3d Property

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::Orientation3d Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::Orientation3d Property
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the logical orientation or sense of the 3D geometry for the curve boundary.

Visual Basic
Property Orientation3d() As VARIANT*
Remarks

This property is a Variant (array of Booleans).

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::GetBoundary Method

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::GetBoundary Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::GetBoundary Method
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Gets the three space and parameter space curves and their corresponding logical orientation.

Visual Basic
Sub GetBoundary(ByRef Geometry3d As VARIANT, ByRef Geometry2d As VARIANT, ByRef Orientation3d As VARIANT, ByRef Orientation2d As VARIANT)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); output-only. Specifies the 3D space curves or points on a curve boundary.
Geometry2d | Variant (array of GeCurve objects); output-only. Specifies the 2D space curves on a curve boundary.
Orientation3d | Variant (array of Booleans); output-only. Specifies the logical orientation of the corresponding curve or point defined in the Geometry3d element.
Orientation2d | Variant (array of Booleans); output-only. Specifies the logical orientation of the corresponding curves defined in the Geometry2d element.
Returns

None

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::IsDegenerate Method

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::IsDegenerate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::IsDegenerate Method
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Determines whether the curve boundary consists of a single element and is degenerate to a point, TRUE, or not, FALSE.

Visual Basic
Sub IsDegenerate(Point As [in, out, optional] VARIANT, Curve As [in, out, optional] VARIANT, Degenerate As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | Variant ( GePoint object); output-only; optional. Specifies the point that the curve boundary degenerates to. This element will only be set when this method returns TRUE.
Curve | Variant ( GeCurve object); output-only; optional. Specifies the parameter space curve on the curve boundary that would degenerate to the point when evaluated. This element will only be set when the method returns TRUE.
Returns

Boolean

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveBoundary::SetBoundary Method

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary::SetBoundary Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary::SetBoundary Method
IGeCurveBoundary Interface IGeCurveBoundary Members IGeCurveBoundary Interface Send Feedback
Summary

Sets the 3D and parameter space curves and their corresponding logical orientation that make up the curve boundary.

Visual Basic
Sub SetBoundary(Geometry3d As VARIANT, Geometry2d As VARIANT, Orientation3d As VARIANT, Orientation2d As VARIANT)
Parameters
Parameters | Description
Geometry3d | Variant (array of GeCurve or GePoint objects); input-only. Specifies the 3D space curves or points on a curve boundary.
Geometry2d | Variant (array of GeCurve objects); input-only. Specifies the 2D space curves on a curve boundary.
Orientation3d | Variant (array of Booleans); input-only. Specifies the logical orientation of the corresponding curve or point defined in the Geometry3d element.
Orientation2d | Variant (array of Booleans); input-only. Specifies the logical orientation of the corresponding curves defined in the Geometry2d element.
Returns

None

Remarks

The length of the arrays of all four elements must be the same size.

Interface

IGeCurveBoundary Interface

Links
IGeCurveBoundary Interface, IGeCurveBoundary Members, IGeCurveBoundary Interface


IGeCurveCurveIntersection Interface

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection Interface
IGeCurveCurveIntersection Members GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates and provides access to the intersection properties between two curves. This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.

Class Hierarchy

Declaration syntax

IGeCurveCurveIntersection
Visual Basic
Public Interface IGeCurveCurveIntersection
Inherits IDispatch
Library

GEAuto Library

Links
IGeCurveCurveIntersection Members, GEAuto Library, Class Hierarchy


IGeCurveCurveIntersection Members

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection Members
IGeCurveCurveIntersection Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurveCurveIntersection.

Interface

IGeCurveCurveIntersection Interface

Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the parameter value of the intersection point.
GetOverlapRanges | Gets the interval ranges of overlap for the specified interval of overlap for two curves being intersected.
IntersectionPoint | Gets the intersection point at the specified intersection index.
IntersectionPointTolerance | Gets the tolerance used to find the point at the specified intersection index.
IsTangential | Gets whether the intersection is tangential at the specified intersection index, TRUE, or not, FALSE.
IsTransversal | Gets whether the intersection is transversal at the specified intersection index, TRUE, or not, FALSE.
ParameterOnCurve1 | Gets the curve parameter value on the first curve at the specified intersection point.
ParameterOnCurve2 | Gets the curve parameter value on the second curve at the specified intersection point.
Set | Sets the two curves being intersected and optionally the tolerance used in the calculation and the interval ranges on the corresponding curves to be considered in the calculation.
Properties
Name | Description
Curve1 | Specifies the first curve operand for intersection.
Curve2 | Specifies the second curve operand for intersection.
IntersectionPointCount | Gets the number of intersection points.
IntervalRange1 | Specifies the interval range on the first curve that is considered in the intersection calculation.
IntervalRange2 | Specifies the interval range on the second curve that is considered in the intersection calculation.
OverlapCount | Gets the number of overlap intervals between two curves.
OverlapDirection | Gets whether the curves are oriented in the same direction where they overlap, TRUE, or not, FALSE.
Tolerance | Specifies the tolerance used in intersection calculations.
Links
IGeCurveCurveIntersection Interface, Legend, Methods, Properties


IGeCurveCurveIntersection::Curve1 Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::Curve1 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::Curve1 Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Specifies the first curve operand for intersection.

Visual Basic
Property Curve1() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.
Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::Curve2 Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::Curve2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::Curve2 Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Specifies the second curve operand for intersection.

Visual Basic
Property Curve2() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.
Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IntersectionPointCount Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IntersectionPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IntersectionPointCount Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the number of intersection points.

Visual Basic
Property IntersectionPointCount() As long*
Remarks

This property is a Long.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IntervalRange1 Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IntervalRange1 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IntervalRange1 Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Specifies the interval range on the first curve that is considered in the intersection calculation.

Visual Basic
Property IntervalRange1() As IGeInterval*
Remarks
  • This property is a GeInterval object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.
Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IntervalRange2 Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IntervalRange2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IntervalRange2 Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Specifies the interval range on the second curve that is considered in the intersection calculation.

Visual Basic
Property IntervalRange2() As IGeInterval*
Remarks
  • This property is a GeInterval object.
  • This property is a determined by the GeCurveCurveIntersection > Set method.
Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::OverlapCount Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::OverlapCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::OverlapCount Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the number of overlap intervals between two curves.

Visual Basic
Property OverlapCount() As long*
Remarks

This property is a Long.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::OverlapDirection Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::OverlapDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::OverlapDirection Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets whether the curves are oriented in the same direction where they overlap, TRUE, or not, FALSE.

Visual Basic
Property OverlapDirection() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::Tolerance Property

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::Tolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::Tolerance Property
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Specifies the tolerance used in intersection calculations.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::GetAllIntersections Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::GetAllIntersections Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::GetAllIntersections Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets all intersection points and the parameters on the intersection operands for every intersection point.

Visual Basic
Sub GetAllIntersections(ByRef Points As IGePoints*, ByRef Curve1Parameters As VARIANT, ByRef Curve2Parameters As VARIANT)
Parameters
Parameters | Description
Points | GePoints collection; output-only. Specifies all intersection points between two curves, Curve1 and Curve2 .
Curve1Parameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the first curve.
Curve2Parameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the second curve.
Returns

None

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::GetIntersectionConfiguration Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::GetIntersectionConfiguration Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::GetIntersectionConfiguration Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the characterization of the specified intersection in the neighborhood just above and below the parameter value of the intersection point.

Visual Basic
Sub GetIntersectionConfiguration(Index As long, ByRef Config1WRT2 As GeCurveCurveIntConfiguration, ByRef Config2WRT1 As GeCurveCurveIntConfiguration)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection for which to get the characterization.
Config1WRT2 | GeCurveCurveIntConfiguration enumeration; output-only. Specifies the configuration of the first curve with respect to the second curve at the intersection point. For instance, if the returned configuration of Config1WRT2 is geRightLeft, it indicates that the first curve crosses the second curve from right to left with respect to the second curve and with respect to the curve plane's normal.
Config2WRT1 | GeCurveCurveIntConfiguration enumeration; output-only. Specifies the configuration of the second curve with respect to the first curve at the intersection point. For instance, if the returned configuration of Config2WRT1 is geRightLeft, it indicates that the second curve crosses the first curve from right to left with respect to the first curve and with respect to the curve plane's normal.
Returns

None

Remarks

This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::GetOverlapRanges Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::GetOverlapRanges Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::GetOverlapRanges Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the interval ranges of overlap for the specified interval of overlap for two curves being intersected.

Visual Basic
Sub GetOverlapRanges(Index As long, ByRef Range1 As IGeInterval*, ByRef Range2 As IGeInterval*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an overlap interval for which to get the interval range.
Range1 | GeInterval object; output-only. Specifies the interval range on the first curve, <ICurve1> .
Range2 | GeInterval object; output-only. Specifies the interval range on the second curve, <ICurve2> .
Returns

None

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IntersectionPoint Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IntersectionPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IntersectionPoint Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for which to get the intersection point.
Remarks

This property is a GePoint object.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IntersectionPointTolerance Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IntersectionPointTolerance Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IntersectionPointTolerance Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the tolerance used to find the point at the specified intersection index.

Visual Basic
Sub IntersectionPointTolerance(Index As long, Tolerance As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the intersection for which to get the calculation tolerance.
Remarks

This property is a Double.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IsTangential Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IsTangential Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IsTangential Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets whether the intersection is tangential at the specified intersection index, TRUE, or not, FALSE.

Visual Basic
Sub IsTangential(Index As long, Tangential As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the check.
Remarks

This property is a Boolean.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::IsTransversal Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::IsTransversal Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::IsTransversal Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets whether the intersection is transversal at the specified intersection index, TRUE, or not, FALSE.

Visual Basic
Sub IsTransversal(Index As long, Transversal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the check.
Remarks

This property is a Boolean.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::ParameterOnCurve1 Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::ParameterOnCurve1 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::ParameterOnCurve1 Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the curve parameter value on the first curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve1(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::ParameterOnCurve2 Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::ParameterOnCurve2 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::ParameterOnCurve2 Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Gets the curve parameter value on the second curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve2(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurveCurveIntersection::Set Method

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection::Set Method
IGeCurveCurveIntersection Interface IGeCurveCurveIntersection Members IGeCurveCurveIntersection Interface Send Feedback
Summary

Sets the two curves being intersected and optionally the tolerance used in the calculation and the interval ranges on the corresponding curves to be considered in the calculation.

Visual Basic
Sub Set(Curve1 As IGeCurve, Curve2 As IGeCurve, Range1 As [in, optional] VARIANT, Range2 As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve for intersection. This element can be later obtained by the GeCurveCurveIntersection > Curve1 property.
Curve2 | GeCurve object; input-only. Specifies the second curve for intersection. This element can be later obtained by the GeCurveCurveIntersection > Curve2 property.
Range1 | GeInterval object; input-only. Specifies the interval range on the first curve. This element can be later obtained by the GeCurveCurveIntersection > IntervalRange1 property.
Range2 | GeInterval object; input-only. Specifies the interval range on the second curve. This element can be later obtained by the GeCurveCurveIntersection > IntervalRange2 property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks

If either optional interval range is specified they both must be specified.

Interface

IGeCurveCurveIntersection Interface

Links
IGeCurveCurveIntersection Interface, IGeCurveCurveIntersection Members, IGeCurveCurveIntersection Interface


IGeCurves Interface

You are here: API Reference > GEAuto Library > IGeCurves Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves Interface
IGeCurves Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeCurve objects.

Class Hierarchy

Declaration syntax

IGeCurves
Visual Basic
Public Interface IGeCurves
Inherits IDispatch
Library

GEAuto Library

Links
IGeCurves Members, GEAuto Library, Class Hierarchy


IGeCurves Members

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves Members
IGeCurves Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurves.

Interface

IGeCurves Interface

Methods
Name | Description
Add | Appends a new curve to the collection.
Item | Gets the curve at the specified index.
Remove | Removes the specified curve from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curves in a curve collection.
Links
IGeCurves Interface, Legend, Methods, Properties


IGeCurves::Application Property

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves::Application Property
IGeCurves Interface IGeCurves Members IGeCurves Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeCurves Interface

Links
IGeCurves Interface, IGeCurves Members, IGeCurves Interface


IGeCurves::Count Property

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves::Count Property
IGeCurves Interface IGeCurves Members IGeCurves Interface Send Feedback
Summary

Gets the total number of the curves in a curve collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGeCurves Interface

Links
IGeCurves Interface, IGeCurves Members, IGeCurves Interface


IGeCurves::Add Method

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves::Add Method
IGeCurves Interface IGeCurves Members IGeCurves Interface Send Feedback
Summary

Appends a new curve to the collection.

Visual Basic
Sub Add(Curve As IGeCurve)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the new curve to add to the collection.
Returns

None

Interface

IGeCurves Interface

Links
IGeCurves Interface, IGeCurves Members, IGeCurves Interface


IGeCurves::Item Method

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves::Item Method
IGeCurves Interface IGeCurves Members IGeCurves Interface Send Feedback
Summary

Gets the curve at the specified index.

Visual Basic
Sub Item(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the curve to get from the collection.
Returns

GeCurve object

Interface

IGeCurves Interface

Links
IGeCurves Interface, IGeCurves Members, IGeCurves Interface


IGeCurves::Remove Method

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves::Remove Method
IGeCurves Interface IGeCurves Members IGeCurves Interface Send Feedback
Summary

Removes the specified curve from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the curve to be removed.
Returns

None

Interface

IGeCurves Interface

Links
IGeCurves Interface, IGeCurves Members, IGeCurves Interface


IGeCurveSurfaceIntersection Interface

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection Interface
IGeCurveSurfaceIntersection Members GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates and provides access to the intersection properties between a curve and a surface.

Class Hierarchy

Declaration syntax

IGeCurveSurfaceIntersection
Visual Basic
Public Interface IGeCurveSurfaceIntersection
Inherits IDispatch
Library

GEAuto Library

Links
IGeCurveSurfaceIntersection Members, GEAuto Library, Class Hierarchy


IGeCurveSurfaceIntersection Members

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection Members
IGeCurveSurfaceIntersection Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCurveSurfaceIntersection.

Interface

IGeCurveSurfaceIntersection Interface

Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the intersection with respect to the curve parameterization.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterOnCurve | Gets the parameter values on the curve at the specified intersection point.
ParameterOnSurface | Gets the parameter values on the surface at the specified intersection point.
Set | Sets the curve and surface being intersected and optionally the tolerance used in the calculation.
Properties
Name | Description
Curve | Specifies the curve for intersection.
IntersectionPointCount | Gets the number of intersection points.
Surface | Specifies the surface for intersection.
Tolerance | Specifies the tolerance used in intersection calculations.
Links
IGeCurveSurfaceIntersection Interface, Legend, Methods, Properties


IGeCurveSurfaceIntersection::Curve Property

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::Curve Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::Curve Property
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Specifies the curve for intersection.

Visual Basic
Property Curve() As IGeCurve*
Remarks
  • This property is a GeCurve object.
  • This property is a determined by the GeCurveSurfaceIntersection > Set method.
Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::IntersectionPointCount Property

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::IntersectionPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::IntersectionPointCount Property
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets the number of intersection points.

Visual Basic
Property IntersectionPointCount() As long*
Remarks

This property is a Long.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::Surface Property

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::Surface Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::Surface Property
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Specifies the surface for intersection.

Visual Basic
Property Surface() As IGeSurface*
Remarks
  • This property is a GeSurface object.
  • This property is a determined by the GeCurveSurfaceIntersection > Set method.
Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::Tolerance Property

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::Tolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::Tolerance Property
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Specifies the tolerance used in intersection calculations.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::GetAllIntersections Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::GetAllIntersections Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::GetAllIntersections Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets all intersection points and the parameters on the intersection operands for every intersection point.

Visual Basic
Sub GetAllIntersections(ByRef Points As IGePoints*, ByRef CurveParameters As VARIANT, ByRef SurfaceParameters As IGePoints*)
Parameters
Parameters | Description
Points | GePoints collection; output-only. Specifies all intersection points between the curve and the surface.
CurveParameters | Variant (array of Doubles). Specifies the parameters on the intersection operands for every intersection point on the curve.
SurfaceParameters | GePoints collection; output-only. Specifies the 2D parameter space points on the intersection operands for every intersection point on the surface.
Returns

None

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets the characterization of the specified intersection in the neighborhood just above and below the intersection with respect to the curve parameterization.

Visual Basic
Sub GetIntersectionConfiguration(Index As long, ByRef Lower As GeCurveSurfIntConfiguration, ByRef Upper As GeCurveSurfIntConfiguration, ByRef SmallAngle As VARIANT_BOOL)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection for which to get the intersection characterization.
Lower | GeCurveSurfIntConfiguration enumeration; output-only. Specifies the characterization of the intersection in the neighborhood below the intersection with respect to the curve parameterization.
Upper | GeCurveSurfIntConfiguration enumeration; output-only. Specifies the characterization of the intersection in the neighborhood above the intersection with respect to the curve parameterization.
SmallAngle | Boolean; input-only.
Returns

None

Remarks

If an intersection is not empty, coincident or tangent, it is transverse.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::IntersectionPoint Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::IntersectionPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::IntersectionPoint Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for which to get the intersection point.
Remarks

This property is a GePoint object.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::ParameterOnCurve Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::ParameterOnCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::ParameterOnCurve Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets the parameter values on the curve at the specified intersection point.

Visual Basic
Sub ParameterOnCurve(Index As long, Parameter As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::ParameterOnSurface Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::ParameterOnSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::ParameterOnSurface Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Gets the parameter values on the surface at the specified intersection point.

Visual Basic
Sub ParameterOnSurface(Index As long, Parameters As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

This property is a Double.

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCurveSurfaceIntersection::Set Method

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection::Set Method
IGeCurveSurfaceIntersection Interface IGeCurveSurfaceIntersection Members IGeCurveSurfaceIntersection Interface Send Feedback
Summary

Sets the curve and surface being intersected and optionally the tolerance used in the calculation.

Visual Basic
Sub Set(Curve As IGeCurve, Surface As IGeSurface, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve for intersection. This element can be later obtained by the GeCurveSurfaceIntersection > Curve property.
Surface | GeSurface object; input-only. Specifies the surface for intersection. This element can be later obtained by the GeCurveSurfaceIntersection > Surface property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Interface

IGeCurveSurfaceIntersection Interface

Links
IGeCurveSurfaceIntersection Interface, IGeCurveSurfaceIntersection Members, IGeCurveSurfaceIntersection Interface


IGeCylinder Interface

You are here: API Reference > GEAuto Library > IGeCylinder Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder Interface
IGeCylinder Members GEAuto Library Class Hierarchy Send Feedback
Summary

A cylindrical surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeCylinder
Visual Basic
Public Interface IGeCylinder
Inherits IGeSurface
Library

GEAuto Library

Links
IGeCylinder Members, GEAuto Library, Class Hierarchy


IGeCylinder Members

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder Members
IGeCylinder Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeCylinder.

Interface

IGeCylinder Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the cylinder and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cylinder by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cylinder.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
Height | Specifies the parameter interval height of the cylinder.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cylinder.
Radius | Specifies the radius of the cylinder.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cylinder.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeCylinder Interface, Legend, Methods, Properties


IGeCylinder::AxisOfSymmetry Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::AxisOfSymmetry Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::AxisOfSymmetry Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the axis of symmetry of this cylinder.

Visual Basic
Property AxisOfSymmetry() As IGeVector**
Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::EndAngle Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::EndAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::EndAngle Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the angle of the end point with respect to the reference vector in the base of the cone.

Visual Basic
Property EndAngle() As double
Remarks

This property is a Double.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::Height Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::Height Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::Height Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the parameter interval height of the cylinder.

Visual Basic
Property Height() As IGeInterval*
Remarks

This property is a GeInterval object.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::Origin Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::Origin Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Gets the center of the base of the cylinder.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::Radius Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::Radius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::Radius Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the radius of the cylinder.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::ReferenceVector Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::ReferenceVector Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::ReferenceVector Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the reference vector from which the start angle and end angle are measured.

Visual Basic
Property ReferenceVector() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::StartAngle Property

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::StartAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::StartAngle Property
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Specifies the angle of the start point with respect to the reference vector in the base of the cylinder.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::IntersectWith Method
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Computes the intersection between the cylinder and a linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this cylinder.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeCylinder::Set Method

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder::Set Method
IGeCylinder Interface IGeCylinder Members IGeCylinder Interface Send Feedback
Summary

Changes the definition of this cylinder by the specified parameters.

Visual Basic
Sub Set(Radius As double, Center As IGePoint, SymmetryAxis As IGeVector, ReferenceAxis As [in, optional] VARIANT, Height As [in, optional] VARIANT, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Radius | Double; input-only. Specifies the radius of the cylinder.
Center | GePoint object; input-only. Specifies the center point of the circular base.
SymmetryAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
ReferenceAxis | GeVector object; input-only. Specifies the cone's axis of rotation or symmetry.
Height | Variant ( GeInterval object); input-only; optional. Specifies the height of the cylinder.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle on the base circle.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle on the base circle.
Returns

None

Interface

IGeCylinder Interface

Links
IGeCylinder Interface, IGeCylinder Members, IGeCylinder Interface


IGeEllipticalArc Interface

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc Interface
IGeEllipticalArc Members GEAuto Library Class Hierarchy Send Feedback
Summary

An ellipse or elliptical arc.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeEllipticalArc
Visual Basic
Public Interface IGeEllipticalArc
Inherits IGeCurve
Remarks

The angle of a point on the ellipse is measured by drawing a full circle with the same center as the ellipse and radius equal to the ellipse major radius and projecting the point onto the circle along a vector perpendicular to the major axis. If a vector is then drawn from the ellipse center to this projected point, the angle between the major axis and this vector (measured counterclockwise about the cross product of the major and minor axes) is the angle of the point on the ellipse. endAngle must be greater than startAngle. To construct a full ellipse, the difference between EndAngle and StartAngle should be 2*pi.

Library

GEAuto Library

Links
IGeEllipticalArc Members, GEAuto Library, Class Hierarchy


IGeEllipticalArc Members

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc Members
IGeEllipticalArc Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeEllipticalArc.

Interface

IGeEllipticalArc Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this elliptical arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the elliptical arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the elliptical arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the elliptical arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.
EndPoint | Gets the end point of this elliptical arc.
Interval | Sets the interval of the curve and returns the index of the interval.
IsCircular | Gets whether the ellipse is a circular arc, TRUE, or not, FALSE.
MajorAxis | Specifies the major axis of the ellipse.
MajorRadius | Specifies the major radius of the ellipse.
MinorAxis | Specifies the minor axis of the ellipse.
MinorRadius | Specifies the minor radius of the ellipse.
Normal | Specifies the normal vector of this elliptical arc.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.
StartPoint | Gets the start point of this elliptical arc.
Links
IGeEllipticalArc Interface, Legend, Methods, Properties


IGeEllipticalArc::Center Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::Center Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::Center Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the center point of the elliptical arc.

Visual Basic
Property Center() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::EndAngle Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::EndAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::EndAngle Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.

Visual Basic
Property EndAngle() As double
Remarks

Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::EndPoint Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::EndPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::EndPoint Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Gets the end point of this elliptical arc.

Visual Basic
Property EndPoint() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::IsCircular Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::IsCircular Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::IsCircular Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Gets whether the ellipse is a circular arc, TRUE, or not, FALSE.

Visual Basic
Property IsCircular() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::MajorAxis Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::MajorAxis Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::MajorAxis Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the major axis of the ellipse.

Visual Basic
Property MajorAxis() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::MajorRadius Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::MajorRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::MajorRadius Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the major radius of the ellipse.

Visual Basic
Property MajorRadius() As double
Remarks

This property is a Double.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::MinorAxis Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::MinorAxis Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::MinorAxis Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the minor axis of the ellipse.

Visual Basic
Property MinorAxis() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::MinorRadius Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::MinorRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::MinorRadius Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the minor radius of the ellipse.

Visual Basic
Property MinorRadius() As double
Remarks

This property is a Double.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::Normal Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::Normal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::Normal Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the normal vector of this elliptical arc.

Visual Basic
Property Normal() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::StartAngle Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::StartAngle Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::StartAngle Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Specifies the angle of the start point with respect to the reference vector in the plane of the arc.

Visual Basic
Property StartAngle() As double
Remarks

This property is a Double.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::StartPoint Property

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::StartPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::StartPoint Property
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Gets the start point of this elliptical arc.

Visual Basic
Property StartPoint() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::IntersectWith Method
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Determines whether the specified geometry entity intersects with this elliptical arc, TRUE, or not, FALSE. They do not need to lie in the same plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, ProjectionDirection As [in, optional] VARIANT, LinePoint1 As [in, out, optional] VARIANT, LinePoint2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeCircularArc , GeLinearEntity, or GePlane object.
Intersections | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
ProjectionDirection | Variant ( GeVector object); input-only; optional. Specifies the normal of a plane that this elliptical arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when the GeEntity element is a GeLinearEntity.
LinePoint1 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
LinePoint2 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::IsInside Method

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::IsInside Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::IsInside Method
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the elliptical arc, FALSE.

Visual Basic
Sub IsInside(Point As IGePoint, Tolerance As [in, optional] VARIANT, Inside As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

This method treats the arc as a full circle or ellipse even if it is bounded and determines if the specified point lies inside of the full circle or ellipse.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEllipticalArc::Set Method

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc::Set Method
IGeEllipticalArc Interface IGeEllipticalArc Members IGeEllipticalArc Interface Send Feedback
Summary

Sets the elliptical arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.

Visual Basic
Sub Set(Center As IGePoint, MajorAxis As IGeVector, MinorAxis As IGeVector, MajorRadius As double, MinorRadius As double, StartAngle As [in, optional] VARIANT, EndAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
Center | GePoint object; input-only. Specifies the center point of the elliptical arc.
MajorAxis | GeVector object; input-only. Specifies the major axis of the ellipse.
MinorAxis | GeVector object; input-only. Specifies the minor axis of the ellipse.
MajorRadius | Double; input-only. Specifies the major radius of the ellipse.
MinorRadius | Double; input-only. Specifies the minor radius of the ellipse.
StartAngle | Variant (Double); input-only; optional. Specifies the start angle of the elliptical arc.
EndAngle | Variant (Double); input-only; optional. Specifies the end angle of the elliptical arc.
Returns

None

Remarks

If the reference vector, start or end angles are specified, they all must be specified.

Interface

IGeEllipticalArc Interface

Links
IGeEllipticalArc Interface, IGeEllipticalArc Members, IGeEllipticalArc Interface


IGeEntities Interface

You are here: API Reference > GEAuto Library > IGeEntities Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities Interface
IGeEntities Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeEntity objects.

Class Hierarchy

Declaration syntax

IGeEntities
Visual Basic
Public Interface IGeEntities
Inherits IDispatch
Library

GEAuto Library

Links
IGeEntities Members, GEAuto Library, Class Hierarchy


IGeEntities Members

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities Members
IGeEntities Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeEntities.

Interface

IGeEntities Interface

Methods
Name | Description
Add | Appends a new geometry entity to the collection.
Item | Gets the geometry entity at the specified index.
Remove | Removes the specified geometry entity from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the geometry entities in a geometry entity collection.
Links
IGeEntities Interface, Legend, Methods, Properties


IGeEntities::Application Property

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities::Application Property
IGeEntities Interface IGeEntities Members IGeEntities Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeEntities Interface

Links
IGeEntities Interface, IGeEntities Members, IGeEntities Interface


IGeEntities::Count Property

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities::Count Property
IGeEntities Interface IGeEntities Members IGeEntities Interface Send Feedback
Summary

Gets the total number of the geometry entities in a geometry entity collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGeEntities Interface

Links
IGeEntities Interface, IGeEntities Members, IGeEntities Interface


IGeEntities::Add Method

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities::Add Method
IGeEntities Interface IGeEntities Members IGeEntities Interface Send Feedback
Summary

Appends a new geometry entity to the collection.

Visual Basic
Sub Add(Entity As IGeEntity)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the new geometry entity to add to the collection.
Returns

None

Interface

IGeEntities Interface

Links
IGeEntities Interface, IGeEntities Members, IGeEntities Interface


IGeEntities::Item Method

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities::Item Method
IGeEntities Interface IGeEntities Members IGeEntities Interface Send Feedback
Summary

Gets the geometry entity at the specified index.

Visual Basic
Sub Item(Index As long, Entity As [out, retval] IGeEntity*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the geometry entity to get from the collection.
Returns

GeEntity object

Interface

IGeEntities Interface

Links
IGeEntities Interface, IGeEntities Members, IGeEntities Interface


IGeEntities::Remove Method

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities::Remove Method
IGeEntities Interface IGeEntities Members IGeEntities Interface Send Feedback
Summary

Removes the specified geometry entity from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the geometry entity to be removed.
Returns

None

Interface

IGeEntities Interface

Links
IGeEntities Interface, IGeEntities Members, IGeEntities Interface


IGeEntity Interface

You are here: API Reference > GEAuto Library > IGeEntity Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity Interface
IGeEntity Members GEAuto Library Class Hierarchy Send Feedback
Summary

A generic geometric entity. Subtypes: GeBoundBlock, IGeCurve, GePoint, IGeSurface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeBoundBlock
    IGeCurve
    IGePoint
    IGeSurface
Visual Basic
Public Interface IGeEntity
Inherits IDispatch
Library

GEAuto Library

Links
IGeEntity Members, GEAuto Library, Class Hierarchy


IGeEntity Members

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity Members
IGeEntity Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeEntity.

Interface

IGeEntity Interface

Methods
Name | Description
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Links
IGeEntity Interface, Legend, Methods, Properties


IGeEntity::Application Property

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::Application Property
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::IsEqualTo Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::IsEqualTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::IsEqualTo Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, IsEqual As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other entity to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

Two entities are considered to be equal only if they are of the same type and they represent the same 3D point set. For instance, if the two entities are of types GeCircularArc and GeEllipticalArc , they are not considered equal even if the ellipse is completely coincident with the circle.

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::IsOn Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::IsOn Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::IsOn Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Determines whether the specified point lies on the entity, TRUE, or not, FALSE.

Visual Basic
Sub IsOn(Point As IGePoint, Tolerance As [in, optional] VARIANT, IsOn As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::Mirror Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::Mirror Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::Mirror Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Mirrors this entity about the specified plane.

Visual Basic
Sub Mirror(Plane As IGePlane)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane with respect to which this entity is mirrored.
Returns

None

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::RotateBy Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::RotateBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::RotateBy Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Rotates this entity around the line with the specified direction vector passing through the specified point.

Visual Basic
Sub RotateBy(Angle As double, Vector As IGeVector, Point As IGePoint)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this polyline. The positive direction of rotation is defined by the right hand rule.
Vector | GeVector object; input-only. Specifies the polar vector to rotate this entity.
Point | GePoint object; input-only. Specifies the base point to rotate this entity.
Returns

None

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::ScaleBy Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::ScaleBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::ScaleBy Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Multiplies this entity by the scale factor.

Visual Basic
Sub ScaleBy(Factor As double, BasePoint As IGePoint)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the scale factor to change the size of this entity.
BasePoint | GePoint object; input-only. Specifies the point that remains in the same location as the selected objects change their sizes and thus move away from the stationary base point.
Returns

None

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::TransformBy Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::TransformBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::TransformBy Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Transforms this entity by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As IGeMatrix)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix by which to transform this entity.
Returns

None

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeEntity::TranslateBy Method

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity::TranslateBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity::TranslateBy Method
IGeEntity Interface IGeEntity Members IGeEntity Interface Send Feedback
Summary

Translates or moves the entity by the specified translation vector.

Visual Basic
Sub TranslateBy(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the translation vector to translate or move this entity.
Returns

None

Interface

IGeEntity Interface

Links
IGeEntity Interface, IGeEntity Members, IGeEntity Interface


IGeInterval Interface

You are here: API Reference > GEAuto Library > IGeInterval Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval Interface
IGeInterval Members GEAuto Library Class Hierarchy Send Feedback
Summary

Represents an interval of the real axis to define bounds.

Class Hierarchy

Declaration syntax

IGeInterval
Visual Basic
Public Interface IGeInterval
Inherits IDispatch
Library

GEAuto Library

Links
IGeInterval Members, GEAuto Library, Class Hierarchy


IGeInterval Members

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval Members
IGeInterval Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeInterval.

Interface

IGeInterval Interface

Methods
Name | Description
Contains | Determines whether the specified parameter value or sub-interval is contained by this interval, TRUE, or not, FALSE.
IsContinuousAtUpper | Determines whether this interval is continuous at the upper bound with the specified interval, TRUE, or not, FALSE.
IsDisjoint | Determines whether the specified interval does not intersect with this interval within this interval's boundary tolerance, TRUE, or not, FALSE.
IsOverlapAtUpper | Determines whether the specified interval overlaps this interval at the upper bound, TRUE, or not, FALSE.
Properties
Name | Description
Application | Gets the GeApplication object.
Bounded | Gets whether the interval is bounded in both directions, TRUE, or not, FALSE.
BoundedAbove | Gets whether the interval has an upper bound, TRUE, or not, FALSE.
BoundedBelow | Gets whether the interval has a lower bound, TRUE, or not, FALSE.
IsSingleton | Gets whether the interval is bounded and the lower and upper bounds are equal, TRUE, or not, FALSE.
IsUnBounded | Gets whether the interval is unbounded, TRUE, or not, FALSE.
Length | Gets the length of the interval.
Lower | Specifies the lower bound of the interval.
Upper | Specifies the upper bound of the interval.
Links
IGeInterval Interface, Legend, Methods, Properties


IGeInterval::Application Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Application Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::Bounded Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Bounded Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Bounded Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets whether the interval is bounded in both directions, TRUE, or not, FALSE.

Visual Basic
Property Bounded() As VARIANT_BOOL
Remarks

This property is a Boolean.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::BoundedAbove Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::BoundedAbove Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::BoundedAbove Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets whether the interval has an upper bound, TRUE, or not, FALSE.

Visual Basic
Property BoundedAbove() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::BoundedBelow Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::BoundedBelow Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::BoundedBelow Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets whether the interval has a lower bound, TRUE, or not, FALSE.

Visual Basic
Property BoundedBelow() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::IsSingleton Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::IsSingleton Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::IsSingleton Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets whether the interval is bounded and the lower and upper bounds are equal, TRUE, or not, FALSE.

Visual Basic
Property IsSingleton() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::IsUnBounded Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::IsUnBounded Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::IsUnBounded Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets whether the interval is unbounded, TRUE, or not, FALSE.

Visual Basic
Property IsUnBounded() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::Length Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Length Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Length Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Gets the length of the interval.

Visual Basic
Property Length() As double*
Remarks

  • This property is a Double.
  • This property will only succeed if the interval is bounded.
Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::Lower Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Lower Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Lower Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Specifies the lower bound of the interval.

Visual Basic
Property Lower() As double
Remarks

This property is a Double.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::Upper Property

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Upper Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Upper Property
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Specifies the upper bound of the interval.

Visual Basic
Property Upper() As double
Remarks

This property is a Double.

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::Contains Method

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::Contains Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::Contains Method
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Determines whether the specified parameter value or sub-interval is contained by this interval, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Value As VARIANT, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Variant (Double or GeInterval object); input-only. Specifies the parameter value or sub-interval to perform the check.
Returns

Boolean

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::IsContinuousAtUpper Method

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::IsContinuousAtUpper Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::IsContinuousAtUpper Method
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Determines whether this interval is continuous at the upper bound with the specified interval, TRUE, or not, FALSE.

Visual Basic
Sub IsContinuousAtUpper(Interval As IGeInterval, Continuous As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
Returns

Boolean

Remarks

This method returns TRUE when:

  • This interval is bounded above.
  • The specified interval is bounded below.
  • The upper bound of this interval is equal to the lower bound of the specified interval within the boundary tolerance of this interval
Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::IsDisjoint Method

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::IsDisjoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::IsDisjoint Method
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Determines whether the specified interval does not intersect with this interval within this interval's boundary tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsDisjoint(Interval As IGeInterval, Disjoint As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
Returns

Boolean

Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeInterval::IsOverlapAtUpper Method

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval::IsOverlapAtUpper Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval::IsOverlapAtUpper Method
IGeInterval Interface IGeInterval Members IGeInterval Interface Send Feedback
Summary

Determines whether the specified interval overlaps this interval at the upper bound, TRUE, or not, FALSE.

Visual Basic
Sub IsOverlapAtUpper(Interval As IGeInterval, OverlapInterval As [in, out, optional] VARIANT, Overlap As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Interval | GeInterval object; input-only. Specifies the other interval to perform the check.
OverlapInterval | Variant ( GeInterval object); output-only; optional. Specifies the overlapped segment between two intervals. This element will only bet set when this method returns TRUE.
Remarks

This method returns TRUE when:

  • This interval is bounded above.
  • The specified interval is bounded below.
  • Both intervals are not singleton .
  • Their intersection is not empty and does not coincide with this interval.
  • The upper bound of this interval is contained in the specified interval, and the lower bound of the specified interval is contained in this interval.
Interface

IGeInterval Interface

Links
IGeInterval Interface, IGeInterval Members, IGeInterval Interface


IGeKnotVector Interface

You are here: API Reference > GEAuto Library > IGeKnotVector Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector Interface
IGeKnotVector Members GEAuto Library Class Hierarchy Send Feedback
Summary

An ordered sequence knot values making up a knot vector for NURB entities.

Class Hierarchy

Declaration syntax

IGeKnotVector
Visual Basic
Public Interface IGeKnotVector
Inherits IDispatch
Remarks

The intervals between two consecutive knots partition a spline into polynomial or rational pieces.

Library

GEAuto Library

Links
IGeKnotVector Members, GEAuto Library, Class Hierarchy


IGeKnotVector Members

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector Members
IGeKnotVector Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeKnotVector.

Interface

IGeKnotVector Interface

Methods
Name | Description
AddKnot | Appends the specified value to the knot vector.
AddKnotVector | Performs a linear transformation (k = a * k + b), with appropriate coefficients a and b, on this vector and on tail vector.
Contains | Determines whether the specified parameter is within the range of the first and last knot value, TRUE, or not, FALSE.
Insert | Inserts the specified value into the appropriate knot interval.
InsertKnot | Inserts the specified value into the knot vector at the specified index.
Interval | Computes the knot interval containing the specified parameter and returns the index of the knot interval.
IsEqualTo | Determines whether this knot vector is equal to the specified knot vector, TRUE, or not, FALSE.
Item | Gets the knot value at the specified index.
Item | Gets the knot value at the specified index.
MultiplicityAt | Computes and returns the knot multiplicity of the knot value at the specified index.
RemoveKnotAt | Removes the knot at the specified index.
RemoveRange | Removes all knots within the specified index range.
Reverse | Performs a linear transformation on the knot sequence so the first knot is mapped to the maximal value, and vice versa, the last knot is mapped to the minimal value.
SetRange | Performs a linear transformation k = a * k + b of the knot sequence in order to place all the values between the specified lower and upper values.
Split | Splits the knot sequence at the specified parameter value. The knot value at the end of the first piece and at the beginning of the second piece is inserted or deleted to satisfy the specified multiplicity values.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the knot values as an array of Doubles.
DistinctKnots | Gets the sequence of all knot values in the vector without duplicates within the vectors tolerance.
EndParameter | Gets the last knot value of the knot vector.
IsEmpty | Gets whether the knot vector is empty, TRUE, or not, FALSE.
Length | Gets the length of the knot values of the knot vector.
NumberOfIntervals | Gets the number of the non-zero intervals between knots.
StartParameter | Gets the first knot value of the knot vector.
Tolerance | Specifies the knot value tolerance used by the knot vector.
Links
IGeKnotVector Interface, Legend, Methods, Properties


IGeKnotVector::Application Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Application Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::AsArray Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::AsArray Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::AsArray Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Specifies the knot values as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::DistinctKnots Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::DistinctKnots Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::DistinctKnots Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the sequence of all knot values in the vector without duplicates within the vectors tolerance.

Visual Basic
Property DistinctKnots() As VARIANT*
Remarks

This property is a Variant (array of Doubles).

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::EndParameter Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::EndParameter Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::EndParameter Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the last knot value of the knot vector.

Visual Basic
Property EndParameter() As double*
Remarks

This property is a Double.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::IsEmpty Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::IsEmpty Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::IsEmpty Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets whether the knot vector is empty, TRUE, or not, FALSE.

Visual Basic
Property IsEmpty() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Length Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Length Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Length Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the length of the knot values of the knot vector.

Visual Basic
Property Length() As long*
Remarks

This property is a Long.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::NumberOfIntervals Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::NumberOfIntervals Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::NumberOfIntervals Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the number of the non-zero intervals between knots.

Visual Basic
Property NumberOfIntervals() As long*
Remarks

This property is a Long.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::StartParameter Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::StartParameter Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::StartParameter Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the first knot value of the knot vector.

Visual Basic
Property StartParameter() As double*
Remarks

This property is a Double.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Tolerance Property

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Tolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Tolerance Property
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Specifies the knot value tolerance used by the knot vector.

Visual Basic
Property Tolerance() As double
Remarks

This property is a Double.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::AddKnot Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::AddKnot Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::AddKnot Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Appends the specified value to the knot vector.

Visual Basic
Sub AddKnot(Value As double, Index As [out, retval] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to append to the knot vector.
Returns

Long

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::AddKnotVector Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::AddKnotVector Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::AddKnotVector Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Performs a linear transformation (k = a * k + b), with appropriate coefficients a and b, on this vector and on tail vector.

Visual Basic
Sub AddKnotVector(Vector As IGeKnotVector, Ratio As [in, defaultvalue(0.0)] double)
Parameters
Parameters | Description
Vector | GeKnotVector object; input-only. Specifies the knot vector based on which to perform the linear transformation.
Ratio | Double, the default value is 0.0; input-only; optional. Specifies the ratio for the knot vector. If the knot ratio is zero, no scaling takes place and this vector is appended with the tail part.
Returns

None

Remarks

The ratio of their lengths becomes equal to specified knot ratio and the tail sequence immediately follows this vector.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Contains Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Contains Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Contains Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Determines whether the specified parameter is within the range of the first and last knot value, TRUE, or not, FALSE.

Visual Basic
Sub Contains(Value As double, Contains As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Variant (Double); input-only. Specifies the parameter to perform the check.
Returns

Boolean

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Insert Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Insert Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Insert Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Inserts the specified value into the appropriate knot interval.

Visual Basic
Sub Insert(Value As double)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to insert.
Returns

None

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::InsertKnot Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::InsertKnot Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::InsertKnot Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Inserts the specified value into the knot vector at the specified index.

Visual Basic
Sub InsertKnot(Value As double, Index As long, Multplicity As [in, defaultvalue(1)] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the value to insert.
Index | Integer; input-only. Specifies the index for the knot vector.
Multiplicity | Integer, the default value is 1; input-only; optional. Specifies the multiplicity to increment the knot. If the specified value is within the knot vectors tolerance of an existing knot value, the multiplicity of the knot is incremented by one.
Returns

None

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Interval Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Interval Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Interval Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Computes the knot interval containing the specified parameter and returns the index of the knot interval.

Visual Basic
Sub Interval(Order As long, Value As double, ByRef Interval As IGeInterval*, Index As [out, retval] long)
Parameters
Parameters | Description
Order | Integer; input-only. Specifies the order of the spline.
Value | Double; input-only. Specifies the parameter value contained in the knot interval. The parameter must be between the knot values indexed by (order - 1) and (number of knots - order), where order is the spline order.
Interval | GeInterval object; output-only. Specifies the knot interval containing the parameter.
Returns

Long

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::IsEqualTo Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::IsEqualTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::IsEqualTo Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Determines whether this knot vector is equal to the specified knot vector, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Vector As IGeKnotVector, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeKnotVector object; input-only. Specifies the other knot vector to perform the check.
Returns

Boolean

Remarks

Two entities are considered to be equal only if they are of the same type and they represent the same 3d point set.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Item Method ([in] long, [in] double)

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Item Method ([in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Item Method ([in] long, [in] double)
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the knot value at the specified index.

Visual Basic
Sub Item(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to perform the calculation.
Remarks

This property is a Double.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Item Method ([in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Item Method ([in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Item Method ([in] long, [out, retval] double*)
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Gets the knot value at the specified index.

Visual Basic
Sub Item(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to perform the calculation.
Remarks

This property is a Double.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::MultiplicityAt Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::MultiplicityAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::MultiplicityAt Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Computes and returns the knot multiplicity of the knot value at the specified index.

Visual Basic
Sub MultiplicityAt(Index As long, Multiplicity As [out, retval] long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the knot vector to perform the calculation.
Returns

Long

Remarks

If two consecutive knots differ by less than the vectors tolerance they are considered identical and their multiplicities are combined.

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::RemoveKnotAt Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::RemoveKnotAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::RemoveKnotAt Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Removes the knot at the specified index.

Visual Basic
Sub RemoveKnotAt(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the knot to remove.
Returns

None

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::RemoveRange Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::RemoveRange Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::RemoveRange Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Removes all knots within the specified index range.

Visual Basic
Sub RemoveRange(Start As long, End As long)
Parameters
Parameters | Description
Start | Integer; input-only. Specifies the start index of the range for the knots to remove.
End | Integer; input-only. Specifies the end index of the range for the knots to remove.
Returns

None

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Reverse Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Reverse Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Reverse Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Performs a linear transformation on the knot sequence so the first knot is mapped to the maximal value, and vice versa, the last knot is mapped to the minimal value.

Visual Basic
Sub Reverse()
Returns

None

Remarks
  • The first knot in the new sequence is the image of the largest knot of the original vector, the second one is the image of the second to the largest one, and so on.
  • The knot vector boundaries remain the same.
Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::SetRange Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::SetRange Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::SetRange Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Performs a linear transformation k = a * k + b of the knot sequence in order to place all the values between the specified lower and upper values.

Visual Basic
Sub SetRange(Lower As double, Upper As double)
Parameters
Parameters | Description
Lower | Double; input-only. Specifies the lower value to perform the linear transformation.
Upper | Double; input-only. Specifies the upper value to perform the linear transformation.
Returns

None

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeKnotVector::Split Method

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector::Split Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector::Split Method
IGeKnotVector Interface IGeKnotVector Members IGeKnotVector Interface Send Feedback
Summary

Splits the knot sequence at the specified parameter value. The knot value at the end of the first piece and at the beginning of the second piece is inserted or deleted to satisfy the specified multiplicity values.

Visual Basic
Sub Split(Value As double, ByRef Head As IGeKnotVector*, HeadMultiplicity As long, ByRef Tail As IGeKnotVector*, TailMultiplicity As long, Index As [out, retval] long)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the parameter value at which to split the knot sequence.
Head | GeKnotVector object; output-only. Specifies the first piece of the knot sequence.
HeadMultiplicity | Long; input-only. Specifies the multiplicity for the first piece of the knot sequence.
Tail | GeKnotVector object; output-only. Specifies the second piece of the knot sequence.
TailMultiplicity | Long; input-only. Specifies the multiplicity for the second piece of the knot sequence.
Returns

Long

Interface

IGeKnotVector Interface

Links
IGeKnotVector Interface, IGeKnotVector Members, IGeKnotVector Interface


IGeLine Interface

You are here: API Reference > GEAuto Library > IGeLine Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLine Interface
IGeLine Members GEAuto Library Class Hierarchy Send Feedback
Summary

An unbounded line.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine
Visual Basic
Public Interface IGeLine
Inherits IGeLinearEntity
Library

GEAuto Library

Links
IGeLine Members, GEAuto Library, Class Hierarchy


IGeLine Members

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLine Members
IGeLine Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeLine.

Interface

IGeLine Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.
Links
IGeLine Interface, Legend, Methods, Properties


IGeLine::Set Method

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLine::Set Method
IGeLine Interface IGeLine Members IGeLine Interface Send Feedback
Summary

Changes the definition of the line to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this line passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this ray respects on the specified point.
Returns

None

Interface

IGeLine Interface

Links
IGeLine Interface, IGeLine Members, IGeLine Interface


IGeLinearEntity Interface

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity Interface
IGeLinearEntity Members GEAuto Library Class Hierarchy Send Feedback
Summary

A generic linear entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine
            IGeLineSegment
            IGeRay
Visual Basic
Public Interface IGeLinearEntity
Inherits IGeCurve
Library

GEAuto Library

Links
IGeLinearEntity Members, GEAuto Library, Class Hierarchy


IGeLinearEntity Members

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity Members
IGeLinearEntity Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeLinearEntity.

Interface

IGeLinearEntity Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.
Links
IGeLinearEntity Interface, Legend, Methods, Properties


IGeLinearEntity::Direction Property

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::Direction Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::Direction Property
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.

Visual Basic
Property Direction() As IGeVector**
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::PointOnLine Property

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::PointOnLine Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::PointOnLine Property
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Gets an arbitrary point on the linear entity.

Visual Basic
Property PointOnLine() As IGePoint**
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::IntersectWith Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Point As IGePoint*, Direction As [in, optional] VARIANT, Point2 As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | .
Point | .
Direction | .
Point2 | .
Tolerance | .
Remarks

If this method returns TRUE then Intersections will be set to either 1 or 2, otherwise it will be set to 0. Point1 will only be set if the number of intersection is greater than zero, and Point2 will only be set if the number of intersections is greater than one. The two arcs do not need to lie in the same plane. The optional projection direction can be used to specify the normal of a plane that this arc and a linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the arc and a linear entity. This option is only available when Curve is a GeLinearEntity. LinePoint1 and LinePoint2 return the possible intersection points on the linear entity when using the projection direction option.

For GeLinearEntity objects: Determines whether the line intersects with the specified linear or plane entity. The Point value is only set if this method returns TRUE. The optional projection direction can be used to specify the normal of a plane that this and the specified linear entity are projected onto before computing the intersection. This provides a line of sight intersection between the linear entities. This option is only available when Entity is a GeLinearEntity. The LinePoint element returns the intersection point on the other linear entity when using the projection direction option.

For GeCone and GeCylinder objects: Computes the intersection between the cone, cylinder, or elliptical arc and a linear entity. The method returns False if there is no intersection.

For GePlane objects: Computes the intersection between the plane and the specified linear entity or other plane.

For GeSphere objects: Computes the intersection between the sphere and the specified linear entity.

For GeTorus objects: Computes the intersection between the torus and the specified linear entity.

Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::IsColinearTo Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::IsColinearTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::IsColinearTo Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Determines if this line is collinear to the specified line.

Visual Basic
Sub IsColinearTo(Line As IGeLinearEntity, Tolerance As [in, optional] VARIANT, Colinear As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Line GeLinearEntity object; input-only .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::IsOnPlane Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::IsOnPlane Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::IsOnPlane Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Determines if the line lies on the specified plane.

Visual Basic
Sub IsOnPlane(Plane As IGePlane, Tolerance As [in, optional] VARIANT, OnPlane As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Plane | Plane GePlane object; input-only .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::IsParallelTo Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::IsParallelTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::IsParallelTo Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Determines if the specified entity is parallel to this entity.

Visual Basic
Sub IsParallelTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Entity GeLinearEntity or GePlane object; input-only; .Entity GeVector object; input-only; .Entity GePlane or GeLinearEntity object; input-only; .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::IsPerpendicularTo Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::IsPerpendicularTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::IsPerpendicularTo Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.

Visual Basic
Sub IsPerpendicularTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | Entity GeLinearEntity or GePlane object; input-only; .Entity GeVector object; input-only; .Entity GeLinearEntity or GePlane object; input-only; .
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .Tolerance Variant(GeTolerance object); input-only; optional; . The tolerance used in the calculation. .
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::Overlap Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::Overlap Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::Overlap Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.

Visual Basic
Sub Overlap(Line As IGeLinearEntity, ByRef Overlap As IGeLinearEntity*, Tolerance As [in, optional] VARIANT, DoOverlap As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | Line GeLinearEntity object; input-only. The linear entity to check for overlap.
Overlap | Overlap GeLinearEntity object. The region of overlap.
Tolerance | Tolerance Variant(GeTolerance object); input-only; optional. The tolerance used in the calculation.
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLinearEntity::PerpendicularPlane Method

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity::PerpendicularPlane Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity::PerpendicularPlane Method
IGeLinearEntity Interface IGeLinearEntity Members IGeLinearEntity Interface Send Feedback
Summary

Calculates a plane perpendicular to the line at the specified point

Visual Basic
Sub PerpendicularPlane(Point As IGePoint, Plane As [out, retval] IGePlane*)
Parameters
Parameters | Description
Point | Point GePoint object; input-only.
Interface

IGeLinearEntity Interface

Links
IGeLinearEntity Interface, IGeLinearEntity Members, IGeLinearEntity Interface


IGeLineSegment Interface

You are here: API Reference > GEAuto Library > IGeLineSegment Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment Interface
IGeLineSegment Members GEAuto Library Class Hierarchy Send Feedback
Summary

A bounded line segment.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLineSegment
Visual Basic
Public Interface IGeLineSegment
Inherits IGeLinearEntity
Library

GEAuto Library

Links
IGeLineSegment Members, GEAuto Library, Class Hierarchy


IGeLineSegment Members

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment Members
IGeLineSegment Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeLineSegment.

Interface

IGeLineSegment Interface

Methods
Name | Description
BaryComb | Returns the point that is the weighted average of the start and end points of the line segment.
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line segment to pass through the specified point in the direction of the specified vector.
TangentTangent | Changes the definition of the line segment so that the line segment is tangent to the two input curves.
TangentTo | Changes the definition of the line segment so that the line segment passes through the specified point and is tangent to the specified curve.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Bisector | Gets the unbounded plane that is perpendicular to the line segment and passes through its midpoint.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
EndPoint | Specifies the end point of the line segment.
Interval | Sets the interval of the curve and returns the index of the interval.
MidPoint | Gets the midpoint of the line segment.
PointOnLine | Gets an arbitrary point on the linear entity.
StartPoint | Specifies the start point of the line segment.
Links
IGeLineSegment Interface, Legend, Methods, Properties


IGeLineSegment::Bisector Property

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::Bisector Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::Bisector Property
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Gets the unbounded plane that is perpendicular to the line segment and passes through its midpoint.

Visual Basic
Property Bisector() As IGePlane**
Remarks

This property is a GePlane object.

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::EndPoint Property

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::EndPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::EndPoint Property
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Specifies the end point of the line segment.

Visual Basic
Property EndPoint() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::MidPoint Property

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::MidPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::MidPoint Property
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Gets the midpoint of the line segment.

Visual Basic
Property MidPoint() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::StartPoint Property

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::StartPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::StartPoint Property
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Specifies the start point of the line segment.

Visual Basic
Property StartPoint() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::BaryComb Method

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::BaryComb Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::BaryComb Method
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Returns the point that is the weighted average of the start and end points of the line segment.

Visual Basic
Sub BaryComb(BlendCoefficient As double, Point As [out, retval] IGePoint*)
Parameters
Parameters
Description
BlendCoefficient
Double; input-only. Specifies the blend coefficient.

  • If the blend coefficient is zero, this method returns the start point of the line segment.
  • If the blend coefficient is 1, this method returns the end point of the line segment.
  • If the blend coefficient is 0.5, this method returns the midpoint of the line segment.
  • If the blend coefficient is between 0 and 1, the returned point will lie on the line segment; Otherwise the returned point will not lie on the line segment but will lie on the unbounded line that is coincident with the line segment.

Returns

GePoint object

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::Set Method

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::Set Method
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Changes the definition of the line segment to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this ray passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this line segment respects on the specified point.
Returns

None

Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::TangentTangent Method

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::TangentTangent Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::TangentTangent Method
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Changes the definition of the line segment so that the line segment is tangent to the two input curves.

Visual Basic
Sub TangentTangent(Curve1 As IGeCurve, Curve2 As IGeCurve, Parameter1 As [in, out, optional] VARIANT, Parameter2 As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve1 | GeCurve object; input-only. Specifies the first curve to be tangent to.
Curve2 | GeCurve object; input-only. Specifies the second curve to be tangent to.
Parameter1 | Variant (Double); optional. Specifies the tangent point on the first curve and the initial guess.
Parameter2 | Variant (Double); optional. Specifies the tangent point on the second curve and the initial guess.
Returns

Boolean

Remarks
  • On input, existing values of the Parameter1 and Parameter2 elements are used as initial guess values to the parameters of the two tangent points.
  • If the tangent line segment was computed successfully, the method returns TRUE, otherwise FALSE and the line segment is unchanged.
Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeLineSegment::TangentTo Method

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment::TangentTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment::TangentTo Method
IGeLineSegment Interface IGeLineSegment Members IGeLineSegment Interface Send Feedback
Summary

Changes the definition of the line segment so that the line segment passes through the specified point and is tangent to the specified curve.

Visual Basic
Sub TangentTo(Curve As IGeCurve, Point As IGePoint, Parameter As [in, out, optional] VARIANT, Success As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Curve | GeCurve object; input-only. Specifies the curve to be tangent to.
Point | GePoint object; input-only. Specifies the point for the line segment to pass through.
Parameter | Variant (Double); optional. Specifies the tangent point on the curve and the initial guess.
Returns

Boolean

Remarks
  • The curve must be planar and the specified point must lie on the plane of the curve.
  • On input, any existing value of the Parameter element is used as an initial guess value to the parameter of the tangent point.
  • If the tangent line segment was computed successfully, the method returns TRUE, otherwise FALSE and the line segment is unchanged.
Interface

IGeLineSegment Interface

Links
IGeLineSegment Interface, IGeLineSegment Members, IGeLineSegment Interface


IGeMatrix Interface

You are here: API Reference > GEAuto Library > IGeMatrix Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix Interface
IGeMatrix Members GEAuto Library Class Hierarchy Send Feedback
Summary

A 4 x 4 matrix representing an affine transformation including translation.

Class Hierarchy

Declaration syntax

IGeMatrix
Visual Basic
Public Interface IGeMatrix
Inherits IDispatch
Library

GEAuto Library

Links
IGeMatrix Members, GEAuto Library, Class Hierarchy


IGeMatrix Members

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix Members
IGeMatrix Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeMatrix.

Interface

IGeMatrix Interface

Methods
Name | Description
GetCoordinateSystem | Gets the origin point and axis direction vectors of the coordinate system that this matrix maps to.
Invert | Sets the matrix to be equal to its inverse.
IsEqualTo | Determines whether this matrix is equal to the specified matrix within the specified tolerance, TRUE, or not, FALSE.
IsOrthogonal | Gets whether the column vectors of the linear portion of the matrix are orthogonal or perpendicular with each other, TRUE, or not, FALSE.
IsSingular | Gets whether any column vector of the linear portion of the matrix is in zero length or whether any two column vectors of the linear portion of the matrix are parallel, TRUE, or not, FALSE.
IsUniformScaledOrtho | Gets whether this matrix is orthogonal or perpendicular to each other, and uniformly scaled, TRUE, or not, FALSE.
Item | Specifies the matrix element value at the specified row and column.
Item | Specifies the matrix element value at the specified row and column.
PostMultiply | Computes the matrix resulting from this matrix multiplied by the specified matrix.
PreMultiply | Computes the matrix resulting from the specified matrix multiplied by this matrix.
Product | Returns the product of this matrix and the specified matrix.
SetToAlignCoordinateSystem | Sets this matrix to the matrix which maps from one specified coordinate system to another specified coordinate system.
SetToCoordinateSystem | Sets this matrix to the matrix which maps the standard coordinate system with the origin (0, 0, 0) and axes (1, 0, 0), (0, 1, 0) and (0, 0, 1) to the specified coordinate system.
SetToIdentity | Sets this matrix to the identity matrix.
SetToMirroring | Sets this matrix to the matrix of mirroring with respect to the specified entity.
SetToProduct | Sets this matrix to the product of the two specified matrices.
SetToProjection | Sets this matrix to the matrix with the parallel projection into the specified plane.
SetToRotation | Sets this matrix to the matrix with the rotation by the specified angle around the specified axis vector.
SetToScaling | Sets this matrix to the matrix with the uniform scaling by the specified scale factor with respect to the specified point.
SetToTranslation | Sets this matrix to the matrix with translation by the specified vector.
TransposeIt | Sets this matrix to its current transpose.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the elements of the 4 x 4 matrix by row from top to bottom.
Determinant | Gets the determinant of this matrix.
Inverse | Gets the inverse matrix of this matrix.
Scale | Multiplies the matrix by the scale factor.
Translation | Specifies the translation portion of the matrix.
Transpose | Gets the transposition matrix of this matrix.
Links
IGeMatrix Interface, Legend, Methods, Properties


IGeMatrix::Application Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Application Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::AsArray Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::AsArray Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::AsArray Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Specifies the elements of the 4 x 4 matrix by row from top to bottom.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant(array of Doubles).

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Determinant Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Determinant Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Determinant Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets the determinant of this matrix.

Visual Basic
Property Determinant() As double*
Remarks

This property is a Double.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Inverse Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Inverse Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Inverse Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets the inverse matrix of this matrix.

Visual Basic
Property Inverse() As IGeMatrix**
Remarks

This property is a GeMatrix object.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Scale Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Scale Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Scale Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Multiplies the matrix by the scale factor.

Visual Basic
Property Scale() As double*
Remarks

This property is a Double.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Translation Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Translation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Translation Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Specifies the translation portion of the matrix.

Visual Basic
Property Translation() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Transpose Property

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Transpose Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Transpose Property
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets the transposition matrix of this matrix.

Visual Basic
Property Transpose() As IGeMatrix**
Remarks

This property is a GeMatrix object.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::GetCoordinateSystem Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::GetCoordinateSystem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::GetCoordinateSystem Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets the origin point and axis direction vectors of the coordinate system that this matrix maps to.

Visual Basic
Sub GetCoordinateSystem(ByRef Origin As IGePoint*, ByRef Axis1 As IGeVector*, ByRef Axis2 As IGeVector*, ByRef Axis3 As IGeVector*)
Parameters
Parameters | Description
Origin | GePoint object; output-only. Returns the origin point of the coordinate system.
Axis1 | GeVector object; output-only. Returns the X axis of the coordinate system.
Axis2 | GeVector object; output-only. Returns the Y axis of the coordinate system.
Axis3 | GeVector object; output-only. Returns the Z axis of the coordinate system.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Invert Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Invert Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Invert Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets the matrix to be equal to its inverse.

Visual Basic
Sub Invert()
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::IsEqualTo Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::IsEqualTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::IsEqualTo Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Determines whether this matrix is equal to the specified matrix within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Matrix As IGeMatrix, Tolerance As [in, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::IsOrthogonal Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::IsOrthogonal Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::IsOrthogonal Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets whether the column vectors of the linear portion of the matrix are orthogonal or perpendicular with each other, TRUE, or not, FALSE.

Visual Basic
Sub IsOrthogonal(Tolerance As [in, optional] VARIANT, Orthogonal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::IsSingular Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::IsSingular Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::IsSingular Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets whether any column vector of the linear portion of the matrix is in zero length or whether any two column vectors of the linear portion of the matrix are parallel, TRUE, or not, FALSE.

Visual Basic
Sub IsSingular(Tolerance As [in, optional] VARIANT, Singular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::IsUniformScaledOrtho Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::IsUniformScaledOrtho Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::IsUniformScaledOrtho Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Gets whether this matrix is orthogonal or perpendicular to each other, and uniformly scaled, TRUE, or not, FALSE.

Visual Basic
Sub IsUniformScaledOrtho(Tolerance As [in, optional] VARIANT, UniformOrtho As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Item Method ([in] long, [in] long, [in] double)

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Item Method ([in] long, [in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Item Method ([in] long, [in] long, [in] double)
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Specifies the matrix element value at the specified row and column.

Visual Basic
Sub Item(I As long, J As long, Value As double)
Parameters
Parameters | Description
I | Long; input-only. Specifies the row where the matrix element lies.
J | Long; input-only. Specifies the column where the matrix element lies.
Remarks

This property is a Double.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Specifies the matrix element value at the specified row and column.

Visual Basic
Sub Item(I As long, J As long, Value As [out, retval] double)
Parameters
Parameters | Description
I | Long; input-only. Specifies the row where the matrix element lies.
J | Long; input-only. Specifies the column where the matrix element lies.
Remarks

This property is a Double.

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::PostMultiply Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::PostMultiply Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::PostMultiply Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Computes the matrix resulting from this matrix multiplied by the specified matrix.

Visual Basic
Sub PostMultiply(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to multiple this matrix for calculation.
Returns

GeMatrix object

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::PreMultiply Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::PreMultiply Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::PreMultiply Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Computes the matrix resulting from the specified matrix multiplied by this matrix.

Visual Basic
Sub PreMultiply(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to be multiplied by this matrix for calculation.
Returns

GeMatrix object

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::Product Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::Product Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::Product Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Returns the product of this matrix and the specified matrix.

Visual Basic
Sub Product(Matrix As IGeMatrix, Result As [out, retval] IGeMatrix*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the other matrix to calculate the product.
Returns

GeMatrix object

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToAlignCoordinateSystem Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToAlignCoordinateSystem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToAlignCoordinateSystem Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix which maps from one specified coordinate system to another specified coordinate system.

Visual Basic
Sub SetToAlignCoordinateSystem(FromOrigin As IGePoint, FromAxis1 As IGeVector, FromAxis2 As IGeVector, FromAxis3 As IGeVector, ToOrigin As IGePoint, ToAxis1 As IGeVector, ToAxis2 As IGeVector, ToAxis3 As IGeVector)
Parameters
Parameters | Description
FromOrigin | GePoint object; input-only. Specifies the origin point of the start coordinate system.
FromAxis1 | GeVector object; input-only. Specifies the X axis of the start coordinate system.
FromAxis2 | GeVector object; input-only. Specifies the Y axis of the start coordinate system.
FromAxis3 | GeVector object; input-only. Specifies the Z axis of the start coordinate system.
ToOrigin | GePoint object; input-only. Specifies the origin point of the target coordinate system.
ToAxis1 | GeVector object; input-only. Specifies the X axis of the end coordinate system.
ToAxis2 | GeVector object; input-only. Specifies the Y axis of the end coordinate system.
ToAxis3 | GeVector object; input-only. Specifies the Z axis of the target coordinate system.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToCoordinateSystem Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToCoordinateSystem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToCoordinateSystem Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix which maps the standard coordinate system with the origin (0, 0, 0) and axes (1, 0, 0), (0, 1, 0) and (0, 0, 1) to the specified coordinate system.

Visual Basic
Sub SetToCoordinateSystem(Origin As IGePoint, Axis1 As IGeVector, Axis2 As IGeVector, Axis3 As IGeVector)
Parameters
Parameters | Description
Origin | GePoint object; input-only. Specifies the origin point of the target coordinate system.
Axis1 | GeVector object; input-only. Specifies the X axis of the target coordinate system.
Axis2 | GeVector object; input-only. Specifies the Y axis of the end coordinate system.
Axis3 | GeVector object; input-only. Specifies the Z axis of the target coordinate system.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToIdentity Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToIdentity Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToIdentity Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the identity matrix.

Visual Basic
Sub SetToIdentity()
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToMirroring Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToMirroring Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToMirroring Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix of mirroring with respect to the specified entity.

Visual Basic
Sub SetToMirroring(Entity As IGeEntity)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity about which to mirror this matrix. It can be a GePlane , GeLine , or GePoint object.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToProduct Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToProduct Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToProduct Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the product of the two specified matrices.

Visual Basic
Sub SetToProduct(Matrix1 As IGeMatrix, Matrix2 As IGeMatrix)
Parameters
Parameters | Description
Matrix1 | GeMatrix object; input-only. Specifies one matrix to get the product matrix.
Matrix2 | GeMatrix object; input-only. Specifies the other matrix to get the product matrix.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToProjection Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToProjection Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToProjection Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix with the parallel projection into the specified plane.

Visual Basic
Sub SetToProjection(Plane As IGePlane, Direction As IGeVector)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane to implement the parallel projection of this matrix.
Direction | GeVector object; input-only. Specifies the direction of the parallel projection.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToRotation Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToRotation Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToRotation Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix with the rotation by the specified angle around the specified axis vector.

Visual Basic
Sub SetToRotation(Angle As double, Axis As IGeVector, Center As IGePoint)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this matrix. The direction of the rotation satisfies the right hand rule.
Axis | GeVector object; input-only. Specifies the axis vector around which to rotate this matrix.
Center | GePoint object; input-only. Specifies a point that the axis vector passes through.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToScaling Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToScaling Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToScaling Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix with the uniform scaling by the specified scale factor with respect to the specified point.

Visual Basic
Sub SetToScaling(Factor As double, Center As IGePoint)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the factor in which to scale this matrix.
Center | GePoint object; input-only. Specifies the base point to scale this matrix.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::SetToTranslation Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::SetToTranslation Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::SetToTranslation Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to the matrix with translation by the specified vector.

Visual Basic
Sub SetToTranslation(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the vector in which to translate or move this matrix.
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeMatrix::TransposeIt Method

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix::TransposeIt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix::TransposeIt Method
IGeMatrix Interface IGeMatrix Members IGeMatrix Interface Send Feedback
Summary

Sets this matrix to its current transpose.

Visual Basic
Sub TransposeIt()
Returns

None

Interface

IGeMatrix Interface

Links
IGeMatrix Interface, IGeMatrix Members, IGeMatrix Interface


IGeNurbCurve Interface

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve Interface
IGeNurbCurve Members GEAuto Library Class Hierarchy Send Feedback
Summary

A Non-Uniform Rational B-spline, or NURB curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeNurbCurve
Visual Basic
Public Interface IGeNurbCurve
Inherits IGeCurve
Library

GEAuto Library

Links
IGeNurbCurve Members, GEAuto Library, Class Hierarchy


IGeNurbCurve Members

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve Members
IGeNurbCurve Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeNurbCurve.

Interface

IGeNurbCurve Interface

Methods
Name
Description
AddFitPointAt
Inserts the specified point into the fit points at the specified index.
AddKnot
Adds the knot value into the curve's knot sequence.
BoundBlock
Computes the bounding box around the curve or the curve interval.
ClosestPointTo
Calculates the closest point on this curve to the specified point.
ClosestPointToCurve
Calculates the closest point on this curve to the specified curve.
ContinuityAtKnot
Gets the degree of the highest derivative that is continuous at a knot. For example, if this NURB curve does not have its first derivative at the specified knot index, the value 0 is returned.
ControlPointAt
Specifies the control point at the specified index.
ControlPointAt
Specifies the control point at the specified index.
DistanceTo
Calculates the minimum distance between this curve to the specified geometry entity.
ElevateDegree
Elevates the degree of the NURB curve by the specified amount.
EvaluatePoint
Returns the point on the curve corresponding to the specified parameter value.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
GetArea
Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature
Gets the curvature of the curve at the specified parameter value.
GetDefinitionData
Gets all the data that defines this NURB curve.
GetFitData
Gets the fit data used by the fit curve.
GetLength
Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints
Evaluates a sampling of points along the curve.
GetSplitCurves
Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint
Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint
Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve
Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface
Calculates the intersection with the specified surface within the specified tolerance.
IsClosed
Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith
Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate
Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo
Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear
Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn
Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval
Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic
Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar
Gets whether this curve is planar, TRUE, or not, FALSE.
JoinWith
Recomputes this NURB curve by joining the specified NURB curve to the end of this NURB curve.
KnotAt
Specifies the knot value at the specified index.
KnotAt
Specifies the knot value at the specified index.
LocalClosestPointTo
Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve
Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
MakeClosed
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this NURB curve to form a smooth closed curve.
  • If the Option element is FALSE and if the curve is closed, it is made open by removing the span between the last and next-to-last knots.
MakePeriodic
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this curve to form a smooth closed curve, and then is made into a periodic curve.
  • If the Option element is FALSE and if the curve is periodic, it is made non-periodic by assigning full knot multiplicity at the first and last knots.
MakeRational
Sets this NURB curve as rational and sets the weight of each control point to the specified weight.
Mirror
Mirrors this entity about the specified plane.
NormalPoint
Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength
Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf
Calculates the parameter value on this curve, which corresponds to the specified point.
ParametersOfC1
Checks whether there are any C1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
ParametersOfG1
Checks whether there are any G1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
Project
Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
PurgeFitData
Removes all fit data from the NURB curve.
RemoveFitPointAt
Removes the fit point at the specified index.
Reverse
Reverses the parametric direction of the curve.
RotateBy
Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy
Multiplies this entity by the scale factor.
SetDefinitionData
Sets the definition data of the NURB curve from the specified parameters.
SetFitData
Recomputes this NURB curve from the specified knot vector, fit points, start and end tangents, and fit tolerance.
TransformBy
Transforms this entity by the specified matrix.
TranslateBy
Translates or moves the entity by the specified translation vector.
TrimByParameters
Trims this NURB curve to the new start and end parameters.
WeightAt
Specifies the weight value for the control point at the specified index.
WeightAt
Specifies the weight value for the control point at the specified index.
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPointCount | Gets the number of control points on this NURB curve.
ControlPoints | Gets all control points on this NURB curve.
Degree | Gets the degree of this NURB curve.
EndParameter | Gets the end parameter value of this NURB curve.
EndPoint | Gets the end point of this NURB curve.
EvaluatorMode | Specifies the curve evaluation optimization mode.
FitEndTangent | Specifies the tangent at the end of a fit curve.
FitPointCount | Gets the number of fit points used to construct this NURB curve.
FitPoints | Gets the fit points used to construct this NURB curve.
FitStartTangent | Specifies the tangent at the start of a fit curve.
FitTolerance | Specifies the tolerance used for interpolating this NURB curve from the fit data.
HasFitData | Gets whether the NURB curve has interpolating fit data.
Interval | Sets the interval of the curve and returns the index of the interval.
IsRational | Gets whether this NURB curve is rational, TRUE, or not, FALSE.
KnotCount | Gets the length of the knot vector for this NURB curve.
Knots | Gets the knot vector from this NURB curve.
Order | Gets the order of this NURB curve.
StartParameter | Gets the start parameter of this NURB curve.
StartPoint | Gets the start point of this NURB curve.
WeightCount | Gets the number of weights for this NURB curve.
Weights | Gets all weights of control points.
Links
IGeNurbCurve Interface, Legend, Methods, Properties


IGeNurbCurve::ControlPointCount Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ControlPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ControlPointCount Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the number of control points on this NURB curve.

Visual Basic
Property ControlPointCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ControlPoints Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ControlPoints Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ControlPoints Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets all control points on this NURB curve.

Visual Basic
Property ControlPoints() As IGePoints**
Remarks

This property is a gePoints collection.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::Degree Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::Degree Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::Degree Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the degree of this NURB curve.

Visual Basic
Property Degree() As long*
Remarks

This property is a Long.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::EndParameter Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::EndParameter Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::EndParameter Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the end parameter value of this NURB curve.

Visual Basic
Property EndParameter() As double*
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::EndPoint Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::EndPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::EndPoint Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the end point of this NURB curve.

Visual Basic
Property EndPoint() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::EvaluatorMode Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::EvaluatorMode Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::EvaluatorMode Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the curve evaluation optimization mode.

Visual Basic
Property EvaluatorMode() As VARIANT_BOOL
Remarks

This property is a Boolean:

  • FALSE: There is no optimization of an internal evaluator. This mode generally should be used if only one or two values per interval between two consecutive knots are evaluated.
  • TRUE: The evaluator optimization is turned on. This will provide better performance if three or more values per knot interval are computed.
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitEndTangent Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitEndTangent Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitEndTangent Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the tangent at the end of a fit curve.

Visual Basic
Property FitEndTangent() As IGeVector*
Remarks
  • This property is a GeVector object.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitPointCount Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitPointCount Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the number of fit points used to construct this NURB curve.

Visual Basic
Property FitPointCount() As long*
Remarks
  • This property is a Long.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitPoints Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitPoints Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitPoints Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the fit points used to construct this NURB curve.

Visual Basic
Property FitPoints() As IGePoints**
Remarks
  • This property is a gePoints collection.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitStartTangent Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitStartTangent Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitStartTangent Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the tangent at the start of a fit curve.

Visual Basic
Property FitStartTangent() As IGeVector*
Remarks
  • This property is a GeVector object.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitTolerance Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitTolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitTolerance Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the tolerance used for interpolating this NURB curve from the fit data.

Visual Basic
Property FitTolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::HasFitData Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::HasFitData Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::HasFitData Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets whether the NURB curve has interpolating fit data.

Visual Basic
Property HasFitData() As VARIANT_BOOL*
Remarks

  • This property is a Boolean.
  • A NURB curve will only have fit data associated if it has been constructed with fit data.
  • Any direct editing of the underlying NURB curve data, such as setting a control point position, a knot value, or a weight, will remove the fit data.
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::IsRational Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::IsRational Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::IsRational Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets whether this NURB curve is rational, TRUE, or not, FALSE.

Visual Basic
Property IsRational() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::KnotCount Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::KnotCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::KnotCount Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the length of the knot vector for this NURB curve.

Visual Basic
Property KnotCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::Knots Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::Knots Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::Knots Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the knot vector from this NURB curve.

Visual Basic
Property Knots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::Order Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::Order Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::Order Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the order of this NURB curve.

Visual Basic
Property Order() As long*
Remarks

  • This property is a Long.
  • The curve is defined on the interval between knot values indexed by order - 1 and numberOfKnots - order. The order is greater than the spline degree by 1.
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::StartParameter Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::StartParameter Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::StartParameter Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the start parameter of this NURB curve.

Visual Basic
Property StartParameter() As double*
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::StartPoint Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::StartPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::StartPoint Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the start point of this NURB curve.

Visual Basic
Property StartPoint() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::WeightCount Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::WeightCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::WeightCount Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the number of weights for this NURB curve.

Visual Basic
Property WeightCount() As long*
Remarks

  • This property is a Long.
  • If the curve is not rational, the number of weights will be zero; otherwise, the number of weights will be equal to the number of control points.
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::Weights Property

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::Weights Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::Weights Property
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets all weights of control points.

Visual Basic
Property Weights() As VARIANT*
Remarks

This property is a Variant (array of Doubles).

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::AddFitPointAt Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::AddFitPointAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::AddFitPointAt Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Inserts the specified point into the fit points at the specified index.

Visual Basic
Sub AddFitPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the new fit point to insert.
Point | GePoint object; input-only. Specifies the new fit point to insert.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::AddKnot Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::AddKnot Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::AddKnot Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Adds the knot value into the curve's knot sequence.

Visual Basic
Sub AddKnot(Value As double, Add As [in, defaultvalue(FALSE)] VARIANT_BOOL)
Parameters
Parameters | Description
Value | Double; input-only. Specifies the knot value to add.
Add | Boolean, the default value is False; input-only; optional. If the knot value already exists and the Add element is FALSE, the knot is not added; otherwise, the multiplicity of the knot is increased by one.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ContinuityAtKnot Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ContinuityAtKnot Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ContinuityAtKnot Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the degree of the highest derivative that is continuous at a knot. For example, if this NURB curve does not have its first derivative at the specified knot index, the value 0 is returned.

Visual Basic
Sub ContinuityAtKnot(Index As long, Tolerance As [in, optional] VARIANT, Continuity As [out, retval] long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the knot index to perform the calculation.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Long.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the control point at the specified index.

Visual Basic
Sub ControlPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index at which to get the control point.
Remarks

This property is a GePoint object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the control point at the specified index.

Visual Basic
Sub ControlPointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index at which to get the control point.
Remarks

This property is a GePoint object.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ElevateDegree Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ElevateDegree Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ElevateDegree Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Elevates the degree of the NURB curve by the specified amount.

Visual Basic
Sub ElevateDegree(Value As long)
Parameters
Parameters | Description
Value | Long; input-only. Specifies the amount in which to elevate the degree the NURB curve. It can only be a positive value.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.

Visual Basic
Sub FitPointAt(Index As long, Point As IGePoint)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point.
Remarks
  • This property is a GePoint object.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.

Visual Basic
Sub FitPointAt(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point.
Remarks
  • This property is a GePoint object.
  • This property is a only available if this NURB curve has fit data, HasFitData .
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::GetDefinitionData Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::GetDefinitionData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::GetDefinitionData Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets all the data that defines this NURB curve.

Visual Basic
Sub GetDefinitionData(ByRef Degree As long, ByRef Rational As VARIANT_BOOL, ByRef Periodic As VARIANT_BOOL, ByRef Knots As IGeKnotVector*, ByRef Points As IGePoints*, ByRef Weights As VARIANT)
Parameters
Parameters | Description
Degree | Long; output-only. Returns the degree of the NURB curve.
Rational | Boolean; output-only. Returns whether this NURB curve is rational, TRUE, or not, FALSE.
Periodic | Boolean; output-only. Returns whether this NURB curve is periodic, TRUE, or not, FALSE.
Knots | GeKnotVector object; output-only. Returns the knot vector of the NURB curve.
Points | gePoints collection; output-only. Returns the controlling points of the NURB curve.
Weights | Variant (array of Doubles); output-only. Returns the weights of the NURB curve. If the NURB curve is not rational, the array of weights will be empty.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::GetFitData Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::GetFitData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::GetFitData Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Gets the fit data used by the fit curve.

Visual Basic
Sub GetFitData(ByRef Points As IGePoints*, ByRef Tolerance As IGeTolerance*, ByRef HasTangents As VARIANT_BOOL, ByRef StartTangent As IGeVector*, ByRef EndTangent As IGeVector*)
Parameters
Parameters | Description
Points | gePoints collection; output-only. Returns the fit points of the NURB curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
HasTangents | Boolean; output-only. Returns whether the tangents exist, TRUE, or not, FALSE.
StartTangent | GeVector object; output-only. Returns the start tangent if it exists; otherwise, this element will not be set.
EndTangent | GeVector object; output-only. Returns the end tangent if it exists; otherwise, this element will not be set.
Returns

None

Remarks

These fit data are only available if the NURB curve has fit data, HasFitData .

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::JoinWith Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::JoinWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::JoinWith Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Recomputes this NURB curve by joining the specified NURB curve to the end of this NURB curve.

Visual Basic
Sub JoinWith(Curve As IGeNurbCurve)
Parameters
Parameters | Description
Curve | GeNurbCurve object; input-only. Specifies the NURB curve to join with this NURB curve,
Returns

None

Remarks

Neither NURB curve may be closed and the start point of the specified NURB curve must be equal to the end point of this NURB curve.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::KnotAt Method ([in] long, [in] double)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::KnotAt Method ([in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::KnotAt Method ([in] long, [in] double)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the knot value at the specified index.

Visual Basic
Sub KnotAt(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to get the value.
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the knot value at the specified index.

Visual Basic
Sub KnotAt(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the knot to get the value.
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::MakeClosed Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::MakeClosed Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::MakeClosed Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this NURB curve to form a smooth closed curve.
  • If the Option element is FALSE and if the curve is closed, it is made open by removing the span between the last and next-to-last knots.
Visual Basic
Sub MakeClosed(Option As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Option | Boolean, the default value is TRUE; input-only; optional.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::MakePeriodic Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::MakePeriodic Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::MakePeriodic Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this curve to form a smooth closed curve, and then is made into a periodic curve.
  • If the Option element is FALSE and if the curve is periodic, it is made non-periodic by assigning full knot multiplicity at the first and last knots.
Visual Basic
Sub MakePeriodic(Option As [in, defaultvalue(TRUE)] VARIANT_BOOL)
Parameters
Parameters | Description
Option | Boolean, the default value is TRUE; input-only; optional.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::MakeRational Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::MakeRational Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::MakeRational Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Sets this NURB curve as rational and sets the weight of each control point to the specified weight.

Visual Basic
Sub MakeRational(Weight As [in, defaultvalue(1.0)] double)
Parameters
Parameters | Description
Weight | Double, the default value is 1.0; input-only; optional. Specifies the weight for each control point on the rational NURB curve.
Returns

None

Remarks

If the curve is already rational, the weight at each control point is set to the specified weight.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ParametersOfC1 Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ParametersOfC1 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ParametersOfC1 Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Checks whether there are any C1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.

Visual Basic
Sub ParametersOfC1(ByRef Parameters As VARIANT, Tolerance As [in, optional] VARIANT, Exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::ParametersOfG1 Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::ParametersOfG1 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::ParametersOfG1 Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Checks whether there are any G1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.

Visual Basic
Sub ParametersOfG1(ByRef Parameters As VARIANT, Tolerance As [in, optional] VARIANT, Exist As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::PurgeFitData Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::PurgeFitData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::PurgeFitData Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Removes all fit data from the NURB curve.

Visual Basic
Sub PurgeFitData()
Returns

None

Remarks

The curve geometric definition is not changed, for instance, control points, knots, and weights remain the same.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::RemoveFitPointAt Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::RemoveFitPointAt Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::RemoveFitPointAt Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Removes the fit point at the specified index.

Visual Basic
Sub RemoveFitPointAt(Index As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the fit point to remove.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::SetDefinitionData Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::SetDefinitionData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::SetDefinitionData Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Sets the definition data of the NURB curve from the specified parameters.

Visual Basic
Sub SetDefinitionData(Degree As long, Knots As IGeKnotVector, Points As IGePoints, Periodic As VARIANT_BOOL, Weights As [in, optional] VARIANT)
Parameters
Parameters | Description
Degree | Long; input-only. Specifies the degree for the NURB curve.
Knots | GeKnotVector object; input-only. Specifies the knot vector for the NURB curve.
Points | gePoints collection; input-only. Specifies the control points for the NURB curve.
Periodic | Boolean; input-only. Specifies whether the NURB curve is periodic, TRUE, or not, FALSE.
Weights | Variant (array of Doubles); input-only; optional. Specifies the weights for the NURB curve; if not specified, the NURB curve is set as non-rational.
Returns

None

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::SetFitData Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::SetFitData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::SetFitData Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Recomputes this NURB curve from the specified knot vector, fit points, start and end tangents, and fit tolerance.

Visual Basic
Sub SetFitData(Points As IGePoints, StartTangent As [in, optional] VARIANT, EndTangent As [in, optional] VARIANT, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Points | gePoints collection; input-only. Specifies the control points to recompute this NURB curve.
StartTangent | Variant ( GeVector object); input-only; optional. Specifies the start tangent for this NURB curve.
EndTangent | Variant ( GeVector object); input-only; optional. Specifies the end tangent for this NURB curve.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks
  • If the fit tolerance equal point is not 0, then the constructed spline may not pass through the fit points but the maximum distance from any fit point to the constructed spline will be no greater than tolerance equal point.
  • If either of the fit tangents are specified, the other fit tangent must be specified as well.
Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::TrimByParameters Method

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::TrimByParameters Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::TrimByParameters Method
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Trims this NURB curve to the new start and end parameters.

Visual Basic
Sub TrimByParameters(Start As double, End As double)
Parameters
Parameters | Description
Start | Double; input-only. Specifies the start parameter from which to trim this NURB curve.
End | Double; input-only. Specifies the start parameter to which to trim this NURB curve.
Returns

None

Remarks

This is done by adding and removing control points and knots, but is not done by just resetting the interval on which this NURB curve is defined.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::WeightAt Method ([in] long, [in] double)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::WeightAt Method ([in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::WeightAt Method ([in] long, [in] double)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the weight value for the control point at the specified index.

Visual Basic
Sub WeightAt(Index As long, Weight As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the control point for which to calculate the weight value.
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)
IGeNurbCurve Interface IGeNurbCurve Members IGeNurbCurve Interface Send Feedback
Summary

Specifies the weight value for the control point at the specified index.

Visual Basic
Sub WeightAt(Index As long, Weight As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index of the control point for which to calculate the weight value.
Remarks

This property is a Double.

Interface

IGeNurbCurve Interface

Links
IGeNurbCurve Interface, IGeNurbCurve Members, IGeNurbCurve Interface


IGeNurbSurface Interface

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface Interface
IGeNurbSurface Members GEAuto Library Class Hierarchy Send Feedback
Summary

A Non-Uniform Rational B-spline, or NURB surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeNurbSurface
Visual Basic
Public Interface IGeNurbSurface
Inherits IGeSurface
Library

GEAuto Library

Links
IGeNurbSurface Members, GEAuto Library, Class Hierarchy


IGeNurbSurface Members

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface Members
IGeNurbSurface Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeNurbSurface.

Interface

IGeNurbSurface Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetDefinitionData | Gets the definition data from this NURB surface.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsPeriodicInU | Gets whether this NURB surface is periodic in the U parameter direction, and obtains the period, TRUE, or not, FALSE.
IsPeriodicInV | Gets whether this NURB surface is periodic in the V parameter direction, and obtains the period, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SetDefinitionData | Sets the definition data for this NURB surface.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPoints | Gets all control points on this NURB surface
DegreeInU | Gets the degree of this NURB surface in the U parameter direction.
DegreeInV | Gets the degree of this NURB surface in the V parameter direction.
IsClosedInU | Gets whether this NURB surface is closed in the U parameter direction, TRUE, or not, FALSE.
IsClosedInV | Gets whether this NURB surface is closed in the V parameter direction, TRUE, or not, FALSE.
IsRationalInU | Gets whether this NURB surface is rational in the U parameter direction, TRUE, or not, FALSE.
IsRationalInV | Gets whether this NURB surface is rational in the V parameter direction, TRUE, or not, FALSE.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
SingularityInU | Gets the characterization of any singularity in the U parameter direction.
SingularityInV | Gets the characterization of any singularity in the V parameter direction.
UControlPointCount | Gets the number of control points in the U parameter direction.
UKnotCount | Gets the number of knots in the U parameter direction.
UKnots | Gets the U knot vector on this NURB surface in the U parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VControlPointCount | Gets the number of control points in the V parameter direction.
VKnotCount | Gets the number of knots in the V parameter direction.
VKnots | Gets the U knot vector on this NURB surface in the V parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Weights | Gets the weights of all control points on this NURB surface.
Links
IGeNurbSurface Interface, Legend, Methods, Properties


IGeNurbSurface::ControlPoints Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::ControlPoints Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::ControlPoints Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets all control points on this NURB surface

Visual Basic
Property ControlPoints() As IGePoints**
Remarks

This property is a gePoints collection.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::DegreeInU Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::DegreeInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::DegreeInU Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the degree of this NURB surface in the U parameter direction.

Visual Basic
Property DegreeInU() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::DegreeInV Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::DegreeInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::DegreeInV Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the degree of this NURB surface in the V parameter direction.

Visual Basic
Property DegreeInV() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsClosedInU Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsClosedInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsClosedInU Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is closed in the U parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsClosedInU() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsClosedInV Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsClosedInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsClosedInV Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is closed in the V parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsClosedInV() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsRationalInU Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsRationalInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsRationalInU Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is rational in the U parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsRationalInU() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsRationalInV Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsRationalInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsRationalInV Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is rational in the V parameter direction, TRUE, or not, FALSE.

Visual Basic
Property IsRationalInV() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::SingularityInU Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::SingularityInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::SingularityInU Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the characterization of any singularity in the U parameter direction.

Visual Basic
Property SingularityInU() As long*
Remarks
  • This property is a Long.
  • Singularity types include: geNoPoles, gePoleAtMin, gePoleAtMax, and gePoleAtBoth.
Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::SingularityInV Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::SingularityInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::SingularityInV Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the characterization of any singularity in the V parameter direction.

Visual Basic
Property SingularityInV() As long*
Remarks
  • This property is a Long.
  • Singularity types include: geNoPoles, gePoleAtMin, gePoleAtMax, and gePoleAtBoth.
Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::UControlPointCount Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::UControlPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::UControlPointCount Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the number of control points in the U parameter direction.

Visual Basic
Property UControlPointCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::UKnotCount Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::UKnotCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::UKnotCount Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the number of knots in the U parameter direction.

Visual Basic
Property UKnotCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::UKnots Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::UKnots Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::UKnots Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the U knot vector on this NURB surface in the U parameter direction.

Visual Basic
Property UKnots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::VControlPointCount Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::VControlPointCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::VControlPointCount Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the number of control points in the V parameter direction.

Visual Basic
Property VControlPointCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::VKnotCount Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::VKnotCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::VKnotCount Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the number of knots in the V parameter direction.

Visual Basic
Property VKnotCount() As long*
Remarks

This property is a Long.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::VKnots Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::VKnots Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::VKnots Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the U knot vector on this NURB surface in the V parameter direction.

Visual Basic
Property VKnots() As IGeKnotVector**
Remarks

This property is a GeKnotVector object.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::Weights Property

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::Weights Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::Weights Property
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the weights of all control points on this NURB surface.

Visual Basic
Property Weights() As VARIANT*
Remarks

This property is a Variant (array of Doubles).

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::GetDefinitionData Method

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::GetDefinitionData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::GetDefinitionData Method
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets the definition data from this NURB surface.

Visual Basic
Sub GetDefinitionData(ByRef DegreeU As long, ByRef DegreeV As long, ByRef PropertiesU As long, ByRef PropertiesV As long, ByRef PointsInU As long, ByRef PointsInV As long, ByRef Points As IGePoints*, ByRef Weights As VARIANT, ByRef KnotsU As IGeKnotVector*, ByRef KnotsV As IGeKnotVector*)
Parameters
Parameters | Description
DegreeU | Long; output-only. Returns the degree of this NURB surface in the U parameter direction.
DegreeV | Long; output-only. Returns the degree of this NURB surface in the V parameter direction.
PropertiesU | Long; output-only. Returns the U direction properties of this NURB surface.
PropertiesV | Long; output-only. Returns the V direction properties of this NURB surface.
PointsInU | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
PointsInV | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
Points | gePoints collection; output-only. Returns all control points on this NURB surface.
Weights | Variant (array of Doubles); output-only. Returns the weights of all control points on this NURB surface.
KnotsU | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the U parameter direction.
KnotsV | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the V parameter direction.
Returns

None

Remarks
  • The control points contains first the U and then the V control points as indicated by the number of control points in U and in V.
  • The weights are similarly partitioned and correspond one to one with the control points.
Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsPeriodicInU Method

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsPeriodicInU Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsPeriodicInU Method
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is periodic in the U parameter direction, and obtains the period, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodicInU(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); output-only; optional. Returns the period of this NURB surface in the U parameter direction. The period will only be set if this NURB surface is periodic in the U parameter direction.
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::IsPeriodicInV Method

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::IsPeriodicInV Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::IsPeriodicInV Method
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Gets whether this NURB surface is periodic in the V parameter direction, and obtains the period, TRUE, or not, FALSE.

Visual Basic
Sub IsPeriodicInV(Period As [in, out, optional] VARIANT, Periodic As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Period | Variant (Double); output-only; optional. Returns the period of this NURB surface in the V parameter direction. The period will only be set if this NURB surface is periodic in the V parameter direction.
Remarks

This property is a Boolean.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeNurbSurface::SetDefinitionData Method

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface::SetDefinitionData Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface::SetDefinitionData Method
IGeNurbSurface Interface IGeNurbSurface Members IGeNurbSurface Interface Send Feedback
Summary

Sets the definition data for this NURB surface.

Visual Basic
Sub SetDefinitionData(DegreeU As long, DegreeV As long, PropertiesU As long, PropertiesV As long, PointsInU As long, PointsInV As long, Points As IGePoints, Weights As VARIANT, KnotsU As IGeKnotVector, KnotsV As IGeKnotVector, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
DegreeU | Long; input-only. Specifies the degree of this NURB surface in the U parameter direction.
DegreeV | Long; output-only. Returns the degree of this NURB surface in the V parameter direction.
PropertiesU | Long; output-only. Returns the U direction properties of this NURB surface.
PropertiesV | Long; output-only. Returns the V direction properties of this NURB surface.
PointsInU | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
PointsInV | Long; output-only. Returns the number of control points on this NURB surface in the U parameter direction.
Points | gePoints collection; output-only. Returns all control points on this NURB surface.
Weights | Variant (array of Doubles); output-only. Returns the weights of all control points on this NURB surface.
KnotsU | GeKnotVector object; output-only. Returns the knot vector of this NURB surface in the U parameter direction.
KnotsV | GeKnotVector object; input-only. Specifies the knot vector of this NURB surface in the V parameter direction.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Remarks

The length of the control points collection and the weights array should be equal to the sum of the specified number of control points in the U parameter direction and the specified number of control points in the V parameter direction.

Interface

IGeNurbSurface Interface

Links
IGeNurbSurface Interface, IGeNurbSurface Members, IGeNurbSurface Interface


IGeOffsetCurve Interface

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve Interface
IGeOffsetCurve Members GEAuto Library Class Hierarchy Send Feedback
Summary

An exact offset of another curve.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeOffsetCurve
Visual Basic
Public Interface IGeOffsetCurve
Inherits IGeCurve
Library

GEAuto Library

Links
IGeOffsetCurve Members, GEAuto Library, Class Hierarchy


IGeOffsetCurve Members

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve Members
IGeOffsetCurve Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeOffsetCurve.

Interface

IGeOffsetCurve Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseCurve | Specifies the base curve that this curve is an offset of.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this offset curve.
OffsetDistance | Specifies the offset distance of this offset curve.
ParameterDirection | Gets whether the parameter direction of this offset curve is the same as the base curve , TRUE, or not, FALSE.
Transformation | Returns the transformation matrix that was applied to the offset curve by calling TransformBy .
Links
IGeOffsetCurve Interface, Legend, Methods, Properties


IGeOffsetCurve::BaseCurve Property

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve::BaseCurve Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve::BaseCurve Property
IGeOffsetCurve Interface IGeOffsetCurve Members IGeOffsetCurve Interface Send Feedback
Summary

Specifies the base curve that this curve is an offset of.

Visual Basic
Property BaseCurve() As IGeCurve*
Remarks

This property is a GeCurve object.

Interface

IGeOffsetCurve Interface

Links
IGeOffsetCurve Interface, IGeOffsetCurve Members, IGeOffsetCurve Interface


IGeOffsetCurve::Normal Property

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve::Normal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve::Normal Property
IGeOffsetCurve Interface IGeOffsetCurve Members IGeOffsetCurve Interface Send Feedback
Summary

Specifies the normal vector of this offset curve.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGeOffsetCurve Interface

Links
IGeOffsetCurve Interface, IGeOffsetCurve Members, IGeOffsetCurve Interface


IGeOffsetCurve::OffsetDistance Property

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve::OffsetDistance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve::OffsetDistance Property
IGeOffsetCurve Interface IGeOffsetCurve Members IGeOffsetCurve Interface Send Feedback
Summary

Specifies the offset distance of this offset curve.

Visual Basic
Property OffsetDistance() As double
Remarks

This property is a Double.

Interface

IGeOffsetCurve Interface

Links
IGeOffsetCurve Interface, IGeOffsetCurve Members, IGeOffsetCurve Interface


IGeOffsetCurve::ParameterDirection Property

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve::ParameterDirection Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve::ParameterDirection Property
IGeOffsetCurve Interface IGeOffsetCurve Members IGeOffsetCurve Interface Send Feedback
Summary

Gets whether the parameter direction of this offset curve is the same as the base curve , TRUE, or not, FALSE.

Visual Basic
Property ParameterDirection() As VARIANT_BOOL*
Remarks

This property is a Boolean.

Interface

IGeOffsetCurve Interface

Links
IGeOffsetCurve Interface, IGeOffsetCurve Members, IGeOffsetCurve Interface


IGeOffsetCurve::Transformation Property

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve::Transformation Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve::Transformation Property
IGeOffsetCurve Interface IGeOffsetCurve Members IGeOffsetCurve Interface Send Feedback
Summary

Returns the transformation matrix that was applied to the offset curve by calling TransformBy .

Visual Basic
Property Transformation() As IGeMatrix**
Remarks
  • This property is a GeMatrix object.
  • If TransformBy has never been called for this offset curve, the matrix returned will be the identity matrix; if TransformBy has been called more than once, the matrix returned will be the concatenation of all of the transformation matrices.
Interface

IGeOffsetCurve Interface

Links
IGeOffsetCurve Interface, IGeOffsetCurve Members, IGeOffsetCurve Interface


IGeOffsetSurface Interface

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface Interface
IGeOffsetSurface Members GEAuto Library Class Hierarchy Send Feedback
Summary

An exact offset of another surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeOffsetSurface
Visual Basic
Public Interface IGeOffsetSurface
Inherits IGeSurface
Library

GEAuto Library

Links
IGeOffsetSurface Members, GEAuto Library, Class Hierarchy


IGeOffsetSurface Members

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface Members
IGeOffsetSurface Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeOffsetSurface.

Interface

IGeOffsetSurface Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
ConvertedSurface | Computes the simple surface equivalent to the offset surface.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Specifies the base surface of the offset surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
OffsetDistance | Specifies the offset distance of this surface.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeOffsetSurface Interface, Legend, Methods, Properties


IGeOffsetSurface::BaseSurface Property

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface::BaseSurface Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface::BaseSurface Property
IGeOffsetSurface Interface IGeOffsetSurface Members IGeOffsetSurface Interface Send Feedback
Summary

Specifies the base surface of the offset surface.

Visual Basic
Property BaseSurface() As IGeSurface*
Remarks

This property is a GeSurface object.

Interface

IGeOffsetSurface Interface

Links
IGeOffsetSurface Interface, IGeOffsetSurface Members, IGeOffsetSurface Interface


IGeOffsetSurface::OffsetDistance Property

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface::OffsetDistance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface::OffsetDistance Property
IGeOffsetSurface Interface IGeOffsetSurface Members IGeOffsetSurface Interface Send Feedback
Summary

Specifies the offset distance of this surface.

Visual Basic
Property OffsetDistance() As double
Remarks

This property is a Double.

Interface

IGeOffsetSurface Interface

Links
IGeOffsetSurface Interface, IGeOffsetSurface Members, IGeOffsetSurface Interface


IGeOffsetSurface::ConvertedSurface Method

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface::ConvertedSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface::ConvertedSurface Method
IGeOffsetSurface Interface IGeOffsetSurface Members IGeOffsetSurface Interface Send Feedback
Summary

Computes the simple surface equivalent to the offset surface.

Visual Basic
Sub ConvertedSurface(Surface As [out, retval] IGeSurface*)
Returns

GeSurface object

Interface

IGeOffsetSurface Interface

Links
IGeOffsetSurface Interface, IGeOffsetSurface Members, IGeOffsetSurface Interface


IGePlane Interface

You are here: API Reference > GEAuto Library > IGePlane Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane Interface
IGePlane Members GEAuto Library Class Hierarchy Send Feedback
Summary

An infinite plane in three-dimensional space.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGePlane
Visual Basic
Public Interface IGePlane
Inherits IGeSurface
Library

GEAuto Library

Links
IGePlane Members, GEAuto Library, Class Hierarchy


IGePlane Members

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane Members
IGePlane Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGePlane.

Interface

IGePlane Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
CoordinateSystem | Gets the coordinate system of this plane.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetCoefficients | Gets the coefficients of the equation of the plane, namely a*x + b*y + c*z + d, where a, b, c, and d are the coefficients of the normal to this plane.
IntersectWith | Computes the intersection between the plane and the specified linear entity or other plane.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsCoplanarWith | Determines whether this plane is coplanar to the specified plane, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsParallelTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this plane.
SignedDistanceTo | Computes the signed distance from the specified point to this plane.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Normal | Specifies the normal vector of this plane.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the origin of the plane.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGePlane Interface, Legend, Methods, Properties


IGePlane::Normal Property

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::Normal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::Normal Property
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Specifies the normal vector of this plane.

Visual Basic
Property Normal() As IGeVector*
Remarks

This property is a GeVector object.

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::Origin Property

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::Origin Property
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Gets the origin of the plane.

Visual Basic
Property Origin() As IGePoint*
Remarks

This property is a GePoint object.

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::CoordinateSystem Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::CoordinateSystem Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::CoordinateSystem Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Gets the coordinate system of this plane.

Visual Basic
Sub CoordinateSystem(ByRef Origin As IGePoint*, ByRef Axis1 As IGeVector*, ByRef Axis2 As IGeVector*)
Parameters
Parameters | Description
Origin | GePoint object. Specifies the origin point of this plane.
Axis1 | GeVector object. Specifies the U axis direction of this plane.
Axis2 | GeVector object. Specifies the V axis direction of this plane.
Returns

None

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::GetCoefficients Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::GetCoefficients Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::GetCoefficients Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Gets the coefficients of the equation of the plane, namely a*x + b*y + c*z + d, where a, b, c, and d are the coefficients of the normal to this plane.

Visual Basic
Sub GetCoefficients(ByRef A As double, ByRef B As double, ByRef C As double, ByRef D As double)
Parameters
Parameters | Description
A | Double; output-only.
B | Double; output-only.
C | Double; output-only.
D | Double; output-only.
Returns

None

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::IntersectWith Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::IntersectWith Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Computes the intersection between the plane and the specified linear entity or other plane.

Visual Basic
Sub IntersectWith(Entity As IGeEntity, ByRef Result As IGeEntity*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the other geometry entity to perform the check. The entity can be a GeLinearEntity or GePlane object.
Returns

GeEntity object; output-only. Returns the intersection region between this plane and the specified geometry entity.

  • It can be any type of geometry entity, depending on the intersection result.
  • This element will only be set if this method returns TRUE.

Tolerance : Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.

Remarks

Boolean

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::IsCoplanarWith Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::IsCoplanarWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::IsCoplanarWith Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Determines whether this plane is coplanar to the specified plane, TRUE, or not, FALSE.

Visual Basic
Sub IsCoplanarWith(Plane As IGePlane, Tolerance As [in, optional] VARIANT, Coplanar As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Plane | Variant ( GePlane object); input-only. Specifies the other plan to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::IsParallelTo Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::IsParallelTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::IsParallelTo Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.

Visual Basic
Sub IsParallelTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity to check the equality with this plane.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::IsPerpendicularTo Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::IsPerpendicularTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::IsPerpendicularTo Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.

Visual Basic
Sub IsPerpendicularTo(Entity As IGeEntity, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Entity | GeEntity object; input-only. Specifies the entity to check the equality with this plane.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::Set Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::Set Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Sets the definition data of this plane.

Visual Basic
Sub Set(Argument1 As VARIANT, Argument2 As VARIANT, Argument3 As [in, optional] VARIANT, Argument4 As [in, optional] VARIANT)
Parameters
Parameters | Description
Argument1 | Variant ( GePoint object or Double); input-only. Specifies the origin of the plane or the first coefficient.
Argument2 | Variant ( GeVector or GePoint object, or Double); input-only. Specifies the normal of this plane, or a point or vector from the origin in the U parameter direction, or the second coefficient.
Argument3 | Variant ( GeVector or GePoint object, or Double); input-only. Specifies a point or vector from the origin in the V parameter direction, or the third coefficient.
Argument4 | Variant (Double); input-only; optional. Specifies the fourth coefficient.
Returns

None

Remarks

The plane can be specified in three different ways of setting parameters:

  • Origin point and normal vector.
  • Origin point, a point or vector in the U parameter direction, and a point or vector in the V parameter direction.
  • Four coefficients making up the plane, a, b, c, and d (ax + by + cz + d = 0).
Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePlane::SignedDistanceTo Method

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane::SignedDistanceTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane::SignedDistanceTo Method
IGePlane Interface IGePlane Members IGePlane Interface Send Feedback
Summary

Computes the signed distance from the specified point to this plane.

Visual Basic
Sub SignedDistanceTo(Point As IGePoint, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point from which to calculate the signed distance to this plane.
Returns

Double

Remarks

The sign of the result is the same as the sign of the dot product of the vector from the specified point to the origin of the plane and the normal to the plane ( Vector(Point, Origin).DotProduct(Normal) ).

Interface

IGePlane Interface

Links
IGePlane Interface, IGePlane Members, IGePlane Interface


IGePoint Interface

You are here: API Reference > GEAuto Library > IGePoint Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint Interface
IGePoint Members GEAuto Library Class Hierarchy Send Feedback
Summary

A three-dimensional point object.

Class Hierarchy

Declaration syntax

IGeEntity
    IGePoint
Visual Basic
Public Interface IGePoint
Inherits IGeEntity
Library

GEAuto Library

Links
IGePoint Members, GEAuto Library, Class Hierarchy


IGePoint Members

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint Members
IGePoint Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGePoint.

Interface

IGePoint Interface

Methods
Name | Description
AsVector | Creates a vector from the point values.
DistanceTo | Calculates the minimum distance between this point and the specified point.
Get | Gets the coordinate system data from this point.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Item | Specifies the item value of this point at the specified index.
Item | Specifies the item value of this point at the specified index.
Mirror | Mirrors this entity about the specified plane.
ProjectToPlane | Returns the 3D point which results from the projection of this point into the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this point by the specified coordinates.
Sum | Returns the point equal to this point offset by the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the coordinate data of this point as an array of Doubles.
X | Specifies the X coordinate data of this point.
Y | Specifies the Y coordinate data of this point.
Z | Specifies the Z coordinate data of this point.
Links
IGePoint Interface, Legend, Methods, Properties


IGePoint::AsArray Property

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::AsArray Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::AsArray Property
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the coordinate data of this point as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::X Property

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::X Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::X Property
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the X coordinate data of this point.

Visual Basic
Property X() As double
Remarks

This property is a Double.

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Y Property

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Y Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Y Property
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the Y coordinate data of this point.

Visual Basic
Property Y() As double
Remarks

This property is a Double.

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Z Property

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Z Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Z Property
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the Z coordinate data of this point.

Visual Basic
Property Z() As double
Remarks

This property is a Double.

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::AsVector Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::AsVector Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::AsVector Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Creates a vector from the point values.

Visual Basic
Sub AsVector(Vector As [out, retval] IGeVector*)
Remarks

GeVector object

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::DistanceTo Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::DistanceTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::DistanceTo Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Calculates the minimum distance between this point and the specified point.

Visual Basic
Sub DistanceTo(Point As IGePoint, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the other point to which to calculate the minimum distance.
Returns

Double

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Get Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Get Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Get Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Gets the coordinate system data from this point.

Visual Basic
Sub Get(ByRef X As double, ByRef Y As double, ByRef Z As double)
Parameters
Parameters | Description
X | Double; output-only. Returns the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the Y axis.
Z | Double; output-only. Returns the coordinate data of the Z axis.
Returns

None

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Item Method ([in] long, [in] double)

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Item Method ([in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Item Method ([in] long, [in] double)
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the item value of this point at the specified index.

Visual Basic
Sub Item(Index As long, Value As double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index to get the item value of this point.
Remarks

This property is a Double.

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Item Method ([in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Item Method ([in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Item Method ([in] long, [out, retval] double*)
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Specifies the item value of this point at the specified index.

Visual Basic
Sub Item(Index As long, Value As [out, retval] double)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index to get the item value of this point.
Remarks

This property is a Double.

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::ProjectToPlane Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::ProjectToPlane Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::ProjectToPlane Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Returns the 3D point which results from the projection of this point into the specified plane.

Visual Basic
Sub ProjectToPlane(Plane As IGePlane, Direction As [in, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Plane | GePlane object; input-only. Specifies the plane with respect onto which this point is projected.
Direction | Variant ( GeVector object); input-only; optional. Specifies the direction in which to project this point; if not specified, the projection is orthogonal to the plane.
Returns

GePoint object

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Set Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Set Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Sets the definition data of this point by the specified coordinates.

Visual Basic
Sub Set(X As double, Y As double, Z As double)
Parameters
Parameters | Description
X | Double; input-only. Specifies the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the X axis.
Z | Double; input-only. Specifies the coordinate data of the X axis.
Returns

None

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoint::Sum Method

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint::Sum Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint::Sum Method
IGePoint Interface IGePoint Members IGePoint Interface Send Feedback
Summary

Returns the point equal to this point offset by the specified vector.

Visual Basic
Sub Sum(Vector As IGeVector, Result As [out, retval] IGePoint*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the offset vector to perform the calculation.
Returns

GePoint object

Interface

IGePoint Interface

Links
IGePoint Interface, IGePoint Members, IGePoint Interface


IGePoints Interface

You are here: API Reference > GEAuto Library > IGePoints Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints Interface
IGePoints Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GePoint objects.

Class Hierarchy

Declaration syntax

IGePoints
Visual Basic
Public Interface IGePoints
Inherits IDispatch
Library

GEAuto Library

Links
IGePoints Members, GEAuto Library, Class Hierarchy


IGePoints Members

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints Members
IGePoints Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGePoints.

Interface

IGePoints Interface

Methods
Name | Description
Add | Appends a new point to the collection.
Item | Gets the point at the specified index.
Remove | Removes the specified point from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | For GePoint objects: Specifies the coordinates of the point as an array of Doubles. For GePoints Collection objects: Specifies the coordinates of the points in the collection as an array of Doubles. The array size must be a multiple of three. Setting the array values clears the current collection and creates new GePoint objects with the new values. For GeKnotVector objects: Specifies the knot values as an array of Doubles. For GeMatrix objects: Specifies the elements of the 4 x 4 matrix by row from top to bottom.
AsArray2d | Specifies the coordinates of the points in the collection as an array of Doubles, two for each point in the collection.
Count | Gets the total number of the points in a point collection.
Links
IGePoints Interface, Legend, Methods, Properties


IGePoints::Application Property

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::Application Property
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::AsArray Property

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::AsArray Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::AsArray Property
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

For GePoint objects: Specifies the coordinates of the point as an array of Doubles.

For GePoints Collection objects: Specifies the coordinates of the points in the collection as an array of Doubles. The array size must be a multiple of three. Setting the array values clears the current collection and creates new GePoint objects with the new values.

For GeKnotVector objects: Specifies the knot values as an array of Doubles.

For GeMatrix objects: Specifies the elements of the 4 x 4 matrix by row from top to bottom.

Visual Basic
Property AsArray() As VARIANT
Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::AsArray2d Property

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::AsArray2d Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::AsArray2d Property
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Specifies the coordinates of the points in the collection as an array of Doubles, two for each point in the collection.

Visual Basic
Property AsArray2d() As VARIANT
Remarks

The array size must be a multiple of two. Setting the array values clears the current collection and creates new GePoint objects with the new values.

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::Count Property

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::Count Property
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Gets the total number of the points in a point collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::Add Method

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::Add Method
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Appends a new point to the collection.

Visual Basic
Sub Add(Point As IGePoint)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the new point to add to the collection.
Returns

None

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::Item Method

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::Item Method
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Gets the point at the specified index.

Visual Basic
Sub Item(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the point to get from the collection.
Returns

GePoint object

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGePoints::Remove Method

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints::Remove Method
IGePoints Interface IGePoints Members IGePoints Interface Send Feedback
Summary

Removes the specified point from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the point to be removed.
Returns

None

Interface

IGePoints Interface

Links
IGePoints Interface, IGePoints Members, IGePoints Interface


IGeRay Interface

You are here: API Reference > GEAuto Library > IGeRay Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeRay Interface
IGeRay Members GEAuto Library Class Hierarchy Send Feedback
Summary

A line bounded at one end.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeRay
Visual Basic
Public Interface IGeRay
Inherits IGeLinearEntity
Library

GEAuto Library

Links
IGeRay Members, GEAuto Library, Class Hierarchy


IGeRay Members

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeRay Members
IGeRay Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeRay.

Interface

IGeRay Interface

Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the ray to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.
Links
IGeRay Interface, Legend, Methods, Properties


IGeRay::Set Method

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeRay::Set Method
IGeRay Interface IGeRay Members IGeRay Interface Send Feedback
Summary

Changes the definition of the ray to pass through the specified point in the direction of the specified vector.

Visual Basic
Sub Set(Point As IGePoint, PointVector As LPDISPATCH)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies a point this ray passes through.
PointVector | Object ( GeVector object); input-only. Specifies the vector this ray respects on the specified point.
Returns

None

Interface

IGeRay Interface

Links
IGeRay Interface, IGeRay Members, IGeRay Interface


IGeSphere Interface

You are here: API Reference > GEAuto Library > IGeSphere Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere Interface
IGeSphere Members GEAuto Library Class Hierarchy Send Feedback
Summary

A spherical surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeSphere
Visual Basic
Public Interface IGeSphere
Inherits IGeSurface
Library

GEAuto Library

Links
IGeSphere Members, GEAuto Library, Class Hierarchy


IGeSphere Members

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere Members
IGeSphere Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeSphere.

Interface

IGeSphere Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between this sphere and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this sphere is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this sphere by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
EndLatitude | Specifies the end angle in the latitudinal parameter direction.
EndLongitude | Specifies the end angle in the longitudinal parameter direction.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
NorthAxis | Gets the direction from the origin of the north pole.
NorthPole | Gets the north pole point of this sphere.
Origin | Gets the center of this sphere.
Radius | Specifies the radius of this sphere.
ReferenceAxis | Gets the direction of the zero meridian.
SouthPole | Gets the south pole point of this sphere.
StartLatitude | Specifies the start angle in the latitudinal parameter direction.
StartLongitude | Specifies the start angle in the longitudinal parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeSphere Interface, Legend, Methods, Properties


IGeSphere::EndLatitude Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::EndLatitude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::EndLatitude Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Specifies the end angle in the latitudinal parameter direction.

Visual Basic
Property EndLatitude() As double
Remarks

This property is a Double.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::EndLongitude Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::EndLongitude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::EndLongitude Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Specifies the end angle in the longitudinal parameter direction.

Visual Basic
Property EndLongitude() As double
Remarks

This property is a Double.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::NorthAxis Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::NorthAxis Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::NorthAxis Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets the direction from the origin of the north pole.

Visual Basic
Property NorthAxis() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::NorthPole Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::NorthPole Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::NorthPole Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets the north pole point of this sphere.

Visual Basic
Property NorthPole() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::Origin Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::Origin Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets the center of this sphere.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::Radius Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::Radius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::Radius Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Specifies the radius of this sphere.

Visual Basic
Property Radius() As double
Remarks

This property is a Double.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::ReferenceAxis Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::ReferenceAxis Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::ReferenceAxis Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets the direction of the zero meridian.

Visual Basic
Property ReferenceAxis() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::SouthPole Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::SouthPole Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::SouthPole Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets the south pole point of this sphere.

Visual Basic
Property SouthPole() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::StartLatitude Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::StartLatitude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::StartLatitude Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Specifies the start angle in the latitudinal parameter direction.

Visual Basic
Property StartLatitude() As double
Remarks

This property is a Double.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::StartLongitude Property

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::StartLongitude Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::StartLongitude Property
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Specifies the start angle in the longitudinal parameter direction.

Visual Basic
Property StartLongitude() As double
Remarks

This property is a Double.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::IntersectWith Method
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Computes the intersection between this sphere and the specified linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this sphere.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Remarks

If there is any intersection this method returns TRUE; otherwise, FALSE.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::IsClosedInU Method

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::IsClosedInU Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::IsClosedInU Method
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Gets whether this sphere is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInU(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSphere::Set Method

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere::Set Method
IGeSphere Interface IGeSphere Members IGeSphere Interface Send Feedback
Summary

Changes the definition of this sphere by the specified parameters.

Visual Basic
Sub Set(Radius As double, Center As IGePoint, NorthAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartLongitude As [in, optional] VARIANT, EndLongitude As [in, optional] VARIANT, StartLatitude As [in, optional] VARIANT, EndLatitude As [in, optional] VARIANT)
Parameters
Parameters | Description
Radius | Double; input-only. Specifies the radius of the sphere.
Center | GePoint object; input-only. Specifies the center point of the sphere.
NorthAxis | Variant ( GeVector object); input-only; optional. Specifies the north pole axis direction of the sphere.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies the reference vector from which longitudinal angles are measured.
StartLongitude | Variant (Double); input-only; optional. Specifies the start longitudinal angle.
EndLongitude | Variant (Double); input-only; optional. Specifies the end longitudinal angle.
StartLatitude | Variant (Double); input-only; optional. Specifies the start latitudinal angle.
EndLatitude | Variant (Double); input-only; optional. Specifies the end latitudinal angle.
Returns

None

Interface

IGeSphere Interface

Links
IGeSphere Interface, IGeSphere Members, IGeSphere Interface


IGeSurface Interface

You are here: API Reference > GEAuto Library > IGeSurface Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface Interface
IGeSurface Members GEAuto Library Class Hierarchy Send Feedback
Summary

A generic surface entity.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeBoundedSurface
        IGeCone
        IGeCylinder
        IGeNurbSurface
        IGeOffsetSurface
        IGePlane
        IGeSphere
        IGeTorus
Visual Basic
Public Interface IGeSurface
Inherits IGeEntity
Library

GEAuto Library

Links
IGeSurface Members, GEAuto Library, Class Hierarchy


IGeSurface Members

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface Members
IGeSurface Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeSurface.

Interface

IGeSurface Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeSurface Interface, Legend, Methods, Properties


IGeSurface::NormalFlipped Property

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::NormalFlipped Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::NormalFlipped Property
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Specifies whether the surface normal is flipped, TRUE, or not, FALSE.

Visual Basic
Property NormalFlipped() As VARIANT_BOOL
Remarks
  • This property is a Boolean.
  • The surface normal is computed as the normal of dU cross product dV. When NormalFlipped is set to TRUE, the surface normal is computed as the negative of the normal of dU cross product dV.
Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::UParameterEnvelope Property

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::UParameterEnvelope Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::UParameterEnvelope Property
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Gets the surface's parameter range in the U parameter direction.

Visual Basic
Property UParameterEnvelope() As IGeInterval**
Remarks

This property is a GeInterval object.

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::VParameterEnvelope Property

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::VParameterEnvelope Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::VParameterEnvelope Property
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Gets the surface's parameter range in the V parameter direction.

Visual Basic
Property VParameterEnvelope() As IGeInterval**
Remarks

This property is a GeInterval object.

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::ClosestPointTo Method

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::ClosestPointTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::ClosestPointTo Method
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Calculates the closest point on this surface to the specified point.

Visual Basic
Sub ClosestPointTo(Point As IGePoint, Parameter As [in, out, optional] VARIANT, Tolerance As [in, optional] VARIANT, ClosestPoint As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Parameter | Variant (Double); optional. Specifies the parameter of the closest point.
Tolerance | Variant (GeTolerance object); input-only; optional. Specifies the tolerance used in the calculation.
Returns

GePoint object

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::DistanceTo Method

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::DistanceTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::DistanceTo Method
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Calculates the minimum distance between the surface and the specified point.

Visual Basic
Sub DistanceTo(Point As IGePoint, Tolerance As [in, optional] VARIANT, Distance As [out, retval] double)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the closest point to.
Tolerance | Variant (GeTolerance object); input-only; optional. Specifies the tolerance used in the calculation.
Returns

Double

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::EvaluatePoint Method

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::EvaluatePoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::EvaluatePoint Method
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Returns the point on the surface corresponding to the specified parameter value.

Visual Basic
Sub EvaluatePoint(ParameterPoint As IGePoint, DerivativeOrder As [in, optional] VARIANT, Derivatives As [in, out, optional] VARIANT, Normal As [in, out, optional] VARIANT, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
ParameterPoint | GePoint object; input-only. Specifies the point to calculate the closest point to.
DerivativeOrder | Variant (Integer); input-only; optional. Specifies the requested derivative order with limit to a value of 2.
Derivatives | Variant ( GeVectors Collection); optional. Specifies the derivative arrays up to the order specified by the derivative order. Derivatives are returned as (order 1) dU or (order 2) dU, dUdU.
Normal | Variant ( GeVector object); optional. Specifies the normal vector at the evaluated point.
Returns

GePoint object

Remarks

If either the optional Derivatives or Normal element is specified, the DerivativeOrder element must be specified.

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::IntersectWithSurface Method

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::IntersectWithSurface Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::IntersectWithSurface Method
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Calculates the intersection between this surface and the specified surface.

Visual Basic
Sub IntersectWithSurface(Surface As IGeSurface, Tolerance As [in, optional] VARIANT, Intersection As [out, retval] IGeSurfaceSurfaceIntersection*)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the surface to intersect with this surface.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GeSurfaceSurfaceIntersection object

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurface::ParameterOf Method

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface::ParameterOf Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface::ParameterOf Method
IGeSurface Interface IGeSurface Members IGeSurface Interface Send Feedback
Summary

Calculates the 2D parameter point on this surface, which corresponds to the specified point.

Visual Basic
Sub ParameterOf(Point As IGePoint, Tolerance As [in, optional] VARIANT, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Point | GePoint object; input-only. Specifies the point to calculate the parameter value. It should lie on the surface within the specified tolerance; otherwise, the results may be unpredictable.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

GePoint object

Interface

IGeSurface Interface

Links
IGeSurface Interface, IGeSurface Members, IGeSurface Interface


IGeSurfaces Interface

You are here: API Reference > GEAuto Library > IGeSurfaces Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces Interface
IGeSurfaces Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeSurface objects.

Class Hierarchy

Declaration syntax

IGeSurfaces
Visual Basic
Public Interface IGeSurfaces
Inherits IDispatch
Library

GEAuto Library

Links
IGeSurfaces Members, GEAuto Library, Class Hierarchy


IGeSurfaces Members

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces Members
IGeSurfaces Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeSurfaces.

Interface

IGeSurfaces Interface

Methods
Name | Description
Add | Appends a new surface to the collection.
Item | Gets the surface at the specified index.
Remove | Removes the specified surface from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the surfaces in a surface collection.
Links
IGeSurfaces Interface, Legend, Methods, Properties


IGeSurfaces::Application Property

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces::Application Property
IGeSurfaces Interface IGeSurfaces Members IGeSurfaces Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeSurfaces Interface

Links
IGeSurfaces Interface, IGeSurfaces Members, IGeSurfaces Interface


IGeSurfaces::Count Property

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces::Count Property
IGeSurfaces Interface IGeSurfaces Members IGeSurfaces Interface Send Feedback
Summary

Gets the total number of the surfaces in a surface collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGeSurfaces Interface

Links
IGeSurfaces Interface, IGeSurfaces Members, IGeSurfaces Interface


IGeSurfaces::Add Method

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces::Add Method
IGeSurfaces Interface IGeSurfaces Members IGeSurfaces Interface Send Feedback
Summary

Appends a new surface to the collection.

Visual Basic
Sub Add(Surface As IGeSurface)
Parameters
Parameters | Description
Surface | GeSurface object; input-only. Specifies the new surface to add to the collection.
Returns

None

Interface

IGeSurfaces Interface

Links
IGeSurfaces Interface, IGeSurfaces Members, IGeSurfaces Interface


IGeSurfaces::Item Method

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces::Item Method
IGeSurfaces Interface IGeSurfaces Members IGeSurfaces Interface Send Feedback
Summary

Gets the surface at the specified index.

Visual Basic
Sub Item(Index As long, Surface As [out, retval] IGeSurface*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the surface to get from the collection.
Returns

GeSurface object

Interface

IGeSurfaces Interface

Links
IGeSurfaces Interface, IGeSurfaces Members, IGeSurfaces Interface


IGeSurfaces::Remove Method

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces::Remove Method
IGeSurfaces Interface IGeSurfaces Members IGeSurfaces Interface Send Feedback
Summary

Removes the specified surface from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the surface to be removed.
Returns

None

Interface

IGeSurfaces Interface

Links
IGeSurfaces Interface, IGeSurfaces Members, IGeSurfaces Interface


IGeSurfaceSurfaceIntersection Interface

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection Interface
IGeSurfaceSurfaceIntersection Members GEAuto Library Class Hierarchy Send Feedback
Summary

Calculates the intersection between two surfaces.

Class Hierarchy

Declaration syntax

IGeSurfaceSurfaceIntersection
Visual Basic
Public Interface IGeSurfaceSurfaceIntersection
Inherits IDispatch
Library

GEAuto Library

Links
IGeSurfaceSurfaceIntersection Members, GEAuto Library, Class Hierarchy


IGeSurfaceSurfaceIntersection Members

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection Members
IGeSurfaceSurfaceIntersection Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeSurfaceSurfaceIntersection.

Interface

IGeSurfaceSurfaceIntersection Interface

Methods
Name | Description
GetIntersectionCofiguration | Gets the characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
IntersectionCurve | Gets the intersection curve at the specified intersection index.
IntersectionDimension | Gets the dimension of the intersection at the specified intersection index.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterCurveOnSurface1 | Gets the parametric curve on the first surface at the specified intersection index.
ParameterCurveOnSurface2 | Gets the parametric curve on the second surface at the specified intersection index.
ParameterOnSurface1 | Gets the surface parameter values on the first surface at the specified intersection index.
ParameterOnSurface2 | Gets the surface parameter values on the second surface at the specified intersection point. This property will fail if the intersection dimension at the specified intersection index is not 0.
Set | Sets the two surfaces being intersected and optionally the tolerance used in the calculation.
Properties
Name | Description
IntersectionCount | Gets the number of intersections calculated.
Surface1 | Specifies the first surface for this intersection.
Surface2 | Specifies the second surface for this intersection.
Tolerance | Specifies the tolerance used in the intersection calculation.
Links
IGeSurfaceSurfaceIntersection Interface, Legend, Methods, Properties


IGeSurfaceSurfaceIntersection::IntersectionCount Property

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::IntersectionCount Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::IntersectionCount Property
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the number of intersections calculated.

Visual Basic
Property IntersectionCount() As long*
Remarks

This property is a Long.

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::Surface1 Property

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::Surface1 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::Surface1 Property
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Specifies the first surface for this intersection.

Visual Basic
Property Surface1() As IGeSurface*
Remarks

This property is a GeSurface object.

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::Surface2 Property

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::Surface2 Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::Surface2 Property
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Specifies the second surface for this intersection.

Visual Basic
Property Surface2() As IGeSurface*
Remarks

This property is a GeSurface object.

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::Tolerance Property

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::Tolerance Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::Tolerance Property
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Specifies the tolerance used in the intersection calculation.

Visual Basic
Property Tolerance() As IGeTolerance*
Remarks

This property is a GeTolerance object.

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.

Visual Basic
Sub GetIntersectionCofiguration(Index As long, ByRef Surf1Left As GeSurfSurfIntConfiguration, ByRef Surf1Right As GeSurfSurfIntConfiguration, ByRef Surf2Left As GeSurfSurfIntConfiguration, ByRef Surf2Right As GeSurfSurfIntConfiguration, ByRef Type As GeSurfSurfIntType, ByRef Dimension As long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the second surface that intersects with this surface.
Surf1Left | GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection characterization of the intersection curve on this surface that is left to its surface normal orientation and the direction of the curve parameterization.
Surf1Right | GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection type of the intersection curve on this surface that is right to its surface normal orientation and the direction of the curve parameterization.
Surf2Left | GeSurfSurfIntConfiguration enumeration; output-only. GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection type of the intersection curve on the specified surface that is left to its surface normal orientation and the direction of the curve parameterization.
Surf2Right | GeSurfSurfIntConfiguration enumeration; output-only. GeSurfSurfIntConfiguration enumeration; output-only. Returns the intersection characterization of the intersection curve on the specified surface that is right to its surface normal orientation and the direction of the curve parameterization.
Type | GeSurfSurfIntType enumeration; output-only. Returns the intersection type of the specified intersection between this surface and the specified surface.
Dimension | Description to come
Returns

None

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::IntersectionCurve Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::IntersectionCurve Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::IntersectionCurve Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the intersection curve at the specified intersection index.

Visual Basic
Sub IntersectionCurve(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension property, IntersectionDimension , at the specified index is not 1.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::IntersectionDimension Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::IntersectionDimension Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::IntersectionDimension Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the dimension of the intersection at the specified intersection index.

Visual Basic
Sub IntersectionDimension(Index As long, Dimension As [out, retval] long)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a Long.
  • A dimension of zero indicates the surface-surface intersection is a point; a dimension of 1 indicates the surfaces intersection is a curve.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::IntersectionPoint Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::IntersectionPoint Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::IntersectionPoint Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the intersection point at the specified intersection index.

Visual Basic
Sub IntersectionPoint(Index As long, Point As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GePoint object.
  • This property will fail if the intersection dimension property, IntersectionDimension , at the specified intersection index is not 0.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the parametric curve on the first surface at the specified intersection index.

Visual Basic
Sub ParameterCurveOnSurface1(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension at the specified index is not 1.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the parametric curve on the second surface at the specified intersection index.

Visual Basic
Sub ParameterCurveOnSurface2(Index As long, Curve As [out, retval] IGeCurve*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks
  • This property is a GeCurve object.
  • This property will fail if the intersection dimension at the specified index is not 1.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the surface parameter values on the first surface at the specified intersection index.

Visual Basic
Sub ParameterOnSurface1(Index As long, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a GePoint object.
  • This property will fail if the intersection dimension at the specified intersection index is not 0.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Gets the surface parameter values on the second surface at the specified intersection point. This property will fail if the intersection dimension at the specified intersection index is not 0.

Visual Basic
Sub ParameterOnSurface2(Index As long, Parameter As [out, retval] IGePoint*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for an intersection to perform the calculation.
Remarks

  • This property is a GePoint object.
  • This property will fail if the intersection dimension at the specified intersection index is not 0.
Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeSurfaceSurfaceIntersection::Set Method

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection::Set Method
IGeSurfaceSurfaceIntersection Interface IGeSurfaceSurfaceIntersection Members IGeSurfaceSurfaceIntersection Interface Send Feedback
Summary

Sets the two surfaces being intersected and optionally the tolerance used in the calculation.

Visual Basic
Sub Set(Surface1 As IGeSurface, Surface2 As IGeSurface, Tolerance As [in, optional] VARIANT)
Parameters
Parameters | Description
Surface1 | GeSurface object; input-only. Specifies the first surface being intersected. This element can be later obtained by the GeSurfaceSurfaceIntersection > Surface1 property.
Surface2 | GeSurface object; input-only. Specifies the second surface being intersected. This element can be later obtained by the GeSurfaceSurfaceIntersection > Surface2 property.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

None

Interface

IGeSurfaceSurfaceIntersection Interface

Links
IGeSurfaceSurfaceIntersection Interface, IGeSurfaceSurfaceIntersection Members, IGeSurfaceSurfaceIntersection Interface


IGeTolerance Interface

You are here: API Reference > GEAuto Library > IGeTolerance Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance Interface
IGeTolerance Members GEAuto Library Class Hierarchy Send Feedback
Summary

Encapsulates tolerance values to use in calculations.

Class Hierarchy

Declaration syntax

IGeTolerance
Visual Basic
Public Interface IGeTolerance
Inherits IDispatch
Library

GEAuto Library

Links
IGeTolerance Members, GEAuto Library, Class Hierarchy


IGeTolerance Members

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance Members
IGeTolerance Interface Legend Properties Send Feedback
Summary

The following tables list the members exposed by IGeTolerance.

Interface

IGeTolerance Interface

Properties
Name | Description
Application | Gets the GeApplication object.
EqualPoint | Specifies the distance between two points at which they are considered equal.
EqualVector | Specifies the tolerance to determine whether two vectors are considered equal, parallel, or perpendicular.
Links
IGeTolerance Interface, Legend, Properties


IGeTolerance::Application Property

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance::Application Property
IGeTolerance Interface IGeTolerance Members IGeTolerance Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeTolerance Interface

Links
IGeTolerance Interface, IGeTolerance Members, IGeTolerance Interface


IGeTolerance::EqualPoint Property

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance::EqualPoint Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance::EqualPoint Property
IGeTolerance Interface IGeTolerance Members IGeTolerance Interface Send Feedback
Summary

Specifies the distance between two points at which they are considered equal.

Visual Basic
Property EqualPoint() As double
Remarks

This property is a Double.

Interface

IGeTolerance Interface

Links
IGeTolerance Interface, IGeTolerance Members, IGeTolerance Interface


IGeTolerance::EqualVector Property

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance::EqualVector Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance::EqualVector Property
IGeTolerance Interface IGeTolerance Members IGeTolerance Interface Send Feedback
Summary

Specifies the tolerance to determine whether two vectors are considered equal, parallel, or perpendicular.

Visual Basic
Property EqualVector() As double
Remarks

This property is a Double.

Interface

IGeTolerance Interface

Links
IGeTolerance Interface, IGeTolerance Members, IGeTolerance Interface


IGeTorus Interface

You are here: API Reference > GEAuto Library > IGeTorus Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus Interface
IGeTorus Members GEAuto Library Class Hierarchy Send Feedback
Summary

A toroid or toroidal segment surface.

Class Hierarchy

Declaration syntax

IGeEntity
    IGeSurface
        IGeTorus
Visual Basic
Public Interface IGeTorus
Inherits IGeSurface
Library

GEAuto Library

Links
IGeTorus Members, GEAuto Library, Class Hierarchy


IGeTorus Members

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus Members
IGeTorus Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeTorus.

Interface

IGeTorus Interface

Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the torus and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this torus is closed in the U parameterization direction.
IsClosedInV | Gets whether this torus is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the torus with the specified center point and major and minor radii, and optionally with the axis of symmetry direction and start and ending angles in the U and V parameter directions.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Gets the axis of symmetry of the torus.
EndAngleInU | Specifies the end angle in the U parameter direction.
EndAngleInV | Specifies the end angle in the V parameter direction.
MajorRadius | Specifies the major radius of this torus.
MinorRadius | Specifies the minor radius of this torus.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of this torus.
ReferenceAxis | Gets the direction of the zero meridian.
StartAngleInU | Specifies the start angle in the U parameter direction.
StartAngleInV | Specifies the start angle in the V parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Links
IGeTorus Interface, Legend, Methods, Properties


IGeTorus::AxisOfSymmetry Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::AxisOfSymmetry Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::AxisOfSymmetry Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Gets the axis of symmetry of the torus.

Visual Basic
Property AxisOfSymmetry() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::EndAngleInU Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::EndAngleInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::EndAngleInU Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the end angle in the U parameter direction.

Visual Basic
Property EndAngleInU() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::EndAngleInV Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::EndAngleInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::EndAngleInV Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the end angle in the V parameter direction.

Visual Basic
Property EndAngleInV() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::MajorRadius Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::MajorRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::MajorRadius Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the major radius of this torus.

Visual Basic
Property MajorRadius() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::MinorRadius Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::MinorRadius Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::MinorRadius Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the minor radius of this torus.

Visual Basic
Property MinorRadius() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::Origin Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::Origin Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::Origin Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Gets the center of this torus.

Visual Basic
Property Origin() As IGePoint**
Remarks

This property is a GePoint object.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::ReferenceAxis Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::ReferenceAxis Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::ReferenceAxis Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Gets the direction of the zero meridian.

Visual Basic
Property ReferenceAxis() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::StartAngleInU Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::StartAngleInU Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::StartAngleInU Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the start angle in the U parameter direction.

Visual Basic
Property StartAngleInU() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::StartAngleInV Property

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::StartAngleInV Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::StartAngleInV Property
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Specifies the start angle in the V parameter direction.

Visual Basic
Property StartAngleInV() As double
Remarks

This property is a Double.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::IntersectWith Method

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::IntersectWith Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::IntersectWith Method
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Computes the intersection between the torus and the specified linear entity.

Visual Basic
Sub IntersectWith(Line As IGeLinearEntity, ByRef Intersections As long, ByRef Point1 As IGePoint*, ByRef Point2 As IGePoint*, ByRef Point3 As IGePoint*, ByRef Point4 As IGePoint*, Tolerance As [in, optional] VARIANT, Intersect As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Line | GeLinearEntity object; input-only. Specifies the line to intersect with this torus.
Intersections | Integer; output-only. Specifies the number of intersection found (0, 1, or 2). If this method returns TRUE, this element will be set to either 1 or 2; otherwise, it will be set to 0.
Point1 | GePoint object; output-only. Specifies the first intersection point. This element will only be set if the number of intersection is greater than 0.
Point2 | GePoint object; output-only. Specifies the second intersection point. This element will only be set if the number of intersections is greater than 1.
Point3 | Variant ( GePoint object); optional. Specifies the first intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 0.
Point4 | Variant ( GePoint object); optional. Specifies the second intersection point on the linear entity. This element will only be set if the Direction element is specified and the number of intersections is greater than 1.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::IsClosedInU Method

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::IsClosedInU Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::IsClosedInU Method
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Gets whether this torus is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInU(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::IsClosedInV Method

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::IsClosedInV Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::IsClosedInV Method
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Gets whether this torus is closed in the U parameterization direction.

Visual Basic
Sub IsClosedInV(Tolerance As [in, optional] VARIANT, Closed As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeTorus::Set Method

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus::Set Method
IGeTorus Interface IGeTorus Members IGeTorus Interface Send Feedback
Summary

Sets the torus with the specified center point and major and minor radii, and optionally with the axis of symmetry direction and start and ending angles in the U and V parameter directions.

Visual Basic
Sub Set(MajorRadius As double, MinorRadius As double, Center As IGePoint, SymmetryAxis As [in, optional] VARIANT, ReferenceAxis As [in, optional] VARIANT, StartUAngle As [in, optional] VARIANT, EndUAngle As [in, optional] VARIANT, StartVAngle As [in, optional] VARIANT, EndVAngle As [in, optional] VARIANT)
Parameters
Parameters | Description
MajorRadius | Double; input-only. Specifies the major radius of this torus.
MinorRadius | Double; input-only. Specifies the minor radius of this torus.
Center | GePoint object; input-only. Specifies the center point of this torus.
SymmetryAxis | Variant ( GeVector object); input-only; optional. Specifies the torus axis of symmetry direction.
ReferenceAxis | Variant ( GeVector object); input-only; optional. Specifies a reference vector from which U angles are measured.
StartUAngle | Variant (Double); input-only; optional. Specifies the start U parameter angle.
EndUAngle | Variant (Double); input-only; optional. Specifies the end U parameter angle.
StartVAngle | Variant (Double); input-only; optional. Specifies the start V parameter angle.
EndVAngle | Variant (Double); input-only; optional. Specifies the end V parameter angle.
Returns

None

Interface

IGeTorus Interface

Links
IGeTorus Interface, IGeTorus Members, IGeTorus Interface


IGeVector Interface

You are here: API Reference > GEAuto Library > IGeVector Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector Interface
IGeVector Members GEAuto Library Class Hierarchy Send Feedback
Summary

A vector in three-dimensional space.

Class Hierarchy

Declaration syntax

IGeVector
Visual Basic
Public Interface IGeVector
Inherits IDispatch
Library

GEAuto Library

Links
IGeVector Members, GEAuto Library, Class Hierarchy


IGeVector Members

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector Members
IGeVector Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeVector.

Interface

IGeVector Interface

Methods
Name | Description
AngleTo | Computes the angle between this vector and the specified vector.
CrossProduct | Computes the cross product of this vector and the specified vector.
DotProduct | Computes the dot product of this vector and the specified vector.
Get | Gets the coordinate data from this vector.
IsCodirectionalTo | Determines whether this vector is codirectional to the specified vector, TRUE, or not, FALSE.
IsEqualTo | Determines whether this vector is equal to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsParallelTo | Determines whether this vector is parallel with the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this vector is perpendicular to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsUnitLength | Gets whether this vector is of unit length, TRUE, or not, FALSE.
IsZeroLength | Gets whether this vector is zero length, TRUE, or not, FALSE.
Item | Specifies the item value at the specified index.
Item | Specifies the item value at the specified index.
Mirror | Mirrors this vector about the specified plane.
MultiplyBy | Computes the vector equal to this vector multiplied by the specified scale factor.
Negate | Sets this vector to be equal to its current opposite vector.
Normalize | Sets this vector to be equal to its normal vector.
PerpendicularVector | Calculates a vector orthogonal to this vector.
Product | Returns the vector equal to the product of the specified matrix and this vector.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
RotateBy | Rotates this vector around the line with the specified direction vector passing through the origin. The specified Rotation angle's positive direction of rotation is defined by the right hand rule.
ScaleBy | Multiplies this vector by the scale factor.
Set | Sets the vector as this vector from the specified start point to the specified end point.
SetToProduct | Sets this vector to the product of the specified matrix and the specified vector.
SetToSum | Sets this vector equal to the sum of the two specified vectors.
Sum | Returns the vector equal to the sum of this vector and the specified vector.
TransformBy | Transforms this vector by the specified matrix.
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Returns the coordinates of elements in unit length on this vector as an array of Doubles.
LargestElement | Gets the index of the largest absolute value coordinate of this vector.
Length | Gets this length of the vector.
Negative | Gets the vector opposite to this vector.
Normal | Returns the unit vector codirectional to this vector.
X | Specifies the X coordinate data of this vector.
Y | Specifies the Y coordinate data of this vector.
Z | Specifies the Z coordinate data of this vector.
Links
IGeVector Interface, Legend, Methods, Properties


IGeVector::Application Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Application Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::AsArray Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::AsArray Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::AsArray Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Returns the coordinates of elements in unit length on this vector as an array of Doubles.

Visual Basic
Property AsArray() As VARIANT
Remarks

This property is a Variant (array of Doubles).

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::LargestElement Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::LargestElement Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::LargestElement Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets the index of the largest absolute value coordinate of this vector.

Visual Basic
Property LargestElement() As long*
Remarks

This property is a Long.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Length Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Length Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Length Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets this length of the vector.

Visual Basic
Property Length() As double*
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Negative Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Negative Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Negative Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets the vector opposite to this vector.

Visual Basic
Property Negative() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Normal Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Normal Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Normal Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Returns the unit vector codirectional to this vector.

Visual Basic
Property Normal() As IGeVector**
Remarks

This property is a GeVector object.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::X Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::X Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::X Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Specifies the X coordinate data of this vector.

Visual Basic
Property X() As double
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Y Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Y Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Y Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Specifies the Y coordinate data of this vector.

Visual Basic
Property Y() As double
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Z Property

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Z Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Z Property
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Specifies the Z coordinate data of this vector.

Visual Basic
Property Z() As double
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::AngleTo Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::AngleTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::AngleTo Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Computes the angle between this vector and the specified vector.

Visual Basic
Sub AngleTo(Vector As IGeVector, ReferenceVector As [in, optional] VARIANT, Angle As [out, retval] double)
Parameters
Parameters
Description
Vector
GeVector object; input-only. Specifies the other vector to perform the calculation.
ReferenceVector
GeVector object; input-only; optional. Specifies the reference vector to perform the calculation.

  • If not specified, the angle returned is in the range [0, PI].
  • If specified and (RefVec.DotProduct(This.CrossProduct(Vector)) >= 0.0 ), the return value coincides with the return value of the method without the reference vector specified; otherwise the return value is 2*PI minus the return value of the method without the reference vector specified.

Returns

Double

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::CrossProduct Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::CrossProduct Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::CrossProduct Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Computes the cross product of this vector and the specified vector.

Visual Basic
Sub CrossProduct(Vector As IGeVector, CrossProduct As [out, retval] IGeVector*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

GeVector object

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::DotProduct Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::DotProduct Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::DotProduct Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Computes the dot product of this vector and the specified vector.

Visual Basic
Sub DotProduct(Vector As IGeVector, DotProduct As [out, retval] double)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

Double

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Get Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Get Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Get Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets the coordinate data from this vector.

Visual Basic
Sub Get(ByRef X As double, ByRef Y As double, ByRef Z As double)
Parameters
Parameters | Description
X | Double; output-only. Returns the coordinate data of the X axis.
Y | Double; output-only. Returns the coordinate data of the Y axis.
Z | Double; output-only. Returns the coordinate data of the Z axis.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsCodirectionalTo Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsCodirectionalTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsCodirectionalTo Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Determines whether this vector is codirectional to the specified vector, TRUE, or not, FALSE.

Visual Basic
Sub IsCodirectionalTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Codirectional As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsEqualTo Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsEqualTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsEqualTo Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Determines whether this vector is equal to the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsEqualTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Equal As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsParallelTo Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsParallelTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsParallelTo Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Determines whether this vector is parallel with the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsParallelTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Parallel As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsPerpendicularTo Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsPerpendicularTo Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsPerpendicularTo Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Determines whether this vector is perpendicular to the specified vector within the specified tolerance, TRUE, or not, FALSE.

Visual Basic
Sub IsPerpendicularTo(Vector As IGeVector, Tolerance As [in, optional] VARIANT, Perpendicular As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the check.
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Returns

Boolean

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsUnitLength Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsUnitLength Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsUnitLength Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets whether this vector is of unit length, TRUE, or not, FALSE.

Visual Basic
Sub IsUnitLength(Tolerance As [in, optional] VARIANT, UnitLength As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::IsZeroLength Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::IsZeroLength Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::IsZeroLength Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Gets whether this vector is zero length, TRUE, or not, FALSE.

Visual Basic
Sub IsZeroLength(Tolerance As [in, optional] VARIANT, ZeroLength As [out, retval] VARIANT_BOOL)
Parameters
Parameters | Description
Tolerance | Variant ( GeTolerance object); input-only; optional. Specifies the tolerance for calculation.
Remarks

This property is a Boolean.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Item Method ([in] long, [in] double)

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Item Method ([in] long, [in] double)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Item Method ([in] long, [in] double)
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Specifies the item value at the specified index.

Visual Basic
Sub Item(Item As long, Value As double)
Parameters
Parameters | Description
Item | Long; input-only. Specifies the index to get the item value.
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Item Method ([in] long, [out, retval] double*)

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Item Method ([in] long, [out, retval] double*)
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Item Method ([in] long, [out, retval] double*)
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Specifies the item value at the specified index.

Visual Basic
Sub Item(Item As long, Value As [out, retval] double)
Parameters
Parameters | Description
Item | Long; input-only. Specifies the index to get the item value.
Remarks

This property is a Double.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Mirror Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Mirror Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Mirror Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Mirrors this vector about the specified plane.

Visual Basic
Sub Mirror(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GePlane object; input-only. Specifies the plane with respect to which this vector is mirrored.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::MultiplyBy Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::MultiplyBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::MultiplyBy Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Computes the vector equal to this vector multiplied by the specified scale factor.

Visual Basic
Sub MultiplyBy(Scale As double, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Scale | Double; input-only. Specifies the scale factor to perform the calculation.
Returns

GeVector object

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Negate Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Negate Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Negate Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Sets this vector to be equal to its current opposite vector.

Visual Basic
Sub Negate()
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Normalize Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Normalize Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Normalize Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Sets this vector to be equal to its normal vector.

Visual Basic
Sub Normalize()
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::PerpendicularVector Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::PerpendicularVector Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::PerpendicularVector Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Calculates a vector orthogonal to this vector.

Visual Basic
Sub PerpendicularVector(Vector As [out, retval] IGeVector*)
Returns

GeVector object

Remarks

The perpendicular vector is determined by the arbitrary axis algorithm.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Product Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Product Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Product Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Returns the vector equal to the product of the specified matrix and this vector.

Visual Basic
Sub Product(Matrix As IGeMatrix, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix based on which to perform the calculation.
Returns

GeVector object

Remarks

The order of multiplication is matrix * vector, where vectors are considered as columns.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Project Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Project Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Project Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Returns the entity that is the projection of the curve onto the projection plane in the specified direction.

Visual Basic
Sub Project(Normal As IGeVector, Direction As [in, optional] VARIANT, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Normal | GeVector object; input-only. Specifies the normal of the plane to which to project this vector.
Direction | Variant ( GeVector object); input-only; optional. Specifies the direction in which to project this vector; if not specified, the projection is orthogonal to the plane.
Returns

GeVector object

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::RotateBy Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::RotateBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::RotateBy Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Rotates this vector around the line with the specified direction vector passing through the origin. The specified Rotation angle's positive direction of rotation is defined by the right hand rule.

Visual Basic
Sub RotateBy(Angle As double, Vector As IGeVector)
Parameters
Parameters | Description
Angle | Double; input-only. Specifies the angle to rotate this vector. The positive direction of rotation is defined by the right hand rule.
Vector | GeVector object; input-only. Specifies the polar vector to rotate this vector.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::ScaleBy Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::ScaleBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::ScaleBy Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Multiplies this vector by the scale factor.

Visual Basic
Sub ScaleBy(Factor As double)
Parameters
Parameters | Description
Factor | Double; input-only. Specifies the scale factor to change the size of this vector.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Set Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Set Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Set Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Sets the vector as this vector from the specified start point to the specified end point.

Visual Basic
Sub Set(StartPoint As IGePoint, EndPoint As IGePoint)
Parameters
Parameters | Description
StartPoint | GePoint object; input-only. Specifies the start point to define this vector.
EndPoint | GePoint object; input-only. Specifies the end point to define this vector.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::SetToProduct Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::SetToProduct Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::SetToProduct Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Sets this vector to the product of the specified matrix and the specified vector.

Visual Basic
Sub SetToProduct(Matrix As IGeMatrix, Vector As IGeVector)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix to perform the calculation.
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

None

Remarks

The order of multiplication is matrix * vector, where vectors are considered as columns.

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::SetToSum Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::SetToSum Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::SetToSum Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Sets this vector equal to the sum of the two specified vectors.

Visual Basic
Sub SetToSum(Vector1 As IGeVector, Vector2 As IGeVector)
Parameters
Parameters | Description
Vector1 | GeVector object; input-only. Specifies the first vector to perform the calculation.
Vector2 | GeVector object; input-only. Specifies the second vector to perform the calculation.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::Sum Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::Sum Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::Sum Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Returns the vector equal to the sum of this vector and the specified vector.

Visual Basic
Sub Sum(Vector As IGeVector, Result As [out, retval] IGeVector*)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the other vector to perform the calculation.
Returns

GeVector object

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVector::TransformBy Method

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector::TransformBy Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector::TransformBy Method
IGeVector Interface IGeVector Members IGeVector Interface Send Feedback
Summary

Transforms this vector by the specified matrix.

Visual Basic
Sub TransformBy(Matrix As IGeMatrix)
Parameters
Parameters | Description
Matrix | GeMatrix object; input-only. Specifies the matrix by which to transform this vector.
Returns

None

Interface

IGeVector Interface

Links
IGeVector Interface, IGeVector Members, IGeVector Interface


IGeVectors Interface

You are here: API Reference > GEAuto Library > IGeVectors Interface
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors Interface
IGeVectors Members GEAuto Library Class Hierarchy Send Feedback
Summary

A collection of GeVector objects.

Class Hierarchy

Declaration syntax

IGeVectors
Visual Basic
Public Interface IGeVectors
Inherits IDispatch
Library

GEAuto Library

Links
IGeVectors Members, GEAuto Library, Class Hierarchy


IGeVectors Members

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors Members
IGeVectors Interface Legend Methods Properties Send Feedback
Summary

The following tables list the members exposed by IGeVectors.

Interface

IGeVectors Interface

Methods
Name | Description
Add | Appends a new vector to the collection.
Item | Gets the vector at the specified index.
Remove | Removes the specified vector from the collection.
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the vectors in a vector collection.
Links
IGeVectors Interface, Legend, Methods, Properties


IGeVectors::Application Property

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors::Application Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors::Application Property
IGeVectors Interface IGeVectors Members IGeVectors Interface Send Feedback
Summary

Gets the GeApplication object.

Visual Basic
Property Application() As IGeApplication**
Remarks

This property is a GeApplication object.

Interface

IGeVectors Interface

Links
IGeVectors Interface, IGeVectors Members, IGeVectors Interface


IGeVectors::Count Property

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors::Count Property
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors::Count Property
IGeVectors Interface IGeVectors Members IGeVectors Interface Send Feedback
Summary

Gets the total number of the vectors in a vector collection.

Visual Basic
Property Count() As long*
Remarks

This property is a Long.

Interface

IGeVectors Interface

Links
IGeVectors Interface, IGeVectors Members, IGeVectors Interface


IGeVectors::Add Method

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors::Add Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors::Add Method
IGeVectors Interface IGeVectors Members IGeVectors Interface Send Feedback
Summary

Appends a new vector to the collection.

Visual Basic
Sub Add(Vector As IGeVector)
Parameters
Parameters | Description
Vector | GeVector object; input-only. Specifies the new vector to add to the collection.
Returns

None

Interface

IGeVectors Interface

Links
IGeVectors Interface, IGeVectors Members, IGeVectors Interface


IGeVectors::Item Method

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors::Item Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors::Item Method
IGeVectors Interface IGeVectors Members IGeVectors Interface Send Feedback
Summary

Gets the vector at the specified index.

Visual Basic
Sub Item(Index As long, Vector As [out, retval] IGeVector*)
Parameters
Parameters | Description
Index | Long; input-only. Specifies the index for the vector to get from the collection.
Returns

GeVector object

Interface

IGeVectors Interface

Links
IGeVectors Interface, IGeVectors Members, IGeVectors Interface


IGeVectors::Remove Method

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors::Remove Method
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors::Remove Method
IGeVectors Interface IGeVectors Members IGeVectors Interface Send Feedback
Summary

Removes the specified vector from the collection.

Visual Basic
Sub Remove(Index As long)
Parameters
Parameters | Description
Index | Integer; input-only. Specifies the index for the point to be removed.
Returns

None

Interface

IGeVectors Interface

Links
IGeVectors Interface, IGeVectors Members, IGeVectors Interface


GeCollectionType Enumeration

You are here: API Reference > GEAuto Library > GeCollectionType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCollectionType Enumeration
GEAuto Library Send Feedback
Summary

Enumerates all collection types of geometry entity objects.

Visual Basic
Public Enum GeCollectionType
  geCurveBoundaries = 1
  geCurves = 2
  geEntities = 3
  gePoints = 4
  geSurfaces = 5
  geVectors = 6
End Enum
Members
Members | Description
geCurveBoundaries | A collection of GeCurveBoundary objects.
geCurves | A collection of GeCurve objects.
geEntities | A collection of GeEntity objects.
gePoints | A collection of GePoint objects.
geSurfaces | A collection of GeSurface objects.
geVectors | A collection of GeVector objects.
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


GeCurveCurveIntConfiguration Enumeration

You are here: API Reference > GEAuto Library > GeCurveCurveIntConfiguration Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveCurveIntConfiguration Enumeration
GEAuto Library Send Feedback
Summary

Enumerates the characterization of the intersection between curves, circles, or circular arcs. This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.

Visual Basic
Public Enum GeCurveCurveIntConfiguration
  geNotDefined = &H1
  geUnknownType = &H2
  geLeftRight = &H4
  geRightLeft = &H8
  geLeftLeft = &H10
  geRightRight = &H20
  gePointLeft = &H40
  gePointRight = &H80
  geLeftOverlap = &H100
  geOverlapLeft = &H200
  geRightOverlap = &H400
  geOverlapRight = &H800
  geOverlapStart = &H1000
  geOverlapEnd = &H2000
  geOverlapOverlap = &H4000
End Enum
Members
Members | Description
geNotDefined | Indicates that the intersection type is not defined.
geUnknownType | Indicates that the intersection type is unknown.
geLeftRight | Indicates that one curve crosses the other curve from left to right with respect to the other curve and with respect to the curve plane's normal.
geRightLeft | Indicates that one curve crosses the other curve from right to left with respect to the other curve and with respect to the curve plane's normal.
geLeftLeft | Indicates that one curve crosses the other curve always on the left side with respect to the other curve and with respect to the curve plane's normal.
geRightRight | Indicates that one curve crosses the other curve always on the right side with respect to the other curve and with respect to the curve plane's normal.
gePointLeft | Indicates that one curve crosses the other curve from one point to the left with respect to the other curve and with respect to the curve plane's normal.
gePointRight | Indicates that one curve crosses the other curve from one point to the right with respect to the other curve and with respect to the curve plane's normal.
geLeftOverlap | Indicates that one curve crosses the other curve from the left side with respect to the other curve and with respect to the curve plane's normal and then overlap with each other.
geOverlapLeft | Indicates that one curve starts overlapping with the other curve and then crosses with the other curve from the left with respect to the other curve and with respect to the curve plane's normal.
geRightOverlap | Indicates that one curve crosses the other curve from the right side with respect to the other curve and with respect to the curve plane's normal and then overlap with each other.
geOverlapRight | Indicates that one curve starts overlapping with the other curve and then crosses with the other curve from the right with respect to the other curve and with respect to the curve plane's normal.
geOverlapStart | Indicates that one curve starts overlapping with the other curve at the start point.
geOverlapEnd | Indicates that one curve starts overlapping with the other curve at the end point.
geOverlapOverlap | Indicates that two curves overlaps with each other completely.
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


GeCurveSurfIntConfiguration Enumeration

You are here: API Reference > GEAuto Library > GeCurveSurfIntConfiguration Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeCurveSurfIntConfiguration Enumeration
GEAuto Library Send Feedback
Summary

Enumerates all intersection characterization in the neighborhood just above and below the intersection between the curve and the surface.

Visual Basic
Public Enum GeCurveSurfIntConfiguration
  geUnknown = 0
  geOutside = 1
  geInside = 2
  geTangentOutside = 3
  geTangentInside = 4
  geCoincident = 5
  geCoincidentUnbounded = 6
End Enum
Members
Members | Description
geUnknown | Indicates that the intersection is not defined.
geOutside | Indicates the intersection is outside the surface with respect to the orientation of the surface's normal.
geInside | Indicates the intersection is inside the surface with respect to the orientation of the surface's normal.
geTangentOutside | Indicates the intersection is tangent with each other and is outside the surface with respect to the orientation of the surface's normal.
geTangentInside | Indicates the intersection is tangent with each other and is inside the surface with respect to the orientation of the surface's normal.
geCoincident | Indicates that the intersection between the curve and surface is coincident.
geCoincidentUnbounded | Indicates that the intersection between the curve and surface is coincident on an unbounded base.
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


GeNurbSurfaceProperties Enumeration

You are here: API Reference > GEAuto Library > GeNurbSurfaceProperties Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeNurbSurfaceProperties Enumeration
GEAuto Library Send Feedback
Summary

type GeNurbSurfaceProperties

geOpen : Description to come

geClosed : Description to come

gePeriodic : Description to come

geRational : Description to come

geNoPoles : Description to come

gePoleAtMin : Description to come

gePoleAtMax : Description to come

gePoleAtBoth : Description to come

Visual Basic
Public Enum GeNurbSurfaceProperties
  geOpen = &H01
  geClosed = &H02
  gePeriodic = &H04
  geRational = &H08
  geNoPoles = &H10
  gePoleAtMin = &H20
  gePoleAtMax = &H40
  gePoleAtBoth = &H80
End Enum
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


GeSurfSurfIntConfiguration Enumeration

You are here: API Reference > GEAuto Library > GeSurfSurfIntConfiguration Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeSurfSurfIntConfiguration Enumeration
GEAuto Library Send Feedback
Summary

Enumerates all intersection characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.

Visual Basic
Public Enum GeSurfSurfIntConfiguration
  geSSIUnknown = 0
  geSSIOutside = 1
  geSSIInside = 2
  geSSICoincident = 3
End Enum
Members
Members | Description
geSSIUnknown | Indicates the intersection characterization is not defined.
geSSIOutside | Indicates that the neighborhood is outside the second surface with respect to the surface normal orientation of the first surface.
geSSIInside | Indicates that the neighborhood is inside the second surface with respect to the surface normal orientation of the first surface.
geSSICoincident | Indicates that two surfaces are coincident.
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


GeSurfSurfIntType Enumeration

You are here: API Reference > GEAuto Library > GeSurfSurfIntType Enumeration
Collapse All
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
GeSurfSurfIntType Enumeration
GEAuto Library Send Feedback
Summary

Enumerates all intersection types between two surfaces.

Visual Basic
Public Enum GeSurfSurfIntType
  geTransverse = 0
  geTangent = 1
  geAntiTangent = 2
End Enum
Members
Members | Description
geTransverse | Indicates that two surfaces are transverse with each other.
geTangent | Indicates that two surfaces are tangent with each other.
geAntiTangent | Indicates that two surfaces are anti-tangent with each other.
Library

GEAuto Library

Links
GEAuto Library
Copyright (c) 2014. All rights reserved.


Mcad2DSPreview

You are here: API Reference > Mcad2DSPreview
Mcad2DSPreview
API Reference Send Feedback

Mechanical Structure Preview ActiveX Control (Mcad2DSPreview). Allows users to display a thumbnail bitmap of a block, a list of entities, a folder, a component view, or an entire component (tiled views).

Remarks

For detailed information about McadFolderDescriptor and McadComponentViewDescriptor, refer to the Symbol, Balloon, and Bill of Materials (SymBBAuto) section in this Reference Guide.

Descriptor Property

When dropping the control on a form, sets the Descriptor property to an McadFolderDescriptor or a McadComponentViewDescriptor:

  • Displays a preview of the definition on the current model space background color if the descriptor actually points to a folder or a component view.
  • Displays a set of model space entities by creating an McadFolderDescriptor and setting the Entities property to a set of ObjectIDs of entities in model space.
  • Displays the contents of a block by creating an McadFolderDescriptor and placing a single element in the Entites member which is the ObjectID of an AcadBlock.
Group

API Reference

Links
API Reference
Copyright (c) 2014. All rights reserved.


64-bit Platform

You are here: 64-bit Platform
64-bit Platform
Send Feedback
64-bit platform.

Updated API Signatures for 64-bit AutoCAD Mechanical

With AutoCAD Mechanical 2008, the parameters in the following methods and properties have been changed to polymorphic types (e.g. INT_PTR, LONG_PTR) for 64-bit compatibility.

In AcadmAuto:

  • McadAttribute.get_ObjectID
  • McadUtility.GetAttributeFromID
  • McadUtility.GetObjectFromID

In SymBBAuto:

  • McadBOM.GetProperties
  • McadPartList.put_ViewID
  • McadPartList.get_ViewID
  • McadBOMMgr.GetBOMTableByCompDefId

32-Bit VBA in 64-Bit AutoCAD Mechanical

Microsoft is not providing a 64-bit version of VBA. In 64-bit AutoCAD Mechanical, VBA will run as an out-of-process component, accessed through a 32-bit-to-64-bit thunking layer. Your VB code will have to be ported to 64-bit AutoCAD Mechanical.

The behavior of VBA in 64-bit AutoCAD Mechanical is not guaranteed to be identical to that of VBA in 32-bit AutoCAD Mechanical. When the VBA IDE is active or when it is displaying a model window, there might be a slight delay in repaint of AutoCAD window.

In 64-bit AutoCAD Mechanical, object IDs are represented by 64-bit values. Accessing the values of object IDs in 32-bit VBA will result in compilation error. With 64-bit AutoCAD Mechanical 2008, the following methods and properties have been added in 64-bit type libraries to support 32-bit VBA.

In AcadmAuto:

  • McadAttribute.ObjectID32
  • McadUtility.GetAttributeFromID32
  • McadUtility.GetObjectFromID32
  • McadUtility.GetIdsFromObject32
  • McadFolderDescriptor.Entities32
  • McadPowObjViewGroupDescriptor.Entities32
  • McadFolder.Entities32
  • McadComponentView.Entities32
  • McadAttribute.FieldValue32
  • McadLayerGroupMgr.GetLayerGroupEntities32

In SymBBAuto:

  • McadBOM.GetProperties32
  • McadBOMMgr.SelectBOMEntity32
  • McadBOMMgr.GetBOMTableByCompDefId32
  • McadBOMItem.GetReferences32
  • McadBOMItem.GetItemDefinition32
  • McadPartList.ViewID32

To run your VBA macro in 64-bit AutoCAD Mechanical, you will have to port the VBA code to replace the corresponding methods/properties (e.g. McadAttribute.ObjectID) with these new methods/properties (e.g. McadAttribute.ObjectID32). In addition, you will have to re-reference the type libraries.


Sample Code

You are here: Sample Code
Sample Code
Send Feedback
Sample Code

This Reference Guide includes some VBA sample code snippets for typical methods or properties, located in relevant Example sections. However, for many more detailed examples, please refer to the Developer Guide.

Also, for more complete sample code projects, including use of mechanical structure methods, please refer to the sample projects in the SDK (Software Developers Kit).


Legend

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IAcadmApplication Members
Legend
Property
read only
Method
Copyright (c) 2014. All rights reserved.


IAcadmApplication Members Methods

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication Members Methods
IAcadmApplication Members Legend
Methods
Name | Description
AddAttributeClass | Creates a new attribute class definition using the specified fields.
DocumentFromHost | Gets the corresponding McadDocument from the specified host application's document.
GetAttributeClassFields | Gets the field information from the specified attribute class definition.
GetFormulaEvaluator | Gets the formula evaluator from the specified Acad object.
ReadAttributeClass | Reads one or more class definitions in a file.
RemoveAttributeClass | Removes the specified attribute class definition.
WriteAttributeClass | Writes the specified attribute class definition to the specified file.


Methods

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IAcadmApplication Members Properties

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplication Members Properties
IAcadmApplication Members Legend
Properties
Name | Description
ActiveDocument | Gets the currently active document (drawing).
Application | Gets the AcadmApplication object.
AttributeClasses | Gets the names of the currently defined attribute classes.
Documents | Gets the collection of all documents for the application.
StructureModeEditEntity | Gets the status of the structure entity edit mode in the editor state.


Properties

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface > IAcadmApplicationVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IAcadmApplicationVersion Members
Legend
Method


IAcadmApplicationVersion Members Methods

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface > IAcadmApplicationVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IAcadmApplicationVersion Members Methods
IAcadmApplicationVersion Members Legend
Methods
Name | Description
GetVersionNumber | Gets the version of AutoCAD Mechanical application that is running.


Methods

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface > IAcadmApplicationVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


Legend

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeApplication Members
Legend
Property
read only
Method


IGeApplication Members Methods

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication Members Methods
IGeApplication Members Legend
Methods
Name | Description
AugmentedLine | Creates a new GeAugmentedLine object.
BoundBlock | Create a new GeBoundBlock object.
CircularArc | Creates a GeCircularArc object.
Collection | Creates a new collection object of the specified type.
CompositeCurve | Creates a new GeCompositeCurve object.
Cone | Creates a GeCone object.
CurveBoundary | Creates a GeCurveBoundary object.
Cylinder | Creates a GeCylinder object.
EllipticalArc | Creates a new GeEllipticalArc object.
Interval | Creates a new GeInterval object.
KnotVector | Creates a new GeKnotVector object.
Line | Creates a new GeLine object.
LineSegment | Creates a new GeLineSegment object.
Matrix | Creates a new GeMatrix object set to identity.
NurbCurve | Creates a new GeNurbCurve object, which is a 3D rational spline by a knot vector, control points, and weights.
NurbSurface | Creates a new GeNurbSurface object.
OffsetCurve | Creates a new GeOffsetCurve object.
OffsetSurface | Creates a new GeOffsetSurface object.
Plane | Creates a new GePlane object.
Point | Creates a new GePoint object.
Ray | Creates a new GeRay object.
Sphere | Creates a new GeSphere object.
Tolerance | Creates a new GeTolerance object.
Torus | Creates a new GeTorus object.
Vector | Creates a new GeVector object.


Methods

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeApplication Members Properties

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeApplication Members Properties
IGeApplication Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.


Properties

You are here: API Reference > GEAuto Library > IGeApplication Interface > IGeApplication Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeAugmentedLine Members
Legend
Property
read only
Method


IGeAugmentedLine Members Methods

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine Members Methods
IGeAugmentedLine Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PointAt | Specifies the point at the specified index on this augmented line.
PointAt | Specifies the point at the specified index on this augmented line.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
SecondDerivativeAt | Specifies the second order derivative vector at the specified index on the augmented line.
Set | Changes the definition of the augmented line to pass through the specified turning points respectively in the direction of the specified vectors.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.
VectorAt | Specifies the normal vector at the specified index on this augmented line.
VectorAt | Specifies the normal vector at the specified index on this augmented line.


Methods

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeAugmentedLine Members Properties

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeAugmentedLine Members Properties
IGeAugmentedLine Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.
Points | Gets the list of points defining the augmented line.
SecondDerivatives | Gets the list of second order derivative vectors from this augmented line.
Vectors | Gets the list of vectors at the points that define this augmented line.


Properties

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface > IGeAugmentedLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeBoundBlock Members
Legend
Property
read only
Method


IGeBoundBlock Members Methods

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock Members Methods
IGeBoundBlock Members Legend
Methods
Name | Description
Contains | Determines whether the specified point lies within the bounding box, TRUE, or not, FALSE.
Extend | Extends the bounding box to include the specified point.
IsDisjoint | Determines whether the specified bounding box does not intersect or is disjoint with this bounding box, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Swell | Expands the bounding box on all sides by the specified distance.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeBoundBlock Members Properties

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundBlock Members Properties
IGeBoundBlock Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
BasePoint | Specifies the base point of the bounding block.
Direction1 | Specifies the first edge from the base point of the bounding box.
Direction2 | Specifies the second edge from the base point of the bounding box.
Direction3 | Specifies the third edge from the base point of the bounding box.
IsBox | Specifies whether the bounding box is an orthogonal coordinate box, TRUE, or not, FALSE.
MaxPoint | Specifies the maximum point of the bounding box.
MinPoint | Specifies the minimum point of the bounding box.


Properties

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface > IGeBoundBlock Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeBoundedSurface Members
Legend
Property
read only
Method


IGeBoundedSurface Members Methods

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface Members Methods
IGeBoundedSurface Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeBoundedSurface Members Properties

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeBoundedSurface Members Properties
IGeBoundedSurface Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Gets the unbounded base surface geometry.
ContourCount | Gets the number of contour boundaries on the surface.
Contours | Obtains the contour objects that make up the boundary loops on this bounded surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface > IGeBoundedSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCircularArc Members
Legend
Property
read only
Method


IGeCircularArc Members Methods

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc Members Methods
IGeCircularArc Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this circular arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the circular arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the circular arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TangentAt | Determines whether the input point lies on the circular arc, TRUE, or not, FALSE.
TangentTangentRadius | Changes the definition of the circular arc to be tangent to the two input curves and have the specified radius and returns whether this method succeeds, TRUE, or fails, FALSE.
TangentTangentTangent | Changes the definition of the arc to be a circle tangent to the three input curves if possible and returns whether this method succeeds, TRUE, or fails, FALSE.
ThreePoint | Changes the definition of the arc to have the specified start and end points and pass through the specified point.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCircularArc Members Properties

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCircularArc Members Properties
IGeCircularArc Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the circular arc.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this circular arc.
Radius | Specifies the radius of the circular arc.
ReferenceVector | Specifies the reference vector of the circular arc from which the start and end angles are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.


Properties

You are here: API Reference > GEAuto Library > IGeCircularArc Interface > IGeCircularArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCompositeCurve Members
Legend
Property
read only
Method


IGeCompositeCurve Members Methods

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve Members Methods
IGeCompositeCurve Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
GlobalToLocal | Determines the parameter value on the specified component curve corresponding to the specified parameter value on the overall composite curve.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
LocalToGlobal | Determines the parameter value on the composite curve corresponding to the specified parameter value on the composite curve at the specified index.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCompositeCurve Members Properties

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCompositeCurve Members Properties
IGeCompositeCurve Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Curves | Specifies the component curves that make up the composite curve.
Interval | Sets the interval of the curve and returns the index of the interval.


Properties

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface > IGeCompositeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCone Members
Legend
Property
read only
Method


IGeCone Members Methods

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone Members Methods
IGeCone Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
HeightAt | Computes the parameter on the axis of symmetry corresponding to the specified height parameter value of the cone.
IntersectWith | Computes the intersection between the cone and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosed | Specifies whether this cone is a full cone, TRUE, or a conic section, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cone by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCone Members Properties

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCone Members Properties
IGeCone Members Legend
Properties
Name | Description
Apex | Specifies the apex vertex of the cone.
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cone.
BaseRadius | Specifies the base radius of the cone.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
HalfAngle | Specifies the angle between the axis of symmetry and the generated cone.
Height | Specifies the parameter interval height of the cone.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cone.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cone.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeCone Interface > IGeCone Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurve Members
Legend
Property
read only
Method


IGeCurve Members Methods

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve Members Methods
IGeCurve Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurve Members Properties

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurve Members Properties
IGeCurve Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Interval | Sets the interval of the curve and returns the index of the interval.


Properties

You are here: API Reference > GEAuto Library > IGeCurve Interface > IGeCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurveBoundaries Members
Legend
Property
read only
Method


IGeCurveBoundaries Members Methods

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries Members Methods
IGeCurveBoundaries Members Legend
Methods
Name | Description
Add | Appends a new curve boundary to the collection.
Item | Gets the curve boundary at the specified index.
Remove | Removes the specified curve boundary from the collection.


Methods

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurveBoundaries Members Properties

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundaries Members Properties
IGeCurveBoundaries Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curve boundaries in a curve boundary collection.


Properties

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface > IGeCurveBoundaries Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurveBoundary Members
Legend
Property
read only
Method


IGeCurveBoundary Members Methods

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary Members Methods
IGeCurveBoundary Members Legend
Methods
Name | Description
GetBoundary | Gets the three space and parameter space curves and their corresponding logical orientation.
IsDegenerate | Determines whether the curve boundary consists of a single element and is degenerate to a point, TRUE, or not, FALSE.
SetBoundary | Sets the 3D and parameter space curves and their corresponding logical orientation that make up the curve boundary.


Methods

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurveBoundary Members Properties

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveBoundary Members Properties
IGeCurveBoundary Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Elements | Gets the number of elements that make up the curve boundary.
Geometry2d | Gets the 2D parameter space geometry for the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Geometry3d | Gets the 3D geometry that makes up the curve boundary. Depending on the creation of the boundary, not all elements of the resulting array may be set to a value.
Orientation2d | Gets the logical orientation or sense of the 2D parameter space geometry for the curve boundary.
Orientation3d | Gets the logical orientation or sense of the 3D geometry for the curve boundary.


Properties

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface > IGeCurveBoundary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurveCurveIntersection Members
Legend
Property
read only
Method


IGeCurveCurveIntersection Members Methods

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection Members Methods
IGeCurveCurveIntersection Members Legend
Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the parameter value of the intersection point.
GetOverlapRanges | Gets the interval ranges of overlap for the specified interval of overlap for two curves being intersected.
IntersectionPoint | Gets the intersection point at the specified intersection index.
IntersectionPointTolerance | Gets the tolerance used to find the point at the specified intersection index.
IsTangential | Gets whether the intersection is tangential at the specified intersection index, TRUE, or not, FALSE.
IsTransversal | Gets whether the intersection is transversal at the specified intersection index, TRUE, or not, FALSE.
ParameterOnCurve1 | Gets the curve parameter value on the first curve at the specified intersection point.
ParameterOnCurve2 | Gets the curve parameter value on the second curve at the specified intersection point.
Set | Sets the two curves being intersected and optionally the tolerance used in the calculation and the interval ranges on the corresponding curves to be considered in the calculation.


Methods

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurveCurveIntersection Members Properties

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveCurveIntersection Members Properties
IGeCurveCurveIntersection Members Legend
Properties
Name | Description
Curve1 | Specifies the first curve operand for intersection.
Curve2 | Specifies the second curve operand for intersection.
IntersectionPointCount | Gets the number of intersection points.
IntervalRange1 | Specifies the interval range on the first curve that is considered in the intersection calculation.
IntervalRange2 | Specifies the interval range on the second curve that is considered in the intersection calculation.
OverlapCount | Gets the number of overlap intervals between two curves.
OverlapDirection | Gets whether the curves are oriented in the same direction where they overlap, TRUE, or not, FALSE.
Tolerance | Specifies the tolerance used in intersection calculations.


Properties

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface > IGeCurveCurveIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurves Members
Legend
Property
read only
Method


IGeCurves Members Methods

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves Members Methods
IGeCurves Members Legend
Methods
Name | Description
Add | Appends a new curve to the collection.
Item | Gets the curve at the specified index.
Remove | Removes the specified curve from the collection.


Methods

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurves Members Properties

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurves Members Properties
IGeCurves Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the curves in a curve collection.


Properties

You are here: API Reference > GEAuto Library > IGeCurves Interface > IGeCurves Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCurveSurfaceIntersection Members
Legend
Property
read only
Method


IGeCurveSurfaceIntersection Members Methods

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection Members Methods
IGeCurveSurfaceIntersection Members Legend
Methods
Name | Description
GetAllIntersections | Gets all intersection points and the parameters on the intersection operands for every intersection point.
GetIntersectionConfiguration | Gets the characterization of the specified intersection in the neighborhood just above and below the intersection with respect to the curve parameterization.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterOnCurve | Gets the parameter values on the curve at the specified intersection point.
ParameterOnSurface | Gets the parameter values on the surface at the specified intersection point.
Set | Sets the curve and surface being intersected and optionally the tolerance used in the calculation.


Methods

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCurveSurfaceIntersection Members Properties

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCurveSurfaceIntersection Members Properties
IGeCurveSurfaceIntersection Members Legend
Properties
Name | Description
Curve | Specifies the curve for intersection.
IntersectionPointCount | Gets the number of intersection points.
Surface | Specifies the surface for intersection.
Tolerance | Specifies the tolerance used in intersection calculations.


Properties

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface > IGeCurveSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeCylinder Members
Legend
Property
read only
Method


IGeCylinder Members Methods

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder Members Methods
IGeCylinder Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the cylinder and a linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this cylinder by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeCylinder Members Properties

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeCylinder Members Properties
IGeCylinder Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Specifies the axis of symmetry of this cylinder.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the base of the cone.
Height | Specifies the parameter interval height of the cylinder.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of the base of the cylinder.
Radius | Specifies the radius of the cylinder.
ReferenceVector | Specifies the reference vector from which the start angle and end angle are measured.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the base of the cylinder.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeCylinder Interface > IGeCylinder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeEllipticalArc Members
Legend
Property
read only
Method


IGeEllipticalArc Members Methods

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc Members Methods
IGeEllipticalArc Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | Determines whether the specified geometry entity intersects with this elliptical arc, TRUE, or not, FALSE. They do not need to lie in the same plane.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsInside | Determines whether the specified point lies inside of the arc, TRUE, or on or outside of the arc or does not lie on the same plane as the elliptical arc, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the elliptical arc based on the specified center point, normal vector, radius, and optionally reference vector, start angle, and end angle.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeEllipticalArc Members Properties

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEllipticalArc Members Properties
IGeEllipticalArc Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Center | Specifies the center point of the elliptical arc.
EndAngle | Specifies the angle of the end point with respect to the reference vector in the plane of the elliptical arc.
EndPoint | Gets the end point of this elliptical arc.
Interval | Sets the interval of the curve and returns the index of the interval.
IsCircular | Gets whether the ellipse is a circular arc, TRUE, or not, FALSE.
MajorAxis | Specifies the major axis of the ellipse.
MajorRadius | Specifies the major radius of the ellipse.
MinorAxis | Specifies the minor axis of the ellipse.
MinorRadius | Specifies the minor radius of the ellipse.
Normal | Specifies the normal vector of this elliptical arc.
StartAngle | Specifies the angle of the start point with respect to the reference vector in the plane of the arc.
StartPoint | Gets the start point of this elliptical arc.


Properties

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface > IGeEllipticalArc Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeEntities Members
Legend
Property
read only
Method


IGeEntities Members Methods

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities Members Methods
IGeEntities Members Legend
Methods
Name | Description
Add | Appends a new geometry entity to the collection.
Item | Gets the geometry entity at the specified index.
Remove | Removes the specified geometry entity from the collection.


Methods

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeEntities Members Properties

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntities Members Properties
IGeEntities Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the geometry entities in a geometry entity collection.


Properties

You are here: API Reference > GEAuto Library > IGeEntities Interface > IGeEntities Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeEntity Members
Legend
Property
read only
Method


IGeEntity Members Methods

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity Members Methods
IGeEntity Members Legend
Methods
Name | Description
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeEntity Members Properties

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeEntity Members Properties
IGeEntity Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.


Properties

You are here: API Reference > GEAuto Library > IGeEntity Interface > IGeEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeInterval Members
Legend
Property
read only
Method


IGeInterval Members Methods

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval Members Methods
IGeInterval Members Legend
Methods
Name | Description
Contains | Determines whether the specified parameter value or sub-interval is contained by this interval, TRUE, or not, FALSE.
IsContinuousAtUpper | Determines whether this interval is continuous at the upper bound with the specified interval, TRUE, or not, FALSE.
IsDisjoint | Determines whether the specified interval does not intersect with this interval within this interval's boundary tolerance, TRUE, or not, FALSE.
IsOverlapAtUpper | Determines whether the specified interval overlaps this interval at the upper bound, TRUE, or not, FALSE.


Methods

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeInterval Members Properties

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeInterval Members Properties
IGeInterval Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Bounded | Gets whether the interval is bounded in both directions, TRUE, or not, FALSE.
BoundedAbove | Gets whether the interval has an upper bound, TRUE, or not, FALSE.
BoundedBelow | Gets whether the interval has a lower bound, TRUE, or not, FALSE.
IsSingleton | Gets whether the interval is bounded and the lower and upper bounds are equal, TRUE, or not, FALSE.
IsUnBounded | Gets whether the interval is unbounded, TRUE, or not, FALSE.
Length | Gets the length of the interval.
Lower | Specifies the lower bound of the interval.
Upper | Specifies the upper bound of the interval.


Properties

You are here: API Reference > GEAuto Library > IGeInterval Interface > IGeInterval Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeKnotVector Members
Legend
Property
read only
Method


IGeKnotVector Members Methods

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector Members Methods
IGeKnotVector Members Legend
Methods
Name | Description
AddKnot | Appends the specified value to the knot vector.
AddKnotVector | Performs a linear transformation (k = a * k + b), with appropriate coefficients a and b, on this vector and on tail vector.
Contains | Determines whether the specified parameter is within the range of the first and last knot value, TRUE, or not, FALSE.
Insert | Inserts the specified value into the appropriate knot interval.
InsertKnot | Inserts the specified value into the knot vector at the specified index.
Interval | Computes the knot interval containing the specified parameter and returns the index of the knot interval.
IsEqualTo | Determines whether this knot vector is equal to the specified knot vector, TRUE, or not, FALSE.
Item | Gets the knot value at the specified index.
Item | Gets the knot value at the specified index.
MultiplicityAt | Computes and returns the knot multiplicity of the knot value at the specified index.
RemoveKnotAt | Removes the knot at the specified index.
RemoveRange | Removes all knots within the specified index range.
Reverse | Performs a linear transformation on the knot sequence so the first knot is mapped to the maximal value, and vice versa, the last knot is mapped to the minimal value.
SetRange | Performs a linear transformation k = a * k + b of the knot sequence in order to place all the values between the specified lower and upper values.
Split | Splits the knot sequence at the specified parameter value. The knot value at the end of the first piece and at the beginning of the second piece is inserted or deleted to satisfy the specified multiplicity values.


Methods

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeKnotVector Members Properties

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeKnotVector Members Properties
IGeKnotVector Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the knot values as an array of Doubles.
DistinctKnots | Gets the sequence of all knot values in the vector without duplicates within the vectors tolerance.
EndParameter | Gets the last knot value of the knot vector.
IsEmpty | Gets whether the knot vector is empty, TRUE, or not, FALSE.
Length | Gets the length of the knot values of the knot vector.
NumberOfIntervals | Gets the number of the non-zero intervals between knots.
StartParameter | Gets the first knot value of the knot vector.
Tolerance | Specifies the knot value tolerance used by the knot vector.


Properties

You are here: API Reference > GEAuto Library > IGeKnotVector Interface > IGeKnotVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeLine Members
Legend
Method
Property
read only


IGeLine Members Methods

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLine Members Methods
IGeLine Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeLine Members Properties

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLine Members Properties
IGeLine Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


Properties

You are here: API Reference > GEAuto Library > IGeLine Interface > IGeLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeLinearEntity Members
Legend
Property
read only
Method


IGeLinearEntity Members Methods

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity Members Methods
IGeLinearEntity Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeLinearEntity Members Properties

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLinearEntity Members Properties
IGeLinearEntity Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


Properties

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface > IGeLinearEntity Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeLineSegment Members
Legend
Property
read only
Method


IGeLineSegment Members Methods

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment Members Methods
IGeLineSegment Members Legend
Methods
Name | Description
BaryComb | Returns the point that is the weighted average of the start and end points of the line segment.
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the line segment to pass through the specified point in the direction of the specified vector.
TangentTangent | Changes the definition of the line segment so that the line segment is tangent to the two input curves.
TangentTo | Changes the definition of the line segment so that the line segment passes through the specified point and is tangent to the specified curve.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeLineSegment Members Properties

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeLineSegment Members Properties
IGeLineSegment Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Bisector | Gets the unbounded plane that is perpendicular to the line segment and passes through its midpoint.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
EndPoint | Specifies the end point of the line segment.
Interval | Sets the interval of the curve and returns the index of the interval.
MidPoint | Gets the midpoint of the line segment.
PointOnLine | Gets an arbitrary point on the linear entity.
StartPoint | Specifies the start point of the line segment.


Properties

You are here: API Reference > GEAuto Library > IGeLineSegment Interface > IGeLineSegment Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeMatrix Members
Legend
Property
read only
Method


IGeMatrix Members Methods

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix Members Methods
IGeMatrix Members Legend
Methods
Name | Description
GetCoordinateSystem | Gets the origin point and axis direction vectors of the coordinate system that this matrix maps to.
Invert | Sets the matrix to be equal to its inverse.
IsEqualTo | Determines whether this matrix is equal to the specified matrix within the specified tolerance, TRUE, or not, FALSE.
IsOrthogonal | Gets whether the column vectors of the linear portion of the matrix are orthogonal or perpendicular with each other, TRUE, or not, FALSE.
IsSingular | Gets whether any column vector of the linear portion of the matrix is in zero length or whether any two column vectors of the linear portion of the matrix are parallel, TRUE, or not, FALSE.
IsUniformScaledOrtho | Gets whether this matrix is orthogonal or perpendicular to each other, and uniformly scaled, TRUE, or not, FALSE.
Item | Specifies the matrix element value at the specified row and column.
Item | Specifies the matrix element value at the specified row and column.
PostMultiply | Computes the matrix resulting from this matrix multiplied by the specified matrix.
PreMultiply | Computes the matrix resulting from the specified matrix multiplied by this matrix.
Product | Returns the product of this matrix and the specified matrix.
SetToAlignCoordinateSystem | Sets this matrix to the matrix which maps from one specified coordinate system to another specified coordinate system.
SetToCoordinateSystem | Sets this matrix to the matrix which maps the standard coordinate system with the origin (0, 0, 0) and axes (1, 0, 0), (0, 1, 0) and (0, 0, 1) to the specified coordinate system.
SetToIdentity | Sets this matrix to the identity matrix.
SetToMirroring | Sets this matrix to the matrix of mirroring with respect to the specified entity.
SetToProduct | Sets this matrix to the product of the two specified matrices.
SetToProjection | Sets this matrix to the matrix with the parallel projection into the specified plane.
SetToRotation | Sets this matrix to the matrix with the rotation by the specified angle around the specified axis vector.
SetToScaling | Sets this matrix to the matrix with the uniform scaling by the specified scale factor with respect to the specified point.
SetToTranslation | Sets this matrix to the matrix with translation by the specified vector.
TransposeIt | Sets this matrix to its current transpose.


Methods

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeMatrix Members Properties

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeMatrix Members Properties
IGeMatrix Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the elements of the 4 x 4 matrix by row from top to bottom.
Determinant | Gets the determinant of this matrix.
Inverse | Gets the inverse matrix of this matrix.
Scale | Multiplies the matrix by the scale factor.
Translation | Specifies the translation portion of the matrix.
Transpose | Gets the transposition matrix of this matrix.


Properties

You are here: API Reference > GEAuto Library > IGeMatrix Interface > IGeMatrix Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeNurbCurve Members
Legend
Property
read only
Method


IGeNurbCurve Members Methods

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve Members Methods
IGeNurbCurve Members Legend
Methods
Name
Description
AddFitPointAt
Inserts the specified point into the fit points at the specified index.
AddKnot
Adds the knot value into the curve's knot sequence.
BoundBlock
Computes the bounding box around the curve or the curve interval.
ClosestPointTo
Calculates the closest point on this curve to the specified point.
ClosestPointToCurve
Calculates the closest point on this curve to the specified curve.
ContinuityAtKnot
Gets the degree of the highest derivative that is continuous at a knot. For example, if this NURB curve does not have its first derivative at the specified knot index, the value 0 is returned.
ControlPointAt
Specifies the control point at the specified index.
ControlPointAt
Specifies the control point at the specified index.
DistanceTo
Calculates the minimum distance between this curve to the specified geometry entity.
ElevateDegree
Elevates the degree of the NURB curve by the specified amount.
EvaluatePoint
Returns the point on the curve corresponding to the specified parameter value.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
FitPointAt
Specifies the fit point at the specified index. This property is a only available if the curve has fit data, HasFitData.
GetArea
Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature
Gets the curvature of the curve at the specified parameter value.
GetDefinitionData
Gets all the data that defines this NURB curve.
GetFitData
Gets the fit data used by the fit curve.
GetLength
Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints
Evaluates a sampling of points along the curve.
GetSplitCurves
Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint
Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint
Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve
Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface
Calculates the intersection with the specified surface within the specified tolerance.
IsClosed
Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith
Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate
Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo
Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear
Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn
Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval
Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic
Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar
Gets whether this curve is planar, TRUE, or not, FALSE.
JoinWith
Recomputes this NURB curve by joining the specified NURB curve to the end of this NURB curve.
KnotAt
Specifies the knot value at the specified index.
KnotAt
Specifies the knot value at the specified index.
LocalClosestPointTo
Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve
Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
MakeClosed
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this NURB curve to form a smooth closed curve.
  • If the Option element is FALSE and if the curve is closed, it is made open by removing the span between the last and next-to-last knots.
MakePeriodic
Using this method:

  • If the Option element is TRUE and if the curve is not already closed, it is made closed by creating a curve between the start and end points and joining it with this curve to form a smooth closed curve, and then is made into a periodic curve.
  • If the Option element is FALSE and if the curve is periodic, it is made non-periodic by assigning full knot multiplicity at the first and last knots.
MakeRational
Sets this NURB curve as rational and sets the weight of each control point to the specified weight.
Mirror
Mirrors this entity about the specified plane.
NormalPoint
Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength
Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf
Calculates the parameter value on this curve, which corresponds to the specified point.
ParametersOfC1
Checks whether there are any C1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
ParametersOfG1
Checks whether there are any G1 discontinuities on the NURB curve, TRUE, or not, FALSE; if this method returns True.
Project
Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
PurgeFitData
Removes all fit data from the NURB curve.
RemoveFitPointAt
Removes the fit point at the specified index.
Reverse
Reverses the parametric direction of the curve.
RotateBy
Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy
Multiplies this entity by the scale factor.
SetDefinitionData
Sets the definition data of the NURB curve from the specified parameters.
SetFitData
Recomputes this NURB curve from the specified knot vector, fit points, start and end tangents, and fit tolerance.
TransformBy
Transforms this entity by the specified matrix.
TranslateBy
Translates or moves the entity by the specified translation vector.
TrimByParameters
Trims this NURB curve to the new start and end parameters.
WeightAt
Specifies the weight value for the control point at the specified index.
WeightAt
Specifies the weight value for the control point at the specified index.


Methods

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeNurbCurve Members Properties

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbCurve Members Properties
IGeNurbCurve Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPointCount | Gets the number of control points on this NURB curve.
ControlPoints | Gets all control points on this NURB curve.
Degree | Gets the degree of this NURB curve.
EndParameter | Gets the end parameter value of this NURB curve.
EndPoint | Gets the end point of this NURB curve.
EvaluatorMode | Specifies the curve evaluation optimization mode.
FitEndTangent | Specifies the tangent at the end of a fit curve.
FitPointCount | Gets the number of fit points used to construct this NURB curve.
FitPoints | Gets the fit points used to construct this NURB curve.
FitStartTangent | Specifies the tangent at the start of a fit curve.
FitTolerance | Specifies the tolerance used for interpolating this NURB curve from the fit data.
HasFitData | Gets whether the NURB curve has interpolating fit data.
Interval | Sets the interval of the curve and returns the index of the interval.
IsRational | Gets whether this NURB curve is rational, TRUE, or not, FALSE.
KnotCount | Gets the length of the knot vector for this NURB curve.
Knots | Gets the knot vector from this NURB curve.
Order | Gets the order of this NURB curve.
StartParameter | Gets the start parameter of this NURB curve.
StartPoint | Gets the start point of this NURB curve.
WeightCount | Gets the number of weights for this NURB curve.
Weights | Gets all weights of control points.


Properties

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface > IGeNurbCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeNurbSurface Members
Legend
Property
read only
Method


IGeNurbSurface Members Methods

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface Members Methods
IGeNurbSurface Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetDefinitionData | Gets the definition data from this NURB surface.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsPeriodicInU | Gets whether this NURB surface is periodic in the U parameter direction, and obtains the period, TRUE, or not, FALSE.
IsPeriodicInV | Gets whether this NURB surface is periodic in the V parameter direction, and obtains the period, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
SetDefinitionData | Sets the definition data for this NURB surface.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeNurbSurface Members Properties

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeNurbSurface Members Properties
IGeNurbSurface Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
ControlPoints | Gets all control points on this NURB surface
DegreeInU | Gets the degree of this NURB surface in the U parameter direction.
DegreeInV | Gets the degree of this NURB surface in the V parameter direction.
IsClosedInU | Gets whether this NURB surface is closed in the U parameter direction, TRUE, or not, FALSE.
IsClosedInV | Gets whether this NURB surface is closed in the V parameter direction, TRUE, or not, FALSE.
IsRationalInU | Gets whether this NURB surface is rational in the U parameter direction, TRUE, or not, FALSE.
IsRationalInV | Gets whether this NURB surface is rational in the V parameter direction, TRUE, or not, FALSE.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
SingularityInU | Gets the characterization of any singularity in the U parameter direction.
SingularityInV | Gets the characterization of any singularity in the V parameter direction.
UControlPointCount | Gets the number of control points in the U parameter direction.
UKnotCount | Gets the number of knots in the U parameter direction.
UKnots | Gets the U knot vector on this NURB surface in the U parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VControlPointCount | Gets the number of control points in the V parameter direction.
VKnotCount | Gets the number of knots in the V parameter direction.
VKnots | Gets the U knot vector on this NURB surface in the V parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.
Weights | Gets the weights of all control points on this NURB surface.


Properties

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface > IGeNurbSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeOffsetCurve Members
Legend
Property
read only
Method


IGeOffsetCurve Members Methods

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve Members Methods
IGeOffsetCurve Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeOffsetCurve Members Properties

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetCurve Members Properties
IGeOffsetCurve Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
BaseCurve | Specifies the base curve that this curve is an offset of.
Interval | Sets the interval of the curve and returns the index of the interval.
Normal | Specifies the normal vector of this offset curve.
OffsetDistance | Specifies the offset distance of this offset curve.
ParameterDirection | Gets whether the parameter direction of this offset curve is the same as the base curve , TRUE, or not, FALSE.
Transformation | Returns the transformation matrix that was applied to the offset curve by calling TransformBy .


Properties

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface > IGeOffsetCurve Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeOffsetSurface Members
Legend
Property
read only
Method


IGeOffsetSurface Members Methods

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface Members Methods
IGeOffsetSurface Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
ConvertedSurface | Computes the simple surface equivalent to the offset surface.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeOffsetSurface Members Properties

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeOffsetSurface Members Properties
IGeOffsetSurface Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
BaseSurface | Specifies the base surface of the offset surface.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
OffsetDistance | Specifies the offset distance of this surface.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface > IGeOffsetSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGePlane Members
Legend
Property
read only
Method


IGePlane Members Methods

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane Members Methods
IGePlane Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
CoordinateSystem | Gets the coordinate system of this plane.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
GetCoefficients | Gets the coefficients of the equation of the plane, namely a*x + b*y + c*z + d, where a, b, c, and d are the coefficients of the normal to this plane.
IntersectWith | Computes the intersection between the plane and the specified linear entity or other plane.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsCoplanarWith | Determines whether this plane is coplanar to the specified plane, TRUE, or not, FALSE.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsParallelTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this plane is coplanar to the specified geometry entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this plane.
SignedDistanceTo | Computes the signed distance from the specified point to this plane.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGePlane Members Properties

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePlane Members Properties
IGePlane Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Normal | Specifies the normal vector of this plane.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the origin of the plane.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGePlane Interface > IGePlane Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGePoint Members
Legend
Property
read only
Method


IGePoint Members Methods

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint Members Methods
IGePoint Members Legend
Methods
Name | Description
AsVector | Creates a vector from the point values.
DistanceTo | Calculates the minimum distance between this point and the specified point.
Get | Gets the coordinate system data from this point.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Item | Specifies the item value of this point at the specified index.
Item | Specifies the item value of this point at the specified index.
Mirror | Mirrors this entity about the specified plane.
ProjectToPlane | Returns the 3D point which results from the projection of this point into the specified plane.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the definition data of this point by the specified coordinates.
Sum | Returns the point equal to this point offset by the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGePoint Members Properties

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoint Members Properties
IGePoint Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Specifies the coordinate data of this point as an array of Doubles.
X | Specifies the X coordinate data of this point.
Y | Specifies the Y coordinate data of this point.
Z | Specifies the Z coordinate data of this point.


Properties

You are here: API Reference > GEAuto Library > IGePoint Interface > IGePoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGePoints Members
Legend
Property
read only
Method


IGePoints Members Methods

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints Members Methods
IGePoints Members Legend
Methods
Name | Description
Add | Appends a new point to the collection.
Item | Gets the point at the specified index.
Remove | Removes the specified point from the collection.


Methods

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGePoints Members Properties

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGePoints Members Properties
IGePoints Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | For GePoint objects: Specifies the coordinates of the point as an array of Doubles. For GePoints Collection objects: Specifies the coordinates of the points in the collection as an array of Doubles. The array size must be a multiple of three. Setting the array values clears the current collection and creates new GePoint objects with the new values. For GeKnotVector objects: Specifies the knot values as an array of Doubles. For GeMatrix objects: Specifies the elements of the 4 x 4 matrix by row from top to bottom.
AsArray2d | Specifies the coordinates of the points in the collection as an array of Doubles, two for each point in the collection.
Count | Gets the total number of the points in a point collection.


Properties

You are here: API Reference > GEAuto Library > IGePoints Interface > IGePoints Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeRay Members
Legend
Method
Property
read only


IGeRay Members Methods

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeRay Members Methods
IGeRay Members Legend
Methods
Name | Description
BoundBlock | Computes the bounding box around the curve or the curve interval.
ClosestPointTo | Calculates the closest point on this curve to the specified point.
ClosestPointToCurve | Calculates the closest point on this curve to the specified curve.
DistanceTo | Calculates the minimum distance between this curve to the specified geometry entity.
EvaluatePoint | Returns the point on the curve corresponding to the specified parameter value.
GetArea | Gets the area of the interval of the curve defined by the specified start parameter and end parameter.
GetCurvature | Gets the curvature of the curve at the specified parameter value.
GetLength | Gets the length of the curve between the two parameter values within the specified tolerance.
GetSamplePoints | Evaluates a sampling of points along the curve.
GetSplitCurves | Gets two segments which are obtained by splitting the curve at the specified parameter value.
HasEndPoint | Gets whether the curve is bounded above and therefore has an end point, TRUE, or not, FALSE.
HasStartPoint | Gets whether the curve is bounded below and therefore has a start point, TRUE, or not, FALSE.
IntersectWith | For GeCircularArc and GeEllipticalArc objects: Determines if the specified arc intersects with this arc.
IntersectWithCurve | Calculates the intersection with the specified curve within the specified tolerance.
IntersectWithSurface | Calculates the intersection with the specified surface within the specified tolerance.
IsClosed | Gets whether the start and end points of the curve are the same, TRUE, or not, FALSE.
IsColinearTo | Determines if this line is collinear to the specified line.
IsCoplanarWith | Determines whether this curve and the specified curve are planar within the specified tolerance and that they lie on the same plane, TRUE, or not, FALSE.
IsDegenerate | Determines whether the curve or curve boundary is degenerate within the specified tolerance, TRUE, or not, FALSE, and if so optionally returns the entity which the curve degenerates into.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsLinear | Determines whether the curve is linear within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
IsOnInterval | Determines whether the specified parameter is within the curve's parameter range, TRUE, or not, FALSE.
IsOnPlane | Determines if the line lies on the specified plane.
IsParallelTo | Determines if the specified entity is parallel to this entity.
IsPeriodic | Gets whether this curve is periodic, TRUE, or not, FALSE.
IsPerpendicularTo | For GeLinearEntity objects: Determines if the specified line or plane is perpendicular to this line. For GeVector objects: Determines if the specified vector is perpendicular to this vector. For GePlane objects: Determines if the specified line or plane is perpendicular to this plane.
IsPlanar | Gets whether this curve is planar, TRUE, or not, FALSE.
LocalClosestPointTo | Computes the closest point to the curve within the specified parameter interval.
LocalClosestPointToCurve | Computes the closest point from the specified curve to this curve within the specified parameter intervals on each entity.
Mirror | Mirrors this entity about the specified plane.
NormalPoint | Finds the point on the curve whose normal passes through the specified point.
Overlap | Determines if two lines overlap and if so returns the line that coincides with their region of overlap. The returned overlap may be an object of any type of GeLinearEntity, depending on the types of the two lines. The overlap entity will only be set if the method returns TRUE.
ParameterAtLength | Calculates the parameter value on the curve that is the specified arc length distance from the specified starting parameter value.
ParameterOf | Calculates the parameter value on this curve, which corresponds to the specified point.
PerpendicularPlane | Calculates a plane perpendicular to the line at the specified point
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
Reverse | Reverses the parametric direction of the curve.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of the ray to pass through the specified point in the direction of the specified vector.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeRay Members Properties

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeRay Members Properties
IGeRay Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Direction | Gets the direction vector of the line. This vector is a unit vector and points in the direction of increasing parameter value.
Interval | Sets the interval of the curve and returns the index of the interval.
PointOnLine | Gets an arbitrary point on the linear entity.


Properties

You are here: API Reference > GEAuto Library > IGeRay Interface > IGeRay Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeSphere Members
Legend
Property
read only
Method


IGeSphere Members Methods

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere Members Methods
IGeSphere Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between this sphere and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this sphere is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Changes the definition of this sphere by the specified parameters.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeSphere Members Properties

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSphere Members Properties
IGeSphere Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
EndLatitude | Specifies the end angle in the latitudinal parameter direction.
EndLongitude | Specifies the end angle in the longitudinal parameter direction.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
NorthAxis | Gets the direction from the origin of the north pole.
NorthPole | Gets the north pole point of this sphere.
Origin | Gets the center of this sphere.
Radius | Specifies the radius of this sphere.
ReferenceAxis | Gets the direction of the zero meridian.
SouthPole | Gets the south pole point of this sphere.
StartLatitude | Specifies the start angle in the latitudinal parameter direction.
StartLongitude | Specifies the start angle in the longitudinal parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeSphere Interface > IGeSphere Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeSurface Members
Legend
Property
read only
Method


IGeSurface Members Methods

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface Members Methods
IGeSurface Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeSurface Members Properties

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurface Members Properties
IGeSurface Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeSurface Interface > IGeSurface Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeSurfaces Members
Legend
Property
read only
Method


IGeSurfaces Members Methods

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces Members Methods
IGeSurfaces Members Legend
Methods
Name | Description
Add | Appends a new surface to the collection.
Item | Gets the surface at the specified index.
Remove | Removes the specified surface from the collection.


Methods

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeSurfaces Members Properties

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaces Members Properties
IGeSurfaces Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the surfaces in a surface collection.


Properties

You are here: API Reference > GEAuto Library > IGeSurfaces Interface > IGeSurfaces Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeSurfaceSurfaceIntersection Members
Legend
Property
read only
Method


IGeSurfaceSurfaceIntersection Members Methods

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection Members Methods
IGeSurfaceSurfaceIntersection Members Legend
Methods
Name | Description
GetIntersectionCofiguration | Gets the characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
IntersectionCurve | Gets the intersection curve at the specified intersection index.
IntersectionDimension | Gets the dimension of the intersection at the specified intersection index.
IntersectionPoint | Gets the intersection point at the specified intersection index.
ParameterCurveOnSurface1 | Gets the parametric curve on the first surface at the specified intersection index.
ParameterCurveOnSurface2 | Gets the parametric curve on the second surface at the specified intersection index.
ParameterOnSurface1 | Gets the surface parameter values on the first surface at the specified intersection index.
ParameterOnSurface2 | Gets the surface parameter values on the second surface at the specified intersection point. This property will fail if the intersection dimension at the specified intersection index is not 0.
Set | Sets the two surfaces being intersected and optionally the tolerance used in the calculation.


Methods

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeSurfaceSurfaceIntersection Members Properties

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeSurfaceSurfaceIntersection Members Properties
IGeSurfaceSurfaceIntersection Members Legend
Properties
Name | Description
IntersectionCount | Gets the number of intersections calculated.
Surface1 | Specifies the first surface for this intersection.
Surface2 | Specifies the second surface for this intersection.
Tolerance | Specifies the tolerance used in the intersection calculation.


Properties

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface > IGeSurfaceSurfaceIntersection Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeTolerance Members
Legend
Property
read only


IGeTolerance Members Properties

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTolerance Members Properties
IGeTolerance Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
EqualPoint | Specifies the distance between two points at which they are considered equal.
EqualVector | Specifies the tolerance to determine whether two vectors are considered equal, parallel, or perpendicular.


Properties

You are here: API Reference > GEAuto Library > IGeTolerance Interface > IGeTolerance Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeTorus Members
Legend
Property
read only
Method


IGeTorus Members Methods

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus Members Methods
IGeTorus Members Legend
Methods
Name | Description
ClosestPointTo | Calculates the closest point on this surface to the specified point.
DistanceTo | Calculates the minimum distance between the surface and the specified point.
EvaluatePoint | Returns the point on the surface corresponding to the specified parameter value.
IntersectWith | Computes the intersection between the torus and the specified linear entity.
IntersectWithSurface | Calculates the intersection between this surface and the specified surface.
IsClosedInU | Gets whether this torus is closed in the U parameterization direction.
IsClosedInV | Gets whether this torus is closed in the U parameterization direction.
IsEqualTo | Determines whether this entity is equal to the specified entity within the specified tolerance, TRUE, or not, FALSE.
IsOn | Determines whether the specified point lies on the entity, TRUE, or not, FALSE.
Mirror | Mirrors this entity about the specified plane.
ParameterOf | Calculates the 2D parameter point on this surface, which corresponds to the specified point.
RotateBy | Rotates this entity around the line with the specified direction vector passing through the specified point.
ScaleBy | Multiplies this entity by the scale factor.
Set | Sets the torus with the specified center point and major and minor radii, and optionally with the axis of symmetry direction and start and ending angles in the U and V parameter directions.
TransformBy | Transforms this entity by the specified matrix.
TranslateBy | Translates or moves the entity by the specified translation vector.


Methods

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeTorus Members Properties

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeTorus Members Properties
IGeTorus Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AxisOfSymmetry | Gets the axis of symmetry of the torus.
EndAngleInU | Specifies the end angle in the U parameter direction.
EndAngleInV | Specifies the end angle in the V parameter direction.
MajorRadius | Specifies the major radius of this torus.
MinorRadius | Specifies the minor radius of this torus.
NormalFlipped | Specifies whether the surface normal is flipped, TRUE, or not, FALSE.
Origin | Gets the center of this torus.
ReferenceAxis | Gets the direction of the zero meridian.
StartAngleInU | Specifies the start angle in the U parameter direction.
StartAngleInV | Specifies the start angle in the V parameter direction.
UParameterEnvelope | Gets the surface's parameter range in the U parameter direction.
VParameterEnvelope | Gets the surface's parameter range in the V parameter direction.


Properties

You are here: API Reference > GEAuto Library > IGeTorus Interface > IGeTorus Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeVector Members
Legend
Property
read only
Method


IGeVector Members Methods

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector Members Methods
IGeVector Members Legend
Methods
Name | Description
AngleTo | Computes the angle between this vector and the specified vector.
CrossProduct | Computes the cross product of this vector and the specified vector.
DotProduct | Computes the dot product of this vector and the specified vector.
Get | Gets the coordinate data from this vector.
IsCodirectionalTo | Determines whether this vector is codirectional to the specified vector, TRUE, or not, FALSE.
IsEqualTo | Determines whether this vector is equal to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsParallelTo | Determines whether this vector is parallel with the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsPerpendicularTo | Determines whether this vector is perpendicular to the specified vector within the specified tolerance, TRUE, or not, FALSE.
IsUnitLength | Gets whether this vector is of unit length, TRUE, or not, FALSE.
IsZeroLength | Gets whether this vector is zero length, TRUE, or not, FALSE.
Item | Specifies the item value at the specified index.
Item | Specifies the item value at the specified index.
Mirror | Mirrors this vector about the specified plane.
MultiplyBy | Computes the vector equal to this vector multiplied by the specified scale factor.
Negate | Sets this vector to be equal to its current opposite vector.
Normalize | Sets this vector to be equal to its normal vector.
PerpendicularVector | Calculates a vector orthogonal to this vector.
Product | Returns the vector equal to the product of the specified matrix and this vector.
Project | Returns the entity that is the projection of the curve onto the projection plane in the specified direction.
RotateBy | Rotates this vector around the line with the specified direction vector passing through the origin. The specified Rotation angle's positive direction of rotation is defined by the right hand rule.
ScaleBy | Multiplies this vector by the scale factor.
Set | Sets the vector as this vector from the specified start point to the specified end point.
SetToProduct | Sets this vector to the product of the specified matrix and the specified vector.
SetToSum | Sets this vector equal to the sum of the two specified vectors.
Sum | Returns the vector equal to the sum of this vector and the specified vector.
TransformBy | Transforms this vector by the specified matrix.


Methods

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeVector Members Properties

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVector Members Properties
IGeVector Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
AsArray | Returns the coordinates of elements in unit length on this vector as an array of Doubles.
LargestElement | Gets the index of the largest absolute value coordinate of this vector.
Length | Gets this length of the vector.
Negative | Gets the vector opposite to this vector.
Normal | Returns the unit vector codirectional to this vector.
X | Specifies the X coordinate data of this vector.
Y | Specifies the Y coordinate data of this vector.
Z | Specifies the Z coordinate data of this vector.


Properties

You are here: API Reference > GEAuto Library > IGeVector Interface > IGeVector Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IGeVectors Members
Legend
Property
read only
Method


IGeVectors Members Methods

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors Members Methods
IGeVectors Members Legend
Methods
Name | Description
Add | Appends a new vector to the collection.
Item | Gets the vector at the specified index.
Remove | Removes the specified vector from the collection.


Methods

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IGeVectors Members Properties

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IGeVectors Members Properties
IGeVectors Members Legend
Properties
Name | Description
Application | Gets the GeApplication object.
Count | Gets the total number of the vectors in a vector collection.


Properties

You are here: API Reference > GEAuto Library > IGeVectors Interface > IGeVectors Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2dComplexStdPartCompGroupDescriptor Members
Legend
Property
read only
Method


IMcad2dComplexStdPartCompGroupDescriptor Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor Members Methods
IMcad2dComplexStdPartCompGroupDescriptor Members Legend
Methods
Name | Description
AddView | Adds a view group descriptor to a 2D complex standard part component group descriptor.
HasEqualTypeWithViewGroup | Checks if a 2D complex standard part component group descriptor has equal type with a given power object view group descriptor, TRUE, or not, FALSE.
MigrateTo2DStructure | Migrates a 2D complex standard part component group to 2D structure. New 2D standard part components with standard part views are created.
RemoveView | Removes the view group descriptor from a 2D complex standard part component group descriptor.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2dComplexStdPartCompGroupDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComplexStdPartCompGroupDescriptor Members Properties
IMcad2dComplexStdPartCompGroupDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D complex standard part component group descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface > IMcad2dComplexStdPartCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2dComponentDescriptor Members
Legend
Property
read only
Method


IMcad2dComponentDescriptor Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor Members Methods
IMcad2dComponentDescriptor Members Legend
Methods
Name | Description
AddComponentView | Adds a component view descriptor to a 2D component descriptor.
CreateComponent | Creates a new 2D component from a 2D component descriptor.
HasEqualTypeWithView | Checks if a 2D component descriptor has equal type with a given component view descriptor, TRUE, or not, FALSE.
RemoveComponentView | Removes the specified component view descriptor from a 2D component descriptor.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2dComponentDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dComponentDescriptor Members Properties
IMcad2dComponentDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets the component from the component descriptor.
ComponentDefinition | Gets and sets the component definition for the component descriptor.
ComponentViews | Gets component view descriptors from the component descriptor.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
OwningComponentDefinition | Gets and sets the owning component definitions on the component descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface > IMcad2dComponentDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2dShaftCompGroupDescriptor Members
Legend
Property
read only
Method


IMcad2dShaftCompGroupDescriptor Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor Members Methods
IMcad2dShaftCompGroupDescriptor Members Legend
Methods
Name | Description
MigrateTo2DStructure | Migrates a 2D shaft component group to 2D structure. A new 2D shaft component with standard parts is created.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2dShaftCompGroupDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2dShaftCompGroupDescriptor Members Properties
IMcad2dShaftCompGroupDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.
Views | Gets view group descriptors from the 2D shaft component group descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface > IMcad2dShaftCompGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface > IMcad2DStructureDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureDescriptor Members
Legend
Property
read only


IMcad2DStructureDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface > IMcad2DStructureDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureDescriptor Members Properties
IMcad2DStructureDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Name | Gets and sets the name of a 2D structure descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface > IMcad2DStructureDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureMgr2 Members
Legend
Property
read only
Method


IMcad2DStructureMgr2 Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr2 Members Methods
IMcad2DStructureMgr2 Members Legend
Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2DStructureMgr2 Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr2 Members Properties
IMcad2DStructureMgr2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface > IMcad2DStructureMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureMgr3 Members
Legend
Method
Property
read only


IMcad2DStructureMgr3 Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3 Members Methods
IMcad2DStructureMgr3 Members Legend
Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2DStructureMgr3 Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr3 Members Properties
IMcad2DStructureMgr3 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureMgr4 Members
Legend
Property
read only
Method


IMcad2DStructureMgr4 Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4 Members Methods
IMcad2DStructureMgr4 Members Legend
Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2DStructureMgr4 Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr4 Members Properties
IMcad2DStructureMgr4 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface > IMcad2DStructureMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureMgr5 Members
Legend
Method
Property
read only


IMcad2DStructureMgr5 Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5 Members Methods
IMcad2DStructureMgr5 Members Legend
Methods
Name | Description
AddNewAnnotationView | Creates new annotation view
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateRootViewDefinition | Creates a master view definition in the specified database. If the database already contains a master view definition, it returns the existing one.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExistsStructure | Checks for the existence of mechanical structure in the specified database.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetReferenceLockMode | Gets the state of the 2D Structure reference lock mode for a database.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
GetStructureMode | Gets the state of the 2D Structure mode for a database.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
SetReferenceLockMode | Sets the state of the 2D Structure reference lock mode for a database.
SetStructureMode | Sets the state of the 2D structure mode for a database.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.
UpdateEntities | Updates 2D structure with entity changes in model space.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2DStructureMgr5 Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr5 Members Properties
IMcad2DStructureMgr5 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.
SelectionLockMode | Property that specifies the state of the 2D Structure selection lock mode.
SelectionOrderMode | Property that specifies the state of the 2D Structure selection order mode.
StartTransaction | Starts a new transaction and returns an McadTransaction object.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface > IMcad2DStructureMgr5 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcad2DStructureMgr Members
Legend
Property
read only
Method


IMcad2DStructureMgr Members Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr Members Methods
IMcad2DStructureMgr Members Legend
Methods
Name | Description
AddNewAnnotationViewDefinition | Create an annotation view and definition based on the specified component definition and component view definitions.
AddNewComponentDefinition | Creates a new component definition in mechanical structure.
AddNewComponentView | Creates a new component view in mechanical structure.
AddNewComponentViewDefinition | Creates a new component view definition in mechanical structure.
AddNewFolder | Creates a new folder in mechanical structure.
AddNewFolderDefinition | Creates a new folder definition in mechanical structure.
CopyComponentFromDatabase | Copies a component definition from the AcadDatabase database into the current document. The newly created component definition is returned.
CopyFolderFromDatabase | Copies a folder definition from the AcadDatabase database into the current document. The newly created folder definition is returned.
Create2dComplexStdPartCompGroupDescriptor | Creates a new empty 2D complex standard part descriptor.
Create2dComponentDescriptor | Creates a new empty 2D component descriptor.
Create2dStdPartComponentDescriptor | Creates a new empty 2D standard part component descriptor.
CreateBlocksFromStructure | Migrates the 2D structure component views and folders to blocks.
CreateComponentViewDescriptor | Creates a new empty component view descriptor.
CreateFolderDescriptor | Creates a new empty folder descriptor.
CreateStructureFromBlocks | Creates an array of 2D structure component or folder descriptors based on existing block definitions.
ExternalStructureDatabases | Gets a list of AcadDatabase objects that correspond to the xref database referenced by this 2D structure.
GetComplexStdPartsForMigr | Gets the array of complex standard part (screw connection and part feature) component descriptors to be migrated to 2D structure.
GetComplexStdPartViewsForMigr | Gets the array of complex standard part (screw connection and part feature) power object view group descriptors to be migrated to 2D structure.
GetComponentDefinitions | Returns a list of component definitions in the current document or in the specified database.
GetComponentViewDefinitions | Returns a list of component view definitions in the current document or in the specified database.
GetFolderDefinitions | Gets all local folder definitions in 2D structure, plus any external folder definitions that are referenced from the host if the Database element is specified.
GetFolderPowerObjectsForMigr | Gets the array of power object folder descriptors to be migrated to 2D structure.
GetNextAnnotationViewDefinitionName | Gets the next unique annotation view definition name based on a specified component definition.
GetNextComponentDefinitionName | Gets the name of the next unique component definition based on the specified name.
GetNextFolderDefinitionName | Gets the name of the next unique folder definition based on a specified name.
GetSelection | Get the currently selected folders and/or component views in 2D structure.
GetShaftsForMigr | Gets the array of shaft component group descriptors to be migrated to 2D structure.
GetSingleStdPartComponentsForMigr | Gets the array of single standard component descriptors to be migrated to 2D structure.
GetSingleStdPartViewsForMigr | Gets the array of single standard part view descriptors to be migrated to 2D structure.
GetStructureFromEntity | Get the a McadFolder or McadComponentView for an entity in model space.
HasComponentDefinition | Checks whether a 2D structure has a component definition for a given name, TRUE, or not, FALSE.
HasFolderDefinition | Checks whether a 2D structure has a folder definition for a given name, TRUE, or not, FALSE.
Highlight | Highlight the McadFolders collection which contains one or more and/or folders or component views in 2D structure.
Is2DStructureEnabled | Checks whether drawings are 2D structure enabled, TRUE, or not, FALSE.
IsEntityAllowed | Determines whether entities are allowed in 2D structure, TRUE, or not, FALSE.
IsFreeEntity | Check whether an entity is a free entity, TRUE, or not, FALSE.
IsInActiveTarget | Checks whether an entity is in the active target, TRUE, or not, FALSE.
IsStructureBlock | Checks whether a block is block structure rather than mechanical structure.
PurgeAll2DS | Purges all 2D structure definitions whose name matches the pattern.
PurgeAnnotationViewDefinitions | Purges all annotation view definitions whose name matches the pattern.
PurgeComponentDefinitions | Purges all component definitions whose name matches the pattern.
PurgeComponentViewDefinitions | Purges all component view definitions whose name matches the pattern.
PurgeFolderDefinitions | Purges all folder definitions whose name matches the pattern.
RestructureViews | Restructures the McadFolders collection that contains one or more folders and/or component views in 2D structure.
RootComponentDefinition | Gets the root, or top level component definition in which 2D structure components are inserted into in this document.
RootViewDefinition | Gets the root, or top level component view definition in which 2D structure component views are inserted into in this document.
Update | Forces an immediate update of 2D structure.
UpdateEntities | Updates 2D structure with entity changes in model space.


Methods

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcad2DStructureMgr Members Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcad2DStructureMgr Members Properties
IMcad2DStructureMgr Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
EditTarget | Sets or gets either a folder or component view in 2D structure as the edit target.


Properties

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAnnotationViewDefinition2 Members
Legend
Method
Property
read only


IMcadAnnotationViewDefinition2 Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2 Members Methods
IMcadAnnotationViewDefinition2 Members Legend
Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
AnnotationViewLabel | Returns annotation view label for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
AnnotationViewLabelPattern | Returns annotation view label pattern for subview of annotation view
Children | Gets the children of the folder definition.
CreateAnnotationViewLabel | Creates annotation view label for subview of annotation view
CreateAnnotationViewLabels | Creates annotation view label for subview of annotation view
Delete | Deletes the object being referenced.
EraseAnnotationViewLabel | Erase annotation view label for subview of annotation view
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
HasAnnotationViewLabel | Erase annotation view label for subview of annotation view
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAnnotationViewDefinition2 Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition2 Members Properties
IMcadAnnotationViewDefinition2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface > IMcadAnnotationViewDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAnnotationViewDefinition Members
Legend
Property
read only
Method


IMcadAnnotationViewDefinition Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition Members Methods
IMcadAnnotationViewDefinition Members Legend
Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Add an annotation view for the specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified child component view of this annotation view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAnnotationViewDefinition Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinition Members Properties
IMcadAnnotationViewDefinition Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
ComponentDefinition | Extracts the component definition that the annotation view is based on.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAnnotationViewDefinitions Members
Legend
Property
read only
Method


IMcadAnnotationViewDefinitions Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions Members Methods
IMcadAnnotationViewDefinitions Members Legend
Methods
Name | Description
Add | Appends a new annotation view definition to the collection.
Item | Gets the annotation view definition at the specified index.
Remove | Removes the specified annotation view definition from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAnnotationViewDefinitions Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewDefinitions Members Properties
IMcadAnnotationViewDefinitions Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of annotation view definitions in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface > IMcadAnnotationViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAnnotationViewLabel Members
Legend
Property
read only
Method


IMcadAnnotationViewLabel Members Methods

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel Members Methods
IMcadAnnotationViewLabel Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAnnotationViewLabel Members Properties

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewLabel Members Properties
IMcadAnnotationViewLabel Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelPattern | Property that returns/sets label pattern of annotation view label entity.
LabelText | Property that returns evaluated text defined by label pattern, this text is displayed by annotation view label entity.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface > IMcadAnnotationViewLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAnnotationViewStandard Members
Legend
Property
read only
Method


IMcadAnnotationViewStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard Members Methods
IMcadAnnotationViewStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAnnotationViewStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAnnotationViewStandard Members Properties
IMcadAnnotationViewStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LabelPattern | Property that returns/sets default label pattern of annotation view label entity.
LabelPatternVariables | Property that returns array of variables supported in label pattern.
LabelPosition | Property that specifies position of annotation view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface > IMcadAnnotationViewStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAttribute Members
Legend
Property
read only
Method


IMcadAttribute Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute Members Methods
IMcadAttribute Members Legend
Methods
Name | Description
FieldDescription | Gets the description for the specified attribute field.
FieldName | Gets the name of the specified attribute field.
FieldType | Gets the data type held by the specified field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
FieldValue32 | Specifies the data value for the specified attribute field.
GetFieldIndex | Gets the index associated with the specified attribute field name.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAttribute Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttribute Members Properties
IMcadAttribute Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ClassName | Gets the name of the attribute's class definition.
Document | Gets the document containing this object.
FieldCount | Gets the number of fields in the attribute.
Holders | Gets references to the object that this attribute is attached to.
ObjectID | Gets the object ID of the attribute object.
ObjectID32 | Gets the object ID of the attribute object.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface > IMcadAttribute Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAttributeField Members
Legend
Property
read only


IMcadAttributeField Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeField Members Properties
IMcadAttributeField Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Description | Specifies the text description or comment describing the contents of the attribute field.
FieldType | Specifies the data type held by the specified attribute field.
Name | Specifies the name of the attribute field.
Static | Specifies whether the fields data is static, TRUE, or shared across all instances of the attribute, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface > IMcadAttributeField Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAttributeFields Members
Legend
Property
read only
Method


IMcadAttributeFields Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields Members Methods
IMcadAttributeFields Members Legend
Methods
Name | Description
Add | Appends an attribute field to the collection.
Item | Gets the attribute field at the specified index.
Remove | Removes the specified attribute field from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAttributeFields Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributeFields Members Properties
IMcadAttributeFields Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of attribute fields in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface > IMcadAttributeFields Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadAttributes Members
Legend
Property
read only
Method


IMcadAttributes Members Methods

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes Members Methods
IMcadAttributes Members Legend
Methods
Name | Description
Add | Appends an attribute to a the collection.
Item | Gets the attribute at the specified index.
Remove | Removes the specified attribute from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadAttributes Members Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadAttributes Members Properties
IMcadAttributes Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of items in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface > IMcadAttributes Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBalloon Members
Legend
Property
read only
Method


IMcadBalloon Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon Members Methods
IMcadBalloon Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AppendBOMItem | Appends the specified BOM item to the collection of items referenced by this balloon.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveBOMItem | Removes the specified bill of materials item from the collection of items referenced by this balloon.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBalloon Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloon Members Properties
IMcadBalloon Members Legend
Properties
Name | Description
AttachmentType | Specifies the leader attachment point type for balloons created by a specific balloon standard.
BalloonType | Specifies the default pattern of balloons created by a specific standard.
BOM | Specifies the bill of materials table referenced by a specific balloon.
BOMItems | Specifies the collection of bill of material items referenced by a specific balloon.
CollectionType | Specifies the alignment type of the balloon's collection.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlock | Specifies the custom block used by a specific balloon.
CustomBlockName | Specifies the name of the custom block used by a specific balloon.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether a specific balloon is displayed using a custom block, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface > IMcadBalloon Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBalloons Members
Legend
Property
read only
Method


IMcadBalloons Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons Members Methods
IMcadBalloons Members Legend
Methods
Name | Description
Add | Appends a new balloon to the collection.
Item | Gets the specific balloon from the collection.
Remove | Removes the specified balloon from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBalloons Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloons Members Properties
IMcadBalloons Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of balloons in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface > IMcadBalloons Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBalloonStandard2 Members
Legend
Property
read only
Method


IMcadBalloonStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard2 Members Methods
IMcadBalloonStandard2 Members Legend
Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBalloonStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard2 Members Properties
IMcadBalloonStandard2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.
TrueColor | Specifies the true color of balloons referencing this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface > IMcadBalloonStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBalloonStandard Members
Legend
Property
read only
Method


IMcadBalloonStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard Members Methods
IMcadBalloonStandard Members Legend
Methods
Name | Description
RemoveColumn | Removes the column at the specified index from the BOM table displayed by balloons referencing the pertinent standard.
SetToDefaults | Sets the properties of the standard balloon symbol to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBalloonStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBalloonStandard Members Properties
IMcadBalloonStandard Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ArrowType | Specifies the leader arrow type for balloon symbols based on this standard.
AttachmentType | Specifies the leader attachment point type for the balloons created from this standard.
AuxiliaryArrowType | Specifies the auxiliary arrow type for balloon symbols created by this standard.
BalloonType | Specifies the type of the balloons referencing this standard.
BOMStandard | Gets the bill of materials standard object referenced by balloons on this balloon standard.
Color | Specifies the color of balloons referencing this standard.
ColumnList | Specifies the columns at a specific index that are shown in the balloon for the current BalloonType . The number of column indices should not exceed the number specified by the MaximumColumns property.
CustomBlockName | Specifies the custom block used for the balloons referencing this standard.
IsAuxiliaryArrowUsed | Specifies whether the balloon symbols referencing this standard are using the auxiliary arrow, TRUE, or not, FALSE.
IsCustomBlockUsed | Specifies whether balloons created by this standard defaults to be displayed using a custom block, TRUE, or not, FALSE.
MaximumColumns | Specifies the maximum number of columns that can be specified for this BalloonType .
Revision | Specifies the revision version of this balloon standard.
RevisionYear | Specifies the revision version year of this balloon standard.
TextHeight | Specifies the height of text in balloon symbols created by on this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface > IMcadBalloonStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOM2 Members
Legend
Method
Property
read only


IMcadBOM2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2 Members Methods
IMcadBOM2 Members Legend
Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
Items
Specifies the collection of bill of materials items contained in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOM2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM2 Members Properties
IMcadBOM2 Members Legend
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface > IMcadBOM2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOM3 Members
Legend
Property
read only
Method


IMcadBOM3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3 Members Methods
IMcadBOM3 Members Legend
Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOM3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM3 Members Properties
IMcadBOM3 Members Legend
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface > IMcadBOM3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOM4 Members
Legend
Method
Property
read only


IMcadBOM4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM4 Members Methods
IMcadBOM4 Members Legend
Methods
Name
Description
AddItem
Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem
Creates an unassociated item entry and adds it to the BOM table.
applySort
Sort the BOM table in an ascending or descending order from the first key, the second key, to the third key.
GetProperties
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetProperties32
Get the properties of a BOM representation, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM representation
GetStructuredChildItems
Gets the immediate child items of a BOM item in a Structured BOM table.
GetStructuredParentItem
Gets the parent item of the specified child item in the structured BOM representation.
Items
Specifies the collection of bill of materials items contained in the BOM table.
MergeItems
Merges the specified BOM items into one row in the BOM table.
SetProperties
Set the properties of a BOM table, including:

  • Expanded or Structured
  • If Structured, whether or not to display the assembly path
  • If Structured and Use Assembly Path, the separator used in the assembly path.
  • Drawing layout associated with the BOM table
  • Whether to regenerate the entire drawing and compute the screen coordinates and view resolutions for all drawing objects
SplitItem
Splits a row of the bill of materials (BOM) into two items.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOM4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM4 Members Properties
IMcadBOM4 Members Legend
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
IsBorder | Checks whether the BOM table is a Border BOM table, TRUE, or not, FALSE.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface > IMcadBOM4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOM Members
Legend
Property
read only
Method


IMcadBOM Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM Members Methods
IMcadBOM Members Legend
Methods
Name | Description
AddItem | Creates a BOM item for the part reference and adds it to the BOM table.
AddUnassociatedItem | Creates an unassociated item entry and adds it to the BOM table.
Items | Specifies the collection of bill of materials items contained in the BOM table.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOM Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOM Members Properties
IMcadBOM Members Legend
Properties
Name | Description
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
PartLists | Gets the list of parts lists associated to the BOM table.
Target | Gets the target definition of a BOM table.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface > IMcadBOM Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMItem2 Members
Legend
Property
read only
Method


IMcadBOMItem2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2 Members Methods
IMcadBOMItem2 Members Legend
Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMItem2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem2 Members Properties
IMcadBOMItem2 Members Legend
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface > IMcadBOMItem2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMItem3 Members
Legend
Property
read only
Method


IMcadBOMItem3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3 Members Methods
IMcadBOMItem3 Members Legend
Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMItem3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem3 Members Properties
IMcadBOMItem3 Members Legend
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface > IMcadBOMItem3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMItem4 Members
Legend
Method
Property
read only


IMcadBOMItem4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4 Members Methods
IMcadBOMItem4 Members Legend
Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetAttribute | Gets the BOM attribute of a specified key.
GetBomOverride | Method that checks if there is a bom override for the specified attrib/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetCalculatedQuantity | Gets the calculated quantity regardless of the AutoCalc flag.
GetItemDefinition | Gets the definitions of the specified BOM items.
GetItemDefinition32 | Gets the definitions of the specified BOM items.
GetItemPartDefinition | The method replaces the previous GetItemDefinition method.
GetItemPartDefinition32 | The method replaces the previous GetItemDefinition32 method.
GetPartBalloons | Gets the attached balloons on the parts.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveAttribute | Method to remove the local attribute value if any from this bom item. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveReference | Removes the specified part reference from this BOM item.
SetAttribute | Sets an BOM attribute value at the specified attribute key.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMItem4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem4 Members Properties
IMcadBOMItem4 Members Legend
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
ExcludeFromPartList | Checks whether this BOM item is excluded from the parts list, TRUE, or not, FALSE.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Phantomed | Checks whether this BOM item is associated with a phantom part, TRUE, or not, FALSE.
Quantity | Specifies the quantity of a BOM item.
SortPriority | Property that indicates the priority of the item for purpose of sorting.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface > IMcadBOMItem4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMItem Members
Legend
Property
read only
Method


IMcadBOMItem Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem Members Methods
IMcadBOMItem Members Legend
Methods
Name | Description
AddReference | Adds the specified part references to this BOM item.
GetReferences | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
GetReferences32 | Gets all the part references associated with a specified BOM item. This method returns an array of arrays of object IDs and the number of items for each part reference in the Items element.
ReferenceExists | Determines whether the specified part reference is associated with this BOM item, TRUE, or not, FALSE.
RemoveReference | Removes the specified part reference from this BOM item.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMItem Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItem Members Properties
IMcadBOMItem Members Legend
Properties
Name | Description
AutoCalculateEnabled | Specifies whether the automatic calculation for the quantity of part references to this BOM item is enabled, TRUE, or not, FALSE, usually obtained from the McadBOM > SetProperties method.
Balloons | Specifies the balloon symbols associated with this BOM item.
BOM | Specifies the BOM table that this BOM item is a member of.
Data | Specifies the BOM table data. The data is represented as a two dimensional array of strings of key value pairs.
Expanded | Specifies whether this expandable BOM item is expanded, TRUE, or not, FALSE.
IsExpandable | Specifies whether this BOM item is expandable, TRUE, or not, FALSE.
ItemNumber | Specifies the item number for this BOM item, usually obtained from the McadBOM > AddItem method.
Quantity | Specifies the quantity of a BOM item.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface > IMcadBOMItem Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMItems Members
Legend
Property
read only
Method


IMcadBOMItems Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems Members Methods
IMcadBOMItems Members Legend
Methods
Name | Description
Add | Appends a specified BOM item to this BOM database table collection.
Item | Specifies the BOM item at a specified index from this BOM database table collection.
Remove | Removes the specified BOM item from this McadBOMItems collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMItems Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMItems Members Properties
IMcadBOMItems Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the number of items in a McadBOMItems collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface > IMcadBOMItems Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMMgr2 Members
Legend
Property
read only
Method


IMcadBOMMgr2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2 Members Methods
IMcadBOMMgr2 Members Legend
Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMMgr2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr2 Members Properties
IMcadBOMMgr2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMMgr3 Members
Legend
Method
Property
read only


IMcadBOMMgr3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr3 Members Methods
IMcadBOMMgr3 Members Legend
Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMMgr3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr3 Members Properties
IMcadBOMMgr3 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface > IMcadBOMMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMMgr4 Members
Legend
Method
Property
read only


IMcadBOMMgr4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr4 Members Methods
IMcadBOMMgr4 Members Legend
Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddBorderBOMTable | Creates a new border BOM database with a given border.
AddPartData | Creates a part data entry for the specified part reference.
AddPartGrfDef | Add graphical definition such as Part Reference or Block Reference, to represent the same part.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
ExportBOM2 | Exports the BOM table to a file of a specific format.
ExportPartList | Exports the parts list to a file of a specific format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetAllPartReferences | Gets all the part references from the specified database.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetBOMTableByCompDefHandle | Gets the specified BOM table associated with the handle of a component definition
GetBOMTableByCompDefId | Gets the BOM table from a given component definition ID.
GetBOMTableByCompDefId32 | Gets the BOM table from a given component definition ID.
GetBOMTableByName | Gets the BOM table from the specified name.
GetBorderBOMTable | Gets a border BOM database from a given border.
GetEvaluatedPartData | Gets the BOM attributes for the specified part
GetPartAttribute | Gets the BOM attribute associated with a given key of a specified part.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
GetSheetBOMTable | Gets the BOM table associated to a specific paper space.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
ImportBOM2 | Imports the data in a file of the specified format into the BOM table.
ImportPartList | Imports the data in a file of the specified format into the parts list.
RemoveBOMTable | Removes the specified BOM table.
RemovePartGrfDef | Removes the graphical definition such as Part Reference or Block Reference, from the part reference.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartAttribute | Sets the BOM attribute associated with a given key of a specified part.
SetPartData | Sets the data entry associated with the specified part reference.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMMgr4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr4 Members Properties
IMcadBOMMgr4 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentBOM | Gets or sets the current BOM table.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface > IMcadBOMMgr4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMMgr Members
Legend
Property
read only
Method


IMcadBOMMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr Members Methods
IMcadBOMMgr Members Legend
Methods
Name | Description
AddBOMTable | Adds a BOM table for the specified target block. Each target block can have only one BOM table associated with it.
AddPartData | Creates a part data entry for the specified part reference.
BOMTableExists | Determines whether a BOM table is associated with this block target object or a specified block target name, TRUE, or not, FALSE.
ExportBOM | Exports the BOM table data to a specified file in a specified format.
GetAllBOMTables | Gets all of the BOM tables in the document.
GetBOMTable | Gets the specified BOM table associated with the specified block target.
GetPartData | Gets the data entry associated with a specified part reference. The part reference is specified as the part reference symbol, block, or block reference of the part instance.
ImportBOM | Imports the BOM table data from the specified file. The new BOM table data are added, with no data lost.
RemoveBOMTable | Removes the specified BOM table.
SelectBOMEntity | Prompts for the selection of part references.
SelectBOMEntity32 | Prompts for the selection of part references.
SetPartData | Sets the data entry associated with the specified part reference.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMMgr Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMMgr Members Properties
IMcadBOMMgr Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for this document.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface > IMcadBOMMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMs Members
Legend
Property
read only
Method


IMcadBOMs Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs Members Methods
IMcadBOMs Members Legend
Methods
Name | Description
Add | Adds a BOM table to the BOM database collection.
Item | Gets the BOM table at a specified index from the BOM database collection.
Remove | Removes the BOM table at a specified index from the BOM database collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMs Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMs Members Properties
IMcadBOMs Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the BOM tables in a BOM database collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface > IMcadBOMs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMStandard2 Members
Legend
Method
Property
read only


IMcadBOMStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard2 Members Methods
IMcadBOMStandard2 Members Legend
Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
GetUOMName | Get the available UOM (units of measure).
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard2 Members Properties
IMcadBOMStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface > IMcadBOMStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBOMStandard Members
Legend
Property
read only
Method


IMcadBOMStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard Members Methods
IMcadBOMStandard Members Legend
Methods
Name | Description
AddColumn | Creates and adds a column definition of the specified type, data type, and caption to the BOM standard.
GetColumn | Gets the column at the specified item number, column name, column caption, column index, or column type. One element must be specified.
MoveColumn | Moves the specified column at a specified index to a new index.
RemoveColumn | Removes the specified column from this BOM standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBOMStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBOMStandard Members Properties
IMcadBOMStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BalloonStandard | Gets the specific balloon standard that is associated with a BOM standard.
ColumnCount | Gets the number of columns specified for this BOM standard.
Columns | Gets the columns definitions for a BOM standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PartListStandard | Gets the specific part list standard that is associated with a BOM standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface > IMcadBOMStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBorder2 Members
Legend
Property
read only
Method


IMcadBorder2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2 Members Methods
IMcadBorder2 Members Legend
Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBorder2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder2 Members Properties
IMcadBorder2 Members Legend
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
BlockId | This is BlockId, a member of class IMcadBorder2.
BlockId32 | This is BlockId32, a member of class IMcadBorder2.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface > IMcadBorder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadBorder Members
Legend
Property
read only
Method


IMcadBorder Members Methods

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder Members Methods
IMcadBorder Members Legend
Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the border.


Methods

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadBorder Members Properties

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadBorder Members Properties
IMcadBorder Members Legend
Properties
Name | Description
Attributes | Property that specifies all the attributes for the border.
Extends | Property that returns the extents of the border.
Name | Property that specifies the name identifier of the border.
Position | Property that returns the position of the border.


Properties

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface > IMcadBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface > IMcadColumnDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadColumnDefinition2 Members
Legend
Property
read only


IMcadColumnDefinition2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface > IMcadColumnDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition2 Members Properties
IMcadColumnDefinition2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface > IMcadColumnDefinition2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadColumnDefinition3 Members
Legend
Property
read only
Method


IMcadColumnDefinition3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3 Members Methods
IMcadColumnDefinition3 Members Legend
Methods
Name | Description
GetPreDefinedList | Retrieves the predefined list associated with this definition if any.
RemovePreDefinedList | Removes the predefined list associated with this definition.
SetPreDefinedList | Sets a predefined list to be associated with this definition.


Methods

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadColumnDefinition3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition3 Members Properties
IMcadColumnDefinition3 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
BOMCaptionAlignment | Property that specifies the BOM column caption alignment type.
BOMDataAlignment | Property that specifies the BOM column data alignment type.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
IsPreDefinedList | Indicates whether this definition is associated with a pre defined list.
IsVisible | Checks whether the BOM table is visible, TRUE, or not, FALSE.
Name | Specifies the name of the column in a BOM database standard object.
PartListCaptionAlignment | Property that specifies the Parts List column caption alignment type.
PartListDataAlignment | Property that specifies the Parts List column data alignment type.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface > IMcadColumnDefinition3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadColumnDefinition Members
Legend
Property
read only


IMcadColumnDefinition Members Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinition Members Properties
IMcadColumnDefinition Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Caption | Specifies the caption for the column.
CaptionAlignment | Property that specifies the BOM and Parts List column caption alignment types.
ColumnType | Specifies the type of the column.
DataAlignment | Property that specifies the BOM and Parts List column data alignment types.
DataType | Specifies the type of the data that the column specifies.
Equivalents | Specifies the list of equivalence strings for this column.
Index | Specifies the index of the column.
Name | Specifies the name of the column in a BOM database standard object.
Precision | Specifies the number of decimal places of precision for the data. The precision only applies when the DataType is sbReal.
Size | Specifies the data size for the column.
Width | Specifies the width of the column.


Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface > IMcadColumnDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadColumnDefinitions Members
Legend
Property
read only
Method


IMcadColumnDefinitions Members Methods

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions Members Methods
IMcadColumnDefinitions Members Legend
Methods
Name | Description
Add | Appends a specified column to this BOM database table.
Item | Gets the column at a specified index from this BOM database table.
Remove | Removes the column at a specified index from this BOM database table.


Methods

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadColumnDefinitions Members Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadColumnDefinitions Members Properties
IMcadColumnDefinitions Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of column definitions in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface > IMcadColumnDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComplexHideSituation Members
Legend
Property
read only
Method


IMcadComplexHideSituation Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation Members Methods
IMcadComplexHideSituation Members Legend
Methods
Name | Description
AddLevel | Adds new level to complex hide, new hide situation pNewHide is created for the new level, or existing hide situation is used as level if it was specified in pNewHide.
Delete | Deletes the object being referenced.
Explode | Converts complex hide situation to normal hide situations. Each levels of complex hide create simple independent hide situation. The foreground and background will be set from the position of the level in the complex hide situation.
Highlight | Highlights the topological entity on the model.
InitFromHide | Initializes the complex hide situation from the specified normal hide situation. The complex hide will has two levels. First level is foreground of the specified hide and the second level is background of the specified hide.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
LookupLevelName | Looks up the level with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
MoveLevel | Changes the position of the level (hide) within the complex hide levels.
RemoveLevel | Removes the specified level (hide) from the complex hide situation.
RemoveLevelByIdx | Removes the level (hide) with the given index from the complex hide situation.
Reverse | Reverses the order of all levels in the complex hide situation.
UpdateBgSelection | Recalculates the background selections based on the current foreground selections.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComplexHideSituation Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituation Members Properties
IMcadComplexHideSituation Members Legend
Properties
Name
Description
Application
Gets the AcadmApplication object.
Concealed
Gets or sets whether the complex hide situation is concealed, TRUE, or not, FALSE.
Definition
Gets or sets the parent folder definition for this complex hide situation.
Document
Gets the corresponding McadDocument from the specified host application's document.
Editable
Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
HiddenLinesInvisible
Gets whether the hidden lines are invisible, TRUE, or dashed, FALSE.
HideAppropriateObjectsOnly
Specifies how background objects are processed:

  • TRUE: A filter is applied and objects that have their 'Usage in Hide' property set to 'Ignore in Hide' or 'Foreground only' (via the Layer/Object property).
  • FALSE: All objects selected for the background are hidden.
HideSituations
Returns all hide situations from this complex hide situation.
IsModifiedStandardPartHide
Gets whether the complex hide situation has been modified by users, TRUE, or not, FALSE.
IsStandardPartHide
Gets whether hide situations was automatically created by standard parts, TRUE, or not, FALSE.
LevelCount
Returns the number of levels in complex hide situation.
Name
Gets or sets the complex hide situation.
NextLevelName
Returns the default name for the next new level in the complex hide situation.
Suppressed
Gets whether the complex hide situation is suppressed, TRUE, or not, FALSE.
SysName
Gets the complex hide situation system name.
WasErased
Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComplexHideSituations Members
Legend
Property
read only
Method


IMcadComplexHideSituations Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations Members Methods
IMcadComplexHideSituations Members Legend
Methods
Name | Description
Add | Appends an complex hide situation to the collection.
Item | Gets the complex hide object at the specified index from the collection.
Remove | Removes the specified Complex hide from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComplexHideSituations Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComplexHideSituations Members Properties
IMcadComplexHideSituations Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of complex hide situations in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface > IMcadComplexHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponent Members
Legend
Property
read only
Method


IMcadComponent Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent Members Methods
IMcadComponent Members Legend
Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ClearOverrideProperties | Clears all override properties of this component if any exists.
ColorOverride | Sets the color override for all the component's views.
ContainingComponent | Returns the lowest level component that this object is inserted into.
CopyDefinition | Creates a copy of the definition for the specified folder or component view as in AMSCOPYDEF.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
GetComponentInDefinition | Gets the component equivalent to this component in the scope of the component's owning component definition.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for all the component's views.
RemoveAttribute | Removes the specified attribute from this component.
ReplaceDefinition | Replaces a specified component with a new definition as in AMSREPLACEDEF.
SortChildren | Sorts the children of this component.
VisibilityOverride | Sets the visibility override for all the component's views.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponent Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponent Members Properties
IMcadComponent Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the occurrences of the children of the component.
ComponentViews | Gets all component views contained in this component.
Definition | Gets the definition for the component.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
hasExternalDef | Gets whether this component has external definitions, TRUE, or not, FALSE.
HasGhostViews | Specifies whether a component has a ghost component view, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether this component has override properties, TRUE, or not, FALSE.
is2D | Gets whether this component is in 2D structure.
Name | Specifies the name associated with the referenced object.
Owner | Gets the definition of the owner for the component.
Position |
Reference | Specifies whether a component is referenced by an external file.
Visible | Gets or sets the visibility of the component.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentDefinition Members
Legend
Property
read only
Method


IMcadComponentDefinition Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition Members Methods
IMcadComponentDefinition Members Legend
Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
AddComponent | Adds an instance of the specified component definition to this component definition.
CopyDefinition | Creates a copy of the component definition.
Delete | Deletes the object being referenced.
Externalize | Externalizes the component definition to the specified file name.
GetAttributes | Gets the attributes attached to the object being referenced.
GetInstances | Get all instances of this definition in a given scope.
GetNextComponentViewDefinitionName | Gets the name of the next unique component view definition based on the specified name.
HasComponentViewDefinition | Checks whether a component view definition with the specified name exists in a component definition, TRUE, or not, FALSE.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
Localize2DS | Localizes the component definition into the document.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.
RemoveComponent | Removes the specified component instance from the subassembly component definition.
SortChildren | Sorts the children in this component definition.
Update | Causes an update or a regeneration of any pending changes on the object.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentDefinition Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinition Members Properties
IMcadComponentDefinition Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Children | Gets the component instances inserted into a subassembly component definition.
ComponentViewDefinitions | Gets the collection of component view definitions contained in this component definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
ExternalPath | Specifies the file name including path for the drawing used by an external component definition.
is2D | Gets whether this component definition is in 2D structure.
is2DAssembly | Gets whether this component definition is associated with 2D assembly.
IsExternal | Gets whether the component definition is to an externally referenced drawing.
isFeature | Gets whether this component definition is associated with a feature.
IsLeafNode | Gets whether the component definition is a leaf node component definition.
IsRoot | Gets whether the component definition is the root component definition.
isShaft | This is isShaft, a member of class IMcadComponentDefinition.
isStandardPart | This is isStandardPart, a member of class IMcadComponentDefinition.
Name | Gets and sets the name of the component definition.
PhantomState | Gets the phantom state of this component definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface > IMcadComponentDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentDefinitions Members
Legend
Property
read only
Method


IMcadComponentDefinitions Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions Members Methods
IMcadComponentDefinitions Members Legend
Methods
Name | Description
Add | Appends a new component definition to the collection.
Item | Gets the component definition at the specified index from the collection.
Remove | Removes the specified component definition from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentDefinitions Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentDefinitions Members Properties
IMcadComponentDefinitions Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component definitions in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface > IMcadComponentDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponents Members
Legend
Property
read only
Method


IMcadComponents Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents Members Methods
IMcadComponents Members Legend
Methods
Name | Description
Add | Appends a new component to the collection.
Item | Gets the component at the specified index from the collection.
Remove | Removes the specified component from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponents Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponents Members Properties
IMcadComponents Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of components in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface > IMcadComponents Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentView Members
Legend
Property
read only
Method


IMcadComponentView Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView Members Methods
IMcadComponentView Members Legend
Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsGhostView | Specifies whether a component view is a ghost component view, TRUE, or not, FALSE.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentView Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentView Members Properties
IMcadComponentView Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
Component | Gets the component of the component view.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
isFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface > IMcadComponentView Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentViewDefinition Members
Legend
Property
read only
Method


IMcadComponentViewDefinition Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition Members Methods
IMcadComponentViewDefinition Members Legend
Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddComponentView | Adds a component view to a specified component view definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveComponentView | Removes the specified component view from this component view definition.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentViewDefinition Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinition Members Properties
IMcadComponentViewDefinition Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsFeature | Gets whether the component view is the view of a feature, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
Owner | Gets the owner of this component definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface > IMcadComponentViewDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentViewDefinitions Members
Legend
Property
read only
Method


IMcadComponentViewDefinitions Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions Members Methods
IMcadComponentViewDefinitions Members Legend
Methods
Name | Description
Add | Appends a new component view definition to the collection.
Item | Gets the component view definition at the specified index from the collection.
Remove | Removes the specified component view definition from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentViewDefinitions Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDefinitions Members Properties
IMcadComponentViewDefinitions Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component view definitions in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface > IMcadComponentViewDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentViewDescriptor Members
Legend
Property
read only
Method


IMcadComponentViewDescriptor Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor Members Methods
IMcadComponentViewDescriptor Members Legend
Methods
Name | Description
CreateComponentView | Creates a new component view from this descriptor.
CreateFolder | Creates a new folder from the folder descriptor.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentViewDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViewDescriptor Members Properties
IMcadComponentViewDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Component | Gets and sets the component for the component view descriptor.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
FullViewName | Gets the full component name for this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface > IMcadComponentViewDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadComponentViews Members
Legend
Property
read only
Method


IMcadComponentViews Members Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews Members Methods
IMcadComponentViews Members Legend
Methods
Name | Description
Add | Appends a new component view to the collection.
Item | Gets the component view at the specified index from the collection.
Remove | Removes the specified component view from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadComponentViews Members Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadComponentViews Members Properties
IMcadComponentViews Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of component views in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface > IMcadComponentViews Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumIdentifier2 Members
Legend
Property
read only
Method


IMcadDatumIdentifier2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2 Members Methods
IMcadDatumIdentifier2 Members Legend
Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumIdentifier2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier2 Members Properties
IMcadDatumIdentifier2 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface > IMcadDatumIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumIdentifier3 Members
Legend
Property
read only
Method


IMcadDatumIdentifier3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3 Members Methods
IMcadDatumIdentifier3 Members Legend
Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadDatumIdentifier3.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadDatumIdentifier3.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumIdentifier3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumIdentifier3 Members Properties
IMcadDatumIdentifier3 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumNote | This is DatumNote, a member of class IMcadDatumIdentifier3.
FarSideStatus | This is FarSideStatus, a member of class IMcadDatumIdentifier3.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadDatumIdentifier3.
SymbolStandard | Specifies the symbol standard for a symbol.
ThreadNote | This is ThreadNote, a member of class IMcadDatumIdentifier3.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface > IMcadDatumIdentifier3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumStandard2 Members
Legend
Property
read only
Method


IMcadDatumStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard2 Members Methods
IMcadDatumStandard2 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard2 Members Properties
IMcadDatumStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
PointTrueColor | Specifies the true color of a point.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface > IMcadDatumStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumStandard Members
Legend
Property
read only
Method


IMcadDatumStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard Members Methods
IMcadDatumStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumStandard Members Properties
IMcadDatumStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of a datum standard's border line.
BorderLineTypeName | Specifies the name of the linetype of a datum identifier's border line.
DrawLeaderArrow | Specifies whether the leader arrow is drawn for a datum identifier, TRUE, or not, FALSE.
HatchAngle | Specifies the angle in radians for a hatch pattern in relation to the X axis of the current WCS coordinates.
HatchDistance | Specifies the distance between lines in the hatch pattern.
HiddenLeaderLineType | Specifies the linetype of a datum identifier's hidden leader line.
HiddenLeaderLineTypeName | Specifies the name of the linetype of a datum identifier's hidden leader line.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PointColor | Specifies the point color of datum identifiers referencing this standard.
PointSize | Specifies the point size of datum identifiers referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface > IMcadDatumStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumTarget2 Members
Legend
Property
read only
Method


IMcadDatumTarget2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2 Members Methods
IMcadDatumTarget2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetTargetAttach | Specifies the datum target to attach.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumTarget2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget2 Members Properties
IMcadDatumTarget2 Members Legend
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleCornerPoint | Specifies the rectangle corner point.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface > IMcadDatumTarget2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDatumTarget Members
Legend
Property
read only
Method


IMcadDatumTarget Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget Members Methods
IMcadDatumTarget Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDatumTarget Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDatumTarget Members Properties
IMcadDatumTarget Members Legend
Properties
Name | Description
CircleRadius | Specifies the radius of the circular termination of a datum target. This property is a only valid if the TargetType is sbCircular.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumValue | Specifies the value of the Datum field of the datum target.
DimensionValue | Specifies the dimension value for a datum target symbol.
DrawLine | Specifies whether the target line is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbLine.
DrawPoint | Specifies whether the point tick is drawn, TRUE, or not, FALSE. This property is a only valid if the TargetType is sbPoint.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LeaderLinetypeHidden | Specifies whether the datum target leader's linetype is hidden.
LineEndPoint | Specifies the end point of the line target.
LineFactor | Specifies the percentage along the TargetOrigin to the LineEndPoint for the leader start point.
LineMidPoint | Gets the midpoint of the line target, or the leader start point.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
RectangleAngle | Specifies the angle of the rectangular area target.
RectangleXSize | Specifies the X axis length of the rectangular area target.
RectangleYSize | Specifies the Y axis length of the rectangular area target.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TargetOrigin | Specifies the origin point of the datum target subsymbol.
TargetType | Specifies the termination type for a datum target.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface > IMcadDatumTarget Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDescriptor Members
Legend
Property
read only


IMcadDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDescriptor Members Properties
IMcadDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.


Properties

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface > IMcadDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDetailSymbol Members
Legend
Property
read only
Method


IMcadDetailSymbol Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol Members Methods
IMcadDetailSymbol Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateLabelEntity | Create detail symbol label.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetSourceGeometry | Set source geometry for the symbol.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDetailSymbol Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbol Members Properties
IMcadDetailSymbol Members Legend
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
BaseViewScale | Specifies scale of the base view.
CoordinateSystem | Specifies the coordinate system for the symbol.
CorrectionScaleFactor | Specifies scale factor when specify by factor.
DetailScale | Specifies scale of the detail View.
IsAssociativeDetail | Specifies whether to create associative details.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelEntity | Specifies the detail symbol label object.
LabelEntityOffset | Specifies the offset of the label.
LabelName | Specifies name of the label for the detail view.
LabelPattern | Specifies the label pattern for the detail view.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Radius | Specifies radius of the base view.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
SpecByAbsoluteScale | Specifies detail View to specify by absolute scale.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface > IMcadDetailSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDetailSymbolLabel Members
Legend
Property
read only
Method


IMcadDetailSymbolLabel Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel Members Methods
IMcadDetailSymbolLabel Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDetailSymbolLabel Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolLabel Members Properties
IMcadDetailSymbolLabel Members Legend
Properties
Name | Description
AnnotationOffset | Specifies offset of the annotation.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelAbove | Specifies position of the label.
LabelText | Property to get the evaluated pattern (with label name and scale).
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolEntity | Specifies the detail symbol object.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface > IMcadDetailSymbolLabel Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDetailSymbolStandard2 Members
Legend
Property
read only
Method


IMcadDetailSymbolStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2 Members Methods
IMcadDetailSymbolStandard2 Members Legend
Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
GetByStandard | Gets if the specified detail view property follow the standard.
SetByStandard | Sets if the specified detail view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDetailSymbolStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard2 Members Properties
IMcadDetailSymbolStandard2 Members Legend
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineColor | Specifies the color of the border line.
BorderLineLineType | Specifies the linetype of the border line.
BorderLineType | Specifies the linetype of the detail border.
BorderLineWeight | Specifies the lineweight of the border line.
BoundaryLineColor | Specifies the color of the boundary line.
BoundaryLineType | Specifies the linetype of the boundary line.
BoundaryLineWeight | Specifies the lineweight of the boundary line.
ConnectionLineColor | Specifies the color of the connection line.
ConnectionLineType | Specifies the linetype of the connection line.
ConnectionLineWeight | Specifies the lineweight of the connection line.
IdentifierOutsideBoundary | Specifies if the identifier is placed outside the boundary.
LabelAbove | Specifies position of the label.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern for the detail view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLabel | Specifies if show label.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface > IMcadDetailSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDetailSymbolStandard Members
Legend
Property
read only
Method


IMcadDetailSymbolStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard Members Methods
IMcadDetailSymbolStandard Members Legend
Methods
Name | Description
AddAllowedScale | Add scale to the list of allowable scales.
EraseAllowedScales | Remove all allowable scales.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDetailSymbolStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDetailSymbolStandard Members Properties
IMcadDetailSymbolStandard Members Legend
Properties
Name | Description
AllowedScales | Specifies the list of allowable scales.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
BorderLineType | Specifies the linetype of the detail border.
LabelAbove | Specifies position of the label.
LabelPattern | Specifies the label pattern for the detail view.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ShowAnnotationLeader | Specifies to show the annotation leader.
ShowBorder | Specifies to show the view border.
ShowLeader | Specifies to show the leader.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface > IMcadDetailSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDocument Members
Legend
Property
read only


IMcadDocument Members Properties

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocument Members Properties
IMcadDocument Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
LayerGroupMgr | Returns the layer group manager for the document.
LayerObjectMgr | This is LayerObjectMgr, a member of class IMcadDocument.
StructureMgr2D | Gets the 2D structure manager object for the document.
Utility | Gets the utility object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface > IMcadDocument Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDocuments Members
Legend
Property
read only
Method


IMcadDocuments Members Methods

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments Members Methods
IMcadDocuments Members Legend
Methods
Name | Description
Item | Gets the document at the specified index from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadDocuments Members Properties

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocuments Members Properties
IMcadDocuments Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of documents in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface > IMcadDocuments Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface > IMcadDocumentVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadDocumentVersion Members
Legend
Method


IMcadDocumentVersion Members Methods

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface > IMcadDocumentVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadDocumentVersion Members Methods
IMcadDocumentVersion Members Legend
Methods
Name | Description
GetVersionNumber | Version of AutoCAD Mechanical that saved the file.


Methods

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface > IMcadDocumentVersion Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


Legend

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadEdge Members
Legend
Property
read only
Method


IMcadEdge Members Methods

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge Members Methods
IMcadEdge Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadEdge Members Properties

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdge Members Properties
IMcadEdge Members Legend
Properties
Name | Description
AllAround | Specifies the all-around designation for the edge symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
Direction | Property that specifies if the direction of the edge symbol's size is defined.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Majority | Specifies the appearance of the majority symbol.
MaxValue | Specifies the value of the upper boundary for the edge symbol.
MinValue | Specifies the value of the lower boundary for the edge symbol.
NewSymbolRev | Specifies if the edge symbol follows new standard revision.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SignValue | Specifies the sign ("+" or "-") for the edge symbol.
Standard | Gets the standard this symbol is used in.
StandardNumber | Specifies if the edge symbol displays the standard number.
SymbolStandard | Specifies the symbol standard for a symbol.
UndefsizeDirection | Property that specifies the direction for the edge symbol's undefined size.


Properties

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface > IMcadEdge Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadEdgeLibraryObject Members
Legend
Property
read only
Method


IMcadEdgeLibraryObject Members Methods

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject Members Methods
IMcadEdgeLibraryObject Members Legend
Methods
Name | Description
RequirementValue | Property to get the main requirement value for the Edge symbol type.


Methods

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadEdgeLibraryObject Members Properties

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeLibraryObject Members Properties
IMcadEdgeLibraryObject Members Legend
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" indication.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsDefinedDirection | Get if the direction of the symbol library object's size is defined.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
StandardNumber | Get the usage of the Standard label note for the symbol library object.
symbolStandardClassName | Get the symbol standard class name.
UndefsizeDirection | Get the direction for the symbol library object's undefined size.


Properties

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface > IMcadEdgeLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadEdgeStandard Members
Legend
Property
read only
Method


IMcadEdgeStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard Members Methods
IMcadEdgeStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadEdgeStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadEdgeStandard Members Properties
IMcadEdgeStandard Members Legend
Properties
Name | Description
AllAroundAllowed | Specifies whether the all-around designation is allowed in the edge symbol.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
FullList | Specifies whether the majority symbol is full list or simplified.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether the majority symbol is allowed in the edge symbol.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
StandardNumAllowed | Specifies whether the standard number is allowed to be displayed in the edge symbol.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface > IMcadEdgeStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFCFLibraryObject Members
Legend
Property
read only
Method


IMcadFCFLibraryObject Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject Members Methods
IMcadFCFLibraryObject Members Legend
Methods
Name | Description
RequirementValue | Property to get the main requirement value for the FCF symbol type.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFCFLibraryObject Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFLibraryObject Members Properties
IMcadFCFLibraryObject Members Legend
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
Symbol | Get the geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol2 | Get the secondary geometric dimensioning and tolerancing symbol of a feature control frame library object.
Symbol3 | Get the third geometric dimensioning and tolerancing symbol of a feature control frame library object.
symbolStandardClassName | Get the symbol standard class name.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface > IMcadFCFLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFCFStandard2 Members
Legend
Property
read only
Method


IMcadFCFStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2 Members Methods
IMcadFCFStandard2 Members Legend
Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFCFStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard2 Members Properties
IMcadFCFStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadFCFStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFCFStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface > IMcadFCFStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFCFStandard Members
Legend
Property
read only
Method


IMcadFCFStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard Members Methods
IMcadFCFStandard Members Legend
Methods
Name | Description
GetSymbolImplementation | Gets the character string implementation representation for the specified symbol type referencing this feature control frame standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFCFStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFCFStandard Members Properties
IMcadFCFStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableAuxiliarySymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for auxiliary material removal modifiers in this standard.
AvailableGDTSymbols | Gets the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are available for geometric characteristics in this standard.
EndPadding | Specifies whether end padding is set to align similar zones of feature control frames referencing this standard, TRUE, or not, FALSE.
FrameGap | Specifies the gap for the annotation and the leader line of feature control frames referencing this standard.
GDTTextFont | Gets the name of the text font for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyle | Specifies the text style for Geometric Dimensioning and Tolerancing (GDT) symbols.
GDTTextStyleName | Specifies the name of the text style for Geometric Dimensioning and Tolerancing (GDT) symbols of feature control frames referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MergeDatum | Specifies whether the duplication of datum references for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeSymbol | Specifies whether the duplication of geometric symbols for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
MergeTolerance | Specifies whether the duplication of tolerances for feature control frames referencing this standard are merged, TRUE, or not, FALSE.
OfferedAuxiliarySymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for auxiliary modifiers for symbols created referencing this standard.
OfferedGDTSymbols | Specifies the list of Geometric Dimensioning and Tolerancing (GDT) symbols that are offered for geometric characteristics for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
SeparateDatumID | Specifies whether the datum identifier symbol is displayed separate.
SeparateProjected | Specifies whether the projected symbol is displayed separate.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface > IMcadFCFStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFeatureControlFrame2 Members
Legend
Property
read only
Method


IMcadFeatureControlFrame2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2 Members Methods
IMcadFeatureControlFrame2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFeatureControlFrame2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame2 Members Properties
IMcadFeatureControlFrame2 Members Legend
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface > IMcadFeatureControlFrame2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFeatureControlFrame3 Members
Legend
Property
read only
Method


IMcadFeatureControlFrame3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3 Members Methods
IMcadFeatureControlFrame3 Members Legend
Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFeatureControlFrame3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame3 Members Properties
IMcadFeatureControlFrame3 Members Legend
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface > IMcadFeatureControlFrame3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFeatureControlFrame4 Members
Legend
Property
read only
Method


IMcadFeatureControlFrame4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4 Members Methods
IMcadFeatureControlFrame4 Members Legend
Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddLeaderWithSurfIndLeader
This is AddLeaderWithSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AddSurfIndLeader
This is AddSurfIndLeader, a member of class IMcadFeatureControlFrame4.
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
GetSurfIndLeader
This is GetSurfIndLeader, a member of class IMcadFeatureControlFrame4.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
RemoveSurfIndLeader
This is RemoveSurfIndLeader, a member of class IMcadFeatureControlFrame4.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFeatureControlFrame4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame4 Members Properties
IMcadFeatureControlFrame4 Members Legend
Properties
Name | Description
BottomNoteValue | Specifies and places all notes related to the tolerance below the feature control frame symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadFeatureControlFrame4.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.
TopNoteValue | Specifies and places all notes related to the tolerance above the feature control frame symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface > IMcadFeatureControlFrame4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFeatureControlFrame Members
Legend
Property
read only
Method


IMcadFeatureControlFrame Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame Members Methods
IMcadFeatureControlFrame Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFeatureControlFrame Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureControlFrame Members Properties
IMcadFeatureControlFrame Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
DatumIDValue | Specifies the value of the Datum ID field of a feature control frame.
DatumPrimary2Value | Specifies the value of the secondary Datum1 field of the feature control frame.
DatumPrimary3Value | Specifies the value of the third Datum1 field of the feature control frame
DatumPrimaryValue | Specifies the value of the Datum1 field of a feature control frame.
DatumSecondary2Value | Specifies the value of the secondary Datum2 field of the feature control frame.
DatumSecondary3Value | Specifies the value of the third Datum2 field of the feature control frame
DatumSecondaryValue | Specifies the value of the Datum2 field of the feature control frame.
DatumTertiary2Value | Specifies the value of the secondary Datum3 field of the feature control frame.
DatumTertiary3Value | Specifies the value of the third Datum3 field of the feature control frame.
DatumTertiaryValue | Specifies the value of the Datum3 field of the feature control frame.
IsAllAround | Specifies whether the all around sign is added to a feature control frame symbol, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ProjectedValue | Specifies the value of the Projected Zone field of the feature control frame.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
Symbol | Specifies the geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol2 | Specifies the secondary geometric dimensioning and tolerancing symbol of a feature control frame.
Symbol3 | Specifies the third geometric dimensioning and tolerancing symbol of a feature control frame.
SymbolStandard | Specifies the symbol standard for a symbol.
Tolerance2Value | Specifies the value of the secondary Tolerance 1 field of a feature control frame.
Tolerance3Value | Specifies the value of the third Tolerance 1 field of the feature control frame.
ToleranceB2Value | Specifies the value of the secondary Tolerance 2 field of the feature control frame.
ToleranceBValue | Specifies the value of the Tolerance 2 field of the feature control frame.
ToleranceValue | Specifies the value of the Tolerance 1 field of the feature control frame.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface > IMcadFeatureControlFrame Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFeatureIdentifier2 Members
Legend
Property
read only
Method


IMcadFeatureIdentifier2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2 Members Methods
IMcadFeatureIdentifier2 Members Legend
Methods
Name
Description
AddLeader
Adds a leader with the specified nodes to a symbol.
AddStdCompliantLeader
Adds a primary leader with the following characteristics:

  1. The first leader segment is perpendicular to the attached object.
  2. Other leader segments are either horizontal or vertical.
  3. Draws surface extension line, if the arrowhead is not located on the attached object (specified by the arrowheadLocation parameter).
AttachGeometry
Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry
Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader
Gets the positions of the nodes of the specified leader.
GetLeaderAttachment
Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode
Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType
Specifies the leader arrow type for the selected symbol leaders.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderColor
Specifies the color of a symbol's leader line.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding
Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
LeaderLineType
Specifies the linetype for a specific symbol's leader.
MoveLeaderNode
Moves the specified leader node associated with a symbol to a new position.
RemoveLeader
Removes the specified leader from a symbol.
RemoveLeaderNode
Removes the specified leader nodes from the symbol's leader.
SetToDefaults
Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject
Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFeatureIdentifier2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFeatureIdentifier2 Members Properties
IMcadFeatureIdentifier2 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


Properties

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface > IMcadFeatureIdentifier2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolder2 Members
Legend
Property
read only
Method


IMcadFolder2 Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder2 Members Methods
IMcadFolder2 Members Legend
Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolder2 Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder2 Members Properties
IMcadFolder2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
OwningSpace | Returns owning space of view, model space or layout block table record
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface > IMcadFolder2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolder Members
Legend
Property
read only
Method


IMcadFolder Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder Members Methods
IMcadFolder Members Legend
Methods
Name | Description
AddEntities | Adds AutoCAD entities, such as lines, arcs, circles, text, and block references, to a folder or folder.
ClearLeaf | Modifies this path from Leaf path to Instance path.
ClearOverrideProperties | Clears all property overrides for the folder or component view if any exists.
ColorOverride | Sets the color override for the folder or component view.
CopyEntities | Copies the entities to this folder or component view as in Content - Copy.
CopyView | Copies the specified view to this view as in Content - Copy
CopyViewDefinition | Creates a copy of the definition for the specified folder or component view as in Break Link.
Delete | Deletes the object being referenced.
Explode | Explode the specified folder or component view to the model space.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsSubentityOf | Checks whether this is subentity of the specified pOther view.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
PredefinedReferenceOverride | Sets the predefined reference override for the folder or component view.
RemoveEntities | Removes AutoCAD entities, such as lines, arcs, circles, text, and block references, from a folder or folder.
ReplaceDefinition | Replace the definitions of a folder with another definition as in AMSREPLACEDEF.
VisibilityOverride | Sets the visibility override for the folder or component view.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolder Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolder Members Properties
IMcadFolder Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
BasePoint | This is BasePoint, a member of class IMcadFolder.
Children | Gets the occurrence of the children views of the folder.
ContextDefinition | Gets the definition in context that this path is expressed. It is the Master View definition in case of the full path.
Definition | Gets the definition of the folder.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Entities | Gets the entities of the folder in model space.
Entities32 | Gets the entities of the folder in model space.
ExtentsMaximum | Gets the upper right point of the extents for the folder or component view
ExtentsMinimum | Gets the lower left point of the extents for the folder or component view.
GeomPathName | Gets the occurrence path of the folder.
HasExternalDef | Checks whether this folder has an external folder definition, TRUE, or not, FALSE.
HasOverrideProperties | Checks whether property overrides exist for the folder or component view, TRUE, or not, FALSE.
IsInstance | Checks whether it is the path to the folder instance, TRUE, or not, FALSE.
IsLeaf | Checks whether it is the path to the leaf entity, TRUE, or not, FALSE.
IsLocked | Gets the lock state of this folder. The folder is locked if it is a suboccurrence of the locked definition.
Owner | Gets the definition of the owner for the folder.
Position | Gets or sets the position of the folder or component view in model space.
ViewName | Gets the name of the folder.
ViewScale | Sets the view scale of the view.
Visible | Gets or sets the visibility of the folder.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolderDefinition Members
Legend
Property
read only
Method


IMcadFolderDefinition Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition Members Methods
IMcadFolderDefinition Members Legend
Methods
Name | Description
AddComplexHideSituation | Creates a new complex hide situation with the specified name in this folder definition.
AddFolder | Adds an instance of the passed in definition to the McadComponentViewDefinition or McadFolderDefinition upon which it is called.
AddFromExistingEntities | Add entities in an existing database to this folder definition.
AddHideSituation | Creates new hide situation with the specified name in this folder definition. You must set one of foreground entities inputs - free MS entities or folder object keys. Otherwise hide will be erased.
Children | Gets the children of the folder definition.
Delete | Deletes the object being referenced.
Extents | Gets the extents of the folder definition geometry expressed in the local coordination system of the folder definition.
Externalize | Externalizes the folder definition.
FindHideSituations | Take entity/view and determines all of the hide situations that reference it as either a background or foreground, and returns them in REVERSE compute order via referring hides.
GetHidesSuppressState | Checks whether the folder definition and its child views have suppressed or unsuppressed hide situations.
Highlight | Highlights the topological entity on the model.
Instances | Gets the instances of the folder definition.
InstancesDefinition | Checks whether this folder or component view definition has an instance of the specified folder or component view definition.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
IsExternal | Checks whether folder definition is external to the given database, TRUE, or not, FALSE.
Localize | Localizes the specified folder definition or all children.
LookupViewName | Look up for the view with the specified name.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
NextViewName | Gets the name of the next view instance for this folder definition.
Occurrences | Gets the occurrences of the folder definition from the specified database.
RemoveFolder | Removes a folder from a folder definition.
SetHidesSuppressState | Sets suppressed/unsuppressed state of all hide situations in the folder definition and its child views.
SortChildren | Sorts the children of the view definition in an alphabetical order of the names of the children components or structure browser nodes.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolderDefinition Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinition Members Properties
IMcadFolderDefinition Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ChildrenCount | Gets the total number of the children for the folder.
ComplexHideSituations | Returns all complex hide situations from this folder definition.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FullName | Gets the full name of this folder definition.
HideSituations | Returns all hide situations from this folder definition.
InstanceCount | Gets the total number of the folder instances.
IsAnnotation | Gets whether this is an annotation view definition, TRUE, or not, FALSE.
IsDetail | Gets whether this is a detail view definition, TRUE, or not, FALSE.
IsLocked | Gets or sets the locked state of this folder definition, TRUE, or not, FALSE.
IsRoot | Checks whether this folder definition is root view definition, TRUE, or not, FALSE.
LockType | Gets the lock type of this folder definition.
Name | Gets or sets the name of this folder definition.
ViewType | Gets or sets the view type of this folder definition.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolderDefinitions Members
Legend
Property
read only
Method


IMcadFolderDefinitions Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions Members Methods
IMcadFolderDefinitions Members Legend
Methods
Name | Description
Add | Appends a new folder definition to the collection.
Item | Gets the folder definition at the specified index from the collection.
Remove | Removes the specified folder definition from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolderDefinitions Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDefinitions Members Properties
IMcadFolderDefinitions Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folder definition definitions in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface > IMcadFolderDefinitions Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolderDescriptor Members
Legend
Property
read only
Method


IMcadFolderDescriptor Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor Members Methods
IMcadFolderDescriptor Members Legend
Methods
Name | Description
CreateFolder | Creates a new folder from the folder descriptor.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolderDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolderDescriptor Members Properties
IMcadFolderDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Definition | Gets and sets folder definition using this descriptor.
Document | Gets the document containing this object.
Entities | Gets and sets entities on this descriptor.
Entities32 | Gets and sets entities on this descriptor.
Name | Gets and sets the name of a 2D structure descriptor.
Position | Gets or sets the position of the folder.
PowerObjectType | Gets the power object type for this descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.
ViewKey | Gets the view key for this descriptor.
ViewName | Gets and sets the view name for this descriptor.
Views | Gets and sets child views from this descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface > IMcadFolderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFolders Members
Legend
Property
read only
Method


IMcadFolders Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders Members Methods
IMcadFolders Members Legend
Methods
Name | Description
Add | Appends a new folder to the collection.
Item | Gets the folder at the specified index from the collection.
Remove | Removes the specified folder from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFolders Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFolders Members Properties
IMcadFolders Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of folders in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface > IMcadFolders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadFormulaEvaluator Members
Legend
Property
read only
Method


IMcadFormulaEvaluator Members Methods

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator Members Methods
IMcadFormulaEvaluator Members Legend
Methods
Name | Description
Evaluate | Evaluates the expression using the all data providers, which were set in McadFormulaEvaluator. If the attribute in expression cannot by evaluated, the attribute name is returned.
Exist | Checks whether the data providers of formula evaluator have the specified attribute, TRUE, or not, FALSE.
GetAllAttribs | Gets all attributes in the given data providers.
GetAllAttribsData | Gets all information about the specified attribute from first data provider of formula evaluator and returns TRUE if this method can be implemented correctly.
GetAllAttribValues | Gets all values for the specified attribute from all providers that supply this attribute.
GetData | Gets the data for the specified attribute name from the first data provider of formula evaluator.
IsEditable | Checks whether the specified attribute data can be modified in the data provider, TRUE, or not, FALSE.
SetData | Sets a new value for the specified attribute in all data providers that contain this attribute.
SetDataProvider | Sets the additional data provider to Mcad Formula evaluator, TRUE, or not, FALSE.


Methods

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadFormulaEvaluator Members Properties

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadFormulaEvaluator Members Properties
IMcadFormulaEvaluator Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.


Properties

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface > IMcadFormulaEvaluator Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadGeometry Members
Legend
Property
read only
Method


IMcadGeometry Members Methods

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry Members Methods
IMcadGeometry Members Legend
Methods
Name | Description
AddAttribute | Adds the specified attribute to the object being referenced by this object.
ContainingComponent | Returns the lowest level component that this object is inserted into.
Delete | Deletes the object being referenced.
GetAttributes | Gets the attributes attached to the object being referenced.
HasChanged | Provides passive notification of whether the referenced geometry has changed since the geometry reference object was created or was last checked (and the state reset).
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveAttribute | Removes the specified attribute from the object being referenced.


Methods

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadGeometry Members Properties

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadGeometry Members Properties
IMcadGeometry Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
Geometry | Specifies the geometric representation of the geometry being referenced.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface > IMcadGeometry Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadHideSituation Members
Legend
Property
read only
Method


IMcadHideSituation Members Methods

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation Members Methods
IMcadHideSituation Members Legend
Methods
Name | Description
AddMSSubent | Adds the model space entity to this hide situation.
AddMSSubents | Adds model space entities to hide situation.
AddSubent | Adds the entity/view to this hide situation.
AddSubents | Adds the entities/views to this hide situation.
AutoSelectBackground | Automatically selects background objects and adds them to a new or existing level.
ClearSubents | Clears the hide situation sub-entities with the given sub-entity type.
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.
RemoveSubent | Removes the entity/view from this hide situation with the given sub-entity type.
RemoveSubentByIdx | Removes the entity/view from this hide situation with the given sub-entity type and index number.
Subents | Gets the hide subentities of this hide situation.
SwapFgAndBg | Swaps foreground and background hide sub-entities.


Methods

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadHideSituation Members Properties

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituation Members Properties
IMcadHideSituation Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
BgSelectionName | Gets or sets the name for the background selection set.
Concealed | Gets or sets whether the hide situation is concealed, TRUE, or not, FALSE.
ContoursOnlyInForeground | Gets or sets the flag how the foreground entities set is used in this hide calculation.
Definition | Gets or sets the parent folder definition of the hide situation.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
FgSelectionName | Gets or sets the name for the foreground selection set.
HiddenLinesInvisible | Gets or sets the hide style for lines is dashed, TRUE, or invisible, FALSE.
HideAppropriateObjectsOnly | Specifies how background objects are hidden, TRUE, or not, FALSE.
IgnoreBgExclude | Gets or sets the BgExclude flag.
IgnoreFgExclude | Gets or sets the FgExclude flag.
IgnoreUpperBgExclude |
InverseForeground | Gets or sets the flag how we use foreground entities set in this hide calculation.
IsComplexHideLevel | Checks whether this is complex hide situation, TRUE, or not, FALSE.
IsLastLevel | Checks if this hide situation is the last level of one complex hide situation, TRUE, or not, FALSE.
IsMigrated | Checks whether this is migrated hide situation, TRUE, or not, FALSE.
IsModifiedStandardPartHide | Checks whether this is the modified standard part hide situation, TRUE, or not, FALSE.
IsStandardPartHide | Checks whether this is standard part hide situation, TRUE, or not, FALSE.
LevelIndex |
Name | Gets or sets the name of the hide situation.
OuterContourOnly | Gets or sets the flag to define the outer contour property.
ParentHide | Gets the complex hide situation that owns this hide situation if this hide situation is part of one complex hide situation.
SaveSimplifiedOuterContour | Optimizes the outer contour selection and stores the contour for future calculations.
Suppressed | Gets or sets the suppression state of the hide situation, TRUE, or the unsuppression state, FALSE.
SysName | Gets or sets the system name.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadHideSituations Members
Legend
Property
read only
Method


IMcadHideSituations Members Methods

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations Members Methods
IMcadHideSituations Members Legend
Methods
Name | Description
Add | Appends a hide situation to the collection.
Item | Gets the hide object at the specified index from the collection.
Remove | Removes the specified Hide from the collection.


Methods

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadHideSituations Members Properties

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadHideSituations Members Properties
IMcadHideSituations Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of hide situations in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface > IMcadHideSituations Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadIdentifier Members
Legend
Property
read only
Method


IMcadIdentifier Members Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifier Members Methods
IMcadIdentifier Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadIdentifier Members Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifier Members Properties
IMcadIdentifier Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Value | Specifies the value of the feature or datum identifier. The maximum length of the value is 2.


Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface > IMcadIdentifier Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadIdentifierStandard2 Members
Legend
Property
read only
Method


IMcadIdentifierStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2 Members Methods
IMcadIdentifierStandard2 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadIdentifierStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard2 Members Properties
IMcadIdentifierStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
FarSideLeaderLineType | This is FarSideLeaderLineType, a member of class IMcadIdentifierStandard2.
FarSideLeaderLineTypeName | This is FarSideLeaderLineTypeName, a member of class IMcadIdentifierStandard2.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | This is SurfIndLeaderArrowScale, a member of class IMcadIdentifierStandard2.
SurfIndLeaderArrowType | This is SurfIndLeaderArrowType, a member of class IMcadIdentifierStandard2.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface > IMcadIdentifierStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadIdentifierStandard Members
Legend
Property
read only
Method


IMcadIdentifierStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard Members Methods
IMcadIdentifierStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadIdentifierStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadIdentifierStandard Members Properties
IMcadIdentifierStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultArrowType | Gets the default arrow type for identifier symbols created referencing this standard.
IsDatumIDSupported | Gets whether datum identifiers are supported by this standard, TRUE, or not, FALSE.
IsFeatureIDSupported | Gets whether feature identifiers are supported by this standard, TRUE, or not, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface > IMcadIdentifierStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadJoint Members
Legend
Property
read only
Method


IMcadJoint Members Methods

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint Members Methods
IMcadJoint Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadJoint Members Properties

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadJoint Members Properties
IMcadJoint Members Legend
Properties
Name | Description
AllAround | Specifes whether the Dead Joint symbol is all around.
Annotation | Specifes the annotation text of Dead Joint symbol.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifes the additional annotation text of Dead Joint symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecAnnotation | Specifes the additional annotation text of Dead Joint symbol.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies the type of Dead Joint symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface > IMcadJoint Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerCfg Members
Legend
Property
read only


IMcadLayerCfg Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfg Members Properties
IMcadLayerCfg Members Legend
Properties
Name | Description
AssocObjects | Specifies objects associated with the layer.
Desc | Specifies the layer description.
Invisible | Specifies the visibility of the layer.
Key | Specifies the layer key.
LineType | Specifies the layer linetype.
LineTypeId | Specifies the layer linetype ID.
LineTypeId32 | Specifies the layer line type ID. Only available for x64 platform.
LineWeight | Specifies the layer lineweight.
Name | Specifies the layer name.
NoPlot | Specifies whether the layer is plotted.
NoReplicateInLayerGroup | Specifies whether the layer is replicated when a new layergroup is created.
OverrideColorByLayerGroup | Specifies whether the color associated with the layer is overridden by the layergroup color.
TrueColor | Specifies the layer color.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface > IMcadLayerCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerCfgs Members
Legend
Property
read only
Method


IMcadLayerCfgs Members Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs Members Methods
IMcadLayerCfgs Members Legend
Methods
Name | Description
Add | This is Add, a member of class IMcadLayerCfgs.
Item | This is Item, a member of class IMcadLayerCfgs.
Remove | This is Remove, a member of class IMcadLayerCfgs.


Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadLayerCfgs Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerCfgs Members Properties
IMcadLayerCfgs Members Legend
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface > IMcadLayerCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerGroupMgr Members
Legend
Property
read only
Method


IMcadLayerGroupMgr Members Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr Members Methods
IMcadLayerGroupMgr Members Legend
Methods
Name | Description
GetLayerGroupEntities | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupEntities32 | Gets the object IDs for the entities associated with that specified layer group.
GetLayerGroupNames | Gets all of the layer group names for the document.
GetLayersFromGroup | Gets the names of all layers in a specified layer group.
MoveLayerGroupEntities | Moves all of the entities in one layer group to another layer group.


Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadLayerGroupMgr Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerGroupMgr Members Properties
IMcadLayerGroupMgr Members Legend
Properties
Name | Description
Document | Gets the corresponding McadDocument from the specified host application's document.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface > IMcadLayerGroupMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerObjectCfg Members
Legend
Property
read only


IMcadLayerObjectCfg Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfg Members Properties
IMcadLayerObjectCfg Members Legend
Properties
Name | Description
Hide | Specifies the layer object hide type.
LayerName | Specifies the layer key.
LayerObjKey | Specifies the layer object key. This table lists the layer object keys and their description.
LineType | Specifies the layer object line type.
LineTypeId | Specifies the layer object line type ID.
LineTypeId32 | Specifies the layer object line type ID. Only available for x64 platform.
LineWeight | Specifies the layer object line weight.
TrueColor | Specifies the layer object color.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface > IMcadLayerObjectCfg Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerObjectCfgs Members
Legend
Property
read only
Method


IMcadLayerObjectCfgs Members Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs Members Methods
IMcadLayerObjectCfgs Members Legend
Methods
Name | Description
Add | This is Add, a member of class IMcadLayerObjectCfgs.
Item | Obtains a specified layer from the collection.
Remove | This is Remove, a member of class IMcadLayerObjectCfgs.


Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadLayerObjectCfgs Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectCfgs Members Properties
IMcadLayerObjectCfgs Members Legend
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadLayerObjectCfgs.
Application | Returns the application object.
Count | Returns the total number of layer objects in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface > IMcadLayerObjectCfgs Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadLayerObjectMgr Members
Legend
Property
read only
Method


IMcadLayerObjectMgr Members Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr Members Methods
IMcadLayerObjectMgr Members Legend
Methods
Name | Description
CreateLayer | Creates a mechanical layer for the current drafting standard.
GetAllLayerObjs | Gets all the mechanical objects specified by the standard.
GetAllLayers | Gets all the mechanical layers for the specified standard in the current drawing.
GetLayerObjProperty | Gets the property of the layer object settings according to the layer object key and standard ID.
GetLayerProperty | Gets the property of the layer settings according to the layer name and standard ID.
ImportLayerObj | Imports the layer object settings from the specified drawing.
SetLayerObjDefault | Resets the mechanical layer and object properties to their default values.


Methods

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadLayerObjectMgr Members Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadLayerObjectMgr Members Properties
IMcadLayerObjectMgr Members Legend
Properties
Name | Description
Document | This is Document, a member of class IMcadLayerObjectMgr.


Properties

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface > IMcadLayerObjectMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadMarkStamp Members
Legend
Property
read only
Method


IMcadMarkStamp Members Methods

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp Members Methods
IMcadMarkStamp Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadMarkStamp Members Properties

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStamp Members Properties
IMcadMarkStamp Members Legend
Properties
Name | Description
ContentValue | Specifies the marking or stamping contents.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MethodValue | Specifies the marking or stamping method.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
SymbolType | Specifies whether the symbol is a marking or stamping symbol.
TechnicalReqValue | Specifies a reference to a technical requirement.


Properties

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface > IMcadMarkStamp Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadMarkStampStandard Members
Legend
Property
read only
Method


IMcadMarkStampStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard Members Methods
IMcadMarkStampStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadMarkStampStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadMarkStampStandard Members Properties
IMcadMarkStampStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableMarkingContents | Gets the list of symbols that are available for marking contents referencing this standard.
AvailableMarkingMethods | Gets the list of symbols that are available for marking methods referencing this standard.
AvailableStampingContents | Gets the list of symbols that are available for stamping contents referencing this standard.
AvailableStampingMethods | Gets the list of symbols that are available for stamping methods referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedMarkingContents | Specifies the list of symbols that are offered for marking contents referencing this standard.
OfferedMarkingMethods | Specifies the list of symbols that are offered for marking methods referencing this standard.
OfferedStampingContents | Specifies the list of symbols that are offered for stamping contents referencing this standard.
OfferedStampingMethods | Specifies the list of symbols that are offered for stamping methods referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface > IMcadMarkStampStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadNote Members
Legend
Property
read only
Method


IMcadNote Members Methods

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote Members Methods
IMcadNote Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustLanding | Specifies new landing for the note symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
CreateNoteText | Creates text in note symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadNote Members Properties

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNote Members Properties
IMcadNote Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
EvaluatedNoteText | Property to specify the rendered text of variables or expressions.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsLeftOriented | Specify if text in note symbol is left-aligned.
Landing | Specifies if note symbol has landing (the extension of the leader line that underlines the text).
LeaderAttachPoint | Specifies the justification of the leader in the note symbol.
LeaderCount | Gets the number of leaders attached to a specific symbol.
NoteText | Specifies the text in the note symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
TextAlignment | Specifies the alignment of the text in the note symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadNote Interface > IMcadNote Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadNoteStandard Members
Legend
Property
read only
Method


IMcadNoteStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard Members Methods
IMcadNoteStandard Members Legend
Methods
Name | Description
AddTemplate | Adds new template and its value to the specified template group.
ChangeTemplateValue | Changes the value of template in the specified template group.
DeleteAllTemplates | Deletes all templates in all template groups.
DeleteTemplate | Deletes template from the specified template group.
GetAllTemplates | Get all templates for the group with given type.
GetFeatureTypes | Get type of features that the note symbol is attached to.
GetTemplateGroup | Gets the type and name of the template group for the specified index.
GetTemplateValue | Gets the non-evaluated value of the template for specified template type and name.
NumberOfTemplateGroups | Gets number of template groups that the note standard holds.
RenameTemplate | Renames template in the specified template group.
SetCompatibilityCondition | Sets up the feature type(s) you are interested in.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTemplate | Sets the default template in the specified template group.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadNoteStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadNoteStandard Members Properties
IMcadNoteStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
Landing | Specifies if note symbol has landing.
LeaderAttachPoint | Specifies default leader justification of the text in note symbol.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface > IMcadNoteStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadObject Members
Legend
Property
read only
Method


IMcadObject Members Methods

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject Members Methods
IMcadObject Members Legend
Methods
Name | Description
Delete | Deletes the object being referenced.
Highlight | Highlights the topological entity on the model.
IsEqualTo | Determines whether the specified object is equal to this object, TRUE, or not, FALSE. The objects can differ in their focus, or scope.
MakePersistent | Assigns a unique identifier for the reference object and stores the reference object with the specified database.


Methods

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadObject Members Properties

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObject Members Properties
IMcadObject Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.
Editable | Gets whether the referenced object can be directly edited, TRUE, or not, FALSE.
WasErased | Gets whether component view definition was erased, TRUE, or not, FALSE.


Properties

You are here: API Reference > AcadmAuto Library > IMcadObject Interface > IMcadObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadObjects Members
Legend
Property
read only
Method


IMcadObjects Members Methods

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects Members Methods
IMcadObjects Members Legend
Methods
Name | Description
Add | Appends a new object to the collection.
Item | Gets the object at the specified index from the collection.
Remove | Long; input-only. Specifies the index of the object to remove.


Methods

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadObjects Members Properties

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadObjects Members Properties
IMcadObjects Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.


Properties

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface > IMcadObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartList2 Members
Legend
Property
read only
Method


IMcadPartList2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2 Members Methods
IMcadPartList2 Members Legend
Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartList2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList2 Members Properties
IMcadPartList2 Members Legend
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface > IMcadPartList2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartList3 Members
Legend
Property
read only
Method


IMcadPartList3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3 Members Methods
IMcadPartList3 Members Legend
Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddFilterType | Creates a filter of a specified type and adds it to the Parts List.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
setWrapPListAttachPoint | Sets the attach point of a parts list that wraps around the title block.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartList3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList3 Members Properties
IMcadPartList3 Members Legend
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
FormulaBarEnabled | Property that specifies whether the Parts List formula bar is enabled.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingTextControl | Property that specifies the Parts List heading text control.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
ResultBarEnabled | Property that specifies whether the Parts List result bar is enabled.
RowTextControl | Property that specifies the Parts List row text control.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapAroundTitle | Specifies whether the parts list can be wrapped around the title block.
WrapText | Property that specifies whether the Parts List heading and row text wraps.
WrapTitleBlockId | Specifies the Id of the title block which is wrapped around.
WrapTitleBlockId32 | Specifies the Id of the title block which is wrapped around. Only available for x64 platform.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface > IMcadPartList3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartList Members
Legend
Property
read only
Method


IMcadPartList Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList Members Methods
IMcadPartList Members Legend
Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartList Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartList Members Properties
IMcadPartList Members Legend
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface > IMcadPartList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListCustomFilter Members
Legend
Property
read only
Method


IMcadPartListCustomFilter Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter Members Methods
IMcadPartListCustomFilter Members Legend
Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListCustomFilter Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListCustomFilter Members Properties
IMcadPartListCustomFilter Members Legend
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface > IMcadPartListCustomFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListFilter2 Members
Legend
Property
read only
Method


IMcadPartListFilter2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2 Members Methods
IMcadPartListFilter2 Members Legend
Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListFilter2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter2 Members Properties
IMcadPartListFilter2 Members Legend
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Type | Property that specifies the filter type of a Parts List filter.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface > IMcadPartListFilter2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListFilter Members
Legend
Property
read only
Method


IMcadPartListFilter Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter Members Methods
IMcadPartListFilter Members Legend
Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListFilter Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilter Members Properties
IMcadPartListFilter Members Legend
Properties
Name | Description
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface > IMcadPartListFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListFilters Members
Legend
Property
read only
Method


IMcadPartListFilters Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters Members Methods
IMcadPartListFilters Members Legend
Methods
Name | Description
Add | Adds a parts list filter to the collection used in this parts list.
Item | Obtains a specified parts list filter from the collection used in this parts list.
Remove | Removes the specified parts list filters from the collection used in this parts list.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListFilters Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListFilters Members Properties
IMcadPartListFilters Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts list filters in the collection used in a parts list.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface > IMcadPartListFilters Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListGOST Members
Legend
Property
read only
Method


IMcadPartListGOST Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST Members Methods
IMcadPartListGOST Members Legend
Methods
Name | Description
AddFilter | Creates a filter of the specified type and adds it to the part list filter list.
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveFilter | Removes the specified part list filter from this part list.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListGOST Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListGOST Members Properties
IMcadPartListGOST Members Legend
Properties
Name | Description
AttachmentPoint | Specifies the placement of the base point for the part list.
BOM | Specifies the bill of materials table that this parts list is referencing.
CoordinateSystem | Specifies the coordinate system for the symbol.
CustomBlockName | Specifies the custom block scheme name used to display this parts list.
CustomBlocks | Gets the custom blocks used to display this parts list.
FilterEmptyBlocks | Specifies whether the parts list filters out empty block references, TRUE, or not, FALSE.
Filters | Gets the list of filters for a parts list.
Height | Specifies the height of a parts list.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsCustomBlockUsed | Gets whether this parts list is displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the parts list's heading is enabled, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the parts list's title is enabled, TRUE, or not, FALSE.
ItemList | Specifies all the BOM items included in a part list.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MappingName | Specifies the name of the custom mapping.
MultipleRow | Specifies the single, double, or triple lines of text in the rows for the parts list.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SkipAfterPart | Specifies if empty line is to be inserted after each part.
SkipLines | Specifies the number of empty lines to insert after the last item of each category.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.
Title | Specifies the parts list's title text.
ViewID | Specifies the object ID of the drawing view that this parts list is associated with.
ViewID32 | Specifies the object ID of the drawing view that this parts list is associated with.
Width | Specifies the width of a parts list.
WrapText | Property that specifies whether the Parts List heading and row text wraps.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface > IMcadPartListGOST Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartLists Members
Legend
Property
read only
Method


IMcadPartLists Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists Members Methods
IMcadPartLists Members Legend
Methods
Name | Description
Add | Adds a parts list to the collection used in this drawing.
Item | Obtains a specified parts list from the collection used in this drawing.
Remove | Removes the specified parts lists from the collection used in this drawing.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartLists Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartLists Members Properties
IMcadPartLists Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of parts lists in the collection used in a drawing.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface > IMcadPartLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListStandard2 Members
Legend
Property
read only
Method


IMcadPartListStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2 Members Methods
IMcadPartListStandard2 Members Legend
Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard2 Members Properties
IMcadPartListStandard2 Members Legend
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface > IMcadPartListStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListStandard3 Members
Legend
Property
read only
Method


IMcadPartListStandard3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3 Members Methods
IMcadPartListStandard3 Members Legend
Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListStandard3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard3 Members Properties
IMcadPartListStandard3 Members Legend
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface > IMcadPartListStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListStandard4 Members
Legend
Property
read only
Method


IMcadPartListStandard4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard4 Members Methods
IMcadPartListStandard4 Members Legend
Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListStandard4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard4 Members Properties
IMcadPartListStandard4 Members Legend
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BoldVerticalLine | Property that specifies whether the Parts List line style is bold.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
ColumnSplitEnabled | Property that specifies whether the Parts List column split is enabled.
ColumnSplitRows | Property that specifies the Parts List column split rows.
ColumnSplitSections | Property that specifies the Parts List column split sections.
ColumnSplitStyle | Property that specifies the Parts List column split style.
ColumnSplitWrap | Property that specifies the Parts List column split wrap direction.
ColumnSplitWrapAroundTitle | Specifies whether the parts list can be wrapped around the title block in this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
FrameTrueColor | Specifies the true color of frames for parts lists referencing this standard.
GripFrameEnabled | Property that specifies whether the Parts List grip frame is enabled.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextControl | Property that specifies the Parts List heading text control.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
HeadingTextMarginBottom | Property that specifies the Parts List heading text bottom margin.
HeadingTextMarginLeft | Property that specifies the Parts List heading text left margin.
HeadingTextMarginRight | Property that specifies the Parts List heading text right margin.
HeadingTextMarginTop | Property that specifies the Parts List heading text top margin.
HeadingTextStyle | Property that specifies the Parts List heading text style.
HeadingTextTrueColor | Specifies the true color of the heading texts for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
RowTextColor | Property that specifies the Parts List row text color
RowTextControl | Property that specifies the Parts List row text control.
RowTextHeight | Property that specifies the Parts List row text height.
RowTextMarginBottom | Property that specifies the Parts List row text bottom margin.
RowTextMarginLeft | Property that specifies the Parts List row text left margin.
RowTextMarginRight | Property that specifies the Parts List row text left margin.
RowTextMarginTop | Property that specifies the Parts List row text top margin.
RowTextStyle | Property that specifies the Parts List row text style.
RowTextTrueColor | Property that specifies the Parts List row text color.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface > IMcadPartListStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListStandard Members
Legend
Property
read only
Method


IMcadPartListStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard Members Methods
IMcadPartListStandard Members Legend
Methods
Name | Description
RemoveColumn | Removes the specified column, by index, from the parts lists referencing this standard.
SetToDefaults | Sets the properties of the standard parts list to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStandard Members Properties
IMcadPartListStandard Members Legend
Properties
Name | Description
ActualRowTextHeight | Gets the actual height of the text in a row of parts lists referencing this standard.
Application | Gets the AcadmApplication object.
AttachmentPoint | Specifies the placement of the base point for the part lists referencing this standard.
BOMStandard | Gets the BOM standard that are associated with parts list referencing this standard.
ColumnList | Specifies the indices for the columns that are used in parts lists referencing this standard.
CustomBlockName | Specifies the custom block scheme name used to display parts lists referencing this standard.
CustomBlocks | Gets the custom blocks used for the parts lists referencing this standard.
FilterEmptyBlocks | Specifies whether the parts lists referencing this standard filters out empty block references, TRUE, or not, FALSE.
FrameColor | Specifies the color of the frame for the parts lists referencing this standard.
HeadingGap | Property that specifies the Parts List heading text gap.
HeadingHeight | Specifies the heading height for parts lists referencing this standard.
HeadingTextColor | Specifies the heading text color for parts lists referencing this standard.
HeadingTextHeight | Specifies the heading text height for parts lists referencing this standard.
IsCustomBlockUsed | Gets whether parts lists created referencing this standard are by default displayed using custom blocks, TRUE, or not, FALSE.
IsHeadingEnabled | Specifies whether the heading is by default enabled for parts lists referencing this standard, TRUE, or not, FALSE.
IsTitleEnabled | Specifies whether the title is by default enabled for parts lists referencing this standard.
MulipleRow | Specifies the single, double, or triple lines of text in the rows for parts lists referencing this standard.
Revision | Specifies the revision version of a parts list standard.
RevisionYear | Gets the revision version year of a parts list standard.
RowGap | Property that specifies the Parts List row text gap.
RowHeight | Specifies the row height for parts lists referencing this standard.
UseMapping | Specifies whether the parts lists referencing this standard use custom mapping, TRUE, or not, FALSE.
WrapText | Specifies whether the text in a row for parts lists referencing this standard wraps around, TRUE, or overflows, FALSE.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface > IMcadPartListStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartListStdPartsFilter Members
Legend
Property
read only
Method


IMcadPartListStdPartsFilter Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStdPartsFilter Members Methods
IMcadPartListStdPartsFilter Members Legend
Methods
Name | Description
Evaluate | Evaluates the filter on the specified BOM item and returns whether the item passes the filter criteria, TRUE, or not, FALSE.
SetCondition | Specifies the filter condition used by the Parts List custom filter to filter parts.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartListStdPartsFilter Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartListStdPartsFilter Members Properties
IMcadPartListStdPartsFilter Members Legend
Properties
Name | Description
Excluded | Property that specifies whether a Parts List filter type is excluded from use in the current context.
IsOn | Specifies whether the part list filter is enabled, TRUE, or not, FALSE.
Name | Specifies the name of the parts list filter.
Operator | Specifies the filter operator used by the Parts List custom filter to filter parts.
Option | Property that specifies the filter option used by the Parts List Standard parts filter to display parts.
PropertyName | Specifies the BOM property name used by the Parts List custom filter to filter parts.
PropertyValue | Specifies the BOM property value used by the Parts List custom filter to filter parts.
Type | Property that specifies the filter type of a Parts List filter.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface > IMcadPartListStdPartsFilter Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartReference2 Members
Legend
Method
Property
read only


IMcadPartReference2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference2 Members Methods
IMcadPartReference2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartReference2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference2 Members Properties
IMcadPartReference2 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface > IMcadPartReference2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartReference3 Members
Legend
Property
read only
Method


IMcadPartReference3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3 Members Methods
IMcadPartReference3 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachExternalBom | Method that attaches the specified BOM from the specified xref drawing to this part reference.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachExternalBom | Method that detaches the external BOM, if any, from this part reference.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetBomOverride | Method that checks if there is a bom override for the specified attribute/column and if so, returns the override properties (the type of bom override if any). Would be set to sbNoOverride if there is no bom override.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveAttribute | Method to remove the local attribute value if any from this part reference. If there is a bom override for this attribute, calling RemoveAttribute will remove the bom override.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetAttributePreDefinedListValue | Sets a specific value within the predefined list for the specified attribute
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartReference3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference3 Members Properties
IMcadPartReference3 Members Legend
Properties
Name | Description
AttachedExternalBom | Property that specifies the attached external BOM, if any, of this part reference.
AttachedExternalBomXrefBlock | Property that specifies the Acad block of the external BOM of this part reference, if any.
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface > IMcadPartReference3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartReference Members
Legend
Property
read only
Method


IMcadPartReference Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference Members Methods
IMcadPartReference Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartReference Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReference Members Properties
IMcadPartReference Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
Data | Specifies the bill of materials table data.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Quantity | Specifies the quantity value of the part reference.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface > IMcadPartReference Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPartReferences Members
Legend
Property
read only
Method


IMcadPartReferences Members Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences Members Methods
IMcadPartReferences Members Legend
Methods
Name | Description
Add | This is Add, a member of class IMcadPartReferences.
Item | This is Item, a member of class IMcadPartReferences.
Remove | This is Remove, a member of class IMcadPartReferences.


Methods

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadPartReferences Members Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPartReferences Members Properties
IMcadPartReferences Members Legend
Properties
Name | Description
_NewEnum | This is _NewEnum, a member of class IMcadPartReferences.
Application | This is Application, a member of class IMcadPartReferences.
Count | This is Count, a member of class IMcadPartReferences.


Properties

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface > IMcadPartReferences Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPick Members
Legend
Property
read only


IMcadPick Members Properties

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPick Members Properties
IMcadPick Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
ObjectType | Specifies the object reference type that the pick is used to select.
PickPoint | Specifies the pick point of the pick object.


Properties

You are here: API Reference > AcadmAuto Library > IMcadPick Interface > IMcadPick Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadPowObjViewGroupDescriptor Members
Legend
Property
read only


IMcadPowObjViewGroupDescriptor Members Properties

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadPowObjViewGroupDescriptor Members Properties
IMcadPowObjViewGroupDescriptor Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the document containing this object.
Entities | Gets the entities from the view group descriptor in model space.
Entities32 | Gets the entities from the view group descriptor in model space.
Name | Gets and sets the name of a 2D structure descriptor.
PowerObjectType | Gets the power object type from the power object view group descriptor.
TargetView | Gets and sets the target (parent) view for this descriptor.


Properties

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface > IMcadPowObjViewGroupDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadRevisionList Members
Legend
Property
read only
Method


IMcadRevisionList Members Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList Members Methods
IMcadRevisionList Members Legend
Methods
Name | Description
Add | Add a revision to the end of the revision list.
Item | Returns the data set for a specified revision in this revision list.
Set | Sets a revision list entry to a specific value.


Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadRevisionList Members Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionList Members Properties
IMcadRevisionList Members Legend
Properties
Name | Description
Border | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Border32 | Property that returns the object ID of the associated title block border with this revision list if AssociatedToBorder property is a TRUE, otherwise NULL object id is returned.
Count | Gets the total number of items in the collection.
Position | Property that returns the input position of the revision list.
Ref | Property that returns a reference to the title/border object.
Ref32 | Read-only property that returns the object ID of this revision list.


Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface > IMcadRevisionList Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadRevisionListDescriptor Members
Legend
Property
read only


IMcadRevisionListDescriptor Members Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionListDescriptor Members Properties
IMcadRevisionListDescriptor Members Legend
Properties
Name | Description
Attributes | Property that gets and sets the attributes of the revision list. You can create a new revision list with the attributes specified in descriptor object.
Border | Returns a pointer to the object id of the associated title block border with this revision list.
Border32 | Returns a pointer to the object id of the associated title block border with this revision list.
Position | Property that sets and gets the position of the revision list.


Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface > IMcadRevisionListDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadRevisionLists Members
Legend
Property
read only
Method


IMcadRevisionLists Members Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists Members Methods
IMcadRevisionLists Members Legend
Methods
Name | Description
Item | Obtains a specified title/border from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadRevisionLists Members Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionLists Members Properties
IMcadRevisionLists Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Property that returns number of revisions in this revision list.


Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface > IMcadRevisionLists Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadRevisionMgr Members
Legend
Property
read only
Method


IMcadRevisionMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr Members Methods
IMcadRevisionMgr Members Legend
Methods
Name | Description
CreateRevisionList | Creates a new revision list.
DeleteRevisionList | Removes a revision list from the drawing. Return TRUE if the specified revision list has been deleted successfully, otherwise return FALSE.
GetRevisionListFromRef | Returns the revision list object referred by object in the drawing.
NewDescriptor | Creates and initializes a new title border descriptor. Returns a new revision list descriptor object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadRevisionMgr Members Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadRevisionMgr Members Properties
IMcadRevisionMgr Members Legend
Properties
Name | Description
RevisionLists | Property that returns the collection object containing all the revision lists maintained by the manager.


Properties

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface > IMcadRevisionMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadScaleArea Members
Legend
Property
read only
Method


IMcadScaleArea Members Methods

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea Members Methods
IMcadScaleArea Members Legend
Methods
Name | Description
CreateViewPort | Creates viewport on specified layout.
DeleteViewPort | Delete viewport for the scale area.
GetAttachedViewportIds | Gets object IDs of all viewports that are attached to the scale area.
GetAttachedViewportIds32 | Gets object IDs of all viewports that are attached to the scale area.
MoveBorder | Moves the border of the scale area.
RescaleObjects | Performs rescaling of specified objects.
SetBasicScale | Sets text scaling factor as the model scale.


Methods

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadScaleArea Members Properties

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleArea Members Properties
IMcadScaleArea Members Legend
Properties
Name | Description
AttachObjectId | Property that specifies the object ID of the defining object, which is the closed curve for the border.
AttachObjectId32 | Property that specifies the object ID of the defining object, which is the closed curve for the border.
LengthScalingFactor | Specifies the length scaling factor of the scale area.
ScaleType | Specifies the type of scale to be text scaling or length scaling.
TextScalingFactor | Specifies the text scaling factor of the scale area.


Properties

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface > IMcadScaleArea Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadScaleAreaMgr Members
Legend
Method


IMcadScaleAreaMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadScaleAreaMgr Members Methods
IMcadScaleAreaMgr Members Legend
Methods
Name | Description
CreateScaleArea | Create a new scale area and append it to the current layout.
DeleteScaleArea | Delete scale area.
FindScaleArea | Search the scale area attached to the given object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface > IMcadScaleAreaMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


Legend

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSectionLine Members
Legend
Property
read only
Method


IMcadSectionLine Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine Members Methods
IMcadSectionLine Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSectionPoint | Adds a vertex to section line.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LabelName | Specifes the name of label in the section line.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetLabelNames | Specifies the label names of the section line.
SetSectionArcPointAt | Sets arc vertex to section line at specified index.
SetSectionPointAt | Sets a vertex to the section line at a specific index.
SetSectionPoints | Sets vertexes of section lines.
SetSectionViewOrigin | Specifies section view origin of the section line.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSectionLine Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLine Members Properties
IMcadSectionLine Members Legend
Properties
Name | Description
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LabelNamesCount | Returns the number of label names.
LabelPattern | Specifies the label pattern for the section line.
LabelText | Property to get the evaluated pattern (with label name and scale).
LabelVisibility | Specifies the visibility of label in the section line.
LeaderCount | Gets the number of leaders attached to a specific symbol.
LineVisibility | Specifies visibility style of the section line.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
PlaneSymbolsVisibility | Specifies the visibility of plane symbols.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SectionPoints | Property to get the array of section point. The VARIANT is a 3-element array of doubles for x, y and z points.
SectionSide | Specifies the direction side of section line symbol. The VARIANT is a 3-element of doubles for x, y and z point.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface > IMcadSectionLine Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSectionLineStandard2 Members
Legend
Property
read only
Method


IMcadSectionLineStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2 Members Methods
IMcadSectionLineStandard2 Members Legend
Methods
Name | Description
GetByStandard | Gets if the specified section view property follow the standard.
SetByStandard | Sets if the specified section view property follow the standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSectionLineStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard2 Members Properties
IMcadSectionLineStandard2 Members Legend
Properties
Name | Description
ArrowLineLength | Specifies the extension length of the arrow line.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
BendLineLength | Specifies the bend line length.
EndArrowType | Specifies the arrow type of the end arrow.
EndBendLineType | Specifies the linetype of end and bend line.
EndLineLength | Specifies the end line length.
EndLineOvershoot | Specifies the end line overshoot.
IdentifierExcludeCharacters | Specifies a string of characters that are to be excluded or invalid for the identifier of section view.
IdentifierOffset | Specifies the identifier offset from section view.
IdentifierPosition | Specifies the identifier position.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelOffset | Specifies the label offset from section view.
LabelPattern | Specifies the label pattern used by the section view.
LabelTextColor | Specifies the text color of view label.
LabelTextHeight | Specifies the text height of view label.
LabelTextStyle | Specifies the text style of view label.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneLineColor | Specifies the color of cutting plane line.
PlaneLineType | Specifies the linetype of cutting plane line.
PlaneLineWeight | Specifies the line weight of cutting plane line.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface > IMcadSectionLineStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSectionLineStandard Members
Legend
Property
read only
Method


IMcadSectionLineStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard Members Methods
IMcadSectionLineStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSectionLineStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSectionLineStandard Members Properties
IMcadSectionLineStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowTowardsLine | Gets whether arrow is drawn as pointing towards or away from the line.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
ArrowVisibility | Specifies whether arrow is visible or hidden at the end of the section line.
LabelAbove | Specifies position of the label. VARIANT_TRUE if set to Above. VARIANT_FALSE if set to Below.
LabelPattern | Specifies the label pattern used by the section view.
LabelVisibility | Specifies whether section view label is visible or hidden.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
LineColor | Specifies the color of section line.
LineTrueColor | Specifies the color of section line.
LineVisibility | Specifies visibility style of the section line.
LineWeight | Specifies the default weight of section line.
MultipleNamesSupported | Specifies whether is to use continuous names for plane symbols.
PlaneSymbolsVisibility | Specifies whether annotation is to be showed at each vertex.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface > IMcadSectionLineStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandard2 Members
Legend
Property
read only
Method


IMcadStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2 Members Methods
IMcadStandard2 Members Legend
Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard2 Members Properties
IMcadStandard2 Members Legend
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface > IMcadStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandard3 Members
Legend
Property
read only
Method


IMcadStandard3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3 Members Methods
IMcadStandard3 Members Legend
Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandard3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard3 Members Properties
IMcadStandard3 Members Legend
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface > IMcadStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandard4 Members
Legend
Property
read only
Method


IMcadStandard4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4 Members Methods
IMcadStandard4 Members Legend
Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.
SupportedArrowTypes | This is SupportedArrowTypes, a member of class IMcadStandard4.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandard4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard4 Members Properties
IMcadStandard4 Members Legend
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
AnnotationViewStandard | Gets the Annotation View Standard contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
DetailSymbolStandard | Property to get the Detail symbol standard.
EdgeStandard | Property to get the edge symbol standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
JointStandard | This is JointStandard, a member of class IMcadStandard4.
LeaderColor | Specifies the color of leader lines created based on this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MarkStampStandard | Gets the marking/stamping symbol standard contained by this standard.
Name | Gets the name of a standard.
NoteStandard | Property to get the Note symbol standard
Scale | Specifies the scale used to create any new symbols based on this standard.
SectionLineStandard | Gets the section line symbol standard contained by this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
SymbolTrueColor | Specifies the true color of symbols created based on this standard.
TaperStandard | Property to get the taper symbol standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
TextTrueColor | Specifies the true color of text in symbols created based on this standard.
TitleBorderStandard | Property to get the title border standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface > IMcadStandard4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandard Members
Legend
Property
read only
Method


IMcadStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard Members Methods
IMcadStandard Members Legend
Methods
Name | Description
AddSymbolStandard | Adds a symbol standard of the specified class name to the standard, and optionally sets the new symbol standard as current.
GetCurrentSymbolStandard | Gets the symbol standard by the specified symbol standard class name that is currently used in the standard.
RemoveSymbolStandard | Removes the specified symbol standard from this standard.
SetCurrentSymbolStandard | Sets the specified symbol standard current in the standard.
SetToDefaults | Sets the properties of this standard to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandard Members Properties
IMcadStandard Members Legend
Properties
Name | Description
AllSymbolStandards | Gets all of the symbol standards contained by this standard.
ArrowScale | Specifies the arrow scale of symbols based on this standard.
ArrowType | Specifies the leader arrow type for symbols based on this standard.
BaseName | Gets the name of the standard that this standard was originally based on.
BOMStandard | Gets the BOM standard based on this standard.
Current | Specifies whether this standard is current standard in the drawing, TRUE, or not, FALSE.
CurrentSymbolStandards | Gets all of the symbol standards that are currently used in this standard.
DatumStandard | Gets the datum symbol standard contained by this standard.
FCFStandard | Gets the feature control frame symbol standard contained by this standard.
IdentifierStandard | Gets the identifier symbol standard contained by this standard.
IsMetric | Specifies whether the standard is metric-based.
LeaderColor | Specifies the color of leader lines created based on this standard.
Name | Gets the name of a standard.
Scale | Specifies the scale used to create any new symbols based on this standard.
StandardMgr | Gets the standard manager for this standard.
SurfaceTextureStandard | Gets the surface texture symbol standard contained by this standard.
SymbolColor | Specifies the color of symbols created based on this standard.
SymbolStandardsSupported | Gets the class names of all of the symbol standards that are registered with this standard.
TextColor | Specifies the color of text in symbols created based on this standard.
TextHeight | Specifies the height of text in symbols created based on this standard.
TextHeightList | Gets the list of valid heights for text.
TextStyle | Specifies the text style for symbols based on this standard.
TextStyleName | Specifies the name of the text style for symbols created based on this standard.
WeldingStandard | Gets the welding symbol standard contained by this standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface > IMcadStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandardMgr Members
Legend
Property
read only
Method


IMcadStandardMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr Members Methods
IMcadStandardMgr Members Legend
Methods
Name | Description
AddStandard | Created a new standard based on an original standard, and optionally sets the new standard as current.
CopyStandard | Creates a copy of an existing standard to the specified new name.
GetStandard | Gets the standard with the specified name.
RemoveStandard | Removes the specified standard from the standard manager. This is equivalent to calling the McadStandard > Delete method on a specified standard to be removed.
UpdateSymbols | Updates all symbols with respect to changes made to their standards.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandardMgr Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandardMgr Members Properties
IMcadStandardMgr Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
CurrentStandard | Specifies the current standard for the document.
CurrentStandardName | Specifies the name of the current standard for the document.
DefaultStandard | Gets the name of the default standard.
StandardCount | Gets the number of symbol standards loaded.
StandardNames | Gets the names of all registered standards.
Standards | Gets all standards for the current document.
SymbolBBMgr | Gets the Symbol BOM and Balloon manager object for the document.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface > IMcadStandardMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadStandards Members
Legend
Property
read only
Method


IMcadStandards Members Methods

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards Members Methods
IMcadStandards Members Legend
Methods
Name | Description
Add | Add a new standard to the collection.
Item | Obtains a specified standard from the collection.
Remove | Removes the specified standard from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadStandards Members Properties

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadStandards Members Properties
IMcadStandards Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Specifies the total number of the standards in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface > IMcadStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTexture2 Members
Legend
Property
read only
Method


IMcadSurfaceTexture2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2 Members Methods
IMcadSurfaceTexture2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTexture2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture2 Members Properties
IMcadSurfaceTexture2 Members Legend
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface > IMcadSurfaceTexture2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTexture3 Members
Legend
Property
read only
Method


IMcadSurfaceTexture3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3 Members Methods
IMcadSurfaceTexture3 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTexture3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture3 Members Properties
IMcadSurfaceTexture3 Members Legend
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface > IMcadSurfaceTexture3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTexture4 Members
Legend
Method
Property
read only


IMcadSurfaceTexture4 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture4 Members Methods
IMcadSurfaceTexture4 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSurfIndLeader | Adds the surface indication leader for the surface texture symbol
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTexture4 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture4 Members Properties
IMcadSurfaceTexture4 Members Legend
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
FirstRequirement | Specifies the first requirement for the surface.
FourthRequirement | Specifies the value of the fourth requirement field for the surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
SecondRequirement | Specifies the second requirement for the surface.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SurfExtLinesOffset | Specifies the value of the offset gap for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as offset from object.
SurfExtLinesOvershot | Specifies the value of the overshoot for all surface extension lines attached to the symbol. In dialog boxes this value is referred to as extension beyond leader.
SymbolStandard | Specifies the symbol standard for a symbol.
ThirdRequirement | Specifies the value of the third requirement field for the surface texture.
WavinessValue | Specifies the value of the waviness field for the surface texture.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface > IMcadSurfaceTexture4 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTexture Members
Legend
Property
read only
Method


IMcadSurfaceTexture Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture Members Methods
IMcadSurfaceTexture Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTexture Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTexture Members Properties
IMcadSurfaceTexture Members Legend
Properties
Name | Description
AllowanceValue | Specifies the value of the machining allowance field.
Angle | Specifies the angle in degrees for the surface texture.
AutomaticAdjust | Specifies whether the surface texture is automatically adjusted to the default position on the leader, TRUE, or not, FALSE.
CommentValue | Specifies the value of the general comment field.
CoordinateSystem | Specifies the coordinate system for the symbol.
CutoffValue | Specifies the value of the cutoff field for a surface texture.
IsAllAround | Specifies whether the all around sign is added to a surface texture, TRUE, or not, FALSE.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
IsForceTail | Specifies whether the tail is forced on for the symbol without text, TRUE, or not, FALSE.
IsMajority | Specifies whether the surface texture is majority, TRUE, or not, FALSE.
LayDirection | Specifies the direction of machining lay for the surface texture.
LayDirectionValue | Specifies the value of the direction of machining lay for the surface texture.
LeaderCount | Gets the number of leaders attached to a specific symbol.
MaximumSpacingValue | Specifies the value of the maximum roughness spacing field for the surface texture.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
OtherMinimumValue | Specifies the value of the other roughness minimum field for the surface texture.
OtherValue | Specifies the value of the other field for the surface texture.
Production2Value | Specifies the value of the secondary production field for the surface texture.
ProductionValue | Specifies the value of the production field for the surface texture.
RaMaximumValue | Specifies the value of the surface roughness average maximum value field for the surface texture.
RaMinimumValue | Specifies the value of the surface roughness average minimum value field for the surface texture.
ReferenceValue | Specifies the value of the reference field for the surface texture.
SamplingLengthValue | Specifies the value of the sampling length field for the surface texture.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SurfaceTexture | Specifies the surface type of the surface texture.
SymbolStandard | Specifies the symbol standard for a symbol.
WavinessValue | Specifies the value of the waviness field for the surface texture.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface > IMcadSurfaceTexture Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTextureLibraryObject Members
Legend
Property
read only
Method


IMcadSurfaceTextureLibraryObject Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject Members Methods
IMcadSurfaceTextureLibraryObject Members Legend
Methods
Name | Description
RequirementValue | Property to get the requirement value of a surface texture library object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTextureLibraryObject Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureLibraryObject Members Properties
IMcadSurfaceTextureLibraryObject Members Legend
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
IsAllAround | Get the usage of the "all around" symbol.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
IsForceTail | Get force tail status.
IsMajority | Get the usage of the majority symbol.
standardName | Gets the standard name of a library object.
SubSymbolType | Get the symbol type of a surface texture library object.
symbolStandardClassName | Get the symbol standard class name.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface > IMcadSurfaceTextureLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTextureStandard2 Members
Legend
Method
Property
read only


IMcadSurfaceTextureStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2 Members Methods
IMcadSurfaceTextureStandard2 Members Legend
Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTextureStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard2 Members Properties
IMcadSurfaceTextureStandard2 Members Legend
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface > IMcadSurfaceTextureStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTextureStandard3 Members
Legend
Property
read only
Method


IMcadSurfaceTextureStandard3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3 Members Methods
IMcadSurfaceTextureStandard3 Members Legend
Methods
Name | Description
IsRequirementSupported | Gets whether the surface texture requirement is supported by this standard.
SetAllSuggestedListsToDefaults | Sets the preset list of values for all surface texture requirements to the factory default values.
SetSuggestedListToDefaults | Sets the preset list of values for the surface texture requirement to the factory default values.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SuggestedList | Specifies the preset list of values for the surface texture requirement.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTextureStandard3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard3 Members Properties
IMcadSurfaceTextureStandard3 Members Legend
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SurfIndLeaderArrowScale | Specifies the setting of surface indication leader arrowhead scale.
SurfIndLeaderArrowType | Specifies the setting of surface indication leader arrowhead type.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface > IMcadSurfaceTextureStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSurfaceTextureStandard Members
Legend
Property
read only
Method


IMcadSurfaceTextureStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard Members Methods
IMcadSurfaceTextureStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSurfaceTextureStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSurfaceTextureStandard Members Properties
IMcadSurfaceTextureStandard Members Legend
Properties
Name | Description
AllAroundAllowed | Specifies whether the all around sign is added to surface textures referencing this standard, TRUE, or not, FALSE.
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableLaySymbols | Gets the list of machining lay symbols that are available for this standard.
FitCircle | Specifies whether a fit circle is used for surface textures referencing this standard, TRUE, or not, FALSE.
ForceTail | Specifies whether a tail is forced on surface textures referencing this standard, TRUE, or not, FALSE.
FullList | Specifies whether a full list view is used for surface textures referencing this standard, TRUE, or a simplified view is used, FALSE.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MajorityAllowed | Specifies whether majority is allowed for surface textures referencing this standard, TRUE, or not, FALSE.
Multiline | Specifies whether a production multiline is used on surface textures referencing this standard, TRUE, or not, FALSE.
OfferedLaySymbols | Specifies the list of direction of lay symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface > IMcadSurfaceTextureStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbol2 Members
Legend
Method
Property
read only


IMcadSymbol2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol2 Members Methods
IMcadSymbol2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbol2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol2 Members Properties
IMcadSymbol2 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface > IMcadSymbol2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbol Members
Legend
Property
read only
Method


IMcadSymbol Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol Members Methods
IMcadSymbol Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbol Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbol Members Properties
IMcadSymbol Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface > IMcadSymbol Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolBBMgr2 Members
Legend
Method
Property
read only


IMcadSymbolBBMgr2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2 Members Methods
IMcadSymbolBBMgr2 Members Legend
Methods
Name | Description
BOMMgr | Gets the BOM manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
TitleBorderMgr | Read-only property that gets the title border manager object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolBBMgr2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr2 Members Properties
IMcadSymbolBBMgr2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface > IMcadSymbolBBMgr2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolBBMgr3 Members
Legend
Method
Property
read only


IMcadSymbolBBMgr3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3 Members Methods
IMcadSymbolBBMgr3 Members Legend
Methods
Name | Description
BOMMgr | Gets the BOM manager object.
RevisionListMgr | Read-only property that gets the revision list manager object.
ScaleAreaMgr | Read-only property that gets the manager object for scale area.
StandardMgr | Gets the StandardMgr object.
SymbolLibrary | This read-only property is used to get the symbol library.
TitleBorderMgr | Read-only property that gets the title border manager object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolBBMgr3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr3 Members Properties
IMcadSymbolBBMgr3 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface > IMcadSymbolBBMgr3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolBBMgr Members
Legend
Property
read only
Method


IMcadSymbolBBMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr Members Methods
IMcadSymbolBBMgr Members Legend
Methods
Name | Description
BOMMgr | Gets the BOM manager object.
StandardMgr | Gets the StandardMgr object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolBBMgr Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolBBMgr Members Properties
IMcadSymbolBBMgr Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface > IMcadSymbolBBMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolLibrary Members
Legend
Method


IMcadSymbolLibrary Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibrary Members Methods
IMcadSymbolLibrary Members Legend
Methods
Name | Description
appendItem | Add the data in this SymId to the library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
modifyItem | Update the data in this library object.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface > IMcadSymbolLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolLibraryObject Members
Legend
Property
read only


IMcadSymbolLibraryObject Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObject Members Properties
IMcadSymbolLibraryObject Members Legend
Properties
Name | Description
entryName | Specifies the name of a symbol library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface > IMcadSymbolLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolLibraryObjects Members
Legend
Property
read only
Method


IMcadSymbolLibraryObjects Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects Members Methods
IMcadSymbolLibraryObjects Members Legend
Methods
Name | Description
Add | Add a symbol library object to the collection.
Item | Obtains a specified library object from the collection.
Remove | Removes a library object from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolLibraryObjects Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolLibraryObjects Members Properties
IMcadSymbolLibraryObjects Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of objects in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface > IMcadSymbolLibraryObjects Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolStandard2 Members
Legend
Property
read only
Method


IMcadSymbolStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2 Members Methods
IMcadSymbolStandard2 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard2 Members Properties
IMcadSymbolStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface > IMcadSymbolStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolStandard3 Members
Legend
Property
read only
Method


IMcadSymbolStandard3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3 Members Methods
IMcadSymbolStandard3 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolStandard3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard3 Members Properties
IMcadSymbolStandard3 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface > IMcadSymbolStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolStandard Members
Legend
Property
read only
Method


IMcadSymbolStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard Members Methods
IMcadSymbolStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandard Members Properties
IMcadSymbolStandard Members Legend
Properties
Name | Description
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface > IMcadSymbolStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadSymbolStandards Members
Legend
Property
read only
Method


IMcadSymbolStandards Members Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards Members Methods
IMcadSymbolStandards Members Legend
Methods
Name | Description
Add | Adds a symbol standard to the collection.
Item | Gets a specified symbol standard from the collection.
Remove | Removes the specified symbol standard from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadSymbolStandards Members Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadSymbolStandards Members Properties
IMcadSymbolStandards Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Count | Gets the total number of the symbol standards in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface > IMcadSymbolStandards Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTaper Members
Legend
Property
read only
Method


IMcadTaper Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper Members Methods
IMcadTaper Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AdjustReferenceLine | Adjust the angle of the landing and symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
SetToDefaults | Sets the properties of this symbol to the factory default values.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTaper Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaper Members Properties
IMcadTaper Members Legend
Properties
Name | Description
AboveCurve | Specifies if the symbol is above the curve.
CoordinateSystem | Specifies the coordinate system for the symbol.
DisplayString | Specifies the string of the symbol text.
HasLeader | Property to specify if the symbol has leader.
Inspect | Specifies if the theoretically exact frame is turned on or off.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the taper symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubSymbolType | Specifies the type of symbol. Currently the type of sbTaper2 only can be set for GB standard.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface > IMcadTaper Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTaperStandard2 Members
Legend
Method
Property
read only


IMcadTaperStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2 Members Methods
IMcadTaperStandard2 Members Legend
Methods
Name | Description
GetDimensionType | Gets or sets preferred dimension type by current taper standard.
SetDimensionType | Sets the preferred dimension type by current taper standard.
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTaperStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard2 Members Properties
IMcadTaperStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface > IMcadTaperStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTaperStandard Members
Legend
Property
read only
Method


IMcadTaperStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard Members Methods
IMcadTaperStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTaperStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTaperStandard Members Properties
IMcadTaperStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
OfferedSymbols | Specifies the list of symbols that are selected for the standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface > IMcadTaperStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitle2 Members
Legend
Property
read only
Method


IMcadTitle2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2 Members Methods
IMcadTitle2 Members Legend
Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitle2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle2 Members Properties
IMcadTitle2 Members Legend
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
BlockId | This is BlockId, a member of class IMcadTitle2.
BlockId32 | This is BlockId32, a member of class IMcadTitle2.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface > IMcadTitle2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitle Members
Legend
Property
read only
Method


IMcadTitle Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle Members Methods
IMcadTitle Members Legend
Methods
Name | Description
SetToDefaultAttributes | Initialize default attributes of the title block.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitle Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitle Members Properties
IMcadTitle Members Legend
Properties
Name | Description
Attributes | Property that specifies all the attributes for the title block.
InActive | Property that specifies the title block is inactive or invisible.
Name | Property that specifies the name identifier of the title block.
Position | Property that returns the position of the title block.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface > IMcadTitle Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorder Members
Legend
Property
read only
Method


IMcadTitleBorder Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder Members Methods
IMcadTitleBorder Members Legend
Methods
Name | Description
Modify | Modifies this title/border.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorder Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorder Members Properties
IMcadTitleBorder Members Legend
Properties
Name | Description
Descriptor | Property that returns the descriptor for this title/border.
Ref | Property that returns a reference to the title/border object.
Ref32 | Property that returns a reference to the title/border object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface > IMcadTitleBorder Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorderContext Members
Legend
Property
Method


IMcadTitleBorderContext Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext Members Methods
IMcadTitleBorderContext Members Legend
Methods
Name | Description
GetMoveObjectsIDs | Get list of objects to be moved within the drawing border.
GetMoveObjectsIDs32 | Get list of objects to be moved within the drawing border.
GetMoveObjectsToPoint | Get destination point within the drawing border.
GetPartReference | Get objectId of the part reference to retrieve the attribute from.
GetPartReference32 | Get objectId of the part reference to retrieve the attribute from.
SetMoveObjects | Set list of objects to be moved and destination point within the drawing border.
SetPartReference | Set object ID of the part reference to retrieve the attribute from.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorderContext Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderContext Members Properties
IMcadTitleBorderContext Members Legend
Properties
Name | Description
AutomaticPlacement | Property that specifies option for automatic placement.
BaseScale | Property that specifies option to set base scale factor.
DwgDefault | Property that specifies option to set drawing defaults.
MoveObjects | Property that specifies option to move specified objects within the drawing border.
Rescale | Property that specifies option to perform rescale.
RetrieveFromAsmProp | Property that specifies option to retrieve from assembly properties.
RetrieveFromPartRef | Property that specifies option to retrieve from part reference.
ThawAllLayers | Property that specifies option to thaw all layers for position of the title/border.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface > IMcadTitleBorderContext Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorderDescriptor Members
Legend
Property
read only


IMcadTitleBorderDescriptor Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderDescriptor Members Properties
IMcadTitleBorderDescriptor Members Legend
Properties
Name | Description
Border | Property that returns the drawing border for the title/border.
Position | Property that specifies the position of the title/border.
Title | Property that returns the title block for the title/border.
TitleBorderScale | Property that specifies scale for title/border.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface > IMcadTitleBorderDescriptor Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorderMgr Members
Legend
Property
read only
Method


IMcadTitleBorderMgr Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr Members Methods
IMcadTitleBorderMgr Members Legend
Methods
Name | Description
CreateTitleBorder | Creates a new title/border.
DeleteTitleBorder | Removes the specified title/border from the drawing.
GetTitleBorderFromRef | Gets title border object from the specified object ID.
NewContext | Creates and initializes a new title border context.
NewDescriptor | Creates and initializes a new title border descriptor.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorderMgr Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderMgr Members Properties
IMcadTitleBorderMgr Members Legend
Properties
Name | Description
TitleBorders | Property that returns the list of all titles/borders in the drawing.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface > IMcadTitleBorderMgr Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorders Members
Legend
Property
read only
Method


IMcadTitleBorders Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders Members Methods
IMcadTitleBorders Members Legend
Methods
Name | Description
Item | Obtains a specified title/border from the collection.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorders Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorders Members Properties
IMcadTitleBorders Members Legend
Properties
Name | Description
Application | Property that returns the application object.
Count | Property that returns the total number of title/border objects in the collection.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface > IMcadTitleBorders Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorderStandard2 Members
Legend
Property
read only
Method


IMcadTitleBorderStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2 Members Methods
IMcadTitleBorderStandard2 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorderStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard2 Members Properties
IMcadTitleBorderStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
InsertInvertPart | Specifies if an inverted drawing number block will be inserted when a title border is created.
InvertPartBorderHeight | Specifies the height of the inverted drawing number block.
InvertPartBorderWidth | Specifies the width of the inverted drawing number block.
InvertPartTextHeight | Specifies the height of the text in the inverted drawing number block.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface > IMcadTitleBorderStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTitleBorderStandard Members
Legend
Property
read only
Method


IMcadTitleBorderStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard Members Methods
IMcadTitleBorderStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadTitleBorderStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTitleBorderStandard Members Properties
IMcadTitleBorderStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
DefaultPaperFormat | Property that specifies the default paper format for the title/border.
DefaultRevisionList | Property that specifies the default revision list.
DefaultTitleBlock | Property that specifies the default title block for the title/border.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
PaperFormats | Property that returns the available paper formats in the Drawing Sheet standard element.
Revision | Gets the revision version of a symbol standard.
RevisionLists | Property that returns available revision lists in the Drawing Sheet standard element.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
TitleBlocks | Property that returns available title blocks in the Drawing Sheet standard element.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface > IMcadTitleBorderStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface > IMcadTransaction Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadTransaction Members
Legend
Property
read only


IMcadTransaction Members Properties

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface > IMcadTransaction Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadTransaction Members Properties
IMcadTransaction Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.


Properties

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface > IMcadTransaction Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadUtility2 Members
Legend
Method
Property
read only


IMcadUtility2 Members Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility2 Members Methods
IMcadUtility2 Members Legend
Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view


Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadUtility2 Members Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility2 Members Properties
IMcadUtility2 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface > IMcadUtility2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadUtility3 Members
Legend
Method
Property
read only


IMcadUtility3 Members Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility3 Members Methods
IMcadUtility3 Members Legend
Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetDrawingType | Obtains the DWG drawing type from the side database.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.
RefocusObject | Repath the folder, component view or hide situation to the target view


Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadUtility3 Members Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility3 Members Properties
IMcadUtility3 Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface > IMcadUtility3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadUtility Members
Legend
Property
read only
Method


IMcadUtility Members Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility Members Methods
IMcadUtility Members Legend
Methods
Name | Description
CreateAttribute | Creates a new attribute instance using a specified ClassName as input.
CreateAttributeField | Creates a new attribute field object.
CreateCollection | Creates a collection object for the specified type.
CreatePickObject | Creates a new pick object.
CreateSystemAttribute | Creates a new system attribute instance.
GetAllAttributes | Gets all of the attributes in the drawing.
GetAttributeFromID | Gets the attribute from a specified object ID.
GetAttributeFromID32 | Gets the attribute object from an object ID.
GetGeometryFromPick | Obtains a geometry reference object of the specified type from the specified pick object.
GetIdsFromObject | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetIdsFromObject32 | Gets the object ID or multiple object IDs that constitute the object being referenced.
GetObjectFromID | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromID32 | Obtains a geometry reference object of the specified type from the specified object ID.
GetObjectFromPick | Creates an object reference of the specified type from the specified pick object.
Pick | Prompts users to pick an object of the specified type, such as component view, detail view, annotation view, and standard part and create an McadPick object with the specific information about the pick that can be used to construct a reference object.


Methods

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadUtility Members Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadUtility Members Properties
IMcadUtility Members Legend
Properties
Name | Description
Application | Gets the AcadmApplication object.
Document | Gets the corresponding McadDocument from the specified host application's document.


Properties

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface > IMcadUtility Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWelding2 Members
Legend
Method
Property
read only


IMcadWelding2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding2 Members Methods
IMcadWelding2 Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
InsertProcess | This is InsertProcess, a member of class IMcadWelding2.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWelding2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding2 Members Properties
IMcadWelding2 Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface > IMcadWelding2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWelding Members
Legend
Property
read only
Method


IMcadWelding Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding Members Methods
IMcadWelding Members Legend
Methods
Name | Description
AddLeader | Adds a leader with the specified nodes to a symbol.
AddSubWelding | Add a new subweld symbol to the weld symbol.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AngleValue | Specifies the value of the angle field for the weld symbol at the arrow side and at the other side.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AreaType | Specifies the type of the supplementary weld symbol describing the weld area.
AssociationType | Specifies the weld association type for the weld symbol.
AssociationType | Specifies the weld association type for the weld symbol.
AttachGeometry | Attaches the symbol's leader to the specified geometry reference object, with the leader arrowhead at the specified location.
BackingValue | Specifies the value of the backing field for the weld symbol.
BackingValue | Specifies the value of the backing field for the weld symbol.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
Brazing | Specifies whether a brazing arrow is enabled on the weld symbol, TRUE, or not, FALSE.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
BrazingValue | Specifies the value of the brazing field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClearanceValue | Specifies the value of the clearance field for the weld symbol.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ClosedTail | Specifies whether the tail is closed for the weld symbol, TRUE, or not, FALSE.
ContourType | Specifies the type of the contour symbol.
ContourType | Specifies the type of the contour symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ContourValue | Specifies the value of the contour field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
ControlCategoryValue | Specifies the value of the weld control category field for the weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DepthValue | Specifies the value of the depth field for a weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DesignationValue | Specifies the value of the weld designation field for the weld symbol.
DetachGeometry | Detaches the specified symbol's leader from any attached geometry references or views.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FieldWeld | Specifies whether the field weld subsymbol is set for the weld symbol, TRUE, or not, FALSE.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
FinishingValue | Specifies the value of the finishing method field for the contour weld symbol.
GapValue | Specifies the size of the gap between weldments.
GapValue | Specifies the size of the gap between weldments.
GetLeader | Gets the positions of the nodes of the specified leader.
GetLeaderAttachment | Gets the attached geometry reference object, if present, for the symbol's leader.
HighlightSubWelding | Highlights the subwelding symbol at the specified index.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IdentificationLine | Specifies the type of identification line used for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexTotalValue | Specifies the value of the total count of index field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
IndexValue | Specifies the value of the index number field for the weld symbol.
InsertLeaderNode | Inserts the specified node point into a symbol's leader before the specified existing node.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderArrowType | Specifies the leader arrow type for the selected symbol leaders.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderColor | Specifies the color of a symbol's leader line.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLanding | Variant (long); input-only; optional. Specifies which of multiple leaders to specify the landing for.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LeaderLineType | Specifies the linetype for a specific symbol's leader.
LengthValue | Specifies the value of the length field for the weld symbol.
LengthValue | Specifies the value of the length field for the weld symbol.
MoveLeaderNode | Moves the specified leader node associated with a symbol to a new position.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NotesValue | Specifies the supplementary data in the notes field for a weld symbol.
NumberValue | Specifies the number of welds for specific weld symbol types.
NumberValue | Specifies the number of welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
PitchValue | Specifies the distance between the centers of the welds for specific weld symbol types.
RemoveLeader | Removes the specified leader from a symbol.
RemoveLeaderNode | Removes the specified leader nodes from the symbol's leader.
RemoveSubWelding | Removes the subwelding symbol at the specified index.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymType | Specifies the type of the secondary symbol type for the weld symbol.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SecondarySymTypeValue | Specifies the value of the secondary symbol type field for specific weld symbol types.
SetToDefaults | Sets the properties of this symbol to the factory default values.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
Size2Value | Specifies the value of the size 2 field for specific weld symbol types.
SizeType | Specifies the type of the size for the weld symbol.
SizeType | Specifies the type of the size for the weld symbol.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeTypeValue | Specifies the value of the size type field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SizeValue | Specifies the value of the size field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpacingValue | Specifies the value of the spacing field for specific weld symbol types.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
SpecificationValue | Specifies the value of the weld specification field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
StandardValue | Specifies the value of the weld standard field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
TechnicalReqValue | Specifies the value of the technical requirements field for the weld symbol.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
ThicknessValue | Specifies the value of the thickness field for specific weld symbol types.
Type | Specifies the type of the symbol for a weld symbol.
Type | Specifies the type of the symbol for a weld symbol.
UpdateToAttachedObject | Update symbol when attached object is modified.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWelding Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWelding Members Properties
IMcadWelding Members Legend
Properties
Name | Description
CoordinateSystem | Specifies the coordinate system for the symbol.
IsAttached | Specifies whether this symbol is attached to geometry or a view, TRUE, or not, FALSE.
LeaderCount | Gets the number of leaders attached to a specific symbol.
Orientation | Specifies the orientation of the arrow data and other data for a weld symbol.
Origin | Specifies the origin point in paper units of a symbol relative to the lower-left corner of the media edge by the paper margin.
Scale | Specifies the scale factor of a symbol. This option is available only if the symbol is not attached to any object.
Standard | Gets the standard this symbol is used in.
SubWeldingCount | Gets the number of subwelding symbols for a weld symbol.
SymbolStandard | Specifies the symbol standard for a symbol.


Properties

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface > IMcadWelding Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWeldingLibrary Members
Legend
Method


IMcadWeldingLibrary Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibrary Members Methods
IMcadWeldingLibrary Members Legend
Methods
Name | Description
appendItem | Add the data in this SymId to the library.
appendItemFromSubWelding | Append a subwelding symbol at the specified index to the welding symbol library.
DefaultItem | Get the default symbol library object of a symbol library.
findItem | Get a symbol library object. Return the Symbol standard class name.
findList | Get a list of symbol library objects.
isItemExist | Check the existence of a symbol library object. Return the Symbol standard class name.
loadItem | Get the data of this library object, itemName and load into SymId. This method will check the symbol type compatiability.
loadItemToSubWelding | Load a subwelding symbol library object to a weld symbol at the specified index.
modifyItem | Update the data in this library object.
modifyItemFromSubWelding | Update the data in library object, itemName, with SymId at index, SubWeldingIndex.
removeItem | Remove a symbol library object from a symbol library.
renameItem | Update the name of the library object, itemName, with newName.
setIsDefaultItem | Set the default status of the library object.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface > IMcadWeldingLibrary Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


Legend

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWeldingLibraryObject Members
Legend
Property
read only
Method


IMcadWeldingLibraryObject Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject Members Methods
IMcadWeldingLibraryObject Members Legend
Methods
Name | Description
ArrowSideReqValue | Get the arrow side requirement value of welding library object.
OtherSideReqValue | Get the requirement value for other side of welding symbol type.
RequirementValue | Get the main requirement value for welding symbol type.
setIsDefault | Change the default of this object.
Type | Get the type of the symbol for a weld symbol.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWeldingLibraryObject Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingLibraryObject Members Properties
IMcadWeldingLibraryObject Members Legend
Properties
Name | Description
AreaType | Get the type of supplementary weld symbol describing the weld area.
AssociationType | Get the weld association type for a welding library object.
ClosedTail | Get whether the tail is closed for a welding library object.
entryName | Specifies the name of a symbol library object.
FieldWeld | Get whether the field weld is set for a welding library object.
IdentificationLine | Get the location of the identification line for a welding library object.
isDefault | Change the default of this object. There will be only one default in for each standard and symbol standard.
standardName | Gets the standard name of a library object.
symbolStandardClassName | Get the symbol standard class name.


Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface > IMcadWeldingLibraryObject Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWeldingStandard2 Members
Legend
Property
read only
Method


IMcadWeldingStandard2 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard2 Members Methods
IMcadWeldingStandard2 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWeldingStandard2 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard2 Members Properties
IMcadWeldingStandard2 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number


Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface > IMcadWeldingStandard2 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWeldingStandard3 Members
Legend
Property
read only
Method


IMcadWeldingStandard3 Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3 Members Methods
IMcadWeldingStandard3 Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWeldingStandard3 Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard3 Members Properties
IMcadWeldingStandard3 Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
ProcessGap | Specifies the scale factor applied to symbols within a welding symbol.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
ScaleFactor | Specifies the gap between the 1st and 2nd welding processes within a welding symbol.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.
WeldProcessPrefix | Specifies the prefix string to prepend to the process number


Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface > IMcadWeldingStandard3 Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


Legend

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
IMcadWeldingStandard Members
Legend
Property
read only
Method


IMcadWeldingStandard Members Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard Members Methods
IMcadWeldingStandard Members Legend
Methods
Name | Description
SetToDefaults | Sets the properties of this symbol standard to the factory default values.
SetToDefaultTextLeader | Set default values for text height, text color, arrow size, arrow type and leader color to the same as that in master standard.
SupportedArrowTypes | Property that specifies the list of arrow types that are supported by this symbol standard. Returns McadArrowType.


Methods

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Method


IMcadWeldingStandard Members Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
IMcadWeldingStandard Members Properties
IMcadWeldingStandard Members Legend
Properties
Name | Description
ArrowScale | Specifies the arrow scale of a leader in a symbol that belongs to this symbol standard.
ArrowType | Specifies the arrow type of leader in symbol that belongs to this symbol standard.
AvailableBackingSymbols | Gets the list of backing weld symbols that are available for backing symbols referencing this standard.
AvailableContourSymbols | Gets the list of contour weld symbols that are available for backing symbols referencing this standard.
AvailableWeldSymbols | Gets the list of weld symbols that are available for backing symbols referencing this standard.
ClosedTailAllowed | Gets whether a closed tail is allowed for symbols referencing this standard.
IdentificationLineAllowed | Gets whether identification lines are supported for weld symbols referencing this standard, TRUE, or not, FALSE.
IdentificationLineGap | Specifies the gap distance between identification lines for weld symbols referencing this standard.
IdentificationLinetype | Specifies the linetype of the identification line for weld symbols referencing this standard.
IdentificationLinetypeName | Specifies the linetype name of the identification line for weld symbols referencing this standard.
LeaderTrueColor | Specifies the true color of leader in symbol that belongs to this symbol standard.
MultipleSymbolsAllowed | Gets whether multiply subwelding symbols are allowed for weld symbols created referencing this standard, TRUE, or not, FALSE.
OfferedBackingSymbols | Specifies the list of backing symbols that are offered for weld symbols created referencing this standard.
OfferedContourSymbols | Specifies the list of contour symbols that are offered for symbols created referencing this standard.
OfferedWeldSymbols | Specifies the list of weld symbols that are offered for symbols created referencing this standard.
Revision | Gets the revision version of a symbol standard.
RevisionYear | Gets the revision version year of a symbol standard.
Standard | Gets the standard that a symbol standard is used in.
SymbolStandardClassName | Property that specifies symbol standard class name by this symbol standard, which is used to identify symbol library object.
TextHeight | Specifies the height of text in symbol that belongs to this symbol standard.
TextTrueColor | Specifies the true color of text in a symbol that belongs to this symbol standard.


Properties

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface > IMcadWeldingStandard Members
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Legend
Legend
Property
read only


AcadmAuto Library CoClasses

You are here: API Reference > AcadmAuto Library
AcadmAuto Library CoClasses
AcadmAuto Library
CoClasses
Name | Description
AcadmApplication | The AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
Mcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group. The types of complex standard parts are screw connections and part features.
Mcad2dComponentDescriptor | Provides a description of a 2D component.
Mcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
Mcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
Mcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
Mcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
McadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing. Annotation views have no impact on the BOM and can be instantiated without increasing the quantity of the component in the BOM. When a component view instance in the assembly is modified, the changes are automatically reflected in the annotation view and vice versa.
McadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
McadArc | An arc curve.
McadAttribute | Represents an instance of an attribute.
McadAttributeField | Represents the description of a single attribute field.
McadAttributeFields | A collection of McadAttributeField objects.
McadAttributes | A collection of McadAttribute objects.
McadAugmentedLine | A multisegmented curve with normal information at the nodes.
McadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
McadComplexHideSituations | A collection of McadComplexHideSituation objects
McadComponent | References an instance of a component definition in the assembly.
McadComponentDefinition | References the definition of an assembly component.
McadComponentDefinitions | A collection of McadcomponentDefinition objects.
McadComponents | A collection of McadComponent objects.
McadComponentView | A collection of McadComponentView objects.
McadComponentViewDefinition | References the definition of a component view.
McadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
McadComponentViewDescriptor | Encapsulates the description of a 2D component view.
McadComponentViews | A collection of McadComponentView objects.
McadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
McadDocuments | The collection of McadDocument objects present in the application.
McadEllipse | An ellipse or elliptical arc object.
McadFolder | References an instance of a folder definition.
McadFolderDefinition | A collection of McadFolderDefinition objects.
McadFolderDefinitions | A collection of McadFolderDefinition objects.
McadFolderDescriptor | Encapsulates the description of a folder.
McadFolders | A collection of McadFolder objects.
McadFormulaEvaluator | This object provides general methods for Standard Data provider
McadHideSituation | This object provides general methods for 2D structure hide situations.
McadHideSituations | This object provides general methods for 2D structure hide situations.
McadLayerCfg | This is class AcadmAuto::McadLayerCfg.
McadLayerCfgs | This is class AcadmAuto::McadLayerCfgs.
McadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
McadLayerObjectCfg | This is class AcadmAuto::McadLayerObjectCfg.
McadLayerObjectCfgs | This is class AcadmAuto::McadLayerObjectCfgs.
McadLayerObjectMgr | This is class AcadmAuto::McadLayerObjectMgr.
McadLine | An unbounded line object.
McadObjects | A collection of IMcadObject subtype objects.
McadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
McadPolyline | A polyline object.
McadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
McadSpline | A spline object.
McadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
McadTransaction | The McadTransaction object. These are created using the Mcad2DStructureMgr.StartTransaction property. Transactions allow a group of operations to be treated at an atomic unit.
McadUtility | This API provides some general utility methods.


AcadmAuto Library Enumerations

You are here: API Reference > AcadmAuto Library
AcadmAuto Library Enumerations
AcadmAuto Library Legend
Enumerations
Name | Description
Mcad2DSViewType | Enumerates the 2D structure view types.
McadCollectionType | Enumerates all collection types for which to create the new collection. Some of collection types can only be used in Mechanical Desktop. mcAttributeFields : Specifies the collection of attribute fields. mcAttributes : Specifies the collection of attributes. mcComponentDefinitions : Specifies the collection of component definitions. mcComponents : Specifies the collection of components. mcObjects : Specifies the collection of Mcad objects. mcComponentViews : Specifies the collection of component views. mcComponentViewDefinitions : Specifies the collection of component view definitions. mcFolders : Specifies the collection of folders. mcFolderDefinitions : Specifies the collection of folder definitions. mcAnnotationViewDefinitions : Specifies the collection of the annotation... more
McadDocDrawingType | type McadDocDrawingType
McadFieldType | Enumerates the field value types. mcShort : Indicates the field value is Short. mcLong : Indicates the field value is Long. mcDouble : Indicates the field value is a Double. mcCharacter : Indicates the field value is Character. mcShortArray : Indicates the field value is Array of Short. mcLongArray : Indicates the field value is Array of Long. mcDoubleArray : Indicates the field value is Array of Double. mcString : Indicates the field value is String. mcObjectID : Indicates the field value is Object ID. mcObjectIDArray : Indicates the field value is Array of Object IDs. mcMcadObject : Indicates the... more
McadHideSituationRefType | Enumerates all referenced types for this hide situation. mc2DSDirectRef : Indicates that the leaf or view instance is directly referred by hide situation. mc2DSSubEntRef : Indicates that the leaf or view instance of a subentity of the view is referenced by hide situation. mc2DSPartialRef : Indicates that the view instance is partially or fully referred by hide situation. mc2DSAllRef : It is equivalent to mc2DSDirectRef | mc2DSSubEntRef.
McadHideSituationSubentType | Enumerates all referenced hide subentity types for this hide situation. mc2DSNoEnt : Indicates that there are no subentities. mc2DSFGEnt : Indicates the foreground hide situation. mc2DSBGEnt : Indicates the background hide situation. mc2DSFGExclEnt : Indicates the foreground excluded hide situation. mc2DSBGExclEnt : Indicates the background excluded hide situation. mc2DSUpperBGExclEnt : Indicates the upper background excluded hide situation.
McadLayerObjectHideType | This is record McadLayerObjectHideType.
McadObjectType | Enumerates all generic objects within the Mechanical Desktop or AutoCAD. mcObject : Specifies the McadObject type of the object. mcGeometry : Specifies the McadObject type of the geometry. mcCurve : Specifies the McadObject type of the curve. mcLine : Specifies the McadObject type of the line. mcArc : Specifies the McadObject type of the arc. mcEllipse : Specifies the McadObject type of the ellipse. mcSpline : Specifies the McadObject type of the spline. mcPolyline : Specifies the McadObject type of the polyline. mcAaugmentedLine : Specifies the McadObject type of the augmented line. mcComponent : Specifies the McadObject type of the... more
McadPhantomState | Enumerates all phantom states. mcNormalDef : Specifies the normal state, with a value of 0. mcPhantomDef : Specifies the phantom state, with a value of 1. mcPhantomDefInCurrent : Specifies the phantom state in the current drawing, with a value of 2.
McadPowerObjectType | Enumerates the power object types. mcNoObj : Specifies no power object. mcShaftCalcObj : Specifies the shaft calculation power object. mcCamCalcObj : Specifies the cam calculation power object. mcFEAObj : Specifies the FEA power object. mcMomOfInertiaObj : Specifies the momentum of inertia power object. mcDeflLineObj : Specifies the line power object. mcScrewConObj : Specifies the screw connection of the power object. mcPartFeatObj : Specifies the part feature power object. mcShaftObj : Specifies the shaft power object. mcAllFolderPowerObj : Specifies the all folders power object.
McadSelectionOrderOption | Enumerates all available 2D Structure selection order options.


Enumerations

You are here: API Reference > AcadmAuto Library
Legend
Legend
Enumeration


AcadmAuto Library Interfaces

You are here: API Reference > AcadmAuto Library
AcadmAuto Library Interfaces
AcadmAuto Library Legend
Interfaces
Name | Description
IAcadmApplication | AcadmApplication object is an instance of the AutoCAD Mechanical application. It is the starting point for any kind of enquiry on the objects and provides access to the root of the object hierarchy in AutoCAD Mechanical.
IAcadmApplicationVersion | Version of AutoCAD Mechanical application that is running
IMcad2dComplexStdPartCompGroupDescriptor | Provides a description of a 2D complex standard part component group.
IMcad2dComponentDescriptor | Provides a description of a 2D component.
IMcad2dShaftCompGroupDescriptor | Provides a description of the group of shaft and standard part objects that comprise a shaft power object.
IMcad2dStdPartComponentDescriptor | Provides a description of the 2D standard part component.
IMcad2DStructureDescriptor | This object is the base class for 2D structure descriptors.
IMcad2DStructureMgr | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr2 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr3 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr4 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcad2DStructureMgr5 | This object provides general methods for creating descriptors for 2D structure and getting objects for migration.
IMcadAnnotationViewDefinition | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinition2 | An annotation view is a component view instance that is created exclusively for the purpose of detailing.
IMcadAnnotationViewDefinitions | A collection of McadAnnotationViewDefinition objects.
IMcadArc | An arc curve.
IMcadAttribute | Represents an instance of an attribute.
IMcadAttributeField | Represents the description of a single attribute field.
IMcadAttributeFields | A collection of McadAttributeField objects.
IMcadAttributes | A collection of McadAttribute objects.
IMcadAugmentedLine | A multisegmented curve with normal information at the nodes.
IMcadComplexHideSituation | This object provides general methods for 2D structure complex hide situations.
IMcadComplexHideSituations | A collection of McadComplexHideSituation objects
IMcadComponent | References an instance of a component definition in the assembly.
IMcadComponentDefinition | References the definition of an assembly component.
IMcadComponentDefinitions | A collection of McadcomponentDefinition objects.
IMcadComponents | A collection of McadComponent objects.
IMcadComponentView | A collection of McadComponentView objects.
IMcadComponentViewDefinition | References the definition of a component view.
IMcadComponentViewDefinitions | A collection of McadComponentViewDefinition objects.
IMcadComponentViewDescriptor | Encapsulates the description of a 2D component view.
IMcadComponentViews | A collection of McadComponentView objects.
IMcadCurve | A generic curve entity.
IMcadDescriptor | A generic descriptor object that contains the overall description of an object.
IMcadDocuments | The collection of McadDocument objects present in the application.
IMcadDocumentVersion | Version of AutoCAD Mechanical that saved the file.
IMcadEllipse | An ellipse or elliptical arc object.
IMcadFolder | References an instance of a folder definition.
IMcadFolder2 | References an instance of a folder definition.
IMcadFolderDefinition | A collection of McadFolderDefinition objects.
IMcadFolderDefinitions | A collection of McadFolderDefinition objects.
IMcadFolderDescriptor | Encapsulates the description of a folder.
IMcadFolders | A collection of McadFolder objects.
IMcadFormulaEvaluator | This object provides general methods for Standard Data provider
IMcadGeometry | This is class IMcadGeometry.
IMcadHideSituation | This object provides general methods for 2D structure hide situations.
IMcadHideSituations | A collection of AMSHide objects.
IMcadLayerCfg | This class contains the configuration settings for a mechanical layer.
IMcadLayerCfgs | This is class IMcadLayerCfgs.
IMcadLayerGroupMgr | Provides access to methods and properties used to manage layers in documents.
IMcadLayerObjectCfg | This class contains the configuration settings for a mechanical object.
IMcadLayerObjectCfgs | This is class IMcadLayerObjectCfgs.
IMcadLayerObjectMgr | This class is for accessing the layer object settings.
IMcadLine | An unbounded line object.
IMcadObject | A reference to a generic object or sub-object within the Mechanical Desktop, AutoCAD or AutoCAD Mechanical.
IMcadObjects | A collection of IMcadObject subtype objects.
IMcadPick | McadPick object from the AutoCAD ActiveX Automation represents a selection of an object on the screen.
IMcadPolyline | A polyline object.
IMcadPowObjViewGroupDescriptor | Encapsulates the description of a power object view group. In other words, it represents the group of views that are in the same power object.
IMcadSpline | A spline object.
IMcadStdPartComponentViewDescriptor | Encapsulates the description of a component view of a standard part.
IMcadUtility | This API provides some general utility methods.
IMcadUtility2 | This is class IMcadUtility2.
IMcadUtility3 | This is class IMcadUtility3.


Interfaces

You are here: API Reference > AcadmAuto Library
Legend
Legend
Interface


Legend

You are here: API Reference > AcadmAuto Library
Legend
AcadmAuto Library
Legend
Interface
Enumeration


Class Hierarchy

You are here: API Reference > AcadmAuto Library > AcadmApplication CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
AcadmApplication CoClass
Class Hierarchy
AcadmAuto::AcadmApplication


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2dComplexStdPartCompGroupDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2dComplexStdPartCompGroupDescriptor CoClass
Class Hierarchy
AcadmAuto::Mcad2dComplexStdPartCompGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2dComponentDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2dComponentDescriptor CoClass
Class Hierarchy
AcadmAuto::Mcad2dComponentDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2dShaftCompGroupDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2dShaftCompGroupDescriptor CoClass
Class Hierarchy
AcadmAuto::Mcad2dShaftCompGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2dStdPartComponentDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2dStdPartComponentDescriptor CoClass
Class Hierarchy
AcadmAuto::Mcad2dStdPartComponentDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2DStructureDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2DStructureDescriptor CoClass
Class Hierarchy
AcadmAuto::Mcad2DStructureDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > Mcad2DStructureMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
Mcad2DStructureMgr CoClass
Class Hierarchy
AcadmAuto::Mcad2DStructureMgr


Example

You are here: API Reference > AcadmAuto Library > McadAnnotationViewDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
McadAnnotationViewDefinition CoClass

Refer to SDK Samples: CreateStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAnnotationViewDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAnnotationViewDefinition CoClass
Class Hierarchy
AcadmAuto::McadAnnotationViewDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAnnotationViewDefinitions CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAnnotationViewDefinitions CoClass
Class Hierarchy
AcadmAuto::McadAnnotationViewDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadArc CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadArc CoClass
Class Hierarchy
AcadmAuto::McadArc


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAttribute CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAttribute CoClass
Class Hierarchy
AcadmAuto::McadAttribute


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAttributeField CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAttributeField CoClass
Class Hierarchy
AcadmAuto::McadAttributeField


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAttributeFields CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAttributeFields CoClass
Class Hierarchy
AcadmAuto::McadAttributeFields


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAttributes CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAttributes CoClass
Class Hierarchy
AcadmAuto::McadAttributes


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadAugmentedLine CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAugmentedLine CoClass
Class Hierarchy
AcadmAuto::McadAugmentedLine


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComplexHideSituation CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComplexHideSituation CoClass
Class Hierarchy
AcadmAuto::McadComplexHideSituation


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComplexHideSituations CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComplexHideSituations CoClass
Class Hierarchy
AcadmAuto::McadComplexHideSituations


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponent CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponent CoClass
Class Hierarchy
AcadmAuto::McadComponent


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentDefinition CoClass
Class Hierarchy
AcadmAuto::McadComponentDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentDefinitions CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentDefinitions CoClass
Class Hierarchy
AcadmAuto::McadComponentDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponents CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponents CoClass
Class Hierarchy
AcadmAuto::McadComponents


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentView CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentView CoClass
Class Hierarchy
AcadmAuto::McadComponentView


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentViewDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentViewDefinition CoClass
Class Hierarchy
AcadmAuto::McadComponentViewDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentViewDefinitions CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentViewDefinitions CoClass
Class Hierarchy
AcadmAuto::McadComponentViewDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentViewDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentViewDescriptor CoClass
Class Hierarchy
AcadmAuto::McadComponentViewDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadComponentViews CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadComponentViews CoClass
Class Hierarchy
AcadmAuto::McadComponentViews


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadDocument CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDocument CoClass
Class Hierarchy
AcadmAuto::McadDocument


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadDocuments CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDocuments CoClass
Class Hierarchy
AcadmAuto::McadDocuments


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadEllipse CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadEllipse CoClass
Class Hierarchy
AcadmAuto::McadEllipse


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFolder CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFolder CoClass
Class Hierarchy
AcadmAuto::McadFolder


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFolderDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFolderDefinition CoClass
Class Hierarchy
AcadmAuto::McadFolderDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFolderDefinitions CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFolderDefinitions CoClass
Class Hierarchy
AcadmAuto::McadFolderDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFolderDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFolderDescriptor CoClass
Class Hierarchy
AcadmAuto::McadFolderDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFolders CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFolders CoClass
Class Hierarchy
AcadmAuto::McadFolders


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadFormulaEvaluator CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFormulaEvaluator CoClass
Class Hierarchy
AcadmAuto::McadFormulaEvaluator


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadHideSituation CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadHideSituation CoClass
Class Hierarchy
AcadmAuto::McadHideSituation


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadHideSituations CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadHideSituations CoClass
Class Hierarchy
AcadmAuto::McadHideSituations


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerCfg CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerCfg CoClass
Class Hierarchy
AcadmAuto::McadLayerCfg


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerCfgs CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerCfgs CoClass
Class Hierarchy
AcadmAuto::McadLayerCfgs


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerGroupMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerGroupMgr CoClass
Class Hierarchy
AcadmAuto::McadLayerGroupMgr


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerObjectCfg CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerObjectCfg CoClass
Class Hierarchy
AcadmAuto::McadLayerObjectCfg


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerObjectCfgs CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerObjectCfgs CoClass
Class Hierarchy
AcadmAuto::McadLayerObjectCfgs


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLayerObjectMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLayerObjectMgr CoClass
Class Hierarchy
AcadmAuto::McadLayerObjectMgr


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadLine CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadLine CoClass
Class Hierarchy
AcadmAuto::McadLine


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadObjects CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadObjects CoClass
Class Hierarchy
AcadmAuto::McadObjects


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadPick CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPick CoClass
Class Hierarchy
AcadmAuto::McadPick


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadPolyline CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPolyline CoClass
Class Hierarchy
AcadmAuto::McadPolyline


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadPowObjViewGroupDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPowObjViewGroupDescriptor CoClass
Class Hierarchy
AcadmAuto::McadPowObjViewGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadSpline CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSpline CoClass
Class Hierarchy
AcadmAuto::McadSpline


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadStdPartComponentViewDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadStdPartComponentViewDescriptor CoClass
Class Hierarchy
AcadmAuto::McadStdPartComponentViewDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadTransaction CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTransaction CoClass
Class Hierarchy
AcadmAuto::McadTransaction


Class Hierarchy

You are here: API Reference > AcadmAuto Library > McadUtility CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadUtility CoClass
Class Hierarchy
AcadmAuto::McadUtility


API Reference Libraries

You are here: API Reference
API Reference Libraries
API Reference
Libraries
Name | Description
AcadmAuto | The Autodesk AutoCAD Mechanical Type Library is used for AutoCAD Mechanical ActiveX Automation. It contains the classes, functions, and properties pertaining to 2D structure.
SymBBAuto | The Autodesk SymBBAuto 3.0 Type Library is used for Symbol, Balloon, and Bill of Materials. Various objects for handling standards, BOMs and symbols are provided.
GEAuto | The Autodesk GeAuto Type Library consists of utility classes for performing common 2D and 3D algebra, such as vectors and matrices. It provides geometric objects such as points, curves, and surfaces and supports geometry query and manipulation.


Topics

You are here: API Reference
Topics
API Reference
Topics
Name | Description
Mcad2DSPreview | Mechanical Structure Preview ActiveX Control (Mcad2DSPreview). Allows users to display a thumbnail bitmap of a block, a list of entities, a folder, a component view, or an entire component (tiled views).


GEAuto Library CoClasses

You are here: API Reference > GEAuto Library
GEAuto Library CoClasses
GEAuto Library
CoClasses
Name | Description
GeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
GeAugmentedLine | A multisegmented curve with normal information at the nodes.
GeBoundBlock | A spatial bounding volume.
GeBoundedSurface | Surface with trimming boundary information.
GeCircularArc | A circle or circular arc curve.
GeCompositeCurve | A curve composed of multiple component curves connected end to end.
GeCone | A bounded right circular cone.
GeCurveBoundaries | A collection of GeCurveBoundary objects.
GeCurveBoundary | A representation for one of a surface's boundaries.
GeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves.
GeCurves | A collection of GeCurve objects.
GeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
GeCylinder | A cylindrical surface.
GeEllipticalArc | An ellipse or elliptical arc.
GeEntities | A collection of GeEntity objects.
GeInterval | Represents an interval of the real axis to define bounds.
GeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
GeLine | An unbounded line.
GeLineSegment | A bounded line segment.
GeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
GeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
GeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
GeOffsetCurve | An exact offset of another curve.
GeOffsetSurface | An exact offset of another surface.
GePlane | An infinite plane in three dimensional space.
GePoint | A three-dimensional point object.
GePoints | A collection of GePoint objects.
GeRay | A line bounded at one end.
GeSphere | A spherical surface.
GeSurfaces | A collection of GeSurface objects.
GeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
GeTolerance | Encapsulates tolerance values to use in calculations.
GeTorus | A toroid or toroidal segment surface.
GeVector | A vector in three-dimensional space.
GeVectors | A collection of GeVector objects.


GEAuto Library Enumerations

You are here: API Reference > GEAuto Library
GEAuto Library Enumerations
GEAuto Library Legend
Enumerations
Name | Description
GeCollectionType | Enumerates all collection types of geometry entity objects.
GeCurveCurveIntConfiguration | Enumerates the characterization of the intersection between curves, circles, or circular arcs. This characterization is only meaningful if the curves being intersected are both planar and coplanar with each other within the specified tolerance.
GeCurveSurfIntConfiguration | Enumerates all intersection characterization in the neighborhood just above and below the intersection between the curve and the surface.
GeNurbSurfaceProperties | type GeNurbSurfaceProperties geOpen : Description to come geClosed : Description to come gePeriodic : Description to come geRational : Description to come geNoPoles : Description to come gePoleAtMin : Description to come gePoleAtMax : Description to come gePoleAtBoth : Description to come
GeSurfSurfIntConfiguration | Enumerates all intersection characterization of the specified intersection in the neighborhood of a surface just to the left or right of the surface-surface intersection curve with respect to the second surface.
GeSurfSurfIntType | Enumerates all intersection types between two surfaces.


Enumerations

You are here: API Reference > GEAuto Library
Legend
Legend
Enumeration


GEAuto Library Interfaces

You are here: API Reference > GEAuto Library
GEAuto Library Interfaces
GEAuto Library Legend
Interfaces
Name | Description
IGeApplication | An instance of the geometry application object. It is the starting point for enquiry on geometry objects within AutoCAD Mechanical.
IGeAugmentedLine | A multisegmented curve with normal information at the nodes.
IGeBoundBlock | A spatial bounding volume.
IGeBoundedSurface | Surface with trimming boundary information.
IGeCircularArc | A circle or circular arc curve.
IGeCompositeCurve | A curve composed of multiple component curves connected end to end.
IGeCone | A bounded right circular cone.
IGeCurve | A generic curve entity.
IGeCurveBoundaries | A collection of GeCurveBoundary objects.
IGeCurveBoundary | A representation for one of a surface's boundaries.
IGeCurveCurveIntersection | Calculates and provides access to the intersection properties between two curves. This object can also be used to calculate self intersection points of a curve by setting both curves with the same curve.
IGeCurves | A collection of GeCurve objects.
IGeCurveSurfaceIntersection | Calculates and provides access to the intersection properties between a curve and a surface.
IGeCylinder | A cylindrical surface.
IGeEllipticalArc | An ellipse or elliptical arc.
IGeEntities | A collection of GeEntity objects.
IGeEntity | A generic geometric entity. Subtypes: GeBoundBlock, IGeCurve, GePoint, IGeSurface.
IGeInterval | Represents an interval of the real axis to define bounds.
IGeKnotVector | An ordered sequence knot values making up a knot vector for NURB entities.
IGeLine | An unbounded line.
IGeLinearEntity | A generic linear entity.
IGeLineSegment | A bounded line segment.
IGeMatrix | A 4 x 4 matrix representing an affine transformation including translation.
IGeNurbCurve | A Non-Uniform Rational B-spline, or NURB curve.
IGeNurbSurface | A Non-Uniform Rational B-spline, or NURB surface.
IGeOffsetCurve | An exact offset of another curve.
IGeOffsetSurface | An exact offset of another surface.
IGePlane | An infinite plane in three-dimensional space.
IGePoint | A three-dimensional point object.
IGePoints | A collection of GePoint objects.
IGeRay | A line bounded at one end.
IGeSphere | A spherical surface.
IGeSurface | A generic surface entity.
IGeSurfaces | A collection of GeSurface objects.
IGeSurfaceSurfaceIntersection | Calculates the intersection between two surfaces.
IGeTolerance | Encapsulates tolerance values to use in calculations.
IGeTorus | A toroid or toroidal segment surface.
IGeVector | A vector in three-dimensional space.
IGeVectors | A collection of GeVector objects.


Interfaces

You are here: API Reference > GEAuto Library
Legend
Legend
Interface


Legend

You are here: API Reference > GEAuto Library
Legend
GEAuto Library
Legend
Interface
Enumeration


Class Hierarchy

You are here: API Reference > GEAuto Library > GeApplication CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeApplication CoClass
Class Hierarchy
GEAuto::GeApplication


Class Hierarchy

You are here: API Reference > GEAuto Library > GeAugmentedLine CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeAugmentedLine CoClass
Class Hierarchy
GEAuto::GeAugmentedLine


Class Hierarchy

You are here: API Reference > GEAuto Library > GeBoundBlock CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeBoundBlock CoClass
Class Hierarchy
GEAuto::GeBoundBlock


Class Hierarchy

You are here: API Reference > GEAuto Library > GeBoundedSurface CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeBoundedSurface CoClass
Class Hierarchy
GEAuto::GeBoundedSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCircularArc CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCircularArc CoClass
Class Hierarchy
GEAuto::GeCircularArc


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCompositeCurve CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCompositeCurve CoClass
Class Hierarchy
GEAuto::GeCompositeCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCone CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCone CoClass
Class Hierarchy
GEAuto::GeCone


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCurveBoundaries CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCurveBoundaries CoClass
Class Hierarchy
GEAuto::GeCurveBoundaries


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCurveBoundary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCurveBoundary CoClass
Class Hierarchy
GEAuto::GeCurveBoundary


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCurveCurveIntersection CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCurveCurveIntersection CoClass
Class Hierarchy
GEAuto::GeCurveCurveIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCurves CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCurves CoClass
Class Hierarchy
GEAuto::GeCurves


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCurveSurfaceIntersection CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCurveSurfaceIntersection CoClass
Class Hierarchy
GEAuto::GeCurveSurfaceIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > GeCylinder CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeCylinder CoClass
Class Hierarchy
GEAuto::GeCylinder


Class Hierarchy

You are here: API Reference > GEAuto Library > GeEllipticalArc CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeEllipticalArc CoClass
Class Hierarchy
GEAuto::GeEllipticalArc


Class Hierarchy

You are here: API Reference > GEAuto Library > GeEntities CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeEntities CoClass
Class Hierarchy
GEAuto::GeEntities


Class Hierarchy

You are here: API Reference > GEAuto Library > GeInterval CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeInterval CoClass
Class Hierarchy
GEAuto::GeInterval


Class Hierarchy

You are here: API Reference > GEAuto Library > GeKnotVector CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeKnotVector CoClass
Class Hierarchy
GEAuto::GeKnotVector


Class Hierarchy

You are here: API Reference > GEAuto Library > GeLine CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeLine CoClass
Class Hierarchy
GEAuto::GeLine


Class Hierarchy

You are here: API Reference > GEAuto Library > GeLineSegment CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeLineSegment CoClass
Class Hierarchy
GEAuto::GeLineSegment


Class Hierarchy

You are here: API Reference > GEAuto Library > GeMatrix CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeMatrix CoClass
Class Hierarchy
GEAuto::GeMatrix


Class Hierarchy

You are here: API Reference > GEAuto Library > GeNurbCurve CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeNurbCurve CoClass
Class Hierarchy
GEAuto::GeNurbCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > GeNurbSurface CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeNurbSurface CoClass
Class Hierarchy
GEAuto::GeNurbSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > GeOffsetCurve CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeOffsetCurve CoClass
Class Hierarchy
GEAuto::GeOffsetCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > GeOffsetSurface CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeOffsetSurface CoClass
Class Hierarchy
GEAuto::GeOffsetSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > GePlane CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GePlane CoClass
Class Hierarchy
GEAuto::GePlane


Class Hierarchy

You are here: API Reference > GEAuto Library > GePoint CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GePoint CoClass
Class Hierarchy
GEAuto::GePoint


Class Hierarchy

You are here: API Reference > GEAuto Library > GePoints CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GePoints CoClass
Class Hierarchy
GEAuto::GePoints


Class Hierarchy

You are here: API Reference > GEAuto Library > GeRay CoClass
Class Hierarchy
GeRay CoClass
Class Hierarchy
GEAuto::GeRay


Class Hierarchy

You are here: API Reference > GEAuto Library > GeSphere CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeSphere CoClass
Class Hierarchy
GEAuto::GeSphere


Class Hierarchy

You are here: API Reference > GEAuto Library > GeSurfaces CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeSurfaces CoClass
Class Hierarchy
GEAuto::GeSurfaces


Class Hierarchy

You are here: API Reference > GEAuto Library > GeSurfaceSurfaceIntersection CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeSurfaceSurfaceIntersection CoClass
Class Hierarchy
GEAuto::GeSurfaceSurfaceIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > GeTolerance CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeTolerance CoClass
Class Hierarchy
GEAuto::GeTolerance


Class Hierarchy

You are here: API Reference > GEAuto Library > GeTorus CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeTorus CoClass
Class Hierarchy
GEAuto::GeTorus


Class Hierarchy

You are here: API Reference > GEAuto Library > GeVector CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeVector CoClass
Class Hierarchy
GEAuto::GeVector


Class Hierarchy

You are here: API Reference > GEAuto Library > GeVectors CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
GeVectors CoClass
Class Hierarchy
GEAuto::GeVectors


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IAcadmApplication Interface
Class Hierarchy
IAcadmApplication


Example

You are here: API Reference > AcadmAuto Library > IAcadmApplication Interface > IAcadmApplication::GetFormulaEvaluator Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IAcadmApplication::GetFormulaEvaluator Method

Refer to SDK Samples: FormulaEvaluator.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IAcadmApplicationVersion Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IAcadmApplicationVersion Interface
Class Hierarchy
IAcadmApplicationVersion


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeApplication Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeApplication Interface
Class Hierarchy
IGeApplication


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeAugmentedLine Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeAugmentedLine Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeAugmentedLine


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeBoundBlock Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeBoundBlock Interface
Class Hierarchy
IGeEntity
    IGeBoundBlock


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeBoundedSurface Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeBoundedSurface Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeBoundedSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCircularArc Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCircularArc Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeCircularArc


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCompositeCurve Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCompositeCurve Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeCompositeCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCone Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCone Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeCone


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurve Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurve Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeAugmentedLine
        IGeCircularArc
        IGeCompositeCurve
        IGeEllipticalArc
        IGeLinearEntity
        IGeNurbCurve
        IGeOffsetCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurveBoundaries Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurveBoundaries Interface
Class Hierarchy
IGeCurveBoundaries


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurveBoundary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurveBoundary Interface
Class Hierarchy
IGeCurveBoundary


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurveCurveIntersection Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurveCurveIntersection Interface
Class Hierarchy
IGeCurveCurveIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurves Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurves Interface
Class Hierarchy
IGeCurves


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCurveSurfaceIntersection Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCurveSurfaceIntersection Interface
Class Hierarchy
IGeCurveSurfaceIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeCylinder Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeCylinder Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeCylinder


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeEllipticalArc Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeEllipticalArc Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeEllipticalArc


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeEntities Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeEntities Interface
Class Hierarchy
IGeEntities


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeEntity Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeEntity Interface
Class Hierarchy
IGeEntity
    IGeBoundBlock
    IGeCurve
    IGePoint
    IGeSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeInterval Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeInterval Interface
Class Hierarchy
IGeInterval


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeKnotVector Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeKnotVector Interface
Class Hierarchy
IGeKnotVector


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeLine Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeLine Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeLinearEntity Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeLinearEntity Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLine
            IGeLineSegment
            IGeRay


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeLineSegment Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeLineSegment Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeLineSegment


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeMatrix Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeMatrix Interface
Class Hierarchy
IGeMatrix


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeNurbCurve Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeNurbCurve Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeNurbCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeNurbSurface Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeNurbSurface Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeNurbSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeOffsetCurve Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeOffsetCurve Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeOffsetCurve


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeOffsetSurface Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeOffsetSurface Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeOffsetSurface


Class Hierarchy

You are here: API Reference > GEAuto Library > IGePlane Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGePlane Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGePlane


Class Hierarchy

You are here: API Reference > GEAuto Library > IGePoint Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGePoint Interface
Class Hierarchy
IGeEntity
    IGePoint


Class Hierarchy

You are here: API Reference > GEAuto Library > IGePoints Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGePoints Interface
Class Hierarchy
IGePoints


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeRay Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeRay Interface
Class Hierarchy
IGeEntity
    IGeCurve
        IGeLinearEntity
            IGeRay


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeSphere Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeSphere Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeSphere


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeSurface Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeSurface Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeBoundedSurface
        IGeCone
        IGeCylinder
        IGeNurbSurface
        IGeOffsetSurface
        IGePlane
        IGeSphere
        IGeTorus


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeSurfaces Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeSurfaces Interface
Class Hierarchy
IGeSurfaces


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeSurfaceSurfaceIntersection Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeSurfaceSurfaceIntersection Interface
Class Hierarchy
IGeSurfaceSurfaceIntersection


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeTolerance Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeTolerance Interface
Class Hierarchy
IGeTolerance


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeTorus Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeTorus Interface
Class Hierarchy
IGeEntity
    IGeSurface
        IGeTorus


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeVector Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeVector Interface
Class Hierarchy
IGeVector


Class Hierarchy

You are here: API Reference > GEAuto Library > IGeVectors Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IGeVectors Interface
Class Hierarchy
IGeVectors


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2dComplexStdPartCompGroupDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2dComplexStdPartCompGroupDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2dComponentDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2dComponentDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2dShaftCompGroupDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2dShaftCompGroupDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dShaftCompGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2dStdPartComponentDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2dStdPartComponentDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComponentDescriptor
            IMcad2dStdPartComponentDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcad2dComplexStdPartCompGroupDescriptor
        IMcad2dComponentDescriptor
        IMcad2dShaftCompGroupDescriptor
        IMcadFolderDescriptor
        IMcadPowObjViewGroupDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureMgr2 Interface
Class Hierarchy
IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureMgr3 Interface
Class Hierarchy
IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr3 Interface > IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureMgr4 Interface
Class Hierarchy
IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr5 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureMgr5 Interface
Class Hierarchy
IMcad2DStructureMgr
    IMcad2DStructureMgr2
        IMcad2DStructureMgr3
            IMcad2DStructureMgr4
                IMcad2DStructureMgr5


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcad2DStructureMgr Interface
Class Hierarchy
IMcad2DStructureMgr
    IMcad2DStructureMgr2


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::GetNextComponentDefinitionName Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::GetNextComponentDefinitionName Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::HasComponentDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::HasComponentDefinition Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::Is2DStructureEnabled Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::Is2DStructureEnabled Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsEntityAllowed Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::IsEntityAllowed Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcad2DStructureMgr Interface > IMcad2DStructureMgr::IsFreeEntity Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcad2DStructureMgr::IsFreeEntity Method

Refer to SDK Samples: CreateStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadAnnotationViewDefinition2 Interface

Refer to SDK Samples: CreateStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAnnotationViewDefinition2 Interface
Class Hierarchy
IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2


Example

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadAnnotationViewDefinition Interface

Refer to SDK Samples: CreateStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAnnotationViewDefinition Interface
Class Hierarchy
IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
            IMcadAnnotationViewDefinition2


Example

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinition Interface > IMcadAnnotationViewDefinition::AddComponentView Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadAnnotationViewDefinition::AddComponentView Method

Refer to SDK Samples: CreateStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAnnotationViewDefinitions Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAnnotationViewDefinitions Interface
Class Hierarchy
IMcadAnnotationViewDefinitions


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewLabel Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAnnotationViewLabel Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadAnnotationViewStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAnnotationViewStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadArc Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadArc Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAttribute Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAttribute Interface
Class Hierarchy
IMcadAttribute


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAttributeField Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAttributeField Interface
Class Hierarchy
IMcadAttributeField


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAttributeFields Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAttributeFields Interface
Class Hierarchy
IMcadAttributeFields


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAttributes Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAttributes Interface
Class Hierarchy
IMcadAttributes


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadAugmentedLine Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadAugmentedLine Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadAugmentedLine


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBalloon Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBalloon Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadBalloon


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBalloons Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBalloons Interface
Class Hierarchy
IMcadBalloons


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBalloonStandard2 Interface
Class Hierarchy
IMcadBalloonStandard
    IMcadBalloonStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBalloonStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBalloonStandard Interface
Class Hierarchy
IMcadBalloonStandard
    IMcadBalloonStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOM2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOM2 Interface
Class Hierarchy
IMcadBOM
    IMcadBOM2
        IMcadBOM3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOM3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOM3 Interface
Class Hierarchy
IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOM4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOM4 Interface
Class Hierarchy
IMcadBOM
    IMcadBOM2
        IMcadBOM3
            IMcadBOM4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOM Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOM Interface
Class Hierarchy
IMcadBOM
    IMcadBOM2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMItem2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMItem2 Interface
Class Hierarchy
IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMItem3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMItem3 Interface
Class Hierarchy
IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMItem4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMItem4 Interface
Class Hierarchy
IMcadBOMItem
    IMcadBOMItem2
        IMcadBOMItem3
            IMcadBOMItem4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMItem Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMItem Interface
Class Hierarchy
IMcadBOMItem
    IMcadBOMItem2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMItems Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMItems Interface
Class Hierarchy
IMcadBOMItems


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMMgr2 Interface
Class Hierarchy
IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3


See Also

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr2 Interface > IMcadBOMMgr2::ExportPartList Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
See Also
IMcadBOMMgr2::ExportPartList Method
See Also

McadBOMMgr Object


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMMgr3 Interface
Class Hierarchy
IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMMgr4 Interface
Class Hierarchy
IMcadBOMMgr
    IMcadBOMMgr2
        IMcadBOMMgr3
            IMcadBOMMgr4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMMgr Interface
Class Hierarchy
IMcadBOMMgr
    IMcadBOMMgr2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMs Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMs Interface
Class Hierarchy
IMcadBOMs


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBOMStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBOMStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadBOMStandard
                IMcadBOMStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBorder2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBorder2 Interface
Class Hierarchy
IMcadBorder
    IMcadBorder2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadBorder Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadBorder Interface
Class Hierarchy
IMcadBorder
    IMcadBorder2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadColumnDefinition2 Interface
Class Hierarchy
IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadColumnDefinition3 Interface
Class Hierarchy
IMcadColumnDefinition
    IMcadColumnDefinition2
        IMcadColumnDefinition3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadColumnDefinition Interface
Class Hierarchy
IMcadColumnDefinition
    IMcadColumnDefinition2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadColumnDefinitions Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadColumnDefinitions Interface
Class Hierarchy
IMcadColumnDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComplexHideSituation Interface
Class Hierarchy
IMcadObject
    IMcadComplexHideSituation


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::AddLevel Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::AddLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Concealed Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Concealed Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Definition Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Definition Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Explode Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Explode Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HiddenLinesInvisible Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::HiddenLinesInvisible Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::HideAppropriateObjectsOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::HideSituations Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::HideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::IsModifiedStandardPartHide Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::IsModifiedStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::IsStandardPartHide Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::IsStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::LevelCount Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::LevelCount Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::LookupLevelName Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::LookupLevelName Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::MoveLevel Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::MoveLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Name Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Name Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::NextLevelName Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::NextLevelName Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::RemoveLevel Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::RemoveLevel Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::RemoveLevelByIdx Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::RemoveLevelByIdx Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Reverse Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Reverse Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::Suppressed Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::Suppressed Property

Refer to SDK Samples: amshide2d.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::SysName Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::SysName Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituation Interface > IMcadComplexHideSituation::UpdateBgSelection Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComplexHideSituation::UpdateBgSelection Method

Refer to SDK Samples: AMSHide2D.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComplexHideSituations Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComplexHideSituations Interface
Class Hierarchy
IMcadComplexHideSituations


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponent Interface
Class Hierarchy
IMcadObject
    IMcadComponent


Example

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::CopyDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComponent::CopyDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadComponent Interface > IMcadComponent::ReplaceDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadComponent::ReplaceDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentDefinition Interface
Class Hierarchy
IMcadObject
    IMcadComponentDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentDefinitions Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentDefinitions Interface
Class Hierarchy
IMcadComponentDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponents Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponents Interface
Class Hierarchy
IMcadComponents


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentView Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentView Interface
Class Hierarchy
IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentViewDefinition Interface
Class Hierarchy
IMcadObject
    IMcadFolderDefinition
        IMcadComponentViewDefinition


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDefinitions Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentViewDefinitions Interface
Class Hierarchy
IMcadComponentViewDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentViewDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentViewDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadComponentViews Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadComponentViews Interface
Class Hierarchy
IMcadComponentViews


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadCurve Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadCurve Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadArc
            IMcadAugmentedLine
            IMcadEllipse
            IMcadLine
            IMcadPolyline
            IMcadSpline


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumIdentifier2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumIdentifier3 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2
                    IMcadDatumIdentifier3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumIdentifier Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumIdentifier Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
                IMcadDatumIdentifier2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDatumStandard
                IMcadDatumStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumTarget2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDatumTarget Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDatumTarget Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadDatumTarget
            IMcadDatumTarget2


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbol Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDetailSymbol Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbol


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolLabel Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDetailSymbolLabel Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadDetailSymbolLabel


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDetailSymbolStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDetailSymbolStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDetailSymbolStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadDetailSymbolStandard
                IMcadDetailSymbolStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadDocument Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDocument Interface
Class Hierarchy
IMcadDocument


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadDocuments Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDocuments Interface
Class Hierarchy
IMcadDocuments


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadDocumentVersion Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadDocumentVersion Interface
Class Hierarchy
IMcadDocumentVersion


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadEdge Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadEdge Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadEdge


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibrary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadEdgeLibrary Interface
Class Hierarchy
IMcadSymbolLibrary
    IMcadEdgeLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadEdgeLibraryObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadEdgeLibraryObject Interface
Class Hierarchy
IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadEdgeStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadEdgeStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadEdgeStandard


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadEllipse Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadEllipse Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadEllipse


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFCFLibrary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFCFLibrary Interface
Class Hierarchy
IMcadSymbolLibrary
    IMcadFCFLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFCFLibraryObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFCFLibraryObject Interface
Class Hierarchy
IMcadSymbolLibraryObject
    IMcadFCFLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFCFStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFCFStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFCFStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadFCFStandard
                IMcadFCFStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureControlFrame2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureControlFrame3 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureControlFrame4 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2
                IMcadFeatureControlFrame3
                    IMcadFeatureControlFrame4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureControlFrame Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureControlFrame Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadFeatureControlFrame
            IMcadFeatureControlFrame2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureIdentifier2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadFeatureIdentifier Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFeatureIdentifier Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadFeatureIdentifier
                IMcadFeatureIdentifier2


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolder2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolder2 Interface
Class Hierarchy
IMcadObject
    IMcadFolder
        IMcadFolder2
            IMcadComponentView


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolder Interface
Class Hierarchy
IMcadObject
    IMcadFolder
        IMcadFolder2


Example

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyEntities Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolder::CopyEntities Method

Refer to SDK Samples: RestructureView.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyView Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolder::CopyView Method

Refer to SDK Samples: RestructureView.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::CopyViewDefinition Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolder::CopyViewDefinition Method

Refer to SDK Samples: XrefStructure.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolder Interface > IMcadFolder::ViewScale Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolder::ViewScale Property

Refer to SDK Samples: RestructureView.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolderDefinition Interface
Class Hierarchy
IMcadObject
    IMcadFolderDefinition
        IMcadAnnotationViewDefinition
        IMcadComponentViewDefinition


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddComplexHideSituation Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::AddComplexHideSituation Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::AddHideSituation Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::AddHideSituation Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::ComplexHideSituations Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::ComplexHideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::FindHideSituations Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::FindHideSituations Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::GetHidesSuppressState Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::GetHidesSuppressState Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::HideSituations Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::HideSituations Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinition Interface > IMcadFolderDefinition::SetHidesSuppressState Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadFolderDefinition::SetHidesSuppressState Method

Refer to SDK Samples: AMSHide2D.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolderDefinitions Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolderDefinitions Interface
Class Hierarchy
IMcadFolderDefinitions


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolderDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolderDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFolders Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFolders Interface
Class Hierarchy
IMcadFolders


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadFormulaEvaluator Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadFormulaEvaluator Interface
Class Hierarchy
IMcadFormulaEvaluator


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadGeometry Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadGeometry Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadHideSituation Interface
Class Hierarchy
IMcadObject
    IMcadHideSituation


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddMSSubent Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::AddMSSubent Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddMSSubents Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::AddMSSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddSubent Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::AddSubent Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AddSubents Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::AddSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::AutoSelectBackground Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::AutoSelectBackground Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::BgSelectionName Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::BgSelectionName Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ClearSubents Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::ClearSubents Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Concealed Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::Concealed Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ContoursOnlyInForeground Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::ContoursOnlyInForeground Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Definition Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::Definition Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::FgSelectionName Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::FgSelectionName Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::HiddenLinesInvisible Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::HiddenLinesInvisible Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::HideAppropriateObjectsOnly Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::HideAppropriateObjectsOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreBgExclude Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IgnoreBgExclude Property

Refer to SDK Samples: amshide2d.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreFgExclude Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IgnoreFgExclude Property

Refer to SDK Samples: amshide2d.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IgnoreUpperBgExclude Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IgnoreUpperBgExclude Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::InverseForeground Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::InverseForeground Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsComplexHideLevel Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IsComplexHideLevel Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsLastLevel Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IsLastLevel Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsModifiedStandardPartHide Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IsModifiedStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::IsStandardPartHide Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::IsStandardPartHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::LevelIndex Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::LevelIndex Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Name Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::Name Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::OuterContourOnly Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::OuterContourOnly Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::ParentHide Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::ParentHide Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::RemoveSubentByIdx Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::RemoveSubentByIdx Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SaveSimplifiedOuterContour Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::SaveSimplifiedOuterContour Property

Refer to SDK Samples: amshide2d.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Subents Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::Subents Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::Suppressed Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::Suppressed Property

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SwapFgAndBg Method
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::SwapFgAndBg Method

Refer to SDK Samples: AMSHide2D.dvb


Example

You are here: API Reference > AcadmAuto Library > IMcadHideSituation Interface > IMcadHideSituation::SysName Property
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Example
IMcadHideSituation::SysName Property

Refer to SDK Samples: AMSHide2D.dvb


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadHideSituations Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadHideSituations Interface
Class Hierarchy
IMcadHideSituations


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadIdentifier Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadIdentifier Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadIdentifier
            IMcadDatumIdentifier
            IMcadFeatureIdentifier


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadIdentifierStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadIdentifierStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadIdentifierStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadIdentifierStandard
                IMcadIdentifierStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadJoint Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadJoint Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadJoint


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadJointStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadJointStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadJointStandard


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerCfg Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerCfg Interface
Class Hierarchy
IMcadLayerCfg


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerCfgs Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerCfgs Interface
Class Hierarchy
IMcadLayerCfgs


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerGroupMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerGroupMgr Interface
Class Hierarchy
IMcadLayerGroupMgr


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfg Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerObjectCfg Interface
Class Hierarchy
IMcadLayerObjectCfg


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectCfgs Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerObjectCfgs Interface
Class Hierarchy
IMcadLayerObjectCfgs


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLayerObjectMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLayerObjectMgr Interface
Class Hierarchy
IMcadLayerObjectMgr


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadLine Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadLine Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadLine


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadMarkStamp Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadMarkStamp Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadMarkStamp


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadMarkStampStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadMarkStampStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadMarkStampStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadNote Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadNote Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadNote


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadNoteStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadNoteStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadNoteStandard


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadObject Interface
Class Hierarchy
IMcadObject
    IMcadComplexHideSituation
    IMcadComponent
    IMcadComponentDefinition
    IMcadFolder
    IMcadFolderDefinition
    IMcadGeometry
    IMcadHideSituation


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadObjects Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadObjects Interface
Class Hierarchy
IMcadObjects


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartList2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartList2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartList3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartList3 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
                IMcadPartList3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartList Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartList Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartList2
            IMcadPartListGOST


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListBalloonedFilter Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListBalloonedFilter Interface
Class Hierarchy
IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListCustomFilter Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListCustomFilter Interface
Class Hierarchy
IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListFilter2 Interface
Class Hierarchy
IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListBalloonedFilter
        IMcadPartListCustomFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListFilter Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListFilter Interface
Class Hierarchy
IMcadPartListFilter
    IMcadPartListFilter2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListFilters Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListFilters Interface
Class Hierarchy
IMcadPartListFilters


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListGOST Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListGOST Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartList
            IMcadPartListGOST


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartLists Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartLists Interface
Class Hierarchy
IMcadPartLists


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListStandard2 Interface
Class Hierarchy
IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListStandard3 Interface
Class Hierarchy
IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListStandard4 Interface
Class Hierarchy
IMcadPartListStandard
    IMcadPartListStandard2
        IMcadPartListStandard3
            IMcadPartListStandard4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListStandard Interface
Class Hierarchy
IMcadPartListStandard
    IMcadPartListStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartListStdPartsFilter Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartListStdPartsFilter Interface
Class Hierarchy
IMcadPartListFilter
    IMcadPartListFilter2
        IMcadPartListCustomFilter
            IMcadPartListStdPartsFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartReference2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartReference2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartReference3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartReference3 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2
                IMcadPartReference3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartReference Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartReference Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadPartReference
            IMcadPartReference2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadPartReferences Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPartReferences Interface
Class Hierarchy
IMcadPartReferences


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadPick Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPick Interface
Class Hierarchy
IMcadPick


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadPolyline Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPolyline Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadPolyline


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadPowObjViewGroupDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadPowObjViewGroupDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadPowObjViewGroupDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadRevisionList Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadRevisionList Interface
Class Hierarchy
IMcadRevisionList


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadRevisionListDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadRevisionListDescriptor Interface
Class Hierarchy
IMcadRevisionListDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadRevisionLists Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadRevisionLists Interface
Class Hierarchy
IMcadRevisionLists


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadRevisionMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadRevisionMgr Interface
Class Hierarchy
IMcadRevisionMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadScaleArea Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadScaleArea Interface
Class Hierarchy
IMcadScaleArea


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadScaleAreaMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadScaleAreaMgr Interface
Class Hierarchy
IMcadScaleAreaMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSectionLine Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSectionLine Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadSectionLine


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSectionLineStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSectionLineStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSectionLineStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSectionLineStandard
                IMcadSectionLineStandard2


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadSpline Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSpline Interface
Class Hierarchy
IMcadObject
    IMcadGeometry
        IMcadCurve
            IMcadSpline


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandard2 Interface
Class Hierarchy
IMcadStandard
    IMcadStandard2
        IMcadStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandard3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandard3 Interface
Class Hierarchy
IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandard4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandard4 Interface
Class Hierarchy
IMcadStandard
    IMcadStandard2
        IMcadStandard3
            IMcadStandard4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandard Interface
Class Hierarchy
IMcadStandard
    IMcadStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandardMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandardMgr Interface
Class Hierarchy
IMcadStandardMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadStandards Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStandards Interface
Class Hierarchy
IMcadStandards


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadStdPartComponentViewDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadStdPartComponentViewDescriptor Interface
Class Hierarchy
IMcadDescriptor
    IMcad2DStructureDescriptor
        IMcadFolderDescriptor
            IMcadComponentViewDescriptor
                IMcadStdPartComponentViewDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTexture2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTexture3 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture4 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTexture4 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2
                IMcadSurfaceTexture3
                    IMcadSurfaceTexture4


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTexture Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTexture Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadSurfaceTexture
            IMcadSurfaceTexture2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibrary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTextureLibrary Interface
Class Hierarchy
IMcadSymbolLibrary
    IMcadSurfaceTextureLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureLibraryObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTextureLibraryObject Interface
Class Hierarchy
IMcadSymbolLibraryObject
    IMcadSurfaceTextureLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTextureStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTextureStandard3 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2
                    IMcadSurfaceTextureStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSurfaceTextureStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSurfaceTextureStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadSurfaceTextureStandard
                IMcadSurfaceTextureStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbol2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbol2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadAnnotationViewLabel
        IMcadBalloon
        IMcadDatumTarget
        IMcadDetailSymbol
        IMcadDetailSymbolLabel
        IMcadEdge
        IMcadFeatureControlFrame
        IMcadIdentifier
        IMcadJoint
        IMcadMarkStamp
        IMcadNote
        IMcadPartList
        IMcadPartReference
        IMcadSectionLine
        IMcadSurfaceTexture
        IMcadTaper
        IMcadWelding


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbol Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbol Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolBBMgr2 Interface
Class Hierarchy
IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolBBMgr3 Interface
Class Hierarchy
IMcadSymbolBBMgr
    IMcadSymbolBBMgr2
        IMcadSymbolBBMgr3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolBBMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolBBMgr Interface
Class Hierarchy
IMcadSymbolBBMgr
    IMcadSymbolBBMgr2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibrary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolLibrary Interface
Class Hierarchy
IMcadSymbolLibrary
    IMcadEdgeLibrary
    IMcadFCFLibrary
    IMcadSurfaceTextureLibrary
    IMcadWeldingLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolLibraryObject Interface
Class Hierarchy
IMcadSymbolLibraryObject
    IMcadEdgeLibraryObject
    IMcadFCFLibraryObject
    IMcadSurfaceTextureLibraryObject
    IMcadWeldingLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolLibraryObjects Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolLibraryObjects Interface
Class Hierarchy
IMcadSymbolLibraryObjects


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolStandard3 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadAnnotationViewStandard
            IMcadBOMStandard
            IMcadDatumStandard
            IMcadDetailSymbolStandard
            IMcadEdgeStandard
            IMcadFCFStandard
            IMcadIdentifierStandard
            IMcadJointStandard
            IMcadMarkStampStandard
            IMcadNoteStandard
            IMcadSectionLineStandard
            IMcadSurfaceTextureStandard
            IMcadTaperStandard
            IMcadTitleBorderStandard
            IMcadWeldingStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadSymbolStandards Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadSymbolStandards Interface
Class Hierarchy
IMcadSymbolStandards


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTaper Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTaper Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadTaper


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTaperStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTaperStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTaperStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTaperStandard
                IMcadTaperStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitle2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitle2 Interface
Class Hierarchy
IMcadTitle
    IMcadTitle2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitle Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitle Interface
Class Hierarchy
IMcadTitle
    IMcadTitle2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorder Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorder Interface
Class Hierarchy
IMcadTitleBorder


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderContext Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorderContext Interface
Class Hierarchy
IMcadTitleBorderContext


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderDescriptor Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorderDescriptor Interface
Class Hierarchy
IMcadTitleBorderDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderMgr Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorderMgr Interface
Class Hierarchy
IMcadTitleBorderMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorders Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorders Interface
Class Hierarchy
IMcadTitleBorders


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorderStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTitleBorderStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTitleBorderStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadTitleBorderStandard
                IMcadTitleBorderStandard2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadTransaction Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadTransaction Interface
Class Hierarchy
IMcadTransaction


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadUtility2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadUtility2 Interface
Class Hierarchy
IMcadUtility
    IMcadUtility2
        IMcadUtility3


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadUtility3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadUtility3 Interface
Class Hierarchy
IMcadUtility
    IMcadUtility2
        IMcadUtility3


Class Hierarchy

You are here: API Reference > AcadmAuto Library > IMcadUtility Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadUtility Interface
Class Hierarchy
IMcadUtility
    IMcadUtility2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWelding2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWelding2 Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWelding Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWelding Interface
Class Hierarchy
IMcadSymbol
    IMcadSymbol2
        IMcadWelding
            IMcadWelding2


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibrary Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWeldingLibrary Interface
Class Hierarchy
IMcadSymbolLibrary
    IMcadWeldingLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWeldingLibraryObject Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWeldingLibraryObject Interface
Class Hierarchy
IMcadSymbolLibraryObject
    IMcadWeldingLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard2 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWeldingStandard2 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard3 Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWeldingStandard3 Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2
                    IMcadWeldingStandard3


Class Hierarchy

You are here: API Reference > SymBBAuto Library > IMcadWeldingStandard Interface
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
IMcadWeldingStandard Interface
Class Hierarchy
IMcadSymbolStandard
    IMcadSymbolStandard2
        IMcadSymbolStandard3
            IMcadWeldingStandard
                IMcadWeldingStandard2


SymBBAuto Library CoClasses

You are here: API Reference > SymBBAuto Library
SymBBAuto Library CoClasses
SymBBAuto Library
CoClasses
Name | Description
McadAnnotationViewLabel | Annotation view label entity.
McadAnnotationViewStandard | Annotation view label standard.
McadBalloon | A balloon symbol object
McadBalloons | A collection of McadBalloon objects
McadBalloonStandard | The balloon standards for a bill of materials symbol standard.
McadBOM | A bill of materials database object.
McadBOMItem | A bill of materials item or row object
McadBOMItems | A collection of McadBOMItem objects
McadBOMMgr | A bill of materials manager object
McadBOMs | A collection of McadBOM objects
McadBOMStandard | A bill of materials symbol standard object
McadBorder | This object represents the drawing border of the title/border created in the drawing.
McadColumnDefinition | Stores the BOM column definition information.
McadColumnDefinitions | A collection of McadColumnDefinition objects
McadDatumIdentifier | Implements datum identifier symbols.
McadDatumStandard | A datum target symbol standard
McadDatumTarget | A datum target symbol
McadDetailSymbol | This object represents the detail symbol created in the drawing.
McadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
McadDetailSymbolStandard | This object represents the Detail symbol standard.
McadEdge | This object represents the edge symbol created in the drawing.
McadEdgeLibrary | This is class SymBBAuto::McadEdgeLibrary.
McadEdgeLibraryObject | This is class SymBBAuto::McadEdgeLibraryObject.
McadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
McadFCFLibrary | This is class SymBBAuto::McadFCFLibrary.
McadFCFLibraryObject | This is class SymBBAuto::McadFCFLibraryObject.
McadFCFStandard | A feature control frame symbol standard
McadFeatureControlFrame | Implements feature control frame symbols.
McadFeatureIdentifier | A feature identifier symbol
McadIdentifier | Implements functionalty common to Datum Identifier symbols and Feature Identifier symbols.
McadIdentifierStandard | Defines the drafting standard settings for Datym and Feature Identifier symbols.
McadJoint | This is class SymBBAuto::McadJoint.
McadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
McadMarkStamp | A marking or stamping symbol
McadMarkStampStandard | A marking/stamping symbol standard
McadNote | This object represents the Note symbol created in the drawing.
McadNoteStandard | This object represents the Note symbol standard.
McadPartList | A part list symbol
McadPartListBalloonedFilter | A filter object that filters the contents of a parts List by ballooned parts.
McadPartListCustomFilter | A filter object that filters the contents of a parts list by a BOM property.
McadPartListFilter | An object that filters the contents of a parts list
McadPartListFilters | A collection of McadPartListFilter objects
McadPartListGOST | A part list object
McadPartLists | A collection of McadPartList objects
McadPartListStandard | The part list-specific information of a bill of materials symbol standard
McadPartListStdPartsFilter | A filter object that filters the contents of a parts list by Standard parts.
McadPartReference | A part reference symbol
McadPartReferences | This is class SymBBAuto::McadPartReferences.
McadRevisionList | This object represents the revision list created in the drawing. The interface is IMcadRevisionList.
McadRevisionListDescriptor | This object contains all data associated with a revision list.
McadRevisionLists | This object is a collection of revision list objects.
McadRevisionMgr | This object is used for general functionality of revision lists.
McadScaleArea | This object represents the scale area created in the model space.
McadScaleAreaMgr | This object is used to create and find a scale area in the model space.
McadSectionLine | The object represents the section line creating in the drawing.
McadSectionLineStandard | This object represents the standard.
McadStandard | This existing object represents the standard.
McadStandardMgr | The symbol standards manager object
McadStandards | A collection of McadStandard objects
McadSurfaceTexture | A surface texture symbol
McadSurfaceTextureLibrary | This is the object representing the surface texture library.
McadSurfaceTextureLibraryObject | Implements the IMcadSurfaceTextureLibraryObject interface.
McadSurfaceTextureStandard | A surface texture symbol standard
McadSymbol | A symbol object.
McadSymbolBBMgr | This existing object is the main manager object in SymBBAuto.
McadSymbolLibrary | Implements the IMcadSymbolLibrary interface.
McadSymbolLibraryObject | Implements the IMcadSymbolLibraryObject interface.
McadSymbolLibraryObjects | Implements the IMcadSymbolLibraryObjects interface.
McadSymbolStandard | A symbol standard.
McadSymbolStandards | A collection of McadSymbolStandard objects
McadTaper | This object represents the taper symbol created in the drawing.
McadTaperStandard | This object represents the Taper and Slope symbol standard.
McadTitle | This object represents the title block of the title/border created in the drawing.
McadTitleBorder | This object represents the title/border created in the drawing.
McadTitleBorderContext | This new object contains all option settings associated with a title/border.
McadTitleBorderDescriptor | This object contains all data associated with a title/border.
McadTitleBorderMgr | This object is used for general functionality for title/border.
McadTitleBorders | This object is a collection of title/border objects.
McadTitleBorderStandard | This object represents the Drawing Sheet standard element.
McadWelding | Implements weld symbols.
McadWeldingLibrary | Implements the IMcadWeldingLibraryObject interface.
McadWeldingLibraryObject | Implemented the IMcadWeldingLibraryObject.
McadWeldingStandard | A weld symbol standard.


SymBBAuto Library Enumerations

You are here: API Reference > SymBBAuto Library
SymBBAuto Library Enumerations
SymBBAuto Library Legend
Enumerations
Name | Description
McadAlignmentType | Enumerates all available alignment types for a drawing document element, such as captions and data in a column of a BOM database.
McadAnnotViewLabelPositionType | McadAnnotViewLabelPositionType defines position of annotation view label.
McadArrowType | Enumerates all available arrow types for a symbol leader. sbNoArrow : Indicates that no arrow is attached to the symbol leader. sbArrowOpen : Indicates that the open arrow is attached to the symbol leader. sbArrowOpen15 : Indicates that the open 15-degree arrow is attached to the symbol leader. sbArrowOpen30 : Indicates that the open 30-dergee arrow is attached to the symbol leader. sbArrowOpen60 : Indicates that the open 60-degree arrow is attached to the symbol leader. sbArrowOpen90 : Indicates that the open 90-degree arrow is attached to the symbol leader. sbArrowEmpty : Indicates that the empty arrow is attached to... more
McadAttachmentPoint | Enumerates all available points for attaching a leader to symbols. sbTopLeft : Places the leader to the top-left of symbols. sbBottomLeft : Places the leader to the bottom-left of symbols. sbBottomRight : Places the leader to the bottom-right of symbols. sbTopRight : Places the leader to the top-right of symbols.
McadAttachmentType | Enumerates all available leader attachment point types for symbols. sbToCenter : Attaches the leader to the center of symbols. sbToExtents : Attaches the leader to the extents of symbols. sbToOrigin : Attaches the leader to the origin of symbols in the coordinate system.
McadAttachPosition | This is record McadAttachPosition.
McadAttributeAssociativity | Enumerates all available behaviors of the attribute when the object that the attribute is attached to is copied. mcDefault : If the McadAttributeAssociativity element is not specified in pertinent methods, the default associativity behavior is used. mcCopyAlways : Indicates this attribute is always copied. mcShareAlways : Indicates this attribute is always shared. mcIgnoreAlways : Indicates this attribute is always ignored.
McadBalloonType | Enumerates all available balloon patterns that can be used to override when creating new balloon symbols by a specific standard. sbByStandardBalloon : Sets the standard option as the balloon pattern in a drawing document. The standard balloon is defined by the drawing manager. sbNoBalloon : Sets the open option as the balloon pattern in a drawing document. sbCircularBalloon : Sets the predefined Circular option as the balloon pattern in a drawing document. sbCircular2Balloon : Sets the predefined Circular2 option as the balloon pattern in a drawing document. sbLinearBalloon : Sets the predefined Linear option as the balloon pattern in a... more
McadBOMExportFormatType | Enumerates all available BOM table export formats. exTXT : Indicates the export format of text separated with tabulator. exCSV : Indicates the export format of text separated with semicolon. exHTML : Indicates the export format of HTML. exMDB : Indicates the export format of the current Microsoft Access. exMDB97 : Indicates the export format of Microsoft Access 97. exEXCEL97 : Indicates the export format of Microsoft Excel 97. exEXCEL95 : Indicates the export format of Microsoft Excel 95. exDB5 : Indicates the export format of dBase 5. exDBIV : Indicates the export format of dBase IV. exDBIII : Indicates the... more
McadBOMImportFormatType | Enumerates all available BOM table import formats. imMDB : Indicates the import format of the current Microsoft Access. imEXCEL97 : Indicates the import format of Microsoft Excel 97. imEXCEL95 : Indicates the import format of Microsoft Excel 95. imDB5 : Indicates the export format of dBase 5. imDBIV : Indicates the export format of dBase IV. imDBIII : Indicates the export format of dBase III. imimFOXVIS : Indicates the export format of Microsoft Visual FoxPro 3.0. imFOX26 : Indicates the export format of Microsoft Visual FoxPro 2.6. imFOX25 : Indicates the export format of Microsoft Visual FoxPro 2.5. imTXT :... more
McadBOMItemDefinitionType | Enumerates all available BOM item definition types. Unknown : Indicates that the BOM item definition type is unknown. NonModal : Indicates that the BOM item definition type is User-Defined. PartRef : Indicates that the BOM item definition type is AutoCAD Mechanical Part Reference. BlockDef : Indicates that the BOM item definition type is Block Definition. CompDef : Indicates that the BOM item definition type is AutoCAD Mechanical/Mechanical Desktop Component Definition.
McadBomOverrideType | Enumerator for BOM override types.
McadBOMUOMType | Enumerates all available BOM UOM (Unit of Measurement) types. Each : Indicates that the BOM UOM type is per item. sqm : Indicates that the BOM UOM type is per each square meter. sqcm : Indicates that the BOM UOM type is per each square centimeter. sqft : Indicates that the BOM UOM type is per each square foot. sqin : Indicates that the BOM UOM type is per each square inch. gal : Indicates that the BOM UOM type is per gallon qt : Indicates that the BOM UOM type is per qt. lqd_oz : Indicates that the BOM... more
McadColumnSplitStyle | Enumerates all available column split styles for a Parts List. sbSplitRows : Specifies that a Parts List is split by rows in a column split. sbSplitSections : Specifies that a Parts List is split by sections in a column split.
McadColumnSplitWrap | Enumerates all available column split wrap directions for a Parts List. sbSplitLeft : Specifies that a Parts List wraps to the left in a column split. sbSplitRight : Specifies that a Parts List wraps to the right in a column split.
McadColumnType | Enumerates all column types available in this BOM database for drawing documents. This ColumnType element is the internal name of the column attribute. sbPartID : Specifies the object ID of this BOM item. sbItem : Specifies the item number for this BOM item. sbQuantity : Specifies the quantity of part references for this BOM item. sbPartListName : Specifies the parts list name that is created from this BOM database. sbPartListPath : Specifies the path to store the parts list that is created from this BOM database. sbDescription : Specifies the supplementary data for this BOM database. sbDescription2 : Specifies the... more
McadDataType | Enumerates all data types that can be used for columns in this BOM database. sbGeneralText : Sets the general text as the data type for columns in this BOM database. sbInteger : Sets Integer as the data type for columns in this BOM database. sbReal : Sets Real as the data type for columns in this BOM database.
McadDetailSymbolStandardPropType | Enumerates the property types for detail view standard that can be set to ByStandard.
McadDirectionLayType | Enumerates all available directions of machining lay specifications for a surface texture symbol in a drawing document. sbNotSpecified : No directions of machining lay specifications are available. sbParallelToPlane : Sets Parallel to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbPerpendicularToPlane : Sets Perpendicular to Plane of Projection for the direction of machining lay specification of a surface texture symbol. sbCrossedIn2SlantDirections : Sets Angular in Both Directions for the direction of machining lay specification of a surface texture symbol. sbMultiDirection : Sets Multidirectional for the direction of machining lay specification of a surface... more
McadEdgeRequirement | Enumerates all available requirements for Edge library object.
McadFCFRequirement | Enumerates all available requirements for FCF library object.
McadFilterOperator | Enumerates all available filter operator for a Parts List custom filter. sbContains : Specifies a "contains" operator. sbDoesNotCont : Specifies a "does not contain" operator. sbEqual : Specifies a "equal" operator. sbNotEqual : Specifies a "not equal" operator. sbLess : Specifies a "less than" operator sbGreater : Specifies a "greater than" operator. sbLessEqual : Specifies a "less than or equal" operator. sbGreaterEqual : Specifies a "greater than or equal" operator.
McadFilterType | Enumerates all available filter types for a Parts List. sbFilterBasic : Specifies a basic filter type for a Parts List. sbFilterBallooned : Specifies a filter that filters the contents of a Parts List by ballooned parts. sbFilterCustom : Specifies a filter that filters the contents of a Parts List by a BOM property. sbFilterParts : Specifies a filter that filters the contents of a Parts List by selected parts. sbFilterStdParts : Specifies a filter that filters the contents of a Parts List by Standard parts. sbFilterSheet : Specifies a filter that filters the contents of a Parts List by a... more
McadGDTSymbolType | Enumerates all symbol types available for a feature control frame symbol. All the enumeration symbol types can be rolled into two groups: Geometric Characteristic and Material Removal Modifier. sbStraightness : Sets Straightness as the GDT symbol type for a feature control frame symbol. sbFlatness : Sets Flatness as the GDT symbol type for a feature control frame symbol. sbCircularity : Sets Circularity as the GDT symbol type for a feature control frame symbol. sbCylindricity : Sets Cylindricity as the GDT symbol type for a feature control frame symbol. sbProfileLine : Sets Profile of a Line as the GDT symbol type... more
McadIdentificationType | Enumerates all available types of identification line used for a weld symbol. Identification lines are not available for ANSI standard. sbNoIdentificationLine : Places no identification line on either the arrow side or the other side for a weld symbol. sbIdentificationOtherSide : Places the identification line on the other side of the arrow. sbIdentificationArrowSide : Places the identification line on the arrow side.
McadIdentifierPositionType | Enumerates the identifier position type for section line.
McadJointType |
McadLineVisibility | Enumerates the available line visibility types.
McadNoteAttachPointType | Enumerates all available note attach point types.
McadNoteTemplateGroupType | Enumerator for note template group type.
McadOrientation | Enumerates all available orientations of welding symbol elements. sbLeftSide : Places a weld tail to the left of the arrow. sbRightSide : Places a weld tail to the right of the arrow. sbBelow : Place symbols on the arrow side upward the weld tail. sbAbove : Place symbols on the other side of the arrow upward the weld tail.
McadScaleType | Enumerator for scale type.
McadSectionLineSegmentType | Enumerates the available line segment types.
McadSectionLineStandardPropType | Enumerates the property types for section view standard, which can be set to ByStandard.
McadStdPartsFilterOption | Enumerates all available filter options for a Parts List Standard parts filter. sbStdPartsOnly : Specifies a Standard parts filter that filters the contents of a Parts List by Standard parts. sbExcludeStdParts : Specifies a Standard parts filter that filters the contents of a Parts List by non-Standard parts.
McadSurfaceTextureRequirement | Surface Texture Requirement information. sbSurfTextRaMax : Roughness value Ra sbSurfTextRaMin : Roughness value Ra - minimum sbSurfTextProduction : Production method sbSurfTextProduction2 : Production method sbSurfTextAllowance : Finish allowance sbSurfTextDirLay : Direction of lay sbSurfTextSampLength : Sampling length or waviness height sbSurfTextCutoff : Cutoff value and evaluation length sbSurfTextOtherValue : Other roughness value sbSurfTextOtherMin : Other roughness minimum value sbSurfTextMaxRspac : Maximum spacing sbSurfTextReference : Reference length and evaluation length sbSurfTextWavines : Surface waviness sbSurfTextComment : Comment sbSurfTextFirstRequirement : First requirement sbSurfTextSecondRequirement : Second requirement sbSurfTextThirdRequirement : Third requirement
McadSurfaceTextureType | Enumerates all available surface types for a surface texture symbol. sbBasic : Set the Basic surface type for a surface texture symbol. sbRemovalOfMaterialRequired : Set the Removal of Material Required surface type for a surface texture symbol. sbRemovalOfMaterialProhibited : Set the Removal of Material Prohibited surface type for a surface texture symbol. sbRemovalAllowanceSpecified : Set the Removal of Allowance Specified surface type for a surface texture symbol.
McadSymBBSymbolLibraryType | Enumerates the available Symbol Library Type.
McadTaperDimensionType | Enumerates the available taper dimension type.
McadTaperRatioFormatType | Enumerates the available ratio format type.
McadTaperSlopeSymType | Enumerator for taper slope symbol type.
McadTargetType | Enumerates all available termination types for a datum target symbol. sbNoTarget : Set the None termination type for a datum target symbol. sbBalloon : Not implemented yet. Set the None termination type for a datum target symbol. sbPoint : Set the None termination type for a datum target symbol. sbLine : Set the None termination type for a datum target symbol. sbCircular : Set the None termination type for a datum target symbol. sbRectangular : Set the None termination type for a datum target symbol. sbAttach : Set the None termination type for a datum target symbol.
McadTextControl | Enumerates all available text controls for a Parts List. sbNone : Specifies that a Parts List text is not controlled. The text overruns the column width when the length of the text exceeds the column width. sbFit : Specifies that a Parts List text fits within the column when the length of the text exceeds the column width. sbWrap : Specifies that a Parts List text wraps to the next line when the length of the text exceeds the column width.
McadUndefinedSize | Enumerates the undefined size's cases for edge symbol
McadUndefinedSizeDirection | Enumerates the undefined size's direction for edge symbol
McadViewDefLockType | Enumerates the lock type of the folder definition or component view definition in mechanical structure. mc2DSNoLock : Specifies no lock in mechanical structure. mc2DSXrefLock : Specifies the lock of the Xref objects in mechanical structure. mc2DSStdPartLock : Specifies the lock of standard parts in mechanical structure. mc2DSUserLock : Specifies the user-defined lock in mechanical structure.
McadWeldAssociation | Enumerates all available association types between two fillet weld symbols for the staggered weldment. sbNoAssociation : Sets no association. sbAssociationSpacer : Space the fillet symbols. sbAssociationMoveStagger : Staggers the fillet symbols. sbAssociationMirrorStagger : Mirrors the fillet symbols. sbAssociationSpecialStagger : Staggers the fillet symbols in a special way. sbAssociationBacking : Back the fillet symbols.
McadWeldingRequirement | Enumerates the available Weld requirements variable.
McadWeldSymbolType | Enumerates all available weld symbol types for a weld symbol standard. All the enumeration weld symbol types can be rolled into three groups: Weld Symbols, Contour Symbols, and Backing Symbols. A weld symbol type may use different signs in different standard, such as ANSI, BSI, and ISO. sbNoSymbol : Sets no weld symbol type for a weld symbol standard. sbFilletWeld : Sets the Fillet Weld symbol type for a weld symbol standard. Available for ANSI sbSecondaryFillet : Sets the Secondary Fillet Weld symbol type for a weld symbol standard. sbPlugWeld : Sets the Plug Weld symbol type for a weld... more
McadBalloonCollectionType | Enumerates all available alignment types of collected balloons for selected part references. The orientation of collected balloons depends on the position of the last leader segment. sbHorizontal : Aligns collected balloons horizontally. sbVertical : Aligns collected balloons vertically.


Enumerations

You are here: API Reference > SymBBAuto Library
Legend
Legend
Enumeration


SymBBAuto Library Interfaces

You are here: API Reference > SymBBAuto Library
SymBBAuto Library Interfaces
SymBBAuto Library Legend
Interfaces
Name | Description
IMcadAnnotationViewLabel | Annotation view label entity.
IMcadAnnotationViewStandard | Annotation view label standard.
IMcadBalloon | A balloon symbol object.
IMcadBalloons | A collection of McadBalloon objects.
IMcadBalloonStandard | The balloon standards for a bill of materials symbol standard.
IMcadBalloonStandard2 | The balloon standards for a bill of materials symbol standard.
IMcadBOM | A bill of materials database object.
IMcadBOM2 | A bill of materials database object.
IMcadBOM3 | A bill of materials database object.
IMcadBOM4 | A bill of materials database object.
IMcadBOMItem | A bill of materials item or row object.
IMcadBOMItem2 | A bill of materials item or row object.
IMcadBOMItem3 | A bill of materials item or row object.
IMcadBOMItem4 | A bill of materials item, or row object.
IMcadBOMItems | A collection of McadBOMItem objects
IMcadBOMMgr | A bill of materials manager object
IMcadBOMMgr2 | A bill of materials manager object
IMcadBOMMgr3 | A bill of materials manager object.
IMcadBOMMgr4 | A bill of materials manager object.
IMcadBOMs | A collection of McadBOM objects
IMcadBOMStandard | A bill of materials symbol standard object
IMcadBOMStandard2 | A bill of materials symbol standard object
IMcadBorder | This object represents the drawing border of the title/border created in the drawing.
IMcadColumnDefinition | Stores the BOM column definition information.
IMcadColumnDefinition2 | Stores the BOM column definition information.
IMcadColumnDefinition3 | Stores the BOM column definition information.
IMcadColumnDefinitions | A collection of McadColumnDefinition objects
IMcadDatumIdentifier | Implements datum identifier symbols.
IMcadDatumStandard | A datum target symbol standard
IMcadDatumStandard2 | A datum target symbol standard
IMcadDatumTarget | A datum target symbol
IMcadDatumTarget2 | A datum target symbol.
IMcadDetailSymbol | This object represents the detail symbol created in the drawing.
IMcadDetailSymbolLabel | This object represents the detail symbol label created in the drawing.
IMcadDetailSymbolStandard | This object represents the Detail symbol standard.
IMcadDetailSymbolStandard2 | This interface is derived from IMcadDetailSymbolStandard. It is used for the detail view standard.
IMcadDocument | The active document. The document is obtained from the AcadmApplication object's ActiveDocument property.
IMcadEdge | This object represents the edge symbol created in the drawing.
IMcadEdgeLibrary | The object representing Edge library.
IMcadEdgeLibraryObject | The Edge library object.
IMcadEdgeStandard | This object represents the edge symbol standard, Edges of Workpieces standard element.
IMcadFCFLibrary | Object representing the Feature Control Frame library.
IMcadFCFLibraryObject | The Feature Control Frame library object.
IMcadFCFStandard | A feature control frame symbol standard
IMcadFeatureControlFrame | Implemets feature control frame symbols.
IMcadFeatureControlFrame2 | IMcadFeatureControlFrame extended interface.
IMcadFeatureIdentifier | A feature identifier symbol.
IMcadIdentifier | An identifier symbol
IMcadIdentifierStandard | An identifier symbol standard
IMcadJoint | The IMcadJoint interface.
IMcadJointStandard | This object represents a Dead Joint symbol standard created in the drawing.
IMcadMarkStamp | Interface for working with the Marking/Stamping symbol created in the drawing.
IMcadMarkStampStandard | Interface for working with the Marking/Stamping symbol standard.
IMcadNote | This object represents the Note symbol created in the drawing.
IMcadNoteStandard | This object represents the Note symbol standard.
IMcadPartList | A part list symbol.
IMcadPartList2 | A part list symbol.
IMcadPartList3 | Stores the Parts List symbol settings information.
IMcadPartListBalloonedFilter | A filter object that filters the contents of a Parts List by ballooned parts.
IMcadPartListCustomFilter | A filter object that filters the contents of a Parts List by a BOM property.
IMcadPartListFilter | An object that filters the contents of a parts list.
IMcadPartListFilter2 | An object that filters the contents of a parts list.
IMcadPartListFilters | A collection of McadPartListFilter objects
IMcadPartListGOST | Interface for interacting with the GOST part list created in the drawing.
IMcadPartLists | A collection of McadPartList objects
IMcadPartListStandard | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard2 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard3 | The part list specific information of a bill of materials symbol standard.
IMcadPartListStandard4 | Stores the Parts List standard setting information.
IMcadPartListStdPartsFilter | A filter object that filters the contents of a Parts List by Standard parts.
IMcadPartReference | A part reference symbol.
IMcadPartReference2 | A part reference symbol.
IMcadPartReference3 | A part reference symbol.
IMcadRevisionList | Interface that represents the revision list created in the drawing.
IMcadRevisionListDescriptor | Interface for interacting with all data associated with a revision list.
IMcadRevisionLists | Interface for working with a collection of revision list objects.
IMcadRevisionMgr | Interface for working with the general functionality of a revision list.
IMcadScaleArea | This object represents the scale area created in the model space.
IMcadScaleAreaMgr | This object is used to create and find a scale area in the modelspace.
IMcadSectionLine | The object represents the section line creating in the drawing.
IMcadSectionLineStandard | Interface for working with the standard.
IMcadSectionLineStandard2 | This interface is derived from IMcadSectionLineStandard. It is for the section view standard.
IMcadStandard | This existing object represents the standard.
IMcadStandard2 | This existing object represents the standard.
IMcadStandard3 | This existing object represents the standard.
IMcadStandard4 | This existing object represents the standard.
IMcadStandardMgr | The symbol standards manager object
IMcadStandards | A collection of McadStandard objects
IMcadSurfaceTexture | A surface texture symbol
IMcadSurfaceTexture2 | A surface texture symbol.
IMcadSurfaceTexture4 | A surface texture symbol.
IMcadSurfaceTextureLibrary | This object represents the surface texture library.
IMcadSurfaceTextureLibraryObject | The IMcadSurfaceTextureLibraryObject interface.
IMcadSurfaceTextureStandard | A surface texture symbol standard
IMcadSurfaceTextureStandard2 | A surface texture symbol standard.
IMcadSurfaceTextureStandard3 | A surface texture symbol standard.
IMcadSymbol | A symbol object.
IMcadSymbol2 | A symbol object.
IMcadSymbolBBMgr | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr2 | This object is the main manager object in SymBBAuto.
IMcadSymbolBBMgr3 | This object is the main manager object in SymBBAuto.
IMcadSymbolLibrary | The IMcadSymbolLibrary interface. The grouping of library object is based on the combination of standard and standard revision type. In each group, there is only one default.
IMcadSymbolLibraryObject | Represents the library of symbol objects.
IMcadSymbolLibraryObjects | The IMcadSymbolLibrary Objects interface.
IMcadSymbolStandard | A symbol standard.
IMcadSymbolStandard2 | A symbol standard.
IMcadSymbolStandard3 | A symbol standard.
IMcadSymbolStandards | A collection of McadSymbolStandard objects
IMcadTaper | This object represents the taper symbol created in the drawing.
IMcadTaperStandard | This object represents the Taper and Slope symbol standard.
IMcadTaperStandard2 | This object represents the Taper and Slope symbol standard.
IMcadTitle | This object represents the title block of the title/border created in the drawing.
IMcadTitle2 | This is class IMcadTitle2.
IMcadTitleBorder | This object represents the title/border created in the drawing.
IMcadTitleBorderContext | This new object contains all option settings associated with a title/border.
IMcadTitleBorderDescriptor | This object contains all data associated with a title/border.
IMcadTitleBorderMgr | This object is used for general functionality for title/border.
IMcadTitleBorders | This object is a collection of title/border objects.
IMcadTitleBorderStandard | This object represents the Drawing Sheet standard element.
IMcadTitleBorderStandard2 | This is class IMcadTitleBorderStandard2.
IMcadTransaction | The McadTransaction object.
IMcadWelding | A weld symbol object
IMcadWelding2 | This is class IMcadWelding2.
IMcadWeldingLibrary | The IMcadWeldingLibrary interface.
IMcadWeldingLibraryObject | The IMcadWeldingLibraryObject interface.
IMcadWeldingStandard | A weld symbol standard.
IMcadWeldingStandard2 | A weld symbol standard.
IMcadWeldingStandard3 | Use this class to handle settings to weld symbols in current standard.
IMcadBorder2 | This is class IMcadBorder2.
IMcadDatumIdentifier2 | This is class IMcadDatumIdentifier2.
IMcadDatumIdentifier3 | This is class IMcadDatumIdentifier3.
IMcadFCFStandard2 | This is class IMcadFCFStandard2.
IMcadFeatureControlFrame3 | This is class IMcadFeatureControlFrame3.
IMcadFeatureControlFrame4 | This is class IMcadFeatureControlFrame4.
IMcadFeatureIdentifier2 | This is class IMcadFeatureIdentifier2.
IMcadIdentifierStandard2 | This is class IMcadIdentifierStandard2.
IMcadPartReferences | This is class IMcadPartReferences.
IMcadSurfaceTexture3 | This is class IMcadSurfaceTexture3.


Interfaces

You are here: API Reference > SymBBAuto Library
Legend
Legend
Interface


Legend

You are here: API Reference > SymBBAuto Library
Legend
SymBBAuto Library
Legend
Interface
Enumeration


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadAnnotationViewLabel CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAnnotationViewLabel CoClass
Class Hierarchy
SymBBAuto::McadAnnotationViewLabel


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadAnnotationViewStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadAnnotationViewStandard CoClass
Class Hierarchy
SymBBAuto::McadAnnotationViewStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBalloon CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBalloon CoClass
Class Hierarchy
SymBBAuto::McadBalloon


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBalloons CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBalloons CoClass
Class Hierarchy
SymBBAuto::McadBalloons


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBalloonStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBalloonStandard CoClass
Class Hierarchy
SymBBAuto::McadBalloonStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOM CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOM CoClass
Class Hierarchy
SymBBAuto::McadBOM


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOMItem CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOMItem CoClass
Class Hierarchy
SymBBAuto::McadBOMItem


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOMItems CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOMItems CoClass
Class Hierarchy
SymBBAuto::McadBOMItems


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOMMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOMMgr CoClass
Class Hierarchy
SymBBAuto::McadBOMMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOMs CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOMs CoClass
Class Hierarchy
SymBBAuto::McadBOMs


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBOMStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBOMStandard CoClass
Class Hierarchy
SymBBAuto::McadBOMStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadBorder CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadBorder CoClass
Class Hierarchy
SymBBAuto::McadBorder


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadColumnDefinition CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadColumnDefinition CoClass
Class Hierarchy
SymBBAuto::McadColumnDefinition


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadColumnDefinitions CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadColumnDefinitions CoClass
Class Hierarchy
SymBBAuto::McadColumnDefinitions


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDatumIdentifier CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDatumIdentifier CoClass
Class Hierarchy
SymBBAuto::McadDatumIdentifier


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDatumStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDatumStandard CoClass
Class Hierarchy
SymBBAuto::McadDatumStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDatumTarget CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDatumTarget CoClass
Class Hierarchy
SymBBAuto::McadDatumTarget


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDetailSymbol CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDetailSymbol CoClass
Class Hierarchy
SymBBAuto::McadDetailSymbol


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDetailSymbolLabel CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDetailSymbolLabel CoClass
Class Hierarchy
SymBBAuto::McadDetailSymbolLabel


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadDetailSymbolStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadDetailSymbolStandard CoClass
Class Hierarchy
SymBBAuto::McadDetailSymbolStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadEdge CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadEdge CoClass
Class Hierarchy
SymBBAuto::McadEdge


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadEdgeLibrary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadEdgeLibrary CoClass
Class Hierarchy
SymBBAuto::McadEdgeLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadEdgeLibraryObject CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadEdgeLibraryObject CoClass
Class Hierarchy
SymBBAuto::McadEdgeLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadEdgeStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadEdgeStandard CoClass
Class Hierarchy
SymBBAuto::McadEdgeStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadFCFLibrary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFCFLibrary CoClass
Class Hierarchy
SymBBAuto::McadFCFLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadFCFLibraryObject CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFCFLibraryObject CoClass
Class Hierarchy
SymBBAuto::McadFCFLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadFCFStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFCFStandard CoClass
Class Hierarchy
SymBBAuto::McadFCFStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadFeatureControlFrame CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFeatureControlFrame CoClass
Class Hierarchy
SymBBAuto::McadFeatureControlFrame


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadFeatureIdentifier CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadFeatureIdentifier CoClass
Class Hierarchy
SymBBAuto::McadFeatureIdentifier


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadIdentifier CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadIdentifier CoClass
Class Hierarchy
SymBBAuto::McadIdentifier


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadIdentifierStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadIdentifierStandard CoClass
Class Hierarchy
SymBBAuto::McadIdentifierStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadJoint CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadJoint CoClass
Class Hierarchy
SymBBAuto::McadJoint


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadJointStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadJointStandard CoClass
Class Hierarchy
SymBBAuto::McadJointStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadMarkStamp CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadMarkStamp CoClass
Class Hierarchy
SymBBAuto::McadMarkStamp


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadMarkStampStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadMarkStampStandard CoClass
Class Hierarchy
SymBBAuto::McadMarkStampStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadNote CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadNote CoClass
Class Hierarchy
SymBBAuto::McadNote


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadNoteStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadNoteStandard CoClass
Class Hierarchy
SymBBAuto::McadNoteStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartList CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartList CoClass
Class Hierarchy
SymBBAuto::McadPartList


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListBalloonedFilter CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListBalloonedFilter CoClass
Class Hierarchy
SymBBAuto::McadPartListBalloonedFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListCustomFilter CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListCustomFilter CoClass
Class Hierarchy
SymBBAuto::McadPartListCustomFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListFilter CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListFilter CoClass
Class Hierarchy
SymBBAuto::McadPartListFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListFilters CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListFilters CoClass
Class Hierarchy
SymBBAuto::McadPartListFilters


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListGOST CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListGOST CoClass
Class Hierarchy
SymBBAuto::McadPartListGOST


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartLists CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartLists CoClass
Class Hierarchy
SymBBAuto::McadPartLists


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListStandard CoClass
Class Hierarchy
SymBBAuto::McadPartListStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartListStdPartsFilter CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartListStdPartsFilter CoClass
Class Hierarchy
SymBBAuto::McadPartListStdPartsFilter


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartReference CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartReference CoClass
Class Hierarchy
SymBBAuto::McadPartReference


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadPartReferences CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadPartReferences CoClass
Class Hierarchy
SymBBAuto::McadPartReferences


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadRevisionList CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadRevisionList CoClass
Class Hierarchy
SymBBAuto::McadRevisionList


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadRevisionListDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadRevisionListDescriptor CoClass
Class Hierarchy
SymBBAuto::McadRevisionListDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadRevisionLists CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadRevisionLists CoClass
Class Hierarchy
SymBBAuto::McadRevisionLists


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadRevisionMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadRevisionMgr CoClass
Class Hierarchy
SymBBAuto::McadRevisionMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadScaleArea CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadScaleArea CoClass
Class Hierarchy
SymBBAuto::McadScaleArea


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadScaleAreaMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadScaleAreaMgr CoClass
Class Hierarchy
SymBBAuto::McadScaleAreaMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSectionLine CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSectionLine CoClass
Class Hierarchy
SymBBAuto::McadSectionLine


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSectionLineStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSectionLineStandard CoClass
Class Hierarchy
SymBBAuto::McadSectionLineStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadStandard CoClass
Class Hierarchy
SymBBAuto::McadStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadStandardMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadStandardMgr CoClass
Class Hierarchy
SymBBAuto::McadStandardMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadStandards CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadStandards CoClass
Class Hierarchy
SymBBAuto::McadStandards


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSurfaceTexture CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSurfaceTexture CoClass
Class Hierarchy
SymBBAuto::McadSurfaceTexture


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureLibrary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSurfaceTextureLibrary CoClass
Class Hierarchy
SymBBAuto::McadSurfaceTextureLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureLibraryObject CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSurfaceTextureLibraryObject CoClass
Class Hierarchy
SymBBAuto::McadSurfaceTextureLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSurfaceTextureStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSurfaceTextureStandard CoClass
Class Hierarchy
SymBBAuto::McadSurfaceTextureStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbol CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbol CoClass
Class Hierarchy
SymBBAuto::McadSymbol


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolBBMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolBBMgr CoClass
Class Hierarchy
SymBBAuto::McadSymbolBBMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolLibrary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolLibrary CoClass
Class Hierarchy
SymBBAuto::McadSymbolLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolLibraryObject CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolLibraryObject CoClass
Class Hierarchy
SymBBAuto::McadSymbolLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolLibraryObjects CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolLibraryObjects CoClass
Class Hierarchy
SymBBAuto::McadSymbolLibraryObjects


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolStandard CoClass
Class Hierarchy
SymBBAuto::McadSymbolStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadSymbolStandards CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadSymbolStandards CoClass
Class Hierarchy
SymBBAuto::McadSymbolStandards


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTaper CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTaper CoClass
Class Hierarchy
SymBBAuto::McadTaper


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTaperStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTaperStandard CoClass
Class Hierarchy
SymBBAuto::McadTaperStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitle CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitle CoClass
Class Hierarchy
SymBBAuto::McadTitle


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorder CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorder CoClass
Class Hierarchy
SymBBAuto::McadTitleBorder


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorderContext CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorderContext CoClass
Class Hierarchy
SymBBAuto::McadTitleBorderContext


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorderDescriptor CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorderDescriptor CoClass
Class Hierarchy
SymBBAuto::McadTitleBorderDescriptor


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorderMgr CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorderMgr CoClass
Class Hierarchy
SymBBAuto::McadTitleBorderMgr


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorders CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorders CoClass
Class Hierarchy
SymBBAuto::McadTitleBorders


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadTitleBorderStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadTitleBorderStandard CoClass
Class Hierarchy
SymBBAuto::McadTitleBorderStandard


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadWelding CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadWelding CoClass
Class Hierarchy
SymBBAuto::McadWelding


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadWeldingLibrary CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadWeldingLibrary CoClass
Class Hierarchy
SymBBAuto::McadWeldingLibrary


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadWeldingLibraryObject CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadWeldingLibraryObject CoClass
Class Hierarchy
SymBBAuto::McadWeldingLibraryObject


Class Hierarchy

You are here: API Reference > SymBBAuto Library > McadWeldingStandard CoClass
AUTODESK AUTOCAD MECHANICAL 2015 ActiveX and VBA Reference
Class Hierarchy
McadWeldingStandard CoClass
Class Hierarchy
SymBBAuto::McadWeldingStandard


Contents

You are here: Contents
Contents
What's New
Introduction
Type Libraries and Object Models
API Reference
AcadmAuto Library
AcadmApplication CoClass
Mcad2dComplexStdPartCompGroupDescriptor CoClass
Mcad2dComponentDescriptor CoClass
Mcad2dShaftCompGroupDescriptor CoClass
Mcad2dStdPartComponentDescriptor CoClass
Mcad2DStructureDescriptor CoClass
Mcad2DStructureMgr CoClass
McadAnnotationViewDefinition CoClass
McadAnnotationViewDefinitions CoClass
McadArc CoClass
McadAttribute CoClass
McadAttributeField CoClass
McadAttributeFields CoClass
McadAttributes CoClass
McadAugmentedLine CoClass
McadComplexHideSituation CoClass
McadComplexHideSituations CoClass
McadComponent CoClass
McadComponentDefinition CoClass
McadComponentDefinitions CoClass
McadComponents CoClass
McadComponentView CoClass
McadComponentViewDefinition CoClass
McadComponentViewDefinitions CoClass
McadComponentViewDescriptor CoClass
McadComponentViews CoClass
McadDocument CoClass
McadDocuments CoClass
McadEllipse CoClass
McadFolder CoClass
McadFolderDefinition CoClass
McadFolderDefinitions CoClass
McadFolderDescriptor CoClass
McadFolders CoClass
McadFormulaEvaluator CoClass
McadHideSituation CoClass
McadHideSituations CoClass
McadLayerCfg CoClass
McadLayerCfgs CoClass
McadLayerGroupMgr CoClass
McadLayerObjectCfg CoClass
McadLayerObjectCfgs CoClass
McadLayerObjectMgr CoClass
McadLine CoClass
McadObjects CoClass
McadPick CoClass
McadPolyline CoClass
McadPowObjViewGroupDescriptor CoClass
McadSpline CoClass
McadStdPartComponentViewDescriptor CoClass
McadTransaction CoClass
McadUtility CoClass
IAcadmApplication Interface
IAcadmApplication Members
IAcadmApplication::ActiveDocument Property
IAcadmApplication::Application Property
IAcadmApplication::AttributeClasses Property
IAcadmApplication::Documents Property
IAcadmApplication::StructureModeEditEntity Property
IAcadmApplication::AddAttributeClass Method
IAcadmApplication::DocumentFromHost Method
IAcadmApplication::GetAttributeClassFields Method
IAcadmApplication::GetFormulaEvaluator Method
IAcadmApplication::ReadAttributeClass Method
IAcadmApplication::RemoveAttributeClass Method
IAcadmApplication::WriteAttributeClass Method
IAcadmApplicationVersion Interface
IAcadmApplicationVersion Members
IAcadmApplicationVersion::GetVersionNumber Method
IMcad2dComplexStdPartCompGroupDescriptor Interface
IMcad2dComplexStdPartCompGroupDescriptor Members
IMcad2dComplexStdPartCompGroupDescriptor::Views Property
IMcad2dComplexStdPartCompGroupDescriptor::AddView Method
IMcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup Method
IMcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dComplexStdPartCompGroupDescriptor::RemoveView Method
IMcad2dComponentDescriptor Interface
IMcad2dComponentDescriptor Members
IMcad2dComponentDescriptor::Component Property
IMcad2dComponentDescriptor::ComponentDefinition Property
IMcad2dComponentDescriptor::ComponentViews Property
IMcad2dComponentDescriptor::OwningComponentDefinition Property
IMcad2dComponentDescriptor::AddComponentView Method
IMcad2dComponentDescriptor::CreateComponent Method
IMcad2dComponentDescriptor::HasEqualTypeWithView Method
IMcad2dComponentDescriptor::RemoveComponentView Method
IMcad2dShaftCompGroupDescriptor Interface
IMcad2dShaftCompGroupDescriptor Members
IMcad2dShaftCompGroupDescriptor::Views Property
IMcad2dShaftCompGroupDescriptor::MigrateTo2DStructure Method
IMcad2dStdPartComponentDescriptor Interface
IMcad2DStructureDescriptor Interface
IMcad2DStructureDescriptor Members
IMcad2DStructureDescriptor::Name Property
IMcad2DStructureMgr Interface
IMcad2DStructureMgr Members
IMcad2DStructureMgr::Application Property
IMcad2DStructureMgr::EditTarget Property
IMcad2DStructureMgr::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr::AddNewComponentDefinition Method
IMcad2DStructureMgr::AddNewComponentView Method
IMcad2DStructureMgr::AddNewComponentViewDefinition Method
IMcad2DStructureMgr::AddNewFolder Method
IMcad2DStructureMgr::AddNewFolderDefinition Method
IMcad2DStructureMgr::CopyComponentFromDatabase Method
IMcad2DStructureMgr::CopyFolderFromDatabase Method
IMcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor Method
IMcad2DStructureMgr::Create2dComponentDescriptor Method
IMcad2DStructureMgr::Create2dStdPartComponentDescriptor Method
IMcad2DStructureMgr::CreateBlocksFromStructure Method
IMcad2DStructureMgr::CreateComponentViewDescriptor Method
IMcad2DStructureMgr::CreateFolderDescriptor Method
IMcad2DStructureMgr::CreateStructureFromBlocks Method
IMcad2DStructureMgr::ExternalStructureDatabases Method
IMcad2DStructureMgr::GetComplexStdPartsForMigr Method
IMcad2DStructureMgr::GetComplexStdPartViewsForMigr Method
IMcad2DStructureMgr::GetComponentDefinitions Method
IMcad2DStructureMgr::GetComponentViewDefinitions Method
IMcad2DStructureMgr::GetFolderDefinitions Method
IMcad2DStructureMgr::GetFolderPowerObjectsForMigr Method
IMcad2DStructureMgr::GetNextAnnotationViewDefinitionName Method
IMcad2DStructureMgr::GetNextComponentDefinitionName Method
IMcad2DStructureMgr::GetNextFolderDefinitionName Method
IMcad2DStructureMgr::GetSelection Method
IMcad2DStructureMgr::GetShaftsForMigr Method
IMcad2DStructureMgr::GetSingleStdPartComponentsForMigr Method
IMcad2DStructureMgr::GetSingleStdPartViewsForMigr Method
IMcad2DStructureMgr::GetStructureFromEntity Method
IMcad2DStructureMgr::HasComponentDefinition Method
IMcad2DStructureMgr::HasFolderDefinition Method
IMcad2DStructureMgr::Highlight Method
IMcad2DStructureMgr::Is2DStructureEnabled Method
IMcad2DStructureMgr::IsEntityAllowed Method
IMcad2DStructureMgr::IsFreeEntity Method
IMcad2DStructureMgr::IsInActiveTarget Method
IMcad2DStructureMgr::IsStructureBlock Method
IMcad2DStructureMgr::PurgeAll2DS Method
IMcad2DStructureMgr::PurgeAnnotationViewDefinitions Method
IMcad2DStructureMgr::PurgeComponentDefinitions Method
IMcad2DStructureMgr::PurgeComponentViewDefinitions Method
IMcad2DStructureMgr::PurgeFolderDefinitions Method
IMcad2DStructureMgr::RestructureViews Method
IMcad2DStructureMgr::RootComponentDefinition Method
IMcad2DStructureMgr::RootViewDefinition Method
IMcad2DStructureMgr::Update Method
IMcad2DStructureMgr::UpdateEntities Method
IMcad2DStructureMgr2 Interface
IMcad2DStructureMgr2 Members
IMcad2DStructureMgr2::StartTransaction Property
IMcad2DStructureMgr3 Interface
IMcad2DStructureMgr3 Members
IMcad2DStructureMgr3::AddNewAnnotationView Method
IMcad2DStructureMgr3::AddNewAnnotationViewDefinition Method
IMcad2DStructureMgr3::UpdateEntities Method
IMcad2DStructureMgr4 Interface
IMcad2DStructureMgr4 Members
IMcad2DStructureMgr4::SelectionLockMode Property
IMcad2DStructureMgr4::SelectionOrderMode Property
IMcad2DStructureMgr4::GetReferenceLockMode Method
IMcad2DStructureMgr4::GetStructureMode Method
IMcad2DStructureMgr4::SetReferenceLockMode Method
IMcad2DStructureMgr4::SetStructureMode Method
IMcad2DStructureMgr5 Interface
IMcad2DStructureMgr5 Members
IMcad2DStructureMgr5::CreateRootViewDefinition Method
IMcad2DStructureMgr5::ExistsStructure Method
IMcadAnnotationViewDefinition Interface
IMcadAnnotationViewDefinition Members
IMcadAnnotationViewDefinition::ComponentDefinition Property
IMcadAnnotationViewDefinition::AddComponentView Method
IMcadAnnotationViewDefinition::RemoveComponentView Method
IMcadAnnotationViewDefinition2 Interface
IMcadAnnotationViewDefinition2 Members
IMcadAnnotationViewDefinition2::AnnotationViewLabel Method
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [in] BSTR)
IMcadAnnotationViewDefinition2::AnnotationViewLabelPattern Method ([in] IMcadComponentView *, [out, retval] BSTR*)
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabel Method
IMcadAnnotationViewDefinition2::CreateAnnotationViewLabels Method
IMcadAnnotationViewDefinition2::EraseAnnotationViewLabel Method
IMcadAnnotationViewDefinition2::HasAnnotationViewLabel Method
IMcadAnnotationViewDefinitions Interface
IMcadAnnotationViewDefinitions Members
IMcadAnnotationViewDefinitions::Application Property
IMcadAnnotationViewDefinitions::Count Property
IMcadAnnotationViewDefinitions::Add Method
IMcadAnnotationViewDefinitions::Item Method
IMcadAnnotationViewDefinitions::Remove Method
IMcadArc Interface
IMcadAttribute Interface
IMcadAttribute Members
IMcadAttribute::Application Property
IMcadAttribute::ClassName Property
IMcadAttribute::Document Property
IMcadAttribute::FieldCount Property
IMcadAttribute::Holders Property
IMcadAttribute::ObjectID Property
IMcadAttribute::ObjectID32 Property
IMcadAttribute::FieldDescription Method
IMcadAttribute::FieldName Method
IMcadAttribute::FieldType Method
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute::FieldValue Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [in] VARIANT)
IMcadAttribute::FieldValue32 Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadAttribute::GetFieldIndex Method
IMcadAttributeField Interface
IMcadAttributeField Members
IMcadAttributeField::Application Property
IMcadAttributeField::Description Property
IMcadAttributeField::FieldType Property
IMcadAttributeField::Name Property
IMcadAttributeField::Static Property
IMcadAttributeFields Interface
IMcadAttributeFields Members
IMcadAttributeFields::Application Property
IMcadAttributeFields::Count Property
IMcadAttributeFields::Add Method
IMcadAttributeFields::Item Method
IMcadAttributeFields::Remove Method
IMcadAttributes Interface
IMcadAttributes Members
IMcadAttributes::Application Property
IMcadAttributes::Count Property
IMcadAttributes::Add Method
IMcadAttributes::Item Method
IMcadAttributes::Remove Method
IMcadAugmentedLine Interface
IMcadComplexHideSituation Interface
IMcadComplexHideSituation Members
IMcadComplexHideSituation::Concealed Property
IMcadComplexHideSituation::Definition Property
IMcadComplexHideSituation::HiddenLinesInvisible Property
IMcadComplexHideSituation::HideAppropriateObjectsOnly Property
IMcadComplexHideSituation::HideSituations Property
IMcadComplexHideSituation::IsModifiedStandardPartHide Property
IMcadComplexHideSituation::IsStandardPartHide Property
IMcadComplexHideSituation::LevelCount Property
IMcadComplexHideSituation::Name Property
IMcadComplexHideSituation::NextLevelName Property
IMcadComplexHideSituation::Suppressed Property
IMcadComplexHideSituation::SysName Property
IMcadComplexHideSituation::AddLevel Method
IMcadComplexHideSituation::Explode Method
IMcadComplexHideSituation::InitFromHide Method
IMcadComplexHideSituation::LookupLevelName Method
IMcadComplexHideSituation::MoveLevel Method
IMcadComplexHideSituation::RemoveLevel Method
IMcadComplexHideSituation::RemoveLevelByIdx Method
IMcadComplexHideSituation::Reverse Method
IMcadComplexHideSituation::UpdateBgSelection Method
IMcadComplexHideSituations Interface
IMcadComplexHideSituations Members
IMcadComplexHideSituations::Application Property
IMcadComplexHideSituations::Count Property
IMcadComplexHideSituations::Add Method
IMcadComplexHideSituations::Item Method
IMcadComplexHideSituations::Remove Method
IMcadComponent Interface
IMcadComponent Members
IMcadComponent::Children Property
IMcadComponent::ComponentViews Property
IMcadComponent::Definition Property
IMcadComponent::hasExternalDef Property
IMcadComponent::HasGhostViews Property
IMcadComponent::HasOverrideProperties Property
IMcadComponent::is2D Property
IMcadComponent::Name Property
IMcadComponent::Owner Property
IMcadComponent::Position Property
IMcadComponent::Reference Property
IMcadComponent::Visible Property
IMcadComponent::AddAttribute Method
IMcadComponent::ClearOverrideProperties Method
IMcadComponent::ColorOverride Method
IMcadComponent::ContainingComponent Method
IMcadComponent::CopyDefinition Method
IMcadComponent::GetAttributes Method
IMcadComponent::GetComponentInDefinition Method
IMcadComponent::PredefinedReferenceOverride Method
IMcadComponent::RemoveAttribute Method
IMcadComponent::ReplaceDefinition Method
IMcadComponent::SortChildren Method
IMcadComponent::VisibilityOverride Method
IMcadComponentDefinition Interface
IMcadComponentDefinition Members
IMcadComponentDefinition::Children Property
IMcadComponentDefinition::ComponentViewDefinitions Property
IMcadComponentDefinition::ExternalPath Property
IMcadComponentDefinition::is2D Property
IMcadComponentDefinition::is2DAssembly Property
IMcadComponentDefinition::IsExternal Property
IMcadComponentDefinition::isFeature Property
IMcadComponentDefinition::IsLeafNode Property
IMcadComponentDefinition::IsRoot Property
IMcadComponentDefinition::isShaft Property
IMcadComponentDefinition::isStandardPart Property
IMcadComponentDefinition::Name Property
IMcadComponentDefinition::PhantomState Property
IMcadComponentDefinition::AddAttribute Method
IMcadComponentDefinition::AddComponent Method
IMcadComponentDefinition::CopyDefinition Method
IMcadComponentDefinition::Externalize Method
IMcadComponentDefinition::GetAttributes Method
IMcadComponentDefinition::GetInstances Method
IMcadComponentDefinition::GetNextComponentViewDefinitionName Method
IMcadComponentDefinition::HasComponentViewDefinition Method
IMcadComponentDefinition::Localize2DS Method
IMcadComponentDefinition::RemoveAttribute Method
IMcadComponentDefinition::RemoveComponent Method
IMcadComponentDefinition::SortChildren Method
IMcadComponentDefinition::Update Method
IMcadComponentDefinitions Interface
IMcadComponentDefinitions Members
IMcadComponentDefinitions::Application Property
IMcadComponentDefinitions::Count Property
IMcadComponentDefinitions::Add Method
IMcadComponentDefinitions::Item Method
IMcadComponentDefinitions::Remove Method
IMcadComponents Interface
IMcadComponents Members
IMcadComponents::Application Property
IMcadComponents::Count Property
IMcadComponents::Add Method
IMcadComponents::Item Method
IMcadComponents::Remove Method
IMcadComponentView Interface
IMcadComponentView Members
IMcadComponentView::Component Property
IMcadComponentView::isFeature Property
IMcadComponentView::IsGhostView Method
IMcadComponentViewDefinition Interface
IMcadComponentViewDefinition Members
IMcadComponentViewDefinition::IsFeature Property
IMcadComponentViewDefinition::Owner Property
IMcadComponentViewDefinition::AddComponentView Method
IMcadComponentViewDefinition::RemoveComponentView Method
IMcadComponentViewDefinitions Interface
IMcadComponentViewDefinitions Members
IMcadComponentViewDefinitions::Application Property
IMcadComponentViewDefinitions::Count Property
IMcadComponentViewDefinitions::Add Method
IMcadComponentViewDefinitions::Item Method
IMcadComponentViewDefinitions::Remove Method
IMcadComponentViewDescriptor Interface
IMcadComponentViewDescriptor Members
IMcadComponentViewDescriptor::Component Property
IMcadComponentViewDescriptor::FullViewName Property
IMcadComponentViewDescriptor::CreateComponentView Method
IMcadComponentViews Interface
IMcadComponentViews Members
IMcadComponentViews::Application Property
IMcadComponentViews::Count Property
IMcadComponentViews::Add Method
IMcadComponentViews::Item Method
IMcadComponentViews::Remove Method
IMcadCurve Interface
IMcadDescriptor Interface
IMcadDescriptor Members
IMcadDescriptor::Application Property
IMcadDescriptor::Document Property
IMcadDocuments Interface
IMcadDocuments Members
IMcadDocuments::Application Property
IMcadDocuments::Count Property
IMcadDocuments::Item Method
IMcadDocumentVersion Interface
IMcadDocumentVersion Members
IMcadDocumentVersion::GetVersionNumber Method
IMcadEllipse Interface
IMcadFolder Interface
IMcadFolder Members
IMcadFolder::BasePoint Property
IMcadFolder::Children Property
IMcadFolder::ContextDefinition Property
IMcadFolder::Definition Property
IMcadFolder::Entities Property
IMcadFolder::Entities32 Property
IMcadFolder::ExtentsMaximum Property
IMcadFolder::ExtentsMinimum Property
IMcadFolder::GeomPathName Property
IMcadFolder::HasExternalDef Property
IMcadFolder::HasOverrideProperties Property
IMcadFolder::IsInstance Property
IMcadFolder::IsLeaf Property
IMcadFolder::IsLocked Property
IMcadFolder::Owner Property
IMcadFolder::Position Property
IMcadFolder::ViewName Property
IMcadFolder::ViewScale Property
IMcadFolder::Visible Property
IMcadFolder::AddEntities Method
IMcadFolder::ClearLeaf Method
IMcadFolder::ClearOverrideProperties Method
IMcadFolder::ColorOverride Method
IMcadFolder::CopyEntities Method
IMcadFolder::CopyView Method
IMcadFolder::CopyViewDefinition Method
IMcadFolder::Explode Method
IMcadFolder::IsSubentityOf Method
IMcadFolder::PredefinedReferenceOverride Method
IMcadFolder::RemoveEntities Method
IMcadFolder::ReplaceDefinition Method
IMcadFolder::VisibilityOverride Method
IMcadFolder2 Interface
IMcadFolder2 Members
IMcadFolder2::OwningSpace Property
IMcadFolderDefinition Interface
IMcadFolderDefinition Members
IMcadFolderDefinition::ChildrenCount Property
IMcadFolderDefinition::ComplexHideSituations Property
IMcadFolderDefinition::FullName Property
IMcadFolderDefinition::HideSituations Property
IMcadFolderDefinition::InstanceCount Property
IMcadFolderDefinition::IsAnnotation Property
IMcadFolderDefinition::IsDetail Property
IMcadFolderDefinition::IsLocked Property
IMcadFolderDefinition::IsRoot Property
IMcadFolderDefinition::LockType Property
IMcadFolderDefinition::Name Property
IMcadFolderDefinition::ViewType Property
IMcadFolderDefinition::AddComplexHideSituation Method
IMcadFolderDefinition::AddFolder Method
IMcadFolderDefinition::AddFromExistingEntities Method
IMcadFolderDefinition::AddHideSituation Method
IMcadFolderDefinition::Children Method
IMcadFolderDefinition::Extents Method
IMcadFolderDefinition::Externalize Method
IMcadFolderDefinition::FindHideSituations Method
IMcadFolderDefinition::GetHidesSuppressState Method
IMcadFolderDefinition::Instances Method
IMcadFolderDefinition::InstancesDefinition Method
IMcadFolderDefinition::IsExternal Method
IMcadFolderDefinition::Localize Method
IMcadFolderDefinition::LookupViewName Method
IMcadFolderDefinition::NextViewName Method
IMcadFolderDefinition::Occurrences Method
IMcadFolderDefinition::RemoveFolder Method
IMcadFolderDefinition::SetHidesSuppressState Method
IMcadFolderDefinition::SortChildren Method
IMcadFolderDefinitions Interface
IMcadFolderDefinitions Members
IMcadFolderDefinitions::Application Property
IMcadFolderDefinitions::Count Property
IMcadFolderDefinitions::Add Method
IMcadFolderDefinitions::Item Method
IMcadFolderDefinitions::Remove Method
IMcadFolderDescriptor Interface
IMcadFolderDescriptor Members
IMcadFolderDescriptor::Definition Property
IMcadFolderDescriptor::Entities Property
IMcadFolderDescriptor::Entities32 Property
IMcadFolderDescriptor::Position Property
IMcadFolderDescriptor::PowerObjectType Property
IMcadFolderDescriptor::TargetView Property
IMcadFolderDescriptor::ViewKey Property
IMcadFolderDescriptor::ViewName Property
IMcadFolderDescriptor::Views Property
IMcadFolderDescriptor::CreateFolder Method
IMcadFolders Interface
IMcadFolders Members
IMcadFolders::Application Property
IMcadFolders::Count Property
IMcadFolders::Add Method
IMcadFolders::Item Method
IMcadFolders::Remove Method
IMcadFormulaEvaluator Interface
IMcadFormulaEvaluator Members
IMcadFormulaEvaluator::Application Property
IMcadFormulaEvaluator::Evaluate Method
IMcadFormulaEvaluator::Exist Method
IMcadFormulaEvaluator::GetAllAttribs Method
IMcadFormulaEvaluator::GetAllAttribsData Method
IMcadFormulaEvaluator::GetAllAttribValues Method
IMcadFormulaEvaluator::GetData Method
IMcadFormulaEvaluator::IsEditable Method
IMcadFormulaEvaluator::SetData Method
IMcadFormulaEvaluator::SetDataProvider Method
IMcadGeometry Interface
IMcadGeometry Members
IMcadGeometry::Geometry Property
IMcadGeometry::AddAttribute Method
IMcadGeometry::ContainingComponent Method
IMcadGeometry::GetAttributes Method
IMcadGeometry::HasChanged Method
IMcadGeometry::RemoveAttribute Method
IMcadHideSituation Interface
IMcadHideSituation Members
IMcadHideSituation::BgSelectionName Property
IMcadHideSituation::Concealed Property
IMcadHideSituation::ContoursOnlyInForeground Property
IMcadHideSituation::Definition Property
IMcadHideSituation::FgSelectionName Property
IMcadHideSituation::HiddenLinesInvisible Property
IMcadHideSituation::HideAppropriateObjectsOnly Property
IMcadHideSituation::IgnoreBgExclude Property
IMcadHideSituation::IgnoreFgExclude Property
IMcadHideSituation::IgnoreUpperBgExclude Property
IMcadHideSituation::InverseForeground Property
IMcadHideSituation::IsComplexHideLevel Property
IMcadHideSituation::IsLastLevel Property
IMcadHideSituation::IsMigrated Property
IMcadHideSituation::IsModifiedStandardPartHide Property
IMcadHideSituation::IsStandardPartHide Property
IMcadHideSituation::LevelIndex Property
IMcadHideSituation::Name Property
IMcadHideSituation::OuterContourOnly Property
IMcadHideSituation::ParentHide Property
IMcadHideSituation::SaveSimplifiedOuterContour Property
IMcadHideSituation::Suppressed Property
IMcadHideSituation::SysName Property
IMcadHideSituation::AddMSSubent Method
IMcadHideSituation::AddMSSubents Method
IMcadHideSituation::AddSubent Method
IMcadHideSituation::AddSubents Method
IMcadHideSituation::AutoSelectBackground Method
IMcadHideSituation::ClearSubents Method
IMcadHideSituation::RemoveSubent Method
IMcadHideSituation::RemoveSubentByIdx Method
IMcadHideSituation::Subents Method
IMcadHideSituation::SwapFgAndBg Method
IMcadHideSituations Interface
IMcadHideSituations Members
IMcadHideSituations::Application Property
IMcadHideSituations::Count Property
IMcadHideSituations::Add Method
IMcadHideSituations::Item Method
IMcadHideSituations::Remove Method
IMcadLayerCfg Interface
IMcadLayerCfg Members
IMcadLayerCfg::AssocObjects Property
IMcadLayerCfg::Desc Property
IMcadLayerCfg::Invisible Property
IMcadLayerCfg::Key Property
IMcadLayerCfg::LineType Property
IMcadLayerCfg::LineTypeId Property
IMcadLayerCfg::LineTypeId32 Property
IMcadLayerCfg::LineWeight Property
IMcadLayerCfg::Name Property
IMcadLayerCfg::NoPlot Property
IMcadLayerCfg::NoReplicateInLayerGroup Property
IMcadLayerCfg::OverrideColorByLayerGroup Property
IMcadLayerCfg::TrueColor Property
IMcadLayerCfgs Interface
IMcadLayerCfgs Members
IMcadLayerCfgs::_NewEnum Property
IMcadLayerCfgs::Application Property
IMcadLayerCfgs::Count Property
IMcadLayerCfgs::Add Method
IMcadLayerCfgs::Item Method
IMcadLayerCfgs::Remove Method
IMcadLayerGroupMgr Interface
IMcadLayerGroupMgr Members
IMcadLayerGroupMgr::Document Property
IMcadLayerGroupMgr::GetLayerGroupEntities Method
IMcadLayerGroupMgr::GetLayerGroupEntities32 Method
IMcadLayerGroupMgr::GetLayerGroupNames Method
IMcadLayerGroupMgr::GetLayersFromGroup Method
IMcadLayerGroupMgr::MoveLayerGroupEntities Method
IMcadLayerObjectCfg Interface
IMcadLayerObjectCfg Members
IMcadLayerObjectCfg::Hide Property
IMcadLayerObjectCfg::LayerName Property
IMcadLayerObjectCfg::LayerObjKey Property
IMcadLayerObjectCfg::LineType Property
IMcadLayerObjectCfg::LineTypeId Property
IMcadLayerObjectCfg::LineTypeId32 Property
IMcadLayerObjectCfg::LineWeight Property
IMcadLayerObjectCfg::TrueColor Property
IMcadLayerObjectCfgs Interface
IMcadLayerObjectCfgs Members
IMcadLayerObjectCfgs::_NewEnum Property
IMcadLayerObjectCfgs::Application Property
IMcadLayerObjectCfgs::Count Property
IMcadLayerObjectCfgs::Add Method
IMcadLayerObjectCfgs::Item Method
IMcadLayerObjectCfgs::Remove Method
IMcadLayerObjectMgr Interface
IMcadLayerObjectMgr Members
IMcadLayerObjectMgr::Document Property
IMcadLayerObjectMgr::CreateLayer Method
IMcadLayerObjectMgr::GetAllLayerObjs Method
IMcadLayerObjectMgr::GetAllLayers Method
IMcadLayerObjectMgr::GetLayerObjProperty Method
IMcadLayerObjectMgr::GetLayerProperty Method
IMcadLayerObjectMgr::ImportLayerObj Method
IMcadLayerObjectMgr::SetLayerObjDefault Method
IMcadLine Interface
IMcadObject Interface
IMcadObject Members
IMcadObject::Application Property
IMcadObject::Document Property
IMcadObject::Editable Property
IMcadObject::WasErased Property
IMcadObject::Delete Method
IMcadObject::Highlight Method
IMcadObject::IsEqualTo Method
IMcadObject::MakePersistent Method
IMcadObjects Interface
IMcadObjects Members
IMcadObjects::Application Property
IMcadObjects::Count Property
IMcadObjects::Add Method
IMcadObjects::Item Method
IMcadObjects::Remove Method
IMcadPick Interface
IMcadPick Members
IMcadPick::Application Property
IMcadPick::ObjectType Property
IMcadPick::PickPoint Property
IMcadPolyline Interface
IMcadPowObjViewGroupDescriptor Interface
IMcadPowObjViewGroupDescriptor Members
IMcadPowObjViewGroupDescriptor::Entities Property
IMcadPowObjViewGroupDescriptor::Entities32 Property
IMcadPowObjViewGroupDescriptor::PowerObjectType Property
IMcadPowObjViewGroupDescriptor::TargetView Property
IMcadSpline Interface
IMcadStdPartComponentViewDescriptor Interface
IMcadUtility Interface
IMcadUtility Members
IMcadUtility::Application Property
IMcadUtility::Document Property
IMcadUtility::CreateAttribute Method
IMcadUtility::CreateAttributeField Method
IMcadUtility::CreateCollection Method
IMcadUtility::CreatePickObject Method
IMcadUtility::CreateSystemAttribute Method
IMcadUtility::GetAllAttributes Method
IMcadUtility::GetAttributeFromID Method
IMcadUtility::GetAttributeFromID32 Method
IMcadUtility::GetGeometryFromPick Method
IMcadUtility::GetIdsFromObject Method
IMcadUtility::GetIdsFromObject32 Method
IMcadUtility::GetObjectFromID Method
IMcadUtility::GetObjectFromID32 Method
IMcadUtility::GetObjectFromPick Method
IMcadUtility::Pick Method
IMcadUtility2 Interface
IMcadUtility2 Members
IMcadUtility2::RefocusObject Method
IMcadUtility3 Interface
IMcadUtility3 Members
IMcadUtility3::GetDrawingType Method
Mcad2DSViewType Enumeration
McadCollectionType Enumeration
McadDocDrawingType Enumeration
McadFieldType Enumeration
McadHideSituationRefType Enumeration
McadHideSituationSubentType Enumeration
McadLayerObjectHideType Enumeration
McadObjectType Enumeration
McadPhantomState Enumeration
McadPowerObjectType Enumeration
McadSelectionOrderOption Enumeration
SymBBAuto Library
McadAnnotationViewLabel CoClass
McadAnnotationViewStandard CoClass
McadBalloon CoClass
McadBalloons CoClass
McadBalloonStandard CoClass
McadBOM CoClass
McadBOMItem CoClass
McadBOMItems CoClass
McadBOMMgr CoClass
McadBOMs CoClass
McadBOMStandard CoClass
McadBorder CoClass
McadColumnDefinition CoClass
McadColumnDefinitions CoClass
McadDatumIdentifier CoClass
McadDatumStandard CoClass
McadDatumTarget CoClass
McadDetailSymbol CoClass
McadDetailSymbolLabel CoClass
McadDetailSymbolStandard CoClass
McadEdge CoClass
McadEdgeLibrary CoClass
McadEdgeLibraryObject CoClass
McadEdgeStandard CoClass
McadFCFLibrary CoClass
McadFCFLibraryObject CoClass
McadFCFStandard CoClass
McadFeatureControlFrame CoClass
McadFeatureIdentifier CoClass
McadIdentifier CoClass
McadIdentifierStandard CoClass
McadJoint CoClass
McadJointStandard CoClass
McadMarkStamp CoClass
McadMarkStampStandard CoClass
McadNote CoClass
McadNoteStandard CoClass
McadPartList CoClass
McadPartListBalloonedFilter CoClass
McadPartListCustomFilter CoClass
McadPartListFilter CoClass
McadPartListFilters CoClass
McadPartListGOST CoClass
McadPartLists CoClass
McadPartListStandard CoClass
McadPartListStdPartsFilter CoClass
McadPartReference CoClass
McadPartReferences CoClass
McadRevisionList CoClass
McadRevisionListDescriptor CoClass
McadRevisionLists CoClass
McadRevisionMgr CoClass
McadScaleArea CoClass
McadScaleAreaMgr CoClass
McadSectionLine CoClass
McadSectionLineStandard CoClass
McadStandard CoClass
McadStandardMgr CoClass
McadStandards CoClass
McadSurfaceTexture CoClass
McadSurfaceTextureLibrary CoClass
McadSurfaceTextureLibraryObject CoClass
McadSurfaceTextureStandard CoClass
McadSymbol CoClass
McadSymbolBBMgr CoClass
McadSymbolLibrary CoClass
McadSymbolLibraryObject CoClass
McadSymbolLibraryObjects CoClass
McadSymbolStandard CoClass
McadSymbolStandards CoClass
McadTaper CoClass
McadTaperStandard CoClass
McadTitle CoClass
McadTitleBorder CoClass
McadTitleBorderContext CoClass
McadTitleBorderDescriptor CoClass
McadTitleBorderMgr CoClass
McadTitleBorders CoClass
McadTitleBorderStandard CoClass
McadWelding CoClass
McadWeldingLibrary CoClass
McadWeldingLibraryObject CoClass
McadWeldingStandard CoClass
IMcadAnnotationViewLabel Interface
IMcadAnnotationViewLabel Members
IMcadAnnotationViewLabel::LabelPattern Property
IMcadAnnotationViewLabel::LabelText Property
IMcadAnnotationViewStandard Interface
IMcadAnnotationViewStandard Members
IMcadAnnotationViewStandard::LabelPattern Property
IMcadAnnotationViewStandard::LabelPatternVariables Property
IMcadAnnotationViewStandard::LabelPosition Property
IMcadBalloon Interface
IMcadBalloon Members
IMcadBalloon::AttachmentType Property
IMcadBalloon::BalloonType Property
IMcadBalloon::BOM Property
IMcadBalloon::BOMItems Property
IMcadBalloon::CollectionType Property
IMcadBalloon::CustomBlock Property
IMcadBalloon::CustomBlockName Property
IMcadBalloon::IsCustomBlockUsed Property
IMcadBalloon::AppendBOMItem Method
IMcadBalloon::RemoveBOMItem Method
IMcadBalloons Interface
IMcadBalloons Members
IMcadBalloons::Application Property
IMcadBalloons::Count Property
IMcadBalloons::Add Method
IMcadBalloons::Item Method
IMcadBalloons::Remove Method
IMcadBalloonStandard Interface
IMcadBalloonStandard Members
IMcadBalloonStandard::Application Property
IMcadBalloonStandard::ArrowType Property
IMcadBalloonStandard::AttachmentType Property
IMcadBalloonStandard::AuxiliaryArrowType Property
IMcadBalloonStandard::BalloonType Property
IMcadBalloonStandard::BOMStandard Property
IMcadBalloonStandard::Color Property
IMcadBalloonStandard::ColumnList Property
IMcadBalloonStandard::CustomBlockName Property
IMcadBalloonStandard::IsAuxiliaryArrowUsed Property
IMcadBalloonStandard::IsCustomBlockUsed Property
IMcadBalloonStandard::MaximumColumns Property
IMcadBalloonStandard::Revision Property
IMcadBalloonStandard::RevisionYear Property
IMcadBalloonStandard::TextHeight Property
IMcadBalloonStandard::RemoveColumn Method
IMcadBalloonStandard::SetToDefaults Method
IMcadBalloonStandard2 Interface
IMcadBalloonStandard2 Members
IMcadBalloonStandard2::TrueColor Property
IMcadBOM Interface
IMcadBOM Members
IMcadBOM::Data Property
IMcadBOM::PartLists Property
IMcadBOM::Target Property
IMcadBOM::AddItem Method
IMcadBOM::AddUnassociatedItem Method
IMcadBOM::Items Method
IMcadBOM2 Interface
IMcadBOM2 Members
IMcadBOM2::applySort Method
IMcadBOM2::GetProperties Method
IMcadBOM2::GetProperties32 Method
IMcadBOM2::SetProperties Method
IMcadBOM3 Interface
IMcadBOM3 Members
IMcadBOM3::IsBorder Property
IMcadBOM3::IsVisible Property
IMcadBOM3::GetStructuredChildItems Method
IMcadBOM3::GetStructuredParentItem Method
IMcadBOM3::MergeItems Method
IMcadBOM4 Interface
IMcadBOM4 Members
IMcadBOM4::SplitItem Method
IMcadBOMItem Interface
IMcadBOMItem Members
IMcadBOMItem::AutoCalculateEnabled Property
IMcadBOMItem::Balloons Property
IMcadBOMItem::BOM Property
IMcadBOMItem::Data Property
IMcadBOMItem::Expanded Property
IMcadBOMItem::IsExpandable Property
IMcadBOMItem::ItemNumber Property
IMcadBOMItem::Quantity Property
IMcadBOMItem::AddReference Method
IMcadBOMItem::GetReferences Method
IMcadBOMItem::GetReferences32 Method
IMcadBOMItem::ReferenceExists Method
IMcadBOMItem::RemoveReference Method
IMcadBOMItem2 Interface
IMcadBOMItem2 Members
IMcadBOMItem2::ExcludeFromPartList Property
IMcadBOMItem2::Phantomed Property
IMcadBOMItem2::GetAttribute Method
IMcadBOMItem2::GetCalculatedQuantity Method
IMcadBOMItem2::GetItemDefinition Method
IMcadBOMItem2::GetItemDefinition32 Method
IMcadBOMItem2::GetPartBalloons Method
IMcadBOMItem2::SetAttribute Method
IMcadBOMItem3 Interface
IMcadBOMItem3 Members
IMcadBOMItem3::SortPriority Property
IMcadBOMItem3::GetItemPartDefinition Method
IMcadBOMItem3::GetItemPartDefinition32 Method
IMcadBOMItem3::SetAttributePreDefinedListValue Method
IMcadBOMItem4 Interface
IMcadBOMItem4 Members
IMcadBOMItem4::GetBomOverride Method
IMcadBOMItem4::RemoveAttribute Method
IMcadBOMItems Interface
IMcadBOMItems Members
IMcadBOMItems::Application Property
IMcadBOMItems::Count Property
IMcadBOMItems::Add Method
IMcadBOMItems::Item Method
IMcadBOMItems::Remove Method
IMcadBOMMgr Interface
IMcadBOMMgr Members
IMcadBOMMgr::Application Property
IMcadBOMMgr::SymbolBBMgr Property
IMcadBOMMgr::AddBOMTable Method
IMcadBOMMgr::AddPartData Method
IMcadBOMMgr::BOMTableExists Method
IMcadBOMMgr::ExportBOM Method
IMcadBOMMgr::GetAllBOMTables Method
IMcadBOMMgr::GetBOMTable Method
IMcadBOMMgr::GetPartData Method
IMcadBOMMgr::ImportBOM Method
IMcadBOMMgr::RemoveBOMTable Method
IMcadBOMMgr::SelectBOMEntity Method
IMcadBOMMgr::SelectBOMEntity32 Method
IMcadBOMMgr::SetPartData Method
IMcadBOMMgr2 Interface
IMcadBOMMgr2 Members
IMcadBOMMgr2::CurrentBOM Property
IMcadBOMMgr2::AddBorderBOMTable Method
IMcadBOMMgr2::AddPartGrfDef Method
IMcadBOMMgr2::ExportBOM2 Method
IMcadBOMMgr2::ExportPartList Method
IMcadBOMMgr2::GetBOMTableByCompDefId Method
IMcadBOMMgr2::GetBOMTableByCompDefId32 Method
IMcadBOMMgr2::GetBOMTableByName Method
IMcadBOMMgr2::GetBorderBOMTable Method
IMcadBOMMgr2::GetEvaluatedPartData Method
IMcadBOMMgr2::GetPartAttribute Method
IMcadBOMMgr2::GetSheetBOMTable Method
IMcadBOMMgr2::ImportBOM2 Method
IMcadBOMMgr2::ImportPartList Method
IMcadBOMMgr2::RemovePartGrfDef Method
IMcadBOMMgr2::SetPartAttribute Method
IMcadBOMMgr3 Interface
IMcadBOMMgr3 Members
IMcadBOMMgr3::GetBOMTableByCompDefHandle Method
IMcadBOMMgr4 Interface
IMcadBOMMgr4 Members
IMcadBOMMgr4::GetAllPartReferences Method
IMcadBOMs Interface
IMcadBOMs Members
IMcadBOMs::Application Property
IMcadBOMs::Count Property
IMcadBOMs::Add Method
IMcadBOMs::Item Method
IMcadBOMs::Remove Method
IMcadBOMStandard Interface
IMcadBOMStandard Members
IMcadBOMStandard::BalloonStandard Property
IMcadBOMStandard::ColumnCount Property
IMcadBOMStandard::Columns Property
IMcadBOMStandard::PartListStandard Property
IMcadBOMStandard::AddColumn Method
IMcadBOMStandard::GetColumn Method
IMcadBOMStandard::MoveColumn Method
IMcadBOMStandard::RemoveColumn Method
IMcadBOMStandard2 Interface
IMcadBOMStandard2 Members
IMcadBOMStandard2::GetUOMName Method
IMcadBorder Interface
IMcadBorder Members
IMcadBorder::Attributes Property
IMcadBorder::Extends Property
IMcadBorder::Name Property
IMcadBorder::Position Property
IMcadBorder::SetToDefaultAttributes Method
IMcadColumnDefinition Interface
IMcadColumnDefinition Members
IMcadColumnDefinition::Application Property
IMcadColumnDefinition::Caption Property
IMcadColumnDefinition::CaptionAlignment Property
IMcadColumnDefinition::ColumnType Property
IMcadColumnDefinition::DataAlignment Property
IMcadColumnDefinition::DataType Property
IMcadColumnDefinition::Equivalents Property
IMcadColumnDefinition::Index Property
IMcadColumnDefinition::Name Property
IMcadColumnDefinition::Precision Property
IMcadColumnDefinition::Size Property
IMcadColumnDefinition::Width Property
IMcadColumnDefinition2 Interface
IMcadColumnDefinition2 Members
IMcadColumnDefinition2::IsVisible Property
IMcadColumnDefinition3 Interface
IMcadColumnDefinition3 Members
IMcadColumnDefinition3::BOMCaptionAlignment Property
IMcadColumnDefinition3::BOMDataAlignment Property
IMcadColumnDefinition3::IsPreDefinedList Property
IMcadColumnDefinition3::PartListCaptionAlignment Property
IMcadColumnDefinition3::PartListDataAlignment Property
IMcadColumnDefinition3::GetPreDefinedList Method
IMcadColumnDefinition3::RemovePreDefinedList Method
IMcadColumnDefinition3::SetPreDefinedList Method
IMcadColumnDefinitions Interface
IMcadColumnDefinitions Members
IMcadColumnDefinitions::Application Property
IMcadColumnDefinitions::Count Property
IMcadColumnDefinitions::Add Method
IMcadColumnDefinitions::Item Method
IMcadColumnDefinitions::Remove Method
IMcadDatumIdentifier Interface
IMcadDatumStandard Interface
IMcadDatumStandard Members
IMcadDatumStandard::BorderLineType Property
IMcadDatumStandard::BorderLineTypeName Property
IMcadDatumStandard::DrawLeaderArrow Property
IMcadDatumStandard::HatchAngle Property
IMcadDatumStandard::HatchDistance Property
IMcadDatumStandard::HiddenLeaderLineType Property
IMcadDatumStandard::HiddenLeaderLineTypeName Property
IMcadDatumStandard::PointColor Property
IMcadDatumStandard::PointSize Property
IMcadDatumStandard2 Interface
IMcadDatumStandard2 Members
IMcadDatumStandard2::PointTrueColor Property
IMcadDatumTarget Interface
IMcadDatumTarget Members
IMcadDatumTarget::CircleRadius Property
IMcadDatumTarget::DatumValue Property
IMcadDatumTarget::DimensionValue Property
IMcadDatumTarget::DrawLine Property
IMcadDatumTarget::DrawPoint Property
IMcadDatumTarget::LeaderLinetypeHidden Property
IMcadDatumTarget::LineEndPoint Property
IMcadDatumTarget::LineFactor Property
IMcadDatumTarget::LineMidPoint Property
IMcadDatumTarget::RectangleAngle Property
IMcadDatumTarget::RectangleXSize Property
IMcadDatumTarget::RectangleYSize Property
IMcadDatumTarget::TargetOrigin Property
IMcadDatumTarget::TargetType Property
IMcadDatumTarget2 Interface
IMcadDatumTarget2 Members
IMcadDatumTarget2::RectangleCornerPoint Property
IMcadDatumTarget2::SetTargetAttach Method
IMcadDetailSymbol Interface
IMcadDetailSymbol Members
IMcadDetailSymbol::AnnotationOffset Property
IMcadDetailSymbol::BaseViewScale Property
IMcadDetailSymbol::CorrectionScaleFactor Property
IMcadDetailSymbol::DetailScale Property
IMcadDetailSymbol::IsAssociativeDetail Property
IMcadDetailSymbol::LabelEntity Property
IMcadDetailSymbol::LabelEntityOffset Property
IMcadDetailSymbol::LabelName Property
IMcadDetailSymbol::LabelPattern Property
IMcadDetailSymbol::LabelText Property
IMcadDetailSymbol::Radius Property
IMcadDetailSymbol::ShowAnnotationLeader Property
IMcadDetailSymbol::ShowBorder Property
IMcadDetailSymbol::ShowLeader Property
IMcadDetailSymbol::SpecByAbsoluteScale Property
IMcadDetailSymbol::CreateLabelEntity Method
IMcadDetailSymbol::SetSourceGeometry Method
IMcadDetailSymbolLabel Interface
IMcadDetailSymbolLabel Members
IMcadDetailSymbolLabel::AnnotationOffset Property
IMcadDetailSymbolLabel::LabelAbove Property
IMcadDetailSymbolLabel::LabelText Property
IMcadDetailSymbolLabel::SymbolEntity Property
IMcadDetailSymbolStandard Interface
IMcadDetailSymbolStandard Members
IMcadDetailSymbolStandard::AllowedScales Property
IMcadDetailSymbolStandard::BorderLineType Property
IMcadDetailSymbolStandard::LabelAbove Property
IMcadDetailSymbolStandard::LabelPattern Property
IMcadDetailSymbolStandard::ShowAnnotationLeader Property
IMcadDetailSymbolStandard::ShowBorder Property
IMcadDetailSymbolStandard::ShowLeader Property
IMcadDetailSymbolStandard::AddAllowedScale Method
IMcadDetailSymbolStandard::EraseAllowedScales Method
IMcadDetailSymbolStandard2 Interface MG2013New
IMcadDetailSymbolStandard2 Members
IMcadDetailSymbolStandard2::BorderLineColor Property MG2013New
IMcadDetailSymbolStandard2::BorderLineLineType Property MG2013New
IMcadDetailSymbolStandard2::BorderLineWeight Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineColor Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineType Property MG2013New
IMcadDetailSymbolStandard2::BoundaryLineWeight Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineColor Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineType Property MG2013New
IMcadDetailSymbolStandard2::ConnectionLineWeight Property MG2013New
IMcadDetailSymbolStandard2::IdentifierOutsideBoundary Property MG2013New
IMcadDetailSymbolStandard2::LabelOffset Property MG2013New
IMcadDetailSymbolStandard2::LabelTextColor Property MG2013New
IMcadDetailSymbolStandard2::LabelTextHeight Property MG2013New
IMcadDetailSymbolStandard2::LabelTextStyle Property MG2013New
IMcadDetailSymbolStandard2::ShowLabel Property MG2013New
IMcadDetailSymbolStandard2::GetByStandard Method MG2013New
IMcadDetailSymbolStandard2::SetByStandard Method MG2013New
IMcadDocument Interface
IMcadDocument Members
IMcadDocument::Application Property
IMcadDocument::LayerGroupMgr Property
IMcadDocument::LayerObjectMgr Property
IMcadDocument::StructureMgr2D Property
IMcadDocument::Utility Property
IMcadEdge Interface
IMcadEdge Members
IMcadEdge::AllAround Property
IMcadEdge::Direction Property
IMcadEdge::Majority Property
IMcadEdge::MaxValue Property
IMcadEdge::MinValue Property
IMcadEdge::NewSymbolRev Property
IMcadEdge::SignValue Property
IMcadEdge::StandardNumber Property
IMcadEdge::UndefsizeDirection Property
IMcadEdgeLibrary Interface
IMcadEdgeLibraryObject Interface
IMcadEdgeLibraryObject Members
IMcadEdgeLibraryObject::IsAllAround Property
IMcadEdgeLibraryObject::IsDefinedDirection Property
IMcadEdgeLibraryObject::IsMajority Property
IMcadEdgeLibraryObject::StandardNumber Property
IMcadEdgeLibraryObject::UndefsizeDirection Property
IMcadEdgeLibraryObject::RequirementValue Method
IMcadEdgeStandard Interface
IMcadEdgeStandard Members
IMcadEdgeStandard::AllAroundAllowed Property
IMcadEdgeStandard::FullList Property
IMcadEdgeStandard::MajorityAllowed Property
IMcadEdgeStandard::StandardNumAllowed Property
IMcadFCFLibrary Interface
IMcadFCFLibraryObject Interface
IMcadFCFLibraryObject Members
IMcadFCFLibraryObject::IsAllAround Property
IMcadFCFLibraryObject::Symbol Property
IMcadFCFLibraryObject::Symbol2 Property
IMcadFCFLibraryObject::Symbol3 Property
IMcadFCFLibraryObject::RequirementValue Method
IMcadFCFStandard Interface
IMcadFCFStandard Members
IMcadFCFStandard::AvailableAuxiliarySymbols Property
IMcadFCFStandard::AvailableGDTSymbols Property
IMcadFCFStandard::EndPadding Property
IMcadFCFStandard::FrameGap Property
IMcadFCFStandard::GDTTextFont Property
IMcadFCFStandard::GDTTextStyle Property
IMcadFCFStandard::GDTTextStyleName Property
IMcadFCFStandard::MergeDatum Property
IMcadFCFStandard::MergeSymbol Property
IMcadFCFStandard::MergeTolerance Property
IMcadFCFStandard::OfferedAuxiliarySymbols Property
IMcadFCFStandard::OfferedGDTSymbols Property
IMcadFCFStandard::SeparateDatumID Property
IMcadFCFStandard::SeparateProjected Property
IMcadFCFStandard::GetSymbolImplementation Method
IMcadFeatureControlFrame Interface
IMcadFeatureControlFrame Members
IMcadFeatureControlFrame::DatumIDValue Property
IMcadFeatureControlFrame::DatumPrimary2Value Property
IMcadFeatureControlFrame::DatumPrimary3Value Property
IMcadFeatureControlFrame::DatumPrimaryValue Property
IMcadFeatureControlFrame::DatumSecondary2Value Property
IMcadFeatureControlFrame::DatumSecondary3Value Property
IMcadFeatureControlFrame::DatumSecondaryValue Property
IMcadFeatureControlFrame::DatumTertiary2Value Property
IMcadFeatureControlFrame::DatumTertiary3Value Property
IMcadFeatureControlFrame::DatumTertiaryValue Property
IMcadFeatureControlFrame::IsAllAround Property
IMcadFeatureControlFrame::ProjectedValue Property
IMcadFeatureControlFrame::Symbol Property
IMcadFeatureControlFrame::Symbol2 Property
IMcadFeatureControlFrame::Symbol3 Property
IMcadFeatureControlFrame::Tolerance2Value Property
IMcadFeatureControlFrame::Tolerance3Value Property
IMcadFeatureControlFrame::ToleranceB2Value Property
IMcadFeatureControlFrame::ToleranceBValue Property
IMcadFeatureControlFrame::ToleranceValue Property
IMcadFeatureControlFrame2 Interface
IMcadFeatureControlFrame2 Members
IMcadFeatureControlFrame2::BottomNoteValue Property
IMcadFeatureControlFrame2::TopNoteValue Property
IMcadFeatureIdentifier Interface
IMcadIdentifier Interface
IMcadIdentifier Members
IMcadIdentifier::Value Property
IMcadIdentifierStandard Interface
IMcadIdentifierStandard Members
IMcadIdentifierStandard::DefaultArrowType Property
IMcadIdentifierStandard::IsDatumIDSupported Property
IMcadIdentifierStandard::IsFeatureIDSupported Property
IMcadJoint Interface
IMcadJoint Members
IMcadJoint::AllAround Property
IMcadJoint::Annotation Property
IMcadJoint::Orientation Property
IMcadJoint::SecAnnotation Property
IMcadJoint::SymbolType Property
IMcadJointStandard Interface
IMcadMarkStamp Interface
IMcadMarkStamp Members
IMcadMarkStamp::ContentValue Property
IMcadMarkStamp::MethodValue Property
IMcadMarkStamp::SymbolType Property
IMcadMarkStamp::TechnicalReqValue Property
IMcadMarkStampStandard Interface
IMcadMarkStampStandard Members
IMcadMarkStampStandard::AvailableMarkingContents Property
IMcadMarkStampStandard::AvailableMarkingMethods Property
IMcadMarkStampStandard::AvailableStampingContents Property
IMcadMarkStampStandard::AvailableStampingMethods Property
IMcadMarkStampStandard::OfferedMarkingContents Property
IMcadMarkStampStandard::OfferedMarkingMethods Property
IMcadMarkStampStandard::OfferedStampingContents Property
IMcadMarkStampStandard::OfferedStampingMethods Property
IMcadNote Interface
IMcadNote Members
IMcadNote::EvaluatedNoteText Property
IMcadNote::IsLeftOriented Property
IMcadNote::Landing Property
IMcadNote::LeaderAttachPoint Property
IMcadNote::NoteText Property
IMcadNote::TextAlignment Property
IMcadNote::AdjustLanding Method
IMcadNote::CreateNoteText Method
IMcadNoteStandard Interface
IMcadNoteStandard Members
IMcadNoteStandard::Landing Property
IMcadNoteStandard::LeaderAttachPoint Property
IMcadNoteStandard::AddTemplate Method
IMcadNoteStandard::ChangeTemplateValue Method
IMcadNoteStandard::DeleteAllTemplates Method
IMcadNoteStandard::DeleteTemplate Method
IMcadNoteStandard::GetAllTemplates Method
IMcadNoteStandard::GetFeatureTypes Method
IMcadNoteStandard::GetTemplateGroup Method
IMcadNoteStandard::GetTemplateValue Method
IMcadNoteStandard::NumberOfTemplateGroups Method
IMcadNoteStandard::RenameTemplate Method
IMcadNoteStandard::SetCompatibilityCondition Method
IMcadNoteStandard::SetToDefaultTemplate Method
IMcadPartList Interface
IMcadPartList Members
IMcadPartList::AttachmentPoint Property
IMcadPartList::BOM Property
IMcadPartList::CustomBlockName Property
IMcadPartList::CustomBlocks Property
IMcadPartList::FilterEmptyBlocks Property
IMcadPartList::Filters Property
IMcadPartList::Height Property
IMcadPartList::IsCustomBlockUsed Property
IMcadPartList::IsHeadingEnabled Property
IMcadPartList::IsTitleEnabled Property
IMcadPartList::ItemList Property
IMcadPartList::MappingName Property
IMcadPartList::MultipleRow Property
IMcadPartList::Title Property
IMcadPartList::ViewID Property
IMcadPartList::ViewID32 Property
IMcadPartList::Width Property
IMcadPartList::WrapText Property
IMcadPartList::AddFilter Method
IMcadPartList::RemoveFilter Method
IMcadPartList2 Interface
IMcadPartList2 Members
IMcadPartList2::ColumnSplitEnabled Property
IMcadPartList2::ColumnSplitRows Property
IMcadPartList2::ColumnSplitSections Property
IMcadPartList2::ColumnSplitStyle Property
IMcadPartList2::ColumnSplitWrap Property
IMcadPartList2::FormulaBarEnabled Property
IMcadPartList2::GripFrameEnabled Property
IMcadPartList2::HeadingTextControl Property
IMcadPartList2::ResultBarEnabled Property
IMcadPartList2::RowTextControl Property
IMcadPartList2::AddFilterType Method
IMcadPartList3 Interface
IMcadPartList3 Members
IMcadPartList3::WrapAroundTitle Property
IMcadPartList3::WrapTitleBlockId Property
IMcadPartList3::WrapTitleBlockId32 Property
IMcadPartList3::setWrapPListAttachPoint Method
IMcadPartListBalloonedFilter Interface
IMcadPartListCustomFilter Interface
IMcadPartListCustomFilter Members
IMcadPartListCustomFilter::Operator Property
IMcadPartListCustomFilter::PropertyName Property
IMcadPartListCustomFilter::PropertyValue Property
IMcadPartListCustomFilter::SetCondition Method
IMcadPartListFilter Interface
IMcadPartListFilter Members
IMcadPartListFilter::IsOn Property
IMcadPartListFilter::Name Property
IMcadPartListFilter::Evaluate Method
IMcadPartListFilter2 Interface
IMcadPartListFilter2 Members
IMcadPartListFilter2::Excluded Property
IMcadPartListFilter2::Type Property
IMcadPartListFilters Interface
IMcadPartListFilters Members
IMcadPartListFilters::Application Property
IMcadPartListFilters::Count Property
IMcadPartListFilters::Add Method
IMcadPartListFilters::Item Method
IMcadPartListFilters::Remove Method
IMcadPartListGOST Interface
IMcadPartListGOST Members
IMcadPartListGOST::SkipAfterPart Property
IMcadPartListGOST::SkipLines Property
IMcadPartLists Interface
IMcadPartLists Members
IMcadPartLists::Application Property
IMcadPartLists::Count Property
IMcadPartLists::Add Method
IMcadPartLists::Item Method
IMcadPartLists::Remove Method
IMcadPartListStandard Interface
IMcadPartListStandard Members
IMcadPartListStandard::ActualRowTextHeight Property
IMcadPartListStandard::Application Property
IMcadPartListStandard::AttachmentPoint Property
IMcadPartListStandard::BOMStandard Property
IMcadPartListStandard::ColumnList Property
IMcadPartListStandard::CustomBlockName Property
IMcadPartListStandard::CustomBlocks Property
IMcadPartListStandard::FilterEmptyBlocks Property
IMcadPartListStandard::FrameColor Property
IMcadPartListStandard::HeadingGap Property
IMcadPartListStandard::HeadingHeight Property
IMcadPartListStandard::HeadingTextColor Property
IMcadPartListStandard::HeadingTextHeight Property
IMcadPartListStandard::IsCustomBlockUsed Property
IMcadPartListStandard::IsHeadingEnabled Property
IMcadPartListStandard::IsTitleEnabled Property
IMcadPartListStandard::MulipleRow Property
IMcadPartListStandard::Revision Property
IMcadPartListStandard::RevisionYear Property
IMcadPartListStandard::RowGap Property
IMcadPartListStandard::RowHeight Property
IMcadPartListStandard::UseMapping Property
IMcadPartListStandard::WrapText Property
IMcadPartListStandard::RemoveColumn Method
IMcadPartListStandard::SetToDefaults Method
IMcadPartListStandard2 Interface
IMcadPartListStandard2 Members
IMcadPartListStandard2::FrameTrueColor Property
IMcadPartListStandard2::HeadingTextTrueColor Property
IMcadPartListStandard3 Interface
IMcadPartListStandard3 Members
IMcadPartListStandard3::BoldVerticalLine Property
IMcadPartListStandard3::ColumnSplitEnabled Property
IMcadPartListStandard3::ColumnSplitRows Property
IMcadPartListStandard3::ColumnSplitSections Property
IMcadPartListStandard3::ColumnSplitStyle Property
IMcadPartListStandard3::ColumnSplitWrap Property
IMcadPartListStandard3::GripFrameEnabled Property
IMcadPartListStandard3::HeadingTextControl Property
IMcadPartListStandard3::HeadingTextMarginBottom Property
IMcadPartListStandard3::HeadingTextMarginLeft Property
IMcadPartListStandard3::HeadingTextMarginRight Property
IMcadPartListStandard3::HeadingTextMarginTop Property
IMcadPartListStandard3::HeadingTextStyle Property
IMcadPartListStandard3::RowTextColor Property
IMcadPartListStandard3::RowTextControl Property
IMcadPartListStandard3::RowTextHeight Property
IMcadPartListStandard3::RowTextMarginBottom Property
IMcadPartListStandard3::RowTextMarginLeft Property
IMcadPartListStandard3::RowTextMarginRight Property
IMcadPartListStandard3::RowTextMarginTop Property
IMcadPartListStandard3::RowTextStyle Property
IMcadPartListStandard3::RowTextTrueColor Property
IMcadPartListStandard4 Interface
IMcadPartListStandard4 Members
IMcadPartListStandard4::ColumnSplitWrapAroundTitle Property
IMcadPartListStdPartsFilter Interface
IMcadPartListStdPartsFilter Members
IMcadPartListStdPartsFilter::Option Property
IMcadPartReference Interface
IMcadPartReference Members
IMcadPartReference::Data Property
IMcadPartReference::Quantity Property
IMcadPartReference2 Interface
IMcadPartReference2 Members
IMcadPartReference2::SetAttributePreDefinedListValue Method
IMcadPartReference3 Interface
IMcadPartReference3 Members
IMcadPartReference3::AttachedExternalBom Property
IMcadPartReference3::AttachedExternalBomXrefBlock Property
IMcadPartReference3::AttachExternalBom Method
IMcadPartReference3::DetachExternalBom Method
IMcadPartReference3::GetBomOverride Method
IMcadPartReference3::RemoveAttribute Method
IMcadRevisionList Interface
IMcadRevisionList Members
IMcadRevisionList::Border Property
IMcadRevisionList::Border32 Property
IMcadRevisionList::Count Property
IMcadRevisionList::Position Property
IMcadRevisionList::Ref Property
IMcadRevisionList::Ref32 Property
IMcadRevisionList::Add Method
IMcadRevisionList::Item Method
IMcadRevisionList::Set Method
IMcadRevisionListDescriptor Interface
IMcadRevisionListDescriptor Members
IMcadRevisionListDescriptor::Attributes Property
IMcadRevisionListDescriptor::Border Property
IMcadRevisionListDescriptor::Border32 Property
IMcadRevisionListDescriptor::Position Property
IMcadRevisionLists Interface
IMcadRevisionLists Members
IMcadRevisionLists::Application Property
IMcadRevisionLists::Count Property
IMcadRevisionLists::Item Method
IMcadRevisionMgr Interface
IMcadRevisionMgr Members
IMcadRevisionMgr::RevisionLists Property
IMcadRevisionMgr::CreateRevisionList Method
IMcadRevisionMgr::DeleteRevisionList Method
IMcadRevisionMgr::GetRevisionListFromRef Method
IMcadRevisionMgr::NewDescriptor Method
IMcadScaleArea Interface
IMcadScaleArea Members
IMcadScaleArea::AttachObjectId Property
IMcadScaleArea::AttachObjectId32 Property
IMcadScaleArea::LengthScalingFactor Property
IMcadScaleArea::ScaleType Property
IMcadScaleArea::TextScalingFactor Property
IMcadScaleArea::CreateViewPort Method
IMcadScaleArea::DeleteViewPort Method
IMcadScaleArea::GetAttachedViewportIds Method
IMcadScaleArea::GetAttachedViewportIds32 Method
IMcadScaleArea::MoveBorder Method
IMcadScaleArea::RescaleObjects Method
IMcadScaleArea::SetBasicScale Method
IMcadScaleAreaMgr Interface
IMcadScaleAreaMgr Members
IMcadScaleAreaMgr::CreateScaleArea Method
IMcadScaleAreaMgr::DeleteScaleArea Method
IMcadScaleAreaMgr::FindScaleArea Method
IMcadSectionLine Interface
IMcadSectionLine Members
IMcadSectionLine::ArrowVisibility Property
IMcadSectionLine::LabelNamesCount Property
IMcadSectionLine::LabelPattern Property
IMcadSectionLine::LabelText Property
IMcadSectionLine::LabelVisibility Property
IMcadSectionLine::LineVisibility Property
IMcadSectionLine::PlaneSymbolsVisibility Property
IMcadSectionLine::SectionPoints Property
IMcadSectionLine::SectionSide Property
IMcadSectionLine::AddSectionPoint Method
IMcadSectionLine::LabelName Method
IMcadSectionLine::SetLabelNames Method
IMcadSectionLine::SetSectionArcPointAt Method
IMcadSectionLine::SetSectionPointAt Method
IMcadSectionLine::SetSectionPoints Method
IMcadSectionLine::SetSectionViewOrigin Method
IMcadSectionLineStandard Interface
IMcadSectionLineStandard Members
IMcadSectionLineStandard::ArrowTowardsLine Property
IMcadSectionLineStandard::ArrowVisibility Property
IMcadSectionLineStandard::LabelAbove Property
IMcadSectionLineStandard::LabelPattern Property
IMcadSectionLineStandard::LabelVisibility Property
IMcadSectionLineStandard::LineColor Property
IMcadSectionLineStandard::LineTrueColor Property
IMcadSectionLineStandard::LineVisibility Property
IMcadSectionLineStandard::LineWeight Property
IMcadSectionLineStandard::MultipleNamesSupported Property
IMcadSectionLineStandard::PlaneSymbolsVisibility Property
IMcadSectionLineStandard2 Interface MG2013New
IMcadSectionLineStandard2 Members
IMcadSectionLineStandard2::ArrowLineLength Property MG2013New
IMcadSectionLineStandard2::BendLineLength Property MG2013New
IMcadSectionLineStandard2::EndArrowType Property MG2013New
IMcadSectionLineStandard2::EndBendLineType Property MG2013New
IMcadSectionLineStandard2::EndLineLength Property MG2013New
IMcadSectionLineStandard2::EndLineOvershoot Property MG2013New
IMcadSectionLineStandard2::IdentifierExcludeCharacters Property MG2013New
IMcadSectionLineStandard2::IdentifierOffset Property MG2013New
IMcadSectionLineStandard2::IdentifierPosition Property MG2013New
IMcadSectionLineStandard2::LabelOffset Property MG2013New
IMcadSectionLineStandard2::LabelTextColor Property MG2013New
IMcadSectionLineStandard2::LabelTextHeight Property MG2013New
IMcadSectionLineStandard2::LabelTextStyle Property MG2013New
IMcadSectionLineStandard2::PlaneLineColor Property MG2013New
IMcadSectionLineStandard2::PlaneLineType Property MG2013New
IMcadSectionLineStandard2::PlaneLineWeight Property MG2013New
IMcadSectionLineStandard2::GetByStandard Method MG2013New
IMcadSectionLineStandard2::SetByStandard Method MG2013New
IMcadStandard Interface
IMcadStandard Members
IMcadStandard::AllSymbolStandards Property
IMcadStandard::ArrowScale Property
IMcadStandard::ArrowType Property
IMcadStandard::BaseName Property
IMcadStandard::BOMStandard Property
IMcadStandard::Current Property
IMcadStandard::CurrentSymbolStandards Property
IMcadStandard::DatumStandard Property
IMcadStandard::FCFStandard Property
IMcadStandard::IdentifierStandard Property
IMcadStandard::IsMetric Property
IMcadStandard::LeaderColor Property
IMcadStandard::Name Property
IMcadStandard::Scale Property
IMcadStandard::StandardMgr Property
IMcadStandard::SurfaceTextureStandard Property
IMcadStandard::SymbolColor Property
IMcadStandard::SymbolStandardsSupported Property
IMcadStandard::TextColor Property
IMcadStandard::TextHeight Property
IMcadStandard::TextHeightList Property
IMcadStandard::TextStyle Property
IMcadStandard::TextStyleName Property
IMcadStandard::WeldingStandard Property
IMcadStandard::AddSymbolStandard Method
IMcadStandard::GetCurrentSymbolStandard Method
IMcadStandard::RemoveSymbolStandard Method
IMcadStandard::SetCurrentSymbolStandard Method
IMcadStandard::SetToDefaults Method
IMcadStandard2 Interface
IMcadStandard2 Members
IMcadStandard2::LeaderTrueColor Property
IMcadStandard2::SymbolTrueColor Property
IMcadStandard2::TextTrueColor Property
IMcadStandard3 Interface
IMcadStandard3 Members
IMcadStandard3::AnnotationViewStandard Property
IMcadStandard3::DetailSymbolStandard Property
IMcadStandard3::EdgeStandard Property
IMcadStandard3::MarkStampStandard Property
IMcadStandard3::NoteStandard Property
IMcadStandard3::TaperStandard Property
IMcadStandard3::TitleBorderStandard Property
IMcadStandard4 Interface
IMcadStandard4 Members
IMcadStandard4::JointStandard Property
IMcadStandard4::SectionLineStandard Property
IMcadStandard4::SupportedArrowTypes Method
IMcadStandardMgr Interface
IMcadStandardMgr Members
IMcadStandardMgr::Application Property
IMcadStandardMgr::CurrentStandard Property
IMcadStandardMgr::CurrentStandardName Property
IMcadStandardMgr::DefaultStandard Property
IMcadStandardMgr::StandardCount Property
IMcadStandardMgr::StandardNames Property
IMcadStandardMgr::Standards Property
IMcadStandardMgr::SymbolBBMgr Property
IMcadStandardMgr::AddStandard Method
IMcadStandardMgr::CopyStandard Method
IMcadStandardMgr::GetStandard Method
IMcadStandardMgr::RemoveStandard Method
IMcadStandardMgr::UpdateSymbols Method
IMcadStandards Interface
IMcadStandards Members
IMcadStandards::Application Property
IMcadStandards::Count Property
IMcadStandards::Add Method
IMcadStandards::Item Method
IMcadStandards::Remove Method
IMcadSurfaceTexture Interface
IMcadSurfaceTexture Members
IMcadSurfaceTexture::AllowanceValue Property
IMcadSurfaceTexture::Angle Property
IMcadSurfaceTexture::AutomaticAdjust Property
IMcadSurfaceTexture::CommentValue Property
IMcadSurfaceTexture::CutoffValue Property
IMcadSurfaceTexture::IsAllAround Property
IMcadSurfaceTexture::IsForceTail Property
IMcadSurfaceTexture::IsMajority Property
IMcadSurfaceTexture::LayDirection Property
IMcadSurfaceTexture::LayDirectionValue Property
IMcadSurfaceTexture::MaximumSpacingValue Property
IMcadSurfaceTexture::OtherMinimumValue Property
IMcadSurfaceTexture::OtherValue Property
IMcadSurfaceTexture::Production2Value Property
IMcadSurfaceTexture::ProductionValue Property
IMcadSurfaceTexture::RaMaximumValue Property
IMcadSurfaceTexture::RaMinimumValue Property
IMcadSurfaceTexture::ReferenceValue Property
IMcadSurfaceTexture::SamplingLengthValue Property
IMcadSurfaceTexture::SurfaceTexture Property
IMcadSurfaceTexture::WavinessValue Property
IMcadSurfaceTexture2 Interface
IMcadSurfaceTexture2 Members
IMcadSurfaceTexture2::FirstRequirement Property
IMcadSurfaceTexture2::FourthRequirement Property
IMcadSurfaceTexture2::SecondRequirement Property
IMcadSurfaceTexture2::ThirdRequirement Property
IMcadSurfaceTexture4 Interface
IMcadSurfaceTexture4 Members
IMcadSurfaceTexture4::AddSurfIndLeader Method
IMcadSurfaceTextureLibrary Interface
IMcadSurfaceTextureLibraryObject Interface
IMcadSurfaceTextureLibraryObject Members
IMcadSurfaceTextureLibraryObject::IsAllAround Property
IMcadSurfaceTextureLibraryObject::IsForceTail Property
IMcadSurfaceTextureLibraryObject::IsMajority Property
IMcadSurfaceTextureLibraryObject::SubSymbolType Property
IMcadSurfaceTextureLibraryObject::RequirementValue Method
IMcadSurfaceTextureStandard Interface
IMcadSurfaceTextureStandard Members
IMcadSurfaceTextureStandard::AllAroundAllowed Property
IMcadSurfaceTextureStandard::AvailableLaySymbols Property
IMcadSurfaceTextureStandard::FitCircle Property
IMcadSurfaceTextureStandard::ForceTail Property
IMcadSurfaceTextureStandard::FullList Property
IMcadSurfaceTextureStandard::MajorityAllowed Property
IMcadSurfaceTextureStandard::Multiline Property
IMcadSurfaceTextureStandard::OfferedLaySymbols Property
IMcadSurfaceTextureStandard2 Interface
IMcadSurfaceTextureStandard2 Members
IMcadSurfaceTextureStandard2::IsRequirementSupported Method
IMcadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults Method
IMcadSurfaceTextureStandard2::SetSuggestedListToDefaults Method
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [in] VARIANT)
IMcadSurfaceTextureStandard2::SuggestedList Method ([in] McadSurfaceTextureRequirement, [out, retval] VARIANT*)
IMcadSurfaceTextureStandard3 Interface
IMcadSurfaceTextureStandard3 Members
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowScale Property
IMcadSurfaceTextureStandard3::SurfIndLeaderArrowType Property
IMcadSymbol Interface
IMcadSymbol Members
IMcadSymbol::CoordinateSystem Property
IMcadSymbol::IsAttached Property
IMcadSymbol::LeaderCount Property
IMcadSymbol::Origin Property
IMcadSymbol::Scale Property
IMcadSymbol::Standard Property
IMcadSymbol::SymbolStandard Property
IMcadSymbol::AddLeader Method
IMcadSymbol::AttachGeometry Method
IMcadSymbol::DetachGeometry Method
IMcadSymbol::GetLeader Method
IMcadSymbol::GetLeaderAttachment Method
IMcadSymbol::InsertLeaderNode Method
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [in] McadArrowType)
IMcadSymbol::LeaderArrowType Method ([in, optional] VARIANT, [out, retval] McadArrowType*)
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [in] ACAD_COLOR)
IMcadSymbol::LeaderColor Method ([in, optional] VARIANT, [out, retval] ACAD_COLOR*)
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [in] VARIANT)
IMcadSymbol::LeaderLanding Method ([in, optional] VARIANT, [out, retval] VARIANT*)
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [in] IAcadLineType*)
IMcadSymbol::LeaderLineType Method ([in, optional] VARIANT, [out, retval] IAcadLineType**)
IMcadSymbol::MoveLeaderNode Method
IMcadSymbol::RemoveLeader Method
IMcadSymbol::RemoveLeaderNode Method
IMcadSymbol::SetToDefaults Method
IMcadSymbol2 Interface
IMcadSymbol2 Members
IMcadSymbol2::UpdateToAttachedObject Method
IMcadSymbolBBMgr Interface
IMcadSymbolBBMgr Members
IMcadSymbolBBMgr::Application Property
IMcadSymbolBBMgr::BOMMgr Method
IMcadSymbolBBMgr::StandardMgr Method
IMcadSymbolBBMgr2 Interface
IMcadSymbolBBMgr2 Members
IMcadSymbolBBMgr2::ScaleAreaMgr Method
IMcadSymbolBBMgr2::TitleBorderMgr Method
IMcadSymbolBBMgr3 Interface
IMcadSymbolBBMgr3 Members
IMcadSymbolBBMgr3::RevisionListMgr Method
IMcadSymbolBBMgr3::SymbolLibrary Method
IMcadSymbolLibrary Interface
IMcadSymbolLibrary Members
IMcadSymbolLibrary::appendItem Method
IMcadSymbolLibrary::DefaultItem Method
IMcadSymbolLibrary::findItem Method
IMcadSymbolLibrary::findList Method
IMcadSymbolLibrary::isItemExist Method
IMcadSymbolLibrary::loadItem Method
IMcadSymbolLibrary::modifyItem Method
IMcadSymbolLibrary::removeItem Method
IMcadSymbolLibrary::renameItem Method
IMcadSymbolLibrary::setIsDefaultItem Method
IMcadSymbolLibraryObject Interface
IMcadSymbolLibraryObject Members
IMcadSymbolLibraryObject::entryName Property
IMcadSymbolLibraryObject::isDefault Property
IMcadSymbolLibraryObject::standardName Property
IMcadSymbolLibraryObject::symbolStandardClassName Property
IMcadSymbolLibraryObjects Interface
IMcadSymbolLibraryObjects Members
IMcadSymbolLibraryObjects::Application Property
IMcadSymbolLibraryObjects::Count Property
IMcadSymbolLibraryObjects::Add Method
IMcadSymbolLibraryObjects::Item Method
IMcadSymbolLibraryObjects::Remove Method
IMcadSymbolStandard Interface
IMcadSymbolStandard Members
IMcadSymbolStandard::Revision Property
IMcadSymbolStandard::RevisionYear Property
IMcadSymbolStandard::Standard Property
IMcadSymbolStandard::SetToDefaults Method
IMcadSymbolStandard2 Interface
IMcadSymbolStandard2 Members
IMcadSymbolStandard2::ArrowScale Property
IMcadSymbolStandard2::ArrowType Property
IMcadSymbolStandard2::LeaderTrueColor Property
IMcadSymbolStandard2::TextHeight Property
IMcadSymbolStandard2::TextTrueColor Property
IMcadSymbolStandard2::SetToDefaultTextLeader Method
IMcadSymbolStandard3 Interface
IMcadSymbolStandard3 Members
IMcadSymbolStandard3::SymbolStandardClassName Property
IMcadSymbolStandard3::SupportedArrowTypes Method
IMcadSymbolStandards Interface
IMcadSymbolStandards Members
IMcadSymbolStandards::Application Property
IMcadSymbolStandards::Count Property
IMcadSymbolStandards::Add Method
IMcadSymbolStandards::Item Method
IMcadSymbolStandards::Remove Method
IMcadTaper Interface
IMcadTaper Members
IMcadTaper::AboveCurve Property
IMcadTaper::DisplayString Property
IMcadTaper::HasLeader Property
IMcadTaper::Inspect Property
IMcadTaper::Orientation Property
IMcadTaper::SubSymbolType Property
IMcadTaper::AdjustReferenceLine Method
IMcadTaperStandard Interface
IMcadTaperStandard Members
IMcadTaperStandard::OfferedSymbols Property
IMcadTaperStandard2 Interface
IMcadTaperStandard2 Members
IMcadTaperStandard2::GetDimensionType Method
IMcadTaperStandard2::SetDimensionType Method
IMcadTitle Interface
IMcadTitle Members
IMcadTitle::Attributes Property
IMcadTitle::InActive Property
IMcadTitle::Name Property
IMcadTitle::Position Property
IMcadTitle::SetToDefaultAttributes Method
IMcadTitle2 Interface
IMcadTitle2 Members
IMcadTitle2::BlockId Property
IMcadTitle2::BlockId32 Property
IMcadTitleBorder Interface
IMcadTitleBorder Members
IMcadTitleBorder::Descriptor Property
IMcadTitleBorder::Ref Property
IMcadTitleBorder::Ref32 Property
IMcadTitleBorder::Modify Method
IMcadTitleBorderContext Interface
IMcadTitleBorderContext Members
IMcadTitleBorderContext::AutomaticPlacement Property
IMcadTitleBorderContext::BaseScale Property
IMcadTitleBorderContext::DwgDefault Property
IMcadTitleBorderContext::MoveObjects Property
IMcadTitleBorderContext::Rescale Property
IMcadTitleBorderContext::RetrieveFromAsmProp Property
IMcadTitleBorderContext::RetrieveFromPartRef Property
IMcadTitleBorderContext::ThawAllLayers Property
IMcadTitleBorderContext::GetMoveObjectsIDs Method
IMcadTitleBorderContext::GetMoveObjectsIDs32 Method
IMcadTitleBorderContext::GetMoveObjectsToPoint Method
IMcadTitleBorderContext::GetPartReference Method
IMcadTitleBorderContext::GetPartReference32 Method
IMcadTitleBorderContext::SetMoveObjects Method
IMcadTitleBorderContext::SetPartReference Method
IMcadTitleBorderDescriptor Interface
IMcadTitleBorderDescriptor Members
IMcadTitleBorderDescriptor::Border Property
IMcadTitleBorderDescriptor::Position Property
IMcadTitleBorderDescriptor::Title Property
IMcadTitleBorderDescriptor::TitleBorderScale Property
IMcadTitleBorderMgr Interface
IMcadTitleBorderMgr Members
IMcadTitleBorderMgr::TitleBorders Property
IMcadTitleBorderMgr::CreateTitleBorder Method
IMcadTitleBorderMgr::DeleteTitleBorder Method
IMcadTitleBorderMgr::GetTitleBorderFromRef Method
IMcadTitleBorderMgr::NewContext Method
IMcadTitleBorderMgr::NewDescriptor Method
IMcadTitleBorders Interface
IMcadTitleBorders Members
IMcadTitleBorders::Application Property
IMcadTitleBorders::Count Property
IMcadTitleBorders::Item Method
IMcadTitleBorderStandard Interface
IMcadTitleBorderStandard Members
IMcadTitleBorderStandard::DefaultPaperFormat Property
IMcadTitleBorderStandard::DefaultRevisionList Property
IMcadTitleBorderStandard::DefaultTitleBlock Property
IMcadTitleBorderStandard::PaperFormats Property
IMcadTitleBorderStandard::RevisionLists Property
IMcadTitleBorderStandard::TitleBlocks Property
IMcadTitleBorderStandard2 Interface
IMcadTitleBorderStandard2 Members
IMcadTitleBorderStandard2::InsertInvertPart Property
IMcadTitleBorderStandard2::InvertPartBorderHeight Property
IMcadTitleBorderStandard2::InvertPartBorderWidth Property
IMcadTitleBorderStandard2::InvertPartTextHeight Property
IMcadTransaction Interface
IMcadTransaction Members
IMcadTransaction::Application Property
IMcadWelding Interface
IMcadWelding Members
IMcadWelding::Orientation Property
IMcadWelding::SubWeldingCount Property
IMcadWelding::AddSubWelding Method
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::AngleValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::AreaType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [in] McadWeldAssociation)
IMcadWelding::AssociationType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldAssociation*)
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::BackingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] VARIANT_BOOL)
IMcadWelding::Brazing Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] VARIANT_BOOL*)
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::BrazingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ClearanceValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding::ClosedTail Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding::ContourType Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ContourValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::ControlCategoryValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::DepthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::DesignationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [in] VARIANT_BOOL)
IMcadWelding::FieldWeld Method ([in, defaultvalue(0)] long, [out, retval] VARIANT_BOOL*)
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::FinishingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::GapValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::HighlightSubWelding Method
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [in] McadIdentificationType)
IMcadWelding::IdentificationLine Method ([in, defaultvalue(0)] long, [out, retval] McadIdentificationType*)
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::IndexTotalValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::IndexValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::LengthValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::NotesValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::NumberValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::PitchValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::RemoveSubWelding Method
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::SecondarySymType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SecondarySymTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::Size2Value Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [in] McadWeldSymbolType)
IMcadWelding::SizeType Method ([in, defaultvalue(0)] long, [out, retval] McadWeldSymbolType*)
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SizeTypeValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::SizeValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::SpacingValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::SpecificationValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::StandardValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [in] BSTR)
IMcadWelding::TechnicalReqValue Method ([in, defaultvalue(0)] long, [out, retval] BSTR*)
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] BSTR)
IMcadWelding::ThicknessValue Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] BSTR*)
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [in] McadWeldSymbolType)
IMcadWelding::Type Method ([in, defaultvalue(TRUE)] VARIANT_BOOL, [in, defaultvalue(0)] long, [in, defaultvalue(TRUE)] VARIANT_BOOL, [out, retval] McadWeldSymbolType*)
IMcadWelding2 Interface
IMcadWelding2 Members
IMcadWelding2::InsertProcess Method
IMcadWeldingLibrary Interface
IMcadWeldingLibrary Members
IMcadWeldingLibrary::appendItemFromSubWelding Method
IMcadWeldingLibrary::loadItemToSubWelding Method
IMcadWeldingLibrary::modifyItemFromSubWelding Method
IMcadWeldingLibraryObject Interface
IMcadWeldingLibraryObject Members
IMcadWeldingLibraryObject::AreaType Property
IMcadWeldingLibraryObject::AssociationType Property
IMcadWeldingLibraryObject::ClosedTail Property
IMcadWeldingLibraryObject::FieldWeld Property
IMcadWeldingLibraryObject::IdentificationLine Property
IMcadWeldingLibraryObject::ArrowSideReqValue Method
IMcadWeldingLibraryObject::OtherSideReqValue Method
IMcadWeldingLibraryObject::RequirementValue Method
IMcadWeldingLibraryObject::setIsDefault Method
IMcadWeldingLibraryObject::Type Method
IMcadWeldingStandard Interface
IMcadWeldingStandard Members
IMcadWeldingStandard::AvailableBackingSymbols Property
IMcadWeldingStandard::AvailableContourSymbols Property
IMcadWeldingStandard::AvailableWeldSymbols Property
IMcadWeldingStandard::ClosedTailAllowed Property
IMcadWeldingStandard::IdentificationLineAllowed Property
IMcadWeldingStandard::IdentificationLineGap Property
IMcadWeldingStandard::IdentificationLinetype Property
IMcadWeldingStandard::IdentificationLinetypeName Property
IMcadWeldingStandard::MultipleSymbolsAllowed Property
IMcadWeldingStandard::OfferedBackingSymbols Property
IMcadWeldingStandard::OfferedContourSymbols Property
IMcadWeldingStandard::OfferedWeldSymbols Property
IMcadWeldingStandard2 Interface
IMcadWeldingStandard2 Members
IMcadWeldingStandard2::WeldProcessPrefix Property
IMcadWeldingStandard3 Interface MG2015New
IMcadWeldingStandard3 Members
IMcadWeldingStandard3::ProcessGap Property
IMcadWeldingStandard3::ScaleFactor Property
IMcadBorder2 Interface
IMcadBorder2 Members
IMcadBorder2::BlockId Property
IMcadBorder2::BlockId32 Property
IMcadDatumIdentifier2 Interface
IMcadDatumIdentifier2 Members
IMcadDatumIdentifier2::SurfExtLinesOffset Property
IMcadDatumIdentifier2::SurfExtLinesOvershot Property
IMcadDatumIdentifier2::AddStdCompliantLeader Method
IMcadDatumIdentifier3 Interface
IMcadDatumIdentifier3 Members
IMcadDatumIdentifier3::DatumNote Property
IMcadDatumIdentifier3::FarSideStatus Property
IMcadDatumIdentifier3::SurfIndLeaderArrowType Property
IMcadDatumIdentifier3::ThreadNote Property
IMcadDatumIdentifier3::AddLeaderWithSurfIndLeader Method
IMcadDatumIdentifier3::GetSurfIndLeader Method
IMcadFCFStandard2 Interface
IMcadFCFStandard2 Members
IMcadFCFStandard2::SurfIndLeaderArrowScale Property
IMcadFCFStandard2::SurfIndLeaderArrowType Property
IMcadFeatureControlFrame3 Interface
IMcadFeatureControlFrame3 Members
IMcadFeatureControlFrame3::SurfExtLinesOffset Property
IMcadFeatureControlFrame3::SurfExtLinesOvershot Property
IMcadFeatureControlFrame3::AddStdCompliantLeader Method
IMcadFeatureControlFrame4 Interface
IMcadFeatureControlFrame4 Members
IMcadFeatureControlFrame4::SurfIndLeaderArrowType Property
IMcadFeatureControlFrame4::AddLeaderWithSurfIndLeader Method
IMcadFeatureControlFrame4::AddSurfIndLeader Method
IMcadFeatureControlFrame4::GetSurfIndLeader Method
IMcadFeatureControlFrame4::RemoveSurfIndLeader Method
IMcadFeatureIdentifier2 Interface
IMcadFeatureIdentifier2 Members
IMcadFeatureIdentifier2::SurfExtLinesOffset Property
IMcadFeatureIdentifier2::SurfExtLinesOvershot Property
IMcadFeatureIdentifier2::AddStdCompliantLeader Method
IMcadIdentifierStandard2 Interface
IMcadIdentifierStandard2 Members
IMcadIdentifierStandard2::FarSideLeaderLineType Property
IMcadIdentifierStandard2::FarSideLeaderLineTypeName Property
IMcadIdentifierStandard2::SurfIndLeaderArrowScale Property
IMcadIdentifierStandard2::SurfIndLeaderArrowType Property
IMcadPartReferences Interface
IMcadPartReferences Members
IMcadPartReferences::_NewEnum Property
IMcadPartReferences::Application Property
IMcadPartReferences::Count Property
IMcadPartReferences::Add Method
IMcadPartReferences::Item Method
IMcadPartReferences::Remove Method
IMcadSurfaceTexture3 Interface
IMcadSurfaceTexture3 Members
IMcadSurfaceTexture3::SurfExtLinesOffset Property
IMcadSurfaceTexture3::SurfExtLinesOvershot Property
McadAlignmentType Enumeration
McadAnnotViewLabelPositionType Enumeration
McadArrowType Enumeration
McadAttachmentPoint Enumeration
McadAttachmentType Enumeration
McadAttachPosition Enumeration
McadAttributeAssociativity Enumeration
McadBalloonType Enumeration
McadBOMExportFormatType Enumeration
McadBOMImportFormatType Enumeration
McadBOMItemDefinitionType Enumeration
McadBomOverrideType Enumeration
McadBOMUOMType Enumeration
McadColumnSplitStyle Enumeration
McadColumnSplitWrap Enumeration
McadColumnType Enumeration
McadDataType Enumeration
McadDetailSymbolStandardPropType Enumeration MG2013New
McadDirectionLayType Enumeration
McadEdgeRequirement Enumeration
McadFCFRequirement Enumeration
McadFilterOperator Enumeration
McadFilterType Enumeration
McadGDTSymbolType Enumeration
McadIdentificationType Enumeration
McadIdentifierPositionType Enumeration MG2013New
McadJointType Enumeration
McadLineVisibility Enumeration
McadNoteAttachPointType Enumeration
McadNoteTemplateGroupType Enumeration
McadOrientation Enumeration
McadScaleType Enumeration
McadSectionLineSegmentType Enumeration
McadSectionLineStandardPropType Enumeration MG2013New
McadStdPartsFilterOption Enumeration
McadSurfaceTextureRequirement Enumeration
McadSurfaceTextureType Enumeration
McadSymBBSymbolLibraryType Enumeration
McadTaperDimensionType Enumeration
McadTaperRatioFormatType Enumeration
McadTaperSlopeSymType Enumeration
McadTargetType Enumeration
McadTextControl Enumeration
McadUndefinedSize Enumeration
McadUndefinedSizeDirection Enumeration
McadViewDefLockType Enumeration
McadWeldAssociation Enumeration
McadWeldingRequirement Enumeration
McadWeldSymbolType Enumeration
McadBalloonCollectionType Enumeration
GEAuto Library
GeApplication CoClass
GeAugmentedLine CoClass
GeBoundBlock CoClass
GeBoundedSurface CoClass
GeCircularArc CoClass
GeCompositeCurve CoClass
GeCone CoClass
GeCurveBoundaries CoClass
GeCurveBoundary CoClass
GeCurveCurveIntersection CoClass
GeCurves CoClass
GeCurveSurfaceIntersection CoClass
GeCylinder CoClass
GeEllipticalArc CoClass
GeEntities CoClass
GeInterval CoClass
GeKnotVector CoClass
GeLine CoClass
GeLineSegment CoClass
GeMatrix CoClass
GeNurbCurve CoClass
GeNurbSurface CoClass
GeOffsetCurve CoClass
GeOffsetSurface CoClass
GePlane CoClass
GePoint CoClass
GePoints CoClass
GeRay CoClass
GeSphere CoClass
GeSurfaces CoClass
GeSurfaceSurfaceIntersection CoClass
GeTolerance CoClass
GeTorus CoClass
GeVector CoClass
GeVectors CoClass
IGeApplication Interface
IGeApplication Members
IGeApplication::Application Property
IGeApplication::AugmentedLine Method
IGeApplication::BoundBlock Method
IGeApplication::CircularArc Method
IGeApplication::Collection Method
IGeApplication::CompositeCurve Method
IGeApplication::Cone Method
IGeApplication::CurveBoundary Method
IGeApplication::Cylinder Method
IGeApplication::EllipticalArc Method
IGeApplication::Interval Method
IGeApplication::KnotVector Method
IGeApplication::Line Method
IGeApplication::LineSegment Method
IGeApplication::Matrix Method
IGeApplication::NurbCurve Method
IGeApplication::NurbSurface Method
IGeApplication::OffsetCurve Method
IGeApplication::OffsetSurface Method
IGeApplication::Plane Method
IGeApplication::Point Method
IGeApplication::Ray Method
IGeApplication::Sphere Method
IGeApplication::Tolerance Method
IGeApplication::Torus Method
IGeApplication::Vector Method
IGeAugmentedLine Interface
IGeAugmentedLine Members
IGeAugmentedLine::Points Property
IGeAugmentedLine::SecondDerivatives Property
IGeAugmentedLine::Vectors Property
IGeAugmentedLine::PointAt Method ([in] long, [in] IGePoint*)
IGeAugmentedLine::PointAt Method ([in] long, [out, retval] IGePoint**)
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine::SecondDerivativeAt Method ([in] long, [out, retval] IGeVector**)
IGeAugmentedLine::Set Method
IGeAugmentedLine::VectorAt Method ([in] long, [in] IGeVector*)
IGeAugmentedLine::VectorAt Method ([in] long, [out, retval] IGeVector**)
IGeBoundBlock Interface
IGeBoundBlock Members
IGeBoundBlock::BasePoint Property
IGeBoundBlock::Direction1 Property
IGeBoundBlock::Direction2 Property
IGeBoundBlock::Direction3 Property
IGeBoundBlock::IsBox Property
IGeBoundBlock::MaxPoint Property
IGeBoundBlock::MinPoint Property
IGeBoundBlock::Contains Method
IGeBoundBlock::Extend Method
IGeBoundBlock::IsDisjoint Method
IGeBoundBlock::Swell Method
IGeBoundedSurface Interface
IGeBoundedSurface Members
IGeBoundedSurface::BaseSurface Property
IGeBoundedSurface::ContourCount Property
IGeBoundedSurface::Contours Property
IGeCircularArc Interface
IGeCircularArc Members
IGeCircularArc::Center Property
IGeCircularArc::EndAngle Property
IGeCircularArc::Normal Property
IGeCircularArc::Radius Property
IGeCircularArc::ReferenceVector Property
IGeCircularArc::StartAngle Property
IGeCircularArc::IntersectWith Method
IGeCircularArc::IsInside Method
IGeCircularArc::Set Method
IGeCircularArc::TangentAt Method
IGeCircularArc::TangentTangentRadius Method
IGeCircularArc::TangentTangentTangent Method
IGeCircularArc::ThreePoint Method
IGeCompositeCurve Interface
IGeCompositeCurve Members
IGeCompositeCurve::Curves Property
IGeCompositeCurve::GlobalToLocal Method
IGeCompositeCurve::LocalToGlobal Method
IGeCone Interface
IGeCone Members
IGeCone::Apex Property
IGeCone::AxisOfSymmetry Property
IGeCone::BaseRadius Property
IGeCone::EndAngle Property
IGeCone::HalfAngle Property
IGeCone::Height Property
IGeCone::Origin Property
IGeCone::ReferenceVector Property
IGeCone::StartAngle Property
IGeCone::HeightAt Method
IGeCone::IntersectWith Method
IGeCone::IsClosed Method
IGeCone::Set Method
IGeCurve Interface
IGeCurve Members
IGeCurve::Interval Property
IGeCurve::BoundBlock Method
IGeCurve::ClosestPointTo Method
IGeCurve::ClosestPointToCurve Method
IGeCurve::DistanceTo Method
IGeCurve::EvaluatePoint Method
IGeCurve::GetArea Method
IGeCurve::GetCurvature Method
IGeCurve::GetLength Method
IGeCurve::GetSamplePoints Method
IGeCurve::GetSplitCurves Method
IGeCurve::HasEndPoint Method
IGeCurve::HasStartPoint Method
IGeCurve::IntersectWithCurve Method
IGeCurve::IntersectWithSurface Method
IGeCurve::IsClosed Method
IGeCurve::IsCoplanarWith Method
IGeCurve::IsDegenerate Method
IGeCurve::IsLinear Method
IGeCurve::IsOnInterval Method
IGeCurve::IsPeriodic Method
IGeCurve::IsPlanar Method
IGeCurve::LocalClosestPointTo Method
IGeCurve::LocalClosestPointToCurve Method
IGeCurve::NormalPoint Method
IGeCurve::ParameterAtLength Method
IGeCurve::ParameterOf Method
IGeCurve::Project Method
IGeCurve::Reverse Method
IGeCurveBoundaries Interface
IGeCurveBoundaries Members
IGeCurveBoundaries::Application Property
IGeCurveBoundaries::Count Property
IGeCurveBoundaries::Add Method
IGeCurveBoundaries::Item Method
IGeCurveBoundaries::Remove Method
IGeCurveBoundary Interface
IGeCurveBoundary Members
IGeCurveBoundary::Application Property
IGeCurveBoundary::Elements Property
IGeCurveBoundary::Geometry2d Property
IGeCurveBoundary::Geometry3d Property
IGeCurveBoundary::Orientation2d Property
IGeCurveBoundary::Orientation3d Property
IGeCurveBoundary::GetBoundary Method
IGeCurveBoundary::IsDegenerate Method
IGeCurveBoundary::SetBoundary Method
IGeCurveCurveIntersection Interface
IGeCurveCurveIntersection Members
IGeCurveCurveIntersection::Curve1 Property
IGeCurveCurveIntersection::Curve2 Property
IGeCurveCurveIntersection::IntersectionPointCount Property
IGeCurveCurveIntersection::IntervalRange1 Property
IGeCurveCurveIntersection::IntervalRange2 Property
IGeCurveCurveIntersection::OverlapCount Property
IGeCurveCurveIntersection::OverlapDirection Property
IGeCurveCurveIntersection::Tolerance Property
IGeCurveCurveIntersection::GetAllIntersections Method
IGeCurveCurveIntersection::GetIntersectionConfiguration Method
IGeCurveCurveIntersection::GetOverlapRanges Method
IGeCurveCurveIntersection::IntersectionPoint Method
IGeCurveCurveIntersection::IntersectionPointTolerance Method
IGeCurveCurveIntersection::IsTangential Method
IGeCurveCurveIntersection::IsTransversal Method
IGeCurveCurveIntersection::ParameterOnCurve1 Method
IGeCurveCurveIntersection::ParameterOnCurve2 Method
IGeCurveCurveIntersection::Set Method
IGeCurves Interface
IGeCurves Members
IGeCurves::Application Property
IGeCurves::Count Property
IGeCurves::Add Method
IGeCurves::Item Method
IGeCurves::Remove Method
IGeCurveSurfaceIntersection Interface
IGeCurveSurfaceIntersection Members
IGeCurveSurfaceIntersection::Curve Property
IGeCurveSurfaceIntersection::IntersectionPointCount Property
IGeCurveSurfaceIntersection::Surface Property
IGeCurveSurfaceIntersection::Tolerance Property
IGeCurveSurfaceIntersection::GetAllIntersections Method
IGeCurveSurfaceIntersection::GetIntersectionConfiguration Method
IGeCurveSurfaceIntersection::IntersectionPoint Method
IGeCurveSurfaceIntersection::ParameterOnCurve Method
IGeCurveSurfaceIntersection::ParameterOnSurface Method
IGeCurveSurfaceIntersection::Set Method
IGeCylinder Interface
IGeCylinder Members
IGeCylinder::AxisOfSymmetry Property
IGeCylinder::EndAngle Property
IGeCylinder::Height Property
IGeCylinder::Origin Property
IGeCylinder::Radius Property
IGeCylinder::ReferenceVector Property
IGeCylinder::StartAngle Property
IGeCylinder::IntersectWith Method
IGeCylinder::Set Method
IGeEllipticalArc Interface
IGeEllipticalArc Members
IGeEllipticalArc::Center Property
IGeEllipticalArc::EndAngle Property
IGeEllipticalArc::EndPoint Property
IGeEllipticalArc::IsCircular Property
IGeEllipticalArc::MajorAxis Property
IGeEllipticalArc::MajorRadius Property
IGeEllipticalArc::MinorAxis Property
IGeEllipticalArc::MinorRadius Property
IGeEllipticalArc::Normal Property
IGeEllipticalArc::StartAngle Property
IGeEllipticalArc::StartPoint Property
IGeEllipticalArc::IntersectWith Method
IGeEllipticalArc::IsInside Method
IGeEllipticalArc::Set Method
IGeEntities Interface
IGeEntities Members
IGeEntities::Application Property
IGeEntities::Count Property
IGeEntities::Add Method
IGeEntities::Item Method
IGeEntities::Remove Method
IGeEntity Interface
IGeEntity Members
IGeEntity::Application Property
IGeEntity::IsEqualTo Method
IGeEntity::IsOn Method
IGeEntity::Mirror Method
IGeEntity::RotateBy Method
IGeEntity::ScaleBy Method
IGeEntity::TransformBy Method
IGeEntity::TranslateBy Method
IGeInterval Interface
IGeInterval Members
IGeInterval::Application Property
IGeInterval::Bounded Property
IGeInterval::BoundedAbove Property
IGeInterval::BoundedBelow Property
IGeInterval::IsSingleton Property
IGeInterval::IsUnBounded Property
IGeInterval::Length Property
IGeInterval::Lower Property
IGeInterval::Upper Property
IGeInterval::Contains Method
IGeInterval::IsContinuousAtUpper Method
IGeInterval::IsDisjoint Method
IGeInterval::IsOverlapAtUpper Method
IGeKnotVector Interface
IGeKnotVector Members
IGeKnotVector::Application Property
IGeKnotVector::AsArray Property
IGeKnotVector::DistinctKnots Property
IGeKnotVector::EndParameter Property
IGeKnotVector::IsEmpty Property
IGeKnotVector::Length Property
IGeKnotVector::NumberOfIntervals Property
IGeKnotVector::StartParameter Property
IGeKnotVector::Tolerance Property
IGeKnotVector::AddKnot Method
IGeKnotVector::AddKnotVector Method
IGeKnotVector::Contains Method
IGeKnotVector::Insert Method
IGeKnotVector::InsertKnot Method
IGeKnotVector::Interval Method
IGeKnotVector::IsEqualTo Method
IGeKnotVector::Item Method ([in] long, [in] double)
IGeKnotVector::Item Method ([in] long, [out, retval] double*)
IGeKnotVector::MultiplicityAt Method
IGeKnotVector::RemoveKnotAt Method
IGeKnotVector::RemoveRange Method
IGeKnotVector::Reverse Method
IGeKnotVector::SetRange Method
IGeKnotVector::Split Method
IGeLine Interface
IGeLine Members
IGeLine::Set Method
IGeLinearEntity Interface
IGeLinearEntity Members
IGeLinearEntity::Direction Property
IGeLinearEntity::PointOnLine Property
IGeLinearEntity::IntersectWith Method
IGeLinearEntity::IsColinearTo Method
IGeLinearEntity::IsOnPlane Method
IGeLinearEntity::IsParallelTo Method
IGeLinearEntity::IsPerpendicularTo Method
IGeLinearEntity::Overlap Method
IGeLinearEntity::PerpendicularPlane Method
IGeLineSegment Interface
IGeLineSegment Members
IGeLineSegment::Bisector Property
IGeLineSegment::EndPoint Property
IGeLineSegment::MidPoint Property
IGeLineSegment::StartPoint Property
IGeLineSegment::BaryComb Method
IGeLineSegment::Set Method
IGeLineSegment::TangentTangent Method
IGeLineSegment::TangentTo Method
IGeMatrix Interface
IGeMatrix Members
IGeMatrix::Application Property
IGeMatrix::AsArray Property
IGeMatrix::Determinant Property
IGeMatrix::Inverse Property
IGeMatrix::Scale Property
IGeMatrix::Translation Property
IGeMatrix::Transpose Property
IGeMatrix::GetCoordinateSystem Method
IGeMatrix::Invert Method
IGeMatrix::IsEqualTo Method
IGeMatrix::IsOrthogonal Method
IGeMatrix::IsSingular Method
IGeMatrix::IsUniformScaledOrtho Method
IGeMatrix::Item Method ([in] long, [in] long, [in] double)
IGeMatrix::Item Method ([in] long, [in] long, [out, retval] double*)
IGeMatrix::PostMultiply Method
IGeMatrix::PreMultiply Method
IGeMatrix::Product Method
IGeMatrix::SetToAlignCoordinateSystem Method
IGeMatrix::SetToCoordinateSystem Method
IGeMatrix::SetToIdentity Method
IGeMatrix::SetToMirroring Method
IGeMatrix::SetToProduct Method
IGeMatrix::SetToProjection Method
IGeMatrix::SetToRotation Method
IGeMatrix::SetToScaling Method
IGeMatrix::SetToTranslation Method
IGeMatrix::TransposeIt Method
IGeNurbCurve Interface
IGeNurbCurve Members
IGeNurbCurve::ControlPointCount Property
IGeNurbCurve::ControlPoints Property
IGeNurbCurve::Degree Property
IGeNurbCurve::EndParameter Property
IGeNurbCurve::EndPoint Property
IGeNurbCurve::EvaluatorMode Property
IGeNurbCurve::FitEndTangent Property
IGeNurbCurve::FitPointCount Property
IGeNurbCurve::FitPoints Property
IGeNurbCurve::FitStartTangent Property
IGeNurbCurve::FitTolerance Property
IGeNurbCurve::HasFitData Property
IGeNurbCurve::IsRational Property
IGeNurbCurve::KnotCount Property
IGeNurbCurve::Knots Property
IGeNurbCurve::Order Property
IGeNurbCurve::StartParameter Property
IGeNurbCurve::StartPoint Property
IGeNurbCurve::WeightCount Property
IGeNurbCurve::Weights Property
IGeNurbCurve::AddFitPointAt Method
IGeNurbCurve::AddKnot Method
IGeNurbCurve::ContinuityAtKnot Method
IGeNurbCurve::ControlPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve::ControlPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve::ElevateDegree Method
IGeNurbCurve::FitPointAt Method ([in] long, [in] IGePoint*)
IGeNurbCurve::FitPointAt Method ([in] long, [out, retval] IGePoint**)
IGeNurbCurve::GetDefinitionData Method
IGeNurbCurve::GetFitData Method
IGeNurbCurve::JoinWith Method
IGeNurbCurve::KnotAt Method ([in] long, [in] double)
IGeNurbCurve::KnotAt Method ([in] long, [out, retval] double*)
IGeNurbCurve::MakeClosed Method
IGeNurbCurve::MakePeriodic Method
IGeNurbCurve::MakeRational Method
IGeNurbCurve::ParametersOfC1 Method
IGeNurbCurve::ParametersOfG1 Method
IGeNurbCurve::PurgeFitData Method
IGeNurbCurve::RemoveFitPointAt Method
IGeNurbCurve::SetDefinitionData Method
IGeNurbCurve::SetFitData Method
IGeNurbCurve::TrimByParameters Method
IGeNurbCurve::WeightAt Method ([in] long, [in] double)
IGeNurbCurve::WeightAt Method ([in] long, [out, retval] double*)
IGeNurbSurface Interface
IGeNurbSurface Members
IGeNurbSurface::ControlPoints Property
IGeNurbSurface::DegreeInU Property
IGeNurbSurface::DegreeInV Property
IGeNurbSurface::IsClosedInU Property
IGeNurbSurface::IsClosedInV Property
IGeNurbSurface::IsRationalInU Property
IGeNurbSurface::IsRationalInV Property
IGeNurbSurface::SingularityInU Property
IGeNurbSurface::SingularityInV Property
IGeNurbSurface::UControlPointCount Property
IGeNurbSurface::UKnotCount Property
IGeNurbSurface::UKnots Property
IGeNurbSurface::VControlPointCount Property
IGeNurbSurface::VKnotCount Property
IGeNurbSurface::VKnots Property
IGeNurbSurface::Weights Property
IGeNurbSurface::GetDefinitionData Method
IGeNurbSurface::IsPeriodicInU Method
IGeNurbSurface::IsPeriodicInV Method
IGeNurbSurface::SetDefinitionData Method
IGeOffsetCurve Interface
IGeOffsetCurve Members
IGeOffsetCurve::BaseCurve Property
IGeOffsetCurve::Normal Property
IGeOffsetCurve::OffsetDistance Property
IGeOffsetCurve::ParameterDirection Property
IGeOffsetCurve::Transformation Property
IGeOffsetSurface Interface
IGeOffsetSurface Members
IGeOffsetSurface::BaseSurface Property
IGeOffsetSurface::OffsetDistance Property
IGeOffsetSurface::ConvertedSurface Method
IGePlane Interface
IGePlane Members
IGePlane::Normal Property
IGePlane::Origin Property
IGePlane::CoordinateSystem Method
IGePlane::GetCoefficients Method
IGePlane::IntersectWith Method
IGePlane::IsCoplanarWith Method
IGePlane::IsParallelTo Method
IGePlane::IsPerpendicularTo Method
IGePlane::Set Method
IGePlane::SignedDistanceTo Method
IGePoint Interface
IGePoint Members
IGePoint::AsArray Property
IGePoint::X Property
IGePoint::Y Property
IGePoint::Z Property
IGePoint::AsVector Method
IGePoint::DistanceTo Method
IGePoint::Get Method
IGePoint::Item Method ([in] long, [in] double)
IGePoint::Item Method ([in] long, [out, retval] double*)
IGePoint::ProjectToPlane Method
IGePoint::Set Method
IGePoint::Sum Method
IGePoints Interface
IGePoints Members
IGePoints::Application Property
IGePoints::AsArray Property
IGePoints::AsArray2d Property
IGePoints::Count Property
IGePoints::Add Method
IGePoints::Item Method
IGePoints::Remove Method
IGeRay Interface
IGeRay Members
IGeRay::Set Method
IGeSphere Interface
IGeSphere Members
IGeSphere::EndLatitude Property
IGeSphere::EndLongitude Property
IGeSphere::NorthAxis Property
IGeSphere::NorthPole Property
IGeSphere::Origin Property
IGeSphere::Radius Property
IGeSphere::ReferenceAxis Property
IGeSphere::SouthPole Property
IGeSphere::StartLatitude Property
IGeSphere::StartLongitude Property
IGeSphere::IntersectWith Method
IGeSphere::IsClosedInU Method
IGeSphere::Set Method
IGeSurface Interface
IGeSurface Members
IGeSurface::NormalFlipped Property
IGeSurface::UParameterEnvelope Property
IGeSurface::VParameterEnvelope Property
IGeSurface::ClosestPointTo Method
IGeSurface::DistanceTo Method
IGeSurface::EvaluatePoint Method
IGeSurface::IntersectWithSurface Method
IGeSurface::ParameterOf Method
IGeSurfaces Interface
IGeSurfaces Members
IGeSurfaces::Application Property
IGeSurfaces::Count Property
IGeSurfaces::Add Method
IGeSurfaces::Item Method
IGeSurfaces::Remove Method
IGeSurfaceSurfaceIntersection Interface
IGeSurfaceSurfaceIntersection Members
IGeSurfaceSurfaceIntersection::IntersectionCount Property
IGeSurfaceSurfaceIntersection::Surface1 Property
IGeSurfaceSurfaceIntersection::Surface2 Property
IGeSurfaceSurfaceIntersection::Tolerance Property
IGeSurfaceSurfaceIntersection::GetIntersectionCofiguration Method
IGeSurfaceSurfaceIntersection::IntersectionCurve Method
IGeSurfaceSurfaceIntersection::IntersectionDimension Method
IGeSurfaceSurfaceIntersection::IntersectionPoint Method
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 Method
IGeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 Method
IGeSurfaceSurfaceIntersection::ParameterOnSurface1 Method
IGeSurfaceSurfaceIntersection::ParameterOnSurface2 Method
IGeSurfaceSurfaceIntersection::Set Method
IGeTolerance Interface
IGeTolerance Members
IGeTolerance::Application Property
IGeTolerance::EqualPoint Property
IGeTolerance::EqualVector Property
IGeTorus Interface
IGeTorus Members
IGeTorus::AxisOfSymmetry Property
IGeTorus::EndAngleInU Property
IGeTorus::EndAngleInV Property
IGeTorus::MajorRadius Property
IGeTorus::MinorRadius Property
IGeTorus::Origin Property
IGeTorus::ReferenceAxis Property
IGeTorus::StartAngleInU Property
IGeTorus::StartAngleInV Property
IGeTorus::IntersectWith Method
IGeTorus::IsClosedInU Method
IGeTorus::IsClosedInV Method
IGeTorus::Set Method
IGeVector Interface
IGeVector Members
IGeVector::Application Property
IGeVector::AsArray Property
IGeVector::LargestElement Property
IGeVector::Length Property
IGeVector::Negative Property
IGeVector::Normal Property
IGeVector::X Property
IGeVector::Y Property
IGeVector::Z Property
IGeVector::AngleTo Method
IGeVector::CrossProduct Method
IGeVector::DotProduct Method
IGeVector::Get Method
IGeVector::IsCodirectionalTo Method
IGeVector::IsEqualTo Method
IGeVector::IsParallelTo Method
IGeVector::IsPerpendicularTo Method
IGeVector::IsUnitLength Method
IGeVector::IsZeroLength Method
IGeVector::Item Method ([in] long, [in] double)
IGeVector::Item Method ([in] long, [out, retval] double*)
IGeVector::Mirror Method
IGeVector::MultiplyBy Method
IGeVector::Negate Method
IGeVector::Normalize Method
IGeVector::PerpendicularVector Method
IGeVector::Product Method
IGeVector::Project Method
IGeVector::RotateBy Method
IGeVector::ScaleBy Method
IGeVector::Set Method
IGeVector::SetToProduct Method
IGeVector::SetToSum Method
IGeVector::Sum Method
IGeVector::TransformBy Method
IGeVectors Interface
IGeVectors Members
IGeVectors::Application Property
IGeVectors::Count Property
IGeVectors::Add Method
IGeVectors::Item Method
IGeVectors::Remove Method
GeCollectionType Enumeration
GeCurveCurveIntConfiguration Enumeration
GeCurveSurfIntConfiguration Enumeration
GeNurbSurfaceProperties Enumeration
GeSurfSurfIntConfiguration Enumeration
GeSurfSurfIntType Enumeration
Mcad2DSPreview
64-bit Platform
Sample Code


Index

You are here: Index

Index

Search Result

Index

_ | 6 | A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

_

_NewEnum

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadPartReferences interface

6

64-bit Platform

A

AboveCurve

IMcadTaper interface

AcadmApplication

AcadmApplication coclass

about AcadmApplication coclass

AcadmApplication interface

about IAcadmApplication interface

ActiveDocument

AddAttributeClass

Application

AttributeClasses

DocumentFromHost

Documents

GetAttributeClassFields

GetFormulaEvaluator

IAcadmApplication members

ReadAttributeClass

RemoveAttributeClass

StructureModeEditEntity

WriteAttributeClass

AcadmApplication::ActiveDocument

AcadmApplication::ActiveDocument property

AcadmApplication::AddAttributeClass

AcadmApplication::AddAttributeClass method

AcadmApplication::Application

AcadmApplication::Application property

AcadmApplication::AttributeClasses

AcadmApplication::AttributeClasses property

AcadmApplication::DocumentFromHost

AcadmApplication::DocumentFromHost method

AcadmApplication::Documents

AcadmApplication::Documents property

AcadmApplication::GetAttributeClassFields

AcadmApplication::GetAttributeClassFields method

AcadmApplication::GetFormulaEvaluator

AcadmApplication::GetFormulaEvaluator method

AcadmApplication::ReadAttributeClass

AcadmApplication::ReadAttributeClass method

AcadmApplication::RemoveAttributeClass

AcadmApplication::RemoveAttributeClass method

AcadmApplication::StructureModeEditEntity

AcadmApplication::StructureModeEditEntity property

AcadmApplication::WriteAttributeClass

AcadmApplication::WriteAttributeClass method

AcadmApplicationVersion

AcadmApplicationVersion interface

about IAcadmApplicationVersion interface

GetVersionNumber

IAcadmApplicationVersion members

AcadmApplicationVersion::GetVersionNumber

AcadmApplicationVersion::GetVersionNumber method

AcadmAuto

AcadmAuto library

AcadmAuto::AcadmApplication

AcadmAuto::Mcad2dComplexStdPartCompGroupDescriptor

AcadmAuto::Mcad2dComponentDescriptor

AcadmAuto::Mcad2dShaftCompGroupDescriptor

AcadmAuto::Mcad2dStdPartComponentDescriptor

AcadmAuto::Mcad2DStructureDescriptor

AcadmAuto::Mcad2DStructureMgr

AcadmAuto::McadAnnotationViewDefinition

AcadmAuto::McadAnnotationViewDefinitions

AcadmAuto::McadArc

AcadmAuto::McadAttribute

AcadmAuto::McadAttributeField

AcadmAuto::McadAttributeFields

AcadmAuto::McadAttributes

AcadmAuto::McadAugmentedLine

AcadmAuto::McadComplexHideSituation

AcadmAuto::McadComplexHideSituations

AcadmAuto::McadComponent

AcadmAuto::McadComponentDefinition

AcadmAuto::McadComponentDefinitions

AcadmAuto::McadComponents

AcadmAuto::McadComponentView

AcadmAuto::McadComponentViewDefinition

AcadmAuto::McadComponentViewDefinitions

AcadmAuto::McadComponentViewDescriptor

AcadmAuto::McadComponentViews

AcadmAuto::McadDocument

AcadmAuto::McadDocuments

AcadmAuto::McadEllipse

AcadmAuto::McadFolder

AcadmAuto::McadFolderDefinition

AcadmAuto::McadFolderDefinitions

AcadmAuto::McadFolderDescriptor

AcadmAuto::McadFolders

AcadmAuto::McadFormulaEvaluator

AcadmAuto::McadHideSituation

AcadmAuto::McadHideSituations

AcadmAuto::McadLayerCfg

AcadmAuto::McadLayerCfgs

AcadmAuto::McadLayerGroupMgr

AcadmAuto::McadLayerObjectCfg

AcadmAuto::McadLayerObjectCfgs

AcadmAuto::McadLayerObjectMgr

AcadmAuto::McadLine

AcadmAuto::McadObjects

AcadmAuto::McadPick

AcadmAuto::McadPolyline

AcadmAuto::McadPowObjViewGroupDescriptor

AcadmAuto::McadSpline

AcadmAuto::McadStdPartComponentViewDescriptor

AcadmAuto::McadTransaction

AcadmAuto::McadUtility

ActiveDocument

IAcadmApplication interface

ActualRowTextHeight

IMcadPartListStandard interface

Add

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

AddAllowedScale

IMcadDetailSymbolStandard interface

AddAttribute

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

AddAttributeClass

IAcadmApplication interface

AddBOMTable

IMcadBOMMgr interface

AddBorderBOMTable

IMcadBOMMgr2 interface

AddColumn

IMcadBOMStandard interface

AddComplexHideSituation

IMcadFolderDefinition interface

AddComponent

IMcadComponentDefinition interface

AddComponentView

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

IMcadComponentViewDefinition interface

AddEntities

IMcadFolder interface

AddFilter

IMcadPartList interface

AddFilterType

IMcadPartList2 interface

AddFitPointAt

IGeNurbCurve interface

AddFolder

IMcadFolderDefinition interface

AddFromExistingEntities

IMcadFolderDefinition interface

AddHideSituation

IMcadFolderDefinition interface

AddItem

IMcadBOM interface

AddKnot

IGeKnotVector interface

IGeNurbCurve interface

AddKnotVector

IGeKnotVector interface

AddLeader

IMcadSymbol interface

AddLeaderWithSurfIndLeader

IMcadDatumIdentifier3 interface

IMcadFeatureControlFrame4 interface

AddLevel

IMcadComplexHideSituation interface

AddMSSubent

IMcadHideSituation interface

AddMSSubents

IMcadHideSituation interface

AddNewAnnotationView

IMcad2DStructureMgr3 interface

AddNewAnnotationViewDefinition

IMcad2DStructureMgr interface

IMcad2DStructureMgr3 interface

AddNewComponentDefinition

IMcad2DStructureMgr interface

AddNewComponentView

IMcad2DStructureMgr interface

AddNewComponentViewDefinition

IMcad2DStructureMgr interface

AddNewFolder

IMcad2DStructureMgr interface

AddNewFolderDefinition

IMcad2DStructureMgr interface

AddPartData

IMcadBOMMgr interface

AddPartGrfDef

IMcadBOMMgr2 interface

AddReference

IMcadBOMItem interface

AddSectionPoint

IMcadSectionLine interface

AddStandard

IMcadStandardMgr interface

AddStdCompliantLeader

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

AddSubent

IMcadHideSituation interface

AddSubents

IMcadHideSituation interface

AddSubWelding

IMcadWelding interface

AddSurfIndLeader

IMcadFeatureControlFrame4 interface

IMcadSurfaceTexture4 interface

AddSymbolStandard

IMcadStandard interface

AddTemplate

IMcadNoteStandard interface

AddUnassociatedItem

IMcadBOM interface

AddView

IMcad2dComplexStdPartCompGroupDescriptor interface

AdjustLanding

IMcadNote interface

AdjustReferenceLine

IMcadTaper interface

AllAround

IMcadEdge interface

IMcadJoint interface

AllAroundAllowed

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

AllowanceValue

IMcadSurfaceTexture interface

AllowedScales

IMcadDetailSymbolStandard interface

AllSymbolStandards

IMcadStandard interface

Angle

IMcadSurfaceTexture interface

AngleTo

IGeVector interface

AngleValue

IMcadWelding interface

IMcadWelding interface

Annotation

IMcadJoint interface

AnnotationOffset

IMcadDetailSymbol interface

IMcadDetailSymbolLabel interface

AnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

AnnotationViewLabelPattern

IMcadAnnotationViewDefinition2 interface

IMcadAnnotationViewDefinition2 interface

AnnotationViewStandard

IMcadStandard3 interface

Apex

IGeCone interface

API Reference

AppendBOMItem

IMcadBalloon interface

appendItem

IMcadSymbolLibrary interface

appendItemFromSubWelding

IMcadWeldingLibrary interface

Application

IAcadmApplication interface

IGeApplication interface

IGeCurveBoundaries interface

IGeCurveBoundary interface

IGeCurves interface

IGeEntities interface

IGeEntity interface

IGeInterval interface

IGeKnotVector interface

IGeMatrix interface

IGePoints interface

IGeSurfaces interface

IGeTolerance interface

IGeVector interface

IGeVectors interface

IMcad2DStructureMgr interface

IMcadAnnotationViewDefinitions interface

IMcadAttribute interface

IMcadAttributeField interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBalloonStandard interface

IMcadBOMItems interface

IMcadBOMMgr interface

IMcadBOMs interface

IMcadColumnDefinition interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDescriptor interface

IMcadDocument interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadFormulaEvaluator interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObject interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartListStandard interface

IMcadPartReferences interface

IMcadPick interface

IMcadRevisionLists interface

IMcadStandardMgr interface

IMcadStandards interface

IMcadSymbolBBMgr interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

IMcadTransaction interface

IMcadUtility interface

applySort

IMcadBOM2 interface

AreaType

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

ArrowLineLength

IMcadSectionLineStandard2 interface

ArrowScale

IMcadStandard interface

IMcadSymbolStandard2 interface

ArrowSideReqValue

IMcadWeldingLibraryObject interface

ArrowTowardsLine

IMcadSectionLineStandard interface

ArrowType

IMcadBalloonStandard interface

IMcadStandard interface

IMcadSymbolStandard2 interface

ArrowVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

AsArray

IGeKnotVector interface

IGeMatrix interface

IGePoint interface

IGePoints interface

IGeVector interface

AsArray2d

IGePoints interface

AssociationType

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

AssocObjects

IMcadLayerCfg interface

AsVector

IGePoint interface

AttachedExternalBom

IMcadPartReference3 interface

AttachedExternalBomXrefBlock

IMcadPartReference3 interface

AttachExternalBom

IMcadPartReference3 interface

AttachGeometry

IMcadSymbol interface

AttachmentPoint

IMcadPartList interface

IMcadPartListStandard interface

AttachmentType

IMcadBalloon interface

IMcadBalloonStandard interface

AttachObjectId

IMcadScaleArea interface

AttachObjectId32

IMcadScaleArea interface

AttributeClasses

IAcadmApplication interface

Attributes

IMcadBorder interface

IMcadRevisionListDescriptor interface

IMcadTitle interface

AugmentedLine

IGeApplication interface

AutoCalculateEnabled

IMcadBOMItem interface

AutomaticAdjust

IMcadSurfaceTexture interface

AutomaticPlacement

IMcadTitleBorderContext interface

AutoSelectBackground

IMcadHideSituation interface

AuxiliaryArrowType

IMcadBalloonStandard interface

AvailableAuxiliarySymbols

IMcadFCFStandard interface

AvailableBackingSymbols

IMcadWeldingStandard interface

AvailableContourSymbols

IMcadWeldingStandard interface

AvailableGDTSymbols

IMcadFCFStandard interface

AvailableLaySymbols

IMcadSurfaceTextureStandard interface

AvailableMarkingContents

IMcadMarkStampStandard interface

AvailableMarkingMethods

IMcadMarkStampStandard interface

AvailableStampingContents

IMcadMarkStampStandard interface

AvailableStampingMethods

IMcadMarkStampStandard interface

AvailableWeldSymbols

IMcadWeldingStandard interface

AxisOfSymmetry

IGeCone interface

IGeCylinder interface

IGeTorus interface

B

BackingValue

IMcadWelding interface

IMcadWelding interface

Balloons

IMcadBOMItem interface

BalloonStandard

IMcadBOMStandard interface

BalloonType

IMcadBalloon interface

IMcadBalloonStandard interface

BaryComb

IGeLineSegment interface

BaseCurve

IGeOffsetCurve interface

BaseName

IMcadStandard interface

BasePoint

IGeBoundBlock interface

IMcadFolder interface

BaseRadius

IGeCone interface

BaseScale

IMcadTitleBorderContext interface

BaseSurface

IGeBoundedSurface interface

IGeOffsetSurface interface

BaseViewScale

IMcadDetailSymbol interface

BendLineLength

IMcadSectionLineStandard2 interface

BgSelectionName

IMcadHideSituation interface

Bisector

IGeLineSegment interface

BlockDef enumeration member

BlockId

IMcadBorder2 interface

IMcadTitle2 interface

BlockId32

IMcadBorder2 interface

IMcadTitle2 interface

BoldVerticalLine

IMcadPartListStandard3 interface

BOM

IMcadBalloon interface

IMcadBOMItem interface

IMcadPartList interface

BOMCaptionAlignment

IMcadColumnDefinition3 interface

BOMDataAlignment

IMcadColumnDefinition3 interface

BOMItems

IMcadBalloon interface

BOMMgr

IMcadSymbolBBMgr interface

BOMStandard

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadStandard interface

BOMTableExists

IMcadBOMMgr interface

Border

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

IMcadTitleBorderDescriptor interface

Border32

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

BorderLineColor

IMcadDetailSymbolStandard2 interface

BorderLineLineType

IMcadDetailSymbolStandard2 interface

BorderLineType

IMcadDatumStandard interface

IMcadDetailSymbolStandard interface

BorderLineTypeName

IMcadDatumStandard interface

BorderLineWeight

IMcadDetailSymbolStandard2 interface

BottomNoteValue

IMcadFeatureControlFrame2 interface

BoundaryLineColor

IMcadDetailSymbolStandard2 interface

BoundaryLineType

IMcadDetailSymbolStandard2 interface

BoundaryLineWeight

IMcadDetailSymbolStandard2 interface

BoundBlock

IGeApplication interface

IGeCurve interface

Bounded

IGeInterval interface

BoundedAbove

IGeInterval interface

BoundedBelow

IGeInterval interface

Brazing

IMcadWelding interface

IMcadWelding interface

BrazingValue

IMcadWelding interface

IMcadWelding interface

bx enumeration member

C

Caption

IMcadColumnDefinition interface

CaptionAlignment

IMcadColumnDefinition interface

Center

IGeCircularArc interface

IGeEllipticalArc interface

ChangeTemplateValue

IMcadNoteStandard interface

Children

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolder interface

IMcadFolderDefinition interface

ChildrenCount

IMcadFolderDefinition interface

CircleRadius

IMcadDatumTarget interface

CircularArc

IGeApplication interface

ClassName

IMcadAttribute interface

ClearanceValue

IMcadWelding interface

IMcadWelding interface

ClearLeaf

IMcadFolder interface

ClearOverrideProperties

IMcadComponent interface

IMcadFolder interface

ClearSubents

IMcadHideSituation interface

ClosedTail

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

ClosedTailAllowed

IMcadWeldingStandard interface

ClosestPointTo

IGeCurve interface

IGeSurface interface

ClosestPointToCurve

IGeCurve interface

cm enumeration member

Collection

IGeApplication interface

CollectionType

IMcadBalloon interface

Color

IMcadBalloonStandard interface

ColorOverride

IMcadComponent interface

IMcadFolder interface

ColumnCount

IMcadBOMStandard interface

ColumnList

IMcadBalloonStandard interface

IMcadPartListStandard interface

Columns

IMcadBOMStandard interface

ColumnSplitEnabled

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitRows

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitSections

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitStyle

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitWrap

IMcadPartList2 interface

IMcadPartListStandard3 interface

ColumnSplitWrapAroundTitle

IMcadPartListStandard4 interface

ColumnType

IMcadColumnDefinition interface

CommentValue

IMcadSurfaceTexture interface

CompDef enumeration member

ComplexHideSituations

IMcadFolderDefinition interface

Component

IMcad2dComponentDescriptor interface

IMcadComponentView interface

IMcadComponentViewDescriptor interface

ComponentDefinition

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

ComponentViewDefinitions

IMcadComponentDefinition interface

ComponentViews

IMcad2dComponentDescriptor interface

IMcadComponent interface

CompositeCurve

IGeApplication interface

Concealed

IMcadComplexHideSituation interface

IMcadHideSituation interface

Cone

IGeApplication interface

ConnectionLineColor

IMcadDetailSymbolStandard2 interface

ConnectionLineType

IMcadDetailSymbolStandard2 interface

ConnectionLineWeight

IMcadDetailSymbolStandard2 interface

ContainingComponent

IMcadComponent interface

IMcadGeometry interface

Contains

IGeBoundBlock interface

IGeInterval interface

IGeKnotVector interface

ContentValue

IMcadMarkStamp interface

ContextDefinition

IMcadFolder interface

ContinuityAtKnot

IGeNurbCurve interface

ContourCount

IGeBoundedSurface interface

Contours

IGeBoundedSurface interface

ContoursOnlyInForeground

IMcadHideSituation interface

ContourType

IMcadWelding interface

IMcadWelding interface

ContourValue

IMcadWelding interface

IMcadWelding interface

ControlCategoryValue

IMcadWelding interface

IMcadWelding interface

ControlPointAt

IGeNurbCurve interface

IGeNurbCurve interface

ControlPointCount

IGeNurbCurve interface

ControlPoints

IGeNurbCurve interface

IGeNurbSurface interface

ConvertedSurface

IGeOffsetSurface interface

CoordinateSystem

IGePlane interface

IMcadSymbol interface

CopyComponentFromDatabase

IMcad2DStructureMgr interface

CopyDefinition

IMcadComponent interface

IMcadComponentDefinition interface

CopyEntities

IMcadFolder interface

CopyFolderFromDatabase

IMcad2DStructureMgr interface

CopyStandard

IMcadStandardMgr interface

CopyView

IMcadFolder interface

CopyViewDefinition

IMcadFolder interface

CorrectionScaleFactor

IMcadDetailSymbol interface

Count

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadRevisionLists interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

Create2dComplexStdPartCompGroupDescriptor

IMcad2DStructureMgr interface

Create2dComponentDescriptor

IMcad2DStructureMgr interface

Create2dStdPartComponentDescriptor

IMcad2DStructureMgr interface

CreateAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

CreateAnnotationViewLabels

IMcadAnnotationViewDefinition2 interface

CreateAttribute

IMcadUtility interface

CreateAttributeField

IMcadUtility interface

CreateBlocksFromStructure

IMcad2DStructureMgr interface

CreateCollection

IMcadUtility interface

CreateComponent

IMcad2dComponentDescriptor interface

CreateComponentView

IMcadComponentViewDescriptor interface

CreateComponentViewDescriptor

IMcad2DStructureMgr interface

CreateFolder

IMcadFolderDescriptor interface

CreateFolderDescriptor

IMcad2DStructureMgr interface

CreateLabelEntity

IMcadDetailSymbol interface

CreateLayer

IMcadLayerObjectMgr interface

CreateNoteText

IMcadNote interface

CreatePickObject

IMcadUtility interface

CreateRevisionList

IMcadRevisionMgr interface

CreateRootViewDefinition

IMcad2DStructureMgr5 interface

CreateScaleArea

IMcadScaleAreaMgr interface

CreateStructureFromBlocks

IMcad2DStructureMgr interface

CreateSystemAttribute

IMcadUtility interface

CreateTitleBorder

IMcadTitleBorderMgr interface

CreateViewPort

IMcadScaleArea interface

CrossProduct

IGeVector interface

Current

IMcadStandard interface

CurrentBOM

IMcadBOMMgr2 interface

CurrentStandard

IMcadStandardMgr interface

CurrentStandardName

IMcadStandardMgr interface

CurrentSymbolStandards

IMcadStandard interface

Curve

IGeCurveSurfaceIntersection interface

Curve1

IGeCurveCurveIntersection interface

Curve2

IGeCurveCurveIntersection interface

CurveBoundary

IGeApplication interface

Curves

IGeCompositeCurve interface

CustomBlock

IMcadBalloon interface

CustomBlockName

IMcadBalloon interface

IMcadBalloonStandard interface

IMcadPartList interface

IMcadPartListStandard interface

CustomBlocks

IMcadPartList interface

IMcadPartListStandard interface

CutoffValue

IMcadSurfaceTexture interface

Cylinder

IGeApplication interface

D

Data

IMcadBOM interface

IMcadBOMItem interface

IMcadPartReference interface

DataAlignment

IMcadColumnDefinition interface

DataType

IMcadColumnDefinition interface

DatumIDValue

IMcadFeatureControlFrame interface

DatumNote

IMcadDatumIdentifier3 interface

DatumPrimary2Value

IMcadFeatureControlFrame interface

DatumPrimary3Value

IMcadFeatureControlFrame interface

DatumPrimaryValue

IMcadFeatureControlFrame interface

DatumSecondary2Value

IMcadFeatureControlFrame interface

DatumSecondary3Value

IMcadFeatureControlFrame interface

DatumSecondaryValue

IMcadFeatureControlFrame interface

DatumStandard

IMcadStandard interface

DatumTertiary2Value

IMcadFeatureControlFrame interface

DatumTertiary3Value

IMcadFeatureControlFrame interface

DatumTertiaryValue

IMcadFeatureControlFrame interface

DatumValue

IMcadDatumTarget interface

DefaultArrowType

IMcadIdentifierStandard interface

DefaultItem

IMcadSymbolLibrary interface

DefaultPaperFormat

IMcadTitleBorderStandard interface

DefaultRevisionList

IMcadTitleBorderStandard interface

DefaultStandard

IMcadStandardMgr interface

DefaultTitleBlock

IMcadTitleBorderStandard interface

Definition

IMcadComplexHideSituation interface

IMcadComponent interface

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadHideSituation interface

Degree

IGeNurbCurve interface

DegreeInU

IGeNurbSurface interface

DegreeInV

IGeNurbSurface interface

Delete

IMcadObject interface

DeleteAllTemplates

IMcadNoteStandard interface

DeleteRevisionList

IMcadRevisionMgr interface

DeleteScaleArea

IMcadScaleAreaMgr interface

DeleteTemplate

IMcadNoteStandard interface

DeleteTitleBorder

IMcadTitleBorderMgr interface

DeleteViewPort

IMcadScaleArea interface

DepthValue

IMcadWelding interface

IMcadWelding interface

Desc

IMcadLayerCfg interface

Description

IMcadAttributeField interface

Descriptor

IMcadTitleBorder interface

DesignationValue

IMcadWelding interface

IMcadWelding interface

DetachExternalBom

IMcadPartReference3 interface

DetachGeometry

IMcadSymbol interface

DetailScale

IMcadDetailSymbol interface

DetailSymbolStandard

IMcadStandard3 interface

Determinant

IGeMatrix interface

DimensionValue

IMcadDatumTarget interface

Direction

IGeLinearEntity interface

IMcadEdge interface

Direction1

IGeBoundBlock interface

Direction2

IGeBoundBlock interface

Direction3

IGeBoundBlock interface

DisplayString

IMcadTaper interface

DistanceTo

IGeCurve interface

IGePoint interface

IGeSurface interface

DistinctKnots

IGeKnotVector interface

Document

IMcadAttribute interface

IMcadDescriptor interface

IMcadLayerGroupMgr interface

IMcadLayerObjectMgr interface

IMcadObject interface

IMcadUtility interface

DocumentFromHost

IAcadmApplication interface

Documents

IAcadmApplication interface

DotProduct

IGeVector interface

DrawLeaderArrow

IMcadDatumStandard interface

DrawLine

IMcadDatumTarget interface

DrawPoint

IMcadDatumTarget interface

DwgDefault

IMcadTitleBorderContext interface

E

Each enumeration member

EdgeStandard

IMcadStandard3 interface

Editable

IMcadObject interface

EditTarget

IMcad2DStructureMgr interface

Elements

IGeCurveBoundary interface

ElevateDegree

IGeNurbCurve interface

EllipticalArc

IGeApplication interface

EndAngle

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

EndAngleInU

IGeTorus interface

EndAngleInV

IGeTorus interface

EndArrowType

IMcadSectionLineStandard2 interface

EndBendLineType

IMcadSectionLineStandard2 interface

EndLatitude

IGeSphere interface

EndLineLength

IMcadSectionLineStandard2 interface

EndLineOvershoot

IMcadSectionLineStandard2 interface

EndLongitude

IGeSphere interface

EndPadding

IMcadFCFStandard interface

EndParameter

IGeKnotVector interface

IGeNurbCurve interface

EndPoint

IGeEllipticalArc interface

IGeLineSegment interface

IGeNurbCurve interface

Entities

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

Entities32

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

entryName

IMcadSymbolLibraryObject interface

EqualPoint

IGeTolerance interface

EqualVector

IGeTolerance interface

Equivalents

IMcadColumnDefinition interface

EraseAllowedScales

IMcadDetailSymbolStandard interface

EraseAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

Evaluate

IMcadFormulaEvaluator interface

IMcadPartListFilter interface

EvaluatedNoteText

IMcadNote interface

EvaluatePoint

IGeCurve interface

IGeSurface interface

EvaluatorMode

IGeNurbCurve interface

Excluded

IMcadPartListFilter2 interface

ExcludeFromPartList

IMcadBOMItem2 interface

exCSV enumeration member

exDB5 enumeration member

exDBIII enumeration member

exDBIV enumeration member

exEXCEL95 enumeration member

exEXCEL97 enumeration member

exFOX25 enumeration member

exFOX26 enumeration member

exFOXVIS enumeration member

exHTML enumeration member

Exist

IMcadFormulaEvaluator interface

ExistsStructure

IMcad2DStructureMgr5 interface

exMDB enumeration member

exMDB97 enumeration member

Expanded

IMcadBOMItem interface

Explode

IMcadComplexHideSituation interface

IMcadFolder interface

ExportBOM

IMcadBOMMgr interface

ExportBOM2

IMcadBOMMgr2 interface

ExportPartList

IMcadBOMMgr2 interface

Extend

IGeBoundBlock interface

Extends

IMcadBorder interface

Extents

IMcadFolderDefinition interface

ExtentsMaximum

IMcadFolder interface

ExtentsMinimum

IMcadFolder interface

Externalize

IMcadComponentDefinition interface

IMcadFolderDefinition interface

ExternalPath

IMcadComponentDefinition interface

ExternalStructureDatabases

IMcad2DStructureMgr interface

exTXT enumeration member

F

FarSideLeaderLineType

IMcadIdentifierStandard2 interface

FarSideLeaderLineTypeName

IMcadIdentifierStandard2 interface

FarSideStatus

IMcadDatumIdentifier3 interface

FCFStandard

IMcadStandard interface

FgSelectionName

IMcadHideSituation interface

FieldCount

IMcadAttribute interface

FieldDescription

IMcadAttribute interface

FieldName

IMcadAttribute interface

FieldType

IMcadAttribute interface

IMcadAttributeField interface

FieldValue

IMcadAttribute interface

IMcadAttribute interface

FieldValue32

IMcadAttribute interface

IMcadAttribute interface

FieldWeld

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

FilterEmptyBlocks

IMcadPartList interface

IMcadPartListStandard interface

Filters

IMcadPartList interface

FindHideSituations

IMcadFolderDefinition interface

findItem

IMcadSymbolLibrary interface

findList

IMcadSymbolLibrary interface

FindScaleArea

IMcadScaleAreaMgr interface

FinishingValue

IMcadWelding interface

IMcadWelding interface

FirstRequirement

IMcadSurfaceTexture2 interface

FitCircle

IMcadSurfaceTextureStandard interface

FitEndTangent

IGeNurbCurve interface

FitPointAt

IGeNurbCurve interface

IGeNurbCurve interface

FitPointCount

IGeNurbCurve interface

FitPoints

IGeNurbCurve interface

FitStartTangent

IGeNurbCurve interface

FitTolerance

IGeNurbCurve interface

ForceTail

IMcadSurfaceTextureStandard interface

FormulaBarEnabled

IMcadPartList2 interface

FourthRequirement

IMcadSurfaceTexture2 interface

FrameColor

IMcadPartListStandard interface

FrameGap

IMcadFCFStandard interface

FrameTrueColor

IMcadPartListStandard2 interface

ft enumeration member

FullList

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

FullName

IMcadFolderDefinition interface

FullViewName

IMcadComponentViewDescriptor interface

G

g enumeration member

gal enumeration member

GapValue

IMcadWelding interface

IMcadWelding interface

GDTTextFont

IMcadFCFStandard interface

GDTTextStyle

IMcadFCFStandard interface

GDTTextStyleName

IMcadFCFStandard interface

geAntiTangent enumeration member

GeApplication

GeApplication coclass

about GeApplication coclass

GeApplication interface

about IGeApplication interface

Application

AugmentedLine

BoundBlock

CircularArc

Collection

CompositeCurve

Cone

CurveBoundary

Cylinder

EllipticalArc

IGeApplication members

Interval

KnotVector

Line

LineSegment

Matrix

NurbCurve

NurbSurface

OffsetCurve

OffsetSurface

Plane

Point

Ray

Sphere

Tolerance

Torus

Vector

GeApplication::Application

GeApplication::Application property

GeApplication::AugmentedLine

GeApplication::AugmentedLine method

GeApplication::BoundBlock

GeApplication::BoundBlock method

GeApplication::CircularArc

GeApplication::CircularArc method

GeApplication::Collection

GeApplication::Collection method

GeApplication::CompositeCurve

GeApplication::CompositeCurve method

GeApplication::Cone

GeApplication::Cone method

GeApplication::CurveBoundary

GeApplication::CurveBoundary method

GeApplication::Cylinder

GeApplication::Cylinder method

GeApplication::EllipticalArc

GeApplication::EllipticalArc method

GeApplication::Interval

GeApplication::Interval method

GeApplication::KnotVector

GeApplication::KnotVector method

GeApplication::Line

GeApplication::Line method

GeApplication::LineSegment

GeApplication::LineSegment method

GeApplication::Matrix

GeApplication::Matrix method

GeApplication::NurbCurve

GeApplication::NurbCurve method

GeApplication::NurbSurface

GeApplication::NurbSurface method

GeApplication::OffsetCurve

GeApplication::OffsetCurve method

GeApplication::OffsetSurface

GeApplication::OffsetSurface method

GeApplication::Plane

GeApplication::Plane method

GeApplication::Point

GeApplication::Point method

GeApplication::Ray

GeApplication::Ray method

GeApplication::Sphere

GeApplication::Sphere method

GeApplication::Tolerance

GeApplication::Tolerance method

GeApplication::Torus

GeApplication::Torus method

GeApplication::Vector

GeApplication::Vector method

GeAugmentedLine

GeAugmentedLine coclass

about GeAugmentedLine coclass

GeAugmentedLine interface

about IGeAugmentedLine interface

IGeAugmentedLine members

PointAt

PointAt

Points

SecondDerivativeAt

SecondDerivativeAt

SecondDerivatives

Set

VectorAt

VectorAt

Vectors

GeAugmentedLine::PointAt

GeAugmentedLine::PointAt method

GeAugmentedLine::Points

GeAugmentedLine::Points property

GeAugmentedLine::SecondDerivativeAt

GeAugmentedLine::SecondDerivativeAt method

GeAugmentedLine::SecondDerivatives

GeAugmentedLine::SecondDerivatives property

GeAugmentedLine::Set

GeAugmentedLine::Set method

GeAugmentedLine::VectorAt

GeAugmentedLine::VectorAt method

GeAugmentedLine::Vectors

GeAugmentedLine::Vectors property

GEAuto

GEAuto library

GEAuto::GeApplication

GEAuto::GeAugmentedLine

GEAuto::GeBoundBlock

GEAuto::GeBoundedSurface

GEAuto::GeCircularArc

GEAuto::GeCompositeCurve

GEAuto::GeCone

GEAuto::GeCurveBoundaries

GEAuto::GeCurveBoundary

GEAuto::GeCurveCurveIntersection

GEAuto::GeCurves

GEAuto::GeCurveSurfaceIntersection

GEAuto::GeCylinder

GEAuto::GeEllipticalArc

GEAuto::GeEntities

GEAuto::GeInterval

GEAuto::GeKnotVector

GEAuto::GeLine

GEAuto::GeLineSegment

GEAuto::GeMatrix

GEAuto::GeNurbCurve

GEAuto::GeNurbSurface

GEAuto::GeOffsetCurve

GEAuto::GeOffsetSurface

GEAuto::GePlane

GEAuto::GePoint

GEAuto::GePoints

GEAuto::GeRay

GEAuto::GeSphere

GEAuto::GeSurfaces

GEAuto::GeSurfaceSurfaceIntersection

GEAuto::GeTolerance

GEAuto::GeTorus

GEAuto::GeVector

GEAuto::GeVectors

GeBoundBlock

GeBoundBlock coclass

about GeBoundBlock coclass

GeBoundBlock interface

about IGeBoundBlock interface

BasePoint

Contains

Direction1

Direction2

Direction3

Extend

IGeBoundBlock members

IsBox

IsDisjoint

MaxPoint

MinPoint

Swell

GeBoundBlock::BasePoint

GeBoundBlock::BasePoint property

GeBoundBlock::Contains

GeBoundBlock::Contains method

GeBoundBlock::Direction1

GeBoundBlock::Direction1 property

GeBoundBlock::Direction2

GeBoundBlock::Direction2 property

GeBoundBlock::Direction3

GeBoundBlock::Direction3 property

GeBoundBlock::Extend

GeBoundBlock::Extend method

GeBoundBlock::IsBox

GeBoundBlock::IsBox property

GeBoundBlock::IsDisjoint

GeBoundBlock::IsDisjoint method

GeBoundBlock::MaxPoint

GeBoundBlock::MaxPoint property

GeBoundBlock::MinPoint

GeBoundBlock::MinPoint property

GeBoundBlock::Swell

GeBoundBlock::Swell method

GeBoundedSurface

GeBoundedSurface coclass

about GeBoundedSurface coclass

GeBoundedSurface interface

about IGeBoundedSurface interface

BaseSurface

ContourCount

Contours

IGeBoundedSurface members

GeBoundedSurface::BaseSurface

GeBoundedSurface::BaseSurface property

GeBoundedSurface::ContourCount

GeBoundedSurface::ContourCount property

GeBoundedSurface::Contours

GeBoundedSurface::Contours property

GeCircularArc

GeCircularArc coclass

about GeCircularArc coclass

GeCircularArc interface

about IGeCircularArc interface

Center

EndAngle

IGeCircularArc members

IntersectWith

IsInside

Normal

Radius

ReferenceVector

Set

StartAngle

TangentAt

TangentTangentRadius

TangentTangentTangent

ThreePoint

GeCircularArc::Center

GeCircularArc::Center property

GeCircularArc::EndAngle

GeCircularArc::EndAngle property

GeCircularArc::IntersectWith

GeCircularArc::IntersectWith method

GeCircularArc::IsInside

GeCircularArc::IsInside method

GeCircularArc::Normal

GeCircularArc::Normal property

GeCircularArc::Radius

GeCircularArc::Radius property

GeCircularArc::ReferenceVector

GeCircularArc::ReferenceVector property

GeCircularArc::Set

GeCircularArc::Set method

GeCircularArc::StartAngle

GeCircularArc::StartAngle property

GeCircularArc::TangentAt

GeCircularArc::TangentAt method

GeCircularArc::TangentTangentRadius

GeCircularArc::TangentTangentRadius method

GeCircularArc::TangentTangentTangent

GeCircularArc::TangentTangentTangent method

GeCircularArc::ThreePoint

GeCircularArc::ThreePoint method

geClosed enumeration member

geCoincident enumeration member

geCoincidentUnbounded enumeration member

GeCollectionType

GeCollectionType enumeration

GeCompositeCurve

GeCompositeCurve coclass

about GeCompositeCurve coclass

GeCompositeCurve interface

about IGeCompositeCurve interface

Curves

GlobalToLocal

IGeCompositeCurve members

LocalToGlobal

GeCompositeCurve::Curves

GeCompositeCurve::Curves property

GeCompositeCurve::GlobalToLocal

GeCompositeCurve::GlobalToLocal method

GeCompositeCurve::LocalToGlobal

GeCompositeCurve::LocalToGlobal method

GeCone

GeCone coclass

about GeCone coclass

GeCone interface

about IGeCone interface

Apex

AxisOfSymmetry

BaseRadius

EndAngle

HalfAngle

Height

HeightAt

IGeCone members

IntersectWith

IsClosed

Origin

ReferenceVector

Set

StartAngle

GeCone::Apex

GeCone::Apex property

GeCone::AxisOfSymmetry

GeCone::AxisOfSymmetry property

GeCone::BaseRadius

GeCone::BaseRadius property

GeCone::EndAngle

GeCone::EndAngle property

GeCone::HalfAngle

GeCone::HalfAngle property

GeCone::Height

GeCone::Height property

GeCone::HeightAt

GeCone::HeightAt method

GeCone::IntersectWith

GeCone::IntersectWith method

GeCone::IsClosed

GeCone::IsClosed method

GeCone::Origin

GeCone::Origin property

GeCone::ReferenceVector

GeCone::ReferenceVector property

GeCone::Set

GeCone::Set method

GeCone::StartAngle

GeCone::StartAngle property

GeCurve

GeCurve interface

about IGeCurve interface

BoundBlock

ClosestPointTo

ClosestPointToCurve

DistanceTo

EvaluatePoint

GetArea

GetCurvature

GetLength

GetSamplePoints

GetSplitCurves

HasEndPoint

HasStartPoint

IGeCurve members

IntersectWithCurve

IntersectWithSurface

Interval

IsClosed

IsCoplanarWith

IsDegenerate

IsLinear

IsOnInterval

IsPeriodic

IsPlanar

LocalClosestPointTo

LocalClosestPointToCurve

NormalPoint

ParameterAtLength

ParameterOf

Project

Reverse

GeCurve::BoundBlock

GeCurve::BoundBlock method

GeCurve::ClosestPointTo

GeCurve::ClosestPointTo method

GeCurve::ClosestPointToCurve

GeCurve::ClosestPointToCurve method

GeCurve::DistanceTo

GeCurve::DistanceTo method

GeCurve::EvaluatePoint

GeCurve::EvaluatePoint method

GeCurve::GetArea

GeCurve::GetArea method

GeCurve::GetCurvature

GeCurve::GetCurvature method

GeCurve::GetLength

GeCurve::GetLength method

GeCurve::GetSamplePoints

GeCurve::GetSamplePoints method

GeCurve::GetSplitCurves

GeCurve::GetSplitCurves method

GeCurve::HasEndPoint

GeCurve::HasEndPoint method

GeCurve::HasStartPoint

GeCurve::HasStartPoint method

GeCurve::IntersectWithCurve

GeCurve::IntersectWithCurve method

GeCurve::IntersectWithSurface

GeCurve::IntersectWithSurface method

GeCurve::Interval

GeCurve::Interval property

GeCurve::IsClosed

GeCurve::IsClosed method

GeCurve::IsCoplanarWith

GeCurve::IsCoplanarWith method

GeCurve::IsDegenerate

GeCurve::IsDegenerate method

GeCurve::IsLinear

GeCurve::IsLinear method

GeCurve::IsOnInterval

GeCurve::IsOnInterval method

GeCurve::IsPeriodic

GeCurve::IsPeriodic method

GeCurve::IsPlanar

GeCurve::IsPlanar method

GeCurve::LocalClosestPointTo

GeCurve::LocalClosestPointTo method

GeCurve::LocalClosestPointToCurve

GeCurve::LocalClosestPointToCurve method

GeCurve::NormalPoint

GeCurve::NormalPoint method

GeCurve::ParameterAtLength

GeCurve::ParameterAtLength method

GeCurve::ParameterOf

GeCurve::ParameterOf method

GeCurve::Project

GeCurve::Project method

GeCurve::Reverse

GeCurve::Reverse method

GeCurveBoundaries

GeCurveBoundaries coclass

about GeCurveBoundaries coclass

geCurveBoundaries enumeration member

GeCurveBoundaries interface

about IGeCurveBoundaries interface

Add

Application

Count

IGeCurveBoundaries members

Item

Remove

GeCurveBoundaries::Add

GeCurveBoundaries::Add method

GeCurveBoundaries::Application

GeCurveBoundaries::Application property

GeCurveBoundaries::Count

GeCurveBoundaries::Count property

GeCurveBoundaries::Item

GeCurveBoundaries::Item method

GeCurveBoundaries::Remove

GeCurveBoundaries::Remove method

GeCurveBoundary

GeCurveBoundary coclass

about GeCurveBoundary coclass

GeCurveBoundary interface

about IGeCurveBoundary interface

Application

Elements

Geometry2d

Geometry3d

GetBoundary

IGeCurveBoundary members

IsDegenerate

Orientation2d

Orientation3d

SetBoundary

GeCurveBoundary::Application

GeCurveBoundary::Application property

GeCurveBoundary::Elements

GeCurveBoundary::Elements property

GeCurveBoundary::Geometry2d

GeCurveBoundary::Geometry2d property

GeCurveBoundary::Geometry3d

GeCurveBoundary::Geometry3d property

GeCurveBoundary::GetBoundary

GeCurveBoundary::GetBoundary method

GeCurveBoundary::IsDegenerate

GeCurveBoundary::IsDegenerate method

GeCurveBoundary::Orientation2d

GeCurveBoundary::Orientation2d property

GeCurveBoundary::Orientation3d

GeCurveBoundary::Orientation3d property

GeCurveBoundary::SetBoundary

GeCurveBoundary::SetBoundary method

GeCurveCurveIntConfiguration

GeCurveCurveIntConfiguration enumeration

GeCurveCurveIntersection

GeCurveCurveIntersection coclass

about GeCurveCurveIntersection coclass

GeCurveCurveIntersection interface

about IGeCurveCurveIntersection interface

Curve1

Curve2

GetAllIntersections

GetIntersectionConfiguration

GetOverlapRanges

IGeCurveCurveIntersection members

IntersectionPoint

IntersectionPointCount

IntersectionPointTolerance

IntervalRange1

IntervalRange2

IsTangential

IsTransversal

OverlapCount

OverlapDirection

ParameterOnCurve1

ParameterOnCurve2

Set

Tolerance

GeCurveCurveIntersection::Curve1

GeCurveCurveIntersection::Curve1 property

GeCurveCurveIntersection::Curve2

GeCurveCurveIntersection::Curve2 property

GeCurveCurveIntersection::GetAllIntersections

GeCurveCurveIntersection::GetAllIntersections method

GeCurveCurveIntersection::GetIntersectionConfiguration

GeCurveCurveIntersection::GetIntersectionConfiguration method

GeCurveCurveIntersection::GetOverlapRanges

GeCurveCurveIntersection::GetOverlapRanges method

GeCurveCurveIntersection::IntersectionPoint

GeCurveCurveIntersection::IntersectionPoint method

GeCurveCurveIntersection::IntersectionPointCount

GeCurveCurveIntersection::IntersectionPointCount property

GeCurveCurveIntersection::IntersectionPointTolerance

GeCurveCurveIntersection::IntersectionPointTolerance method

GeCurveCurveIntersection::IntervalRange1

GeCurveCurveIntersection::IntervalRange1 property

GeCurveCurveIntersection::IntervalRange2

GeCurveCurveIntersection::IntervalRange2 property

GeCurveCurveIntersection::IsTangential

GeCurveCurveIntersection::IsTangential method

GeCurveCurveIntersection::IsTransversal

GeCurveCurveIntersection::IsTransversal method

GeCurveCurveIntersection::OverlapCount

GeCurveCurveIntersection::OverlapCount property

GeCurveCurveIntersection::OverlapDirection

GeCurveCurveIntersection::OverlapDirection property

GeCurveCurveIntersection::ParameterOnCurve1

GeCurveCurveIntersection::ParameterOnCurve1 method

GeCurveCurveIntersection::ParameterOnCurve2

GeCurveCurveIntersection::ParameterOnCurve2 method

GeCurveCurveIntersection::Set

GeCurveCurveIntersection::Set method

GeCurveCurveIntersection::Tolerance

GeCurveCurveIntersection::Tolerance property

GeCurves

GeCurves coclass

about GeCurves coclass

geCurves enumeration member

GeCurves interface

about IGeCurves interface

Add

Application

Count

IGeCurves members

Item

Remove

GeCurves::Add

GeCurves::Add method

GeCurves::Application

GeCurves::Application property

GeCurves::Count

GeCurves::Count property

GeCurves::Item

GeCurves::Item method

GeCurves::Remove

GeCurves::Remove method

GeCurveSurfaceIntersection

GeCurveSurfaceIntersection coclass

about GeCurveSurfaceIntersection coclass

GeCurveSurfaceIntersection interface

about IGeCurveSurfaceIntersection interface

Curve

GetAllIntersections

GetIntersectionConfiguration

IGeCurveSurfaceIntersection members

IntersectionPoint

IntersectionPointCount

ParameterOnCurve

ParameterOnSurface

Set

Surface

Tolerance

GeCurveSurfaceIntersection::Curve

GeCurveSurfaceIntersection::Curve property

GeCurveSurfaceIntersection::GetAllIntersections

GeCurveSurfaceIntersection::GetAllIntersections method

GeCurveSurfaceIntersection::GetIntersectionConfiguration

GeCurveSurfaceIntersection::GetIntersectionConfiguration method

GeCurveSurfaceIntersection::IntersectionPoint

GeCurveSurfaceIntersection::IntersectionPoint method

GeCurveSurfaceIntersection::IntersectionPointCount

GeCurveSurfaceIntersection::IntersectionPointCount property

GeCurveSurfaceIntersection::ParameterOnCurve

GeCurveSurfaceIntersection::ParameterOnCurve method

GeCurveSurfaceIntersection::ParameterOnSurface

GeCurveSurfaceIntersection::ParameterOnSurface method

GeCurveSurfaceIntersection::Set

GeCurveSurfaceIntersection::Set method

GeCurveSurfaceIntersection::Surface

GeCurveSurfaceIntersection::Surface property

GeCurveSurfaceIntersection::Tolerance

GeCurveSurfaceIntersection::Tolerance property

GeCurveSurfIntConfiguration

GeCurveSurfIntConfiguration enumeration

GeCylinder

GeCylinder coclass

about GeCylinder coclass

GeCylinder interface

about IGeCylinder interface

AxisOfSymmetry

EndAngle

Height

IGeCylinder members

IntersectWith

Origin

Radius

ReferenceVector

Set

StartAngle

GeCylinder::AxisOfSymmetry

GeCylinder::AxisOfSymmetry property

GeCylinder::EndAngle

GeCylinder::EndAngle property

GeCylinder::Height

GeCylinder::Height property

GeCylinder::IntersectWith

GeCylinder::IntersectWith method

GeCylinder::Origin

GeCylinder::Origin property

GeCylinder::Radius

GeCylinder::Radius property

GeCylinder::ReferenceVector

GeCylinder::ReferenceVector property

GeCylinder::Set

GeCylinder::Set method

GeCylinder::StartAngle

GeCylinder::StartAngle property

GeEllipticalArc

GeEllipticalArc coclass

about GeEllipticalArc coclass

GeEllipticalArc interface

about IGeEllipticalArc interface

Center

EndAngle

EndPoint

IGeEllipticalArc members

IntersectWith

IsCircular

IsInside

MajorAxis

MajorRadius

MinorAxis

MinorRadius

Normal

Set

StartAngle

StartPoint

GeEllipticalArc::Center

GeEllipticalArc::Center property

GeEllipticalArc::EndAngle

GeEllipticalArc::EndAngle property

GeEllipticalArc::EndPoint

GeEllipticalArc::EndPoint property

GeEllipticalArc::IntersectWith

GeEllipticalArc::IntersectWith method

GeEllipticalArc::IsCircular

GeEllipticalArc::IsCircular property

GeEllipticalArc::IsInside

GeEllipticalArc::IsInside method

GeEllipticalArc::MajorAxis

GeEllipticalArc::MajorAxis property

GeEllipticalArc::MajorRadius

GeEllipticalArc::MajorRadius property

GeEllipticalArc::MinorAxis

GeEllipticalArc::MinorAxis property

GeEllipticalArc::MinorRadius

GeEllipticalArc::MinorRadius property

GeEllipticalArc::Normal

GeEllipticalArc::Normal property

GeEllipticalArc::Set

GeEllipticalArc::Set method

GeEllipticalArc::StartAngle

GeEllipticalArc::StartAngle property

GeEllipticalArc::StartPoint

GeEllipticalArc::StartPoint property

GeEntities

GeEntities coclass

about GeEntities coclass

geEntities enumeration member

GeEntities interface

about IGeEntities interface

Add

Application

Count

IGeEntities members

Item

Remove

GeEntities::Add

GeEntities::Add method

GeEntities::Application

GeEntities::Application property

GeEntities::Count

GeEntities::Count property

GeEntities::Item

GeEntities::Item method

GeEntities::Remove

GeEntities::Remove method

GeEntity

GeEntity interface

about IGeEntity interface

Application

IGeEntity members

IsEqualTo

IsOn

Mirror

RotateBy

ScaleBy

TransformBy

TranslateBy

GeEntity::Application

GeEntity::Application property

GeEntity::IsEqualTo

GeEntity::IsEqualTo method

GeEntity::IsOn

GeEntity::IsOn method

GeEntity::Mirror

GeEntity::Mirror method

GeEntity::RotateBy

GeEntity::RotateBy method

GeEntity::ScaleBy

GeEntity::ScaleBy method

GeEntity::TransformBy

GeEntity::TransformBy method

GeEntity::TranslateBy

GeEntity::TranslateBy method

geInside enumeration member

GeInterval

GeInterval coclass

about GeInterval coclass

GeInterval interface

about IGeInterval interface

Application

Bounded

BoundedAbove

BoundedBelow

Contains

IGeInterval members

IsContinuousAtUpper

IsDisjoint

IsOverlapAtUpper

IsSingleton

IsUnBounded

Length

Lower

Upper

GeInterval::Application

GeInterval::Application property

GeInterval::Bounded

GeInterval::Bounded property

GeInterval::BoundedAbove

GeInterval::BoundedAbove property

GeInterval::BoundedBelow

GeInterval::BoundedBelow property

GeInterval::Contains

GeInterval::Contains method

GeInterval::IsContinuousAtUpper

GeInterval::IsContinuousAtUpper method

GeInterval::IsDisjoint

GeInterval::IsDisjoint method

GeInterval::IsOverlapAtUpper

GeInterval::IsOverlapAtUpper method

GeInterval::IsSingleton

GeInterval::IsSingleton property

GeInterval::IsUnBounded

GeInterval::IsUnBounded property

GeInterval::Length

GeInterval::Length property

GeInterval::Lower

GeInterval::Lower property

GeInterval::Upper

GeInterval::Upper property

GeKnotVector

GeKnotVector coclass

about GeKnotVector coclass

GeKnotVector interface

about IGeKnotVector interface

AddKnot

AddKnotVector

Application

AsArray

Contains

DistinctKnots

EndParameter

IGeKnotVector members

Insert

InsertKnot

Interval

IsEmpty

IsEqualTo

Item

Item

Length

MultiplicityAt

NumberOfIntervals

RemoveKnotAt

RemoveRange

Reverse

SetRange

Split

StartParameter

Tolerance

GeKnotVector::AddKnot

GeKnotVector::AddKnot method

GeKnotVector::AddKnotVector

GeKnotVector::AddKnotVector method

GeKnotVector::Application

GeKnotVector::Application property

GeKnotVector::AsArray

GeKnotVector::AsArray property

GeKnotVector::Contains

GeKnotVector::Contains method

GeKnotVector::DistinctKnots

GeKnotVector::DistinctKnots property

GeKnotVector::EndParameter

GeKnotVector::EndParameter property

GeKnotVector::Insert

GeKnotVector::Insert method

GeKnotVector::InsertKnot

GeKnotVector::InsertKnot method

GeKnotVector::Interval

GeKnotVector::Interval method

GeKnotVector::IsEmpty

GeKnotVector::IsEmpty property

GeKnotVector::IsEqualTo

GeKnotVector::IsEqualTo method

GeKnotVector::Item

GeKnotVector::Item method

GeKnotVector::Length

GeKnotVector::Length property

GeKnotVector::MultiplicityAt

GeKnotVector::MultiplicityAt method

GeKnotVector::NumberOfIntervals

GeKnotVector::NumberOfIntervals property

GeKnotVector::RemoveKnotAt

GeKnotVector::RemoveKnotAt method

GeKnotVector::RemoveRange

GeKnotVector::RemoveRange method

GeKnotVector::Reverse

GeKnotVector::Reverse method

GeKnotVector::SetRange

GeKnotVector::SetRange method

GeKnotVector::Split

GeKnotVector::Split method

GeKnotVector::StartParameter

GeKnotVector::StartParameter property

GeKnotVector::Tolerance

GeKnotVector::Tolerance property

geLeftLeft enumeration member

geLeftOverlap enumeration member

geLeftRight enumeration member

GeLine

GeLine coclass

about GeLine coclass

GeLine interface

about IGeLine interface

IGeLine members

Set

GeLine::Set

GeLine::Set method

GeLinearEntity

GeLinearEntity interface

about IGeLinearEntity interface

Direction

IGeLinearEntity members

IntersectWith

IsColinearTo

IsOnPlane

IsParallelTo

IsPerpendicularTo

Overlap

PerpendicularPlane

PointOnLine

GeLinearEntity::Direction

GeLinearEntity::Direction property

GeLinearEntity::IntersectWith

GeLinearEntity::IntersectWith method

GeLinearEntity::IsColinearTo

GeLinearEntity::IsColinearTo method

GeLinearEntity::IsOnPlane

GeLinearEntity::IsOnPlane method

GeLinearEntity::IsParallelTo

GeLinearEntity::IsParallelTo method

GeLinearEntity::IsPerpendicularTo

GeLinearEntity::IsPerpendicularTo method

GeLinearEntity::Overlap

GeLinearEntity::Overlap method

GeLinearEntity::PerpendicularPlane

GeLinearEntity::PerpendicularPlane method

GeLinearEntity::PointOnLine

GeLinearEntity::PointOnLine property

GeLineSegment

GeLineSegment coclass

about GeLineSegment coclass

GeLineSegment interface

about IGeLineSegment interface

BaryComb

Bisector

EndPoint

IGeLineSegment members

MidPoint

Set

StartPoint

TangentTangent

TangentTo

GeLineSegment::BaryComb

GeLineSegment::BaryComb method

GeLineSegment::Bisector

GeLineSegment::Bisector property

GeLineSegment::EndPoint

GeLineSegment::EndPoint property

GeLineSegment::MidPoint

GeLineSegment::MidPoint property

GeLineSegment::Set

GeLineSegment::Set method

GeLineSegment::StartPoint

GeLineSegment::StartPoint property

GeLineSegment::TangentTangent

GeLineSegment::TangentTangent method

GeLineSegment::TangentTo

GeLineSegment::TangentTo method

GeMatrix

GeMatrix coclass

about GeMatrix coclass

GeMatrix interface

about IGeMatrix interface

Application

AsArray

Determinant

GetCoordinateSystem

IGeMatrix members

Inverse

Invert

IsEqualTo

IsOrthogonal

IsSingular

IsUniformScaledOrtho

Item

Item

PostMultiply

PreMultiply

Product

Scale

SetToAlignCoordinateSystem

SetToCoordinateSystem

SetToIdentity

SetToMirroring

SetToProduct

SetToProjection

SetToRotation

SetToScaling

SetToTranslation

Translation

Transpose

TransposeIt

GeMatrix::Application

GeMatrix::Application property

GeMatrix::AsArray

GeMatrix::AsArray property

GeMatrix::Determinant

GeMatrix::Determinant property

GeMatrix::GetCoordinateSystem

GeMatrix::GetCoordinateSystem method

GeMatrix::Inverse

GeMatrix::Inverse property

GeMatrix::Invert

GeMatrix::Invert method

GeMatrix::IsEqualTo

GeMatrix::IsEqualTo method

GeMatrix::IsOrthogonal

GeMatrix::IsOrthogonal method

GeMatrix::IsSingular

GeMatrix::IsSingular method

GeMatrix::IsUniformScaledOrtho

GeMatrix::IsUniformScaledOrtho method

GeMatrix::Item

GeMatrix::Item method

GeMatrix::PostMultiply

GeMatrix::PostMultiply method

GeMatrix::PreMultiply

GeMatrix::PreMultiply method

GeMatrix::Product

GeMatrix::Product method

GeMatrix::Scale

GeMatrix::Scale property

GeMatrix::SetToAlignCoordinateSystem

GeMatrix::SetToAlignCoordinateSystem method

GeMatrix::SetToCoordinateSystem

GeMatrix::SetToCoordinateSystem method

GeMatrix::SetToIdentity

GeMatrix::SetToIdentity method

GeMatrix::SetToMirroring

GeMatrix::SetToMirroring method

GeMatrix::SetToProduct

GeMatrix::SetToProduct method

GeMatrix::SetToProjection

GeMatrix::SetToProjection method

GeMatrix::SetToRotation

GeMatrix::SetToRotation method

GeMatrix::SetToScaling

GeMatrix::SetToScaling method

GeMatrix::SetToTranslation

GeMatrix::SetToTranslation method

GeMatrix::Translation

GeMatrix::Translation property

GeMatrix::Transpose

GeMatrix::Transpose property

GeMatrix::TransposeIt

GeMatrix::TransposeIt method

geNoPoles enumeration member

geNotDefined enumeration member

GeNurbCurve

GeNurbCurve coclass

about GeNurbCurve coclass

GeNurbCurve interface

about IGeNurbCurve interface

AddFitPointAt

AddKnot

ContinuityAtKnot

ControlPointAt

ControlPointAt

ControlPointCount

ControlPoints

Degree

ElevateDegree

EndParameter

EndPoint

EvaluatorMode

FitEndTangent

FitPointAt

FitPointAt

FitPointCount

FitPoints

FitStartTangent

FitTolerance

GetDefinitionData

GetFitData

HasFitData

IGeNurbCurve members

IsRational

JoinWith

KnotAt

KnotAt

KnotCount

Knots

MakeClosed

MakePeriodic

MakeRational

Order

ParametersOfC1

ParametersOfG1

PurgeFitData

RemoveFitPointAt

SetDefinitionData

SetFitData

StartParameter

StartPoint

TrimByParameters

WeightAt

WeightAt

WeightCount

Weights

GeNurbCurve::AddFitPointAt

GeNurbCurve::AddFitPointAt method

GeNurbCurve::AddKnot

GeNurbCurve::AddKnot method

GeNurbCurve::ContinuityAtKnot

GeNurbCurve::ContinuityAtKnot method

GeNurbCurve::ControlPointAt

GeNurbCurve::ControlPointAt method

GeNurbCurve::ControlPointCount

GeNurbCurve::ControlPointCount property

GeNurbCurve::ControlPoints

GeNurbCurve::ControlPoints property

GeNurbCurve::Degree

GeNurbCurve::Degree property

GeNurbCurve::ElevateDegree

GeNurbCurve::ElevateDegree method

GeNurbCurve::EndParameter

GeNurbCurve::EndParameter property

GeNurbCurve::EndPoint

GeNurbCurve::EndPoint property

GeNurbCurve::EvaluatorMode

GeNurbCurve::EvaluatorMode property

GeNurbCurve::FitEndTangent

GeNurbCurve::FitEndTangent property

GeNurbCurve::FitPointAt

GeNurbCurve::FitPointAt method

GeNurbCurve::FitPointCount

GeNurbCurve::FitPointCount property

GeNurbCurve::FitPoints

GeNurbCurve::FitPoints property

GeNurbCurve::FitStartTangent

GeNurbCurve::FitStartTangent property

GeNurbCurve::FitTolerance

GeNurbCurve::FitTolerance property

GeNurbCurve::GetDefinitionData

GeNurbCurve::GetDefinitionData method

GeNurbCurve::GetFitData

GeNurbCurve::GetFitData method

GeNurbCurve::HasFitData

GeNurbCurve::HasFitData property

GeNurbCurve::IsRational

GeNurbCurve::IsRational property

GeNurbCurve::JoinWith

GeNurbCurve::JoinWith method

GeNurbCurve::KnotAt

GeNurbCurve::KnotAt method

GeNurbCurve::KnotCount

GeNurbCurve::KnotCount property

GeNurbCurve::Knots

GeNurbCurve::Knots property

GeNurbCurve::MakeClosed

GeNurbCurve::MakeClosed method

GeNurbCurve::MakePeriodic

GeNurbCurve::MakePeriodic method

GeNurbCurve::MakeRational

GeNurbCurve::MakeRational method

GeNurbCurve::Order

GeNurbCurve::Order property

GeNurbCurve::ParametersOfC1

GeNurbCurve::ParametersOfC1 method

GeNurbCurve::ParametersOfG1

GeNurbCurve::ParametersOfG1 method

GeNurbCurve::PurgeFitData

GeNurbCurve::PurgeFitData method

GeNurbCurve::RemoveFitPointAt

GeNurbCurve::RemoveFitPointAt method

GeNurbCurve::SetDefinitionData

GeNurbCurve::SetDefinitionData method

GeNurbCurve::SetFitData

GeNurbCurve::SetFitData method

GeNurbCurve::StartParameter

GeNurbCurve::StartParameter property

GeNurbCurve::StartPoint

GeNurbCurve::StartPoint property

GeNurbCurve::TrimByParameters

GeNurbCurve::TrimByParameters method

GeNurbCurve::WeightAt

GeNurbCurve::WeightAt method

GeNurbCurve::WeightCount

GeNurbCurve::WeightCount property

GeNurbCurve::Weights

GeNurbCurve::Weights property

GeNurbSurface

GeNurbSurface coclass

about GeNurbSurface coclass

GeNurbSurface interface

about IGeNurbSurface interface

ControlPoints

DegreeInU

DegreeInV

GetDefinitionData

IGeNurbSurface members

IsClosedInU

IsClosedInV

IsPeriodicInU

IsPeriodicInV

IsRationalInU

IsRationalInV

SetDefinitionData

SingularityInU

SingularityInV

UControlPointCount

UKnotCount

UKnots

VControlPointCount

VKnotCount

VKnots

Weights

GeNurbSurface::ControlPoints

GeNurbSurface::ControlPoints property

GeNurbSurface::DegreeInU

GeNurbSurface::DegreeInU property

GeNurbSurface::DegreeInV

GeNurbSurface::DegreeInV property

GeNurbSurface::GetDefinitionData

GeNurbSurface::GetDefinitionData method

GeNurbSurface::IsClosedInU

GeNurbSurface::IsClosedInU property

GeNurbSurface::IsClosedInV

GeNurbSurface::IsClosedInV property

GeNurbSurface::IsPeriodicInU

GeNurbSurface::IsPeriodicInU method

GeNurbSurface::IsPeriodicInV

GeNurbSurface::IsPeriodicInV method

GeNurbSurface::IsRationalInU

GeNurbSurface::IsRationalInU property

GeNurbSurface::IsRationalInV

GeNurbSurface::IsRationalInV property

GeNurbSurface::SetDefinitionData

GeNurbSurface::SetDefinitionData method

GeNurbSurface::SingularityInU

GeNurbSurface::SingularityInU property

GeNurbSurface::SingularityInV

GeNurbSurface::SingularityInV property

GeNurbSurface::UControlPointCount

GeNurbSurface::UControlPointCount property

GeNurbSurface::UKnotCount

GeNurbSurface::UKnotCount property

GeNurbSurface::UKnots

GeNurbSurface::UKnots property

GeNurbSurface::VControlPointCount

GeNurbSurface::VControlPointCount property

GeNurbSurface::VKnotCount

GeNurbSurface::VKnotCount property

GeNurbSurface::VKnots

GeNurbSurface::VKnots property

GeNurbSurface::Weights

GeNurbSurface::Weights property

GeNurbSurfaceProperties

GeNurbSurfaceProperties enumeration

GeOffsetCurve

GeOffsetCurve coclass

about GeOffsetCurve coclass

GeOffsetCurve interface

about IGeOffsetCurve interface

BaseCurve

IGeOffsetCurve members

Normal

OffsetDistance

ParameterDirection

Transformation

GeOffsetCurve::BaseCurve

GeOffsetCurve::BaseCurve property

GeOffsetCurve::Normal

GeOffsetCurve::Normal property

GeOffsetCurve::OffsetDistance

GeOffsetCurve::OffsetDistance property

GeOffsetCurve::ParameterDirection

GeOffsetCurve::ParameterDirection property

GeOffsetCurve::Transformation

GeOffsetCurve::Transformation property

GeOffsetSurface

GeOffsetSurface coclass

about GeOffsetSurface coclass

GeOffsetSurface interface

about IGeOffsetSurface interface

BaseSurface

ConvertedSurface

IGeOffsetSurface members

OffsetDistance

GeOffsetSurface::BaseSurface

GeOffsetSurface::BaseSurface property

GeOffsetSurface::ConvertedSurface

GeOffsetSurface::ConvertedSurface method

GeOffsetSurface::OffsetDistance

GeOffsetSurface::OffsetDistance property

Geometry

IMcadGeometry interface

Geometry2d

IGeCurveBoundary interface

Geometry3d

IGeCurveBoundary interface

GeomPathName

IMcadFolder interface

geOpen enumeration member

geOutside enumeration member

geOverlapEnd enumeration member

geOverlapLeft enumeration member

geOverlapOverlap enumeration member

geOverlapRight enumeration member

geOverlapStart enumeration member

gePeriodic enumeration member

GePlane

GePlane coclass

about GePlane coclass

GePlane interface

about IGePlane interface

CoordinateSystem

GetCoefficients

IGePlane members

IntersectWith

IsCoplanarWith

IsParallelTo

IsPerpendicularTo

Normal

Origin

Set

SignedDistanceTo

GePlane::CoordinateSystem

GePlane::CoordinateSystem method

GePlane::GetCoefficients

GePlane::GetCoefficients method

GePlane::IntersectWith

GePlane::IntersectWith method

GePlane::IsCoplanarWith

GePlane::IsCoplanarWith method

GePlane::IsParallelTo

GePlane::IsParallelTo method

GePlane::IsPerpendicularTo

GePlane::IsPerpendicularTo method

GePlane::Normal

GePlane::Normal property

GePlane::Origin

GePlane::Origin property

GePlane::Set

GePlane::Set method

GePlane::SignedDistanceTo

GePlane::SignedDistanceTo method

GePoint

GePoint coclass

about GePoint coclass

GePoint interface

about IGePoint interface

AsArray

AsVector

DistanceTo

Get

IGePoint members

Item

Item

ProjectToPlane

Set

Sum

X

Y

Z

GePoint::AsArray

GePoint::AsArray property

GePoint::AsVector

GePoint::AsVector method

GePoint::DistanceTo

GePoint::DistanceTo method

GePoint::Get

GePoint::Get method

GePoint::Item

GePoint::Item method

GePoint::ProjectToPlane

GePoint::ProjectToPlane method

GePoint::Set

GePoint::Set method

GePoint::Sum

GePoint::Sum method

GePoint::X

GePoint::X property

GePoint::Y

GePoint::Y property

GePoint::Z

GePoint::Z property

gePointLeft enumeration member

gePointRight enumeration member

GePoints

GePoints coclass

about GePoints coclass

gePoints enumeration member

GePoints interface

about IGePoints interface

Add

Application

AsArray

AsArray2d

Count

IGePoints members

Item

Remove

GePoints::Add

GePoints::Add method

GePoints::Application

GePoints::Application property

GePoints::AsArray

GePoints::AsArray property

GePoints::AsArray2d

GePoints::AsArray2d property

GePoints::Count

GePoints::Count property

GePoints::Item

GePoints::Item method

GePoints::Remove

GePoints::Remove method

gePoleAtBoth enumeration member

gePoleAtMax enumeration member

gePoleAtMin enumeration member

geRational enumeration member

GeRay

GeRay coclass

about GeRay coclass

GeRay interface

about IGeRay interface

IGeRay members

Set

GeRay::Set

GeRay::Set method

geRightLeft enumeration member

geRightOverlap enumeration member

geRightRight enumeration member

GeSphere

GeSphere coclass

about GeSphere coclass

GeSphere interface

about IGeSphere interface

EndLatitude

EndLongitude

IGeSphere members

IntersectWith

IsClosedInU

NorthAxis

NorthPole

Origin

Radius

ReferenceAxis

Set

SouthPole

StartLatitude

StartLongitude

GeSphere::EndLatitude

GeSphere::EndLatitude property

GeSphere::EndLongitude

GeSphere::EndLongitude property

GeSphere::IntersectWith

GeSphere::IntersectWith method

GeSphere::IsClosedInU

GeSphere::IsClosedInU method

GeSphere::NorthAxis

GeSphere::NorthAxis property

GeSphere::NorthPole

GeSphere::NorthPole property

GeSphere::Origin

GeSphere::Origin property

GeSphere::Radius

GeSphere::Radius property

GeSphere::ReferenceAxis

GeSphere::ReferenceAxis property

GeSphere::Set

GeSphere::Set method

GeSphere::SouthPole

GeSphere::SouthPole property

GeSphere::StartLatitude

GeSphere::StartLatitude property

GeSphere::StartLongitude

GeSphere::StartLongitude property

geSSICoincident enumeration member

geSSIInside enumeration member

geSSIOutside enumeration member

geSSIUnknown enumeration member

GeSurface

GeSurface interface

about IGeSurface interface

ClosestPointTo

DistanceTo

EvaluatePoint

IGeSurface members

IntersectWithSurface

NormalFlipped

ParameterOf

UParameterEnvelope

VParameterEnvelope

GeSurface::ClosestPointTo

GeSurface::ClosestPointTo method

GeSurface::DistanceTo

GeSurface::DistanceTo method

GeSurface::EvaluatePoint

GeSurface::EvaluatePoint method

GeSurface::IntersectWithSurface

GeSurface::IntersectWithSurface method

GeSurface::NormalFlipped

GeSurface::NormalFlipped property

GeSurface::ParameterOf

GeSurface::ParameterOf method

GeSurface::UParameterEnvelope

GeSurface::UParameterEnvelope property

GeSurface::VParameterEnvelope

GeSurface::VParameterEnvelope property

GeSurfaces

GeSurfaces coclass

about GeSurfaces coclass

geSurfaces enumeration member

GeSurfaces interface

about IGeSurfaces interface

Add

Application

Count

IGeSurfaces members

Item

Remove

GeSurfaces::Add

GeSurfaces::Add method

GeSurfaces::Application

GeSurfaces::Application property

GeSurfaces::Count

GeSurfaces::Count property

GeSurfaces::Item

GeSurfaces::Item method

GeSurfaces::Remove

GeSurfaces::Remove method

GeSurfaceSurfaceIntersection

GeSurfaceSurfaceIntersection coclass

about GeSurfaceSurfaceIntersection coclass

GeSurfaceSurfaceIntersection interface

about IGeSurfaceSurfaceIntersection interface

GetIntersectionCofiguration

IGeSurfaceSurfaceIntersection members

IntersectionCount

IntersectionCurve

IntersectionDimension

IntersectionPoint

ParameterCurveOnSurface1

ParameterCurveOnSurface2

ParameterOnSurface1

ParameterOnSurface2

Set

Surface1

Surface2

Tolerance

GeSurfaceSurfaceIntersection::GetIntersectionCofiguration

GeSurfaceSurfaceIntersection::GetIntersectionCofiguration method

GeSurfaceSurfaceIntersection::IntersectionCount

GeSurfaceSurfaceIntersection::IntersectionCount property

GeSurfaceSurfaceIntersection::IntersectionCurve

GeSurfaceSurfaceIntersection::IntersectionCurve method

GeSurfaceSurfaceIntersection::IntersectionDimension

GeSurfaceSurfaceIntersection::IntersectionDimension method

GeSurfaceSurfaceIntersection::IntersectionPoint

GeSurfaceSurfaceIntersection::IntersectionPoint method

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface1

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface1 method

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface2

GeSurfaceSurfaceIntersection::ParameterCurveOnSurface2 method

GeSurfaceSurfaceIntersection::ParameterOnSurface1

GeSurfaceSurfaceIntersection::ParameterOnSurface1 method

GeSurfaceSurfaceIntersection::ParameterOnSurface2

GeSurfaceSurfaceIntersection::ParameterOnSurface2 method

GeSurfaceSurfaceIntersection::Set

GeSurfaceSurfaceIntersection::Set method

GeSurfaceSurfaceIntersection::Surface1

GeSurfaceSurfaceIntersection::Surface1 property

GeSurfaceSurfaceIntersection::Surface2

GeSurfaceSurfaceIntersection::Surface2 property

GeSurfaceSurfaceIntersection::Tolerance

GeSurfaceSurfaceIntersection::Tolerance property

GeSurfSurfIntConfiguration

GeSurfSurfIntConfiguration enumeration

GeSurfSurfIntType

GeSurfSurfIntType enumeration

Get

IGePoint interface

IGeVector interface

GetAllAttribs

IMcadFormulaEvaluator interface

GetAllAttribsData

IMcadFormulaEvaluator interface

GetAllAttributes

IMcadUtility interface

GetAllAttribValues

IMcadFormulaEvaluator interface

GetAllBOMTables

IMcadBOMMgr interface

GetAllIntersections

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

GetAllLayerObjs

IMcadLayerObjectMgr interface

GetAllLayers

IMcadLayerObjectMgr interface

GetAllPartReferences

IMcadBOMMgr4 interface

GetAllTemplates

IMcadNoteStandard interface

geTangent enumeration member

geTangentInside enumeration member

geTangentOutside enumeration member

GetArea

IGeCurve interface

GetAttachedViewportIds

IMcadScaleArea interface

GetAttachedViewportIds32

IMcadScaleArea interface

GetAttribute

IMcadBOMItem2 interface

GetAttributeClassFields

IAcadmApplication interface

GetAttributeFromID

IMcadUtility interface

GetAttributeFromID32

IMcadUtility interface

GetAttributes

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

GetBomOverride

IMcadBOMItem4 interface

IMcadPartReference3 interface

GetBOMTable

IMcadBOMMgr interface

GetBOMTableByCompDefHandle

IMcadBOMMgr3 interface

GetBOMTableByCompDefId

IMcadBOMMgr2 interface

GetBOMTableByCompDefId32

IMcadBOMMgr2 interface

GetBOMTableByName

IMcadBOMMgr2 interface

GetBorderBOMTable

IMcadBOMMgr2 interface

GetBoundary

IGeCurveBoundary interface

GetByStandard

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

GetCalculatedQuantity

IMcadBOMItem2 interface

GetCoefficients

IGePlane interface

GetColumn

IMcadBOMStandard interface

GetComplexStdPartsForMigr

IMcad2DStructureMgr interface

GetComplexStdPartViewsForMigr

IMcad2DStructureMgr interface

GetComponentDefinitions

IMcad2DStructureMgr interface

GetComponentInDefinition

IMcadComponent interface

GetComponentViewDefinitions

IMcad2DStructureMgr interface

GetCoordinateSystem

IGeMatrix interface

GetCurrentSymbolStandard

IMcadStandard interface

GetCurvature

IGeCurve interface

GetData

IMcadFormulaEvaluator interface

GetDefinitionData

IGeNurbCurve interface

IGeNurbSurface interface

GetDimensionType

IMcadTaperStandard2 interface

GetDrawingType

IMcadUtility3 interface

GetEvaluatedPartData

IMcadBOMMgr2 interface

GetFeatureTypes

IMcadNoteStandard interface

GetFieldIndex

IMcadAttribute interface

GetFitData

IGeNurbCurve interface

GetFolderDefinitions

IMcad2DStructureMgr interface

GetFolderPowerObjectsForMigr

IMcad2DStructureMgr interface

GetFormulaEvaluator

IAcadmApplication interface

GetGeometryFromPick

IMcadUtility interface

GetHidesSuppressState

IMcadFolderDefinition interface

GetIdsFromObject

IMcadUtility interface

GetIdsFromObject32

IMcadUtility interface

GetInstances

IMcadComponentDefinition interface

GetIntersectionCofiguration

IGeSurfaceSurfaceIntersection interface

GetIntersectionConfiguration

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

GetItemDefinition

IMcadBOMItem2 interface

GetItemDefinition32

IMcadBOMItem2 interface

GetItemPartDefinition

IMcadBOMItem3 interface

GetItemPartDefinition32

IMcadBOMItem3 interface

GetLayerGroupEntities

IMcadLayerGroupMgr interface

GetLayerGroupEntities32

IMcadLayerGroupMgr interface

GetLayerGroupNames

IMcadLayerGroupMgr interface

GetLayerObjProperty

IMcadLayerObjectMgr interface

GetLayerProperty

IMcadLayerObjectMgr interface

GetLayersFromGroup

IMcadLayerGroupMgr interface

GetLeader

IMcadSymbol interface

GetLeaderAttachment

IMcadSymbol interface

GetLength

IGeCurve interface

GetMoveObjectsIDs

IMcadTitleBorderContext interface

GetMoveObjectsIDs32

IMcadTitleBorderContext interface

GetMoveObjectsToPoint

IMcadTitleBorderContext interface

GetNextAnnotationViewDefinitionName

IMcad2DStructureMgr interface

GetNextComponentDefinitionName

IMcad2DStructureMgr interface

GetNextComponentViewDefinitionName

IMcadComponentDefinition interface

GetNextFolderDefinitionName

IMcad2DStructureMgr interface

GetObjectFromID

IMcadUtility interface

GetObjectFromID32

IMcadUtility interface

GetObjectFromPick

IMcadUtility interface

GeTolerance

GeTolerance coclass

about GeTolerance coclass

GeTolerance interface

about IGeTolerance interface

Application

EqualPoint

EqualVector

IGeTolerance members

GeTolerance::Application

GeTolerance::Application property

GeTolerance::EqualPoint

GeTolerance::EqualPoint property

GeTolerance::EqualVector

GeTolerance::EqualVector property

GeTorus

GeTorus coclass

about GeTorus coclass

GeTorus interface

about IGeTorus interface

AxisOfSymmetry

EndAngleInU

EndAngleInV

IGeTorus members

IntersectWith

IsClosedInU

IsClosedInV

MajorRadius

MinorRadius

Origin

ReferenceAxis

Set

StartAngleInU

StartAngleInV

GeTorus::AxisOfSymmetry

GeTorus::AxisOfSymmetry property

GeTorus::EndAngleInU

GeTorus::EndAngleInU property

GeTorus::EndAngleInV

GeTorus::EndAngleInV property

GeTorus::IntersectWith

GeTorus::IntersectWith method

GeTorus::IsClosedInU

GeTorus::IsClosedInU method

GeTorus::IsClosedInV

GeTorus::IsClosedInV method

GeTorus::MajorRadius

GeTorus::MajorRadius property

GeTorus::MinorRadius

GeTorus::MinorRadius property

GeTorus::Origin

GeTorus::Origin property

GeTorus::ReferenceAxis

GeTorus::ReferenceAxis property

GeTorus::Set

GeTorus::Set method

GeTorus::StartAngleInU

GeTorus::StartAngleInU property

GeTorus::StartAngleInV

GeTorus::StartAngleInV property

GetOverlapRanges

IGeCurveCurveIntersection interface

GetPartAttribute

IMcadBOMMgr2 interface

GetPartBalloons

IMcadBOMItem2 interface

GetPartData

IMcadBOMMgr interface

GetPartReference

IMcadTitleBorderContext interface

GetPartReference32

IMcadTitleBorderContext interface

GetPreDefinedList

IMcadColumnDefinition3 interface

GetProperties

IMcadBOM2 interface

GetProperties32

IMcadBOM2 interface

geTransverse enumeration member

GetReferenceLockMode

IMcad2DStructureMgr4 interface

GetReferences

IMcadBOMItem interface

GetReferences32

IMcadBOMItem interface

GetRevisionListFromRef

IMcadRevisionMgr interface

GetSamplePoints

IGeCurve interface

GetSelection

IMcad2DStructureMgr interface

GetShaftsForMigr

IMcad2DStructureMgr interface

GetSheetBOMTable

IMcadBOMMgr2 interface

GetSingleStdPartComponentsForMigr

IMcad2DStructureMgr interface

GetSingleStdPartViewsForMigr

IMcad2DStructureMgr interface

GetSplitCurves

IGeCurve interface

GetStandard

IMcadStandardMgr interface

GetStructuredChildItems

IMcadBOM3 interface

GetStructuredParentItem

IMcadBOM3 interface

GetStructureFromEntity

IMcad2DStructureMgr interface

GetStructureMode

IMcad2DStructureMgr4 interface

GetSurfIndLeader

IMcadDatumIdentifier3 interface

IMcadFeatureControlFrame4 interface

GetSymbolImplementation

IMcadFCFStandard interface

GetTemplateGroup

IMcadNoteStandard interface

GetTemplateValue

IMcadNoteStandard interface

GetTitleBorderFromRef

IMcadTitleBorderMgr interface

GetUOMName

IMcadBOMStandard2 interface

GetVersionNumber

IAcadmApplicationVersion interface

IMcadDocumentVersion interface

geUnknown enumeration member

geUnknownType enumeration member

GeVector

GeVector coclass

about GeVector coclass

GeVector interface

about IGeVector interface

AngleTo

Application

AsArray

CrossProduct

DotProduct

Get

IGeVector members

IsCodirectionalTo

IsEqualTo

IsParallelTo

IsPerpendicularTo

IsUnitLength

IsZeroLength

Item

Item

LargestElement

Length

Mirror

MultiplyBy

Negate

Negative

Normal

Normalize

PerpendicularVector

Product

Project

RotateBy

ScaleBy

Set

SetToProduct

SetToSum

Sum

TransformBy

X

Y

Z

GeVector::AngleTo

GeVector::AngleTo method

GeVector::Application

GeVector::Application property

GeVector::AsArray

GeVector::AsArray property

GeVector::CrossProduct

GeVector::CrossProduct method

GeVector::DotProduct

GeVector::DotProduct method

GeVector::Get

GeVector::Get method

GeVector::IsCodirectionalTo

GeVector::IsCodirectionalTo method

GeVector::IsEqualTo

GeVector::IsEqualTo method

GeVector::IsParallelTo

GeVector::IsParallelTo method

GeVector::IsPerpendicularTo

GeVector::IsPerpendicularTo method

GeVector::IsUnitLength

GeVector::IsUnitLength method

GeVector::IsZeroLength

GeVector::IsZeroLength method

GeVector::Item

GeVector::Item method

GeVector::LargestElement

GeVector::LargestElement property

GeVector::Length

GeVector::Length property

GeVector::Mirror

GeVector::Mirror method

GeVector::MultiplyBy

GeVector::MultiplyBy method

GeVector::Negate

GeVector::Negate method

GeVector::Negative

GeVector::Negative property

GeVector::Normal

GeVector::Normal property

GeVector::Normalize

GeVector::Normalize method

GeVector::PerpendicularVector

GeVector::PerpendicularVector method

GeVector::Product

GeVector::Product method

GeVector::Project

GeVector::Project method

GeVector::RotateBy

GeVector::RotateBy method

GeVector::ScaleBy

GeVector::ScaleBy method

GeVector::Set

GeVector::Set method

GeVector::SetToProduct

GeVector::SetToProduct method

GeVector::SetToSum

GeVector::SetToSum method

GeVector::Sum

GeVector::Sum method

GeVector::TransformBy

GeVector::TransformBy method

GeVector::X

GeVector::X property

GeVector::Y

GeVector::Y property

GeVector::Z

GeVector::Z property

GeVectors

GeVectors coclass

about GeVectors coclass

geVectors enumeration member

GeVectors interface

about IGeVectors interface

Add

Application

Count

IGeVectors members

Item

Remove

GeVectors::Add

GeVectors::Add method

GeVectors::Application

GeVectors::Application property

GeVectors::Count

GeVectors::Count property

GeVectors::Item

GeVectors::Item method

GeVectors::Remove

GeVectors::Remove method

GlobalToLocal

IGeCompositeCurve interface

GripFrameEnabled

IMcadPartList2 interface

IMcadPartListStandard3 interface

H

HalfAngle

IGeCone interface

HasAnnotationViewLabel

IMcadAnnotationViewDefinition2 interface

HasChanged

IMcadGeometry interface

HasComponentDefinition

IMcad2DStructureMgr interface

HasComponentViewDefinition

IMcadComponentDefinition interface

HasEndPoint

IGeCurve interface

HasEqualTypeWithView

IMcad2dComponentDescriptor interface

HasEqualTypeWithViewGroup

IMcad2dComplexStdPartCompGroupDescriptor interface

hasExternalDef

IMcadComponent interface

HasExternalDef

IMcadFolder interface

HasFitData

IGeNurbCurve interface

HasFolderDefinition

IMcad2DStructureMgr interface

HasGhostViews

IMcadComponent interface

HasLeader

IMcadTaper interface

HasOverrideProperties

IMcadComponent interface

IMcadFolder interface

HasStartPoint

IGeCurve interface

HatchAngle

IMcadDatumStandard interface

HatchDistance

IMcadDatumStandard interface

HeadingGap

IMcadPartListStandard interface

HeadingHeight

IMcadPartListStandard interface

HeadingTextColor

IMcadPartListStandard interface

HeadingTextControl

IMcadPartList2 interface

IMcadPartListStandard3 interface

HeadingTextHeight

IMcadPartListStandard interface

HeadingTextMarginBottom

IMcadPartListStandard3 interface

HeadingTextMarginLeft

IMcadPartListStandard3 interface

HeadingTextMarginRight

IMcadPartListStandard3 interface

HeadingTextMarginTop

IMcadPartListStandard3 interface

HeadingTextStyle

IMcadPartListStandard3 interface

HeadingTextTrueColor

IMcadPartListStandard2 interface

Height

IGeCone interface

IGeCylinder interface

IMcadPartList interface

HeightAt

IGeCone interface

HiddenLeaderLineType

IMcadDatumStandard interface

HiddenLeaderLineTypeName

IMcadDatumStandard interface

HiddenLinesInvisible

IMcadComplexHideSituation interface

IMcadHideSituation interface

Hide

IMcadLayerObjectCfg interface

HideAppropriateObjectsOnly

IMcadComplexHideSituation interface

IMcadHideSituation interface

HideSituations

IMcadComplexHideSituation interface

IMcadFolderDefinition interface

Highlight

IMcad2DStructureMgr interface

IMcadObject interface

HighlightSubWelding

IMcadWelding interface

Holders

IMcadAttribute interface

I

IdentificationLine

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

IdentificationLineAllowed

IMcadWeldingStandard interface

IdentificationLineGap

IMcadWeldingStandard interface

IdentificationLinetype

IMcadWeldingStandard interface

IdentificationLinetypeName

IMcadWeldingStandard interface

IdentifierExcludeCharacters

IMcadSectionLineStandard2 interface

IdentifierOffset

IMcadSectionLineStandard2 interface

IdentifierOutsideBoundary

IMcadDetailSymbolStandard2 interface

IdentifierPosition

IMcadSectionLineStandard2 interface

IdentifierStandard

IMcadStandard interface

IgnoreBgExclude

IMcadHideSituation interface

IgnoreFgExclude

IMcadHideSituation interface

IgnoreUpperBgExclude

IMcadHideSituation interface

imCSV enumeration member

imDB5 enumeration member

imDBIII enumeration member

imDBIV enumeration member

imEXCEL95 enumeration member

imEXCEL97 enumeration member

imFOX25 enumeration member

imFOX26 enumeration member

imimFOXVIS enumeration member

imMDB enumeration member

ImportBOM

IMcadBOMMgr interface

ImportBOM2

IMcadBOMMgr2 interface

ImportLayerObj

IMcadLayerObjectMgr interface

ImportPartList

IMcadBOMMgr2 interface

imTXT enumeration member

in enumeration member

InActive

IMcadTitle interface

Index

IMcadColumnDefinition interface

IndexTotalValue

IMcadWelding interface

IMcadWelding interface

IndexValue

IMcadWelding interface

IMcadWelding interface

InitFromHide

IMcadComplexHideSituation interface

Insert

IGeKnotVector interface

InsertInvertPart

IMcadTitleBorderStandard2 interface

InsertKnot

IGeKnotVector interface

InsertLeaderNode

IMcadSymbol interface

InsertProcess

IMcadWelding2 interface

Inspect

IMcadTaper interface

InstanceCount

IMcadFolderDefinition interface

Instances

IMcadFolderDefinition interface

InstancesDefinition

IMcadFolderDefinition interface

IntersectionCount

IGeSurfaceSurfaceIntersection interface

IntersectionCurve

IGeSurfaceSurfaceIntersection interface

IntersectionDimension

IGeSurfaceSurfaceIntersection interface

IntersectionPoint

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeSurfaceSurfaceIntersection interface

IntersectionPointCount

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IntersectionPointTolerance

IGeCurveCurveIntersection interface

IntersectWith

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

IGeLinearEntity interface

IGePlane interface

IGeSphere interface

IGeTorus interface

IntersectWithCurve

IGeCurve interface

IntersectWithSurface

IGeCurve interface

IGeSurface interface

Interval

IGeApplication interface

IGeCurve interface

IGeKnotVector interface

IntervalRange1

IGeCurveCurveIntersection interface

IntervalRange2

IGeCurveCurveIntersection interface

Introduction

Inverse

IGeMatrix interface

InverseForeground

IMcadHideSituation interface

Invert

IGeMatrix interface

InvertPartBorderHeight

IMcadTitleBorderStandard2 interface

InvertPartBorderWidth

IMcadTitleBorderStandard2 interface

InvertPartTextHeight

IMcadTitleBorderStandard2 interface

Invisible

IMcadLayerCfg interface

is2D

IMcadComponent interface

IMcadComponentDefinition interface

is2DAssembly

IMcadComponentDefinition interface

Is2DStructureEnabled

IMcad2DStructureMgr interface

IsAllAround

IMcadEdgeLibraryObject interface

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsAnnotation

IMcadFolderDefinition interface

IsAssociativeDetail

IMcadDetailSymbol interface

IsAttached

IMcadSymbol interface

IsAuxiliaryArrowUsed

IMcadBalloonStandard interface

IsBorder

IMcadBOM3 interface

IsBox

IGeBoundBlock interface

IsCircular

IGeEllipticalArc interface

IsClosed

IGeCone interface

IGeCurve interface

IsClosedInU

IGeNurbSurface interface

IGeSphere interface

IGeTorus interface

IsClosedInV

IGeNurbSurface interface

IGeTorus interface

IsCodirectionalTo

IGeVector interface

IsColinearTo

IGeLinearEntity interface

IsComplexHideLevel

IMcadHideSituation interface

IsContinuousAtUpper

IGeInterval interface

IsCoplanarWith

IGeCurve interface

IGePlane interface

IsCustomBlockUsed

IMcadBalloon interface

IMcadBalloonStandard interface

IMcadPartList interface

IMcadPartListStandard interface

IsDatumIDSupported

IMcadIdentifierStandard interface

isDefault

IMcadSymbolLibraryObject interface

IsDefinedDirection

IMcadEdgeLibraryObject interface

IsDegenerate

IGeCurve interface

IGeCurveBoundary interface

IsDetail

IMcadFolderDefinition interface

IsDisjoint

IGeBoundBlock interface

IGeInterval interface

IsEditable

IMcadFormulaEvaluator interface

IsEmpty

IGeKnotVector interface

IsEntityAllowed

IMcad2DStructureMgr interface

IsEqualTo

IGeEntity interface

IGeKnotVector interface

IGeMatrix interface

IGeVector interface

IMcadObject interface

IsExpandable

IMcadBOMItem interface

IsExternal

IMcadComponentDefinition interface

IMcadFolderDefinition interface

isFeature

IMcadComponentDefinition interface

IMcadComponentView interface

IsFeature

IMcadComponentViewDefinition interface

IsFeatureIDSupported

IMcadIdentifierStandard interface

IsForceTail

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsFreeEntity

IMcad2DStructureMgr interface

IsGhostView

IMcadComponentView interface

IsHeadingEnabled

IMcadPartList interface

IMcadPartListStandard interface

IsInActiveTarget

IMcad2DStructureMgr interface

IsInside

IGeCircularArc interface

IGeEllipticalArc interface

IsInstance

IMcadFolder interface

isItemExist

IMcadSymbolLibrary interface

IsLastLevel

IMcadHideSituation interface

IsLeaf

IMcadFolder interface

IsLeafNode

IMcadComponentDefinition interface

IsLeftOriented

IMcadNote interface

IsLinear

IGeCurve interface

IsLocked

IMcadFolder interface

IMcadFolderDefinition interface

IsMajority

IMcadEdgeLibraryObject interface

IMcadSurfaceTexture interface

IMcadSurfaceTextureLibraryObject interface

IsMetric

IMcadStandard interface

IsMigrated

IMcadHideSituation interface

IsModifiedStandardPartHide

IMcadComplexHideSituation interface

IMcadHideSituation interface

IsOn

IGeEntity interface

IMcadPartListFilter interface

IsOnInterval

IGeCurve interface

IsOnPlane

IGeLinearEntity interface

IsOrthogonal

IGeMatrix interface

IsOverlapAtUpper

IGeInterval interface

IsParallelTo

IGeLinearEntity interface

IGePlane interface

IGeVector interface

IsPeriodic

IGeCurve interface

IsPeriodicInU

IGeNurbSurface interface

IsPeriodicInV

IGeNurbSurface interface

IsPerpendicularTo

IGeLinearEntity interface

IGePlane interface

IGeVector interface

IsPlanar

IGeCurve interface

IsPreDefinedList

IMcadColumnDefinition3 interface

IsRational

IGeNurbCurve interface

IsRationalInU

IGeNurbSurface interface

IsRationalInV

IGeNurbSurface interface

IsRequirementSupported

IMcadSurfaceTextureStandard2 interface

IsRoot

IMcadComponentDefinition interface

IMcadFolderDefinition interface

isShaft

IMcadComponentDefinition interface

IsSingleton

IGeInterval interface

IsSingular

IGeMatrix interface

isStandardPart

IMcadComponentDefinition interface

IsStandardPartHide

IMcadComplexHideSituation interface

IMcadHideSituation interface

IsStructureBlock

IMcad2DStructureMgr interface

IsSubentityOf

IMcadFolder interface

IsTangential

IGeCurveCurveIntersection interface

IsTitleEnabled

IMcadPartList interface

IMcadPartListStandard interface

IsTransversal

IGeCurveCurveIntersection interface

IsUnBounded

IGeInterval interface

IsUniformScaledOrtho

IGeMatrix interface

IsUnitLength

IGeVector interface

IsVisible

IMcadBOM3 interface

IMcadColumnDefinition2 interface

IsZeroLength

IGeVector interface

Item

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGeKnotVector interface

IGeKnotVector interface

IGeMatrix interface

IGeMatrix interface

IGePoint interface

IGePoint interface

IGePoints interface

IGeSurfaces interface

IGeVector interface

IGeVector interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadDocuments interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadRevisionList interface

IMcadRevisionLists interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

IMcadTitleBorders interface

ItemList

IMcadPartList interface

ItemNumber

IMcadBOMItem interface

Items

IMcadBOM interface

J

JointStandard

IMcadStandard4 interface

JoinWith

IGeNurbCurve interface

K

Key

IMcadLayerCfg interface

KnotAt

IGeNurbCurve interface

IGeNurbCurve interface

KnotCount

IGeNurbCurve interface

Knots

IGeNurbCurve interface

KnotVector

IGeApplication interface

L

l enumeration member

LabelAbove

IMcadDetailSymbolLabel interface

IMcadDetailSymbolStandard interface

IMcadSectionLineStandard interface

LabelEntity

IMcadDetailSymbol interface

LabelEntityOffset

IMcadDetailSymbol interface

LabelName

IMcadDetailSymbol interface

IMcadSectionLine interface

LabelNamesCount

IMcadSectionLine interface

LabelOffset

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelPattern

IMcadAnnotationViewLabel interface

IMcadAnnotationViewStandard interface

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

IMcadSectionLine interface

IMcadSectionLineStandard interface

LabelPatternVariables

IMcadAnnotationViewStandard interface

LabelPosition

IMcadAnnotationViewStandard interface

LabelText

IMcadAnnotationViewLabel interface

IMcadDetailSymbol interface

IMcadDetailSymbolLabel interface

IMcadSectionLine interface

LabelTextColor

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelTextHeight

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelTextStyle

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

LabelVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

Landing

IMcadNote interface

IMcadNoteStandard interface

LargestElement

IGeVector interface

LayDirection

IMcadSurfaceTexture interface

LayDirectionValue

IMcadSurfaceTexture interface

LayerGroupMgr

IMcadDocument interface

LayerName

IMcadLayerObjectCfg interface

LayerObjectMgr

IMcadDocument interface

LayerObjKey

IMcadLayerObjectCfg interface

lb enumeration member

LeaderArrowType

IMcadSymbol interface

IMcadSymbol interface

LeaderAttachPoint

IMcadNote interface

IMcadNoteStandard interface

LeaderColor

IMcadStandard interface

IMcadSymbol interface

IMcadSymbol interface

LeaderCount

IMcadSymbol interface

LeaderLanding

IMcadSymbol interface

IMcadSymbol interface

LeaderLineType

IMcadSymbol interface

IMcadSymbol interface

LeaderLinetypeHidden

IMcadDatumTarget interface

LeaderTrueColor

IMcadStandard2 interface

IMcadSymbolStandard2 interface

Length

IGeInterval interface

IGeKnotVector interface

IGeVector interface

LengthScalingFactor

IMcadScaleArea interface

LengthValue

IMcadWelding interface

IMcadWelding interface

LevelCount

IMcadComplexHideSituation interface

LevelIndex

IMcadHideSituation interface

Line

IGeApplication interface

LineColor

IMcadSectionLineStandard interface

LineEndPoint

IMcadDatumTarget interface

LineFactor

IMcadDatumTarget interface

LineMidPoint

IMcadDatumTarget interface

LineSegment

IGeApplication interface

LineTrueColor

IMcadSectionLineStandard interface

LineType

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineTypeId

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineTypeId32

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

LineVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

LineWeight

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

IMcadSectionLineStandard interface

loadItem

IMcadSymbolLibrary interface

loadItemToSubWelding

IMcadWeldingLibrary interface

LocalClosestPointTo

IGeCurve interface

LocalClosestPointToCurve

IGeCurve interface

Localize

IMcadFolderDefinition interface

Localize2DS

IMcadComponentDefinition interface

LocalToGlobal

IGeCompositeCurve interface

LockType

IMcadFolderDefinition interface

LookupLevelName

IMcadComplexHideSituation interface

LookupViewName

IMcadFolderDefinition interface

Lower

IGeInterval interface

lqd_oz enumeration member

M

m enumeration member

MajorAxis

IGeEllipticalArc interface

Majority

IMcadEdge interface

MajorityAllowed

IMcadEdgeStandard interface

IMcadSurfaceTextureStandard interface

MajorRadius

IGeEllipticalArc interface

IGeTorus interface

MakeClosed

IGeNurbCurve interface

MakePeriodic

IGeNurbCurve interface

MakePersistent

IMcadObject interface

MakeRational

IGeNurbCurve interface

MappingName

IMcadPartList interface

MarkStampStandard

IMcadStandard3 interface

Matrix

IGeApplication interface

MaximumColumns

IMcadBalloonStandard interface

MaximumSpacingValue

IMcadSurfaceTexture interface

MaxPoint

IGeBoundBlock interface

MaxValue

IMcadEdge interface

mc2DSAllRef enumeration member

mc2DSAuxiliaryView enumeration member

mc2DSBackView enumeration member

mc2DSBGEnt enumeration member

mc2DSBGExclEnt enumeration member

mc2DSBottomView enumeration member

mc2DSDetailView enumeration member

mc2DSDirectRef enumeration member

mc2DSFGEnt enumeration member

mc2DSFGExclEnt enumeration member

mc2DSFrontView enumeration member

mc2DSHalfSectionView enumeration member

mc2DSHalfSectionVisibleView enumeration member

mc2DSNoEnt enumeration member

mc2DSNoLock enumeration member

mc2DSPartialRef enumeration member

mc2DSPartialView enumeration member

mc2DSSectionView enumeration member

mc2DSSideLeftView enumeration member

mc2DSSideRightView enumeration member

mc2DSSideView enumeration member

mc2DSStdPartLock enumeration member

mc2DSSubEntRef enumeration member

mc2DSTopView enumeration member

mc2DSUndefinedView enumeration member

mc2DSUpperBGExclEnt enumeration member

mc2DSUserLock enumeration member

mc2DSXrefLock enumeration member

mcAaugmentedLine enumeration member

mcAcad enumeration member

mcAcadM enumeration member

mcAcadMStruct enumeration member

Mcad2dComplexStdPartCompGroupDescriptor

Mcad2dComplexStdPartCompGroupDescriptor coclass

about Mcad2dComplexStdPartCompGroupDescriptor coclass

Mcad2dComplexStdPartCompGroupDescriptor interface

about IMcad2dComplexStdPartCompGroupDescriptor interface

AddView

HasEqualTypeWithViewGroup

IMcad2dComplexStdPartCompGroupDescriptor members

MigrateTo2DStructure

RemoveView

Views

Mcad2dComplexStdPartCompGroupDescriptor::AddView

Mcad2dComplexStdPartCompGroupDescriptor::AddView method

Mcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup

Mcad2dComplexStdPartCompGroupDescriptor::HasEqualTypeWithViewGroup method

Mcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure

Mcad2dComplexStdPartCompGroupDescriptor::MigrateTo2DStructure method

Mcad2dComplexStdPartCompGroupDescriptor::RemoveView

Mcad2dComplexStdPartCompGroupDescriptor::RemoveView method

Mcad2dComplexStdPartCompGroupDescriptor::Views

Mcad2dComplexStdPartCompGroupDescriptor::Views property

Mcad2dComponentDescriptor

Mcad2dComponentDescriptor coclass

about Mcad2dComponentDescriptor coclass

Mcad2dComponentDescriptor interface

about IMcad2dComponentDescriptor interface

AddComponentView

Component

ComponentDefinition

ComponentViews

CreateComponent

HasEqualTypeWithView

IMcad2dComponentDescriptor members

OwningComponentDefinition

RemoveComponentView

Mcad2dComponentDescriptor::AddComponentView

Mcad2dComponentDescriptor::AddComponentView method

Mcad2dComponentDescriptor::Component

Mcad2dComponentDescriptor::Component property

Mcad2dComponentDescriptor::ComponentDefinition

Mcad2dComponentDescriptor::ComponentDefinition property

Mcad2dComponentDescriptor::ComponentViews

Mcad2dComponentDescriptor::ComponentViews property

Mcad2dComponentDescriptor::CreateComponent

Mcad2dComponentDescriptor::CreateComponent method

Mcad2dComponentDescriptor::HasEqualTypeWithView

Mcad2dComponentDescriptor::HasEqualTypeWithView method

Mcad2dComponentDescriptor::OwningComponentDefinition

Mcad2dComponentDescriptor::OwningComponentDefinition property

Mcad2dComponentDescriptor::RemoveComponentView

Mcad2dComponentDescriptor::RemoveComponentView method

Mcad2dShaftCompGroupDescriptor

Mcad2dShaftCompGroupDescriptor coclass

about Mcad2dShaftCompGroupDescriptor coclass

Mcad2dShaftCompGroupDescriptor interface

about IMcad2dShaftCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor members

MigrateTo2DStructure

Views

Mcad2dShaftCompGroupDescriptor::MigrateTo2DStructure

Mcad2dShaftCompGroupDescriptor::MigrateTo2DStructure method

Mcad2dShaftCompGroupDescriptor::Views

Mcad2dShaftCompGroupDescriptor::Views property

Mcad2DSPreview

Mcad2dStdPartComponentDescriptor

Mcad2dStdPartComponentDescriptor coclass

about Mcad2dStdPartComponentDescriptor coclass

Mcad2dStdPartComponentDescriptor interface

about IMcad2dStdPartComponentDescriptor interface

Mcad2DStructureDescriptor

Mcad2DStructureDescriptor coclass

about Mcad2DStructureDescriptor coclass

Mcad2DStructureDescriptor interface

about IMcad2DStructureDescriptor interface

IMcad2DStructureDescriptor members

Name

Mcad2DStructureDescriptor::Name

Mcad2DStructureDescriptor::Name property

Mcad2DStructureMgr

Mcad2DStructureMgr coclass

about Mcad2DStructureMgr coclass

Mcad2DStructureMgr interface

about IMcad2DStructureMgr interface

AddNewAnnotationViewDefinition

AddNewComponentDefinition

AddNewComponentView

AddNewComponentViewDefinition

AddNewFolder

AddNewFolderDefinition

Application

CopyComponentFromDatabase

CopyFolderFromDatabase

Create2dComplexStdPartCompGroupDescriptor

Create2dComponentDescriptor

Create2dStdPartComponentDescriptor

CreateBlocksFromStructure

CreateComponentViewDescriptor

CreateFolderDescriptor

CreateStructureFromBlocks

EditTarget

ExternalStructureDatabases

GetComplexStdPartsForMigr

GetComplexStdPartViewsForMigr

GetComponentDefinitions

GetComponentViewDefinitions

GetFolderDefinitions

GetFolderPowerObjectsForMigr

GetNextAnnotationViewDefinitionName

GetNextComponentDefinitionName

GetNextFolderDefinitionName

GetSelection

GetShaftsForMigr

GetSingleStdPartComponentsForMigr

GetSingleStdPartViewsForMigr

GetStructureFromEntity

HasComponentDefinition

HasFolderDefinition

Highlight

IMcad2DStructureMgr members

Is2DStructureEnabled

IsEntityAllowed

IsFreeEntity

IsInActiveTarget

IsStructureBlock

PurgeAll2DS

PurgeAnnotationViewDefinitions

PurgeComponentDefinitions

PurgeComponentViewDefinitions

PurgeFolderDefinitions

RestructureViews

RootComponentDefinition

RootViewDefinition

Update

UpdateEntities

Mcad2DStructureMgr::AddNewAnnotationViewDefinition

Mcad2DStructureMgr::AddNewAnnotationViewDefinition method

Mcad2DStructureMgr::AddNewComponentDefinition

Mcad2DStructureMgr::AddNewComponentDefinition method

Mcad2DStructureMgr::AddNewComponentView

Mcad2DStructureMgr::AddNewComponentView method

Mcad2DStructureMgr::AddNewComponentViewDefinition

Mcad2DStructureMgr::AddNewComponentViewDefinition method

Mcad2DStructureMgr::AddNewFolder

Mcad2DStructureMgr::AddNewFolder method

Mcad2DStructureMgr::AddNewFolderDefinition

Mcad2DStructureMgr::AddNewFolderDefinition method

Mcad2DStructureMgr::Application

Mcad2DStructureMgr::Application property

Mcad2DStructureMgr::CopyComponentFromDatabase

Mcad2DStructureMgr::CopyComponentFromDatabase method

Mcad2DStructureMgr::CopyFolderFromDatabase

Mcad2DStructureMgr::CopyFolderFromDatabase method

Mcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor

Mcad2DStructureMgr::Create2dComplexStdPartCompGroupDescriptor method

Mcad2DStructureMgr::Create2dComponentDescriptor

Mcad2DStructureMgr::Create2dComponentDescriptor method

Mcad2DStructureMgr::Create2dStdPartComponentDescriptor

Mcad2DStructureMgr::Create2dStdPartComponentDescriptor method

Mcad2DStructureMgr::CreateBlocksFromStructure

Mcad2DStructureMgr::CreateBlocksFromStructure method

Mcad2DStructureMgr::CreateComponentViewDescriptor

Mcad2DStructureMgr::CreateComponentViewDescriptor method

Mcad2DStructureMgr::CreateFolderDescriptor

Mcad2DStructureMgr::CreateFolderDescriptor method

Mcad2DStructureMgr::CreateStructureFromBlocks

Mcad2DStructureMgr::CreateStructureFromBlocks method

Mcad2DStructureMgr::EditTarget

Mcad2DStructureMgr::EditTarget property

Mcad2DStructureMgr::ExternalStructureDatabases

Mcad2DStructureMgr::ExternalStructureDatabases method

Mcad2DStructureMgr::GetComplexStdPartsForMigr

Mcad2DStructureMgr::GetComplexStdPartsForMigr method

Mcad2DStructureMgr::GetComplexStdPartViewsForMigr

Mcad2DStructureMgr::GetComplexStdPartViewsForMigr method

Mcad2DStructureMgr::GetComponentDefinitions

Mcad2DStructureMgr::GetComponentDefinitions method

Mcad2DStructureMgr::GetComponentViewDefinitions

Mcad2DStructureMgr::GetComponentViewDefinitions method

Mcad2DStructureMgr::GetFolderDefinitions

Mcad2DStructureMgr::GetFolderDefinitions method

Mcad2DStructureMgr::GetFolderPowerObjectsForMigr

Mcad2DStructureMgr::GetFolderPowerObjectsForMigr method

Mcad2DStructureMgr::GetNextAnnotationViewDefinitionName

Mcad2DStructureMgr::GetNextAnnotationViewDefinitionName method

Mcad2DStructureMgr::GetNextComponentDefinitionName

Mcad2DStructureMgr::GetNextComponentDefinitionName method

Mcad2DStructureMgr::GetNextFolderDefinitionName

Mcad2DStructureMgr::GetNextFolderDefinitionName method

Mcad2DStructureMgr::GetSelection

Mcad2DStructureMgr::GetSelection method

Mcad2DStructureMgr::GetShaftsForMigr

Mcad2DStructureMgr::GetShaftsForMigr method

Mcad2DStructureMgr::GetSingleStdPartComponentsForMigr

Mcad2DStructureMgr::GetSingleStdPartComponentsForMigr method

Mcad2DStructureMgr::GetSingleStdPartViewsForMigr

Mcad2DStructureMgr::GetSingleStdPartViewsForMigr method

Mcad2DStructureMgr::GetStructureFromEntity

Mcad2DStructureMgr::GetStructureFromEntity method

Mcad2DStructureMgr::HasComponentDefinition

Mcad2DStructureMgr::HasComponentDefinition method

Mcad2DStructureMgr::HasFolderDefinition

Mcad2DStructureMgr::HasFolderDefinition method

Mcad2DStructureMgr::Highlight

Mcad2DStructureMgr::Highlight method

Mcad2DStructureMgr::Is2DStructureEnabled

Mcad2DStructureMgr::Is2DStructureEnabled method

Mcad2DStructureMgr::IsEntityAllowed

Mcad2DStructureMgr::IsEntityAllowed method

Mcad2DStructureMgr::IsFreeEntity

Mcad2DStructureMgr::IsFreeEntity method

Mcad2DStructureMgr::IsInActiveTarget

Mcad2DStructureMgr::IsInActiveTarget method

Mcad2DStructureMgr::IsStructureBlock

Mcad2DStructureMgr::IsStructureBlock method

Mcad2DStructureMgr::PurgeAll2DS

Mcad2DStructureMgr::PurgeAll2DS method

Mcad2DStructureMgr::PurgeAnnotationViewDefinitions

Mcad2DStructureMgr::PurgeAnnotationViewDefinitions method

Mcad2DStructureMgr::PurgeComponentDefinitions

Mcad2DStructureMgr::PurgeComponentDefinitions method

Mcad2DStructureMgr::PurgeComponentViewDefinitions

Mcad2DStructureMgr::PurgeComponentViewDefinitions method

Mcad2DStructureMgr::PurgeFolderDefinitions

Mcad2DStructureMgr::PurgeFolderDefinitions method

Mcad2DStructureMgr::RestructureViews

Mcad2DStructureMgr::RestructureViews method

Mcad2DStructureMgr::RootComponentDefinition

Mcad2DStructureMgr::RootComponentDefinition method

Mcad2DStructureMgr::RootViewDefinition

Mcad2DStructureMgr::RootViewDefinition method

Mcad2DStructureMgr::Update

Mcad2DStructureMgr::Update method

Mcad2DStructureMgr::UpdateEntities

Mcad2DStructureMgr::UpdateEntities method

Mcad2DStructureMgr2

Mcad2DStructureMgr2 interface

about IMcad2DStructureMgr2 interface

IMcad2DStructureMgr2 members

StartTransaction

Mcad2DStructureMgr2::StartTransaction

Mcad2DStructureMgr2::StartTransaction property

Mcad2DStructureMgr3

Mcad2DStructureMgr3 interface

about IMcad2DStructureMgr3 interface

AddNewAnnotationView

AddNewAnnotationViewDefinition

IMcad2DStructureMgr3 members

UpdateEntities

Mcad2DStructureMgr3::AddNewAnnotationView

Mcad2DStructureMgr3::AddNewAnnotationView method

Mcad2DStructureMgr3::AddNewAnnotationViewDefinition

Mcad2DStructureMgr3::AddNewAnnotationViewDefinition method

Mcad2DStructureMgr3::UpdateEntities

Mcad2DStructureMgr3::UpdateEntities method

Mcad2DStructureMgr4

Mcad2DStructureMgr4 interface

about IMcad2DStructureMgr4 interface

GetReferenceLockMode

GetStructureMode

IMcad2DStructureMgr4 members

SelectionLockMode

SelectionOrderMode

SetReferenceLockMode

SetStructureMode

Mcad2DStructureMgr4::GetReferenceLockMode

Mcad2DStructureMgr4::GetReferenceLockMode method

Mcad2DStructureMgr4::GetStructureMode

Mcad2DStructureMgr4::GetStructureMode method

Mcad2DStructureMgr4::SelectionLockMode

Mcad2DStructureMgr4::SelectionLockMode property

Mcad2DStructureMgr4::SelectionOrderMode

Mcad2DStructureMgr4::SelectionOrderMode property

Mcad2DStructureMgr4::SetReferenceLockMode

Mcad2DStructureMgr4::SetReferenceLockMode method

Mcad2DStructureMgr4::SetStructureMode

Mcad2DStructureMgr4::SetStructureMode method

Mcad2DStructureMgr5

Mcad2DStructureMgr5 interface

about IMcad2DStructureMgr5 interface

CreateRootViewDefinition

ExistsStructure

IMcad2DStructureMgr5 members

Mcad2DStructureMgr5::CreateRootViewDefinition

Mcad2DStructureMgr5::CreateRootViewDefinition method

Mcad2DStructureMgr5::ExistsStructure

Mcad2DStructureMgr5::ExistsStructure method

Mcad2DSViewType

Mcad2DSViewType enumeration

McadAlignmentType

McadAlignmentType enumeration

McadAnnotationViewDefinition

McadAnnotationViewDefinition coclass

about McadAnnotationViewDefinition coclass

McadAnnotationViewDefinition interface

about IMcadAnnotationViewDefinition interface

AddComponentView

ComponentDefinition

IMcadAnnotationViewDefinition members

RemoveComponentView

McadAnnotationViewDefinition::AddComponentView

McadAnnotationViewDefinition::AddComponentView method

McadAnnotationViewDefinition::ComponentDefinition

McadAnnotationViewDefinition::ComponentDefinition property

McadAnnotationViewDefinition::RemoveComponentView

McadAnnotationViewDefinition::RemoveComponentView method

McadAnnotationViewDefinition2

McadAnnotationViewDefinition2 interface

about IMcadAnnotationViewDefinition2 interface

AnnotationViewLabel

AnnotationViewLabelPattern

AnnotationViewLabelPattern

CreateAnnotationViewLabel

CreateAnnotationViewLabels

EraseAnnotationViewLabel

HasAnnotationViewLabel

IMcadAnnotationViewDefinition2 members

McadAnnotationViewDefinition2::AnnotationViewLabel

McadAnnotationViewDefinition2::AnnotationViewLabel method

McadAnnotationViewDefinition2::AnnotationViewLabelPattern

McadAnnotationViewDefinition2::AnnotationViewLabelPattern method

McadAnnotationViewDefinition2::CreateAnnotationViewLabel

McadAnnotationViewDefinition2::CreateAnnotationViewLabel method

McadAnnotationViewDefinition2::CreateAnnotationViewLabels

McadAnnotationViewDefinition2::CreateAnnotationViewLabels method

McadAnnotationViewDefinition2::EraseAnnotationViewLabel

McadAnnotationViewDefinition2::EraseAnnotationViewLabel method

McadAnnotationViewDefinition2::HasAnnotationViewLabel

McadAnnotationViewDefinition2::HasAnnotationViewLabel method

McadAnnotationViewDefinitions

McadAnnotationViewDefinitions coclass

about McadAnnotationViewDefinitions coclass

McadAnnotationViewDefinitions interface

about IMcadAnnotationViewDefinitions interface

Add

Application

Count

IMcadAnnotationViewDefinitions members

Item

Remove

McadAnnotationViewDefinitions::Add

McadAnnotationViewDefinitions::Add method

McadAnnotationViewDefinitions::Application

McadAnnotationViewDefinitions::Application property

McadAnnotationViewDefinitions::Count

McadAnnotationViewDefinitions::Count property

McadAnnotationViewDefinitions::Item

McadAnnotationViewDefinitions::Item method

McadAnnotationViewDefinitions::Remove

McadAnnotationViewDefinitions::Remove method

McadAnnotationViewLabel

McadAnnotationViewLabel coclass

about McadAnnotationViewLabel coclass

McadAnnotationViewLabel interface

about IMcadAnnotationViewLabel interface

IMcadAnnotationViewLabel members

LabelPattern

LabelText

McadAnnotationViewLabel::LabelPattern

McadAnnotationViewLabel::LabelPattern property

McadAnnotationViewLabel::LabelText

McadAnnotationViewLabel::LabelText property

McadAnnotationViewStandard

McadAnnotationViewStandard coclass

about McadAnnotationViewStandard coclass

McadAnnotationViewStandard interface

about IMcadAnnotationViewStandard interface

IMcadAnnotationViewStandard members

LabelPattern

LabelPatternVariables

LabelPosition

McadAnnotationViewStandard::LabelPattern

McadAnnotationViewStandard::LabelPattern property

McadAnnotationViewStandard::LabelPatternVariables

McadAnnotationViewStandard::LabelPatternVariables property

McadAnnotationViewStandard::LabelPosition

McadAnnotationViewStandard::LabelPosition property

McadAnnotViewLabelPositionType

McadAnnotViewLabelPositionType enumeration

McadArc

McadArc coclass

about McadArc coclass

McadArc interface

about IMcadArc interface

McadArrowType

McadArrowType enumeration

McadAttachmentPoint

McadAttachmentPoint enumeration

McadAttachmentType

McadAttachmentType enumeration

McadAttachPosition

McadAttachPosition enumeration

McadAttribute

McadAttribute coclass

about McadAttribute coclass

McadAttribute interface

about IMcadAttribute interface

Application

ClassName

Document

FieldCount

FieldDescription

FieldName

FieldType

FieldValue

FieldValue

FieldValue32

FieldValue32

GetFieldIndex

Holders

IMcadAttribute members

ObjectID

ObjectID32

McadAttribute::Application

McadAttribute::Application property

McadAttribute::ClassName

McadAttribute::ClassName property

McadAttribute::Document

McadAttribute::Document property

McadAttribute::FieldCount

McadAttribute::FieldCount property

McadAttribute::FieldDescription

McadAttribute::FieldDescription method

McadAttribute::FieldName

McadAttribute::FieldName method

McadAttribute::FieldType

McadAttribute::FieldType method

McadAttribute::FieldValue

McadAttribute::FieldValue method

McadAttribute::FieldValue32

McadAttribute::FieldValue32 method

McadAttribute::GetFieldIndex

McadAttribute::GetFieldIndex method

McadAttribute::Holders

McadAttribute::Holders property

McadAttribute::ObjectID

McadAttribute::ObjectID property

McadAttribute::ObjectID32

McadAttribute::ObjectID32 property

McadAttributeAssociativity

McadAttributeAssociativity enumeration

McadAttributeField

McadAttributeField coclass

about McadAttributeField coclass

McadAttributeField interface

about IMcadAttributeField interface

Application

Description

FieldType

IMcadAttributeField members

Name

Static

McadAttributeField::Application

McadAttributeField::Application property

McadAttributeField::Description

McadAttributeField::Description property

McadAttributeField::FieldType

McadAttributeField::FieldType property

McadAttributeField::Name

McadAttributeField::Name property

McadAttributeField::Static

McadAttributeField::Static property

McadAttributeFields

McadAttributeFields coclass

about McadAttributeFields coclass

McadAttributeFields interface

about IMcadAttributeFields interface

Add

Application

Count

IMcadAttributeFields members

Item

Remove

McadAttributeFields::Add

McadAttributeFields::Add method

McadAttributeFields::Application

McadAttributeFields::Application property

McadAttributeFields::Count

McadAttributeFields::Count property

McadAttributeFields::Item

McadAttributeFields::Item method

McadAttributeFields::Remove

McadAttributeFields::Remove method

McadAttributes

McadAttributes coclass

about McadAttributes coclass

McadAttributes interface

about IMcadAttributes interface

Add

Application

Count

IMcadAttributes members

Item

Remove

McadAttributes::Add

McadAttributes::Add method

McadAttributes::Application

McadAttributes::Application property

McadAttributes::Count

McadAttributes::Count property

McadAttributes::Item

McadAttributes::Item method

McadAttributes::Remove

McadAttributes::Remove method

McadAugmentedLine

McadAugmentedLine coclass

about McadAugmentedLine coclass

McadAugmentedLine interface

about IMcadAugmentedLine interface

McadBalloon

McadBalloon coclass

about McadBalloon coclass

McadBalloon interface

about IMcadBalloon interface

AppendBOMItem

AttachmentType

BalloonType

BOM

BOMItems

CollectionType

CustomBlock

CustomBlockName

IMcadBalloon members

IsCustomBlockUsed

RemoveBOMItem

McadBalloon::AppendBOMItem

McadBalloon::AppendBOMItem method

McadBalloon::AttachmentType

McadBalloon::AttachmentType property

McadBalloon::BalloonType

McadBalloon::BalloonType property

McadBalloon::BOM

McadBalloon::BOM property

McadBalloon::BOMItems

McadBalloon::BOMItems property

McadBalloon::CollectionType

McadBalloon::CollectionType property

McadBalloon::CustomBlock

McadBalloon::CustomBlock property

McadBalloon::CustomBlockName

McadBalloon::CustomBlockName property

McadBalloon::IsCustomBlockUsed

McadBalloon::IsCustomBlockUsed property

McadBalloon::RemoveBOMItem

McadBalloon::RemoveBOMItem method

McadBalloonCollectionType

McadBalloonCollectionType enumeration

McadBalloons

McadBalloons coclass

about McadBalloons coclass

McadBalloons interface

about IMcadBalloons interface

Add

Application

Count

IMcadBalloons members

Item

Remove

McadBalloons::Add

McadBalloons::Add method

McadBalloons::Application

McadBalloons::Application property

McadBalloons::Count

McadBalloons::Count property

McadBalloons::Item

McadBalloons::Item method

McadBalloons::Remove

McadBalloons::Remove method

McadBalloonStandard

McadBalloonStandard coclass

about McadBalloonStandard coclass

McadBalloonStandard interface

about IMcadBalloonStandard interface

Application

ArrowType

AttachmentType

AuxiliaryArrowType

BalloonType

BOMStandard

Color

ColumnList

CustomBlockName

IMcadBalloonStandard members

IsAuxiliaryArrowUsed

IsCustomBlockUsed

MaximumColumns

RemoveColumn

Revision

RevisionYear

SetToDefaults

TextHeight

McadBalloonStandard::Application

McadBalloonStandard::Application property

McadBalloonStandard::ArrowType

McadBalloonStandard::ArrowType property

McadBalloonStandard::AttachmentType

McadBalloonStandard::AttachmentType property

McadBalloonStandard::AuxiliaryArrowType

McadBalloonStandard::AuxiliaryArrowType property

McadBalloonStandard::BalloonType

McadBalloonStandard::BalloonType property

McadBalloonStandard::BOMStandard

McadBalloonStandard::BOMStandard property

McadBalloonStandard::Color

McadBalloonStandard::Color property

McadBalloonStandard::ColumnList

McadBalloonStandard::ColumnList property

McadBalloonStandard::CustomBlockName

McadBalloonStandard::CustomBlockName property

McadBalloonStandard::IsAuxiliaryArrowUsed

McadBalloonStandard::IsAuxiliaryArrowUsed property

McadBalloonStandard::IsCustomBlockUsed

McadBalloonStandard::IsCustomBlockUsed property

McadBalloonStandard::MaximumColumns

McadBalloonStandard::MaximumColumns property

McadBalloonStandard::RemoveColumn

McadBalloonStandard::RemoveColumn method

McadBalloonStandard::Revision

McadBalloonStandard::Revision property

McadBalloonStandard::RevisionYear

McadBalloonStandard::RevisionYear property

McadBalloonStandard::SetToDefaults

McadBalloonStandard::SetToDefaults method

McadBalloonStandard::TextHeight

McadBalloonStandard::TextHeight property

McadBalloonStandard2

McadBalloonStandard2 interface

about IMcadBalloonStandard2 interface

IMcadBalloonStandard2 members

TrueColor

McadBalloonStandard2::TrueColor

McadBalloonStandard2::TrueColor property

McadBalloonType

McadBalloonType enumeration

McadBOM

McadBOM coclass

about McadBOM coclass

McadBOM interface

about IMcadBOM interface

AddItem

AddUnassociatedItem

Data

IMcadBOM members

Items

PartLists

Target

McadBOM::AddItem

McadBOM::AddItem method

McadBOM::AddUnassociatedItem

McadBOM::AddUnassociatedItem method

McadBOM::Data

McadBOM::Data property

McadBOM::Items

McadBOM::Items method

McadBOM::PartLists

McadBOM::PartLists property

McadBOM::Target

McadBOM::Target property

McadBOM2

McadBOM2 interface

about IMcadBOM2 interface

applySort

GetProperties

GetProperties32

IMcadBOM2 members

SetProperties

McadBOM2::applySort

McadBOM2::applySort method

McadBOM2::GetProperties

McadBOM2::GetProperties method

McadBOM2::GetProperties32

McadBOM2::GetProperties32 method

McadBOM2::SetProperties

McadBOM2::SetProperties method

McadBOM3

McadBOM3 interface

about IMcadBOM3 interface

GetStructuredChildItems

GetStructuredParentItem

IMcadBOM3 members

IsBorder

IsVisible

MergeItems

McadBOM3::GetStructuredChildItems

McadBOM3::GetStructuredChildItems method

McadBOM3::GetStructuredParentItem

McadBOM3::GetStructuredParentItem method

McadBOM3::IsBorder

McadBOM3::IsBorder property

McadBOM3::IsVisible

McadBOM3::IsVisible property

McadBOM3::MergeItems

McadBOM3::MergeItems method

McadBOM4

McadBOM4 interface

about IMcadBOM4 interface

IMcadBOM4 members

SplitItem

McadBOM4::SplitItem

McadBOM4::SplitItem method

McadBOMExportFormatType

McadBOMExportFormatType enumeration

McadBOMImportFormatType

McadBOMImportFormatType enumeration

McadBOMItem

McadBOMItem coclass

about McadBOMItem coclass

McadBOMItem interface

about IMcadBOMItem interface

AddReference

AutoCalculateEnabled

Balloons

BOM

Data

Expanded

GetReferences

GetReferences32

IMcadBOMItem members

IsExpandable

ItemNumber

Quantity

ReferenceExists

RemoveReference

McadBOMItem::AddReference

McadBOMItem::AddReference method

McadBOMItem::AutoCalculateEnabled

McadBOMItem::AutoCalculateEnabled property

McadBOMItem::Balloons

McadBOMItem::Balloons property

McadBOMItem::BOM

McadBOMItem::BOM property

McadBOMItem::Data

McadBOMItem::Data property

McadBOMItem::Expanded

McadBOMItem::Expanded property

McadBOMItem::GetReferences

McadBOMItem::GetReferences method

McadBOMItem::GetReferences32

McadBOMItem::GetReferences32 method

McadBOMItem::IsExpandable

McadBOMItem::IsExpandable property

McadBOMItem::ItemNumber

McadBOMItem::ItemNumber property

McadBOMItem::Quantity

McadBOMItem::Quantity property

McadBOMItem::ReferenceExists

McadBOMItem::ReferenceExists method

McadBOMItem::RemoveReference

McadBOMItem::RemoveReference method

McadBOMItem2

McadBOMItem2 interface

about IMcadBOMItem2 interface

ExcludeFromPartList

GetAttribute

GetCalculatedQuantity

GetItemDefinition

GetItemDefinition32

GetPartBalloons

IMcadBOMItem2 members

Phantomed

SetAttribute

McadBOMItem2::ExcludeFromPartList

McadBOMItem2::ExcludeFromPartList property

McadBOMItem2::GetAttribute

McadBOMItem2::GetAttribute method

McadBOMItem2::GetCalculatedQuantity

McadBOMItem2::GetCalculatedQuantity method

McadBOMItem2::GetItemDefinition

McadBOMItem2::GetItemDefinition method

McadBOMItem2::GetItemDefinition32

McadBOMItem2::GetItemDefinition32 method

McadBOMItem2::GetPartBalloons

McadBOMItem2::GetPartBalloons method

McadBOMItem2::Phantomed

McadBOMItem2::Phantomed property

McadBOMItem2::SetAttribute

McadBOMItem2::SetAttribute method

McadBOMItem3

McadBOMItem3 interface

about IMcadBOMItem3 interface

GetItemPartDefinition

GetItemPartDefinition32

IMcadBOMItem3 members

SetAttributePreDefinedListValue

SortPriority

McadBOMItem3::GetItemPartDefinition

McadBOMItem3::GetItemPartDefinition method

McadBOMItem3::GetItemPartDefinition32

McadBOMItem3::GetItemPartDefinition32 method

McadBOMItem3::SetAttributePreDefinedListValue

McadBOMItem3::SetAttributePreDefinedListValue method

McadBOMItem3::SortPriority

McadBOMItem3::SortPriority property

McadBOMItem4

McadBOMItem4 interface

about IMcadBOMItem4 interface

GetBomOverride

IMcadBOMItem4 members

RemoveAttribute

McadBOMItem4::GetBomOverride

McadBOMItem4::GetBomOverride method

McadBOMItem4::RemoveAttribute

McadBOMItem4::RemoveAttribute method

McadBOMItemDefinitionType

McadBOMItemDefinitionType enumeration

McadBOMItems

McadBOMItems coclass

about McadBOMItems coclass

McadBOMItems interface

about IMcadBOMItems interface

Add

Application

Count

IMcadBOMItems members

Item

Remove

McadBOMItems::Add

McadBOMItems::Add method

McadBOMItems::Application

McadBOMItems::Application property

McadBOMItems::Count

McadBOMItems::Count property

McadBOMItems::Item

McadBOMItems::Item method

McadBOMItems::Remove

McadBOMItems::Remove method

McadBOMMgr

McadBOMMgr coclass

about McadBOMMgr coclass

McadBOMMgr interface

about IMcadBOMMgr interface

AddBOMTable

AddPartData

Application

BOMTableExists

ExportBOM

GetAllBOMTables

GetBOMTable

GetPartData

IMcadBOMMgr members

ImportBOM

RemoveBOMTable

SelectBOMEntity

SelectBOMEntity32

SetPartData

SymbolBBMgr

McadBOMMgr::AddBOMTable

McadBOMMgr::AddBOMTable method

McadBOMMgr::AddPartData

McadBOMMgr::AddPartData method

McadBOMMgr::Application

McadBOMMgr::Application property

McadBOMMgr::BOMTableExists

McadBOMMgr::BOMTableExists method

McadBOMMgr::ExportBOM

McadBOMMgr::ExportBOM method

McadBOMMgr::GetAllBOMTables

McadBOMMgr::GetAllBOMTables method

McadBOMMgr::GetBOMTable

McadBOMMgr::GetBOMTable method

McadBOMMgr::GetPartData

McadBOMMgr::GetPartData method

McadBOMMgr::ImportBOM

McadBOMMgr::ImportBOM method

McadBOMMgr::RemoveBOMTable

McadBOMMgr::RemoveBOMTable method

McadBOMMgr::SelectBOMEntity

McadBOMMgr::SelectBOMEntity method

McadBOMMgr::SelectBOMEntity32

McadBOMMgr::SelectBOMEntity32 method

McadBOMMgr::SetPartData

McadBOMMgr::SetPartData method

McadBOMMgr::SymbolBBMgr

McadBOMMgr::SymbolBBMgr property

McadBOMMgr2

McadBOMMgr2 interface

about IMcadBOMMgr2 interface

AddBorderBOMTable

AddPartGrfDef

CurrentBOM

ExportBOM2

ExportPartList

GetBOMTableByCompDefId

GetBOMTableByCompDefId32

GetBOMTableByName

GetBorderBOMTable

GetEvaluatedPartData

GetPartAttribute

GetSheetBOMTable

IMcadBOMMgr2 members

ImportBOM2

ImportPartList

RemovePartGrfDef

SetPartAttribute

McadBOMMgr2::AddBorderBOMTable

McadBOMMgr2::AddBorderBOMTable method

McadBOMMgr2::AddPartGrfDef

McadBOMMgr2::AddPartGrfDef method

McadBOMMgr2::CurrentBOM

McadBOMMgr2::CurrentBOM property

McadBOMMgr2::ExportBOM2

McadBOMMgr2::ExportBOM2 method

McadBOMMgr2::ExportPartList

McadBOMMgr2::ExportPartList method

McadBOMMgr2::GetBOMTableByCompDefId

McadBOMMgr2::GetBOMTableByCompDefId method

McadBOMMgr2::GetBOMTableByCompDefId32

McadBOMMgr2::GetBOMTableByCompDefId32 method

McadBOMMgr2::GetBOMTableByName

McadBOMMgr2::GetBOMTableByName method

McadBOMMgr2::GetBorderBOMTable

McadBOMMgr2::GetBorderBOMTable method

McadBOMMgr2::GetEvaluatedPartData

McadBOMMgr2::GetEvaluatedPartData method

McadBOMMgr2::GetPartAttribute

McadBOMMgr2::GetPartAttribute method

McadBOMMgr2::GetSheetBOMTable

McadBOMMgr2::GetSheetBOMTable method

McadBOMMgr2::ImportBOM2

McadBOMMgr2::ImportBOM2 method

McadBOMMgr2::ImportPartList

McadBOMMgr2::ImportPartList method

McadBOMMgr2::RemovePartGrfDef

McadBOMMgr2::RemovePartGrfDef method

McadBOMMgr2::SetPartAttribute

McadBOMMgr2::SetPartAttribute method

McadBOMMgr3

McadBOMMgr3 interface

about IMcadBOMMgr3 interface

GetBOMTableByCompDefHandle

IMcadBOMMgr3 members

McadBOMMgr3::GetBOMTableByCompDefHandle

McadBOMMgr3::GetBOMTableByCompDefHandle method

McadBOMMgr4

McadBOMMgr4 interface

about IMcadBOMMgr4 interface

GetAllPartReferences

IMcadBOMMgr4 members

McadBOMMgr4::GetAllPartReferences

McadBOMMgr4::GetAllPartReferences method

McadBomOverrideType

McadBomOverrideType enumeration

McadBOMs

McadBOMs coclass

about McadBOMs coclass

McadBOMs interface

about IMcadBOMs interface

Add

Application

Count

IMcadBOMs members

Item

Remove

McadBOMs::Add

McadBOMs::Add method

McadBOMs::Application

McadBOMs::Application property

McadBOMs::Count

McadBOMs::Count property

McadBOMs::Item

McadBOMs::Item method

McadBOMs::Remove

McadBOMs::Remove method

McadBOMStandard

McadBOMStandard coclass

about McadBOMStandard coclass

McadBOMStandard interface

about IMcadBOMStandard interface

AddColumn

BalloonStandard

ColumnCount

Columns

GetColumn

IMcadBOMStandard members

MoveColumn

PartListStandard

RemoveColumn

McadBOMStandard::AddColumn

McadBOMStandard::AddColumn method

McadBOMStandard::BalloonStandard

McadBOMStandard::BalloonStandard property

McadBOMStandard::ColumnCount

McadBOMStandard::ColumnCount property

McadBOMStandard::Columns

McadBOMStandard::Columns property

McadBOMStandard::GetColumn

McadBOMStandard::GetColumn method

McadBOMStandard::MoveColumn

McadBOMStandard::MoveColumn method

McadBOMStandard::PartListStandard

McadBOMStandard::PartListStandard property

McadBOMStandard::RemoveColumn

McadBOMStandard::RemoveColumn method

McadBOMStandard2

McadBOMStandard2 interface

about IMcadBOMStandard2 interface

GetUOMName

IMcadBOMStandard2 members

McadBOMStandard2::GetUOMName

McadBOMStandard2::GetUOMName method

McadBOMUOMType

McadBOMUOMType enumeration

McadBorder

McadBorder coclass

about McadBorder coclass

McadBorder interface

about IMcadBorder interface

Attributes

Extends

IMcadBorder members

Name

Position

SetToDefaultAttributes

McadBorder::Attributes

McadBorder::Attributes property

McadBorder::Extends

McadBorder::Extends property

McadBorder::Name

McadBorder::Name property

McadBorder::Position

McadBorder::Position property

McadBorder::SetToDefaultAttributes

McadBorder::SetToDefaultAttributes method

McadBorder2

McadBorder2 interface

about IMcadBorder2 interface

BlockId

BlockId32

IMcadBorder2 members

McadBorder2::BlockId

McadBorder2::BlockId property

McadBorder2::BlockId32

McadBorder2::BlockId32 property

McadCollectionType

McadCollectionType enumeration

McadColumnDefinition

McadColumnDefinition coclass

about McadColumnDefinition coclass

McadColumnDefinition interface

about IMcadColumnDefinition interface

Application

Caption

CaptionAlignment

ColumnType

DataAlignment

DataType

Equivalents

IMcadColumnDefinition members

Index

Name

Precision

Size

Width

McadColumnDefinition::Application

McadColumnDefinition::Application property

McadColumnDefinition::Caption

McadColumnDefinition::Caption property

McadColumnDefinition::CaptionAlignment

McadColumnDefinition::CaptionAlignment property

McadColumnDefinition::ColumnType

McadColumnDefinition::ColumnType property

McadColumnDefinition::DataAlignment

McadColumnDefinition::DataAlignment property

McadColumnDefinition::DataType

McadColumnDefinition::DataType property

McadColumnDefinition::Equivalents

McadColumnDefinition::Equivalents property

McadColumnDefinition::Index

McadColumnDefinition::Index property

McadColumnDefinition::Name

McadColumnDefinition::Name property

McadColumnDefinition::Precision

McadColumnDefinition::Precision property

McadColumnDefinition::Size

McadColumnDefinition::Size property

McadColumnDefinition::Width

McadColumnDefinition::Width property

McadColumnDefinition2

McadColumnDefinition2 interface

about IMcadColumnDefinition2 interface

IMcadColumnDefinition2 members

IsVisible

McadColumnDefinition2::IsVisible

McadColumnDefinition2::IsVisible property

McadColumnDefinition3

McadColumnDefinition3 interface

about IMcadColumnDefinition3 interface

BOMCaptionAlignment

BOMDataAlignment

GetPreDefinedList

IMcadColumnDefinition3 members

IsPreDefinedList

PartListCaptionAlignment

PartListDataAlignment

RemovePreDefinedList

SetPreDefinedList

McadColumnDefinition3::BOMCaptionAlignment

McadColumnDefinition3::BOMCaptionAlignment property

McadColumnDefinition3::BOMDataAlignment

McadColumnDefinition3::BOMDataAlignment property

McadColumnDefinition3::GetPreDefinedList

McadColumnDefinition3::GetPreDefinedList method

McadColumnDefinition3::IsPreDefinedList

McadColumnDefinition3::IsPreDefinedList property

McadColumnDefinition3::PartListCaptionAlignment

McadColumnDefinition3::PartListCaptionAlignment property

McadColumnDefinition3::PartListDataAlignment

McadColumnDefinition3::PartListDataAlignment property

McadColumnDefinition3::RemovePreDefinedList

McadColumnDefinition3::RemovePreDefinedList method

McadColumnDefinition3::SetPreDefinedList

McadColumnDefinition3::SetPreDefinedList method

McadColumnDefinitions

McadColumnDefinitions coclass

about McadColumnDefinitions coclass

McadColumnDefinitions interface

about IMcadColumnDefinitions interface

Add

Application

Count

IMcadColumnDefinitions members

Item

Remove

McadColumnDefinitions::Add

McadColumnDefinitions::Add method

McadColumnDefinitions::Application

McadColumnDefinitions::Application property

McadColumnDefinitions::Count

McadColumnDefinitions::Count property

McadColumnDefinitions::Item

McadColumnDefinitions::Item method

McadColumnDefinitions::Remove

McadColumnDefinitions::Remove method

McadColumnSplitStyle

McadColumnSplitStyle enumeration

McadColumnSplitWrap

McadColumnSplitWrap enumeration

McadColumnType

McadColumnType enumeration

McadComplexHideSituation

McadComplexHideSituation coclass

about McadComplexHideSituation coclass

McadComplexHideSituation interface

about IMcadComplexHideSituation interface

AddLevel

Concealed

Definition

Explode

HiddenLinesInvisible

HideAppropriateObjectsOnly

HideSituations

IMcadComplexHideSituation members

InitFromHide

IsModifiedStandardPartHide

IsStandardPartHide

LevelCount

LookupLevelName

MoveLevel

Name

NextLevelName

RemoveLevel

RemoveLevelByIdx

Reverse

Suppressed

SysName

UpdateBgSelection

McadComplexHideSituation::AddLevel

McadComplexHideSituation::AddLevel method

McadComplexHideSituation::Concealed

McadComplexHideSituation::Concealed property

McadComplexHideSituation::Definition

McadComplexHideSituation::Definition property

McadComplexHideSituation::Explode

McadComplexHideSituation::Explode method

McadComplexHideSituation::HiddenLinesInvisible

McadComplexHideSituation::HiddenLinesInvisible property

McadComplexHideSituation::HideAppropriateObjectsOnly

McadComplexHideSituation::HideAppropriateObjectsOnly property

McadComplexHideSituation::HideSituations

McadComplexHideSituation::HideSituations property

McadComplexHideSituation::InitFromHide

McadComplexHideSituation::InitFromHide method

McadComplexHideSituation::IsModifiedStandardPartHide

McadComplexHideSituation::IsModifiedStandardPartHide property

McadComplexHideSituation::IsStandardPartHide

McadComplexHideSituation::IsStandardPartHide property

McadComplexHideSituation::LevelCount

McadComplexHideSituation::LevelCount property

McadComplexHideSituation::LookupLevelName

McadComplexHideSituation::LookupLevelName method

McadComplexHideSituation::MoveLevel

McadComplexHideSituation::MoveLevel method

McadComplexHideSituation::Name

McadComplexHideSituation::Name property

McadComplexHideSituation::NextLevelName

McadComplexHideSituation::NextLevelName property

McadComplexHideSituation::RemoveLevel

McadComplexHideSituation::RemoveLevel method

McadComplexHideSituation::RemoveLevelByIdx

McadComplexHideSituation::RemoveLevelByIdx method

McadComplexHideSituation::Reverse

McadComplexHideSituation::Reverse method

McadComplexHideSituation::Suppressed

McadComplexHideSituation::Suppressed property

McadComplexHideSituation::SysName

McadComplexHideSituation::SysName property

McadComplexHideSituation::UpdateBgSelection

McadComplexHideSituation::UpdateBgSelection method

McadComplexHideSituations

McadComplexHideSituations coclass

about McadComplexHideSituations coclass

McadComplexHideSituations interface

about IMcadComplexHideSituations interface

Add

Application

Count

IMcadComplexHideSituations members

Item

Remove

McadComplexHideSituations::Add

McadComplexHideSituations::Add method

McadComplexHideSituations::Application

McadComplexHideSituations::Application property

McadComplexHideSituations::Count

McadComplexHideSituations::Count property

McadComplexHideSituations::Item

McadComplexHideSituations::Item method

McadComplexHideSituations::Remove

McadComplexHideSituations::Remove method

McadComponent

McadComponent coclass

about McadComponent coclass

McadComponent interface

about IMcadComponent interface

AddAttribute

Children

ClearOverrideProperties

ColorOverride

ComponentViews

ContainingComponent

CopyDefinition

Definition

GetAttributes

GetComponentInDefinition

hasExternalDef

HasGhostViews

HasOverrideProperties

IMcadComponent members

is2D

Name

Owner

Position

PredefinedReferenceOverride

Reference

RemoveAttribute

ReplaceDefinition

SortChildren

VisibilityOverride

Visible

McadComponent::AddAttribute

McadComponent::AddAttribute method

McadComponent::Children

McadComponent::Children property

McadComponent::ClearOverrideProperties

McadComponent::ClearOverrideProperties method

McadComponent::ColorOverride

McadComponent::ColorOverride method

McadComponent::ComponentViews

McadComponent::ComponentViews property

McadComponent::ContainingComponent

McadComponent::ContainingComponent method

McadComponent::CopyDefinition

McadComponent::CopyDefinition method

McadComponent::Definition

McadComponent::Definition property

McadComponent::GetAttributes

McadComponent::GetAttributes method

McadComponent::GetComponentInDefinition

McadComponent::GetComponentInDefinition method

McadComponent::hasExternalDef

McadComponent::hasExternalDef property

McadComponent::HasGhostViews

McadComponent::HasGhostViews property

McadComponent::HasOverrideProperties

McadComponent::HasOverrideProperties property

McadComponent::is2D

McadComponent::is2D property

McadComponent::Name

McadComponent::Name property

McadComponent::Owner

McadComponent::Owner property

McadComponent::Position

McadComponent::Position property

McadComponent::PredefinedReferenceOverride

McadComponent::PredefinedReferenceOverride method

McadComponent::Reference

McadComponent::Reference property

McadComponent::RemoveAttribute

McadComponent::RemoveAttribute method

McadComponent::ReplaceDefinition

McadComponent::ReplaceDefinition method

McadComponent::SortChildren

McadComponent::SortChildren method

McadComponent::VisibilityOverride

McadComponent::VisibilityOverride method

McadComponent::Visible

McadComponent::Visible property

McadComponentDefinition

McadComponentDefinition coclass

about McadComponentDefinition coclass

McadComponentDefinition interface

about IMcadComponentDefinition interface

AddAttribute

AddComponent

Children

ComponentViewDefinitions

CopyDefinition

Externalize

ExternalPath

GetAttributes

GetInstances

GetNextComponentViewDefinitionName

HasComponentViewDefinition

IMcadComponentDefinition members

is2D

is2DAssembly

IsExternal

isFeature

IsLeafNode

IsRoot

isShaft

isStandardPart

Localize2DS

Name

PhantomState

RemoveAttribute

RemoveComponent

SortChildren

Update

McadComponentDefinition::AddAttribute

McadComponentDefinition::AddAttribute method

McadComponentDefinition::AddComponent

McadComponentDefinition::AddComponent method

McadComponentDefinition::Children

McadComponentDefinition::Children property

McadComponentDefinition::ComponentViewDefinitions

McadComponentDefinition::ComponentViewDefinitions property

McadComponentDefinition::CopyDefinition

McadComponentDefinition::CopyDefinition method

McadComponentDefinition::Externalize

McadComponentDefinition::Externalize method

McadComponentDefinition::ExternalPath

McadComponentDefinition::ExternalPath property

McadComponentDefinition::GetAttributes

McadComponentDefinition::GetAttributes method

McadComponentDefinition::GetInstances

McadComponentDefinition::GetInstances method

McadComponentDefinition::GetNextComponentViewDefinitionName

McadComponentDefinition::GetNextComponentViewDefinitionName method

McadComponentDefinition::HasComponentViewDefinition

McadComponentDefinition::HasComponentViewDefinition method

McadComponentDefinition::is2D

McadComponentDefinition::is2D property

McadComponentDefinition::is2DAssembly

McadComponentDefinition::is2DAssembly property

McadComponentDefinition::IsExternal

McadComponentDefinition::IsExternal property

McadComponentDefinition::isFeature

McadComponentDefinition::isFeature property

McadComponentDefinition::IsLeafNode

McadComponentDefinition::IsLeafNode property

McadComponentDefinition::IsRoot

McadComponentDefinition::IsRoot property

McadComponentDefinition::isShaft

McadComponentDefinition::isShaft property

McadComponentDefinition::isStandardPart

McadComponentDefinition::isStandardPart property

McadComponentDefinition::Localize2DS

McadComponentDefinition::Localize2DS method

McadComponentDefinition::Name

McadComponentDefinition::Name property

McadComponentDefinition::PhantomState

McadComponentDefinition::PhantomState property

McadComponentDefinition::RemoveAttribute

McadComponentDefinition::RemoveAttribute method

McadComponentDefinition::RemoveComponent

McadComponentDefinition::RemoveComponent method

McadComponentDefinition::SortChildren

McadComponentDefinition::SortChildren method

McadComponentDefinition::Update

McadComponentDefinition::Update method

McadComponentDefinitions

McadComponentDefinitions coclass

about McadComponentDefinitions coclass

McadComponentDefinitions interface

about IMcadComponentDefinitions interface

Add

Application

Count

IMcadComponentDefinitions members

Item

Remove

McadComponentDefinitions::Add

McadComponentDefinitions::Add method

McadComponentDefinitions::Application

McadComponentDefinitions::Application property

McadComponentDefinitions::Count

McadComponentDefinitions::Count property

McadComponentDefinitions::Item

McadComponentDefinitions::Item method

McadComponentDefinitions::Remove

McadComponentDefinitions::Remove method

McadComponents

McadComponents coclass

about McadComponents coclass

McadComponents interface

about IMcadComponents interface

Add

Application

Count

IMcadComponents members

Item

Remove

McadComponents::Add

McadComponents::Add method

McadComponents::Application

McadComponents::Application property

McadComponents::Count

McadComponents::Count property

McadComponents::Item

McadComponents::Item method

McadComponents::Remove

McadComponents::Remove method

McadComponentView

McadComponentView coclass

about McadComponentView coclass

McadComponentView interface

about IMcadComponentView interface

Component

IMcadComponentView members

isFeature

IsGhostView

McadComponentView::Component

McadComponentView::Component property

McadComponentView::isFeature

McadComponentView::isFeature property

McadComponentView::IsGhostView

McadComponentView::IsGhostView method

McadComponentViewDefinition

McadComponentViewDefinition coclass

about McadComponentViewDefinition coclass

McadComponentViewDefinition interface

about IMcadComponentViewDefinition interface

AddComponentView

IMcadComponentViewDefinition members

IsFeature

Owner

RemoveComponentView

McadComponentViewDefinition::AddComponentView

McadComponentViewDefinition::AddComponentView method

McadComponentViewDefinition::IsFeature

McadComponentViewDefinition::IsFeature property

McadComponentViewDefinition::Owner

McadComponentViewDefinition::Owner property

McadComponentViewDefinition::RemoveComponentView

McadComponentViewDefinition::RemoveComponentView method

McadComponentViewDefinitions

McadComponentViewDefinitions coclass

about McadComponentViewDefinitions coclass

McadComponentViewDefinitions interface

about IMcadComponentViewDefinitions interface

Add

Application

Count

IMcadComponentViewDefinitions members

Item

Remove

McadComponentViewDefinitions::Add

McadComponentViewDefinitions::Add method

McadComponentViewDefinitions::Application

McadComponentViewDefinitions::Application property

McadComponentViewDefinitions::Count

McadComponentViewDefinitions::Count property

McadComponentViewDefinitions::Item

McadComponentViewDefinitions::Item method

McadComponentViewDefinitions::Remove

McadComponentViewDefinitions::Remove method

McadComponentViewDescriptor

McadComponentViewDescriptor coclass

about McadComponentViewDescriptor coclass

McadComponentViewDescriptor interface

about IMcadComponentViewDescriptor interface

Component

McadComponentViewDescriptor interface

CreateComponentView

FullViewName

IMcadComponentViewDescriptor members

McadComponentViewDescriptor::Component

McadComponentViewDescriptor::Component property

McadComponentViewDescriptor::CreateComponentView

McadComponentViewDescriptor::CreateComponentView method

McadComponentViewDescriptor::FullViewName

McadComponentViewDescriptor::FullViewName property

McadComponentViews

McadComponentViews coclass

about McadComponentViews coclass

McadComponentViews interface

about IMcadComponentViews interface

Add

Application

Count

IMcadComponentViews members

Item

Remove

McadComponentViews::Add

McadComponentViews::Add method

McadComponentViews::Application

McadComponentViews::Application property

McadComponentViews::Count

McadComponentViews::Count property

McadComponentViews::Item

McadComponentViews::Item method

McadComponentViews::Remove

McadComponentViews::Remove method

McadCurve

McadCurve interface

about IMcadCurve interface

McadDataType

McadDataType enumeration

McadDatumIdentifier

McadDatumIdentifier coclass

about McadDatumIdentifier coclass

McadDatumIdentifier interface

about IMcadDatumIdentifier interface

McadDatumIdentifier2

McadDatumIdentifier2 interface

about IMcadDatumIdentifier2 interface

AddStdCompliantLeader

IMcadDatumIdentifier2 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadDatumIdentifier2::AddStdCompliantLeader

McadDatumIdentifier2::AddStdCompliantLeader method

McadDatumIdentifier2::SurfExtLinesOffset

McadDatumIdentifier2::SurfExtLinesOffset property

McadDatumIdentifier2::SurfExtLinesOvershot

McadDatumIdentifier2::SurfExtLinesOvershot property

McadDatumIdentifier3

McadDatumIdentifier3 interface

about IMcadDatumIdentifier3 interface

AddLeaderWithSurfIndLeader

DatumNote

FarSideStatus

GetSurfIndLeader

IMcadDatumIdentifier3 members

SurfIndLeaderArrowType

ThreadNote

McadDatumIdentifier3::AddLeaderWithSurfIndLeader

McadDatumIdentifier3::AddLeaderWithSurfIndLeader method

McadDatumIdentifier3::DatumNote

McadDatumIdentifier3::DatumNote property

McadDatumIdentifier3::FarSideStatus

McadDatumIdentifier3::FarSideStatus property

McadDatumIdentifier3::GetSurfIndLeader

McadDatumIdentifier3::GetSurfIndLeader method

McadDatumIdentifier3::SurfIndLeaderArrowType

McadDatumIdentifier3::SurfIndLeaderArrowType property

McadDatumIdentifier3::ThreadNote

McadDatumIdentifier3::ThreadNote property

McadDatumStandard

McadDatumStandard coclass

about McadDatumStandard coclass

McadDatumStandard interface

about IMcadDatumStandard interface

BorderLineType

BorderLineTypeName

DrawLeaderArrow

HatchAngle

HatchDistance

HiddenLeaderLineType

HiddenLeaderLineTypeName

IMcadDatumStandard members

PointColor

PointSize

McadDatumStandard::BorderLineType

McadDatumStandard::BorderLineType property

McadDatumStandard::BorderLineTypeName

McadDatumStandard::BorderLineTypeName property

McadDatumStandard::DrawLeaderArrow

McadDatumStandard::DrawLeaderArrow property

McadDatumStandard::HatchAngle

McadDatumStandard::HatchAngle property

McadDatumStandard::HatchDistance

McadDatumStandard::HatchDistance property

McadDatumStandard::HiddenLeaderLineType

McadDatumStandard::HiddenLeaderLineType property

McadDatumStandard::HiddenLeaderLineTypeName

McadDatumStandard::HiddenLeaderLineTypeName property

McadDatumStandard::PointColor

McadDatumStandard::PointColor property

McadDatumStandard::PointSize

McadDatumStandard::PointSize property

McadDatumStandard2

McadDatumStandard2 interface

about IMcadDatumStandard2 interface

IMcadDatumStandard2 members

PointTrueColor

McadDatumStandard2::PointTrueColor

McadDatumStandard2::PointTrueColor property

McadDatumTarget

McadDatumTarget coclass

about McadDatumTarget coclass

McadDatumTarget interface

about IMcadDatumTarget interface

CircleRadius

DatumValue

DimensionValue

DrawLine

DrawPoint

IMcadDatumTarget members

LeaderLinetypeHidden

LineEndPoint

LineFactor

LineMidPoint

RectangleAngle

RectangleXSize

RectangleYSize

TargetOrigin

TargetType

McadDatumTarget::CircleRadius

McadDatumTarget::CircleRadius property

McadDatumTarget::DatumValue

McadDatumTarget::DatumValue property

McadDatumTarget::DimensionValue

McadDatumTarget::DimensionValue property

McadDatumTarget::DrawLine

McadDatumTarget::DrawLine property

McadDatumTarget::DrawPoint

McadDatumTarget::DrawPoint property

McadDatumTarget::LeaderLinetypeHidden

McadDatumTarget::LeaderLinetypeHidden property

McadDatumTarget::LineEndPoint

McadDatumTarget::LineEndPoint property

McadDatumTarget::LineFactor

McadDatumTarget::LineFactor property

McadDatumTarget::LineMidPoint

McadDatumTarget::LineMidPoint property

McadDatumTarget::RectangleAngle

McadDatumTarget::RectangleAngle property

McadDatumTarget::RectangleXSize

McadDatumTarget::RectangleXSize property

McadDatumTarget::RectangleYSize

McadDatumTarget::RectangleYSize property

McadDatumTarget::TargetOrigin

McadDatumTarget::TargetOrigin property

McadDatumTarget::TargetType

McadDatumTarget::TargetType property

McadDatumTarget2

McadDatumTarget2 interface

about IMcadDatumTarget2 interface

IMcadDatumTarget2 members

RectangleCornerPoint

SetTargetAttach

McadDatumTarget2::RectangleCornerPoint

McadDatumTarget2::RectangleCornerPoint property

McadDatumTarget2::SetTargetAttach

McadDatumTarget2::SetTargetAttach method

McadDescriptor

McadDescriptor interface

about IMcadDescriptor interface

Application

Document

IMcadDescriptor members

McadDescriptor::Application

McadDescriptor::Application property

McadDescriptor::Document

McadDescriptor::Document property

McadDetailSymbol

McadDetailSymbol coclass

about McadDetailSymbol coclass

McadDetailSymbol interface

about IMcadDetailSymbol interface

AnnotationOffset

BaseViewScale

CorrectionScaleFactor

CreateLabelEntity

DetailScale

IMcadDetailSymbol members

IsAssociativeDetail

LabelEntity

LabelEntityOffset

LabelName

LabelPattern

LabelText

Radius

SetSourceGeometry

ShowAnnotationLeader

ShowBorder

ShowLeader

SpecByAbsoluteScale

McadDetailSymbol::AnnotationOffset

McadDetailSymbol::AnnotationOffset property

McadDetailSymbol::BaseViewScale

McadDetailSymbol::BaseViewScale property

McadDetailSymbol::CorrectionScaleFactor

McadDetailSymbol::CorrectionScaleFactor property

McadDetailSymbol::CreateLabelEntity

McadDetailSymbol::CreateLabelEntity method

McadDetailSymbol::DetailScale

McadDetailSymbol::DetailScale property

McadDetailSymbol::IsAssociativeDetail

McadDetailSymbol::IsAssociativeDetail property

McadDetailSymbol::LabelEntity

McadDetailSymbol::LabelEntity property

McadDetailSymbol::LabelEntityOffset

McadDetailSymbol::LabelEntityOffset property

McadDetailSymbol::LabelName

McadDetailSymbol::LabelName property

McadDetailSymbol::LabelPattern

McadDetailSymbol::LabelPattern property

McadDetailSymbol::LabelText

McadDetailSymbol::LabelText property

McadDetailSymbol::Radius

McadDetailSymbol::Radius property

McadDetailSymbol::SetSourceGeometry

McadDetailSymbol::SetSourceGeometry method

McadDetailSymbol::ShowAnnotationLeader

McadDetailSymbol::ShowAnnotationLeader property

McadDetailSymbol::ShowBorder

McadDetailSymbol::ShowBorder property

McadDetailSymbol::ShowLeader

McadDetailSymbol::ShowLeader property

McadDetailSymbol::SpecByAbsoluteScale

McadDetailSymbol::SpecByAbsoluteScale property

McadDetailSymbolLabel

McadDetailSymbolLabel coclass

about McadDetailSymbolLabel coclass

McadDetailSymbolLabel interface

about IMcadDetailSymbolLabel interface

AnnotationOffset

IMcadDetailSymbolLabel members

LabelAbove

LabelText

SymbolEntity

McadDetailSymbolLabel::AnnotationOffset

McadDetailSymbolLabel::AnnotationOffset property

McadDetailSymbolLabel::LabelAbove

McadDetailSymbolLabel::LabelAbove property

McadDetailSymbolLabel::LabelText

McadDetailSymbolLabel::LabelText property

McadDetailSymbolLabel::SymbolEntity

McadDetailSymbolLabel::SymbolEntity property

McadDetailSymbolStandard

McadDetailSymbolStandard coclass

about McadDetailSymbolStandard coclass

McadDetailSymbolStandard interface

about IMcadDetailSymbolStandard interface

AddAllowedScale

AllowedScales

BorderLineType

EraseAllowedScales

IMcadDetailSymbolStandard members

LabelAbove

LabelPattern

ShowAnnotationLeader

ShowBorder

ShowLeader

McadDetailSymbolStandard::AddAllowedScale

McadDetailSymbolStandard::AddAllowedScale method

McadDetailSymbolStandard::AllowedScales

McadDetailSymbolStandard::AllowedScales property

McadDetailSymbolStandard::BorderLineType

McadDetailSymbolStandard::BorderLineType property

McadDetailSymbolStandard::EraseAllowedScales

McadDetailSymbolStandard::EraseAllowedScales method

McadDetailSymbolStandard::LabelAbove

McadDetailSymbolStandard::LabelAbove property

McadDetailSymbolStandard::LabelPattern

McadDetailSymbolStandard::LabelPattern property

McadDetailSymbolStandard::ShowAnnotationLeader

McadDetailSymbolStandard::ShowAnnotationLeader property

McadDetailSymbolStandard::ShowBorder

McadDetailSymbolStandard::ShowBorder property

McadDetailSymbolStandard::ShowLeader

McadDetailSymbolStandard::ShowLeader property

McadDetailSymbolStandard2

McadDetailSymbolStandard2 interface

about IMcadDetailSymbolStandard2 interface

BorderLineColor

BorderLineLineType

BorderLineWeight

BoundaryLineColor

BoundaryLineType

BoundaryLineWeight

ConnectionLineColor

ConnectionLineType

ConnectionLineWeight

GetByStandard

IdentifierOutsideBoundary

IMcadDetailSymbolStandard2 members

LabelOffset

LabelTextColor

LabelTextHeight

LabelTextStyle

SetByStandard

ShowLabel

McadDetailSymbolStandard2::BorderLineColor

McadDetailSymbolStandard2::BorderLineColor property

McadDetailSymbolStandard2::BorderLineLineType

McadDetailSymbolStandard2::BorderLineLineType property

McadDetailSymbolStandard2::BorderLineWeight

McadDetailSymbolStandard2::BorderLineWeight property

McadDetailSymbolStandard2::BoundaryLineColor

McadDetailSymbolStandard2::BoundaryLineColor property

McadDetailSymbolStandard2::BoundaryLineType

McadDetailSymbolStandard2::BoundaryLineType property

McadDetailSymbolStandard2::BoundaryLineWeight

McadDetailSymbolStandard2::BoundaryLineWeight property

McadDetailSymbolStandard2::ConnectionLineColor

McadDetailSymbolStandard2::ConnectionLineColor property

McadDetailSymbolStandard2::ConnectionLineType

McadDetailSymbolStandard2::ConnectionLineType property

McadDetailSymbolStandard2::ConnectionLineWeight

McadDetailSymbolStandard2::ConnectionLineWeight property

McadDetailSymbolStandard2::GetByStandard

McadDetailSymbolStandard2::GetByStandard method

McadDetailSymbolStandard2::IdentifierOutsideBoundary

McadDetailSymbolStandard2::IdentifierOutsideBoundary property

McadDetailSymbolStandard2::LabelOffset

McadDetailSymbolStandard2::LabelOffset property

McadDetailSymbolStandard2::LabelTextColor

McadDetailSymbolStandard2::LabelTextColor property

McadDetailSymbolStandard2::LabelTextHeight

McadDetailSymbolStandard2::LabelTextHeight property

McadDetailSymbolStandard2::LabelTextStyle

McadDetailSymbolStandard2::LabelTextStyle property

McadDetailSymbolStandard2::SetByStandard

McadDetailSymbolStandard2::SetByStandard method

McadDetailSymbolStandard2::ShowLabel

McadDetailSymbolStandard2::ShowLabel property

McadDetailSymbolStandardPropType

McadDetailSymbolStandardPropType enumeration

McadDirectionLayType

McadDirectionLayType enumeration

McadDocDrawingType

McadDocDrawingType enumeration

McadDocument

McadDocument coclass

about McadDocument coclass

McadDocument interface

about IMcadDocument interface

Application

IMcadDocument members

LayerGroupMgr

LayerObjectMgr

StructureMgr2D

Utility

McadDocument::Application

McadDocument::Application property

McadDocument::LayerGroupMgr

McadDocument::LayerGroupMgr property

McadDocument::LayerObjectMgr

McadDocument::LayerObjectMgr property

McadDocument::StructureMgr2D

McadDocument::StructureMgr2D property

McadDocument::Utility

McadDocument::Utility property

McadDocuments

McadDocuments coclass

about McadDocuments coclass

McadDocuments interface

about IMcadDocuments interface

Application

Count

IMcadDocuments members

Item

McadDocuments::Application

McadDocuments::Application property

McadDocuments::Count

McadDocuments::Count property

McadDocuments::Item

McadDocuments::Item method

McadDocumentVersion

McadDocumentVersion interface

about IMcadDocumentVersion interface

GetVersionNumber

IMcadDocumentVersion members

McadDocumentVersion::GetVersionNumber

McadDocumentVersion::GetVersionNumber method

McadEdge

McadEdge coclass

about McadEdge coclass

McadEdge interface

about IMcadEdge interface

AllAround

Direction

IMcadEdge members

Majority

MaxValue

MinValue

NewSymbolRev

SignValue

StandardNumber

UndefsizeDirection

McadEdge::AllAround

McadEdge::AllAround property

McadEdge::Direction

McadEdge::Direction property

McadEdge::Majority

McadEdge::Majority property

McadEdge::MaxValue

McadEdge::MaxValue property

McadEdge::MinValue

McadEdge::MinValue property

McadEdge::NewSymbolRev

McadEdge::NewSymbolRev property

McadEdge::SignValue

McadEdge::SignValue property

McadEdge::StandardNumber

McadEdge::StandardNumber property

McadEdge::UndefsizeDirection

McadEdge::UndefsizeDirection property

McadEdgeLibrary

McadEdgeLibrary coclass

about McadEdgeLibrary coclass

McadEdgeLibrary interface

about IMcadEdgeLibrary interface

McadEdgeLibraryObject

McadEdgeLibraryObject coclass

about McadEdgeLibraryObject coclass

McadEdgeLibraryObject interface

about IMcadEdgeLibraryObject interface

IMcadEdgeLibraryObject members

IsAllAround

IsDefinedDirection

IsMajority

RequirementValue

StandardNumber

UndefsizeDirection

McadEdgeLibraryObject::IsAllAround

McadEdgeLibraryObject::IsAllAround property

McadEdgeLibraryObject::IsDefinedDirection

McadEdgeLibraryObject::IsDefinedDirection property

McadEdgeLibraryObject::IsMajority

McadEdgeLibraryObject::IsMajority property

McadEdgeLibraryObject::RequirementValue

McadEdgeLibraryObject::RequirementValue method

McadEdgeLibraryObject::StandardNumber

McadEdgeLibraryObject::StandardNumber property

McadEdgeLibraryObject::UndefsizeDirection

McadEdgeLibraryObject::UndefsizeDirection property

McadEdgeRequirement

McadEdgeRequirement enumeration

McadEdgeStandard

McadEdgeStandard coclass

about McadEdgeStandard coclass

McadEdgeStandard interface

about IMcadEdgeStandard interface

AllAroundAllowed

FullList

IMcadEdgeStandard members

MajorityAllowed

StandardNumAllowed

McadEdgeStandard::AllAroundAllowed

McadEdgeStandard::AllAroundAllowed property

McadEdgeStandard::FullList

McadEdgeStandard::FullList property

McadEdgeStandard::MajorityAllowed

McadEdgeStandard::MajorityAllowed property

McadEdgeStandard::StandardNumAllowed

McadEdgeStandard::StandardNumAllowed property

McadEllipse

McadEllipse coclass

about McadEllipse coclass

McadEllipse interface

about IMcadEllipse interface

McadFCFLibrary

McadFCFLibrary coclass

about McadFCFLibrary coclass

McadFCFLibrary interface

about IMcadFCFLibrary interface

McadFCFLibraryObject

McadFCFLibraryObject coclass

about McadFCFLibraryObject coclass

McadFCFLibraryObject interface

about IMcadFCFLibraryObject interface

IMcadFCFLibraryObject members

IsAllAround

RequirementValue

Symbol

Symbol2

Symbol3

McadFCFLibraryObject::IsAllAround

McadFCFLibraryObject::IsAllAround property

McadFCFLibraryObject::RequirementValue

McadFCFLibraryObject::RequirementValue method

McadFCFLibraryObject::Symbol

McadFCFLibraryObject::Symbol property

McadFCFLibraryObject::Symbol2

McadFCFLibraryObject::Symbol2 property

McadFCFLibraryObject::Symbol3

McadFCFLibraryObject::Symbol3 property

McadFCFRequirement

McadFCFRequirement enumeration

McadFCFStandard

McadFCFStandard coclass

about McadFCFStandard coclass

McadFCFStandard interface

about IMcadFCFStandard interface

AvailableAuxiliarySymbols

AvailableGDTSymbols

EndPadding

FrameGap

GDTTextFont

GDTTextStyle

GDTTextStyleName

GetSymbolImplementation

IMcadFCFStandard members

MergeDatum

MergeSymbol

MergeTolerance

OfferedAuxiliarySymbols

OfferedGDTSymbols

SeparateDatumID

SeparateProjected

McadFCFStandard::AvailableAuxiliarySymbols

McadFCFStandard::AvailableAuxiliarySymbols property

McadFCFStandard::AvailableGDTSymbols

McadFCFStandard::AvailableGDTSymbols property

McadFCFStandard::EndPadding

McadFCFStandard::EndPadding property

McadFCFStandard::FrameGap

McadFCFStandard::FrameGap property

McadFCFStandard::GDTTextFont

McadFCFStandard::GDTTextFont property

McadFCFStandard::GDTTextStyle

McadFCFStandard::GDTTextStyle property

McadFCFStandard::GDTTextStyleName

McadFCFStandard::GDTTextStyleName property

McadFCFStandard::GetSymbolImplementation

McadFCFStandard::GetSymbolImplementation method

McadFCFStandard::MergeDatum

McadFCFStandard::MergeDatum property

McadFCFStandard::MergeSymbol

McadFCFStandard::MergeSymbol property

McadFCFStandard::MergeTolerance

McadFCFStandard::MergeTolerance property

McadFCFStandard::OfferedAuxiliarySymbols

McadFCFStandard::OfferedAuxiliarySymbols property

McadFCFStandard::OfferedGDTSymbols

McadFCFStandard::OfferedGDTSymbols property

McadFCFStandard::SeparateDatumID

McadFCFStandard::SeparateDatumID property

McadFCFStandard::SeparateProjected

McadFCFStandard::SeparateProjected property

McadFCFStandard2

McadFCFStandard2 interface

about IMcadFCFStandard2 interface

IMcadFCFStandard2 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadFCFStandard2::SurfIndLeaderArrowScale

McadFCFStandard2::SurfIndLeaderArrowScale property

McadFCFStandard2::SurfIndLeaderArrowType

McadFCFStandard2::SurfIndLeaderArrowType property

McadFeatureControlFrame

McadFeatureControlFrame coclass

about McadFeatureControlFrame coclass

McadFeatureControlFrame interface

about IMcadFeatureControlFrame interface

DatumIDValue

DatumPrimary2Value

DatumPrimary3Value

DatumPrimaryValue

DatumSecondary2Value

DatumSecondary3Value

DatumSecondaryValue

DatumTertiary2Value

DatumTertiary3Value

DatumTertiaryValue

IMcadFeatureControlFrame members

IsAllAround

ProjectedValue

Symbol

Symbol2

Symbol3

Tolerance2Value

Tolerance3Value

ToleranceB2Value

ToleranceBValue

ToleranceValue

McadFeatureControlFrame::DatumIDValue

McadFeatureControlFrame::DatumIDValue property

McadFeatureControlFrame::DatumPrimary2Value

McadFeatureControlFrame::DatumPrimary2Value property

McadFeatureControlFrame::DatumPrimary3Value

McadFeatureControlFrame::DatumPrimary3Value property

McadFeatureControlFrame::DatumPrimaryValue

McadFeatureControlFrame::DatumPrimaryValue property

McadFeatureControlFrame::DatumSecondary2Value

McadFeatureControlFrame::DatumSecondary2Value property

McadFeatureControlFrame::DatumSecondary3Value

McadFeatureControlFrame::DatumSecondary3Value property

McadFeatureControlFrame::DatumSecondaryValue

McadFeatureControlFrame::DatumSecondaryValue property

McadFeatureControlFrame::DatumTertiary2Value

McadFeatureControlFrame::DatumTertiary2Value property

McadFeatureControlFrame::DatumTertiary3Value

McadFeatureControlFrame::DatumTertiary3Value property

McadFeatureControlFrame::DatumTertiaryValue

McadFeatureControlFrame::DatumTertiaryValue property

McadFeatureControlFrame::IsAllAround

McadFeatureControlFrame::IsAllAround property

McadFeatureControlFrame::ProjectedValue

McadFeatureControlFrame::ProjectedValue property

McadFeatureControlFrame::Symbol

McadFeatureControlFrame::Symbol property

McadFeatureControlFrame::Symbol2

McadFeatureControlFrame::Symbol2 property

McadFeatureControlFrame::Symbol3

McadFeatureControlFrame::Symbol3 property

McadFeatureControlFrame::Tolerance2Value

McadFeatureControlFrame::Tolerance2Value property

McadFeatureControlFrame::Tolerance3Value

McadFeatureControlFrame::Tolerance3Value property

McadFeatureControlFrame::ToleranceB2Value

McadFeatureControlFrame::ToleranceB2Value property

McadFeatureControlFrame::ToleranceBValue

McadFeatureControlFrame::ToleranceBValue property

McadFeatureControlFrame::ToleranceValue

McadFeatureControlFrame::ToleranceValue property

McadFeatureControlFrame2

McadFeatureControlFrame2 interface

about IMcadFeatureControlFrame2 interface

BottomNoteValue

IMcadFeatureControlFrame2 members

TopNoteValue

McadFeatureControlFrame2::BottomNoteValue

McadFeatureControlFrame2::BottomNoteValue property

McadFeatureControlFrame2::TopNoteValue

McadFeatureControlFrame2::TopNoteValue property

McadFeatureControlFrame3

McadFeatureControlFrame3 interface

about IMcadFeatureControlFrame3 interface

AddStdCompliantLeader

IMcadFeatureControlFrame3 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadFeatureControlFrame3::AddStdCompliantLeader

McadFeatureControlFrame3::AddStdCompliantLeader method

McadFeatureControlFrame3::SurfExtLinesOffset

McadFeatureControlFrame3::SurfExtLinesOffset property

McadFeatureControlFrame3::SurfExtLinesOvershot

McadFeatureControlFrame3::SurfExtLinesOvershot property

McadFeatureControlFrame4

McadFeatureControlFrame4 interface

about IMcadFeatureControlFrame4 interface

AddLeaderWithSurfIndLeader

AddSurfIndLeader

GetSurfIndLeader

IMcadFeatureControlFrame4 members

RemoveSurfIndLeader

SurfIndLeaderArrowType

McadFeatureControlFrame4::AddLeaderWithSurfIndLeader

McadFeatureControlFrame4::AddLeaderWithSurfIndLeader method

McadFeatureControlFrame4::AddSurfIndLeader

McadFeatureControlFrame4::AddSurfIndLeader method

McadFeatureControlFrame4::GetSurfIndLeader

McadFeatureControlFrame4::GetSurfIndLeader method

McadFeatureControlFrame4::RemoveSurfIndLeader

McadFeatureControlFrame4::RemoveSurfIndLeader method

McadFeatureControlFrame4::SurfIndLeaderArrowType

McadFeatureControlFrame4::SurfIndLeaderArrowType property

McadFeatureIdentifier

McadFeatureIdentifier coclass

about McadFeatureIdentifier coclass

McadFeatureIdentifier interface

about IMcadFeatureIdentifier interface

McadFeatureIdentifier2

McadFeatureIdentifier2 interface

about IMcadFeatureIdentifier2 interface

AddStdCompliantLeader

IMcadFeatureIdentifier2 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadFeatureIdentifier2::AddStdCompliantLeader

McadFeatureIdentifier2::AddStdCompliantLeader method

McadFeatureIdentifier2::SurfExtLinesOffset

McadFeatureIdentifier2::SurfExtLinesOffset property

McadFeatureIdentifier2::SurfExtLinesOvershot

McadFeatureIdentifier2::SurfExtLinesOvershot property

McadFieldType

McadFieldType enumeration

McadFilterOperator

McadFilterOperator enumeration

McadFilterType

McadFilterType enumeration

McadFolder

McadFolder coclass

about McadFolder coclass

McadFolder interface

about IMcadFolder interface

AddEntities

BasePoint

Children

ClearLeaf

ClearOverrideProperties

ColorOverride

ContextDefinition

CopyEntities

CopyView

CopyViewDefinition

Definition

Entities

Entities32

Explode

ExtentsMaximum

ExtentsMinimum

GeomPathName

HasExternalDef

HasOverrideProperties

IMcadFolder members

IsInstance

IsLeaf

IsLocked

IsSubentityOf

Owner

Position

PredefinedReferenceOverride

RemoveEntities

ReplaceDefinition

ViewName

ViewScale

VisibilityOverride

Visible

McadFolder::AddEntities

McadFolder::AddEntities method

McadFolder::BasePoint

McadFolder::BasePoint property

McadFolder::Children

McadFolder::Children property

McadFolder::ClearLeaf

McadFolder::ClearLeaf method

McadFolder::ClearOverrideProperties

McadFolder::ClearOverrideProperties method

McadFolder::ColorOverride

McadFolder::ColorOverride method

McadFolder::ContextDefinition

McadFolder::ContextDefinition property

McadFolder::CopyEntities

McadFolder::CopyEntities method

McadFolder::CopyView

McadFolder::CopyView method

McadFolder::CopyViewDefinition

McadFolder::CopyViewDefinition method

McadFolder::Definition

McadFolder::Definition property

McadFolder::Entities

McadFolder::Entities property

McadFolder::Entities32

McadFolder::Entities32 property

McadFolder::Explode

McadFolder::Explode method

McadFolder::ExtentsMaximum

McadFolder::ExtentsMaximum property

McadFolder::ExtentsMinimum

McadFolder::ExtentsMinimum property

McadFolder::GeomPathName

McadFolder::GeomPathName property

McadFolder::HasExternalDef

McadFolder::HasExternalDef property

McadFolder::HasOverrideProperties

McadFolder::HasOverrideProperties property

McadFolder::IsInstance

McadFolder::IsInstance property

McadFolder::IsLeaf

McadFolder::IsLeaf property

McadFolder::IsLocked

McadFolder::IsLocked property

McadFolder::IsSubentityOf

McadFolder::IsSubentityOf method

McadFolder::Owner

McadFolder::Owner property

McadFolder::Position

McadFolder::Position property

McadFolder::PredefinedReferenceOverride

McadFolder::PredefinedReferenceOverride method

McadFolder::RemoveEntities

McadFolder::RemoveEntities method

McadFolder::ReplaceDefinition

McadFolder::ReplaceDefinition method

McadFolder::ViewName

McadFolder::ViewName property

McadFolder::ViewScale

McadFolder::ViewScale property

McadFolder::VisibilityOverride

McadFolder::VisibilityOverride method

McadFolder::Visible

McadFolder::Visible property

McadFolder2

McadFolder2 interface

about IMcadFolder2 interface

IMcadFolder2 members

OwningSpace

McadFolder2::OwningSpace

McadFolder2::OwningSpace property

McadFolderDefinition

McadFolderDefinition coclass

about McadFolderDefinition coclass

McadFolderDefinition interface

about IMcadFolderDefinition interface

AddComplexHideSituation

AddFolder

AddFromExistingEntities

AddHideSituation

Children

ChildrenCount

ComplexHideSituations

Extents

Externalize

FindHideSituations

FullName

GetHidesSuppressState

HideSituations

IMcadFolderDefinition members

InstanceCount

Instances

InstancesDefinition

IsAnnotation

IsDetail

IsExternal

IsLocked

IsRoot

Localize

LockType

LookupViewName

Name

NextViewName

Occurrences

RemoveFolder

SetHidesSuppressState

SortChildren

ViewType

McadFolderDefinition::AddComplexHideSituation

McadFolderDefinition::AddComplexHideSituation method

McadFolderDefinition::AddFolder

McadFolderDefinition::AddFolder method

McadFolderDefinition::AddFromExistingEntities

McadFolderDefinition::AddFromExistingEntities method

McadFolderDefinition::AddHideSituation

McadFolderDefinition::AddHideSituation method

McadFolderDefinition::Children

McadFolderDefinition::Children method

McadFolderDefinition::ChildrenCount

McadFolderDefinition::ChildrenCount property

McadFolderDefinition::ComplexHideSituations

McadFolderDefinition::ComplexHideSituations property

McadFolderDefinition::Extents

McadFolderDefinition::Extents method

McadFolderDefinition::Externalize

McadFolderDefinition::Externalize method

McadFolderDefinition::FindHideSituations

McadFolderDefinition::FindHideSituations method

McadFolderDefinition::FullName

McadFolderDefinition::FullName property

McadFolderDefinition::GetHidesSuppressState

McadFolderDefinition::GetHidesSuppressState method

McadFolderDefinition::HideSituations

McadFolderDefinition::HideSituations property

McadFolderDefinition::InstanceCount

McadFolderDefinition::InstanceCount property

McadFolderDefinition::Instances

McadFolderDefinition::Instances method

McadFolderDefinition::InstancesDefinition

McadFolderDefinition::InstancesDefinition method

McadFolderDefinition::IsAnnotation

McadFolderDefinition::IsAnnotation property

McadFolderDefinition::IsDetail

McadFolderDefinition::IsDetail property

McadFolderDefinition::IsExternal

McadFolderDefinition::IsExternal method

McadFolderDefinition::IsLocked

McadFolderDefinition::IsLocked property

McadFolderDefinition::IsRoot

McadFolderDefinition::IsRoot property

McadFolderDefinition::Localize

McadFolderDefinition::Localize method

McadFolderDefinition::LockType

McadFolderDefinition::LockType property

McadFolderDefinition::LookupViewName

McadFolderDefinition::LookupViewName method

McadFolderDefinition::Name

McadFolderDefinition::Name property

McadFolderDefinition::NextViewName

McadFolderDefinition::NextViewName method

McadFolderDefinition::Occurrences

McadFolderDefinition::Occurrences method

McadFolderDefinition::RemoveFolder

McadFolderDefinition::RemoveFolder method

McadFolderDefinition::SetHidesSuppressState

McadFolderDefinition::SetHidesSuppressState method

McadFolderDefinition::SortChildren

McadFolderDefinition::SortChildren method

McadFolderDefinition::ViewType

McadFolderDefinition::ViewType property

McadFolderDefinitions

McadFolderDefinitions coclass

about McadFolderDefinitions coclass

McadFolderDefinitions interface

about IMcadFolderDefinitions interface

Add

Application

Count

IMcadFolderDefinitions members

Item

Remove

McadFolderDefinitions::Add

McadFolderDefinitions::Add method

McadFolderDefinitions::Application

McadFolderDefinitions::Application property

McadFolderDefinitions::Count

McadFolderDefinitions::Count property

McadFolderDefinitions::Item

McadFolderDefinitions::Item method

McadFolderDefinitions::Remove

McadFolderDefinitions::Remove method

McadFolderDescriptor

McadFolderDescriptor coclass

about McadFolderDescriptor coclass

McadFolderDescriptor interface

about IMcadFolderDescriptor interface

CreateFolder

Definition

Entities

Entities32

IMcadFolderDescriptor members

Position

PowerObjectType

TargetView

ViewKey

ViewName

Views

McadFolderDescriptor::CreateFolder

McadFolderDescriptor::CreateFolder method

McadFolderDescriptor::Definition

McadFolderDescriptor::Definition property

McadFolderDescriptor::Entities

McadFolderDescriptor::Entities property

McadFolderDescriptor::Entities32

McadFolderDescriptor::Entities32 property

McadFolderDescriptor::Position

McadFolderDescriptor::Position property

McadFolderDescriptor::PowerObjectType

McadFolderDescriptor::PowerObjectType property

McadFolderDescriptor::TargetView

McadFolderDescriptor::TargetView property

McadFolderDescriptor::ViewKey

McadFolderDescriptor::ViewKey property

McadFolderDescriptor::ViewName

McadFolderDescriptor::ViewName property

McadFolderDescriptor::Views

McadFolderDescriptor::Views property

McadFolders

McadFolders coclass

about McadFolders coclass

McadFolders interface

about IMcadFolders interface

Add

Application

Count

IMcadFolders members

Item

Remove

McadFolders::Add

McadFolders::Add method

McadFolders::Application

McadFolders::Application property

McadFolders::Count

McadFolders::Count property

McadFolders::Item

McadFolders::Item method

McadFolders::Remove

McadFolders::Remove method

McadFormulaEvaluator

McadFormulaEvaluator coclass

about McadFormulaEvaluator coclass

McadFormulaEvaluator interface

about IMcadFormulaEvaluator interface

Application

Evaluate

Exist

GetAllAttribs

GetAllAttribsData

GetAllAttribValues

GetData

IMcadFormulaEvaluator members

IsEditable

SetData

SetDataProvider

McadFormulaEvaluator::Application

McadFormulaEvaluator::Application property

McadFormulaEvaluator::Evaluate

McadFormulaEvaluator::Evaluate method

McadFormulaEvaluator::Exist

McadFormulaEvaluator::Exist method

McadFormulaEvaluator::GetAllAttribs

McadFormulaEvaluator::GetAllAttribs method

McadFormulaEvaluator::GetAllAttribsData

McadFormulaEvaluator::GetAllAttribsData method

McadFormulaEvaluator::GetAllAttribValues

McadFormulaEvaluator::GetAllAttribValues method

McadFormulaEvaluator::GetData

McadFormulaEvaluator::GetData method

McadFormulaEvaluator::IsEditable

McadFormulaEvaluator::IsEditable method

McadFormulaEvaluator::SetData

McadFormulaEvaluator::SetData method

McadFormulaEvaluator::SetDataProvider

McadFormulaEvaluator::SetDataProvider method

McadGDTSymbolType

McadGDTSymbolType enumeration

McadGeometry

McadGeometry interface

about IMcadGeometry interface

AddAttribute

ContainingComponent

Geometry

GetAttributes

HasChanged

IMcadGeometry members

RemoveAttribute

McadGeometry::AddAttribute

McadGeometry::AddAttribute method

McadGeometry::ContainingComponent

McadGeometry::ContainingComponent method

McadGeometry::Geometry

McadGeometry::Geometry property

McadGeometry::GetAttributes

McadGeometry::GetAttributes method

McadGeometry::HasChanged

McadGeometry::HasChanged method

McadGeometry::RemoveAttribute

McadGeometry::RemoveAttribute method

McadHideSituation

McadHideSituation coclass

about McadHideSituation coclass

McadHideSituation interface

about IMcadHideSituation interface

AddMSSubent

AddMSSubents

AddSubent

AddSubents

AutoSelectBackground

BgSelectionName

ClearSubents

Concealed

ContoursOnlyInForeground

Definition

FgSelectionName

HiddenLinesInvisible

HideAppropriateObjectsOnly

IgnoreBgExclude

IgnoreFgExclude

IgnoreUpperBgExclude

IMcadHideSituation members

InverseForeground

IsComplexHideLevel

IsLastLevel

IsMigrated

IsModifiedStandardPartHide

IsStandardPartHide

LevelIndex

Name

OuterContourOnly

ParentHide

RemoveSubent

RemoveSubentByIdx

SaveSimplifiedOuterContour

Subents

Suppressed

SwapFgAndBg

SysName

McadHideSituation::AddMSSubent

McadHideSituation::AddMSSubent method

McadHideSituation::AddMSSubents

McadHideSituation::AddMSSubents method

McadHideSituation::AddSubent

McadHideSituation::AddSubent method

McadHideSituation::AddSubents

McadHideSituation::AddSubents method

McadHideSituation::AutoSelectBackground

McadHideSituation::AutoSelectBackground method

McadHideSituation::BgSelectionName

McadHideSituation::BgSelectionName property

McadHideSituation::ClearSubents

McadHideSituation::ClearSubents method

McadHideSituation::Concealed

McadHideSituation::Concealed property

McadHideSituation::ContoursOnlyInForeground

McadHideSituation::ContoursOnlyInForeground property

McadHideSituation::Definition

McadHideSituation::Definition property

McadHideSituation::FgSelectionName

McadHideSituation::FgSelectionName property

McadHideSituation::HiddenLinesInvisible

McadHideSituation::HiddenLinesInvisible property

McadHideSituation::HideAppropriateObjectsOnly

McadHideSituation::HideAppropriateObjectsOnly property

McadHideSituation::IgnoreBgExclude

McadHideSituation::IgnoreBgExclude property

McadHideSituation::IgnoreFgExclude

McadHideSituation::IgnoreFgExclude property

McadHideSituation::IgnoreUpperBgExclude

McadHideSituation::IgnoreUpperBgExclude property

McadHideSituation::InverseForeground

McadHideSituation::InverseForeground property

McadHideSituation::IsComplexHideLevel

McadHideSituation::IsComplexHideLevel property

McadHideSituation::IsLastLevel

McadHideSituation::IsLastLevel property

McadHideSituation::IsMigrated

McadHideSituation::IsMigrated property

McadHideSituation::IsModifiedStandardPartHide

McadHideSituation::IsModifiedStandardPartHide property

McadHideSituation::IsStandardPartHide

McadHideSituation::IsStandardPartHide property

McadHideSituation::LevelIndex

McadHideSituation::LevelIndex property

McadHideSituation::Name

McadHideSituation::Name property

McadHideSituation::OuterContourOnly

McadHideSituation::OuterContourOnly property

McadHideSituation::ParentHide

McadHideSituation::ParentHide property

McadHideSituation::RemoveSubent

McadHideSituation::RemoveSubent method

McadHideSituation::RemoveSubentByIdx

McadHideSituation::RemoveSubentByIdx method

McadHideSituation::SaveSimplifiedOuterContour

McadHideSituation::SaveSimplifiedOuterContour property

McadHideSituation::Subents

McadHideSituation::Subents method

McadHideSituation::Suppressed

McadHideSituation::Suppressed property

McadHideSituation::SwapFgAndBg

McadHideSituation::SwapFgAndBg method

McadHideSituation::SysName

McadHideSituation::SysName property

McadHideSituationRefType

McadHideSituationRefType enumeration

McadHideSituations

McadHideSituations coclass

about McadHideSituations coclass

McadHideSituations interface

about IMcadHideSituations interface

Add

Application

Count

IMcadHideSituations members

Item

Remove

McadHideSituations::Add

McadHideSituations::Add method

McadHideSituations::Application

McadHideSituations::Application property

McadHideSituations::Count

McadHideSituations::Count property

McadHideSituations::Item

McadHideSituations::Item method

McadHideSituations::Remove

McadHideSituations::Remove method

McadHideSituationSubentType

McadHideSituationSubentType enumeration

McadIdentificationType

McadIdentificationType enumeration

McadIdentifier

McadIdentifier coclass

about McadIdentifier coclass

McadIdentifier interface

about IMcadIdentifier interface

IMcadIdentifier members

Value

McadIdentifier::Value

McadIdentifier::Value property

McadIdentifierPositionType

McadIdentifierPositionType enumeration

McadIdentifierStandard

McadIdentifierStandard coclass

about McadIdentifierStandard coclass

McadIdentifierStandard interface

about IMcadIdentifierStandard interface

DefaultArrowType

IMcadIdentifierStandard members

IsDatumIDSupported

IsFeatureIDSupported

McadIdentifierStandard::DefaultArrowType

McadIdentifierStandard::DefaultArrowType property

McadIdentifierStandard::IsDatumIDSupported

McadIdentifierStandard::IsDatumIDSupported property

McadIdentifierStandard::IsFeatureIDSupported

McadIdentifierStandard::IsFeatureIDSupported property

McadIdentifierStandard2

McadIdentifierStandard2 interface

about IMcadIdentifierStandard2 interface

FarSideLeaderLineType

FarSideLeaderLineTypeName

IMcadIdentifierStandard2 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadIdentifierStandard2::FarSideLeaderLineType

McadIdentifierStandard2::FarSideLeaderLineType property

McadIdentifierStandard2::FarSideLeaderLineTypeName

McadIdentifierStandard2::FarSideLeaderLineTypeName property

McadIdentifierStandard2::SurfIndLeaderArrowScale

McadIdentifierStandard2::SurfIndLeaderArrowScale property

McadIdentifierStandard2::SurfIndLeaderArrowType

McadIdentifierStandard2::SurfIndLeaderArrowType property

McadJoint

McadJoint coclass

about McadJoint coclass

McadJoint interface

about IMcadJoint interface

AllAround

Annotation

IMcadJoint members

Orientation

SecAnnotation

SymbolType

McadJoint::AllAround

McadJoint::AllAround property

McadJoint::Annotation

McadJoint::Annotation property

McadJoint::Orientation

McadJoint::Orientation property

McadJoint::SecAnnotation

McadJoint::SecAnnotation property

McadJoint::SymbolType

McadJoint::SymbolType property

McadJointStandard

McadJointStandard coclass

about McadJointStandard coclass

McadJointStandard interface

about IMcadJointStandard interface

McadJointType

McadJointType enumeration

McadLayerCfg

McadLayerCfg coclass

about McadLayerCfg coclass

McadLayerCfg interface

about IMcadLayerCfg interface

AssocObjects

Desc

IMcadLayerCfg members

Invisible

Key

LineType

LineTypeId

LineTypeId32

LineWeight

Name

NoPlot

NoReplicateInLayerGroup

OverrideColorByLayerGroup

TrueColor

McadLayerCfg::AssocObjects

McadLayerCfg::AssocObjects property

McadLayerCfg::Desc

McadLayerCfg::Desc property

McadLayerCfg::Invisible

McadLayerCfg::Invisible property

McadLayerCfg::Key

McadLayerCfg::Key property

McadLayerCfg::LineType

McadLayerCfg::LineType property

McadLayerCfg::LineTypeId

McadLayerCfg::LineTypeId property

McadLayerCfg::LineTypeId32

McadLayerCfg::LineTypeId32 property

McadLayerCfg::LineWeight

McadLayerCfg::LineWeight property

McadLayerCfg::Name

McadLayerCfg::Name property

McadLayerCfg::NoPlot

McadLayerCfg::NoPlot property

McadLayerCfg::NoReplicateInLayerGroup

McadLayerCfg::NoReplicateInLayerGroup property

McadLayerCfg::OverrideColorByLayerGroup

McadLayerCfg::OverrideColorByLayerGroup property

McadLayerCfg::TrueColor

McadLayerCfg::TrueColor property

McadLayerCfgs

McadLayerCfgs coclass

about McadLayerCfgs coclass

McadLayerCfgs interface

_NewEnum

about IMcadLayerCfgs interface

Add

Application

Count

IMcadLayerCfgs members

Item

Remove

McadLayerCfgs::_NewEnum

McadLayerCfgs::_NewEnum property

McadLayerCfgs::Add

McadLayerCfgs::Add method

McadLayerCfgs::Application

McadLayerCfgs::Application property

McadLayerCfgs::Count

McadLayerCfgs::Count property

McadLayerCfgs::Item

McadLayerCfgs::Item method

McadLayerCfgs::Remove

McadLayerCfgs::Remove method

McadLayerGroupMgr

McadLayerGroupMgr coclass

about McadLayerGroupMgr coclass

McadLayerGroupMgr interface

about IMcadLayerGroupMgr interface

Document

GetLayerGroupEntities

GetLayerGroupEntities32

GetLayerGroupNames

GetLayersFromGroup

IMcadLayerGroupMgr members

MoveLayerGroupEntities

McadLayerGroupMgr::Document

McadLayerGroupMgr::Document property

McadLayerGroupMgr::GetLayerGroupEntities

McadLayerGroupMgr::GetLayerGroupEntities method

McadLayerGroupMgr::GetLayerGroupEntities32

McadLayerGroupMgr::GetLayerGroupEntities32 method

McadLayerGroupMgr::GetLayerGroupNames

McadLayerGroupMgr::GetLayerGroupNames method

McadLayerGroupMgr::GetLayersFromGroup

McadLayerGroupMgr::GetLayersFromGroup method

McadLayerGroupMgr::MoveLayerGroupEntities

McadLayerGroupMgr::MoveLayerGroupEntities method

McadLayerObjectCfg

McadLayerObjectCfg coclass

about McadLayerObjectCfg coclass

McadLayerObjectCfg interface

about IMcadLayerObjectCfg interface

Hide

IMcadLayerObjectCfg members

LayerName

LayerObjKey

LineType

LineTypeId

LineTypeId32

LineWeight

TrueColor

McadLayerObjectCfg::Hide

McadLayerObjectCfg::Hide property

McadLayerObjectCfg::LayerName

McadLayerObjectCfg::LayerName property

McadLayerObjectCfg::LayerObjKey

McadLayerObjectCfg::LayerObjKey property

McadLayerObjectCfg::LineType

McadLayerObjectCfg::LineType property

McadLayerObjectCfg::LineTypeId

McadLayerObjectCfg::LineTypeId property

McadLayerObjectCfg::LineTypeId32

McadLayerObjectCfg::LineTypeId32 property

McadLayerObjectCfg::LineWeight

McadLayerObjectCfg::LineWeight property

McadLayerObjectCfg::TrueColor

McadLayerObjectCfg::TrueColor property

McadLayerObjectCfgs

McadLayerObjectCfgs coclass

about McadLayerObjectCfgs coclass

McadLayerObjectCfgs interface

_NewEnum

about IMcadLayerObjectCfgs interface

Add

Application

Count

IMcadLayerObjectCfgs members

Item

Remove

McadLayerObjectCfgs::_NewEnum

McadLayerObjectCfgs::_NewEnum property

McadLayerObjectCfgs::Add

McadLayerObjectCfgs::Add method

McadLayerObjectCfgs::Application

McadLayerObjectCfgs::Application property

McadLayerObjectCfgs::Count

McadLayerObjectCfgs::Count property

McadLayerObjectCfgs::Item

McadLayerObjectCfgs::Item method

McadLayerObjectCfgs::Remove

McadLayerObjectCfgs::Remove method

McadLayerObjectHideType

McadLayerObjectHideType enumeration

McadLayerObjectMgr

McadLayerObjectMgr coclass

about McadLayerObjectMgr coclass

McadLayerObjectMgr interface

about IMcadLayerObjectMgr interface

CreateLayer

Document

GetAllLayerObjs

GetAllLayers

GetLayerObjProperty

GetLayerProperty

IMcadLayerObjectMgr members

ImportLayerObj

SetLayerObjDefault

McadLayerObjectMgr::CreateLayer

McadLayerObjectMgr::CreateLayer method

McadLayerObjectMgr::Document

McadLayerObjectMgr::Document property

McadLayerObjectMgr::GetAllLayerObjs

McadLayerObjectMgr::GetAllLayerObjs method

McadLayerObjectMgr::GetAllLayers

McadLayerObjectMgr::GetAllLayers method

McadLayerObjectMgr::GetLayerObjProperty

McadLayerObjectMgr::GetLayerObjProperty method

McadLayerObjectMgr::GetLayerProperty

McadLayerObjectMgr::GetLayerProperty method

McadLayerObjectMgr::ImportLayerObj

McadLayerObjectMgr::ImportLayerObj method

McadLayerObjectMgr::SetLayerObjDefault

McadLayerObjectMgr::SetLayerObjDefault method

McadLine

McadLine coclass

about McadLine coclass

McadLine interface

about IMcadLine interface

McadLineVisibility

McadLineVisibility enumeration

McadMarkStamp

McadMarkStamp coclass

about McadMarkStamp coclass

McadMarkStamp interface

about IMcadMarkStamp interface

ContentValue

IMcadMarkStamp members

MethodValue

SymbolType

TechnicalReqValue

McadMarkStamp::ContentValue

McadMarkStamp::ContentValue property

McadMarkStamp::MethodValue

McadMarkStamp::MethodValue property

McadMarkStamp::SymbolType

McadMarkStamp::SymbolType property

McadMarkStamp::TechnicalReqValue

McadMarkStamp::TechnicalReqValue property

McadMarkStampStandard

McadMarkStampStandard coclass

about McadMarkStampStandard coclass

McadMarkStampStandard interface

about IMcadMarkStampStandard interface

AvailableMarkingContents

AvailableMarkingMethods

AvailableStampingContents

AvailableStampingMethods

IMcadMarkStampStandard members

OfferedMarkingContents

OfferedMarkingMethods

OfferedStampingContents

OfferedStampingMethods

McadMarkStampStandard::AvailableMarkingContents

McadMarkStampStandard::AvailableMarkingContents property

McadMarkStampStandard::AvailableMarkingMethods

McadMarkStampStandard::AvailableMarkingMethods property

McadMarkStampStandard::AvailableStampingContents

McadMarkStampStandard::AvailableStampingContents property

McadMarkStampStandard::AvailableStampingMethods

McadMarkStampStandard::AvailableStampingMethods property

McadMarkStampStandard::OfferedMarkingContents

McadMarkStampStandard::OfferedMarkingContents property

McadMarkStampStandard::OfferedMarkingMethods

McadMarkStampStandard::OfferedMarkingMethods property

McadMarkStampStandard::OfferedStampingContents

McadMarkStampStandard::OfferedStampingContents property

McadMarkStampStandard::OfferedStampingMethods

McadMarkStampStandard::OfferedStampingMethods property

McadNote

McadNote coclass

about McadNote coclass

McadNote interface

about IMcadNote interface

AdjustLanding

CreateNoteText

EvaluatedNoteText

IMcadNote members

IsLeftOriented

Landing

LeaderAttachPoint

NoteText

TextAlignment

McadNote::AdjustLanding

McadNote::AdjustLanding method

McadNote::CreateNoteText

McadNote::CreateNoteText method

McadNote::EvaluatedNoteText

McadNote::EvaluatedNoteText property

McadNote::IsLeftOriented

McadNote::IsLeftOriented property

McadNote::Landing

McadNote::Landing property

McadNote::LeaderAttachPoint

McadNote::LeaderAttachPoint property

McadNote::NoteText

McadNote::NoteText property

McadNote::TextAlignment

McadNote::TextAlignment property

McadNoteAttachPointType

McadNoteAttachPointType enumeration

McadNoteStandard

McadNoteStandard coclass

about McadNoteStandard coclass

McadNoteStandard interface

about IMcadNoteStandard interface

AddTemplate

ChangeTemplateValue

DeleteAllTemplates

DeleteTemplate

GetAllTemplates

GetFeatureTypes

GetTemplateGroup

GetTemplateValue

IMcadNoteStandard members

Landing

LeaderAttachPoint

NumberOfTemplateGroups

RenameTemplate

SetCompatibilityCondition

SetToDefaultTemplate

McadNoteStandard::AddTemplate

McadNoteStandard::AddTemplate method

McadNoteStandard::ChangeTemplateValue

McadNoteStandard::ChangeTemplateValue method

McadNoteStandard::DeleteAllTemplates

McadNoteStandard::DeleteAllTemplates method

McadNoteStandard::DeleteTemplate

McadNoteStandard::DeleteTemplate method

McadNoteStandard::GetAllTemplates

McadNoteStandard::GetAllTemplates method

McadNoteStandard::GetFeatureTypes

McadNoteStandard::GetFeatureTypes method

McadNoteStandard::GetTemplateGroup

McadNoteStandard::GetTemplateGroup method

McadNoteStandard::GetTemplateValue

McadNoteStandard::GetTemplateValue method

McadNoteStandard::Landing

McadNoteStandard::Landing property

McadNoteStandard::LeaderAttachPoint

McadNoteStandard::LeaderAttachPoint property

McadNoteStandard::NumberOfTemplateGroups

McadNoteStandard::NumberOfTemplateGroups method

McadNoteStandard::RenameTemplate

McadNoteStandard::RenameTemplate method

McadNoteStandard::SetCompatibilityCondition

McadNoteStandard::SetCompatibilityCondition method

McadNoteStandard::SetToDefaultTemplate

McadNoteStandard::SetToDefaultTemplate method

McadNoteTemplateGroupType

McadNoteTemplateGroupType enumeration

McadObject

McadObject interface

about IMcadObject interface

Application

Delete

Document

Editable

Highlight

IMcadObject members

IsEqualTo

MakePersistent

WasErased

McadObject::Application

McadObject::Application property

McadObject::Delete

McadObject::Delete method

McadObject::Document

McadObject::Document property

McadObject::Editable

McadObject::Editable property

McadObject::Highlight

McadObject::Highlight method

McadObject::IsEqualTo

McadObject::IsEqualTo method

McadObject::MakePersistent

McadObject::MakePersistent method

McadObject::WasErased

McadObject::WasErased property

McadObjects

McadObjects coclass

about McadObjects coclass

McadObjects interface

about IMcadObjects interface

Add

Application

Count

IMcadObjects members

Item

Remove

McadObjects::Add

McadObjects::Add method

McadObjects::Application

McadObjects::Application property

McadObjects::Count

McadObjects::Count property

McadObjects::Item

McadObjects::Item method

McadObjects::Remove

McadObjects::Remove method

McadObjectType

McadObjectType enumeration

McadOrientation

McadOrientation enumeration

McadPartList

McadPartList coclass

about McadPartList coclass

McadPartList interface

about IMcadPartList interface

AddFilter

AttachmentPoint

BOM

CustomBlockName

CustomBlocks

FilterEmptyBlocks

Filters

Height

IMcadPartList members

IsCustomBlockUsed

IsHeadingEnabled

IsTitleEnabled

ItemList

MappingName

MultipleRow

RemoveFilter

Title

ViewID

ViewID32

Width

WrapText

McadPartList::AddFilter

McadPartList::AddFilter method

McadPartList::AttachmentPoint

McadPartList::AttachmentPoint property

McadPartList::BOM

McadPartList::BOM property

McadPartList::CustomBlockName

McadPartList::CustomBlockName property

McadPartList::CustomBlocks

McadPartList::CustomBlocks property

McadPartList::FilterEmptyBlocks

McadPartList::FilterEmptyBlocks property

McadPartList::Filters

McadPartList::Filters property

McadPartList::Height

McadPartList::Height property

McadPartList::IsCustomBlockUsed

McadPartList::IsCustomBlockUsed property

McadPartList::IsHeadingEnabled

McadPartList::IsHeadingEnabled property

McadPartList::IsTitleEnabled

McadPartList::IsTitleEnabled property

McadPartList::ItemList

McadPartList::ItemList property

McadPartList::MappingName

McadPartList::MappingName property

McadPartList::MultipleRow

McadPartList::MultipleRow property

McadPartList::RemoveFilter

McadPartList::RemoveFilter method

McadPartList::Title

McadPartList::Title property

McadPartList::ViewID

McadPartList::ViewID property

McadPartList::ViewID32

McadPartList::ViewID32 property

McadPartList::Width

McadPartList::Width property

McadPartList::WrapText

McadPartList::WrapText property

McadPartList2

McadPartList2 interface

about IMcadPartList2 interface

AddFilterType

ColumnSplitEnabled

ColumnSplitRows

ColumnSplitSections

ColumnSplitStyle

ColumnSplitWrap

FormulaBarEnabled

GripFrameEnabled

HeadingTextControl

IMcadPartList2 members

ResultBarEnabled

RowTextControl

McadPartList2::AddFilterType

McadPartList2::AddFilterType method

McadPartList2::ColumnSplitEnabled

McadPartList2::ColumnSplitEnabled property

McadPartList2::ColumnSplitRows

McadPartList2::ColumnSplitRows property

McadPartList2::ColumnSplitSections

McadPartList2::ColumnSplitSections property

McadPartList2::ColumnSplitStyle

McadPartList2::ColumnSplitStyle property

McadPartList2::ColumnSplitWrap

McadPartList2::ColumnSplitWrap property

McadPartList2::FormulaBarEnabled

McadPartList2::FormulaBarEnabled property

McadPartList2::GripFrameEnabled

McadPartList2::GripFrameEnabled property

McadPartList2::HeadingTextControl

McadPartList2::HeadingTextControl property

McadPartList2::ResultBarEnabled

McadPartList2::ResultBarEnabled property

McadPartList2::RowTextControl

McadPartList2::RowTextControl property

McadPartList3

McadPartList3 interface

about IMcadPartList3 interface

IMcadPartList3 members

setWrapPListAttachPoint

WrapAroundTitle

WrapTitleBlockId

WrapTitleBlockId32

McadPartList3::setWrapPListAttachPoint

McadPartList3::setWrapPListAttachPoint method

McadPartList3::WrapAroundTitle

McadPartList3::WrapAroundTitle property

McadPartList3::WrapTitleBlockId

McadPartList3::WrapTitleBlockId property

McadPartList3::WrapTitleBlockId32

McadPartList3::WrapTitleBlockId32 property

McadPartListBalloonedFilter

McadPartListBalloonedFilter coclass

about McadPartListBalloonedFilter coclass

McadPartListBalloonedFilter interface

about IMcadPartListBalloonedFilter interface

McadPartListCustomFilter

McadPartListCustomFilter coclass

about McadPartListCustomFilter coclass

McadPartListCustomFilter interface

about IMcadPartListCustomFilter interface

IMcadPartListCustomFilter members

Operator

PropertyName

PropertyValue

SetCondition

McadPartListCustomFilter::Operator

McadPartListCustomFilter::Operator property

McadPartListCustomFilter::PropertyName

McadPartListCustomFilter::PropertyName property

McadPartListCustomFilter::PropertyValue

McadPartListCustomFilter::PropertyValue property

McadPartListCustomFilter::SetCondition

McadPartListCustomFilter::SetCondition method

McadPartListFilter

McadPartListFilter coclass

about McadPartListFilter coclass

McadPartListFilter interface

about IMcadPartListFilter interface

Evaluate

IMcadPartListFilter members

IsOn

Name

McadPartListFilter::Evaluate

McadPartListFilter::Evaluate method

McadPartListFilter::IsOn

McadPartListFilter::IsOn property

McadPartListFilter::Name

McadPartListFilter::Name property

McadPartListFilter2

McadPartListFilter2 interface

about IMcadPartListFilter2 interface

Excluded

IMcadPartListFilter2 members

Type

McadPartListFilter2::Excluded

McadPartListFilter2::Excluded property

McadPartListFilter2::Type

McadPartListFilter2::Type property

McadPartListFilters

McadPartListFilters coclass

about McadPartListFilters coclass

McadPartListFilters interface

about IMcadPartListFilters interface

Add

Application

Count

IMcadPartListFilters members

Item

Remove

McadPartListFilters::Add

McadPartListFilters::Add method

McadPartListFilters::Application

McadPartListFilters::Application property

McadPartListFilters::Count

McadPartListFilters::Count property

McadPartListFilters::Item

McadPartListFilters::Item method

McadPartListFilters::Remove

McadPartListFilters::Remove method

McadPartListGOST

McadPartListGOST coclass

about McadPartListGOST coclass

McadPartListGOST interface

about IMcadPartListGOST interface

IMcadPartListGOST members

SkipAfterPart

SkipLines

McadPartListGOST::SkipAfterPart

McadPartListGOST::SkipAfterPart property

McadPartListGOST::SkipLines

McadPartListGOST::SkipLines property

McadPartLists

McadPartLists coclass

about McadPartLists coclass

McadPartLists interface

about IMcadPartLists interface

Add

Application

Count

IMcadPartLists members

Item

Remove

McadPartLists::Add

McadPartLists::Add method

McadPartLists::Application

McadPartLists::Application property

McadPartLists::Count

McadPartLists::Count property

McadPartLists::Item

McadPartLists::Item method

McadPartLists::Remove

McadPartLists::Remove method

McadPartListStandard

McadPartListStandard coclass

about McadPartListStandard coclass

McadPartListStandard interface

about IMcadPartListStandard interface

ActualRowTextHeight

Application

AttachmentPoint

BOMStandard

ColumnList

CustomBlockName

CustomBlocks

FilterEmptyBlocks

FrameColor

HeadingGap

HeadingHeight

HeadingTextColor

HeadingTextHeight

IMcadPartListStandard members

IsCustomBlockUsed

IsHeadingEnabled

IsTitleEnabled

MulipleRow

RemoveColumn

Revision

RevisionYear

RowGap

RowHeight

SetToDefaults

UseMapping

WrapText

McadPartListStandard::ActualRowTextHeight

McadPartListStandard::ActualRowTextHeight property

McadPartListStandard::Application

McadPartListStandard::Application property

McadPartListStandard::AttachmentPoint

McadPartListStandard::AttachmentPoint property

McadPartListStandard::BOMStandard

McadPartListStandard::BOMStandard property

McadPartListStandard::ColumnList

McadPartListStandard::ColumnList property

McadPartListStandard::CustomBlockName

McadPartListStandard::CustomBlockName property

McadPartListStandard::CustomBlocks

McadPartListStandard::CustomBlocks property

McadPartListStandard::FilterEmptyBlocks

McadPartListStandard::FilterEmptyBlocks property

McadPartListStandard::FrameColor

McadPartListStandard::FrameColor property

McadPartListStandard::HeadingGap

McadPartListStandard::HeadingGap property

McadPartListStandard::HeadingHeight

McadPartListStandard::HeadingHeight property

McadPartListStandard::HeadingTextColor

McadPartListStandard::HeadingTextColor property

McadPartListStandard::HeadingTextHeight

McadPartListStandard::HeadingTextHeight property

McadPartListStandard::IsCustomBlockUsed

McadPartListStandard::IsCustomBlockUsed property

McadPartListStandard::IsHeadingEnabled

McadPartListStandard::IsHeadingEnabled property

McadPartListStandard::IsTitleEnabled

McadPartListStandard::IsTitleEnabled property

McadPartListStandard::MulipleRow

McadPartListStandard::MulipleRow property

McadPartListStandard::RemoveColumn

McadPartListStandard::RemoveColumn method

McadPartListStandard::Revision

McadPartListStandard::Revision property

McadPartListStandard::RevisionYear

McadPartListStandard::RevisionYear property

McadPartListStandard::RowGap

McadPartListStandard::RowGap property

McadPartListStandard::RowHeight

McadPartListStandard::RowHeight property

McadPartListStandard::SetToDefaults

McadPartListStandard::SetToDefaults method

McadPartListStandard::UseMapping

McadPartListStandard::UseMapping property

McadPartListStandard::WrapText

McadPartListStandard::WrapText property

McadPartListStandard2

McadPartListStandard2 interface

about IMcadPartListStandard2 interface

FrameTrueColor

HeadingTextTrueColor

IMcadPartListStandard2 members

McadPartListStandard2::FrameTrueColor

McadPartListStandard2::FrameTrueColor property

McadPartListStandard2::HeadingTextTrueColor

McadPartListStandard2::HeadingTextTrueColor property

McadPartListStandard3

McadPartListStandard3 interface

about IMcadPartListStandard3 interface

BoldVerticalLine

ColumnSplitEnabled

ColumnSplitRows

ColumnSplitSections

ColumnSplitStyle

ColumnSplitWrap

GripFrameEnabled

HeadingTextControl

HeadingTextMarginBottom

HeadingTextMarginLeft

HeadingTextMarginRight

HeadingTextMarginTop

HeadingTextStyle

IMcadPartListStandard3 members

RowTextColor

RowTextControl

RowTextHeight

RowTextMarginBottom

RowTextMarginLeft

RowTextMarginRight

RowTextMarginTop

RowTextStyle

RowTextTrueColor

McadPartListStandard3::BoldVerticalLine

McadPartListStandard3::BoldVerticalLine property

McadPartListStandard3::ColumnSplitEnabled

McadPartListStandard3::ColumnSplitEnabled property

McadPartListStandard3::ColumnSplitRows

McadPartListStandard3::ColumnSplitRows property

McadPartListStandard3::ColumnSplitSections

McadPartListStandard3::ColumnSplitSections property

McadPartListStandard3::ColumnSplitStyle

McadPartListStandard3::ColumnSplitStyle property

McadPartListStandard3::ColumnSplitWrap

McadPartListStandard3::ColumnSplitWrap property

McadPartListStandard3::GripFrameEnabled

McadPartListStandard3::GripFrameEnabled property

McadPartListStandard3::HeadingTextControl

McadPartListStandard3::HeadingTextControl property

McadPartListStandard3::HeadingTextMarginBottom

McadPartListStandard3::HeadingTextMarginBottom property

McadPartListStandard3::HeadingTextMarginLeft

McadPartListStandard3::HeadingTextMarginLeft property

McadPartListStandard3::HeadingTextMarginRight

McadPartListStandard3::HeadingTextMarginRight property

McadPartListStandard3::HeadingTextMarginTop

McadPartListStandard3::HeadingTextMarginTop property

McadPartListStandard3::HeadingTextStyle

McadPartListStandard3::HeadingTextStyle property

McadPartListStandard3::RowTextColor

McadPartListStandard3::RowTextColor property

McadPartListStandard3::RowTextControl

McadPartListStandard3::RowTextControl property

McadPartListStandard3::RowTextHeight

McadPartListStandard3::RowTextHeight property

McadPartListStandard3::RowTextMarginBottom

McadPartListStandard3::RowTextMarginBottom property

McadPartListStandard3::RowTextMarginLeft

McadPartListStandard3::RowTextMarginLeft property

McadPartListStandard3::RowTextMarginRight

McadPartListStandard3::RowTextMarginRight property

McadPartListStandard3::RowTextMarginTop

McadPartListStandard3::RowTextMarginTop property

McadPartListStandard3::RowTextStyle

McadPartListStandard3::RowTextStyle property

McadPartListStandard3::RowTextTrueColor

McadPartListStandard3::RowTextTrueColor property

McadPartListStandard4

McadPartListStandard4 interface

about IMcadPartListStandard4 interface

ColumnSplitWrapAroundTitle

IMcadPartListStandard4 members

McadPartListStandard4::ColumnSplitWrapAroundTitle

McadPartListStandard4::ColumnSplitWrapAroundTitle property

McadPartListStdPartsFilter

McadPartListStdPartsFilter coclass

about McadPartListStdPartsFilter coclass

McadPartListStdPartsFilter interface

about IMcadPartListStdPartsFilter interface

IMcadPartListStdPartsFilter members

Option

McadPartListStdPartsFilter::Option

McadPartListStdPartsFilter::Option property

McadPartReference

McadPartReference coclass

about McadPartReference coclass

McadPartReference interface

about IMcadPartReference interface

Data

IMcadPartReference members

Quantity

McadPartReference::Data

McadPartReference::Data property

McadPartReference::Quantity

McadPartReference::Quantity property

McadPartReference2

McadPartReference2 interface

about IMcadPartReference2 interface

IMcadPartReference2 members

SetAttributePreDefinedListValue

McadPartReference2::SetAttributePreDefinedListValue

McadPartReference2::SetAttributePreDefinedListValue method

McadPartReference3

McadPartReference3 interface

about IMcadPartReference3 interface

AttachedExternalBom

AttachedExternalBomXrefBlock

AttachExternalBom

DetachExternalBom

GetBomOverride

IMcadPartReference3 members

RemoveAttribute

McadPartReference3::AttachedExternalBom

McadPartReference3::AttachedExternalBom property

McadPartReference3::AttachedExternalBomXrefBlock

McadPartReference3::AttachedExternalBomXrefBlock property

McadPartReference3::AttachExternalBom

McadPartReference3::AttachExternalBom method

McadPartReference3::DetachExternalBom

McadPartReference3::DetachExternalBom method

McadPartReference3::GetBomOverride

McadPartReference3::GetBomOverride method

McadPartReference3::RemoveAttribute

McadPartReference3::RemoveAttribute method

McadPartReferences

McadPartReferences coclass

about McadPartReferences coclass

McadPartReferences interface

_NewEnum

about IMcadPartReferences interface

Add

Application

Count

IMcadPartReferences members

Item

Remove

McadPartReferences::_NewEnum

McadPartReferences::_NewEnum property

McadPartReferences::Add

McadPartReferences::Add method

McadPartReferences::Application

McadPartReferences::Application property

McadPartReferences::Count

McadPartReferences::Count property

McadPartReferences::Item

McadPartReferences::Item method

McadPartReferences::Remove

McadPartReferences::Remove method

McadPhantomState

McadPhantomState enumeration

McadPick

McadPick coclass

about McadPick coclass

McadPick interface

about IMcadPick interface

Application

IMcadPick members

ObjectType

PickPoint

McadPick::Application

McadPick::Application property

McadPick::ObjectType

McadPick::ObjectType property

McadPick::PickPoint

McadPick::PickPoint property

McadPolyline

McadPolyline coclass

about McadPolyline coclass

McadPolyline interface

about IMcadPolyline interface

McadPowerObjectType

McadPowerObjectType enumeration

McadPowObjViewGroupDescriptor

McadPowObjViewGroupDescriptor coclass

about McadPowObjViewGroupDescriptor coclass

McadPowObjViewGroupDescriptor interface

about IMcadPowObjViewGroupDescriptor interface

Entities

Entities32

IMcadPowObjViewGroupDescriptor members

PowerObjectType

TargetView

McadPowObjViewGroupDescriptor::Entities

McadPowObjViewGroupDescriptor::Entities property

McadPowObjViewGroupDescriptor::Entities32

McadPowObjViewGroupDescriptor::Entities32 property

McadPowObjViewGroupDescriptor::PowerObjectType

McadPowObjViewGroupDescriptor::PowerObjectType property

McadPowObjViewGroupDescriptor::TargetView

McadPowObjViewGroupDescriptor::TargetView property

McadRevisionList

McadRevisionList coclass

about McadRevisionList coclass

McadRevisionList interface

about IMcadRevisionList interface

Add

Border

Border32

Count

IMcadRevisionList members

Item

Position

Ref

Ref32

Set

McadRevisionList::Add

McadRevisionList::Add method

McadRevisionList::Border

McadRevisionList::Border property

McadRevisionList::Border32

McadRevisionList::Border32 property

McadRevisionList::Count

McadRevisionList::Count property

McadRevisionList::Item

McadRevisionList::Item method

McadRevisionList::Position

McadRevisionList::Position property

McadRevisionList::Ref

McadRevisionList::Ref property

McadRevisionList::Ref32

McadRevisionList::Ref32 property

McadRevisionList::Set

McadRevisionList::Set method

McadRevisionListDescriptor

McadRevisionListDescriptor coclass

about McadRevisionListDescriptor coclass

McadRevisionListDescriptor interface

about IMcadRevisionListDescriptor interface

Attributes

Border

Border32

IMcadRevisionListDescriptor members

Position

McadRevisionListDescriptor::Attributes

McadRevisionListDescriptor::Attributes property

McadRevisionListDescriptor::Border

McadRevisionListDescriptor::Border property

McadRevisionListDescriptor::Border32

McadRevisionListDescriptor::Border32 property

McadRevisionListDescriptor::Position

McadRevisionListDescriptor::Position property

McadRevisionLists

McadRevisionLists coclass

about McadRevisionLists coclass

McadRevisionLists interface

about IMcadRevisionLists interface

Application

Count

IMcadRevisionLists members

Item

McadRevisionLists::Application

McadRevisionLists::Application property

McadRevisionLists::Count

McadRevisionLists::Count property

McadRevisionLists::Item

McadRevisionLists::Item method

McadRevisionMgr

McadRevisionMgr coclass

about McadRevisionMgr coclass

McadRevisionMgr interface

about IMcadRevisionMgr interface

CreateRevisionList

DeleteRevisionList

GetRevisionListFromRef

IMcadRevisionMgr members

NewDescriptor

RevisionLists

McadRevisionMgr::CreateRevisionList

McadRevisionMgr::CreateRevisionList method

McadRevisionMgr::DeleteRevisionList

McadRevisionMgr::DeleteRevisionList method

McadRevisionMgr::GetRevisionListFromRef

McadRevisionMgr::GetRevisionListFromRef method

McadRevisionMgr::NewDescriptor

McadRevisionMgr::NewDescriptor method

McadRevisionMgr::RevisionLists

McadRevisionMgr::RevisionLists property

McadScaleArea

McadScaleArea coclass

about McadScaleArea coclass

McadScaleArea interface

about IMcadScaleArea interface

AttachObjectId

AttachObjectId32

CreateViewPort

DeleteViewPort

GetAttachedViewportIds

GetAttachedViewportIds32

IMcadScaleArea members

LengthScalingFactor

MoveBorder

RescaleObjects

ScaleType

SetBasicScale

TextScalingFactor

McadScaleArea::AttachObjectId

McadScaleArea::AttachObjectId property

McadScaleArea::AttachObjectId32

McadScaleArea::AttachObjectId32 property

McadScaleArea::CreateViewPort

McadScaleArea::CreateViewPort method

McadScaleArea::DeleteViewPort

McadScaleArea::DeleteViewPort method

McadScaleArea::GetAttachedViewportIds

McadScaleArea::GetAttachedViewportIds method

McadScaleArea::GetAttachedViewportIds32

McadScaleArea::GetAttachedViewportIds32 method

McadScaleArea::LengthScalingFactor

McadScaleArea::LengthScalingFactor property

McadScaleArea::MoveBorder

McadScaleArea::MoveBorder method

McadScaleArea::RescaleObjects

McadScaleArea::RescaleObjects method

McadScaleArea::ScaleType

McadScaleArea::ScaleType property

McadScaleArea::SetBasicScale

McadScaleArea::SetBasicScale method

McadScaleArea::TextScalingFactor

McadScaleArea::TextScalingFactor property

McadScaleAreaMgr

McadScaleAreaMgr coclass

about McadScaleAreaMgr coclass

McadScaleAreaMgr interface

about IMcadScaleAreaMgr interface

CreateScaleArea

DeleteScaleArea

FindScaleArea

IMcadScaleAreaMgr members

McadScaleAreaMgr::CreateScaleArea

McadScaleAreaMgr::CreateScaleArea method

McadScaleAreaMgr::DeleteScaleArea

McadScaleAreaMgr::DeleteScaleArea method

McadScaleAreaMgr::FindScaleArea

McadScaleAreaMgr::FindScaleArea method

McadScaleType

McadScaleType enumeration

McadSectionLine

McadSectionLine coclass

about McadSectionLine coclass

McadSectionLine interface

about IMcadSectionLine interface

AddSectionPoint

ArrowVisibility

IMcadSectionLine members

LabelName

LabelNamesCount

LabelPattern

LabelText

LabelVisibility

LineVisibility

PlaneSymbolsVisibility

SectionPoints

SectionSide

SetLabelNames

SetSectionArcPointAt

SetSectionPointAt

SetSectionPoints

SetSectionViewOrigin

McadSectionLine::AddSectionPoint

McadSectionLine::AddSectionPoint method

McadSectionLine::ArrowVisibility

McadSectionLine::ArrowVisibility property

McadSectionLine::LabelName

McadSectionLine::LabelName method

McadSectionLine::LabelNamesCount

McadSectionLine::LabelNamesCount property

McadSectionLine::LabelPattern

McadSectionLine::LabelPattern property

McadSectionLine::LabelText

McadSectionLine::LabelText property

McadSectionLine::LabelVisibility

McadSectionLine::LabelVisibility property

McadSectionLine::LineVisibility

McadSectionLine::LineVisibility property

McadSectionLine::PlaneSymbolsVisibility

McadSectionLine::PlaneSymbolsVisibility property

McadSectionLine::SectionPoints

McadSectionLine::SectionPoints property

McadSectionLine::SectionSide

McadSectionLine::SectionSide property

McadSectionLine::SetLabelNames

McadSectionLine::SetLabelNames method

McadSectionLine::SetSectionArcPointAt

McadSectionLine::SetSectionArcPointAt method

McadSectionLine::SetSectionPointAt

McadSectionLine::SetSectionPointAt method

McadSectionLine::SetSectionPoints

McadSectionLine::SetSectionPoints method

McadSectionLine::SetSectionViewOrigin

McadSectionLine::SetSectionViewOrigin method

McadSectionLineSegmentType

McadSectionLineSegmentType enumeration

McadSectionLineStandard

McadSectionLineStandard coclass

about McadSectionLineStandard coclass

McadSectionLineStandard interface

about IMcadSectionLineStandard interface

ArrowTowardsLine

ArrowVisibility

IMcadSectionLineStandard members

LabelAbove

LabelPattern

LabelVisibility

LineColor

LineTrueColor

LineVisibility

LineWeight

MultipleNamesSupported

PlaneSymbolsVisibility

McadSectionLineStandard::ArrowTowardsLine

McadSectionLineStandard::ArrowTowardsLine property

McadSectionLineStandard::ArrowVisibility

McadSectionLineStandard::ArrowVisibility property

McadSectionLineStandard::LabelAbove

McadSectionLineStandard::LabelAbove property

McadSectionLineStandard::LabelPattern

McadSectionLineStandard::LabelPattern property

McadSectionLineStandard::LabelVisibility

McadSectionLineStandard::LabelVisibility property

McadSectionLineStandard::LineColor

McadSectionLineStandard::LineColor property

McadSectionLineStandard::LineTrueColor

McadSectionLineStandard::LineTrueColor property

McadSectionLineStandard::LineVisibility

McadSectionLineStandard::LineVisibility property

McadSectionLineStandard::LineWeight

McadSectionLineStandard::LineWeight property

McadSectionLineStandard::MultipleNamesSupported

McadSectionLineStandard::MultipleNamesSupported property

McadSectionLineStandard::PlaneSymbolsVisibility

McadSectionLineStandard::PlaneSymbolsVisibility property

McadSectionLineStandard2

McadSectionLineStandard2 interface

about IMcadSectionLineStandard2 interface

ArrowLineLength

BendLineLength

EndArrowType

EndBendLineType

EndLineLength

EndLineOvershoot

GetByStandard

IdentifierExcludeCharacters

IdentifierOffset

IdentifierPosition

IMcadSectionLineStandard2 members

LabelOffset

LabelTextColor

LabelTextHeight

LabelTextStyle

PlaneLineColor

PlaneLineType

PlaneLineWeight

SetByStandard

McadSectionLineStandard2::ArrowLineLength

McadSectionLineStandard2::ArrowLineLength property

McadSectionLineStandard2::BendLineLength

McadSectionLineStandard2::BendLineLength property

McadSectionLineStandard2::EndArrowType

McadSectionLineStandard2::EndArrowType property

McadSectionLineStandard2::EndBendLineType

McadSectionLineStandard2::EndBendLineType property

McadSectionLineStandard2::EndLineLength

McadSectionLineStandard2::EndLineLength property

McadSectionLineStandard2::EndLineOvershoot

McadSectionLineStandard2::EndLineOvershoot property

McadSectionLineStandard2::GetByStandard

McadSectionLineStandard2::GetByStandard method

McadSectionLineStandard2::IdentifierExcludeCharacters

McadSectionLineStandard2::IdentifierExcludeCharacters property

McadSectionLineStandard2::IdentifierOffset

McadSectionLineStandard2::IdentifierOffset property

McadSectionLineStandard2::IdentifierPosition

McadSectionLineStandard2::IdentifierPosition property

McadSectionLineStandard2::LabelOffset

McadSectionLineStandard2::LabelOffset property

McadSectionLineStandard2::LabelTextColor

McadSectionLineStandard2::LabelTextColor property

McadSectionLineStandard2::LabelTextHeight

McadSectionLineStandard2::LabelTextHeight property

McadSectionLineStandard2::LabelTextStyle

McadSectionLineStandard2::LabelTextStyle property

McadSectionLineStandard2::PlaneLineColor

McadSectionLineStandard2::PlaneLineColor property

McadSectionLineStandard2::PlaneLineType

McadSectionLineStandard2::PlaneLineType property

McadSectionLineStandard2::PlaneLineWeight

McadSectionLineStandard2::PlaneLineWeight property

McadSectionLineStandard2::SetByStandard

McadSectionLineStandard2::SetByStandard method

McadSectionLineStandardPropType

McadSectionLineStandardPropType enumeration

McadSelectionOrderOption

McadSelectionOrderOption enumeration

McadSpline

McadSpline coclass

about McadSpline coclass

McadSpline interface

about IMcadSpline interface

McadStandard

McadStandard coclass

about McadStandard coclass

McadStandard interface

about IMcadStandard interface

AddSymbolStandard

AllSymbolStandards

ArrowScale

ArrowType

BaseName

BOMStandard

Current

CurrentSymbolStandards

DatumStandard

FCFStandard

GetCurrentSymbolStandard

IdentifierStandard

IMcadStandard members

IsMetric

LeaderColor

Name

RemoveSymbolStandard

Scale

SetCurrentSymbolStandard

SetToDefaults

StandardMgr

SurfaceTextureStandard

SymbolColor

SymbolStandardsSupported

TextColor

TextHeight

TextHeightList

TextStyle

TextStyleName

WeldingStandard

McadStandard::AddSymbolStandard

McadStandard::AddSymbolStandard method

McadStandard::AllSymbolStandards

McadStandard::AllSymbolStandards property

McadStandard::ArrowScale

McadStandard::ArrowScale property

McadStandard::ArrowType

McadStandard::ArrowType property

McadStandard::BaseName

McadStandard::BaseName property

McadStandard::BOMStandard

McadStandard::BOMStandard property

McadStandard::Current

McadStandard::Current property

McadStandard::CurrentSymbolStandards

McadStandard::CurrentSymbolStandards property

McadStandard::DatumStandard

McadStandard::DatumStandard property

McadStandard::FCFStandard

McadStandard::FCFStandard property

McadStandard::GetCurrentSymbolStandard

McadStandard::GetCurrentSymbolStandard method

McadStandard::IdentifierStandard

McadStandard::IdentifierStandard property

McadStandard::IsMetric

McadStandard::IsMetric property

McadStandard::LeaderColor

McadStandard::LeaderColor property

McadStandard::Name

McadStandard::Name property

McadStandard::RemoveSymbolStandard

McadStandard::RemoveSymbolStandard method

McadStandard::Scale

McadStandard::Scale property

McadStandard::SetCurrentSymbolStandard

McadStandard::SetCurrentSymbolStandard method

McadStandard::SetToDefaults

McadStandard::SetToDefaults method

McadStandard::StandardMgr

McadStandard::StandardMgr property

McadStandard::SurfaceTextureStandard

McadStandard::SurfaceTextureStandard property

McadStandard::SymbolColor

McadStandard::SymbolColor property

McadStandard::SymbolStandardsSupported

McadStandard::SymbolStandardsSupported property

McadStandard::TextColor

McadStandard::TextColor property

McadStandard::TextHeight

McadStandard::TextHeight property

McadStandard::TextHeightList

McadStandard::TextHeightList property

McadStandard::TextStyle

McadStandard::TextStyle property

McadStandard::TextStyleName

McadStandard::TextStyleName property

McadStandard::WeldingStandard

McadStandard::WeldingStandard property

McadStandard2

McadStandard2 interface

about IMcadStandard2 interface

IMcadStandard2 members

LeaderTrueColor

SymbolTrueColor

TextTrueColor

McadStandard2::LeaderTrueColor

McadStandard2::LeaderTrueColor property

McadStandard2::SymbolTrueColor

McadStandard2::SymbolTrueColor property

McadStandard2::TextTrueColor

McadStandard2::TextTrueColor property

McadStandard3

McadStandard3 interface

about IMcadStandard3 interface

AnnotationViewStandard

DetailSymbolStandard

EdgeStandard

IMcadStandard3 members

MarkStampStandard

NoteStandard

TaperStandard

TitleBorderStandard

McadStandard3::AnnotationViewStandard

McadStandard3::AnnotationViewStandard property

McadStandard3::DetailSymbolStandard

McadStandard3::DetailSymbolStandard property

McadStandard3::EdgeStandard

McadStandard3::EdgeStandard property

McadStandard3::MarkStampStandard

McadStandard3::MarkStampStandard property

McadStandard3::NoteStandard

McadStandard3::NoteStandard property

McadStandard3::TaperStandard

McadStandard3::TaperStandard property

McadStandard3::TitleBorderStandard

McadStandard3::TitleBorderStandard property

McadStandard4

McadStandard4 interface

about IMcadStandard4 interface

IMcadStandard4 members

JointStandard

SectionLineStandard

SupportedArrowTypes

McadStandard4::JointStandard

McadStandard4::JointStandard property

McadStandard4::SectionLineStandard

McadStandard4::SectionLineStandard property

McadStandard4::SupportedArrowTypes

McadStandard4::SupportedArrowTypes method

McadStandardMgr

McadStandardMgr coclass

about McadStandardMgr coclass

McadStandardMgr interface

about IMcadStandardMgr interface

AddStandard

Application

CopyStandard

CurrentStandard

CurrentStandardName

DefaultStandard

GetStandard

IMcadStandardMgr members

RemoveStandard

StandardCount

StandardNames

Standards

SymbolBBMgr

UpdateSymbols

McadStandardMgr::AddStandard

McadStandardMgr::AddStandard method

McadStandardMgr::Application

McadStandardMgr::Application property

McadStandardMgr::CopyStandard

McadStandardMgr::CopyStandard method

McadStandardMgr::CurrentStandard

McadStandardMgr::CurrentStandard property

McadStandardMgr::CurrentStandardName

McadStandardMgr::CurrentStandardName property

McadStandardMgr::DefaultStandard

McadStandardMgr::DefaultStandard property

McadStandardMgr::GetStandard

McadStandardMgr::GetStandard method

McadStandardMgr::RemoveStandard

McadStandardMgr::RemoveStandard method

McadStandardMgr::StandardCount

McadStandardMgr::StandardCount property

McadStandardMgr::StandardNames

McadStandardMgr::StandardNames property

McadStandardMgr::Standards

McadStandardMgr::Standards property

McadStandardMgr::SymbolBBMgr

McadStandardMgr::SymbolBBMgr property

McadStandardMgr::UpdateSymbols

McadStandardMgr::UpdateSymbols method

McadStandards

McadStandards coclass

about McadStandards coclass

McadStandards interface

about IMcadStandards interface

Add

Application

Count

IMcadStandards members

Item

Remove

McadStandards::Add

McadStandards::Add method

McadStandards::Application

McadStandards::Application property

McadStandards::Count

McadStandards::Count property

McadStandards::Item

McadStandards::Item method

McadStandards::Remove

McadStandards::Remove method

McadStdPartComponentViewDescriptor

McadStdPartComponentViewDescriptor coclass

about McadStdPartComponentViewDescriptor coclass

McadStdPartComponentViewDescriptor interface

about IMcadStdPartComponentViewDescriptor interface

McadStdPartsFilterOption

McadStdPartsFilterOption enumeration

McadSurfaceTexture

McadSurfaceTexture coclass

about McadSurfaceTexture coclass

McadSurfaceTexture interface

about IMcadSurfaceTexture interface

AllowanceValue

Angle

AutomaticAdjust

CommentValue

CutoffValue

IMcadSurfaceTexture members

IsAllAround

IsForceTail

IsMajority

LayDirection

LayDirectionValue

MaximumSpacingValue

OtherMinimumValue

OtherValue

Production2Value

ProductionValue

RaMaximumValue

RaMinimumValue

ReferenceValue

SamplingLengthValue

SurfaceTexture

WavinessValue

McadSurfaceTexture::AllowanceValue

McadSurfaceTexture::AllowanceValue property

McadSurfaceTexture::Angle

McadSurfaceTexture::Angle property

McadSurfaceTexture::AutomaticAdjust

McadSurfaceTexture::AutomaticAdjust property

McadSurfaceTexture::CommentValue

McadSurfaceTexture::CommentValue property

McadSurfaceTexture::CutoffValue

McadSurfaceTexture::CutoffValue property

McadSurfaceTexture::IsAllAround

McadSurfaceTexture::IsAllAround property

McadSurfaceTexture::IsForceTail

McadSurfaceTexture::IsForceTail property

McadSurfaceTexture::IsMajority

McadSurfaceTexture::IsMajority property

McadSurfaceTexture::LayDirection

McadSurfaceTexture::LayDirection property

McadSurfaceTexture::LayDirectionValue

McadSurfaceTexture::LayDirectionValue property

McadSurfaceTexture::MaximumSpacingValue

McadSurfaceTexture::MaximumSpacingValue property

McadSurfaceTexture::OtherMinimumValue

McadSurfaceTexture::OtherMinimumValue property

McadSurfaceTexture::OtherValue

McadSurfaceTexture::OtherValue property

McadSurfaceTexture::Production2Value

McadSurfaceTexture::Production2Value property

McadSurfaceTexture::ProductionValue

McadSurfaceTexture::ProductionValue property

McadSurfaceTexture::RaMaximumValue

McadSurfaceTexture::RaMaximumValue property

McadSurfaceTexture::RaMinimumValue

McadSurfaceTexture::RaMinimumValue property

McadSurfaceTexture::ReferenceValue

McadSurfaceTexture::ReferenceValue property

McadSurfaceTexture::SamplingLengthValue

McadSurfaceTexture::SamplingLengthValue property

McadSurfaceTexture::SurfaceTexture

McadSurfaceTexture::SurfaceTexture property

McadSurfaceTexture::WavinessValue

McadSurfaceTexture::WavinessValue property

McadSurfaceTexture2

McadSurfaceTexture2 interface

about IMcadSurfaceTexture2 interface

FirstRequirement

FourthRequirement

IMcadSurfaceTexture2 members

SecondRequirement

ThirdRequirement

McadSurfaceTexture2::FirstRequirement

McadSurfaceTexture2::FirstRequirement property

McadSurfaceTexture2::FourthRequirement

McadSurfaceTexture2::FourthRequirement property

McadSurfaceTexture2::SecondRequirement

McadSurfaceTexture2::SecondRequirement property

McadSurfaceTexture2::ThirdRequirement

McadSurfaceTexture2::ThirdRequirement property

McadSurfaceTexture3

McadSurfaceTexture3 interface

about IMcadSurfaceTexture3 interface

IMcadSurfaceTexture3 members

SurfExtLinesOffset

SurfExtLinesOvershot

McadSurfaceTexture3::SurfExtLinesOffset

McadSurfaceTexture3::SurfExtLinesOffset property

McadSurfaceTexture3::SurfExtLinesOvershot

McadSurfaceTexture3::SurfExtLinesOvershot property

McadSurfaceTexture4

McadSurfaceTexture4 interface

about IMcadSurfaceTexture4 interface

AddSurfIndLeader

IMcadSurfaceTexture4 members

McadSurfaceTexture4::AddSurfIndLeader

McadSurfaceTexture4::AddSurfIndLeader method

McadSurfaceTextureLibrary

McadSurfaceTextureLibrary coclass

about McadSurfaceTextureLibrary coclass

McadSurfaceTextureLibrary interface

about IMcadSurfaceTextureLibrary interface

McadSurfaceTextureLibraryObject

McadSurfaceTextureLibraryObject coclass

about McadSurfaceTextureLibraryObject coclass

McadSurfaceTextureLibraryObject interface

about IMcadSurfaceTextureLibraryObject interface

IMcadSurfaceTextureLibraryObject members

IsAllAround

IsForceTail

IsMajority

RequirementValue

SubSymbolType

McadSurfaceTextureLibraryObject::IsAllAround

McadSurfaceTextureLibraryObject::IsAllAround property

McadSurfaceTextureLibraryObject::IsForceTail

McadSurfaceTextureLibraryObject::IsForceTail property

McadSurfaceTextureLibraryObject::IsMajority

McadSurfaceTextureLibraryObject::IsMajority property

McadSurfaceTextureLibraryObject::RequirementValue

McadSurfaceTextureLibraryObject::RequirementValue method

McadSurfaceTextureLibraryObject::SubSymbolType

McadSurfaceTextureLibraryObject::SubSymbolType property

McadSurfaceTextureRequirement

McadSurfaceTextureRequirement enumeration

McadSurfaceTextureStandard

McadSurfaceTextureStandard coclass

about McadSurfaceTextureStandard coclass

McadSurfaceTextureStandard interface

about IMcadSurfaceTextureStandard interface

AllAroundAllowed

AvailableLaySymbols

FitCircle

ForceTail

FullList

IMcadSurfaceTextureStandard members

MajorityAllowed

Multiline

OfferedLaySymbols

McadSurfaceTextureStandard::AllAroundAllowed

McadSurfaceTextureStandard::AllAroundAllowed property

McadSurfaceTextureStandard::AvailableLaySymbols

McadSurfaceTextureStandard::AvailableLaySymbols property

McadSurfaceTextureStandard::FitCircle

McadSurfaceTextureStandard::FitCircle property

McadSurfaceTextureStandard::ForceTail

McadSurfaceTextureStandard::ForceTail property

McadSurfaceTextureStandard::FullList

McadSurfaceTextureStandard::FullList property

McadSurfaceTextureStandard::MajorityAllowed

McadSurfaceTextureStandard::MajorityAllowed property

McadSurfaceTextureStandard::Multiline

McadSurfaceTextureStandard::Multiline property

McadSurfaceTextureStandard::OfferedLaySymbols

McadSurfaceTextureStandard::OfferedLaySymbols property

McadSurfaceTextureStandard2

McadSurfaceTextureStandard2 interface

about IMcadSurfaceTextureStandard2 interface

IMcadSurfaceTextureStandard2 members

IsRequirementSupported

SetAllSuggestedListsToDefaults

SetSuggestedListToDefaults

SuggestedList

SuggestedList

McadSurfaceTextureStandard2::IsRequirementSupported

McadSurfaceTextureStandard2::IsRequirementSupported method

McadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults

McadSurfaceTextureStandard2::SetAllSuggestedListsToDefaults method

McadSurfaceTextureStandard2::SetSuggestedListToDefaults

McadSurfaceTextureStandard2::SetSuggestedListToDefaults method

McadSurfaceTextureStandard2::SuggestedList

McadSurfaceTextureStandard2::SuggestedList method

McadSurfaceTextureStandard3

McadSurfaceTextureStandard3 interface

about IMcadSurfaceTextureStandard3 interface

IMcadSurfaceTextureStandard3 members

SurfIndLeaderArrowScale

SurfIndLeaderArrowType

McadSurfaceTextureStandard3::SurfIndLeaderArrowScale

McadSurfaceTextureStandard3::SurfIndLeaderArrowScale property

McadSurfaceTextureStandard3::SurfIndLeaderArrowType

McadSurfaceTextureStandard3::SurfIndLeaderArrowType property

McadSurfaceTextureType

McadSurfaceTextureType enumeration

McadSymBBSymbolLibraryType

McadSymBBSymbolLibraryType enumeration

McadSymbol

McadSymbol coclass

about McadSymbol coclass

McadSymbol interface

about IMcadSymbol interface

AddLeader

AttachGeometry

CoordinateSystem

DetachGeometry

GetLeader

GetLeaderAttachment

IMcadSymbol members

InsertLeaderNode

IsAttached

LeaderArrowType

LeaderArrowType

LeaderColor

LeaderColor

LeaderCount

LeaderLanding

LeaderLanding

LeaderLineType

LeaderLineType

MoveLeaderNode

Origin

RemoveLeader

RemoveLeaderNode

Scale

SetToDefaults

Standard

SymbolStandard

McadSymbol::AddLeader

McadSymbol::AddLeader method

McadSymbol::AttachGeometry

McadSymbol::AttachGeometry method

McadSymbol::CoordinateSystem

McadSymbol::CoordinateSystem property

McadSymbol::DetachGeometry

McadSymbol::DetachGeometry method

McadSymbol::GetLeader

McadSymbol::GetLeader method

McadSymbol::GetLeaderAttachment

McadSymbol::GetLeaderAttachment method

McadSymbol::InsertLeaderNode

McadSymbol::InsertLeaderNode method

McadSymbol::IsAttached

McadSymbol::IsAttached property

McadSymbol::LeaderArrowType

McadSymbol::LeaderArrowType method

McadSymbol::LeaderColor

McadSymbol::LeaderColor method

McadSymbol::LeaderCount

McadSymbol::LeaderCount property

McadSymbol::LeaderLanding

McadSymbol::LeaderLanding method

McadSymbol::LeaderLineType

McadSymbol::LeaderLineType method

McadSymbol::MoveLeaderNode

McadSymbol::MoveLeaderNode method

McadSymbol::Origin

McadSymbol::Origin property

McadSymbol::RemoveLeader

McadSymbol::RemoveLeader method

McadSymbol::RemoveLeaderNode

McadSymbol::RemoveLeaderNode method

McadSymbol::Scale

McadSymbol::Scale property

McadSymbol::SetToDefaults

McadSymbol::SetToDefaults method

McadSymbol::Standard

McadSymbol::Standard property

McadSymbol::SymbolStandard

McadSymbol::SymbolStandard property

McadSymbol2

McadSymbol2 interface

about IMcadSymbol2 interface

IMcadSymbol2 members

UpdateToAttachedObject

McadSymbol2::UpdateToAttachedObject

McadSymbol2::UpdateToAttachedObject method

McadSymbolBBMgr

McadSymbolBBMgr coclass

about McadSymbolBBMgr coclass

McadSymbolBBMgr interface

about IMcadSymbolBBMgr interface

Application

BOMMgr

IMcadSymbolBBMgr members

StandardMgr

McadSymbolBBMgr::Application

McadSymbolBBMgr::Application property

McadSymbolBBMgr::BOMMgr

McadSymbolBBMgr::BOMMgr method

McadSymbolBBMgr::StandardMgr

McadSymbolBBMgr::StandardMgr method

McadSymbolBBMgr2

McadSymbolBBMgr2 interface

about IMcadSymbolBBMgr2 interface

IMcadSymbolBBMgr2 members

ScaleAreaMgr

TitleBorderMgr

McadSymbolBBMgr2::ScaleAreaMgr

McadSymbolBBMgr2::ScaleAreaMgr method

McadSymbolBBMgr2::TitleBorderMgr

McadSymbolBBMgr2::TitleBorderMgr method

McadSymbolBBMgr3

McadSymbolBBMgr3 interface

about IMcadSymbolBBMgr3 interface

IMcadSymbolBBMgr3 members

RevisionListMgr

SymbolLibrary

McadSymbolBBMgr3::RevisionListMgr

McadSymbolBBMgr3::RevisionListMgr method

McadSymbolBBMgr3::SymbolLibrary

McadSymbolBBMgr3::SymbolLibrary method

McadSymbolLibrary

McadSymbolLibrary coclass

about McadSymbolLibrary coclass

McadSymbolLibrary interface

about IMcadSymbolLibrary interface

appendItem

DefaultItem

findItem

findList

IMcadSymbolLibrary members

isItemExist

loadItem

modifyItem

removeItem

renameItem

setIsDefaultItem

McadSymbolLibrary::appendItem

McadSymbolLibrary::appendItem method

McadSymbolLibrary::DefaultItem

McadSymbolLibrary::DefaultItem method

McadSymbolLibrary::findItem

McadSymbolLibrary::findItem method

McadSymbolLibrary::findList

McadSymbolLibrary::findList method

McadSymbolLibrary::isItemExist

McadSymbolLibrary::isItemExist method

McadSymbolLibrary::loadItem

McadSymbolLibrary::loadItem method

McadSymbolLibrary::modifyItem

McadSymbolLibrary::modifyItem method

McadSymbolLibrary::removeItem

McadSymbolLibrary::removeItem method

McadSymbolLibrary::renameItem

McadSymbolLibrary::renameItem method

McadSymbolLibrary::setIsDefaultItem

McadSymbolLibrary::setIsDefaultItem method

McadSymbolLibraryObject

McadSymbolLibraryObject coclass

about McadSymbolLibraryObject coclass

McadSymbolLibraryObject interface

about IMcadSymbolLibraryObject interface

entryName

IMcadSymbolLibraryObject members

isDefault

standardName

symbolStandardClassName

McadSymbolLibraryObject::entryName

McadSymbolLibraryObject::entryName property

McadSymbolLibraryObject::isDefault

McadSymbolLibraryObject::isDefault property

McadSymbolLibraryObject::standardName

McadSymbolLibraryObject::standardName property

McadSymbolLibraryObject::symbolStandardClassName

McadSymbolLibraryObject::symbolStandardClassName property

McadSymbolLibraryObjects

McadSymbolLibraryObjects coclass

about McadSymbolLibraryObjects coclass

McadSymbolLibraryObjects interface

about IMcadSymbolLibraryObjects interface

Add

Application

Count

IMcadSymbolLibraryObjects members

Item

Remove

McadSymbolLibraryObjects::Add

McadSymbolLibraryObjects::Add method

McadSymbolLibraryObjects::Application

McadSymbolLibraryObjects::Application property

McadSymbolLibraryObjects::Count

McadSymbolLibraryObjects::Count property

McadSymbolLibraryObjects::Item

McadSymbolLibraryObjects::Item method

McadSymbolLibraryObjects::Remove

McadSymbolLibraryObjects::Remove method

McadSymbolStandard

McadSymbolStandard coclass

about McadSymbolStandard coclass

McadSymbolStandard interface

about IMcadSymbolStandard interface

IMcadSymbolStandard members

Revision

RevisionYear

SetToDefaults

Standard

McadSymbolStandard::Revision

McadSymbolStandard::Revision property

McadSymbolStandard::RevisionYear

McadSymbolStandard::RevisionYear property

McadSymbolStandard::SetToDefaults

McadSymbolStandard::SetToDefaults method

McadSymbolStandard::Standard

McadSymbolStandard::Standard property

McadSymbolStandard2

McadSymbolStandard2 interface

about IMcadSymbolStandard2 interface

ArrowScale

ArrowType

IMcadSymbolStandard2 members

LeaderTrueColor

SetToDefaultTextLeader

TextHeight

TextTrueColor

McadSymbolStandard2::ArrowScale

McadSymbolStandard2::ArrowScale property

McadSymbolStandard2::ArrowType

McadSymbolStandard2::ArrowType property

McadSymbolStandard2::LeaderTrueColor

McadSymbolStandard2::LeaderTrueColor property

McadSymbolStandard2::SetToDefaultTextLeader

McadSymbolStandard2::SetToDefaultTextLeader method

McadSymbolStandard2::TextHeight

McadSymbolStandard2::TextHeight property

McadSymbolStandard2::TextTrueColor

McadSymbolStandard2::TextTrueColor property

McadSymbolStandard3

McadSymbolStandard3 interface

about IMcadSymbolStandard3 interface

IMcadSymbolStandard3 members

SupportedArrowTypes

SymbolStandardClassName

McadSymbolStandard3::SupportedArrowTypes

McadSymbolStandard3::SupportedArrowTypes method

McadSymbolStandard3::SymbolStandardClassName

McadSymbolStandard3::SymbolStandardClassName property

McadSymbolStandards

McadSymbolStandards coclass

about McadSymbolStandards coclass

McadSymbolStandards interface

about IMcadSymbolStandards interface

Add

Application

Count

IMcadSymbolStandards members

Item

Remove

McadSymbolStandards::Add

McadSymbolStandards::Add method

McadSymbolStandards::Application

McadSymbolStandards::Application property

McadSymbolStandards::Count

McadSymbolStandards::Count property

McadSymbolStandards::Item

McadSymbolStandards::Item method

McadSymbolStandards::Remove

McadSymbolStandards::Remove method

McadTaper

McadTaper coclass

about McadTaper coclass

McadTaper interface

about IMcadTaper interface

AboveCurve

AdjustReferenceLine

DisplayString

HasLeader

IMcadTaper members

Inspect

Orientation

SubSymbolType

McadTaper::AboveCurve

McadTaper::AboveCurve property

McadTaper::AdjustReferenceLine

McadTaper::AdjustReferenceLine method

McadTaper::DisplayString

McadTaper::DisplayString property

McadTaper::HasLeader

McadTaper::HasLeader property

McadTaper::Inspect

McadTaper::Inspect property

McadTaper::Orientation

McadTaper::Orientation property

McadTaper::SubSymbolType

McadTaper::SubSymbolType property

McadTaperDimensionType

McadTaperDimensionType enumeration

McadTaperRatioFormatType

McadTaperRatioFormatType enumeration

McadTaperSlopeSymType

McadTaperSlopeSymType enumeration

McadTaperStandard

McadTaperStandard coclass

about McadTaperStandard coclass

McadTaperStandard interface

about IMcadTaperStandard interface

IMcadTaperStandard members

OfferedSymbols

McadTaperStandard::OfferedSymbols

McadTaperStandard::OfferedSymbols property

McadTaperStandard2

McadTaperStandard2 interface

about IMcadTaperStandard2 interface

GetDimensionType

IMcadTaperStandard2 members

SetDimensionType

McadTaperStandard2::GetDimensionType

McadTaperStandard2::GetDimensionType method

McadTaperStandard2::SetDimensionType

McadTaperStandard2::SetDimensionType method

McadTargetType

McadTargetType enumeration

McadTextControl

McadTextControl enumeration

McadTitle

McadTitle coclass

about McadTitle coclass

McadTitle interface

about IMcadTitle interface

Attributes

IMcadTitle members

InActive

Name

Position

SetToDefaultAttributes

McadTitle::Attributes

McadTitle::Attributes property

McadTitle::InActive

McadTitle::InActive property

McadTitle::Name

McadTitle::Name property

McadTitle::Position

McadTitle::Position property

McadTitle::SetToDefaultAttributes

McadTitle::SetToDefaultAttributes method

McadTitle2

McadTitle2 interface

about IMcadTitle2 interface

BlockId

BlockId32

IMcadTitle2 members

McadTitle2::BlockId

McadTitle2::BlockId property

McadTitle2::BlockId32

McadTitle2::BlockId32 property

McadTitleBorder

McadTitleBorder coclass

about McadTitleBorder coclass

McadTitleBorder interface

about IMcadTitleBorder interface

Descriptor

IMcadTitleBorder members

Modify

Ref

Ref32

McadTitleBorder::Descriptor

McadTitleBorder::Descriptor property

McadTitleBorder::Modify

McadTitleBorder::Modify method

McadTitleBorder::Ref

McadTitleBorder::Ref property

McadTitleBorder::Ref32

McadTitleBorder::Ref32 property

McadTitleBorderContext

McadTitleBorderContext coclass

about McadTitleBorderContext coclass

McadTitleBorderContext interface

about IMcadTitleBorderContext interface

AutomaticPlacement

BaseScale

DwgDefault

GetMoveObjectsIDs

GetMoveObjectsIDs32

GetMoveObjectsToPoint

GetPartReference

GetPartReference32

IMcadTitleBorderContext members

MoveObjects

Rescale

RetrieveFromAsmProp

RetrieveFromPartRef

SetMoveObjects

SetPartReference

ThawAllLayers

McadTitleBorderContext::AutomaticPlacement

McadTitleBorderContext::AutomaticPlacement property

McadTitleBorderContext::BaseScale

McadTitleBorderContext::BaseScale property

McadTitleBorderContext::DwgDefault

McadTitleBorderContext::DwgDefault property

McadTitleBorderContext::GetMoveObjectsIDs

McadTitleBorderContext::GetMoveObjectsIDs method

McadTitleBorderContext::GetMoveObjectsIDs32

McadTitleBorderContext::GetMoveObjectsIDs32 method

McadTitleBorderContext::GetMoveObjectsToPoint

McadTitleBorderContext::GetMoveObjectsToPoint method

McadTitleBorderContext::GetPartReference

McadTitleBorderContext::GetPartReference method

McadTitleBorderContext::GetPartReference32

McadTitleBorderContext::GetPartReference32 method

McadTitleBorderContext::MoveObjects

McadTitleBorderContext::MoveObjects property

McadTitleBorderContext::Rescale

McadTitleBorderContext::Rescale property

McadTitleBorderContext::RetrieveFromAsmProp

McadTitleBorderContext::RetrieveFromAsmProp property

McadTitleBorderContext::RetrieveFromPartRef

McadTitleBorderContext::RetrieveFromPartRef property

McadTitleBorderContext::SetMoveObjects

McadTitleBorderContext::SetMoveObjects method

McadTitleBorderContext::SetPartReference

McadTitleBorderContext::SetPartReference method

McadTitleBorderContext::ThawAllLayers

McadTitleBorderContext::ThawAllLayers property

McadTitleBorderDescriptor

McadTitleBorderDescriptor coclass

about McadTitleBorderDescriptor coclass

McadTitleBorderDescriptor interface

about IMcadTitleBorderDescriptor interface

Border

IMcadTitleBorderDescriptor members

Position

Title

TitleBorderScale

McadTitleBorderDescriptor::Border

McadTitleBorderDescriptor::Border property

McadTitleBorderDescriptor::Position

McadTitleBorderDescriptor::Position property

McadTitleBorderDescriptor::Title

McadTitleBorderDescriptor::Title property

McadTitleBorderDescriptor::TitleBorderScale

McadTitleBorderDescriptor::TitleBorderScale property

McadTitleBorderMgr

McadTitleBorderMgr coclass

about McadTitleBorderMgr coclass

McadTitleBorderMgr interface

about IMcadTitleBorderMgr interface

CreateTitleBorder

DeleteTitleBorder

GetTitleBorderFromRef

IMcadTitleBorderMgr members

NewContext

NewDescriptor

TitleBorders

McadTitleBorderMgr::CreateTitleBorder

McadTitleBorderMgr::CreateTitleBorder method

McadTitleBorderMgr::DeleteTitleBorder

McadTitleBorderMgr::DeleteTitleBorder method

McadTitleBorderMgr::GetTitleBorderFromRef

McadTitleBorderMgr::GetTitleBorderFromRef method

McadTitleBorderMgr::NewContext

McadTitleBorderMgr::NewContext method

McadTitleBorderMgr::NewDescriptor

McadTitleBorderMgr::NewDescriptor method

McadTitleBorderMgr::TitleBorders

McadTitleBorderMgr::TitleBorders property

McadTitleBorders

McadTitleBorders coclass

about McadTitleBorders coclass

McadTitleBorders interface

about IMcadTitleBorders interface

Application

Count

IMcadTitleBorders members

Item

McadTitleBorders::Application

McadTitleBorders::Application property

McadTitleBorders::Count

McadTitleBorders::Count property

McadTitleBorders::Item

McadTitleBorders::Item method

McadTitleBorderStandard

McadTitleBorderStandard coclass

about McadTitleBorderStandard coclass

McadTitleBorderStandard interface

about IMcadTitleBorderStandard interface

DefaultPaperFormat

DefaultRevisionList

DefaultTitleBlock

IMcadTitleBorderStandard members

PaperFormats

RevisionLists

TitleBlocks

McadTitleBorderStandard::DefaultPaperFormat

McadTitleBorderStandard::DefaultPaperFormat property

McadTitleBorderStandard::DefaultRevisionList

McadTitleBorderStandard::DefaultRevisionList property

McadTitleBorderStandard::DefaultTitleBlock

McadTitleBorderStandard::DefaultTitleBlock property

McadTitleBorderStandard::PaperFormats

McadTitleBorderStandard::PaperFormats property

McadTitleBorderStandard::RevisionLists

McadTitleBorderStandard::RevisionLists property

McadTitleBorderStandard::TitleBlocks

McadTitleBorderStandard::TitleBlocks property

McadTitleBorderStandard2

McadTitleBorderStandard2 interface

about IMcadTitleBorderStandard2 interface

IMcadTitleBorderStandard2 members

InsertInvertPart

InvertPartBorderHeight

InvertPartBorderWidth

InvertPartTextHeight

McadTitleBorderStandard2::InsertInvertPart

McadTitleBorderStandard2::InsertInvertPart property

McadTitleBorderStandard2::InvertPartBorderHeight

McadTitleBorderStandard2::InvertPartBorderHeight property

McadTitleBorderStandard2::InvertPartBorderWidth

McadTitleBorderStandard2::InvertPartBorderWidth property

McadTitleBorderStandard2::InvertPartTextHeight

McadTitleBorderStandard2::InvertPartTextHeight property

McadTransaction

McadTransaction coclass

about McadTransaction coclass

McadTransaction interface

about IMcadTransaction interface

Application

IMcadTransaction members

McadTransaction::Application

McadTransaction::Application property

McadUndefinedSize

McadUndefinedSize enumeration

McadUndefinedSizeDirection

McadUndefinedSizeDirection enumeration

McadUtility

McadUtility coclass

about McadUtility coclass

McadUtility interface

about IMcadUtility interface

Application

CreateAttribute

CreateAttributeField

CreateCollection

CreatePickObject

CreateSystemAttribute

Document

GetAllAttributes

GetAttributeFromID

GetAttributeFromID32

GetGeometryFromPick

GetIdsFromObject

GetIdsFromObject32

GetObjectFromID

GetObjectFromID32

GetObjectFromPick

IMcadUtility members

Pick

McadUtility::Application

McadUtility::Application property

McadUtility::CreateAttribute

McadUtility::CreateAttribute method

McadUtility::CreateAttributeField

McadUtility::CreateAttributeField method

McadUtility::CreateCollection

McadUtility::CreateCollection method

McadUtility::CreatePickObject

McadUtility::CreatePickObject method

McadUtility::CreateSystemAttribute

McadUtility::CreateSystemAttribute method

McadUtility::Document

McadUtility::Document property

McadUtility::GetAllAttributes

McadUtility::GetAllAttributes method

McadUtility::GetAttributeFromID

McadUtility::GetAttributeFromID method

McadUtility::GetAttributeFromID32

McadUtility::GetAttributeFromID32 method

McadUtility::GetGeometryFromPick

McadUtility::GetGeometryFromPick method

McadUtility::GetIdsFromObject

McadUtility::GetIdsFromObject method

McadUtility::GetIdsFromObject32

McadUtility::GetIdsFromObject32 method

McadUtility::GetObjectFromID

McadUtility::GetObjectFromID method

McadUtility::GetObjectFromID32

McadUtility::GetObjectFromID32 method

McadUtility::GetObjectFromPick

McadUtility::GetObjectFromPick method

McadUtility::Pick

McadUtility::Pick method

McadUtility2

McadUtility2 interface

about IMcadUtility2 interface

IMcadUtility2 members

RefocusObject

McadUtility2::RefocusObject

McadUtility2::RefocusObject method

McadUtility3

McadUtility3 interface

about IMcadUtility3 interface

GetDrawingType

IMcadUtility3 members

McadUtility3::GetDrawingType

McadUtility3::GetDrawingType method

McadViewDefLockType

McadViewDefLockType enumeration

McadWeldAssociation

McadWeldAssociation enumeration

McadWelding

McadWelding coclass

about McadWelding coclass

McadWelding interface

about IMcadWelding interface

AddSubWelding

AngleValue

AngleValue

AreaType

AreaType

AssociationType

AssociationType

BackingValue

BackingValue

Brazing

Brazing

BrazingValue

BrazingValue

ClearanceValue

ClearanceValue

ClosedTail

ClosedTail

ContourType

ContourType

ContourValue

ContourValue

ControlCategoryValue

ControlCategoryValue

DepthValue

DepthValue

DesignationValue

DesignationValue

FieldWeld

FieldWeld

FinishingValue

FinishingValue

GapValue

GapValue

HighlightSubWelding

IdentificationLine

IdentificationLine

IMcadWelding members

IndexTotalValue

IndexTotalValue

IndexValue

IndexValue

LengthValue

LengthValue

NotesValue

NotesValue

NumberValue

NumberValue

Orientation

PitchValue

PitchValue

RemoveSubWelding

SecondarySymType

SecondarySymType

SecondarySymTypeValue

SecondarySymTypeValue

Size2Value

Size2Value

SizeType

SizeType

SizeTypeValue

SizeTypeValue

SizeValue

SizeValue

SpacingValue

SpacingValue

SpecificationValue

SpecificationValue

StandardValue

StandardValue

SubWeldingCount

TechnicalReqValue

TechnicalReqValue

ThicknessValue

ThicknessValue

Type

Type

McadWelding::AddSubWelding

McadWelding::AddSubWelding method

McadWelding::AngleValue

McadWelding::AngleValue method

McadWelding::AreaType

McadWelding::AreaType method

McadWelding::AssociationType

McadWelding::AssociationType method

McadWelding::BackingValue

McadWelding::BackingValue method

McadWelding::Brazing

McadWelding::Brazing method

McadWelding::BrazingValue

McadWelding::BrazingValue method

McadWelding::ClearanceValue

McadWelding::ClearanceValue method

McadWelding::ClosedTail

McadWelding::ClosedTail method

McadWelding::ContourType

McadWelding::ContourType method

McadWelding::ContourValue

McadWelding::ContourValue method

McadWelding::ControlCategoryValue

McadWelding::ControlCategoryValue method

McadWelding::DepthValue

McadWelding::DepthValue method

McadWelding::DesignationValue

McadWelding::DesignationValue method

McadWelding::FieldWeld

McadWelding::FieldWeld method

McadWelding::FinishingValue

McadWelding::FinishingValue method

McadWelding::GapValue

McadWelding::GapValue method

McadWelding::HighlightSubWelding

McadWelding::HighlightSubWelding method

McadWelding::IdentificationLine

McadWelding::IdentificationLine method

McadWelding::IndexTotalValue

McadWelding::IndexTotalValue method

McadWelding::IndexValue

McadWelding::IndexValue method

McadWelding::LengthValue

McadWelding::LengthValue method

McadWelding::NotesValue

McadWelding::NotesValue method

McadWelding::NumberValue

McadWelding::NumberValue method

McadWelding::Orientation

McadWelding::Orientation property

McadWelding::PitchValue

McadWelding::PitchValue method

McadWelding::RemoveSubWelding

McadWelding::RemoveSubWelding method

McadWelding::SecondarySymType

McadWelding::SecondarySymType method

McadWelding::SecondarySymTypeValue

McadWelding::SecondarySymTypeValue method

McadWelding::Size2Value

McadWelding::Size2Value method

McadWelding::SizeType

McadWelding::SizeType method

McadWelding::SizeTypeValue

McadWelding::SizeTypeValue method

McadWelding::SizeValue

McadWelding::SizeValue method

McadWelding::SpacingValue

McadWelding::SpacingValue method

McadWelding::SpecificationValue

McadWelding::SpecificationValue method

McadWelding::StandardValue

McadWelding::StandardValue method

McadWelding::SubWeldingCount

McadWelding::SubWeldingCount property

McadWelding::TechnicalReqValue

McadWelding::TechnicalReqValue method

McadWelding::ThicknessValue

McadWelding::ThicknessValue method

McadWelding::Type

McadWelding::Type method

McadWelding2

McadWelding2 interface

about IMcadWelding2 interface

IMcadWelding2 members

InsertProcess

McadWelding2::InsertProcess

McadWelding2::InsertProcess method

McadWeldingLibrary

McadWeldingLibrary coclass

about McadWeldingLibrary coclass

McadWeldingLibrary interface

about IMcadWeldingLibrary interface

appendItemFromSubWelding

IMcadWeldingLibrary members

loadItemToSubWelding

modifyItemFromSubWelding

McadWeldingLibrary::appendItemFromSubWelding

McadWeldingLibrary::appendItemFromSubWelding method

McadWeldingLibrary::loadItemToSubWelding

McadWeldingLibrary::loadItemToSubWelding method

McadWeldingLibrary::modifyItemFromSubWelding

McadWeldingLibrary::modifyItemFromSubWelding method

McadWeldingLibraryObject

McadWeldingLibraryObject coclass

about McadWeldingLibraryObject coclass

McadWeldingLibraryObject interface

about IMcadWeldingLibraryObject interface

AreaType

ArrowSideReqValue

AssociationType

ClosedTail

FieldWeld

IdentificationLine

IMcadWeldingLibraryObject members

OtherSideReqValue

RequirementValue

setIsDefault

Type

McadWeldingLibraryObject::AreaType

McadWeldingLibraryObject::AreaType property

McadWeldingLibraryObject::ArrowSideReqValue

McadWeldingLibraryObject::ArrowSideReqValue method

McadWeldingLibraryObject::AssociationType

McadWeldingLibraryObject::AssociationType property

McadWeldingLibraryObject::ClosedTail

McadWeldingLibraryObject::ClosedTail property

McadWeldingLibraryObject::FieldWeld

McadWeldingLibraryObject::FieldWeld property

McadWeldingLibraryObject::IdentificationLine

McadWeldingLibraryObject::IdentificationLine property

McadWeldingLibraryObject::OtherSideReqValue

McadWeldingLibraryObject::OtherSideReqValue method

McadWeldingLibraryObject::RequirementValue

McadWeldingLibraryObject::RequirementValue method

McadWeldingLibraryObject::setIsDefault

McadWeldingLibraryObject::setIsDefault method

McadWeldingLibraryObject::Type

McadWeldingLibraryObject::Type method

McadWeldingRequirement

McadWeldingRequirement enumeration

McadWeldingStandard

McadWeldingStandard coclass

about McadWeldingStandard coclass

McadWeldingStandard interface

about IMcadWeldingStandard interface

AvailableBackingSymbols

AvailableContourSymbols

AvailableWeldSymbols

ClosedTailAllowed

IdentificationLineAllowed

IdentificationLineGap

IdentificationLinetype

IdentificationLinetypeName

IMcadWeldingStandard members

MultipleSymbolsAllowed

OfferedBackingSymbols

OfferedContourSymbols

OfferedWeldSymbols

McadWeldingStandard::AvailableBackingSymbols

McadWeldingStandard::AvailableBackingSymbols property

McadWeldingStandard::AvailableContourSymbols

McadWeldingStandard::AvailableContourSymbols property

McadWeldingStandard::AvailableWeldSymbols

McadWeldingStandard::AvailableWeldSymbols property

McadWeldingStandard::ClosedTailAllowed

McadWeldingStandard::ClosedTailAllowed property

McadWeldingStandard::IdentificationLineAllowed

McadWeldingStandard::IdentificationLineAllowed property

McadWeldingStandard::IdentificationLineGap

McadWeldingStandard::IdentificationLineGap property

McadWeldingStandard::IdentificationLinetype

McadWeldingStandard::IdentificationLinetype property

McadWeldingStandard::IdentificationLinetypeName

McadWeldingStandard::IdentificationLinetypeName property

McadWeldingStandard::MultipleSymbolsAllowed

McadWeldingStandard::MultipleSymbolsAllowed property

McadWeldingStandard::OfferedBackingSymbols

McadWeldingStandard::OfferedBackingSymbols property

McadWeldingStandard::OfferedContourSymbols

McadWeldingStandard::OfferedContourSymbols property

McadWeldingStandard::OfferedWeldSymbols

McadWeldingStandard::OfferedWeldSymbols property

McadWeldingStandard2

McadWeldingStandard2 interface

about IMcadWeldingStandard2 interface

IMcadWeldingStandard2 members

WeldProcessPrefix

McadWeldingStandard2::WeldProcessPrefix

McadWeldingStandard2::WeldProcessPrefix property

McadWeldingStandard3

McadWeldingStandard3 interface

about IMcadWeldingStandard3 interface

IMcadWeldingStandard3 members

ProcessGap

ScaleFactor

McadWeldingStandard3::ProcessGap

McadWeldingStandard3::ProcessGap property

McadWeldingStandard3::ScaleFactor

McadWeldingStandard3::ScaleFactor property

McadWeldSymbolType

McadWeldSymbolType enumeration

mcAllFolderPowerObj enumeration member

mcAnnotationViewDefinition enumeration member

mcAnnotationViewDefinitions enumeration member

mcArc enumeration member

mcAttributeFields enumeration member

mcAttributes enumeration member

mcBottomUp enumeration member

mcCamCalcObj enumeration member

mcCharacter enumeration member

mcComplexHideSituations enumeration member

mcComponent enumeration member

mcComponentDefinition enumeration member

mcComponentDefinitions enumeration member

mcComponents enumeration member

mcComponentView enumeration member

mcComponentViewDefinition enumeration member

mcComponentViewDefinitions enumeration member

mcComponentViews enumeration member

mcCopyAlways enumeration member

mcCurve enumeration member

mcDefault enumeration member

mcDeflLineObj enumeration member

mcDontHide enumeration member

mcDouble enumeration member

mcDoubleArray enumeration member

mcEllipse enumeration member

mcFEAObj enumeration member

mcFolder enumeration member

mcFolderDefinition enumeration member

mcFolderDefinitions enumeration member

mcFolders enumeration member

mcGeometry enumeration member

mcHideBg enumeration member

mcHideFg enumeration member

mcHideFgBg enumeration member

mcHideSituations enumeration member

mcIgnoreAlways enumeration member

mcInventorLink enumeration member

mcLine enumeration member

mcLong enumeration member

mcLongArray enumeration member

mcMcadObject enumeration member

mcMcadObjectArray enumeration member

mcMDT enumeration member

mcMDTPart enumeration member

mcMomOfInertiaObj enumeration member

mcNoObj enumeration member

mcNormalDef enumeration member

mcObject enumeration member

mcObjectID enumeration member

mcObjectIDArray enumeration member

mcObjects enumeration member

mcPartFeatObj enumeration member

mcPhantomDef enumeration member

mcPhantomDefInCurrent enumeration member

mcPolyline enumeration member

mcScrewConObj enumeration member

mcShaftCalcObj enumeration member

mcShaftObj enumeration member

mcShareAlways enumeration member

mcShort enumeration member

mcShortArray enumeration member

mcSpline enumeration member

mcString enumeration member

mcTopDown enumeration member

mcUndefined enumeration member

MergeDatum

IMcadFCFStandard interface

MergeItems

IMcadBOM3 interface

MergeSymbol

IMcadFCFStandard interface

MergeTolerance

IMcadFCFStandard interface

MethodValue

IMcadMarkStamp interface

mg enumeration member

MidPoint

IGeLineSegment interface

MigrateTo2DStructure

IMcad2dComplexStdPartCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor interface

MinorAxis

IGeEllipticalArc interface

MinorRadius

IGeEllipticalArc interface

IGeTorus interface

MinPoint

IGeBoundBlock interface

MinValue

IMcadEdge interface

Mirror

IGeEntity interface

IGeVector interface

ml enumeration member

mm enumeration member

Modify

IMcadTitleBorder interface

modifyItem

IMcadSymbolLibrary interface

modifyItemFromSubWelding

IMcadWeldingLibrary interface

MoveBorder

IMcadScaleArea interface

MoveColumn

IMcadBOMStandard interface

MoveLayerGroupEntities

IMcadLayerGroupMgr interface

MoveLeaderNode

IMcadSymbol interface

MoveLevel

IMcadComplexHideSituation interface

MoveObjects

IMcadTitleBorderContext interface

MulipleRow

IMcadPartListStandard interface

Multiline

IMcadSurfaceTextureStandard interface

MultipleNamesSupported

IMcadSectionLineStandard interface

MultipleRow

IMcadPartList interface

MultipleSymbolsAllowed

IMcadWeldingStandard interface

MultiplicityAt

IGeKnotVector interface

MultiplyBy

IGeVector interface

N

Name

IMcad2DStructureDescriptor interface

IMcadAttributeField interface

IMcadBorder interface

IMcadColumnDefinition interface

IMcadComplexHideSituation interface

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolderDefinition interface

IMcadHideSituation interface

IMcadLayerCfg interface

IMcadPartListFilter interface

IMcadStandard interface

IMcadTitle interface

Negate

IGeVector interface

Negative

IGeVector interface

NewContext

IMcadTitleBorderMgr interface

NewDescriptor

IMcadRevisionMgr interface

IMcadTitleBorderMgr interface

NewSymbolRev

IMcadEdge interface

NextLevelName

IMcadComplexHideSituation interface

NextViewName

IMcadFolderDefinition interface

NonModal enumeration member

NoPlot

IMcadLayerCfg interface

NoReplicateInLayerGroup

IMcadLayerCfg interface

Normal

IGeCircularArc interface

IGeEllipticalArc interface

IGeOffsetCurve interface

IGePlane interface

IGeVector interface

NormalFlipped

IGeSurface interface

Normalize

IGeVector interface

NormalPoint

IGeCurve interface

NorthAxis

IGeSphere interface

NorthPole

IGeSphere interface

NoteStandard

IMcadStandard3 interface

NotesValue

IMcadWelding interface

IMcadWelding interface

NoteText

IMcadNote interface

NumberOfIntervals

IGeKnotVector interface

NumberOfTemplateGroups

IMcadNoteStandard interface

NumberValue

IMcadWelding interface

IMcadWelding interface

NurbCurve

IGeApplication interface

NurbSurface

IGeApplication interface

O

ObjectID

IMcadAttribute interface

ObjectID32

IMcadAttribute interface

ObjectType

IMcadPick interface

Occurrences

IMcadFolderDefinition interface

OfferedAuxiliarySymbols

IMcadFCFStandard interface

OfferedBackingSymbols

IMcadWeldingStandard interface

OfferedContourSymbols

IMcadWeldingStandard interface

OfferedGDTSymbols

IMcadFCFStandard interface

OfferedLaySymbols

IMcadSurfaceTextureStandard interface

OfferedMarkingContents

IMcadMarkStampStandard interface

OfferedMarkingMethods

IMcadMarkStampStandard interface

OfferedStampingContents

IMcadMarkStampStandard interface

OfferedStampingMethods

IMcadMarkStampStandard interface

OfferedSymbols

IMcadTaperStandard interface

OfferedWeldSymbols

IMcadWeldingStandard interface

OffsetCurve

IGeApplication interface

OffsetDistance

IGeOffsetCurve interface

IGeOffsetSurface interface

OffsetSurface

IGeApplication interface

Operator

IMcadPartListCustomFilter interface

Option

IMcadPartListStdPartsFilter interface

Order

IGeNurbCurve interface

Orientation

IMcadJoint interface

IMcadTaper interface

IMcadWelding interface

Orientation2d

IGeCurveBoundary interface

Orientation3d

IGeCurveBoundary interface

Origin

IGeCone interface

IGeCylinder interface

IGePlane interface

IGeSphere interface

IGeTorus interface

IMcadSymbol interface

OtherMinimumValue

IMcadSurfaceTexture interface

OtherSideReqValue

IMcadWeldingLibraryObject interface

OtherValue

IMcadSurfaceTexture interface

OuterContourOnly

IMcadHideSituation interface

Overlap

IGeLinearEntity interface

OverlapCount

IGeCurveCurveIntersection interface

OverlapDirection

IGeCurveCurveIntersection interface

OverrideColorByLayerGroup

IMcadLayerCfg interface

Owner

IMcadComponent interface

IMcadComponentViewDefinition interface

IMcadFolder interface

OwningComponentDefinition

IMcad2dComponentDescriptor interface

OwningSpace

IMcadFolder2 interface

oz enumeration member

P

PaperFormats

IMcadTitleBorderStandard interface

ParameterAtLength

IGeCurve interface

ParameterCurveOnSurface1

IGeSurfaceSurfaceIntersection interface

ParameterCurveOnSurface2

IGeSurfaceSurfaceIntersection interface

ParameterDirection

IGeOffsetCurve interface

ParameterOf

IGeCurve interface

IGeSurface interface

ParameterOnCurve

IGeCurveSurfaceIntersection interface

ParameterOnCurve1

IGeCurveCurveIntersection interface

ParameterOnCurve2

IGeCurveCurveIntersection interface

ParameterOnSurface

IGeCurveSurfaceIntersection interface

ParameterOnSurface1

IGeSurfaceSurfaceIntersection interface

ParameterOnSurface2

IGeSurfaceSurfaceIntersection interface

ParametersOfC1

IGeNurbCurve interface

ParametersOfG1

IGeNurbCurve interface

ParentHide

IMcadHideSituation interface

PartListCaptionAlignment

IMcadColumnDefinition3 interface

PartListDataAlignment

IMcadColumnDefinition3 interface

PartLists

IMcadBOM interface

PartListStandard

IMcadBOMStandard interface

PartRef enumeration member

PerpendicularPlane

IGeLinearEntity interface

PerpendicularVector

IGeVector interface

Phantomed

IMcadBOMItem2 interface

PhantomState

IMcadComponentDefinition interface

Pick

IMcadUtility interface

PickPoint

IMcadPick interface

PitchValue

IMcadWelding interface

IMcadWelding interface

Plane

IGeApplication interface

PlaneLineColor

IMcadSectionLineStandard2 interface

PlaneLineType

IMcadSectionLineStandard2 interface

PlaneLineWeight

IMcadSectionLineStandard2 interface

PlaneSymbolsVisibility

IMcadSectionLine interface

IMcadSectionLineStandard interface

Point

IGeApplication interface

PointAt

IGeAugmentedLine interface

IGeAugmentedLine interface

PointColor

IMcadDatumStandard interface

PointOnLine

IGeLinearEntity interface

Points

IGeAugmentedLine interface

PointSize

IMcadDatumStandard interface

PointTrueColor

IMcadDatumStandard2 interface

Position

IMcadBorder interface

IMcadComponent interface

IMcadFolder interface

IMcadFolderDescriptor interface

IMcadRevisionList interface

IMcadRevisionListDescriptor interface

IMcadTitle interface

IMcadTitleBorderDescriptor interface

PostMultiply

IGeMatrix interface

PowerObjectType

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

Precision

IMcadColumnDefinition interface

PredefinedReferenceOverride

IMcadComponent interface

IMcadFolder interface

PreMultiply

IGeMatrix interface

ProcessGap

IMcadWeldingStandard3 interface

Product

IGeMatrix interface

IGeVector interface

Production2Value

IMcadSurfaceTexture interface

ProductionValue

IMcadSurfaceTexture interface

Project

IGeCurve interface

IGeVector interface

ProjectedValue

IMcadFeatureControlFrame interface

ProjectToPlane

IGePoint interface

PropertyName

IMcadPartListCustomFilter interface

PropertyValue

IMcadPartListCustomFilter interface

PurgeAll2DS

IMcad2DStructureMgr interface

PurgeAnnotationViewDefinitions

IMcad2DStructureMgr interface

PurgeComponentDefinitions

IMcad2DStructureMgr interface

PurgeComponentViewDefinitions

IMcad2DStructureMgr interface

PurgeFitData

IGeNurbCurve interface

PurgeFolderDefinitions

IMcad2DStructureMgr interface

Q

qt enumeration member

Quantity

IMcadBOMItem interface

IMcadPartReference interface

R

Radius

IGeCircularArc interface

IGeCylinder interface

IGeSphere interface

IMcadDetailSymbol interface

RaMaximumValue

IMcadSurfaceTexture interface

RaMinimumValue

IMcadSurfaceTexture interface

Ray

IGeApplication interface

ReadAttributeClass

IAcadmApplication interface

RectangleAngle

IMcadDatumTarget interface

RectangleCornerPoint

IMcadDatumTarget2 interface

RectangleXSize

IMcadDatumTarget interface

RectangleYSize

IMcadDatumTarget interface

Ref

IMcadRevisionList interface

IMcadTitleBorder interface

Ref32

IMcadRevisionList interface

IMcadTitleBorder interface

Reference

IMcadComponent interface

ReferenceAxis

IGeSphere interface

IGeTorus interface

ReferenceExists

IMcadBOMItem interface

ReferenceValue

IMcadSurfaceTexture interface

ReferenceVector

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

RefocusObject

IMcadUtility2 interface

Remove

IGeCurveBoundaries interface

IGeCurves interface

IGeEntities interface

IGePoints interface

IGeSurfaces interface

IGeVectors interface

IMcadAnnotationViewDefinitions interface

IMcadAttributeFields interface

IMcadAttributes interface

IMcadBalloons interface

IMcadBOMItems interface

IMcadBOMs interface

IMcadColumnDefinitions interface

IMcadComplexHideSituations interface

IMcadComponentDefinitions interface

IMcadComponents interface

IMcadComponentViewDefinitions interface

IMcadComponentViews interface

IMcadFolderDefinitions interface

IMcadFolders interface

IMcadHideSituations interface

IMcadLayerCfgs interface

IMcadLayerObjectCfgs interface

IMcadObjects interface

IMcadPartListFilters interface

IMcadPartLists interface

IMcadPartReferences interface

IMcadStandards interface

IMcadSymbolLibraryObjects interface

IMcadSymbolStandards interface

RemoveAttribute

IMcadBOMItem4 interface

IMcadComponent interface

IMcadComponentDefinition interface

IMcadGeometry interface

IMcadPartReference3 interface

RemoveAttributeClass

IAcadmApplication interface

RemoveBOMItem

IMcadBalloon interface

RemoveBOMTable

IMcadBOMMgr interface

RemoveColumn

IMcadBalloonStandard interface

IMcadBOMStandard interface

IMcadPartListStandard interface

RemoveComponent

IMcadComponentDefinition interface

RemoveComponentView

IMcad2dComponentDescriptor interface

IMcadAnnotationViewDefinition interface

IMcadComponentViewDefinition interface

RemoveEntities

IMcadFolder interface

RemoveFilter

IMcadPartList interface

RemoveFitPointAt

IGeNurbCurve interface

RemoveFolder

IMcadFolderDefinition interface

removeItem

IMcadSymbolLibrary interface

RemoveKnotAt

IGeKnotVector interface

RemoveLeader

IMcadSymbol interface

RemoveLeaderNode

IMcadSymbol interface

RemoveLevel

IMcadComplexHideSituation interface

RemoveLevelByIdx

IMcadComplexHideSituation interface

RemovePartGrfDef

IMcadBOMMgr2 interface

RemovePreDefinedList

IMcadColumnDefinition3 interface

RemoveRange

IGeKnotVector interface

RemoveReference

IMcadBOMItem interface

RemoveStandard

IMcadStandardMgr interface

RemoveSubent

IMcadHideSituation interface

RemoveSubentByIdx

IMcadHideSituation interface

RemoveSubWelding

IMcadWelding interface

RemoveSurfIndLeader

IMcadFeatureControlFrame4 interface

RemoveSymbolStandard

IMcadStandard interface

RemoveView

IMcad2dComplexStdPartCompGroupDescriptor interface

renameItem

IMcadSymbolLibrary interface

RenameTemplate

IMcadNoteStandard interface

ReplaceDefinition

IMcadComponent interface

IMcadFolder interface

RequirementValue

IMcadEdgeLibraryObject interface

IMcadFCFLibraryObject interface

IMcadSurfaceTextureLibraryObject interface

IMcadWeldingLibraryObject interface

Rescale

IMcadTitleBorderContext interface

RescaleObjects

IMcadScaleArea interface

RestructureViews

IMcad2DStructureMgr interface

ResultBarEnabled

IMcadPartList2 interface

RetrieveFromAsmProp

IMcadTitleBorderContext interface

RetrieveFromPartRef

IMcadTitleBorderContext interface

Reverse

IGeCurve interface

IGeKnotVector interface

IMcadComplexHideSituation interface

Revision

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadSymbolStandard interface

RevisionListMgr

IMcadSymbolBBMgr3 interface

RevisionLists

IMcadRevisionMgr interface

IMcadTitleBorderStandard interface

RevisionYear

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadSymbolStandard interface

RootComponentDefinition

IMcad2DStructureMgr interface

RootViewDefinition

IMcad2DStructureMgr interface

RotateBy

IGeEntity interface

IGeVector interface

RowGap

IMcadPartListStandard interface

RowHeight

IMcadPartListStandard interface

RowTextColor

IMcadPartListStandard3 interface

RowTextControl

IMcadPartList2 interface

IMcadPartListStandard3 interface

RowTextHeight

IMcadPartListStandard3 interface

RowTextMarginBottom

IMcadPartListStandard3 interface

RowTextMarginLeft

IMcadPartListStandard3 interface

RowTextMarginRight

IMcadPartListStandard3 interface

RowTextMarginTop

IMcadPartListStandard3 interface

RowTextStyle

IMcadPartListStandard3 interface

RowTextTrueColor

IMcadPartListStandard3 interface

S

Sample Code

SamplingLengthValue

IMcadSurfaceTexture interface

SaveSimplifiedOuterContour

IMcadHideSituation interface

sbAbove enumeration member

sbAboveDirectionArrowLine enumeration member

sbAboveDirectionArrowSymbol enumeration member

sbAngularity enumeration member

sbAnnotLabelAbove enumeration member

sbAnnotLabelBelow enumeration member

sbArcSegmentCenter enumeration member

sbArcSegmentSecond enumeration member

sbArrowAcadArchTick enumeration member

sbArrowAcadBoxBlank enumeration member

sbArrowAcadBoxFilled enumeration member

sbArrowAcadClosed enumeration member

sbArrowAcadClosedBlank enumeration member

sbArrowAcadClosedFilled enumeration member

sbArrowAcadDatumBlank enumeration member

sbArrowAcadDatumFilled enumeration member

sbArrowAcadDot enumeration member

sbArrowAcadDotBlank enumeration member

sbArrowAcadDotSmall enumeration member

sbArrowAcadIntegral enumeration member

sbArrowAcadNone enumeration member

sbArrowAcadOblique enumeration member

sbArrowAcadOpen enumeration member

sbArrowAcadOpen30 enumeration member

sbArrowAcadOpen90 enumeration member

sbArrowAcadOrigin enumeration member

sbArrowAcadOrigin2 enumeration member

sbArrowAcadSmall enumeration member

sbArrowBoxBlank enumeration member

sbArrowBoxFilled enumeration member

sbArrowClosed enumeration member

sbArrowClosed15 enumeration member

sbArrowClosed30 enumeration member

sbArrowClosed60 enumeration member

sbArrowClosed90 enumeration member

sbArrowDatumBlank45 enumeration member

sbArrowDatumBlank60 enumeration member

sbArrowDatumFilled45 enumeration member

sbArrowDatumFilled60 enumeration member

sbArrowDatumThickLine enumeration member

sbArrowDot enumeration member

sbArrowDotBlank enumeration member

sbArrowDotBlankSmall enumeration member

sbArrowDotSmall enumeration member

sbArrowEmpty enumeration member

sbArrowEmpty15 enumeration member

sbArrowEmpty30 enumeration member

sbArrowEmpty60 enumeration member

sbArrowEmpty90 enumeration member

sbArrowEmptyHalf enumeration member

sbArrowFilled enumeration member

sbArrowFilled15 enumeration member

sbArrowFilled20 enumeration member

sbArrowFilled30 enumeration member

sbArrowFilled60 enumeration member

sbArrowFilled90 enumeration member

sbArrowFilledHalf enumeration member

sbArrowOblique enumeration member

sbArrowOpen enumeration member

sbArrowOpen15 enumeration member

sbArrowOpen30 enumeration member

sbArrowOpen60 enumeration member

sbArrowOpen90 enumeration member

sbArrowOrigin enumeration member

sbAssembly enumeration member

sbAssociationBacking enumeration member

sbAssociationMirrorStagger enumeration member

sbAssociationMoveStagger enumeration member

sbAssociationSpacer enumeration member

sbAssociationSpecialStagger enumeration member

sbAttach enumeration member

sbAttachBottom enumeration member

sbAttachLeft enumeration member

sbAttachRight enumeration member

sbAttachTop enumeration member

sbAxiality enumeration member

sbBackLendingWeld enumeration member

sbBackWeld enumeration member

sbBalloon enumeration member

sbBasic enumeration member

sbBelow enumeration member

sbBetween enumeration member

sbBetweenPlanes enumeration member

sbBevelGrooveShapeWeld enumeration member

sbBevelGrooveWeld enumeration member

sbBottomBottomLine enumeration member

sbBottomLeft enumeration member

sbBottomNote enumeration member

sbBottomRight enumeration member

sbBottomText enumeration member

sbBottomTopLine enumeration member

sbByStandard enumeration member

sbByStandardBalloon enumeration member

sbCategory enumeration member

sbCenter enumeration member

sbChamfer enumeration member

sbCircular enumeration member

sbCircular2Balloon enumeration member

sbCircularBalloon enumeration member

sbCircularity enumeration member

sbCircularRelativeToCenter enumeration member

sbComments enumeration member

sbConcaveContour enumeration member

sbConcaveSmoothContour enumeration member

sbConcentricity enumeration member

sbConsInsert enumeration member

sbContains enumeration member

sbContinuous enumeration member

sbConvexContour enumeration member

sbCorner enumeration member

sbCounterBore enumeration member

sbCounterSink enumeration member

sbCrossedIn2SlantDirections enumeration member

sbCutEnforceWeld enumeration member

sbCylindricity enumeration member

sbDatumId enumeration member

sbDatumPrimary enumeration member

sbDatumPrimary2 enumeration member

sbDatumSecondary enumeration member

sbDatumSecondary2 enumeration member

sbDatumTertiary enumeration member

sbDatumTertiary2 enumeration member

sbDefSize enumeration member

sbDescription enumeration member

sbDescription2 enumeration member

sbDetailViewBorderLineColor enumeration member

sbDetailViewBorderLineType enumeration member

sbDetailViewBorderLineWeight enumeration member

sbDetailViewBoundaryLineColor enumeration member

sbDetailViewBoundaryLineType enumeration member

sbDetailViewBoundaryLineWeight enumeration member

sbDetailViewConnectionLineColor enumeration member

sbDetailViewConnectionLineType enumeration member

sbDetailViewConnectionLineWeight enumeration member

sbDetailViewIdentifierTextColor enumeration member

sbDetailViewIdentifierTextHeight enumeration member

sbDetailViewIdentifierTextStyle enumeration member

sbDetailViewLabelTextColor enumeration member

sbDetailViewLabelTextHeight enumeration member

sbDetailViewLabelTextStyle enumeration member

sbDetailViewSymbol enumeration member

sbDetailViewSymbolColor enumeration member

sbDiameter enumeration member

sbDimension enumeration member

sbDoesNotCont enumeration member

sbDrawingManagerID enumeration member

sbEdgeLibrary enumeration member

sbEdgeMax enumeration member

sbEdgeMin enumeration member

sbEdgeSign enumeration member

sbEdgeWeld enumeration member

sbEmptyBalloon enumeration member

sbEndCuttingPlane enumeration member

sbEndDirectionArrow enumeration member

sbEnvelope enumeration member

sbEqual enumeration member

sbExamination enumeration member

sbExcludeStdParts enumeration member

sbFCFLibrary enumeration member

sbFieldWeld enumeration member

sbFieldWeldEmpty enumeration member

sbFillet enumeration member

sbFilletWeld enumeration member

sbFilter enumeration member

sbFilterBallooned enumeration member

sbFilterBasic enumeration member

sbFilterCustom enumeration member

sbFilterParts enumeration member

sbFilterRange enumeration member

sbFilterSheet enumeration member

sbFilterStdParts enumeration member

sbFilterView enumeration member

sbFit enumeration member

sbFlangeCornerWeld enumeration member

sbFlangeEdgeWeld enumeration member

sbFlareBevelGrooveWeld enumeration member

sbFlareVGrooveWeld enumeration member

sbFlatness enumeration member

sbFlushContour enumeration member

sbFlushFinishedContour enumeration member

sbFoldJointWeld enumeration member

sbFormat enumeration member

sbFormulaOverride enumeration member

sbFraction enumeration member

sbFreeState enumeration member

sbGeneralText enumeration member

sbGluing enumeration member

sbGreater enumeration member

sbGreaterEqual enumeration member

sbHalfRoundedWeld enumeration member

sbHalfWWeld enumeration member

sbHoleDrilled enumeration member

sbHorizontal enumeration member

sbIdentificationArrowSide enumeration member

sbIdentificationOtherSide enumeration member

sbImportOverride enumeration member

sbInclinedJointWeld enumeration member

sbInteger enumeration member

sbIntermittentWeld enumeration member

sbItem enumeration member

sbJGrooveWeld enumeration member

sbLeastMaterialCondition enumeration member

sbLeft enumeration member

sbLeftSide enumeration member

sbLess enumeration member

sbLessEqual enumeration member

sbLine enumeration member

sbLinearBalloon enumeration member

sbLineSegment enumeration member

sbMass enumeration member

sbMaterial enumeration member

sbMaterial2 enumeration member

sbMaximumMaterialCondition enumeration member

sbMeltThrough enumeration member

sbMiddleBottomLine enumeration member

sbMiddleText enumeration member

sbMiddleTopLine enumeration member

sbMultiDirection enumeration member

sbName enumeration member

sbNAngleBalloon enumeration member

sbNoArrow enumeration member

sbNoAssociation enumeration member

sbNoBalloon enumeration member

sbNoFraction enumeration member

sbNoIdentificationLine enumeration member

sbNoLines enumeration member

sbNone enumeration member

sbNoOverride enumeration member

sbNoPoint enumeration member

sbNoSymbol enumeration member

sbNoTarget enumeration member

sbNote enumeration member

sbNotEqual enumeration member

sbNotSpecified enumeration member

sbNumber enumeration member

sbOpenContourWeld enumeration member

sbOther enumeration member

sbOverlapping enumeration member

sbParallelism enumeration member

sbParallelToPlane enumeration member

sbPart enumeration member

sbParticulateNonDirectional enumeration member

sbPartID enumeration member

sbPartListName enumeration member

sbPartListPath enumeration member

sbPartNumber enumeration member

sbPattern enumeration member

sbPercentage enumeration member

sbPermanentBackingStripWeld enumeration member

sbPerpendicularity enumeration member

sbPerpendicularToPlane enumeration member

sbPlugWeld enumeration member

sbPoint enumeration member

sbPosition enumeration member

sbPrice enumeration member

sbProfileLine enumeration member

sbProfileSection enumeration member

sbProfileSurface enumeration member

sbProjectedToleranceZone enumeration member

sbProjectedZone enumeration member

sbQtyOverride enumeration member

sbQuantity enumeration member

sbRadialRelativeToCenter enumeration member

sbRatio enumeration member

sbReal enumeration member

sbReciprocityCondition enumeration member

sbRectangular enumeration member

sbRegardlessOfFeatureSize enumeration member

sbRemovableBackingStripWeld enumeration member

sbRemovalAllowanceSpecified enumeration member

sbRemovalOfMaterialProhibited enumeration member

sbRemovalOfMaterialRequired enumeration member

sbRight enumeration member

sbRightSide enumeration member

sbRoundedWeld enumeration member

sbRunoutCircular enumeration member

sbRunoutCircularFilled enumeration member

sbRunoutTotal enumeration member

sbRunoutTotalFilled enumeration member

sbScaleDf enumeration member

sbScalePf enumeration member

sbScarfGrooveWeld enumeration member

sbSeamOnRefLineWeld enumeration member

sbSeamWeld enumeration member

sbSecondaryFillet enumeration member

sbSectionViewEndBendLineColor enumeration member

sbSectionViewEndBendLineType enumeration member

sbSectionViewEndBendLineWeight enumeration member

sbSectionViewEndSymbol enumeration member

sbSectionViewIdentifierTextColor enumeration member

sbSectionViewIdentifierTextHeight enumeration member

sbSectionViewIdentifierTextStyle enumeration member

sbSectionViewLabelTextColor enumeration member

sbSectionViewLabelTextHeight enumeration member

sbSectionViewLabelTextStyle enumeration member

sbSectionViewPlaneLineColor enumeration member

sbSectionViewPlaneLineType enumeration member

sbSectionViewPlaneLineWeight enumeration member

sbSectionViewStartSymbol enumeration member

sbSectionViewSymbolColor enumeration member

sbSide enumeration member

sbSingleBevelBroadRootFace enumeration member

sbSingleVBroadRootFace enumeration member

sbSlope1 enumeration member

sbSlope2 enumeration member

sbSlotWeld enumeration member

sbSmoothContour enumeration member

sbSmoothWeld enumeration member

sbSoldering enumeration member

sbSpecialStaggerWeld enumeration member

sbSplitLeft enumeration member

sbSplitRight enumeration member

sbSplitRows enumeration member

sbSplitSections enumeration member

sbSpotOnRefLineWeld enumeration member

sbSpotWeld enumeration member

sbSquare enumeration member

sbSqureGrooveWeld enumeration member

sbStandard enumeration member

sbStandard2 enumeration member

sbStartDirectionArrow enumeration member

sbStatisticalTolerance enumeration member

sbStdPartsOnly enumeration member

sbSteepFlankedBevelWeld enumeration member

sbSteepFlankedVWeld enumeration member

sbStitching enumeration member

sbStraightness enumeration member

sbStudWeld enumeration member

sbSurfaceJointWeld enumeration member

sbSurfaceTextureLibrary enumeration member

sbSurfacingWeld enumeration member

sbSurfTextAllowance enumeration member

sbSurfTextComment enumeration member

sbSurfTextCutoff enumeration member

sbSurfTextDirLay enumeration member

sbSurfTextFirstRequirement enumeration member

sbSurfTextFourthRequirement enumeration member

sbSurfTextMaxRspac enumeration member

sbSurfTextOtherMin enumeration member

sbSurfTextOtherValue enumeration member

sbSurfTextProduction enumeration member

sbSurfTextProduction2 enumeration member

sbSurfTextRaMax enumeration member

sbSurfTextRaMin enumeration member

sbSurfTextReference enumeration member

sbSurfTextSampLength enumeration member

sbSurfTextSecondRequirement enumeration member

sbSurfTextThirdRequirement enumeration member

sbSurfTextWavines enumeration member

sbSymbol enumeration member

sbSymbol2 enumeration member

sbSymmetry enumeration member

sbTangentPlane enumeration member

sbTaper1 enumeration member

sbTaper2 enumeration member

sbToCenter enumeration member

sbToExtents enumeration member

sbTolerance enumeration member

sbTolerance2 enumeration member

sbToleranceB enumeration member

sbToleranceB2 enumeration member

sbToOrigin enumeration member

sbTop enumeration member

sbTopBottomLine enumeration member

sbTopLeft enumeration member

sbTopLineRefLine enumeration member

sbTopNote enumeration member

sbTopRight enumeration member

sbTopText enumeration member

sbTopTopLine enumeration member

sbTotalMass enumeration member

sbUGrooveWeld enumeration member

sbUnderlineAllText enumeration member

sbUnitOfMeasure enumeration member

sbUnknownType enumeration member

sbUser1 enumeration member

sbUser2 enumeration member

sbUser3 enumeration member

sbUser4 enumeration member

sbUser5 enumeration member

sbUser6 enumeration member

sbUser7 enumeration member

sbUser8 enumeration member

sbUserArrowDialog enumeration member

sbUserArrowType enumeration member

sbUserBalloon enumeration member

sbUserDirect enumeration member

sbUserDirectionLayType enumeration member

sbUserID enumeration member

sbUserSymbolGDT enumeration member

sbUserSymbolType enumeration member

sbUVWeld enumeration member

sbVaries enumeration member

sbVendor enumeration member

sbVertical enumeration member

sbVGrooveWeld enumeration member

sbWeldAllAround enumeration member

sbWeldAllAroundSquare enumeration member

sbWeldAngle enumeration member

sbWeldBacking enumeration member

sbWeldBrazing enumeration member

sbWeldClearance enumeration member

sbWeldContour enumeration member

sbWeldControlCategory enumeration member

sbWeldDepth enumeration member

sbWeldDesignation enumeration member

sbWeldFinishing enumeration member

sbWeldGap enumeration member

sbWeldGroovedRoot enumeration member

sbWeldIndex enumeration member

sbWeldIndexTotal enumeration member

sbWeldingLibrary enumeration member

sbWeldingTail enumeration member

sbWeldLength enumeration member

sbWeldMullded enumeration member

sbWeldNotes enumeration member

sbWeldNumber enumeration member

sbWeldPitch enumeration member

sbWeldSecondarySymbol enumeration member

sbWeldSize enumeration member

sbWeldSize2 enumeration member

sbWeldSizeSymbol enumeration member

sbWeldSpacing enumeration member

sbWeldSpecification enumeration member

sbWeldStandard enumeration member

sbWeldTechnicalReq enumeration member

sbWeldThickness enumeration member

sbWithBurr enumeration member

sbWithoutBurr enumeration member

sbWrap enumeration member

sbWWeld enumeration member

sbWWeld2 enumeration member

sbZigZagBalloon enumeration member

sbZigzagWeld enumeration member

sbZone enumeration member

Scale

IGeMatrix interface

IMcadStandard interface

IMcadSymbol interface

ScaleAreaMgr

IMcadSymbolBBMgr2 interface

ScaleBy

IGeEntity interface

IGeVector interface

ScaleFactor

IMcadWeldingStandard3 interface

ScaleType

IMcadScaleArea interface

SecAnnotation

IMcadJoint interface

SecondarySymType

IMcadWelding interface

IMcadWelding interface

SecondarySymTypeValue

IMcadWelding interface

IMcadWelding interface

SecondDerivativeAt

IGeAugmentedLine interface

IGeAugmentedLine interface

SecondDerivatives

IGeAugmentedLine interface

SecondRequirement

IMcadSurfaceTexture2 interface

SectionLineStandard

IMcadStandard4 interface

SectionPoints

IMcadSectionLine interface

SectionSide

IMcadSectionLine interface

SelectBOMEntity

IMcadBOMMgr interface

SelectBOMEntity32

IMcadBOMMgr interface

SelectionLockMode

IMcad2DStructureMgr4 interface

SelectionOrderMode

IMcad2DStructureMgr4 interface

SeparateDatumID

IMcadFCFStandard interface

SeparateProjected

IMcadFCFStandard interface

Set

IGeAugmentedLine interface

IGeCircularArc interface

IGeCone interface

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeCylinder interface

IGeEllipticalArc interface

IGeLine interface

IGeLineSegment interface

IGePlane interface

IGePoint interface

IGeRay interface

IGeSphere interface

IGeSurfaceSurfaceIntersection interface

IGeTorus interface

IGeVector interface

IMcadRevisionList interface

SetAllSuggestedListsToDefaults

IMcadSurfaceTextureStandard2 interface

SetAttribute

IMcadBOMItem2 interface

SetAttributePreDefinedListValue

IMcadBOMItem3 interface

IMcadPartReference2 interface

SetBasicScale

IMcadScaleArea interface

SetBoundary

IGeCurveBoundary interface

SetByStandard

IMcadDetailSymbolStandard2 interface

IMcadSectionLineStandard2 interface

SetCompatibilityCondition

IMcadNoteStandard interface

SetCondition

IMcadPartListCustomFilter interface

SetCurrentSymbolStandard

IMcadStandard interface

SetData

IMcadFormulaEvaluator interface

SetDataProvider

IMcadFormulaEvaluator interface

SetDefinitionData

IGeNurbCurve interface

IGeNurbSurface interface

SetDimensionType

IMcadTaperStandard2 interface

SetFitData

IGeNurbCurve interface

SetHidesSuppressState

IMcadFolderDefinition interface

setIsDefault

IMcadWeldingLibraryObject interface

setIsDefaultItem

IMcadSymbolLibrary interface

SetLabelNames

IMcadSectionLine interface

SetLayerObjDefault

IMcadLayerObjectMgr interface

SetMoveObjects

IMcadTitleBorderContext interface

SetPartAttribute

IMcadBOMMgr2 interface

SetPartData

IMcadBOMMgr interface

SetPartReference

IMcadTitleBorderContext interface

SetPreDefinedList

IMcadColumnDefinition3 interface

SetProperties

IMcadBOM2 interface

SetRange

IGeKnotVector interface

SetReferenceLockMode

IMcad2DStructureMgr4 interface

SetSectionArcPointAt

IMcadSectionLine interface

SetSectionPointAt

IMcadSectionLine interface

SetSectionPoints

IMcadSectionLine interface

SetSectionViewOrigin

IMcadSectionLine interface

SetSourceGeometry

IMcadDetailSymbol interface

SetStructureMode

IMcad2DStructureMgr4 interface

SetSuggestedListToDefaults

IMcadSurfaceTextureStandard2 interface

SetTargetAttach

IMcadDatumTarget2 interface

SetToAlignCoordinateSystem

IGeMatrix interface

SetToCoordinateSystem

IGeMatrix interface

SetToDefaultAttributes

IMcadBorder interface

IMcadTitle interface

SetToDefaults

IMcadBalloonStandard interface

IMcadPartListStandard interface

IMcadStandard interface

IMcadSymbol interface

IMcadSymbolStandard interface

SetToDefaultTemplate

IMcadNoteStandard interface

SetToDefaultTextLeader

IMcadSymbolStandard2 interface

SetToIdentity

IGeMatrix interface

SetToMirroring

IGeMatrix interface

SetToProduct

IGeMatrix interface

IGeVector interface

SetToProjection

IGeMatrix interface

SetToRotation

IGeMatrix interface

SetToScaling

IGeMatrix interface

SetToSum

IGeVector interface

SetToTranslation

IGeMatrix interface

setWrapPListAttachPoint

IMcadPartList3 interface

ShowAnnotationLeader

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

ShowBorder

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

ShowLabel

IMcadDetailSymbolStandard2 interface

ShowLeader

IMcadDetailSymbol interface

IMcadDetailSymbolStandard interface

SignedDistanceTo

IGePlane interface

SignValue

IMcadEdge interface

SingularityInU

IGeNurbSurface interface

SingularityInV

IGeNurbSurface interface

Size

IMcadColumnDefinition interface

Size2Value

IMcadWelding interface

IMcadWelding interface

SizeType

IMcadWelding interface

IMcadWelding interface

SizeTypeValue

IMcadWelding interface

IMcadWelding interface

SizeValue

IMcadWelding interface

IMcadWelding interface

SkipAfterPart

IMcadPartListGOST interface

SkipLines

IMcadPartListGOST interface

SortChildren

IMcadComponent interface

IMcadComponentDefinition interface

IMcadFolderDefinition interface

SortPriority

IMcadBOMItem3 interface

SouthPole

IGeSphere interface

SpacingValue

IMcadWelding interface

IMcadWelding interface

SpecByAbsoluteScale

IMcadDetailSymbol interface

SpecificationValue

IMcadWelding interface

IMcadWelding interface

Sphere

IGeApplication interface

Split

IGeKnotVector interface

SplitItem

IMcadBOM4 interface

sqcm enumeration member

sqft enumeration member

sqin enumeration member

sqm enumeration member

Standard

IMcadSymbol interface

IMcadSymbolStandard interface

StandardCount

IMcadStandardMgr interface

StandardMgr

IMcadStandard interface

IMcadSymbolBBMgr interface

standardName

IMcadSymbolLibraryObject interface

StandardNames

IMcadStandardMgr interface

StandardNumAllowed

IMcadEdgeStandard interface

StandardNumber

IMcadEdge interface

IMcadEdgeLibraryObject interface

Standards

IMcadStandardMgr interface

StandardValue

IMcadWelding interface

IMcadWelding interface

StartAngle

IGeCircularArc interface

IGeCone interface

IGeCylinder interface

IGeEllipticalArc interface

StartAngleInU

IGeTorus interface

StartAngleInV

IGeTorus interface

StartLatitude

IGeSphere interface

StartLongitude

IGeSphere interface

StartParameter

IGeKnotVector interface

IGeNurbCurve interface

StartPoint

IGeEllipticalArc interface

IGeLineSegment interface

IGeNurbCurve interface

StartTransaction

IMcad2DStructureMgr2 interface

Static

IMcadAttributeField interface

StructureMgr2D

IMcadDocument interface

StructureModeEditEntity

IAcadmApplication interface

Subents

IMcadHideSituation interface

SubSymbolType

IMcadSurfaceTextureLibraryObject interface

IMcadTaper interface

SubWeldingCount

IMcadWelding interface

SuggestedList

IMcadSurfaceTextureStandard2 interface

IMcadSurfaceTextureStandard2 interface

Sum

IGePoint interface

IGeVector interface

SupportedArrowTypes

IMcadStandard4 interface

IMcadSymbolStandard3 interface

Suppressed

IMcadComplexHideSituation interface

IMcadHideSituation interface

Surface

IGeCurveSurfaceIntersection interface

Surface1

IGeSurfaceSurfaceIntersection interface

Surface2

IGeSurfaceSurfaceIntersection interface

SurfaceTexture

IMcadSurfaceTexture interface

SurfaceTextureStandard

IMcadStandard interface

SurfExtLinesOffset

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

IMcadSurfaceTexture3 interface

SurfExtLinesOvershot

IMcadDatumIdentifier2 interface

IMcadFeatureControlFrame3 interface

IMcadFeatureIdentifier2 interface

IMcadSurfaceTexture3 interface

SurfIndLeaderArrowScale

IMcadFCFStandard2 interface

IMcadIdentifierStandard2 interface

IMcadSurfaceTextureStandard3 interface

SurfIndLeaderArrowType

IMcadDatumIdentifier3 interface

IMcadFCFStandard2 interface

IMcadFeatureControlFrame4 interface

IMcadIdentifierStandard2 interface

IMcadSurfaceTextureStandard3 interface

SwapFgAndBg

IMcadHideSituation interface

Swell

IGeBoundBlock interface

SymBBAuto

SymBBAuto library

SymBBAuto::McadAnnotationViewLabel

SymBBAuto::McadAnnotationViewStandard

SymBBAuto::McadBalloon

SymBBAuto::McadBalloons

SymBBAuto::McadBalloonStandard

SymBBAuto::McadBOM

SymBBAuto::McadBOMItem

SymBBAuto::McadBOMItems

SymBBAuto::McadBOMMgr

SymBBAuto::McadBOMs

SymBBAuto::McadBOMStandard

SymBBAuto::McadBorder

SymBBAuto::McadColumnDefinition

SymBBAuto::McadColumnDefinitions

SymBBAuto::McadDatumIdentifier

SymBBAuto::McadDatumStandard

SymBBAuto::McadDatumTarget

SymBBAuto::McadDetailSymbol

SymBBAuto::McadDetailSymbolLabel

SymBBAuto::McadDetailSymbolStandard

SymBBAuto::McadEdge

SymBBAuto::McadEdgeLibrary

SymBBAuto::McadEdgeLibraryObject

SymBBAuto::McadEdgeStandard

SymBBAuto::McadFCFLibrary

SymBBAuto::McadFCFLibraryObject

SymBBAuto::McadFCFStandard

SymBBAuto::McadFeatureControlFrame

SymBBAuto::McadFeatureIdentifier

SymBBAuto::McadIdentifier

SymBBAuto::McadIdentifierStandard

SymBBAuto::McadJoint

SymBBAuto::McadJointStandard

SymBBAuto::McadMarkStamp

SymBBAuto::McadMarkStampStandard

SymBBAuto::McadNote

SymBBAuto::McadNoteStandard

SymBBAuto::McadPartList

SymBBAuto::McadPartListBalloonedFilter

SymBBAuto::McadPartListCustomFilter

SymBBAuto::McadPartListFilter

SymBBAuto::McadPartListFilters

SymBBAuto::McadPartListGOST

SymBBAuto::McadPartLists

SymBBAuto::McadPartListStandard

SymBBAuto::McadPartListStdPartsFilter

SymBBAuto::McadPartReference

SymBBAuto::McadPartReferences

SymBBAuto::McadRevisionList

SymBBAuto::McadRevisionListDescriptor

SymBBAuto::McadRevisionLists

SymBBAuto::McadRevisionMgr

SymBBAuto::McadScaleArea

SymBBAuto::McadScaleAreaMgr

SymBBAuto::McadSectionLine

SymBBAuto::McadSectionLineStandard

SymBBAuto::McadStandard

SymBBAuto::McadStandardMgr

SymBBAuto::McadStandards

SymBBAuto::McadSurfaceTexture

SymBBAuto::McadSurfaceTextureLibrary

SymBBAuto::McadSurfaceTextureLibraryObject

SymBBAuto::McadSurfaceTextureStandard

SymBBAuto::McadSymbol

SymBBAuto::McadSymbolBBMgr

SymBBAuto::McadSymbolLibrary

SymBBAuto::McadSymbolLibraryObject

SymBBAuto::McadSymbolLibraryObjects

SymBBAuto::McadSymbolStandard

SymBBAuto::McadSymbolStandards

SymBBAuto::McadTaper

SymBBAuto::McadTaperStandard

SymBBAuto::McadTitle

SymBBAuto::McadTitleBorder

SymBBAuto::McadTitleBorderContext

SymBBAuto::McadTitleBorderDescriptor

SymBBAuto::McadTitleBorderMgr

SymBBAuto::McadTitleBorders

SymBBAuto::McadTitleBorderStandard

SymBBAuto::McadWelding

SymBBAuto::McadWeldingLibrary

SymBBAuto::McadWeldingLibraryObject

SymBBAuto::McadWeldingStandard

Symbol

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

Symbol2

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

Symbol3

IMcadFCFLibraryObject interface

IMcadFeatureControlFrame interface

SymbolBBMgr

IMcadBOMMgr interface

IMcadStandardMgr interface

SymbolColor

IMcadStandard interface

SymbolEntity

IMcadDetailSymbolLabel interface

SymbolLibrary

IMcadSymbolBBMgr3 interface

SymbolStandard

IMcadSymbol interface

symbolStandardClassName

IMcadSymbolLibraryObject interface

SymbolStandardClassName

IMcadSymbolStandard3 interface

SymbolStandardsSupported

IMcadStandard interface

SymbolTrueColor

IMcadStandard2 interface

SymbolType

IMcadJoint interface

IMcadMarkStamp interface

SysName

IMcadComplexHideSituation interface

IMcadHideSituation interface

T

TangentAt

IGeCircularArc interface

TangentTangent

IGeLineSegment interface

TangentTangentRadius

IGeCircularArc interface

TangentTangentTangent

IGeCircularArc interface

TangentTo

IGeLineSegment interface

TaperStandard

IMcadStandard3 interface

Target

IMcadBOM interface

TargetOrigin

IMcadDatumTarget interface

TargetType

IMcadDatumTarget interface

TargetView

IMcadFolderDescriptor interface

IMcadPowObjViewGroupDescriptor interface

TechnicalReqValue

IMcadMarkStamp interface

IMcadWelding interface

IMcadWelding interface

TextAlignment

IMcadNote interface

TextColor

IMcadStandard interface

TextHeight

IMcadBalloonStandard interface

IMcadStandard interface

IMcadSymbolStandard2 interface

TextHeightList

IMcadStandard interface

TextScalingFactor

IMcadScaleArea interface

TextStyle

IMcadStandard interface

TextStyleName

IMcadStandard interface

TextTrueColor

IMcadStandard2 interface

IMcadSymbolStandard2 interface

ThawAllLayers

IMcadTitleBorderContext interface

ThicknessValue

IMcadWelding interface

IMcadWelding interface

ThirdRequirement

IMcadSurfaceTexture2 interface

ThreadNote

IMcadDatumIdentifier3 interface

ThreePoint

IGeCircularArc interface

Title

IMcadPartList interface

IMcadTitleBorderDescriptor interface

TitleBlocks

IMcadTitleBorderStandard interface

TitleBorderMgr

IMcadSymbolBBMgr2 interface

TitleBorders

IMcadTitleBorderMgr interface

TitleBorderScale

IMcadTitleBorderDescriptor interface

TitleBorderStandard

IMcadStandard3 interface

Tolerance

IGeApplication interface

IGeCurveCurveIntersection interface

IGeCurveSurfaceIntersection interface

IGeKnotVector interface

IGeSurfaceSurfaceIntersection interface

Tolerance2Value

IMcadFeatureControlFrame interface

Tolerance3Value

IMcadFeatureControlFrame interface

ToleranceB2Value

IMcadFeatureControlFrame interface

ToleranceBValue

IMcadFeatureControlFrame interface

ToleranceValue

IMcadFeatureControlFrame interface

TopNoteValue

IMcadFeatureControlFrame2 interface

Torus

IGeApplication interface

Transformation

IGeOffsetCurve interface

TransformBy

IGeEntity interface

IGeVector interface

TranslateBy

IGeEntity interface

Translation

IGeMatrix interface

Transpose

IGeMatrix interface

TransposeIt

IGeMatrix interface

TrimByParameters

IGeNurbCurve interface

TrueColor

IMcadBalloonStandard2 interface

IMcadLayerCfg interface

IMcadLayerObjectCfg interface

Type

IMcadPartListFilter2 interface

IMcadWelding interface

IMcadWelding interface

IMcadWeldingLibraryObject interface

Type Libraries and Object Models

U

UControlPointCount

IGeNurbSurface interface

UKnotCount

IGeNurbSurface interface

UKnots

IGeNurbSurface interface

UndefsizeDirection

IMcadEdge interface

IMcadEdgeLibraryObject interface

Unknown enumeration member

UParameterEnvelope

IGeSurface interface

Update

IMcad2DStructureMgr interface

IMcadComponentDefinition interface

UpdateBgSelection

IMcadComplexHideSituation interface

UpdateEntities

IMcad2DStructureMgr interface

IMcad2DStructureMgr3 interface

UpdateSymbols

IMcadStandardMgr interface

UpdateToAttachedObject

IMcadSymbol2 interface

Upper

IGeInterval interface

UseMapping

IMcadPartListStandard interface

Utility

IMcadDocument interface

V

Value

IMcadIdentifier interface

VControlPointCount

IGeNurbSurface interface

Vector

IGeApplication interface

VectorAt

IGeAugmentedLine interface

IGeAugmentedLine interface

Vectors

IGeAugmentedLine interface

ViewID

IMcadPartList interface

ViewID32

IMcadPartList interface

ViewKey

IMcadFolderDescriptor interface

ViewName

IMcadFolder interface

IMcadFolderDescriptor interface

Views

IMcad2dComplexStdPartCompGroupDescriptor interface

IMcad2dShaftCompGroupDescriptor interface

IMcadFolderDescriptor interface

ViewScale

IMcadFolder interface

ViewType

IMcadFolderDefinition interface

VisibilityOverride

IMcadComponent interface

IMcadFolder interface

Visible

IMcadComponent interface

IMcadFolder interface

VKnotCount

IGeNurbSurface interface

VKnots

IGeNurbSurface interface

VParameterEnvelope

IGeSurface interface

W

WasErased

IMcadObject interface

WavinessValue

IMcadSurfaceTexture interface

WeightAt

IGeNurbCurve interface

IGeNurbCurve interface

WeightCount

IGeNurbCurve interface

Weights

IGeNurbCurve interface

IGeNurbSurface interface

WeldingStandard

IMcadStandard interface

WeldProcessPrefix

IMcadWeldingStandard2 interface

What's New

Width

IMcadColumnDefinition interface

IMcadPartList interface

WrapAroundTitle

IMcadPartList3 interface

WrapText

IMcadPartList interface

IMcadPartListStandard interface

WrapTitleBlockId

IMcadPartList3 interface

WrapTitleBlockId32

IMcadPartList3 interface

WriteAttributeClass

IAcadmApplication interface

X

X

IGePoint interface

IGeVector interface

Y

Y

IGePoint interface

IGeVector interface

yd enumeration member

Z

Z

IGePoint interface

IGeVector interface

Copyright (c) 2014. All rights reserved.