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Introduction 
InfoWorks ICM is the first software modelling package allowing the full integration of 
hydrodynamic and hydrological models within a powerful workgroup management platform.  

InfoWorks ICM provides a new single simulation engine that fully integrates 1D and 2D simulation 
of drainage networks, open channels, rivers and floodplains. InfoWorks ICM can be used to 
model manholes, pipes, inlets, natural channels, man-made channels and rivers for complete 
integration of above and below ground elements. The resulting model contains common 
hydrology and can include both catchment and floodplain data. 

 

Enhanced user-friendly interface for more 
efficient modelling 
InfoWorks ICM employs the latest techniques to provide a user interface that is more user 
friendly and intuitive than ever before, leading to real performance gains as the user can work 
more efficiently to meet project goals. Features such as undo/redo and recycle bin allow the 
user to easily modify errors, while the dockable windows and editable property sheets, enable 
the user to create a more efficient workspace. Version control allows multiple modellers to 
access the database and make edits while maintaining data integrity through auditing, comparing, 
and conflict resolution. The new model edit strip allows easy access to all common properties, 
which dynamically update as the user changes selection. Additionally, in-line validation quickly 
and efficiently highlights any unintentional errors during model building leading to more accurate 
results in less time. 

 

Powerful scenario manager transforms 
modelling workflow 
An easy-to-use scenario manager allows the user to quickly apply different “what if” scenarios to 
the base network model. This enables the user to maintain a single model of the drainage system 
and quickly construct, apply, and evaluate different scenarios as they relate to that model. 
Scenarios can be cut, copied, and pasted between different branches of the inheritance tree, 
allowing the user to quickly combine different scenarios to address a particular modelling 
concern. 

 

New simulation server allows distributed model 
simulation 
InfoWorks ICM supports the running of simulations on standalone workstations, or where more 
computing resources are available, such as servers or high-end computers, model simulation can 
be distributed to take maximum advantage of those resources. Users can schedule simulations to 
run on their own local computers as well as remote computers, setting them to run as soon as 
possible or at a specified time. They can then monitor and control the progress of selected 
simulations and the queue of simulation jobs on a straightforward user interface. Simulations on 
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remote computers can continue even when users have disconnected their own local computers 
and the simulation load can be balanced on an individual machine or within named groups of 
machines, giving equal priority to all users. 

The new simulation server also allows users to store results locally or share them on a central 
server. Simulations can be left to complete, and their results uploaded to the central server 
without further user intervention. 

 

Data Management 
InfoWorks ICM is a workgroup based modelling and configuration management system that can 
also be used as a standalone product. 

To facilitate both workgroup and standalone operation, InfoWorks ICM maintains data in a 
centralised multi-user Master Database, consisting of a database and additional files. 

Local working copies of parts of the master data, (such as networks with changes that have not 
yet been committed), are stored in each users Local Working Folder. 

Information that relates to the master database, but is not stored in the database, such as ground 
model data, is stored in Remote Roots. The files containing this data can be very large, so it is 
better to store them outside of the database. 

Transportable databases are used to transfer information between master databases. 

 

Master Database Formats 
To begin working with InfoWorks ICM, a master database must be set-up. The master database 
stores all data and information for the network. Databases in ICM can be standalone or 
workgroup. The database format has no size limit therefore all data and results can be stored in 
one database.  If a model is migrated from InfoWorks CS or SD, it will need to be imported into a 
new/clean master database.  The Master Database provides a flexible hierarchy for managing 
data. 

The top level of this hierarchical structure is the Model Group. All data within the master database 
must be contained in a Model Group. A Model Group can contain the following: 

1. Other Model Groups  
2. Version controlled items such as Networks  
3. Non version controlled items such as Selection Lists  

The database types currently supported by InfoWorks ICM are: 
• Standard Standalone Database - the default database type for InfoWorks ICM. This 

database is intended for use by individual users working on a single PC. This database type 
is only appropriate for use on a standalone machine.  

• Standard (WorkGroup) Database - intended for use by individuals and groups of users. 
Requires the use of the Workgroup Data Server software, running as a service on the 
machine hosting the database.  

• SQL Server (WorkGroup) Database - you must already have your own Microsoft SQL 
Server database installation  
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• Oracle (WorkGroup) Database - you must already have your own Oracle database 
installation 

For more details about the Workgroup Data Server please refer to the Help Topic.  
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Workshop 1: Setting up the Database 
To begin working with InfoWorks ICM, a Master Database must be set-up. There are two master 
database types available in InfoWorks ICM: 

• Work Group Database - The default database type for InfoWorks ICM. Intended for use by 
individuals and groups of users. Requires the use of the Workgroup Data Server. 

• Standalone Database - This database is intended for use by individual users working on a 
single PC. This database type is only appropriate for use on a standalone machine. 

1A. Master Database Settings 

We will begin by setting up a new Master Database in InfoWorks ICM. 

 To create a new Standalone Master Database, go to File > Open > Open/Create master 

database… or alternatively click on the Open/Create master database icon under the File 

toolbar.  

 

 Select Standalone and click New...  

 Create a new folder on the C drive called RAFTS in ICM Training and call the Master 

Database RAFTSinICM.icmm. 

 

 The Master Database object should now be visible in the Explorer Window. 

NOTE: If you do not see the Explorer Window, go to Window > New Explorer window. 

 

1B. Local Folders 

The Local Folders is where ICM will store the working files. A new .wdb file will be created every 
time a network is opened in the GeoPlan. This is specific to the user and their working folder and 
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will not update the Master Database until the changes are committed. The location for this is 
automatically set by ICM but it can be manually changed. As it is one of the main folders that ICM 
is reading and writing data in it should be ensured that it is on an appropriate drive. 

It is important to manage this folder as it can end up containing a lot of data if it is not maintained 
regularly. To maintain the size of the working folders there is the button to Clean unused files 
from the folder for this database. This will remove historic network objects that are not currently 
open which have been committed to the Master Database file so that they can be retrieved in the 
future. 

Review the location of your Local Folders. 

 Go to Tools > Options… to open the Options menu and select the Local Folders tab. From 

here you can select either Working Folder or Results Folder from the drop-down menu. 

Select Working Folder and then click on Open the folder for this database with Windows 

Explorer. 

 

1C. Transportable Databases 

To move database content from one master database to another, a Transportable Database is 
required.  This will allow the data to be zipped up and emailed/transferred to a new location. 
NEVER copy the master database, ALWAYS use a transportable database to move data. A 
transportable database is useful to transfer data between colleagues, to clients or to Innovyze 
support (support@innovyze.com). 

mailto:support@innovyze.com
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Workshops in this Training Manual will use template data that has been stored in a Transportable 
Database. 

Open a Transportable Database and copy data to your Master Database. 

 Go to File > Open > Open transportable database… navigate to the RAFTS in ICM data 

folder and choose RAFTSinICM_TD.icmt from the files and click Open.  Alternatively use 

the Open transportable database icon under the File Toolbar. 

 

NOTE: The model files were developed in InfoWorks ICM 2021.3. You will need to be working with 
version 2021.3 or higher to open the transportable database. 

 A new window will appear with model objects inside.  Select the RAFTS Part1 – COMPLETE 

Model group object, right click and Copy.  In your newly created Master database, right 

click on the Master database and Paste the objects (with children). Check the options to 

copy ground models and simulation results. 

 Close the transportable database window.  

NOTE: To create a transportable database, go to File > Open > Open new transportable 
database… Again, there will be a dialog prompting you to save the file in a specific location. The 
file will be given the extension .icmt. 

 

1D. Model Groups & Networks 

A Model Group stores all modelling and simulation data created in InfoWorks ICM for a project. It 
is also possible to use model groups to group particular data types together, for example, it is 
possible to set up a model group for rainfall or inflow files. Just like the C drive on your computer 
can have many file folders, a master database can have many model groups. 

Create a new project Model Group and Network. 

 Right click on the Master Database Object in the Explorer Window and select New > Model 

group and give it the name RAFTS Part1. This will be the folder that contains all your project 

components (network, rainfall, results etc). 

 Right click on the Model group and select New InfoWorks > InfoWorks network and type 

the name Industrial Development. 
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 Double click on the new Network object (Industrial Development) to open in the GeoPlan 

and maximise the window. 

1E. Units & Projection / Co-ordinate System 

Set up the Units for the Master Database and the Coordinate System for the project Network. 

 Go to Tools > Options… and select the Units tab. Notice the units that are assigned to each 

item in the Description column. Set your units to Metric (Native) and click OK. 

 

 To set the coordinate system for the network go to GeoPlan > Set coordinate system…  

Click on the ellipsis icon to see the available projections.  Select MGA Zone 56 (GDA 94) 

[EPSG 28356] from the list under the Map Grid of Australia 1994 (MGA94). 
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1F. Data Flags 

Data Flags are an important part of the model auditing process and are important in determining 
where data originated. There are some fixed default flags in InfoWorks ICM as shown in the User 
Defined Flags window below. 

Set up user defined flags within the Master Database. 

 Go to File > Master database settings > User defined flags... or alternatively click on the 

User Flags icon under the File toolbar. 

 

 Right click in the first empty row under Name and type in your initials, select a display 

colour and provide the description Manual Changes.  
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 Add an additional 4 user defined flags as described below and click OK. 

• FD – Field Data 
• AS – Assumed Data 
• OP – Options Testing 
• IN – Inferred Data 

 Click on the Use edit flag icon under the Edit toolbar and then select your initials from the 

dropdown menu. This will flag any manual changes you make in the model with your 

initials.   

 

 

1G. Setting User Defined Defaults 

Set the default Land use ID and Runoff surface under Subcatchments for the Network. 

 Go to Network > User defined defaults > Subcatchment. Use the down arrow next to the 

Land use ID to Open Land use DEFAULT. 

 Change the Land use ID to RURAL. 
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 Use the down arrow next to Runoff surface 1 to open the runoff surface properties. 

Populate the Description as IL=15_CL=2.5_n=0.045, set the Surface type to Pervious, the 

Routing model to RAFTS, the Runoff volume type to DefConLoss, the Maximum deficit 

(mm) to 15, the Infiltration loss coefficient (mm/hr) to 2.5, the Initial loss type to Abs and 

0 for the Initial loss value (m). Then set the Equivalent Manning’s n to 0.045. Click Close 

on the Runoff surface window and Close the Land use window. 

 

 Back in the Subcatchment defaults dialog, change the Land use ID to RURAL and click OK. 



 

  
 
 
 

14 

RAFTS in InfoWorks ICM / ICMOne 

 

1H. ICM Help 

Getting started can sometimes be the most difficult hurdle, so we have put together a collection 
of resources that we think will get you up and running with InfoWorks ICM right away. The 
InfoWorks ICM Online Help is a great source of information that includes links to the Innovyze 
Support Portal and Knowledgebase. The Knowledgebase has a host of articles available that 
cover topics in more depth, include more “how-to” instructions, and answer common support 
questions in more detail. The Knowledgebase can be accessed from the Support Portal.   

The ICM Help is very robust with a wealth of information and detail about the features and 
functionality of the software. ICM Help can also be accessed from the Start Menu if ICM is not 
open. If it is, you can simply go to Help on the menu toolbar.    

Access the InfoWorks ICM Help. 

 On the menu bar, go to Help > Help topics. Now type “RAFTS” into the search bar and 

select List Topics. 

 This will now bring up a list of topics which contain the key words underneath. Select the 

topic called RAFTS Routing Model by double clicking. This will highlight the key words 

which can be cleared by pressing F5.  

https://help.innovyze.com/display/infoworksicm/InfoWorks+ICM+Help+Documentation
https://help.innovyze.com/display/infoworksicm/InfoWorks+ICM+Help+Documentation
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Workshop 2: Setting up Project Data 

2A. Background Layers 

The InfoWorks Suite interacts closely with a number of GIS packages including ArcGIS and 
MapInfo. Layers from these GIS packages such as shape files, images and mapinfo files can be 
added to the GeoPlan as background images. InfoWorks is most commonly installed with 
MapXtreme. Using MapXtreme will allow background layers of varying types to be inserted on 
the GeoPlan without need for any additional GIS licences. However, should an ArcGIS licence be 
available additional interaction with ESRI Geodatabases will be available from within the 
InfoWorks interface. 

Add background layers to the GeoPlan. 

 Right-click on the Geoplan and select GIS Layer control...  Click on Add… and browse 

through the RAFTS in ICM Data\Part 1 folder. Make sure that the File type is set to Raster 

Image, select Aerial_1.jpg and click Open. Check that the image is in the same projection 

as our network and click OK.   

 

 Right click in the Geoplan and View entire GIS layer… and select the JPG to zoom to the 

project area. Note the scale bar at the bottom of the Geoplan. 
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 Right click in the GeoPlan again and select View online > Google Maps.  The internet 

browser should open Google Maps at the same location as the mouse pointer.  This is a 

good check to ensure you have the right projection set for the site.  

 Pan the project site by pressing and holding the mouse wheel and the moving hand 

appears next to the cursor to pan around the image. Use the mouse wheel to zoom in and 

out by rolling the wheel forward and backwards, respectively. A second option is to use the 

Pan and Zoom icons in the GeoPlan toolbar.  

 

Tip – Press F8 on the keyboard to toggle between select and pan.  

 The background layers can be saved for use at a later date or in another network.  Right 

click on the Model group and go to New InfoWorks > Layer list. Give the object the name 

Aerial Img and select OK. 
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2B. Importing Ground Models 

Ground models are a very useful way of looking at and interrogating data. They can be used by 
the Inference tool in order to fill in gaps in the network data and they are necessary for 2D 
simulations. Ground models are also particularly useful for looking at bridge openings and 
definition.  

Import Ground Model data into the project Model group. 

 Right click on the RAFTS Part1 Model group and go to Import InfoWorks > Ground model 

grid > from ground model grid folder…  

 Navigate through the following path RAFTS in ICM data\Part 1\NSW Government – 

Spatial Services\DEMs and select the 1 Metre folder. 

 Type in NSWGov DEM 1m for the Ground model Grid name, choose Meters (Native) for the 

Units and ensure you use the Floating point or mixed to include elevations with decimal 

places. Click OK. 

 

 Drag the new Ground model object onto the GeoPlan to add it to the view.  

 You can view the ground model draped over the background images using the New 3D 

network window icon in the Windows toolbar or going to Window > New 3D network 
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window.  Right click in the 3D view to bring up the Properties dialog. From here you can 

further exaggerate the vertical factor of the ground model’s elevation (see image below).   

 Close the 3D view. 

NOTE: You can clear the ground model from the GeoPlan by going to Network > Clear ground 
model. 

 

 

2C. Using Properties & Themes 

A significant proportion of the GeoPlan functionality originates from the GeoPlan Properties and 
Themes dialog box. A number of visual changes can be made as well as the addition of themes 
to the network.  

The properties of each asset (e.g. colour, display settings etc.) can be altered using the Layers 
and Themes tab of the dialog box. When starting ICM, all assets are assigned a default colour 
and all are visible in the GeoPlan. It is possible to turn off any of the network objects to improve 
the visibility of other network objects. 

Open the GeoPlan Properties and Themes dialog, save changed settings as a default and load 
pre-defined themes from the transportable database. 

 Right click anywhere in the GeoPlan and select Properties & Themes…  
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 Go to the Visual tab and under Misc check on the Show ground level, flood depth, 2D 

depth and spatial rain in coordinates panel. This will turn on Z elevations for the cursor 

location in the bottom right corner of the GeoPlan. 

 

 Click Apply then Save and select Save as default for this network. Click OK to exit.  

 Move your curser over the Ground model to investigate the grid elevations. 

 Locate the RAFTS Hydrology Theme object within the transportable files that we copied 

into our Master Database earlier and drag it onto the GeoPlan. You will notice a change in 

the Ground model definition. 
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2D. Committing Changes 

Every time a change to the network is committed, a new version of the network is created. The 
Show commit history (found under the Network > Version control menu or by right clicking on 
the network) details each version of the network. For every commit, there is a corresponding 
version. It tells the user the version number, date, user and the number of changes made. The 
notes section should be used as a model log to detail the version number and any changes that 
have been made.  By maintaining detailed commentary, a model log kept outside the software is 
generally not required.  
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Commit the changes to the Master Database. 

 Right-click on the Industrial Development network in the Explorer Window and select 

Commit changes to master database. In the Comments, type in a summary of what has 

been made so far since the last commit. A good example would be Workshop 2 – Setup 

GeoPlan and background data. Changes made to Subcatchment defaults. Click OK.   

 Click NO in the Validation Window. You will notice committing changes will turn the 

undo/redo greyed out. This network is now version controlled.  

 

 Right click again on the Industrial Development Network object and select Show commit 

history.  Here we can see the versions committed so far (2). 
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Workshop 3. XPRAFTS model Import 
Before importing an existing model into InfoWorks ICM it will first need to be exported from 
XPRAFTS classic.  With the desired XPRAFTS model network open, go to File > Export Data… and 
ensure All Objects and All Variables are selected.  Save and Export the XPX file. 

 

 

3A. Importing XPRAFTS Network  

Use the XPRAFTS importer to import a XPRAFTS Network into ICM. 

 With the Industrial Development Network open in the GeoPlan, go to Network > Import > 

Model > from XPRAFTS XPX file…  

 Navigate to the RAFTS in ICM Data folder, select the Development1.xpx file and click 

Open.  The import options dialog will appear to select the Unit size and Lag links options. 

Select Small and Maintain network connectivity by converting downstream lag links to 

channel.  
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 Close the Import log. Right click in the GeoPlan and select Zoom to network. The shortcut 

F12 can also be used to zoom to the network. 

 

3B. Importing XPRAFTS Storms 

Import the Global storms from a XPRAFTS model as Rainfall objects in the project Model group. 

 Right click on RAFTS Part1 in the Explorer Window and select Import InfoWorks > Rainfall 

event > from XPRAFTS XPX file…  

 Navigate to the RAFTS in ICM data\Part 1 folder, select the Development1.xpx file again 

and click Open.  All the available storms in the XPRAFTS model will now be available as 

individual Rainfall objects under the Model group.  
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3C. Validating the Network 

Before we can commit a network and run a simulation, the network must be validated.   

The validation tool will flag any user-input values that are inaccurate, inappropriate, or missing. 
These are judged with a range of priorities: 

• Red = an error that MUST be fixed if you want to be able to simulate the network 
• Yellow = a warning that something is possibly not right 
• Blue = information that you might wish to take note  

Validate the Network model and view the Output messages. 

 Go to Network > Validate network or select the red tick in the Validation toolbar . 

Select OK in the Network Validation window. 

 The message output box should appear with a number of warnings and errors.  

 

 The validation tool has alerted the need to include an outfall in the network. There are also 

several warnings in the output which can be ignored due to the purpose of this model. The 

errors will be resolved in the following steps.  

3D. Adding Objects Manually 

XPRAFTS models do not include Outfall nodes and in ICM subcatchments wont drain to Outfalls.  
To remove the validation errors, an outfall will need to be added to the Network. 

Add an outfall node and a ‘Dummy’ weir to validate the Network.  

 Select Node from the dropdown box within the GeoPlan toolbar. Press the New object 

button to begin creating a node. 
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 Create a new node downstream of node C10. Give the name Outlet, set the node Type to 

Outfall and the System Type to storm. 

 

NOTE: The properties dialog should automatically appear for the new node that has been 
created. You will notice there are some validation messages appearing where critical data for the 
node is missing.  We will need to populate this data before we can validate the network for a 
simulation.  

 In the properties dialog enter 0 for the Ground level (m AD).  XPRAFTS models do not 

include invert levels however ICM will start the imported network grade at RL 0 m. 
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 Select Link from the dropdown box within the GeoPlan toolbar. Press the New object 

button to begin creating a link.   

 

 Draw a link from C10 to Outlet. Double click to complete the link and the Create New Link 

dialog will be shown. Select storm as the System Type and Weir as the Type. A default 

value of 1 will be adopted as the Suffix. 

 

 In the properties dialog, enter 0 for the Crest (m AD) and then set the Width (m) to 30.   

 

 Validate the network. This time no errors should appear in the Output window. 

3E. Customising the Object Property window 

In ICM, Users have the ability to customise the Object Properties window to highlight the 
important input data, group together desired properties or hide irrelevant information just to 
name a few examples. 

Create a new Group within the Subcatchment object properties and group in selected 
subcatchment properties. 

 Double click on Subcatchment C10#1 to open the subcatchment object properties. 

 Click on the drop-down next to the Configuration icon and select Layout > Edit. 
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 Right click within the Object properties window and select Add group. Call the new group 

RAFTS. Ensure that the new RAFTS group is moved to the top of the window. 

 Find the following subcatchment properties and drag them under the RAFTS group: 

Subcatchment ID, Total area (ha), Contributing area (ha), Land use ID, Slope (m/m), 

Output lag (minutes), Bypass runoff 

 Click on the drop-down next the Configuration again and select Layout > Save locally. 

Right click within the properties window and select Close to exit the edit window. 

 

 Right click on the Industrial Development Network in the Explorer Window and select 

Commit changes to master database.  In the Comments, type in a summary of what has 

been made so far since the last commit.  A good example would be Workshop 3 – 

XPRAFTS model imported and outfall added. Click OK and select Yes to validating the 

network if required.  
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Workshop 4. Simulating and Reviewing 
Results 

4A. Updating the Channel Definition 

By default, the imported Channel links will have a minimum of 5 computational nodes per link 
when the engine is performing the model calculations in the hydraulic simulation. This is based 
on global default simulation parameters, chosen for optimum accuracy and performance. The 
Simulation Parameters can be viewed in Model > Model parameters > Simulation parameters.  

Editing of the global simulation parameters is not recommended. However, we are able to update 
the minimum number of computational nodes individually for each channel links without 
affecting the simulation parameters across the entire network to improve the performance of the 
model calculations. 

Inspect the pre-defined SQL and Run to change the minimum number of computational nodes 
for each channel. 

 From the Transportable Database, right click on the CHANNEL: min no. comp nodes SQL 

and select Open.  

 You can see from the editor that the SQL is going to update the Minimum computational 

nodes field based on the slope of the channel. Press Close. 

 

 Drag the SQL onto the GeoPlan and open the properties for a few of the channels in the 

model. The min. computational nodes field will be updated from 5. 
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 Validate and commit the Network. 

4B. Setting up the Run object 

Now we are going to set up the simulation data and parameters and run the simulation. 

 Right click on the RAFTS Part1 Model Group and select New InfoWorks > Run.  

 Fill in the Run title as Industrial Development Run.  

 Select the Industrial Development Network and the Rafts Storms group from the Group 

Window (Use the CTRL key to multi-select) and drag them onto the Run Window dropping 

anywhere within the grey area of the dialog.    

 Check the Allow re-runs using updated network option which means we can re-run and 

overwrite the results rather than creating a copy of the run later.  

 Change the Timestep (s) to 1, the Result timestep multiplier to 60 and the duration to 120 

minutes. 

 Click Run simulations and OK. 
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4C. Simulation Results 

With the simulations complete, we are ready to analyse and present the results. The 
interpretation of simulation results is key to the hydraulic modelling process.  There are a large 
number of tools in InfoWorks ICM to assist the user in reviewing results.   

Firstly, we will look at the summary results and text output files. Then open the time-varying 
results and explore the different methods of interrogation including setting up custom graph 
templates. 

 Right click one of the simulation icons  and go to Open As... The following dialog appears:  

 
Full Replay Results: 
Visual GeoPlan results 
as explained above.  
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 Open one of the simulation’s PRN and Log files and investigate any messages that may 

appear. 

An example section of the PRN results is shown below. It is used to get an overview of the 
network results containing maximum results for nodes and links.  

 

An example of the Log results is shown below. It is used to summarize the input data and 
performance of the simulation.  It will contain any error or warning messages as well as a 
summary of the model run times. 

Useful information will be the summary of total rainfall, runoff, inflow, outflow and lost volume. 
These can be used to ensure that the 1D model is behaving as expected.  

‘PRN’ summary results: 
This is a summary of the 
networks inputs and 
outputs at all locations.   

Log results: A breakdown of 
the simulation, any 
simulation errors are listed 
here; this is especially useful 
if the model is not 
completely successful. 

As alternate results for 
comparison: Open two 
GeoPlan results for 
comparison.   

Simulation properties: 
Summary properties for the 
simulation. Can be used to re-
run.   
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Should the simulation fail then the Log file will be the only results text file available. This will 
allow you to analyse the failed simulation for problems. 

NOTE: You can turn on more detailed log files by using the Diagnostics tool which is built into the 
simulation window. To activate select the Timestep Log option. 

 

There are many messages that can appear within the Log files which can provide information as 
to why the model simulation may have been unsuccessful.  It is beyond the scope of this course 
to go through them all and knowing how to deal with each one will come with experience. While 
building your InfoWorks ICM experience it may be useful to use the blog posts and knowledge 
articles which can be accessed through the Support Portal. 

 Right click on the RAFTS Part1 model group and select Open results manager. This will 

provide a summary of the results under that model group including the ID, simulation 

results size and location. 

 

This information can be extremely useful as it can be used to estimate how much storage a full 
set of results may use, help you understand why you cannot view simulation results or identify 
which simulation results are associated to the runs. 

NOTE: Using the Results manager, you can move results from your local results folder to the 
remote root and vice versa. This means that you can have those results locally that you require 
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fast, read/write access and then move them once reviewing is complete. This can cut down on 
speed issues resulting from slow network connectivity. 

The properties dialog which is opened using the  tool will automatically open on the 
properties results page when results are active. You can toggle between the object properties 

and results using the  icon. The time is displayed on the left-hand corner. 

NOTE: The results that can be viewed are snapshot intervals taken at the timestep and results 
multiplier. Therefore, unless the maximum and minimum values occurred at a major timestep the 
graph and object results will differ. This should not however be significant. If there is a significant 
difference it may indicate that the model is having convergence problems, and this should be 
investigated further. 

  

The results properties will show a range of result parameters at the current timestep.  When 
animating time-varying results the results value will change as the results timestep changes (as 
will the grids and any themes you have active). 

 Open the ECN_20pct_1hr_1 simulation results by right clicking Open or dragging into the 

GeoPlan. Select a node or channel of your choice using the Properties tool in the GeoPlan 

toolbar. 

4D. Results Grids, Themes & Graphs 

Results can be graphed using either the quick Graph tool  or the Graph selected objects 

tool which has the red bar underneath . 

Time-varying results: this 
will display the values for 
the individual timesteps of 
the simulation. 

Maxima results: These are the 
maximum values for those 
properties which are displayed. 

Selected useful properties to 
aid the user. 

Time and simulation: this 
states the timestep of the 
results and the simulation 
name. 
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 Use the Graph tool and click on Subcatchment C10#1. Use the CTL key to select both 

Runoff (m3/s) and Total outflow (m3/s) from the attributes to graph list and click OK. 

 

 

 Select all objects in the GeoPlan using the Select all objects tool . Then go to Results 

> Custom graphs > Simulation per page report… 

 Drag the completed Run object into the Sim window and press the # key in the Selection 

list to use the current selection. Move to the Layout tab and select Runoff (Subcatchment) 

in the Attribute for axis (Left) dialog and select all the Subcatchments (17 in total) from the 

Plot attribute at these locations dialog.  
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 Click on the Graph view tool in the top left corner of the dialog to view the Subcatchment 

runoff results.  

 

The result grids tabulate all the result information for the individual objects. You will see the 
default layout when we open the results grids. This can be customised and saved so that the 
most useful information is moved into the left-hand columns for easier viewing. 

 Grids are a good way to review the object results all together. Go to the Window > Grid 

windows > New Subcatchment results window. 

 

In the Subcatchment results grid you will notice green column headings which represent the 
time-varying results for the time step you are on and black column headings which represent the 
maximum results.   
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The process is the same for theming results and data input (as we did previously). However, when 
we have results open, we will get an additional set of options from the drop-down menus. During 
this part of the exercise, we will set-up some basic themes that will make viewing the model 
easier, as well as presenting some basic results.  

 Right click in the GeoPlan and go to Properties & Themes… Click on Edit for the Channel 

Object Layer under Theme and add two new subthemes by pressing the Add New box in 

the top left-hand corner of the dialog window.  

 Edit the subthemes as per the figures below.  
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 Click on the Auto Labels and Tooltips tab. Check the option to Rotate Link Labels then 

select User under the Label Field and click Set. 

 Change the Object Type to Channel, choose US flow in the Field drop-down and press 

Insert Field. Click OK. 
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 Go back to the Layers and Themes tab and check on the box for AutoLabel next to 

Channel. 

 Save the themes under Save to database object to the RAFTS Part1 model group with the 

name RAFTS Sim Results. 

4E. Exporting Results  

Export subcatchment hydrographs to CSV. 

 Go to Results > CSV export… drag in the ECN_20pct_1hr_1 simulation object, check runoff 

under the Subcatchment tab and set the Output Folder to an appropriate location. Click 

OK. 
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Workshop 5. Creating a New Network   

5A. Using Network Templates 

We will use a Template Network to create a new network to shortcut setting up the background 
information and settings from workshop 1 and 2. Any network created from a template will contain 
all the data and settings from the templated network.  In this example, the template contains some 
default node, link and Subcatchment settings, themes and the projected co-ordinate system. It also 
has a development site and existing ground contour information.  

 Open up the RAFTSinICM.icmt transportable database from the training data folder again 

and copy the RAFTS Part2 - Template Model group in the master database. 

 Go to Tools > Template Network.  Drag in the Template MGA9455 from the files copied 

from the transportable database and click Apply then OK.  

 

 Right click on the Master Database Object in the Explorer Window and select New 

InfoWorks > Model group and give it the name RAFTS Part2. This will be the folder that 

contains all your project components (network, rainfall, results etc). 

 Right click on the Model group and select New InfoWorks > InfoWorks network, type the 

name Urban Development and check on Use template network. Press OK. 

 Double click on the new Network object (Urban Development) to open in the GeoPlan 

and maximise the window. 

 Right-click on the GeoPlan and select GIS layer control… Press Add… and select 

Aerial_2.jpg from the Part 2 data folder. Note that the background layer is a Raster image 

type. 
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 Save the GIS image to the Model group as a new Layer List: Aerial Img – P2. Now drag on 

the Label list: Development Site from the copied transportable database files. The 

network should look like the below. 

 

5B. Adding Subcatchments  

From the contour information we can see there is an external catchment draining to the top of the 
development site.  We will start by importing Subcatchment data from GIS and manually create 
any missing subcatchments that drain to the development site.  

 To import the subcatchments go to Network > Import > Open Data Import Centre… 

 Set the Table to Import Data Into as Subcatchment and set the Data Source Type to Raw 

Shape File. Press the ellipsis button and browse to UrbanDev_Subcatchments.shp in the 

RAFTS in ICM data/ Part 2 folder path. 

 Under Import Fields, set the Subcatchment ID equal to the CatchID and the System type 

to storm from the drop down under Default Values. Click Import and then Close. You 

should get a message outlining that 3 new objects have been imported.  
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 Use the Custom label icon in the GeoPlan toolbar to add a label to the two subcatchments 

shown in the image below.  
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Note that the subcatchments do not cover the full area draining to the top of the development 
site.  We will add the missing Subcatchment manually using the Geoplan tools. 

 To add the missing Subcatchment manually, select Subcatchment/Storage from the 

dropdown menu and click on the New object tool to start drawing. Using the background 

contours for reference, add in the missing catchment area.  Ensure that the Use snap mode 

is turned on. 

 

 Set the Name to C_2 and the Type to Subcatchment.   

 Add a Custom label to the new Subcatchment. 
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 We can use the Model tools to ensure the 4 subcatchments have snapped vertices and no 

gaps or overlaps.  Hold down CTRL to select all 4 polygons using the select tool. 

Alternatively, you can right-click on Subcatchments in the Key window and choose Select 

objects.  

 Go to Model > Geometry > Close gaps and overlaps…  Set the area to 50m and then click 

Select and Close.  Once there are no more gaps or overlaps select Cancel to close the 

window. 
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 For the purpose of the training, we will manually overwrite the area of the drawn 

subcatchment to ensure consistent results. Open the Subcatchment properties for C_2 and 

set the Total area (ha) as 4.57.  Note the contributing area should automatically update.  

5C. Entering Subcatchment Data 

A Subcatchment describes an area draining to one or more inflow nodes. Some of the 
parameters are defined directly in the subcatchment. The specific Runoff Surfaces are defined in 
a Land Use which is associated with one or more subcatchments. The Land Use also provides 
some default parameters for the subcatchment. These defaults can be over-ridden in the 
subcatchment data if necessary. 

A Land Use contains a list of Runoff Surfaces particular to the type of Land Use being defined. 
Example Land Uses are Residential, Industrial, Commercial, etc. It also contains default values for 
several factors, including the percentage of total area for each Runoff Surface, Population 
Density, and Connectivity. The two typical surface types used with the RAFTS Procedure are 
Pervious and Impervious. The software allows use of up to 12 Runoff Surfaces per Land Use to 
support the modelling of more complex mixed surfaces.  

 

A Runoff Surface describes the runoff characteristics of a specific surface type, for example 
Road, Roof or Pasture. For each surface type individual characteristics can be defined that 
determine how runoff of rainfall occurs on that surface, the volume of runoff and the rate at which 
it enters the drainage system.  Runoff Surfaces include parameters like Infiltration, Manning’s n 
and Routing Model.  
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In the example above, we can assume that this typical Urban Land Use has 3 types of Runoff 
Surfaces:  Impervious with Storage, Impervious with no storage, and Pervious with Infiltration.  
Each surface has its own characteristics, and runoff subcatchment when rainfall falls on them.   

The relationship between Runoff Surface, Land Use and Catchments is illustrated in this example 
below: 

 

We are going to create a new Land Use with user defined Runoff Surfaces to apply to our 
subcatchments.   

 Double click on Subcatchment C_1 to open the properties dialog. Click on the down arrow 

next to the Land use ID under our new RAFTS group heading and go to Insert New Land 

use Object… 

 

 Name the Land use ID, Rural and click OK.  A land use can be made up of up to 12 different 

Runoff Surfaces (eg. Roads, buildings, vegetation, waterbody).   
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NOTE: When using RAFTS hydrology in Urban areas, a minimum of 2 runoff surfaces are 
recommended. One for impervious areas and one for pervious areas.  

 From the dropdown menu set the Runoff surface 1 to 1. Then use the down arrow key to 

Open Runoff surface 1. 

 

 Populate Runoff surface 1 as; Description to Pervious, Surface type to Pervious, Routing 

model to RAFTS, Ground slope (m/m) is NULL. Runoff volume type equal to DefConLoss, 

Maximum deficit (mm) to 15, Infiltration loss coefficient (mm/hr) is 2.5, Initial loss type is 

Abs, Initial loss value (m) to 0, Equivalent manning’s n to 0.035. 

 

 Use the green back arrow in the properties dialog to go back to the Land use Object 

Properties.  Set the Default area 1 (%) to 100.  This will set the Rural Land use to be 100% 

pervious if not overwritten manually on each subcatchment. 
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Now that we have setup the Runoff Surfaces that make up our Land use, we need to apply the 
this to the other subcatchments and also set the subcatchment slope.  

 Go to Window > Grid windows > New subcatchments window. Highlight the 

Subcatchment ID column and right click on the header to Freeze Columns. This will show 

the Subcatchment ID at all times in the table.  

NOTE: To change the order of the data in the grid windows, highlight a column, right click and 
choose one of the Sort options provided or set your own rules. 

 Scroll to the Land use ID, highlight the column and right click in the first cell and go to 

Current Cell(s) Value > Set new value(s) for cell(s). Set all subcatchments to Rural and 

click OK.  

 Scroll further across to the Slope (m/m) column.  Populate the Subcatchment slopes for 

each subcatchment as per below: 

 

 

 

 

 

Note: The Subcatchment slopes in this example are >10%, so only a rough estimate of the slope is 
needed as the impact of changing this by say +- 10% is unlikely to affect results.   

 Finally, ensure you check on the Per-surface RAFTS B option for each subcatchment.  This 

will tell ICM to calculate B from the parameters you provided in the Runoff surfaces (for 

example manning’s n, Surface Type, RAFTS adapt factor also known as BX) and not from 

those in the subcatchment. 

 

Subcatchment Slope (m/m) 

C_1 0.40 

C_2 0.40 

C_3 0.20 

C_4 0.04 
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 Right click on Urban Development Network and Commit changes to master database. 

Add to the comments Workshop 5 - Added Land use, Runoff surface and Subcatchment 

data and click OK. Select No to validating the model at this stage.   
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Workshop 6. Hydrograph Translation  

6A. Draining the Subcatchment 

ICM allows Subcatchments to drain to a variety of different network elements.  The locations a 
Subcatchment can drain to within ICM are described below. 

Database Value Description  

Node Specify a Node ID to which the subcatchment drains. 

Link Specify a Node ID and Link Suffix to which link the subcatchment 
drains. 

Subcatchment Specify Subcatchment ID to which the subcatchment drains. This 
also allows for Bypass flow / lagging links. 

Multiple Links Subcatchment flows can be distributed to multiple links via a list of 
conduits and weighted flows.  

2D Point Source Specify a Point Source ID to which the subcatchment drains allowing 
direct distribution to the 2D mesh.  

 

Lagging Links 

In this example, the upper 3 subcatchment flowpaths will be represented as lag links.  We will 
drain Subcatchment C_1 and C_2 to the outlet of C_3.   

 Double click on Subcatchment C_1 to bring up the properties page.  Change the Drains to 

to Subcatchment and the To subcatchment ID to C_3.   

 Then repeat the above steps for C_2.  

NOTE: The output lag on the Subcatchment represents the time it takes the hydrograph to move 
from the outlet of C_1 and C_2 to the outlet of C_3. We can manually move the drainage arrows 
from the centroids to the outlets to better represent this connection.  

 Select the Edit object geometry tool from the GeoPlan toolbar and click on the end of the 

arrows to show the vertex and then drag the vertex to desired location (see image below). 
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 Lastly, set the Output lag (minutes) to 5 and check on the Bypass runoff for both 

subcatchment C_1 and C_2. This can be done in the property window for each 

subcatchment or in the subcatchment grid windows.  

  

Channel Links 

Subcatchment C_3 will outlet to the top of a channel which will be sized as part of the project.   

 Select Node from the New object dropdown list and select the New object icon from the 

toolbar.  Create a new node at the top of the north end of the development site and set the 

ID to US, the Type to Break and the System Type to storm.  Click OK. 
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 Press Esc to exit out of the new object pointer and bring up the properties page for C_3. 

Set the Drains to Node ID to US. 

 Choose the New object tool again and draw a new node at the downstream end of the 

development site.  Set the ID to DS, the Type to Outfall and the System Type to storm.  

Click OK. 

 

 The properties page for the new Outfall should appear and ICM will provide a red validation 

error where the Ground level (m AD) needs to be populated.  Set it to 10.  

Now we will add the channel.  

 Select Link from the dropdown list and select New object from the toolbar.  Create a new 

link from US to DS nodes. Set the Type to Channel and the System Type to storm.  Click 

OK. The Suffix with automatically adopt 1. 
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 The properties page for the new channel should appear and ICM will provide a red 

validation error where the invert levels and section shape need to be populated.  Set the 

US invert to 20 and DS invert to 10.  

 Override the Length (m) to equal 250. 

 Click on the down arrow next to the Shape ID and Insert New channel shape object…  Give 

it the name Channel1.  In the new properties page, set the roughness type to N and click 

on the 3 ellipses to set the Channel profile.  

 

 We will start with a 5m wide, 2m deep channel with a manning’s n of 0.035. Set the Channel 

shape up as shown below and press OK. 
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 The Subcatchment covering the development site will drain to the channel for now. Bring 

up the properties page for C_4 and set the Drains to field to Link, the Node ID to US and 

the Link suffix to 1. This will add the flows midway.  

 

 We are ready to validate the network and commit the changes.  Right click on the Urban 

Development Network and select Commit changes to master database. In the comments 

add: Workshop 6 – Added lags, lag links and a channel.  Click OK and Yes to validating 

the network.  
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Workshop 7. Rainfall Data 

7A. ARR Rainfall Generator 

We are going to use the ARR Storm Generator in ICM to create a new rainfall object containing 
design storms from the ARR Data Hub and BOM websites. 

 To create a new Rainfall object, right click on the Model Group and select New InfoWorks 

> Rainfall event. Give it the name ARR19_Ensembles and click OK. Select Australian (2016) 

Rainfall and click OK. 

 Select the ARR Storm Generator... button from the bottom left corner.  

 

NOTE: By default, the storm generator will access an ARR Storm Generator folder in your working 
documents.  This allows you to keep all your rainfall together in a single folder.  If the rainfall is 
project specific you may want to save it in your project folder or the same file location as the 
project (.icmm) file (C:\...\RAFTS in ICM Training\).   
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 Select New to create a new dataset of storms. The AEPs and Durations lists should be 

empty.  

 To populate the storm data (AEPs and Durations), select ARR Data… from the top right side 

of the dialog box.  

 Use the centre scroll button on the mouse to zoom and pan to find the Brisbane Airport.  

Left click on the Airport to populate the Latitude (-27.381) and Longitude (153.123) of the 

desired location. Alternatively, you could type these in manually.  
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 Select Download. The Data Files status should change to ‘Downloaded’ once successful. 

Click OK.  

NOTE: If no internet connection is available or there is an issue with either the BOM or ARR Data 
Hub websites, files can be downloaded, and the Add from File action can be used to generate 
rainfall data manually. (refer https://help.innovyze.com/display/arr2016/Importing+Storms).   

 The available AEPs and Durations lists should now be populated. Uncheck the Select All 

box at the top of both lists to deselect all. Then select the desired events (10% and 1% AEPs, 

10-45min durations). 

https://help.innovyze.com/display/arr2016/Importing+Storms
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 Click on the View Summary Report… to check the storms that will be added to the model. 

There should be 120 (6 ensemble containing 10 patterns for both the 10% and 1% AEPs). If 

you are happy with the summary report, select OK. 
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 You should now see the newly created zip file displayed in the window. This file contains 

all the data files used to create the storms. Select the new file, use the Add to Existing, On 

import option and click Import. 

 

 The storms can be toggled on and off in the Rainfall Dialog Editor. To apply the initial loss 

at the Subcatchment level, change the DefConLoss initial deficit (mm) back to 0. Click OK 

to accept the current rainfall storms.   

NOTE: The continuing losses from the Data Hub are shown in the dialog however they are for 
information only.  



 

  
 
 
 

59 

RAFTS in InfoWorks ICM / ICMOne 

 

NOTE: Rainfall objects become ‘Read Only’ once used in a Run.  This is to allow Run objects to be 
re-simulated later without changes to the outcome.  

 You can view each rainfall event details individually by right clicking on the Rainfall object 

and going to Open As... > Grid Editor (TVD Read only) and the selecting an event to view.  
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7B. Spatial Rainfall Profiles  
By default, all subcatchments in the model will have the Rainfall and Evaporation Profiles set to 1 
and is not used unless there are multiple rainfall profiles applied to a simulation.  However, these 
can be manually updated to apply different rainfall profiles to different subcatchments within the 
same network.  

Subcatchment Dialog 
 

 

Rainfall Object Dialog 
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Workshop 8. Running ARR Storms & 
Analysing Results  

8A. Setting up the Run Object 

Now we are going to set up the simulation data and parameters and run the simulation with the 
new rainfall ensembles. 

 Right click on the RAFTS Part2 Model Group and select New InfoWorks > Run.  

 Fill in the Run title as Urban Development Run (Pre-dev).  

 Select the Urban Development Network and the ARR19_Ensembles object from the 

Group Window (Use the CTRL key to multi-select) and drag them onto the Run Window 

dropping anywhere within the grey area of the dialog.    

 Check the Allow re-runs using updated network option which means we can re-run and 

overwrite the results rather than creating a copy of the run later.  

 Change the Timestep (s) to 10, the Result timestep multiplier to 6 and the duration to 5 

Hours. 
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 There is no need to simulate a 10min storm for 5hrs as the flows would have passed through 

the network well before 5hrs. To run the simulations efficiently, click on the Timestep 

Control and go to the Outflows tab. Check on the Check for outflows dialog and set the 

flow Threshold (m3/s) to 0.1 and the Lag (minutes) to 15.  This will stop the simulation 

15min after there is less than 0.1m3/s outflow. Click OK.   
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 Click Run simulations and OK.  

NOTE: Once the simulations are complete, it is a good idea to make sure the flows look OK in the 
model before running the ensemble statistical analysis. Refer to Workshop 4 for reviewing results.  

 

8B. ARR Statistics  
Statistical analysis can be run on a Subcatchment, node, link or 2D network result object for any 
associated result field. They can include multiple simulation results (such as an ensemble) or a 
single result such as looking at the average depth over time.  

We will create a Statistical Report to analyse the ensemble results at the downstream end of the 
network.   

 Clear any selections on the GeoPlan. Now, using the Select tool select the Channel link.  

 Right click again on the Model group and select New InfoWorks > Statistics template. 

Name this Ensemble Analysis Channel Flows and press OK. 

 

 We will now define the rules by which we want to undertake the statistics on. Select Link 

from the Location type drown down and US flow for the attribute. This will be the flow to 

be conveyed through the development site from upstream.  

 Click on the Add current selection to add the channel location. Then click on Add new tab 

and select DS flow from the attribute menu and Add the current selection.  This will be 

the peak pre-development site discharges.  

 Then click Save and close the dialog.  



 

  
 
 
 

64 

RAFTS in InfoWorks ICM / ICMOne 

 

 From the top toolbar go to Results > Statistical reports… Then populate the boxes with the 

simulation objects that we have run and the Ensemble Analysis Channel Flows Statistics 

template by dragging and dropping into the relevant windows. 

 

 Select Produce report and then select Yes from the pop-up window. This is a warning that 

it is going to create the statistics as this can take a long time if you have a lot of simulations.  
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ICM will now generate the statistics report which will contain information for the Channel – US.1. 
The Statistical report will show the peak flow at the US and DS end of the channel for each storm 
pattern within the ensembles. The Ensemble summary tab analyses the Maximum Flow results 
for each sim in the ensemble and provides the statistical results for Mean, Median, Min and Max 
and the correlating sim name. 

 

 You can also export this information to excel or produce a box and whisker plot. With the 

curser set on an US Flow attribute row, navigate to the top toolbar and click to Statistics > 

Export ensemble box plot.  

 

 Select a location to save the box and whisker plot information and Save with the default 

name. Have a play with the available options and turn on the Show Mean Marks and display 

the Mean value at the top of the boxplot. Note the storms that give the Mean peak flows. 
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 Repeat the process for the DS flow attribute.  

 

Flow to size 
channel 

Flow to check 
freeboard 

Max. Permissible 
discharge 
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Workshop 9. Developed Case  
We will now look at the hydrology of the development site and determine what size storage 
would be needed to maintain the current peak flows.   

9A. Creating a scenario  
 Press Create scenario on the Scenarios toolbar and type Developed for the New Scenario 

Name. 

 

 Ensure that you are working in the Developed scenario within the GeoPlan.   

 

9B. Using Stored Queries  
In Workshop 5 we created the Rural landuse and associated runoff surface manually.  In this 
example we will use a stored query to help automatically populate new Landuse data for us. 

 From the transportable files, drag in the Stored Query: Create New Landuse into the 

GeoPlan.  Populate the dialog for an Urban Landuse as below and then click OK.  
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 Next, we will set the Development Subcatchment (C_4) to the Urban landuse. Select 

Subcatchment C_4 and drag on the object Stored Query: Apply Landuse to 

Subcatchment into the Geoplan. 

 Choose Urban from the dropdown menu and leave the Subcatchment slope as 0.  The 

stored query is setup not to update the Subcatchment slope if it is set to 0.  

  

 It is always a good idea to check your updates in the model after using stored queries.  

Open the properties dialog for Subcatchment C_4 and check the Landuse is set to Urban.  

Then open the two new Runoff surfaces and check the losses and manning’s roughness. 

 Once satisfied the model is correct, validate and commit the changes.  Set the comments 

to Workshop 9 - Added Developed scenario.  

9C. Running scenario simulations   
 Double click on the Urban Development Run object. Click on update to latest, change the 

name to Urban Development Run (Post-dev), choose the Developed scenario then select 

Run simulations.   

 We will now repeat the ARR statistics for the downstream end of the channel. Note that 

the mean peak discharge has increased only by 0.2m3/s for the 1% AEP.  
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Workshop 10. Detention Basins 
In this workshop we are going to look at adding storage to the model to reduce the site discharge 
post development.     

10A. Adding a storage node  
 Create a new scenario with the name Mitigated.  Check on the option to Copy an existing 

scenario and select the Developed scenario.  

 

 Select Node from the New object drop down menu and draw a new node near the 

development outlet. Set the ID to Basin, the Type to Storage and the System Type to 

storm.   
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 In the properties dialog, set the Ground level (m AD) to 12.  Check on Relative stages to 

use depth-based storage values and the click on the ellipses button to set the Storage 

array. Set the storage array Area (m2) to 900 and the Level (m AD) 1.5 high. 

 

 Use the New object tool again to insert a node into the Channel close to the DS node. Set 

both the ID and the Type to Break. Ensure the Split checkbox is selected.  Click OK. 

10B. Adding Storage Outlets 
 Select Link from the New object dropdown menu and create a new link between the Basin 

and the Break nodes.  Set the Type to Conduit and the System type to storm. 
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 In the properties dialog, set the Width (mm) to 300, the US invert level (m AD) to 12 and 

the DS invert level (m AD) to match the channel invert at the break point. Open the Channel 

properties to view the level. 

 Next, draw a second link connecting the same nodes. It is a good idea to insert a vertex 

halfway (using the Alt key) so the two links can be seen (not on top of each other).  This time 

set the Type to Weir and the System type to storm. 

 

 In the properties dialog, set the Crest (m AD) to 12.8 (0.8m above the storage invert), the 

Width (m) to 3 and the Discharge coefficient to 0.64.   
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NOTES: 

1. The Discharge coefficient in ICM is not the same as the commonly documented Weir 
Coefficient. To convert a standard Weir Coefficient to a Discharge coefficient for ICM, 
divide the value by the square root of gravity.  For example, a Weir Coefficient of 2 would 
equal a Discharge coefficient in ICM of 0.64.   

2. The Secondary discharge coefficient is used only if a Roof height (m) is specified and the 
flow becomes pressurised.  At this stage, the orifice equation is used.  

10C. Re-routing flows 
 Now the Basin is setup, we need to re-route the Subcatchment flows through the basin 

before getting to the outlet channel.  Bring up the properties of Subcatchment C_4 and 

change the Drains to back to Node and set the Node ID to Basin.  

 Validate and commit the network and add the comments Workshop 10 - Added Mitigated 

scenario.  

10D. Running scenario simulations  
 Double click on the Urban Development Run (Post-dev) object to open. Click on update 

to latest, change the title to Urban Development Run (Mitigated) and choose only the 

Mitigated scenario. 

 Keep all other fields the same and click Run Simulations. 
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 We will now repeat the ARR statistics for the downstream end of the channel. Note that 

we need to create a new statistics template now that we have reconfigured the network.  

Firstly, select the channel between the Break node and the DS outlet.  

 Right click again on the Model group and select New InfoWorks > Statistics template. 

Name this Ensemble Analysis Mitigated Channel Flows and press OK. 

 

 We will now define the rules by which we want to undertake the statistics on. Select Link 

from the Location type drown down and DS flow for the attribute. 
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 Click on the Add current selection to add the channel location.  

 Then click Save and close the dialog. 

 

 Go to Results > Statistical reports… and add the mitigated run results and the new 

statistical template. After producing the results from the dialog, you can add the box and 

whisker plot by going to Statistics > Export box and whisker plot. 
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 We can do the same ensemble statistics for the depth in the basin. Firstly, select the Basin 

node in the GeoPlan. 

 Right click again on the Model group and select New InfoWorks > Statistics template. 

Name this Ensemble Analysis Mitigated Basin Levels and press OK. 

 We will now define the rules by which we want to undertake the statistics on. Select Node 

from the Location type drown down and Level for the attribute.  

 Click on the Add current selection to add the Basin node.  Then click Save and close the 

dialog. 

 Go to Results > Statistical reports… and add the mitigated run results and the new 

statistical template. After producing the results from the dialog, you can add the box and 

whisker plot by going to Statistics > Export box and whisker plot.  
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Workshop 11. Displaying Results 
In this workshop we will look at how we can layout our model results easily on a single plan. This 
is a good way to pass on the information we have gathered for the development site to the Civil 
Designer. 

11A. Print Layout  
 In Workshop 8 we determined the flowrate needed to size the conveyance channel 

through the development site.  Click on the Custom label button and add a label to 

Channel US.1.   

 Double-click on the new label, click on the Free text radial button and type in Open 

Channel to Convey 8.2 m3/s.  

 Go to the Formatting tab and set the Font Size to 9 and change the Callout Line Width to 

2. 

 Then do the same for the Basin node, except add the text Basin to provide ~1000m3 

storage.  

 We will now add a print layout. First position the network how you want it to be viewed in 

the print layout then go to GeoPlan > Spatial Bookmarks > Add from View…  Set the name 

to Plot View. 

 Create a new print layout by going to File > Print Layout. 

 Drag in the GeoPlan from the Data views options and fit to desired size. Then double click 

on the View and go to GeoPlan Scale tab.  Set it to Fit Geospatial Bookmark and choose 

Plot View from the dropdown list. Click OK. 

 Add a North point, a Scale bar some Text and an Image.  You can also add any graphs, 

long sections or grid results that are open in the working window.   

 Then press Save As… icon in the toolbar and save to the working model group with the 

name Plot Layout: Mitigated.  From here you can print to either PDF or a printer.  

 Close all tabs in the GeoPlan once you are finished. 
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Workshop 12. Adding the 2D Zone 
Finally, we will look to create a new scenario and add a 2D zone so that we can model the 
subcatchment hydrographs as overland flow in the 2D engine. We will drain the subcatchments 
to 2D point sources, import a mesh level zone to act as channel for flow diversion, re-run the 
model and compare the hydrographs leading to the development site. 

12A. Creating a scenario 
 Open the Urban Development network to the GeoPlan. 

 Press Create scenario on the Scenarios toolbar and type 2D for the New Scenario Name. 

 

 Ensure that you are working in the 2D scenario within the GeoPlan.   

 

12B. Setting up the 2D zone 
4. Right-click on the tutorial model group and select Import InfoWorks > Ground model grid 

> from ground model grid files… Navigate to the Part 2 folder within the training files and 

select both Ground1.asc and Ground2.asc. Press Open. 

5. From the Ground model grid dialog, name the Grid as DEM_1m, ensure the Units are set to 

Metres and check on the Floating point or mixed radio button. Press OK. 
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6. Drag the newly created Ground Model onto the GeoPlan to open. Also drag on the 2D 

Theme object from the template files. 

7. Now we will draw the 2D zone. Select Polygon  from the new 

object dropdown and digitise a 2D zone around the existing subcatchments and 

development site. Set the Type and ID to 2D zone. 
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8. The 2D zone Object Properties should now be open. Set the highlighted 2D zone fields as 

per the figure below. 

 

9. The next step is to create the 2D mesh elements. With the 2D zone selected, go to Model 

> Meshing > Mesh 2D zones… Drag in DEM_1m to the Ground Model field and Run the mesh 

generation on your machine. 

10. Once the meshing process is complete (progress can be viewed in the Job Control window) 

go to Model > Meshing > Load mesh job results… and with the completed mesh job 

highlighted select Load Mesh. You will now see the completed mesh within the 2D zone. 

 A summary of the mesh can be viewed. Open the properties for the 2D zone and select the 

ellipsis in the Mesh summary field. Take note of the number of elements and triangles 

created. 

12C. Draining Subcatchments to the 2D zone 

2D Point Source objects can be used to define the location of a flow-time boundary point. Inflow 
associated with the point source discharges to the 2D mesh element in which the point is located. 
It should be ensured that the mesh element is an appropriate size to cope with the inflow. 
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 Select Point  from the new object dropdown and digitise 

four 2d point source objects close to the subcatchment outlets and name them as per the 

corresponding subcatchment e.g., C_2. 

 We now need to drain our subcatchments to the 2D point sources so that the hydrographs 

can be applied to the 2D mesh. Open the properties for subcatchment C_1 by double 

clicking on the object. Set the Drains to field to 2D point source and the 2D point ID to C_1. 

 From the transportable template files drag the Stored Query: Drain Subcatch to 2D onto 

the GeoPlan to assign the remaining subcatchments to their respective 2D point IDs. 

 As this is a 2D scenario we will need to remove the 1D network within the Development 

Site. This time from the transportable template files, drag the Stored Query: Remove 1D 

Objects onto the GeoPlan. 

 Validate the network and Commit the changes. 

12D. Meshing techniques 

We will be using a Mesh Level zone to define a diversion channel through the development site 
and build a Network result line into the mesh for inspection of flow results later. 

 Go to Network > Import > Open Data Import Centre… and select Mesh Level Zone as the 

Table, Raw Shape File as the Source and the MLZ_Channel.shp file from the Part 2 folder. 

From the Import Fields choose polygon_id for ID and click Import. 
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 There should be 1 new object imported. Close the Open Data Import Centre. 

 Open the object properties for the newly imported Mesh level zone and select the ellipsis 

within the Vertices field. 

 Click on the Vertex elevation type column header to highlight the column. Right-click on 

the one of the highlighted rows and select Set new value(s) for cell(s). Choose Set from 

the dropdown and press OK. 

 Fill out the Elevation (m AD) for each vertex as per the figure below. Selecting a row will 

highlight which vertex you are editing in the GeoPlan. 

 

 Now select Line  from the new object dropdown and digitise 

a line through the downstream end of Subcatchment C_3. Make sure that the line is drawn 

left-to-right looking downstream as this will ensure that the flow through the line is positive 

when we view the simulation results. 

 Set the Type to Network results line (2D) and the Name as Flow to Development. 
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 Re-mesh the 2D zone to incorporate the diversion channel and network result line. 

NOTE: Opening a New 3D network window can help to visualise the 2D mesh changes imposed 
by Mesh zones, Mesh level zones, etc.  

 Validate the Network and Commit the changes. 

12E. Running the 2D zone scenario 

Lastly, we will run the critical storm for flow to the development site from our 1D model, inspect 
the 2D results and compare the incoming flow hydrographs. 

 Right-click on the ARR19_Ensembles rainfall object, select Copy then Right-click on the 

tutorial model group and Paste. This will create a copy of the rainfall object that is no longer 

Read Only (R/O).  

 Rename the copy ECN_1pct_15min_5 and open. Select the Disable all button and then 

scroll down and check on the 1% 15min Storm 5. Click OK to save. 

 Create a new Run object by right-clicking on the model group and selecting New 

InfoWorks > Run. Set up the Run object as per the figure below and run the simulation. 
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NOTE: 2D calculations can be accelerated significantly by accessing any available GPUs. To use a 
GPU card for the 2D calculations click on 2D Parameters in the Run object window and navigate 
to the GPU tab. If ‘Always’ is selected and no GPU is present the run will fail. 

 Once the simulation is complete drag the result onto the GeoPlan and enable the 2D zone 

depth and velocity themes set in the 2D Theme object via the network Properties and 

Themes if they are not already turned on. 



 

  
 
 
 

88 

RAFTS in InfoWorks ICM / ICMOne 

 

 Use the Replay toolbar  to play through the 

simulation results and view the maxima. 
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 Next, use the Graph tool  to select the 2D Network result line and 

select the Flow (m3/s) attribute. Here we can see a peak flow of around 7.7m3/s occurring 

at a time of 19mins from the beginning of the storm. 
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 Compare the result with the same storm simulation completed in the Urban Development 

(Pre-dev) Run. Graph the Total outflow (m3/s) attribute for Subcatchment C_3. The 

estimated peak flow is around 8.1 m3/s occurring 17mins after the beginning of the storm. 

 

 What are some factors that could cause the 2D hydrograph to estimate slightly lower and 

delayed flows? 


